FireTune Information
Top Next

firefoxlustregelb

FireTune for Mozilla Firefox v1.x
© 2005 by Totalidea Software
http://www.totalidea.com

This Software is being distributed as Freeware. It may be freely used, copied and distributed as long as it is not sold, and all original files are included, including this license. You are NOT allowed to make a charge for distributing this Software (either for profit or merely to recover your media and distribution costs) whether as a stand-alone product, or as part of a compilation or anthology, without explicit prior written permission. With using FireTune you do agree to the FireTune License Agreement.

Please note that Totalidea Software does not offer any product support for any of its freeware products! For the latest version of FireTune, please visit

http://www.firetune.com

or visit the FireTune User Board at

http://board.firetune.com

Table of content:

1. What is FireTune?
2. What does FireTune do?
3. How to tell whether Firefox is faster after optimizing it
4. What changes are applied by FireTune?
5. Usage instructions
6. Plans for future versions
7. Language support

1.) What is FireTune?

FireTune is a free software application to easily optimize several configuration settings for the Mozilla Firefox webbrowser. FireTune is based on an article on TweakFactor (http://www.tweakfactor.com), however - similar optimization guides can be found on lots of Firefox related websites. Actually it automates the procedure of optimizing the browsers preferences for faster browsing with the FireFox webbrowser.

System Requirements:

This software has been tested on Windows XP only. However - it should also run on Windows 2000 / 2003.

Since this is a tuning software for Mozilla Firefox, Mozilla Firefox is therefore required. On some systems the Microsoft Visual Basic runtime files might also be required. Those files are usally pre-installed on Windows 2000/XP/2003. If you get an error message during startup of FireTune, please download and install these runtime libraries from the Microsoft website - download here.

FireTune versions vs Firefox versions:

From time to time people ask whether the version number of FireTune is somehow related to the version number of Firefox. This is NOT the case. Any version of FireTune will work with any version of Firefox 1.x as long as we do announce that you need to update your version of FireTune for a specific version of Firefox. So: FireTune v1.0.3 for instance is not limited to Firefox v1.0.3. The FireTune version number does not indicate any limited compatibility to a specific version of Firefox.

2.) What does FireTune do?

Instead of changing all relevant preferences of FireFox manually as described in the TweakFactor tweaking guide for FireFox, you can use FireTune to automatically apply all the configuration changes to FireFox.

Known problems:

Some users of FireTune reported, that after running an optimization on Firefox with FireTune, all their extensions were disabled, cookies were cleared etc. We were not able to reproduce this problem on our machines. However - you should always create a backup of your configuration file BEFORE any optimization is applied in case something goes wrong, so that you can restore your settings easily.

3.) How to tell whether Firefox is faster after optimizing it

There's a simple way to tell whether Firefox works faster after optimizing it with FireTune. Just follow these instructions:

· Clear the cache of Firefox from the Firefox settings dialog - this is very important!
· Before you optimize Firefox, navigate to http://www.numion.com/stopwatch/ and do a speed test on http://www.mozilla.org/products/firefox/
· The time needed to load the site completely will be displayed to you in the browser window. Write down the time
· Clear the cache of Firefox from the Firefox settings dialog again - this is very important!
· Now, close Firefox, and optimize it with FireTune
· Start Firefox again, and repeat the speed test on http://www.mozilla.org/products/firefox/
· Compare the displayed result with the result from the test before the optimization

On our testmachine we noticed a speed improvement of 1.25 seconds - the loadtime was 3.99 seconds before optimizations, and 2.74 seconds after optimization.

4.) What changes are applied by FireTune?

Performance Settings

One of the limitations of pretty much all computer applications is the need to target for a general audience because of the wide array of computer components and varied network infrastructure. This is where tweaking comes in. Firefox by default is aimed at a general audience too and hopefully we can tune it more to the needs of theindividual. The majority of the information comes from this excellent thread over at the MozillaZine Forum. The first post in particular goes through in great detail what each of the settings do. The thread however gets fairly long and convoluted and we attempt to summarize the contents of this thread along with a couple other sources into something that is easier to digest. As with the settings on the previous page, the contents are copied into the user.js file. We do not go into major detail about the setting as the thread goes into detailed explanations of what the settings mean in the first post. Instead, the configurations are culled from the thread of what people have reported to have worked for them along with some modifications on our end.

Quick and Dirty Settings (part of the tweaks further below)

user_pref("network.http.pipelining", true);
user_pref("network.http.pipelining.firstrequest", true);
user_pref("network.http.pipelining.maxrequests", 8);
user_pref("nglayout.initialpaint.delay", 0);

Pipelining does multiple data requests at once and should speed things up. I believe IE did this before and this was partially attributable to the speed advantage that IE had over older versions of Mozilla/Netscape. Initial Paint Delay actually slows down the rendering of the ENTIRE page but since users tend to start reading before the entire page is rendered, setting this to a low value gives the impression that the page loads faster.

The following configurations are based off of recommendations off of the Mozillazine thread with some editing.

These are the settings that seem to be common to all configuration files regardless of connection speed or computer speed with a couple of additions - plugin paths can be found with about:plugins and the bookmark menu delay is turned off.

user_pref("network.http.pipelining", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("network.http.pipelining.maxrequests", 8);
user_pref("network.http.request.max-start-delay", 0);
user_pref("content.notify.backoffcount", 5);
user_pref("plugin.expose_full_path", true);
user_pref("ui.submenuDelay", 0);
user_pref("nglayout.initialpaint.delay", 0);

Fast Computer, Fast Connection:

Definitions:

Fast Computer: is a machine with a CPU greater than 1.5Ghz and with memory installed of at least 512MB RAM
Fast Connection: is a DSL, cable or a better connection

According to the above, 'Slower' connections means slower DSL or cable connections as well as double line ISDN connections,
and 'Slow' means all other analog modem connections.

A 'Slow' computer is a computer with a CPU slower than 1.5Ghz, and with less memory than 512MB RAM.

user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("browser.cache.memory.capacity", 65536);

A couple settings of note - Firefox is allocated 4096 KB of memory by default and in this configuration we give it roughly 65MB as denoted by the last line. This can be changed according to what is used.

Fast Computer, Slower Connection:

This configuration is more suited to people without ultra fast connections. We are talking about slower DSL / Cable connections as well as double line ISDN connections.

user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("browser.cache.memory.capacity", 65536);

Fast Computer, Slow Connection:

Slow connection means connections through an analog 57k modem or slower.

user_pref("browser.xul.error_pages.enabled", true);
user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 3000000);
user_pref("content.maxtextrun", 8191);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("network.http.max-connections", 32);
user_pref("network.http.max-connections-per-server", 8);
user_pref("network.http.max-persistent-connections-per-proxy", 8);
user_pref("network.http.max-persistent-connections-per-server", 4);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("browser.cache.memory.capacity", 65536);

Slow Computer, Fast Connection:

user_pref("content.max.tokenizing.time", 3000000);
user_pref("content.notify.backoffcount", 5);
user_pref("content.notify.interval", 1000000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 1000000);
user_pref("content.maxtextrun", 4095);
user_pref("nglayout.initialpaint.delay", 1000);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("dom.disable_window_status_change", true);

One of the changes made for this particular configuration is the final line where the status bar is disabled for changing web pages to save processor time.

Slow Computer, Slow Connection:

We have entered the doldrums of the dial-up user

user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("nglayout.initialpaint.delay", 750);
user_pref("network.http.max-connections", 32);
user_pref("network.http.max-connections-per-server", 8);
user_pref("network.http.max-persistent-connections-per-proxy", 8);
user_pref("network.http.max-persistent-connections-per-server", 4);
user_pref("dom.disable_window_status_change", true);

Some of the options we chose not to include as opposed to suggestions on the Mozillazine threads included the suggestion of catching SSL pages. Regardless of computer speed, one of the common trends is that pipelining is a good thing. Those with faster computers and gobs of memory may want to up the amount of memory available to Firefox while those with slower computers can still increase the default 4MB to something higher. This was not done in our configuration files however. Powerusers are also welcome to disable the status bar to eek out thatextra CPU cycle or two.

5.) Usage instructions

FireTune is very easy to use. The only thing you need to do is to create a backup of your current Firefox configuration file (you can do that easily with FireTune's backup feature), then make your selection from the available tuning options. FireTune will optimize Firefox according to your selections when you click the 'Tune it!' button.

· Close FireFox
· Start FireTune - if you want ot optimize the portable version of Firefox, you will have to show FireTune where the portable version of Firefox is located on your machine
· If you have not created a backup of your configuration file before, you should do that now
· After creating a backup of your configuration file, make your section from the available optimization settings. For details on the different options, please check the section above
· Click the 'Tune it!' button
· FireTune will then optimize the Firefox configuration file accoring to your selections from the option list. Once the optimization is done, you may restart Firefox
· Please note that FireTune does not show what optimizations you have chosen last time you used it. Do also note that you must re-select a user profile before you can change its configuration again using FireTune

Notes:

· if you are upgrading from a previous version of FireTune, then you can just re-apply your optimizations ontop of your current configuration file. You do not have to restore your original settings before working with the latest version of FireTune
· if you want to switch between the portable version of Firefox, and the installed version, you can do that from the 'Settings' menu of FireTune

6.) Plans for future versions

You know an interesting tweak for Mozilla Firefox v1.x? Is it something other Firefox users might be interested in? Do you want us to consider including it to the next version of FireTune? If so, send us an email, and include all details about your suggestion. We will review it, and if we find your suggestion useful, we might add it to the next version of FireTune. Please note that we cannot answer every suggestion we receive. Thank you for your ideas!

7.) Language support

If you want to see FireTune in your language, why don't you create a translation of the language file? The language files can be found in the FireTune program folder. They are editable with notepad, or any other text editor. Send us your translated language file attched to an email so that we can include it to the FireTune package.

© 2005 by Totalidea Software. All rights reserved. You agree to the License Agreement by using the FireTune software.
http://www.firetune.com


License Information
Previous Top

SOFTWARE LICENSE AGREEMENT *FREEWARE*

YOU MUST AGREE TO THIS LICENSE BEFORE USING THE SOFTWARE!

1. GENERAL

This Software License Agreement (hereinafter this Agreement) is a legal agreement between you i.e., the end user or customer (either an individual or a legal entity) and Totalidea Software NZ, Ltd. (hereinafter "Totalidea Software"). The copyright of this software (hereinafter the Software) and its associated documentation (including any, files, images, text incorporated into the Software) as well as any accompanying written materials (unless otherwise statet) by Totalidea Software (the Owner) and is protected by national copyright laws and international treaties.

By installing, copying, downloading or otherwise using this software, you agree with the Owner to be bound by the terms and conditions of this Agreement, which will govern your use of the Software. If you do not agree to this Agreement, do not install or use this Software.

Customers should carefully read the following terms and conditions before using the Software.

2. LICENSE

Totalidea Software grants, and the customer accepts, a nontransferable and nonexclusive license to use the Software on the following terms and conditions:

· You are permitted to pass copies of the software.
· You may copy the software how often you want.

You are not permitted to:

a) Selling the software on any medium or over an paid internet service without written permission from Totalidea Software. We apologize that you ask for a permission in any case you want to present the software on a public Internetsite or any other medium.

b) rent, lease, sub-license, loan, modify, alter, adapt, merge, translate, reverse engineer, decompile, or re-package the software into another product, or to disassemble it or create derivative works, based on the whole, or any part, of the software or its associated documentation.

3. TERM

This Agreement is effective until you terminate it by destroying the Software and its documentation, together with all copies. This agreement will also terminate if you fail to abide by its terms. Upon termination, you agree to destroy all copies of the Software, and its documentation, including any Software stored on the hard disk of any server/computer under your control.

4. OWNERSHIP

The Software is licensed to you. You do not own it. The Owner shall at all times retain ownership of the Software as well as all subsequent copies thereof, regardless of form or storage medium. The owner also retains the title, and all proprietary rights to the Software, including, but not limited to, all patent, copyright, trade secret, service marks, registered service marks, trademark or registered trademark rights.

5. DISCLAIMER OF WARRANTY

THE OWNER DOES NOT GUARANTEE THE FOLLOWING: THAT THE SOFTWARE WILL BE FREE FROM BUGS, ERRORS, OR OMISSIONS, THAT IT WILL PERFORM WITHOUT INTERRUPTION, THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS, THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE, THAT DEFECTS IN THE SOFTWARE WILL BE CORRECTED, OR THAT NEW RELEASES AND/OR UPGRADES OF THE SOFTWARE WILL BE PROVIDED. THE SOFTWARE, ANY INFORMATION, CODES, AND/OR EXECUTABLES PROVIDED, IS SUPPLIED AS IS, WITHOUT WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE OWNER FURTHER DISCLAIMS ALL WARRANTIES EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. THE RECIPIENT ACCEPTS ANY AND ALL RISK ASSOCIATED WITH THE USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE OWNER SHALL NOT BE LIABLE FOR ANY DAMAGES WHATSOEVER, INCLUDING, BUT NOT LIMITED TO, DIRECT, INDIRECT, OR INCIDENTAL LOSS OF BUSINESS PROFITS, SPECIAL DAMAGES ARISING FROM THE USE (OR INABILITY TO USE) THE SOFTWARE, OR FROM ERRORS OR DEFICIENCIES IN IT, WHETHER CAUSED BY NEGLIGENCE OR OTHERWISE, EVEN IF THE OWNER HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL THE OWNER'S LIABILITY EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE. INDISPENSABLE CLAIMS FOR PRODUCT LIABILITY BY LAW REMAIN UNAFFECTED.