DirectX 诊断工具

“Microsoft® DirectX® 诊断工具”文档包含如下主题：

  • 关于“DirectX 诊断工具”
  • 查找内容
  • 测试 DirectX 组件
  • 替代默认行为


关于“DirectX 诊断工具”

Microsoft® DirectX® 诊断工具提供有关系统上 DirectX 应用程序编程界面 (API) 组件和驱动程序的信息。它使您能够测试声音和图形输出以及 DirectPlay® 服务提供者。它也使您能够禁用一些硬件加速功能。

可以使用该工具在拨打支持电话的过程中为技术人员收集信息，也可以保存该工具收集的信息并将其粘贴到电子邮件中去。

信息呈现在一系列页面上。可以按照如下方式在页面之间切换：

  • 单击选项卡。
  • 单击“下一页”按钮。
  • 当输入集中在某个选项卡上时，按左箭头键或右键头键。

可以指定该工具如何显示表格。为此，请选择要按照其对表格行进行排序的列。单击该列顶部的标题按钮，表格就会根据该列中的项目按字母或数字顺序进行排序。要颠倒排序顺序，请再次单击标题按钮。

可以单击“保存所有信息”按钮，将所有信息保存到一个文本文件中。

注意

  • 某些信息（如显示卡上的内存容量）可能是不精确的。


查找内容

如果运行 Microsoft® DirectX® 应用程序时出现错误，DirectX 诊断工具就会帮助查找故障根源。下面是一些应该检查的情况：

  • DirectX 组件的版本不正确。 在“DirectX 文件”页的“注意”区域中，查找有关 Beta 和调试文件的警告。Beta 文件是早期测试版本，并不应与商用应用程序一起安装。调试版本（它们用于程序开发中，因此不应与最终产品一起安装）可能导致应用程序比这些组件的零售版本下运行速度慢得多。
  • 缺乏硬件加速。 如果 Microsoft DirectDraw® 或 Direct3D® 硬件加速不可用，有些程序运行速度非常慢或根本不能运行。在“显示”页上，在“DirectX 特性”下检查 DirectDraw、Direct3D 或 AGP Texture 加速是否标有“不可用”。如果标有“不可用”，您可能需要考虑升级硬件。
  • 没有连接设备。 如果游戏杆或其它输入设备没有反应，可能是设置不正确。确保在“DirectX 诊断工具”的“输入”页上对该设备进行了设置。如果没有，请通过“控制面板”添加该设备。
  • 驱动程序未签名。 Microsoft 没有测试未签名的驱动程序是否与 DirectX 的最新版本完全兼容。这些驱动程序在相应组件页上列出。

注意：如果使用“终端服务”在支持硬件加速的远程系统上工作，DirectX 诊断工具可能表明支持硬件加速。但是，终端服务不可以使用硬件加速，因此支持不可用。


测试 DirectX 组件

可以在连接到系统的每个显示器上测试 Microsoft® DirectDraw® 和 Direct3D® 也可以在每个波形输出设备上测试 DirectSound® 以及在每个音乐端口上测试 DirectMusic®。

测试 DirectX 特性：在适当页面上单击“测试”按钮，阅读显示的信息以及观察或倾听测试情况。运行每个测试，直到出现一条询问测试是否成功的消息。如果回答“否”，那么就不再继续运行测试。

如果是 DirectMusic，则只有一项测试。对音乐播放状态正常与否感到满意后，单击“确定”。

可以在任何可用服务提供者上测试 Microsoft DirectPlay® 的功能。

测试 DirectPlay

  1. 在“网络”页上，单击“测试 DirectPlay”。在“DirectPlay 测试”对话框中，键入用户名并选择服务提供者。选择“创建新会话”，并单击“确定”。如果选择了调制解调器连接，请在“调制解调器连接”对话框中单击“应答”，以便将调制解调器置于自动应答模式。
  2. 现在，在可以与第一个计算机建立选定连接的另一个计算机上运行 Microsoft DirectX® 诊断工具。单击“测试 DirectPlay”，键入一个不同的用户名，选择相同的服务提供者，单击“加入现有会话”按钮，并单击“确定”。

    对于某些类型的连接，您可能需要提供更多信息（例如，电话号码）。对于局域网上的 TCP/IP 连接，可以将文本框保留为空白。

  3. 在第二个计算机上，从包含第一个计算机上创建的会话名称的“会话列表”中选择会话名称，并单击“确定”。
  4. 现在，两个计算机都应该显示聊天对话框。在其中一个计算机上的输入框中键入信息，并单击“发送”。该信息应该出现在两个计算机上的聊天对话框的滚动区域中。


替代默认行为

在“声音”页上，您可以通过移动滑动块设置一个不同水平的硬件加速。这种水平的硬件加速在关闭 Microsoft® DirectX® 诊断工具之后一直有效。

可以对 Microsoft DirectDraw® 或 Direct3D® 禁用硬件加速（如果这样的加速可用的话）。为此，转到每个显示设备的“显示”页，并单击“禁用”按钮。一旦禁用硬件加速，即使关闭 DirectX 诊断工具，任何程序都不再可以使用它。要重新启用硬件加速，请在适当的“显示”页上单击“启用”按钮。

注意

  • 禁用 DirectDraw 加速同时会禁用 Direct3D 的加速。

也可以替代 DirectDraw 全屏幕应用程序设置的显示器刷新率。只有在遇到应用程序显示问题或有合理理由相信该应用程序设置无效刷新率的情况下，才应该这样做。

设置替代刷新率

  1. 在“更多帮助”页上，单击“替代”按钮。
  2. 在“替代 DirectDraw 刷新行为”对话框中，选择编辑框并为显示器输入有效刷新率。

    执行此操作时，会自动选择“替代值”选项按钮。

  3. 单击“确定”。

取消替代刷新率并让 DirectDraw 应用程序设置其自己的刷新率。

  1. 在“更多帮助”页上，单击“替代”按钮。
  2. 在“替代 DirectDraw 刷新行为”对话框中，选择“默认”选项按钮，并单击“确定”。