Folder Crypt Features

  • Crittografa i dati in WindowsTM usando una vera codifica a basso livello e algoritmi standard:

    • DES (chiave a 64 bit)
    • Triple DES (chiave a 128 bit)
    • ArcFour (chiave fino a 2048 bit)
    • AES-Rijndael (chiave fino a 256 bit)
    • Blowfish (chiave fino a 448 bit)

  • Nasconde e protegge i dati sensibili e i documenti in modo facile e sicuro. A differenza di altre applicazioni, Folder Crypt esegue una reale crittografia su tutti i byte dei dati, rendendo perciò impossibile il loro recupero senza la chiave di cifrature.

  • Nessuna traccia dei dati cifrati rimane sul computer (i file possono essere eliminati fisicamente dalle periferiche attraverso lo shredding)

Folder Crypt è una applicazione Microsoft .NET Framework (smart client), il che garantisce una robustezza di ultima generazione e la correttezza degli algoritmi utilizzati.

Folder Crypt implementa algoritmi di cifratura standard e non presenta alcun tipo di procedura di recupero dati di sicurezza o backdoor. E' possibile acquistare i codici sorgente delle funzioni di crifratura per verificare quanto detto.

Before

After


Folder Crypt - How to encrypt Windows files

COME CIFRARE UNO O PIU' FILE

  1. Selezionare la voce di menù Folder/Nuovo...

  2. Una maschera chiederà il nome da dare al nuovo archivio cifrato, cioè il file .crypt che conterrà i file cifrati.

  3. Un altra maschera apparirà, chidedendo il file o i file da aggiungere all'archivio cifrato.
    - oppure -
    E' possibile trascinare i file che si vogliono cifrare su una finestra aperta di Folder Crypt.
  4. Un avviso di "possibile perdita dei dati " appare. Dal momento che il processo di cifratura dipende esclusivamente dalla chiave (password o passphrase) inserita, esso non è reversibile se la chiave viene persa. Gli algoritmi implementati da Folder Crypt sono tra i più forti e inviolabili sul mercato. Non esistono ragionevoli possibilità di recuperare i dati se la password viene smarrita. E' possibile altresì evitare di mostrare ogni volta questo avviso, selezionando l'apposita opzione attraverso la voce di menù, Visualizza/Opzioni.

  5. La maschera di cifratura viene mostrata. I file saranno immessi nell'archivio cifrato (file .crypt) indicato. E' possibile decidere di spostare la destinazione del file .crypt premendo il pulsante "...".

  6. Ora è possibile selezionare l'algoritmo di cifratura. Ogni algoritmo nella lista è usato ampiamente nell'industria ed è considerato standard. Ciò significa che la cifratura dipende esclusivamente sulla chiave (password) inserita. Scegliere un algoritmo non è tuttavia obbligatorio: uno di default verrà scelto dall'applicazione. L'algoritmo di default può essere impostato nella finestra delle opzioni.

  7. Il passo più importante è la scelta della password o passphrase. La passphrase è una password che contiene una frase separata da spazi. Maggiore è la lunghezza della password, più sicura è la cifratura. E' molto importante scriversi la password o memorizzarla su un supporto sicuro. Non è possibile in alcun modo recuperare i contenuti di un archivio cifrato se non si ricorda la password. E' possibile ottenere una password complessa generata in modo random usando il generatore random di password.

  8. Premere "Cifra". Il processo di cifratura ha inizio.


Folder Crypt - How to encrypt a Windows folder

COME CIFRARE UNA CARTELLA

  1. Selezionare la cartella che si desidera cifrare selezionando la voce di menù "Folder/Cifra...", oppure usando il tasto destro del mouse in Windows, oppure ancora trascinando la cartella su una finestra aperta di Folder Crypt.

  2. Un avviso di "possibile perdita dei dati " appare. Dal momento che il processo di cifratura dipende esclusivamente dalla chiave (password o passphrase) inserita, esso non è reversibile se la chiave viene persa. Gli algoritmi implementati da Folder Crypt sono tra i più forti e inviolabili sul mercato. Non esistono ragionevoli possibilità di recuperare i dati se la password viene smarrita. E' possibile altresì evitare di mostrare ogni volta questo avviso, selezionando l'apposita opzione attraverso la voce di menù, Visualizza/Opzioni.

  3. I dati da cifrare verranno salvati nella directory mostrata a fianco del pulsante "...". Al loro posto, apparirà un'icona verde e un file con estensione .crypt. Selezionando il pulsante "...", è possibile indicare un'altra directory come destinazione del file .crypt.

  4. Se l'opzione "Ricorsivo" è selezionata, i dati presenti nella cartella e in tutte le sottocartelle di quella cartella verranno cifrati. Altrimenti, solo i contenuti della cartella senza le sottocartelle verranno cifrati.
  5. Se l'opzione "Mantieni directory" è selezionata, i dati presenti nella cartella non saranno cancellati dopo la cifratura. In questo modo, i dati verranno "copiati" nell'archivio cifrato e questo non sostituirà i dati originali, che rimarranno inalterati. Questa opzione è utile se si desidera inviare, ad esempio via e-mail, una copia cifrata dei dati, o crearsi un backup cifrato degli stessi.
  6. Se l'opzione "Elimina fisicamente" è selezionata, la cartella originale e tutti i suoi contenuti saranno sottoposti a shredding. Ciò significa che l'area dei file da cifrare sul disco fisico o su qualunque altro dispositivo di memorizzazione saranno riscritti tre volte bit per bit con una sequenza 1-0-1. Facendo questo, si rende impossibile il recupero stesso dei dati, con qualsiasi software di Undelete o tramite procedure di laboratorio.
  7. Ora è possibile selezionare l'algoritmo di cifratura. Ogni algoritmo nella lista è usato ampiamente nell'industria ed è considerato standard. Ciò significa che la cifratura dipende esclusivamente sulla chiave (password) inserita. Scegliere un algoritmo non è tuttavia obbligatorio: uno di default verrà scelto dall'applicazione. L'algoritmo di default può essere impostato nella finestra delle opzioni.
  8. Il passo più importante è la scelta della password o passphrase. La passphrase è una password che contiene una frase separata da spazi. Maggiore è la lunghezza della password, più sicura è la cifratura. E' molto importante scriversi la password o memorizzarla su un supporto sicuro. Non è possibile in alcun modo recuperare i contenuti di un archivio cifrato se non si ricorda la password. E' possibile ottenere una password complessa generata in modo random usando il generatore random di password.
    Sopra la textbox di inserimento della password, c'è un indicatore della forza della password stessa, che viene aggiornato mentre la password è digitata. Questo indicatore assume colore rosso per password non sicure, giallo per password mediamente sicure e verde per password forti. Posizionando il cursore sopra l'indicatore viene visualizzato l'indice di forza della password.
  9. Premere "Cifra". Il processo di cifratura ha inizio.


Folder Crypt - How to decrypt a Windows folder

COME DECIFRARE UN ARCHIVIO CIFRATO (file .crypt)

  1. Selezionare l'archivio cifrato in Windows, clickare col tasto destro del mouse e selezionare "Decifra con Folder Crypt"

  2. - Oppure - Eseguire Folder Crypt e selezionare la voce di menù "Folder/Apri Cifrato...", oppure premere l'icona "Apri" sulla toolbar.

  3. - Oppure - Trascinare un file .crypt dentro una finestra aperta di Folder Crypt.

  4. Inserire la password che si era utilizzata per la cifratura. Notate che se avete dimenticato la password NON ESISTE ALCUN MODO per recuperare i dati cifrati. Per questo è importante eseguire un backup dei dati o memorizzare la password in modo sicuro.

  5. Premere "Ok". I dati originali sono ora decifrati e disponibili.


Folder Crypt - Folder Lock

COME FUNZIONA LA CIFRATURA

Quando Folder Crypt cifra dei dati, lo fa eseguendo i passi di cui sotto:

  1. I file o la cartella da cifrare vengono esaminati per vedere se si dispone dei permessi di scrittura.
  2. I file vengono copiati in un archivio solido, che è qualcosa di simile ad un archivio zip.
  3. La password di cifratura fornita dall'utente è trasformata in una strong password estraendo da essa l'hash code con l'algoritmo SHA.
  4. L'archivio solido viene cifrato bit per bit con l'algoritmo di cifratura scelto dall'utente.
  5. L'archivio solido cifrato (il file con estensione .crypt) è scritto sulla cartella padre dei dati originali.
  6. I dati originali vengono cancellati. Se si è scelta l'apposita opzione, i dati vengono cancellati fisicamente dal disco.


Folder Crypt - Folder Unlock

COME FUNZIONA LA DECIFRATURA

Quando Folder Crypt decifra i dati da un archivio cifrato, i seguenti passi vengono eseguiti:

  1. La password fornita dall'utente viene trasformata in una strong password estraendone l'hash code con l'algoritmo SHA.
  2. L'archivio solido cifrato (il file .crypt) viene decifrato usando l'algoritmo specificato e la strong password.
  3. Il risultato della decifratura viene copiato nella cartella temporanea dell'utente. Questo è l'archivio solido dei dati originali.
  4. Dall'archivio solido vengono estratti i dati originali. La destinazione di questi dati può essere la directory in cui l'archivio cifrato era contenuto, o qualsiasi altra directory fornita dall'utente.
  5. L'archivio solido viene cancellato dalla directory temporanea.
  6. L'archivio cifrato (il file .crypt) viene cancellato - a meno che l'utente non abbia selezionato l'opzione "Mantieni il file .crypt".


Folder Crypt - How to encrypt a Windows folder

USARE UNA CARTELLA CIFRATA COME UNA NORMALE CARTELLA

Se avete bisogno di una cifratura non molto spinta, ma volete che i vostri dati siano comunque protetti, potete usare la combinazione di opzioni descritta di sotto. Seguendola si ottiene comunque una cifratura reale bit-per-bit dei dati, ma anche la possibilita' di usare la cartella normalmente come se fosse una normale cartella di Windows, poiche' la cifratura avviene molto velocemente.

Ecco alcune opzioni da impostare:

  1. Scegliere nelle opzioni 'Abilitare i metadati'
  2. Scegliere "DES (64 bit)" come algoritmo

E' possibile usare una cartella cifrata normalmente: aprire un file facendo doppio click, guardarlo, modificarlo e lavorarci normalmente. Occorre solo ricordare di salvare il documento prima di uscire. In questo modo, Folder Crypt si accorgera' delle modifiche e chiedera' se si vuole aggiornare l'archivio cifrato con la nuova versione.


Untitled Document

IMPOSTARE LE OPZIONI DI CIFRATURA DI UNA CARTELLA

OPZIONE 'RICORSIVO'

Se l'opzione "Ricorsivo" è selezionata, i dati presenti nella cartella e in tutte le sottocartelle di quella cartella verranno cifrati. Altrimenti, solo i contenuti della cartella senza le sottocartelle verranno cifrati.

OPZIONE 'MANTIENI DIRECTORY'

Se l'opzione "Mantieni directory" è selezionata, i dati presenti nella cartella non saranno cancellati dopo la cifratura. In questo modo, i dati verranno "copiati" nell'archivio cifrato e questo non sostituirà i dati originali, che rimarranno inalterati. Questa opzione è utile se si desidera inviare, ad esempio via e-mail, una copia cifrata dei dati, o crearsi un backup cifrato degli stessi.

OPZIONE 'ELIMINA FISICAMENTE'

Se l'opzione "Elimina fisicamente" è selezionata, la cartella originale e tutti i suoi contenuti saranno sottoposti a shredding. Ciò significa che l'area dei file da cifrare sul disco fisico o su qualunque altro dispositivo di memorizzazione saranno riscritti tre volte bit per bit con una sequenza 1-0-1. Facendo questo, si rende impossibile il recupero stesso dei dati, con qualsiasi software di Undelete o tramite procedure di laboratorio.


Folder Crypt - Extract File

COME ESTRARRE UN FILE DA UN ARCHIVIO CIFRATO

Non è necessario decifrare un intero archivio ogni volta che si desidera utilizzare un file da esso. E' possibile invece selezionare il file e, clickando con il tasto destro del mouse:

  • Aprirlo: selezionando "Apri" (Open), se l'estensione del file è registrata in Windows, l'applicazione con cui aprirlo verrà richiamata e il file aperto.
  • Estrarlo: selezionando "Estrai" è possibile salvare il file in una directory a scelta
  • Estrarlo sul desktop: selezionando "Estrai sul desktop" è possibile salvare il file sul desktop.

E' infine possibile cancellare il file dall'archivio selezionando "Cancella", oppure rinominarlo selezionando "Rinomina".

E' inoltre possibile trascinare il file fuori dalla finestra di Folder Crypt per estrarlo automaticamente in una cartella di destinazione o sul desktop.


Folder Crypt - Drag And Drop

COME CIFRARE/DECIFRARE I DATI CON IL DRAG AND DROP

Un metodo comune per manipolare i file sotto Windows è conosciuto come "Drag and drop". L'utente muove il puntatore del mouse su un'icona rappresentante un file o una cartella e preme un pulsante del mouse. Trattenendo il pulsante premuto mentre si muove il puntatore verso un'altra locazione si effettua il drag. Rilasciando il pulsante del mouse dopo il drag su un'altra icona o finestra si effettua il drop. Questa operazione è anche detta "trascinare su".

Folder Crypt implementa il drag and drop sia per la cifratura che per la decifratura. Inoltre è possibile aggiungere in questo modo dei file a degli archivi cifrati.

1. CIFRATURA DI UNA CARTELLA CON DRAG'N'DROP

Trascinare una cartella su di una finestra aperta di Folder Crypt: la maschera di cifratura apparirà chiedendo un metodo di cifratura e una password.

2. CIFRATURA DI UNO O PIU' FILE CON DRAG'N'DROP

Selezionare uno o più file e trascinarli su una finestra aperta di Folder Crypt: apparirà una maschera di cifratura. Prima di tutto l'utente deve inserire il nome del nuovo archivio che si intende creare (il nome del file .crypt), poi una maschera apparirà chiedendo metodo di cifratura e password.

3. DECIFRATURA DI UN ARCHIVIO CON DRAG'N'DROP

Trascinare un archivio cifrato (un file con estensione .crypt) su una finestra aperta di Folder Crypt: il processo di decifrazione comincerà chiedendo all'utente una password per quell'archivio.

4. AGGIUNGERE UN FILE AD UN ARCHIVIO CIFRATO

Se si apre un archivio cifrato con Folder Crypt (come in figura), è possibile aggiungervi un file trascinandolo sopra la finestra aperta. Se si trascina il file con il pulsante destro del mouse, è possibile scegliere se "copiare" i file (quelli originali verranno lasciati) oppure "spostarli" (quelli originali verranno cancellati).


Passphrase & Strong password

PASSWORD / PASSPHRASE

Una passphrase è una password che contiene uno o più spazi. Folder Crypt accetta password o passphrase come chiavi di cifratura. Una password può contenere qualsiasi carattere di Windows, compresi segni di interpunzione e numeri.

Esempi di password corrette:

  • mario123
  • djskll3JLJKLJKLSiww
  • il mio cane è un Alano

Le password sono sensibili alle maiuscole, per cui

  • abcdefghi

è diverso da

  • aBcdefGhi

STRONG PASSWORD

Una password è sicura se è ragionevolmente esente da attacchi "a dizionario". Questo vuol dire che se la password è una parola di uso comune o un nome, gli attacchi fatti con un dizionario di parole potrebbero scoprirla. Gli attacchi, invece, a "forza bruta" hanno successo quando la password contiene un numero molto basso di caratteri (4) oppure un set ridotto di caratteri (es.: solo lettere alfabetiche minuscole).

Pertanto, Folder Crypt accetta solo password con un numero di caratteri maggiore di cinque.

Inoltre è fortemente raccomandato l'uso di numeri e di lettere maiuscole e minuscole nella password. Una tale password di chiama strong password. Così ad esempio

  • sdjh329dshdKHJKW9i23 [STRONG PASSWORD o password forte]

è una password migliore e più difficilmente attaccabile di

  • il mio nome è john [PASSWORD DEBOLE: usa solo caratteri minuscoli e parole di senso compiuto]

Folder Crypt dispone di un utility per la generazione automatica di strong password. Per richiamarla, selezionare "Azione/Generatore di Password".

Aggiustando la lunghezza della password, una nuova password viene generata in alto. Clickando "Copia" è possibile copiarla nella clipboard per utilizzarla poi come password di cifratura premendo "CTRL+V" o premendo col pulsante destro del mouse sulla textbox "Password" quando si cifra una cartella o un insieme di file.

La password che verrà utilizzata realmente nel processo di cifratura è data dalla funzione HASH applicata alla codifica UTF8 dei caratteri della password. Nella maschera di generazione password è possibile vedere la password "reale" nel riquadro "Password reale (binaria)"


Folder Crypt - Solid Archive

ARCHIVIO SOLIDO

Prima che avvenga la cifratura, la cartella o i file vengono trasformati in un archivio solido, il quale è messo nella directory dei dati temporanei dell'applicazione. L'archivio solido è simile ad un normale archivio TAR o ZIP. E' possibile indicare un livello di compressione dell'archivio solido nella maschera Opzioni.


Folder Crypt - Open Encrypted Archive

APRIRE UN ARCHIVIO CIFRATO

Per vedere i contenuti di un archivio cifrato è necessario aprirlo fornendo la password corretta. Il metodo di cifratura verrà automaticamente riconosciuto da Folder Crypt all'apertura dello stesso.

Quando un archivio cifrato è aperto è possibile:

  • Ripristinare la cartella originale o i file contenuti
  • Aprire un file (facendo doppio click su di esso o selezionando Apri). Se il file è registrato in Windows, l'applicazione che lo utilizza verrà aperta. Il file verrà decifrato nella directory temporanea dell'utente. Uscendo da Folder Crypt, il file temporaneo verrà eliminato.
  • Estrarre uno o più file dall'archivio in una directory a scelta o sul desktop
  • Vedere i dettagli di ogni file nell'archivio (nome, data di creazione, tipo, lunghezza, CRC e path originale)
  • Cancellare uno o più file dall'archivio
  • Rinominare un file dell'archivio
  • Vedere le proprietà di un file e del suo archivio

Tutte queste operazioni sono disponibili selezionando uno o più file e aprendo il menù contestuale premendo il tasto destro del mouse.


Folder Crypt - View Archive Contents

GUARDARE I CONTENUTI DI UN ARCHIVIO CIFRATO

Per guardare i contenuti di un archivio cifrato (file .crypt) viene richiesta l'immissione dellla password. Se questa è corretta, i contenuti dell'archivio vengono mostrati. Attraverso la voce di menù "Visualizza" è possibile mostrare i contenuti in vari modi: elenco, icone grandi, icone piccole e via dicendo.

E' possibile a quel punto ripristinare l'archivio selezionando l'icona della toolbar "Decifra", oppure selezionare un file ed estrarlo.


Folder Crypt - Shredding

ELIMINAZIONE FISICA DEI DATI

Usando Folder Crypt si vuole la massima sicurezza sui propri dati. A parte le forti caratteristiche crittografiche di Folder Crypt, qualche volte i dati possono essere rivelati ispezionando l'hardware del computer in cui i dati erano PRIMA DI ESSERE CIFRATI.

Infatti i dati vengono prima spostati dalla loro posizione originale all'archivio cifrato. Lo spostamente viene normalmente fatto chiamando la funzione del sistema operativo "Delete". Ciò può non essere sufficiente. Infatti, il sistema operativo non cancella FISICAMENTE l'area su cui il file era originariamente, ma semplicemente la MARCA come cancellabile. In questo modo l'area può (o non può) essere cancellata con una riscrittura.

L'eliminazione fisica dei dati è un'operazione che Folder Crypt esegue sui dati originali, riscrivendone la porzione su disco per n volte. In particolare, dalla finestra delle opzioni è possibile scegliere tra questi metodi di eliminazione:

SIMPLE METHOD

Questo metodo "azzera" l'area , cioè la sovrascrive interamente con il byte 0x00 (bit 0).

PSEUDO-RANDOM METHOD

Il metodo pseudorandom sovrascrive cinque volte l'area con una sequenza pseudo-random di byte generata al momento.

COMPLEX METHOD

Il metodo Complex sovrascrive l'area tre volte con i byte

  1. 0x00 (00000000)
  2. 0xFF (11111111)
  3. 0x00 (00000000)

METHOD DoD 5520-22M / NISPOM 8-306

L'implementazione della raccomandazione del dipartimento della difesa americano (DoD 5520-22M) segue questo schema:

Tre iterazioni sovrascrivono l'area per sei volte. Ogni iterazione sovrascrive per due volte l'area del file: la prima scrive 0xFF (1) e la seconda scrive 0x00 (0). Dopo la terza iterazione, un settimo passo sovrascrive con il byte “246” (in hex 0xF6)

Per maggiori informazioni, si legga il documentoDoD 5220.22-M US Defence Security Service alla voce Web Site (Capitolo 8, Clearing and Sanitization Matrix ).

METHOD GUTMANN

Questo metodo è basato sul famoso documento di Peter Gutmann "Secure Deletion of Data from Magnetic and Solid-State Memory". In particolare, lo schema di sovrascrittura - preso da quel documento - è il seguente:

Dati sovrascritti
Passo | Byte
1 | Random
2 | Random
3 | Random
4 | Random
5 | 01010101 01010101 01010101 0x55
6 | 10101010 10101010 10101010 0xAA
7 | 10010010 01001001 00100100 0x92 0x49 0x24
8 | 01001001 00100100 10010010 0x49 0x24 0x92
9 | 00100100 10010010 01001001 0x24 0x92 0x49
10 | 00000000 00000000 00000000 0x00
11 | 00010001 00010001 00010001 0x11
12 | 00100010 00100010 00100010 0x22
13 | 00110011 00110011 00110011 0x33
14 | 01000100 01000100 01000100 0x44
15 | 01010101 01010101 01010101 0x55
16 | 01100110 01100110 01100110 0x66
17 | 01110111 01110111 01110111 0x77
18 | 10001000 10001000 10001000 0x88
19 | 10011001 10011001 10011001 0x99
20 | 10101010 10101010 10101010 0xAA
21 | 10111011 10111011 10111011 0xBB
22 | 11001100 11001100 11001100 0xCC
23 | 11011101 11011101 11011101 0xDD
24 | 11101110 11101110 11101110 0xEE
25 | 11111111 11111111 11111111 0xFF
26 | 10010010 01001001 00100100 0x92 0x49 0x24
27 | 01001001 00100100 10010010 0x49 0x24 0x92
28 | 00100100 10010010 01001001 0x24 0x92 0x49
29 | 01101101 10110110 11011011 0x6D 0xB6 0xDB
30 | 10110110 11011011 01101101 0xB6 0xDB 0x6D
31 | 11011011 01101101 10110110 0xDB 0x6D 0xB6
32 | Random
33 | Random
34 | Random
35 | Random

Se avete la necessità di effettuare eliminazione fisica dei dati in modo sistematico o con più opzioni, potreste valutare il prodotto LittleLite NShred: http://www.littlelite.net/nshred


Encryption Algorithms - DES and Triple DES

"DES" e "Triple DES"
Data Encryption Standard

  • Che cos'è?
  • Come lo implementa Folder Crypt?

Che cos'è?

L'algoritmo descritto in questo standard specifica sia le operazioni di cifratura sia quelle di decifratura, che sono basate su un numero binario chiamato chiave.

La chiave consiste di N bits (tipicamente 64), di cui 56 sono generati a caso e usati direttamente dall'algoritmo. Gli altri 8 bit, che non sono usati dall'algoritmo, vengono utilizzati per trovare errori. Gli utenti autorizzati nell'uso di dati cifrati devono avere la chiave che è stata usata per cifrare i dati stessi per riuscire a decifrarli. Benché l'algoritmo sia noto e disponibile a tutti, la chiave lo rende unico. Infatti, selezionando una chiave diversa si ottiene un codice cifrato differente rispetto a quello ottenuto con un'altra chiave. La sicurezza crittografica del dato dipende dalla sicurezza con cui la chiave viene custodita e trasmessa.

DES funziona cifrando gruppi di 64 bit, cioè 16 numeri esadecimali per volta. Per cifrare, DES usa chiavi che sono apparentemente di 16 numeri esadecimali, ma l'ottavo bit è sempre ignorato e viene utilizzato per fare un controllo di parità.

DES è un codice di crifratura a blocchi, che vuole dire che opera su blocchi di una determinata dimensione (64 bit) e ritorna blocchi cifrati della stessa dimensione. Perciò DES effettua una permutazione tra le 2^64 possibili combinazioni di un blocco di 64 bit. Ogni blocco è poi diviso in due blocchi da 32 bit, un blocco di sinistra (L) e un blocco di destra (R).

Questa modalità di cifratura per blocchi, in DES si chiama modalità ECB (Electronic Code Block mode). DES però può anche operare in modalità a catena di blocchi (CBC, Chain Block Encoding) o in modalità a feedback (CFB, Cipher Feedback). In queste due ulteriori modalità, ogni blocco fa riferimento al blocco precedente attraverso operazioni di XOR logico.

L'algoritmo DES viene completamente spiegato in http://www.itl.nist.gov/fipspubs/fip46-2.htm

Come lo implementa Folder Crypt?

L'algoritmo necessita di una CHIAVE e di un VETTORE DI INIZIALIZZAZIONE per poter funzionare. In Folder Crypt la chiave è data dai primi 64 bit dell'hash SHA384 ottenuto dalla password inserita dall'utente.

Così, ad esempio, se la password è 'Romanoff', la chiave è generata dall'hash code con algoritmo SHA384 della codifica secondo lo standard UTF8 dei caratteri che compongono la password. Il VETTORE DI INIZIALIZZAZIONE, invece, è ricavato dai successivi 64 bit dell'hash code ottenuto in precedenza.

Il triplo DES (Triple DES) è nient'altro che l'applicazione dell'algoritmo DES a dei dati per tre volte consecutive. Nell'implementazione di Folder Crypt, la chiave di questo algoritmo può essere lunga da 128 a 192 bit. Mentre per l'algoritmo DES la chiave è fissa a 64 bit.


Encryption Algorithms - Rijndael

Rijndael (AES)

  • Che cos'è?
  • Come lo implementa Folder Crypt?

Che cos'è

Dall'anno 2001, Rijndael è stato approvato come il nuovo American Encryption Standard (AES).

Rijndael è un sistema di cifratura a blocchi, progettato da Joan Daemen e da Vincent Rijmen

La lunghezza della chiave può essere 128, 192 o 256 bit in accordo con i requisiti AES. A differenza di DES o Twofish, la dimensione della chiave deve essere uno di questi valori, non può essere arbitrario. A differenza inoltre degli altri candidati AES, Rijndael può avere blocchi di lunghezza variabile a 128, 192 o 256 bit. Così le nove combinazioni di lunghezze di chiave e blocchi sono possibili - ma per una implementazione corretta di AES, il blocco deve essere di 128 bit. Il numero di iterazioni dell'algoritmo principale può variare da 10 a 14 ed è dipendente dalle lunghezze del blocco e della chiave. Il basso numero di iterazioni è stato uno dei principali motivi di critica a Rijndael, ma se questo dovesse in futuro rivelarsi un problema, il numero di iterazioni può molto facilmente essere aumentato.

La descrizione dettagliata dell'algoritmo è contenuta nel documento ufficiale Rijndael, sottoposto alla commissione AES dai suoi progettisti. Il documento è piuttosto tecnico e un certo grado di conoscenze matematiche è richiesto.

Le specifiche Rijndael possono essere trovate qui.

Come Folder Crypt lo implementa

L'implementazione di Rijndael da parte di Folder Crypt è fatta su blocchi da 128 bit, mentre la chiave può essere di 128, 192 o 256 bit. I valori possono essere selezionati nella maschera "Opzioni" dal menù Azioni/Opzioni.

Il valore della chiave è dato dai primi 128/192/256 bit della funzione SHA applicata alla password immessa dall'utente in fase di cifratura. Se la lunghezza della chiave più il blocco è minore o uguale di 384 bit, viene usato l'algoritmo SHA384, altrimenti viene usato l'SHA512.

I byte vengono sottomessi alla funzione di hashing traducendo i caratteri secondo la codifica UTF8.


Encryption Algorithms - ArcFour

ArcFour (ARC4)

  • Cos'è?
  • Come è implementato da Folder Crypt?

Cos'è

L'algoritmo ARC4 ("Alleged RC4") è compatibile con l'algoritmo RC4(TM) che è uno dei più famosi, di proprietà della RSA Security Inc.

E' un semplica algoritmo di generazione di sequenze random. L'algoritmo è immune alla criptoanalisi differenziale e lineare. La logica che vi sta dietro può generare molte migliaia di stati differente. Non ha un modo di operazioni a blocchi poiché cifra uno stream di dati.

ARC4 è usato con successo in molte applicazioni, ad esempio IPSEC, il protocollo SSH e TLS. Ci sono molti Internet Draft che descrivono come può essere applicato, ad es.: [Caronni], [SSH].

L'algoritmo può essere usato con differenti lunghezze di chiavi, solitamente a 40 e a 128 bit.

[Caronni] Caronni, G., Waldvogel, M. "The ESP Stream Transform", ftp://ds.internic.net/internet-drafts/ draft-caronni-esp-stream-01.txt, September, 1996.
[SSH] Ylonen, T., "SSH Transport Layer Protocol", ftp://ietf.org/internet-drafts/draft-ietf-secsh-transport-00.txt, March, 1997.

Com'è implementato da Folder Crypt

L'implementazione di ARC4 fatta da Folder Crypt presenta una varietà di scelta per le chiavi da 128 a 2048 bit.

La chiave è costruita con i primi bit della funzione SHA estratta dalla chiave inserita dall'utente mentre si cifrano i dati. Se la lunghezza della chiave è superiore a 512 bit (che risultano dall'utilizzo dell'algoritmo di hash SHA512), i rimanenti bit sono presi dalla successiva applicazione dello stesso hash code, fino a un massimo di 4 volte per la chiave a 2048 bit.

Così ad esempio se la password è "Romanoff", la chiave reale viene generata applicando l'hash code alla stringa "Romanoff" e utilizzando i bit di quell'hash code come chiave reale. I byte che formano la password vengono estratti utilizzando la codifica UTF8.

See Mozilla: A Stream Cipher Encryption Algorithm "Arcfour"


Encryption Algorithms - Rijndael

Blowfish

  • Che cos'è?
  • Come lo implementa Folder Crypt?

Che cos'è

Blowfish è un algoritmo di cifratura simmetrico a blocchi con chiave variabile da 32 a 448 bit, ideale per usi domestici o dove è richiesta maggior sicurezza. E' stato progettato nel 1993 da Bruce Shneier come una veloce, facile alternativa agli algoritmi di cifratura esistenti. Da allora è stato considerevolmente analizzato, e sta lentamente guadagnando la fama di essere un algoritmo sicuro e forte. Non è protetto da patenti ed è liberamente utilizzabile.

La documentazione originale di Blowfish fu presentata al workshop First Fast Software Encryption di Cambridge dell'Aprile 1994.

Molti crittografi hanno analizzato Blowfish ed esistono alcune referenze, tra cui quella di Serge Vaudenay e di Vincent Rijmen.

Le specifiche Blowfish possono essere trovate qui.

Come Folder Crypt lo implementa

L'implementazione di Blowfish da parte di Folder Crypt è fatta su blocchi da 128 bit, mentre la chiave può essere di 128, 256 o 448 bit. I valori possono essere selezionati nella maschera "Opzioni" dal menù Azioni/Opzioni.

Il valore della chiave è dato dai primi 128/256/448 bit della funzione SHA applicata alla password immessa dall'utente in fase di cifratura. Se la lunghezza della chiave più il blocco è minore o uguale di 384 bit, viene usato l'algoritmo SHA384, altrimenti viene usato l'SHA512.

I byte vengono sottomessi alla funzione di hashing traducendo i caratteri secondo la codifica UTF8.


Folder Crypt - Options

OPZIONI

1. SELEZIONE DELL'ALGORITMO DI CIFRATURA

Qui è possibile selezionare l'algoritmo con cui i file saranno cifrati. Questi sono ordinati in ordine di complessità. In genere, più complesso è l'algoritmo, più difficile sarà attaccarlo, ma sarà anche meno veloce nel cifrare.

Se non si è sicuri, un buon compromesso tra sicurezza e velocità è l'algoritmo AES a 128 bit.

Ricordate che questa opzione determina solo l'algoritmo di default: questo può però essere impostato diversamente ad ogni nuova operazione di cifratura.

2. MISCELLANEE

Qui è possibile selezionare varie opzioni.

3. COMPRESSIONE

Imposta la compressione degli archivi cifrati.

4. TOOLBAR

La toolbar è l'insieme di icone che si trovano sotto il menù nella finestra di Folder Crypt. Qui è possibile determinare:

  • Se mostrare la toolbar
  • Se mostrare il testo delle icone nella toolbar

Senza toolbar, la finestra di Folder Crypt è notevolmente più piccola, il che può risultare vantaggioso su client con risoluzioni basse (es.: 640x480)

5. LINGUA

Qui è possibile determinare la lingua dell'applicativo.


Folder Crypt - How to Register

COME REGISTRARE FOLDER CRYPT

Folder Crypt è un prodotto software shareware. Ciò significa che è distribuito con una formula "prova e poi compra". Infatti è possibile è provare il prodotto (senza alcun tipo di limitazioni) per 30 giorni, dopo di che occorre registrarlo o disinstallarlo.

Il prodotto cesserà di funzionare dopo 30 giorni a partire dalla prima installazione.

La registrazione di Folder Crypt permette di acquistare una o più licenze d'uso dello stesso. La licenza può essere letta qui. Gli utenti registrati possono continuare ad usare il prodotto oltre i 30 giorni e hanno diritto a:

  • pieno supporto via e-mail
  • upgrade gratuiti dell'applicativo (ogni volta che esce una nuova versione)

Per registrare Folder Crypt occorre connettersi al sito http://www.littlelite.net/foldercrypt e premere il pulsante "Download" a destra. Poi premere "Acquista". Sarete rediretti sul sito del nostro partner per l'e-commerce "Share-IT", che dispone di connessione SSL sicura e può genstire transazioni via carta di credito o bonifico bancario (e anche altri metodi di pagamento). Se avete domande o commenti relativamente alla fase di acquisto di licenze, potete consultare il Customer Care di Share-IT.

Subito dopo aver effettuato l'ordine, riceverete un codice di registrazione via e-mail che potrete applicare al prodotto per registrarlo e renderlo definitivamente funzionante. Il codice di registrazione va inserito nella maschera di sotto, cui si accede dalla voce di menù ?/Registra. Nella maschera vanno inseriti gli stessi dati forniti a Share-IT/LittleLite durante la fase di acquisto.

PRESTARE ATTENZIONE: I campi fanno tutti differenza tra maiuscole e minuscole, per cui

Nome: john

Cognome: edwerton

è diverso da:

Nome: John

Cognome: Edwerton

Una volta applicato il codice di registrazione, il prodotto è definitivamente registrato per un uso continuativo oltre i 30 giorni di valutazione. Le maschere che invitano alla registrazione non saranno più mostrate e il nome della persona a cui il software è stato registrato verranno mostrati nella maschera ?/Informazioni.

Questa è una registrazione "perpetua" che è valida per tutte le future versioni del prodotto. In ogni caso, dopo aver acquistato una o più licenze di Folder Crypt, vi sarà riconosciuta una garanzia di rimborso per la durata di 30 giorni, che potrete far valere nel caso in cui il prodotto non sia per voi soddisfacente.


Folder Crypt - Licenza

LICENZA D'USO PER L'UTENTE FINALE (EULA)

LICENZA:

  • Questo limitato accordo per utilizzo di software (l' "Accordo") è un accordo legale tra Lei ("Licenziatario"), l'utente finale, e la LittleLite Software ("LittleLite") per l'uso del programma "Folder Crypt" (il "Programma"). Usando questo programma o memorizzandolo su un hard disk di computer (o qualsiasi altra periferica), Lei è d'accordo con i termini di questo Accordo. Se non è d'accordo con questi termini, cancelli il programma da tutte le periferiche.
  • Lei può installare questo Programma per testare e valutare se soddisfa i Suoi bisogni e desidera acquistarlo. Il periodo di valutazione dura un mese (trenta giorni) a partire dalla data di installazione del prodotto. Dopo questo periodo, le funzionalità del programma cesseranno di funzionare.
  • Questo programma è licenziato, non venduto. Posto che Lei sia d’accordo con quanto espresso in questo EULA: (a) Lei può installare ed usare una copia del Programma, o una versione precedente, per lo stesso sistema operativo, su un singolo computer per un uso da parte di un singolo operatore; e (b) Lei può installare una singola copia del Programma, strettamente per uso personale, su un computer portatile di Sua proprietà. Nessun altro uso, copia o distribuzione del Programma è permessa. Lei non può noleggiare il Programma, né può offrirne l’uso ad altri attraverso la vendita di un servizio o attraverso un Application Service Provider.
  • Questo Programma può essere distribuito liberamente su servizi online, siti, BBS o altri media elettronici a patto che i file vengano distribuiti nella loro interezza. Questo Programma non può essere distribuito su CD-ROM, dischi o altre periferiche chiedendo un corrispettivo senza il permesso di LittleLite Software.
  • Lei non può alterare il Programma in alcun modo, incluso cambiare o rimuovere messaggi o finestre.
  • Lei non può decompilare, fare reverse-engineering, disassemblare o ridurre in alcun modo il Programma sotto alcuna forma leggibile. Lei non può modificare, noleggiare o rivendere per profitto questo Programma, o crearne delle opere derivate. Lei non può pubblicare o distribuire i codici di registrazione, le informazioni di registrazione o gli algoritmi di registrazione di questo Programma senza il permesso di LittleLite. Lei non può usare codici di registrazione del Programma che non siano stati acquistati da LittleLite o da un rappresentante autorizzato di LittleLite.
  • Lei accetta la responsabilità per i costi derivanti dagli usi in Rete o altri costi causati dall’uso del Programma.

NESSUNA GARANZIA – LittleLite ESPRESSAMENTE DISCONOSCE ALCUNA GARANZIA per il Programma. Il Programma e ogni documentazione relativa è fornita “così com’è” (as-is) senza alcuna garanzia di alcun genere, sia esplicita che implicita, incluso, senza limitazione, la capacità del Programma di assolvere ad uno scopo particolare.

L’intero rischio derivante dall’uso o dalle performance del Programma è di Sua competenza.

QUESTO PROGRAMMA NON E’ FAULT TOLERANT E NON DOVREBBE ESSERE UTILIZZATO IN ALCUN AMBIENTE CHE LO RICHIEDA.

NESSUNA RESPONSABILITA’ PER I DANNI. In nessun caso LittleLite o i suoi rappresentanti saranno imputabili per quasiasi danno (incluso, senza limitazione, i danni per perdita di profitto, interruzione di servizio, perdita di informazioni o altre perdite pecuniarie) che dipendano dall’uso o dall’incapacità d’uso di questo Programma.

--------------------------------

COPYRIGHT:

  • Folder Crypt è protetto da Copyright da parte di LittleLite Software. Lei deve trattare questo Programma come qualsiasi altro materiale protetto da copyright.

--------------------------------


Folder Crypt - Algorithm Sleection Option

OPZIONI DI SELEZIONE DELL'ALGORITMO DI DEFAULT

Si può selezionare qui l'algoritmo di cifratura di default.

Per scoprire quale fa meglio per le vostre necessità, potete provare a guardare i "Dettagli..." dopo la cifratura o decifratura per scoprire il tempo impiegato dalla macchina. Gli algoritmi disponibili sono ordinati in base alla complessità e alla potenza. Un algoritmo più complesso è in generale più difficile da attaccare - ma la velocità di cifratura può essere inferiore.

Se non siete sicuri, un buon compromesso tra velocità e complessità è l' AES (128 bit), mentre l'algoritmo più veloce è il DES a 64 bit.

Ricordate che questa opzione determina solo il valore di default: l'algoritmo può comunque essere scelto ogni volta che si effettua una cifratura.


Folder Crypt - Compression Options

OPZIONI DI COMPRESSIONE

I dati cifrati possono essere compressi a scelta tra i valori 'Nessuna compressione' e 'Massima compressione'

Una tipica cartella contenente documenti MS WordTM da 1Mb può essere compressa fino ad occupare 200kb al massimo livello di compressione. Naturalmente, maggiore è la compressione, minore sarà la velocità di cifratura.


Folder Crypt - Details

DETTAGLI DI CIFRATURA/DECIFRATURA

Ogni operazione di cifratura o decifratura con Folder Crypt può essere ispezionata guardando il dettaglio delle operazioni. Questo può essere fatto clickando sul pulsante "Dettagli..." quando è disponibile, o selezionando la voce di menù "Vista/Dettagli".

La finestra dei dettagli mostra ogni singola azione fatta dal programma, un piccolo sommario delle operazioni e il tempo totale delle operazioni, utile anche per decidere quale algoritmo e compressione utilizzare su un certo set di dati.

Premendo il pulsante "Copia", i contenuti della finestra saranno copiati nella clipboard di sistema per un uso futuro attravarso Cut-Copy-Pase.


LittleLite Software - Folder Crypt Home Page

FOLDER CRYPT
Cifratura avanzata di basso livello per file e directory

LittleLite Software

Protezione sicura per i file e le directory in WindowsTM


Folder Crypt - Miscellaneous Options

OPZIONI MISCELLANEE

Qui è possibile selezionare

  • MOSTRA L'AVVISO DI PERDITA DATI
    Se non è impostato, l'avviso che appare ad ogni cifratura circa la possibile perdita di dati, non verrà più mostrato.

  • ABILITA IL MENU CONTESTUALE PER OGNI FOLDER
    Quando Folder Crypt viene installato, aggiunge di default una nuove voce di menù a tutte le cartelle di Windows che si chiama "Cifra con Folder Crypt". Questa voce viene mostrata quando si clicka col pulsante destro del mouse su di una cartella. Richiamando questo comando, Folder Crypt verrà eseguito per cifrare la cartella selezionalta. Disabilitare questa opzione significa non volere questo tipo di integrazione con Windows. Deselezionare questa opzione non è raccomandato.

  • ABILITA IL MENU CONTESTUALE PER OGNI FILE
    Impostando questa opzione, apparirà una nuova voce di menù per ogni file di Windows, nominata "Cifra con Folder Crypt". Chiamando questo comando, Folder Crypt verrà eseguito in modalità di cifratura file. Questa opzione non è selezionata di default.

  • ELIMINA IL FOLDER ORIGINALE DI DEFAULT
    Impostando questa opzione si farà in modo che ogni volta che si cifra una cartella, l'opzione "Elimina i file fisicamente" sia impostata di default.
  • MOSTRA SPLASH SCREEN
    Deselezionando, lo splash screen iniziale non verrà più mostrato.
  • ABILITA METADATI
    Normalmente, Folder Crypt salva le informazioni relative all'algoritmo di cifratura usato dentro l'archivio cifrato. Questo al fine di rendere più facile l'utilizzo all'utente finale, che dovrà ricordarsi solo la password. Disabilitando i metadati, queste informazioni non verranno più salvate, aumentando la sicurezza dell'archivio. D'altra parte l'utente dovrà ricordarsi sia la password sia il metodo di cifratura utilizzato, che verrà richiesto ad ogni decifratura.


FOLDER CRYPT Screenshots

An encrypted folder may be viewed just like any other Windows folder (after having supplied the right password).

File comparison is done with MD5 and SHA256 hash codes.

You can compare entire folders too.

Folder Crypt adds also two"magic" extension to your Windows desktop:

By right clicking any folder you may Lock or, if it's locked, Unlock it.


Folder Crypt - Options - Toolbar

OPZIONI DELLA TOOLBAR

La toolbar è l'insieme di icone che si trovano sotto il menù nella finestra di Folder Crypt. Qui è possibile determinare:

  • Se mostrare la toolbar
  • Se mostrare il testo delle icone nella toolbar

Senza toolbar, la finestra di Folder Crypt è notevolmente più piccola, il che può risultare vantaggioso su client con risoluzioni basse.