{

Operace FLASHPOINT

Úvod

Úvod

3. světová válka je na obzoru. Úsvit a soumrak se střetají nad Maldenskými ostrovy a vy se ocitáte mezi nimi. Použijte veškeré dostupné zdroje, abyste zabránil příchodu noci. Pěchota, obrněné divize a letecké síly – to vše čeká, připraveno k vašim službám, abyste mohl odrazit síly světa útisku a bezpráví. Nejdřív se ale musíte sám vypracovat… Vítejte v armádě, vojáku! Snad tuto zkušenost vydržíte.

Instalace

Vložte CD s Operation Flashpoint™ do mechaniky CD-ROM a zásuvku s diskem zavřete. Počkejte několik sekund, než se mechanika inicializuje. Máte-li na počítači zapnuté Automatické přehrávání, Operation Flashpoint™ se začne automaticky instalovat. Nemáte-li zapnuté Automatické přehrávání, přejděte k nabídce Start a vyberte SPUSTIT. Napište D:\setup (písmeno „D“ nahraďte označením své mechaniky CD‑ROM) a stiskněte [ENTER]. Proběhne inicializace instalačního programu; v instalaci pokračujte dál podle pokynů na obrazovce. Operation Flashpoint™ vyžaduje přítomnost DirectX 8.0 ve vašem počítačovém systému. Během instalace hry dostanete příležitost nainstalovat také DirectX 8.0.

Upozornění, varování před epilepsií a poznámka o pirátství

Upozornění

– Při manipulaci se nedotýkejte povrchu disku, držte jej za okraj.

– Disk udržujte čistý, stírejte jej jemně měkkým hadříkem. Zabraňte vzniku škrábanců na povrchu disku.

– Nevystavujte disk extrémním teplotám, přímému slunečnímu světlu ani nadměrné vlhkosti.

– Nikdy nepoužívejte zlomené nebo ohnuté disky, ani když byly opravené lepidlem. Mohly by vzniknout funkční problémy.

Varování před epilepsií

Čtěte, prosím, před použitím tohoto výrobku.

Někteří lidé jsou náchylní k epileptickým záchvatům nebo ztrátě vědomí, jsou-li v každodenním životě vystaveni určitým typům blikajících světel nebo světelných vzorů.

Takoví lidé mohou dostat záchvat během hraní některých videoher. Může k tomu dojít, dokonce i když osoba dosud žádný lékařský záznam o epilepsii neměla ani epilepsií nikdy netrpěla.

Jestliže se u vás nebo u kohokoliv z vaší rodiny někdy vyskytly při vystavení blikajícím světlům symptomy spojované s epilepsií (záchvaty či ztráta vědomí), poraďte se před použitím tohoto výrobku se svým lékařem.

Vyskytnou-li se u vás nebo vašich dětí během hraní videohry některé z následujících příznaků: závratě, pozměněné vidění, cukání očí nebo svalů, ztráta vědomí, dezorientace, bezděčné pohyby nebo křeče, okamžitě přestaňte hrát a obraťte se na svého lékaře.

Předběžná opatření, která byste měl při používání tohoto výrobku dodržovat:

– Nesedejte příliš blízko monitoru. Zajistěte si polohu v dostatečné vzdálenosti od obrazovky.

– Dávejte přednost hraní na malém monitoru.

– Nepoužívejte výrobek, jste-li unavený nebo nevyspalý.

– Zajistěte si, aby místnost, ve které hrajete, byla dobře osvětlena.

– Při hraní videohry odpočívejte každou hodinu nejméně 10 až 15 minut.

Poznámka o pirátství

Kopírování komerčních her, jako je tato, se považuje za porušení autorského práva a je trestným činem. Platí to jak pro používání zkopírovaných her, tak pro jejich držení. Kopírování a následný prodej takových her může být trestáno odnětím svobody.

Zkopírovaná hra se považuje za zcizený majetek.

© 2001 Bohemia Interactive Studio a The Codemasters Software Company Limited ("Codemasters"). Všechna práva vyhrazena. „Codemasters“® a logo Codemasters jsou registrované obchodní značky vlastněné Codemasters. „Operation Flashpoint“™ a „GENIUS AT PLAY“™ jsou obchodní značky Codemasters. Všechna ostatní autorská práva nebo obchodní značky jsou majetkem příslušných vlastníků. Vyvinuto v Bohemia Interactive Studio. Vydává Codemasters.

Vyvinuto v Bohemia Interactive Studio. Vydává Codemasters. V ČR vydává CENEGA nv. Určeno výhradně pro soukromé a domácí použití.

OVLÁDÁNÍ

Ovládání

Pěchota

Klávesnice

[W] nebo [↑] Dopředu

[E] nebo [Shift] + [W] /[↑] Sprint

[A] nebo [←] Úkrok vlevo

[D] nebo [→] Úkrok vpravo

[S] nebo [↓] Vzad

[Shift] + směrová klávesa Rychlý pohyb

[Q] nebo [Page Up] / [Z] nebo [Page Down] Leh/vztyk

[R] nebo [Home] Nabití zbraně

[ENTER] Otvírá nabídku činností (viz Nabídka činností)

[0] – [9] Vyvolání nabídky činností a výběr položky nabídky (viz Ve velení družstva)

[,] (num. klávesnice) Zap./vyp. velitelského pohledu

[V] nebo [0] (num. klávesnice) Zap./vyp. pohledu zbraně

[ENTER] (num. klávesnice) Pohled vlastníma očima/vnější pohled

[+] /[–] Přiblížení/oddálení (pouze pohled vlastníma očima, vnější pohled)

Myš

Myš vlevo / vpravo Otáčení vlevo / vpravo

Myš nahoru / dolů Pohled nahoru / dolů

Levé tlačítko myši Výstřel ze zbraně / hod granátem

Vydání rozkazu k přesunu zvoleným vojákům (viz Ve velení družstva)

Kolečko myši Vyvolání nabídky činností a zvýraznění položek nabídky

Prostřední tlačítko myši /

klepnutí kolečkem myši Výběr položky z nabídky činností

Pravé tlačítko myši Přiblížení / zachycení cíle (podle používané zbraně)

Ovládání vozidel

Klávesnice

[Q] Pomalu dopředu

[W] nebo [↑] Dopředu

[E] nebo [Shift] + [W] / [↑] Rychle dopředu

[A] nebo [←] Zatočení vlevo

[D] nebo [→] Zatočení vpravo

[S] nebo [↓] Zpomalení / brždění

[Shift] + směrová klávesa Rychlý pohyb

[L] Zap./vyp. světlometů (je-li jimi vozidlo vybaveno)

[TAB] Přepínání dostupných cílů

Myš

Klávesou [*] na numerické klávesnici přepínáte mezi rozhlížením myší a řízením myší.

Rozhlížení myší Řízení myší

Myš vlevo / vpravo Pohled vlevo / vpravo Zatáčení vlevo / vpravo

Myš nahoru / dolů Pohled nahoru / dolů

Pravé tlačítko myši Výběr cíle / zachycení (viz Zaměřování a střelba z palubních zbraní)

Levé tlačítko myši

(s vybraným cílem) Odpálení zbraně / vydání rozkazu STŘÍLET nebo NESTŘÍLET

Levé tlačítko myši

(BEZ vybraného cíle) Přesun na místo (jste-li v roli velitele a máte ve své osádce řidiče)

Pozn.: K zaměřovacím a zbraňovým systémům vozidla máte přístup pouze v případě, že k tomu máte oprávnění (tzn. výhradně jako člen osádky vozidla na pozici střelce nebo velitele tanku – viz Řízení tanku a Zaměřování a střelba z palubních zbraní).

Ovládání vzdušných dopravních prostředků

Klávesnice

[W] nebo [↑] Dopředu

Ve vrtulnících – zvýšení rychlosti rotoru (zapnuté řízení myší)

V letadlech – zvýšení rychlosti

[E] nebo [Shift] + [W] / [↑] Rychle dopředu

[A] nebo [←] Posun / zatočení vlevo

[D] nebo [→] Posun / zatočení vpravo

[X] nebo [Del] Otáčení doleva (ve visu)

[C] nebo [End] Otáčení doleva (ve visu)

[S] nebo [↓] Zpomalení

Ve vrtulnících – snížení rychlosti rotoru (zapnuté řízení myší)

V letadlech – snížení rychlosti

[Q] Start motoru / stoupání

[Z] Klesání

[G] Pouze v letadle – zasunutí / vysunutí podvozku

[F] Pouze v letadle – vysunutí/zasunutí vztlakových klapek

[TAB] Přepínání dostupných cílů

Univerzální ovládání

[Mezerník] nebo pravý [Ctrl] Přepínání dostupných zbraní

[[] / []] / kolečko myši Výběr položky z nabídky činností

[F1] Nabídka povelů

[G] Ukázat kompas

[*] (num. klávesnice) Přepnutí rozhlížení myší / řízení myší

[M] Mapa (podrobnosti k ovládání mapy viz Mapa)

[+] / [–] (hlavní klávesnice) Zrychlení / zpomalení běhu hry

[ESC] Pozastavení

[H] Zobrazení posledního textu nápovědy

Nabídka činností

[Po straně: Příklad, jak může ve hře vypadat nabídka činností.]

M16 do ruky

Zbraň dalekohled

Založit zás. M16

Posadit

[ENTER] / prostřední tlačítko myši – otevření nabídky činností

[[] / []] / kolečko myši – zvýraznění činnosti

[ENTER] / prostřední tlačítko myši – potvrzení činnosti a zavření nabídky

Kontextová nabídka činností se používá k takovým účelům, jako je výběr a příprava zbraní nebo volba zvláštní zbraně či střeliva. Používá se také pro vstup do vozidla, změnu postu ve vozidle (pouze v pohledu vlastníma očima) nebo k opuštění vozidla.

Když v misi narazíte na určité místo, mohou se v nabídce činností objevit nové volby. Jakmile k tomu dojde, objeví se nabídka činností automaticky, abyste tyto nové možnosti mohl aktivovat.

Nabídka činností také zprostředkovává přístup k funkcím, které nejsou přístupné prostřednictvím standardních ovládacích kláves. Stiskem [ENTER] nebo prostředního tlačítka myši vyvoláte nabídku činností a pomocí [[] a []] nebo kolečka myši zvýrazníte činnost, kterou máte v úmyslu provést. Jakmile ji máte vybranou, stiskněte znovu [ENTER] nebo prostřední tlačítko myši a činnosti aktivujete.

HARDWARE

Minimální požadavky

Windows 95, 98, ME, 2000

Pentium II 400 CPU

96 MB RAM

16 bitová zvuková karta, DirectX kompatibilní

3D grafická karta se 16 MB RAM, DirectX kompatibilní

CD-ROM se 4x rychlostí otáčení

300 MB volného místa na pevném disku (po instalaci)

Doporučená konfigurace

Windows 95, 98, ME, 2000

Pentium III 700 CPU

128 MB RAM

16 bitová zvuková karta, DirectX kompatibilní

3D grafická karta s 32 MB RAM, DirectX kompatibilní

CD-ROM s 8x rychlostí otáčení

300 MB volného místa na pevném disku (po instalaci)

Podporované 3D čipové sady

3Dfx Voodoo 2, Voodoo Banshee, Voodoo3, Voodoo 4, Voodoo5

ATI Rage 128, Radeon

Matrox G200, G400, G450

nVidia Riva TNT, Riva TNT2, GeForce 256, GeForce 2

Požadavky pro síťovou / internetovou hru

• Modem s minimální rychlostí 33,6 kbps

• Síť TCP/IP

• Libovolná síť 100% podporovaná Microsoft DirectPlay®

Podpora

Technická podpora

Editor

Editor

S editorem misí, který je dodáván společně se hrou, si můžete vytvářet také své vlastní mise. Editor misí může být používán v jednom ze dvou režimů, v jednoduchém nebo pokročilém. S pokročilým editorem vám může pomoci následující průvodce (KLEPNĚTE NA TANK).

POKROČILÝ EDITOR

Díl první – umisťování jednotek, skupin a orientačních bodů

Pro začátek, po výběru editoru misí, nahrajte ostrov Everon. Seznamte se s rozhraním, všimněte si tlačítek nahoře a klávesových zkratek na nich (stiskem F1 umisťujete jednotky atd.). Po mapě se můžete pohybovat buď pomocí myši nebo klávesnice, držením pravého tlačítka myši mapu uchopíte a můžete ji posouvat tažením, pomocí kolečka myši ji přibližujete a oddalujete. Na klávesnici můžete použít k posouvání mapy její numerickou část a k přibližování a oddalování klávesy + / –.

Najděte na mapě vesnici ENTRE DEUX. Zhruba v půli cesty k pobřeží po silnici vedoucí na východ z Entre Deux je farma; na ní se bude odehrávat náš děj.

První umisťovanou věcí je postava, za kterou budeme hrát. Ta nám pak umožní misi zkoušet a sledovat, zda vše funguje tak, jak má. Najděte vhodné místo nedaleko farmy a z nabídky nahoře na obrazovce vyberte JEDNOTKY (F1). Klepněte dvojitě na mapu, kam chcete položit svého hráče. Objeví se nové okno, VLOŽ JEDNOTKU. V tomto okně nastavujete všechny vlastnosti jednotky, kterou se chystáte umístit. Když klepnete vedle STRANA:, kde je právě uvedeno ZÁPAD, uvidíte seznam stran, ke kterým může umisťovaná jednotka patřit. Dejme tomu, že stranu změníme a nastavíme příslušnost našeho hráče k VÝCHODu.

Rámeček TŘÍDA: můžeme nechat beze změn, poněvadž chceme, aby náš hráč byl člověk a ne tank, ani letadlo. Beze změn můžeme nechat také OVLÁDÁNÍ:, poněvadž první jednotka, kterou umisťujeme je vždy standardně HRÁČ. Můžete si všimnout, že dalšími dvěma možnostmi pro Ovládání jsou NEHRATELNÉ, což znamená, že jednotku bude vždy ovládat počítač, a HRATELNÉ, která se využívá v misích určených pro síťovou hru.

STÁŘÍ: můžeme ponechat jako NEZNÁMÉ; tuto volbu pravděpodobně nebudete potřebovat pro žádnou svoji jednotku. ZÁMEK VOZIDLA: můžete také nechat na STANDARDNÍ; měnit jej budete muset jen velmi zřídka.

HODNOST: nastavme o něco vyšší než VOJÍN, řekněme KAPITÁN, ale v této misi to nebude hrát žádnou roli, poněvadž v ní budeme sami.

Z rámečku JEDNOTKA: vyberte OSTŘELOVAČ – ve hře není dostatek ostřelovačských misí, takže si jednu připravíme.

Rámeček ZVLÁŠTNÍ: nastavme na NIC, protože pro jedince není FORMACE důležitá; jak formace funguje si vysvětlíme později.

Do políčka NÁZEV: napište název, který chcete této jednotce dát, ovšem není to název, který bude vidět ve hře, ale název, který budeme používat ve výrazech a proměnných zacházejících s touto jednotkou. Svoji jednotku jsem si nazval "aP"; žádný zřejmý důvod k tomu není, ale občas se budu v této lekci k aP odkazovat, takže uděláte nejlépe, když si jednotku pojmenujete také aP.

Poslední věcí, kterou musíme změnit, je směr, jakým se budeme dívat při vstupu do hry (AZIMUT). Klepněte vlevo na kružnici a nastavte hodnotu zhruba 250.

Pak klepněte na OK a umístíte svoji první jednotku. Na pravé straně obrazovky byste měl vidět nové tlačítko, ZKUSIT. Klepněte na něj a ocitnete se ve hře. Prozkoumejte své nejbližší okolí a jakmile budete připraven vrátit se zpět do editoru, stiskněte ESC, pak PŘERUŠIT a potom POKRAČOVAT. Chcete-li, můžete svoji jednotku přemístit tažením levým tlačítkem myši.

Dále připravíme nepřátelské družstvo. Z horní lišty vyberte SKUPINY (F2) a klepněte dvojitě někam k silnici směrem k Entre Deux. V okně VLOŽ SKKUPINU vyberte STRANA: ZÁPAD, TYP: PĚCHOTA a zbývající možnosti nechte, jak jsou. Klepněte na OK a umístíte nepřátelské jednotky na mapu. Bude mezi nimi důstojník, kulometčík, granátometčík, pár vojáků a raketometčík. Tyrkysové spojnice mezi nimi naznačují, že všichni tito vojáci podléhají svému důstojníkovi.

Nyní jim poskytneme vozidlo, kterým budou cestovat. Znovu vyberte JEDNOTKY (F1) a klepněte na silnici přímo před skupinu, kterou jste právě umístil. V okně vyberte: STRANA: ZÁPAD, TŘÍDA: AUTO, HODNOST: KAPITÁN, JEDNOTKA: 5T NÁKLADNÍ AUTO, ZVLÁŠTNÍ: NIC, NÁZEV: westcar, AZIMUT: 140.

Jakmile automobil umístíte, měl byste vidět modré spojnice, které znázorňují, že skupina je nyní propojena s právě vloženým automobilem.

Za budovu farmy, kde je náš ostřelovač, umístíme další automobil. Vůz bude mít následující vlastnosti: STRANA: PRÁZDNÁ, TŘÍDA: AUTO, JEDNOTKA: UAZ, ZVLÁŠTNÍ: NIC, NÁZEV: uscar, AZIMUT: 0. Tento automobil bude v závěru využit jako náš cíl.

Nyní pomocí několika orientačních bodů necháme nasednout nepřátelskou skupinu do náklaďáku, popojet s ním o kousek po silnici, vysednout a pokusit se zničit právě umístěný UAZ. Z nabídky vyberte ORIENT. BODY (F4), jednou klepněte na náklaďák, a pak znovu dvojitě na náklaďák. Měl byste vidět nabídku VLOŽ ORIENTAČNÍ BOD. Zde stačí změnit jediný rámeček – VYBERT TYP: NASTUP.

Abychom dali náklaďák do pohybu, klepněte na orientační bod nástupu, který jsme vložili, tak, aby byl zvýrazněný, pak klepněte dvojitě na silnici v lese, blíž k ostřelovači. V rámečku POŘADÍ ORIENT. BODU: byste měl vidět 1: a dále změňte VYBER TYP: na VYSTUP. Poslední orientační bod umístěte na UAZ, POŘADÍ ORIENT. BODU: by mělo být 2: a typ ZNIČ.

Poznámka na okraj; chcete-li se dostat "pod orientační bod", abyste upravil jednotky, nad kterými orientační bod je, stačí držet stisknutou klávesu SHIFT.

Nyní je vhodný okamžik pro další test tlačítkem ZKUSIT. Teď by už měla naše mise dobře fungovat. Náklaďák by měl dojet na kopec v dálce, zastavit, vojáci z něj vystoupí, zaútočí a pokusí se zničit UAZ zaparkovaný za budovou farmy.

V další části se soustředíme na SPÍNAČE.

K DRUHÉMU DÍLU

Díl druhý – Spínače

Takže si to shrňme, nyní bychom měli mít funkční misi, ve které jste vy, jakožto ostřelovač nedaleko farmy. Nepřátelé přijíždí přes kopec v náklaďáku, vystoupí a pokusí se zničit UAZ zaparkovaný za domem.

Nyní se chystáme přidat na mapu několik SPÍNAČŮ, které nám umožní vyrobit kraťoučké předělové scény a, co je důležitější, definovat ukončení mise. Začneme s nejjednodušším typem spínače, který bude zjišťovat přítomnost nepřátelských vojáků v určené kruhové oblasti. Jakmile v této oblasti nebudou žádní vojáci, nastaví svoji proměnnou na TRUE (pravda), a ta pak může být využita v jiných spínačích. Zní to složitě, ale podívejme se, jak to funguje v praxi.

Z nabídky v horní liště vyberte SPÍNAČE (F3). Dvojitým klepnutím zhruba v poloviční vzdálenosti mezi ostřelovačem a nepřítelem spínač umístěte. Navzdory tomu, jak složité věci lze spínači zvládnout, je jejich nastavování snadné. Horní část okna VLOŽ SPÍNAČ obsahuje parametry velikosti a tvaru spínače, které musíme nastavit, neboť připravujeme zjišťovací spínač. Nastavte HL. 1/2OSA a VEDL. 1/2OSA na 500 (poloosy elipsy). ÚHEL může zůstat 0, protože vytváříme kružnici. Zkontrolujte, že rámečkem je zvýrazněno slovo ELIPSA.

Další část okna VLOŽIT SPÍNAČ slouží pro aktivaci spínače. My požadujeme, aby náš spínač zjistil, kdy v jeho oblasti nejsou žádné západní jednotky, takže z rámečku AKTIVACE vybereme ZÁPAD. Zvýrazněte rámeček JEDNOU, protože tento spínač budeme chtít aktivovat pouze jedenkrát. Pak zvýrazněte rámeček NEPŘÍTOMEN. Oddíl časování prozatím můžeme nechat beze změn, poněvadž ten určuje prodlevu před aktivací spínače nebo dobu, po kterou spínač funguje (odpočítávání).

Třetí část je stručná. V rámečku TYP vyberte PŘEPNI. Typ bychom mohli nechat prázdný, ale technicky se jedná o spínací senzor. Rámeček TEXT slouží pro zadání označení spínače na mapě, já jsem si jej nazval westdead. Je dobrým zvykem dávat spínačům označení, která se nějakým způsobem váží k jejich funkci. Rámeček NÁZEV můžeme ponechat prázdný; používá se vložení názvu, který je možné využít v jiných podmínkových výrazech.

Poslední část okna VLOŽ SPÍNAČ je nejsložitější, ale také nejužitečnější. Nejdříve se budeme zabývat rámečkem PODMÍNKA. Jestliže tento rámeček obsahuje slovo THIS (tento), pak spínač bude používat parametry nastavené v první a druhé části okna VLOŽIT SPÍNAČ. Obvykle se nastavují podmínky k aktivaci spínače pomocí proměnných z jiných spínačů. V takovém případě nemusíte psát proměnná = true, stačí napsat pouze proměnná. Často se používají také logické operátory AND, OR, NOT.

Typický výraz použitý u spínače může vypadat takto

this an2:00 PM 3/19/01d (not (alive aP)) and variable1

this říká, že se použijí parametry z aktivačního rámečku spínače.

(not (alive aP)) je použito pro označení smrti hráče (vzpomeňte si, že jsme našeho hráče nazvali aP).

variable1 by mohla být proměnná, která byla nastavena na hodnotu true jiným spínačem.

Nicméně, pro náš spínač potřebujeme pouze slovo this, protože jeho chování závisí výhradně na parametrech v aktivačním rámečku.

Druhé pole zde je PŘI AKTIVACI. Tento rámeček říká, co se stane, když je spínač aktivován. Používá se k provádění mnoha různých úloh, od prostého naplnění proměnných, které slouží k rozhodování o splnění úkolů mise z brífinku, přes aktivaci orientačních bodů, odemčení vozidel a vykonání skriptů.

Pro náš senzor přidáme řádek

"1" objStatus "DONE"; v1=true

první část výrazu "1" objStatus "DONE" označuje, že byl splněn první cíl z brífinku. K brífinku se dostaneme v další části této výuky. Znak ; se používá k oddělování výrazů v jedné větě. Druhá část řádky v1=true nastavuje proměnnou v1 na stav true (pravda). Tuto proměnou budeme využívat v některých jiných spínačích.

Poslední rámeček okna VLOŽ SPÍNAČ neobsahuje nic, čím bychom se museli nyní zabývat. Používá se nejčastěji pro opakované spínače nebo pro spínače, které se aktivují podle časovačů.

A tím by byl první spínač hotov. Kdybychom chtěli, stačilo by nyní připravit konec mise, což by se provedlo umístěním SPÍNAČE KONEC. Chceme však připravit naši misi poněkud složitější, takže vložíme ještě některé další spínače.

První z nich bude zjišťovat stav UAZu zaparkovaného nedaleko od domu. Umístěte SPÍNAČ v blízkosti UAZu. Měl by mít následující nastavení

HL. 1/2OSA: 0, VEDL. 1/2OSA: 0, AKTIVACE: ŽÁDNÁ, TYP: PŘEPNI, TEXT: uscardead, PODMÍNKA: not(alive uscar), PŘI AKTIVACI: endlose=true

Protože v této PODMÍNCE nemáme slovo this, bude spínač aktivován pouze řetězcem v poli PODMÍNKA. Aktivuje se, když uscar (tak jsme nazvali UAZ) nežije. Jakmile dojde k aktivaci, nastaví se proměnná endlose na true (pravda).

Další senzor bude zjišťovat stav nákladního vozu používaného nepřáteli. Tento náklaďák jsme si pojmenovali westcar. Umístěte další SPÍNAČ do blízkosti náklaďáku. Bude mít následující parametry

HL. 1/2OSA: 0, VEDL. 1/2OSA: 0, AKTIVACE: ŽÁDNÁ, TYP: PŘEPNI, TEXT: westcar, PODMÍNKA: not(alive westcar), PŘI AKTIVACI: "2" objStatus "DONE"; westcardead=true

Nyní byste měl význam parametrů už chápat sám. Máme splněný cíl objStatus a nastavenou novou proměnnou westcardead.

Čtvrtý SPÍNAČ dejte kamkoliv chcete. Bude sloužit k dvojité kontrole stavu některých proměnných a k odškrtnutí 3. cíle z brífinku. Nastavení spínače:

HL. 1/2OSA: 0, VEDL. 1/2OSA: 0, AKTIVACE: ŽÁDNÁ, TYP: ŽÁDNÝ, TEXT: objthree, PODMÍNKA: (alive uscar and v1 and westcardead), PŘI AKTIVACI: "3" objStatus "DONE"; uscaralive=true

Nyní začneme přidávat pár KONCOVÝCH SPÍNAČŮ. První umístěte k farmě; půjde o ukončení v závislosti na proměnné endlose, která, jestli si pamatujete, byla nastavována na hodnotu true, když UAZ "nežije" (tzn. je zničen). Takže pro tento spínač použijeme následující hodnoty:

HL. 1/2OSA: 0, VEDL. 1/2OSA: 0, AKTIVACE: ŽÁDNÁ, TYP: KONEC Č. 2, TEXT: endlose, PODMÍNKA: endlose

Důležitý je zde TYP: KONEC Č. 2, který ukončuje misi a ukazuje brífink s koncem číslo 2. Všimněte si také PODMÍNKY: endlose. Ta využívá proměnnou endlose která byla definována v jednom z předchozích spínačů a nastavuje se na hodnotu pravda, když dojde ke zničení UAZu.

Nyní umístíme další SPÍNAČ. Ten bude sloužit k ukončení s jiným koncem, kdy v misi vítězíte.

HL. 1/2OSA: 0, VEDL. 1/2OSA: 0, AKTIVACE: ŽÁDNÁ, TYP: KONEC Č. 1, TEXT: endWIN, PODMÍNKA: sy and westcardead and uscaralive

KONEC Č. 1 bude definován v brífinku, sy je proměnná naplňovaná v okamžiku, kdy v oblasti nejsou žádní nepřátelé, westcardead je proměnná plněná hodnotou pravda, když zničíte náklaďák a uscar alive je proměnná, která kontroluje, zda nebyl váš UAZ zničen.

Vaše mise je nyní plně funkční, včetně dobrého i špatného konce. V další kapitole se podíváme na to, jak se přidávají předělové scény a zvukové efekty.

K TŘETÍMU DÍLU

Díl třetí – předělové scény a zvuky

Nyní, když je naše mise plně funkční (dobrá, kromě brífinku), přidáme si několik 'parádiček'.

Začneme předělovou scénou, která se odehraje hned na začátku naší mise. Provedeme to tak, že umístíme SPÍNAČ nedaleko ostřelovače u farmy. Tento spínač nastavte následovně:

HL. 1/2OSA: 50, VEDL. 1/2OSA: 50, AKTIVACE: KDOKOLI, TEXT: init, PODMÍNKA: this

Protože poloměr tohoto spínače hráče přesahuje, bude aktivován rovnou. V okně VLOŽ SPÍNAČ klepněte na tlačítko EFEKTY dole. Nyní před sebou máte okno UPRAV EFEKTY. Z části KAMERA vyberte EFEKT: Dokola a POZICE: Zezadu. V části TITULKY vyberte TYP: TEXT, EFEKT: UPROSTŘED a do rámečku TEXT: napište Američané přijíždějí po silnici od západu… jsem poslední nadějí, musím je zastavit!!!

Ještě připravíme jednu předělovou scénu na okamžik, kdy nepřátelští vojáci vysedají z náklaďáku. Umístěte další SPÍNAČ nedaleko orientačního bodu náklaďáku VYSTUP. Pro tento spínač zvolte:

HL. 1/2OSA: 50, VEDL. 1/2OSA: 50, AKTIVACE: KDOKOLI, TEXT: ŽÁDNÝ, PODMÍNKA: this

EFEKTY nastavte takto:

EFEKT=Pomalé přiblížení, POZICE: Zepředu

Nyní v části ZVUKY vyberte

ANONYMNÍ: SPUSŤ POPLACH, PROSTŘEDÍ: Zvuk bitvy

Výborně, právě jste přidal další předělovou scénu a dva typy zvukových efektů.

V poslední části se podíváme na brífinky.

KE ČTVRTÉMU DÍLU

Díl čtvrtý – brífink

Brífinky lze napsat pouze z prostředí mimo hru. Píší se v HTML, takže pokud víte něco o psaní webových stránek (ručně, bez použití WYSIWIG editorů), měl byste je zvládnout velmi rychle.

Protože psaní brífinku úplně od nuly by mohlo být poněkud obtížné, nabízím vám už připravený brífink pro tuto misi. Můžete jej využít jako šablonu pro kteroukoliv další misi, kterou vytvoříte sám.

BRÍFINK

Můžete také přidat STRUČNÝ PŘEHLED mise, což je krátký popis, který vidíte, když vybíráte misi ze seznamu jednotlivých misí. Jeden takový jsem připravil pro tuto misi.

PŘEHLED

Chcete-li brífink a přehled použít, klepněte na ně pravým tlačítkem, dejte "uložit jako" a uložte je do adresáře se svojí misí. Příponu zvolte .html.

Můžete si přidat také obrázek. Doporučuji zkopírovat některý z jiných jednotlivých misí, přejmenovat jej na pic.paa a umístit do adresáře se svojí misí.

Tady mám pro vás ještě několik poznámek, které vám pomohou při tvorbě vlastního brífinku:

Když si myslíte, že jste hotov, podívejte se na přehled a brífink ke hře. Všimnete-li si, že je něco špatně, pak ze hry odejděte a opravte to. Pravděpodobně jste zapomněl něco změnit v šabloně.

Do brífinku můžete přidávat zvláštní značky, kterými přeskakujete po mapě. Stačí umístit je na mapu v editoru misí a odvolat se na ně v brífinku řádkem podobným tomuto:

<a href="marker:nazevznacky">text v brífinku</a>

Jakmile svoji misi dokončíte, zkopírujte ji ze svého adresáře flashpoint/users/vasejmeno/missions do adresáře flashpoint/missions. Pak se k této misi budete moci dostat přímo z nabídky jednotlivých misí ve Flashpointu. Tak si budete moci také náležitě prohlédnout brífink.