Ferramenta de diagnóstico do DirectX

Ferramenta de diagnóstico do DirectX

A documentação da Ferramenta de diagnóstico do Microsoft® DirectX® contém os seguintes tópicos:

  • Sobre a Ferramenta de diagnóstico do DirectX
  • O que procurar
  • Testando componentes do DirectX
  • Substituindo o comportamento padrão


Sobre a Ferramenta de diagnóstico do DirectX

A Ferramenta de diagnóstico do Microsoft® DirectX® fornece informações sobre componentes e drivers da interface de programação de aplicativo (API) do DirectX no sistema. Ela permite que você teste as saídas de sons e de elementos gráficos e os provedores de serviços do Microsoft DirectPlay®. Também permite que você desative alguns recursos de aceleração de hardware.

Você pode usar a ferramenta de diagnóstico para coletar informações a serem passadas para um técnico de suporte durante uma chamada e pode salvar as informações coletadas pela ferramenta e colá-las em uma mensagem de email.

As informações são apresentadas em várias páginas. Você pode mover-se entre as páginas seguindo um destes métodos:

  • Clicar nas guias.
  • Clicar no botão Próxima página.
  • Pressionar as teclas SETA PARA A ESQUERDA ou SETA PARA A DIREITA quando o foco de entrada estiver em uma guia.

Você também pode clicar no botão Salvar todas informações para salvar todas as informações em um arquivo de texto.

Observação Algumas informações, como o volume de memória em uma placa de vídeo, podem ser aproximadas.


O que procurar

Se você está tendo problemas ao executar os aplicativos do Microsoft® DirectX®, a Ferramenta de diagnóstico do DirectX poderá ajudá-lo a entender o porquê. Eis alguns dos itens pelo qual você deve estar procurando:

  • Versões incorretas dos componentes do DirectX. Na seção Observações da página Arquivos do DirectX, procure pelos avisos sobre os arquivos Beta e de depuração. Os arquivos Beta são versões de teste anteriores e não devem ser instalados em aplicativos comerciais. As versões de depuração, que são usadas no desenvolvimento de programas e que também não devem ser instaladas no produto final, podem tornar a execução dos aplicativos mais lenta do que quando eles são instalados em versões comerciais dos componentes.
  • Falta de aceleração de hardware. Alguns programas são executados bem lentamente ou podem até não ser executados, a menos que as acelerações de hardware do Microsoft DirectDraw® ou do Direct3D® estejam disponíveis. Na página Vídeo, em Recursos do DirectX, veja se as acelerações do DirectDraw, do Direct3D ou do AGP Texture estão marcadas como "Não disponíveis". Se estiverem, você poderá considerar a hipótese de atualizar o hardware.
  • Dispositivo não conectado. Se um joystick ou outro dispositivo de entrada não responder, é possível que ele não esteja devidamente configurado. Certifique-se de que o dispositivo apareça na página Entrada da Ferramenta de diagnóstico do DirectX. Se não aparecer, adicione o dispositivo usando o Painel de controle.
  • Drivers não certificados. A Microsoft não verificou se os drivers não certificados possuem total compatibilidade com a versão mais recente do DirectX. Esses drivers estão listados na página apropriada do componente.


Testando componentes do DirectX

Você pode testar o Microsoft® DirectDraw® e o Direct3D® em qualquer monitor conectado ao sistema. Também pode testar o DirectSound® em qualquer dispositivo de saída de som wave e o DirectMusic® em qualquer porta de música.

Para testar um recurso do DirectX: clique no botão Teste na página apropriada, leia qualquer mensagem exibida e observe ou escute os testes. Execute todos os testes até aparecer uma mensagem perguntando se o teste obteve êxito. Se a resposta for Não, nenhum outro teste será executado.

No caso do DirectMusic, só há um teste. Clique em OK para indicar se a música está sendo reproduzida corretamente ou não.

Você pode testar a funcionalidade do Microsoft DirectPlay® em qualquer provedor de serviços disponível.

seta de procedimento Para testar o DirectPlay

  1. Na página Rede, clique em Testar DirectPlay. Na caixa de diálogo Teste do DirectPlay, digite um nome de usuário e escolha um provedor de serviços. Selecione Criar nova sessão e clique em OK. Se você escolheu uma conexão de modem, clique em Resposta na caixa de diálogo Conexão do modem para colocar o modem no modo de resposta automática.
  2. Agora execute a Ferramenta de diagnóstico do Microsoft DirectX® em outro computador que possa estabelecer a conexão selecionada com o primeiro computador. Clique em Testar DirectPlay, digite um nome de usuário distinto, escolha o mesmo provedor de serviços, clique no botão Juntar-se à sessão existente e clique em OK.

    3. Para alguns tipos de conexão, talvez seja preciso fornecer mais informações, como, por exemplo, um número de telefone. Para uma conexão TCP/IP em uma rede local, você pode deixar a caixa de texto em branco.

  3. No segundo computador, selecione o nome da sessão na Lista de sessões que contiver o nome da sessão criada no primeiro computador e clique em OK.
  4. Os dois computadores devem mostrar agora uma caixa de diálogo de bate-papo. Digite uma mensagem na caixa de entrada de um dos computadores e clique em Enviar. A mensagem deve ser exibida na área de rolagem da caixa de diálogo de bate-papo dos dois computadores.


Substituindo o comportamento padrão

Na página Som, você pode definir um nível de aceleração de hardware diferente movendo o controle deslizante. Esse nível permanece em vigor após você ter fechado a Ferramenta de diagnóstico do Microsoft® DirectX®.

Observação Este recurso não está disponível no Microsoft Windows® 95.

Você pode desativar a aceleração de hardware para o Microsoft DirectDraw® ou o Direct3D®, caso essa aceleração esteja disponível. Para tal, vá para a página Vídeo para cada dispositivo de vídeo e clique no botão Desativar. Após desativar a aceleração de hardware, ela não ficará disponível aos aplicativos, mesmo depois de você fechar a Ferramenta de diagnóstico do DirectX. Para reativar a aceleração de hardware, clique no botão Ativar na página Vídeo apropriada.

Observação Desativar a aceleração do DirectDraw também desativa a aceleração de Direct3D.

Você também pode substituir a taxa de atualização do monitor definida pelos aplicativos de tela inteira do DirectDraw. Apenas faça isso se você estiver com problemas de exibição em um aplicativo e tiver motivos plausíveis para acreditar que o aplicativo está definindo uma taxa de atualização inválida.

seta de procedimento Para definir uma taxa de atualização de substituição

  1. Na página Mais ajuda, clique no botão Substituir.
  2. Na caixa de diálogo Substituir o comportamento de atualização do DirectDraw, selecione a caixa de edição e insira uma taxa de atualização válida para o monitor.

    3. A opção Substituir valor é automaticamente selecionada quando você efetua essa ação.

  3. Clique em OK.

seta de procedimento Para cancelar a taxa de atualização de substituição e permitir que os aplicativos do DirectDraw definam sua própria taxa de atualização

  1. Na página Mais ajuda, clique no botão Substituir.
  2. Na caixa de diálogo Substituir o comportamento de atualização do DirectDraw, selecione o botão de opção Padrão e clique em OK.


Tópico não encontrado

Nenhum tópico correspondente foi encontrado. Algumas causas e soluções possível estão descritas a seguir:

  • O arquivo (.chm) que contém o tópico de destino não está no local esperado.

    • Solução: Execute novamente a instalação do MSDN Library.

  • O arquivo (.chm) que contém o tópico atual ou de destino está desatualizado e o link não é mais válido.

    • Solução: Instale a última versão do MSDN Library.

  • O CD do MSDN Library não está na unidade de CD-ROM.

    • Solução: Insira o CD do MSDN Library na unidade de CD-ROM.