DirectX 診断ツール

Microsoft DirectX 診断ツールのヘルプの内容は、次のとおりです。

  • DirectX 診断ツールの概要
  • DirectX 診断ツールを使用して問題を診断する
  • DirectX コンポーネントのテストを行う
  • 既定の動作を変更する
  • 情報を保存する
  • WHQL デジタル署名を確認する


DirectX 診断ツールの概要

Microsoft DirectX 診断ツールは、システム上の DirectX アプリケーション プログラミング インターフェイス (API) コンポーネントおよびドライバに関する情報を提供します。これにより、サウンドやグラフィックの出力テストや、Microsoft DirectPlay サービス プロバイダを有効にすることができます。また、一部のハードウェア アクセラレータの機能を無効にすることもできます。

このツールを使うと、サポート センターへの問い合わせ中に情報を収集し、サポート技術者に伝えることができます。ツールが収集した情報を保存し、電子メール メッセージに貼り付けることもできます。

情報は、数ページのタブに分けて表示されます。次のいずれかの方法で、ページ間を移動できます。

  • タブをクリックする。
  • [次ページ] をクリックする。
  • フォーカスがタブにあるときに、左右の方向キーを押す。

[DirectX ファイル]、[ミュージック]、[入力] など、診断ツールのページによっては、表に情報が表示される場合があります。表の情報を並べ替えることで、探している情報の詳細を簡単に見つけることができます。

表の情報を並べ替えるには

  1. 表の並べ替えに使用したい情報が含まれる列を特定します。
  2. その列の上部にあるヘッダー ボタンをクリックします。

    その列の項目に基づいて、アルファベット順または数字順に表が並べ替えられます。並べ替えの順序を逆にする (たとえば「A から Z」ではなく「Z から A」) には、もう一度ヘッダー ボタンをクリックします。

* 注

  • ディスプレイ カードのメモリ量など、一部の情報については、概算の場合があります。
  • DirectX 診断ツールで収集した情報の保存について詳しくは、「関連情報」をクリックしてください。

関連情報

DirectX コンポーネントのテストを行う

情報を保存する


DirectX 診断ツールを使用して問題を診断する

Microsoft DirectX アプリケーションの実行中に問題が発生した場合に、DirectX 診断ツールを使って問題の原因を調べることができます。次のような問題がないか確認してください。

  • 誤ったバージョンの DirectX コンポーネント。[DirectX ファイル] ページの [注意] で、ベータ ファイルやデバッグ ファイルに関する警告がないか確認してください。ベータ ファイルは初期のテスト用バージョンで、商用プログラムと共にインストールすべきものではありません。デバッグ バージョンはプログラムを開発する際に使われるファイルで、最終製品と共にインストールすべきものではありません。コンポーネントのデバッグ バージョンがインストールされていると、製品版がインストールされている場合よりもプログラムの実行速度が大幅に低下することがあります。
  • ハードウェア アクセラレータの欠如。一部のプログラムは、Microsoft DirectDraw または Direct3D ハードウェア アクセラレータが利用できないと、実行速度が非常に低下するか、またはまったく動作しません。[ディスプレイ] ページの [DirectX の機能] で、DirectDraw アクセラレータ、Direct3D アクセラレータ、または AGP テクスチャ アクセラレータに "なし" と表示されていないことを確認してください。表示されている場合は、ハードウェアのアップグレードをお勧めします。また、Windows Server 2003 ファミリで製品を使用している場合は、グラフィック アクセラレータを有効にしなければならないことがあります。設定するには、コントロール パネルの [画面] を開き、[設定] タブをクリックして [詳細設定] をクリックします。[トラブルシューティング] タブをクリックし、[ハードウェア アクセラレータ] スライダを [最大] にします。
  • デバイスが接続されていない。ジョイスティックなどの入力デバイスが応答しない場合、正しくセットアップされていない可能性があります。そのデバイスが、DirectX 診断ツールの [入力] ページに表示されているかどうか確認してください。表示されていない場合は、コントロール パネルを使ってデバイスを追加します。
  • 未署名のドライバ。マイクロソフトでは、未署名のドライバが最新バージョンの DirectX と完全に互換性があるかどうかをテストしていません。Microsoft Windows Hardware Quality Lab (WHQL) によってデジタル署名されたドライバを使用することをお勧めします。

* 注

  • ターミナル サービスを使用してハードウェア アクセラレータをサポートするリモート システムで作業する場合、ハードウェア アクセラレータをサポートしていることが DirectX 診断ツールによって示される場合があります。ただし、ターミナル サービスではハードウェア アクセラレータを使用できないため、サポートを利用することはできません。

関連情報

情報を保存する

WHQL デジタル署名を確認する


DirectX コンポーネントのテストを行う

システムに接続されている各モニタでの Microsoft DirectDraw および Direct3D のテストを行うことができます。また、各 WAVE 出力デバイスでの DirectSound のテスト、および各ミュージック ポートでの DirectMusic のテストを行うことができます。

DirectX の機能をテストするには

  1. 適切なページで [テスト] をクリックします。
  2. 表示されるメッセージを確認します。
  3. テストのための表示や音を確認します。
  4. テストが成功したかどうかを確認するメッセージが表示されるまで、それぞれのテストを実行します。[いいえ] をクリックした場合は、それ以上テストは実行されません。

DirectMusic の場合は、単一のテストが行われます。演奏された音楽に問題がない場合、または正しく演奏されない場合、どちらの場合も [OK] をクリックします。

また、有効なサービス プロバイダ上の Microsoft DirectPlay のテストを行うこともできます。

DirectPlay をテストするには

  1. [ネットワーク] ページで、[DirectPlay のテスト] をクリックします。
  2. [DirectPlay のテスト] ダイアログ ボックスで、ユーザー名を入力して、サービス プロバイダを選択します。
  3. [新しいセッションの作成] を選択し、[OK] をクリックします。
  4. モデム接続を選択していた場合は、[モデム接続] ダイアログ ボックスで [応答] をクリックしてモデムを接続待ちの状態にしてください。

Microsoft DirectX 診断ツールを、1 つ目のコンピュータと接続の確立が可能な他のコンピュータ上で起動します。

  1. [DirectPlay のテスト] をクリックします。
  2. 別のユーザー名を入力します。
  3. 同じサービス プロバイダを選択します。
  4. [既存のセッションに参加] ボタンをクリックし、[OK] をクリックします。

    接続の種類によっては、電話番号などの情報の入力を求められます。ローカル ネットワーク上の TCP/IP 接続の場合には、このテキスト ボックスには何も入力する必要はありません。

  5. [セッションの一覧] に 1 つ目のコンピュータ上で作成したセッション名が表示されます。セッション名を選択します。
  6. 両方のコンピュータでチャット ダイアログが表示されます。入力ボックスにメッセージを入力し、[送信] をクリックします。入力されたメッセージは、両方のコンピュータ上のチャット ダイアログにあるスクロール エリアに表示されます。


既定の動作を変更する

[サウンド] ページでスライダを操作して、ハードウェア アクセラレータの設定を変更することができます。ハードウェア アクセラレータの設定を変更するには、システム管理者でなければなりません。ここでの設定は、Microsoft DirectX 診断ツールを終了した後もそのまま有効になります。

Microsoft DirectDraw または Direct3D でハードウェア アクセラレータを利用可能な場合に、それを無効にすることができます。無効にするには、システムにインストールされている各ディスプレイ デバイスに対する [ディスプレイ] ページで [無効] をクリックします。無効にしたハードウェア アクセラレータは、DirectX 診断ツールを終了した後も無効のままで、アプリケーションから利用することはできなくなります。アクセラレータをもう一度有効にするには、適切な [ディスプレイ] ページで [有効] をクリックします。

* 注

  • DirectDraw アクセラレータを無効にすると、Direct3D のアクセラレータも無効になります。

また、DirectDraw の全画面表示アプリケーション使用時のモニタのリフレッシュ レートを変更することもできます。この変更は、特定のアプリケーションでディスプレイに関する問題が発生していて、そのアプリケーションが無効なリフレッシュ レートを設定していると考えられるような場合にだけ行ってください。

リフレッシュ レートを変更するには

  1. [それでも問題が解決しない場合] ページで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスで [上書き値] を選択し、モニタに対して有効なリフレッシュ レートを入力します。
  3. [OK] をクリックします。

リフレッシュ レートの変更を取り消して、DirectDraw アプリケーションが独自のリフレッシュ レートを設定できるようにするには

  1. [それでも問題が解決しない場合] ページで、[上書き] をクリックします。
  2. [DirectDraw リフレッシュ レートの上書き] ダイアログ ボックスで、[既定値] をクリックします。


情報を保存する

情報を保存するには

  1. Microsoft DirectX 診断ツールで収集した情報を保存するには、[情報をすべて保存] をクリックします。
  2. すべてのページの情報は、選択した名前で、選択した場所に 1 ファイルで保存されます。XML ファイルとして保存するには、[ファイルの種類] で [XML ファイル (*.xml)] をクリックします。

* 注

  • コマンド プロンプトで次のように入力して情報を保存することもできます。

    dxdiag [/x <出力ファイル>] [/t <出力ファイル>]

    このコマンドで、/x は XML ファイルへのデータの送信、/t はテキスト ファイルへのデータの送信、および <出力ファイル> はファイルの名前と場所の指定をそれぞれ表します。


WHQL デジタル署名を確認する

使用しているドライバが Microsoft Windows Hardware Quality Lab (WHQL) によってデジタル署名済みであることが確認されると、DirectX 診断ツールはインターネットに接続して新しい WHQL 証明書をダウンロードしようとします。この処理中に、システム情報が流出することはありません。このツールを初めて実行するときは、インターネットへの接続の許可を求めるメッセージが表示されます。このメッセージは 1 度だけ表示されます。設定を変更するには、[システム] ページで [WHQL デジタル署名を確認する] をオンまたはオフにします。

コマンド プロンプトで次のように入力して設定を変更することもできます。

dxdiag [/whql:on] [/whql:off]

このコマンドで、/whql:on は DirectX 診断ツールによる WHQL デジタル署名の確認を許可し、/whql:off は許可しないことをそれぞれ表します。