rün Desteği Hizmetleri Nelerdir?

FrontPage Server Extensions Nelerdir?

FrontPage Server Extensions, 'i yöneten, oluşturan ve görüntüleyenler için çeşitli yararlı yordamlar gerçekleştiren üç programdan oluşur. Sunucu uzantıları olmadan bu görevlerin bazıları hiç yapılamaz veya bu kadar kolayca gerçekleştirilemez.

— Microsoft Windows NT Server, Digital UNIX ve SunOS — gibi çeşitli ortamlar arasında Web sunucusu uyumluluğu sağlayan, en çok kullanılan tüm bu işletim sistemlerine sunucu uzantılarını kolayca yükleyebilirsiniz. Sunucu uzantıları ayrıca Microsoft Internet Information Services (IIS), Netscape ve WebSite gibi en sık kullanılan Web sunucularını ve ayrıca Stronghold ve NCSA gibi ücretsiz ve paylaşılan Web sunucularını da destekler.

FrontPage Server Extensions doğrudan yönetilmez. Onun yerine, yönetimsel işlevlere sahip çeşitli araçlardan biriyle yönetilir. Bu araçlardan biri FrontPage MMC Snap-in'dir.

FrontPage Server Extensions hakkında daha fazla bilgi için, http://www.microsoft.com/frontpage/wpp/serk adresindeki FrontPage Server Extensions Resource Kit'e bakın. FrontPage Server Extensions bilgisayarınızda yüklüyse, varsayılan olarak C:\ProgramFiles\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm konumunda bulunan FrontPage Server Extensions Resource Kit'e de erişebilirsiniz. \nnnn klasörü, FrontPage Server Extensions'ın yüklü olduğu dile bağlı olan sayısal bir addır. Örneğin, İngilizce )ABD) yüklemesinde bu yol C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1033\default.htm olur.


FrontPage Server Extensions Kullanmanın Yararları

FrontPage Server Extensions, Web oluşturucularının Web sitelerine karmaşık işlevsellikler eklemelerini kolaylaştırır ve Web yöneticilerinin bu işlevsellikleri desteklemelerine yardımcı olur. Sunucu uzantıları şunları sağlar:

  • Web oluşturucularına bir oluşturmalarında ve korumalarında yardımcı olur, Web sitesini doğrudan sunucu bilgisayarı üzerinde düzenlemelerine izin verir (böylece yükleme süresinden kazanç sağlanır) ve programlama yapmaksızın kendi Web sitelerine kolayca işlevler eklemelerini sağlar.
  • Ziyaret sayaçlarını, tam metin aramalarını, elektronik posta formu işlemeyi ve bir Web oluşturucusunun FrontPage kullanarak bir Web sitesine ekleyebileceği diğer işlevleri destekler. Tüm işlevlerin çalışmasını sağlayan ayrı bir uyumlu program yüklemenize, satın almanıza veya kurmanıza gerek yoktur.
  • Windows NT ve UNIX gibi en sık kullanılan sunucu ortamlarında ve Microsoft Internet Information Services (IIS), WebSite ve Netscape gibi çok çeşitli Web sunucularında çalışabilir.
  • Bir Web sitesindeki sayfa silindiğinde, taşındığında veya yeniden adlandırıldığında, köprüler otomatik olarak güncelleştirilir (Sayfanın tümü yerine yalnızca sayfa adının Web'e aktarımı yeterlidir).
  • Microsoft Office, Visual SourceSafe ve Index Server ile birlikte çalışılabilirliği destekler.


FrontPage MMC Yönetim Eki Hakkında

FrontPage MMC yönetim eki FrontPage Server Extensions ve yönetmek için kullandığınız bir Windows programıdır. Bu programı , oluşturmak, web üzerinde sunucu uzantıları oluşturmak, klasörleri alt web'lere dönüştürmek veya tersi, 'deki köprüleri oluşturmak ve daha bir çok şey için kullanabilirsiniz.

FrontPage MMC yönetim eki, komutları, özellik sayfalarını ve FrontPage Server Extensions'ı yönetmek için gerekli olan diğer araçları MMC "kabuğuna" ekleyerek, Microsoft Management Console'u (MMC) "harekete geçirir". Bunun dışında, FrontPage MMC yönetim eki aracı içindeki diğer araçlara benzer ve onlar gibi çalışır.

Bir bilgisayarda Microsoft Internet Information Services (IIS) 4.0 veya daha sonraki bir sürümü yüklüyse, FrontPage MMC yönetim eki IIS Internet Service Manager yönetim ekini "harekete geçirir" ve böylece kendi işlevselliğini IIS yönetim ekine ekler. IIS 4.0 veya bunun sonraki sürümlerinin dışında başka bir Web sunucusu yüklüyse, FrontPage MMC yönetim eki kendi işlevselliğini doğrudan uçbirime ekler ve buna Server Extensions Administrator denir. Bir 'ni yönetmek için gerekli tüm araçlar tek bir konumda toplanmıştır.

FrontPage MMC yönetim eki, FrontPage'in önceki sürümlerinde yer alan Fpsrvwin adlı yönetim programının yerini almıştır ve bundan daha gelişmiş bir yardımcı programdır. Fpsrvadm ve Fpremadm yardımcı programlarını ve diğer bazı ek araçları kullanarak gerçekleştirdiğiniz yönetimle ilgili görevlerin çoğunu FrontPage MMC yönetim ekini kullanarak gerçekleştirebilirsiniz.

FrontPage Server Extensions'ı yönetmek için Fpsrvadm ve Fpremadm yardımcı programlarının nasıl kullanılacağı hakkında daha fazla bilgiyi, http://www.microsoft.com/frontpage/wpp/serk adresindeki FrontPage Server Extensions Resource Kit'te bulabilirsiniz. Bilgisayarınızda FrontPage Server Extensions yüklüyse, varsayılan olarak C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm yolunda yüklü olan FrontPage Server Extensions Resource Kit'e de erişebilirsiniz. \nnnn klasörü FrontPage Server Extensions'ı yüklediğiniz dile bağlı sayısal bir addır. Örneğin, İngilizce (ABD) sürümü yüklendiğinde bu yol C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1033\default.htm olur.


FrontPage MMC Yönetim Eki FPsrvwin.exe Yardımcı Programının Yerini Alır: Farklılıkları Keşfedin

FrontPage Server Extensions'ın daha önceki sürümlerini kullandıysanız, yönetim için Fpsrvwin yardımcı programını kullanmış olabilirsiniz. Fpsrvwin yardımcı programı, Web sunucusunda sunucu uzantılarını yükleme, denetleme, düzeltme ve kaldırma gibi yönetimsel görevleri gerçekleştirmek için kullanılırdı.

FrontPage MMC yönetim eki, Fpsrvwin yardımcı programının en sık kullanılan işlevlerini ve buna ek olarak aşağıdakileri sağlar:

  • Performans, e-posta seçenekleri, kodlama izinleri ve yazma günlükleri gibi web özelliklerini ayarlama.
  • oluşturma.
  • Yönetici ekleme.
  • Klasörleri alt web'lere dönüştürme veya tam tersi.
  • Alt web'leri silme.
  • FrontPage içinde bir açma (FrontPage web ile aynı bilgisayarda yüklüyse).
  • Varsayılan bir belirleme.
  • Yazma eylemlerinin günlüğünü tutma.
  • Köprüleri yeniden oluşturma.


FrontPage Server Extensions'ı Yönetmek için Kullanabileceğiniz Diğer Araçlar

FrontPage MMC yönetim eki, FrontPage Server Extensions'ı kolayca yönetebilmek için kullanabileceğiniz grafik arabirimli bir programdır. Frontpage'in önceki sürümünde yer alan grafik arabirimli bir yardımcı yönetim programı olan Fpsrvwin'in yerini almıştır ve önemli ek özellikleri de beraberinde getirmiştir. Bununla birlikte, FrontPage MMC yönetim eki yalnızca Windows işletim sistemlerinde çalışır ve sunucu uzantılarını 'dan yönetmek için bunu kullanamazsınız.

Ancak, FrontPage MMC yönetim eki, FrontPage Server Extensions'ı yönetmek için kullanılabilecek çeşitli araçlardan yalnızca biridir. Hemen hemen FrontPage MMC yönetim eki ile aynı işlevselliği sağlayan diğer araçlar, bu yönetim ekinin çalışamadığı ortamlarda çalışabilirler:

  • Fpsrvadm yardımcı programı hem Windows NT hem de çeşitli UNIX işletim sistemlerinde çalışabilen bir komut satırı programıdır. Bu yardımcı programı gerçekleştirmek için kullanabilirsiniz. Fpsrvadm FrontPage Server Extensions'ı yüklediğinizde yüklenir. Uzaktaki bir bilgisayardan sunucu uzantılarını yönetmek için Fpsrvadm programını kullanamazsınız.
  • Fpremadm komut satırı yardımcı programını FrontPage Server Extensions'ı uzaktaki bir bilgisayardan yönetmek için kullanabilirsiniz. Ancak, Fpremadm yalnızca Windows NT Workstation, Windows NT Server ve Windows 95/98 işletim sistemlerinde çalışır, Linux ve SunOS gibi UNIX işletim sistemlerinde çalışmaz. Fpremadm, FrontPage Server Extensions'ı yüklediğinizde yüklenir.
  • HTML Administration Forms, FrontPage Server Extensions'ı bir Web sunucusundan uzaktan yönetmek için kullanabileceğiniz HTML formlarıdır.

Bu yardımcı programlar hakkında daha fazla bilgi için, http://www.microsoft.com/frontpage/wpp/serk adresinden FrontPage Server Extensions Resource Kit'e bakın. Bilgisayarınızda FrontPage Server Extensions yüklü ise, varsayılan olarak C:\ProgramFiles\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm konumunda bulunan FrontPage Server Extensions Resource Kit'e de erişebilirsiniz. \nnnn klasörü, FrontPage Server Extensions'ın yüklü olduğu dile bağlı olan sayısal bir addır. Örneğin, İngilizce )ABD) yüklemesinde bu yol C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1033\default.htm olur.


FrontPage MMC Yönetim Ekini Kullanarak Gerçekleştirebileceğiniz Yönetme Görevleri

FrontPage MMC Yönetim Ekini Kullanarak Gerçekleştirebileceğiniz Yönetime Görevleri

Aşağıdaki görevleri gerçekleştirmek için FrontPage MMC yönetim ekini kullanabilirsiniz:

  • Bir Web sunucusuna FrontPage Server Extensions'ı yükleme.
  • Bir 'yu FrontPage Server Extensions ile .
  • Bir üstündeki FrontPage Server Extensions'ı denetleme ve düzeltme .
  • Web üstündeki FrontPage Server Extensions'ı güncelleştirme.
  • FrontPage Server Extensions'ı web'den kaldırma.
  • FrontPage Server Extensions ile geliştirdiğiniz bir 'i silme.
  • Bir alt web'i klasöre dönüştürme veya tam tersi.
  • Web üstündeki tüm köprüleri yeniden hesaplama.
  • Yönetici ekleme.
  • Web üstünde değişiklik yapmayı etkinleştirme veya devre dışı bırakma.
  • 'nı geliştirme.
  • Yazma işlemlerinin günlüğünü tutma.
  • Yazma için isteme.
  • Çalıştırılabilir veya programlar içerebilen klasörleri belirleme.
  • 'ni etkinleştirme.
  • E-posta seçeneklerini ayarlama.

Aşağıdaki görevleri FrontPage MMC yönetim ekini kullanarak yerine getiremezsiniz:

  • FrontPage Server Extensions'ı 'dan yönetme (bunun için Fpremadm yardımcı programını kullanın).
  • işlemi (bunun için Fpsrvadm yardımcı programını kullanın).


FrontPage Server Extensions'ı Yönetmek için Gerekli FrontPage MMC Yönetim Eki Bileşenleri Nerede Bulunur?

Gerek duyduğunuz görevi hangi FrontPage MMC yönetim eki menüsü, komutu, iletişim kutusu veya bileşeni gerçekleştirir ve bu bileşeni nerede bulabilirsiniz?

FrontPage Server Extensions'ı yönetmek için kullanabileceğini üç ana bileşen vardır:

  • Yeni bir oluşturmak, yeni bir yönetici eklemek vb. gibi içinde seçmiş olduğunuz öğeye bağlı olarak değişen, çeşitli komutları seçebildiğiniz Yeni menüsü.
  • FrontPage Server Extensions'ı denetlemek, düzeltmek, kaldırmak ve güncelleştirmek ve aynı zamanda diğer görevleri de gerçekleştirmek için gerekli komutları seçebileceğiniz Görev menüsü. Uçbirim ağacından seçmiş olduğunuz öğe Görev alt menüsü içinde görüntülenecek komutları belirler.
  • Server Extensions sekmesi, e-posta seçenekleri ve güvenlik ayarları gibi, çeşitli FrontPage Server Extensions ayarlarını değiştirmenize olanak verir.

Aşağıdaki tabloda, FrontPage MMC yönetim ekini kullanarak gerçekleştirebileceğiniz yönetimsel görevler, her görev için kullanacağınız araç ve bu aracın konumu listelenmiştir. Parantez içindeki yerimler yalnızca Web sunucusu Microsoft Internet Information Services (IIS) 4.0 veya sonraki sürümlerinden birisi ise görüntülenir.

Görev | Araç ve konum
Bir sanal sunucuyu sunucu uzantıları ile geliştirme (IIS 4.0 veya sonraki sürümü) | Kısayol menüsü > Görev > Server Extensions'ı Yapılandır
Bir sanal sunucuyu sunucu uzantıları ile geliştirme (IIS olmayan web sunucusu ve IIS 3.0 için) | Kısayol menüsü > Yeni > Web
Alt web oluşturma | Kısayol menüsü > Yeni > (Server Extensions) Web
Yönetici ekleme | Kısayol menüsü > Yeni > (Server Extensions Web) Yönetici
Web veya alt web üstündeki sunucu uzantılarını denetleme ve düzeltme | Kısayol menüsü > Görev > sunucu Uzantılarını Denetle
Web üstündeki sunucu uzantılarını güncelleştirme | Kısayol menüsü > Görev > Server Extensions'ı Yükselt
Sunucu uzantılarını kök web'deb veya onun alt web'lerinden kaldırma | Kısayol menüsü > Görev > Server Extensions'ı Kaldır
Web üstündeki tüm köprüleri yeniden oluşturma | Kısayol menüsü > Görev > Web'i Yeniden Oluştur
Alt web silme | Kısayol menüsü > Görev > Server Extensions Web'ini Sil
Klaösrü alt web'e dönüştürme | Kısayol menüsü > Görev > Klasörü Server Extensions Web'ine Dönüştür
Alt web'i klasöre dönüştürme | Kısayol menüsü > Görev > Server Extensions Web'ini Klasöre Dönüştür
Yazıma izin verme veya devre dışı bırakma | Kısayol menüsü > Özellikler > Server Extensions sekmesi> Yazıma izin ver onay kutusu
Kaynak denetimini etkinleştirme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Sürüm denetimi kutusu
Web başarımını iyileştirme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Başarım kutusu
Varsayılan olarak üretilecek kodlama dilini belirleme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > İstemci kodlaması kutusu
E-posta seçeneklerini belirleme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Ayarlar
Ana web'in güvenlik ayarlarını alt web'e uygulama | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Güvenlik ayarlarını devral onay kutusu
Yazım eylemlerini raporlama | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Yazım eylemlerini raporla onay kutusu
İzinleri el ile belirleme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > İzinleri el ile yönet onay kutusu
Yazım için Secure Sockets Layer (SSL) isteme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Yazım için SSL gerekli onay kutusu
Bir klasörün çalıştırılabilir kodlar veya programlar içerip içermeyeceğini belirleme | Kısayol menüsü > Özellikler > Server Extensions sekmesi > Web oluşturucularına çalıştırılabilir dosyalar yükleme izni ver onay kutusu


FrontPage içindeki İzin Modeli

Bir Web sunucusu üstündeki 'e olan erişimi yönetmenize yardım etmek için, FrontPage size basit bir rol tabanlı modeli ve izinleri ayarlamanız için yararlı yönetimsel araçlar sağlar. Rol tabanlı model, kullanıcının rolüne bağlı olarak (bir kullanıcı bir kişi, grup veya bilgisayar olabilir) basit bir şekilde kullanıcıya verdiğiniz izinleri gösterir.

Web sunucusu üstündeki her bir için, aşağıdaki üç rolde kullanıcı izinlerini belirleyebilirsiniz:

  • ziyaretçileri, bir FrontPage uzantılı web bir Web sunucusu üstünde yayınlandıktan sonra, bunun görüntülenmesi ve kullanılması için tarama iznini verdiğiniz kullanıcılardır.
  • Web oluşturucuları, bir FrontPage uzantılı web'in açılıp içeriğinin değiştirilebilmesi için, yazma iznini verdiğiniz kullanıcılardır.
  • Yöneticiler, FrontPage Server Extensions'ı eklemek, güncelleştirmek veya FrontPage uzantılı bir web'den kaldırmak, oluşturmak ve silmek, yazım işlemlerinin günlüğünü tutmak, diğer kullanıcıların izinlerini belirlemek ve diğer yönetimle ilgili görevleri gerçekleştirmek gibi işleri yerine getirebilmesi için yönetim iznini verdiğiniz kullanıcılardır.

FrontPage uzantılı web izinleri sıradüzensel yapıdadır: Yönetim izinleri olan bir kullanıcı yazma ve tarama izinlerine de sahiptir. Yazım izni olan bir kullanıcının tarama izni de vardır.

Varsayılan olarak, bir web için belirlediğiniz izinler, bunun altındaki tüm alt web'ler için de geçerlidir. Bununla birlikte, bir alt web'in ana web'den devraldığı izinlerini geçersiz kılmak için, alt web'e özel izinler verebilirsiniz. Bu şekilde her kullanıcı veya grup için her alt web'e farklı düzeyde erişimler verebilirsiniz. Örneğin, aynı kullanıcıya bir alt web için yazma izni verirken, başka bir alt web için tarama izni verebilirsiniz.

Hangi kullanıcılar için izin belirlenebilir? Bunun yanıtı çalışmakta olduğunuz Web sunucusuna bağlıdır. Microsoft Internet Information Services (IIS), kullanıcı hesaplarını Windows NT hesap listesinden alır. Yalnızca bu listedeki kullanıcıların izinlerini belirleyebilirsiniz; yeni kullanıcı hesapları oluşturamazsınız. Başka Web sunucularında, kullanıcı listesi Web sunucusu tarafından saklanır ve yeni kullanıcı hesapları oluşturabilirsiniz.

Fpsrvadm ve Araçlar menüsündeki İzinler komutu gibi FrontPage Server Extensions yardımcı programlarını ve komutlarını kullanarak FrontPage içindeki bir web'in izinlerini belirleyebilirsiniz.


FrontPage MMC Yönetim Eki Farklı Web Sunucularıyla Nasıl Çalışır?

Hem Microsoft Internet Information Services (IIS) hem de WebSite veya Netscape gibi diğer Web sunucuları ile çalıştıysanız, FrontPage MMC yönetim ekinin IIS 4.0 veya sonraki sürümleriye olan çalışmasının, IIS 3.0 dahil diğer farklı Web sunucularıyla birlikte olan çalışmasından daha farklı olduğunu anlamışsınızdır.

IIS 4.0 veya sonraki sürümleri, Microsoft Management Console'u (MMC) harekete geçiren bir yönetim ekine sahiptir. FrontPage MMC yönetim eki, IIS 4.0 veya sonraki sürümünün yönetim ekini harekete geçirecek şekilde oluşturulmuştur. Bu nedenle bilgisayarda IIS 4.0 veya sonraki sürümü yüklüyse, FrontPage yönetim eki işlevselliği IIS ile tam olarak birleştirilir.

IIS MMC yönetim eki ile daha önceden çalıştıysanız, Eylem ve kısayol menülerine bazı komutların eklendiğini ve Özellikler bölümüne bir Server Extensions özellik sayfasının eklendiğini fark etmiş olabilirsiniz. Bu yeni işlevselliği FrontPage MMC yönetim eki ekler. Çakışan işlevsellikler varsa, FrontPage yönetim eki komutu değil, IIS komutu görüntülenir. IIS içinde, tüm IIS 'lerini, 'leri ve diğer Web sitelerini listeler.

FrontPage MMC yönetim eki, IIS 4.0 veya sonraki sürümleri dışındaki bir Web sunucusu ile yüklenmişse, yönetim ekinin işlevselliği Web sunucusununkiyle birleştirilmez; gerçekte Web sunucusunda kendi işlevselliğini uçbirime ekleyecek bir MMC yönetim eki olmayabilir. Bu durumda, uçbirim ağacı yalnıca FrontPage uzantılı web'leri görüntüler, bilgisayarda yüklü olan tüm Web siteleri listelenmez.

Bazen, hem IIS 4.0 veya sonraki sürümlerinden biri hem de diğer Web sunucuları aynı bilgisayarda yüklü olabilir. Bu durumda, her Web sunucusu için, Web sunucunun altında listelenen Web siteleriyle birlikte bir üst düzey öğesi görürsünüz. IIS 4.0 veya sonraki sürümlü Web sunucu üstünde bulunan bir 'i seçip kısayol menüsünü görüntülediğinizde, FrontPage yönetim eki komutları ile birlikte IIS yönetim eki komutlarını birlikte görürsünüz. IIS Web sunucusu dışındaki bir web sunucuda bulunan bir web'i seçip kısayol menüsünü görüntülediğinizde, yalnızca FrontPage yönetim eki tarafından sağlanan FrontPage Server Extensions'ın yönetimle ilgili komutlar gelir.


Sanal Sunucuyu FrontPage Server Extensions ile Geliştirme

Bir oluşturduktan sonra, bunu FrontPage Server Extensions ile sanal sunucuyu bir 'i haline getirebilirsiniz. Bir sanal sunucuyu geliştirmeden önce, sunucu uzantılarının ana makinede yüklü olması gerekir.

Sanal sunucuyu FrontPage Server Extensions ile geliştirmek için

  1. içinde, geliştirmek istediğiniz sanal sunucuyu sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra Server Extensions'ı Yapılandır'ı seçin.

Web sunucusu IIS 4.0 veya sonraki sürümlerinden biri değilse, kısayol menüsünden Yeni'yi tıklattıktan sonra Web'i tıklatın.

  3. Server Extensions Yapılandırma Sihirbazı içindeki adımları izleyin.

Not

Bir sanal sunucunun altındaki 'leri oluşturabilmeniz için önce sanal sunucuyu geliştirerek kök web haline getirmelisiniz.


Alt Web Oluşturma

Bir alt web 'in bir klasörü veya tam bir 'in başka bir alt web'idir. Alt web, bütün bir içeriğinin mantıksal bir bölümüdür.

Bir alt web, ayrı ayrı yönetme, yazma ve tarama belirtmenizi, başarımı artırmak için web içeriğini mantıksal alt bölümlere ayırmanızı, her alt web'in sayfalarına farklı farklı görünümler uygulamanızı ve köprüleri kolayca yönetmenizi sağlar.

Bir alt web'i yalnızca bir kök web'in altında veya kök web altındaki bir alt web'in veya klasörün altında oluşturabilirsiniz. Bir alt web oluşturduğunuzda, aynı zamanda bunu FrontPage Server Extensitons ile olursunuz. Sistem alt web için otomatik olarak bir klasör oluşturur.

Alt web oluşturmak ve bunu FrontPage Server Extensions ile geliştirmek için

  1. içinde, altında alt web oluşturmak istediğiniz 'i (veya klasörü) sağ tıklatın.
  2. Kısayol menüsünden Yeni'yi tıklattıktan sonra, Server Extensions Web komutunu seçin.

Web IIS 4.0 veya sonraki sürümlerinden biri değilse, kısayol menüsünden Yeni'yi tıklattıktan sonra Web'i seçin.

  3. Yeni Alt Web Sihizbazı içindeki adımları izleyin.


Yönetici Ekleme

Parolanızı unutursanız veya web'i başka birinin yönetebilmesi için, yönetici ekleyebilirsiniz.

Yönetici eklemek için

  1. içinde, içine yönetici eklemek istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Yeni'yi tıklattıktan sonra Server Extensions Yöneticisi'ni tıklatın.

Web sunucusu IIS 4.0 veya sonraki sürümlerinden biri değilse, kısayol menüsünden Yeni'yi tıklattıktan sonra Yönetici komutunu tıklatın.

  3. Kullanıcı Adı kutusuna web'e yönetici olarak eklemek istediğiniz bir Windows NT hesap adını girin.

Web sunucusu IIS 4.0 veya sonraki sürümlerinden biri değilse, Kullanıcı Adı kutusuna bir ad girin ve Parola ve Parolayı onayla kutularına aynı parolayı yazın.


FrontPage Server Extensions'ı Kök Web'den ve Onun Alt Web'lerinden Kaldırma

Herhangi bir zamanda, siz veya bir yazarı, FrontPage Server Extensions'ın artık web için gerekli olmadığına karar verebilir. Bu durumda, sunucu uzantılarını 'den ve onun tüm 'inden silebilirsiniz.

Sunucu uzantılarını kaldırdığınızda, ziyaret sayacı ve e-posta işleyicisi gibi, FrontPage Server Extensions tarafından desteklenen web içindeki işlevler artık çalışmayacaktır. Web içeriği olduğu gibi kalır. Yalnızca sunucu uzantıları silinir.

Sunucu uzantılarını kök web'den ve onun alt web'lerinden kaldırmak için

  1. içinde, içindeki sunucu uzantılarını kaldırmak istediğiniz kök web'i sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra, Server Extensions'ı Kaldır'ı seçin.

Varsayılan olarak, web yapısı, temaları vb. hakkında bilgiler içeren dosyalar silinmez, bu nedenle daha sonraki bir tarihte web'i yeniden geliştirmeye karar verirseniz, aynen eskiden olduğu haliyle web'i yeniden oluşturabilirsiniz. Bu web üstünde artık hiç bir zaman FrontPage Sever Extensions'a gerek olmayacaksa, Uzantıları yeniden yüklemek için gerekli dosyaları silme onay kutusunu temizleyin.

  3. Tamam'ı tıklatın.


Web veya Alt Web Üstünde FrontPage Server Extensions'ı Denetleme ve Düzeltme

Bazen bir oluşturucusu web içeriğini yükleyemeyebilir, web'i doğrudan sunucu bilgisayarında değiştiremeyebilir veya FrontPage Server Extensions tarafından desteklenen diğer işlevleri gerçekleştiremeyebilir. Sorunun nedeni, yanlışlıkla silinmiş veya adı değiştirilmiş önemli dosyalardan bozulmuş 'ne kadar çok çeşitli olabilir. Web oluşturma sırasında çıkan bir çok sorunu çözmek için Server Extensions'ı Denetle komutunu kullanabilirsiniz. Bu komut şunları yapar:

  • Okuma 'lerini denetler.
  • Service.cnf ve Service.lck dosyalarının okunur/yazılır olup olmadığını denetler.
  • Postinfo.html ve _vti_inf.htm dosyalarını güncelleştirir.
  • _vti_pvt, _vti_log ve _vti_bin'in yüklü olup olmadığını ve _vti_bin'in çalışabilir olup olmadığını denetler.
  • kök veya metabase ayarlarının doğru olup olmadığını ve güncel olup olmadığını belirler.
  • IUSR anonim hesabının yazma hakkında sahip olup olmadığını denetler.
  • Herhangi bir Web güvenliği sağlamanın mümkün olmadığı bir FAT dosya sistemi üzerinde çalışıyorsanız sizi uyarır (IIS çalışıyorsa).

FrontPage Server Extensions'ı Denetlemek ve Düzeltmek için

  1. içinden, içindeki sunucu gelişimlerini denetlemek ve düzeltmek istediğiniz web'i sağ tıklatın.

Bu web ve altındaki tüm denetlenip düzeltilecektir.

  2. Kısayol menüsünden Görev'i tıklattıktan sonra Server Extensions'ı Denetle'yi tıklatın.

Web Denetimi penceresi denetlenen her web'in durum raporunu görüntüler.


Web Üstünde FrontPage Server Extensions'ı Yükseltme

Zaman geçtikçe FrontPage Server Extensions'ın yeni sürümleri çıkacaktır. Yeni sürümler web oluşturucuları ve yöneticiler için gelişmiş destek veya varolan destek özellikleri üzerinde düzeltmeler ve ziyaret sayacı gibi FrontPage içindeki varolan fonksiyonlara destek sağlayacaktır.

Tüm bu yeni desteklerden yararlanmak için, öncelikle sunucu bilgisayara sunucu uzantılarının en son sürümünü yüklemeli ve sonra 'i bu sürüme yükseltmelisiniz. Yalnızca üstündeki sunucu uzantılarını güncelleştirebilirsiniz, ancak bir kök web'i güncelleştirme onun altındaki tüm 'leri de güncelleştirecektir.

FrontPage Server Extensions'ı En Son Sürümüne Yükseltme

  1. içinde, sunucu uzantılarını güncelleştirmek istediğiniz kök web'i sağ tıklatın.
  2. Kısayol menüsünden Görev'i sağ tıklattıktan sonra, Uzantıları Yükselt'i tıklatın.

Notlar

Uzantıları Yükselt komutu yalnızca sunucu uzantılatının kullanılabilir daha yeni bir sürümü varsa görüntülenir.

Bir bilgisayardaki tüm kök web için FrontPage Server Extensions'ı güncelleştirmek için, uçbirim ağacı içinden Bilgisayarım'ı sağ tıklatın.


FrontPage Uzantılı Web'i Silme

Bir güncelliğini yitirmiş, ender kullanılır hale gelmiş olmasından ya da herhangi bir nedenden dolayı artık gerekli olmayabilir. Örneğin, bu bir kuruluşun intranet'i üzerinde bilgileri yayınlanmış ve bitmiş veya yeniden düzenlenmiş bir proje olabilir veya bir abonenin artık devam etmeyen bir Internet Hizmet Sağlayıcısı'na gönderdiği de olabilir. Bu ve diğer durumlarda alt web'i silmeniz gerekebilir.

Bir alt web'i sildiğinizde, onun tüm içeriğini, dosyalarını, klasörlerini, altındaki alt web'leri ve tabiki onun FrontPage Server Extensions'ını da silmiş olursunuz. Silinen bir alt web'i geri alamazsınız.

Alt web'i silmek için

  1. içinde, silmek istediğiniz alt web'i sağ tıklatın.
  2. Kısayol menüsünden Görevler'i tıklattıktan sonra, Sunucu Uzantılı Web'i Sil komutunu seçin.
  3. Tamam'ı tıklatın.

Not

Silmekte olduğunuz alt web'in altında silme iznine sahip olmadığınız başka bir alt web varsa, bu alt web silinmez.


Web içindeki Klasörü Alt Web'e Dönüştürme

Bir klasörün kendi 'ni oluşturabilecek kadar yeterli (web sayfaları ve grafikleri gibi) web içeriği taşıdığını düşünüyorsanız, bu klasörü kolayca 'e dönüştürebilirsiniz. Bu yöntem gerçekte oluşturmanın bir yoludur.

Klasörü alt web'e dönüştürmek için

  1. içinde, FrontPage uzantılı alt web'e dönüştürmek istediğiniz klasörü sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra Server Extensions'ı Yapılandır'ı tıklatın.

Web sunucusu IIS 4.0 veya sonraki sürümlerinden biri değilse, kısayol menüsünden Görevler 'i tıklattıktan sonra Klasörü Web'e Dönüştür komutunu seçin.


Alt Web'i Klasöre Dönüştürme

Bazen bir 'in artık gerekli olmadığına karar verebilir, ancak içeriğini korumaya devam etmek isteyebilirsiniz. Bu durumda 'i kendi 'i altındaki bir klasöre dönüştürebilirsiniz. Alt web'i bir klasöre dönüştürdüğünüzde, FrontPage Server Extensions alt web'den kaldırılır, alt web, ana web'in normal bir klasörüne dönüştürülür ve dönüştürülen alt web'in içindeki diğer alt web'ler ilgli ana web'lere bağlanır.

Dönüştürülen alt web'in altındaki alt web'ler farklı tema ve ayarları alabilir. Dönüştürülen alt web'in altında başka alt web'ler yoksa, dönüştürülen alt web'in içindeki sayfalar bazı web özelliklerini kaybedebilir.

Alt web'i klasöre dönüştürmek için

  1. içinde, klasöre dönüştürmek istediğiniz FrontPage uzantılı alt web'i sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra, Sunucu Uzantılı Web'i Klasöre Dönüştür komutunu seçin.

Web sunucusu IIS 4.0 veya sonraki sürümlerinden biri değilse, kısayol menüsünden Görevler'i tıklattıktan sonra Web'i Klasöre Dönüştür'ü seçin.


FrontPage Kullanarak Web Açma

Bir yönetici olarak, veya içindeki temayı, metni, grafikleri veya diğer içerikleri zaman zaman değiştirmeniz gerekebilir. FrontPage, veya alt web ile aynı sunucu bilgisayarında yüklüyse, web'i doğrudan içinden açıp FrontPage içinde içeriğini değiştirebilir veya diğer eylemleri gerçekleştirebilirsiniz. Aksi durumda bir web'i uçbirim içinden açamazsınız.

FrontPage kullanarak web açmak için

  1. içinden FrontPage içinde açmak istediğiniz web'i sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra FrontPage ile Aç komutunu seçin.
  3. FrontPage içinde web içeriğini değiştirin ve yaptığınız değişiklikleri kaydedin.

Not

Sunucu bilgisayarında FrontPage yüklü değilse, FrontPage ile Aç komutu görüntülenmez.


Web içindeki Tüm Köprüleri Yeniden Hesaplama

Bir 'in yapısında meydana gelen herhangi bir değişiklik, web'in farklı bölümleri arasındaki bağlantıları değiştirebilir. Örneğin, bir sayfa eklendiğinde, yeniden adlandırıldığında veya bir klasörden diğerine taşındığında, yeniden hesaplamak için, diğer sayfalardan bu sayfaya olan köprülerin güncelleştirilmesi veya yeniden oluşturulması gerekir. FrontPage köprüleri otomatik olarak yeniden hesaplar. Ancak, yeniden hesaplama için bir "zorlama" getirmek isterseniz, bunu da yapabilirsiniz.

Web'deki tüm köprüleri yeniden hesaplamak için

  1. içinde, köprülerini yeniden hesaplamak istediğiniz web'i sağ tıklatın.
  2. Kısayol menüsünden Görev'i tıklattıktan sonra Web'i Yeniden Hesapla sekmesini tıklatın.


Varsayılan Olarak Üretilecek Kodlama Dilini Belirleme

Bazı belirli yanıt eylemlerine yanıt olarak, FrontPage Server Extensions istemci türü kodlar üretir. Varsayılan olarak, sunucu uzantıları bu kodları JavaScript 'nde üretir. JavaScript, Netscape Navigator ve Microsoft Internet Explorer gibi en çok kullanılan Web tarayıcıları tarafından tanınır. Kodlarınızı Netscape Navigator tarafından tanınan VBScript dilinde üretmeyi de seçebilirsiniz; bununla birlikte örneğin Internet Explorer ile özel olarak çalışan bir kuruluşun intranet'ini yönetiyorsanız veya kuruluşun teknik personelinin kodlama dili seçimi VBScript ise, VBScript sizin de seçiminiz olabilir.

Varsayılan olarak üretilecek kodlama dilini belirlemek için

  1. içinde, varsayılan olarak üretilecek kodlama dilini belirlemek istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. İstemci kodlaması kutusundan bir kodlama dili seçin.


İzinleri El İle Belirleme

FrontPage kullanarak her üstünde yöneticiler, web oluşturucuları ve ziyaretçileri için belirleyebileceğiniz ve yönetebileceğiniz rol tabanlı her zaman gereksiniminizi karşılamayabilir. Örneğin, dosyalar ve klasörler üzerindeki izinleri belirlemek isteyebilirsiniz. Özel izinleri doğrudan üstündeki izinleri ayarlayarak el ile belirleyebilirsiniz. Özel izinleri belirleme hakkında daha fazla bilgi için, http://www.microsoft.com/frontpage/wpp/serk adresinden FrontPage Server Extensions Resource Kit'e bakın.

İzinleri yönetmek için FrontPage kullanıyorsanız, ACL'leri sıfırlayarak belirlediğiniz özel izinler değişecektir. Özel izinlerin sizin tarafınızdan veya başka biri tarafından değiştirilmediğinden emin olmak için, FrontPage içindeki zinleri devre dışı bırakabilirsiniz.

İzinleri el ile belirlemek için

  1. içinde, izinlerini el ile belirlemek istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. İzinleri el ile yönet onay kutusunun seçili olduğundan emin olun.


Web'de Yazmayı Etkinleştirme veya Devre Dışı Bırakma

Kök Web veya Onun Alt Web'inde Üstünde Yazmayı Etkinleştirme veya Devre Dışı Bırakma

Yazılmakta olan veya sık sık güncelleştirilmesi gereken web yazarları tarafından erişilebilmelidir. Ancak bazı web'ler tamamlandıktan sonra, değişmemesi gereken bazı önemli veya kalıcı bilgiler içerebilir veya bir web'i başka bir konuma taşırken veya üzerinde değişiklikler yaparken, başkalarının we üzerinde değişiklik yapmasına engel olmak isteyebilirsiniz. Bir web içindeki bilgileri korumak için, web üstünde yazmayı devre dışı bırakarak, kullanıcıların web içeriğini değiştirmelerine engel olabilirsiniz.

Kök web veya onun alt web'de yazmayı etkinleştirmek veya devre dışı bırakmak için

  1. üstünde yazmayı etkinleştirmek veya devre dışı bırakmak istediğiniz kök web'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra, Server Extensions sekmesini tıklatın.
  3. Değişikliğe izin vermek için, Yazmaya izin ver onay kutusunun seçili olduğundan emin olun.

Yazmaya engel olmak için, Yazmaya izin ver onay kutusunu temizleyin.


Bir Klasörün Çalıştırılabilir Kodlar veya Programlar İÇerip İçeremeyeceğini Belirleme

Bir web oluşturucusu, içine bir veya etkin sunucu sayfası katmak isterse, bu web oluşturucusunun kasıtlı olmaksızın Web sunucunuza kötü yazılmış bir program veya — daha da kötüsü — bir virüs yüklemediğinden nasıl emin olabilirsiniz? Virüs ve kötü yazılmış program risklerinden kaçınmak için, web oluşturucularının bir 'in parçası olan herhangi bir klasöre kod ve programlar yüklemelerine engel olabilirsiniz.

Klasörlerin çalıştırılabilir kodlar veya programlar içerip içermeyeceğini belirlemek için

  1. içinde, çalıştırılabilir klasörler oluşturmak istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. Web oluşturucularına çalıştırılabilir dosyalar yükleme izni ver onay kutusunun seçili olduğundan emin olun.


Yazma Eylemlerini Raporlama

Bir 'in içeriğini değiştirme iznine sahip kullanıcılar, içerikteki metni, grafikleri, bağlantıları, yapıyı vb. değiştirebilirler. Bir web üstünde kimlerin değişiklik yaptığını ve hangi dosyaların değiştiğini izlemek için, bir ve onun tüm 'leri içindeki yazma eylemlerinin günlüğünü tutabilirsiniz. Böylece sistem bir web oluşturucusunun gerçekleştirdiği eylemin zamanını, oluşturucunun adını, web adını, uzaktaki ana makinenin adını ve her işlem verisini kaydeder ve bu bilgileri kök web içinde bulunan _vti_log/Author.log adlı günlük dosyasında saklar. Bir güvenlik çiğnemesi olduğunda, bu günlük dosyasını inceleyerek web üstünde gerçekleştirilen yazma eylemini belirleyebilirsiniz.

Yazma eylemlerinin günlüğünü tutmak için

  1. içinde, üztündeki yazma eylemlerinin günlüğünü tutmak istediğiniz kök web'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra, Server Extensions sekmesini tıklatın.
  3. Yazma eylemlerinin günlüğünü tut onay kutusunun seçili olduğundan emin olun.


Yazma için Güvenli Yuvalar Tabakası (SSL) Gereksinimi

Web bilgileri en fazla bir 'den diğerine "gönderilirken" — tehlikeye açıktır. Bu bilgi gidiş hattını, FrontPage, Web tarayıcıları ve Web sunucuları için standart olan 'nı kullanarak kapatabilirsiniz.

Yazma için SSL gerektirmek için

  1. içinde, SSL kullanımını gerekli kılmak istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. Yazma için SSL gerektir onay kutusunun seçili olduğundan emin olun.

Not

Yazım için SSL isterseniz, web üstünde çalışan web oluşturucuları FrontPage içinden seçebilecekleri SSL kullanmaları gerektiğini söyleyen bir ileti alacaklardır.


Web Başarımını İyileştirme

Bir 'in FrontPage istemcisinden gelen isteklere yanıt hızı daha çok web'in boyutuna özellikle de içerdiği sayfaların ve diğer dosyaların sayısına bağlıdır. Bir web'in yanıt süresini onun üstünde "ince ayar" yaparak artırabilirsiniz. Bir web üstünde ince ayarlar yaptığınızda, FrontPage Server Extensions, web sayfalarının adedine bağlı olarak web için belirli miktarda bir ön bellek ayırır. Örneğin, 100 sayfadan daha az veya 1.000 sayfadan daha çok olacak şekilde web üstünde ince ayarlar yapabilirsiniz. Ayrıca ön bellek boyutunu ve tam metin arama dizin boyutunu da özelleştirebilirsiniz.

Web başarımının ince ayarlarını yapmak için

  1. içinde, başarımını artırmak istediğiniz web'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. Performans kutusundan, üzerinde ince ayarlar yapmakta olduğunuz web içindeki gerçek sayfa sayısına en yakın sayfa aralığını seçin.
  4. Web üstünde özel ince ayarlar yapmak için, Özel ayarları kullan'ı tıklatın ve istediğiniz ön bellek ve tam metin arama dizin boyutlarını girin.


Kaynak Denetimini Etkinleştirme

Web içeriğini birden fazla kişi değiştiriyorsa, belirli bir web belgesini kimin değiştirdiğini görmek, değişiklikleri tanımlamak, birinin yaptığı değişikliklerin bir başka kişininkileri silmesine engel olmak ve gerektiğinde bir belgenin önceki sürümüne dönmek için kaynak denetimini kullanabilirsiniz. Belirli bir için kaynak denetimini sağlamak amacıyla, yerleşik kaynak denetimini seçebilir veya Microsoft Visual SourceSafe gibi FrontPage'i destekleyen harici bir kaynak denetim programını kullanabilirsiniz.

FrontPage Server Extensions içinde yerleşik bir kaynak denetimi vardır. Bunu bir web'i düzenlemek üzere almak ve teslim etmek için, web'in en son kaydedilen sürümüne geri dönmek için kullanabilirsiniz. Visual SourceSafe ve diğer kaynak denetimi programlarının ayrı olarak satın alınıp bilgisayara yüklenmesi gerekir. Genelde harici kaynak denetimi programları yerleşik kaynak denetimi programlarının yaptıkları her şeyi yapabilirler ve buna ek olarak değişiklikleri izleyerek bir web'in bir kaç önceki sürümlerinden herhangi birine dönüş yaptırabilirler.

Kaynak denetimini etkinleştirmek için

  1. içinde, kaynak denetimini etkinleştirmek istediğiniz web'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. Sürüm denetimi kutusundan Hariciyi kullan veya Yerleşiği kullan seçeneklerinden birini seçin.

Hariciyi kullan'ı seçtiyseniz Visual SourceSafe'in veya kullanmak istediğiniz başka bir projenin adını girin.

Not

FrontPage ile Visual SourceSafe'i kullanabilmeniz için, Visual SourceSafe içindeki Enable SourceSafe integration seçeneğini etkinleştirmeniz gerekir. Bu, Visual SourceSafe'i yüklerken seçmeniz gereken özel bir yükleme seçeneğidir.


E-Posta Seçeneklerini Belirleme

Bazı özellikler web'i tarayan site yöneticilerine e-posta göndermeyi gerektirebilir. E-posta işleyicisi bu özelliğe bir örnektir. E-posta göndermek amacıyla bu özellikleri etkinleştirmek için, Web sunucusunun posta adresini, bir ilgili kişi adresini, SNMP ana makinesini, posta kodlama türünü ve posta karakter kümesini belirlemeniz gerekir.

E-posta seçeneklerini belirlemek için

  1. içinde, e-posta seçeneklerini belirlemek istediğiniz 'i sağ tıklatın.
  2. Kısayol menüsünden Özellikler'i tıklattıktan sonra Server Extensions sekmesini tıklatın.
  3. Seçenekler kutusundan Ayarlar'ı tıklatın.
  4. İstediğiniz ayarları girin.


Web'deki Microsoft Ürün Desteği Hizmetleri

Internet'teki teknik sorulara en son yanıtları alın

Web'deki Microsoft Ürün Desteği Hizmetleri

Teknik bir sorunuz varsa ve Windows 2000 Yardımı'nda yanıtını bulamadıysanız, Web'deki Microsoft Ürün Desteği Hizmetlerine gidin. Özel destek sitelerimizin birinde, Knowledge Base, Sık Sorulan Sorular ve sorun gidericiler gibi Microsoft Ürün Desteği Hizmetleri kaynaklar topluluğunda hızlı ve kesin yanıtları kolayca bulabilirsiniz. Microsoft Ürün Desteği Hizmetleri sorularınıza yanıt bulmanızda yardımcı olacak belirli kaynakları biraraya getirir.

Aramanızı başlatmak için, Microsoft Web sitesinde çevrimiçi ürün desteğine gidin. (http://www.microsoft.com/)


E-Posta Ayarları

Bu iletişim kutusunda, e-posta tabanlı özellikler içeren bir web'den e-posta iletilerinin nasıl gönderileceğini belirlersiniz, örneğin form işleyicisi gibi gibi.

Web sunucularının posta adresi

FrontPage'de, sonuç formları gibi, belirli bir bileşen tarafından gönderilen e-posta iletilerinin, Kimden satırında görüntülenmesini istediğiniz e-posta adresini girin.

Kişi adresi

Kullanıcılar sorunlarla karşılaştıklarında, bu sorunları yazmaları gereken e-posta adresini girin. Girdiğiniz adres, FrontPage kullanıcılarının karşılaştıkları bazı sorunlar için görüntülenen hata iletilerinde gösterilecektir.

SMTP Posta sunucusu

İletileri web'e yönlendirecek veya web'den alacak olan SMTP ana makinesinin adını girin.

Posta kodlama

Posta iletileriniz için kullanmak istediğiniz posta kodlama şeklini tıklatın. Varsayılan kodlama en yaygın kodlama şekli olan 8 bitlik kodlamadır. E-posta alıcısının farklı bir kodlama şekli kullandığını ve iletilerinizi yorumlayamacağını biliyorsanız, kodlama şeklinizi değiştirebilirsiniz.

Karakter Kümesi

E-posta iletilerinde kullanmak istediğiniz karakter kümesinin adını tıklatın. Her karakter kümesi bir dilin alfabesinden oluşur.


Başarım

Bu iletişim kutusunda, bir web'de sıklıkla kullanılan her türdeki bilgi için ön bellek miktarını belirtebilirsiniz. Seçili web için uygun ön bellek miktarını belirterek, web'in kullanıcı etkinliklerine karşı yanıtını hızlandırabilirsiniz.

Bellekteki belge ön belleği

Bağlantı eşlemeleri ve web parametreleri gibi özellik bilgilerini bellekte etkin olarak korumak istediğiniz belgelerin maksimum sayısını girin. Bu sayı, çalıştığınız son <belirteceğiniz sayı> belgeyi gösterir. Örneğin, 4096 seçerseniz, 4097. belgenin özellik bilgileri bellekten çıkarılacaktır.

Dosya ekleme ön belleği

Diğer dosyalara eklemek için bellekte saklamak istediğiniz dosyaların sayısını girin. Örneğin, bir Web sitesinin bazı veya tüm web sayfalarına eklemek istediğiniz üstbilgi, altbilgi ve telif hakkı dosyaları olabilir.

Resim dosyası ön belleği

Web sayfaları içinde katmanlı resimler oluşturmak için FrontPage Server Extensions'ın kullanabileceği bellekteki resim sayısını girin. Örneğin, bir dosya bir arka plan, başka bir dosya ise gezinti düğmesi içerebilir. Sunucu uzantıları, bir web sayfasına arka plan ekleyerek ve sonra gezinti düğmesi görüntüsü yerleştirerek bir resim oluşturabilir. Bileşen dosyalar bir ön belleğin içinde olduğunda resim daha hızlı oluşturulabilir.

Tam metin arama dizin boyutu

Bir tam metin arama dizinini saklamak için ayrılabilecek en fazla disk alanı miktarını girin. Bu miktar aşıldıktan sonra, (bu sayı artırılmadıkça) Web sitesi üstündeki diğer sayfalar dizinlenemez.

Ön bellekteki en fazla belge boyutu

Bellekte en büyük belge boyutunu girin. Bu boyut kısıtlaması dosyalara, görüntü dosyalarına ve bir ön bellekte saklanabilecek diğer dosyalara uygulanır.


Varsayılan Web Özellikleri - Özellik Sayfasını Yayınlama

Varsayılan Web Sitesi Özellikleri- Server Extensions Özellik Sayfası

Bu özellik sayfası üstünde, FrontPage uzantılı bir web için yayımlama denetimlerini ayarlayabilirsiniz.

Yazmayı etkinleştirme (yalnızca kök web için)

Web oluşturucularının seçili web içeriğine erişip bunu değiştirmek için FrontPage kullanmalarına olanak verir. Herhangi birinin seçili web'e erişip üzerinde değişiklik yapmasına engel olmak için Yazmayı etkinleştir onay kutusunu temizleyin.

Sürüm denetimi

Web içeriğini değiştirenleri izlemek, değişiklikleri tanımlamak ve web yazarlarının birbirlerinin değişikliklerini silmelerine engel olmak için kullanmak istediğiniz kaynak denetimi yöntemini tıklatın. Yerleşik kaynak denetimini seçebileceğiniz gibi Microsoft Visual SourceSafe gibi daha fazla kaynak denetim özelliğine sahip olan harici bir program da kullanabilirsiniz.

Performans

Seçili web içindeki gerçek sayfa sayısına en yakın sayfa aralığını tıklatın. FrontPage Server Extensions seçtiğiniz sayfa aralığına bağlı olarak belirli bir miktar ön bellek ayıracaktır.

İstemci kodlama

FrontPage Server Extensions tarafından sayfaların içinde otomatik olarak oluşturulacak kodlama dilini tıklatın: JScript veya VBScript.

Postanın nasıl gönderileceğini belirleme

İçinde e-posta form işleyicileri gibi, e-posta tabanlı web özelliklerinin Web sitesi ziyaretçilerine nasıl e-posta göndereceğini belirleyebileceğiniz, E-posta Ayarları iletişim kutusunu görüntüler. Web sunucusunun e-posta adresini, ilgli kişinin e-posta adresini, posta kodlama şeklini ve karakter kümesini belirlemek için bu iletişim kutusunu kullanabilirsiniz.

Office birlikte çalışabilirlik özelliklerini yapılandırma

Çalışma grubu tartışmaları gibi, içinden Office birlikte çalışabilirlik özelliklerini yönetebileceğiniz Office Server Extensions web yönetim sayfalarını görüntüler. Bilgisayarınızda Office Web Server (OWS) yüklü değilse bu seçenek kullanılamaz.

Güvenlik ayarlarını almama

Varsayılan olarak, her kök web, Web sunucunun genel güvenlik ayarlarını devralır. Seçili kök web (ve onun alt web'leri) için bu ayarları geçersiz kılmak amacıyla, bu onay kutusunu seçin. Seçili kök web'in güvenlik ayarlarını Web sunucunun genel ayarlarından devralmasını istiyorsanız bu onay kutusunu temizleyin.

Yazma eylemlerini raporlama

Web oluşturucusunun gerçekleştirdiği eylemin, kullanıcı adının, web adının, uzaktaki ana bilgisayarın ve her işlem verisinin sistem tarafından kaydedilmesini ve bu bilgilerin kök web içindeki in _vti_log/Author.log adlı bir günlük dosyasında saklanmasını sağlar. Yazma eylemlerini raporlamak istemiyorsanız bu onay kutusunu temizleyin.

İzinleri el ile yönet

FrontPage Server Extension yönetimsel araçlarının (FrontPage MMC yönetim eki gibi) güvenlik ayarı işlevlerini devre dışı bırakarak seçili web'in güvenlik ayarlarını değiştirmek için bu araçların kullanılmamasını sağlar. Güvenlik ayarlarının FrontPage Server Extensions yönetim araçları ile değiştirilmesine izin vermek için bu onay kutusunu temizleyin.

Yazma için Güvenli Yuvalar Tabakası (SSL) gerektirme

Olası web oluşturucularının kimlik denetimini yapmak için SSL kullanımını sağlar. Yalnızca Web üzerinden iletilen bilgileri (yazarın adı ve parolası gibi) şifreleyen Ana Kimlik Doğrulama kullanıyorsanız, bu yöntemi kullanmanız önerilir. Yazma için SSL kullanmak istemiyorsanız bu onay kutusunu temizleyin.

Yazarların çalıştırılabilir dosyalar yüklemesine izin verme

Yazarların seçili web'e CGI kodlarını veya etkin sunucu sayfalarını yüklemesine izin verir. Çalıştırılabilir dosyaların web'e yüklenmesini istemiyorsanız ve olası hatalı yazılmış kodlardan ve Web sunucunuza virüs bulaşma riskinden kaçınmak istiyorsanız bu onay kutusunu temizleyin.