AM-DeadLink Help

Welcome to AM-DeadLink.

AM-DeadLink is free tool which detects dead links and duplicates in your Browser Bookmarks. If a Bookmark has become unavailable you can delete it from your Browser.

AM-Deadlink checks Bookmarks from Internet Explorer, Opera and Netscape.

If you are looking for a bookmark manager with more functions you can download our tool WebSite-Watcher. WebSite-Watcher allows you to monitor any number of websites for updates and changes with a minimum of time and online-costs. When changes in a website are detected, WebSite-Watcher saves the last two versions to your hard disk and highlights all changes in the text.

www.aignes.com


Basic use

  1. Select your browser in the checkbox
  2. Check the bookmark list
  3. Sort bookmarks
  4. Open/Validate/Delete dead bookmarks from your browser

Tip:
When AM-DeadLink detects dead links it is recommended to validate the result before deleting the bookmarks from your browser. In several cases a server can send an error message when the site is temporarily not reachable.

When you delete Bookmarks AM-DeadLink writes the log file deadlink.log with the deleted bookmarks.

When you delete Bookmarks from Opera or from Netscape, AM-DeadLink generates BAK files of your Bookmark file called:

  • operaX.adr_deadlink_bak (Opera)
  • bookmark.htm_deadlink_bak (Netscape)


Error codes

100 Continue
101 Switching Protocols
200 OK
201 Created
202 Accepted
203 Non-Authoritative Information
204 No Content
205 Reset Content
206 Partial Content
300 Multiple Choices
301 Moved Permanently
302 Moved Temporarily
303 See Other
304 Not Modified
305 Use Proxy
400 Bad Request
401 Unauthorized / Authentication failure
402 Payment Required
403 Forbidden
404 Site Not Found
405 Method Not Allowed
406 Not Acceptable
407 Proxy Authentication Required
408 Request Time-out
409 Conflict
410 Gone
411 Length Required
412 Precondition Failed
413 Request Entity Too Large
414 Request-URI Too Large
415 Unsupported Media Type
500 Internal Server Error
501 Not Implemented
502 Bad Gateway
503 Service Unavailable
504 Gateway Time-out
505 HTTP Version not supported

Winsock error messages:

10004 The operation is canceled.
10013 The requested address is a broadcast address, but flag is not set.
10014 Invalid argument.
10022 Socket not bound, invalid address or listen is not invoked prior to accept.
10024 No more file descriptors are available, accept queue is empty.
10035 Socket is non-blocking and the specified operation will block.
10036 A blocking Winsock operation is in progress.
10037 The operation is completed. No blocking operation is in progress.
10038 The descriptor is not a socket.
10039 Destination address is required.
10040 The datagram is too large to fit into the buffer and is truncated.
10041 The specified port is the wrong type for this socket.
10042 Option unknown, or unsupported.
10043 The specified port is not supported.
10044 Socket type not supported in this address family.
10045 Socket is not a type that supports connection oriented service.
10047 Address Family is not supported.
10048 Address in use.
10049 Address is not available from the local machine.
10050 Network subsystem failed.
10051 The network cannot be reached from this host at this time.
10052 Connection has timed out when SO_KEEPALIVE is set.
10053 Connection is aborted due to timeout or other failure.
10054 The connection is reset by remote side.
10055 No buffer space is available.
10056 Socket is already connected.
10057 Socket is not connected.
10058 Socket has been shut down.
10060 The attempt to connect timed out.
10061 Connection is forcefully rejected.
10201 Socket already created for this object.
10202 Socket has not been created for this object.
11001 Authoritative answer: Host not found.
11002 Non-Authoritative answer: Host not found.
11003 Non-recoverable errors.
11004 Valid name, no data record of requested type.


FAQ

Q. I cannot change my IE favorites, why?

A. Please check if you have the necessary rights to modify your favorites. If you have the necessary rights please check if your favorites files have the flag "read only" (can occur when you copy back your favorites from a CD backup to your hard disc).

Q. Why does AM-DeadLink find my IE favorites, but not my NS or Opera bookmarks?

A. IE favorites are stored in one single folder while NS and Opera can be installed more than once. So you can have different bookmark files and you must select the bookmark file manually (general options).

Q. Every bookmark reports an error, why?

A. If you need a proxy to access to the internet you must enter the proxy configuration in the general options. Some users reported problems with firewalls or virus tools, maybe such a tool causes an error.

Q. I cannot check FTP sites through a proxy, why?

A. AM-DeadLink supports the transparent login, maybe this login is not supported by your proxy.

Q. How can I get back my deleted bookmarks?

A. In the file menu you can find the menu entry "Show logfile". All deleted bookmarks are written to this log file..


Privacy

AM-DeadLink does NOT send any personal data to any server.
We don't collect any data of any kind!
AM-DeadLink is NOT Spyware.

AM-DeadLink only checks your browser bookmarks if they are available.

PS.
If you won't believe it feel free to open and check all your bookmarks manually with your browser :-))


License Agreement

Terms of License for the software product AM-DeadLink (in the following called "SOFTWARE PRODUCT")

WebSite: http://aignes.com
Author: Martin Aignesberger, aignes.com
Revision: 28-Dec-2001

Please pay attention to the following notes before you start using this software.
If you do not agree with the following, do not use the SOFTWARE PRODUCT and remove it from your system.

1. License Agreement

The SOFTWARE PRODUCT is Freeware! You may install and use an unlimited number of copies of the SOFTWARE PRODUCT.

2. Reproduction and Distribution

The SOFTWARE PRODUCT may be freely distributed, provided the distribution package is not modified. The SOFTWARE PRODUCT and the attached documentation can not be distributed together with commercial software. For this you need to be authorized by the manufacturer.
No person or company may charge a fee for the distribution of the SOFTWARE PRODUCT without written permission of the author. The SOFTWARE PRODUCT may not be sold or be included in a product or package.

3. Other Rights and Limitations

Limitations on Reverse Engineering, Decompilation, and Disassembly: You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.
Separation of Components: The SOFTWARE PRODUCT is licensed as a single product. Its component parts may not be separated for use on more than one computer.
Termination: Without prejudice to any other rights, the Author of this Software may terminate this End-User License Agreement if you fail to comply with the terms and conditions of this End-User License Agreement. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

4. Copyright

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.

5. No Warranties

The Author of the SOFTWARE PRODUCT expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation is provided "AS IS" without warranty of any kind, either express or implied, including, without limitation, the implied warranties or merchantability, fitness for a particular purpose, or noninfringement. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.
No Liability for Damages: In no event shall the author of this Software be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use this product, even if the Author of the SOFTWARE PRODUCT has been advised of the possibility of such damages. Because some states/jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.

6. Other Provisions

The license agreement for this software may be modified if necessary. Therefore the license agreement under which the software has been delivered will be applied. Should one or more provisions of this agreement be or become unvalid, all other license agreements and provisions remain valid. Unvalid provisions have to be replaced by others which are equal for the economical contents. The latest revision of this document can be found at the website mentioned above. All mentioned trademarks and copyrights are property of the relative owner.

Martin Aignesberger, aignes.com