Oversigt over Opgavestyring

Du kan bruge Opgavestyring til at planlægge kørsel af kommandoer, programmer eller scripts på bestemte tidspunkter.

  • Før du anvender Opgavestyring, er det en god idé at læse afsnittet Kontrolliste.
  • Du kan finde hjælp til bestemte opgaver i afsnittet Sådan.
  • Generelle oplysninger finder du i afsnittet Begreber.
  • Du kan finde hjælp til problemløsning i afsnittet Fejlfinding.


Kontrolliste for Opgavestyrings

Kontrolliste

I nedenstående tabel vises en liste over alle de handlinger, der hyppigst anvendes i Opgavestyring. Du kan finde yderligere oplysninger i afsnittet Sådan.

Trin | Reference
Før du kan planlægge en opgave, skal du tilføje opgaven. | Planlægning af en ny opgave
Når du har oprettet de planlagte opgaver, kan du ændre programmet, planlægningen eller andre parametre for en bestemt opgave. | Ændring af en planlagt opgave
Du kan fjerne planlagte opgaver, hvis der ikke længere er brug for dem. | Fjernelse af en planlagt opgave
I de tilfælde, hvor en planlagt opgave starter, mens du er ved at bruge computeren, kan du standse opgaven og køre den senere. | Standsning af en planlagt opgave, der kører
Du kan midlertidigt standse eller afbryde alle planlagte opgaver og køre dem igen på et senere tidspunkt. | Standsning af alle planlagte opgaver midlertidigt


Sådan...

  • Planlægges opgaver
  • Håndteres Opgavestyring


Planlægning af opgaver
  • Start af Opgavestyring
  • Planlægning af en ny opgave
  • Ændring af en planlagt opgave
  • Fjernelse af en planlagt opgave
  • Standsning af en planlagt opgave, der kører
  • Kørsel af en opgave med det samme


Start af Opgavestyring

Sådan startes Opgavestyring

  • Du kan starte Opgavestyring ved at dobbeltklikke på Denne computer og derefter dobbeltklikke på mappen Planlagte opgaver.
  • Dobbeltklik på Planlagte opgaver, og dobbeltklik derefter på Planlæg ny opgave for at starte guiden Opgaveplanlægning, som hjælper dig med at planlægge en opgave.


Planlægning af en ny opgave

Sådan planlægges en ny opgave
  1. Start Opgavestyring.
  2. Dobbeltklik på Planlæg ny opgave.
  3. Følg vejledningen i guiden Planlæg ny opgave.

Bemærk!

  • Hvis du vil konfigurere avancerede egenskaber for opgaven, skal du markere afkrydsningsfeltet Åbn avancerede egenskaber for denne opgave, når jeg klikker på Udfør på det sidste skærmbillede i guiden.
  • Hvis en ny opgave skal gentages, hver gang den kører, skal du markere afkrydsningsfeltet Åbn avancerede egenskaber for denne opgave, når jeg klikker på Udfør på det sidste skærmbillede i guiden, klikke på fanen Planlæg og derefter klikke på Avanceret.
  • Hvis programmet, der kører opgaven, skal startes med parametre, skal du markere afkrydsningsfeltet Åbn avancerede egenskaber for denne opgave, når jeg klikker på Udfør på det sidste skærmbillede i guiden, klikke på fanen Opgave og derefter skrive parametrene i boksen Kør efter programstien.
  • Kontroller, at systemets dato og klokkeslæt er korrekt indstillet på computeren. Opgavestyring benytter disse oplysninger til at afgøre, hvornår de planlagte opgaver skal køres. Dobbeltklik på klokkeslættet på proceslinjen for at kontrollere eller redigere dato og klokkeslæt.


Ændring af en planlagt opgave

Sådan ændres en planlagt opgave
  1. Start Opgavestyring.
  2. Højreklik på den opgave, der skal ændres, og klik derefter på Egenskaber.
  3. Gør ét eller flere af følgende:
    • Angiv stien til det nye program i boksen Kør for at ændre det program, der skal køres.
    • Klik på fanen Planlæg for at redigere planlægningen af opgaven.
    • Klik på fanen Indstillinger for at tilpasse indstillingerne for opgaven.

Bemærk!

  • Hvis du ændrer brugerkontoen eller det program, der køres, skal du angive adgangskoden til brugerkontoen.
  • Hvis programmet, der kører opgaven, skal startes med kommandolinjeindstillinger, skal du skrive dem i boksen Kør efter programstien.
  • Hvis stien til programmet, der kører opgaven, indeholder mellemrum, skal du sætte hele programstien i anførselstegn ("").
  • Kontroller, at systemets dato og klokkeslæt er korrekt indstillet på computeren. Opgavestyring benytter disse oplysninger til at afgøre, hvornår de planlagte opgaver skal køres. Dobbeltklik på klokkeslættet på proceslinjen for at kontrollere eller redigere dato og klokkeslæt.


Fjernelse af en planlagt opgave

Sådan fjernes en planlagt opgave
  1. Start Opgavestyring.
  2. Højreklik på den opgave, der skal fjernes, og klik derefter på Slet.

Bemærk!

  • Når du fjerner en planlagt opgave, er det kun planlægningen af opgaven, der fjernes fra listen over planlagte opgaver. Programfilen fjernes ikke fra harddisken.
  • Du kan også fjerne en planlagt opgave ved at trykke på DELETE på tastaturet.


Standsning af en planlagt opgave, der kører

Sådan standses en planlagt opgave, der kører
  1. Start Opgavestyring.
  2. Højreklik på den opgave, du vil standse, og klik derefter på Afslut opgave.

Bemærk!

  • Hvis en planlagt opgave starter et andet program, standser denne kommando den oprindelige, planlagte opgave, og ikke det andet program.
  • Du kan genstarte en standset opgave ved at højreklikke på opgaven og derefter klikke på Kør.


Kørsel af en opgave med det samme

Sådan køres en opgave med det samme
  1. Start Opgavestyring.
  2. Højreklik på den ønskede opgave, og klik derefter på Kør.

Bemærk!

  • Du kan standse opgaven ved at klikke på Afslut opgave i menuen Filer.
  • Hvis en planlagt opgave ikke køres som planlagt, kan du klikke på Vis log i menuen Avanceret for at kontrollere opgavens log.


Opgavestyring
  • Få vist en log over tidligere, planlagte opgaver
  • Få vist planlagte opgaver fra fjerncomputere
  • Midlertidig standsning af alle planlagte opgaver
  • Midlertidig afbrydelse af Opgavestyring
  • Indstilling af AT-serviceprogrammet


Få vist en log over tidligere, planlagte opgaver

Sådan får du vist en log over tidligere, planlagte opgaver
  1. Start Opgavestyring.
  2. Klik på Vis log i menuen Avanceret.


Få vist planlagte opgaver fra fjerncomputere

Sådan får du vist planlagte opgaver fra fjerncomputere
  1. Dobbeltklik på ikonet Andre computere på skrivebordet.
  2. Dobbeltklik på den computer, du vil se de planlagte opgaver på.
  3. Klik på Planlagte opgaver.

Bemærk!

  • Du kan kun se planlagte opgaver fra en fjerncomputer, der kører Windows, hvis du er administrator på denne computer.
  • Du kan kun ændre opgaver fra en fjerncomputer, der kører Windows, hvis computeren har software til fjernadministration installeret, og hvis drev x$, hvor x står for den harddisk, hvor mappen Planlagte opgaver er placeret, er delt. Computeren, der kører Windows, skal også have registreret, at din brugerkonto har adgang til fjernadministration. Du kan angive, hvilke brugere der skal have adgang til fjernadministration på en computer, der kører Windows, ved at klikke på Adgangskoder i Kontrolpanel.


Midlertidig standsning af alle planlagte opgaver

Sådan standses alle planlagte opgaver midlertidigt
  1. Start Opgavestyring.

  2. Klik på Afbryd Opgavestyring i menuen Avanceret.

Bemærk!

  • Denne kommando er nyttig, hvis du kører et andet program, f.eks. et spil, eller installerer software, og du ikke vil køre de planlagte opgaver samtidig.
  • Planlagte opgaver, som ikke blev kørt, mens Opgavestyring var midlertidigt standset, køres først igen på næste planlagte tidspunkt.
  • Klik på Fortsæt Opgavestyring i menuen Avanceret for at genstarte Opgavestyring, så alle planlagte opgaver kan køres.


Midlertidig afbrydelse af Opgavestyring

Sådan afbrydes Opgavestyring midlertidigt
  1. Start Opgavestyring.
  2. Klik på Afslut Opgavestyring i menuen Avanceret.

Bemærk!

  • Når du afbryder Opgavestyring, køres de planlagte opgaver ikke, og Opgavestyring starter ikke automatisk, næste gang Windows startes.


Indstilling af AT-serviceprogrammet

Sådan indstilles AT-serviceprogrammet
  1. Start Opgavestyring.
  2. Klik på AT-serviceprogram i menuen Avanceret.
  3. Klik på Denne konto, og angiv derefter den brugerkonto, der skal køre de opgaver, som planlægges ved hjælp af AT-kommandoen.
  4. Angiv den korrekte adgangskode til kontoen i boksene Adgangskode og Bekræft adgangskode.

Bemærk!

  • AT-serviceprogrammet er kun tilgængeligt under Windows NT.
  • Du kan også klikke på Systemkonto. Hvis du gør det, kører Opgavestyring de opgaver, der er planlagt ved hjælp af AT-kommandoen via den lokale systemkonto. Dette kræver, at du har administratorrettigheder.

  • Den angivne brugerkonto skal have de nødvendige tilladelser for at køre de opgaver, du planlægger ved hjælp af AT-kommandoen. Hvis du f.eks. planlægger at køre et program, som kun administratorer kan køre, skal den angivne brugerkonto være en administratorkonto.


Begreber i Opgavestyring

Begreber

Dette afsnit indeholder generelle oplysninger om Opgavestyring:

  • Introduktion til Opgavestyring
  • Brug af Opgavestyring
  • Opgavestyring og AT-kommandoen
  • Opgavestyring og sikkerhed
  • Fejlfinding i Opgavestyring


Introduktion til Opgavestyring

Ved hjælp af Opgavestyring kan du planlægge kørslen af opgaver, f.eks. Diskdefragmentering, på de tidspunkter, der passer dig bedst. Opgavestyring starter, hver gang Windows startes, og programmet kører i baggrunden.

Med Opgavestyring kan du:

  • Planlægge kørslen af en opgave dagligt, ugentligt eller månedligt eller på bestemte tidspunkter, f.eks. ved systemstart.
  • Ændre planlægningen af en opgave.
  • Standse en planlagt opgave.
  • Tilpasse, hvordan opgaven skal køres på et planlagt tidspunkt.


Brug af Opgavestyring

Opgavestyring installeres automatisk under Windows. Dobbeltklik på mappen Planlagte opgaver i Denne computer for at bruge planlægningsfunktionen.

Du kan tilføje opgaver ved at dobbeltklikke på Planlæg ny opgave. Herved startes guiden Opgaveplanlægning. Du kan tilføje opgaver ved at trække scripts, programmer eller dokumenter fra Windows Stifinder eller skrivebordet til vinduet Opgaveplanlægning.

Du kan også bruge Opgavestyring til at ændre, slette, midlertidig afbryde eller standse planlagte opgaver, få vist en log over tidligere, planlagte opgaver eller få vist planlagte opgaver fra en fjerncomputer.

Yderligere oplysninger om brug af Opgavestyring finder du i afsnittet Sådan.

Optimal udnyttelse af Opgavestyring

Under Windows kan du bruge Opgavestyring til at planlægge kørsel af et hvilket som helst program. For at få det bedste ud af Opgavestyring skal du kontrollere, at systemets dato og klokkeslæt på computeren er korrekt indstillet, før du tilføjer en opgave.


Opgavestyring og AT-kommandoen

Ud over at bruge Opgavestyring kan du også bruge AT-kommandoen til at køre opgaver automatisk.

Opgavestyring er ikke det samme som AT-kommandoen, men de arbejder sammen. Når du planlægger en opgave ved hjælp af AT-kommandoen, vises den på listen over opgaver i vinduet Opgavestyring.

Du kan bruge Opgavestyring til at ændre egenskaber for en opgave, der er planlagt ved hjælp af AT-kommandoen. Hvis du gør det, skal du fortsætte med at bruge Opgavestyring for at få adgang til opgaven. Du kan ikke længere få adgang til den ved hjælp af AT-kommandoen.

Hvis du vil angive, hvilken brugerkonto der skal køre de opgaver, der er planlagt ved hjælp af AT-kommandoen, skal du klikke på ikonet Denne computer, klikke på Planlagte opgaver og derefter klikke på AT-serviceprogram i menuen Avanceret.

Bemærk!

  • AT-serviceprogrammet er kun tilgængeligt under Windows NT.


Opgavestyring og sikkerhed

I Opgavestyring kan du forøge sikkerheden ved at tildele et brugernavn og en adgangskode til en bestemt opgave. Når der er angivet et brugernavn og en adgangskode, kan opgaven ikke annulleres eller slettes af en anden bruger.

Bemærk!

  • Sikkerhedsfunktionen er kun tilgængelig under Windows NT.
  • Du skal angive et brugernavn i guiden Opgaveplanlægning, før du kan planlægge en opgave. Det er ikke nødvendigt at angive en adgangskode.
  • Hvis du vil ændre eller angive en ny adgangskode, skal du markere afkrydsningsfeltet Åbn avancerede egenskaber for denne opgave, når jeg klikker på Udfør på det sidste skærmbillede i guiden.


Fejlfinding i Opgavestyring

Hvis en planlagt opgave ikke kører som forventet, kan du højreklikke på opgaven og derefter klikke på Egenskaber. Kontroller, at afkrydsningsfeltet Aktiveret er markeret under fanen Opgave. Kontroller, at opgaven er oprettet korrekt under fanen Planlæg.

Hvis programmet, der kører opgaven, ikke kører korrekt, skal du muligvis tilføje kommandolinjeindstillinger. Du kan finde yderligere oplysninger om et bestemt program og dets kommandolinjeindstillinger ved at gøre ét af følgende:

  • Se i online Hjælp til programmet, hvis det findes.

  • Prøv at skrive følgende ved en kommandopromt (hvor program skal erstattes med navnet på programmet):

    • program /?


Windows NT-komponent er ikke installeret

Dette program kunne ikke startes

Mulige årsager kan være:

    • Programmet er blevet fjernet af en systemadministrator.
    • Systemadministratoren har ændret en regel, der var tilknyttet filen.
    • Programmet er ikke installeret på computeren.
    • Programmet er blevet slettet ved en fejltagelse.
    • Filen er beskadiget.

Kontakt systemadministratoren for at finde ud af, hvorfor programmet ikke kan startes.