Общие сведения

Калькулятор аудиотреков – программа для суммирования продолжительности отрезков времени в минутах и секундах (например, длительности аудиотреков).

В окне программы имеется сорок ячеек, предназначенных для ввода данных. При заполнении этих ячеек автоматически рассчитывается восемь различных сумм (суммы значений ячеек, выделенных белым, синим и красным цветом, общая сумма, а также суммы по первому, второму, третьему и четвертому десятку ячеек).

Ячейки заполняются с клавиатуры, в них можно вводить значения от 00:00 до 59:59. При полном заполнении ячейки курсор автоматически переходит на следующую ячейку (в случае, если ячейка была последней, то на первую ячейку). При нажатии правой кнопки мыши на ячейке появляется меню, в котором можно выбрать цвет ячейки.

В программе имеется панель инструментов (находится справа внизу), кнопками которой можно перейти с ячейки на ячейку, выделить текущую ячейку белым, синим или красным цветом, установить белый цвет для всех ячеек, обнулить значения всех ячеек.

Также есть главное меню, выбрав пункт которого можно сделать те же операции, что и с помощью панели инструментов (за исключением движения по ячейкам), а также посмотреть справку, информацию о программе или выйти из программы.

Все действия, выполняемые с помощью панели инструментов и меню, можно выполнить без использования мыши с помощью нажатия одной или нескольких клавиш (сочетаний клавиш).

См. также:
Панель инструментов, Меню программы, Сочетания клавиш

© Александр Ицков
itskoff.nextmail.ru


Панель инструментов

Кнопка панели инструментов |  | Сочетание клавиш | Выполняемое действие
 | Только белый | Ctrl+Delete | Установка белого цвета для всех ячеек
 | Сброс | Ctrl+BackSpace | Обнуление значений всех ячеек
 | Переход вверх | Up (↑) | Переход на предыдущую ячейку
 | Переход влево | PageUp | Переход на предыдущий столбец
 | Переход вправо | PageDown | Переход на следующий столбец
 | Переход вниз | Down (↓) | Переход на следующую ячейку
 | Выделить белым | Ctrl+W | Выделение текущей ячейки белым цветом
 | Выделить синим | Ctrl+B | Выделение текущей ячейки синим цветом
 | Выделить красным | Ctrl+R | Выделение текущей ячейки красным цветом

Примечание: при нажатии и удерживании кнопок со стрелками включается режим автоповтора (выполняемое действие повторяется каждую двадцатую долю секунды).

См. также:
Общие сведения, Меню программы, Сочетания клавиш


Меню программы

Главное меню

Пункт меню |  | Сочетание клавиш | Выполняемое действие
Меню "Действия" |  |  |
 | Выделить белым | Ctrl+W | Выделение текущей ячейки белым цветом
 | Выделить синим | Ctrl+B | Выделение текущей ячейки синим цветом
 | Выделить красным | Ctrl+R | Выделение текущей ячейки красным цветом
 | Только белый | Ctrl+Delete | Установка белого цвета для всех ячеек
 | Сброс | Ctrl+BackSpace | Обнуление значений всех ячеек
 | Выход | Alt+F4 | Выход из программы
Меню "Информация" |  |  |
 | Справка | F1 | Вызов справки
 | О программе | Ctrl+F1 | Просмотр информации о программе

Контекстное меню ячейки

Пункт меню |  | Сочетание клавиш | Выполняемое действие
 | Белый | Ctrl+W | Выделение ячейки белым цветом
 | Синий | Ctrl+B | Выделение ячейки синим цветом
 | Красный | Ctrl+R | Выделение ячейки красным цветом

См. также:
Общие сведения, Панель инструментов, Сочетания клавиш


Сочетания клавиш

Клавиши для ввода и изменения данных

Клавиша (сочетание клавиш) | Выполняемое действие | После выполнения
Цифровые клавиши | Ввод цифр от 0 до 9 | Курсор переходит на следующий цифровой символ
Delete | Замена текущего символа на цифру 0 | Курсор переходит на следующий цифровой символ
BackSpace | Замена предыдущего цифрового символа на цифру 0 | Курсор переходит на предыдущий цифровой символ
Ctrl+BackSpace | Обнуление значений всех ячеек | Курсор переходит на первый символ в первой ячейке

Клавиши передвижения по ячейкам

Клавиша (сочетание клавиш) | Выполняемое действие
Стрелка влево (←) | Переход на предыдущий цифровой символ
Стрелка вправо (→) | Переход на следующий цифровой символ
Стрелка вверх (↑) или Shift+Tab | Переход на предыдущую ячейку
Стрелка вниз (↓) или Tab | Переход на следующую ячейку
PageUp | Переход на предыдущий столбец
PageDown | Переход на следующий столбец
Home | Переход на верхнюю ячейку в столбце
End | Переход на нижнюю ячейку в столбце
Ctrl+Home | Переход на первую ячейку
Ctrl+End | Переход на последнюю ячейку

Клавиши установки цвета

Клавиша (сочетание клавиш) | Выполняемое действие
Ctrl+W | Выделение текущей ячейки белым цветом
Ctrl+B | Выделение текущей ячейки синим цветом
Ctrl+R | Выделение текущей ячейки красным цветом
Ctrl+Delete | Установка белого цвета для всех ячеек

Клавиши управления

Клавиша (сочетание клавиш) | Выполняемое действие
F1 | Вызов справки
Ctrl+F1 | Просмотр информации о программе
Alt+F4 | Выход из программы
Alt или F10 | Выбор строки меню
Shift+F10 | Вызов контекстного меню текущей ячейки

См. также:
Общие сведения, Панель инструментов, Меню программы


Благодарность

В процессе разработки автором использовались следующие программы:

Программа | № версии | Для чего использовалась
Notepad++ | 3.8 | Работа с исходными текстами
Free Pascal Compiler | 1.0.10 | Компиляция исполняемого файла
GoRC | 0.90.2 | Компиляция ресурсов
GIMP | 2.2.11 | Создание графики и иконок
Студия иконок | 5.15 | Создание графики и иконок
UPX | 2.02 | Сжатие исполняемого файла
HTML Help Workshop | 1.3 | Создание справки
NSIS | 2.23 | Создание инсталлятора программы
OpenOffice.org | 2.0.1 | Ведение вспомогательной документации

Автор выражает огромную благодарность создателям этих программ.


Лицензионное соглашение

1. Авторские права на программу «Калькулятор аудиотреков» (далее по тексту – программу) принадлежат Александру Ицкову (далее по тексту – автору).

2. Программа является свободно распространяемой при условии выполнения настоящего лицензионного соглашения. Под свободным распространением в данном случае понимается как бесплатное распространение, так и распространение за плату (например, в сборниках программ на CD/DVD).

3. Разрешается изготавливать сколько угодно копий программы, устанавливать программу и использовать ее на любом количестве компьютеров. Срок использования программы не ограничен.

4. Программа поставляется по принципу «как есть». Никаких гарантий не предоставляется. В случае возникновения ошибки в программе (хотя, по мнению автора, были предприняты все возможные меры по исключению ошибок), Вы можете направить письмо с подробным описанием ошибки по адресу: itskoff@nextmail.ru.

5. Исходные тексты программы не являются открытыми и пользователю не предоставляются.

6. Никто, кроме автора, не имеет права вносить изменения в программу.

7. Выполнение условий настоящего лицензионного соглашения является обязательным, за исключением случаев, прямо предусмотренных действующим законодательством.

8. Использование программы предполагает согласие с условиями настоящего соглашения.