“计划任务”程序概述

“计划任务”程序 是将任务（如“磁盘碎片整理程序”）安排为定期运行或在最方便时运行的工具。每次启动 Windows 时启动“计划任务”程序，并在后台运行。

在 Windows 95 或更高版本上运行“计划任务”程序时，这个图标 图像：计划任务图标 出现在任务栏的时钟旁边。

在运行 Windows 95 或更高版本的计算机上，可以双击任务栏上的“计划任务”图标打开“计划任务”程序。在运行 Windows 95（或更高版本）或 Windows NT 的计算机上，双击“我的电脑”，再双击“计划任务” 文件夹也可以打开“计划任务”程序。

打开“计划任务”程序，您可以执行以下操作：

  • 将任务计划为每天、每星期、每月或在特定的时间（如在计算机启动时或空闲时）运行。
  • 更改现有任务的计划或关闭现有任务。
  • 规定任务在为其安排的时间内如何运行。


计划新任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 在任务列表中，单击“添加计划任务”。
  3. 按照“添加计划任务”向导中的指令来安排任务。
  4. 如果想对任务进行高级设置（如将其设置为每次运行时重复运行），请在向导的最后屏幕中选择“打开任务的高级属性”复选框。

注意

  • 如果想对任务进行高级设置（如将其设置为每次运行时重复运行，或者指定任务命令的参数），请在向导的最后屏幕中选中“打开任务的高级属性”复选框。
  • 要使新的任务每次运行时重复运行，请在向导的最后屏幕中选中“打开任务的高级属性”复选框，然后单击“计划”选项卡并单击“高级”。
  • 如果任务程序需要参数，请在向导的最后屏幕中选择“打开任务的高级属性”复选框，然后单击“任务”选项卡，并在键入任务路径后，在“运行”框中键入参数。
  • 计算机的系统日期和时间要确保无误。“计划任务”程序 依靠该信息来运行计划的任务。双击任务栏上的时间，可以检查或更改日期和时间。


修改计划的任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 右键单击要修改的任务，然后单击“属性”。
    • 要更改想运行的程序，请在“运行”框中键入任务的路径，或者单击“浏览”。
    • 要更改任务的计划，请单击“计划”选项卡。
    • 要自定义任务的设置，请单击“设置”选项卡。

注意

  • 如果任务程序需要参数，请在键入任务路径后，在“运行”框中键入参数。
  • 如果任务程序的路径包括空格，将整个任务路径放在一对双引号中间。
  • 计算机的系统日期和时间要确保无误。“计划任务” 依靠该信息来运行计划的任务。双击任务栏上的时间，可以检查或更改日期和时间。


删除计划的任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 右键单击要删除的任务，然后单击“删除”。

注意

  • 删除计划的任务只从计划列表中删除计划。并没有将程序文件从硬盘中删除。
  • 按 DEL 键也可以删除所选任务的计划。


停止当前运行的计划任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 右键单击要停止的任务，然后单击“结束任务”。

注意

  • 如果计划任务启动了另一个程序，该命令只停止最初的计划任务，而不停止第二个计划任务。
  • 要重新启动任务，右键单击该任务，然后单击“运行”。


立即运行任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 右键单击要启动的任务，然后单击“运行”。

注意

  • 单击“文件”菜单中的“结束计划任务”，可以结束任务。
  • 如果该运行的任务没有运行，请单击“高级”菜单上的“查看日志文件”，查看日志文件以查明原因。


查看过去计划任务的日志

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开已计划的任务窗口。
  2. 单击“高级”菜单的“查看日志文件”。


查看远程计算机上的计划任务

  1. 双击“网上邻居”图标。
  2. 双击要查看其计划任务的计算机。
  3. 双击“计划任务”文件夹。

注意

  • 要在运行 Windows NT 的远程计算机上查看任务，您必须是该远程计算机上的管理员。
  • 要在运行 Windows 95 或更高版本的远程计算机上编辑任务，该远程计算机必须安装远程注册软件并共享 x$ share（其中 x 是“计划任务”文件夹所在的硬盘）。运行 Windows 95 或更高版本的计算机还必须特别列出具有远程注册访问权限的用户帐号。双击“控制面板”中的“密码”图标，可以指定对运行 Windows 的计算机拥有远程注册访问权限的用户。


临时关闭所有计划任务

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开已计划的任务窗口。
  2. 单击“高级”菜单上的“暂停执行计划任务程序”。

    如果正在运行其他程序（如游戏）或安装软件，而不想同时运行计划的任务，则该操作非常有用。

注意

  • “计划任务”程序暂停时，在任务栏上，“计划任务”程序图标将显示为： 图像：在计划任务的图标上有个 'x' 。
  • “计划任务”程序 暂停时，正在运行的任务将停止运行，直到它们下一次计划的时间来到。
  • 要重新开始所有任务的计划，请单击“高级”菜单上的“继续执行计划任务程序”。


关闭“计划任务”程序r

关闭“计划任务”程序

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开“计划任务”窗口。
  2. 单击“高级”菜单上的“终止使用计划任务程序”。

注意

  • 关闭“计划任务”程序时，计划的任务将不再运行，并在下次启动 Windows 时将不再自动启动“计划任务”程序。


“计划任务”程序疑难解答

如果该运行的计划任务却没有运行，请右键单击任务列表，然后单击“属性”。在“任务”选项卡上，确认“启用”复选框已被选中。在“计划”选项卡上，确认计划已正确设置。

如果任务程序运行不正常，则需要提供任务程序的命令参数。要查找有关程序及其参数的详细信息，请尝试以下操作：

  • 如果程序有联机帮助，请参阅该帮助。
  • 在命令提示符下键入以下命令，其中 program 是程序的名称：
    program /?


在 Windows NT 上使用“计划任务”程序

在 Windows NT 上，还可以使用 at 命令自动计划任务。（at 命令在 Windows 95 或更高版本上不能使用。）

“计划任务”程序与 at 命令不同，但二者可以一起工作。用 at 命令计划任务时，at 命令将出现在“计划任务”窗口的任务列表中。

也可以使用“计划任务”程序修改用 at 命令计划的任务的属性。但是，如果这样做了，必须一直使用“计划任务”程序访问该任务。不能再用 at 命令访问该任务。

要指定运行通过 at 命令计划的任务的用户帐号，请双击“我的电脑”，双击“计划任务”文件夹，然后单击“高级”菜单上的“AT 服务帐号”。


与 Windows 95 Plus! System Agent 一起使用“计划任务”程序

Windows 95 Plus! 中有一个称作 System Agent 的任务计划工具。如果在安装 Internet Explorer 4.0 时已经安装了 Plus!，则 System Agent 将自动更新为“计划任务”程序。以前使用 System Agent 计划的所有任务都将转化为“计划任务”程序任务，并显示在“计划任务”程序 的任务列表中。

“计划任务”程序以 System Agent 相同的方式使用 Plus! 应用程序。例如，使用 磁盘空间管理 3 升级或压缩驱动器之后，“计划任务”程序将安排“压缩代理”按一定时间间隔运行，就好象 System Agent 自动安排了“压缩代理”一样。

尽管 System Agent 已升级为“计划任务”程序，在 Windows 95 Plus! 帮助文件中仍有 System Agent 的“帮助”。但该“帮助”不再有效。


设置 At 服务帐号（仅限于 Windows NT）

  1. 双击“我的电脑”，再双击“计划任务”文件夹，从而打开已计划的任务窗口。
  2. 单击“高级”菜单上的“AT 服务帐号”。
  3. 单击“系统帐号”或“该帐号”，然后键入运行用 at 命令计划的任务时所用的用户帐号。
  4. 如果单击了“该帐号”，请在“密码”和“确认密码”框中键入该帐号的密码。

注意

  • 如果单击“系统帐号”，at 命令任务将使用 LocalSystem 帐号运行，该帐号具有管理员权限。
  • 指定的帐号必须具有足够的权限，能够运行所有用 at 命令安排的任务。例如，如果安排只能由管理员运行的程序，您指定的帐号必须是管理员帐号。
  • 要获得有关项目的“帮助”，请单击对话框右上角的 图像：问号按钮 ，然后单击该项目。


版权信息

Microsoft Windows 98

本文档中的信息如有变动，恕不另行通知。此处所涉及的公司名、产品名、人名、人物和/或数据若非特殊声明，均属虚构，决不代表任何真正的个人、公司、产品或事件。遵守所有已生效的著作权法是用户的义务。未经 Microsoft 公司明确的书面许可， 不得为任何目的、以任何手段（电子或机械）复制或传播本文档的任何部分。

本文档可能涉及 Microsoft 的专利、专有产品、商标、版权或其他知识产权，除非得到 Microsoft 公司的明确书面许可协议， 本文档不授予使用这些专利、专有产品、商标、版权或其他知识产权的任何许可协议。

© 1998 Microsoft Corporation. All rights reserved。

Microsoft、ActiveX、BackOffice、MS、MS-DOS、MSN、Windows 以及 Windows NT 是 Microsoft 公司在美国或其他国家（地区）的注册商标或商标。

本文档所涉及的其他产品和公司名可能是各自相应所有者的商标。


启动“计划任务”程序

如果计算机运行 Windows 95 或更高版本，单击“开始”，指向“程序”，指向“附件”，指向“系统工具”，然后单击“计划任务”。

如果计算机运行 Windows NT，请单击“开始”，指向“程序”，指向“管理工具”，然后单击“计划任务”。