Your Guide to Microsoft Technical Support

Upon availability of the final retail product, Microsoft will provide full technical support for Microsoft Internet Explorer 5.0.

Microsoft cannot provide formal product support for this beta version. However, we have provided a few online support resources to help you work with Internet Explorer 5.0 Beta 1. Please visit:
http://www.microsoft.com/sitebuilder/ie/iefeedback.htm


Direct Assistance Engineer


Choosing the support option that’s right for you


Other Microsoft Services


Self-Help Tools


Self-Help Tools Other


Microsoft Technical Support Worldwide