Microsoft FrontPage Express 简介

问号 Microsoft
FrontPage Express
帮助
Microsoft FrontPage Express 简介

FrontPage Express 是一种能够让您充分使用 HTML 强大功能的网页编辑器。使用 FrontPage Express 可以按照 HTML 的格式创建网页并编排格式。由于使用的是“所见即所得(WYSIWYG)”的工作方式，因此您所看见的也是网页实际显示时的格式和版面。

FrontPage Express 也可使用“自定义文件夹”向导功能（在“我的电脑”中的“查看”菜单上）。因此您可以轻松地自定义文件夹的显示效果。

借助 FrontPage Express 简便易用的特性，您可以创建复杂多样且功能强大的网页。例如，您可以：

  • 从工具栏上的列表中使用 HTML 标志，而不需要手工键入。

  • 选择文本或图形、通过单击工具栏按钮来设置格式和对齐方式。

  • 从珍藏的收集品（FrontPage Express 不包含的收集内容）中插入已创建或剪辑的图像。

  • 直接从 Web 上打开已有的网页（如果您已经安装了 Microsoft Web 发布向导），也可以直接从本机或网上的文件中打开网页。

  • 可以将您所做的工作直接保存到 Web 上（使用 Microsoft Web 发布向导）或文件中。

  • 添加字幕（滚动的文字）。

FrontPage Express 在一个很小的软件包中提供众多 Microsoft FrontPage Editor 的功能。它使您不必学习创建网页的新程序或方法，就可以方便地使用 FrontPage。FrontPage 还提供了 FrontPage Editor 和 FrontPage Explorer 的一些新增功能。


使用 Web 样式自定义文件夹

现在，您在网页上能做的一切，在硬盘上的任何文件夹中均可实现！

以 Web 风格显示计算机中的内容时，可以使用“自定义文件夹”向导（位于“我的电脑”的“查看”菜单上）来自定义文件夹的背景。更令人激动的是，使用该向导程序及 FrontPage Express 可将任何文件夹转换为网页。

如果文件夹是以网页的形式显示的，使用 FrontPage Express 可以添加与 Outlook Express 或其他组件的链接、插入 ActiveX 控件、自定义字形和字号或添加水印。这些功能可以用于自娱自乐，也可以用于在自定义的共享文件夹中共享最新的商业信息。无论是哪种情况，您都可以创建满足自身要求的文件夹。


FrontPage Express 高级功能

借助 FrontPage Express 简便易用的特性，您可以创建复杂多样且功能强大的网页：

  • 添加背景色及水印。

  • 使用 WebBot 组件无需进行复杂的编程即可添加丰富的功能。WebBot 是网页上的“动态对象”，当网页作者在 Web 服务器上保存网页或当用户查看网页时将运行该对象。FrontPage Express 包含 WebBot，WebBot 可以向网页添加时间戳、包含以及搜索功能（要获得全套 WebBot，诸如表格处理、导航栏等，您可以升级到 Microsoft FrontPage。）。

  • 使用 ActiveX 控件使您的网页功能更强大。

  • 使用“HTML 标记”命令插入可用的新 HTML 标记。

  • 直接在网页中查看和编辑所有 HTML 标记。通过 FrontPage Express 中的颜色代码能够很容易地区分标记与内容。


升级到 FrontPage

升级到 Microsoft FrontPage

如果想要创建更高级的网页，可以很轻松地从 Microsoft FrontPage Express 升级到 Microsoft FrontPage。由于 FrontPage Express 是以 Microsoft FrontPage 的 FrontPage Editor 为基础设计的，因此这两个产品在外观上极其相似。

Microsoft FrontPage 是为网页创作者和 Web 站点管理员提供的一套完整的软件包。从简单地查看和编辑(FrontPage Express)网页到无限制地编辑、查看和进行 Web 管理，FrontPage Express和 FrontPage 的完美结合都将充分满足企业内各个层次的需求。

FrontPage 通过以下组件为用户提供了完整的 Web 创作环境：

  • FrontPage Editor，用于创建、查看和保存 HTML 页。它包括多种模板、向导和 WebBots，以便您可以轻松地创建功能强大的网页。由于 FrontPage Editor 同时也是一个小巧的浏览器，因此您可以使用它导入 Internet 或 Intranet 上的任何网页。

  • FrontPage Explorer，用于管理、查看和控制 Web 站点。您可以在自己的个人计算机上开发和测试 Web 站点，然后将整个站点复制到 Web 服务器上。也可以用 FrontPage Explorer 作为个人 Web 服务器，直接从您的桌面上运行 Web 站点，另外还可以将它作为 Intranet 的一部分或者作为 World Wide Web 上的一个公开站点。