WinWasher

WinWasher is a service that removes unwanted files from the system. Copy the program file to the computer to be cleaned and install it with the command

WinWasher.exe /install

After that you might want to make it start automatically at system startup with the services applet. You can create an INI file called WinWasher.ini in the same folder as the program file (see also sample.ini):

[Options]
Interval=15
Cleanup=00:00:00
Verbose=1

In this example, WinWasher will wake up every 15 minutes and reread the INI file. Cleanup specifies the time of day, when the filesystem will be cleaned. When Verbose is set to 1 you will get verbose messages, with 0 just a few. The values printed above are assumed whenever no INI file is found.

If there is no INI file in the same folder, the program tries to read the path to it from the registry:

Branch HKEY_LOCAL_MACHINE\Software\WinWasher Key Folder

This way you can create one central INI file on a network drive to be used by all computers on the network. Make sure that the service is assigned to a user account, that has read and write access to the folder containing the INI file. You could just create a user for this purpose.

To decide which files belong on the computer and which don't, a reference list is needed. This list is read from the file

<COMPUTERNAME>.txt

in the same folder as the INI file, i.e. either the program folder, or a folder on the the network.

If there are several computers with exactly the same content, you don't have to keep lists for each of them. Simply add an alias section to the INI file. The entries

[Alias]
r01401=r014
r01402=r014
r01403=r014

make WinWasher use the file r014.txt for the computers named r01401, r01402 and r01403.

If the reference file doesn't exist, it will automatically be created. All files on all local drives are simply listed in the text file. After that you might want to edit it, for example by removing filenames of currently existing temporary files, browser history and cache files, user profiles etc.. All the files you remove from the list will be deleted the first time WinWasher cleans up and again whenever they appear, along with all other files not on the list. Whenever you change the system to be cleaned, for example by installing a new program, you should delete the reference list and restart the service or update the list manually by adding the new files. Otherwise you will loose the new program at the next cleanup. If you remove all files from a drive from the list, this drive will be skipped. No files will be deleted there.

All actions taken are logged to

<COMPUTERNAME>.log

again in the same folder where the INI file is kept.

Another section in the INI file will suppress all messages about some folders, for example

[Quiet]
Count=4
Item0=C:\Temp
Item1=D:\Temp
Item2=C:\RECYCLER
Item3=D:\RECYCLER

If you're running WinWasher on a couple of computers and want to upgrade to a new version, you can use the Perl script update.pl coming with the program. You will need a Perl distribution and the command line tool Netsvc.exe from the Ressource Kit to run it. You will also need to change two variables in the script: the list of computer names and the path to windows on them.


Informations

Author | Fabian Mörchen
Compiler | Delphi 5.0
Status | Freeware
Informations | www.mybytes.de
Contact | fabian@mybytes.de

This software is freeware so don't hesitate to copy it and pass it on to your friends. Still all rights are reserved, so you may not distribute this software without any licensing agreement. The software is provided as is and I will take no responsibility if anything goes wrong. Please report any bugs.