Novità di Internet Explorer Administration Kit

È possibile utilizzare il programma di personalizzazione di Internet Explorer e il Gestione profili di IEAK, entrambi inclusi in IEAK, per personalizzare, distribuire e gestire Internet Explorer. Per ulteriori informazioni sui contenuti di IEAK, vedere Contenuto di Internet Explorer Administration Kit.

Di seguito sono riportate alcune delle nuove funzioni chiave di IEAK.

  • Personalizzazione e distribuzione del software client di MSN Messenger Service. Se si intende utilizzare il nome e il logo della propria organizzazione, è possibile includere il client MSN Messenger Service nel pacchetto ed eseguire la marcatura del client di Messenger Service. Il programma di installazione per il client di Messenger Service personalizzato è contenuto nel file eseguibile relativo. È possibile includere il client di Messenger Service personalizzato come componente nell'installazione di Windows Update o distribuirne il programma di installazione separatamente da Internet Explorer.
  • Scelta del momento in cui installare i componenti personalizzati. È possibile scegliere di installare un componente personalizzato prima o dopo l'installazione di Internet Explorer o soltanto a installazione ultimata. È inoltre possibile specificare che il componente è installato, al termine del riavvio del sistema. Questo tipo di controllo è utile in caso si intenda inserire gli aggiornamenti del sistema in uno o più componenti personalizzati. Per ulteriori informazioni, vedere Inserimento di aggiornamenti Microsoft in componenti personalizzati.
  • Scelta dei criteri da configurare. I criteri di sistema e le restrizioni che è possibile impostare nel programma di personalizzazione di IEAK e gestire successivamente in Gestione profilo di IEAK possono essere configurati per gli utenti dei sistemi operativi Windows 95, Windows 98 e Windows Millennium Edition. Tuttavia, per gli utenti che non dispongono dei privilegi di amministrazione sulle piattaforme Windows NT o Windows 2000 è possibile configurare soltanto un sottoinsieme di questi criteri di sistema e restrizioni. In IEAK è possibile scegliere quali criteri visualizzare in base alla piattaforma e ai privilegi dell'utente applicabili a questo particolare pacchetto. Per ulteriori informazioni, vedere Amministrazione di Microsoft Internet Explorer in Windows 2000.
  • Installazione dei pacchetti che richiedono privilegi di amministrazione, a riavvio del sistema ultimato. È possibile personalizzare il pacchetto per conservare i privilegi di amministrazione, a riavvio del sistema utlimato. È inoltre possibile distribuire il pacchetto manualmente oppure come parte di un metodo di distribuzione automatico, ad esempio Systems Management Server (SMS). In entrambi i casi, non è necessario che gli utenti abbiano i privilegi di amministratore la volta successiva che accederanno al sistema.
  • Rimozione dei collegamenti e delle icone di Outlook Express, della Connessione guidata di Internet e dei canali. È possibile includere Outlook Express nel pacchetto e configurare l'installazione in modo da impedire la visualizzazione dei collegamenti sul desktop, sul menu Avvia o sulla barra Avvio veloce. È altrettanto possibile rimuovere i collegamenti dalla barra Avvio veloce ai canali o alla Connessione guidata Internet.
  • Creazione di pacchetti per Windows a 32 bit. Questa versione di Internet Explorer Administration Kit crea pacchetti browser personalizzati solo per piattaforme Windows a 32 bit. Se si intende creare un pacchetto personalizzato per le piattaforme Windows a 16 bit o UNIX, usare Internet Explorer Administration Kit 5.0x.

Per ulteriori informazioni sulle novità di Internet Explorer 5.5, vedere la Guida in linea del prodotto.


Contenuto di Internet Explorer Administration Kit

Microsoft Internet Explorer Administration Kit (IEAK) contiene programmi e strumenti che consentono di personalizzare e amministrare Internet Explorer.

È possibile:

  • Configurare il browser e gli altri componenti Internet in modo da soddisfare le esigenze della società o dell'utente. Ad esempio, è possibile personalizzare la barra dei collegamenti e l’elenco Preferiti per promuovere la propria società o fornire informazioni utili.
  • Configurare le impostazioni prima dell’installazione in modo da non dovere impostare le opzioni su ciascun computer.
  • Personalizzare il programma di installazione in modo che richieda un minore intervento e installi i programmi personalizzati.
  • Per gli amministratori delle reti intranet, controllare quali impostazioni possono essere modificate dai dipendenti per assicurare che le impostazioni relative alla protezione, alla connessione e ad altre importanti funzioni siano conformi agli standard della società.

Prima di utilizzare Microsoft Internet Explorer Administration Kit, è opportuno decidere quali impostazioni personalizzare, preparare tutte le immagini e i file personalizzati necessari e pianificare il metodo di distribuzione. È inoltre consigliabile fare pratica nell’uso dei programmi e degli strumenti di Microsoft Internet Explorer Administration Kit.

Per ulteriori informazioni sulla nuova versione di vedere Novità di Internet Explorer Administration Kit

Strumenti di Internet Explorer Administration Kit

Programma di personalizzazione di Internet Explorer

Il programma di personalizzazione è costituito da cinque fasi durante le quali vengono visualizzate diverse schermate che consentono di creare pacchetti di Internet Explorer personalizzati.

Gestione profili di IEAK

Gestione profili consente all’utente di modificare automaticamente le proprie impostazioni e restrizioni, dopo che Internet Explorer è stato installato. Per ulteriori informazioni, vedere Come utilizzare Gestione profili di IEAK.

Kit di strumenti di IEAK

Il kit di strumenti di IEAK contiene strumenti, programmi e file di esempio utili, quali il programma IExpress, i file di esempio e aggiuntivi per l'abbonamento, immagini e altri strumenti. Questi elementi si trovano nella cartella \Toolkit di IEAK.

Guida in linea di Internet Explorer Administration Kit

Per trovare gli argomenti desiderati, utilizzare le funzioni Indice, Sommario e Ricerca. È possibile stampare un "libro" o un gruppo di argomenti correlati dalla funzione Sommario.


Requisiti hardware e di sistema

Requisiti per Internet Explorer

Per i requisiti hardware e di sistema per una versione specifica di Internet Explorer, vedere il relativo file leggimi.

Requisiti hardware ulteriori per la creazione di pacchetti di installazione personalizzati

Prima di avviare il programma di personalizzazione di Internet Explorer, controllare lo spazio disponibile su disco dell'unità di destinazione del pacchetto personalizzato. L'unità di destinazione può trovarsi sullo stesso computer che si sta usando per eseguire il programma di personalizzazione.

Prima di creare pacchetti IEAK, aggiungere ai requisiti di sistema di Internet Explorer quanto segue:

  • In base al numero di componenti presenti nel pacchetto di installazione, saranno necessari fino a 100 MB di spazio su disco.
  • Per ogni pacchetto personalizzato creato, possono essere necessari altri 100 MB di spazio su disco. Un pacchetto creato per un tipo di supporto diverso, ad esempio CD-ROM, viene considerato come un pacchetto a parte.

Requisiti IEAK

È necessario creare i pacchetti IEAK con computer che utilizzano Internet Explorer 5.5 e un qualsiasi sistema operativo Windows a 32 bit, ad eccezione di Windows NT3.51.

I computer che utilizzano Windows NT 4.0 devono aver installato anche Service Pack 3 o successivo.

Questa versione di Internet Explorer Administration Kit crea pacchetti browser personalizzati solo per piattaforme Windows a 32 bit. Se si desidera creare un pacchetto personalizzato per le piattaforme Windows a 16 bit o UNIX, usare Internet Explorer Administration Kit 5.0x. Se si desidera creare un pacchetto personalizzato per Macintosh, usare Internet Explorer Administration Kit per Macintosh.

È possibile installare sullo stesso computer sia la versione 5.0 che la versione 5.5 di Internet Explorer Administration Kit, in directory separate.

Requisiti per gli utenti

Se gli utenti usano WindowsNT o Windows2000, sarà necessario disporre di privilegi amministrativi su tali computer al momento del primo avvio dopo l'installazione o la disinstallazione di Internet Explorer dal pacchetto IEAK.

Per ulteriori informazioni sull'installazione di Internet Explorer sui computer degli utenti, vedere Passaggio da altre versioni o prodotti e Amministrazione di Microsoft Internet Explorer in Windows 2000.


Ridistribuzione di Internet Explorer

IEAK consente di ridistribuire Internet Explorer come parte del processo di installazione di un altro programma. Uno sviluppatore indipendente di software (ISV, Independent Software Vendor), può ad esempio personalizzare l'installazione di Internet Explorer affinché il programma personalizzato offra una serie di scelte per l'installazione e suggerimenti per gli utenti.

Per ridistribuire Internet Explorer, creare un pacchetto IEAK utilizzando il programma di personalizzazione di Internet Explorer. Scegliere l'opzione Provider di contenuti/Sviluppatore nella Fase 1 del programma di personalizzazione di Internet Explorer.

È possibile personalizzare l'aspetto e la funzionalità del browser e dell'installazione di Windows Update, se specificato nel contratto di licenza. Per controllare la funzionalità e l'esperienza dell'utente nell'eseguire l'installazione di Windows Update, è inoltre possibile utilizzare:

  • Installazione in modalità batch
  • Parametri di installazione della modalità batch di Intenet Explorer
  • Parametri di installazione della modalità batch di IExpress
  • File di informazioni per l’installazione (inf)


Panoramica per i provider di contenuti Internet

Microsoft® Internet Explorer Administration Kit (IEAK) permette ai provider di contenuti Internet (ICP) e ai produttori di software indipendenti (ISV) di creare browser personalizzati per gli utenti che già dispongono di un account Internet.

L'ICP può inoltre creare un browser personalizzato nel caso decida di usare il server di riferimento Microsoft come parte del pacchetto personalizzato. Il server di riferimento, che fornisce informazioni riguardo i provider di servizi Internet della propria zona, è gestito da Microsoft. È possibile connettersi ai server per l'iscrizione Internet utilizzando il server di riferimento.

Questo kit può essere utilizzato per eseguire le seguenti operazioni:

Personalizzazione del programma di installazione

  • Personalizzazione della visualizzazione del programma di installazione di Windows Update e configurazione delle modalità di installazione, ad esempio installazione tipica e minima.
  • Indirizzamento degli utenti ai server Internet per accedere alle versioni più recenti dei prodotti.
  • Determinazione della versione in lingua di Internet Explorer che si intende includere nel pacchetto di installazione. È necessario eseguire il programma di personalizzazione di Internet Explorer per ciascuna versione in lingua che si desidera creare.

Personalizzazione del browser e dei canali

  • Personalizzazione della pagina iniziale, della pagina di ricerca e della pagina del supporto in linea.
  • Caricamento dei collegamenti e delle cartelle in Preferiti.
  • Modifica della barra del titolo e del logo del browser.
  • Aggiunta di un canale o di una categoria di canali.

Uso del logo di Internet Explorer

Nel rispetto delle condizioni del contratto di licenza, è obbligatorio visualizzare il logo di Internet Explorer sui pacchetti, sui prodotti promozionali e sul sito Web. Per ulteriori informazioni sul logo e sulle immagini predefinite e per eventuali esempi, visitare ilsito Web di IEAK .

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.

Importante

  • La disponibilità di alcune funzionalità dipende dal contratto di licenza sottoscritto. Per ulteriori informazioni, consultare il contratto.


ICP: Preparazione dell'esecuzione della procedura guidata

Internet
Provider di contenuti

Preparazione dell'esecuzione della procedura guidata

Prima di eseguire il programma di personalizzazione di Internet Explorer, è necessario raccogliere le informazioni necessarie e creare bitmap personalizzate.

Determinazione dei requisiti iniziali della piattaforma

  • Verificare che il computer con il quale verrà creato il pacchetto e i computer nei quali verrà installato lo stesso soddisfino i requisiti hardware e di sistema.
  • Determinare i livelli di crittografia per il pacchetto browser. Per ulteriori informazioni sulla crittografia di Internet Explorer, vedere il sito Web IEAK.

Modalità di distribuzione

Decidere le modalità di distribuzione del pacchetto personalizzato, tramite CD, download, rete locale (LAN) o disco floppy. Al termine della creazione del pacchetto, sarà necessario copiare i file del browser personalizzato sul supporto selezionato. Se si è deciso di distribuire il pacchetto tramite download, sarà necessario spostare i file in una posizione appropriata sul server.

Se si è deciso di pubblicare il pacchetto browser su un server Internet, sarà necessario conoscere il percorso del server e l'URL dal quale scaricare i file. Quindi, creare una cartella sul server Web, ad esempio CIE, per pubblicare tutti i file e tutte le cartelle relative al browser personalizzato. Ad esempio, è possibile creare il seguente percorso del server su C:\Inetpub\Wwwroot\Cie. Se nomecomputer corrisponde alla directory principale virtuale del server Web, il relativo URL sarà http://nomecomputer/Cie/.

Come ottenere un certificato digitale

Se i file vengono distribuiti attraverso Internet o una rete intranet non appositamente configurata, è necessario eseguire alcune operazioni preliminari per la firma di determinati file, ad esempio i file personalizzati creati dal programma di personalizzazione di Internet Explorer e qualsiasi altro componente personalizzato. In base alle funzionalità di protezione del browser, prima del download di file non autenticati viene visualizzato un messaggio di avviso. Le firme digitali identificano l'origine dei programmi e garantiscono che il codice non è stato modificato dopo la firma.

Se si dispone di un certificato di distribuzione assegnato dall'autorità di certificazione, il programma di personalizzazione di Internet Explorer potrà firmare i file. Per preparare i certificati utilizzati da IEAK, importarli sul computer utilizzando la procedura guidata di importazione di Certificate Manager. Se si è ricevuto un file con estensione .spc, per avviare la procedura guidata di importazione di Certificate Manager fare doppio clic sul file .spc in Esplora risorse (Gestione risorse in Windows 95) o Risorse del computer.

Certificate Manager può essere aperto anche da Internet Explorer. Per eseguire questa operazione, scegliere Opzioni Internet dal menu Strumenti, fare clic sulla scheda Contenuto, quindi su Certificati. Fare clic su Importa per avviare la procedura guidata di importazione di Certificate Manager, quindi seguire le istruzioni sullo schermo.

Creazione della struttura sul computer utilizzato per la compilazione

Nome cartella | Descrizione
\CIE | Directory principale per i file creati da IEAK e per i file a cui fa riferimento il pacchetto personalizzato
\CIE\Bitmaps | File di bitmap personalizzate; saranno necessari file grafici per il browser personalizzato

Creazione della grafica appropriata

È possibile personalizzare le seguenti bitmap del browser. Spostare le bitmap nella cartella \CIE\Bitmaps prima di eseguire il programma di personalizzazione di Internet Explorer.

Gli sfondi e i pulsanti personalizzati vengono visualizzati esclusivamente su computer ad almeno 256 colori, ossia a 8 bit. Su computer a 16 colori, ossia a 4 bit, verranno visualizzate le bitmap sfondo e i pulsanti a bassa risoluzione.

  • Una bitmap sfondo per la schermata dell'esecuzione automatica del CD-ROM, nel caso di un pacchetto CD-ROM.

    Se si è deciso di distribuire il browser personalizzato su CD, sarà necessario creare le bitmap come parte della la schermata di avvio dell'esecuzione automatica che viene visualizzata dopo aver inserito il CD. Per creare questa bitmap, vedere Creazione di una bitmap per la schermata di avvio dell'esecuzione

  • Immagine personalizzata per i pulsanti del CD-ROM nel caso di un pacchetto CD-ROM.
  • Due bitmap personalizzate per l'installazione guidata di Windows Update se si desidera personalizzarne l'aspetto: una bitmap di 162 x 312 pixel per la parte sinistra della prima schermata del programma e una bitmap di 496 x 56 pixel per la parte superiore di tutte le altre schermate del programma.
  • Bitmap personalizzate della barra degli strumenti, che vengono visualizzate come sfondo per i pulsanti e i menu.
  • Due immagini bitmap statiche a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.
  • Due immagini bitmap animate a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.

    IEAK contiene due strumenti per creare e vedere in anteprima le bitmap animate personalizzate del browser. Per ulteriori informazioni sull'uso di questi strumenti, vedere Strumenti per le bitmap animate.

Raccolta degli URL per la pagina iniziale, di ricerca e di supporto tecnico.

Si consiglia di creare una pagina di supporto tecnico che verrà visualizzata in caso si verifichino problemi durante l'installazione del browser. Durante l'esecuzione del programma di personalizzazione verrà chiesto di immettere gli URL corrispondenti a queste pagine.

Note

  • Per ulteriori informazioni sull’installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


ICP: Fase 1 della procedura guidata: Raccolta informazioni

Internet
Provider di contenuti

Fase 1 della procedura guidata: Raccolta informazioni

In questa prima fase del programma di personalizzazione guidata di Internet Explorer, ai Provider di contenuti e agli sviluppatori indipendenti di software vengono richieste le seguenti informazioni.

  • Il nome della società e il codice di personalizzazione a dieci cifre incluso nell'altro kit di informazioni ricevuto da Microsoft.
  • La qualifica in base al contratto di licenza. È necessario specificare se si svolge l'attività di provider di contenuti o sviluppatore, provider di servizi o amministratore delle reti intranet.
  • La cartella di destinazione del pacchetto del browser personalizzato creato.
  • Lingua del pacchetto browser che si sta creando. Sarà necessario eseguire il programma di personalizzazione di Internet Explorer per ciascuna versione internazionale che si desidera creare.
  • Il supporto di distribuzione che si desidera utilizzare, ad esempio il CD-ROM o il download.
  • Le caratteristiche da personalizzare. Se ad esempio le modifiche da apportare al browser sono minime, non sarà necessario visualizzare tutte le schermate del programma di personalizzazione di IEAK.

Nota

  • Il programma di personalizzazione di Internet Explorer non funzionerà correttamente se non è installato Internet Explorer 5.5. Per ulteriori informazioni, vedere Requisiti hardware e di sistema.


ICP: Fase 2 della procedura guidata: Parametri di installazione

Internet
Provider di contenuti

Fase 2 della procedura guidata: Parametri di installazione

In questa fase della procedura di personalizzazione guidata di Internet Explorer, ai provider di contenuti viene richiesto ciò che segue.

  • Scaricare o aggiornare tutti i componenti Microsoft con Sincronizzazione automatica versione. È necessario eseguire il download di Internet Explorer, ma è possibile scegliere quali altri componenti scaricare.
  • Selezione di qualsiasi altro componente personalizzato che si desidera includere.

    È inoltre possibile specificare fino a 10 componenti aggiuntivi, che possono essere file eseguibili autoestraenti (exe) oppure file cab compressi.


ICP: Fase 3 della procedura guidata: Personalizzazione dell'installazione

Internet
Provider di contenuti

Fase 3 della procedura guidata: Personalizzazione dell'installazione

In questa fase del programma di personalizzazione di Internet Explorer, i provider di contenuti possono determinare l'aspetto e il funzionamento dell'installazione di Windows Update:

  • Personalizzare la schermata dell'esecuzione automatica del CD-ROM, se il pacchetto viene creato su CD-ROM.
  • Personalizzare le opzioni aggiuntive del CD-ROM, se il pacchetto viene creato su CD-ROM.
  • Personalizzare l'installazione guidata di Windows Update per Internet Explorer e Accesso a Internet. Tali impostazioni influiscono sull'aspetto del programma di installazione.
  • Specificare un numero massimo di 10 opzioni di installazione univoche e scelta dei componenti da includere in ciascuna di esse.
  • Specificare un numero massimo di 10 siti dai quali scaricare il pacchetto.
  • Specificare le modalità di aggiornamento dei componenti degli utenti.
  • Specifica della modalità di rilevamento dei componenti esistenti e dei componenti che gli utenti possono personalizzare.
  • Determinare la disponibilità dei componenti scaricati ma non aggiunti a tutti i pacchetti tramite la funzione Installazione su richiesta di Internet Explorer.
  • Specificare le informazioni sull'autorità di certificazione, in caso si disponga di un certificato digitale, in modo da poter firmare i programmi durante la creazione del pacchetto IEAK.

Note

  • Per ulteriori informazioni sull'installazione, vedereInstallazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.
  • Per visualizzare un diagramma di flusso delle operazioni che avvengono quando si usa il programma di personalizzazione guidata di Internet Explorer, vedere Creazione con IEAK dei pacchetti personalizzati.


ICP: Fase 4 della procedura guidata: Personalizzazione del browser

Internet
Provider di contenuti

Fase 4 della procedura guidata: Personalizzazione del browser

In questa fase del programma di personalizzazione guidata di Internet Explorer i provider di contenuti hanno la possibilità di personalizzare gli elementi che seguono.

  • Barra del titolo e bitmap sfondo della barra degli strumenti del browser. Quando si seleziona una bitmap, assicurarsi che i colori contrastino con quelli del testo.
  • Pulsanti della barra degli strumenti del browser. È possibile aggiungere pulsanti personalizzati alla barra degli strumenti per l'esecuzione di script e programmi.
  • Logo di Internet Explorer nell'angolo superiore destro del browser.
  • Pagine iniziali, di ricerca e del supporto in linea del browser.
  • Preferiti, cartelle preferiti e collegamenti della barra dei collegamenti.
  • Canali. È possibile aggiungere un canale o una categoria di canali, ossia una cartella di canali.
  • Pagina iniziale, ovvero la pagina che viene visualizzata quando il browser viene avviato per la prima volta.
  • Stringa agente utente. L'identificazione dell'agente utente è opzionale ed è utilizzata per tenere traccia dell'utilizzo del browser personalizzato.

Note

  • Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


ICP: Fase 5 della procedura guidata: Personalizzazione dei componenti

Internet
Provider di contenuti

Fase 5 della procedura guidata: Personalizzazione dei componenti

In questa fase del programma di personalizzazione guidata di Internet Explorer i provider di contenuti hanno la possibilità di personalizzare gli elementi che seguono.

  • Impostazioni predefinite dei programmi, come i programmi specifici di posta elettronica e i programmi per modificare i file HTML.
  • Marcatura di MSN Messenger Service, se si intende includere nel pacchetto l'installazione personalizzata del client di Messenger Service.
  • Elementi multimediali di MSN Messenger Service, se si intende apportare modifiche alla grafica, al contenuto promozionale o sonoro utilizzato in un'installazione personalizzata del client di Messenger Service.
  • Informazioni sull'account di MSN Messenger Service, se si intende modificare le impostazioni predefinite dell'account e le impostazioni per l'integrazione della posta elettronica di Passport in un'installazione personalizzata del client di Messenger Service.
  • Criteri di sistema e impostazioni, per preimpostare le opzioni Internet.


ICP: Distribuzione del pacchetto browser

Internet
Provider di contenuti

Distribuzione del pacchetto browser

Come impostazione predefinita, il programma di personalizzazione di Internet Explorer crea dei file che gli utenti possono scaricare da Internet. È inoltre possibile distribuire un pacchetto browser personalizzato su CD-ROM. Per un elenco completo dei supporti di distribuzione, vedere Selezione dei supporti.

File che è possibile scaricare

Qualora sia stato creato il pacchetto browser su un server Internet o intranet, è necessario impostare il sito Web in modo che utenti possano scaricare i file. Ad esempio, è possibile creare una pagina contenente le informazioni sul download e un collegamento al modulo di gestione dell'installazione, IE5setup.exe.

Se il pacchetto del browser è stato creato su un disco rigido o su un'unità di rete, sarà necessario spostare gli elementi che seguono sul server Internet o intranet:

  • La cartella che contiene la versione nella lingua desiderata e il contenuto della cartella stessa. Ad esempio, la cartella per la versione in inglese è denominata En, quindi è necessario spostare la cartella En e i file in essa contenuti. Questa cartella sarà contenuta in cartelle a seconda del tipo di supporto, ad esempio Download e piattaforma. L'unica piattaforma designata in Internet Explorer Administrative Kit 5.5 è "Win32"; per i client UNIX e Windows a 16-bit, usare Internet Explorer Administrative Kit 5.0x.
  • Il file Ie5sites.dat. Questo file indica il sito di download (o i siti) specificato quando è stato eseguito il programma di personalizzazione di Internet Explorer.

Per un'illustrazione, vedere Impostazione dei file per la distribuzione.

Per un diagramma di flusso dei file creati dal programma di personalizzazione di Internet Explorer, vedere Come IEAK genera i pacchetti personalizzati.

Firma dei pacchetti personalizzati

I browser Web dispongono di funzioni di protezione che consentono di evitare il download di programmi che potrebbero danneggiare il computer. A seconda del livello di protezione e della piattaforma, all'utente può essere impedito il download, oppure può essere inviato un messaggio di avvertimento, in relazione al download di programmi che non sono firmati digitalmente.

I file cab personalizzati creati dal programma di personalizzazione di Internet Explorer devono essere firmati, a meno che la zona intranet locale non sia stata preconfigurata con un livello di protezione basso. Tutti i componenti personalizzati distribuiti insieme al pacchetto browser per tali piattaforme devono essere firmati. Se si dispone di un certificato digitale, il programma di personalizzazione di Internet Explorer può firmare automaticamente tali file.

Note

  • La firma dei file cab e dei programmi personalizzati richiede: un certificato digitale e la specifica delle relative informazioni quando viene eseguito il programma di personalizzazione di Internet Explorer. Per ulteriori informazioni, vedere Firma dei programmi.
  • Potrebbe essere necessario modificare i caratteri maiuscoli o minuscoli per file inviati su un server FTP UNIX. Di seguito sono riportate le convenzioni da utilizzare per i sistemi operativi UNIX.
    • UNIX Solaris
      Se si utilizza un server FTP UNIX che rileva la differenza tra maiuscole e minuscole, sarà necessario verificare che il nome della cartella cab non sia formattato tutto in maiuscolo e che i file elencati di seguito siano in maiuscolo: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • AT&T UNIX
      Su un server FTP UNIX AT&T, tutti i nomi dei file devono essere i in maiuscolo.
    • IRIX UNIX (Silicon Graphics)
      I nomi dei file che seguono devono essere in maiuscolo: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. È inoltre necessario utilizzare un editor di testo per modificare i nomi dei file elencati in IE.CIF in base alla distinzione tra maiuscole e minuscole utilizzata nei file.

CD-ROM

Se il browser personalizzato per Windows 95 e Windows 98 è stato distribuito su CD, verrà visualizzata una schermata di avvio del programma di esecuzione automatica. Questo programma offre agli utenti la possibilità di scegliere tra l’installazione del browser personalizzato o la visualizzazione di ulteriori informazioni. Se la versione corrente di Internet Explorer è già installata, il programma di esecuzione automatica lo rileverà. Il browser viene visualizzato in quella che è conosciuta come modalità tutto schermo con caricato il file Start.htm.

Per ulteriori informazioni

Per informazioni più dettagliate sull'installazione di Windows Update, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet. Per un'illustrazione del processo di download, vedere l'illustrazione Installazione di Windows Update per Internet Explorer e Accesso a Internet.


ICP Come distribuire il client di Messenger Service

Internet
Provider di contenuti

Come distribuire il client di Messenger Service

Se MSN Messenger Service è stato incluso tra le opzioni di installazione, il programma di personalizzazione di Internet Explorer provvederà alla creazione di un pacchetto distinto per il download del client di Messenger Service personalizzato dal server Internet o intranet.

File che è possibile scaricare

Qualora sia stato creato il pacchetto client di Messenger Service su un server Internet o intranet, verificare di aver impostato il sito Web in modo che agli utenti sia permesso il download dei file. Ad esempio, è possibile creare una pagina dove rendere disponibili informazioni per il download e un collegamento al file dell'installazione (mmssetup.exe) per il client di Messenger Service.

Se il file mmssetup.exe è stato creato sul proprio disco rigido o su una unità di rete, è necessario spostarlo su un server Internet o intranet per ogni versione in lingua che si sta rendendo disponibile. Ogni versione in lingua crea una sottocartella nella cartella Messenger della directory di lavoro. Ad esempio, la versione inglese di mmssetup.exe si trova nella sottocartella En. Se è stato specificato un URL per il download durante la personalizzazione, creare all'interno della pagina dell'URL per il download un collegamento che punta a mmssetup.exe. Tutti i componenti necessari per la distribuzione di un client di Messenger Service personalizzato sono inclusi in questo eseguibile.

Firma dell'installazione del client di Messenger Service

Qualora sia stato incluso un certificato digitale utilizzato per la firma del pacchetto browser quando si esegue l'installazione guidata di IEAK, lo stesso certificato digitale verrà utilizzato per firmare l'installazione singola di mssetup.exe. Vedere Firme digitali e Firma dei programmi per ulteriori dettagli.

Client di Messenger Service come parte del pacchetto browser

Il client di Messenger Service personalizzato verrà installato come parte del pacchetto browser, se nelle opzioni di installazione, è stato specificato di includere MSN Messenger Service. Un pacchetto cab separato viene creato per il client di Messenger Service personalizzato e il client verrà incluso come componente quando viene eseguito ie5setup.exe. Vedere Distribuzione del pacchetto del browser per ulteriori dettagli sulla distribuzione del pacchetto completo del browser.

Client di Messenger Service e firewall

Qualora sia necessario specificare opzioni avanzate per il proxy per la messaggistica dietro un firewall, non specificare un URL per il download. Inoltre, è necessario editare un testo per generare un file di installazione per la preconfigurazione delle opzioni del proxy. Vedere Personalizzazione avanzata del client di Messenger Service per ulteriori dettagli.


Panoramica per i Provider di servizi Internet

Microsoft® Internet Explorer Administration Kit (IEAK) consente ai Provider dei servizi Internet (ISP) di creare un pacchetto per l'iscrizione contenente un browser e dei servizi Internet personalizzati in base alle esigenze dei propri utenti.

Il prodotto può essere utilizzato per eseguire le seguenti operazioni:

Personalizzazione del programma di installazione

  • Personalizzazione della visualizzazione del programma di installazione di Windows Update e configurazione delle modalità di installazione (come ad esempio l'installazione Tipica e Minima).
  • Suggerimenti agli utenti sui server Internet che consentono di accedere alle ultime versioni dei prodotti.
  • Estrazione di programmi aggiuntivi o di procedure personalizzate e di manutenzione tramite Internet Explorer.
  • Determinazione della versione in lingua di Internet Explorer che si intende includere nel pacchetto di installazione. L'esecuzione del programma di personalizzazione dovrà essere ripetuta per ciascuna lingua desiderata.

Personalizzazione del browser e dei canali

  • Personalizzare la pagina iniziale, la pagina di ricerca e la pagina del supporto in linea.
  • Caricamento collegamenti e cartelle in Preferiti.
  • Modifica della barra del titolo e del logo del browser.
  • Aggiunta di un canale o di una categoria di canali.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.

Controllo delle modalità di iscrizione al servizio

  • Implementazione di un pacchetto d'iscrizione ad un server: se l'utente non ha ancora sottoscritto il servizio, sarà possibile assegnargli un account pienamente funzionale utilizzando un server per l'iscrizione basato su HTML semplice da implementare.
  • Implementazione di un pacchetto d'iscrizione senza server: se un utente dispone già di un account per il proprio o per un altro servizio, sarà possibile modificare il sito dell'utente con un browser personalizzato utilizzando un processo semplificato che non prevede l'utilizzo di un server Questo tipo di pacchetto richiede all'utente di specificare alcune impostazioni finali al momento dell'installazione.

Per un esempio del processo di iscrizione, vedere Processo di iscrizione per l'ISP.

Uso del logo di Internet Explorer

Nel rispetto delle condizioni del contratto di licenza, è obbligatorio visualizzare il logo di Internet Explorer sui pacchetti, sui prodotti promozionali e sul sito Web. Il modello del logo per il sito Web, la confezione e i relativi prodotti promozionali è disponibile nella cartella di programma \<IEAK>\Toolkit\\Graphics\\Samples.

Importante

  • La disponibilità di alcune funzionalità dipende dal Contratto Microsoft sottoscritto. Per ulteriori informazioni, consultare il contratto.


ISP- Opzioni per l'abbonamento a Internet

Provider di servizi
Internet

Opzioni per l'abbonamento a Internet

Un Server per l'abbonamento a Internet (ISS) che automatizza l'aggiunta di nuovi clienti al relativo database di un ISP. Il server di abbonamento a Internet raccoglie le informazioni da ogni nuovo cliente, le aggiunge al database clienti dell'ISP e poi invia al computer del cliente un pacchetto di configurazione. Il pacchetto di configurazione contiene informazioni utili per la configurazione del browser affinché il cliente possa connettersi successivamente ai servizi offerti dal provider.

Per aggiungere un nuovo cliente al database dell'ISP, il server di abbonamento a Internet esegue le seguenti operazioni.

  • Connette il computer del cliente al server di abbonamento a Internet stabilendo una connessione HTTP.
  • Raccoglie dall'utente le informazioni per l'abbonamento.
  • Gestisce l'accettazione o il rifiuto da parte del cliente dei servizi dell'ISP.

Quando si usa IEAK, sono disponibili tre opzioni per effettuare l'abbonamento a Internet.

  • Abbonamento tramite server usando Connessione guidata Internet (ICW)
  • Abbonamento tramite server usando il browser in modalità a tutto schermo
  • Abbonamento senza server

L'abbonamento tramite server è preferibile, a meno che non si sia in grado di fornire un server per l'abbonamento, dato che è più semplice modificare le impostazioni sul server piuttosto che sul client. Delle due opzioni basate sul server, si raccomanda il metodo Connessione guidata Internet, dato che usa una interfaccia guidata standard che può essere personalizzata a seconda delle esigenze. I provider di servizi Internet possono specificare che i propri clienti usino Connessione guidata Internet come strumento per effettuare l'abbonamento ed eseguire la configurazione dei propri computer per i servizi Internet.

Per ulteriori informazioni, vedere Implementazione di un pacchetto per l'abbonamento tramite server.

Importante

  • Se si usa marcatura di un solo dischetto, non usare la modalità di abbonamento di Connessione guidata Internet se si prevede che alcuni utenti usino Internet Explorer 4.01 Service Pack 1 o precedente; invece, creare un pacchetto separato usando abbonamento in modalità tutto schermo per questi clienti.

Codice di esempio Toolkit IEAK

Soluzioni personalizzabili per l'abbonamento a Internet sono disponibili nel Toolkit IEAK. Il codice viene fornito nelle pagine ASP insieme al formato Perl, in modo da facilitare la creazione di un server per l'abbonamento Internet mediante Connessione guidata Internet per server Web su diverse piattaforme. Se si utilizza il codice di esempio, l'unica operazione che resta da compiere è l'integrazione del server per l'abbonamento ai sistemi di registrazione e di pagamento. Se si prende parte al Windows Referral Server Program il codice del server di abbonamento è simile sia per l'abbonamento IEAK sia per la registrazione al server Referral.

Nota

  • Dal momento che la soluzione IEAK include più file isp (Internet sign-up) per differenti esigenze dei clienti, è necessario includere il componente Binding dei dati HTML dinamico nel pacchetto personalizzato.

Creazione di più versioni personalizzate di Internet Explorer

Se si stanno creando più versioni personalizzate di Internet Explorer e diverse impostazioni rimangono le stesse in molte o in tutte le versioni, è possibile semplificare il processo. Per ulteriori informazioni, vedere Creazione di più versioni del browser.


ISP- Implementazione di un pacchetto per l'abbonamento tramite server

Provider di servizi
Internet

Implementazione di un processo per l'abbonamento tramite server

Il processo di abbonamento tramite server rende automatica la registrazione e imposta delle operazioni per gli utenti esistenti e per quelli nuovi. Questo processo usa un Server per l'abbonamento a Internet (ISS) per raccogliere informazioni da ogni utente. Il server per l'abbonamento aggiunge i dati al database dei clienti e invia un pacchetto di configurazione al computer dell'utente. Questo pacchetto configura il browser per le connessioni successive ai servizi Internet.

Agli ISP sono disponibili i seguenti metodi per l'abbonamento tramite server.

  • Connessione guidata Internet. Usando il programma di personalizzazione di Internet Explorer, è possibile specificare che i clienti usino Connessione guidata Internet (ICW) come strumento per effettuare l'abbonamento ed eseguire la configurazione dei relativi computer per i servizi Internet. Questo è il metodo consigliato, in quanto usa una interfaccia guidata standard che è possibile personalizzare a seconda delle necessità della società e degli utenti. La funzione di configurazione automatica di Connessione guidata Internet abilita alla configurazione delle impostazioni degli utenti che hanno già account Internet.
  • Modalità presentazione continua a tutto schermo. Tramite il programma di personalizzazione di Internet Explorer, è possibile specificare che le schermate create per il processo di abbonamento siano visualizzate modalità presentazione continua a tutto schermo.

Per un esempio del processo di abbonamento, vedere Processo di abbonamento all'ISP.

Creazione di un pacchetto personalizzato per la modalità di abbonamento tramite server

Per creare un pacchetto browser personalizzato che includa la modalità di abbonamento tramite server, specificare ciò che segue nella Fase 4 del programma di personalizzazione di Internet Explorer.

  • Scegliere , come metodo di abbonamento, Abbonamento tramite server usando Connessione guidata Internet o Abbonamento tramite server usando la modalità presentazione continua a schermo intero.
  • Il percorso alla cartella di lavoro che contiene i file per l'abbonamento personalizzati. Questi file abilitano gli utenti alla configurazione dei computer per la connessione al server di abbonamento.
  • Le informazioni del server per l'abbonamento, inclusi i parametri per Accesso remoto che abilitano l'utente a stabilire una connessione al server per l'abbonamento e l'URL della prima pagina per l'abbonamento in linea.
  • Le informazioni di personalizzazione di Connessione guidata Internet, inclusa la barra del titolo e le immagini personalizzate, se è stato selezionato Abbonamento tramite server usando Connessione guidata Internet.

Per assicurarsi della corretta installazione del pacchetto, verificare che nella cartella dei file di sottoscrizione personalizzati siano presenti:

  • Signup.htm - Questa pagina HTML fornisce informazioni sui servizi Internet del provider e deve includere un collegamento ad una appropriata pagina HTML sul server per l'abbonamento. È possibile personalizzare il file di esempio Signup.htm, che si trova nella directory IEAK \Reskit\ISP\Server\Client. Ad esempio, è possibile aggiungere dati per il supporto tecnico o includere collegamenti a file isp di abbonamento Internet.
  • Signup.isp - Questo file per l'abbonamento a Internet viene usato per il collegamento al server per l'abbonamento e viene referenziato da Signup.htm. Questo file deve inoltre contenere un collegamento all'URL del server script che genera i file ins di Impostazioni Internet. Utilizzando il programma di personalizzazione di Internet Explorer, è possibile modificare i parametri contenuti nel file per l'abbonamento. Il programma di personalizzazione di Internet Explorer genera inoltre altri file isp per il processo di abbonamento.
  • Tutti gli altri file per l'abbonamento - Tutti i file correlati, inclusi file grafici gif e jpg, devono essere salvati nella stessa cartella dei file personalizzati per l'abbonamento. Ad esempio, è possibile includere una versione personalizzata del file Install.gif.

Distribuzione di un pacchetto personalizzato per la modalità di abbonamento tramite server

Se si usa un metodo di abbonamento tramite server, il processo di abbonamento per il pacchetto browser personalizzato si svolge in tre fasi.

  1. Il computer dell'utente stabilisce una connessione con il server per l'abbonamento.
  2. Tramite una finestra di dialogo basata su HTML/HTTP le informazioni dell'utente vengono raccolte e aggiunte al database clienti.
  3. Il server per l'abbonamento invia al computer del cliente un pacchetto di configurazione. Il pacchetto include informazioni sulla configurazione e sulla marcatura. Include inoltre il numero di telefono locale affinché il cliente possa accedere al provider di servizi Internet.

    4. Notare che se le opzioni di protezione dell'utente sono impostate su Alta, il server per l'abbonamento non funzionerà perché i file necessari non potranno essere scaricati sul computer dell'utente.

Stabilire una connessione con il server per l'abbonamento

L'utente apre il programma per l'abbonamento, il quale avvia Internet Explorer, chiama il server per l'abbonamento e invia una richiesta iniziale di connessione. Quindi, il server per l'abbonamento esegue le procedure seguenti.

  • Accetta la richiesta dal computer dell'utente, ossia il client HTTP, e stabilisce una connessione HTTP.
  • Crea un archivio dati locale per contenere le informazioni immesse dall'utente.
  • Assegna un handle di sessione univoco, incorporato in tutte le successive transazioni HTTP con il client.

HTTP è un protocollo senza sessione, ma il server per l'abbonamento opera in modalità orientata alle sessione e usa l'handle di sessione per identificare tutte le transazioni associate al processo di abbonamento per uno specifico utente. Ad esempio, l'handle di sessione potrebbe essere una sequenza di numeri generati automaticamente che il database assegna alla transazione.

Raccolta delle informazioni per l'abbonamento dell'utente

Il server per l'abbonamento raccoglie le informazioni dell'utente da una sequenza di pagine HTML che guidano l'utente durante il processo di abbonamento, in modo simile a una procedura guidata di un programma Windows. Il server per l'abbonamento invia, su richiesta, le pagine al computer dell'utente. Il processo di abbonamento si conclude quando l'utente fa clic sull'appropriato pulsante nella pagina HTML finale per accettare o rifiutare il contratto di abbonamento.

È possibile scegliere il proprio formato e contenuto per le pagine HTML. Generalmente, ogni pagina HTML include ciò che segue.

  • Una scheda da compilare per l'utente.
  • Pulsanti di esplorazione che l'utente può usare per avanzare o tornare indietro fra le pagine.
  • Un pulsante che l'utente può scegliere per interrompere la sessione per l'abbonamento.

Ogni scheda HTML include controlli per la raccolta del testo inviato, per l'esplorazione fra le pagine e l'identificazione della sessione. La scheda raccoglie informazioni dall'utente e le invia al server per l'abbonamento quando l'utente fa clic sul pulsante di esplorazione. Inoltre, il server per l'abbonamento può convalidare i dati e inviare una pagina per la correzione nel caso in cui questi non siano corretti.

Nota

  • Accertarsi di salvare il file HTML nella directory corretta del server per l'abbonamento; il file Signup.isp include un collegamento a file del server per le versioni a 32 bit di Windows, mentre il file Signup.htm include un collegamento a file del server per le versioni a 16 bit di Windows.

Invio di un pacchetto di configurazione al computer dell'utente

Se l'utente accetta il contratto di abbonamento, il server per l'abbonamento crea un pacchetto di configurazione con un file ins, generato dal programma di personalizzazione di Internet Explorer, che include informazioni sull'utente e sui servizi Internet. Il file ins può contenere solo le impostazioni per la connessione, oppure può contenere impostazioni per la connessione, il browser e il programma di posta che include immagini.

Il server per l'abbonamento invia il pacchetto di configurazione al computer dell'utente usando il file ins che può essere generato sul momento, o semplicemente reindirizzato sul computer dell'utente. Quindi, il computer dell'utente può continuare il processo di installazione del pacchetto browser personalizzato. Se l'utente rifiuta o abbandona il contratto di abbonamento, il server per l'abbonamento indirizza il computer dell'utente a un file che annulla il processo di abbonamento.

Il pacchetto di configurazione include le seguenti informazioni.

  • Dati per la configurazione delle connessioni a Internet
  • Funzionalità dell'account dell'utente, inclusi e-mail e newsreader
  • Informazioni di marcatura, che personalizzano l'aspetto delle pagine per l'abbonamento della società
  • Il numero di telefono locale, in modo che l'utente possa accedere ai servizi Internet.

I primi due tipi di dati vengono creati come parte del server per l'abbonamento. Il programma di personalizzazione di Internet Explorer prepara i file ins per la marcatura. Alcune impostazioni, come Voce, Utente, Telefono, Dispositivo, Server, TCP/IP, non possono essere specificate nella procedura guidata, ma è necessario assegnarle manualmente nel file ins.

Se si desidera fornire diverse versioni "marcate privatamente" di Internet Explorer per differenti gruppi di utenti, è possibile gestire più serie di informazioni di marcatura che il server per l'abbonamento inserisce nel file ins. Ad esempio, è possibile personalizzare delle versioni con loghi, barre del titolo, preferiti, pagine di ricerca, pagine iniziali, collegamenti speciali, o siti per l'assistenza in linea differenti. Tutti i compact disc distribuiti agli utenti saranno uguali, ma saranno marcati differentemente quando l'utente effettua l'abbonamento ai servizi Internet.

Considerazioni sul server per l'abbonamento in relazione a Internet Information Server

Se si usa Internet Information Server come server per l'abbonamento, è necessario configurare il server per l'abbonamento Internet per fornire un Indirizzo IP DHCP al client quando questo si connette al server. Poiché il processo di abbonamento è relativamente breve, è possibile che il tempo di scadenza riservato all'indirizzo IP sia solo di pochi minuti.

Il processo di abbonamento deve essere usato tramite una connessione Accesso remoto da punto a punto, in modo che l'indirizzo IP allocato per il server DHCP non debba formalmente essere associato agli indirizzi IP.È responsabilità dell'ISP determinare se gli indirizzi IP DHCP saranno indirizzi Internet validi o indirizzi arbitrari.

Registrazione del tipo MIME di file ins

Affinché il client possa elaborare automaticamente il file ins, è necessario registrare un tipo MIME per il file ins con il server per l'abbonamento. Questo tipo MIME è stato designato "application/x-Internet-signup". Quando il client richiede un file ins, il server per l'abbonamento risponde con questo tipo MIME, che avvia l'applicazione di installazione associata sul client.

È necessario modificare manualmente i tipi MIME nel registro di configurazione. Per aggiungere il tipo MIME di file ins, utilizzare Regedt32.exe per aggiungere le informazioni seguenti.

Alla chiave
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\InetInfo\Parameters\MimeMap

aggiungere il valore
application/x-internet-signup,ins,,5

A questo valore non è associata alcuna stringa. Per ulteriori informazioni sull'impostazione dei tipi MIME, è anche possibile fare riferimento alla Guida in linea di IIS.

Nota

  • Affinché queste impostazioni del registro di configurazione diventino effettive, è necessario arrestare tutti i servizi di ISS dopo l'aggiunta del nuovo tipo MIME. Non è sufficiente arrestare e riavviare il servizio di publishing di pagine Web. In pratica, è probabile che i servizi FTP e Gopher non siano in esecuzione nella configurazione con server per l'abbonamento.


ISP- Impostazione di un server per l'abbonamento per la modalità presentazione continua a schermo intero

Internet
Provider di servizi

Impostazione di un server per l'abbonamento per la modalità presentazione continua a schermo intero

Un Server per l'abbonamento a Internet (ISS, Internet Sign-up Server) è un server HTTP (Hypertext Transfer Protocol) che automatizza l'operazione di aggiunta di nuovi utenti a un database dei clienti di un provider di servizi Internet (ISP). Il server per l'iscrizione Internet raccoglie le informazioni relative a ogni nuovo client, aggiunge le informazioni al database dei clienti dell'ISP e invia il pacchetto di configurazione al computer del cliente. Questo pacchetto di informazioni configura il browser Internet del cliente per usare i servizi dell'ISP.

Per un esempio del processo di iscrizione, vedere Processo di iscrizione alll'ISP.

L'ISS aggiunge un nuovo utente al database dell'ISP nel modo seguente.

  1. Stabilisce una connessione HTTP con il computer di un utente.
  2. Raccoglie le informazioni di abbonamento dall'utente.
  3. Gestisce l'accettazione o il rifiuto da parte del cliente dei servizi dell'ISP.

Per gestire questi compiti, è possibile adattare il codice di esempio fornito per Abbonamento Internet usando Connessione guidata Internet. Questo codice si trova nella cartella IEAK Toolkit, nella cartella \<IEAK>\Toolkit\ISP\Server\ICW\ e nelle relative sottodirectory.

Gli argomenti che seguono descrivono come sviluppare un processo di iscrizione mediante la Connessione guidata Internet. Nonostante quella descritta sia una soluzione sperimentata e intuitiva per l'abbonamento, e che è consigliata nella maggior parte dei casi, è possibile personalizzare il processo di abbonamento per meglio soddisfare le esigenze della propria società.

  • Iscrizione a Internet tramite Connessione guidata Internet
  • Requisiti di codifica delle schermate della Connessione guidata Internet
  • Uso dei file di esempio per l'abbonamento tramite Connessione guidata Internet
  • Creazione del file Icwsign.htm, delle pagine di errore e della pagina finale per l'abbonamento tramite ICW
  • Creazione delle schermate per l'abbonamento tramite ICW


Abbonamento a Internet con Connessione guidata Internet

Internet
Provider di servizi

Iscrizione a Internet tramite Connessione guidata Internet

Un ISP, può specificare Connessione guidata Internet (ICW) come strumento utilizzato dagli utenti per l'abbonamento e la configurazione dei computer per l'uso dei servizi Internet. È possibile utilizzare soluzioni basate su server per lo scambio delle informazioni con le schermate della Connessione guidata Internet. Questa funzione non è disponibile con la modalità di abbonamento senza server.

Soluzioni personalizzabili per Abbonamento a Internet si trovano nel Toolkit IEAK, nella cartella \<IEAK>\Toolkit\ISP\Server\ICW\ e nelle relative sottodirectory. Il codice viene fornito in ASP e in formato Perl, in modo da facilitare la creazione di un server per l'abbonamento mediante Connessione guidata Internet per i server Web su diverse piattaforme. Se si utilizza il codice di esempio, l'unica operazione che resta da compiere è l'integrazione del server per l'iscrizione ai sistemi di registrazione e di pagamento.

Se si prende parte al Windows Referral Server Program il codice del server di abbonamento è simile sia per l'iscrizione a IEAK sia per la registrazione al server Referral.

Per un esempio del processo di abbonamento, vedere Processo di abbonamento all'ISP.

Gli argomenti che seguono descrivono come sviluppare un processo di abbonamento mediante Connessione guidata Internet. Nonostante quella descritta sia una soluzione sperimentata e intuitiva per l'abbonamento, e che è consigliata nella maggior parte dei casi, è possibile personalizzare il processo di abbonamento per meglio soddisfare le esigenze della propria società.

  • Requisiti per la codifica delle schermate della Connessione guidata Internet
  • Uso dei file di esempio per Connessione guidata Internet
  • Creazione del file Icwsign.htm, delle pagine di errore e della pagina finale per l'abbonamento tramite ICW
  • Creazione delle schermate per l'abbonamento tramite ICW
  • Uso della configurazione automatica di ICW per l'abbonamento ad un ISP

Importante

  • Se si usa marcatura di un solo dischetto, non usare la modalità di abbonamento di Connessione guidata Internet se si prevede che alcuni utenti usino Internet Explorer 4.01 Service Pack 1 o precedente; invece, creare un pacchetto separato usando abbonamento in modalità tutto schermo per questi clienti.


Uso dei file di esempio per Connessione guidata Internet

Se si desidera simulare il processo di abbonamento prima della creazione di file personalizzati, è possibile usare i file di esempio del Toolkit IEAK, nella cartella del programma \<IEAK>\Toolkit\ISP\Server\ICW\. I file di esempio forniscono un'idea generale del funzionamento del processo di abbonamento e del tipo di informazioni che sarà necessario fornire.

Per eseguire tale operazione, procedere come descritto di seguito.

  1. Creare una directory denominata Signup nella directory wwwroot del proprio server.
  2. Copiare i file del ToolKit IEAK nella directory Signup.
  3. All'interno dei file modificare tutti i riferimenti in modo che puntino al server per l'abbonamento.
  4. Nel codice HTML della pagine del server per l'abbonamento, modificare tutti i riferimenti dell'ISP Acme usando il nome della propria società.
  5. Modificare l'ultima pagina del server per l'abbonamento affinché rispecchi le impostazioni del file ins.


Requisiti di codifica e accesso per l'abbonamento mediante la Connessione guidata Internet

Internet
Provider di servizi

Requisiti di codifica delle schermate della Connessione guidata Internet

Il sistema per l'abbonamento mediante la Connessione guidata Internet di IEAK si basa sull'idea che un server per l'abbonamento Internet si presenta e funziona come una procedura guidata standard di Windows. Anche se la Connessione guidata Internet si avvale della potenza e della flessibilità HTML, non utilizza però lo stesso tipo di formato.

Le pagine HTML della procedura guidata utilizzano i caratteri e i colori Windows e devono soddisfare i requisiti di accesso. A meno che non venga specificato diversamente, le pagine HTML della procedura guidata non possono contenere elementi HTML particolari come tabelle con i bordi visibili, immagini o elementi di ancoraggio. Il formato solo testo e gli elementi dei moduli, dove richiesti, sono invece consentiti. Per il layout è inoltre possibile utilizzare le tabelle con i bordi invisibili.

Per supportare i colori di sistema degli utenti, è necessario che tutte le pagine HTML, fatta eccezione per Icwsign.htm, non contengano alcun attributo per i colori e i caratteri, a meno che non sia specificato altrimenti. Lo stile dei caratteri e i colori sono definiti dal programma di personalizzazione principale.

L'unico requisito per l'implementazione dei moduli all'interno delle pagine HTML è che questi utilizzino i parametri NAME negli elementi <FORM> definiti nelle specifiche. È possibile specificare nomi token per tutti gli altri elementi delle pagine HTML; questi elementi verranno quindi inviati al server per l'abbonamento.

Funzionalità dei pulsanti Indietro e Avanti

L'abbonamento mediante la Connessione guidata Internet presenta requisiti particolari che devono essere rispettati affinché i pulsanti Indietro e Avantidella Connessione guidata Internet funzionino correttamente.

Il codice di esempio del server per l'abbonamento incluso in IEAK è già conforme a questi requisiti.

Pulsante Indietro

Affinché il pulsante Indietro funzioni correttamente, occorre aggiungere un elemento FORM alla pagina del server per l'abbonamento che specifichi l'URL del pulsante. Per conservare i dati raccolti in precedenza durante la procedura di abbonamento, occorre aggiungerli all'URL utilizzato per il pulsante Indietro.

Di seguito è riportato l'elemento FORM richiesto perché il pulsante Indietro possa riportare l'utente alla pagina precedente del processo di inscrizione. S i noti che i dati vengono aggiunti all'URL nella coppia nome/valore:

<FORM NAME="INDIETRO"
      AZIONE="http://myserver/page2.asp"?nome=bob&cognome=smith&indirizzo=...">
</FORM>

Nota

  • L'elemento NAME e il valore corrispondente devono essere scritti in maiuscolo perché la Connessione guidata Internet fa distinzione tra maiuscole e minuscole.

Pulsante Avanti

Affinché il pulsante Avanti funzioni correttamente, occorre aggiungere un elemento FORM alla pagina del server per l'abbonamento che specifica l'URL del pulsante. Per passare i dati raccolti alla pagina successiva durante la procedura di abbonamento, occorre aggiungere dei campi nascosti del modulo alle pagine del server per l'abbonamento contenenti gli elementi dei dati raccolti nella schermata corrente e in quelle precedenti. L'URL di riferimento deve contenere il codice che raccoglie i dati della pagina precedente e visualizzare la pagina successiva della procedura di abbonamento.

Di seguito è riportato l'elemento FORM richiesto perché il pulsante Avanti possa portare l'utente alla pagina successiva della procedura di abbonamento:

<FORM NAME="AVANTI"
      AZIONE="http://myserver/page2.asp"?nome=bob&cognome=smith&indirizzo=...">
</FORM>

Requisiti di accesso

Per garantire che gli elementi della pagina siano accessibili utilizzando solo la tastiera, ogni elemento del modulo deve soddisfare i seguenti requisiti:

  • Una tasto di accesso (hotkey) deve essere associato ad un elemento del modulo. Utilizzare il parametro ACCESSKEY= di Internet Explorer nel tag <INPUT>. Il tipo di carattere del tasto di accesso deve essere sottolineato utilizzando il tag <U>. Le lettere b, f, g, n e o sono riservate per la Connessione guidata Internet e non possono essere utilizzate come tasti di accesso. Per ulteriori informazioni sul parametro ACCESSKEY, consultare il sito di MSDN Online Web Workshop.
  • Ogni elemento della pagina deve appartenere all'ordinamento dei tasti TAB della Connessione guidata Internet. Per fare parte dell'ordinamento dei tasti TAB della Connessione guidata Internet, gli elementi devono avere un ID univoco nel tag <INPUT>.
  • A ogni elemento deve essere associata un'etichetta. Per associare un'etichetta ai diversi tipi di input del modulo HTML, utilizzare il parametro LABEL= di Internet Explorer.

Esempio

Il seguente elemento del modulo del pulsante di opzione soddisfa i requisiti di accesso di Connessione guidata Internet:

<INPUT ID="option2"
       TYPE="radio"
       NAME="billing"
       VALUE="hour"
       ACCESSKEY="h"
       CHECKED
>
<LABEL for="option2">
    5 <U>H</U>ours per month for $10.
</LABEL>

HTML e requisiti di progettazione

Ogni pagina di Connessione guidata Internet dovrebbe presentare i seguenti elementi e rispettare le seguenti convenzioni.

Importante

  • Sono consentiti il formato solo testo e gli elementi dei moduli HTML. Non sono consentite immagini, collegamenti ipertestuali o barre di scorrimento.

Foglio di stile

Non specificare alcuno stile dei caratteri dei caratteri o attributi di colore. Questi attributi vengono impostati dalla procedura guidata principale. Se si utilizza il tag <TABLE> nelle pagine di errore, il tag dovrà includere il seguente stile:

<TABLE style="font: 8pt 'ms sans serif' buttontext"> </TABLE>

Elementi dei moduli richiesti

Questa pagina deve includere quattro elementi <FORM> HTLM per specificare le diverse proprietà della pagina:

Elemento | Requisiti
PAGEID univoco della pagina | Il valore NAME del modulo deve essere "PAGEID" (in maiuscolo). L’attributo ACTION del modulo deve essere un ID univoco che non corrisponde al PAGEID di qualsiasi altra pagina nella sezione ISP della procedura guidata (ad esempio, <FORM NAME="PAGEID" ACTION="page4"></FORM>).
Funzione del pulsante Indietro | Il valore NAME del modulo deve essere "INDIETRO" (in maiuscolo). L’attributo ACTION di questo modulo deve corrispondere all’URL assoluto della pagina precedente (ad esempio, ACTION="HTTP://signup/bin/page1.cgi"); in caso contrario, nessun dato verrebbe inviato a questa pagina.
Caratteristiche della pagina | Il modulo è identificato dal valore NAME "PAGETYPE" (in maiuscolo). Poiché questo è il frame standard con cui il provider di servizi Internet definisce l'intero spazio, l'attributo ACTION del modulo deve corrispondere a una stringa vuota (ad esempio, ACTION="").
Funzione del pulsante Avanti | Il valore NAME del modulo deve essere "AVANTI" (in maiuscolo). Questo è il modulo che contiene gli elementi veri e propri che verranno inviati al server per l'abbonamento dell'ISP. Non esistono restrizioni per i nomi token degli elementi <INPUT> all'interno del modulo. L'attributo ACTION per il modulo deve corrispondere all'URL assoluto dove andranno inviate le informazioni del modulo. L'URL di destinazione del proprio server deve contenere uno script che riceve i dati e quindi visualizza la pagina HTML successiva della procedura guidata.


Uso della configurazione automatica di Connessione guidata Internet per l'abbonamento all'ISP

Internet
Provider di servizi

Uso della configurazione automatica di ICW per l'abbonamento ad un ISP

La configurazione automatica di ICW abilita gli utenti che hanno già un account con un provider di servizi Internet ad avere le impostazioni di un account riconfigurate automaticamente. Quando gli utenti acquistano un nuovo computer, questa funzione è di aiuto per la configurazione della macchina per usare lo stesso account Internet usato su un precedente computer o su un computer al lavoro. È inoltre particolarmente utile nel caso in cui le impostazioni dell'account Internet si siano danneggiate. La funzione di configurazione automatica ripristina le impostazioni e l'utente deve solo fornire l'identificativo utente, la password e il server POP.

Nelle versioni personalizzate di Internet Explorer l'utente si connette al server per la configurazione automatica dal CD di Internet Explorer facendo clic su un collegamento nella pagina Icwsign.htm. Questo collegamento indirizza l'utente al server di configurazione automatica. Un volta stabilito il collegamento al server per l'abbonamento, è possibile chiedere all'utente il nome utente, la password e il server POP. Mediante queste informazioni è possibile inviare un file ins al computer dell'utente per la riconfigurazione dell'account.

Due metodi per il supporto della configurazione automatica di ICW

Le modalità possibili per il ripristino degli account utente mediante la configurazione automatica sono due.

  • Chiedere all'utente il nome utente, la password e il server POP. Queste informazioni sono sufficienti per ricreare il file ins, inviarlo all'utente e riconfigurare l'account. Se si temono abusi di questa funzione, si consiglia di richiedere il numero di carta di credito dell'utente e di controllare questo dato nel database di registrazione.
  • Archiviare i file ins con il resto delle informazioni dell'account dell'utente. Quando un utente si connette al server di configurazione automatica, può ottenere il file ins fornendo solo il nome utente e la password. Il server di configurazione automatica effettuerà delle ricerche sull'account dell'utente e invierà una copia del file ins originale. Come per la modalità precedente, se si teme un abuso di questa funzione, si consiglia di richiedere il numero di carta di credito dell'utente e di controllare questo dato nel database di registrazione.

Per impostare una configurazione automatica di ICW , fare riferimento a Requisiti di codifica delle schermate di Connessione guidata Internet e designare l'account, il login, la pagina e-mail dell'ISP, la pagina di selezione del POP e la pagina finale.


ISP: Implementazione di un pacchetto per l'abbonamento senza server

Provider di servizi
Internet

Implementazione di un pacchetto per l'abbonamento senza server

Il processo di abbonamento senza server consente agli utenti di installare la versione personalizzata di Internet Explorer utilizzando un CD, dischi floppy o file scaricabili. Il processo di installazione richiede agli utenti di immettere solo il nome, la password e le informazioni di connessione per configurare un account e connettersi a Internet tramite il browser personalizzato. Gli ISP possono personalizzare le impostazioni degli utenti senza che sia necessario l'uso di server per l'abbonamento. In questo caso infatti le informazioni di configurazione vengono distribuite con il pacchetto IEAK e quindi risiedono nel computer dell'utente. Il processo non è pertanto dinamico come l'abbonamento tramite server.

Non è possibile usare la modalità di abbonamento senza server per personalizzare Connessione guidata Internet.

Creazione di un pacchetto personalizzato per la modalità di abbonamento senza server

Per creare un pacchetto browser personalizzato che includa la modalità di abbonamento senza server, specificare ciò che segue nella fase 4 del programma di personalizzazione guidata di Internet Explorer.

  • Sottoscrizione abbonamento senza server come metodo di abbonamento.
  • Il percorso alla cartella che contiene i file di abbonamento personalizzati. Questi file abilitano gli utenti alla configurazione dei computer per i servizi Internet.
  • I parametri di Accesso remoto che abilitano gli utenti a stabilire una connessione per i servizi Internet.

Per assicurarsi della corretta installazione del pacchetto, verificare che nella cartella dei file di sottoscrizione personalizzati siano presenti i file seguenti.

  • Signup.htm - Questa pagina HTML fornisce informazioni sui servizi Internet e deve includere un collegamento al file ins che contiene le impostazioni di configurazione per il pacchetto browser personalizzato.
  • Tutti gli altri file per l'abbonamento - Tutti i file correlati, inclusi file grafici gif e jpg, devono essere salvati nella stessa cartella dei file personalizzati per l'abbonamento. Ad esempio, è possibile includere la versione personalizzata dei file Install.gif e Logohere.gif.

Distribuzione di un pacchetto personalizzato per la modalità di abbonamento senza server

Il pacchetto personalizzato include un file di configurazione denominato Install.ins che contiene le impostazioni specificate per il browser personalizzato. A differenza della modalità di abbonamento Internet con server, questo file ins non contiene informazioni di configurazione specifiche per l'utente. Quando l'utente avvia il programma di abbonamento, un collegamento contenuto nella pagina HTML in locale avvia il file ins. L'utente fornisce il nome utente, la password e le informazioni per la connessione. Quindi, questo file ins configura l'account dell'utente per la connessione a Internet usando il browser personalizzato.

Svantaggi dell'uso di un processo per l'abbonamento senza server

Poiché il file di configurazione viene distribuito con il pacchetto IEAK, non è possibile modificare dinamicamente le impostazioni utente sul server per l'abbonamento.

Il server per l'abbonamento ordinario raccoglie informazioni relative all'utente e predispone un file di configurazione personalizzato che viene scaricato sul computer dell'utente. Tramite il software del pacchetto di installazione di Internet Explorer è possibile usare il file di configurazione per configurare il computer.

Nella versione senza server il file di configurazione viene creato prima della fornitura del pacchetto ed è incluso nel pacchetto di installazione. Il file di configurazione non contiene quindi informazioni di configurazione specifiche per l'utente. Il file di configurazione Install.ins viene richiamato come un collegamento dall'interno della pagina HTML locale e imposta la maggior parte degli aspetti di Internet Explorer. Poiché il file di configurazione è incluso nel pacchetto di installazione, risiede nel computer dell'utente.

Per compensare questo svantaggio, l'opzione avanzata nel processo di abbonamento senza server usa un controllo ActiveX (installx.exe) per generare velocemente un file ins che contiene le informazioni relative all'utente. Internet Explorer usa quindi il file generato dal controllo ActiveX per configurare le impostazioni dell'utente.


ISP: Preparazione dell'esecuzione della procedura guidata

Internet
Provider di servizi

Preparazione dell'esecuzione della procedura guidata

Prima di eseguire il programma di personalizzazione di Internet Explorer, è necessario raccogliere le informazioni necessarie e creare bitmap personalizzate.

Determinazione dei requisiti iniziali della piattaforma

  • Verificare che il computer con il quale verrà creato il pacchetto e i computer nei quali verrà installato lo stesso soddisfino i requisiti hardware e di sistema.
  • Determinare i livelli di crittografia per il pacchetto browser. Per ulteriori informazioni sulla crittografia di Internet Explorer, vedere il sito Web di IEAK.

Modalità di distribuzione

Decidere le modalità di distribuzione del pacchetto personalizzato (tramite CD, download, rete locale (LAN) o disco floppy). Al termine della creazione del pacchetto, sarà necessario copiare i file del browser personalizzato sul supporto selezionato. Se si è deciso di distribuire il pacchetto tramite download, sarà necessario spostare i file in una posizione appropriata sul server.

Se si è deciso di pubblicare il pacchetto browser su un server Internet, sarà necessario conoscere il percorso del server e l'URL dal quale scaricare i file. Quindi, creare una cartella sul server Web, ad esempio CIE, per pubblicare tutti i file e tutte le cartelle relative al browser personalizzato. Ad esempio, è possibile creare il seguente percorso del server su C:\Inetpub\Wwwroot\Cie. Se nomecomputer corrisponde alla directory principale virtuale del server Web, il relativo URL sarà http://nomecomputer/Cie/.

Come ottenere un certificato digitale

Effettuare le operazioni di preparazione per la firma di alcuni file, ad esempio file personalizzati creati dal programma di personalizzazione di Internet Explorer e da qualsiasi componente personalizzato, se si distribuiscono file via Internet o via una rete intranet non configurata per questo scopo. In base alle funzionalità di protezione del browser, prima del download di file non autenticati viene visualizzato un messaggio di avviso. Le firme digitali identificano l'origine dei programmi e garantiscono che il codice non è stato modificato dopo la firma.

Se si dispone di un certificato di distribuzione assegnato dall'autorità di certificazione, il programma di personalizzazione di Internet Explorer potrà firmare i file. Per preparare i certificati utilizzati da IEAK, importarli sul computer utilizzando la procedura guidata di importazione di Certificate Manager. Se si è ricevuto un file con estensione .spc, per avviare la procedura guidata di importazione di Certificate Manager fare doppio clic sul file spc in Esplora risorse (Gestione risorse in Windows 95) o Risorse del computer.

Certificate Manager può essere aperto anche da Internet Explorer. Per eseguire questa operazione, scegliere Opzioni Internet dal menu Strumenti, fare clic sulla scheda Contenuto, quindi su Certificati. Fare clic su Importa per avviare la procedura guidata di importazione di Certificate Manager, quindi seguire le istruzioni sullo schermo.

Creazione della struttura sul computer utilizzato per la compilazione

Creare la seguente struttura di cartelle:

Nome cartella | Descrizione
\CIE | Directory principale per i file creati da IEAK e per i file a cui fa riferimento il pacchetto personalizzato
\CIE\Custom | File di personalizzazione (quali Signup.isp, Signup.htm, Icwsign.htm, Install.ins e Cancel.ins, a seconda del metodo di iscrizione) per le iscrizioni tramite server
\CIE\Dist | Cartella di destinazione di tutti i file (necessaria solo se il pacchetto del browser è creato sul disco rigido o su un'unità di rete)
\CIE\Bitmaps | File di bitmap personalizzate; saranno necessari file grafici per il browser personalizzato

Per copiare i file per l'iscrizione in questa struttura

  1. Selezionare tutti i file contenuti nelle seguenti sottocartelle dove è stato installato IEAK: \<IEAK>\Toolkit\Isp\Servless per l'iscrizione a Internet senza server o \<IEAK>\Toolkit\Isp\Server\ per l'iscrizione a Internet tramite server.
  2. Copiare i file nella cartella CIE\Custom.

Metodi di iscrizione e personalizzazione dei file per l'iscrizione

Nel pacchetto personalizzato è possibile specificare la modalità di iscrizione e di connessione a Internet. È possibile scegliere tra procedure di iscrizione tramite server o senza server, o disattivare del tutto la funzione di iscrizione per distribuire aggiornamenti software agli utenti. File di esempio per pagine HTML necessari al supporto di questi metodi di iscrizione sono disponibili nel Kit di strumenti IEAK.

Per ulteriori informazioni su queste opzioni, vedere Opzioni per l'abbonamento a Internet.

Per un'illustrazione del processo di iscrizione, vedere Processo di iscrizione per l'ISP.

Creazione della grafica appropriata

È possibile personalizzare le seguenti bitmap del browser. Spostare le bitmap nella cartella \CIE\Bitmaps prima di eseguire il programma di personalizzazione di Internet Explorer.

Gli sfondi e i pulsanti personalizzati vengono visualizzati esclusivamente su computer ad almeno 256 colori, ossia a 8 bit. Su computer a 16 colori, ossia a 4 bit, verranno visualizzate le bitmap sfondo e i pulsanti a bassa risoluzione.

  • Una bitmap sfondo per la schermata dell'esecuzione automatica del CD-ROM, nel caso di un pacchetto CD-ROM.

    Se si è deciso di distribuire il browser personalizzato su CD, sarà necessario creare le bitmap come parte della la schermata di avvio dell'esecuzione automatica che viene visualizzata dopo aver inserito il CD. Per creare questa bitmap, vedere Creazione di una bitmap per la schermata di avvio dell'esecuzione automatica.

  • Immagine personalizzata per i pulsanti del CD-ROM nel caso di un pacchetto CD-ROM.
  • Due bitmap personalizzate per l'installazione guidata di Windows Update se si desidera personalizzarne l'aspetto: una bitmap di 162 x 312 pixel per la parte sinistra della prima schermata del programma e una bitmap di 496 x 56 pixel per la parte superiore di tutte le altre schermate del programma.
  • Bitmap personalizzate della barra degli strumenti, che vengono visualizzate come sfondo per i pulsanti e i menu.
  • Due immagini bitmap statiche a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.
  • Due immagini bitmap animate a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.

    IEAK contiene due strumenti per creare e vedere in anteprima le bitmap animate personalizzate del browser. Per ulteriori informazioni sull'uso di questi strumenti, vedere Strumenti per bitmap animate.

Per un elenco completo di tutti i tipi di grafica, vedere Creazione di grafica personalizzata.

Raccolta degli URL per la pagina iniziale, di ricerca e di supporto tecnico.

Si consiglia di creare una pagina di supporto tecnico che verrà visualizzata in caso si verifichino problemi durante l'installazione del browser. Durante l'esecuzione del programma di personalizzazione verrà chiesto di immettere gli URL corrispondenti a queste pagine.

Note

  • Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


ISP: Fase 1 della procedura guidata: Raccolta di informazioni

Internet
Provider di servizi

Fase 1 della procedura guidata: Raccolta di informazioni

In questa fase del programma di personalizzazione di Internet Explorer, ai provider di servizi Internet viene chiesto:

  • Il nome della società e il codice di personalizzazione a dieci cifre incluso insieme ad altre informazioni sul kit ricevute da Microsoft.
  • La qualifica in base al contratto di licenza. È necessario specificare se si svolge l'attività di provider di contenuti o sviluppatore, provider di servizi o amministratore delle reti intranet.
  • La cartella di destinazione del pacchetto del browser personalizzato creato.
  • La lingua del pacchetto browser che si sta creando. Sarà necessario eseguire il programma di personalizzazione di Internet Explorer per ciascuna versione internazionale che si desidera creare.
  • Il supporto di distribuzione che si desidera utilizzare, ad esempio il CD-ROM o il download.
  • Le caratteristiche da personalizzare. Se ad esempio le modifiche da apportare al browser sono minime, non sarà necessario visualizzare tutte le schermate del programma di personalizzazione di IEAK.

Nota

  • Il programma di personalizzazione di Internet Explorer non funzionerà correttamente se non è installato Internet Explorer 5.5. Per ulteriori informazioni, vedere Requisiti hardware e di sistema.


ISP: Fase 2 della procedura guidata: parametri di installazione

Internet
Provider di servizi

Fase 2 della procedura guidata: parametri di installazione

In questa fase del programma di personalizzazione guidata di Internet Explorer, ai provider di servizi viene richiesto ciò che segue:

  • Scaricare o aggiornare tutti i componenti Microsoft con Sincronizzazione automatica versione. È necessario eseguire il download di Internet Explorer, ma è possibile scegliere quali altri componenti scaricare.
  • Selezionare qualsiasi altro componente personalizzato che si desidera includere.

    È inoltre possibile specificare fino a 10 componenti aggiuntivi, che possono essere file eseguibili autoestraenti (exe) oppure file cab compressi (cab).


ISP: Fase 3 della procedura guidata: Personalizzazione dell'installazione

Internet
Provider di servizi

Fase 3 della procedura guidata: Personalizzazione dell'installazione

In questa fase del programma di personalizzazione di Internet Explorer, i provider di servizi Internet possono determinare l'aspetto e il funzionamento dell' installazione di Windows Update:

  • Personalizzare la schermata di esecuzione automatica per le installazioni da CD, se il pacchetto viene creato su CD.
  • Personalizzare le opzioni aggiuntive da CD , se il pacchetto viene creato su CD.
  • Personalizzare l'installazione guidata di Windows Update per Internet Explorer e Accesso a Internet. Tali impostazioni influiscono sull'aspetto del programma di installazione.
  • Specificare un numero massimo di dieci opzioni univoche di installazione e determinare i componenti da includere in ciascuna di esse.
  • Specificare un numero massimo di dieci siti dai quali scaricare il pacchetto.
  • Specificare le modalità di aggiornamento dei componenti degli utenti.
  • Specificare se si desidera che l'installazione individui i componenti esistenti e controlli quali di essi possono essere personalizzati dagli utenti.
  • Determinare la disponibilità dei componenti scaricati ma non aggiunti a tutti i pacchetti tramite la funzione Installazione su richiesta di Internet Explorer.
  • Importare un profilo personalizzato o crearne uno nuovo utilizzando CMAK (Connection Manager Administration Kit).
  • Specificare le informazioni sull'autorità di certificazione, in caso si disponga di un certificato digitale, in modo da poter firmare i programmi durante la creazione del pacchetto di IEAK.

Note

  • Per ulteriori informazioni sull'installazione, vedereInstallazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.
  • Per visualizzare un diagramma di flusso delle operazioni che avvengono quando si usa il programma di personalizzazione guidata di Internet Explorer, vedere Creazione con IEAK dei pacchetti personalizzati.


ISP: Fase 4 della procedura guidata: Personalizzazione del browser

Internet
Provider di servizi

Fase 4 della procedura guidata: Personalizzazione del browser

In questa fase del programma di personalizzazione di Internet Explorer i provider di servizi Internet hanno la possibilità di personalizzare i seguenti elementi:

  • Barra del titolo e bitmap sfondo della barra degli strumenti del browser. Quando si seleziona una bitmap, assicurarsi che i colori contrastino con quelli del testo.
  • Pulsanti della barra degli strumenti del browser. È possibile aggiungere pulsanti personalizzati alla barra degli strumenti per l'esecuzione di script e programmi.
  • Logo di Internet Explorer nell'angolo superiore destro del browser.
  • Pagine iniziali, di ricerca e del supporto in linea del browser.
  • Preferiti, cartelle preferiti e collegamenti della barra dei collegamenti.
  • Canali. È possibile aggiungere un canale o una categoria di canali, ossia una cartella di canali.
  • Pagina iniziale, ovvero la pagina che viene visualizzata quando il browser viene avviato per la prima volta.
  • Stringa agente utente. L'identificazione dell'agente utente è opzionale ed è utilizzata per tenere traccia dell'utilizzo del browser personalizzato.
  • Impostazioni di connessione utente, attraverso la personalizzazione, l'importazione o l'eliminazione delle impostazioni utente esistenti.
  • Impostazioni proxy.
  • Certificato principale.
  • Modalità di sottoscrizione dell'utente.
  • File per l'iscrizione. È possibile specificare il percorso della cartella contenente i file per l'iscrizione e specificare se si desidera modificarli.
  • Parametri per la connessione di accesso remoto e file per le impostazioni Internet necessari per la connessione al server degli abbonamenti Internet.
  • Impostazioni della Connessione guidata Internet, se gli utenti utilizzeranno la procedura guidata per sottoscrivere i servizi.

Note

  • Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


ISP: Fase 5 della procedura guidata: personalizzazione dei componenti

Internet
Provider di servizi

Fase 5 della procedura guidata: personalizzazione dei componenti

In questa fase del programma di personalizzazione di Internet Explorer i provider di servizi Internet hanno la possibilità di personalizzare i seguenti elementi:

  • Impostazioni predefinite dei programmi, come i programmi specifici di posta elettronica e i programmi per modificare i file HTML.
  • Server delle news e della posta elettronica, se si include Outlook Express nel pacchetto personalizzato.
  • Impostazioni IMAP del server di posta elettronica degli utenti, se si utilizza Outlook Express e un server IMAP.
  • Contenuto personalizzato di Outlook Express, aggiungendo il proprio messaggio e-mail per dare il benvenuto agli utenti e personalizzando il Riquadro informazioni che viene visualizzato all'avvio del programma.
  • Impostazioni personalizzate di Outlook Express, ad esempio impostazione di client della posta e delle news predefiniti, la fornitura di assistenza agli utenti che necessitano di ulteriori account di posta elettronica e la creazione di un file regole di messaggio predefinito.
  • Impostazioni dell'interfaccia utente di Outlook Express, come la barra cartelle, l'elenco cartelle, i contatti MSN Messenger, la barra di stato o la barra di Outlook.
  • Impostazioni di composizione di Outlook Express, per allegare una firma o una dichiarazione di non responsabilità della società ai messaggi di posta elettronica o ai newsgroup.
  • Servizio di elenchi in linea della Rubrica di Windows, se si desidera fornire agli utenti un servizio di elenchi in linea e personalizzare i server LDAP (Lightweight Directory Access Protocol).
  • Marcatura di MSN Messenger Service, se si intende includere nel pacchetto l'installazione personalizzata del client di Messenger Service.
  • Elementi multimediali di MSN Messenger Service, se si intende apportare modifiche alla grafica, al contenuto promozionale o sonoro utilizzato in un'installazione personalizzata del client di Messenger Service.
  • Informazioni sull'account di MSN Messenger Service, se si intende modificare le impostazioni predefinite dell'account e le impostazioni per l'integrazione della posta elettronica di Passport in un'installazione personalizzata del client di Messenger Service.
  • Criteri di sistema e impostazioni, per preimpostare le opzioni Internet.


ISP: Distribuzione del pacchetto browser

Internet
Provider di servizi

Distribuzione del pacchetto browser

Per impostazione predefinita, il programma di personalizzazione di Internet Explorer crea dei file che gli utenti possono scaricare da Internet. È inoltre possibile distribuire un pacchetto browser personalizzato su CD-ROM. Per un elenco completo dei supporti di distribuzione, vedere Selezione dei supporti.

File scaricabili

I provider di servizi Internet possono distribuire agli utenti un unico file contenente il modulo di gestione dell'installazione che verrà utilizzato per scaricare i componenti dell'applicazione da un server Internet.

Se il pacchetto del browser è stato creato su un server Internet, sarà necessario configurare il sito Web in modo che gli utenti possano scaricare i file. È ad esempio possibile creare una pagina contenente le informazioni sul download e un collegamento al modulo di gestione dell'installazione, IE5setup.exe.

Se il pacchetto del browser è stato creato sul proprio disco rigido o su un'unità di rete, sarà necessario spostare gli elementi che seguono sul server Internet:

  • La cartella che contiene la versione nella lingua desiderata e il contenuto della cartella stessa. Ad esempio, la cartella per la versione in inglese è denominata En, quindi è necessario spostare la cartella En e i file in essa contenuti. Questa cartella sarà in cartelle a seconda del tipo di supporto, ad esempio Download, e della piattaforma. L'unica piattaforma designata in Internet Explorer Administrative Kit 5.5 è "Win32"; per client UNIX e Windows 16-bit, usare Internet Explorer Administrative Kit 5.0x.
  • File Ie5sites.dat. Questo file indica il sito di download,o i siti, specificati quando è stato eseguito il programma di personalizzazione di Internet Explorer.

    • A questo riguardo, vedere l’illustrazione riportata in Impostazione dei file per la distribuzione.

    Per un diagramma di flusso dei file creati dal programma di personalizzazione di Internet Explorer, vedere Creazione di pacchetti personalizzati in IEAK.

Firma dei pacchetti personalizzati

I browser Web dispongono di funzioni di protezione che consentono di evitare il download di programmi che potrebbero danneggiare il computer. A seconda del livello di protezione e della piattaforma, all'utente può essere impedito il download, oppure può essere inviato un messaggio di avvertimento, in relazione al download di programmi che non hanno firma digitale.

I file cab personalizzati creati dal programma di personalizzazione di Internet Explorer devono essere firmati, a meno che la zona intranet locale non sia stata preconfigurata su un livello di protezione basso. Tutti i componenti personalizzati distribuiti insieme al pacchetto browser per tali piattaforme devono essere firmati. Se si dispone di un certificato digitale, il programma di personalizzazione di Internet Explorer può firmare automaticamente tali file.

Note

  • La firma dei file cab e dei programmi personalizzati richiede due fasi: ottenere un certificato digitale e specificare le relative informazioni quando viene eseguito il programma di personalizzazione di Internet Explorer. Per ulteriori informazioni, vedere Firma dei programmi.
  • Potrebbe essere necessario modificare i caratteri maiuscoli o minuscoli per file inviati su un server FTP UNIX. Di seguito sono riportate le convenzioni da utilizzare per i sistemi operativi UNIX.
    • UNIX Solaris
      Se si utilizza un server FTP UNIX che rileva la differenza tra maiuscole e minuscole, sarà necessario verificare che il nome della cartella cab non sia formattato tutto in maiuscolo e che i file elencati di seguito siano scritti nel modo seguente: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • AT&T UNIX
      Su un server FTP UNIX AT&T, tutti i nomi dei file devono essere scritti in maiuscolo .
    • IRIX UNIX (Silicon Graphics)
      I nomi dei file che seguono devono essere scritti in maiuscolo: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. È inoltre necessario utilizzare un editor di testo per modificare i nomi dei file elencati in IE.CIF in base alla distinzione tra maiuscole e minuscole utilizzata nei file.

CD-ROM

Se il browser personalizzato verrà distribuito agli utenti di Windows 95, all’inserimento del CD apparirà una schermata del programma di avvio automatico. Questo programma offre agli utenti la possibilità di scegliere tra l’installazione del browser personalizzato o la visualizzazione di ulteriori informazioni. Se la versione corrente di Internet Explorer è già installata, il programma di esecuzione automatica lo rileva. Il browser viene visualizzato in quella che è conosciuta come modalità tutto schermo con caricato il file Start.htm.

Per ulteriori informazioni

Per informazioni più dettagliate sull'installazione di Windows Update, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet. Per un'illustrazione del processo di download, vedere l'illustrazione Installazione di Windows Update per Internet Explorer e Accesso a Internet.


ISP: Come distribuire il client di Messenger Service

Internet
Provider di servizi

Come distribuire il client di servizi Messenger

Se MSN Messenger Service è stato incluso tra le opzioni di installazione, il programma di personalizzazione di Internet Explorer provvederà alla creazione di un pacchetto distinto per il download del client di servizi Messenger personalizzato da Internet.

File che è possibile scaricare

Qualora sia stato creato il pacchetto client di servizi Messenger su un server Internet, verificare di aver impostato il sito Web in modo che agli utenti sia permesso il download dei file. Ad esempio, è possibile creare una pagina dove rendere disponibili informazioni per il download e un collegamento al file dell'installazione (mmssetup.exe) per il client di servizi Messenger.

Se il file mmssetup.exe è stato creato sul proprio disco rigido o su una unità di rete, è necessario spostarlo su un server Internet per ogni versione in lingua che si sta rendendo disponibile. Ogni versione in lingua crea una sottocartella nella cartella Messenger della directory di lavoro. Ad esempio, la versione inglese di mmssetup.exe si trova nella sottocartella En. Se è stato specificato un URL di download durante la personalizzazione, creare all'interno della pagina dell'URL un collegamento per i download che punta a mmssetup.exe. Tutti i componenti necessari per distribuire un client di Messenger Service personalizzato sono inclusi in questo eseguibile.

Firma dell'installazione del client di Messenger Service

Qualora sia stato incluso un certificato digitale utilizzato per la firma del pacchetto browser quando si esegue l'installazione guidata di IEAK, lo stesso certificato digitale verrà utilizzato per firmare l'installazione singola di mssetup.exe. Vedere Firme digitali e Firma dei programmi per ulteriori dettagli.

Client di Messenger Service come parte del pacchetto browser

Il client di Messenger Service personalizzato verrà installato come parte del pacchetto browser, se nelle opzioni di installazione, è stato specificato di includere MSN Messenger Service. Un pacchetto cab separato viene creato per il client di Messenger Service personalizzato e il client verrà incluso come componente quando viene eseguito ie5setup.exe. Vedere Distribuzione del pacchetto del browser per ulteriori dettagli sulla distribuzione del pacchetto completo del browser.

Client di servizi Messenger e firewall

Qualora sia necessario specificare opzioni avanzate per il proxy per la messaggistica all'interno di un firewall, non specificare un URL per il download. Inoltre, è necessario editare un testo per generare un file di installazione per la preconfigurazione delle opzioni del proxy. Vedere Personalizzazione avanzata di Messenger Client per ulteriori dettagli.


Panoramica per gli amministratori delle reti intranet

Microsoft(r) Internet Explorer Administration Kit (IEAK) consente la creazione di un programma di installazione personalizzata visibile all'utente di Microsoft Internet Explorer, che non richiede l'intervento dello stesso e che risponde alle esigenze specifiche della propria società.

Questo kit può essere utilizzato per eseguire le seguenti operazioni:

Personalizzazione del programma di installazione

  • Personalizzazione della visualizzazione del programma di installazione di Windows Update e configurazione delle modalità di installazione, ad esempio l'installazione Tipica e Minima.
  • Indirizzamento degli utenti su server Internet o intranet per l'accesso all'ultima versione disponibile del prodotto.
  • Trasferimento dalla memoria al disco di programmi interni e script personalizzati o di manutenzione quando l'utente esegue l'installazione di Internet Explorer.
  • Determinazione della versione in lingua di Internet Explorer che si intende includere nel pacchetto di installazione. È necessario eseguire il programma di personalizzazione di Internet Explorer per ciascuna versione in lingua che si desidera creare.

Personalizzazione del browser e Aggiornamento desktop di Windows

  • Impostazione della pagina iniziale, della pagina di ricerca e della pagina del supporto in linea che si desidera utilizzare.
  • Caricamento dei collegamenti e delle cartelle nell'elenco Preferiti.
  • Modifica della barra del titolo e del logo del browser.
  • Configurazione e controllo di Aggiornamento desktop di Windows, incluso Active Desktop, barre degli strumenti del desktop, Pannello di controllo e Risorse del computer.
  • Controllo dei canali che vengono visualizzati sul desktop dell'azienda.
  • Creazione di un desktop per la propria società e determinazione delle impostazioni che potranno essere modificate dai singoli utenti.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Modalità di personalizzazione.

Gestione delle restrizioni di accesso

  • Preinstallazione dei certificati sul computer dell'utente e blocco del download di altri certificati.
  • Preimpostazione delle restrizioni di accesso in base alle esigenze della società.
  • Impostazione di una dichiarazione standard di non responsabilità per ogni messaggio inviato su un newsgroup da un utente della propria società.
  • Utilizzo di aree di protezione per impostare diversi livelli di protezione e aree di affidabilità.
  • Impostazioni per il proxy per indirizzi e porte.

Importante

  • La disponibilità di alcune funzionalità dipende dal contratto di licenza sottoscritto. Per ulteriori informazioni, consultare il contratto.


Amministratore delle reti intranet Preparazione dell'esecuzione della procedura guidata

Amministratore
delle reti intranet

Preparazione dell'esecuzione della procedura guidata

Prima di eseguire il programma di personalizzazione di Internet Explorer, è necessario raccogliere le informazioni necessarie e creare bitmap personalizzate.

Determinare i requisiti iniziali della piattaforma

  • Verificare che il computer con il quale verrà creato il pacchetto e i computer nei quali verrà installato lo stesso soddisfino i requisiti hardware e di sistema.
  • Determinare i livelli di crittografia per il pacchetto browser. Per ulteriori informazioni sulla crittografia di Internet Explorer, vedere il sito Web IEAK.

Decidere le modalità di distribuzione

Decidere le modalità di distribuzione del pacchetto personalizzato; tramite CD, download, rete locale (LAN) o disco floppy. Al termine della creazione del pacchetto, sarà necessario copiare i file del browser personalizzato sul supporto selezionato. Se si è deciso di distribuire il pacchetto tramite download, sarà necessario spostare i file in una posizione appropriata sul server.

Se si è deciso di pubblicare il pacchetto browser su un server Internet, sarà necessario conoscere il percorso del server e l'URL dal quale scaricare i file. Quindi, creare una cartella sul server Web, ad esempio CIE, per pubblicare tutti i file e tutte le cartelle relative al browser personalizzato. Ad esempio, è possibile creare il seguente percorso del server su C:\Inetpub\Wwwroot\Cie. Se nomecomputer corrisponde alla directory principale virtuale del server Web, il relativo URL sarà http://nomecomputer/Cie/.

Ottenere un certificato digitale

Se i file vengono distribuiti attraverso Internet o una rete Intranet non appositamente configurata, è necessario eseguire alcune operazioni preliminari per la firma di determinati file, ad esempio i file personalizzati creati dalla procedura di personalizzazione di Internet Explorer e qualsiasi altro componente personalizzato. In base alle funzionalità di protezione del browser, prima del download di file non autenticati viene visualizzato un messaggio di avviso. Le firme digitali identificano l'origine dei programmi e garantiscono che il codice non è stato modificato dopo la firma.

Se si dispone di un certificato di distribuzione assegnato dall'autorità di certificazione, il programma di personalizzazione di Internet Explorer potrà firmare i file. Per preparare i certificati utilizzati da IEAK, importarli sul computer utilizzando la procedura guidata di importazione di Certificate Manager. Se si è ricevuto un file con estensione .spc, per avviare la procedura guidata di importazione di Certificate Manager fare doppio clic sul file .spc in Esplora risorse (Gestione risorse in Windows 95) o Risorse del computer.

Certificate Manager può essere aperto anche da Internet Explorer. Per eseguire questa operazione, scegliere Opzioni Internet dal menu Strumenti, fare clic sulla scheda Contenuto, quindi su Certificati. Fare Clic su Importa per avviare la procedura guidata di importazione di Certificate Manager, quindi seguire le istruzioni sullo schermo.

Decidere se configurare Aggiornamento desktop di Windows per la propria organizzazione.

Creare la struttura sul computer utilizzato per la compilazione

Nome cartella | Descrizione
\CIE | Directory principale per i file creati da IEAK e per i file a cui fa riferimento il pacchetto personalizzato
\CIE\Bitmaps | File di bitmap personalizzate; saranno necessari file grafici per il browser personalizzato

Creare la grafica appropriata

È possibile personalizzare le seguenti bitmap del browser. Spostare le bitmap nella cartella \CIE\Bitmaps prima di eseguire il programma di personalizzazione di Internet Explorer.

Gli sfondi e i pulsanti personalizzati vengono visualizzati esclusivamente su computer ad almeno 256 colori, ossia a 8 bit. Su computer a 16 colori, ossia a 4 bit, verranno visualizzate le bitmap sfondo e i pulsanti a bassa risoluzione.

  • Una bitmap sfondo per la schermata dell'esecuzione automatica del CD-ROM, nel caso di un pacchetto CD-ROM.

    Se si è deciso di distribuire il browser personalizzato su CD, sarà necessario creare le bitmap come parte della la schermata di avvio dell'esecuzione automatica che viene visualizzata dopo aver inserito il CD. Per creare questa bitmap, vedere Creazione di una bitmap per la schermata di avvio dell'esecuzione automatica.

  • Immagine personalizzata per i pulsanti del CD-ROM nel caso di un pacchetto CD-ROM.
  • Due bitmap personalizzate per l'installazione guidata di Windows Update se si desidera personalizzarne l'aspetto: una bitmap di 162 x 312 pixel per la parte sinistra della prima schermata del programma e una bitmap di 496 x 56 pixel per la parte superiore di tutte le altre schermate del programma.
  • Bitmap personalizzate della barra degli strumenti, che vengono visualizzate come sfondo per i pulsanti e i menu.
  • Due immagini bitmap statiche a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.
  • Due immagini bitmap animate a 256 colori, una di 38 x 38 pixel e un'altra di 22 x 22 pixel, utilizzate per personalizzare il browser Internet Explorer con il proprio logo.

    IEAK contiene due strumenti per creare e vedere in anteprima le bitmap animate personalizzate del browser. Per ulteriori informazioni sull'uso di questi strumenti, vedere Strumenti per bitmap animate.

Per un elenco completo di tutti i tipi di grafica, vedere Creazione di grafica personalizzata.

Raccogliere gli URL per la pagina iniziale, di ricerca e di supporto tecnico.

Si consiglia di creare una pagina di supporto tecnico che verrà visualizzata in caso si verifichino problemi durante l'installazione del browser. Durante l'esecuzione del programma di personalizzazione verrà chiesto di immettere gli URL corrispondenti a queste pagine.

Pianificare la protezione e le strategie per l'Aggiornamento desktop di Windows

È possibile personalizzare e controllare numerose impostazioni utente, quali la protezione e l'Aggiornamento desktop di Windows. È necessario pianificare la strategia prima di avviare il programma di personalizzazione di Internet Explorer.

Note

  • Per ulteriori informazioni sull’installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


Ammininistratore delle reti intranet: Fase 1 della procedura guidata: Raccolta informazioni

Amministratore delle
reti intranet

Fase 1 della procedura guidata: Raccolta informazioni

In questa fase del programma di personalizzazione guidata di Internet Explorer, agli amministratori delle reti intranet vengono richieste le seguenti informazioni:

  • Nome società e codice di personalizzazione a 10 cifre. Il codice di personalizzazione è stato incluso nell'altro kit di informazioni inviato da Microsoft.
  • La qualifica in base al Contratto Microsoft. È necessario specificare se si svolge l'attività di provider o sviluppatore di contenuti, provider di servizi o amministratore delle reti intranet.
  • La cartella di destinazione del pacchetto del browser personalizzato creato.
  • Lingua del pacchetto browser. Sarà necessario eseguire il programma di personalizzazione di IEAK per ciascuna versione che si desidera creare.
  • Il supporto di distribuzione che si desidera utilizzare, ad esempio il CD-ROM o il download da una rete intranet o da Internet.
  • Le caratteristiche da personalizzare. Se ad esempio le modifiche da apportare al browser sono minime, non sarà necessario visualizzare tutte le schermate del programma di personalizzazione di IEAK.

Nota

  • Il programma di personalizzazione di IEAK non verrà eseguito correttamente se nel computer in uso non è installato Internet Explorer 5.5. Per ulteriori informazioni, vedere Requisiti hardware e di sistema.


Corp. Admin.: Fase 2 della procedura guidata: Specificazione dei parametri di installazione

Amministratore delle
reti intranet

Fase 2 della procedura guidata: Specificazione dei parametri di installazione

In questa fase della procedura di personalizzazione guidata di Internet Explorer, gli amministratori delle reti intranet viene richiesto di:

  • Scaricare o aggiornare tutti i componenti Microsoft con Sincronizzazione automatica versione. È necessario eseguire il download di Internet Explorer, ma è possibile scegliere quali altri componenti di Internet Explorer scaricare.
  • Selezionare qualsiasi altro componente personalizzato che si desidera includere.

    È inoltre possibile specificare fino a 10 componenti aggiuntivi che possono essere file eseguibili autoestraenti (exe) oppure file cab compressi.


Ammin. servizi intranet: Fase 3 della procedura guidata: Personalizzazione dell'installazione

Amministratore delle
reti intranet

Fase 3 della procedura guidata: Personalizzazione dell'installazione

In questa fase della procedura di personalizzazione guidata per Internet Explorer, gli amministratori delle reti intranet possono determinare l'aspetto e il funzionamento dell' installazione di Windows Update :

  • Personalizzare la schermata di avvio per le installazioni da CD, se il pacchetto viene creato su CD.
  • Personalizzare le opzioni aggiuntive da CD , se il pacchetto viene creato su CD.
  • Personalizzare l'installazione guidata di Windows Update per Internet Explorer e Accesso a Internet. Queste impostazioni influiscono sull'aspetto del programma di installazione.
  • Selezionare l'installazione invisibile, in modo che venga visualizzato un numero limitato o nessun messaggio di conferma.
  • Specificare un numero massimo di dieci opzioni univoche di installazione e determinare i componenti da includere in ciascuna di esse.
  • Specificare un numero massimo di dieci siti dai quali scaricare il pacchetto. È possibile specificare fino a un massimo di 10 siti, ad eccezione degli amministratori delle reti intranet che eseguono installazioni invisibili all'utente.
  • Specificare le modalità di aggiornamento dei componenti degli utenti.
  • Specificare il percorso di installazione di Internet Explorer nel computer e indicare se agli utenti sarà consentito modificarlo.
  • Determinare se agli utenti sarà consentito personalizzare l'installazione, se installare le informazioni sulla disinstallazione, se è possibile installare Internet Explorer insieme a una versione precedente e se Internet Explorer deve essere utilizzato come browser predefinito.
  • Specificare se si desidera che l'installazione individui i componenti e controlli quali di essi possono essere personalizzati dagli utenti.
  • Determinare la disponibilità dei componenti scaricati ma non aggiunti a tutti i pacchetti tramite la funzione Installazione su richiesta di Internet Explorer.
  • Specificare se si desidera aggiornare il desktop e le cartelle con le funzionalità del browser Web. Tale funzionalità è integrata in Windows 98.
  • Specificare le informazioni sull'autorità di certificazione, in caso si disponga di un certificato digitale, in modo da poter firmare i programmi durante la creazione del pacchetto di IEAK.

Note

  • Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.
  • Per visualizzare un diagramma di flusso delle operazioni che avvengono quando si usa il programma di personalizzazione guidata di Internet Explorer, vedere Creazione con IEAK dei pacchetti personalizzati.


Amministratore delle reti intranet: Fase 4 della procedura guidata: Personalizzazione del browser

Amministratore delle
reti intranet

Fase 4 della procedura guidata: Personalizzazione del browser

In questa fase del programma di personalizzazione di Internet Explorer, gli amministratori delle reti intranet possono personalizzare:

  • Barra del titolo e bitmap sfondo della barra degli strumenti del browser. Quando si seleziona una bitmap, assicurarsi che i colori contrastino con quelli del testo.
  • Pulsanti della barra degli strumenti del browser. È possibile aggiungere pulsanti personalizzati alla barra degli strumenti per l'esecuzione di script e programmi.
  • Logo di Internet Explorer nell'angolo superiore destro del browser.
  • Pagine iniziali, di ricerca e del supporto in linea del browser.
  • Preferiti, cartelle Preferiti e collegamenti della barra dei collegamenti.
  • Canali per consentire agli utenti di ricevere il contenuto automaticamente aggiornato.
  • Pagina iniziale, ovvero la pagina che viene visualizzata quando il browser viene avviato per la prima volta.
  • Personalizzazione di Active Desktop, se si esegue anche l'installazione di Aggiornamento desktop di Windows. Per poter visualizzare questa schermata, è necessario che nel computer usato per la creazione del pacchetto sia installato Active Desktop.
  • Impostazioni della barra degli strumenti del desktop. È possibile importare le impostazioni della barra degli strumenti del desktop dal proprio computer e utilizzarle come standard aziendale. Per poter visualizzare questa schermata, è necessario che nel computer usato per la creazione del pacchetto sia installato Active Desktop.
  • Risorse del computer e Pannello di controllo specificando i file Mycomp.htt e Controlp.htt, se si esegue l'installazione di Aggiornamento desktop di Windows. Per poter visualizzare questa schermata, è necessario che nel computer usato per la creazione del pacchetto sia installato Active Desktop.
  • Stringa agente utente. L'identificazione dell'agente utente è opzionale ed è utilizzata per tenere traccia dell'utilizzo del browser personalizzato.
  • Impostazioni di connessione utente, tramite la personalizzazione, l'importazione o l'eliminazione delle impostazioni utente esistenti.
  • Configurazione automatica. È possibile specificare il percorso dei file che consentono la configurazione automatica del browser.
  • Impostazioni proxy.
  • Impostazioni per i certificati di protezione e per Authenticode.
  • Impostazioni per aree di protezione e restrizioni.

Note

  • Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


Amministratore delle reti intranet: Fase 5 della procedura guidata: Personalizzazione dei componenti

Amministratore delle
reti intranet

Fase 5 della procedura guidata: Personalizzazione dei componenti

In questa fase del programma di personalizzazione di Internet Explorer, gli amministratori delle reti intranet possono personalizzare:

  • Impostazioni predefinite dei programmi, ad esempio programmi specifici da usare per la posta elettronica e per modificare i file HTML.
  • Server delle news e della posta elettronica, se si include Outlook Express nel pacchetto personalizzato.
  • Impostazioni IMAP del server di posta elettronica degli utenti, se si utilizza Outlook Express e un server IMAP.
  • Contenuto personalizzato di Outlook Express, aggiungendo il proprio messaggio e-mail per dare il benvenuto agli utenti e personalizzando il Riquadro informazioni che viene visualizzato all'avvio del programma.
  • Impostazioni personalizzate di Outlook Express, ad esempio impostazione di client della posta e delle news predefiniti, la fornitura di assistenza agli utenti che necessitano di ulteriori account di posta elettronica e la creazione di un file regole di messaggio predefinito.
  • Impostazioni dell'interfaccia utente di Outlook Express, come la barra cartelle, l'elenco cartelle, i contatti MSN Messenger, la barra di stato o la barra di Outlook.
  • Impostazioni di composizione di Outlook Express, per allegare una firma o una dichiarazione di non responsabilità della società ai messaggi di posta elettronica o newsgroup di Internet.
  • Servizio di elenchi in linea della Rubrica di Windows, se si desidera fornire agli utenti un servizio di elenchi in linea e personalizzare i server LDAP (Lightweight Directory Access Protocol).
  • Marcatura di MSN Messenger Service, se si intende includere nel pacchetto l'installazione personalizzata del client di Messenger Service.
  • Elementi multimediali di MSN Messenger Service, se si intende apportare modifiche alla grafica, al contenuto promozionale o al sonoro utilizzato in un'installazione personalizzata del client di Messenger Service.
  • Informazioni sull'account di MSN Messenger Service, se si intende modificare le impostazioni predefinite dell'account e le impostazioni per l'integrazione della posta elettronica di Passport in un'installazione personalizzata del client di Messenger Service.
  • Criteri di sistema e impostazioni, per predefinire o controllare le impostazioni, incluse le opzioni per il browser, la posta elettronica, la protezione e il desktop.
  • Evidenziare particolari criteri di sistema e restrizioni particolari, a seconda di quale sistema operativo viene utilizzato. Se gli utenti usano Windows NT o Windows 2000, alcuni criteri di sistema e restrizioni devono essere gestiti rispettivamente tramite Editor dei criteri di Windows NT o Criteri di gruppo di Windows 2000, invece che dal programma di personalizzazione guidata di Gestione profili di IEAK.


Ammininistratore delle reti intranet: Distribuzione del pacchetto browser

Amministratore delle
reti intranet

Distribuzione del pacchetto browser

Come impostazione predefinita il programma di personalizzazione di Internet Explorer crea dei file che possono essere scaricati da Internet. È inoltre possibile distribuire un pacchetto browser personalizzato su CD-ROM. Per un elenco completo dei supporti di distribuzione, vedere Selezione dei supporti.

File che è possibile scaricare

Qualora sia stato creato il pacchetto browser su un server Internet o intranet, è necessario impostare il sito Web in modo che agli utenti sia permesso scaricare i file. È ad esempio possibile creare una pagina contenente le informazioni sul download e un collegamento al modulo di gestione dell'installazione, IE5setup.exe.

Se il pacchetto del browser è stato creato sul disco rigido o su un'unità di rete, sarà necessario spostare gli elementi che seguono sul server Internet o intranet:

  • La cartella che contiene la versione nella lingua desiderata e il contenuto della cartella stessa. Ad esempio, la cartella per la versione in inglese è denominata En, quindi è necessario spostare la cartella En e i file in essa contenuti. Questa cartella si trova in cartelle specifiche in base al tipo di supporto, ad esempio Download, e piattaforma. L'unica piattaforma designata in Internet Explorer Administrative Kit 5.5 è "Win32"; per client UNIX e Windows 16-bit, usare Internet Explorer Administrative Kit 5.0x.
  • File Ie5sites.dat. Questo file indica il sito di download,o i siti, specificati quando è stato eseguito il programma di personalizzazione di Internet Explorer.

L'installazione del browser viene effettuata facendo clic su IE5setup.exe. Il file è contenuto nella cartella della lingua e della versione della piattaforma all'interno della cartella Download, ad esempio \Download\Win32\En per la versione in inglese.

A questo riguardo, vedere l'illustrazione riportata in Impostazione dei file per la distribuzione.

Per un diagramma dei file creati dal programma di personalizzazione di Internet Explorer, vedere Come IEAK genera i pacchetti personalizzati.

Firma dei pacchetti personalizzati

I browser Web dispongono di funzioni di protezione che consentono di evitare il download di programmi che potrebbero danneggiare il computer. In base al livello di protezione e al sistema operativo, sarà possibile impedire il download di programmi che non dispongano di firma digitale o semplicemente avvisare gli utenti che si apprestano a effettuarlo.

I file .cab personalizzati creati dal programma di personalizzazione di Internet Explorer devono essere firmati, a meno che la zona intranet locale non sia stata preconfigurata su un livello di protezione basso. Si consiglia inoltre di apporre la firma digitale a qualsiasi componente personalizzato distribuito con il pacchetto del browser per determinati sistemi operativi. Se si dispone di un certificato digitale, il programma di personalizzazione di Internet Explorer può firmare automaticamente tali file.

Note

  • La firma dei file cab e dei programmi personalizzati richiede due fasi: il recupero del certificato digitale e la specifica delle informazioni relative al certificato al momento dell'esecuzione del programma di personalizzazione. Per ulteriori informazioni, vedere Firma dei programmi.
  • Potrebbe essere necessario modificare i caratteri maiuscoli o minuscoli per file inviati su un server FTP UNIX. Di seguito sono riportate le convenzioni da utilizzare per i sistemi operativi UNIX.

    • UNIX Solaris
      Se si utilizza un server FTP UNIX che rileva la differenza tra maiuscole e minuscole, sarà necessario verificare che il nome della cartella cab non sia in maiuscolo e che i file elencati di seguito siano scritti nel modo seguente: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT.
    • AT&T UNIX
      Su un server FTP UNIX AT&T, tutti i nomi dei file devono essere scritti in maiuscolo.
    • IRIX UNIX (Silicon Graphics)
      I nomi dei file che seguono devono essere scritti in maiuscolo: BRANDING.CAB, CUSTOM.CIF, DESKTOP.CAB, IE.CIF, IECIF.CAB e IE5SITES.DAT. È inoltre necessario utilizzare un editor di testo per modificare i nomi dei file elencati in IE.CIF in modo che sia rispettata la distinzione tra maiuscole e minuscole utilizzata nei file.

CD-ROM

Se il browser personalizzato viene distribuito agli utenti di Windows 95 o Windows 98, all'inserimento del CD verrà visualizzata la schermata di avvio del programma di esecuzione automatica. Tale programma consente di installare il browser personalizzato o di visualizzare ulteriori informazioni. Se la versione corrente di Internet Explorer è già installata, il programma di esecuzione automatica lo rileva. Il browser viene visualizzato in quella che è conosciuta come modalità tutto schermo con caricato il file Start.htm.

Con l' installazione personalizzata di Windows Update , è possibile inviare i file ad un server intranet o Internet. È inoltre possibile creare versioni per CD-ROM per gli utenti che non dispongono inizialmente dell'accesso a Internet.

Per ulteriori informazioni

Per informazioni più dettagliate sull'installazione di Windows Update, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet. Per un'illustrazione del processo di download, vedere l'illustrazione Installazione di Windows Update per Internet Explorer e Accesso a Internet.


Amministratore delle reti intranet: Distribuzione del client di Messenger Service

Amministratore delle
reti intranet

Distribuzione del client di Messenger Service

Se tra le opzioni di installazione è stato incluso MSN Messenger Service, il programma di personalizzazione di Internet Explorer provvederà alla creazione di un pacchetto distinto per il download del client di Messenger Service personalizzato dal server Internet o intranet.

File che è possibile scaricare

Qualora sia stato creato il pacchetto client di Messenger Service su un server Internet o intranet, verificare di aver impostato il sito Web in modo che agli utenti sia permesso scaricare i file. Ad esempio, è possibile creare una pagina dove rendere disponibili informazioni per il download e un collegamento al file dell'installazione (mmssetup.exe) per il client di Messenger Service.

Se il file mmssetup.exe è stato creato sul disco rigido o su una unità di rete, è necessario spostarlo su un server Internet o intranet per ogni versione in lingua che si sta rendendo disponibile. Ogni versione in lingua crea una sottocartella nella cartella Messenger della directory di lavoro. Ad esempio, la versione inglese di mmssetup.exe si trova nella sottocartella En. Se è stato specificato un URL di download durante la personalizzazione, creare all'interno della pagina dell'URL un collegamento per i download che punta a mmssetup.exe. Tutti i componenti necessari per distribuire un client di Messenger Service personalizzato sono inclusi in questo eseguibile.

Firma dell'installazione del client di Messenger Service

Qualora sia stato incluso un certificato digitale utilizzato per la firma del pacchetto browser quando si esegue l'installazione guidata di IEAK, lo stesso certificato digitale verrà utilizzato per firmare l'installazione singola mssetup.exe. Vedere Firme digitali e Firma dei programmi per ulteriori dettagli.

Client di Messenger Service come parte del pacchetto browser

Il client di Messenger Service personalizzato verrà installato come parte del pacchetto browser, se nelle opzioni di installazione, è stato specififcato di includere MSN Messenger Service. Un pacchetto .cab separato viene creato per il client di Messenger Service personalizzato e il client verrà incluso come componente quando viene eseguito ie5setup.exe. Vedere Distribuzione del pacchetto del browser per ulteriori dettagli sulla distribuzione del pacchetto completo del browser.

Client di Messenger Service e firewall

Qualora sia necessario specificare opzioni avanzate per il proxy per la messaggistica dietro un firewall, non specificare un URL di download. Inoltre, è necessario editare un testo per generare un file di installazione per la preconfigurazione delle opzioni del proxy. Vedere Personalizzazione avanzata del client di Messenger Service per ulteriori dettagli.


Gestione delle impostazioni utente

Dopo aver impostato le opzioni utente e dopo aver distribuito il browser, gli amministratori di reti intranet possono continuare a gestire queste impostazioni. Memorizzando nel server un file INS principale scaricabile a ciascun accesso, gli amministratori potranno modificare in qualsiasi momento le impostazioni relative alle opzioni dei singoli utenti. Utilizzando le procedure di accesso esistenti, gli amministratori potranno gestire e aggiornare a intervalli regolari le impostazioni utente direttamente da un server centralizzato.

Utilizzando Gestione profili di IEAK, sarà possibile amministrare i file di configurazione in modo estremamente semplice. Gestione profili consente infatti di aprire qualsiasi file .ins e di apportare modifiche alle impostazioni desiderate, quali le impostazioni del server proxy, la pagina iniziale, la barra di ricerca e le informazioni relative a LDAP (Lightweight Directory Access Protocol).

Per i sistemi che utilizzano Windows2000, è possibile gestire alcune impostazioni utente usando Criteri di gruppo.

Dopo l'installazione, gli amministratori potranno gestire in modo remoto tutti i certificati degli autori e dei siti consentiti, aggiungendo o rimuovendo nuovi certificati dall'apposito elenco.


Come utilizzare Gestione profili di IEAK

Prima dell'installazione di Internet Explorer, è possibile usare il programma di personalizzazione guidata di Internet Explorer per preconfigurare i pacchetti personalizzati in modo da includere la configurazione automatica del browser e Rilevamento automatico. Con queste funzioni, i computer degli utenti possono trovare automaticamente il file ins di configurazione automatica che si trova sul server ed usarlo per aggiornare le impostazioni di configurazione del browser a intervalli specificati.

Dopo l'installazione di Internet Explorer, è possibile usare Gestione profili di IEAK per la gestione delle impostazioni di configurazione del browser sui computer degli utenti. Tramite Gestione profili di IEAK è possibile aprire ogni file ins di configurazione automatica e modificare le impostazioni, ad esempio firme digitali e opzioni di aree di protezione.

È inoltre possibile usare Gestione profili di IEAK per abilitare la configurazione automatica del browser nel caso questa funzione non sia stata preconfigurata prima dell'installazione. La funzione Rilevamento automatico, se abilitata, troverà i file ins di configurazione automatica aggiornati, oppure è possibile impostare la configurazione automatica del browser manualmente sui computer client.

Un amministratore delle reti intranet, per gestire le proprie versioni di Internet Explorer, può usare Gestione profili di IEAK che fornisce un accesso facile e veloce alle impostazioni del sistema da una postazione centrale. Per usare la configurazione automatica, è necessario creare un profilo che consiste in un file ins e ogni file cab generato da Gestione profili. Il profilo contiene informazioni che vengono usate per configurare i browser degli utenti. Dopo la creazione del profilo, è necessario mettere il file sul server.

Quando si esegue il programma di personalizzazione guidata di Internet Explorer, è necessario digitare il percorso al server per il file ins. Se in seguito è necessario modificare le impostazioni dell'utente, è sufficiente modificare il file ins. La volta successiva che il browser viene avviato dagli utenti o in base a una pianificazione specificata, le modifiche vengono rese effettive sul computer di ogni utente.

Per ulteriori informazioni sull'impostazione della configurazione automatica del browser, vedere Impostazioni e restrizioni.

Aggiornamento delle impostazioni di configurazione del browser

Il programma di personalizzazione guidata di Internet Explorer crea un file ins di configurazione automatica per ogni pacchetto che viene creato. In base all'impostazione predefinita, questo file è denominato Install.ins, ma è possibile rinominare il file per ogni pacchetto personalizzato.

Dopo l'installazione del browser, è possibile usare Gestione profili di IEAK per aggiornare le impostazioni di configurazione aprendo il file ins di configurazione automatica, modificando le impostazioni e quindi salvando il file. Gestione profili di IEAK mantiene inoltre i file associati correnti ogni volta che il file ins di configurazione automatica viene salvato.

È possibile modificare due tipi di impostazioni di configurazione.

  • Impostazioni della procedura guidata

    Queste impostazioni corrispondono alle opzioni del browser e dei componenti inizialmente configurate nelle fasi da 2 a 5 del programma di personalizzazione guidata di Internet Explorer.

  • Criteri e restrizioni

    Queste impostazioni corrispondono alle opzioni del browser e dei componenti inizialmente configurate nella schermata Criteri e restrizioni nella Fase 5 del programma di personalizzazione guidata di Internet Explorer.

Gestione della configurazione automatica

È possibile usare un URL di configurazione automatica per indirizzare automaticamenteil browser dell'utente al Profilo IEAK. È inoltre possibile specificare il file ins o creare e specificare un file asp (Active Server Page) in grado di generare un file ins automaticamente.

È inoltre possibile specificare i file di script in formato js, jvs o pac per configurare e gestire le impostazioni avanzate del proxy. Se si specificano degli URL sia per la configurazione automatica che per il proxy automatico , quest'ultimo verrà incorporato nel file INS. L’URL corretto è http://share/test.ins

Attivazione della configurazione automatica

  1. Selezionare la casella di controllo Consenti configurazione automatica.
  2. Alla voce URL configurazione automatica (file .INS), digitare l'URL dei file ins o asp desiderati.
  3. Alla voce URL proxy automatico (file js, jvs o pac), digitare l'URL dello script proxy automatico.

Esecuzione di Gestione profili di IEAK

  1. Nel menu di avvio, selezionare Programmi, selezionare Microsoft IEAK e fare clic su Gestione profili di IEAK.
  2. Nel menu File, fare clic su Apri, quindi aprire il file ins che si desidera modificare, oppure fare clic su Nuovo per creare un nuovo file ins.

    Per utilizzare i file dei criteri di protezione per sistemi operativi diversi, scegliere l'opzione desiderata dal menu Piattaforma.

  3. Per modificare le impostazioni, fare clic su Impostazioni del programma di personalizzazione o su Criteri di protezione e restrizioni per visualizzare le categorie di impostazioni.
  4. Nel riquadro a sinistra fare clic su ciascuna categoria che si desidera modificare, quindi nel riquadro a destra apportare le modifiche desiderate.
  5. Scegliere Salva dal menu File.

    Immettere il percorso del file ins, l'URL dei file cab e i nomi di questi ultimi in caso differissero dalle impostazioni predefinite.

La posizione predefinita per il salvataggio dei file ins di configurazione automatica è la cartella
\directory di creazione\Ins\sistema operativo\lingua. Ad esempio, una versione inglese del file ins creato per la piattaforma Windows a 32 bit viene salvato nella cartella \Build1\Ins\Win32\En.

Prima dell'aggiornamento delle impostazioni di configurazione sul computer degli utenti, è necessario copiare il file ins di configurazione automatica e l'associato file cab generato da Gestione profili di IEAK in una directory di lavoro e provare la configurazione. Dopo aver convalidato le modifiche, copiare il nuovo file ins di configurazione automatica sul server. La funzione di configurazione automatica del browser aggiorna le impostazioni di configurazione sui computer degli utenti.

Note

  • Se il numero di versione del file ins non viene modificato, i nuovi file cab non verranno scaricati. Il numero di versione è composto dalla data in cui il file ins è stato modificato e dal numero di volte che il file è stato aggiornato.
  • Se si ha familiarità con i file adm, sarà possibile utilizzare le restrizioni e i criteri di protezione impostati nei propri file adm facendo clic su Criteri di protezione, quindi su Importa.
  • Se si utilizza la configurazione automatica e si supporta sia Internet Explorer 5 (o successivo) che Internet Explorer 4.0 con lo stesso file di configurazione automatica, alcune impostazioni che differiscono tra una versione e l'altra non saranno configurate in Internet Explorer 4.0.

File generati da Gestione profili di IEAK

Quando si aggiornano e si salvano le impostazioni di configurazione, Gestione profili di IEAK genera i file seguenti.

Tipo di file | Scopo
File ins di configurazione automatica | Questo file contiene le impostazioni del browser e dei componenti che Internet Explorer usa per aggiornare la configurazione del browser sui computer degli utenti. È possibile specificare queste impostazioni nella sezione Impostazioni della procedura guidata di Gestione profili di IEAK.
File cab | Questi file sono usati per organizzare i file di installazione scaricati sui computer degli utenti. I file creati da Gestione profili di IEAK devono apporre una firma digitale. Per ulteriori informazioni sulla firma dei file cab, vedere Firma dei programmi. I file cab di configurazione automatica contengono inoltre file dei file di informazione (inf).
File inf | Questi file contengono i criteri di sistema e restrizioni che il sistema operativo usa per aggiornare la configurazione del sistema sui computer degli utenti. È possibile specificare queste impostazioni nella sezione Criteri di sistema e restrizioni del Gestione profili di IEAK. Ogni file inf contiene inoltre informazioni sulla versione. Quando si modificano le impostazioni di configurazione, Gestione profili di IEAK aggiorna i file inf interessati e le relative informazioni sulla versione e crea nuovamente i file cab associati.

Internet Explorer scarica i file ins di configurazione automatica, ne elabora il contenuto ed effettua le necessarie modifiche alla configurazione dei computer degli utenti. Internet Explorer inoltre scarica e decomprime i file cab associati affinché il sistema operativo possa elaborarli. Se il numero di versione del file ins di configurazione automatica non viene modificato, i nuovi file cab non vengono scaricati. Il numero di versione è composto dalla data in cui il file ins è stato modificato e dal numero di volte che il file è stato aggiornato.

Per un'illustrazione della configurazione automatica, vedere Modalità di configurazione automatica.

Creazione di file di configurazione specifici per differenti gruppi di utenti

Se vi sono utenti con necessità diverse o se si desidera modificare le impostazioni di configurazione di alcuni utenti, indipendentemente da altri, è possibile creare più file ins di configurazione automatica. Usare Gestione profili di IEAK per specificare differenti impostazioni di configurazione per ogni gruppo e salvarle come file gruppoutente.inf individuali, dove gruppoutente è un nome univoco per ogni gruppo di utenti. Gestione profili di IEAK genera automaticamente i file cab associati. Ad esempio, è possibile specificare una configurazione specifica per il settore amministrazione e salvare la configurazione come amministrazione.ins. Gestione profili di IEAK genera quindi i file cab associati.

Nota

  • Se vengono creati più file ins di configurazione automatica, accertarsi che i pacchetti personalizzati siano configurati per usare i file corretti. È inoltre possibile usare una soluzione server automatica che abilita all'uso di più file inf senza che sia necessario ricreare i pacchetti personalizzati.

Uso di modelli personalizzati per i criteri

Gestione profili di IEAK usa una serie di modelli predefiniti di Windows per i criteri, o file di amministrazione (adm), per definire le regole per i criteri di sistema e le restrizioni. I file adm e i criteri di sistema e restrizioni sono funzioni standard delle piattaforme Windows a 32 e a 16 bit. Se si ha familiarità con i file adm, è possibile creare i propri modelli per la definizione di ulteriori restrizioni. Per ulteriori informazioni, consultare la documentazione di Windows.

Mediante Gestione profili di IEAK è possibile importare i propri file adm personalizzati e includerli insieme alle impostazioni di configurazione aggiornate. Gestione profili di IEAK genera un file inf associato, usando il prefisso del file per il file adm che viene importato. Ad esempio, se viene importato un file denominato Custom.adm, un file con lo stesso nome viene generato e aggiunto al file cab associato. Per ulteriori informazioni sull'uso di file ADM personalizzati, vedere Impostazioni e restrizioni.

Modifica della posizione di memorizzazione dei file inf di configurazione automatica

Se è necessario spostare i file di configurazione automatica in un server differente, è possibile usare Gestione profili di IEAK per aggiornare l'URL per la configurazione automatica del browser. Se si imposta il file ins di configurazione automatica per eseguire gli aggiornamenti a determinati intervalli, dopo l'aggiornamento dell'URL per la configurazione automatica, è necessario attendere due intervalli affinché le modifiche abbiano effetto.

Aggiornamento dell'URL per la configurazione automatica del browser

  1. Nel menu di avvio, selezionare Programmi, selezionare Microsoft IEAK e fare clic su Gestione profili di IEAK.
  2. Nel menu File, fare clic su Apri, quindi fare clic sul file ins di configurazione automatica del pacchetto personalizzato.
  3. In Impostazioni della procedura guidata, fare clic su Configurazione automatica del browser.
  4. Nella casella URL configurazione automatica (file ins), digitare il nuovo percorso al server.
  5. Scegliere Salva con nome dal menu File. Digitare un nome per il file, mantenendo l'estensione ins.
  6. Digitare il percorso al nuovo server per i file ins per farlo corrispondere all'URL inserito, all'URL dei file cab e i nomi dei file cab.

    È necessario copiare tutti i file cab che sono stati creati nella cartella di creazione nella stessa cartella che contiene il file ins.

Quando l'utente avvia il browser ed è previsto l'aggiornamento delle impostazioni di configurazione, il puntatore all'URL per la configurazione automatica del browser viene aggiornato sul computer dell'utente. A questo punto, il browser usa ancora le impostazioni della configurazione automatica del file INS originale, ad esempio http://percorso esistente/Default.ins).

Quando l'utente avvia il browser una seconda volta ed è nuovamente previsto l'aggiornamento delle impostazioni di configurazione, il browser legge il nuovo file INS per la configurazione automatica, ad esempio http://nuovo percorso/Default.ins). Quando si è certi che le impostazioni di tutti i computer degli utenti sono state aggiornate, è possibile rimuovere la copia del file inf di configurazione automatica dalla sua posizione originale.

Uso di Gestione profili per la gestione di sistemi Windows 2000

Se si usa una installazione automatica per distribuire Internet Explorer su Windows 2000, è possibile usare Gestione profili di IEAK per specificare impostazioni personalizzate per Internet Explorer. Queste impostazioni verranno configurate quando lo script di installazione automatica viene eseguito. Gestione profili abilita alla creazione di file inf e, se necessario, di file cab. Il file ins è specificato nella sezione [Branding] del file Unattend.txt. Per ulteriori informazioni, consultare la documentazione dell'Installazione di Windows 2000.

Pr specificare Windows 2000 come piattaforma, fare clic sul menu Piattaforma, quindi su Windows 2000. In Impostazioni della procedura guidata, fare clic sulle voci che si desidera personalizzare.

Restrizioni, che determina quali impostazioni sono modificabili dagli utenti, non è disponibile in Gestione profili di IEAK nella piattaforma Windows 2000. Per impostare delle restrizioni nella piattaforma Windows 2000, usare Criteri di gruppo. Per ulteriori informazioni, ricercare la voce "Criteri di gruppo" nella guida in linea di Windows 2000.

Opzioni per certificati digitali non sono disponibili in Gestione profili di IEAK in Windows 2000, dal momento che Windows 2000 contiene caratteristiche avanzate di gestione dei certificati. Per ulteriori informazioni, ricercare la voce "Certificati digitali" nella guida in linea di Windows 2000.


Riferimenti IEAK

Per informazioni su IEAK, vedere i seguenti argomenti:

  • Amministrazione di Microsoft Internet Explorer in Windows 2000
  • Marcatura e personalizzazione della grafica
  • Protezione in Internet Explorer
  • Personalizzazione del client di servizi Messenger
  • Ridistribuzione di Internet Explorer
  • Installazione in modalità batch
  • Aggiornamento periodico per gli utenti
  • Installazione di Windows Update per Internet Explorer e Accesso a Internet
  • Utilizzo dei file di informazioni per l’installazione (inf)
  • Tipi di file
  • Configurazione della ricerca automatica
  • Personalizzazione della barra di ricerca e di Search Assistant

Risorse ulteriori

Per verificare le risorse e gli aggiornamenti alla tecnologia più recenti, visitare i seguenti siti Web:

  • Il sito Web di IEAK
  • Il sito Web di Microsoft Security Advisor
  • Il sito MSDN Online Web Workshop
  • Il sito Web Corporate Windows Update


Configurazione della ricerca automatica

È possibile personalizzare ricerca automatica che abilita gli utenti a digitare una parola di uso convenzionale nella barra degli indirizzi per ricercare pagine di Internet Explorer frequentemente usate. Gli utenti non devono ricordare gli URL delle pagine specificate, in modo da facilitare la ricerca delle informazioni importanti.

Ad esempio è possibile visualizzare una pagina Web sulle fatture quando l'utente digita fattura nella barra degli Indirizzi anche se l'URL della pagina non contiene questo termine. Gli amministratori delle reti intranet possono visualizzare il seguente argomento per personalizzare la ricerca automatica. Per ulteriori informazioni i fornitori di contenuto Internet o i fornitori di servizi Internet possono inviare un messaggio di posta elettronica a autosrch@microsoft.com.

Questa funzionalità è già attivata per Internet. Per esempio, immettendo uno di questi termini distinti nella barra degli indirizzi viene subito visualizzato il sito Web associato. Quando a un dato termine non è possibile associare in modo distinto un sito Web, se ad esempio vi sono troppe corrispondenze, viene visualizzata una pagina Web in cui sono riportati i risultati più significativi.

Il sito Web visualizzato non contiene necessariamente nel proprio URL il termine di ricerca specificato. Se un sito Web con lo stesso dominio del termine non corrisponde al termine di ricerca, se ad esempio il termine di ricerca ha lo stesso URL senza "www." e ".com", l'utente viene reindirizzato al sito che meglio corrisponde al temine. In base all'impostazione predefinita, l'utente viene informato quando si verifica il reindirizzamento.

Impostazione della ricerca automatica

  1. Creazione di file script (ASP) per il controllo condizionale dei termini di ricerca e l'invio a un server intranet alla posizione seguente.

    http://ieautosearch/response.asp?MT=%1&srch=%2

    Vedere Parametri per la configurazione della ricerca automatica per la descrizione dei parametri %1 e %2.

    Se non si usa Internet Information Server (IIS), si deve reimpostare l'URL nell'indirizzo in cui si trova lo script.

  2. Se si modificano le impostazioni dal programma di personalizzazione di Internet Explorer, nella schermata Criteri e restrizioni della Fase 5, fare clic su Impostazioni Internet.

    oppure

    se l’opzione viene impostata nel Gestione profili, fare clic su Criteri di protezione e restrizioni, quindi su Impostazioni Internet.

  3. Fare clic su Impostazioni avanzate e quindi su Ricerca, nella barra Ricerca parola chiave del fornitore, digitare intranet.

Note

  • È possibile usare i criteri di protezione e restrizioni per reindirizzare gli utenti su un altro sito invece di fornire i risultati della ricerca. Per eseguire questa operazione, fare clic su Impostazioni Avanzate. Alla voce Ricerca, nella barra Ricerca dalla barra degli indirizzi, sceglierePassa al sito che maggiormente corrisponde ai criteri di ricerca specificati.
  • Gli amministratori delle reti intranet che non hanno accesso a Internet e che non desiderano una ricerca personalizzata possono usare i criteri di protezione e restrizioni per disabilitare la ricerca automatica. Per eseguire questa operazione, fare clic su Impostazioni Avanzate. Alla voce Ricerca, nella barra Ricerca dalla barra degli indirizzi , scegliere Non eseguire la ricerca dalla barra degli indirizzi.

Parametri per la configurazione della ricerca automatica

Configurazione della ricerca automatica http://ieautosearch/response.asp?MT=%1&srch=%2 sostituendo i due parametri con i segni di percentuale (%). Questi due valori devono appartenere all'URL.

Parametro | Valore
%1 | Stringa digitata dall'utente nella barra degli Indirizzi.
%2 | Tipo di ricerca selezionato dall'utente.
 | 3 | Visualizza i risultati e passa al sito che maggiormente corrisponde ai criteri di ricerca specificati
 | 2 | Passa al sito che maggiormente corrisponde ai criteri di ricerca specificati.
 | 1 | Visualizza i risultati nella finestra principale.
 | 0 | Non eseguire la ricerca nella barra degli Indirizzi.

Script asp di esempio di ricerca automatica

<%@ Language=VBScript %>

<%
    'ricerca contiene le parole digitate nella barra degli indirizzi
    ' dall'utente, senza delimitatori come "visualizza" o
    ' "cerca" o altri delimitatori come
    ' "+" per gli spazi.
    Se l'utente digita
    ' "Apple pie," search = "Apple pie."
    Se l'utente digita
    ' "find Apple pie," search = "Apple pie."
    search = Request.QueryString("MT")
    search = UCase(search)
    searchOption = Request.QueryString("srch")

    ' Questo è un semplice if/then/else
    ' per reindirizzare il browser al sito
    ' selezionato sulla base di quello che
    ' l'utente ha digitato.
    Esempio: gestione dei rimborsi spese è una pagina intranet
    per la compilazione della gestione dei rimborsi spese
    if (search = "NEW HIRE") then
        Response.Redirect("http://admin/hr/newhireforms.htm")
    elseif (search = "LIBRARY CATALOG") then
        Response.Redirect("http://library/catalog")
    elseif (search = "EXPENSE REPORT") then
        Response.Redirect("http://expense")
    elseif (search = "LUNCH MENU") then
        Response.Redirect("http://cafe/menu/")
    else
        ' Se non si trova la corrispondenza, usare
        ' il server predefinito di ricerca automatica IE
        Response.Redirect("http://auto.search.msn.com/response.asp?MT="
        + search + "&srch=" + searchOption +
        "&prov=&utf8")
    end if

%>

Per informazioni su altri modi di personalizzazione della ricerca dell'utente, vedere Personalizzazione della barra di ricerca e di Search Assistant.


Personalizzazione della barra di ricerca e di Search Assistant

È possibile utilizzare la barra di ricerca per effettuare una ricerca e visualizzare i relativi risultati. Quando si fa clic sul pulsante Cerca, la barra di ricerca viene visualizzata alla sinistra del browser in una sezione denominata barra Explorer.

Nella barra di ricerca viene visualizzato Microsoft Windows Search Assistant, che offre agli utenti la possibilità di effettuare una ricerca unificata scegliendo tra diverse tipologie di ricerca. Search Assistant dispone di vari pulsanti che consentono agli utenti di specificare il tipo di informazioni che stanno cercando invece del motore di ricerca che desiderano utilizzare.

L'utente può personalizzare Internet Explorer in modo che nella barra di ricerca venga utilizzato un solo motore di ricerca. In alternativa, l'ISP o l'amministratore di reti intranet può personalizzare la barra di ricerca per adattarla alle esigenze dell'azienda, utilizzando JScript (compatibile con le specifiche del linguaggio ECMA 262), Visual Basic Scripting Edition (VBScript), controlli ActiveX, HTML dinamico, set di frame, fogli di stile CSS (cascading style sheets) e tutte le altre tecnologie compatibili con il browser Internet Explorer. Specificare l'URL della barra di ricerca nella schermata URL importanti nella Fase 4 del programma di personalizzazione di Internet Explorer.

I risultati della ricerca vengono in genere visualizzati nella barra di ricerca. L’utilizzo dei risultati di qualsiasi servizio di ricerca non è facile. Le funzionalità della barra di ricerca possono essere utilizzate per memorizzare informazioni dettagliate relative al testo, all'URL o alle dimensioni dei file. Queste informazioni vengono visualizzate sotto forma di descrizioni comando che appaiono quando si sposta il puntatore sul risultato di una ricerca. In questo modo la pagina dei risultati è comunque leggibile e le informazioni fornite all'utente sono dettagliate.

Come personalizzare l'interfaccia utente della barra di ricerca

Di seguito sono riportate alcune indicazioni per personalizzare la barra di ricerca senza comprometterne il corretto funzionamento all'interno della barra di Explorer.

  • Dalle pagine dei risultati dovrebbe essere sempre possibile effettuare un'altra ricerca, attraverso pulsanti per la modifica e l'esecuzione della ricerca situati nella parte superiore della finestra.
  • La larghezza delle pagine non dovrebbe essere superiore alla larghezza della barra di ricerca, che in base all'impostazione predefinita è pari a 200 pixel. Se si utilizzano delle tabelle o altri elementi in formato HTML, verificare che si adattino alla larghezza disponibile. In caso contrario sarà necessario visualizzare le barre di scorrimento orizzontale, con una conseguente riduzione dell'area destinata al contenuto e un notevole aumento di lavoro per l'utente. Le descrizioni comando sono consigliate se si desidera includere altre informazioni di ogni genere senza ridurre ulteriormente lo spazio.
  • Per ottenere effetti dinamici e migliorare la multimedialità, è possibile utilizzare l’HTML dinamico, la tecnologia ActiveX, Java e i fogli di stile CSS, purché si tenga ben presente che lo spazio per la barra di ricerca è limitato.
  • La dimensione predefinita della barra di ricerca è pari a 200 pixel di ampiezza e alla dimensione complessiva verticale della finestra del browser, pari a 430 pixel. A seconda delle proprie necessità, è possibile inserire contenuti pubblicitari, marcature e informazioni relative alla ricerca. L'utente potrà ridimensionare quest'area.
  • Poiché lo spazio della barra di ricerca è limitato, si dovrà dare priorità all’interfaccia utente. La regola di base consiste nell’offrire all’utente le migliori informazioni senza ostacolarne o confonderne la visualizzazione. Dall’alto verso il basso l’interfaccia si presenta normalmente nel seguente ordine:
    • Marcatura
    • Campi nei quali definire meglio la ricerca
    • Risultati della ricerca
    • Pubblicità o altri servizi
    È opportuno collocare le informazioni pubblicitarie nella parte inferiore della pagina in modo che gli utenti non debbano necessariamente scorrerle per vedere i risultati.
  • Se è necessario che l'utente faccia scorrere la pagina, controllare che siano subito disponibili un numero significativo di risultati effettivi e non solo i risultati di una categoria.
  • I collegamenti per i risultati della ricerca vengono normalmente visualizzati nella barra di ricerca. Quando un utente fa clic su uno di questi collegamenti, la pagina Web viene visualizzata nell'area della finestra del browser. È meglio evitare di aprire le pagine Web dalla barra di ricerca, perché questa non contiene i pulsanti Indietro e Avanti.

Tecniche per la personalizzazione di Search Assistant

Lo strumento Search Assistant può essere personalizzato per meglio soddisfare le particolari esigenze di ricerca. È ad esempio possibile archiviare all’interno della descrizione comando altre informazioni sui risultati della ricerca e tali risultati possono apparire evidenziati in una data pagina Web.

Ricerca mediante la selezione di parti evidenziate

Il metodo NavigateAndFind può essere utilizzato per ricercare nelle pagine Web una parola o una frase. Questo metodo carica una pagina Web specifica ed effettua la scansione del documento per trovare una corrispondenza con la stringa fornita. Se la corrispondenza viene trovata, la stringa nel documento viene evidenziata.

Esempio

L’esempio che segue apre il sito Web Microsoft per cercare la stringa "Microsoft Corporation".

window.external.NavigateAndFind("http://www.microsoft.com","Microsoft Corporation");

Sunti delle descrizioni comandi e dei collegamenti

Per conservare lo spazio nella finestra del browser e migliorare la leggibilità dei risultati della ricerca, Internet Explorer consente di definire particolari informazioni riguardanti un dato collegamento che devono essere incluse nella descrizione comando. Per eseguire questa operazione, definire l’attributo TITLE= di un tag di ancoraggio HTML.

Esempio

L’esempio che segue offre ulteriori informazioni sul collegamento:

<A HREF="http://www.acme-sports.com" TITLE="Ultime notizie sportive e risultati, aggiornati di ora in ora.">Ultime notizie sportive</A>
aggiornate di ora in ora. Interviste con i vincitori.">Ultime notizie sportive</A>

Aprire questo collegamento per visualizzare l'anteprima: Ultime notizie sportive

Forzare l'interruzione di linea nelle descrizioni comando

La descrizione comando interrompe automaticamente le righe ad una lunghezza di tre pollici e può contenere almeno un paragrafo di testo. All’interno del testo della descrizione comando non sono ammessi tuttavia più di 1.024 caratteri. È anche possibile aggiungere una nuova riga o degli spazi di tabulazione utilizzando i caratteri speciali &#10 e &#13 per il ritorno a capo e l'avanzamento riga e &#09 per gli spazi di tabulazione.

Esempio

L’esempio che segue include un ritorno a capo e un avanzamento riga dopo la riga 1 della descrizione comando:

<A HREF="http://www.microsoft.com"
   TITLE="Testo visualizzato alla riga1&#10;&#13;
   Testo visualizzato alla riga2&#10;
   &#09;Testo visualizzato alla riga2&#10;
   &#09;Testo visualizzato alla riga4">
Uso di più righe nelle descrizioni comando</A>

Aprire questo collegamento per visualizzare l'anteprima: Uso di più righe nelle descrizioni comando

Per ulteriori informazioni sugli script e sull'HTML dinamico, visitare MSDN Online Web Workshop.

Per informazioni sulla funzione di ricerca automatica, che consente agli utenti di digitare frasi nella barra degli strumenti Indirizzo, vedere Configurazione della ricerca automatica.


Tipi di file

Tipo di file | Descrizione
.adm | Il file di amministrazione (adm) definisce i criteri di sistema e le restrizioni per il desktop, la shell e la protezione. È possibile personalizzare e limitare le impostazioni in un file adm utilizzando Internet Explorer Administration Kit (IEAK) o l'Editor dei criteri di sistema di Windows. Per una lista dei criteri di sistema e le restrizioni che è possibile impostare in un file standard adm, vedere Come utilizzare Gestione profili di IEAK
.asp | Se si distribuisce Internet Explorer da un server Web, è possibile includere un file asp (Active Server Page) nel pacchetto browser personalizzato. Utilizzando i file asp, è possibile incorporare script nelle pagine HTML per creare un contenuto dinamico e interattivo del sito Web. Ad esempio, è possibile creare pagine per l'abbonamento che consentono di scaricare il browser e iscriversi ai servizi Internet. È possibile indicare i file asp nel programma di personalizzazione di Internet Explorer o nel Gestione profili di IEAK. Il CD-ROM del Resource kit include i file asp di esempio.
bat | Un file di testo ASCII contenente una sequenza di comandi del sistema operativo, inclusi parametri e operatori supportati dal linguaggio di comandi batch. Quando viene digitato il nome del file batch dal prompt dei comandi, il computer elabora i comandi in modo sequenziale.
bmp, gif, jpeg, jpg | Internet Explorer può includere immagini animate e statiche che utilizzano file in formato bmp, gif, jpeg o jpg. Oltre ad utilizzare i file di grafica forniti con IEAK, è possibile crearne di nuovi ed includerli nel pacchetto browser personalizzato. Ad esempio, è possibile sostituire il logo di Internet Explorer o la schermata di avvio dell'esecuzione con file di grafica animata o statica. IEAK include due strumenti di supporto per la creazione di immagini animate personalizzate. Per ulteriori informazioni sui requisiti della grafica che è possibile personalizzare, vedere Creazione di grafica personalizzata.
cab | I file cab vengono utilizzati per organizzare e contenere i file di installazione compressi copiati nel computer dell'utente. Installazione di Windows Update (IE5Setup.exe) consente di scaricare i file cab necessari per l'installazione di Internet Explorer nel computer dell'utente. I file cab possono contenere i componenti del browser e i componenti personalizzati. Una volta terminato il download, l'installazione di Windows Update è completa. IEAK contiene una serie di strumenti di ausilio alla creazione dei file cab per i componenti personalizzati.
cdf | Un file cdf (channel definition format) consente di utilizzare canali per distribuire il contenuto Web o aggiornare il software. Il file cdf fornisce un indice di risorse disponibili in un canale e una pianificazione consigliata degli aggiornamenti dei canali sui computer. Quando si è sottoscritto l'abbonamento ad un canale, la cache locale viene aggiornata con nuove informazioni specificate dall'autore nel file cdf.
cif | Un file cif (component information) denominato IESetup.cif identifica i componenti che è possibile installare con Internet Explorer, inclusi quelli nuovi o gli aggiornamenti. Nel file cif ad ogni componente corrisponde un ComponentID. L'installazione di Windows Update legge i file cdf e determina, in tal modo, se un componente con unComponentID specifico è già installato e se è disponibile una versione più aggiornata per l'installazione.
cmp | I file cmp (connection profile) sono creati da CMAK e contengono informazioni specificate dall'utente. Non modificare i file cmp. L'utente potrebbe sovrascrivere le modifiche.
cms | I file del provider di servizi (cms) sono creati da CMAK e specificano la configurazione della rubrica e gran parte delle altre funzioni dei profili di servizio. La maggior parte delle personalizzazioni avanzate di un profilo di servizi viene effettuata modificando il file cms specifico.
exe | Il file eseguibile (exe) denominato IE5Setup.exe è il programma che controlla il processo di installazione. Esso scarica i file cab che installano il pacchetto browser personalizzato sul computer degli utenti. I file cab possono includere file autoestraenti aggiuntivi per i componenti del browser e i componenti personalizzati.
htt | I file htt (HTML template) forniscono modelli personalizzati per Risorse del computer (Mycomp.htt), Pannello di controllo (Controlp.htt), Stampanti (Printers.htt), e le visualizzazioni Web predefinite della cartelle (Folder.htt). Utilizzando un editor di testo o di HTML, è possibile personalizzare questi file con speciali istruzioni, logo o collegamenti ai siti Web. È possibile includere Mycomp.htt e Controlp.htt nel pacchetto browser personalizzato. È necessario personalizzare i modelli Printers.htt e Folder.htt direttamente sul computer degli utenti.
inf | Di solito ogni file cab di Internet Explorer contiene un file inf con ulteriori informazioni per l'installazione. Il file inf può fare riferimento a dei file contenuti nel file cab, così come a dei file referenziati da altri URL.
ins | L'installazione di Windows Update contiene un file ins che provvede a configurare il browser e i suoi componenti. È possibile creare più versioni del pacchetto browser personalizzando copie di questo file. Il Gestione profili di IEAK consente inoltre di creare, salvare e caricare file ins per l'aggiornamento delle impostazioni di configurazione di Internet Explorer.
isp | Se si sta effettuando un processo di iscrizione con il pacchetto browser personalizzato, un file isp (Internet sign-up) denominato Signup.isp fornirà informazioni sulla connessione per i servizi Internet. Utilizzando il programma di personalizzazione di Internet Explorer, è possibile modificare i parametri contenuti nel file per l'abbonamento a Internet. Il file per l'abbonamento contiene anche un collegamento all'URL dello script eseguito sul server che crea il file di configurazione ins, utile in caso di modalità di abbonamento basato su server.
pac, js, jvs | È possibile utilizzare un editor di testo per creare un file script del proxy automatico per il pacchetto browser personalizzato. Un file script del proxy automatico può essere un file JScript (js), JavaScript (jvs), o di configurazione del proxy automatico (pac). Se è stato specificato un file script del proxy automatico, Internet Explorer userà tale file per determinare dinamicamente se effettuare una connessione diretta al server o se usare un server proxy. Nella Fase 4 del programma di personalizzazione di Internet Explorer, è possibile specificare un URL del proxy automatico per configurare e conservare impostazioni avanzate del proxy.
pdf | Se si utilizza Microsoft Systems Management Server per distribuire Internet Explorer, il pacchetto browser personalizzato consiste in una cartella di file di installazione e in un file di definizione del pacchetto (pdf). Il file IE5.pdf contiene un programma di installazione, opzioni di installazione e sintassi della riga di comando per l'installazione automatica di Internet Explorer sul server o sui computer degli utenti. Questo file consente l'installazione senza l'intervento dell'amministratore o dell'utente.
pvk | Un file delle chiavi private che contiene la chiave privata associata ad una firma digitale.
pwl | File contenente la password di Windows di un utente di questo computer.
sed | I file sed (connection profile) sono creati da CMAK e contengono le istruzioni relative alla creazione di un file eseguibile autoestraente (exe) per i profili di servizio. Non modificare i file sed.
spc | Un file Certificato distribuzione software. I certificati contengono il nome e altre informazioni relative al possessore del certificato, la chiave pubblica associata al certificato, un numero seriale, il periodo di validità del certificato e la firma digitale dell'autorità che lo ha emesso.


Creazione di grafica personalizzata

Prima della preparazione della grafica per il logo, controllare il contratto di licenza per verificare che la personalizzazione sia legalmente possibile.

Installazione di Windows Update

Grafica | Dimensione e tipo | Note aggiuntive
Linee verticali a sinistra | File bmp a 256 colori, 162 x 312 pixel | L’icona verticale viene visualizzata sulla prima pagina della procedura guidata dell’installazione di Windows Update.
Linee orizzontali in alto | File bmp a 256 colori, 496 x 312 pixel | L’icona orizzontale viene visualizzata su tutte le pagine nella procedura guidata dopo la prima pagina. L’intestazione orizzontale in alto deve essere chiara come una “filigrana” per rendere leggibile il testo nell’interfaccia utente.

Browser Internet Explorer

Per un'illustrazione su dove vengono visualizzati i grafici nel browser personalizzato, vedere Modalità della personalizzazione.

Grafica | Dimensione e tipo | Note aggiuntive
Logo statico File bmp di 38 x 38 e
22 x 22 pixel 		Creazione di due bitmap a 256-colori (38 x 38 e 22 x 22 pixel). Salvare i file nella cartella bitmap personalizzata (CIE\Bitmaps). Quando il browser non è attivo, il primo frame del logo animato viene utilizzato come logo statico.
Logo animato File bmp di 38 x 38 e
22 x 22 pixel per ciascun frame animato 		Per ogni frame animato, creare due bitmap a 256 colori (38 x 38 e 22 x 22 pixel). Salvare i file nella cartella bitmap personalizzata (CIE\Bitmaps). Quando il browser non è attivo, il primo frame del logo animato viene utilizzato come logo statico.

Utilizzare gli strumenti per le bitmap animate di IEAK per impilare le bitmap nel formato corretto e creare il logo animato. Il logo animato deve contenere uno stack verticale di immagini di animazione di cella che seguono le regole di animazione di Internet Explorer.

Regole di animazione per il logo di Internet Explorer

  • Le celle da 1 a 4 sono celle principali che vengono visualizzate quando Internet Explorer comincia a sfogliare.
  • Le celle da 5 a X, dove X sta per il numero totale delle celle, vengono eseguite finché le operazioni di browse sono completate.
Sfondo della barra degli strumenti | Nessuna dimensione specifica | Lo sfondo dovrà avere le dimensioni della barra degli strumenti e un colore tale da fare risaltare il testo di colore nero.
Pulsante della barra degli strumenti del browser | Due file di icona con immagini monocromatiche e a colori per gli stati attivo e inattivo | Per ulteriori informazioni, vedere Progettazione delle icone della barra degli strumenti di Internet Explorer.
Icone per l'elenco Preferiti | File bmp di 16 x 16 pixel per ciascun elemento che si desidera personalizzare
Schermata di avvio dell’esecuzione automatica (se viene distribuito il pacchetto personalizzato su CD) | Bitmap di 540 x 357 pixel visualizzata dopo aver inserito il CD | Prima di creare la schermata di avvio, sarà necessario convertire tutte le immagini a 24 bit in una comune tavolozza a 256 colori. Per ulteriori informazioni vedereCreazione di una bitmap per la schermata di avvio dell'esecuzione automatica.
Canali Per ciascun canale
  • un’icona di 32 x 32 pixel
  • un grafico di 80 x 32 pixel per la barra dei canali
  • un grafico di 194 x 32 pixel per il riquadro dei canali
 I grafici di 80 x 32 e 194 x 32 pixel possono essere in formato gif, bmp o jpeg.

Connessione guidata Internet, abbonamento a Internet

Grafica | Dimensione e tipo
Immagine superiore visualizzata nell’angolo superiore destro della Connessione guidata Internet | File bmp a 49 x 312 pixel
Immagine verticale visualizzata sul lato sinistro delle schermate della Connessione guidata Internet | File bmp a 164 x 458 pixel

Nota

  • La Connessione guidata Internet non è disponibile con la modalità di abbonamento senza server.

Il servizio di elenchi in linea della Rubrica di Windows (usato in Outlook Express)

Dimensione e tipo | Note aggiuntive
File bmp a 134 x 38 pixel | Usare la tavolozza di Windows a 16 colori.

Personalizzazione di MSN Messenger Service

Dimensione e tipo | Note aggiuntive
File gif a 234 x 50 pixel | Usare uno sfondo bianco (valore RGB 255,255,255) e non un canale di trasparenza. Usare una tavolozza a prova di browser.


Strumenti per bitmap animate

Prima della preparazione della grafica per il logo, controllare il contratto di licenza per verificare che la personalizzazione sia legalmente possibile.

IEAK dispone di due strumenti distinti per creare e personalizzare le bitmap animate per il browser.

  • Il Creatore di bitmap animate viene utilizzato per impilare una serie di bitmap numerate in modo sequenziale, creando un'unica bitmap con il formato corretto per l'animazione.
  • Il Visualizzatore in anteprima di bitmap animate fornisce invece un'anteprima dell'animazione della bitmap e può essere utilizzato anche per visualizzare qualsiasi bitmap che abbia un formato corretto.

È necessario verificare che le bitmap abbiano la dimensione e il formato corretti. Per ulteriori informazioni, vedere Creazione di grafica personalizzata.

Nota

  • Questi strumenti sono forniti agli amministratori e non sono distribuiti come prodotti supportati da Microsoft. Si trovano entrambi nella cartella \<IEAK>\Toolkit\Graphics\Tools.

Creatore di bitmap animate (Makebmp.exe)

Per eseguire questo strumento, digitare l’istruzione seguente al prompt dei comandi MS-DOS.

makebmp nomebase numfile nomeoutput

Elementi della sintassi | Significato
makebmp | Nome dello strumento
nomebase | Parte del nome comune a tutti i file, senza numeri e senza estensione .bmp.
numfile | Numero di bitmap che devono essere aggiunte in modo sequenziale al file di animazione.
nomeoutput | Nome del file finale. È necessario includere l'estensione .bmp.

Esempio

Per combinare i file da Bitmap0.bmp a Bitmap19.bmp, digitare quanto segue.

makebmp bitmap 20 final.bmp

Nota

  • Numerare in modo sequenziale i file iniziando da 0. Ad esempio, Iebmp0.bmp Iebmp1.bmp Iebmp2.bmp fino a Iebmp24.bmp. La parte comune del nome di questi 25 file è Iebmp.

Visualizzatore in anteprima di bitmap animate (Animbmp.exe)

È possibile avviare questo programma sia dal prompt dei comandi MS-DOS che da Esplora risorse. Dopo avere avviato Animbmp.exe, sono disponibili due metodi per visualizzare in anteprima una bitmap animata: trascinare il file nella casella o scegliere Apri dal menu File. I frame principali vengono visualizzati solo una volta, mentre le bitmap vengono eseguite continuamente.


Creazione di una bitmap per la schermata di avvio dell'esecuzione automatica

Queste istruzioni presuppongono che si inizi con bitmap di formato RGB a 24 bit. Se il file non è un bitmap di formato RGB a 24 bit, è necessario convertirlo.

  1. Creazione di una immagine bitmap a 540 x 357 pixel, 256 colori.

    Una bitmap di questo tipo costituisce un'introduzione al prodotto e contiene le etichette per due pulsanti, uno per l'installazione di Internet Explorer e l'altro per la visualizzazione di ulteriori informazioni.

  2. Usando un programma di grafica, creare una immagine di lavoro per la propria tavolozza. A tale scopo, copiare i file per lo sfondo e per il pulsante in un singolo file. Accertarsi che i file siano affiancati e che non si sovrappongano.
  3. Salvare il file con il nome Palette.bmp.

Nota

  • Le dimensioni della bitmap sono importanti, poiché in base a queste verranno modificate le dimensioni della finestra di dialogo. Se la bitmap non è sufficientemente ampia, il testo presente nella finestra di dialogo potrebbe essere visualizzato solo parzialmente.


Progettazione delle icone della barra degli strumenti di Internet Explorer

Per creare un'icona per la barra degli strumenti, sarà necessario definire ogni immagine con due intensità di colore e in due dimensioni, una per ciascuno degli stati della barra, ovvero monocromatica per lo stato predefinito e a colori per lo stato attivo quando l'utente posiziona il mouse su di essa.

Creazione di immagini

  1. Dopo avere disegnato le immagini utilizzando un programma di grafica, posizionare le immagini a 16 e a 256 colori in file separati.
  2. Associare ogni file alla tavolozza di Windows appropriata, a 16 colori o dei mezzitoni. Assegnare un colore specifico per la trasparenza.
  3. Salvare ogni file in formato .bmp.

Di seguito vengono riportate le immagini necessarie:

Stato dell'icona Grandezza, in pixel Intensità del colore/Tavolozza Bordo Aspetto Esempio
Attivo 20 per 20 Tavolozza a mezzitoni di Windows a 256 colori Stile bordi delle icone: a colori sui margini superiore e sinistro e in nero sui margini inferiore e destro
  • Immagine a colori
  • Più ombreggiatura e profondità rispetto ad un'immagine a 16 colori
  • Una sorgente luminosa dall'angolo superiore sinistro e un'ombreggiatura dove necessario
 Stato attivo: 256 colori, 20 x 20 pixel
20 x 20 Tavolozza di Windows a 16 colori Nero, tranne quando un bordo impedisce la corretta lettura di un'icona
  • Immagine a colori
  • Poca ombreggiatura; nessun effetto
 Stato attivo: 16 colori, 20 x 20 pixel
16 x 16 Tavolozza di Windows a 16 colori Nero, tranne quando un bordo impedisce la corretta lettura di un'icona
  • Immagine a colori
  • Poca ombreggiatura; nessun effetto
 Stato attivo: 16 colori, 16 x 16 pixel
Predefinito 20 x 20 Tavolozza a mezzitoni di Windows a 256 colori Stile bordi delle icone: a toni di grigio sui margini superiore e sinistro e in nero sui margini inferiore e destro
  • Immagine monocromatica
  • Più ombreggiatura e profondità rispetto ad un'immagine a 16 colori
  • Una sorgente luminosa dall'angolo superiore sinistro e un'ombreggiatura dove necessario
 Stato predefinito: 256 colori, 20 x 20 pixel
20 x 20 Tavolozza di Windows a 16 colori Nero, tranne quando un bordo impedisce la corretta lettura di un'icona
  • Immagine monocromatica
  • Poca ombreggiatura; nessun effetto
 Stato predefinito: 16 colori, 20 x 20 pixel
16 x 16 Tavolozza di Windows a 16 colori Nero, tranne quando un bordo impedisce la corretta lettura di un'icona
  • Immagine monocromatica
  • Poca ombreggiatura; nessun effetto
 Stato predefinito: 16 colori, 16 x 16 pixel

Assicurarsi che la transizione visiva tra le immagini predefinite e quelle attive sia omogenea. Un metodo semplice per effettuare un controllo consiste nel creare livelli separati per tali immagini utilizzando un programma fotografico che consenta di visualizzarle in sovrapposizione.

Modifica di immagini bitmap in icone

Sarà necessario creare due file .ico per ciascuna icona:

  • Il primo file contiene l'immagine attiva, a colori, con entrambe le dimensioni e le intensità di colore.
  • Il secondo file contiene le immagini predefinite, monocromatiche, con entrambe le dimensioni e le intensità di colore.

Si consiglia di utilizzare un programma di grafica per disegnare le icone e un ambiente di sviluppo, ad esempio Microsoft Visual C++ Development Studio, per creare i file di icona.

Esempio

I due file .ico dell'icona Pagina iniziale contengono le seguenti immagini:

Stato attivo | Stato predefinito
Icone per lo stato attivo | Icone per lo stato predefinito

Per creare file di icona in Visual C++

  1. Aprire ciascun file .bmp.
  2. Scegliere New dal menu File, quindi fare clic su Icon. Come impostazione predefinita, la finestra dell'icona che viene visualizzata contiene l'immagine di un video standardi 32 x 32 pixel.
  3. Nella finestra icona, fare clic su New Device Image. Fare clic su Custom, quindi creare le seguenti immagini video:
    • Un'immagine a 16 colori, 22 x 20 pixel
    • Un'immagine a 256 colori, 22 x 20 pixel
    • Un'immagine a 16 colori, 18 x 16 pixel

    Nota

    • Le immagini video sono maggiori di due pixel se paragonate alle altre immagini. Posizionare le immagini al centro dell'area del video.
  4. Eliminare l'immagine video predefinita di 32 x 32 pixel.
  5. Copiare le immagini a colori dai file .bmp e incollarle nella dimensione e intensità di colore apprpriata dell'immagine video.
  6. Per rendere trasparente lo sfondo, selezionare il colore trasparente dalla tavolozza dei colori e applicarlo allo sfondo di tutte le immagini che si desidera rendere trasparenti.
  7. Salvare questo file come file di icona.

Per creare un file di icona monocromatico predefinito, seguire la stessa procedura.


Inclusione di una stringa Agente utente

Alcune società effettuano delle statistiche sul proprio sito, ad esempio il numero di accessi e il tipo di browser Web usato. Le stringhe Agente utente consentono di identificare il tipo di browser in uso.

Se si raccolgono dati statistici relativi ai browser e le informazioni comprendono una stringa Agente utente, sarà possibile tenere traccia della frequenza di uso del browser personalizzato. Nel programma di personalizzazione guidata di Internet Explorer è possibile personalizzare la stringa Agente utente aggiungendo una serie di caratteri al termine di tale stringa.

La stringa personalizzata verrà visualizzata in tutte le statistiche che comprendono la stringa Agente utente. Anche altre società che tengono traccia di queste statistiche potranno visualizzare la stringa personalizzata. Evitare di utilizzare una stringa che non si desidera rendere nota a terze parti.

Esempio

Di seguito è riportato un esempio di stringa Agente utente.

Mozilla/4.0(compatible; MSIE 5.5; WindowsNT; StringaPersonalizzata)

Nota

La dimensione massima consigliata per la stringa Agente utente è di 200 caratteri.


Protezione in Internet Explorer

Internet Explorer consente di controllare il livello di protezione in diversi modi: medante i certificati dei siti, gli autori di Authenticode e le aree di protezione. È possibile preinstallare i certificati nei computer degli utenti per impedire il download di altri certificati. È inoltre possibile impostare restrizioni sul contenuto visualizzato dagli utenti.

Gli amministratori delle reti intranet possono specificare le impostazioni di protezione e le restrizioni del contenuto nelle fasi 4 e 5 del programma di personalizzazione di Internet Explorer.

Informazioni sulle aree di protezione

Le opzioni di protezione di Internet Explorer consentono di assegnare siti Web specifici a varie aree a seconda del livello di affidabilità del contenuto del sito.

Quando si installa Internet Explorer, vengono impostate le seguenti aree di protezione:

  • Un'area Internet che come impostazione predefinita contiene tutti i siti Internet
  • Un'area Intranet locale per i computer collegati ad una rete locale
  • Un'area Siti attendibili a cui è possibile assegnare i siti ritenuti affidabili
  • Un'area Siti con restrizioni a cui è possibile assegnare i siti non affidabili
  • Un'area Risorse del computer, che contiene i file nel computer locale

A queste aree è possibile applicare le quattro impostazioni predefinite riportate di seguito: Alta, Media, Medio-bassa e Bassa. I livelli di protezione possono essere inoltre impostati per ogni singola area.

È possibile visualizzare tutte le impostazioni di protezione facendo clic sull'icona Internet nel Pannello di controllo, quindi scegliendo la scheda Protezione. Per ulteriori informazioni su queste opzioni e sulla loro interazione, vedere Opzioni di protezione di Internet Explorer.

È necessario tenere presente che il livello di protezione dipende dalle impostazioni specificate. Internet Explorer fornisce tutte le informazioni e gli strumenti necessari per specificare impostazioni di protezione attendibili.

Al momento dell’esecuzione del programma di personalizzazione è possibile preimpostare le opzioni di protezione, oltre a stabilire se tali impostazioni possono essere modificate dagli utenti. Se le opzioni di protezione non vengono preimpostate, è opportuno consigliare il migliore livello di protezione per gli utenti, basandosi sulle reali necessità dell’azienda e sul livello di preparazione degli utenti.

Note

  • Se la lingua del pacchetto browser Internet Explorer creato è diversa da quella del browser installato sul proprio computer e si importano aree di protezione, potrebbero apparire alcuni caratteri irriconoscibili nell'interfaccia delle aree di protezione del browser creto.
  • L'area Risorse del computer può essere configurata solo da IEAK; queste impostazioni non sono disponibili nell'interfaccia del browser. È consigliabile utilizzare le impostazioni predefinite per quest'area, a meno di particolari esigenze da parte della propria organizzazione. Un livello di sicurezza basso può comportare dei rischi, mentre un livello alto può compromettere la funzionalità.

Per ulteriori informazioni, vedere:

Impostazione dell'area Internet

L'area Internet contiene tutti i siti che non sono inclusi nelle altre aree. Come 'impostazione predefinita, l'area Internet è impostata sul livello di protezione medio. Per evitare che durante l'esplorazione della rete si verifichino problemi di protezione, è possibile specificare un livello di protezione più alto. Se si aumenta il livello di protezione, all'interno di alcune pagine Web non sarà più consentita l'esecuzione di operazioni potenzialmente rischiose e anche il corretto funzionamento di alcune funzionalità e la corretta visualizzazione di alcune pagine potrebbe risultare compromesso.

Ogni singola decisione di protezione per una data area può essere controllata scegliendo delle impostazioni personalizzate. Per eseguire questa operazione, fare clic sull'icona Internet nel Pannello di controllo, quindi sulla scheda Protezione e infine scegliere il pulsante Personalizza livello.

Aggiunta di siti alle aree affidabili e a quelle con restrizioni

Esistono due aree a cui è possibile assegnare siti Web attendibili in misura superiore o inferiore rispetto a quelli contenuti nell'area Internet e nell'area Intranet locale. Per aggiungere dei siti a tali aree, selezionare l'area, quindi scegliere il pulsante Siti.

Come impostazione predefinita, all'area Siti attendibili viene assegnato un livello di protezione basso. Quest'area è riservata ai siti altamente garantiti, ad esempio quelli delle società con cui si collabora frequentemente, denominati talvolta "extranet". Se si assegna un sito all'area Siti attendibili, questo sito potrà eseguire operazioni più efficaci. Verrà inoltre chiesto all'utente di effettuare un numero inferiore di scelte relative alla protezione. Aggiungere un sito a quest'area solo se si è certi che il relativo contenuto non danneggerà in alcun modo il computer. Per le aree dei siti attendibili, si consiglia di utilizzare il protocollo HTTPS o comunque assicurarsi che le connessioni al sito siano protette.

Come impostazione predefinita, all'area Siti con restrizioni viene assegnato un livello di protezione alto. Se si assegna un sito all'area Siti con restrizioni, quel sito potrà eseguire operazioni minime e molto protette. Quest'area è riservata ai rari siti non affidabili. Diverse pagine Web incluse in quest'area non verranno visualizzate correttamente in modo da garantire un elevato livello di protezione per il contenuto non attendibile.

Impostazione dell'area Intranet locale per gli amministratori della rete

Per proteggere l'area Intranet locale, è necessario impostarla congiuntamente al server proxy e al firewall. Tutti i siti dell'area devono essere "all'interno del firewall", mentre i server proxy devono essere configurati in modo da non consentire alcuna risoluzione dei nomi DNS esterni in quest'area. La configurazione della protezione dell'area Client richiede una conoscenza dettagliata della configurazione di rete, dei server proxy e dei firewall protetti esistenti. Se non si dispone di queste informazioni, contattare l'amministratore della rete.

Come impostazione predefinita, l'area Intranet locale è costituita dai nomi di dominio locali e da quelli per i quali è stato specificato di ignorare il server proxy nella scheda Connessione. Queste impostazioni possono essere configurate nella schermata Impostazioni della connessione del programma di personalizzazione di Internet Explorer. Per ciascun utente è possibile configurare più impostazioni di connessione. L'amministratore della rete deve confermare la sicurezza di tali impostazioni per l'installazione oppure modificare le impostazioni di protezione in base alle esigenze degli utenti.

Durante l'impostazione dell'area è possibile specificare quali categorie di URL devono essere prese in considerazione. È inoltre possibile aggiungere siti specifici all'area.

Per specificare le categorie di URL da includere nell'area dal browser

  1. Scegliere Opzioni Internet dal menu Strumenti di Internet Explorer, quindi scegliere la scheda Protezione.
  2. Fare clic sull'area Intranet locale, quindi su Siti.
  3. Selezionare le seguenti caselle di controllo:

    Includi tutti i siti locali (intranet) non elencati in altre aree
    Includi tutti i siti che non utilizzano il server proxy
    Includi tutti i percorsi di rete (UNC)

Note

  • Per aggiungere un dato sito a quest'area, fare clic su Avanzate, immettere l'URL e fare clic su Aggiungi. Per richiedere l'utilizzo della verifica del server, selezionare la casella di controllo Richiedi verifica server (https:) per tutti i siti compresi nell'area.
  • Per specificare la categorie URL da includere nell'area del browser, fare click su Personalizza le impostazioni delle aree di protezione nella schermata Imposta protezione del programma di personalizzazione, quindi su Modifica impostazioni.

Le regole enunciate di seguito si applicano alle opzioni dell'area Intranet locale. L'aggiunta di un sito a un'area qualsiasi ha comunque la precedenza su tali regole.

  • Includi tutti i siti locali (intranet) non elencati in altre aree: I nomi dei siti intranet non includono punti (ad esempio, http://local). Il sito http://www.microsoft.com non è un sito locale perché contiene dei punti. Questo sito potrebbe far parte dell'area Internet. Le regole relative ai nomi dei siti intranet si applicano sia ai file: che a quelli http: URL.
  • Includi tutti i siti che non utilizzano il server proxy: Le configurazioni intranet tipiche utilizzano un server proxy per accedere a Internet con una connessione diretta ai server intranet. Questa impostazione utlizza questo tipo di configurazione per distinguere il contenuto della rete intranet da quello di Internet ai fini dell'assegnazione a una determinata area. Se il server proxy è configurato diversamente è necessario deselezionare questa opzione e utilizzarne altre per specificare i file assegnati all'area Intranet locale. Nei sistemi che non dispongono di un server proxy, queste impostazioni non hanno effetto.
  • Includi tutti i percorsi di rete (UNC): I percorsi di rete (ad esempio \\local\file.txt) sono in genere utilizzati per il contenuto della rete locale che deve essere incluso nell'area Intranet locale. Se ci sono percorsi di rete che non appartengono all'area Intranet locale, è necessario deselezionare questa opzione e utilizzarne altre per specificare i file assegnati all'area Intranet locale. In alcune configurazioni CIFS (Common Internet File System) è ad esempio possibile che un percorso di rete faccia riferimento a contenuti Internet.

Dopo avere confermato il livello di protezione dell'area Intranet locale, è possibile specificare un livello di protezione Medio-basso o Basso per consentire l'esecuzione di un numero maggiore di operazioni più efficaci. È inoltre possibile modificare le singole impostazioni di protezione nella finestra di dialogo Impostazioni protezione.

Se alcune parti della rete intranet sono meno protette o garantite, è possibile escluderle da quest'area assegnandole all'area Siti con restrizioni.

Si consiglia di utilizzare IEAK per configurare l'area Intranet locale, benché sia possibile utilizzare anche le opzioni della scheda Protezione della finestra di dialogo delle proprietà di Internet.

Uso dei suffissi dei nomi di dominio

Se si desidera fare riferimento a un server Web utilizzando una versione più breve dell' indirizzo che non includa il nome di dominio, sarà possibile utilizzare un suffisso del nome di dominio. È ad esempio possibile fare riferimento a un server Web denominato esempio.microsoft.com utilizzando il suffisso esempio. È inoltre possibile accedere a questo stesso contenuto digitando http://esempio.microsoft.com o http://esempio.

Per impostare questa funzionalità, è necessario aggiungere il suffisso di dominio all'ordine di ricerca del suffisso di dominio delle proprietà del protocollo TCP/IP attenendosi alla seguente procedura:

  1. Fare clic con il pulsante destro del mouse sull'icona Risorse di rete, quindi scegliere Proprietà.
  2. Selezionare TCP/IP, quindi Proprietà.
  3. Scegliere la scheda Configurazione DNS, quindi aggiungere le informazioni desiderate nell'area Ordine di ricerca del suffisso di dominio.

È importante impostare correttamente le aree di protezione per questa configurazione. In base all'impostazione predefinita, un URL senza punti, quale //esempio, è considerato appartenente all'area Intranet locale, mentre un URL con i punti, quale esempio.microsoft.com, è considerato appartenente all'area Internet. Se pertanto si utilizza questo tipo di configurazione e non viene ignorato alcun server proxy ai fini della corretta assegnazione del contenuto all'area appropriata, sarà necessario modificare le impostazioni dell'area.

A seconda che il contenuto al quale si ha accesso tramite il suffisso di dominio sia considerato di tipo intranet o Internet, sarà necessario assegnare gli URL dei siti non definiti alle aree appropriate. Per assegnare URL quali http://esempio all'area Internet, deselezionare la casella di controllo Includi tutti i siti locali (intranet) non elencati in altre aree per l'area Intranet locale, quindi includere il sito nel relativo elenco per l'area.

Altre note sulla protezione valide per tutte le aree

È possibile accedere al contenuto di un sito Web attraverso un nome DNS (Domain Name System) o un indirizzo IP. Nel caso di siti che utilizzano sia il nome DNS che l'indirizzo IP, è importante configurare entrambi i riferimenti alla stessa area. I siti intranet locali sono in genere identificabili attraverso il nome locale o gli indirizzi IP nell'elenco dei server proxy da ignorare. Tutti gli altri nomi e indirizzi IP saranno associati all'area Internet. Se tuttavia nell'elenco dei siti appartenenti all'area Siti attendibili o all'area Siti con restrizioni è specificato solo il nome di un sito e non il relativo intervallo di indirizzi IP, nel caso in cui si acceda a tale sito utilizzando l'indirizzo IP, il sito verrà considerato appartenente all'area Internet.

È necessario tenere presente che un utente è in grado di copiare contenuti da un'area all'altra, aumentando o diminuendo il livello di protezione relativo a tale contenuto.

Se si utilizza la configurazione automatica e si supporta sia Internet Explorer 5, o versioni successive, o Internet Explorer 4 con lo stesso file di configurazione automatica, alcune impostazioni che differiscono tra una versione e l'altra non saranno configurate in Internet Explorer 4.


Opzioni di protezione di Internet Explorer

Grazie alla suddivisione della rete in aree di protezione diverse, in Internet Explorer è possibile specificare opzioni di protezione differenti a seconda dell'area di appartenenza di una determinata pagina Web. Un'area è un insieme di siti Web con lo stesso livello di attendibilità. Ogni sito Web viene aggiunto ad una determinata area alla quale vengono poi assegnate le opzioni di protezione adeguate.

È possibile modificare le impostazioni predefinite di Internet Explorer in base alle caratteristiche di protezione del sistema in uso. Per la sicurezza di una rete intranet, ad esempio, la protezione viene normalmente impostata su un livello basso o su valori personalizzati adeguati (dopo che l'area della rete intranet locale è stata configurata per adattarsi al firewall).

In questa sezione verranno analizzate in modo dettagliato le opzioni di protezione di Internet Explorer al fine di agevolare la scelta della misura di protezione più appropriata per le opzioni di ciascuna area. Le opzioni di protezione del browser Internet Explorer, non riguardano necessariamente l'intero sistema. È pertanto possibile che i programmi aggiuntivi di Internet Explorer non rispettino queste impostazioni.

Per impostare le opzioni di protezione a livello aziendale, è necessario modificare le impostazioni utilizzando IEAK. L'utente finale può visualizzare le opzioni di protezione direttamente dal browser scegliendo Opzioni Internet dal menu Strumenti, quindi facendo clic sulla scheda Protezione. Per visualizzare le impostazioni personalizzate, selezionare un'area di protezione e fare clic su Personalizza livello.

Per ulteriori informazioni, vedere:

Controlli ActiveX e Plug-in

Queste opzioni controllano il modo in cui i controlli ActiveX e Plug-in vengono approvati, scaricati ed eseguiti dall'amministratore. Per ulteriori informazioni sulla gestione e l'approvazione dei controlli ActiveX, vedere Gestione dei controlli ActiveX.

Quando si esegue il download di un controllo ActiveX da un sito diverso da quello in cui il controllo è abitualmente utilizzato, Internet Explorer applica le impostazioni più restrittive delle due aree di siti. Se ad esempio un utente accede a una pagina Web all'interno di un'area impostata per consentire il download e il codice viene scaricato da un'altra area impostata per visualizzare un prompt, verranno utilizzate le impostazioni della seconda area.

Esegui script controlli ActiveX contrassegnati come sicuri
Questa opzione determina se un controllo ActiveX contrassegnato come sicuro per lo script può interagire con uno script. Questa opzione non ha alcun effetto sui controlli sicuri per l'inizializzazione caricati con i tag PARAM. Questa opzione viene ignorata quando è attivata l'impostazione Inizializza e esegui script sui controlli ActiveX non contrassegnati come sicuri, in quanto in questo caso la protezione degli oggetti non viene presa in considerazione. Non è possibile eseguire lo script sui controlli non contrassegnati come sicuri bloccando contemporaneamente lo script di quelli sicuri.

Inizializza e esegui script sui controlli ActiveX non contrassegnati come sicuri
I controlli ActiveX possono essere classificati come sicuri o non sicuri. Questa opzione controlla se uno script può interagire con controlli considerati non sicuri. I controlli non sicuri non dovrebbero essere utilizzati nelle pagine Web di Internet, ma in alcuni casi possono essere utilizzati con pagine considerate assolutamente attendibili e che non utilizzano i controlli in modo ambiguo. Si consiglia di imporre la protezione degli oggetti, a meno che tutti i controlli ActiveX e gli script che potrebbero interagire con le pagine dell'area non siano garantiti. Le impostazioni sono le seguenti:

Esegui controlli ActiveX e Plug-in
Questa opzione stabilisce se i controlli ActiveX e i Plug-in possono essere eseguiti nelle pagine delle aree specificate. La disattivazione di questa opzione impedisce l'esecuzione di qualsiasi controllo ActiveX o Plug-in, ignorando anche le altre impostazioni ActiveX. Il download, l'esecuzione e lo script dei controlli ActiveX sono tre passaggi distinti con opzioni specifiche. Le opzioni di download fanno distinzione tra controlli autenticati e non autenticati. Le opzioni di script possono essere impostate separatamente per i controlli sicuri e non sicuri. L'autore del controllo, determina se il controllo è sicuro per lo script o inizializzazione, il che non deve essere confuso con l'autenticazione. Autenticazione e sicurezza sono due aspetti distinti. Per ulteriori informazioni, visitare il sito MSDN Online Web Workshop.

Scarica controlli ActiveX con firma elettronica
Questa opzione consente agli utenti di eseguire il download dei controlli con firma elettronica dalle pagine di quest'area. Le impostazioni sono le seguenti:

  • Attiva consente di eseguire i controlli autenticati in modo invisibile all'utente.
  • Chiedi conferma visualizza un avviso prima che gli utenti eseguano il download dei controlli autenticati da autori che non sono attendibili. Questa impostazione abilita ancora gli utenti a eseguire, in modo invisibile, il download dei codici autenticati da autori attendibili.
  • Disattiva impedisce agli utenti di eseguire il download di tutti i controlli autenticati.

Scarica controlli ActiveX senza firma elettronica
Questa opzione consente agli utenti di eseguire il download dei controlli ActiveX non autenticati dalle pagine di quest'area. Questo tipo di codice è potenzialmente pericoloso, specialmente se proviene da un'area non attendibile.

  • Attiva consente di ignorare la protezione degli oggetti. I controlli ActiveX vengono eseguiti e caricati con i parametri e il relativo script viene eseguito senza impostare la protezione degli oggetti per i dati o gli script non garantiti. Si consiglia di utilizzare questa impostazione solo nel caso di aree sicure e amministrate. Dopo avere specificato questa impostazione, sia i controlli garantiti che quelli non garantiti vengono inizializzati e viene eseguito lo script, ignorando l'opzione Esegui script controlli ActiveX contrassegnati come sicuri.
  • Richiedi consente di tentare di imporre la protezione degli oggetti. Se tuttavia i controlli ActiveX non possono essere resi sicuri per dati o script non garantiti, l'utente potrà caricare il controllo con i relativi parametri oppure eseguire lo script.
  • Disattiva consente di imporre la protezione degli oggetti per dati o script non garantiti. I controlli ActiveX che non è possibile rendere sicuri non vengono caricati con i relativi parametri e non viene eseguito lo script.

Java

Autorizzazioni Java

Per poter disporre delle opzioni Java, occorre prima installare Microsoft Virtual Machine (Microsoft VM).

Queste opzioni consentono il controllo del download e dell'esecuzione di Java all'interno dell'area specificata. Nel caso del download di Java, se un controllo viene scaricato da un sito diverso da quello della pagina nella quale è utilizzato, verranno utilizzate le impostazioni maggiormente restrittive. Se ad esempio un utente accede a una pagina Web all'interno di un'area impostata per consentire il download e il codice viene scaricato da un'altra area impostata per visualizzare un prompt, verranno utilizzate le impostazioni della seconda area.

L'impostazione di ciascuna opzione consente di determinare:

  • Il livello massimo di autorizzazioni automaticamente concesse alle applicazioni con firma scaricate dall'area.
  • Le autorizzazioni concesse alle applicazioni senza firma scaricate dall'area.
  • Le autorizzazioni concesse agli script sulle pagine all'interno dell'area che richiamano queste applicazioni.

Le cinque possibili opzioni sono:

  • Personalizza consente di controllare le impostazioni delle singole autorizzazioni. Nella scheda Non firmato della finestra di dialogo Autorizzazioni personalizzate sono specificate sia le autorizzazioni per le applicazioni senza firma che quelle per gli script basati sull'utilizzo di Java. Nella scheda Consentito senza avviso viene specificato il limite delle autorizzazioni concesse automaticamente alle applicazioni.
  • Protezione bassa consente di effettuare liberamente tutte le operazioni all'interno delle applicazioni.
  • Protezione media abilita l'esecuzione delle applicazioni in un'area di memoria all'esterno della quale i programmi non possono effettuare chiamate. Abilita inoltre funzioni quali l'utilizzo di un'area di memoria riservata, garantita e protetta sul computer client, e operazioni di input/output dei file controllate dall'utente.
  • Protezione alta consente di eseguire le applicazioni in un'area di memoria all'esterno della quale il programma non può effettuare chiamate.
  • Disattiva Java non consente di eseguire alcuna applicazione Java.

Esecuzione script in corso

Esecuzione script attivo
Questa opzione determina se eseguire il codice di script nelle pagine di quest'area.

Esecuzione script delle applicazioni Java
Questa opzione determina se gli script all'interno dell’area possono utilizzare oggetti delle applicazioni Java, autorizzando lo script nella pagina a interagire con l'applicazione.

Download

Download dei file
Controlla se l'esecuzione del download dei file è autorizzato all'interno dell'area. L'opzione viene determinata in base all'area della pagina nella quale si trova il collegamento che consente il download e non in base all'area dalla quale viene importato il file.

Download dei caratteri
Questa opzione determina se gli utenti possono scaricare caratteri HTML dalle pagine all'interno di quest'area.

Autenticazione utente

Accedi

L'autenticazione HTTP rispetta i criteri di protezione dell'area per le credenziali di accesso che possono presentare uno dei quattro seguenti valori:

  • Accesso automatico solo nell'area intranet: Per le altre aree vengono richiesti l'ID utente e la password. Una volta effettuata la richiesta, questo valore potrà essere automaticamente utilizzato per il resto della sessione.
  • Accesso anonimo: disattiva l'autenticazione HTTP e utilizza l'account ospite solo per Common Internet File System (CIFS).
  • Richiedi nome utente e password: vengono richiesti l'ID utente e la password. Una volta effettuata la richiesta, questo valore potrà essere automaticamente utilizzato per il resto della sessione.
  • Accedi automaticamente con il nome utente e la password correnti: Le credenziali di accesso vengono verificate automaticamente da Windows NT Challenge response (NTLM), un protocollo di autenticazione tra il client dell'utente finale e il server dell'applicazione, prima di effettuare la richiesta.

Varie

Accesso a origini dati attraverso domini
Questa opzione specifica se ai componenti che si connettono alle origini dati è consentito connettersi a un server diverso per recuperare i dati. Questa opzione è applicabile solo ai collegamenti dati, come gli oggetti dati attivi. Le impostazioni sono le seguenti:

  • Attiva consente l'accesso al database di qualsiasi origine, anche di altri domini.
  • Chiedi conferma richiede la conferma dell'utente prima di autorizzare l'accesso a database diversi in altri domini.
  • Disattiva consente l'accesso solo al database sullo stesso dominio della pagina.

Invia dati modulo non crittografati
Questa opzione specifica se le pagine HTML all'interno dell'area possono inviare o accettare moduli dai server nell'area. L'invio di moduli crittografati con SSL (Secure Sockets Layer) è sempre autorizzato. Questa impostazione riguarda solo l'invio di moduli privi di crittografia di tipo SSL.

Avvio di applicazioni e file in un IFrame
Questa opzione controlla se gli utenti possono avviare le applicazioni e i file da un tag IFRAME (contenente la directory di una cartella) nelle pagine Web all'interno dell'area.

Installazione oggetti del desktop
Questa opzione consente agli utenti di installare oggetti del desktop dalle pagine Web all'interno dell'area.

Trascina o Copia e Incolla file
Questa opzione consente di controllare se gli utenti possono trascinare o copiare file dalle pagine Web all'interno dell'area.

Autorizzazioni al canale del software
Le impostazioni sono le seguenti:

  • Una protezione bassa consente:
    • La notifica di una e-mail
    • Il download automatico
    • L'installazione automatica
  • Una protezione media consente:
    • La notifica di una e-mail
    • Il download automatico
  • Una protezione alta consente:
    • Nessuna delle caratteristiche di distribuzione dei canali del software

Cookie

Consenti cookie (non memorizzati) sessione per sessione
Determina le impostazioni per i cookie, i file di testo nei quali vengono memorizzate le preferenze dell'utente, utilizzate da un sito Web quando viene visitato dall'utente. Questa impostazione determina ad esempio se è possibile creare un "controllo della spesa virtuale" mentre l'utente esegue acquisti in linea. I cookie creati sessione per sessione non rimangono sul disco rigido.

Le impostazioni sono le seguenti:

  • Attiva significa che i cookie vengono accettati automaticamente.
  • Chiedi conferma significa che all'utente viene chiesta una conferma prima di creare un cookie.
  • Disattiva significa che non verranno creati cookie. Disabilitando i cookie sessione per sessione, alcune pagine Web potrebbero non funzionare correttamente.

Consente i cookie memorizzati sul computer
Determina le impostazioni per i cookie memorizzati sul disco rigido dell'utente per le sessioni successive. Questa impostazione stabilisce ad esempio se è stato conservato un elenco delle preferenze o un nome utente per le visite successive dell'utente.

Le impostazioni sono le seguenti:

  • Attiva significa che i cookie permanenti vengono accettati automaticamente.
  • Chiedi conferma significa che gli utenti ricevono una richiesta di conferma prima di creare un cookie permanente.
  • Disattiva significa che non verrà creato alcun cookie permanente. Disabilitando cookie permanenti, alcuni siti Web non conserveranno le impostazioni quando l'utente tornerà a visitarli.

Opzioni di protezione che non possono essere configurate

Le opzioni elencate di seguito sono predefinite e non possono essere impostate dall'utente. Le impostazioni dell'area Alto, Medio, Medio-basso e Basso non modificano il comportamento di queste opzioni.

Opzione relativa all'avvio dalla visualizzazione Web
Questa opzione consente di avviare applicazioni e file da una cartella visualizzata come una pagina Web. Questa impostazione si applica agli utenti di Windows 98 e a quelli che hanno eseguito l'aggiornamento da Internet Explorer 4 e stanno utilizzando l' Aggiornamento desktop di Windows.. Le impostazioni che seguono non sono tuttavia determinate dall'area in cui si trova la cartella, bensì dall'area di appartenenza del contenuto Web personalizzato.

Risorse del computer | Intranet locale | Siti attendibili | Internet | Siti con restrizioni
Attiva | Attiva | Attiva | Richiedi | Richiedi


Gestione dei controlli ActiveX

IEAK 5 introduce una nuova funzione che consente all’amministratore di specificare esattamente quali controlli ActiveX possono essere eseguiti in una data area. Questa funzione offre un ampio utilizzo dei controlli ActiveX e quindi un alto livello di protezione in due diverse situazioni.

Primo caso: utilizzo limitato dei controlli ActiveX su Internet

Pur limitando l’utilizzo al di fuori del firewall (ovvero su Internet), molte aziende utilizzano pesantemente i controlli ActiveX sulle reti Intranet locali. Sebbene il contenuto delle reti Intranet locali sia garantito contro un utilizzo improprio dei controlli, questi non sono adatti per essere utilizzati con le pagine Web di Internet. L’amministratore può specificare una serie di controlli generici che possono essere utilizzati su Internet. In tal caso, i siti che utilizzano i controlli possono ancora essere supportati nel tentativo di impedire l’utilizzo inadeguato di altri controlli nell’area.

L’amministratore può ad esempio scegliere di limitare l’utilizzo dei controlli ActiveX, pur continuando a consentirne l’impiego in un importante sito Internet, quale quello di un partner in affari o di un provider di servizi. Visitare il sito per vedere quali controlli ActiveX vengono utilizzati notando le nuove voci nella sottocartella Programmi scaricati della cartella Windows. Per specificare che i controlli sono autorizzati dall’amministratore, eseguire la procedura riportata al termine di questo argomento.

Al termine della configurazione, solo questi controlli potranno essere eseguiti nel sito in questione. Qualsiasi tentativo di una pagina Internet di utilizzare i controlli specificati per la rete Intranet verrà bloccato.

Secondo caso: utilizzo limitato dei controlli ActiveX

Un livello di protezione elevato può essere raggiunto elencando tutti i controlli ActiveX autorizzati e consentendo al browser di eseguire solo questi. Il raggiungimento di un tale livello richiede tuttavia un grosso sforzo per elencare tutti i controlli che l’amministratore intende utilizzare, quindi questo tipo di approccio è consigliato solo quando il numero dei controlli è piuttosto ridotto.

Valutare i controlli autorizzati per l’utilizzo in qualsiasi sito. Nel caso di aree i cui siti possono utilizzare questi controlli, eseguire la procedura riportata al termine di questo argomento per specificare che i controlli sono autorizzati dall’amministratore. Nel caso di aree ai cui siti non è concesso l’utilizzo di questi controlli, selezionare Disattiva nell’area Esegui controlli ActiveX e Plug-in. In questo modo solo i controlli specificati potranno essere eseguiti nelle pagine Web e solo nelle aree in cui sono consentiti.

Scelta dei controlli ActiveX

Alcuni dei controlli ActiveX più comuni sono elencati nel file dei controlli attivi autorizzati dall’amministratore, Axaa.adm, fornito con IEAK. L’elenco ha il solo scopo di presentare i controlli ActiveX più utilizzati provenienti dal Web e non quello di consigliare quelli da utilizzare. In qualità di amministratore, è possibile scegliere quali di questi controlli sono i più adatti alle esigenze della propria azienda. Il file può essere modificato aggiungendovi eventuali nuovi controlli. In base all’impostazione predefinita, nessun controllo viene elencato come autorizzato. Per aggiungere altri controlli dopo l’installazione di Internet Explorer da parte degli utenti, utilizzare il programma di configurazione automatica.

Per specificare che i controlli ActiveX devono essere autorizzati da un amministratore e per indicare quelli da approvare, attenersi alla seguente procedura:

  1. Rivedere le impostazioni dei controlli ActiveX nel file Axaa.adm, disponibile nella sottocartella \Policies\<Lingua> della cartella di IEAK. Per aggiungere altri controlli all’elenco, ad esempio quelli creati dall’azienda, utilizzare un editor di testo per modificare il file Axaa.adm.

    Si consiglia si eseguire una copia di backup di questo file nel caso in cui si debbano ripristinare le impostazioni originali.

  2. Nella schermata Personalizzazione delle aree di protezione e delle restrizioni del contenuto del programma di personalizzazione di Internet Explorer, fare clic su Personalizza le impostazioni delle aree di protezione , quindi su Modifica impostazioni.
  3. Selezionare l’area in cui verranno gestiti i controlli ActiveX e fare clic su Personalizza livello.
  4. Nell’area Esegui controlli ActiveX e plug-in, fare clic su Autorizzato dall’amministratore.
  5. Ripetere gli ultimi due passaggi fino a impostare tutte le aree desiderate.
  6. Nella pagina Criteri e restrizioni della Fase 5 del programma di personalizzazione di Internet Explorer, fare clic sulla categoria Gestione controlli per espandere i contenuti e selezionare le caselle di controllo per i controlli che si desidera autorizzare.


Firma dei programmi

È possibile utilizzare IEAK per contrassegnare con una firma digitale i propri pacchetti personalizzati. Le firme digitali indicano la provenienza del programma e verificano che i programmi non siano stati alterati. Se i pacchetti browser e i programmi personalizzati sono contrassegnati dalla firma dell'utente, durante l'installazione del browser personalizzato non si riceveranno messaggi di avviso.

Per firmare i file è necessario, tuttavia, ottenere un certificato digitale. La posizione del certificato può essere determinata durante l'esecuzione del programma di personalizzazione di Internet Explorer che firmerà i file al momento della creazione del pacchetto. Per informazioni su come ottenere un certificato digitale, vedere "Come ottenere i certificati digitali".

Se si intende distribuire i pacchetti personalizzati via Internet, è necessario che IEAK firmi i file cab personalizzati che crea. Se si intende distribuire i pacchetti personalizzati tramite una rete intranet, è necessario firmare i file personalizzati o configurare l'area della intranet locale con un livello di protezione basso. Le impostazioni di protezione predefinite non consentono di scaricare programmi o codici non firmati. Per ulteriori informazioni sulle aree di protezione, vedere Protezione in Internet Explorer.

Verranno firmati i seguenti file personalizzati:

Nome file | Funzione del file
Branding.cab | Dati di marcatura dell'Installazione di Windows Update
Desktop.cab | Aggiornamento desktop di Windows
Iecif.cab | Identifica i componenti di Microsoft Internet installati come parti dell'Installazione di Windows Update
IE5setup.exe | Installazione di Windows Update
Mmssetup.exe | Installazione del client di MSN Messenger Service
MMSsetup.cab | Dati di marcatura del client di MSN Messenger Service
Custom<n>.cab | Componenti personalizzati installati dopo il riavvio del sistema. Ogni componente è contenuto in un file cab distinto e numerato.

Per un diagramma relativo alle modalità di creazione dei file del programma di personalizzazione di Internet Explorer, vedere Creazione di pacchetti personalizzati in IEAK.

Note

  • È possibile evitare l'installazione dei controlli ActiveX e dei pacchetti Java non firmati.
  • È inoltre necessario firmare i programmi personalizzati in formato exe o cab che si intendono includere nel pacchetto browser.
  • Se si desidera che la propria organizzazione utilizzi l'Installazione su richiesta tramite Internet, è necessario firmare i file cab e specificare nelle impostazioni di protezione che il server che contiene i file cab è affidabile o, nel caso di un sito intranet, impostare un livello di protezione basso. Per ulteriori informazioni, vedere Gestione dell'installazione su richiesta.

    Se il livello di protezione della intranet è impostato su un livello medio o su un valore maggiore, è necessario specificare che i server di rete sono affidabili. A tal fine, eseguire una delle seguenti operazioni:

    1. Nella pagina Impostazioni di protezione della procedura guidata, fare clic su Importa impostazioni aree di protezione correnti, quindi scegliere Modifica impostazioni.
    2. Selezionare Area intranet locale, quindi fare clic su Siti.
    3. Deselezionare la casella di controllo Includi tutti i percorsi di rete (UNC), quindi fare clic su OK.
    4. Selezionare l'area Siti affidabili, fare clic su Siti e digitare il percorso del server, quindi fare clic su Aggiungi.
    5. Ripetere il passaggio precedente per specificare come affidabili altri server di download.

Per ulteriori informazioni, vedere:

Come ottenere i certificati digitali

I certificati digitali fanno parte della tecnologia Authenticode™ che consente di identificare la provenienza dei programmi e di verificare che non vi siano state apportate modifiche. È possibile ottenere i certificati da un'autorità di certificazione o da un server di certificazione controllato privatamente. I certificati possono essere commerciali o individuali.

Per ulteriori informazioni sulla tecnologia Authenticode e sulla protezione, visitare il sito Web Microsoft Security Advisor all'indirizzo http://www.microsoft.com/security/.

Apposizione della firma digitale sui file cab o sui programmi personalizzati

Dopo aver ottenuto il certificato, è necessario firmare il codice. Gli strumenti per firmare il codice sono disponibili al sito Web Microsoft Site Builder Network Workshop.

È inoltre necessario conoscere le chiavi pubbliche e private, ovvero un set di chiavi corrispondenti create dall'autore del software e utilizzate per le operazioni di crittografia e decrittografia. Le chiavi vengono create nel momento in cui il certificato viene richiesto all'autorità di certificazione (CA). Vengono create sul computer e la chiave privata non viene mai inviata né alla CA né ad altre autorità.

Scadenza dei certificati

La scadenza dei certificati costituisce un'ulteriore misura di protezione. Se, ad esempio, un'università richiede la certificazione di tutti gli studenti iscritti mediante un ID digitale, sarà possibile impostare la scadenza di ciascun ID in concomitanza con il termine del corso di studi. Un codice firmato utilizzando un certificato scaduto non è considerato valido. Una volta scaduto il certificato, l'autore del software dovrà apporre una nuova firma e pubblicare nuove versioni del programma creato.

Per firmare il codice, gli autori del software possono utilizzare un indicatore dell'ora in modo da poter provare la validità del certificato al momento dell'apposizione della firma. In tal modo il codice firmato continua ad essere valido anche dopo la scadenza del certificato.

Uso di Authenticode da parte degli amministratori di reti intranet

Un amministratore di reti intranet può preconfigurare le aree di protezione e le restrizioni di accesso, oltre a personalizzare le autorità di certificazione. Gli amministratori possono inoltre impostare dei criteri di protezione e restrizioni per controllare se gli utenti possono modificare o meno le impostazioni di protezione. Per ulteriori informazioni sulle aree di protezione, vedere Opzioni di protezione di Internet Explorer.

È possibile stabilire che vengano visualizzati messaggi di avviso quando si tenta di accedere a contenuti potenzialmente dannosi. È inoltre possibile impedire che gli utenti effettuino il download di controlli ActiveX e di pacchetti Java privi di firma digitale.

Conseguenze dell'apposizione della firma digitale

Il processo di apposizione della firma del codice è semplice e rapido Per firmare un codice, non è necessario conoscere i dettagli tecnici di questa operazione.

Dopo aver sviluppato e verificato un codice, l'autore appone la propria firma digitale. Viene utilizzato un apposito programma, ad esempio Signcode.exe, per attribuire un hash al codice, producendo così una codifica del file. Tramite il livello del sistema operativo, il programma esegue la codifica con la chiave privata e combina tale codifica con il nome dell'algoritmo hash e del certificato della CA, contenente il nome dell'autore, la chiave pubblica e così via, in una struttura definita blocco di identificazione. Il programma incorpora quindi tale blocco nel file del codice. A questo punto il file è pronto per la distribuzione su Internet. Tenere presente che anche il file cab al quale è stata apposta una firma digitale contiene un blocco di identificazione.

Quando il file viene scaricato da Internet, l'applicazione che effettua il download avvia una funzione di verifica, in base alla quale il sistema operativo estrae il blocco di identificazione, determina la CA che ha convalidato il certificato e utilizza la chiave pubblica per decodificare il codice. Il sistema usa quindi l'algoritmo hash indicato nel blocco di identificazione per creare una seconda codifica. Se il programma non ha subito modifiche dal momento dell'apposizione della firma, il nuovo codice corrisponderà a quello precedente. Se i due codici non corrispondono significa che è stato modificato il programma oppure che le chiavi pubblica e privata non appartengono alla stessa coppia. In entrambi i casi il codice è divenuto sospetto e quindi vengono visualizzati i messaggi di avviso.


Personalizzazione avanzata di Messenger Client

Se il client di servizi Messenger personalizzato si trova all'interno di un firewall, ad esempio su una rete intranet di una società, è possibile preconfigurare il client per supportare server proxy. Tuttavia, non è possibile configurare le impostazioni del proxy utilizzate dal client di servizi Messenger durante la procedura guidata di IEAK. Al contrario, per includere il server proxy personalizzato nei file di installazione del client di servizi Messenger, è necessario modificare uno dei file di configurazione, quindi avviare nuovamente la procedura guidata. Nella maggior parte dei casi, la personalizzazione del server proxy non è necessaria poiché il protocollo di messaggistica è del tipo TCP; questo protocollo funziona anche se l'utente non si trova all'interno di un firewall.

Importante

  • Se si è deciso di configurare le impostazioni del server proxy, non specificare l'URL di download nella sezione Marcatura di MSN Messenger Service della procedura guidata di IEAK. L'URL di download è compreso nella e-mail di benvenuto del client; questo tipo di e-mail non è riservata esclusivamente agli utenti che si trovano all'interno del firewall e che usano il server proxy. Lasciare in bianco l'URL di download in modo che la e-mail di benvenuto indirizzi al file di installazione del client MSN Messeger Service, e informare gli utenti che la e-mail di benvenuto non è un buon metodo per distribuire il cliente all'interno dell'ambiente proxy personalizzato.

Per configurare le impostazioni del client proxy di servizi Messenger

  1. Avviare la procedura guidata di IEAK e impostare le configurazioni del client di servizi Messenger personalizzato e di tutti i componenti desiderati. In questo modo si ottiene una prima versione dei file di configurazione e del pacchetto di installazione sia per Internet Explorer che per il client di servizi Messenger. Non utilizzare questi pacchetti di installazione iniziali poiché andranno ricreati.
  2. Ricercare il file msmsgs.in_ creato durante la procedura guidata. Questo file si trova nelle sottocartelle sistema operativo e lingua della cartella INS, dentro la cartella di lavoro. Un percorso tipico è [cartella di compilazione]\INS\WIN32\En\msmsgs.in_. Utilizzando un editor di testo, ad esempio Notepad, aprire il file msmsgs.in_.
  3. Se si specifica un server proxy, aggiungere la seguente linea di testo alla fine del file:
    ProxyOn=1
  4. Specificare il tipo di proxy, se SOCKS4 o SOCKS5, aggiungendo una delle seguenti linee di testo:
    ProxyVersion=4
    or
    ProxyVersion=5
  5. Specificare la posizione del server proxy aggiungendo una delle seguenti linee di testo:
    ProxyServer=[DNS name or IP address]
  6. Specificare la porta utilizzata dal server proxy per la connessione iniziale aggiungendo una delle seguenti linee di testo:
    ProxyPort=1080
    1080 is the SOCKS4 default port; type another port number if your proxy is configured differently.
  7. Salvare il file con il nome originale ed uscire dall'editor di testo.
  8. Avviare nuovamente la procedura guidata di IEAK. Nella pagina Posizione file della procedura guidata di IEAK, fare clic sul pulsante Opzioni avanzate.
  9. Nella finestra di dialogo Opzioni avanzate, passare alla posizione in cui si trova il file install.ins creato dalla procedura guidata di IEAK e selezionarlo. Facendo riferimento al file install.ins, è possibile caricare tutte le impostazioni precedenti anche se le impostazioni personalizzate del client di servizi Messenger si trovano nel file msmsgs.in_. Scegliere OK.
  10. Continuare ad utilizzare la procedura guidata per generare nuovi file exe e cab sia per il client di servizi Messenger che per i pacchetti browser completi.

L'installazione preconfigurerà il client di servizi Messenger in modo che si colleghi al server di messaggistica utilizzando il server proxy specificato. Se si utilizza il protocollo SOCKS5 con autenticazione dell'utente, prima di potersi collegare al server proxy l'utente dovrà digitare il proprio nome utente e la password di rete nella finestra di dialogo Opzioni | Connessione del client di servizi Messenger personalizzato. Dopo l'installazione iniziale, l'utente può configurare tutte le opzioni del proxy tramite le opzioni del client di servizi Messenger.


Contenuti promozionali nel client di Messenger Service personalizzato

Il file xml consente di pubblicizzare i propri contenuti nell'area destinata alle promozioni della finestra principale del client di Messenger Service. Nel client MSN Messenger Service, questo contenuto viene gestito tramite MSN. Specificando un file xml, i contenuti promozionali si alterneranno ai contenuti pianificati da MSN nell'ordine indicato di seguito:

Contenuto | Durata
Logo (specificato in campo Logo ) | circa 7,5 secondi
Logo di compatibilità con MSN network | circa7,5 secondi
Contenuto promozionale specificato nel file xml | circa 45 secondi
Logo (specificato in campo Logo ) | circa 7,5 secondi
Logo di compatibilità con MSN network | circa7,5 secondi
contenuto programmato da MSN | circa45 secondi

Tale pianificazione si ripete approssimativamente ogni 120 secondi.

Il file xml viene distribuito da un server Web al sito dell'utente. È possibile distribuire sempre lo stesso file xml, oppure incollare un nuovo file nella stessa posizione per fornire dei contenuti aggiornati. In questo caso l'URL deve rimanere lo stesso. È possibile configurare il client di Messenger Service affinché controlli ed esegua nuovi file xml ogni cinque minuti. È possibile continuare a visualizzare lo stesso contenuto nell'area destinata alle promozioni oppure visualizzare contenuti differenti per ogni rotazione pubblicitaria specificando più di un gruppo di articoli. Sono disponibili fino a cinque gruppi di articoli. Per ulteriori informazioni, vedere Formato del file XML per la promozione di Messenger Service.

Formattazione dei suggerimenti pubblicitari

I gruppi di articoli possono contenere:

  • Un'immagine gif di grandi dimensioni, fino a 234 pixel di larghezza e 60 pixel di altezza. L'immagine può essere animata.
  • Fino a tre collegamenti in formato solo testo. Il collegamento viene visualizzato come punto elenco.
  • Fino a tre collegamenti in formato solo testo e una piccola immagine gif. L'immagine può essere animata. I collegamenti vengono visualizzati sul client come punti elenco, mentre l'immagine è giustificata a sinistra e vicina ai collegamenti. Poiché la larghezza dell'immagine diminuisce lo spazio disponibile ai collegamenti, la dimensione consigliabile è pari a 60 x 60 pixel e l'altezza non dovrebbe superare i 60 pixel.

Se il testo promozionale è troncato, il testo dei collegamenti non andrà a capo e le barre di scorrimento non verranno visualizzate in maniera corretta. Il testo troncato viene visualizzato con i puntini di sospensione, come nell'esempio: "Il collegamento visualizzato è troppo lungo", che potrebbe apparire come "Il collegamento..."). Per evitare questo problema è pertanto consigliabile utilizzare immagini piccole e testi dei collegamenti più brevi. Infatti, malgrado gli utenti possano ridimensionare la finestra principale, preferiscono in genere mantenerla nella dimensione predefinita.

Nota

  • i gruppi di articoli con i collegamenti hanno un aspetto migliore e richiamano l'attenzione se sono abbinati anche ad un'immagine.


Formato del file XML per la promozione di Messenger Service

Il file XML per la promozione viene ospitato su un server sul proprio sito e viene aggiornato da un client di Messenger Service a intervalli configurabili. Le stringhe nel file devono essere codificate UTF-8 (il formato ASCII semplice viene automaticamente codificato in UTF-8), ed è permesso il formato BOM (Byte Order Mark). Affinché i client di Messenger Service vedano correttamente il contenuto, il formato specificato nel codice XML deve essere seguito in modo rigoroso. Microsoft non è responsabile per una codifica XML non corretta e dei relativi effetti. Vedere Contenuti promozionali del client di Messenger Service personalizzato per informazioni generali sull'inclusione di materiale promozionale nel client di Messenger Service personalizzato.

Tabella di riferimento dei tag

Tag | Descrizione | Principale
msn-data | Obbligatorio. Il livello di contenitore più alto di materiale promozionale. | (nessuno}
RefreshLogin | Obbligatorio. Un valore booleano che determina quando scaricare nuovi contenuti. Se impostato su True, viene scaricato un nuovo file XML dal server non appena un utente si collega e il timer di aggiornamento viene impostato su zero. Se impostato su False, il contenuto non viene automaticamente aggiornato a ogni collegamento, ma solo quando viene raggiunto l'intervallo prefissato e il timer di aggiornamento viene conservato fra i vari collegamenti. RefreshLogin=True è raccomandato. È preferibile impostare RefreshLogin su True se si teme che il server XML riceva un numero elevato di richieste dopo un'interruzione del servizio o a orari di punta. | msn-data
RefreshInterval | Obbligatorio. Il numero di minuti da attendere prima di aggiornare l'intero file XML sul client. Se l'utente si collega e RefreshLogin è impostato su False, il valore del timer viene conservato fra i vari collegamenti. Il minimo è 5, il massimo è 10080, ossia una settimana. | msn-data
article-group | Contenitore per un insieme di articoli. Ogni gruppo di articoli determinerà il contenuto che deve essere visualizzato all'interno dell'area Promozione e, se ne è specificata più di una, il gruppo di articoli verrà ruotato in modo sequenziale. Almeno un gruppo di articoli deve essere specificato e sono permessi un massimo di cinque gruppi di articoli nel file Promozione XML. In un gruppo di articoli non devono essere inclusi più di tre collegamenti e una immagine. | msn-data
article | Contenitore di ogni singolo articolo. Un articolo può essere sia un collegamento, impostazione predefinita, oppure una immagine, nel qual caso è necessario specificare <article type="image">. | article-group
image-url | Specifica l'URL dell'immagine che deve essere usata solo se l'articolo è type="image." L'area Promozione può visualizzare solo immagini gif. I file JPEG non verranno visualizzati. La dimensione raccomandata per l'immagine è di 60 x 60 pixel nel caso in cui si visualizzi una immagine con diversi collegamenti. Se viene visualizzata una sola immagine senza collegamenti, ad esempio un banner pubblicitario, la dimensione massima e di 234 x 60 pixel. È possibile usare immagini gif animate. | article type="image"
URL | Specifica l'URL che viene caricato in una nuova finestra del browser quando un utente fa clic sul collegamento o sull'immagine. | article
title | Specifica il testo da visualizzare come collegamento all'utente. Da usare solo se l'articolo non è type="image." | article

Esempio

<?xml version="1.0"?>
<msn-data>
  <RefreshLogin>True</RefreshLogin>
  <RefreshInterval>360</RefreshInterval>

  <article-group>

    <article type="image">
      <image-url>http://msdn.microsoft.com/workshop/graphics/icons/xml.gif</image-url>
      <url>http://msdn.microsoft.com/xml/index.asp</url>
    </article>

    <article>
      <title>Nozioni su XML a MSDN</title>
      <url>http://msdn.microsoft.com/xml/index.asp</url>
    </article>

    <article>
      <title>Guida per sviluppatori XML a MSDN</title>
      <url>http://msdn.microsoft.com/xml/xmlguide/default.asp</url>
    </article>

    <article>
      <title>Chat su XML</title>
      <url>http://msdn.microsoft.com/chats/xml.asp</url>
    </article>

  </article-group>

  <article-group>

    <article>
      <title>FAQ su MSN Messenger Service</title>
      <url>http://messenger.msn.com/support/knownissues.asp</url>
    </article>

    <article>
      <title>Download di MSN Messenger Service</title>
      <url>http://messenger.msn.com/download/download.asp</url>
    </article>

    <article>
      <title>MSN Messenger Service è usato in tutto il mondo</title>
      <url>http://messenger.msn.com/support/intl_map.asp</url>
    </article>

  </article-group>

</msn-data>


Installazione in modalità batch

Il programma di personalizzazione di Internet Explorer abilita al controllo delle funzionalità e dell'esperienza dell'utente con Installazione di Windows Update. È possibile controllare ulteriormente il processo di installazione usando un file batch, le opzioni della riga di comando o una combinazione dei due. Questi metodi possono essere utilizzati independentemente dal fatto che Internet Explorer sia installato da solo o con Microsoft Office.

Nella maggior parte dei casi il metodo del file batch consente un maggiore controllo sull'installazione dei singoli componenti ed è costituito da pochi passaggi. Le opzioni della riga di comando vengono fornite per garantire la compatibilità con le versioni precedenti e per supportare soluzioni personalizzate.

Creazione di un file batch

Per creare un file batch, usare un editor di testo come Microsoft Notepad e denominare il file IEbatch.txt. Se si prevede di eseguire il file batch tramite opzioni della riga di comando, è possibile usare un nome differente per il file batch, ma sarà necessario ricordarsi di usare il nome corretto nella sintassi della riga di comando. Per ulteriori informazioni, vedere Sintassi del file batch. Per un esempio, vedere Esempio di file batch per l'installazione.

Uso dei file batch per la distribuzione di Internet Explorer

Se si distribuisce Internet Explorer tramite Internet o una rete intranet, è possibile inviare il file batch al sito dal quale gli utenti effettuano il download di Internet Explorer. Se la distribuzione avviene ad esempio attraverso un CD o un disco floppy, il file batch può essere inserito in tali supporti. Posizionare il file nella stessa cartella del file IE5Setup.exe.

Potrebbe essere preferibile conservare il file batch in un luogo diverso se tale file non era disponibile al momento della preparazione del pacchetto IEAK oppure se si desidera modificare temporaneamente o permanentemente le impostazioni di installazione specificate nel pacchetto IEAK personalizzato.

Esecuzione dell'installazione tramite opzioni della riga di comando

Nel caso in cui si stia preparando un pacchetto contenente sia Internet Explorer e relativi componenti associati sia prodotti propri, generalmente vengono usate le opzioni della riga di comando per installare un pacchetto IEAK come parte del programma di installazione. Se si desidera modificare l'installazione usando opzioni della riga di comando, è possibile usare la procedura guidata di IExpress, inclusa con IEAK, oppure un altro programma per preparare il pacchetto dei file di installazione.

Per ulteriori informazioni, vedere Parametri di installazione della modalità batch di Internet Explorer e Parametri di installazione della modalità batch di IExpress.

Motivi per i quali eseguire l'installazione da una riga di comando o un file batch

Di seguito sono riportate alcune ragioni per le quali si potrebbe desiderare l'aggiunta di ulteriori controlli per l'Installazione di Windows Update.

Implementare l'installazione visibile all'utente

L'amministratore della rete intranet può distribuire Internet Explorer agli utenti, dopo il normale orario lavorativo. Sebbene IEAK risulti particolarmente utile in un'installazione "invisibile" o "silenziosa" che richiede un intervento minimo da parte dell'utente, è possibile stabilire un maggior controllo su tale processo. Usando delle impostazioni nei file batch o tramite opzioni della riga di comando, è possibile determinare quali messaggi vengono visualizzati all'utente e se il computer si riavvia alla fine dell'installazione.

Ridistribuire Internet Explorer

I produttori di software indipendenti hanno la possibilità di offrire Internet Explorer con il proprio programma e di installare Internet Explorer senza le icone o l'interfaccia browser. A tale scopo, usare un file batch con l'opzione Redist o con l'opzione /X. Per ulteriori informazioni, vedere Parametri di installazione della modalità batch di Internet Explorer.

Ottenere maggiore controllo su specifici componenti

Uso di un file batch abilita all'installazione e al controllo dei componenti, indipendentemente dal fatto che questi componenti siano inclusi o meno nel pacchetto IEAK. È inoltre possibile limitare il numero di modalità di installazione, ad esempio Tipica e Minima, disponibili agli utenti. Usare ComponentID, una stringa del tipo NetMeeting, per identificare i componenti. Le informazioni su ComponentID si trovano nel file Iesetup.cif.

Modificare le opzioni di installazione senza che sia necessario creare nuovamente il pacchetto IEAK

Nel caso di un'installazione particolare di Internet Explorer senza creare nuovamente il pacchetto IEAK. È possibile usare un file batch o dei parametri per modificare le impostazioni precedentemente specificate nella procedura guidata dell'installazione di Internet Explorer quando è stato creato il pacchetto.


Sintassi del file batch

È possibile usare un file batch per controllare ulteriormente la procedura di installazione e l'installazione guidata di Windows Update per Internet Explorer e Accesso a Internet. La seguente tabella indica le sezioni e le voci relative al file batch. Per ulteriori informazioni sull'uso dei file batch, vedere Installazione in modalità batch. Per un file di esempio completo, vedere Esempio di file batch per l'installazione.

Sezioni di un file batch

[Options]

[Welcome]

[SetupChoice]

[Custom]

[Download]

[DownloadSite]

[PrepareSetup]

[Diskspace]

[Progress]

[RebootPartial]

[Finish]

[Reboot]

[Upgrade]

[Options]
SaveUninstallInfo=[0,1]
ExtraSection=
Quiet=[A,C,U]
ShowErrors=[0,1]
Display=[0,1]

Voci della sezione | Descrizione
SaveUninstallInfo=[0,1] Determina se le informazioni relative alla rimozione dei componenti vengono memorizzate.
  • 0 specifica che le informazioni non vengono memorizzate. Se si utilizza questo parametro non sarà possibile disinstallare Internet Explorer dal Pannello di controllo
  • 1 (predefinito) specifica che le informazioni vengono memorizzate.
ExtraSection=sezione1[,sezione2,...] | Esegue le sezioni specificate nel file Iesetup.inf. Separare le sezioni con virgole, ad esempio sezione1,sezione2,sezione3).
Quiet=[A,C,U] Rappresenta la modalità silenziosa, tramite la quale l'installazione viene eseguita con un intervento minimo o nullo da parte dell'utente.
  • A specifica la modalità amministrativa nella quale all'utente non viene visualizzata l'installazione e non viene eseguito alcun controllo degli errori.
  • C elimina il pulsante Annulla dalla pagina che indica l'avanzamento dell'operazione.
  • U specifica che l'installazione non sarà visibile all'utente, a meno che non sia necessario un input, ad esempio la directory di download.
ShowErrors=[0,1] Determina la visualizzazione degli errori di installazione.
  • 0 specifica che l'installazione esegue l'operazione predefinita per ogni messaggio senza alcun intervento da parte dell'utente.
  • 1 (predefinito) specifica che gli errori di installazione verrano visualizzati.
Torna all'inizio

[Welcome]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione della schermata iniziale dell'installazione.
  • 0 specifica che la schermata iniziale dell'installazione non viene visualizzata.
  • 1 (predefinito) specifica che la schermata iniziale dell'installazione viene visualizzata.
Torna all'inizio

[SetupChoice]
Display=[0,1]
SetupChoice=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione della schermata che consente agli utenti di scegliere l'opzione di installazione per la personalizzazione.
  • 0 specifica che la schermata relativa al tipo di installazione non viene visualizzata.
  • 1 (predefinito) specifica che la schermata relativa al tipo di installazione viene visualizzata.
SetupChoice=[0,1] Determina quale opzione di installazione scegliere.
  • 0 (predefinito) specifica Installa - Installazione tipica.
  • 1 specifica Installazione personalizzata.
Torna all'inizio

[Custom]
Display=[0,1]
InstallDir=foldername
InstallDirRO=[0,1]
UseInfInstallDir=[0,1]
SetupMode=[0,1,2]
SetupModeRO=[0,1]
Component=[ComponentID_1, ComponentID_2, ...]
ComponentListRO=[0,1]
DownloadOnly=[0,1]
DownloadOnlyRO=[0,1]
IECompat=[0,1]
IECompatRO=[0,1]
IECompatShow=[0,1]
ShowAdvanced=[0,1]
IEDefault=[0,1]
IEDefaultRO=[0,1]

Voci della sezione | Descrizione
Display=[0,1] Determina la visualizzazione della schermata delle opzioni dei componenti, che consente agli utenti di selezionare i componenti e fare clic su Avanzate per specificarne ulteriori opzioni.
  • 0 specifica che la schermata delle opzioni dei componenti non viene visualizzata.
  • 1 (predefinito) specifica che la schermata delle opzioni dei componenti viene visualizzata.
InstallDir=foldername | Specifica la cartella nella quale installare i file. Se questa impostazione non viene definita, l'installazione utilizzerà le impostazioni presenti nel file Iesetup.inf. Se si dispone di una precedente versione di Internet Explorer, i file verranno installati nella stessa cartella della versione precedente.
InstallDirRO=[0,1] Determina se all'utente è consentito cambiare la cartella di installazione.
  • 0 (predefinito) specifica che all'utente è consentito cambiare la cartella di installazione.
  • 1 specifica che all'utente non è consentito cambiare la cartella di installazione.
UseInfInstallDir=[0,1] Determina la cartella nella quale verrà installato Internet Explorer.
  • 0 (predefinito) specifica che l'installazione utilizza la cartella di installazione predefinita oppure la stessa cartella della versione precedente di Internet Explorer.
  • 1 specifica che verrà utilizzata la cartella di installazione indicata nel file Iesetup.inf.
SetupMode=[0,1,2] Determina il tipo di installazione.
  • 0 specifica l'installazione Minima.
  • 1 (predefinito) specifica l'installazione Tipica.
  • 2 specifica l'installazione Completa.
SetupModeRO=[0,1] Determina se all'utente è consentito cambiare il tipo di installazione.
  • 0 specifica che all'utente è consentito cambiare il tipo di installazione.
  • 1 (predefinito) specifica che all'utente non è consentito cambiare il tipo di installazione.
Component=[IDcomponente1[,IDcomponente2,...]]

Specifica che verranno installati solo i componenti indicati nell'impostazione Component=. L’IDcomponente è una stringa che identifica in modo univoco un componente; è possibile trovare la stringa corrispondente nella sezione dei componenti del file Iesetup.cif. È inoltre possibile trovare informazioni sull'IDcomponente al sito Web di IEAK.
ComponentListRO=[0,1]

Determina se all'utente è consentito specificare quali componenti installare, oltre a quelli previsti dal tipo di installazione.

  • 0 (predefinito) specifica che all'utente è consentito modificare l'elenco dei componenti.
  • 1 specifica che all'utente non è consentito modificare l'elenco dei componenti.
DownloadOnly=[0,1] Determina se Internet Explorer verrà solo scaricato o anche installato.
  • 0 (predefinito) specifica che i file vengono scaricati e installati.
  • 1 specifica che i file vengono scaricati ma non installati.
DownloadOnlyRO=[0,1] Determina se all'utente è consentito specificare se i file verranno solo scaricati o anche installati.
  • 0 (predefinito) specifica che all'utente è consentito cambiare questa impostazione.
  • 1 specifica che all'utente non è consentito cambiare questa impostazione.
IECompat=[0,1] Determina se Internet Explorer 5 o versione successiva è stato installato sullo stesso computer nel quale si trova Internet Explorer 4, in modo da rendere disponibili le funzionalità di entrambi i programmi.
  • 0 specifica che Internet Explorer 5 o versione successiva non può essere installato insieme a Internet Explorer 4.
  • 1 specifica che Internet Explorer 5 o versione successiva può essere installato insieme a Internet Explorer 4.
IECompatRO=[0,1] Determina se all'utente è consentito specificare se utilizzare le funzionalità di Internet Exporer 4 insieme a quelle di Internet Explorer 5 o versione successiva.
  • 0 (predefinito) specifica che all'utente è consentito cambiare questa impostazione.
  • 1 specifica che all'utente non è consentito cambiare questa impostazione.
IECompatShow=[0,1] Determina la visualizzazione della casella di controllo Compatibilità, che consente agli utenti di utilizzare Internet Explorer 5 o versione successiva parallelamente a Internet Explorer 4.
  • 0 specifica che la casella di controllo non verrà visualizzata durante la procedura guidata.
  • 1 (predefinito) specifica che la casella di controllo verrà visualizzata durante la procedura guidata.
ShowAdvanced=[0,1] Determina la visualizzazione del pulsante Avanzate nella schermata delle opzioni dei componenti dell'installazione guidata di Windows Update. Facendo clic su questo pulsante, verranno visualizzate le opzioni Solo download, Compatibilità e Non associare tipi di file.
  • 0 specifica che il pulsante Avanzate non verrà visualizzato durante la procedura guidata.
  • 1 (predefinito) specifica che il pulsante Avanzate verrà visualizzato durante la procedura guidata.
IEDefault=[0,1] Determina se utilizzare Internet Explorer come browser predefinito.
  • 0 specifica che Internet Explorer non verrà utilizzato come browser predefinito.
  • 1 (predefinito) specifica che Internet Explorer verrà utilizzato come browser predefinito.
IEDefaultRO=[0,1] Determina se all'utente è consentito specificare Internet Explorer come browser predefinito.
  • 0 specifica che all'utente è consentito determinare se Internet Explorer verrà utilizzato come browser predefinito.
  • 1 (predefinito) specifica che all'utente non è consentito determinare se Internet Explorer verrà utilizzato come browser predefinito.
Torna all'inizio

[Download]
Display=[0,1]
DownloadDir=foldername
DownloadDirRO=[0,1]
DownloadOS=[0,1]
DownloadOSRO=[0,1]

Voci della sezione | Descrizione
Display=[0,1] Determina la visualizzazione dell'opzione per scaricare o installare i file.
  • 0 specifica che l'opzione per scaricare o installare i file non viene visualizzata.
  • 1 (predefinito) specifica che l'opzione per scaricare o installare i file viene visualizzata.
DownloadDir=nomecartella | Specifica la cartella nella quale scaricare i file. Se questa impostazione non viene definita, l'installazione creerà una cartella denominata File di installazione di Windows Update nell'unità che dispone di maggiore spazio.
DownloadDirRO=[0,1] Determina se agli utenti è consentito modificare la cartella nella quale verranno scaricati i file.
  • 0 (predefinito) specifica che all'utente è consentito cambiare la cartella di download.
  • 1 specifica che all'utente non è consentito cambiare la cartella di download.
DownloadOS=[0,1] Determina il download dei file relativi a uno specifico sistema operativo. Questa impostazione è valida solo se i file vengono scaricati ma non installati (DownloadOnly=1).
  • 0 (predefinito) specifica il sistema operativo corrente.
  • 1 specifica Windows 95, Windows 98, Windows Millennium Edition, Windows NT e Windows 2000.
DownloadOSRO=[0,1] Determina se agli utenti è consentito specificare il sistema operativo dei file scaricati nel computer.
  • 0 (predefinito) specifica che all'utente è consentito cambiare questa impostazione.
  • 1 specifica che all'utente non è consentito cambiare questa impostazione.
Torna all'inizio

[DownloadSite]
Display=[0,1]
DownloadLocation=URL
DownloadSiteList=URL

Voci della sezione | Descrizione
Display=[0,1] Determina la visualizzazione dei siti per il download.
  • 0 specifica che all'utente non vengono visualizzati i siti per il download.
  • 1 (predefinito) specifica che all'utente vengono visualizzati i siti per il download.
DownloadLocation=URL | Specifica l'indirizzo del sito dal quale gli utenti possono scaricare i file cab se la distribuzione avviene tramite il Web. Se in questa sezione si utilizza Display=0 o qualsiasi altro parametro che impedisce la visualizzazione di questa pagina, sarà necessario immettere un sito per il download.
DownloadSiteList=URL | Specifica la posizione dell'elenco dei siti per il download. L'elenco è presente nel file Ie5sites.dat come impostazione predefinita. Se questa impostazione non viene definita, l'installazione utilizzerà le impostazioni presenti nel file Iesetup.inf.
Torna all'inizio

[PrepareSetup]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione della schermata Preparazione dell'installazione.
  • 0 specifica che all'utente non viene visualizzata la schermata Preparazione dell'installazione.
  • 1 (predefinito) specifica che all'utente viene visualizzata la schermata Preparazione dell'installazione.
Torna all'inizio

[Diskspace]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione della quantità di spazio su disco necessaria.
  • 0 specifica che all'utente non viene visualizzata la quantità di spazio su disco necessaria. Se lo spazio su disco è insufficiente, l'installazione verrà interrotta.
  • 1 (predefinito) specifica che all'utente viene visualizzata la quantità di spazio su disco necessaria.
Torna all'inizio

[Progress]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione dell'avanzamento dell'installazione.
  • 0 specifica che all'utente non viene visualizzato l'avanzamento dell'installazione.
  • 1 (predefinito) specifica che all'utente viene visualizzato l'avanzamento dell'installazione.
Torna all'inizio

[RebootPartial]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione della schermata dell'installazione non completata in caso di mancata installazione di un componente.
  • 0 specifica che in caso di mancata installazione di un componente, non verrà visualizzata la schermata di installazione non completata.
  • 1 specifica che in caso di mancata installazione di un componente, verrà visualizzata la schermata di installazione non completata.
Torna all'inizio

[Finish]
Display=[0,1]

Voci della sezione Descrizione
Display=[0,1] Determina la visualizzazione del messaggio che il computer verrà riavviato al termine dell'installazione.
  • 0 specifica di non visualizzare il messaggio che il computer verrà riavviato al termine dell'installazione. Se si desidera riavviare il computer al termine dell'installazione, impostare 0.
  • 1 (predefinito) specifica di visualizzare il messaggio che il computer verrà riavviato al termine dell'installazione.
Torna all'inizio

[Reboot]
Reboot=[0,1]

Voci della sezione Descrizione
Reboot=[0,1] Determina il riavvio del computer al termine dell'installazione.
  • 0 specifica che non si desidera riavviare il computer al termine dell'installazione. Se si decide di riavviare il computer, sarà il programma ad effettuare le operazioni di riavvio. Internet Explorer non sarà configurato correttamente se il computer non viene riavviato.
  • 1 (predefinito) specifica che si desidera riavviare il computer al termine dell'installazione.
Torna all'inizio

[Upgrade]
ReinstallAll=[0,1]

Voci della sezione Descrizione
ReinstallAll=[0,1] Determina se reinstallare tutti i componenti nel caso in cui l'installazione venga eseguita una seconda volta.
  • 0 (predefinito) specifica che non è necessario eseguire nuovamente l'installazione se tutti i componenti sono già stati installati.
  • 1 specifica di eseguire la reinstallazione di tutti i componenti.
Torna all'inizio


Parametri di installazione della modalità batch di IExpress

La procedura guidata di IExpress consente di passare facilmente i parametri di installazione da un programma all'altro. Durante l'uso di IExpress, i parametri di Internet Explorer vengono inseriti all'interno dell'espressione di IExpress nel modo seguente:

Ie5setup <parametri IExpress> /c:" ie5wzd <parametri Internet Explorer>"

Parametri IExpress

I parametri IExpress che seguono sono quelli più utilizzati per il controllo del processo di estrazione durante l'installazione. Questi parametri non sono specifici per Internet Explorer.

Parametri | Azione
/Q | Specifica la modalità silenziosa o elimina i messaggi di richiesta inviati all'utente durante l'estrazione dei file. Questo parametro non elimina i messaggi di richiesta inviati all'utente durante l'esecuzione dell'installazione di Windows Update.
/Q:U | Specifica la modalità silenziosa per l'utente che visualizza solo alcune finestre di dialogo.
/Q:A | Specifica la modalità silenziosa per l'amministratore che non visualizza alcuna finestra di dialogo all'utente.
/C:<UNC location> | Specifica il percorso e il nome del file di installazione inf o exe.
/R:N | Non riavvia il computer al termine dell'installazione.
/R:A | Riavvia sempre il computer al termine dell'installazione.
/R:S | Riavvia il computer al termine dell'installazione senza inviare alcun messaggio all'utente.
/T:<directory path> | Specifica la cartella nella quale installare i file estratti.

Per ulteriori informazioni su IExpress, vedere Tecnologia IExpress e procedura guidata di IExpress.

Per un elenco completo dei parametri di installazione di Internet Explorer, vedere Parametri di installazione della modalità batch di Internet Explorer.


Tecnologia IExpress e creazione guidata pacchetti IExpress

IExpress è una tecnologia progettata per semplificare la creazione dei programmi di installazione. Utilizzando la procedura guidata passo per passo di IExpress è possibile creare file autoestraenti che eseguano automaticamente il programma di installazione in essi contenuto. Il programma di installazione può essere un file inf o un programma eseguibile. Al termine dell'installazione, la tecnologia IExpress rimuove automaticamente i file di installazione, consentendo un notevole risparmio di tempo e di energia.

La Creazione guidata pacchetti IExpress consente di eseguire installazioni specifiche per il browser personalizzato, stabilendo ad esempio se il computer dovrà essere riavviato al termine dell'installazione. Il file IExpress.exe, che consente di eseguire la procedura guidata di IExpress, è contenuto nella cartella \<Programmi IEAK>\Tools. Alcune delle scelte effettuate durante l'esecuzione della procedura guidata corrispondono a particolari parametri di installazione della modalità batch.

IExpress utilizza un file sed (Self-Extraction Directive) in cui memorizzare le informazioni relative al pacchetto. Durante l'esecuzione della creazione guidata pacchetti IExpress è possibile utilizzare un file sed esistente oppure crearne uno nuovo utilizzando la procedura guidata. Il file sed conterrà tutte le informazioni e le istruzioni relative al pacchetto di installazione.

Se si crea un file autoestraente con IExpress la cui versione in lingua differisce da quella del programma di personalizzazione di Internet Explorer, è necessario copiare i file Wextract.exe e Advpack.dll contenuti nella cartella \<Programmi IEAK>\Iebin\<lang>\Optional nella cartella \<Programmi IEAK>\Tools (dove si trovano i file Iexpress.exe, Makecab.exe, W95inf32.dll, e W95inf16.dll). Includere advpack.dll nel pacchetto.

Caratteristiche della tecnologia IExpress

  • Installazione visibile e installazione invisibile all'utente di Internet Explorer.
  • Supporto per gli aggiornamenti indipendenti dalla rimozione di eventuali installazioni precedenti.
  • Supporto per l'aggiornamento o per un'ulteriore installazione della stessa versione.
  • Installazione che non richiede il riavvio dei computer che eseguono Windows 98 OSR2.

Impostazioni che è possibile specificare nei file inf usati da IExpress

  • Determinazione della destinazione del pacchetto autoinstallante agli amministratori o agli utenti generici.
  • Impostazione delle diverse modalità di esecuzione del comando di installazione incorporato, quali normale o invisibile all'utente.
  • Determinazione dell'aggiornamento delle librerie di collegamento dinamico (file dll) di IExpress presenti nel computer di un utente rispetto a quelle correnti.
  • Determinazione delle versioni di destinazione, quali gli intervalli di versione del sistema operativo, del browser o di un'applicazione, identificata da una o più versioni del file, compatibili con il pacchetto.
  • Determinazione della visualizzazione in modalità batch di un messaggio di avviso in caso di esecuzione contemporanea di una seconda copia del pacchetto o preclusione dell'effettuazione di un'altra operazione.
  • Aggiornamento e aggiunta di file al pacchetto IExpress tramite lo strumento UPDFILE senza dover ricreare il pacchetto.
  • Sostituzione di Runonce con RunOnceEx, nel caso in cui esista una versione più aggiornata di iernonce.dll, per consentire all'autore il controllo sull'ordine di esecuzione dell'operazione e sulla visualizzazione dello stato.
  • Installazione di qualsiasi tipo di supporto necessario ai singoli utenti da parte degli amministratori delle reti intranet.
  • Creazione di pacchetti che includano desktop preconfingurati per la presentazione del contenuto personalizzato da parte dei provider di contenuti e di servizi Internet.
  • Come supportare più siti per il download.
  • Come supportare uno sviluppo integrato interno ed esterno, la personalizzazione, l'espandivibilità e il debug avanzato.
  • Risparmio dello spazio su disco tramite la pulizia del disco rigido (Cestino, Occache, cache Wininet, cartella Temp) nelle modalità di installazione., disinstallazione e manutenzione.
  • Come supportare il set di caratteri non SBCS esteso.
  • Come supportare il formato dei file inf durante il download dei componenti Internet.

Per ulteriori informazioni, vedere Uso dei file di informazioni per l'installazione (inf).


Parametri di installazione della modalità batch di Internet Explorer

È possibile controllare il modo in cui Installazione di Windows Update viene eseguito per gli utenti. Tramite parametri della riga di comando è possibile selezionare la modalità di installazione, specificare una modalità silenziosa, che comporta l'eliminazione o la riduzione del numero di messaggi di richiesta visualizzati all'utente, o controllare se il computer deve essere riavviato o meno dopo l'installazione.

È possibile fare in modo che gli utenti includano questi parametri quando eseguono Installazione di Windows Update, ma generalmente si crea il pacchetto Internet Explorer usando un altro programma, ad esempio IExpress, per una installazione batch.

Parametri di Internet Explorer

Le opzioni che seguono consentono di controllare l'installazione di Internet Explorer.

Parametro | Descrizione
/Q | Specifica una modalità di installazione silenziosa e visibile all'utente in cui vengono chieste solo le informazioni non specificate.
/Q:A | Specifica una modalità silenziosa senza messaggi all'utente.
/Q:C | Specifica una modalità silenziosa senza che sia visualizzato il pulsante Annulla, in modo che l'utente non possa interrompere l'installazione. Durante l'installazione in qualità di amministratore delle reti intranet, il programma di personalizzazione guidata di Internet Explorer utilizza queste opzioni se si seleziona Installazione invisibile all'utente.
/B:nomedifile | Specifica il file di script batch da usare.
/M[:{0|1|2|3...10}] Specifica la modalità di installazione. Nel caso di pacchetti di IEAK personalizzati, 0 indica la prima modalità di installazione, 1 la seconda e così via, ad esempio 0=minima, 1=tipica, 2=completa. È possibile specificare fino a dieci modalità di installazione di IEAK.

Se il parametro /M viene usato senza un numero, l'installazione non assume nessuna modalità e vengono istallati solo i componenti specificati. Se questo parametro non viene usato, l'installazione usa il modo predefinito specificato nel file inf.
/E:ID Componenti[, ...] | Specifica componenti aggiuntivi da installare, indipendentemente dalla modalità di installazione. Usare questo parametro per specificare componenti che non sono parte del tipo di installazione specificato nel programma di personalizzazione guidata. Questo parametro ignora inoltre le impostazioni nel file batch di testo, se utilizzato. L'ID Componenti è una stringa che identifica in modo univoco un componente; è possibile trovare la stringa corrispondente nella sezione componenti del file Iesetup.cif.
/S:""#e"" Indica il percorso sorgente di Ie5setup.exe. Il valore ""#e"" indica il nome e il percorso completo del file eseguibile.

Nota

  • Il nome del percorso deve iniziare e terminare con un doppio apice.
/R:N | Non fa effettuare il riavvio del computer al termine dell'installazione. Se dopo il completamento di Installazione di Windows Update non viene eseguito il riavvio del computer, questo deve essere effettuato dal programma di installazione del componente personalizzato. Internet Explorer risulterà correttamente configurato solo dopo il riavvio del computer.
/D | Specifica che si desiderano scaricare solo i file necessari per il sistema operativo corrente.
/D:1 | Specifica che si desiderano scaricare solo i file necessari per i sistemi operativi Microsoft Windows e Windows NT.
/G:sezione[, ...] | Consente di eseguire solo determinate sezioni di installazione contenute in Iesetup.inf. Le sezioni devono essere separate da virgole (,).
/X | Installa Internet Explorer senza la shell, le icone o i collegamenti. Questa opzione è utile per inserire i controlli del browser nella propria applicazione.
/X:1 | Installa Internet Explorer senza la shell, le icone o i collegamenti, ma non prende il controllo delle impostazioni predefinite per le associazioni del browser e del protocollo http.
/P | Visualizza i componenti richiesti da un'installazione e lo spazio necessario su disco. Questa opzione permette di vedere quanto spazio su disco verrà usato a seconda delle opzioni di installazione selezionate. Vedere Valutazione delle dimensioni di installazione di Internet Explorer più avanti per ulteriori informazioni.

Nota

  • Se si installa Internet Explorer su un computer in cui non è mai stato presente Internet Explorer 4 e si desidera fornire agli utenti i canali, includere come componente, in ciascuna opzione di installazione, il Modulo di esplorazione non in linea. Se questo componente non fa parte delle opzioni di installazione, aggiungere il Modulo di esplorazione non in linea come componente richiesto usando il parametro /E: con MobilePk come ID componente.

Parametri della riga di comando usati con IExpress.

La procedura guidata di IExpress consente di passare facilmente i parametri da un programma all'altro. Durante l'uso di IExpress, i parametri di Internet Explorer vengono inseriti all'interno dell'espressione di IExpress nel modo seguente.

Ie5setup <parametri IExpress> /c:" ie5wzd <parametri Internet Explorer>"

Per un elenco completo dei parametri di installazione di IExpress, vedere Parametri di installazione della modalità batch di IExpress.

Esempi

Di seguito sono riportati alcuni esempi di comandi usati per installare Internet Explorer.

  • L'espressione che segue consente di eseguire un'installazione in modalità silenziosa. Nulla viene visualizzato all'utente e il computer non viene riavviato dopo l'installazione.

    ie5setup.exe /C:"ie5wzd /S:""#e"" /Q /R:N"

  • L'espressione che segue ignora l'elenco dei siti di Ie5sites.dat e installa Internet Explorer da un luogo specificato. È una espressione singola, visualizzata usando più linee di testo per migliorarne la leggibilità.

    ie5setup.exe
    /C:"ie5wzd
    /S:""\\risorsedelserver.com\directory\ie5setup.exe"""

    Questa espressione viene usata per indirizzare gli utenti verso un altro sito di download, ad esempio un'altra nazione o regione, senza che sia necessario ricompilare il pacchetto IEAK.

Valutazione dello spazio dell'installazione di Internet Explorer

È possibile usare i parametri batch di Internet Explorer per passare informazioni sull'installazione di Internet Explorer al pacchetto IEAK personalizzato. Ci sono due ragioni principali per fare questo. Una è visualizzare dinamicamente, a seconda delle opzioni selezionate dall'utente, lo spazio richiesto su disco per l'installazione di Internet Explorer, e la seconda è per fornire informazioni sullo stato dell'installazione durante l'esecuzione della stessa.

Se viene usato il parametro /P, questa informazione viene memorizzata nel registro di configurazione durante l'installazione. In base a questa informazione, Installazione di Windows Update restituisce le seguenti informazioni aggiuntive in HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del registro di configurazione.

Sottochiave | Tipo di dati | Valore
InstallSize | Stringa | numero di kb, cioè la dimensione effettiva dell'installazione.
AdminRights | Binario | 1 o 0
EstimatedCopy | Stringa | numero di kb Questo valore è generalmente più grande di InstallSize, dato che durante il processo di installazione è richiesto uno spazio maggiore. Questo risultato viene usato per una valutazione della modalità di visualizzazione delle informazioni sull'avanzamento del processo.

Codici di ritorno e stato di Installazione di Windows update

Dopo l'installazione di un'applicazione o se l'installazione non è riuscita, il programma di installazione deve indicare quello che è accaduto. Poiché IE5wzd.exe si trova all’interno di Ie5setup.exe, i codici di ritorno non possono essere restituiti direttamente. Dopo l'installazione, il programma memorizza le informazioni in HKEY_LOCAL_MACHINE\Software\Microsoft\Active Setup\InstallInfo del registro di configurazione. Qualsiasi valore HResult Failed ivi riportato indica un errore di qualche tipo.

Sottochiave | Tipo di dati | Valore
Completato | Stringa | DWORD indica l'HRESULT dell'installazione nel modo seguente.
 |  | 0 | Riuscita
 |  | 0x80100003 | Mancano dei file per l'installazione richiesta.
 |  | 0x80100001 | L'installazione è parzialmente riuscita. Uno o più componenti non sono stati scaricati o installati. Controllare la sottochiave FailedComponents per l'elenco di tali componenti.
 |  | 0x80100002 | L'installazione è riuscita parzialmente, ma l'utente ha annullato l'installazione. Uno o più componenti non sono stati scaricati o installati.

Vengono inoltre fornite le seguenti informazioni, relative ai componenti la cui installazione non è avvenuta correttamente:

Sottochiave | Tipo di dati | Valore
FailedComponents | MultiSZ | <Nome del componente da CIFID>null<Nome del componente...>
InstallStatus | Binario | 0 | Installazione eseguita con successo.
 |  | 1 | Installazione interrotta. L'utente ha interrotto l'installazione e viene chiesto se desidera annullarla.
 |  | 2 | No, non annullare, riprendi l'installazione.
 |  | 3 | Si, annullamento confermato, interrompere l'installazione. In alcuni casi, è possibile che sia necessario completare un'attività in corso, ad esempio la copia o l'estrazione di un file.


Aggiornamento periodico per gli utenti

È possibile avvertire automaticamente gli utenti quando è disponibile una nuova versione di Internet Explorer. È infatti possibile configurare Internet Explorer affinché ricerchi le informazioni aggiornate e definire la frequenza di tale ricerca.

Di seguito viene descritto il funzionamento di tale opzione.

  • Quando viene individuata una nuova versione di Internet Explorer, la pagina iniziale dell'utente viene temporaneamente sostituita da una pagina di notifica dell'aggiornamento. Da questa pagina è possibile aggiornare il proprio browser, aggiungere la stessa all'elenco Preferiti oppure eliminare l'aggiornamento.
  • Per impostazione predefinita, viene utilizzata la pagina di Internet Explorer di Microsoft Windows Update come pagina di notifica dell'aggiornamento. È inoltre possibile visualizzare una pagina Web personalizzata che fornisca informazioni sull'aggiornamento dei prodotti o anche informazioni sull'azienda. Ad esempio, è possibile creare una pagina Web per fornire agli utenti informazioni su nuove versioni di Internet Explorer, su nuovi percorsi server e sulla società.

    La pagina di notifica dell'aggiornamento permette di fornire periodicamente agli utenti informazioni in formato htm. È inoltre possibile distribuire questo tipo di informazioni agli utenti utilizzando i canali e i file in formato cdf.

  • Al successivo avvio del browser, verrà visualizzata la pagina iniziale definita dall'utente.

È possibile specificare le impostazioni della pagina di notifica effettuando le seguenti operazioni:

  1. Se si modificano le impostazioni dal programma di personalizzazione di Internet Explorer, in Criteri di protezione e restrizioni della Fase 5, fare clic su Impostazioni Internet.

    oppure

    se si modificano le impostazioni dal Gestione profili, fare clic su Criteri di protezione e restrizioni, quindi su Impostazioni Internet.

  2. Selezionare la casella di controllo Verifica automaticamente aggiornamenti di Internet Explorer.
  3. Sul lato sinistro dello schermo, fare clic su Aggiornamento componenti.
  4. Se si desidera utilizzare la pagina predefinita di Windows Update, non sostituire l'URL predefinito.

    Se si desidera utilizzare una pagina personalizzata, digitare il relativo indirizzo nella casella URL da visualizzare per gli aggiornamenti.

  5. In Intervallo controllo aggiornamenti, specificare l'intervallo espresso in giorni tra un controllo e l'altro.

Se si decide di creare una pagina personalizzata per la propria organizzazione, vedere il file di esempio ieupdate.htm nella cartella \<IEAK>\Toolkit.

Nota

  • Alla voce Restrizioni d'accesso, presente nelle pagine della procedura guidata Gestione profili e Criteri di protezione e restrizioni, è possibile specificare in Aggiornamento componenti se effettuare periodicamente il controllo per le versioni aggiornate di Internet Explorer e Accesso a Internet.


Rilevazione e configurazione automatica delle impostazioni del browser

È possibile configurare la propria rete in modo che Internet Explorer venga automaticamente personalizzato al primo avvio. In questo modo è possibile ridurre il sovraccarico amministrativo e le eventuali richieste di aiuto relative alle impostazioni del browser.

Il rilevamento automatico delle impostazioni del browser, basato su Web Proxy AutoDiscovery (WPAD), è supportato sia dal protocollo DHCP (Dynamic Host Configuration Protocol) sia dal DNS (Domain Name System). Con le impostazioni adeguate, i server DHCP e DNS possono rilevare e configurare automaticamente le impostazioni del browser. Questa funzionalità si basa su tecnologie di configurazione automatica esistenti, che consentono la configurazione di un browser da una posizione centrale utilizzando un URL di un file di configurazione automatica (file ins) o un file di configurazione proxy Javascript (js, jvs, o pac).

Grazie al rilevamento automatico, il browser può essere configurato automaticamente all'avvio, anche se questo non è stato precedentemente personalizzato dall'amministratore. Ad esempio, se si deve scaricare da Internet un browser non personalizzato, il rilevamento automatico può configurare e personalizzare automaticamente il browser dell'utente, invece di installare una versione personalizzata dal server dell'azienda.

Per impostare il rilevamento automatico delle impostazioni del browser in IEAK, selezionare Rileva automaticamente impostazioni in Configurazione automatica del programma di personalizzazione di Internet Explorer. Per un'illustrazione della configurazione automatica, vedere Modalità di configurazione automatica.

Rilevamento automatico delle impostazioni del browser per i server DHCP e DNS

Un server DHCP consente all'amministratore di specificare parametri TCP/IP globali e specifici per le subnet e di definire i parametri per i client utilizzando indirizzi riservati. Quando un computer client si sposta tra subnet, all'avvio viene automaticamente riconfigurato per il TCP/IP.

Importante

  • Il server DHCP deve supportare i messaggi DHCPINFORM, come avviene per il server DHCP in Windows 2000.

Il DNS è costituito da un insieme di protocolli e servizi su una rete TCP/IP e consente agli utenti di individuare altri computer utilizzando nomi gerarchici semplici, denominati spesso "host", invece di indirizzi IP numerici.

L'uso del DHCP con rilevamento automatico è consigliato per gli utenti che utilizzano una rete LAN, mentre il DNS permette il rilevamento delle impostazioni sia degli utenti di reti LAN che degli utenti che utilizzano una connessione di accesso remoto. Sebbene il DNS sia in grado di gestire entrambi i tipi di utenti, il DHCP assicura agli utenti di reti LAN un accesso più veloce e una maggiore flessibilità nella definizione dei file di configurazione.

Per attivare il rilevamento automatico delle impostazioni del browser, è necessario configurare alcune impostazioni specifiche sul server DNS o DHCP, o su entrambi.

Per ulteriori informazioni, vedere:

Attivazione del rilevamento automatico delle impostazioni del browser su un server DHCP

Per impostare il rilevamento automatico delle impostazioni del browser su un server DHCP, è necessario creare un nuovo tipo di opzione con il numero di codice 252. Per il valore associato a questo codice, digitare l'URL che indica il file di configurazione. Questo file di configurazione può avere un'estensione pac, jvs, js o ins.

Per informazioni specifiche sulla configurazione del server DHCP, consultare la relativa documentazione.

Esempi

http://www.microsoft.com/webproxy.pac

http://marketing/config.ins

http://###.#.###.#/account.pac

Attivazione del rilevamento automatico su un server DNS

Per attivare il rilevamento automatico delle impostazioni del browser su un server DNS, è necessario configurare il record host o il record "alias" CNAME presente nel file di database del DNS.

Record host

Il record host viene usato per associare i nomi dell'host agli indirizzi IP all'interno di un'area. Il record host contiene le voci per tutti gli host che richiedono mapping statici, come le workstation, i server dei nomi e della posta.

La sintassi è: <nome host> IN A <indirizzo ip dell'host>

Ad esempio:

corserv | IN | A | 192.55.200.143
nomeserver2 | IN | A | 192.55.200.2
serverdiposta1 | IN | A | 192.55.200.51

record CNAME

Questi record vengono denominati a volte "alias" ma tecnicamente sono definiti elementi CNAME (Canonical Name). Consentono di utilizzare più nomi per indicare un unico host. I record CNAME permettono ad esempio di installare sullo stesso computer un server FTP e un server Web.

Configurazione del file di database del DNS per il rilevamento automatico delle impostazioni del browser

  • Nel file del database DNS, immettere un record host denominato wpad che fa riferimento all'indirizzo IP del server Web che contiene i file di configurazione automatica con estensione pac, jvs, js o ins.

    Altrimenti, immettere un record CNAME denominato wpad che faccia riferimento al nome del server (al nome risolto, non all'indirizzo IP) che contiene i file di configurazione automatica con estensione pac, jvs, js o ins.

Note

  • Dopo aver aggiunto il record e dopo aver distribuito il file di database al server, il nome del DNS wpad.dominio.com dovrebbe essere risolto nello stesso nome di computer del server che contiene i file di configurazione automatica.

  • Utilizzando un server DNS, Internet Explorer crea un modello di URL predefinito basandosi sul nome dell'host wpad.

    Ad esempio:

    http://wpad.dominio.com/wpad.dat

    Quindi, sul server Web wpad, è necessario impostare un file o reindirizzare i punti denominati wpad.dat, che forniscono i contenuti del file di configurazione automatica.


Gestione dell'installazione su richiesta

Quando l'utente installa Internet Explorer, può scegliere i componenti desiderati, controllando lo spazio occupato sul disco e riducendo il tempo per l'esecuzione del download e dell'installazione. Durante l'esplorazione del Web l'utente può tuttavia accorgersi della necessità di altri componenti.

Nel caso in cui l'utente visiti una pagina Web per la quale è necessario programma o un componente ancora non installato, l'Installazione su richiesta invia un messaggio che chiede di installare i componenti necessari.

L'amministratore di rete o l'ISP possono controllare questa funzionalità tramite l'utilizzo di IEAK.

Nota

  • Se l'azienda utilizza l'installazione su richiesta per Internet, occorre autenticare i file cab e specificare le impostazioni di protezione indicando che il server su cui risiedono tali file è attendibile o, solo nel caso di un sito intranet, impostare un livello di protezione basso. Per ulteriori informazioni, vedere Firma dei programmi.

    Se la protezione della rete intranet è di livello medio o elevato e si intende definire i server di rete come attendibili, attenersi alla seguente procedura:

    1. Dalla pagina delle impostazioni di sicurezza della procedura guidata, fare clic su Personalizza le impostazioni delle aree di protezione, quindi fare clic su Modifica impostazioni.
    2. Selezionare l'area Intranet locale e fare clic su Siti.
    3. Deselezionare la casella di controllo Includi tutti i percorsi di rete (UNC) e fare clic su OK.
    4. Selezionare l'area Siti affidabili, fare clic su Siti e digitare il percorso del server per il download, quindi fare clic su Aggiungi.
    5. Ripetere le operazioni precedenti per tutti i server che eseguono il download e che si desidera specificare come attendibili.


Gestione dell'Aggiornamento desktop di Windows

Con l'Aggiornamento desktop di Windows di Microsoft la visualizzazione e le modalità di utilizzo del desktop e delle cartelle sono simili a quelle utilizzate per esplorare il Web. Anche se il programma per l’aggiornamento del desktop di Windows non fa parte di Internet Explorer 5 (o versioni successive), è possibile includerlo nel pacchetto IEAK. Gli utenti di Windows 98, Windows 98 Second Edition, Windows Millennium Edition o Windows 2000, dispongono già delle nuove funzioni del desktop.

Se si desidera installare e personalizzare l'Aggiornamento desktop di Windows, è necessario che questo venga eseguito con le seguenti configurazioni:

  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition
  • Windows 2000
  • Se si è installato l'Aggiornamento desktop di Windows su altre versioni di Windows, sarà necessario utilizzare Internet Explorer 5.5, aggiornando la versione 4.0.

L'Aggiornamento desktop di Windows può rivelarsi utile per impostare un desktop standard aziendale.

Se è installato l'Aggiornamento desktop di Windows, è possibile esplorare il computer con le stesse modalità di esplorazione del Web. In Windows saranno pertanto disponibili i menu di Internet Explorer Vai e Preferiti e le modalità di esplorazione del Web. È possibile aggiungere un contenuto attivo al desktop, ad esempio un programma per controllare i dati di borsa, alla barra delle applicazioni o alle cartelle e scegliere di aprire ed eseguire i file facendo click su di essi.

È inoltre possibile controllare la modifica di queste impostazioni da parte degli utenti, nonché le impostazioni di protezione e del proxy. Tali impostazioni vengono specificate in Criteri di protezione e restrizioni nella Fase 5 del programma di personalizzazione di Internet Explorer oppure utilizzando Gestione profili di IEAK. È possibile inoltre controllare con regolarità i profili utilizzando la funzione di configurazione automatica.

Nota

  • Se si include l'Aggiornamento desktop di Windows come componente del pacchetto che si intende distribuire, la lingua utilizzata nel pacchetto IEAK deve corrispondere a quella del sistema operativo del computer. Se si tenta di installare il browser e l'Aggiornamento desktop di Windows in una lingua diversa, verrà installato soltanto il browser.


Impostazioni e restrizioni

Criteri di protezione e restrizioni di Internet Explorer è un meccanismo utile per migliorare la gestibilità dei computer. Criteri di protezione e restrizioni, definite in un file di protezione, gestisce i privilegi dell'utente e di accesso al computer ignorando i valori di registro predefiniti durante l'accesso dell'utente.

È possibile usare il programma di personalizzazione di Internet per predefinire i criteri di sistema e le restrizioni e per la creazione di una configurazione standard di Internet Explorer nel pacchetto browser personalizzato. Dopo aver installato Internet Explorer, è possibile usare Gestione profili di IEAK per la gestione e l'aggiornamento dei criteri di sistema e restrizioni sul desktop. Se gruppi diversi di utenti hanno esigenze specifiche, è possibile usare Gestione profili di IEAK per la creazione di file ins di protezione per ciascun gruppo.

È possibile ad esempio specificare che i criteri di sistema e restrizioni eseguano le seguenti operazioni:

  • Determinare le caratteristiche che possono essere modificate dall'utente come le barre degli strumenti di Active Desktop e di Internet Explorer.
  • Gestire la larghezza di banda e controllare il comportamento e l'aspetto di Internet Explorer.
  • Specificare gli elenchi dei server per componenti quali Microsoft NetMeeting e impostare una pagina per l'aggiornamento periodico degli utenti.
  • Stabilire quali programmi vengono utilizzati per la posta elettronica e per le chiamate Internet.
  • Predeterminare le impostazione delle connessioni degli utenti. Per gestire le impostazioni di più connessioni, utilizzare l'importazione del profilo da Connection Manager Administration Kit (CMAK).

Per un esempio di questa funzionalità, vedere Criteri di sistema e impostazioni.

Vantaggi dell'utilizzo dei criteri di sistema e delle restrizioni

Le società possono usufruire dei seguenti vantaggi dall'implementazione dei criteri di sistema e restrizioni:

  • I criteri di sistema e restrizioni consentono l'implementazione della configurazione standard di Internet Explorer. È possibile creare un pacchetto browser personalizzato per gli utenti con le impostazioni comuni per le caratteristiche e le funzioni browser.
  • È possibile limitare la possibilità per gli utenti di accedere a Internet Explorer utilizzando i criteri di sistema e restrizioni. Ad esempio, è possibile preimpostare le opzioni di NetMeeting per controllare l'accesso audio e video. È possibile utilizzare queste opzioni anche per bloccare le caratteristiche e le funzioni in modo che risultino o non risultino attive sul desktop.
  • I criteri di sistema e le restrizioni consentono di modificare i valori di registro predefiniti. È possibile utilizzare le impostazioni in un file di protezione per modificare i valori di registro su più computer, eliminando l'esigenza di specificare le impostazioni singole su ciascun computer.

Prima di impostare i criteri di protezione e le restrizioni

Prima di implementare i criteri di protezione e le restrizioni, è necessario considerare quanto segue:

  • Quali tipi di criteri di sistema e restrizioni si desidera definire e gestire? Per esempio, si desidera limitare l'accesso alle caratteristiche di NetMeeting?
  • Si desidera usare una serie di criteri standard di sistema e restrizioni per tutti gli utenti e computer o si desidera creare più file di protezione per gruppi di utenti? Diversi gruppi di utenti possono avere esigenze specifiche.
  • Che tipo di impostazioni di protezione si desidera implementare? È possibile bloccare tutte le impostazioni, controllare le impostazioni ma renderle disponibili agli utenti con profilo comune per il download o la personalizzazione delle impostazioni consentendo di modificarle.

    È necessario considerare l'impatto di queste impostazioni, specialmente se gli utenti con profilo comune condividono il computer con altri. Per esempio, quali sono le implicazioni di rimuovere le icone dal desktop o non consentire agli utenti di modificare le proprie impostazioni di protezione? Assicurarsi che gli utenti sappiano a quali caratteristiche possono accedere.

  • Si desidera archiviare i file di protezione in una postazione centrale o sui computer degli utenti? È possibile archiviare il file su un server in modo che gli utenti con profilo comune possano accedere alle impostazioni da un computer all'altro. Questa funzionalità è ad esempio utile nel caso di un utente che necessita di una protezione bassa, ma che accede a un computer che viene utilizzato da un utente con impostazioni di protezione molto restrittive.

Gestione dei criteri di protezione e restrizioni per Windows NT and Windows 2000

I criteri di sistema e le restrizioni che è possibile impostare nel programma di personalizzazione di IEAK e gestire successivamente in Gestione profili di IEAK possono essere configurati per gli utenti dei sistemi operativi Windows 95, Windows 98 e Windows Millennium Edition.

Tuttavia, per gli utenti che non dispongono dei privilegi di amministrazione sulle piattaforme Windows NT o Windows 2000 è possibile configurare soltanto un sottoinsieme di questi criteri di sistema e restrizioni. Al contrario, per configurare i criteri e le restrizioni rimanenti si consiglia di utilizzare l'editor dei criteri di Windows NT o i criteri di gruppo di Windows 2000. Per ulteriori informazioni, vedere Amministrazione di Microsoft Internet Explorer in Windows 2000.

Impostazione e gestione dei criteri di protezione e restrizioni

I criteri di protezione e le restrizioni possono essere impostati in due modi:

  • Nella Fase 5 del programma di personalizzazione di Internet Explorer.
  • Nel Gestione profili, utilizzando la configurazione automatica.

Per utilizzare Gestione profili di IEAK, creare un nuovo profilo utente o aprire un profilo già esistente. Espandere quindi le cartelle fino a visualizzare le impostazioni o le restrizioni che si desidera modificare. Ulteriori informazioni sui criteri di protezione e sulle restrizioni sono disponibili facendo clic sulla cartella della categoria desiderata.

Con la configurazione automatica, le impostazioni e le restrizioni del browser vengono mantenute nella posizione specificata nel programma di personalizzazione di Internet Explorer o nella finestra di dialogo Opzioni Internet.

Per verificare le impostazioni della configurazione automatica sui computer degli utenti:

  1. Fare clic sul menu Strumenti nel browser.
  2. Fare clic su Opzioni Internet.
  3. Scegliere la scheda Connessioni, quindi fare clic su Impostazioni LAN.

    Verificare che l’opzione Utilizza script di configurazione automatico sia selezionata e controllare il percorso nella casella Indirizzi

Creazione e gestione dei criteri di protezione per i programmi personalizzati

Quando si utilizza il programma di personalizzazione di Internet Explorer, sarà possibile utilizzare le restrizioni e i criteri di protezione impostati nei file adm,facendo clic su Criteri di protezione, quindi su Importa. I file adm personalizzabili sono disponibili nella lingua adeguata per la cartella dei criteri di protezione di IEAK.


Uso degli elenchi Selezione dei server proxy e Proxy da ignorare

Utilizzando un server proxy è possibile limitare l'accesso a Internet. È possibile specificare il server proxy dal programma di personalizzazione di Internet Explorer, da Gestione profili di IEAK e dal browser. È inoltre possibile limitare la possibilità per gli utenti di modificare le impostazioni per il proxy, usando o la pagina Criteri e restrizioni del programma di personalizzazione di Internet Explorer o Gestione profili.

Per istruzioni dettagliate sulla configurazione delle impostazioni Selezione dei server proxy e Proxy da ignorare tramite IEAK, vedere la schermata Configurazione automatica e Impostazioni per il proxy della Fase 4 del programma di personalizzazione di Internet Explorer.

Nota

  • La funzionalità che consente di ignorare i proxy potrebbe rendere non necessario l'utilizzo di procedure JavaScript o JScript.

Configurare le impostazioni Selezione dei server proxy e Proxy da ignorare in Internet Explorer

  1. Scegliere Opzioni Internet dal menu Strumenti di Internet Explorer.
  2. Scegliere la scheda Connessioni, quindi fare clic su Impostazioni LAN.
  3. Nell'area Server proxy selezionare la casella di controllo Utilizza un server proxy.
  4. Fare clic su Avanzate, quindi immettere l'indirizzo del proxy e il numero di porta per ciascun protocollo Internet supportato.

    Note

    • Nella maggior parte dei casi, viene usato un solo server proxy per tutti i protocolli. In questo caso, immettere l'indirizzo del proxy e il numero di porta per le impostazioni HTTP, quindi selezionare la casella di controllo Usa lo stesso server proxy per tutti i protocolli.
    • Un indirizzo proxy che non inizia con un protocollo, ad esempio "http://" o "ftp://", viene considerato un proxy HTTP di tipo CERN. Ad esempio, la voce "proxy" sarà trattata allo stesso modo della voce "http://proxy". Per i gateway FTP, ad esempio il gateway TIS FTP e il proxy FTP Modem per Windows 95 WinGate, il proxy deve essere elencato con il protocollo "ftp://" prima del nome del proxy. Ad esempio, il gateway FTP "ftpproxy" deve essere specificato come "ftp://ftpproxy".
  5. Per ignorare indirizzi più complessi, digitare l'indirizzo nella casella Non utilizzare il server proxy per gli indirizzi che iniziano per: .

    Una voce dell'elenco Proxy da ignorare può iniziare con il tipo di protocollo, ad esempio http://, https://, ftp:// o gopher://. In tal caso, l'eccezione verrà applicata solo alle richieste relative a quel protocollo. Per il valore del protocollo non viene fatta distinzione tra maiuscole e minuscole. Se si immettono più voci, sarà necessario separarle con il punto e virgola (;).

    In seguito, deve essere immesso un indirizzo Internet, un indirizzo IP, o un nome di dominio. Se non si è specificato alcun protocollo, le richieste che utilizzano tale indirizzo verranno ignorate. Se si è specificato il protocollo, le richieste che utilizzano tale indirizzo verranno ignorate solo se sono del tipo di protocollo indicato. Come per il tipo di protocollo, anche per le voci relative agli indirizzi non viene fatta distinzione tra maiuscole e minuscole.

    È infine, è possibile aggiungere un numero di porta. In questo caso, la richiesta viene elaborata solo se tutti i requisiti precedenti sono stati soddisfatti e se la richiesta usa il numero di porta specificato.

    La casella delle eccezioni consente di utilizzare un carattere jolly ( * ) al posto di nessuno o più caratteri.

Esempi di caratteri jolly

È possibile usare i caratteri jolly come di seguito:

  • Digitare il carattere jolly all'inizio di un indirizzo Internet, di un indirizzo IP o di un nome di dominio per ignorare i server che terminano allo stesso modo. Ad esempio, utilizzare "*.esempio.com" per ignorare tutte le voci che terminano in ".esempio.com", come "un.esempio.com" e "www.esempio.com".
  • Digitare il carattere jolly all'interno di un indirizzo Internet, di un indirizzo IP o di un nome di dominio per ignorare i server che iniziano e che terminano allo stesso modo. Ad esempio, la voce "www.*.com" corrisponde a tutte le voci che iniziano con"www" e che terminano con "com", come "www.esempio.com", "www.prova.com" e così via.
  • Digitare il carattere jolly alla fine di un indirizzo Internet, di un indirizzo IP o di un nome di dominio per ignorare i server che iniziano allo stesso modo. Ad esempio, utilizzare "www.esempio.*" per ignorare tutte le voci che iniziano con "www.esempio.", come "www.esempio.com", "www.esempio.org" e "www.esempio.due.com".
  • Utilizzare più caratteri jolly per ignorare gli indirizzi strutturati in modo simile. Ad esempio, utilizzare "123.1*.66.*" per ignorare indirizzi come "123.144.66.12", "123.133.66.15" e "123.187.66.13.".

Nota

  • Sebbene i caratteri jolly siano utili, è necessario utilizzarli con attenzione. Se ad esempio si digita "www.*.com", Internet Explorer ignorerà il server proxy per la maggior parte dei siti Web.


Amministrazione di Microsoft Internet Explorer in Windows 2000

È possibile utilizzare Criteri di gruppo per personalizzare Microsoft Internet Explorer in computer che usano Windows 2000 dopo la distribuzione. Ad esempio. è possibile impostare la pagina iniziale dell'utente e personalizzare i collegamenti ai preferiti. I Criteri di gruppo permettono agli amministratori che usano Windows2000 di controllare le impostazioni degli utenti e i computer di siti, domini e organizzazioni.

I metodi per utilizzare Criteri di gruppo dipendono dal tipo di gruppo che si desidera amministrare. Per ulteriori informazioni, ricercare la voce "Criteri di gruppo" nella guida in linea di Windows 2000.

Per ulteriori informazioni, vedere:

Come usare Criteri di gruppo per gestire e personalizzare Internet Explorer

  1. In Criteri di gruppo, fare clic su Configurazione utente.
  2. Fare clic su Impostazioni di Windows, quindi su Manutenzione di Internet Explorer.
  3. Fare clic sull'icona della funzione che si desidera modificare.
  4. Fare doppio clic sul titolo della funzione che si desidera amministrare.
  5. Modificare le impostazioni desiderate.

Note

  • Se si usa Gestione profili di IEAK per amministrare Internet Explorer su altre piattaforme con configurazione automatica, si consiglia di esportare le impostazioni di Criteri di gruppo in un file ins e, se possibile, in file cab. In questo modo, le impostazioni configurate in Windows2000 non dovranno essere modificate in caso si utilizzi un'altra piattaforma.
  • Se si utilizza OEM Preinstallation Kit, è possibile usare il programma di personalizzazione di Internet Explorer per personalizzare Windows2000 prima della distribuzione.
  • Se si utilizza l'installazione guidata di Windows2000, è possibile usare Gestione profili di IEAK per generare file necessari alla marcatura del browser. Per ulteriori informazioni, consultare la documentazione di Windows2000.

Impostazioni di Esporta criteri di gruppo di Internet Explorer

È possibile utilizzare Criteri di gruppo in Windows 2000 per esportare tutte le impostazioni di Internet Explorer in un file ins e se necessario in file cab. Queste impostazioni possono essere usate per configurare automaticamente i computer con sistemi operativi diversi..

Per esportare le impostazioni di Internet Explorer in Windows2000

  1. In Criteri di gruppo, fare clic su Configurazione utente.
  2. Fare clic su Impostazioni di Windows, quindi doppio clic sulla schermata di Internet Explorer che contiene le impostazioni che si desidera esportare.
  3. Fare clic su Esporta impostazioni browser.
  4. Digitare il nome del file ins e i nomi dei file cab, se esistenti, dove si desidera esportare le impostazioni.
  5. Digitare l'URL di destinazione dei file sul server Web.

Funzioni configurabili con Criteri di gruppo

Tramite Criteri di gruppo, è possibile personalizzare:

  • L'interfaccia utente e l'aspetto del browser
  • Le Impostazioni di connessione, ad esempio le connessioni tramite Accesso remoto e tramite LAN, e le stringhe agente utente.
  • Gli URL, ad esempio l'URL dei preferiti, della barra di ricerca e della pagina iniziale
  • Le impostazioni di protezione, ad esempio le aree di protezione e le restrizioni sul contenuto
  • I programmi predefiniti per effettuare operazioni come la lettura di e-mail e la visualizzazione di newsgroup.

Importante

  • Indipendentemente dalle opzioni di installazione configurate nel pacchetto, Installazione di Windows Update presenta una sola opzione di installazione agli utenti del sistema operativo Windows 2000. L'opzione di installazione include tutti i componenti Internet di Microsoft, insieme a tutti i componenti personalizzati inclusi nel pacchetto.


Installazione di Internet Explorer con Microsoft Office

Il programma di installazione personalizzata di Microsoft Office (CIW) permette di personalizzare la distribuzione dei programmi Office agli utenti. Per semplificare il processo di installazione, IEAK è progettato per funzionare con il programma per l'installazione guidata personalizzata.

Se si desidera includere Internet Explorer nel pacchetto di Office personalizzato, è possibile scegliere tra due possibilità:

  • Se non si desidera personalizzare Internet Explorer, è possibile installare i componenti di Internet Explorer utilizzando CIW; non è necessario utilizzare IEAK.
  • Se si è deciso di distribuire una versione personalizzata di Internet Explorer come parte del pacchetto Office, fare clic sul pulsante Personalizza nella schermata Opzioni di installazione personalizzata di IE 5 durante il programma di installazione di Office. Il programma avvierà automaticamente IEAK.

Esecuzione di IEAK dal programma di installazione personalizzata di Office

Il programma di personalizzazione di Internet Explorer viene eseguito in modalità amministratore delle reti intranet con le seguenti impostazioni:

  • Il supporto di distribuzione deve contenere tutti i file in un'unica cartella.
  • Le opzioni di installazione disponibili sono due: Non è possibile modificare i nomi di queste opzioni, ma è possibile specificare quali componenti saranno installati con ciascuna opzione di installazione.
  • Tutti i file cab e i componenti personalizzati creati da IEAK vengono collocati nella stessa cartella. Il nome predefinito della cartella è IE5_CUST.

Una volta terminato il pacchetto personalizzato, il nome del file e il percorso del programma Installazione di Windows Update (IE5Setup.exe) sarà visualizzato sulla schermata Opzioni di installazione personalizzata di IE 5.

Per utilizzare IEAK come parte di CIW, è necessario installare le versioni richieste di Internet Explorer e di IEAK nel computer in cui è in corso la personalizzazione del pacchetto di installazione.

Nota

  • In un pacchetto IEAK creato con il programma di installazione personalizzata di Office, durante l'installazione non vengono visualizzate le opzioni per l'utente da Instalazione di Windows Update per Internet Explorer. Il programma di installazione personalizzata di Office determina l'interfaccia utente utilizzata durante l'installazione di Windows Update.


Passaggio da altre versioni o prodotti

Prima che dipendenti o clienti installino Internet Explorer, è opportuno identificare e indirizzare tutti i problemi che potrebbero insorgere.

Aggiornamento da Internet Explorer 5

Il programma di installazione di Internet Explorer esegue l'installazione sulla precedente versione di Internet Explorer 5 dalla quale importa impostazioni proxy, Preferiti e cookie.

Aggiornamento da Internet Explorer 4

Il programma di installazione di Internet Explorer esegue l'installazione sulla precedente versione di Internet Explorer 4 dalla quale importa impostazioni proxy, Preferiti e cookie. È tuttavia necessario installare nuovamente tutti i plug-in che si desidera conservare.

Internet Explorer 4 e Internet Explorer 5.x possono essere in esecuzione contemporaneamente sullo stesso computer.

Se si desidera che gli utenti dispongano dell'Active Desktop effettuando l'aggiornamento da Internet Explorer 4.0, è possibile includere il desktop nei pacchetti del browser di Internet Explorer per Windows 95 e Windows NT 4.0. Active Desktop può essere ad esempio messo a disposizione di tutti gli utenti di Internet Explorer 4.0 e di Internet Explorer 3.

Active Desktop fa parte di Windows 98.

Aggiornamento da Internet Explorer 3

Il programma di installazione di Internet Explorer esegue l'installazione sulla precedente versione di Internet Explorer 3 dalla quale importa impostazioni proxy, Preferiti e cookie. È tuttavia necessario installare nuovamente tutti i plug-in che si desidera conservare.

Passaggio da Netscape Navigator 3 e 4

Durante l'installazione di Internet Explorer, è possibile importare impostazioni proxy, Preferiti e cookie da Netscape. È tuttavia necessario installare nuovamente tutti i plug-in che si desidera conservare. Al termine dell’installazione di Internet Explorer, è possibile scegliere se impostare Internet Explorer come browser predefinito.

Installazione di Internet Explorer con Microsoft Office

Per ulteriori informazioni, vedere Installazione di Internet Explorer con Microsoft Office.


Installazione di Windows Update per Internet Explorer e Accesso a Internet

La procedura guidata per l'Installazione di Windows Update (IE5Setup.exe) semplifica agli amministratori la distribuzione di Internet Explorer, facilita l'installazione del programma e agevola il recupero di installazioni non riuscite.

L'installazione guidata è compatta e di dimensioni ridotte, contiene il numero minimo di codici necessari per garantire al client l'accesso a Internet e fornisce le funzionalità di base per il download dei file.

È possibile usare IEAK per personalizzare l'Installazione di Windows Update in base alle esigenze degli utenti.

Vantaggi dell'installazione guidata di Windows Update

Questo pacchetto permette inoltre all'Installazione di Windows Update di raccogliere le informazioni relative al computer host prima di iniziare il download. La procedura di installazione usa queste informazioni per gestire in maniera coerente il download dei file cab di Internet Explorer e per rendere l'installazione il più possibile efficiente e senza problemi. Scaricando questo piccolo pacchetto di installazione all'inizio della procedura si ottengono molti vantaggi, inclusi quelli descritti di seguito.

  • Velocità. Con un collegamento a 28 kbps, sono necessari circa due minuti per il download di IE5Setup.exe.
  • Nel caso in cui lo spazio su disco non sia sufficiente, gli utenti ricevono consigli e suggerimenti già all'inizio della procedura di installazione, invece che aspettare fino al completamento di una lunga fase di download che potrebbe non andare a buon fine.
  • Qualsiasi informazione utile viene raccolta all'inizio del processo, in modo che nel corso del download e dell'installazione dei file non sia necessario alcun intervento da parte dell'utente.
  • Se il collegamento ad un server di distribuzione non è affidabile ed è necessaria la riconnessione, il download viene ripreso dal punto in cui era stato precedentemente interrotto. In tal modo si prosegue con il completamento dell'installazione ogni volta che questa viene riavviata, e non è necessario ricominciare sempre dall'inizio.
  • Qualora non sia possibile ristabilire un collegamento ad un server di distribuzione, la procedura di installazione cerca automaticamente altri server di distribuzione.
  • Gli utenti ricevono informazioni utili sul progresso del download, relative non solo alla velocità espressa in byte al secondo, ma anche ai minuti necessari al completamento dell'installazione.
  • Quando la versione corrente di un componente è già installata, i file non vengono installati di nuovo.
  • È possibile creare ed eseguire un pacchetto di download personalizzato senza che sia necessario riscrivere l'installazione.
  • È possibile rimuovere dal disco rigido i file temporanei non necessari per liberare spazio per l'installazione.

Per un'illustrazione, vedere Installazione guidata di Windows Update per Internet Explorer e Accesso a Internet.

Installazione di altri componenti con Internet Explorer

Oltre al browser Internet Explorer, è possibile includere molti altri componenti Internet di Microsoft e di altre società nella versione personalizzata dell'Installazione di Windows Update. Il programma di personalizzazione di Internet Explorer consente di visualizzare in modo semplice il software più recente disponibile per il download. Quando gli utenti installano il browser, il pacchetto personalizzato facilita l'installazione dei componenti nonché degli altri programmi personalizzati selezionati.

I componenti Microsoft variano dagli strumenti per la creazione di siti Web ai supporti multilingue. La gamma di componenti disponibili viene continuamente aggiornata e l'elenco più recente viene visualizzato nel programma di personalizzazione di Internet Explorer, a condizione di disporre di una connessione Internet.

Per informazioni sugli ultimi aggiornamenti dei prodotti, visitare il sito Web Corporate Windows Update.

Funzionamento dell'Installazione di Windows Update

Dopo che IE5Setup.exe ha raccolto dall'utente e dal computer tutte le informazioni necessarie, scarica i file .cab necessari da uno dei server ufficiali di distribuzione Microsoft su Internet. Dal momento che la procedura di installazione contiene l'elenco di tutti i componenti di Internet Explorer esistenti sul computer e ha già richiesto all'utente quali sono quelli desiderati, non scarica nessun file cab non necessario.

Nella fase successiva dell'installazione guidata verrà utilizzato il programma di installazione ACME, comune alla maggior parte dei prodotti Microsoft. A questo punto, l'unica differenza tra l'installazione di Internet Explorer e un programma di installazione tradizionale consiste nel fatto che i file cab vengono memorizzati in una cartella del disco rigido locale anziché in un disco floppy o in un'unità di rete.

Gli amministratori di reti intranet possono creare un pacchetto di installazione personalizzato, conosciuto anche come pacchetto IExpress, senza che sia necessario riscrivere l'Installazione di Windows Update. A tal fine, creare una versione personalizzata di IE5Setup.exe usando la tecnologiaIExpress.

È possibile aggiungere ulteriori parametri alla riga di comando per adattare alle proprie esigenze il processo di installazione. Per ulteriori informazioni, vedere Parametri di installazione della modalità batch di Internet Explorer.

Personalizzazione dell'Installazione di Windows Update

È possibile personalizzare l'Installazione di Windows Update in diversi modi, ad esempio aggiungendo componenti di Internet Explorer o creando fino a 10 impostazioni di installazione differenti. In questo modo si ampliano le opzioni Minima, Tipica e Completa che sono quelle predefinite di Internet Explorer. L'aggiunta di più opzioni di installazione si rivela utile quando gli impiegati di un'azienda hanno necessità d'uso e limitazioni di spazio su disco diverse.

Importante

  • Indipendentemente dalle opzioni di installazione configurate nel pacchetto, l'Installazione di Windows Update dispone di una sola opzione di installazione per gli utenti del sistema operativo Windows 2000. L'opzione di installazione include tutti i componenti Internet di Microsoft, insieme a tutti i componenti personalizzati inclusi nel pacchetto.

Per rendere le operazioni più semplici, è possibile effettuare determinate scelte già nel programma di installazione invece che lasciarle agli utenti. È possibile configurare Internet Explorer in modo che sia possibile effettuare l'installazione senza o con il minimo intervento da parte degli utenti. Questo tipo di installazione viene anche definito "installazione invisibile".

Le installazioni che richiedono interventi minimi sono in genere utilizzate per installare Internet Explorer quando le postazioni non sono occupate dagli impiegati. Questi tipi di installazione possono essere ulteriormente adattati usando i parametri della riga di comando o i file batch. Dal momento che vengono effettuate delle scelte per conto dell'utente, è possibile creare solo un'opzione per l'installazione invisibile.

Se si eliminano completamente i messaggi all'utente, inclusi quelli di errore e le informazioni di stato, è necessario fare in modo che la procedura di installazione sia in grado di gestire gli errori. Se viene eliminato il messaggio che avvisa di riavviare il computer dopo l'installazione, è necessario fare in modo che il riavvio avvenga automaticamente per garantire la corretta impostazione di Internet Explorer. Per ulteriori informazioni su queste opzioni, vedere Installazione invisibile.

Può essere conveniente installare i propri componenti personalizzati, ad esempio dei programmi antivirus o degli script, quando si installa Internet Explorer. È possibile includere fino a 10 componenti personalizzati nel pacchetto personalizzato.

È inoltre possibile modificare l'aspetto del programma di installazione aggiungendo una bitmap e includendo una descrizione personalizzata delle differenti opzioni di installazione.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione. Per visualizzare un diagramma di flusso delle operazioni che avvengono quando si usa il programma di personalizzazione guidata di Internet Explorer, vedere Creazione con IEAK dei pacchetti personalizzati.

File di registro nei quali vengono memorizzati i problemi di installazione

Le funzioni di registro avanzate semplificano la risoluzione dei problemi di installazione all'utente, all'amministratore e a Microsoft. Nel corso dell'installazione guidata vengono creati i due file di registro descritti di seguito, che segnalano gli eventuali problemi. I file di registro vengono salvati nella cartella Windows o WinNT.

  • Active Setup Log.txt. Registra tutte le operazioni che hanno luogo durante l'installazione guidata del programma o dei componenti. Fare riferimento a questo file di registro se i componenti di Internet Explorer non sono stati installati correttamente. Per ulteriori informazioni, vedere Informazioni sugli errori nel file di registro Active Setup Log.txt.
  • RunOnceEx Log.txt. Registra tutte le operazioni che hanno luogo durante la registrazione della Dynamic Link Library. Fare riferimento a questo file di registro quando si riceve un messaggio indicante che uno specifico file dll non è stato registrato correttamente o se viene visualizzata una finestra di dialogo inaspettata durante la fase finale del processo di installazione.


Rendere disponibili agli utenti i componenti aggiuntivi

Dopo avere creato un pacchetto browser personalizzato, sarà necessario renderlo disponibile su Internet per consentire ad altri utenti di scaricarlo. È possibile indicare i siti di destinazione durante la Fase 3 del programma di personalizzazione di Internet Explorer. È inoltre possibile specificare la posizione dalla quale gli utenti possono prelevare i nuovi componenti o gli aggiornamenti degli stessi. Questi sono denominati componenti aggiuntivi.

Quando l'utente fa clic su Strumenti e quindi su Windows Update, il browser apre l'URL specificato per i componenti aggiuntivi. Lo stesso accade quando l'utente fa clic su Installazione applicazioni nel Pannello di controllo, quindi fa clic su Internet Explorer e Accesso a Internet, poi su Aggiungi/Rimuovi e quindi seleziona Aggiungi un componente.

Nota

  • Nell'indirizzo relativo ai componenti aggiuntivi si consiglia di specificare il percorso completo per Addon.htm (ad esempio, http://risorsedelserver/componenti aggiuntivi/addon.htm).

Esempi di pagine Web per l'aggiunta di componenti

IEAK contiene un esempio di pagina Web personalizzabile, Addon.htm, relativa ai componenti aggiuntivi. Tale pagina si trova nella cartella \<IEAK>\Toolkit\Addons\HTML e contiene inoltre collegamenti ai file Head.htm, Main.htm e Info.htm.

Di seguito è riportata una descrizione dei quattro file di esempio contenuti nella cartella \<IEAK>\Toolkit\Addons\HTML:

  • Addon.htm: Set di frame che contiene riferimenti per i due file seguenti.
    • Head.htm: frame di intestazione per il titolo
    • Main.htm: frame principale con lo script di installazione e il collegamento a Info.htm
  • Info.htm: informazioni su tutti i componenti disponibili

La maggior parte delle modifiche verranno effettuate al file Main.htm, composto da tre parti.

  • Script di installazione
  • Tabella delle caselle di controllo, nomi dei componenti e dimensioni
  • Impostazione del controllo ActiveX

Utilizzo dei file di esempio

Copiare i quattro file di esempio nel percorso di download o in un altro percorso, quindi utilizzare un editor di testo o un editor HTML per modificarne il contenuto.

Per garantire un corretto funzionamento della procedura, è necessario installare i file nel modo seguente:

  • Il file IEcif.cab deve trovarsi in un server Web.
  • Nella sezione <SCRIPT> del file Main.htm, è necessario che la voce L_cab_Address= indichi la posizione del file IEcif.cab.
  • La tabella deve contenere solo i componenti scaricati da Microsoft che si desidera fornire con il pacchetto del browser.

Per aggiungere nuovi componenti

  1. Accertarsi di aver scaricato i componenti durante la Sincronizzazione automatica versione (AVS).
  2. Individuare il nome corretto del componente in IESetup.cif.
  3. Aggiungere alla pagina Addon.htm una casella di controllo che abbia lo stesso nome.

Se si dispone di una conoscenza adeguata della creazione di pagine Web, non sarà necessario utilizzare il modello fornito con IEAK.

Informazioni per autori esperti di pagine Web

In Main.htm vengono utilizzati due linguaggi per la creazione di procedure: JScript e Visual Basic Script Edition (VBScript). Il codice JScript contiene la funzione Install(). Tale funzione viene chiamata facendo clic sul pulsante Installa, situato nella parte inferiore della pagina e controlla il processo di installazione. La funzione Install() effettua chiamate a diverse subroutine VBScript.

All'interno delle procedure la proprietà name (appartenente al tag input) delle caselle di controllo viene utilizzata per leggere il contenuto di IEsetup.cif. Tale file è contenuto nel file IEcif.cab e viene aperto dalla subroutine Window_onLoad().

Nota

  • I componenti per Windows non NT e quelli per Windows NT possono avere nomi diversi. Nel file IESetup.cif sono disponibili le informazioni necessarie.

Per sapere se un componente è già installato, è possibile usare la subroutine VBScript IsComponentInstalled().

IsComponentInstalled(ComponentID)

ComponentID corrisponde al nome della casella di controllo e al valore indicato nel file IESetup.cif.

Codice di ritorno | Significato
0 | Componente non installato
1 | Componente già installato
2 | Componente installato, ma è disponibile una versione aggiornata
3 | Protezione utente: stato indeterminato

Quando viene controllato il primo componente utilizzando questo metodo, il motore ActiveX attiva una finestra di dialogo di protezione che richiede il permesso per controllare lo stato dei componenti installati sul computer dell'utente. Se l'utente seleziona "No", il codice di ritorno per tutti i componenti è 3.


Distribuzione degli aggiornamenti Microsoft in componenti personalizzati

È possibile installare una versione di un componente Microsoft diversa da quella disponibile utilizzando Sincronizzazione automatica versione (AVS). Ad esempio, nel caso in cui si desidera rendere disponibile una patch QFE in Windows Update che non è disponibile tramite AVS, oppure se l'azienda utilizza come standard una versione differente di un componente Microsoft incluso in Internet Explorer, ad esempio NetMeeting e si intende far utilizzare agli utenti quella particolare versione piuttosto che la procedura di installazione di IEAK presente nel pacchetto.

In questi casi, è possibile distribuire questi file inserendoli in un componente personalizzato che verrà inserito nel pacchetto personalizzato.

Per evitare che gli utenti debbano riavviare troppe volte il sistema, è possibile scegliere quando installare questo componente in base agli altri passaggi nel processo di installazione. È possibile installare il componente prima o dopo l'installazione di Internet Explorer oppure dopo il necessario riavvio del sistema.

Per ulteriori informazioni, vedere Siti di download e Sincronizzazione automatica versione (AVS) e Aggiunta di componenti personalizzati: condizioni di installazione.


Disinstallazione dei componenti personalizzati

La registrazione del programma di disinstallazione per il componente personalizzato durante l'installazione del componente, abilita l'utente alla rimozione del programma facendo doppio clic sull'icona Installazione applicazioni nel Pannello di controllo. Per un esempio di file di disinstallazione, vedere il file Uncheck.inf nella cartella \<IEAK>\Toolkit\Inf del Toolkit IEAK.

Per registrare il programma di disinstallazione in modo che venga visualizzato in Installazione applicazioni nel Pannello di controllo, durante il processo di installazione del componente, l'applicazione deve aggiungere le voci elencate di seguito nella seguente chiave del registro di configurazione.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\NomeApplicazione

Tale chiave del registro di configurazione viene inoltre usata da Installazione di Windows Update per verificare che il componente sia stato correttamente installato.

Sottochiave | Tipo di dati | Valore
DisplayName | Stringa | Nome dell'applicazione.
UninstallString | Stringa | Riga di comando completa, percorso incluso per la disinstallazione dell'applicazione. Non usare un file batch o un sottoprocesso.

Il valore di NomeApplicazione deve corrispondere al valore del Codice disinstallazione nella schermata Componenti personalizzati aggiuntivi nel programma di personalizzazione di Internet Explorer.

Per ulteriori informazioni, vedere Inserimento della funzionalità di disinstallazione in una procedura inf.


Utilizzo dei file di informazioni per l’installazione (inf)

Un file di informazioni (inf) è un file di testo in cui sono specificati i file che devono essere presenti o scaricati affinché il componente possa essere eseguito sulle versioni di Windows a 32 bit. Il servizio di download di componenti tramite Internet utilizza queste istruzioni per installare e registrare i componenti software scaricati da Internet e tutti i file richiesti dai componenti. Il servizio di download di componenti tramite Internet fa parte di Internet Explorer a partire dalla versione 3.0.

Un'unità di distribuzione del software di Internet è un "pacchetto" composto da un file cab che contiene un file inf. Un’unità di distribuzione può contenere anche un componente software, ad esempio un controllo ActiveX (ocx), un file dll, un file exe, un file di classi Java o un’applicazione. Quando a un file cab contenente un file inf fa riferimento l’attributo CODEBASE di un elemento OBJECT di una pagina Web, Internet Explorer 3.0 e versioni successive lo considerano come un’unità di distribuzione del software.

Con i file inf è possibile creare istruzioni personalizzate di installazione del software da includere nelle voci del registro di configurazione e nelle cartelle di destinazione. I file inf sono in grado di garantire un’indipendenza di piattaforma limitata e di specificare delle dipendenze software limitate.

I seguenti argomenti forniscono ulteriori informazioni sull’utilizzo dei file inf:

  • Definizione di file di informazioni per l’installazione (inf)
  • Gestione di cartelle e file utilizzando file di informazioni per l’installazione (inf)
  • Estensioni del programma di installazione di Windows
  • Inserimento della funzionalità di disinstallazione in uno script inf
  • Personalizzazione avanzata del client di Messenger
  • Uso della tecnologia RunOnce
  • File inf di esempio per il servizio download dei componenti

Nota

  • Per ulteriori informazioni sul servizio di download dei componenti Internet, consultare il sito MSDN Online Web Workshop.


Estensioni del programma di installazione di Windows

È possibile estendere il programma di installazione di Windows in tre modi.

  • Eseguendo i file inf di Windows dalla riga di comando usando Rundll.exe.
  • Installando i componenti software opzionali di Windows dal codice del programma a 32 bit in alternativa all'installazione del software dalla finestra di dialogo Installazione applicazioni del Pannello di controllo.
  • Creando un'icona sul desktop di Windows sulla quale l'utente possa fare clic per eseguire un file inf, eliminando la necessità di sviluppare il codice del programma di installazione.

Esecuzione dei file inf da riga di comando

Per eseguire la sezione Install contenuta nei file inf è possibile utilizzare i comandi di sistema di Windows Rundll.exe o Rundll32.exe. La sintassi della riga di comando è la seguente.

RunDll setupx.dll,InstallHinfSection <sezione> <modalità-riavvio> <nome-inf>

Il parametro <sezione> corrisponde a una sezione Install presente nel file inf. La riga di comando che segue consente ad esempio di installare il componente opzionale Giochi e, se il programma di installazione rileva che è necessario riavviare il computer, all'utente viene richiesto se riavviare il immediatamente computer al termine dell'installazione. Il significato dei valori del parametro <modalità-riavvio> è descritto più avanti in "Uso del parametro modalità-riavvio".

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Note

  • L'uso di tale comando presuppone che sia disponibile lo spazio richiesto per l'installazione dei file. Non viene quindi effettuato alcun controllo dello spazio su disco.
  • L'applicazione di installazione non deve più avere codice da eseguire dopo che la chiamata a RUNDLL o RUNDLL32 è stata effettuata, perché Setupx.dll che ha il controllo potrebbe causare il riavvio del computer. Se il processo di installazione richiede l'esecuzione di altro codice dopo l'esecuzione della chiamata a RUNDLL o RUNDLL32, utilizzare l'elenco RunOnce nel file inf.
  • Non usare l'elenco RunOnce per eseguire i componenti opzionali che si stanno installando.

Uso del parametro modalità-riavvio

Le modalità di riavvio sono cinque.

define HOW_NEVER_REBOOT 0
define HOW_ALWAYS_SILENT_REBOOT 1
define HOW_ALWAYS_PROMPT_REBOOT 2
define HOW_SILENT_REBOOT 3
define HOW_PROMPT_REBOOT 4

Se <nome-inf> specifica un file inf utente invece di uno di Windows, aggiungere 128 ai valori precedenti. Nell'esempio precedente in cui viene installato il componente opzionale Giochi, <modalità-riavvio> è impostato a 4. Ciò avviene perché Applets.inf è un file inf di Windows. Se si installa un componente opzionale che possiede un proprio file inf, il parametro <modalità-riavvio> deve essere impostato a 132. Aggiungendo 128 al parametro <modalità-riavvio>, tutti i file che si stanno installando si devono trovare nella stessa cartella del file inf dell'utente sul disco di installazione.

Nota

  • Gli unici valori consigliati per il parametro <modalità-riavvio> sono 4, se il file inf è un file di Windows 95 oppure 132, se il file inf è fornito dall'utente. Se si utilizza qualsiasi altro valore tra quelli sopra indicati, è possibile che il computer venga riavviato inutilmente oppure che non venga riavviato quando necessario.

Il seguente elenco descrive ciascuna delle modalità di riavvio.

NeverReboot
Impostare <modalità-riavvio> a 0 o 128. In qualsiasi situazione il computer non verrà riavviato. Sarà il sistema operativo che dovrà determinare se il computer deve essere riavviato. Per il programma di installazione ciò significa che vi è un file C:\Windows\Wininit.ini le cui dimensioni sono diverse da zero.

AlwaysSilentReboot
Impostare <modalità-riavvio> a 1 o 129. All'utente non verrà richiesto di riavviare il computer e il computer verrà sempre riavviato.

AlwaysPromptReboot
Impostare <modalità-riavvio> a 2 o 130. All'utente verrà sempre richiesto se desidera o meno riavviare il computer. Il programma di installazione non deciderà se è necessario riavviare il computer.

SilentReboot
Impostare <modalità-riavvio> a 3 o 131. Se il programma di installazione rileva che il computer deve essere riavviato, non vi sarà alcuna interazione con l'utente.

PromptReboot
Impostare <modalità-riavvio> a 4 o 132. Se il programma di installazione rileva che il computer deve essere riavviato, visualizza all'utente un'apposita finestra di dialogo.

Torna all'inizio del file

Installazione di componenti opzionali dal codice di un'applicazione a 32 bit

Dopo l'installazione di Windows su un computer, può essere necessario aggiungere uno o più dei componenti opzionali di Windows, ad esempio Giochi. Questo tipo di installazione, che ha luogo dopo l'installazione iniziale di Windows, è denominata installazione in modalità di manutenzione. L'installazione in modalità di manutenzione viene in genere iniziata da Windows facendo clic sull'icona Installazione applicazioni del Pannello di controllo. Per i fornitori di componenti software opzionali è tuttavia disponibile un'alternativa. I componenti opzionali possono essere installati utilizzando una chiamata CreateProcess in una applicazione a 32 bit.

Nota

  • La modalità CreateProcess per l'installazione dei componenti opzionali descritta di seguito deve essere utilizzata soltanto nelle applicazioni a 32 bit.

Per installare un componente opzionale da un'applicazione a 32 bit, usare una combinazione delle modalità descritte di seguito.

Controllo del registro di configurazione

Controllare innanzitutto il registro di configurazione per individuare se il componente opzionale è già installato, oppure cercare i relativi file. Il percorso delle informazioni della chiave del registro di configurazione relativamente a tutti i componenti opzionali correntemente installati è quello che segue.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents]

È possibile che sotto tale chiave vi siano dei valori che puntano a delle sottochiavi e che ciascuna di esse contenga delle informazioni sui componenti opzionali installati, nonché informazioni necessarie per l'installazione di un nuovo componente opzionale. Si supponga ad esempio di voler installare Giochi come componente opzionale. Per controllare se è già installato, cercare il seguente valore di sottochiave sotto la chiave OptionalComponents.

"Games"="Games"

Aprire quindi la chiave "Games" sotto la chiave dei componenti opzionali per visualizzare quanto segue.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SETUP\OptionalComponents\Games]
"INF"="applets.inf"
"Section"="games"
"Installed"="0"

Questo mostra che il componente opzionale Giochi non è installato in questo computer, perché il flag "Installed" è impostato a 0.

Codifica di una chiamata alla funzione CreateProcess

Per installare un componente opzionale come Giochi, utilizzare i valori "INF" e "Section" della chiave precedente in una chiamata CreateProcess che esegue Setupx.dll mediante RUNDLL. L'operazione è la stessa eseguita utilizzando l'icona Installazione applicazioni del Pannello di controllo quando si installa un componente. La sintassi del parametro lpCommandLine della chiamata CreateProcess è la seguente.

RunDll setupx.dll,InstallHinfSection <sezione> <modalità-riavvio> <nome-inf>

I valori dei parametri <sezione> e <nome-inf> sono quelli rilevati nella chiave di registro di configurazione descritta sopra. La chiamata CreateProcess installa ad esempio il componente opzionale Giochi e, se il programma di installazione di Windows rileva che è necessario riavviare il computer, chiede all'utente se desidera riavviare immediatamente il computer al termine dell'installazione. Il significato dei valori del parametro <modalità-riavvio> è descritto nella sezione "Uso del parametro modalità-riavvio".

RunDll setupx.dll,InstallHinfSection games 4 applets.inf

Nota

  • Prima di installare un componente, è opportuno controllare lo spazio disponibile su disco. Durante il controllo, considerare che è necessario spazio sufficiente per i file di scambio del sistema.

L'applicazione di installazione non deve più avere codice da eseguire dopo che la chiamata a CreateProcess è stata effettuata, perché una volta che Setupx.dll ha il controllo, il codice aggiuntivo potrebbe causare il riavvio del computer. Se il processo di installazione richiede l'esecuzione di altro codice dopo l'esecuzione della chiamata a CreateProcess, utilizzare l'elenco RunOnce nel file INF.

Nota

  • Non utilizzare l'elenco RunOnce per eseguire i componenti opzionali che si stanno installando.

Esecuzione di un file inf con il pulsante destro del mouse

Il programma di installazione riconosce un nome particolare della sezione di installazione, denominata DefaultInstall, nei file inf che installano i componenti opzionali. Se si utilizza una sezione [DefaultInstall] nel file inf, l'utente può fare clic con il pulsante destro del mouse sull'icona di un file inf nell'interfaccia utente delle versioni a 32 bit di Windows per eseguire la sezione [DefaultInstall]. Dopo che l'utente ha fatto clic con il pulsante destro del mouse sull'icona di un file inf, viene visualizzato un menu di scelta rapida in cui l'utente, per eseguire la sezione [DefaultInstall], deve selezionare l'opzione Installa.

L'uso di una sezione di installazione denominata [DefaultInstall] nel file inf si rivela utile per l'installazione dei componenti opzionali. Tale metodo si rivela particolarmente utile durante lo sviluppo dell'applicazione. Se si desidera scrivere un'applicazione di installazione, si ha a disposizione un metodo per installare i componenti opzionali prima di sviluppare il codice dell'applicazione di installazione.

Di seguito è riportato un esempio della sezione DefaultInstall contenente delle voci tipiche.

[DefaultInstall]
CopyFiles=QCD.copy.prog, QCD.copy.hlp, QCD.copy.win, QCD.copy.sys, QCD.copy.inf
UpdateInis=QCD.Links
AddReg=QCD.reg, QCD.run
Uninstall=FlexiCD_remove


Gestione di cartelle e file utilizzando file di informazioni per l'installazione (inf)

I file inf possono essere utilizzati per gestire i file e le cartelle in diversi modi. Di seguito sono elencati i modi principali:

  • Creazione di cartelle e collegamenti nelle cartelle
  • Creazione ed eliminazione di nomi di file lunghi
  • Impostazione degli attributi per i file e le cartelle
  • Copia di file nella cartella Programmi

Creazione di cartelle e collegamenti nelle cartelle

La creazione di una cartella nella cartella Programmi o la creazione di collegamenti in una cartella viene eseguita dalla shell dopo l'installazione di un componente. Il programma di installazione cerca nel file Setup.ini una sezione [progman.groups], quindi la analizza per creare delle cartelle e i relativi collegamenti.

Se si installa un componente che richiederà una cartella o dei collegamenti nella cartella Programmi, creare una sezione UpdateInis che creerà le voci appropriate nel file Setup.ini. Il file Setup.ini utilizza la seguente sintassi per creare le cartelle e i collegamenti. Le cartelle sono relative al menu di Avvio.

[progman.groups]
folder_1=Nome-Cartella-1
folder_2=Nome-Cartella-2
:
folder_n=Nome-Cartella-n

[[folder_1]
nome-collegamento, nome-.exe, Nome-file-icona, Indice-icona, profilo

Se il campo profilo viene lasciato NULL, il collegamento verrà sempre aggiunto alla cartella.

Note

  • Se nome-exe è un elemento NULL, verrà eliminato dal gruppo, qualora presente.
  • Se una cartella o un collegamento ha uno spazio nella propria descrizione, utilizzare le doppie virgolette per metterlo in evidenza nel file Setup.ini. Vedere i seguenti esempi:

Esempio: Giochi

[Optional Components]
giochi

[giochi]
OptionDesc= %GAMES_DESC%
CopyFiles= file.giochiwin
UpdateInis= collegamenti.giochiwin
[file.giochiwin]
cards.dll
freecell.exe
freecell.hlp
mshearts.exe
mshearts.hlp
sol.exe
sol.hlp
winmine.exe
winmine.hlp

[wingames.links]
setup.ini, progman.groups,, "gamesfolder=%GAMES_DESC%" ;crea cartella
setup.ini, gamesfolder,, """Solitario"",SOL.EXE,,," ;crea collegamento
setup.ini, gamesfolder,, "Campo minato,WINMINE.EXE,,," ;crea collegamento
setup.ini, gamesfolder,, ""Hearts"",MSHEARTS.EXE,,,";crea collegamento
setup.ini, gamesfolder,, "FreeCell,FREECELL.EXE,,," ;crea collegamento

Risultato: La voce relativa a "Giochi" verrà visualizzata nella finestra di dialogo dei componenti opzionali nel programma di installazione e, se è selezionata, verrà creata una cartella Giochi nella cartella Programmi con i collegamenti a Solitario, Campo minato, Hearts e FreeCell.

Creazione ed eliminazione di nomi di file lunghi

La sezione principale del registro per le operazioni di ridenominazione è la seguente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RenameFiles

La sezione principale del registro per le operazioni di eliminazione è la seguente:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DeleteFiles

Ciascun gruppo di operazioni di ridenominazione e di eliminazione viene aggiunto a una sottochiave sotto ciascuna sezione. Ogni gruppo di operazioni è limitato alla ridenominazione o all'eliminazione dei file in un'unica cartella. Per rendere effettiva l'operazione di ridenominazione o eliminazione, è necessario includere in ciascuna sottochiave un minimo di due voci: il percorso della cartella dei file da rinominare o eliminare e l'operazione di ridenominazione o eliminazione.

La prima chiave di ciascun gruppo di operazioni è la voce della cartella. Ciascuna voce di un'operazione di ridenominazione nella relativa cartella è una voce con il seguente formato "nome-breve-vecchio"="nome-lungo-nuovo,[flag-attrib]".

Il flag opzionale flag-attrib viene utilizzato per impostare gli attributi del file durante l'operazione di ridenominazione. Il flag è composto dai seguenti valori.

1 | READONLY
2 | HIDDEN
3 | SYSTEM

Per impostare più attributi in un file o in una cartella, i flag vengono aggiunti insieme; ad esempio, per impostare gli attributi READONLY e HIDDEN, il flag flaf-attrib deve essere 3.

Il seguente esempio consiste in una sezione AddReg che imposta gli attributi SYSTEM e HIDDEN per la cartella \Windows\System\Sample:

HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,,,%11% HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sys,SAMPLE,,"SAMPLE,6"

Nota

  • Affinché il nome del file rimanga breve, si devono utilizzare tutte lettere maiuscole.

Ciascuna voce per un'operazione di eliminazione nella relativa cartella corrisponde a una voce nel formato "nome-chiave-arbitrario"="nome-lungo-da-eliminare".

Il seguente esempio corrisponde a una sezione AddReg che:

  • Rinomina il file Vecchionome.txt in Nuovo Nome Lungo.txt nella cartella C:\Samples.
  • Rinomina il file Mioleggimi.txt in Leggimi Mia Applicazione.txt nella cartella Windows.

[MiaAppDaBreveALungo]
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Samples,vecchionome.txt,,"Nuovo Nome Lungo.txt"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Win,mioleggimi.txt,,"Leggimi Mia Applicazione.txt"

Il seguente esempio corrisponde a una sezione AddReg che:

  • Elimina il file Nuovo Nome Lungo.txt dalla cartella C:\Samples.
  • Elimina il file Leggimi MiaApplicazione.txt dalla cartella Windows.

[MiaAppEliminaLungo]
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,,,C:\Samples
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Samples,vecchionome.txt,,"Nuovo Nome Lungo.txt"

HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,,,%25%
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Win,mioleggimi.txt,,"Leggimi Mia Applicazione.txt"

Una volta elaborate tali ridenominazioni ed eliminazioni, le voci vengono rimosse dal registro.

Nota

  • Durante l'operazione di ridenominazione, il file di destinazione viene eliminato prima che venga rinominato un file. Se la stessa operazione di ridenominazione viene accodata due volte, è possibile che si perda il file. Si supponga ad esempio di voler rinominare una bitmap da Immagine.bmp a "Immagine 3D Veramente°Speciale.bmp." La seconda volta che si esegue l'operazione di ridenominazione, il file "Immagine 3D Veramente°Speciale.bmp" esiste già, quindi viene eliminato prima che venga eseguita l'operazione di ridenominazione. L'eccezione a tale regola si verifica quando il nome del file di destinazione esistente corrisponde a una cartella.

Impostazione degli attributi per i file e le cartelle

Per impostare gli attributi di un file o di una cartella, utilizzare la stessa convenzione utilizzata per creare i nomi file lunghi servendosi di un flag opzionale.

Per ulteriori informazioni, vedere la sezione "Creazione ed eliminazione di nomi di file lunghi".

Copia di file nella cartella Programmi

Nel seguente esempio vengono copiati tre file nella cartella Programmi\Accessori e creati i collegamenti a uno dei file:

[WordPadInstall]
CopyFiles = WordPadCopyFiles
UpdateInis = WordPadInis

[DestinationDirs]
WordPadCopyFiles = 24,%PROGRAMM%\%ACCESSOR%

[WordPadCopyFiles]
mswd6_32.wpc
wordpad.exe
write32.wpc
[WordPadInis]
setup.ini, progman.groups,, "group4=%APPS_DESC%" ;crea cartella Accessori (se non esistente)
setup.ini, group4,, """%WORDPAD_LINK%"", ""%24%\%PROGRAMM%\%ACCESSOR%\WORDPAD.EXE""" ;crea collegamento nella cartella Accessori

[Strings]
APPS_DESC = "Accessori"
WORDPAD_LINK = "WordPad"
; Nome cartella - Le versioni brevi devono corrispondere ai
; nomi di 8 caratteri troncati per le versioni lunghe, altrimenti si verificano dei problemi.
PROGRAMM = "Progra~1" ; Primi 6 caratteri di Programmi, + "~1" ACCESSOR = "Access~1" ; Primi 6 caratteri di Accessori, + "~1"

Limitazioni dei file inf

  • Le cartelle non possono essere eliminate.
  • I file non possono essere spostati in un percorso diverso quando si utilizza RenFiles. (Il comando RenFiles rinomina soltanto un file nel proprio percorso.)
  • Non è possibile fare copie di un file. (Il comando CopyFiles copia soltanto i file dal disco di origine nella cartella di destinazione.)


Inserimento della funzionalità di disinstallazione in una procedura inf

Nei file inf è possibile inserire una funzionalità di disinstallazione aggiungendo una sezione Install che elimina i file, le voci di registro e i collegamenti, quindi aggiunge il componente all’elenco dei programmi che è possibile disinstallare utilizzando la finestra di dialogo Installazione applicazioni del Pannello di controllo. In IEAK Toolkit è disponibile un esempio nella cartella \<IEAK>\Toolkit\inf\.

Per aggiungere un componente nella finestra di dialogo Installazione applicazioni, aggiungere una nuova chiave e nuovi valori alla seguente chiave di registro:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nome-app,"DisplayName",,"descrizione"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\nome-app,"UninstallString",,"riga-comando"

descrizione
Questa stringa viene visualizzata nella casella di riepilogo della finestra di dialogo Installazione applicazioni.

riga-comando
Questa è la riga di comando che sarà eseguita quando il componente viene selezionato dalla casella di riepilogo della finestra di dialogo Installazione applicazioni. Per eseguire una sezione in un file inf, è possibile utilizzare il punto di ingresso InstallHinfSection di Setupx.dll, descritto di seguito.

Le seguenti voci di esempio AddReg aggiungono "Mia Applicazione Test" alla casella di riepilogo della finestra di dialogo Installazione applicazioni ed eseguono la sezione Install di Remove_TestApp in Test.inf:

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"DisplayName",,"Mia Applicazione Test"

HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Test,"UninstallString",,"RunDll setupx.dll,InstallHinfSection Remove_TestApp 4 test.inf"

Note

  • Durante la procedura di installazione il file inf deve essere copiato nella cartella Windows\Inf quando il componente viene installato. Tale percorso è quello predefinito e viene ricercato quando viene richiamato il punto di ingresso InstallHinfSection di Setupx.dll.
  • Durante la procedura di disinstallazione è necessario rimuovere la chiave creata nella chiave del registro di disinstallazione in modo che i programmi non siano più presenti nella casella di riepilogo Installazione applicazioni una volta disinstallati.


File inf di esempio per il servizio download dei componenti

, Il seguente file inf di esempio esegue le operazioni:
; - Copia dei file nelle cartelle Windows, System, Inf e Help.
; - Creazione di una serie di voci di registro (incluse voci che
; rinomineranno i file copiati in nomi di file lunghi).
; - Creazione di un collegamento nel menu.
; - Sezione di disinstallazione che registra l’operazione di disinstallazione
; nella finestra di dialogo Installazione applicazioni del Pannello di controllo.
; - Utilizzo delle stringhe sostituibili per semplificare la localizzazione.

[Version]
Signature=$CHICAGO$

[DestinationDirs]
SampleCopy = 24,%PROGRAMM%\Sample
SampleDel = 24,%PROGRAMM%\Sample
SampleWinCopy = 25
SampleSysCopy = 11
SampleINFCopy = 17
SampleHLPCopy = 18

[DefaultInstall]
CopyFiles = SampleCopy, SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
AddReg = SampleRegisterApp, SampleRegUninstall, SampleRenameFiles
UpdateInis = SampleAddLinks

[RemoveSample]
DelFiles = SampleWinCopy, SampleSysCopy, SampleINFCopy, SampleHLPCopy
DelReg = SampleUnRegisterApp, SampleRegUninstall
AddReg = SampleRemoveLFNs
UpdateInis = SampleRemoveLinks

[SampleCopy]
sample.bmp

[SampleWinCopy]
sample.exe

[SampleSysCopy]
sample.dll

[SampleINFCopy]
sample.inf

[SampleHLPCopy]
sample.hlp

[SampleRegisterApp]
;Creazione di una voce di registro arbitraria (per un utilizzo privato di Sample.exe):
HKLM,Software\Sample,Installed,,"1"

[SampleUnRegisterApp]
;Eliminazione della voce di registro (eliminazione dell’intera chiave):
HKLM,Software\Sample

[SampleRegUninstall]
;Aggiunta di una voce nella finestra di dialogo Installazione applicazioni del Pannello di controllo per disinstallare il programma:
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"DisplayName",,"Sample Application"
HKLM,SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sample,"UninstallString",,"RunDll setupx.dll,InstallHinfSection RemoveSample 4 sample.inf"

[SampleRenameFiles]
;Ridenominazione dei nomi di file 8.3 utilizzando nomi di file lunghi:
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,,,"%24%\%PROGRAMM%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\RenameFiles\Sample,sample.bmp,,"Sample Bitmap.bmp"

[SampleRemoveLFNs]
;Eliminazione dei file con nomi file lunghi durante la disinstallazione:
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,,,"%24%\%PROGRAMF%\Sample"
HKLM,Software\Microsoft\Windows\CurrentVersion\DeleteFiles\Sample,sample.bmp,,"Sample Bitmap.bmp"

[SampleAddLinks]
;Aggiunta di un collegamento a Sample.exe nel menu di avvio:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;crea la cartella
setup.ini, Sample,, """%SampleDesc%"", %25%\SAMPLE.EXE" ;crea il collegamento

[SampleRemoveLinks]
;Rimozione del collegamento a Sample.exe nel menu di avvio durante la disinstallazione:
setup.ini, progman.groups,, "Sample=%SampleFolder%" ;creazione della cartella
setup.ini, Sample,, """%SampleDesc%""" ;eliminazione del collegamento

[SourceDisksNames]
99 = %DiskName%,Sample,0

[SourceDisksFiles]
sample.exe = 1,,13456
sample.dll = 1,,20987
sample.bmp = 1,,64098
sample.hlp = 1,,55441
sample.inf = 1,,5687

[Strings]
PROGRAMF = "PROGRA~1"
SampleFolder = "Samples"
SampleDesc = "Sample Application"
DiskName = "Sample Application Installation Disk"


Definizione di file di informazioni per l'installazione (inf)

Un file inf di base contiene le sezioni elencate di seguito. È possibile che i file inf più complessi abbiano delle sezioni aggiuntive. I nomi di sezione in grassetto corrispondono alle parole chiave riservate. I nomi di sezione in corsivo corrispondono a nomi arbitrari creati dall'autore del file inf.

  • Sezione Version
  • Sezioni Install
    • Sezioni Copy File (CopyFiles)
    • Sezioni Rename Files (RenFiles)
    • Sezioni Delete Files (DelFiles)
    • Sezioni Update ini File (UpdateInis)
    • Sezioni Update ini Fields (UpdateIniFields)
    • Sezioni Add Registry (AddReg)
    • Sezioni Delete Registry (DelReg)
    • Sezioni Add Ini File to Registry (Ini2Reg)
    • Sezioni Update Config.sys (UpdateCfgSys)
    • Sezioni Update Autoexec.bat (UpdateAutoBat)
  • Sezione DestinationDirs
  • Sezione SourceDisksNames
  • Sezione SourceDisksFiles
  • Sezione Strings
  • Sezione Optional Components
[Version] | Informazioni di base sulla versione per la convalida del file inf
[DefaultInstall] | Sezione di installazione eseguita in base all'impostazione predefinita. Contiene dei puntatori ad altre sezioni che specificano i file da copiare ed eliminare, gli aggiornamenti del registro di configurazione , gli aggiornamenti del file ini e così via.
[AltrasezioneInstall] | Utilizza lo stesso formato della sezione [DefaultInstall], ma deve essere richiamata esplicitamente. Utile per definire la modalità di disinstallazione di un componente.
[DestinationDirs] | Specifica il percorso sul disco rigido in cui verranno copiati, eliminati o rinominati i file di una sezione, ad esempio \Windows o Windows\System.
[FileCopy/Delete/RenameSezione/i] | Elenca i file da copiare, eliminare o rinominare.
[RegistryUpdateSezione/i] | Specifica le aggiunte o le eliminazioni dal registro di configurazione.
[IniFileUpdateSezione/i] | Specifica gli aggiornamenti dei file ini. In questa sezione vengono creati i collegamenti.
[SourceDisksNames] | Elenca i dischi contenenti i file.
[SourceDisksFiles] | Elenca il disco specifico su cui si trova ciascun file.
[Strings] | Elenca le stringhe localizzabili utilizzate in precedenza.
Torna all'inizio del file

Sezione versione

[Version]
Signature="$Chicago$"
LayoutFile=nomefileinf
Definisce l'intestazione standard per tutti i file inf di Windows. Se la firma non è $Chicago$, Windows non accetterà il file inf come tale per alcuna delle classi di periferiche riconosciute dallo stesso Windows.

Per il riconoscimento della stringa relativa alla firma non viene fatta distinzione tra maiuscole e minuscole. È quindi possibile, ad esempio, utilizzare sia $Chicago$ che $CHICAGO$.

nome file inf
Denomina il file inf contenente le informazioni sul layout (dischi e file di origine) necessarie per installare il componente. Questa riga è opzionale. Se non specificate altrove, le sezioni SourceDisksNames e SourceDisksFiles devono essere specificate in questo file inf.

Di seguito è riportato un esempio di una tipica sezione Version.

[Version]
Signature="$CHICAGO$"

Torna all'inizio del file

Sezioni installazione

[nome-sezione-Install]

Copyfiles = sezione-elenco-file[,<sezione-elenco-file>]...
Renfiles = sezione-elenco-file[,sezione-elenco-file]...
Delfiles = sezione-elenco-file[,sezione-elenco-file]...
UpdateInis = sezione-aggiornamento-ini[,sezione-aggiornamento-ini]...
UpdateIniFields = sezione-aggiornamento-campi-ini[,sezione-aggiornamento-campi-ini]...
AddReg = sezione-aggiunta-registro[,sezione-aggiunta-registro]...
DelReg = sezione-eliminazione-dal-registro[,sezione-eliminazione-dal-registro]...
Ini2Reg = sezione-aggiunta-registro[,sezione-aggiunta-registro]...
UpdateCfgSys = sezione-aggiornamento-config
UpdateAutoBat =sezione-aggiornamento-autoexec

Identifica le sezioni aggiuntive nel file inf contenente le informazioni per l'installazione del componente.

Non tutti i tipi di elementi contenuti nella precedente sintassi sono necessari o richiesti in una sezione Install. Quando viene utilizzato un tipo di voce, si deve specificare il nome di una sezione nel file inf. Un'eccezione è costituita dalla voce CopyFiles, che può utilizzare il carattere "@" con un nome di file per copiare un solo file senza specificare un nome di sezione. Il nome di sezione deve essere costituito da caratteri stampabili.

In una sezione Install è possibile utilizzare una sola voce per ciascun tipo. In una voce è possibile elencare più di un nome di sezione, ma ogni nome aggiuntivo deve essere preceduto da una virgola.

nome-sezione-install
Se la sezione installazione viene denominata [DefaultInstall], verrà eseguita quando viene fatto clic sul file inf e quindi su Installa. Questa sezione viene eseguita anche quando si seleziona un file inf come opzione di installazione utilizzando la procedura guidata Cabpack.

Di seguito è riportato un esempio di una tipica sezione Install . Contiene le voci Copyfiles e AddReg che identificano le sezioni contenenti informazioni sui file da installare.

[MyApplication]
Copyfiles=MyAppWinFiles, MyAppSysFiles, @SRSutil.exe
AddReg=MyAppRegEntries

In questo esempio, notare che rinominando la sezione [MyApplication] in [DefaultInstall], la sezione install verrà eseguita quando viene fatto clic con il tasto destro sul file inf e quindi su Installa.

La voce CopyFiles fornisce una notazione speciale che consente di copiare un singolo file direttamente dalla riga di copia. Per copiare un singolo file, aggiungere al nome di file il prefisso @. La destinazione dei file copiati utilizzando tale notazione è DefaultDestDir, come definito nella sezione DestinationDirs . Il seguente esempio mostra come copiare singoli file.

CopyFiles=SezioneFile1,@miofile.txt,@altrofile.txt,NomeUltimaSezione

Torna all'inizio del file

Sezioni Copy Files (CopyFiles)

[nome-sezione-CopyFiles]
nome-file-destinazione[, nome-file-origine][,nome-file-temporaneo][,flag]
[nome-file-destinazione[,nome-file-origine][, nome-file-temporaneo]][,flag]

Elenca i nomi dei file da copiare da un disco di origine in una cartella di destinazione. Il disco di origine e la cartella di destinazione associati a ciascun file sono specificati in altre sezioni del file inf. Il nome di sezione-elenco-file deve essere contenuto nella voce CopyFiles di una sezione Install.

È possibile specificare di copiare un singolo file nella voce CopyFiles della stessa sezione Install senza creare una sezione CopyFiles. Utilizzare il carattere speciale "@" per forzare la copia di un singolo file. Un esempio di utilizzo del carattere "@" nella voce CopyFiles si trova nell'argomento di riferimento della sezione Install. Una copia di un file singolo di questo tipo è piuttosto limitata in quanto il nome del file di origine e di quello di destinazione devono, in questo caso, essere uguali e non è possibile utilizzare un file temporaneo.

nome-file-destinazione
Nome del file di destinazione. Se non viene specificato il nome del file di origine, questo viene considerato anche il nome del file di origine.

nome-file-origine
Nome del file di origine. Se il nome del file di origine e di quello di destinazione sono uguali, questo nome non è necessario.

nome-file-temporaneo
Nome di un file temporaneo per l'operazione di copia dei file. Il programma di installazione copia il file di origine ma gli assegna il nome temporaneo. Al successivo avvio del sistema operativo, il file temporaneo viene rinominato con il nome file di destinazione. Ciò si rivela utile per copiare i file in una destinazione attualmente aperta o utilizzata da Windows.

flag
Parametro opzionale utilizzato per eseguire operazioni speciali durante il processo di installazione. Sommando i valori è possibile utilizzare più flag per creare il flag combinato. È possibile utilizzare i seguenti flag validi.

1 | In CopyFiles: segnalare se l'utente cerca di ignorare il file.
1 | In DelFiles. Se il file è in uso, accodare l'esecuzione delle eliminazioni in ritardo in Wininit.ini. In caso contrario, i file in uso non saranno eliminati.
2 | Installazione critica: non consente all'utente di ignorare il file.
4 | Ignorare il controllo della versione e copiare sempre i file. Il file più recente viene sovrascritto.
8 | Forzare la ridenominazione. Il programma di installazione considera il file come se fosse in uso. Ciò accade soltanto se il file esiste già sul computer dell'utente.
16 | Se il file esiste già a destinazione, non eseguire la copia.
32 | Non visualizzare la finestra di dialogo dei conflitti di versione e non sovrascrivere i file più recenti.

Nel seguente esempio vengono copiati tre file.

[CopyTheseFilesSec]
file11 ; copia il file11
file21, file22, file23 ; copia il file22, denominandolo temporaneamente file23
file31, file32 ; copia il file32 sul file31

Tutti i nomi di file di origine utilizzati in questo esempio devono essere definiti in una sezione SourceDisksFiles e i numeri dei dischi logici che compaiono nella sezione SourceDisksFiles devono essere stati definiti in una sezione SourceDisksNames. In alternativa, per fornire tali informazioni è possibile utilizzare un file LayoutINF.

Torna all'inizio del file

Sezioni Rename Files (RenFiles)

[nome-sezione-rinomina-file]
nome-nuovo-file, nome-vecchio-file
.
.
Elenca i nomi dei file da rinominare. Il nome della sezione deve comparire in una voce Renfiles in una sezione Install del file inf.

nome-nuovo-file
Nuovo nome del file.

nome-vecchio-file
Vecchio nome del file.

Il seguente esempio rinomina file42 in file41, file52 in file51 e file62 in file61.

[RenameOldFilesSec]
file41, file42
file51, file52
file61, file62

Tutti i vecchi nomi di file utilizzati nell'esempio (file42, file52 e file62) devono essere definiti in una sezione SourceDisksFiles e i numeri dei dischetti logici che compaiono nella sezione SourceDisksFiles devono essere stati definiti in una sezione SourceDisksNames.

Torna all'inizio del file

Sezioni Delete Files (DelFiles)

[ sezione-elenco-file]
nome-file[,,,flag]
.
.
Una sezione
DelFiles elenca i nomi dei file da eliminare. Il nome di sezione-elenco-file deve comparire nella voce Delfiles di una sezione Install.

nome-file
Identifica un file da eliminare.

flag
Parametro opzionale utilizzato per forzare Windows a eliminare il file denominato nella voce se in uso durante il processo di installazione. Per segnalare a Windows di accodare l'operazione di eliminazione del file finché il computer viene riavviato, impostare il valore del parametro flag a 1. Se un file contrassegnato dall'impostazione del parametro flag a 1 non può essere eliminato perché in uso, al termine dell'installazione della periferica il sistema verrà riavviato.

Se non si utilizza il valore del parametro flag uguale a 1 con un parametro nome-file, il file non verrà eliminato dal computer se è in uso durante l'esecuzione della sezione DelFiles.

Nel seguente esempio vengono eliminati tre file.

[DeleteOldFilesSec]
file1
file2
file3

Torna all'inizio del file

Sezioni Update ini File (UpdateInis)

[ nome-sezione-aggiornamento-ini]
file-ini, sezione-ini, [vecchia-voce-ini], [nuova-voce-ini], [flag]
.
.
Sostituisce, elimina o aggiunge voci complete nel file ini specificato. Il nome di sezione, nome-sezione-aggiornamento-ini, deve comparire nella voce UpdateInis in una sezione Install del file inf.

file-ini
Nome del file ini contenente la voce da modificare. Per ulteriori informazioni sulla definizione del nome del file .ini, vedere i seguenti commenti.

sezione-ini
Nome della sezione contenente la voce da modificare.

vecchia-voce-ini
Opzionale. Generalmente ha il formato Chiave=Valore.

nuova-voce-ini
Opzionale. Generalmente ha il formato Chiave=Valore. Sia la chiave che il valore possono specificare stringhe sostituibili. Sia la chiave che il valore specificati nel parametro nuova-voce-ini possono ad esempio corrispondere a %String1%, dove la stringa che sostituisce %String1% è definita nella sezione Strings del file inf.

flag
Flag di operazioni opzionali. Può corrispondere a uno dei seguenti valori.

0 Predefinito. Se la chiave vecchia-voce-ini è presente in una voce del file ini, tale voce viene sostituita con nuova-voce-ini. Soltanto le chiavi del parametro vecchia-voce-ini e della voce del file inf devono corrispondere; il valore di ciascuna voce viene ignorato.

Per aggiungere senza alcuna condizione nuova-voce-ini al file ini, impostare vecchia-voce-ini su NULL. Per eliminare senza alcuna condizione vecchia-voce-ini dal file ini, impostare nuova-voce-ini su NULL.

1 | Se sia la chiave che il valore di vecchia-voce-ini esistono già in una voce del file ini, quella voce viene sostituita con nuova-voce-ini. Affinché la sostituzione venga eseguita, è necessario che il parametro vecchia-voce-ini e la voce del file inf corrispondano. Ciò contrasta con l'utilizzo di un valore del flag di operazione uguale a 0, in cui, affinché la sostituzione venga eseguita, è necessario che corrispondano soltanto le chiavi.
2 Se la chiave del parametro vecchia-voce-ininon esiste nel file ini, in quest'ultimo non viene eseguita alcuna operazione.

Se sia la chiave del parametro vecchia-voce-iniche la chiave del parametro nuova-voce-iniesistono in una voce del file ini, la voce del file ini che corrisponde alla chiave del parametro nuova-voce-iniviene eliminata e la voce del file ini che corrisponde al parametro vecchia-voce-iniviene trattata nel modo seguente. la chiave della voce del file ini viene sostituita con la chiave del parametro nuova-voce-ini.

Se la chiave del parametro vecchia-voce-iniesiste in una voce del file ini e la chiave del parametro nuova-voce-ininon esiste in alcuna voce del file ini, al file ini viene aggiunta una voce costituita dalla chiave del parametro nuova-voce-inie dal vecchio valore.

La corrispondenza del parametro vecchia-voce-inie della voce del file ini si basa sulla sola chiave, non sulla chiave e sul valore.

3 | Uguale al valore del parametro del flag 2 sopra descritto, tranne per la corrispondenza del parametro vecchia-voce-ini e una voce del file inf basata sulla corrispondenza sia della chiave che del valore, non soltanto della chiave.
Quando si specificano la chiave e il valore, è possibile utilizzare il carattere jolly asterisco (*) e si avrà una corretta interpretazione.

Il nome file-ini può corrispondere a una stringa o a una chiave di stringhe. Una chiave di stringhe ha il formato %chiave stringa%, in cui chiave stringa è definito nella sezione Strings del file inf. In entrambi i casi, il nome deve essere costituito da un nome di file valido.

Il nome deve comprendere il nome della cartella contenente il file, ma il nome della cartella deve essere specificato come identificatore logico della directory (LDID) piuttosto che come nome reale. Il programma di installazione sostituisce gli LDID con nomi reali durante l'installazione.

Un LDID ha il formato %ldid%, in cui ldid è uno degli identificatori predefiniti o un identificatore definito nella sezione DestinationDirs. Quando le costanti LDID_BOOT e LDID_BOOTHOST vengono sostituite, la barra rovesciata (\) viene compresa nel percorso. LDID_BOOT può ad esempio essere sostituito da C:\. Nel file inf è tuttavia possibile utilizzare o non utilizzare la barra rovesciata. Ad esempio, per riferirsi a BOOT.ini nella cartella principale dell'unità di avvio è possibile utilizzare "%30%boot.ini" oppure "%30%\boot.ini".

I seguenti esempi illustrano voci individuali di una sezione Update ini File di un file inf.

%11%\esempio.ini, Sezione1,, Value1=2 ; aggiunge una nuova voce
%11%\esempio.ini, Sezione2, Value3=*, ; elimina una vecchia voce
%11%\esempio.ini, Sezione4, Value5=1, Value5=4 ; sostituisce una vecchia voce

La serie di voci che segue contenuta in una sezione Update ini File di un file inf interviene sulla sezione Boot di SYSTEM.ini. Le condizioni create nel parametro flag delle voci del file inf vengono utilizzate per aggiungere la voce "comm.drv=comm.drv" alla sezione Boot a meno che in tale sezione esistano le voci "comm.drv=*vcoscomm.drv" o "comm.drv=*r0dmdcom.drv", nel qual caso la voce esistente viene preservata e la voce "comm.drv=comm.drv" non viene aggiunta al file ini. Dopo che le quattro voci del file inf sono state eseguite, vi sarà una voce "comm.drv=" nella sezione Boot del file ini. "comm.drv=*vcoscomm.drv", "comm.drv=*r0dmdcom.drv" o "comm.drv=comm.drv."

system.ini, boot, "comm.drv=*vcoscomm.drv","~CommDrvTemp~=*", 3
system.ini, boot, "comm.drv=*r0dmdcom.drv","~CommDrvTemp~=*", 3
system.ini, boot,,"comm.drv=comm.drv"
system.ini, boot, "~CommDrvTemp~=*","comm.drv=*", 3

Torna all'inizio del file

Sezioni Update ini Fields (UpdateIniFields)

[ nome-sezione-aggiornamento-campi ini ]
file-ini, sezione-ini, nome-profilo, [vecchio-campo], [nuovo-campo],[flag]
.

.
Sostituisce, aggiunge ed elimina i campi nel valore di una determinata voce ini. A differenza della sezione Update ini File, questo tipo di sezione sostituisce, aggiunge o elimina soltanto una parte di un valore in una voce di un file ini, anziché tutto il valore. Il nome di sezione, nome-sezione-aggiornamento-campi-ini, deve comparire nella voce UpdateIniFields in una sezione Install del file inf.

file-ini
Nome del file ini che contiene le voci da modificare. Per ulteriori informazioni sulla definizione del nome del file ini, vedere l'argomento relativo alla sezione Update ini File.

sezione-ini
Nome della sezione del file .ini che contiene la voce da modificare.

nome-profilo
Nome della voce da modificare.

vecchio-campo
Valore del campo da eliminare.

nuovo-campo
Valore del campo da aggiungere, se non ancora esistente.

flag
Specifica se trattare i parametri vecchio-campo e nuovo-campo come se avessero o non avessero un carattere jolly e/o il carattere separatore da utilizzare quando si aggiunge un campo nuovo a un file ini. Può corrispondere a uno dei seguenti valori.

Valore | Significato
0 | (Predefinito) Considera il carattere "*" letteralmente quando si cerca una corrispondenza tra i campi e non come carattere jolly. Quando si aggiunge un campo nuovo a una voce, come separatore utilizzare uno spazio vuoto (" ").
1 | Considera il carattere "*" come carattere jolly quando si cerca una corrispondenza tra i campi. Quando si aggiunge un campo nuovo a una voce, come separatore utilizzare uno spazio vuoto (" ").
2 | Considera il carattere "*" letteralmente quando si cerca una corrispondenza tra i campi e non come carattere jolly. Quando si aggiunge un campo nuovo a una voce, come separatore utilizzare una virgola (",").
3 | Considera il carattere "*" come carattere jolly quando si cerca una corrispondenza tra i campi. Quando si aggiunge un campo nuovo a una voce, come separatore utilizzare una virgola (",").
Tutti i commenti nella riga del file ini vengono rimossi perché non sono applicabili dopo le modifiche. Quando i campi di questa riga del file ini vengono elaborati, come delimitatori di campo vengono utilizzati, spazi, tabulazioni e virgole. Quando tuttavia alla riga viene aggiunto un campo nuovo, come separatore viene utilizzato uno spazio.
Torna all'inizio del file

Sezioni Add Registry (AddReg)

[ sezione-aggiunta-registro]
stringa-principale-reg, [sottochiave], [nome-valore], [valore]
[stringa-principale-reg, [sottochiave], [nome-valore], [flag], [valore]]
.
.
Aggiunge sottochiavi o nomi di valori al registro, impostando opzionalmente il valore. Il nome sezione-aggiunta-registro deve comparire in una voce AddReg di una sezione Install.

stringa-principale-reg
Nome principale del registro. Può corrispondere a uno dei seguenti valori.

HKCR è uguale a HKEY_CLASSES_ROOT
HKCU è uguale a HKEY_CURRENT_USER
HKLM è uguale a HKEY_LOCAL_MACHINE
HKU è uguale a HKEY_USERS.
HKR significa relativo rispetto alla chiave immessa in GenInstallEx

sottochiave
Opzionale. Identifica la sottochiave da impostare. Ha il formato chiave1\chiave2\chiave3.... Il parametro può essere espresso come stringa sostituibile. È ad esempio possibile utilizzare %Subkey1%, in cui la stringa da sostituire a %Subkey1% è definita nella sezione Strings del file inf.

nome-valore
Opzionale. Identifica il nome del valore per il parametro sottochiave. Per il tipo di stringa, se il parametro nome-valore viene lasciato vuoto, il valore della sottochiave specificata nel parametro sottochiave è impostato su una stringa NULL. Il parametro nome-valore può essere espresso come stringa sostituibile. È ad esempio possibile utilizzare %Valname1%, in cui la stringa da sostituire a %Valname1% è definita nella sezione Strings del file inf.

flag
Opzionale. Determina sia il tipo di valore che se la chiave di registro viene sostituita se già esistente.

Valore | Significato
0 | (Predefinito) Il valore è una stringa ANSI. Sostituire la chiave se esistente.
1 | Il valore è un numero esadecimale. Sostituire la chiave se esistente.
2 | Il valore è una stringa ANSI. Non sostituire la chiave se esistente.
3 | Il valore è un numero esadecimale. Non sostituire la chiave se esistente.
valore
Opzionale. Valore da impostare. Può corrispondere a una stringa ANSI o a un numero in notazione esadecimale e formato Intel. Qualsiasi voce contenente un valore binario può essere estesa oltre il valore massimo della riga di 128 byte utilizzando una barra rovesciata (\). È possibile specificare anche una chiave di stringa nel formato %chiavestringa%. chiavestringadeve essere definito nella sezione Strings del file inf. Per utilizzare un carattere % nella riga, usare %%.

Sono necessari almeno due campi, ma uno può essere nullo. Quando si utilizza tale formato, è richiesta pertanto almeno una virgola.

Le due voci della seguente sezione AddReg aggiungono due nomi di valori al registro. Notare che %25% sarà esteso alla cartella Windows del computer.

[VociRegMiaApp]
HKLM,Software\MiaApp,NomeProgramma,,"Mia applicazione"
HKLM,Software\MiaApp,"Posizione Programma",,"%25%\MiaApp.exe"

Torna all'inizio del file

Sezioni Delete Registry (DelReg)

[ sezione-eliminazione-registro]
stringa-principale-reg, sottochiave, [nome-valore]
[stringa-principale-reg, sottochiave, [nome-valore]]
.
.
Elimina una sottochiave o un nome di valore dal registro. Il nome sezione-eliminazione-registro deve comparire in una voce DelReg in una sezione Install.

stringa-principale-reg
Nome principale del registro. Può corrispondere a uno dei seguenti valori.

HKCR Uguale a HKEY_CLASSES_ROOT
HKCU Uguale a HKEY_CURRENT_USER
HKLM Uguale a HKEY_LOCAL_MACHINE
HKU Uguale a HKEY_USERS.
HKR significa relativo rispetto alla chiave immessa in GenInstallEx

sottochiave
Identifica la sottochiave da eliminare. Ha il formato key1\key2\key3... Il parametro può essere espresso come stringa sostituibile. È ad esempio possibile utilizzare %Subkey1%, in cui la stringa da sostituire a %Subkey1% è definita nella sezione Strings del file inf.

nome-valore
Opzionale. Identifica il nome del valore per il parametro sottochiave. Il parametro nome-valore può essere espresso come stringa sostituibile. È ad esempio possibile utilizzare %Valname1%, in cui la stringa da sostituire a %Valname1% è definita nella sezione Strings del file inf.

Questo tipo di sezione può contenere un numero qualsiasi di voci. Ciascuna voce elimina una sottochiave o un nome di valore dal registro.

Sezioni Ini File to Registry (Ini2Reg)

[ sezione-ini-a-registro]
file-ini, sezione-ini, [chiave-ini], stringa-principale-reg, sottochiave[,flag]
.
.
Sposta le righe o le sezioni da un file ini nel registro, creando o sostituendo una voce di registro sotto una determinata chiave nel registro. Il nome di sezione sezione-ini-a-registro deve comparire in una voce Ini2Reg di una sezione Install del file inf.

file-ini
Nome del file ini contenente la chiave da copiare. Per ulteriori informazioni sulla definizione del nome del file ini, vedere i commenti nell'argomento di riferimento relativo alla sezione Update ini File.

sezione-ini
Nome della sezione del file ini contenente la chiave da copiare.

chiave-ini
Nome della chiave del file ini da copiare nel registro. Se chiave-ini è vuoto, l'intera sezione viene trasferita nella chiave di registro specificata.

stringa-principale-reg
Nome principale del registro. Può corrispondere a uno dei seguenti valori.

HKCR è uguale a HKEY_CLASSES_ROOT
HKCU è uguale a HKEY_CURRENT_USER
HKLM è uguale a HKEY_LOCAL_MACHINE
HKU è uguale a HKEY_USERS.
HKR significa relativo rispetto alla chiave immessa in GenInstallEx

sottochiave
Identifica la sottochiave per ricevere il valore. Ha il formato chiave1\chiave2\chiave3...

flag
Indica se eliminare la chiave ini dopo il trasferimento nel registro e se sovrascrivere il valore del registro se la chiave del registro esiste già. Può corrispondere a uno dei seguenti valori.

Valore | Significato
0 | (Predefinito) Non eliminare la voce ini dal file ini dopo avere spostato le informazioni della voce nel registro. Se la sottochiave del registro esiste già, non sostituirne il valore attuale.
1 | Eliminare la voce ini dal file ini dopo avere spostato le informazioni della voce nel registro. Se la sottochiave del registro esiste già, non sostituirne il valore attuale.
2 | Non eliminare la voce ini dal file ini dopo avere spostato le informazioni della voce nel registro. Se la sottochiave del registro esiste già, sostituirne il valore attuale con il valore della voce del file ini.
3 | Eliminare la voce ini dal file ini dopo avere spostato le informazioni della voce nel registro. Se la sottochiave del registro esiste già, sostituirne il valore attuale con il valore della voce del file ini.
Si supponga ad esempio che la voce seguente esista già nel file Win.ini.

[Windows]
CursorBlinkRate=15

Se sotto Control Panel\Desktop non esiste una sottochiave CursorBlinkRate, la seguente voce in una sezione Ini File to Registry crea la sottochiave, imposta il valore della sottochiave a 15 e lascia inalterata la riga originale WIN.ini.

win.ini,Windows,CursorBlinkRate,HKCU,"Control Panel\Desktop"

Se la sottochiave esiste già, la voce del file inf imposta il valore della sottochiave a 15 e lascia inalterata la riga originale in WIN.ini.

Sezioni Update Config.sys (UpdateCfgSys)

[ sezione-aggiornamento-config]
Buffers=valore-buffer-dos-valido
DelKey=chiave
DevAddDev=nome-driver,parolachiaveconfig[,flag][,stringa-param]
DevDelete=nome-perif-corrente
DevRename=nome-perif-corrente,nome-nuova-perif
Files=valore-file-dos-valido
PrefixPath=ldid[,ldid]
RemKey=chiave
Stacks=valori-stack-dos-validi

Fornisce i comandi per aggiungere, eliminare o rinominare i comandi nel file Config.sys. Il nome di sezione, nome-sezione-aggiornamento-config, deve comparire nella voce UpdateConfigSys di una sezione Install del file inf.

Non tutti i tipi di voci presenti nella sintassi precedente sono necessari o richiesti. Una sezione Update Config.sys può contenere il numero necessario di voci DevRename, DevDelete, DevAddDev, DelKey e RemKey, ma le voci Buffers, Files e Stacks possono essere utilizzate soltanto una volta in una sezione. Quando si elabora una sezione Update Config.sys, il programma di installazione elabora per prime tutte le voci DevRenames , poi tutte le voci DevDelete e infine tutte le voci DevAddDev. La sintassi e il significato di ognuno di questi tipi di voci utilizzabili in una sezione Update Config.sys sono disponibili più avanti in questo argomento.

Voce Buffers

Buffers=valore-buffer-dos-valido
Imposta il numero di buffer dei file. Come con la voce Stacks, il programma di installazione confronta il valore esistente con il valore proposto e imposta sempre i buffer dei file sul valore maggiore tra i due.

valore-buffer-dos-valido
Un valore dei buffer MS-DOS valido.

Voce DelKey

DelKey=chiave
Fa sì che il comando Config.sys con la chiave specificata sia evidenziato nel file Config.sys. Ad esempio, la seguente voce del file inf.

DelKey=Break

mette in evidenza nel file Config.sys un comando Break=on.

La voce DelKey produce lo stesso effetto della voce RemKey . In una sezione del file inf vi possono essere più voci DelKey e/o RemKey .

chiave
La chiave del comando Config.sys da evidenziare.

Voce DevAddDev

DevAddDev=nome-driver,parolachiaveconfig[,flag][,stringa-param]
Aggiunge un comando device o install al file CONFIG.SYS.

nome-driver
Nome del driver o del file eseguibile da aggiungere. Il programma di installazione convalida l'estensione del nome file, garantendo che sia sys o exe.

parolachiaveconfig
Nome comando. Può essere device o install.

flag
Flag di posizionamento opzionale. Se 0, il comando viene posizionato alla fine del file. Se 1, è posizionato in cima al file. Se non specificato, in base all'impostazione predefinita viene utilizzato 0.

stringa-param
Parametri di comando opzionali. Devono essere validi per il driver della periferica o il file eseguibile specificati.

Voce DevDelete

DevDelete=nome-driver-periferica
Elimina qualsiasi riga contenente il nome di file specificato dal file Config.sys.

nome-driver-periferica
Nome di un file o driver di periferica. Il programma di installazione cerca nel file Config.sys il nome ed elimina tutte le righe che lo contengono. Poiché MS-DOS non accetta estensioni dei nomi di file implicite in Config.sys, ciascun nome-driver-periferica deve esplicitamente specificare l'estensione del nome di file.

La seguente voce di esempio DevDelete di una sezione Update Config.sys elimina le righe 1 e 3 ma non la riga 2 del file di esempio Config.sys:

DevDelete=nomefile.sys

;; righe in Config.sys
Device=Nomefile.sys ;; riga1
Install=Nomefile.exe ;; riga2
Device=Nomefile.sys /d:b800 /I:3 ;; riga3

Voce DevRename

DevRename=nome-perif-corrente,nome-nuova-perif
Rinomina un driver di periferica nel file Config.sys.

nome-perif-corrente
Nome del driver di periferica o del file eseguibile da rinominare. Il programma di installazione cerca il nome sul lato destro di un comando device o install nel file Config.sys.

nome-nuova-perif
Nuovo nome del driver o del file eseguibile.

Voce Files

Files=valore-file-dos-valido
Imposta il numero massimo di file aperti nel file Config.sys. Come con la voce Stacks, il programma di installazione confronta il valore esistente con il valore proposto e imposta sempre il numero massimo di file aperti sul valore maggiore tra i due.

valore-file-dos-valido
Un valore dei file di MS-DOS validi.

Voce PrefixPath

PrefixPath=ldid[,ldid]...
Appende al comando path il percorso associato all'LDID dato.

ldid
Può corrispondere a qualsiasi dei valori LDID predefiniti o a un nuovo valore definito nel file inf. Per una definizione di tutti i valori LDID predefiniti, vedere l'argomento di riferimento relativo alla sezione DestinationDirs.

Voce RemKey

RemKey=chiave
Fa sì che il comando Config.sys con la chiave specificata sia evidenziato nel file Config.sys. Ad esempio, la seguente voce del file inf.

RemKey=Break

mette in evidenza nel file Config.sys un comando Break=on.

La voce RemKey produce lo stesso effetto della voce DelKey . In una sezione del file inf vi possono essere più voci RemKey e/o DelKey.

chiave
La chiave del comando Config.sys da evidenziare.

Voce Stacks

Stacks=valori-stack-dos-validi
Imposta il numero e le dimensioni degli stack nel file Config.sys. Il programma di installazione confronta il valore esistente con il valore proposto e imposta sempre gli stack sul valore maggiore tra i due. Se Config.sys ad esempio contiene stack=9.218 e un file inf contiene stack=5.256, il programma di installazione imposta il nuovo valore su stack=9.256.

valori-stack-dos-validi
Un valore degli stack di MS-DOS valido.

Torna all'inizio del file

Sezioni Update Autoexec.bat (UpdateAutoBat)

[ sezione-aggiornamento-autoexec]
CmdAdd=nome-comando[,parametri-comando]
CmdDelete=nome-comando
PrefixPath=ldid[,ldid]
RemOldPath=ldid[,ldid]
TmpDir=ldid[,sottodir]
UnSet=nome-var-ambiente

Fornisce i comandi per gestire le righe del file Autoexec.bat. Il nome di sezione, nome-sezione-aggiornamento-autoexec, deve comparire nella voce UpdateAutoBat di una sezione Install del file inf.

Non tutti i tipi di voci contenuti nella sintassi precedente sono necessari o richiesti in una sezione Update Autoexec.bat. La sezione può contenere il numero necessario di voci CmdAdd, CmdDelete e UnSet, ma in un file inf è possibile utilizzare soltanto una voce PrefixPath, RemOldPath e TmpDir. La sintassi e il significato di ciascun tipo di voce sono descritti più avanti in questo argomento.

Il programma di installazione elabora innanzitutto tutte le voci CmdDelete, quindi tutte le voci CmdAdd.

Voce CmdAdd

CmdAdd =nome-comando[,"parametri-comando"]
Aggiunge il comando specificato e i parametri opzionali del comando alla fine del file Autoexec.bat.

nome-comando
Nome di un file eseguibile, con o senza estensione. Se il nome di file è definito anche nelle sezioni SourceDisksFiles e DestinationDirs del file inf, il programma di installazione aggiunge il percorso corretto al nome di file prima di scriverlo nel file Autoexec.bat.

parametri-comando
Una stringa racchiusa tra doppie virgolette o una stringa sostituibile come %String1% o %Myparam%, in cui le stringhe che sostituiscono %String1% e %Myparam% sono definite nella sezione Strings del file inf. Il programma di installazione aggiunge la stringa a nome-comando prima di aggiungere la riga alla fine del file Autoexec.bat. Il formato di questa riga dipende dai requisiti della riga di comando del file eseguibile specificato.

Voce CmdDelete

CmdDelete=nome-comando
Elimina tutte le righe nel file Autoexec.bat che contengono il nome del comando specificato. Il programma di installazione cerca ed elimina tutte le occorrenze del nome specificato con estensione exe, com e bat.

nome-comando
Nome di un file eseguibile senza estensione.

Voce PrefixPath

PrefixPath=ldid[,ldid]...
Appende al comando path il percorso associato all'LDID dato.

ldid
Può corrispondere a qualsiasi dei valori LDID predefiniti o a un nuovo valore definito nel file. Per una definizione di tutti i valori LDID predefiniti, vedere l'argomento di riferimento relativo alla sezione DestinationDirs.

Voce RemOldPath

RemOldPath=ldid[,ldid]
Rimuove il percorso associato all'LDID specificato dal comando path. Se l'utente ad esempio installa la nuova versione di Windows in C:\NuovoWin e ha una copia precedente di Windows in C:\Windows, la seguente voce del file inf rimuove C:\Windows dalla variabile di ambiente path:

RemOldPath=10

ldid
Può corrispondere a qualsiasi dei valori LDID predefiniti o a un nuovo valore definito nel file inf. Per una definizione di tutti i valori LDID predefiniti, vedere l'argomento di riferimento relativo alla sezione DestinationDirs.

Voce TmpDir

TmpDir=ldid[,sottodir]
Crea una cartella temporanea all'interno della cartella specificata dall'LDID, se non esiste già.

ldid
Può corrispondere a qualsiasi dei valori LDID predefiniti o a un nuovo valore definito nel file inf. Per una definizione di tutti i valori LDID predefiniti, vedere l'argomento di riferimento relativo alla sezione DestinationDirs.

sottodir
Un nome di percorso. Se ldid\sottodir non esiste già, viene creato.

Voce UnSet

UnSet=nome-var-ambiente
Rimuove tutti i comandi set dal file Autoexec.bat che include il nome della variabile di ambiente specificato.

nome-var-ambiente
Nome di una variabile di ambiente.

Torna all'inizio del file

Sezione DestinationDirs

[DestinationDirs]
sezione-elenco-file =ldid[, sottodir ]
.
.
[DefaultDestDir=ldid[, sottodir ]]

La sezione DestinationDirs definisce le cartelle di destinazione per le operazioni specificate nelle sezioni elenco-file, ossia CopyFiles, RenFiles o DelFiles. Opzionalmente, è possibile specificare una cartella di destinazione predefinita per le sezioni CopyFiles, RenFiles o DelFiles nel file inf non esplicitamente denominate nella sezione DestinationDirs.

sezione-elenco-file
Nome di una sezione CopyFiles, RenFiles o DelFiles. Al nome si deve fare riferimento in una voce Copyfiles, RenFiles o DelFiles di una sezione Install.

ldid
Un identificatore logico del disco (LDID). Può corrispondere a uno dei seguenti valori.

00 | LDID nullo - può essere utilizzato per creare un nuovo LDID
01 | Unità di origine:\nomepercorso
10 | Cartella Machine (si mappa sulla cartella di Windows in un'installazione basata su server)
11 | Cartella System
12 | Cartella IOSubsys
13 | Cartella Command
17 | Cartella Inf
18 | Cartella Help
20 | Fonts
21 | Viewers
22 | VMM32
23 | Cartella Color
24 | Cartella principale dell'unità contenente la cartella Windows
25 | Cartella Windows
26 | Periferica di avvio garantita per Windows (Winboot)
28 | Host Winboot
30 | Cartella principale dell'unità di avvio
31 | Cartella principale dell'unità host di un'unità di avvio virtuale
sottodir
Nome della cartella all'interno della cartella denominata dall'LDID come cartella di destinazione.

La voce opzionale DefaultDestDir fornisce una destinazione predefinita per tutte le voci CopyFiles che utilizzano la notazione di copia diretta (@nome file) o le sezioni CopyFiles, RenFiles o DelFiles non specificate nella sezioneDestinationDirs. Se una sezione DefaultDestDir non viene utilizzata in una sezioneDestinationDirs, la cartella predefinita viene impostata su LDID_WIN.

Il seguente esempio imposta la cartella di destinazione per la sezione MoveMiniPort su Windows\Iosybsys e la cartella predefinita per le altre sezioni sulla cartella Bin nell'unità di avvio:

[DestinationDirs]
MoveMiniPort=12 ; La destinazione per la sezione MoveMiniPort è
; windows\iosubsys
DefaultDestDirs=30,bin ; Copie dirette in boot:\bin

Torna all'inizio del file

Sezione SourceDisksNames

[SourceDisksNames]
ordinale-disco="descrizione-disco",etichetta-disco,numero-serie-disco
.
.
Identifica i nomi e i dischi contenenti i file di origine per le operazioni di copia e ridenominazione dei file.

ordinale-disco
Un numero univoco che identifica un disco di origine. Se vi sono più dischi di origine, a ognuno deve corrispondere un numero ordinale univoco.

descrizione-disco
Una stringa o una chiave di stringhe che descrive il contenuto o la funzione del disco. Il programma di installazione visualizza la stringa all'utente per identificare il disco. La descrizione è racchiusa tra doppie virgolette.

etichetta-disco
L'etichetta di volume del disco di origine impostata quando viene formattato.

numero-serie-disco
Non utilizzato. Il valore deve essere uguale a 0.

Questo esempio identifica un disco di origine. La descrizione del disco viene specificata come chiave di stringhe:

[SourceDisksNames]
55 = %ID1%, Instd1, 0

[Strings]
ID1="Disco 1 di Installazione Mia Applicazione 1"

Torna all'inizio del file
Sezione SourceDisksFiles

[SourceDisksFiles]
nome file=numero-disco[,sottodir] [,dimensione-file]
.
.
color=#000000Nomina i file di origine utilizzati durante l'installazione e identifica i dischi di origine contenenti i file.

color=#000000nome file
color=#000000Nome del file sul disco di origine.

numero-disco
color=#000000Numero ordinale del disco di origine contenente il file. Questo numero ordinale deve essere definito nella sezione SourceDisksNames e deve avere un valore maggiore o uguale a 1 (zero non è un valore valido per il parametro numero-disco).

sottodir
Parametro opzionale che specifica la sottocartella sul disco di origine dove risiede il file. Se questo parametro non viene utilizzato, il valore predefinito corrisponde alla cartella principale del disco di origine.

dimensione-file Parametro opzionale che specifica le dimensioni del file in byte.

color=#000000La seguente sezione di esempio SourceDisksFiles identifica un singolo file di origine, SRS01.386, sul disco con il numero ordinale 1.

[SourceDisksFiles]
SRS01.386 = 1

Torna all'inizio del file

Sezione Strings

[Strings]
chiave-stringhe=valore
.
.
Definisce una o più chiavi di stringhe. Una chiave di stringhe è un nome che rappresenta una stringa di caratteri stampabili. Sebbene la sezione Strings sia generalmente l'ultima sezione del file inf, una chiave di stringhe definita in questa sezione può essere utilizzata in qualsiasi punto del file inf in cui viene utilizzata la stringa corrispondente. Il programma di installazione espande la chiave di stringhe alla stringa specificata e la utilizza per ulteriori elaborazioni. Le chiavi di stringhe devono essere racchiuse tra segni di percentuale (%).

chiave-stringhe
Un nome univoco costituito da lettere e cifre.

valore
Una stringa costituita da lettere, cifre o altri caratteri stampabili. Deve essere racchiusa tra doppie virgolette se la chiave delle stringhe corrispondente viene utilizzata in un tipo di voce che richiede le doppie virgolette.

La sezione Strings esegue la traduzione delle stringhe per i mercati internazionali più facilmente posizionando tutte le stringhe visualizzabili nell'interfaccia utente quando il file inf viene utilizzato in una sola sezione del file inf. Le chiavi di stringhe devono essere sempre utilizzate qualora sia possibile.

L'esempio seguente mostra la sezione Strings per un file inf di esempio.

[Strings]
String0="Mia Applicazione"
String1="File Leggimi Mia Applicazione"
String2="Scheda SCSI CX2590"

Torna all'inizio del file

Sezione Optional Components

[Optional Components]
nome-sezione-install
[nome-sezione-Install]
.
.
Elenca le sezioni Install visualizzate quando l'utente sceglie l'icona Installazione applicazioni nel Pannello di controllo, fa clic sulla scheda Installazione di Windows, quindi sceglie il pulsante Disco driver. Le sezioni Install sono visualizzate come caselle di controllo nell'elenco.

La sezione Optional Components viene ignorata quando si esegue un file inf facendo clic con il pulsante destro del mouse sul file inf e selezionando il verbo "install". Quando si esegue un file inf in questo modo, viene eseguita la sezione [DefaultInstall]. La sezione Optional Components viene ignorata anche se il file inf viene eseguito per mezzo del punto di ingresso InstallHinfSection di Setupx.dll. Quando si esegue un file inf per mezzo del punto di ingresso SETUPX, viene eseguita la sezione Install specificata nel parametro sul punto di ingresso.

Le sezioni Install seguono lo stesso formato descritto precedentemente. Alla sezione Install è possibile inoltre aggiungere delle chiavi aggiuntive per guidare l'interfaccia nella finestra di dialogo "Disco driver".

OptionDesc=descrizione-opzione
Tip=descrizione-suggerimento
InstallDefault=0 | 1 ; Se installare questo componente in base all'impostazione predefinita. 1=Sì, 0=No.
IconIndex=indice-icona
Parent=nome-sezione-Install
Needs=nome-sezione-Install, [nome-sezione-Install]
Include=file-inf, [file-inf]

descrizione-opzione
Valore della stringa utilizzato come nome del componente nella casella di riepilogo. Il parametro descrizione-opzione può essere %String1%, in cui la stringa che sostituisce %String1% è definita nella sezione Strings del file inf.

descrizione-suggerimento
Valore della stringa visualizzata nella casella Descrizione quando il componente viene selezionato nella casella di riepilogo. Il parametro descrizione-suggerimento ha un limite di 255 caratteri e può essere %String1%, in cui la stringa che sostituisce %String1% è definita nella sezione Strings del file inf.

indice-icona
Valore numerico che determina la mini icona visualizzata accanto al nome del componente. I valori validi sono: 0 Computer (base e schermo)
1 Circuito integrato
2 Schermo
3 Cavi di rete
4 Bandiera di Windows
5 Mouse
6 Tastiera (3 tasti)
7 Telefono
8 Altoparlanti
9 Dischi rigidi
10 Connettore Comm
11 Rombo (valore predefinito)
12 Casella selezionata
13 Casella non selezionata
14 Stampante
15 Scheda di rete
16 Uguale a 0
17 Uguale a 0 w/ con mano per la condivisione
18 Sconosciuto (?)
19 Modello del logo
20 Casella di controllo ombreggiata
21 Accesso remoto
22 Connessione diretta via cavo
23 Sincronia file
24 Exchange
25 Selezione parziale
26 Gruppo Accessori
27 Gruppo Multimedia
28 Anteprima
29 MSN
30 Calcolatrice
31 Utilità di deframmentazione dischi
32 Documento generico
33 DriveSpace
34 Solitario
35 HyperTerminal
36 Packager
37 Paint
38 Screen saver
39 WordPad
40 Visualizzatore Cartella Appunti
41 Accesso facilitato
42 Backup
43 Documento bitmap
44 Mappa caratteri
45 Puntatori Mouse
46 Analizzatore di rete
47 Connessione telefonica
48 Monitor di sistema
49 Libro della Guida
50 Mappamondo (impostazioni internazionali)
51 Compressione audio
52 Lettore CD
53 Lettore multimediale
54 Combinazione di suoni
55 Video clip
56 Compressione video
57 Controllo volume
58 Combinazione di suoni Musica
59 combinazione di suoni Jungle
60 Combinazione di suoni Robotz
61 Combinazione di suoni Utopia

Parent
La casella di riepilogo visualizzata nell'interfaccia dei componenti opzionali può contenere dei sottolivelli. Se il componente opzionale è secondario, la parola chiave Parent= definisce la sezione Install principale.

Needs
Se questo componente dipende da altri componenti, definisce le sezioni Install richieste da questo componente. Se il componente viene selezionato, all'utente verrà segnalato che il componente richiede i componenti descritti nelle sezioni Install elencate nella riga Needs=.

Le sezioni Install elencate nella riga Needs= devono essere le stesse del file inf. Se tuttavia nella riga Needs= sono elencati dei componenti dipendenti da altri file inf, questi ultimi devono essere specificati nella riga Include=.

Include
La voce Include consente di specificare i file inf che il programma di installazione deve caricare in memoria quando carica il file inf dell'utente, poiché questi file inf contengono delle sezioni che devono essere eseguite in aggiunta alle sezioni Install del file inf. La voce Needs specifica i nomi delle sezioni che si desidera eseguire nei file inf inclusi.

Il seguente esempio definisce due sezioni Install relative ai componenti aggiuntivi; ciascuna sezione Install utilizza le voci aggiuntive per specificare gli elementi di interfaccia e le dipendenze:

[Optional Components]
InstallMieiComponenti
InstallaGiochi

[InstallaMieiGiochi]
OptionDesc=%Toys_DESC%
Tip=%Toys_TIP%
IconIndex=35 ;Mini icona a forma di telefono per le finestre di dialogo
Parent=PostaApp
Needs=MSMAIL, MAPI, MicrosoftNetwork
Include=mos.inf, msmail.inf
CopyFiles=FileMieiGiochi
UpdateInis=CollegamentiMieiGiochi
AddReg=VociRegMieiGiochi

[InstallaAltreApp]
OptionDesc=%Other_DESC%
Tip=%Other_TIP%
IconIndex=4 ;Mini icona di Windows per le finestre di dialogo
CopyFiles=AltriFile
UpdateInis=AltriCollegamenti
AddReg=AltreVociReg

[Strings]
Toys_DESC="Utilità Posta"
Toys_TIP="Utilità aggiuntive per l'invio e l'organizzazione della posta"
Other_DESC="Altre utilità utili"
Other_TIP="Calcolatrice, controllo del disco e controllo delle prestazioni"

Torna all'inizio del file


Uso della tecnologia RunOnce

È possibile eseguire tutti i programmi dopo aver eseguito un file inf aggiungendo voci alla chiave di registro RunOnce . Le voci RunOnce la volta successiva al riavvio del computer e dopo che l'utente si connette al sistema (se è possibile l'accesso al sistema).

La chiave di registro Runonce consente di avviare i programmi una volta in Windows e di specificare se devono essere eseguiti in modo invisibile all'utente (senza inviare alcun messaggio all'utente) oppure come parte di un elenco di programmi o di operazioni visibili all’utente. Il riferimento al programma viene quindi eliminato in modo che il programma non venga nuovamente eseguito.

Per eseguire i programmi in modo invisibile all'utente, aggiungere le voci stringa-descrizione=riga-comando alla seguente chiave di registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce

Per eseguire i programmi eseguiti in modo sincrono nel gestore di Windows Runonce, aggiungere le voci stringa-descrizione=riga-comando alla seguente voce di registro:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup

L’esempio seguente mostra una sezione AddReg che provoca quanto indicato:

  • Avvio del file Miaapp.exe (situato nella cartella Windows) senza alcuna interfaccia utente.

    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce,"SilentApp",,"%25%\Miaapp.exe"

  • Avvio del file Test.exe (presente nella cartella System) e visualizzazione del messaggio "Installazione delle seguenti voci":
    HKLM,Software\Microsoft\Windows\CurrentVersion\RunOnce\Setup,"Test Utility",,"%11%\test.exe"

Nota

  • La stringa di descrizione nella chiave di registro del programma di installazione viene visualizzata nell’interfaccia utente.


Esempi di IEAK

Questa sezione contiene script di configurazione, file batch per l'installazione ed un esempio di file .inf per il proxy automatico. Sono inoltre presenti delle immagini che possono risultare utili per approfondire alcuni concetti relativi a Internet Explorer e IEAK.

  • Esempio in JavaScript o JScript di file per il proxy automatico
  • Esempio di file .inf per il servizio di download dei componenti
  • Esempio di file batch per l'installazione
  • Illustrazioni relative ai concetti di IEAK

È inoltre possibile trovare ulteriori esempi, come file di esempio per la creazione di un pacchetto per l'abbonamento basato sul server e pagine per il download e l'installazione di componenti aggiuntivi, nel Toolkit IEAK.


Contenuti di IEAK Toolkit

Il kit di strumenti di IEAK contiene strumenti, programmi e file di esempio che possono essere di grande aiuto per l'utente. Il contenuto del kit di strumenti si trova nella cartella \<Programmi\IEAK>\Toolkit e nelle relative sottocartelle.

Nella cartella del kit di strumenti, è disponibile il file Insref.xls con riferimenti utili per i file isp e ins .

Cartella Addons

Questa cartella contiene pagine di esempio relative al download dei componenti aggiuntivi.

Cartella Corp

Contiene file ins di esempio per la configurazione automatica e script ASP (Active Server Page) personalizzabili. I file asp sono specifici per i server Web che eseguono Internet Information Server 3.0 e versioni successive, ma possono essere visualizzati con un browser qualsiasi.

Cartella Graphics

Contiene immagini di esempio e strumenti.

Cartella Inf

Contiene un file inf di esempio per la creazione di un programma di disinstallazione.

Cartella ISP

Contiene numerosi strumenti ed esempi per fornitori di servizi Internet (ISP):

  • Lo strumento procedura guidata del file ISP configura le informazioni di accesso remoto.
  • Uno strumento che facilita la memorizzazione in memoria cache delle password di ciascun utente, in modo che non debbano essere digitate a ogni accesso.
  • Script di esempio, strumenti e soluzioni personalizzabili per i pacchetti per l'abbonamento Internet, non basata su server, basata su server e su Connessione guidata Internet.


Illustrazioni relative ai concetti di IEAK

I diagrammi seguenti illustrano le funzioni chiave e i concetti di IEAK.

Esperienza dell'utente durante l'installazione di Internet Explorer da un pacchetto generato da IEAK

Installazione di Windows Update per Internet Explorer e Accesso a Internet

Modalità di personalizzazione

Modalità di configurazione automatica

Creazione di un pacchetto tramite IEAK

Creazione di pacchetti personalizzati in IEAK

Sincronizzazione automatica versione

Preparazione dei file per la distribuzione

Abbonamento Internet

Processo di abbonamento ad un l'ISP

Amministratori di reti Intranet

Criteri di protezione e impostazioni


File di esempio del proxy automatico in JavaScript o JScript

Di seguito sono riportati esempi di utilizzo di un file pac per specificare un URL per il proxy automatico. Per utilizzare queste funzioni, è necessario modificare i nomi dei proxy, i numeri di porta e gli indirizzi IP.

Note

  • Le funzioniisInNet, isResolvable, e dnsResolve consentono di effettuare una ricerca in un server DNS.
  • Riferimenti ad oggetti, proprietà o metodi del modello di oggetti provocano un errore nel file di configurazione automatica del proxy. Ad esempio, i riferimenti window.open(...), alert(...), e password(...) provocano un errore nel file di configurazione automatica del proxy su Internet Explorer.

Esempio 1: Gli host locali effettuano la connessione direttamente, tutti gli altri attraverso un proxy

La funzione riportata di seguito verifica che il nome dell'host corrisponda a un host locale e, in caso affermativo, che la connessione sia diretta. Se il nome dell'host non corrisponde a un host locale, la connessione avverrà attraverso il proxy (proxy).

funzione FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

La funzione isPlainHostName controlla se vi sono punti nel nome dell'host. In caso affermativo, restituisce false, altrimenti restituisce true.

Esempio 2: Gli host all'interno del firewall effettuano la connessione direttamente, i server locali all'esterno attraverso un proxy

La funzione riportata di seguito verifica che il nome dell'host non includa il nome del dominio oppure che sia parte di un particolare dominio (.societa.it), ma che non sia né www né home.

function FindProxyForURL(url, host)
  {
    if ((isPlainHostName(host) ||
      dnsDomainIs(host, ".societa.it")) &&
      !localHostOrDomainIs(host, "www.societa.it") &&
      !localHostOrDoaminIs(host, "home.societa.it"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Note

  • La funzione localHostOrDomainIs viene eseguita solo per gli URL del dominio locale.
  • La funzione dnsDomainIs restituisce true se il dominio del nome dell'host corrisponde al dominio dato.

Esempio 3: Se è possibile risolvere l'host, effettuare la connessione direttamente. Altrimenti utilizzare un proxy.

La funzione riportata di seguito richiede al server DNS di risolvere il nome dell'host che gli viene passato. Se questo è possibile, viene effettuata una connessione diretta, in caso contrario attraverso un proxy. Questa funzione risulta utile quando viene utilizzato un server interno DNS per la risoluzione di tutti i nomi interni degli host.

function FindProxyForURL(url, host)
  {
    if (isResolvable(host))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Vedere la nota sulla funzione isResolvable all'inizio della pagina.

Esempio 4: Se l'host si trova nella subnet specificata, effettuare la connessione direttamente. Altrimenti, effettuare la connessione attraverso un a proxy.

La funzione riportata di seguito confronta una maschera e un modello di indirizzo IP specificati con il nome dell'host. Questa funzione è utile quando alcuni host di una subnet devono essere connessi direttamente ed altri attraverso un proxy.

function FindProxyForURL(url, host)
  {
    if (isInNet(host, "999.99.9.9", "255.0.255.0"))
      return "DIRECT";
    else
      return "PROXY proxy:80";
  }

Vedere la nota sulla funzione isInNet all'inizio della pagina.

La funzione isInNet(host, modello, maschera) restituisce true se l'indirizzo IP dell'host corrisponde al modello specificato. La maschera indica quale parte dell'indirizzo IP deve corrispondere (255=ricerca corrispondenza, 0=ignora).

Esempio 5: Determinare il tipo di connessione sulla base del dominio dell'host

La funzione riportata di seguito specifica una connessione diretta se l'host è locale. In caso contrario, la funzione determinerà quale proxy dovrà essere utilizzato a seconda del dominio dell'host. Questa funzione è utile se il nome del dominio dell'host è uno dei criteri di selezione del proxy.

function FindProxyForURL(url, host)
  {
    if (isPlainHostName(host))
      return "DIRECT";
    else if (shExpMatch(host, "*.com"))
      return "PROXY comproxy:80";
    else if (shExpMatch(host, "*.edu"))
      return "PROXY eduproxy:80";
    else
      return "PROXY proxy";
  }

La funzione shExpMatch(str, shexp) restituisce true se, tramite l'utilizzo di modelli di espressione di shell, str corrisponde a shexp.

Esempio 6: Determinare il tipo di connessione sulla base del protocollo utilizzato

La funzione riportata di seguito estrae il protocollo utilizzato e sulla base di questo esegue una selezione di proxy. Se non è possibile trovare una corrispondenza con un protocollo, verrà effettuata una connessione diretta. Questa funzione è utile quando il protocollo utilizzato è uno dei criteri di selezione del proxy.

function FindProxyForURL(url, host)
  {
    if (url.substring(0, 5) == "http:") {
      return "PROXY proxy:80";
    }
    else if (url.substring(0, 4) == "ftp:") {
      return "PROXY fproxy:80";
    }
    else if (url.substring(0, 7) == "gopher:") {
      return "PROXY gproxy";
    }
    else if (url.substring(0, 6) == "https:") {
      return "PROXY secproxy:8080";
    }
    else {
      return "DIRECT";
    }
  }

La funzione substring estrae da una stringa il numero di caratteri specificato.

Esempio 7: Determinare l'impostazione del proxy verificando che il nome dell'host corrisponda all'indirizzo IP

La funzione riportata di seguito effettua la selezione di un proxy convertendo il nome dell'host in un indirizzo IP e confrontandolo con una stringa specificata.

function FindProxyForURL(url, host)
  {
    if (dnsResolve(host) == "999.99.99.999") {  // = http://secproxy
      return "PROXY secproxy:8080";
    }
    else {
      return "PROXY proxy:80";
    }
  }

Vedere la nota sulla funzione dnsResolve all'inizio della pagina.

Esempio 8: Effettuare una connessione attraverso un proxy se l'indirizzo IP dell'host corrisponde a un indirizzo IP specificato, altrimenti effettuare la connessione direttamente

La funzione riportata di seguito consente di effettuare la selezione di un proxy sulla base di un indirizzo IP specificato. A differenza dell'esempio 7, nel quale viene utilizzata la funzione dnsResolve per convertire il nome dell'host nell'indirizzo IP numerico, in questo esempio la funzione viene chiamata per recuperare esplicitamente l'indirizzo IP numerico.

function FindProxyForURL(url, host)
  {
    if (myIpAddress() == "999.99.999.99") {
      return "PROXY proxy:80";
    }
    else {
      return "DIRECT";
    }
  }

La funzione myIpAddress restituisce in formato composto da numeri interi separati da punti l'indirizzo IP dell'host sul quale è in esecuzione il browser.

Esempio 9: Se il nome dell'host contiene punti, effettuare la connessione attraverso un proxy. Altrimenti effettuare la connessione direttamente.

La funzione riportata di seguito verifica il numero dei punti contenuti nel nome dell'host. Se vengono rilevati dei punti, effettuare la connessione attraverso un proxy. In caso contrario, effettuare una connessione diretta. Questa funzione consente di determinare il tipo di connessione sulla base delle caratteristiche del nome dell'host.

function FindProxyForURL(url, host)
  {
    if (dnsDomainLevels(host) > 0) {  // se il numero di punti in host > 0
      return "PROXY proxy:80";
    }
    return "DIRECT";
  }

La funzione dnsDomainLevels restituisce un numero intero uguale al numero di punti contenuti nel nome dell'host.

Esempio 10: Specificare i giorni della settimana in cui effettuare la connessione attraverso un proxy e i giorni in cui effettuare una connessione diretta

La funzione riportata di seguito determina il tipo di connessione specificando i giorni della settimana in cui utilizzare un proxy. Nei giorni non inclusi tra quelli specificati, effettuare una connessione diretta. Questa funzione potrebbe essere utilizzata per impiegare un proxy quando il traffico di dati è intenso e per consentire una connessione diretta quando il traffico è irrilevante.

function FindProxyForURL(url, host)
  {
    if(weekdayRange("WED", "SAT", "GMT"))
      return "PROXY proxy:80";
    else
      return "DIRECT";
  }

La funzione weekdayRange(giorno1 [,giorno2] [,GMT] ) restituisce true se l'ora di sistema corrente si trova all'interno dell'intervallo specificato dai parametri giorno1, giorno2, e GMT. È richiesto solo il primo parametro. Il parametro GMT stabilisce che l'ora debba essere considerata in base all'ora di Greenwich (GMT, Greenwich Mean Time) anziché in base al fuso orario locale.


Esempio di file batch per l'installazione

Esempio di un semplice file Iebatch.txt che indica la cartella di installazione prescelta,
esegue la prima opzione di installazione presente nell'elenco e riavvia automaticamente il computer.

[Welcome]
Display=0

[SetupChoice]
Display=0

[Custom]
Display=0
Mode=0
InstallDir=c:\Int_exp\en

[Download]
Display=0
DownloadDir=c:\Int_exp\download\

[Finish]
Display=0

[Reboot]
Reboot=1

Per ulteriori informazioni, vedere gli argomenti seguenti:

  • Installazione in modalità batch
  • Sintassi del file batch


Risoluzione dei problemi del pacchetto personalizzato

Se il pacchetto personalizzato non funziona in modo corretto, controllare quanto segue:

Problemi nell'installazione di Windows Update

Se l' installazione di Windows Update non viene completata correttamente, è possibile risolvere gli errori relativi utilizzando il file Active Setup Log.txt . Si tratta di un file di registro dell'intero processo di installazione, dal momento dell'esecuzione di IE5Setup.exe fino al completamento del download dell'ultimo file cab.

Una volta eseguito IE5Setup.exe, il file Active Setup Log.txt viene creato nella cartella in cui è installato Windows, in genere C:\Windows. Se esiste già un file Active Setup Log.txt creato da una sessione di installazione di Internet Explorer precedente, tale file verrà rinominato come Active Setup Log.bak.

Il file registro inizia con la data e l'ora in cui è stato avviato il programma di installazione e termina con la data e l'ora del completamento del download dell'ultimo file cab. Nel corso dell'installazione guidata vengono gradualmente aggiunte nuove voci al file registro. Tale file è la fonte di informazioni più completa per determinare in quale momento si è verificato un errore di download e quali sono le conseguenze. La maggior parte delle voci registrate in questo file vengono anche scritte nel registro di configurazione. Tali dati vengono archiviati per consentire il ripristino delle informazioni perdute.

I codici di errore consentono di determinare la fase dell'installazione in cui si è verificato l'errore e la causa. Per informazioni sui codici di errore, vedere Informazioni sul registro errori per Active Setup Log.txt.

Download dei file non eseguibile durante l'installazione di Windows Update.

Il programma di installazione di Windows Update consente di cambiare server durante un'installazione per mantenere la massima velocità di trasmissione dei dati o per ripristinare i dati da un sito di distribuzione che non risponde. Il passaggio da un server a un altro avviene quando il programma di installazione di Windows Update non registra alcuna trasmissione di dati oppure registra una velocità di trasmissione minore di un byte ogni due minuti.

Se una connessione si interrompe, il programma di installazione proverà a connettersi al successivo sito di download dell'elenco e continuerà il processo di installazione a partire dall'ultimo file cab parzialmente scaricato. Se una connessione si interrompe e il programma di installazione non passa a un altro server, proverà a riconnettersi al sito di download e continuerà il processo di installazione dal punto in cui è avvenuta l'interruzione. Se non è possibile stabilire una connessione al sito di download, verrà chiesto se si desidera interrompere l'installazione o riprovare.

Se il primo sito non può essere utilizzato, ad esempio per problemi relativi al server, durante l'installazione di Windows Update non sarà possibile individuare i rimanenti siti in base all'impostazione predefinita. Una soluzione alternativa può essere sovrascrivere il primo sito con il seguente comando:

<percorso>\ie5setup.exe /C:"ie5wzd.exe /S:""<percorso>\ie5setup.exe"" /L:""http://server Web/sito Web/ie5sites.dat"""

dove <percorso> indica la cartella contenente il file IE5setup.exe.

Esempio

Di seguito viene riportato un esempio di sintassi da utilizzare in caso di malfunzionamento del primo sito. Esempio di riga di comando singola, visualizzata mediante tre linee di testo per facilitare la lettura.

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<Indirizzonuovoserver>/<Directorydidownload>/ie5sites.dat """

Modalità di installazione non disponibili agli utenti di Windows 2000

Indipendentemente dalle opzioni di installazione configurate nel pacchetto, Installazione di Windows Update presenta una sola opzione di installazione agli utenti del sistema operativo Windows 2000. L'opzione di installazione include tutti i componenti Internet di Microsoft, insieme a tutti i componenti personalizzati inclusi nel pacchetto.

Non applicabilità delle modifiche nella marcatura eseguite tramite configurazione automatica in Windows°2000

Le modifiche nella marcatura distribuite agli utenti tramite configurazione automatica non vengono applicate se il criterio Nessuna marcatura esterna è impostato in Criteri di gruppo di Windows 2000. Questo criterio non consente la marcatura dei programmi Internet, quali ad esempio la personalizzazione dei logo di Internet Explorer e Outlook Express e le barre del titolo, da parte di terze parti come il provider di servizi o di contenuti Internet. Per ulteriori informazioni, vedere Amministrazione di Microsoft Internet Explorer in Windows 2000.

Se viene disinstallato un pacchetto versione 5.5, sul computer rimarrà Internet Explorer 4 e non Internet Explorer 5

Se il software viene installato o disinstallato seguendo le seguenti operazioni nell'ordine riportato, il computer verrà configurato come segue:

  1. Avviamento di Internet Explorer 4.
  2. Installazione di Internet Explorer 5 da un pacchetto personalizzato IEAK o da altre fonti.
  3. Installazione di Internet Explorer 5.5 da un pacchetto personalizzato IEAK o da altre fonti.
  4. Disinstallazione di Internet Explorer 5.5.

A questo punto, l'installazione di Internet Explorer 4 è completata. Se si intende procedere al suo utilizzo, è necessario reinstallare Internet Explorer 5.

Impossibile installare i componenti

Quando il processo di disinstallazione non viene completato correttamente, lo strumento più importante per risolvere questo tipo di problema è il file registro di disinstallazione, IE5 Uninstall Log.txt, che si trova nella cartella \Windows. In questo file è registrato in sequenza l'intero processo di disinstallazione, comprese le aggiunte o rimozioni di file, le aggiunte, modifiche o rimozioni di voci del registro di configurazione e tutte le finestre di dialogo visualizzate dall'utente.

Il file registro è diviso nelle singole fasi del processo di disinstallazione. Le voci contenute nel file di registro sono identificate da un numero oggetto che corrisponde alla voce della riga in Setup.stf. Le righe prive di numero oggetto corrispondono ad azioni personalizzate specifiche di Internet Explorer e si trovano nel file IE5.inf oppure in un file inf creato dal programma di disinstallazione di un componente esterno.

Se non è possibile utilizzare l'icona Installazione applicazioni nel Pannello di controllo per disinstallare Internet Explorer, è probabile che le informazioni sulla disinstallazione siano state eliminate dal computer. Di seguito sono riportati i file di disinstallazione principali:

  • IE5bak.dat
  • IE5bak.ini
  • Integrated Browser.dat
  • Integrated Browser.ini.

La finestra di dialogo per la disinstallazione avanzata di Internet Explorer consente di disinstallare queste informazioni di backup, impedendo tuttavia la disinstallazione di Internet Explorer in futuro.

Per informazioni sulla disinstallazione dei componenti personalizzati, vedere Inserimento della funzionalità di disinstallazione in una procedura inf e Disinstallazione dei componenti personalizzati.

L'abbonamento a Internet con Internet Connection wizard (ICW) non funziona con la marcatura di un solo dischetto

Se si prevede che alcuni utenti utilizzeranno Internet Explorer 4.01 Service Pack 1 o versione precedente, non ricorrere alla modalità di abbonamento mediante la Connessione guidata Internet in caso di marcatura di un solo dischetto. Per questi utenti è opportuno creare, invece, un pacchetto separato utilizzando abbonamento in modalità tutto schermo.


Risoluzione dei problemi del programma di personalizzazione di Internet Explorer

Se non è possibile individuare alcune delle schermate specifiche del programma di personalizzazione di Internet Explorer, verificare quanto segue.

  • Accertarsi di aver selezionato la qualifica corretta, ossia provider di contenuti Internet (ICP), fornitore di software indipendente (ISV), provider di servizi Internet (ISP) oppure amministratore delle reti intranet.
  • Assicurarsi di aver selezionato il sistema operativo corretto.
  • Nella schermata relativa alla selezione delle caratteristiche accertarsi di aver selezionato tutte le caratteristiche che si desidera personalizzare. Se non viene selezionata la casella di controllo relativa alle singole caratteristica, le schermate corrispondenti non verranno visualizzate.
  • Per la personalizzazione di Outlook Express, verificare di aver scaricato i file di Outlook Express e di aver aggiunto Outlook Express ad almeno una delle opzioni di installazione.

Se si desidera personalizzare Aggiornamento desktop di Windows, è necessario che questo venga eseguito con una delle seguenti configurazioni.

  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition
  • Windows 2000
  • Se si è installato l'Aggiornamento desktop di Windows su altre versioni di Windows, sarà necessario utilizzare Internet Explorer 5.5, aggiornando la versione 4.0.

Nota

  • Se si sta configurando un'installazione invisibile all'utente o si sta eseguendo il programma di personalizzazione di Internet Explorer dall'installazione guidata di Office, alcune delle opzioni di installazione non saranno disponibili.


Informazioni sul registro errori per Active Setup Log.txt

Il file Active Setup Log.txt consente di risolvere i problemi relativi agli errori di installazione di Windows Setup e di identificare lo stato dell'installazione al momento dell'errore. Nel file di registro sono contenute le seguenti voci:

Voce del registro | Significato
0 | Inizializzazione tramite creazione di una cartella temporanea e verifica dello spazio su disco disponibile.
1 | Controllo di tutte le dipendenze.
2 | Download dei file dal server.
3 | Copia dei file dalla cartella di download alla cartella di installazione temporanea.
4 | Riavvio del download e ulteriore tentativo dell'installazione a causa di un errore di timeout o di un altro errore durante il download.
5 | Verifica dell'attendibilità e delle autorizzazioni.
6 | Estrazione dei file.
7 | Esecuzione del programma di installazione (file inf o exe).
8 | Installazione completata.
9 | Download completato. È stato eseguito il download di tutti i file.

Di seguito sono riportati alcuni dei più comuni codici di errore.

Codice di errore | Significato
80100003 | Alcuni file della cartella di download risultano mancanti durante l'installazione.
800bxxxx | Un codice di errore che inizia con 800b indica un errore di attendibilità.
800Cxxxx | Un codice di errore che inizia con 800C indica un errore relativo all'URL.

Esempi

Di seguito sono riportati alcuni esempi.

800C005: Impossibile trovare il file o il server.

800C00B: Tempo di connessione esaurito.

8004004: Installazione interrotta dall'utente.


Glossario

A

abbonamento senza server
Vedere abbonamento.
abbonamento tramite server
Vedere abbonamento.
abbonamento
Una volta che Internet Explorer è stato installato, è possibile usare funzioni di sottoscrizione per completare il processo di registrazione dell'utente. Le procedure di sottoscrizione al server forniscono una grande flessibilità e si adattano dinamicamente a varie opzioni di sottoscrizione, ma richiedono l'uso di script CGI o ActiveX su un server Web. L'abbonamento senza server non richiede un server. Se si seleziona questa opzione, il programma di personalizzazione di Internet Explorer richiederà le informazioni necessarie per controllare il processo di abbonamento.
Accesso remoto
La connessione ad una rete di comunicazione dei dati usando una rete telefonica pubblica invece di un circuito dedicato o un'altra rete privata.
Active Desktop
Uno dei due componenti installati con Aggiornamento desktop di Windows. Active Desktop permette agli utenti di aggiungere un contenuto attivo, ad esempio un programma per controllare i dati di borsa, al desktop, alla barra delle applicazioni o alle cartelle. È inoltre possibile eseguire e aprire i file facendo clic su di essi. Active Desktop può essere disabilitato in Internet Explorer Administration Kit, anche se Aggiornamento desktop di Windows è installato.
Aggiornamento desktop di Windows
Aggiornamento desktop di Windows è costituito da due componenti: Active Desktop e integrazione della shell. Aggiornamento desktop di Windows è incluso in Windows 98, Windows 98 Second Edition, Windows Millennium Edition, e Windows 2000. Questo componente non viene reinstallato in computer sui quali è presente uno di questi sistemi operativi.
Aggiornamento desktop
Vedere Aggiornamento desktop di Windows.
amministratore di reti intranet
Una persona responsabile dell'impostazione e della gestione dei computer e delle applicazioni all'interno della società. Gli amministratori gestiscono inoltre gli account di utenti e gruppi, assegnano le password e i permessi e forniscono assistenza agli utenti per questioni riguardanti la rete.
area autenticazione
Una funzione di Connection Manager Administration Kit che fornisce un prefisso, ad esempio società) o suffisso, ad esempio @società.com ad un nome utente quando si connette a un servizio Connection Manager.
area di protezione
In Internet Explorer, un segmento di Internet o della intranet al quale è stato assegnato un determinato livello di protezione, dipendente dal livello di fiducia dell'amministratore in relazione ai contenuti del sito Web. Le aree di protezione permettono ad un amministratore di limitare l'accesso degli utenti a determinati siti Web.
area
Vedere area di protezione.
assegnazione del numero di versione
Esistono due modi per assegnare un numero di versione a Internet Explorer. A ogni pacchetto Internet Explorer viene assegnato un numero di versione, che può essere imposto in modo che ai pacchetti vecchi non sia possibile sovrascrivere nuove versioni dello stesso pacchetto. Anche ai singoli componenti di Internet Explorer viene assegnato un numero di versione, e questi non vengono scaricati e installati se una versione compatibile esiste sul computer client. Il numero di versione contiene un codice di due lettere che indica la modalità usata per creare il pacchetto IEAK, ossia IC per Provider di contenuti Internet, IS per Provider di servizi Internet e CO per amministratore delle reti intranet.
Authenticode
Una tecnologia che rende possibile identificare la compagnia o la persona che ha pubblicato un determinato software e verifica che non sia stato modificato da quando è stato pubblicato. Gli amministratori delle reti intranet possono preconfigurare aree di protezione, le restrizioni e personalizzare le autorità di certificazione in modo che gli utenti non scarichino software non firmato. L'amministratore può inoltre impostare criteri di protezione e restrizioni per controllare se gli utenti possono modificare o meno le impostazioni di protezione.
autorità di certificazione
Società come VeriSign o GTE che emettono certificati digitali. Tali società hanno la funzione di fonti attendibili, quindi verificano l'autenticità di un certificato usato per firmare e autenticare digitalmente i pacchetti software.

B

barra di avvio veloce
Una barra degli strumenti speciale che si trova vicino al pulsante di avvio, progettata per fornire agli utenti un accesso veloce al Web, alla e-mail, al desktop e ad altri servizi base del sistema, e ai programmi o altre icone frequentemente usate. Questa barra degli strumenti è generalmente riservata per la personalizzazione da parte dell'utente.
barra di Explorer
Il lato sinistro del browser dove vengono visualizzati gli elenchi Cerca, Cronologia e Favoriti quando viene fatto clic sul pulsante corrispondente nella barra degli strumenti. L'utente può inoltre creare sia una barra personalizzata di Explorer che un pulsante personalizzato per aprirla.
bitmap
Formato dei file per le immagini usate per personalizzare la grafica in un pacchetto Internet Explorer Administration Kit.

C

cache
Un'area del disco rigido riservata per la memorizzazione di immagini, testo e altri file precedentemente visualizzati dall'utente su Internet.
canali e categorie
Un canale è un sito Web abilitato per programmi che ricevono informazioni. Questo avviene grazie al file cdf (Channel Definition Format, file di definizione del canale). I canali possono essere organizzati in categorie e posizionati sul desktop dell'utente.
carattere jolly
Un carattere della tastiera che può essere usato per rappresentare uno o più caratteri. L'asterisco (*), ad esempio, rappresenta generalmente uno o più caratteri, mentre il punto interrogativo (?) rappresenta generalmente un singolo carattere. I caratteri jolly vengono spesso usati nei sistemi operativi per specificare il nome di più di un file.
certificato digitale
Una certificazione elettronica emessa da una autorità di certificazione che mostra l'origine di un programma e prova che il pacchetto di installazione non è stato modificato. Gli amministratori devono firmare il loro codice con un certificato digitale se prevedono di distribuire un pacchetto Internet Explorer via Internet.
certificato
Vedere certificato digitale.
chat
Vedere MSN Messenger Service.
chiave del registro
Un identificatore per un record o per un gruppo di record nel registro di configurazione.
client personalizzato del servizio Messenger
Il software client generato quando viene marcato un client MSN Messenger Service per includere il proprio logo grafico, l'URL per il download e altre opzioni personalizzate.
cliente
Vedere utente.
CMAK (Connection Manager Administration Kit)
Uno strumento per la creazione, la modifica e la gestione dei profili di Connection Manager. Connection Manager è il client per la connessione. CMAK è disponibile in Windows 2000 server e in Windows 2000 Administration Kit.
codice di personalizzazione
Un codice di licenza emesso per una società quando viene scaricato Internet Explorer Administration Kit (IEAK). Il codice di personalizzazione non è richiesto per l'installazione di IEAK, ma lo è per la creazione di pacchetti IEAK.
componente aggiuntivo
Un componente che non è incluso nel pacchetto, ma che un utente può installare dopo il completamento di Installazione di Windows Update.
componente personalizzato
Un componente che è possibile includere in un pacchetto personalizzato, in aggiunta ai componenti Internet scaricati da Microsoft usando Sincronizzazione automatica versione (AVS).
componente
L'amministratore può includere diversi componenti Internet di Microsoft e di altre compagnie insieme al browser Internet Explorer. Esempi di componenti sono Outlook Express, Microsoft NetMeeting e MSN Messenger.
configurazione automatica
Un processo che abilita gli amministratori delle reti intranet alla gestione e all'aggiornamento delle impostazioni utente, dei criteri di sistema e delle restrizioni di Microsoft Internet Explorer da una postazione centrale. Un puntatore ad un file di configurazione automatica che può essere impostato manualmente all'interno del browser oppure configurando l'installazione del browser tramite IEAK.
Connection Manager
Un client versatile per la connessione a Internet che è possibile personalizzare usando CMAK.
Criteri di gruppo
In Windows 2000, uno strumento di amministrazione per la gestione di criteri di sistema.
criteri di sistema
Impostazioni che permettono all'amministratore di specificare e controllare come i programmi, le risorse di rete e il sistema operativo si comportano in relazione agli utenti e ai computer della società.
criteri
Vedere criteri di sistema.
crittografia
Un metodo per rendere indecifrabili i dati al fine di proteggerli da visione o uso non autorizzati.

D

DHCP (Dynamic Host Configuration Protocol)
Un protocollo standard industriale TCP/IP che assegna configurazioni IP ai computer. Il computer server DHCP effettua le assegnazioni e il computer client chiama il server per ottenere l'indirizzo.
distribuzione
Il processo di distribuzione e di installazione di un programma esteso ad una intera società. La distribuzione non è la stessa cosa di un "pilota", dove il programma viene fornito ad un ristretto gruppo di utenti per identificare e valutare problemi che potrebbero verificarsi durante la vera distribuzione.
DNS (Domain Name System)
Un insieme di indicazioni e di regole sviluppate dall'intera comunità Internet, che permette l'esplorazione sia mediante l'uso di nomi di domini, ad esempio bluestem.prairienet.org, che di indirizzi IP, ad esempio 192.12.3.4. Il nome di dominio è usato da utenti umani e viene automaticamente tradotto nell'indirizzo IP numerico, che viene usato dal software di routing dei pacchetti.

E

esecuzione automatica
Vedere schermata di esecuzione automatica da CD.

F

file adm (modelli dei criteri di protezione)
Un file che definisce i criteri di protezione e le restrizioni che è possibile impostare per il desktop, per la shell e per la protezione del sistema. Vedere criteri di protezione.
file batch (bat)
Un file di testo ASCII contenente una sequenza di comandi del sistema operativo, inclusi parametri e operatori supportati dal linguaggio di comandi batch. Quando l'utente digita il nome del file batch dal prompt dei comandi, il computer elabora i comandi in modo sequenziale.
file cab
Una libreria di file compressi per l'installazione memorizzati in un singolo file, usati per ridurre le dimensione e il relativo tempo di download da un sito Web in Internet o da un server intranet della società. IEAK contiene strumenti per la preparazione di pacchetti personalizzati in uno o più file cab che possono essere inclusi nel pacchetto IEAK.
file inf (information file)
Un file che fornisce a Installazione di Windows Update per Internet Explorer 5 e Accesso a Internet le informazioni necessarie per l'impostazione di un dispositivo o di un programma. Il file include un elenco di configurazioni valide, i nomi dei file dei driver associati al dispositivo o programma e così via.
file ins (Internet settings file)
Un file che fornisce a Installazione di Windows Update le impostazioni per Internet usate per configurare il browser e i componenti associati. È possibile creare più versioni del pacchetto browser modificando il file ins usato da ogni pacchetto. Usare Gestione profili di IEAK per creare, salvare e caricare i file ins.
file script
Vedere script del proxy automatico.
filigrana
Una bitmap visualizzata sotto alla barra degli strumenti di Internet Explorer. Colorare la filigrana in modo che non copra il testo o la grafica dei pulsanti della barra degli strumenti.
firma del codice
Il processo di firma di un pacchetto Internet Explorer completo con un certificato digitale. La firma di un pacchetto richiede due prerequisiti: un certificato digitale e la firma del codice.
firma digitale
Un metodo di autenticazione personale basato sulla crittografia e su codici di autorizzazione segreti usato per "firmare" documenti elettronici.

G

gateway
Un computer connesso a più reti fisiche che hanno la capacità di routing o di recapito dei pacchetti al loro interno.
Gestione profili
Uno strumento in Internet Explorer Administration Kit usato da amministratori delle reti intranet per la creazione e la gestione dinamica delle impostazioni di configurazione automatica del browser e del desktop.
gruppo pilota
Un campione rappresentativo di computer destinati ad uso lavorativo usati per provare un pacchetto Internet Explorer prima della distribuzione all'intera società. A differenza di un gruppo laboratorio, un gruppo pilota si basa su computer e utenti in un contesto lavorativo.
GUID
Un identificatore univoco globale (GUID) distingue un programma od oggetto da un altro. Quando si usa Internet Explorer Administration Kit, è possibile generare un GUID per ogni componente personalizzato. Il numero è basato su informazioni di sistema e altri parametri, ad esempio l'ora del giorno. Se nel computer è installata una scheda di rete con indirizzo hardware a 48 bit IEEE, questo indirizzo univoco globale è incorporato nella GUID. In caso contrario, verrà creato uno pseudo indirizzo casuale sulla base delle informazioni relative allo stato del computer.

H

home page
Nel contesto di Internet Explorer, la home page è la pagina iniziale che viene visualizzata quando l'utente avvia il browser. "Home page" è inoltre un termine più generale per la pagina principale di un sito Web, che generalmente contiene un menu principale o un indice che contiene collegamenti al ad altre pagine all'interno del sito.
HTML (Hypertext Markup Language)
Il linguaggio usato per creare e progettare pagine Web. HTML è un insieme di tag che gli autori di pagine Web usano per creare il layout della pagina, formattare il testo, inserire immagini e oggetti multimediali e altro ancora.
HTML dinamico
Un'insieme di funzioni che estendono le capacità dell'HTML tradizionale, fornendo maggiore flessibilità, opzioni di progettazione e controllo creativo ai creatori di pagine Web per quel che riguarda l'aspetto e il comportamento della pagine stesse.
HTTP (Hypertext Transfer Protocol)
Un protocollo che rende disponibili informazioni ipertestuali, ad esempio pagine Web, su Internet quando un browser Web è connesso ad un server appropriato.

I

ICP (Internet content provider)
Una organizzazione che prepara i contenuti di pagine da mettere sul Web.
ICW (Internet Connection wizard)
Uno strumento che aiuta gli utenti a effettuare l'abbonamento ai servizi Internet e gestisce automaticamente i passi necessari per la configurazione del software per avere l'accesso a Internet. Gli ISP possono personalizzare e preconfigurare Connessione guidata Internet in relazione alle esigenze dei propri clienti.
IEAK
Vedere Internet Explorer Administration Kit.
IMAP (Internet Message Access Protocol)
Un protocollo molto usato per la ricezione di messaggi e-mail. Permette ad un client e-mail di accedere e manipolare un file e-mail remoto senza scaricarlo sul computer locale. Viene usato principalmente da utenti di società che desiderano leggere la loro e-mail da una postazione remota. Confrontare con POP3.
impostazioni di connessione
Impostazioni usate da Internet Explorer per la connessione a Internet. Le impostazioni per la connessione sono generalmente un insieme di impostazioni per le voci di Accesso remoto, ad esempio impostazioni per il proxy, account e password e configurazioni del modem.
indirizzo IP (Internet Protocol address)
L'indirizzo numerico di un computer. Alcuni ISP forniscono agli utenti l'indirizzo IP del loro server. Se non si è sicuri della necessità o meno di immettere un indirizzo IP, contattare il proprio provider di servizi Internet.
indirizzo
In riferimento a Internet, il nome di un sito Web al quale gli utenti possono connettersi, ad esempio www.microsoft.com, o l'indirizzo di un destinatario e-mail, ad esempio nome@società.com. Un tipico indirizzo inizia con il nome di un protocollo, ad esempio ftp:// o http://, seguito dal nome dell'organizzazione che gestisce il sito. Il suffisso identifica il tipo di organizzazione. Ad esempio, gli indirizzi dei siti commerciali terminano spesso in com.
installazione automatica
Vedere installazione su richiesta.
Installazione di Windows Update
Il programma di installazione che installa Internet Explorer e altri componenti Internet. IEAK rende possibile la personalizzazione di Installazione di Windows Update in modo da poter facilitare gli utenti.
installazione in modalità batch
Esecuzione del programma di installazione da un comando contenuto in un file batch o direttamente da un prompt dei comandi.
installazione interattiva
Configurare Installazione di Windows Update in modo che venga richiesto agli utenti di effettuare delle scelte durante l'installazione. Questa opzione è disponibile solo per gli amministratori delle reti intranet. Confrontare installazione visibile all'utente, installazione invisibile all'utente.
installazione invisibile all'utente
Configurare Installazione di Windows Update in modo che non venga richiesto agli utenti di prendere decisioni relative alle opzioni di installazione e che non vengano informati sullo stato dell'installazione e sugli errori. Questa opzione è disponibile solo per gli amministratori delle reti intranet. Confrontare installazione visibile all'utente, installazione interattiva.
installazione su richiesta
Una funzione che richiede all'utente di installare componenti non presenti sul computer, quando si visualizza una pagina Web che richiede quel componente. IEAK permette di limitare la disponibilità di questa funzione agli utenti.
installazione visibile all'utente
Configurare Installazione di Windows Update in modo che non venga richiesto agli utenti di prendere decisioni e che vengano informati sullo stato dell'installazione e sugli errori. Questa opzione è disponibile solo per gli amministratori delle reti intranet. Confrontare installazione invisibile all'utente, installazione interattiva.
integrazione della shell
Uno dei due componenti installati con Aggiornamento desktop di Windows. L'integrazione della shell abilita gli utenti all'esplorazione del computer con le stesse modalità di quella sul Web. I menu Vai e Preferiti vengono incontrati spesso.
Internet Explorer Administration Kit (IEAK)
Un insieme di strumenti che abilitano amministratori delle reti intranet, ISP e ICP alla creazione, alla distribuzione e alla gestione dei pacchetti personalizzati di Internet Explorer in una società. IEAK contiene il programma di personalizzazione di Internet Explorer, Gestione profili di IEAK e il Toolkit IEAK.
ISDN (Integrated Services Digital Networking)
Un sistema di comunicazione digitale mondiale, disponibile tramite la maggior parte delle compagnie telefoniche. ISDN viene usata per comunicazioni ad alta velocità per Internet, sevizi commerciali in linea o reti intranet.
ISV (independent software vendor)
Uno sviluppatore di software esterno, un individuo o una società che crea software per computer in modo indipendente.

J

K

L

laboratorio
Un insieme di computer non destinati ad usi lavorativi usati per provare il pacchetto Internet Explorer. Il gruppo laboratorio non è la stessa cosa di un gruppo pilota.
LDAP (Lightweight Directory Access Protocol)
Uno standard aperto per la memorizzazione e il recupero di nomi, indirizzi e-mail, numeri di telefono e altre informazioni relative a persone. La Rubrica di Windows supporta LDAP per l'accesso ai servizi di elenchi in linea e ha integrato l'accesso ad alcuni dei servizi più diffusi. Gli amministratori possono specificare un servizio aggiuntivo per i loro utenti.

M

marcatura di un solo dischetto
La personalizzazione di una installazione esistente di Internet Explorer, inclusa la sottoscrizione Internet per gli ISP, senza la reinstallazione di Internet Explorer. Questa opzione non abilita all'inserimento nel pacchetto e alla relativa installazione di componenti personalizzati.
marcatura
Personalizzazione del browser Internet Explorer e dei relativi componenti, dell'installazione guidata di Windows Update e della schermata di esecuzione automatica del CD con l'identificativo della società, i logo, le impostazioni e le informazioni di configurazione. La marcatura di un'installazione differenzia il pacchetto di una società da una installazione generica di Internet Explorer.
MIME (Multipurpose Internet Mail Extensions)
Uno standard che estende il protocollo SMTP per permettere la trasmissioni di dati come video, suoni e file binari attraverso Internet senza che sia necessaria la conversione dei dati in formato ASCII.
modalità
Un sottoinsieme di funzionalità nel programma di personalizzazione di IEAK, basato sui requisiti di licenza d'uso della società. Le tre modalità nel programma di personalizzazione sono Provider di contenuti Internet, Provider di servizi Internet e amministratore delle reti intranet. Il numero di versione del pacchetto creato contiene un codice di due lettere che indica la modalità usata per creare il pacchetto IEAK, ossia IC per Provider di contenuti Internet, IS per Provider di servizi Internet e CO per amministratore delle reti intranet.
MSN Messenger Service
Un servizio di messaggistica in tempo reale di Microsoft, usato per comunicare con altre persone via Web. MSN Messenger Service Client, o una sua versione personalizzata, può essere integrato con il pacchetto browser, oppure può essere distribuito come singolo eseguibile per l'installazione.

N

nessun abbonamento
Un'installazione ISP progettata per i provider che supportano i modem via cavo. Tale installazione non include Connessione guidata Internet e non è richiesto all'utente di completare il processo di abbonamento al servizio dopo l'installazione sul computer di Internet Explorer.
newsgroup
Vedere Usenet.
NNTP (Network News Transfer Protocol)
Il protocollo usato per distribuire messaggi di news ai server associati e ai client, ossia i lettori di news, su Internet.
nome di dominio
Nome della connessione di rete usata dal DNS che definisce il proprietario di tale società in formato gerarchico: server.società.tipo. Ad esempio, www.whitehouse.gov identifica il server Web alla Casa Bianca, parte del governo degli Stai Uniti. In un indirizzo e-mail, il nome del dominio si trova dopo il simbolo "@".

O

P

pacchetto di abbonamento
Un insieme di pagine HTML che raccolgono dai clienti le informazioni di sottoscrizione e le trasferiscono, su richiesta, al server di sottoscrizione dell'ISP. La sequenza di pagine guida il cliente per la durata del processo di abbonamento, in modo simile alla procedura guidata di un programma Windows.
pacchetto personalizzato
Contiene versioni personalizzate di tutti gli strumenti di installazione, il codice del browser e i componenti aggiuntivi necessari per rendere velocemente disponibile alla società Internet Explorer.
pacchetto
Un insieme di codice d'installazione personalizzato per Internet Explorer. Un pacchetto contiene tutto il codice e i file necessari per l'installazione, la configurazione e l'uso di Internet Explorer. Internet Explorer Administration Kit può configurare i pacchetti per diversi tipi di supporti d'installazione. Vedere anche pacchetto personalizzato.
pagina di benvenuto
La pagina visualizzata la prima volta che l'utente esegue Internet Explorer. Le volte successive, Internet Explorer visualizza la pagina iniziale dell'utente ogni volta che l'utente avvia il browser.
pagina iniziale in modalità a tutto schermo
Una pagina in modalità tutto schermo, nella quale non sono visualizzate la barra degli strumenti del browser e la barra dei menu, che viene visualizzata dopo l'installazione da parte dell'utente di Internet Explorer.
Passport
Un servizio di autenticazione via Web fornito da Microsoft. Un Passport viene usato per il collegamento a MSN Messenger Service oppure ad un client di Messenger Service personalizzato.
percorso del file
La posizione fisica dei file di distribuzione su un server Web. Ad esempio, "C:\inetpub\wwwroot\ie5\download."
percorso Web
Nel contesto di Internet Explorer Administration Kit, il percorso Web è il percorso usato per connettere un browser ai file di installazione di Internet Explorer. Ad esempio, "www.miasocietà.com/ie5."
piattaforma
Un tipo di client, ad esempio Windows 2000, Windows NT 4.0, Windows Millennium Edition, Windows 98, Windows 3.x, Macintosh o UNIX.
PICS (Parental Internet Content Selection)
Regole che abilitano i fornitori di contenuti Web all'uso di meta tag per la classificazione volontaria del contenuto in base al criterio approvato PICS. I browser possono impedire all'utente l'accesso al sito Web in base al valore delle tag. Vedere anche restrizioni sul contenuto.
POP3 (Post Office Protocol 3)
Un protocollo molto usato per la ricezione di messaggi e-mail. Questo protocollo viene spesso usato dagli ISP. I server POP3 permettono l'accesso a cartelle Posta in arrivo singole, a differenza dei server IMAP che forniscono l'accesso a più cartelle sul lato server. Confrontare con IMAP e SMTP.
Preferiti
Collegamenti predefiniti a siti Web. I Preferiti sono anche conosciuti come "segnalibri". I Preferiti in Internet Explorer possono essere configurati per avvisare automaticamente l'utente quando i contenuti del sito sono stati modificati.
profilo di Connection Manager
Un modo per automatizzare una connessione telefonica, simile alle voci di accesso remoto.
Programma di personalizzazione guidata di Internet Explorer
Il componente primario di Internet Explorer Administration Kit, usato per generare una versione personalizzata di Internet Explorer per l'installazione in una specifica società.
programma di personalizzazione guidata
Vedere Programma di personalizzazione guidata di Internet Explorer.
Provider di servizi Internet (ISP)
Una società che gestisce un server connesso direttamente a Internet. Gli utenti che non sono direttamente connessi a Internet, generalmente si connettono tramite un provider di servizi. Per ottenere queste connessioni, gli utenti contattano il provider e impostano un account.
proxy automatico
Una funzione che permette ad un amministratore di configurare Internet Explorer in modo che il browser determini dinamicamente se effettuare una connessione diretta al server o se usare un server proxy.

Q

R

RAS (Remote Access Service)
Un servizio che fornisce servizi di rete remoti per il telelavoro e per gli amministratori delle reti intranet che controllano e gestiscono i server.
registro di configurazione
Un database gerarchico centrale usato per memorizzare informazioni sulla configurazione del computer di uno o più utenti, applicazioni e dispositivi hardware. Il registro di configurazione contiene informazioni alle quali il sistema operativo fa continuamente riferimento durante l'uso, ad esempio profili per ogni utente, le applicazioni installate sul computer e i tipi di documenti che ognuna di esse può creare, la finestra delle proprietà delle impostazioni delle cartelle e delle icone delle applicazioni, l'hardware esistente nel sistema e quali porte sono in uso.
restrizioni sul contenuto
Microsoft Internet Explorer permette agli amministratori di controllare il tipo di contenuti ai quali il computer può accedere su Internet. L'amministratore può regolare le impostazioni per i contenuti relativi a linguaggio, scene di nudo, sesso e violenza. Vedere anche PICS.
ricerca automatica
Una funzione di Internet Explorer che abilita gli utenti a digitare una parola di uso convenzionale nella barra degli Indirizzi per ricercare pagine frequentemente usate. Non è necessario che gli utenti ricordino l'URL esatto di tali pagine.
Riquadro informazioni di Outlook Express
Un'area dove i provider di contenuti possono inserire informazioni utili e collegamenti. Gli amministratori possono personalizzare questo riquadro inserendo i numeri del servizio tecnico, le domande frequenti, ossia le FAQ, e informazioni sulla società.
riquadro informazioni
Vedere Riquadro informazioni di Outlook Express.
risoluzione del nome
Il procedimento usato nella rete per risolvere l'indirizzo di un computer come nome dello stesso. La risoluzione del nome abilita i computer alla ricerca di altri computer nella rete e al relativo collegamento ad essi.

S

schermata di esecuzione automatica da CD
Schermata visualizzata automaticamente quando un CD di installazione di Internet Explorer viene inserito in una workstation. La schermata di esecuzione automatica del CD è generalmente composta da un pulsante "Installazione di Internet Explorer 5.5", da un pulsante "Annulla" e da una immagine personalizzabile.
script del proxy automatico
In IEAK, i file in formato JScript (js), JavaScript (jvs) o configurazione del proxy automatico (pac) che abilitano alla configurazione e alla gestione di impostazioni avanzate del proxy. Se è stato specificato un file script del proxy automatico, Internet Explorer usa tale file per determinare dinamicamente se effettuare una connessione diretta al server o se usare un server proxy.
Secure Password Authentication (SPA)
Un protocollo nel quale il server usa una password crittata per verificare l'identità dell'utente.
Server di abbonamento a Internet (ISS)
Un server HTTP che automatizza l'aggiunta di nuovi clienti al relativo database di un ISP. Il server di abbonamento a Internet raccoglie le informazioni da ogni cliente, le aggiunge al database clienti dell'ISP e poi invia al computer del cliente un pacchetto di configurazione. Il pacchetto di configurazione contiene informazioni utili per la configurazione del browser affinché il cliente possa connettersi successivamente ai servizi offerti dal provider.
server DNS
Un computer gestito da un ISP che fa corrispondere gli indirizzi IP ai nomi dell'host. Alcuni ISP forniscono un indirizzo DNS specifico.
server IMAP
Un server che usa IMAP per fornire accesso a più cartelle sul server. Confrontare con server POP3.
server per l'abbonamento
Vedere server per l'abbonamento a Internet.
server POP3
Un server che fornisce l'accesso a singole cartelle Posta in arrivo. Confrontare con server IMAP.
server proxy
Un componente del firewall che gestisce il traffico Internet per e da una rete locale (LAN) e che può fornire altre funzioni, ad esempio la cache dei documenti e il controllo dell'accesso. Un server proxy può migliorare le prestazioni fornendo dati richiesti con frequenza, ad esempio pagine Web molto usate, e può filtrare e scartare le richieste che il proprietario non considera appropriate, ad esempio richieste di accesso non autorizzate a file riservati. Le impostazioni del proxy possono essere effettuate automaticamente come parte del pacchetto Internet Explorer Administration Kit.
servizio di download dei componenti di Internet
Un servizio di sistema per il download e l'installazione di software da siti Web Internet e intranet. Questo servizio fornisce anche la funzione di controllo dei certificati. Il download dei componenti Internet è supportato da Microsoft Internet Explorer 3.0 e successivi.
Sincronizzazione automatica versione (AVS)
Una tecnologia che controlla automaticamente se esistono versioni aggiornate di ogni componente di Internet Explorer ogni volta che Internet Explorer Administration Kit (IEAK) viene eseguito. I componenti aggiornati possono essere scaricati da Microsoft e inclusi nei pacchetti IEAK successivi.
sito di download
Un server HTTP o FTP dal quale gli utenti possono scaricare il pacchetto. Se si verifica un time out durante la connessione, il programma d'installazione di Windows Update tenta la connessione al sito di download successivo, specificato nel file IE5Sites.dat, per continuare il processo di installazione all'inizio del file .cab.
SMTP (Simple Mail Transfer Protocol)
Un protocollo usato per il trasferimento o l'invio di messaggi e-mail fra server. Un altro protocollo, ad esempio POP3, viene usato per recuperare i messaggi. Vedere POP3.
SSL (Secure Sockets Layer)
Un protocollo che permette il trasferimento dei dati in modo sicuro tramite crittazione e decrittazione dei dati. Questo protocollo abilita la riservatezza delle comunicazioni nella rete tramite una combinazione di chiavi di crittografia pubbliche e crittografia dei dati
stringa agente utente
Testo che identifica la versione specifica e l'origine del browser.
supporto
Supporto fisico usato per memorizzare informazioni elettroniche. I supporti generalmente scelti per la distribuzione del pacchetto IEAK sono CD-ROM, download via Web o dischi floppy.

T

TCP/IP (Transmission Control Protocol/Internet Protocol)
Un insieme di protocolli di comunicazione che permettono ai computer di dialogare tra di loro.
testo della barra del titolo
Il testo nella parte alta di una finestra di programma. Il testo nella barra del titolo può essere personalizzato in diversi componenti di un pacchetto Internet Explorer, inclusi il browser stesso, la schermata dell'esecuzione automatica del CD-ROM, Outlook Express e MSN Messenger Service.

U

URL (Uniform Resource Locator)
Un indirizzo Web, ad esempio "http://www.microsoft.com". Vedere indirizzo.
URL di configurazione automatica
La posizione del file delle impostazioni Internet, ossia il file ins, usato per configurare il browser in questo pacchetto. Usare il file ins per controllare le impostazioni di diversi utenti da una postazione centrale.
URL di configurazione del proxy automatico
La posizione del file script del proxy automatico. Modificando questo file, è possibile controllare le impostazioni proxy di diversi utenti da una postazione centrale.
Usenet
I gruppi Usenet sono denominati anche newsgroup. Sono newsgroup testo che hanno la funzione di servizi BBS nei quali è permessa la scrittura a tutti gli utenti.
utente finale
Vedere utente.
utente
La persona che installa Internet Explorer e altri componenti di un pacchetto personalizzato IEAK su un computer.

V

visualizzazione Web delle cartelle
Gli amministratori possono personalizzare la modalità di visualizzazione sui computer della società di Risorse del computer e del Pannello di controllo, personalizzando i file HTTP utilizzati come modelli per questo scopo. Visualizzazione Web delle cartelle richiede l'installazione di Aggiornamento desktop di Windows.

W

Web Proxy AutoDiscovery (WPAD)
Un protocollo di rete standard usato per rendere possibile la ricerca automatica e l'interfacciamento di un software client Internet con i servizi di cache di una rete.
WINS (Windows Internet Name Service)
Un servizio di risoluzione del nome che risolve i nomi dei computer di una rete Windows in indirizzi IP in un ambiente a indirizzamento. Un server che usa questo servizio gestisce le registrazioni dei nomi, le query e i rilasci.

X

Y

Z


Download e distribuzione del pacchetto del browser personalizzato

Dopo avere scelto il pulsante Fine, la procedura guidata crea automaticamente il pacchetto del browser personalizzato. Nella maggior parte dei casi, le fasi successive saranno la preparazione dei file per il download tramite Web e quindi la preparazione di altri supporti, ad esempio dei compact disc, per la distribuzione del prodotto. Per ulteriori informazioni sui tipi di supporti, vedere Selezione del supporto.

I programmi e i file cabinet distribuiti tramite Internet o una rete intranet che non sia specificamente configurata, devono disporre della firma digitale. Le firme digitali indicano la provenienza del programma e verificano che i programmi non siano stati alterati. Per ulteriori informazioni, vedere Firma dei programmi. Se si è specificato che il programma di personalizzazione di Internet Explorer deve applicare la firma ai programmi, tale azione viene eseguita durante la compilazione del pacchetto. Se l’opzione non è stata specificata, sarà necessario firmare manualmente questi file prima di consentire il download agli utenti.

Le fasi da intraprendere in seguito per la distribuzione del pacchetto personalizzato variano in base al ruolo dello sviluppatore e al supporto utilizzato per la distribuzione del pacchetto. Per ulteriori informazioni, fare clic su uno dei seguenti collegamenti.

  • Provider di contenuti Internet (ICP) o Sviluppatore
  • Provider di servizi Internet (ISP)
  • Amministratore delle reti intranet


Definizione di file cab

Un file cab è una libreria di file compressi memorizzati come un unico file. I file cab vengono usati per organizzare i file di installazione che vengono copiati sul sistema dell'utente. Un file compresso di grandi dimensioni può essere suddiviso in più file cab.

Per diversi anni i file cab sono stati utilizzati per comprimere software distribuito su dischi floppy. In origine, tali file venivano utilizzati per ridurre il numero di dischi floppy forniti con il prodotto. Attualmente vengono utilizzati per ridurre le dimensioni del file e il relativo tempo di download del contenuto Web che si trova su Internet o sui server della rete intranet della società.

I file presenti nel file cab sono generalmente file di informazioni (inf) che forniscono ulteriori dati di installazione. Il file inf può fare riferimento ad altri file presenti nel file cab, così come a file di altri URL.

IEAK contiene un insieme di strumenti per la creazione di file cab e per l'utilizzo della tecnologia IExpress.

Formato cab

Ciascun file compresso in un file cab viene interamente memorizzato all'interno di una singola cartella. Un file cab può contenere una o più cartelle o parti di esse. Per questo motivo, un file compresso con dimensioni superiori a quelle di un file cab verrà memorizzato all'interno di una cartella che occupa più file cab. Questa serie di file cab forma un insieme. Ogni file cab contiene le informazioni sul nome per i file cab logicamente adiacenti.

Il formato cab usato per il download di componenti di Internet Explorer da Internet è un formato non proprietario basato sulla compressione Lempel-Ziv.

Firme digitali

Un file cab può essere firmato digitalmente come un controllo ActiveX. Una firma digitale fornisce una referenza per gli sviluppatori di software e associa il nome di un fornitore di software ad un determinato file. Una firma può essere apposta ad un file cab usando tecnologia Authenticode™.

I file cab consentono di accrescere l'esperienza degli utenti. A questi ultimi sarà infatti consentito scaricare più file, ma riceveranno un unico certificato. Informazioni su questa tecnologia sono disponibili sul sito MSDN Online Web Workshop.

Se un controllo viene contrassegnato come "sicuro per la procedura", gli utenti saranno informati del fatto che tale controllo non potrà essere utilizzato da una procedura contenuta in una pagina HTML per danneggiare il sistema o per ottenere informazioni che gli utenti non desiderano fornire.

Se un controllo viene contrassegnato come "sicuro per l'inizializzazione", gli utenti saranno informati del fatto che un autore di pagine HTML non sarà in grado di danneggiare il computer fornendo dati non validi per il controllo al momento dell'inizializzazione.

Nota

  • Gli strumenti per la firma del codice consentono di autenticare interi file cab usando un certificato digitale.


Uso dei canali

Grazie ai canali di Internet Explorer, è possibile specificare cosa scaricare e quando eseguire il download. È possibile fornire le ultime notizie e le informazioni su una società. Per gli utenti che aggiornano Internet Explorer 4 o che utilizzano Windows 98, è possibile visualizzare i canali in una barra sul desktop.

Un canale è un sito Web abilitato per programmi che ricevono informazioni. Questo avviene grazie al file cdf (Channel Definition Format, file di definizione del canale). Per i canali è possibile utilizzare contenuti dei quali già si dispone, ad esempio pagine Web e grafica. È possibile organizzarli in maniera differente per essere sicuri che gli utenti ricevano la giusta quantità di contenuti in modo organizzato.

Se si creano canali per più sistemi operativi, assicurarsi che i contenuti siano corretti e leggibili per tutte le piattaforme.

File di definizione del canale (cdf)

Il file cdf fornisce un indice di risorse disponibili nel canale e una pianificazione consigliata degli aggiornamenti dei canali sul computer locale. Un file cdf contiene tag che specificano i logo, i file da aggiornare e la pianificazione degli orari per aggiornarli.

Se il file cdf contiene un ABSTRACT per ciascun elemento del canale, sarà possibile visualizzare una descrizione di questi elementi. Quando il puntatore del mouse viene posizionato su un elemento, le informazioni dell'Abstract vengono visualizzate nella descrizione del comando. Gli autori di siti Web possono usare questa funzione per descrivere il contenuto di una particolare pagina Web o per attirare l'attenzione degli utenti e incoraggiarli a vederne immediatamente il contenuto.

Nota

  • Quando si specifica un file cdf per un canale personalizzato in IEAK, il file cdf non deve contenere l'elemento LOGO con l'attributo IMAGE o ICON.

Risorse ulteriori

Il formato cdf è basato sul linguaggio XML (eXtensible Markup Language), un linguaggio standard per la memorizzazione e la trasmissione di dati strutturati. Come per l'HTML, un documento XML contiene un testo annotato con tag. Per ulteriori informazioni ed esempi, consultare il sito MSDN Online Web Workshop.


Diagramma dei Criteri di protezione e delle impostazioni

 Criteri di protezione e impostazioni


Diagramma di Installazione di Windows Update

 Installazione di Internet Explorer


Diagramma del processo di abbonamento ad un ISP

 Processo di abbonamento ad un l'ISP


Diagramma del processo di personalizzazione

 Processo di personalizzazione


Diagramma di Sincronizzazione automatica versione

 Sincronizzazione automatica versione


Diagramma della modalità di configurazione automatica

 Modalità di configurazione automatica


Diagramma sulla preparazione dei file per la distribuzione

 Preparazione dei file per la distribuzione


Diagramma sulla creazione di pacchetti personalizzati in IEAK

 Creazione di pacchetti personalizzati in IEAK


Abbonamento a Internet tramite Connessione guidata Internet

Internet
Provider di servizi

Creazione delle schermate per l'abbonamento tramite ICW

Ognuna delle schermate in Connessione guidata Internet deve soddisfare gli standard descritti in Requisiti di codifica delle schermate di Connessione guidata Internet.

Creazione della schermata del nome e dell'indirizzo per l'abbonamento tramite Connessione guidata Internet

Quando l'utente si connette al server per l'abbonamento, la prima pagina visualizzata è quella del nome e dell'indirizzo.

La sezione HTML del nome e dell'indirizzo viene visualizzata in un frame all'interno della procedura guidata. Le dimensioni del frame sono di 444 x 273 pixel. Se la pagina HTML supera queste dimensioni, le barre di scorrimento non vengono visualizzate.

Creazione della schermata delle opzioni di pagamento per l'abbonamento tramite Connessione guidata Internet

Nella pagina delle opzioni di pagamento è possibile visualizzare le opzioni per il pagamento del servizio tra le quali l'utente può scegliere. Le opzioni vengono presentate utilizzando un modulo HTML all'interno di un frame nella finestra della procedura guidata.

L'utente potrà selezionare l'opzione desiderata utilizzando il relativo pulsante di opzione HTML. Come impostazione predefinita, uno dei pulsanti deve essere selezionato. Se fosse necessario per l'utente eseguire più selezioni, nel frame è possibile includere anche caselle di controllo HTML.

Il file HTML delle opzioni di pagamento viene visualizzato in un frame mobile all'interno della procedura guidata. Le dimensioni del frame sono di 444 x 273 pixel. Se la pagina HTML supera queste dimensioni, le barre di scorrimento non vengono visualizzate.

Creazione della schermata del metodo di pagamento per l'abbonamento tramite Connessione guidata Internet

Nella pagina del metodo di pagamento, l'utente specifica il metodo di pagamento desiderato per il servizio Internet. Ogni ISP controlla quali metodi di pagamento rendere disponibili nell'elenco. L'informazione viene raccolta nel modulo che appare nel frame sottostante la selezione, che varia a seconda del metodo di pagamento selezionato nell'elenco.

I metodi di pagamento offerti sono di vario tipo.

  • Carta di credito. È possibile specificare il tipo di carta, ad esempio Visa o American Express
  • Carta di addebito
  • Fattura
  • Addebito su bolletta telefonica

Creazione della schermata di accesso all'account dell'ISP e alla posta elettronica per l'abbonamento tramite Connessione guidata Internet

La quarta pagina sul server per l'abbonamento è quella per l'accesso all'account e alla posta elettronica, che consente all'utente di selezionare un accesso e/o un identificativo per la posta elettronica e una password.

La pagina HTML per l'accesso all'account e alla posta elettronica inviata dal server per l'abbonamento viene visualizzata in un frame mobile all'interno della procedura guidata. Le dimensioni del frame sono di 444 x 273 pixel. Se la pagina HTML supera queste dimensioni, le barre di scorrimento non vengono visualizzate.

Creazione della schermata di selezione del POP dell'ISP per l'abbonamento tramite Connessione guidata Internet

In questa pagina l'utente seleziona un numero di telefono locale per l'accesso a Internet.

La pagina HTML per la selezione del POP inviata dal server per l'abbonamento all'ISP viene visualizzata in un frame mobile all'interno della procedura guidata. Le dimensioni del frame sono di 444 x 273 pixel. Se la pagina HTML supera queste dimensioni, le barre di scorrimento non vengono visualizzate.

L'utente non dovrà inserire il prefisso o il numero di telefono una seconda volta. I campi del prefisso e del numero di telefono nel frame dovranno essere precompilati usando le informazioni del modulo per il nome e l'indirizzo già inviate al server per l'abbonamento all'ISP.

Creazione della schermata dei termini e delle condizioni dell'ISP per l'abbonamento tramite Connessione guidata Internet

Nella pagina dei termini e delle condizioni dell'ISP visualizza i termini del contratto che l'utente deve leggere prima di abbonarsi al servizio. Per accertarsi che l’utente abbia accettato le condizioni del contratto, il pulsante Avanti della Connessione guidata Internet è disponibile solo dopo che l'utente ha fatto clic su Accetto.

L'utente può salvare una versione HTML dei termini per poterla visualizzare anche successivamente facendo clic sul pulsante Salva copia. Quando l'utente fa clic sul pulsante, viene richiesta l'immissione di un nome per il file e il percorso di dove essere salvato.

La pagina HTML dei termini e delle condizioni inviata dal server per l'abbonamento all'ISP viene visualizzata in un frame mobile con un bordo di 2 pixel all'interno della procedura guidata. La larghezza del frame è di 426 pixel, senza includere il bordo di 2 pixel e la barra di scorrimento verticale. Se la pagina HTML supera queste dimensioni, la barra di scorrimento orizzontale non viene visualizzata.

La pagina dei termini e delle condizioni deve iniziare con il titolo del documento e le istruzioni che spiegano come trovare una copia del documento legale sul sito Web dell'ISP per la stampa o per una nuova visualizzazione.

Nota

  • Non sono richiesti particolari requisiti di accesso per questa pagina perché non sono consentiti elementi dei moduli HTML.


Creazione di Icwsign.htm, delle pagine di errore e della pagina finale per l'abbonamento tramite Connessione guidata Internet

Per l'abbonamento tramite Connessione guidata Internet, è necessario definire la schermata iniziale visualizzata all'utente, ossia Icwsign.htm, le pagine di errore e la pagina finale.

Schermata iniziale: Icwsign.htm

La prima schermata visualizzata all'utente dopo l'installazione di Internet Explorer 5 e il riavvio del computer, è la pagina Icwsign.htm. Questa pagina dà il benvenuto da parte dell'ISP all'utente e chiede di: (a) fare clic su Avanti per iniziare il processo di abbonamento, se per viene richiesto solo un file da parte dell'ISP oppure (b) selezionare la città e lo stato da cui viene eseguita la chiamata, in modo che Connessione guidata Internet possa selezionare il file sul server dell'ISP da utilizzare per l'abbonamento.

Quando l'utente sceglie di fare clic su Avanti, Connessione guidata Internet compone il numero e connette l'utente al server per l'abbonamento dell'ISP. Questa pagina viene specificata in IEAK ed è inclusa nel pacchetto di Internet Explorer. Non viene salvata sul server per l'abbonamento.

Pagine degli errori per l'iscrizione tramite Connessione guidata Internet

Se i dati presentati al server per l'abbonamento, in un momento qualsiasi durante il processo, non sono validi, il server può visualizzare una pagina HTML contenente un messaggio di errore. Ad esempio, se il cliente richiede un indirizzo e-mail già in uso, è possibile suggerire delle alternative e chiedere al cliente di richiedere un indirizzo e-mail differente.

La pagina HTML degli errori inviata dal server per l'iscrizione dell'ISP viene visualizzata in un frame mobile all'interno della procedura guidata. Le dimensioni del frame sono di 444 x 273 pixel. Se la pagina HTML supera queste dimensioni, le barre di scorrimento non vengono visualizzate.

Il frame dovrà contenere del testo per indicare all'utente che i dati inseriti non sono validi e fornire gli elementi del modulo necessari all'utente per inserire i nuovi dati.

Per informazioni sull'HTML e gli elementi del modulo necessari, vedere Requisiti di codifica e accesso per l'iscrizione mediante la Connessione guidata Internet.

Pagina finale per l'iscrizione tramite Connessione guidata Internet

Quando l'utente sceglie di fare clic su Avanti nella pagina finale dell'ISP, il file ins viene elaborato e il computer viene configurato per il nuovo account Internet. Al termine di questa operazione, Connessione guidata Internet visualizza la pagina finale per informare l'utente che la connessione a Internet è configurata e spiega come iniziare l'esplorazione in Internet. Questa pagina non presenta un'interfaccia configurabile dall'ISP.

La pagina finale offre inoltre le opzioni per iniziare immediatamente l'esplorazione semplicemente facendo clic sul pulsanteInizia.

È possibile specificare la pagina visualizzata dal browser quando viene aperto per la prima volta, utilizzando il valore StartURL nel file ins.

Uso del file ins per configurare un computer di riferimento

Al termine del processo di abbonamento, il server per l'abbonamento deve fornire le informazioni su come configurare il computer dell'utente per l'accesso a Internet. Queste informazioni sono contenute nel file ins, scaricato al termine del processo di abbonamento.


Ulteriori informazioni su Internet

Oltre alla possibilità di gestire l'account IEAK, su Internet sono disponibili ulteriori informazioni.

Per ulteriori informazioni, visitare il sito Web di IEAK. Poiché questo sito viene aggiornato frequentemente, si consiglia di accedervi spesso per reperire le informazioni più recenti.


Creazione di più versioni del browser

Utilizzare questo processo per creare versioni diverse del browser, ad esempio versioni che utilizzano server di posta elettronica diversi ma che condividono le stesse impostazioni.

Il programma di personalizzazione di Internet Explorer visualizza le impostazioni specificate per la versione iniziale del browser personalizzato. Queste impostazioni sono memorizzate nel file Install.ins. Rinominando i file ins, è possibile apportare velocemente le modifiche a ogni versione del browser personalizzato.

  1. Creare una versione del browser personalizzato utilizzando la procedura guidata.
  2. Rinominare il file Instal.ins presente nella cartella CIE\Custom. Se ad esempio è necessaria una versione per utenti di Firenze, denominare il file Firenze.ins.
  3. Aprire il file Signup.htm nella cartella CIE\Custom. In questo file creare un collegamento al file Firenze.ins.
  4. Eseguire nuovamente la procedura guidata e specificare la stessa cartella personalizzata della cartella di destinazione dei file di output.

    5. Mantenere uguali tutte le impostazioni della procedura guidata eccetto le impostazioni che seguono, che è possibile personalizzare per ciascuna versione:

    • Logo
    • Testo della barra del titolo
    • Preferiti
    • Barra dei collegamenti
    • Pagina iniziale e pagina di ricerca
    • Server della posta e dominio
  5. Ripetere i passaggi da 2 a 4 fino ad avere creato tutte le versioni desiderate del browser personalizzato.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


Creazione di un file isp

Se si sta effettuando un processo di iscrizione con il pacchetto browser personalizzato, un file isp (Internet sign-up) denominato Signup.isp fornirà informazioni sulla connessione per i servizi Internet. Il file per l'abbonamento contiene anche un collegamento all'URL dello script eseguito sul server che crea il file di configurazione ins, utile in caso di modalità di abbonamento basato su server. Il Toolkit IEAK include uno strumento denominato ISP File Wizard, che consente la creazione automatica dei file isp.

Per installare ISP File wizard, fare doppio click sul file Filewiz.exe nella cartella. \<IEAK >\Toolkit\ISP\Wizard.

Per avviare ISP File Wizard
  • Fare clic sul menu di Avvio , scegliere Programmi, quindi fare clic su ISP File Procedura guidata.
  • Per creare un file isp con le impostazioni personalizzate, seguire le istruzioni visualizzate durante l'esecuzione della procedura guidata.

Nota

  • È possibile impedire che il codice predefinito di un'area venga impostato da una voce nel file.isp. La sintassi di questo flag è:
    Dial_As_Is=Yes

    L'impostazione di questo flag può essere utile ad esempio quando gli utenti chiamano da un indicativo di località diverso da quello predefinito. Se gli utenti non sanno che il prefisso predefinito differisce dal proprio prefisso, è possibile che incorrano in consistenti addebiti inaspettati.


Microsoft Product Support Services Worldwide

Supporto tecnico nel mondo

All’estero, per qualsiasi domanda riguardante un prodotto Microsoft:

  • consultare la documentazione e altro materiale stampato incluso nella confezione del prodotto.
  • consultare la Guida in linea.
  • consultare i file LEGGIMI presenti nei dischi del prodotto. Questi file contengono informazioni generali divenute disponibili dopo la stampa dei manuali.
  • consultare i servizi on-line.

Se non si trova una soluzione, è possibile ricevere informazioni su come ottenere assistenza per i prodotti contattando la filiale Microsoft del paese in cui ci si trova.

Servizi di supporto Microsoft

I servizi di supporto Microsoft, ove disponibili, offrono un’ampia gamma di scelte e accesso ad un supporto tecnico completo e di alta qualità.

I servizi di supporto Microsoft sono soggetti ai prezzi, termini e condizioni Microsoft validi in ogni paese al momento in cui un servizio viene usato, e sono soggetti a cambiamenti senza preavviso.

Chiamare una filiale Microsoft

Prima di chiamare, accertarsi di avere a portata di mano la documentazione del prodotto e di trovarsi in prossimità del computer. Potrebbe inoltre essere necessario fornire le seguenti informazioni:

  • il numero di versione del prodotto Microsoft utilizzato e il numero di serie, se disponibile.
  • il tipo di hardware di cui si dispone, compreso l’hardware di rete, se esistente.
  • il sistema operativo in uso.
  • il contenuto esatto dei messaggi visualizzati.
  • la descrizione dell’operazione che si stava eseguendo quando si è verificato il problema.
  • il modo in cui si è tentato di risolvere il problema.

Di seguito sono indicati i numeri di telefono delle filiali Microsoft nei vari paesi.

Se nel paese di interesse non è presente una filiale Microsoft, rivolgersi al rivenditore presso cui è stato acquistato il prodotto Microsoft.

Per un elenco aggiornato dei numeri di telefono consultare l’indirizzo Internet in lingua inglese . http://www.microsoft.com/support/

Argentina
Microsoft de Argentina S.A.
Customer Service: (54) (11) 4316-4600
Fax: (54) (11) 316-1922
Technical Support: (54) (11) 4316-4664
Internet: http://www.microsoft.com/argentina/soporte/

Armenia
See Russia

Australia
Microsoft Pty. Ltd.
Phone: 13 20 58
Fax: 612 9023-5021
Internet: //http://www.microsoft.com/australia/support//
Technical Support: 612 13 20 58

Austria
Microsoft Ges.m.b.H.
Phone: (+43) 1 610 64-0
Fax: (+43) 1 610 64-200
InfoServices: 08000-123 345
Fax: +43-2236-64595
E-mail: InfoService@microsoft.at
Direct Services (Updates, etc.): +43-1- 795 67028
Fax: +43-1-795 67029
E-mail: austria@msdirectservices.com
Standard Support:
Installation and Handling: (+43) 1 50222-2255
General information about Support Network in Central Europe:
Fax: 01805-251191

Azerbaijan
See Russia

Belgium
Microsoft NV
Phone: +32 2 704 3000
Fax: +32 2 704 3535
TechNet Subscription: +353 1 703 8738
MSDN Subscription: +322 513 8684
Microsoft Information Center: +32 2 513 3113
Technical Support:
32-2-513 32 74 (Dutch speaking)
+32-2-502 34 32 (English speaking)
+32-2-513 22 68 (French speaking)
Internet: //www.microsoft.com/benelux/support

Belarus
See Russia

Bolivia
See Uruguay

Brazil
Microsoft Informatica Ltda.
Phone: (55) (11) 5514-7100
Fax: (55) (11) 5514-7106/5514-7107
Technical Support: (55) (11) 5504-2155
Fax: (55) (11) 5504-2227
Automatic Fax: (55) (11) 5506-8506
Technical Support Bulletin Board Service: (55) (11) 5506-1234
Customer Services: (55) (11) 822-5764
Customer Services Fax: (55) (11) 822-6227
Internet: http://www.microsoft.com/brasil/suporte/default.stm

Canada
Microsoft Canada Co.
Head Office Phone: 1 (905) 568-0434
Customer Information Centre: 1 (800) 563-9048
Technical Support:
Desktop Systems: (905) 568-4494
Other Standard Technical Support: (905) 568-3503
Priority Support Information: (800) 668-7975
Text Telephone (TTY/TDD): (905) 568-9641

Caribbean
Microsoft Caribbean, Inc.
Phone: (809) 273-3600
Fax: (809) 273-3636
Technical Support/Soporte Tecnico: (408) 953 8086
Support E-mail/Correo Electronico para Soporte Tecnico: mscarsup@microsoft.com
Customer Service/Centro de Servicios: (800) 297 5982 for area codes 787 & 809 only
Customer Service E-mail/Correo Electronico para Atencion a Usarios: msccatus@microsoft.com
Internet: http://www.microsoft.com/latam/soporte/contactos.htm

Central America
Technical Support/Soporte Tecnico: (506) 298-2020
Support E-Mail/Correo Electronico para Soporte Tecnico: mscarsup@microsoft.com
Customer Service/Centro de Servicios: (506) 298-2000
Customer Service E-mail/Correo Electronico para Atencion a Usarios: msccatus@microsoft.com

Chile
Microsoft Chile S.A.
Phone: 56-2-330-6000
Fax: 56-2-330-6190
Customer Service: 56-2-800-330-6000
Personal Operating System and Desktop Applications:
Phone: 56-2-330-6222
Fax: 56-2-341-1439 Internet: http://www.microsoft.com/latam/soporte/

China
Microsoft (China) Co. Ltd.
6/F, Beijing Sigma Center
No. 49, Zhichun Road, Haidian District
Beijing, 100080, PRC
Phone: 011-86-10-6261 7711
Fax: 011-86-10-6253 6630

Microsoft Asia Regional Engineering Center
19th - 20th Floor, Metro Tower
No. 30 Tian Yao Qiao Road
Shanghai, 200030, PRC
Phone: 011-86-21-64691188/ 011-86-21-6469 8899
Fax: 011-86-21-6469 1166 / 011-86-21-6469 9900

Colombia
Microsoft Colombia
Carrera 7a. # 71-21 Torre B Piso 7
Santa Fé de Bogotá
Phone: (571) 317 3838
Fax: (571) 317 3494
Technical Support:
Línea de Respuesta Microsoft
Phone: (091) 524 0404
Other cities: 9800-10595
Fax: (091) 524 0405

Croatia
Microsoft Hrvatska d.o.o.
Trg D. Petrovica 3
10 000 Zagreb
Phone: (385) (1) 4802 500
Fax: (385) (1) 4843 688
Product Support Phone: 385 1 393539
E-mail: hot-line@microsoft.hr
Customer Service Phone: (385) 0800 300 300
E-mail: info-line@microsoft.hr

Czech Republic
Microsoft s.r.o.
Phone: (+420) (2) 611 97 111
Fax: (+420) (2) 611 97 100
Technical Support: (+420) (2) 2150 3222

Denmark
Microsoft Denmark
Phone: (45) 44 89 01 00
Fax: (45) 44 68 55 10
Technical Support:
Phone: (45) 44 89 01 11
Microsoft Sales Support: (45) 44 89 01 90
Microsoft FastTips: (45) 44 89 01 44
(Document 303030 in FastTips contains detailed instructions)
Microsoft MSDL (BBS): (45) 44 66 90 46
Internet: http://www.microsoft.com/danmark/support/

Dominican Republic
See Central America

Dubai
Microsoft Middle East
Phone: (971) 4 513 888
Fax: (971) 4 527 444
Technical Support (Personal Operating Systems & Desktop Applications only):
Phone: (971) (4) 555 443
Fax: (971) (4) 523 264
E-mail: mswsgulf@microsoft.com
Customer Service Center (Version upgrade / TechNet and MSDN subscription):
Phone: (971) (4) 655 082
Fax: (971) (4) 655 097

Ecuador
Corporation Microsoft del Ecuador S.A.
Phone/PBX: (593) (2) 460-453
Fax: (593) (2) 463-093
Technical Support and Customer Service: (593) (2) 258-025
Internet: http://www.microsoft.com/ecuador/soporte/

Egypt
Microsoft Egypt
Technical Support:
Personal Operating Systems and Desktop Applications only:
Phone: (202) 338 8724 / 338 9794
Fax: (202) 360 4976

England
See United Kingdom

Estonia
See Germany
Technical Support: (+372) 650 49 99
Internet: http://www.microsoft.com/germany/support/servicesupport/supportberater.asp

Finland
Microsoft OY
Phone: +358-(0) 9-525 501
Fax: +358-(0) 9-878 8770
Technical Support:
Phone: +358-(0) 9-525 502 5026
Standard +358 (0) 9-525-502-500
Priority: +358 (0) 9-525-502-20
Internet: http://www.microsoft.com/finland/support/

France
Phone: (011)(33) 825 827 829 (*)
Customer Service Phone: (011)(33) 0 825 827 829 (*)
Fax: (33) 01 64-46-06-60
Telex: MSPARIS 604322
Technical Support:
Phone: (011)(33) 825 827 829 (*) access code 1020
Fax: (011)(33) 1 69 28 00 28
(*) indigo number 0,99 F TTC per minute

French Polynesia
See France

Georgia
See Russia

Germany
Microsoft GmbH
Phone: 089/3176-0
Fax: 089/3176-1000
Telex: (17) 89/83 28 MS GMBH D
Information: 089/3176-1199
Prices, updates, etc.: 08105-25-1199
Internet: //www.microsoft.com/germany
Standard Support:
Installation and Handling: 01805/67 22 55
General information about Microsoft support in Central Europe: Fax: 1805-25-1191

Greece
Microsoft Hellas, S.A.
Phone: (30) (1) 6806-775 through (30) (1) 6806-779
Fax: (30) (1) 6806-780
Technical Support:
Phone: (30) (1) 6806-111
Fax: (30) (1) 6809-528

Gulf & Eastern Mediterranean
PO Box 52244 Dubai, UAE
Phone: 971 4 3973888
Fax: 971 4 3972244

Personal Support Contact Details:
(Personal Operating Systems & Desktop Applications only):

Gulf (Bahrain, Malta, Qatar, and United Arab Emirates)
Phone: 971 4 3975443
Fax: 971 4 3972304
E-mail: mswsgulf@microsoft.com

Lebanon (Cyprus and Lebanon)
Phone: 961 1 983348
Fax: 961 1 983349
E-mail: mts@lebanon-online.com.lb

Kuwait
Phone: 965 2431071
Fax: 965 2430249
E-mail: mspsskuw@microsoft.com

Oman
Phone: 968 691191
Fax: 968 698568
E-mail: mspss@gto.net.om

Pakistan
Phone: 92 21 111 674357
Fax: 92 21 4533370
E-mail: mssupport@nets.net.pk
Customer Service Center (Version upgrade / TechNet and MSDN subscription):
Phone: (971) (4) 655 082
Fax: (971) (4) 655 097

Hong Kong SAR
Microsoft Hong Kong SAR Limited
Fax: (852) 2560-2217
Microsoft Information Hotline: (852)2804-4234
Personal Technical Support: (852) 2804-4222
Professional Technical Support: (852) 2804-4288

Hungary
Microsoft Hungary
Phone: +36 (1) 437-2800
Fax: +36 (1) 437-2899
Customer Services: (+36) (1) 267-4636 (2MSINFO)
Technical Support: (+36) (1) 267-7846 (2MSSUGO)

Iceland
See Denmark

India
Microsoft India
Phone: (91) (80) 559 5733, (91) (11) 629 4600, (91) (22) 2850193
Fax: (91) (80) 559 7133, (011) (91) (11) 629 2650

Indonesia (SP)
Microsoft Indonesia - Jakarta
Technical Support:
Phone: 62 21 570 42 54
Fax: 62 21 520 81 22

Ireland
See United Kingdom

Israel
Microsoft Israel Ltd.
Reception:
Phone: +972-9-952-5353
Fax: +972-9-952-5333
Customer Service & Information Center:
Phone: +972-9-9525400
Fax: +972-9-9525411
Technical Free Support for Windows, Office and Microsoft Fun:
Phone: +972-9-9525400
Fax: +972-9-9525403

Italy
Microsoft Italia Srl
Phone: (39) 02 70398398
Fax: (39) 02 70392020
Customer Service (New product info, product literature):
(39) 02 70398398
Customer Service for IT/Operatori del settore IT:
(39) 02 70398398
Technical Support: (39) 02 70398398
Microsoft Consulting Service: (39) 02 70398398

Internet: http://www.microsoft.com/italy/support/

Japan
Microsoft Company Ltd.
Technical Support (Standard Support): (81) (3) 5354-4500
Technical Support options/ Support Contract: (81) (3) 5354-4700
Channel Marketing Information Center (Presales Product Support):
Tokyo Phone: (81) (3) 5454-2300
Osaka Phone: (81) (6) 6245-6995
Customer Service Phone (Version upgrade/Registration):
Phone: (81) (48) 226-5500
Fax: (81) (48) 226-5511

Kazakhstan
See Russia

Kingdom of Saudi Arabia
Phone: +966-1-488-1165
Fax: +966-1-488-1576
Technical Support (Personal Operating System and Desktop Applications only):
Phone: 800 124 0500 (toll-free within Saudi Arabia)
Fax: 966-1-4740576

Kirgizia
See Russia

Korea
Microsoft CH
Phone: (82) (2) 531-4500
Fax: (82) (2) 531-1724
Customer Service: : 080-985-2000 (toll-free domestic only)
Technical Support:
Windows: (82) (2) 508-0040
Microsoft FastTips: (82) (2) 3453-7555

Kuwait
PO Box 5244
13053 Safat
Phone: +965-243-0248
Fax: +965-243-0249
Technical Support:
(Personal Operating Systems, Desktop Applications and Developer Tools only):
Phone: +965-243-1071

Latin America
Microsoft
Latin American Headquarters (U.S.A.)
Phone: (305) 489-4800
Fax: (305) 491-1616
Customer Service: (425) 936-8661
Technical Support: (214) 714-9100
Internet: //www.microsoft.com/latam/soporte

Liechtenstein
See Switzerland

Luxembourg
Microsoft NV
Phone: +32-2-730 39 11
Microsoft Support Network Info. Center: +31-800-9977-57
TechNet Subscription: +353-1-703 8738
MSDN Subscription: +353-1-708-8690
Microsoft Information Center: +32-2-481 52 52
Bulletin Board: +32-2-726 85 45
(1200/2400/9600/14400 baud, 8N1, ANSI)
Technical Support:
+32-2-513 32 74 (Dutch speaking)
+32-2-502 34 32 (English speaking)
+32-2-513 22 68 (French speaking)
Internet: //www.microsoft.com/benelux/support

Malaysia (SP)
Microsoft (Malaysia) Sdn Bhd:
Phone: (6) (03) 757-2266
Fax: (6) (03) 757-2265
Customer Services:
Phone: Toll-free 1-800-88-3249
Fax: +6 (03) 758-5011
Technical Support:
Phone: +6 (03) 793-9595
Fax: +6 (03) 295-2065
Internet: http://www.microsoft.com/malaysia/

México
Microsoft México, S.A. de C.V.
267-2110 Atencion a Distribuidores
265-3380 Atencion a Clientes
265-3399 Soporte Sistemas Operativos y Applicaciones de Escritorio
267-2190 Soporte de Servidores y Herramientas de Desarrollo
Fast Tips: (52)(5) 2612199
Microsoft BBS 628-6200/02 MSMEXICO sin password
Internet: http://www.microsoft.com/mexico/soporte/

Middle East
Phone: (971) 4 397 3888
Fax: (971) 4 397 2244
Technical Support:
(Personal Operating Systems & Desktop Applications only):
Phone: (971) (4) 397 5443
Fax: (971) (4) 397 2304
E-mail: mswsgulf@microsoft.com
Customer Service Center (Version upgrade / TechNet and MSDN subscription):
Phone: (971) (4) 299 5082
Fax: (971) (4) 299 5097

Morocco
Microsoft Afrique Du Nord
Phone: (212) 2 95 80 80
Fax: (212) 2 95 85 85

Netherlands
Jaar 2000 informatie centrum
Netherlands: (020) 5001033
Belgium: +32-2 7043000
Luxemburg: +32-2-5139979
Product Support:
· Netherlands (Dutch): (020) 5001005
· Netherlands (English): (020) 5001053
· Belgium (Dutch): +32 2 513 31 13
· Belgium (French): +32 2 513 22 68
· Belgium (English): +32 2 502 34 32
· Luxemburg (French): +32 2 513 2268
· Luxemburg (English): +32 2 502 3432
Microsoft Consulting Services Benelux:
Netherlands, Belgium and Luxemburg: +31 (0)20 5001005
Information Services and Subscriptions:
TechNet:
· Netherlands: (020) 5001035
· Belgium: +32 2 5022176
· Luxemburg: +32 2 5022176
Microsoft Developer Network:
· Netherlands: (020) 5001037
· Belgium: +32 2 5138684
· Luxemburg: +32 2 5138684
Internet: //www.microsoft.com/benelux/support

New Zealand
Microsoft New Zealand Ltd.
Phone: 64 (9) 357-5800
Fax: 64 (9) 357-0868
Technical Support:
Phone: 64 (9) 357-5575
Fax: 64 (9) 357-5577

Northern Ireland
See United Kingdom

Norway
Microsoft Norway AS
Phone: +(47) 22 02 25 00
Fax: +(47) 22 95 06 64
Technical Support:
Standard: +(47) 22 02 25 50
Priority: +(47) 22 02 25 45
Premier: +(47) 22 02 25 46
Microsoft Sales Support: +(47) 22 02 25 80
Microsoft MSDL: +(47) 22 18 22 09
Microsoft FastTips: +(47) 22 02 25 70
(Document 404040 in FastTips contains detailed instructions)
Internet: http://www.microsoft.com/norge/support/

Panama
Technical Support/Soporte Tecnico: (506) 298 2020
Support E-mail/Correo Electronico Para Soporte Tecnico: mscarsup@microsoft.com
Customer Service/Centro de Servicios: (506) 298 2000
Customer Service E-mail/Correo Electronico para Atencion a Usuarios: msccatus@microsoft.com

Papua New Guinea
See Australia

Paraguay
See Uruguay

Peru
Phone: (511) 421-1200
Fax: (511) 4217307
Technical Support:
(511) 215-5002 & (511) 215-5005

Philippines (SP)
Microsoft Philippines
Phone: 632 811 0062
Technical Support:
Phone: 632 892 2295/2495
Fax: 632 813 2493

Poland
Microsoft Sp. z o.o.
Phone: +(48-22) 661-54-00
Fax: +(48-22) 661-54-34
Information Service: +(48-22) 865-99-33
Technical Support: +(48-22) 865-99-66

Portugal
Microsoft Portugal MSFT, Lda.
Phone: (351) 1 4409200
Fax: (351) 1 4412101
Technical Support:
Standard Support: (351) 1 4409280
Fax: (351) 1 4411655

Puerto Rico
Technical Support/Soporte Tecnico: (408) 953 8086
Support E-mail/Correo Electronico Para Soporte Tecnico: mscarsup@microsoft.com
Customer Service/Centro de Servicios: (800) 297 5982 for area codes 787 & 809 only
Customer Service E-mail/Correo Electronico para Atencion a Usuarios: msccatus@microsoft.com

Republic of Ireland
See United Kingdom

Romania
Microsoft s.r.l.
Phone: (+40) (1) 222 90 16
Fax: (+40) (1) 222 90 12
Technical Support: (+40) (1) 312 09 48

Russia
Microsoft Z.A.O.
Microsoft Information Center:
Moscow: +7 (095) 916-7171
St.Peterburg: +7 (812) 118-3636
Novosibirsk: +7 (3832) 119-019
Kiev: +380 (044) 2305101
Fax:
Moscow: +7 (095) 916-7112
Technical Support:
Phone:
Moscow: +7 (095) 745-5445
St.Peterburg: +7 (812) 118-3636
Novosibirsk: +7 (3832) 119-019
Kiev: +380 (044) 2305102
Fax:
Moscow: +7 (095) 916-7112
Internet: //www.microsoft.com/rus/support/

Saudi Arabia
Phone: +966 (1) 218-0808
Fax: +966 (1) 218-0809
Technical Support (Personal Operating System and Desktop Applications only):
Phone: 800 124-2255 (toll-free within Saudi Arabia)
Fax: 800 124-2255 (press 2 to send a fax)

Scotland
See United Kingdom

Singapore
Microsoft Singapore Pte Ltd
Phone: (65) 337-6088
Fax: (65) 337-6788
Customer Services:
Phone: (65) 324-5255
Fax: (65) 324-6181
Product Support Services:
Phone: (65) 378-3600
Fax: (65) 378-3662

Slovak Republic
Microsoft Slovakia s.r.o.
Bratislava Business Center IV
Prievozska 6/A
821 09 Bratislava
Phone: +421-7-5341 9841
Fax: +421-7-5341 9840
Hotline: +421-7-67 296 296
Infoservice: +421-7-67 296 297

Slovenia/Slovenija
Microsoft d.o.o.
Phone: (+386) (61) 1800 800
Fax: (+386) (61) 1800 822
Technical Support: (+386) (61) 185 3449

South Africa
Microsoft South Africa
Phone: (27) 11 445 0000 or 0860225567 (inside South Africa)
Fax: (27) 11 257 0257
Technical Support Fax: (+27) 11 257-0424

South East Africa and Indian Ocean Islands
See South Africa

Spain
Microsoft Iberica SRL
Inside Spain:
Phone: 902 197 198
Fax: 91 803 8310
Technical Support: 902 197 198
Customer Service: 902 197 198
Fax Back telephone: 902 197 198
Outside Spain:
Phone: (34) 91 353 69 60
Fax: (34) 91 803 8310
Technical Support: (34) 91 353 69 60
Customer Service: (34) 91 353 69 60
Fax Back telephone: (34) 91 353 69 60
Internet: http://www.microsoft.com/spain/support/default.asp

Sweden
Microsoft AB
Phone: +46 (0) 8-752 56 00
Fax: +46 (0) 8-750 51 58
Technical Support:
Standard: +46 (0) 8-752 09 29
Priority: +46 (0) 8-751 09 80
Premier: +46 (0) 8-632 57 01
Internet: http://www.microsoft.com/sverige/support/

Switzerland
Microsoft AG
Phone: 01-839 61 11
Fax: 01-831 08 69
Customer Service Phone: 0848-858-868
Microsoft Info-Service, Postfach, 8001 Zürich, Fax: 01 311-72-27
Support:
Standard Technical Support (German speaking) Installation and Handling:
Phone 0848 80 - 2255
Standard Technical Support (French speaking):
Phone 022-738 96 88
General information about Microsoft Support in Central Europe:
Phone 0848-80-2330
Internet: //www.microsoft.com/switzerland

Tadzikistan
See Russia

Taiwan
Microsoft Taiwan Corp.
Phone: (886) (2) 2504-3122
Fax: (886) (2) 2504-3121
Technical Support:
Phone: (886) (2) 2508-9501
Fax: (886) (2) 2508-9575

Thailand
Microsoft (Thailand) Limited
Phone: (662) 266-3300
Fax: (662) 266-3310
Technical Support:
Phone: (662) 613-7208 through 11
Fax: (662) 613-7198

Turkey
Microsoft Turkey
Phone: 90 (212) 258 59 98
Fax: 90 (212) 258 59 54
Support Hotline:
Phone: 90 (212) 275 24 66
Fax: 90 (212) 272 77 55

Turkmenistan
See Russia

United Kingdom
Microsoft Limited
Phone: (0870) 60 10 100
Fax: (0870) 60 20 100
Technical Support:
Desktop Applications, Home Products, Personal Operating Systems and hardware:
0870 50 10 100
Business Systems: 0870 50 10 300
Customers phoning from Ireland should dial 706 5353 for technical support

Uruguay
Technical Support: (598) (2) 774934
Fax: (598) (2) 774935
Internet: http://www.microsoft.com/uruguay/soporte/

Uzbekistan
See Russia

Venezuela
Corporation MS 90 de Venezuela S.A.
Other information: (582) 265-9922
Fax: (582) 265-0863
Technical Support: (582) 993-6755
Internet: http://www.microsoft.com/venezuela/soporte/

Wales
See United Kingdom


Guida in linea di Internet Explorer Administration Kit

The Internet Explorer Administration Kit

agevola la personalizzazione, distribuzione e gestione di Internet Explorer.

È possibile distribuire il "Web nel modo desiderato". Sfogliare la Guida in linea per le modalità.

square bullet Esplorazione dell'Indice

square bullet Esecuzione di una ricerca

square bullet Stampa degli argomenti

© 1999-2000 Microsoft Corporation. Tutti i diritti riservati. Condizioni per l'uso.
Fotografia: Rob Goldman/CORBIS


Nome società e codice di personalizzazione

In questa schermata è possibile immettere il nome della società o dell'organizzazione e il codice di personalizzazione a 10 cifre, nonché selezionare il ruolo corrispondente al contratto di licenza.

Nome società
Digitare il nome della società o dell'organizzazione. Questo non è il nome che apparirà sulla barra del titolo del browser. Tale opzione verrà infatti impostata in seguito nel programma di personalizzazione di Internet Explorer.
Codice di personalizzazione
Il codice di personalizzazione viene inviato per posta ordinaria o elettronica dopo aver provveduto alla registrazione sul sito Web di IEAK. È necessario registrarsi su Microsoft per ricevere la licenza che consente di ridistribuire Internet Explorer e i prodotti correlati legalmente.

È obbligatorio specificare il codice di personalizzazione. Senza questo codice non è possibile eseguire il programma di personalizzazione. Tenere il codice in un luogo sicuro e non fornirlo a persone o organizzazioni non autorizzate.

Note

  • Il programma di personalizzazione di Internet Explorer viene fornito con un codice di personalizzazione predefinito. Questo valore consente di visualizzare tutte le schermate del programma di personalizzazione ma non permette di produrre un pacchetto di installazione personalizzato.
  • In caso di smarrimento del codice di personalizzazione, visitare il sito Web di IEAK per ulteriori istruzioni.
Ruolo
Selezionare il ruolo che corrisponde a ciò che si desidera realizzare con IEAK.
  • Provider di contenuti/Sviluppatore, qualora si forniscano agli utenti contenuti, collegamenti e funzionalità personalizzati.
  • Provider di servizi, qualora si fornisca agli utenti un servizio Internet.
  • Amministratore delle reti Intranet, qualora si gestiscano prodotti software e servizi Internet per una società o un'organizzazione.

Importante

  • Il ruolo scelto deve corrispondere al contratto di licenza.


Selezione lingua

Selezionare la lingua desiderata dall'elenco Lingua di destinazione. Se la lingua che si desidera utilizzare non è elencata, uscire dal programma di personalizzazione, inserire il CD contenente la lingua da utilizzare, quindi riavviare il programma di personalizzazione.

Per ciascun pacchetto localizzato di Internet Explorer che si intende creare è necessario eseguire una volta il programma di personalizzazione di Internet Explorer. Per mantenere le stesse impostazioni in più versioni, specificare la stessa cartella di destinazione per ciascuna versione. Le versioni localizzate verranno salvate in sottocartelle separate nella cartella di destinazione.

Esempio

Ad esempio, IT è l'abbreviazione per la versione italiana e DE quella per la versione tedesca.

Se si specifica C:\Cie\Build1\ come cartella di destinazione, il pacchetto personalizzato contenente una versione scaricabile di Internet Explorer in lingua italiana viene creato nella seguente cartella:
C:\Cie\Build1\Download\Win32\It

Il pacchetto personalizzato contenente una versione scaricabile di Internet Explorer in lingua tedesca viene creato nella seguente cartella:
C:\Cie\Build1\Download\Win32\de

Note

  • È possibile installare una versione di Internet Explorer in lingua diversa da quella usata dal sistema operativo.
  • Se nel pacchetto viene incluso come componente l'Aggiornamento desktop di Windows, la lingua utilizzata per il pacchetto di IEAK deve corrispondere a quella del sistema operativo dell'utente. Se si tenta di installare il browser e l'Aggiornamento desktop di Windows in una lingua diversa, verrà istallato soltanto il browser.
  • L'unica piattaforma designata in Internet Explorer Administrative Kit 5.5 è "Win32"; per client UNIX e Windows 16-bit, usare Internet Explorer Administrative Kit 5.0x.


Selezione supporti

In questa schermata si determina il tipo di supporto da utilizzare per distribuire il pacchetto personalizzato.

Download
Selezionare questa opzione per creare un pacchetto da scaricare via Intranet o Internet. È possibile creare i pacchetti personalizzati sul proprio disco rigido, quindi spostarli su un server Internet o, nel caso degli amministratori delle reti aziendali, su un server Intranet. È inoltre possibile creare i pacchetti direttamente sul server specificando il percorso del server e la cartella di destinazione. Per ulteriori informazioni, vedere Destinazione file.
CD-ROM
Quando si crea una versione su CD, è possibile specificare le impostazioni relative all'avvio automatico. Questa opzione ordina il pacchetto personalizzato in una serie di cartelle e fornisce il supporto per l’avvio automatico, che consiste in una schermata visualizzata quando il CD viene inserito nel computer.
Normale (tutti i file in una cartella)
Se i pacchetti vengono realizzati su una rete locale o se si pensa di spostarli su una rete locale, selezionare questa opzione per posizionare tutti i file necessari in una sottocartella della cartella di destinazione, ad esempio C:\Cie\Lingua.
Marcatura di un solo dischetto
Selezionare questa opzione per personalizzare un'installazione esistente di Internet Explorer (versioni 4.01 Service Pack 1, forniti con Windows 98 e versioni successive). Questa opzione crea un file Setup.exe nella cartella BrndOnly del percorso di creazione. È possibile distribuire questo file in qualunque supporto o server. Una volta eseguito questo file, le funzioni di Internet Explorer vengono personalizzate, compresa l’iscrizione a Internet per gli ISP, senza l’installazione di Internet Explorer. Non è possibile includere componenti personalizzati o profili di Connection Manager in un pacchetto con marcatura di un solo dischetto, poiché la dimensione del pacchetto sarebbe maggiore della capacità di un disco floppy.

Importante

  • Per la marcatura di un solo dischetto, non utilizzare l'iscrizione mediante la Connessione guidata Internet se si prevede che alcuni utenti utilizzano Internet Explorer 4.01 Service Pack 1 o versioni precedenti, ma creare invece un pacchetto separato utilizzando l'iscrizione per la modalità presentazione continua.


Destinazione file

È possibile modificare la cartella di destinazione, in cui viene creato il pacchetto IEAK personalizzato, e la cartella in cui vengono scaricati i componenti.

Cartella di destinazione
La cartella di destinazione è quella nella quale verranno memorizzati i pacchetti personalizzati al termine del programma di personalizzazione. È possibile creare il pacchetto del browser sul proprio disco rigido e spostarlo su un server Internet o Intranet oppure è possibile crearlo direttamente su un server Web.

Nella cartella di destinazione specificata dall’utente per ciascuna piattaforma e tipo di supporto vengono create delle sottocartelle per ogni versione localizzata.

Se il pacchetto viene creato sul disco rigido o su un'unità di rete, la cartella di destinazione consigliata è C:\Cie\Dist. Se il pacchetto viene invece creato su un server Web eseguito dal proprio disco rigido, come cartella di destinazione utilizzare il percorso del server Web.

A questo riguardo, vedere l’illustrazione riportata in Impostazione dei file per la distribuzione.

Esempio: posizione della cartella di destinazione

Se si specifica, ad esempio, la cartella di destinazione C:\Inetpub\Wwwroot\Cie\Dist, la versione in lingua italiana per la piattaforma Windows viene creata in C:\Inetpub\Wwwroot\Cie\Dist\Download\Win32\It.

Opzioni avanzate
Per personalizzare il percorso e il processo per il download dei file oppure per importare le impostazioni da un file .ins esistente, fare clic su Opzioni avanzate.
Cerca i componenti più aggiornati tramite Sincronizzazione automatica versione (AVS)
Quando si crea il pacchetto di Internet Explorer, IEAK è in grado di rilevare su Internet la presenza delle versioni aggiornate dei componenti. Questa funzione consente di individuare nuove versioni rese disponibili dall’ultima volta che è stato eseguito il programma di personalizzazione di Internet Explorer.

Se IEAK è stato scaricato da Internet, è necessario eseguire il programma di personalizzazione con la funzione Sincronizzazione automatica versione (AVS) almeno una volta, in modo che il programma di personalizzazione possa verificare l'esistenza di versioni aggiornate dei componenti.

Percorso del file .ins da cui importare le impostazioni
Per importare le impostazioni da un file .ins esistente come punto di partenza per un nuovo pacchetto IEAK, immettere il percorso completo. L’importazione delle impostazioni consente di evitare tempi lunghi nel caso in cui il nuovo pacchetto abbia delle impostazioni simili. È tuttavia possibile modificare tutte le impostazioni desiderate.
Cartella dei componenti scaricati
I componenti e i file di installazione scaricati vengono collocati nella cartella specificata. La funzione di Sincronizzazione automatica versione (AVS) ricerca automaticamente questa cartella per determinare i componenti più aggiornati disponibili. Con AVS, vengono scaricati solo i componenti che sono stati modificati dall’ultima volta che sono stati scaricati. Si consiglia di non modificare questa cartella per poter tenere traccia dei componenti sincronizzati.

Cambiare questa cartella solo se intende conservare i file scaricati l'ultima volta che è stato eseguito il programma di personalizzazione e si desidera scaricare un nuovo gruppo di componenti.


Selezione funzioni

È possibile determinare le restanti schermate del programma di personalizzazione da visualizzare selezionando o deselezionando le caselle di controllo in questa schermata. Se ad esempio si intende personalizzare solo collegamenti e URL, le altre caselle di controllo andranno deselezionate in modo che non vengano visualizzate altre schermate. La selezione delle funzioni consente di creare il pacchetto in modo rapido e semplice poiché il programma di personalizzazione di Internet Explorer visualizzerà solo le schermate necessarie.

Per utilizzare la configurazione di un pacchetto IEAK creato precedentemente come base per la creazione di un altro pacchetto, tornare alla schermata Destinazione file e scegliere il pulsante Opzioni avanzate per importare un file .ins. Dopo aver creato il nuovo pacchetto, è possibile modificare le impostazioni importate.


Riepilogo del passaggio 1: Raccolta informazioni

Programma di personalizzazione

Passaggio 1: Raccolta informazioni

In questa fase del programma di personalizzazione di Internet Explorer, vengono richieste informazioni basilari, come la lingua del pacchetto che si sta creando e le funzioni che si desidera personalizzare nel pacchetto.

Le opzioni disponibili variano a seconda se si è un:

  • Provider di contenuti Internet
  • Provider di servizi Internet
  • Amministratore delle reti Intranet

Nota

  • Se non si è installato Internet Explorer 5.5 o versione successiva, il programma di personalizzazione di Internet Explorer non funzionerà correttamente. Per ulteriori informazioni, vedere Requisiti hardware e di sistema.


Sito di download e Sincronizzazione automatica versione (AVS)

In queste fasi verranno scaricati i programmi e gli strumenti Microsoft più aggiornati. Se già di dispone dell'ultima versione di un componente, verrà richiesto di mantenerlo. Per scaricare i componenti potrebbe essere necessario disattivare temporaneamente il programma antivirus. In tal caso verrà visualizzato un messaggio.

Sito di download Microsoft
Scegliere il sito da cui scaricare la versione aggiornata di Internet Explorer e Accesso a Internet, quindi scegliere Avanti per visualizzare la schermata di Sincronizzazione automatica versione nel programma di personalizzazione di Internet Explorer.
Download dei componenti di Internet Explorer
Scaricare la versione aggiornata dei componenti Microsoft mostrati nel riquadro. Lo stato di ciascun componente è indicato nel seguente modo:
Simbolo | Significato
X rossa | Componente non disponibile.
punto esclamativo giallo | Nella cartella di download si trova una versione obsoleta del componente.
segno di spunta verde | Nella cartella di download si trova la versione aggiornata del componente.

Per continuare a eseguire il programma di personalizzazione di IEAK, è necessario scaricare il browser Internet Explorer.

Per scaricare o aggiornare più componenti, selezionare ciascun componente desiderato, quindi scegliere il pulsante Sincronizza. Per scaricare tutti i componenti disponibili, scegliere il pulsante Sincronizza tutto.

A volte, sul sito Web di Windows Update possono essere disponibili versioni più recenti di alcuni componenti e patch software rispetto a quelle rilevate dalla funzione Sincronizzazione automatica versione di IEAK. Per includere nel pacchetto file di altre versioni, è possibile raggruppare i file associati in un componente personalizzato. Per ulteriori informazioni, vedere Inserimento di aggiornamenti Microsoft in componenti personalizzati.

Per un'illustrazione della funzione AVS, vedere Sincronizzazione automatica versione.

Per informazioni sugli ultimi aggiornamenti dei prodotti, visitare il sito Web Corporate Windows Update.

In questa fase del programma di personalizzazione viene effettuato il download nel computer dell'utente dei file di installazione di Internet Explorer e dei relativi componenti. Si consiglia di mantenere una copia di questi file sul disco rigido per quando sarà nuovamente necessario creare il pacchetto. Infatti, in quella fase, il programma di personalizzazione di Internet Explorer potrà verificare se per questi programmi sono disponibili versioni più recenti.

Note

  • Se si deseleziona la casella di controllo Cerca i componenti più aggiornati tramite Sincronizzazione automatica versione nella finestra di dialogo Opzioni avanzate della fase 1 del programma di personalizzazione (vedere Destinazione file), il programma di personalizzazione di Internet Explorer non potrà verificare se la versione dei componenti di cui si dispone è la più aggiornata. La relativa icona non sarà infatti di colore verde anche se è stata installata la versione più recente. Per i componenti già scaricati, le icone saranno di colore giallo. Per i componenti da scaricare, le icone saranno di colore rosso. Inoltre, se si disattiva la sincronizzazione della versione, non sarà possibile scaricare componenti specifici in questa fase del programma di personalizzazione.
  • Per ulteriori informazioni sui componenti e le relative stringhe ComponentID associate, visitare il sito Web di IEAK.


Aggiunta componenti personalizzati

È possibile specificare un numero massimo di dieci componenti personalizzati che gli utenti possono installare contemporaneamente all'installazione del browser. Questi componenti possono essere file .cab compressi o file .exe autoestraenti. In alternativa, è possibile installare una versione di un componente Microsoft diversa da quella disponibile mediante la funzione Sincronizzazione automatica versione (AVS).

Si consiglia di firmare gli eventuali codici personalizzati che verranno scaricati via Internet. In questo modo gli altri utenti potranno verificare l'attendibilità del codice prima di procedere al download. In base all'impostazione predefinita, in Internet Explorer il codice non firmato non verrà accettato.

Alcune delle seguenti opzioni non sono disponibili su tutte le piattaforme.

Comando
Se si specifica un file .cab, è necessario specificare anche un comando da eseguire per l'estrazione del file .cab.
Componente
Digitare in questa casella il nome del componente. Questo nome apparirà nella schermata di installazione in fase di installazione del software.
Descrizione
Digitare una descrizione per il componente di 511 caratteri al massimo. Questo testo verrà visualizzato nella fase di installazione quando viene selezionato il componente.
GUID
Se il programma in uso dispone già di un identificatore univoco globale o GUID, digitarlo in questa casella. Se invece il programma non dispone di un GUID, ne verrà creato uno. Un GUID stabilisce un’identità unica per programmi, oggetti e altre voci.
Posizione
Digitare il percorso del programma o scegliere Sfoglia per cercarlo.
Parametro
È possibile specificare le opzioni da eseguire insieme al programma di personalizzazione. Sarà ad esempio possibile installare un programma in modo invisibile all'utente senza conferme, in modo che non vengano visualizzate agli utenti richieste per il programma e per Internet Explorer. Per escludere i messaggi di richiesta dell'installazione, utilizzare l'opzione /Q:A.
Disinstallazione
L'installazione di Windows Update confronta questo valore con HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall\Nome applicazione per verificare che il componente sia stato installato correttamente.

Per ulteriori informazioni, vedere Disinstallazione dei componenti personalizzati.

Verifica
Per i programmi installati via Internet è generalmente necessaria la firma digitale che ne identifica l'origine e garantisce che il codice non è stato modificato da quando è stato firmato. A seconda delle impostazioni di protezione del browser è possibile avvisare gli utenti prima che il programma venga scaricato. Le autorità di certificazione possono fornire le chiavi pubbliche e private necessarie per la firma del codice. Per stabilire se il programma dispone della firma digitale, scegliere il pulsante Verifica. Se durante il programma di personalizzazione di Internet Explorer vengono firmati i restanti file, anche questo componente verrà firmato con quel certificato.

Per ulteriori informazioni sulla firma del codice, visitare il sito Web Microsoft Security Advisor.

Versione
Il programma di installazione utilizza il numero di versione per confrontare la versione in corso di installazione con quella attualmente installata sul computer. Durante la reinstallazione di un componente, il programma di installazione non installerà una versione precedente. Il numero di versione consente di tenere traccia delle versioni del programma personalizzato e di assicurarsi che venga installata la versione più recente. Il formato corretto per il numero di versione è il seguente: xxxx,xxxx,xxxx,xxxx.

Condizioni di installazione

Installa prima di Internet Explorer
Utilizzare questa opzione quando è necessario installare un componente personalizzato prima che sia installato Internet Explorer, ad esempio per eseguire un file batch che preconfiguri le impostazioni utente.
Installa dopo Internet Explorer
Utilizzare questa opzione quando si desidera installare uno o più patch software di Internet Explorer (QFE) o una versione diversa di un componente incluso nel pacchetto base di Internet Explorer scaricato tramite la funzione AVS.

Nota

  • Inserendo i file di un'altra versione di un componente base di Internet Explorer, come DirectAnimation o NetMeeting, nel pacchetto del componente personalizzato, la durata del download aumenterà poiché lo stesso sottoinsieme di file viene effettivamente scaricato due volte.
Installa dopo il riavvio del sistema
Utilizzare questa opzione quando il componente personalizzato contiene service pack di sistema o aggiornamenti di Microsoft Java Virtual Machine (VM).
Installa solo se Internet Explorer è stato installato correttamente
Il componente viene installato solo se Internet Explorer è installato sul computer dell'utente.

Note

  • Gli strumenti per la creazione di script IExpress vengono forniti con IEAK. Ulteriori strumenti sono disponibili sul sito Web MSDN Online Web Workshop. Per ulteriori informazioni sull'installazione, vedere Installazione di Windows Update per Internet Explorer e Accesso a Internet.
  • Per un'illustrazione su come viene eseguita la marcatura e l'installazione dei componenti personalizzati del browser personalizzato, vedere Funzionamento della personalizzazione.


Riepilogo del passaggio 2: parametri di installazione

Programma di personalizzazione

Passaggio 2: parametri di installazione

In questa fase del programma di personalizzazione di Internet Explorer vengono specificati i componenti da includere nel pacchetto personalizzato.

Le opzioni disponibili variano a seconda se si è un:

  • Provider di contenuti Internet
  • Provider di servizi Internet
  • Amministratore delle reti Intranet


Personalizzazione dell’installazione

È possibile personalizzare il modo in cui l'installazione di Windows Update apparirà agli utenti. È possibile modificare la barra del titolo e l'immagine visualizzata quando viene eseguita l'installazione guidata di Windows Update. È inoltre possibile assegnare un nome all'eventuale gruppo di componenti personalizzati incluso nel pacchetto del browser.

Testo della barra del titolo dell'installazione guidata
Questo testo appare sulla barra del titolo del programma di installazione guidata che verrà eseguito dagli utenti. Questo testo non sarà invece visualizzato sulla barra del titolo del browser personalizzato. È possibile personalizzare il titolo del browser in una fase successiva del programma di personalizzazione di IEAK.
Percorso delle bitmap dell'installazione guidata
Con queste immagine è possibile personalizzare l'aspetto dell'installazione guidata. Si consiglia di non utilizzare immagini con linee e motivi complessi.

Nota

  • l'installazione guidata contiene due bitmap a 256 colori. La bitmap verticale a sinistra (nella prima pagina dell'installazione guidata) è di 162x312 pixel. La bitmap orizzontale in alto (nelle restanti pagine dell'installazione guidata) è di 496x56 pixel. L'immagine orizzontale viene visualizzata dietro alcune istruzioni sull’installazione, quindi si consiglia di utilizzare una bitmap che non comprometta la leggibilità.
Titolo per l'installazione dei componenti personalizzati
I componenti personalizzati possono essere installati durante l'installazione del browser personalizzato. Se viene specificato più di un componente personalizzato, è possibile nominarli come gruppo; è ad esempio possibile avere un gruppo di componenti denominato Programmi d’inventario. Questo nome appare nell'installazione guidata di Windows Update quando viene installato il pacchetto personalizzato. Immettere il titolo che si desidera venga visualizzato.

Per un'illustrazione su come viene eseguita la marcatura e l'installazione dei componenti personalizzati del browser personalizzato, vedere Funzionamento della personalizzazione.


Personalizzazione di Connection Manager

Connection Manager Administration Kit (CMAK) è lo strumento utilizzato per configurare e gestire la modalità di connessione a Internet o ad una rete aziendale privata. Con CMAK, è possibile modificare l'aspetto e le impostazioni della connessione di Microsoft Connection Manager utilizzando icone e file della guida in linea personalizzati e grafica animata.

CMAK non è disponibile con Internet Explorer Administration Kit 5.5. CMAK viene fornito con Windows 2000 Server e Windows 2000 Administration Pack; una versione precedente di CMAK è disponibile con la versione 5 di Internet Explorer Administration Kit.

Se è già stato creato un profilo personalizzato con CMAK, è possibile importarlo nel pacchetto di installazione utilizzando il programma di personalizzazione di Internet Explorer.

Usa profilo personalizzato
Se è già stato creato un profilo personalizzato con CMAK, digitare il percorso del profilo da usare per il pacchetto del browser. Il profilo specifica il contenuto e le modalità di connessione personalizzati.

Note

  • CMAK crea un file eseguibile autoestraente (*.exe) che si installa autonomamente nel computer dell'utente. Quando l'utente sceglie l'icona personalizzata per la connessione a Internet, viene visualizzata la finestra di dialogo relativa alla composizione automatica personalizzata che è stata creata.
  • Non è necessario apporre una firma digitale al file .exe creato con CMAK prima di includerlo in IEAK. Firmando i file IEAK, verrà automaticamente firmato anche il file CMAK.

Per ulteriori informazioni, vedere la Guida in linea di Connection Manager Administration Kit.


Esperienza degli utenti

Durante l'installazione di Windows Update è possibile specificare le azioni che verranno eseguite dagli utenti.

Installazione invisibile all'utente

Per permettere agli utenti di effettuare delle scelte durante l'installazione di Windows Update, scegliere Installazione interattiva. Gli utenti possono selezionare il tipo di installazione, il sito di download, la cartella di installazione e vedere tutte le finestre di dialogo di avanzamento e i messaggi di errore.

Esistono due tipi di installazione invisibile all'utente.

Per non fare eseguire alcuna selezione agli utenti ma per tenerli comunque informati sull'avanzamento dell'installazione e sugli errori, scegliere Installazione visibile all'utente.

Per fare eseguire agli utenti l'installazione del browser personalizzato senza che venga visualizzata alcuna finestra di dialogo o indicatore di avanzamento, scegliere Installazione invisibile all'utente. La selezione di questa opzione equivale ad installare Internet Explorer con l'opzione /Q:A.

Per definire ulteriormente l'installazione, è possibile utilizzare altre opzioni di installazione batch di Internet Explorer e di installazione batch di IExpress.

Esperienza degli utenti durante un'installazione invisibile e visibile

Un’installazione di questo tipo, visibile o invisibile all’utente, svolge le seguenti funzioni:

  • Rispondere ai messaggi di conferma visualizzati consentendo il proseguimento dell'installazione.
  • Accettare i termini del Contratto Microsoft.
  • Specificare che Internet Explorer è installato e non soltanto scaricato.
  • Completare il tipo di installazione, Tipica o Personalizzata, specificata per il pacchetto di installazione.
  • Installare Internet Explorer nel percorso specificato, se l’installazione non è stata ancora eseguita. In tal caso, la nuova versione del browser viene installata nello stesso percorso della versione precedente.
  • Connettersi al primo sito di download specificato per il pacchetto.

Queste modalità non sono interattive e gli utenti non hanno il controllo sull'avanzamento dell'installazione di Windows Update. Quando un'installazione invisibile all'utente non viene completata in modo appropriato, gli utenti non ricevono alcun messaggio di errore. Questa opzione può essere utilizzata per installazioni eseguite quando l’utente non è presente.

Nota

  • Durante l'esecuzione dell'installazione invisibile all'utente è possibile specificare una sola opzione di installazione e un solo sito di download.

Privilegi degli utenti

Il modello di protezione di Windows NT e Windows 2000 è in grado di evitare l'installazione di software sul sistema. Per registrare file di sistema importanti, è necessario disporre dei privilegi di amministratore sia durante l'installazione del software che dopo il riavvio del computer. Questo requisito complica la distribuzione delle nuove versioni di Internet Explorer su sistemi in cui gli utenti senza privilegi di amministratore accedono al sistema dopo l'installazione del pacchetto.

Abilita connessione dopo il riavvio con accesso a livello utente
Selezionare questa casella di controllo per personalizzare il pacchetto in modo da mantenere l'accesso a livello amministratore dopo il riavvio del computer. Dopo il riavvio del computer e la connessione dell'utente, Windows Installer completa la registrazione dei file di sistema di Internet Explorer. È quindi possibile distribuire manualmente questo pacchetto agli utenti oppure come parte di un metodo di distribuzione automatico, ad esempio Systems Management Server (SMS) In entrambi i casi, non è richiesto che gli utenti abbiano i privilegi di amministratore la volta successiva che accedono al sistema.

Per installare un pacchetto IEAK su computer con Windows 95, Windows 98 o Windows Millennium Edition, non è necessario disporre dei privilegi di amministratore poiché il sistema operativo non gestisce la registrazione dei file su questi sistemi.

Quando questo pacchetto viene installato su un client SMS, il componente genera un file di stato .mif. SMS utilizza questo file per rilevare se il pacchetto è stato installato correttamente.

Importante

  • Se si seleziona questa opzione, verificare che il formato sul supporto contenente il pacchetto sia normale, con tutti i file in una cartella.
  • Prima di utilizzare questa opzione, verificare che durante l'installazione del pacchetto non sia in esecuzione alcuna altra installazione di Windows Installer.
  • Non utilizzare questo metodo quando Internet Explorer è un componente di un'altra installazione di Windows Installer, come Microsoft Office 2000.
  • Se si seleziona questa opzione, verificare ampiamente le potenziali interazioni prima di distribuire il pacchetto agli utenti.


Opzioni di installazione

È possibile specificare fino a 10 opzioni di installazione, come Tipica e Personalizzata, e determinare il browser e i componenti personalizzati da installare con ciascuna di esse. Gli amministratori delle reti Intranet che hanno specificato per il pacchetto l'installazione invisibile all'utente, possono specificare una sola opzione o modalità di installazione.

Importante

  • Indipendentemente dalle opzioni di installazione configurate nel pacchetto, l'installazione di Windows Update presenta una sola opzione di installazione agli utenti del sistema operativo Windows 2000. L'opzione di installazione include tutti i componenti Internet di Microsoft, insieme a tutti i componenti personalizzati inclusi nel pacchetto.
Opzione
Selezionare l'opzione di installazione predefinita desiderata oppure scegliere Nuova per creare una nuova opzione di installazione. Digitare la descrizione dell'opzione, quindi aggiungere o rimuovere i componenti desiderati facendo clic sulle apposite frecce.

Nel caso di provider di servizi Internet è possibile creare un'opzione di installazione per uno specifico gruppo di utenti. Nel caso degli amministratori delle reti Intranet è invece possibile specificare opzioni di installazione differenti per i diversi reparti della società.

Descrizione
Digitare una descrizione per l'opzione di installazione, ad esempio l'elenco dei componenti e dei programmi che verranno installati. Questo testo verrà visualizzato durante l'esecuzione dell' installazione guidata di Windows Update .

Nota

  • Per produrre un carattere di sottolineatura nel testo della descrizione, digitare la e commerciale (&). Per produrre il carattere e commerciale, digitare due caratteri e commerciale (&&).
Componenti disponibili
L'elenco dei componenti disponibili include i componenti di Internet Explorer scaricati e i componenti personalizzati definiti. Per aggiungere altri componenti a questo elenco, tornare alla Fase 2 del programma di personalizzazione di IEAK.
Componenti da installare
L'elenco dei componenti che verranno installati con l'opzione visualizzata nella casella Opzione. Fare clic sulle frecce singole per aggiungere o rimuovere un singolo componente o sulle frecce doppie per aggiungere o rimuovere tutti i componenti disponibili.

Per un'illustrazione su come viene eseguita la marcatura e l'installazione di componenti specifici del browser personalizzato, vedere Funzionamento della personalizzazione.

Nota

  • Se si installa Internet Explorer su un computer in cui non era presente la versione 4 e si desidera fornire agli utenti i canali, includere in ciascuna opzione di installazione il Modulo di esplorazione non in linea come uno dei componenti.


Siti di download dei componenti

In caso di utilizzo di un server HTTP o FTP è necessario specificare almeno un sito di download da cui gli utenti potranno scaricare il pacchetto del browser. È possibile specificare un numero massimo di dieci siti. È necessario collocare tutti i componenti Microsoft e i componenti personalizzati in corrispondenza di ciascun URL specificato in questa schermata.

Nome sito
Digitare il nome del sito. È possibile specificare un nome breve che consenta una più rapida identificazione del sito. Non utilizzare virgole all'interno del nome.
URL sito
Digitare l'URL del sito. Il file Ie5sites.dat verrà aggiunto o aggiornato e nell’URL verrà creata una sottocartella per la lingua del pacchetto, ad esempio It per la versione italiana.
Area sito
Digitare l'area in cui si trova il sito, come la città, la provincia, la regione o il paese.
Siti di download personalizzato
I siti specificati verranno elencati in questa colonna.

Nota

  • Gli amministratori delle reti Intranet che hanno specificato per il pacchetto l'installazione invisibile all'utente, possono specificare un solo sito di download.

Per un'illustrazione, vedere Impostazione dei file per la distribuzione e Installazione di Windows Update per Internet Explorer e Accesso a Internet.

Cosa fare quando l'URL del primo sito non funziona

Se il primo sito non può essere utilizzato, ad esempio per problemi relativi al server, durante l'installazione non sarà possibile individuare i rimanenti siti in base all'impostazione predefinita. Una soluzione alternativa può essere sovrascrivere il primo sito con il seguente comando:

<percorso>\ie5setup.exe /C:"ie5wzd.exe /S:""<percorso>\ie5setup.exe"" /L:""http://server Web/sito Web/ie5sites.dat"""

dove <percorso> indica la cartella contenente il file IE5setup.exe.

Esempio

Di seguito viene riportato un esempio di sintassi da utilizzare in caso di malfunzionamento del primo sito. Esempio di linea di comando singola, visualizzata mediante tre linee di testo per facilitare la lettura

C:\ie5setup.exe /C:"ie5wzd.exe
/S:""D:\Build\1700\package\download\win95_nt\en\ie5setup.exe""
/L:""http://<Indirizzonuovoserver>/<Directorydidownload>/ie5sites.dat """


Download di componenti

Quando è disponibile una nuova versione di Internet Explorer, è possibile eseguire l'aggiornamento scegliendo Windows Update dal menu Strumenti. Questa pagina può essere visualizzata anche dal Pannello di controllo, scegliendo Installazione applicazioni, Internet Explorer e Accesso a Internet, quindi selezionando Aggiungi/Rimuovi.

La posizione predefinita in cui trovare gli aggiornamenti dei prodotti è quella del sito dal quale sono stati scaricati i browser personalizzati, ma è comunque possibile specificare la pagina dei componenti aggiuntivi personalizzati dalla quale gli utenti possono scaricare ulteriori componenti aggiuntivi.

Scarica componenti da Microsoft dopo l'installazione
Selezionare questa casella di controllo per specificare che tutti i componenti saranno scaricati dai siti Microsoft dopo l'installazione.
URL della pagina dei componenti aggiuntivi
Se si desidera che gli utenti ottengano aggiornamenti software o componenti aggiuntivi da qualsiasi posizione, specificare un altro URL.

Nota

  • L'ID di configurazione e il numero di versione disponibili nelle versioni precedenti di IEAK, che prima apparivano in questa schermata, non sono più necessari. Questi valori vengono creati automaticamente. Le personalizzazioni o marcature generate con IEAK vengono sempre installate, indipendentemente dal numero di versione o dall'ID di configurazione.


Cartella di installazione

Gli amministratori delle reti Intranet possono specificare la posizione in cui gli utenti installeranno Internet Explorer e gli altri componenti Internet. È inoltre possibile determinare se gli utenti possono modificare la cartella specificata.

Per avere la possibilità di modificare il percorso specificato, selezionare la casella di controllo Consenti selezione della cartella di installazione. Facendo clic su questa casella di controllo, il percorso selezionato viene visualizzato come percorso predefinito.

Se si seleziona il pulsante di opzione Installa nella cartella specificata contenuta nella cartella Windows o Installa nella cartella specificata contenuta nella cartella Programmi, Internet Explorer verrà installato nella sottocartella visualizzata nella casella.

Se si seleziona la casella di controllo Specifica il percorso completo di una cartella personalizzata, sarà possibile digitare il percorso desiderato. Nel caso in cui tale percorso non esista sul disco rigido dell'utente, verrà creato automaticamente.

Nota

  • Se Internet Explorer è già installato, la nuova versione verrà installata su quella precedente. Il browser personalizzato non verrà installato nel percorso personalizzato indicato.


Opzioni di installazione su reti aziendali

È possibile determinare l'eventuale limite di personalizzazione dell'installazione di Windows Update per gli utenti.

Disattiva opzione installazione personalizzata
Gli utenti possono aggiungere o rimuovere componenti per personalizzare ulteriormente l'installazione. Per impedire agli utenti di aggiungere o rimuovere componenti specifici, selezionare questa casella di controllo.
Disattiva salvataggio delle informazioni di disinstallazione
L'installazione di Windows Update salva automaticamente le informazioni di disinstallazione. Per risparmiare spazio su disco, è possibile disattivare questa funzione selezionando questa casella di controllo. Gli utenti però non saranno più in grado di rimuovere Internet Explorer da Installazione applicazioni nel Pannello di controllo.
Disattiva modalità di compatibilità di Internet Explorer
Con l'opzione di compatibilità di Internet Explorer gli utenti possono verificare le funzioni della pagina Web di Internet Explorer 4 sullo stesso computer in cui si trova Internet Explorer 5 e versioni successive. Per disattivare questa funzione, selezionare la relativa casella di controllo.
Opzioni del browser predefinito
Scegliere una delle tre opzioni per determinare se Internet Explorer è il browser predefinito e se gli utenti possono effettuare questa scelta. Il browser predefinito viene eseguito all’apertura di file .htm, .html e altri tipi di file associati. Questa opzione determina anche se il Lettore multimediale di Windows è il programma predefinito per la lettura di file multimediali.

Nota

  • Se si sta utilizzando un'installazione invisibile all'utente oppure si sta personalizzando la distribuzione di Internet Explorer per Microsoft Office mediante il programma di personalizzazione dell'installazione di Office, le opzioni utente per Internet Explorer non verranno visualizzate durante l'installazione.


Aggiornamento desktop di Windows

L’Aggiornamento desktop di Windows rende l'aspetto di desktop e cartelle più simile a quello del Web. Nonostante l’Aggiornamento desktop di Windows non sia compreso in Internet Explorer 5, è possibile includerlo nel pacchetto IEAK. Gli utenti di Windows 98 o versioni successive del sistema operativo dispongono già delle caratteristiche del desktop.

Se si sceglie di installare l’Aggiornamento desktop di Windows, è possibile personalizzarne in seguito le impostazioni nel programma di personalizzazione se nel computer in uso è in esecuzione una delle seguenti configurazioni:

  • Windows 98
  • Windows 98 Second Edition
  • Windows Millennium Edition
  • Windows 2000
  • Se si è installato l'Aggiornamento desktop di Windows su altre versioni di Windows, sarà necessario utilizzare Internet Explorer 5.5, aggiornando la versione 4.0.

L'Aggiornamento desktop di Windows può rivelarsi utile per impostare un desktop standard della società.

Si desidera integrare l’Aggiornamento desktop di Windows nel pacchetto personalizzato?
Per installare l'Aggiornamento desktop di Windows, selezionare il pulsante di opzione Sì. Per non installarlo, selezionare il pulsante di opzione No.


Opzioni di installazione avanzate

Per personalizzare ulteriormente l'installazione di Windows Update, è possibile impostare il programma di installazione in modo che rilevi l'esistenza dei componenti, nonché definire i componenti che possono essere aggiunti dagli utenti, nel caso in cui essi personalizzino l'installazione.

Ottimizza per download Web
Il programma di installazione è in grado di rilevare se la stessa versione di un componente è già installata sul computer dell'utente. Se tale versione è esistente e funzionante con Internet Explorer, l'installazione non scaricherà il componente. Ciò consente di ridurre la durata del download.

Nota

  • Non effettuare l'ottimizzazione per il download dal Web quando si desidera installare una particolare versione di un componente, diversa da quella inclusa nei file .cab di Internet Explorer scaricati precedentemente con la funzione AVS. Per ulteriori informazioni, vedere Inserimento di aggiornamenti Microsoft in componenti personalizzati.
Impedisci personalizzazione installazione per componenti specifici
Nel caso in cui gli utenti possano personalizzare le proprie installazioni e si desidera che essi non personalizzino determinati componenti, deselezionare le caselle di controllo di tali componenti. Nell'installazione di Windows Update, Forza installazione verrà visualizzato nella colonna destra accanto ai componenti che vengono installati automaticamente insieme al browser.


Componenti su supporto

I componenti presenti in questo elenco sono stati scaricati sul computer ma non sono inclusi in alcuna delle modalità specificate per l'installazione di Windows Update. I componenti selezionati possono essere resi disponibili per l’installazione se gli utenti utilizzano una funzione che li richiede, denominata Installazione automatica.


Firme digitali

Se si è in possesso di un certificato autori emesso da un’autorità di certificazione o da Microsoft Certificate Server, in questa fase del programma di personalizzazione è possibile firmare il proprio pacchetto personalizzato. Per ulteriori informazioni sui certificati, vedere Autenticazione dei programmi.

Per preparare i certificati utilizzati da Microsoft Internet Explorer Administration Kit, importarli sul computer utilizzando la procedura guidata di importazione di Certificate Manager. Se si è ricevuto un file con estensione .spc, per avviare la procedura guidata di importazione di Certificate Manager fare doppio clic sul file .spc in Esplora risorse (Gestione risorse in Windows 95) o Risorse del computer.

Certificate Manager può essere aperto anche da Internet Explorer, scegliendo Opzioni Internet dal menu Strumenti, selezionando la scheda Contenuto, quindi scegliendo Certificati. Scegliere Importa per avviare la procedura guidata di importazione di Certificate Manager e seguire le istruzioni visualizzate.

Nome della società sul certificato
Se sul computer si trova un certificato autori, il relativo nome della società appare in questo elenco.
File di certificato distribuzione software (.spc)
Digitare il nome del file .spc associato al certificato oppure scegliere Sfoglia per individuare il file.
File di chiave privata (.pvk)
Digitare il nome del file .pvk associato al certificato oppure scegliere Sfoglia per individuare il file.
Testo descrizione
Digitare il testo da visualizzare nella finestra di dialogo che appare quando gli utenti scaricano i programmi che sono stati firmati con questo certificato.
URL per ulteriori informazioni
Digitare l'URL su cui è possibile fare clic per ottenere ulteriori informazioni sul certificato e la società.


Personalizzazione della schermata di avvio automatico su CD

Se si crea una versione su CD del browser personalizzato, sarà possibile creare una schermata di avvio automatico che verrà visualizzata all'inserimento del CD nell'apposita unità.

L'immagine deve essere di tipo bitmap a 256 colori, di 540x357 pixel. Per ulteriori informazioni sulla creazione di questa immagine, vedere Creazione di una bitmap per la schermata di avvio. Per ulteriori informazioni su tutte le immagini, vedere Creazione di immagini personalizzate.

Se si aggiunge una schermata di avvio automatico, è possibile definire una bitmap per lo sfondo delle etichette per due pulsanti: uno per installare Internet Explorer e l’altro per visualizzare ulteriori informazioni. Sarà inoltre possibile personalizzare la barra del titolo e il colore del testo.

Testo della barra del titolo
Questo testo viene visualizzato sulla barra del titolo della schermata di avvio automatico.
Percorso della bitmap per lo sfondo personalizzato
È possibile fornire una bitmap da visualizzare dietro il testo. Assicurarsi che il colore di sfondo non sia in conflitto con il colore del testo.
Colore del testo standard
Questa impostazione determina il colore del testo che non fa parte del collegamento.
Colore del testo evidenziato
Questa impostazione determina il colore dei collegamenti presenti sulla pagina.
Stile pulsante
È possibile determinare l'aspetto dei pulsanti che vengono scelti dagli utenti per installare Internet Explorer e per ottenere ulteriori informazioni.
  • I pulsanti smussati standard sono simili a quelli visualizzati nei programmi software standard.
  • I pulsanti bitmap 3D hanno un aspetto tridimensionale.
  • Una bitmap personalizzata si basa su una bitmap fornita dall'utente. Per individuare la posizione dell'immagine, scegliere Sfoglia.


Altre opzioni per l'installazione da CD

Per personalizzare ulteriormente l’installazione da CD aggiungere un file informativo, denominato generalmente file Leggimi, e far sì che dopo l’installazione venga visualizzata una pagina Web speciale.

File di testo per ulteriori informazioni
Specificaare il percorso e il nome del file da visualizzare dopo l'installazione. In base all’impostazione predefinita, la schermata di avvio automatico su CD fornisce un collegamento a tale file. Se si modifica il nome del file, sarà necessario aggiornare il percorso nella schermata di avvio automatico.
Usa pagina iniziale in modalità tutto schermo
Specificare il percorso e il nome del file .htm da visualizzare dopo l'installazione di Internet Explorer. Questa pagina verrà visualizzata in modalità presentazione continua (schermo intero), in base alla quale la barra dei menu e la barra degli strumenti del browser non vengono visualizzate. Tutte le immagini associate a tale pagina devono essere collocate nello stesso percorso del file .htm.


Riepilogo del passaggio 3: personalizzazione dell’installazione

Programma di personalizzazione

Passaggio 3: personalizzazione dell’installazione

In questa fase del programma di personalizzazione di Internet Explorer, si specifica come viene personalizzata l'installazione di Windows Update.

Le opzioni disponibili variano a seconda se si è un:

  • Provider di contenuti Internet
  • Provider di servizi Internet
  • Amministratore delle reti Intranet


Titolo browser

È possibile personalizzare il testo che viene visualizzato sulla barra del titolo del browser Web Internet Explorer e di Outlook Express nel caso in cui questa applicazione sia inclusa nel pacchetto personalizzato. Digitare il testo che si desidera venga visualizzato. Questo testo sarà aggiunto dopo "Microsoft Internet Explorer" o "Outlook Express".

Personalizzazione delle barre del titolo
Per personalizzare le barre del titolo, selezionare la casella di controllo Personalizza barre del titolo, quindi digitare il testo desiderato nella casella Testo per la barra del titolo.
Bitmap di sfondo della barra degli strumenti
È possibile specificare una bitmap personalizzata per la barra degli strumenti. Tale bitmap verrà visualizzata come sfondo dei pulsanti e dei menu a discesa. Lo sfondo deve essere delle stesse dimensioni della barra degli strumenti e di un colore sufficientemente chiaro da far risaltare il testo di colore nero. Per ulteriori informazioni, vedere Creazione di grafica personalizzata.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


Pulsanti della barra degli strumenti del browser

È possibile personalizzare i pulsanti della barra degli strumenti nel browser dell’utente specificando lo script o il programma avviato dai pulsanti, nonché il relativo aspetto. Per ulteriori informazioni sulla creazione di programmi personalizzati, consultare il sito di MSDN Online Web Workshop. Per ulteriori informazioni sullo sviluppo di icone per la barra degli strumenti, vedere Progettazione delle icone della barra degli strumenti di Internet Explorer.

Eliminazione di pulsanti esistenti della barra degli strumenti, se presenti (solo per amministratori delle reti intranet)
Per eliminare i pulsanti esistenti della barra degli strumenti nel browser dell'utente, selezionare questa casella di controllo.
Aggiungi
È possibile aggiungere barre degli strumenti personalizzate che eseguono script o file eseguibili. Scegliendo Aggiungi verranno richieste ulteriori informazioni, quali l'icona, il nome e l'operazione che i pulsanti devono eseguire.
Nome della barra degli strumenti (obbligatorio)
Specificare un nome o un'etichetta visualizzati al di sotto del pulsante quando l'utente visualizza sia il testo che l'icona sui pulsanti della barra degli strumenti. Le dimensioni massime consigliate sono pari a 10 caratteri.
Azione della barra degli strumenti, come file script o programma eseguibile (obbligatorio)
È necessario specificare lo script o il file eseguibile che verrà eseguito quando viene fatto clic sul pulsante della barra degli strumenti.
Icona a colori (obbligatoria)
Specificare l'icona a colori che sarà visualizzata sui pulsanti della barra degli strumenti. L'icona è costituita da immagini di 20x20 pixel per gli stati attivo e inattivo. Per ulteriori informazioni, visitare il sito MSDN Online Web Workshop.
Icona monocromatica (obbligatoria)
È possibile specificare un'icona monocromatica per le barre degli strumenti visualizzate sui monitor monocromatici.
Come impostazione predefinita, questo pulsante deve essere visualizzato nella barra degli strumenti
Selezionare questa casella di controllo per abilitare il pulsante specificato della barra degli strumenti che, come impostazione predefinita, deve essere visualizzato nel browser dell'utente.

Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


Logo di Internet Explorer

Il logo di Internet Explorer nell'angolo superiore destro del browser viene visualizzato in due stati. Animato quando il browser è in uso e statico quando non viene eseguita alcuna operazione. È possibile sostituire la bitmap del logo predefinito con una bitmap personalizzata animata o statica.

Personalizzazione del logo animato

Se si usa una bitmap animata, il primo frame viene visualizzato in modalità statica quando non viene eseguita alcuna operazione dal browser. I frame rimanenti vengono visualizzati in modalità animata quando il browser è in uso.

Per usare un logo animato personalizzato, è necessario creare due bitmap animate, una di 22x22 e l'altra di 38x38 pixel.

Digitare i percorsi delle bitmap animate personalizzate grandi e piccole nelle apposite caselle. Esempi di bitmap animate sono disponibili nel Toolkit IEAK installato nella cartella \<IEAK>\Toolkit.

Personalizzazione del logo statico

Se si usa una bitmap statica, questa verrà comunque visualizzata in modalità statica indipendentemente dalle eventuali operazioni eseguite nel browser. Per usare un logo statico personalizzato, è necessario creare due bitmap, una di 22x22 e l'altra di 38x38 pixel.

Digitare i percorsi delle bitmap statiche personalizzate grandi e piccole nelle apposite caselle di questa schermata.

Note

  • In IEAK sono inseriti due strumenti per la creazione di bitmap animate per il browser. Uno strumento viene usato per impilare le bitmap nel formato descritto precedentemente, mentre l'altro consente di visualizzare in anteprima l'animazione. Per ulteriori informazioni sull'uso di questi strumenti, vedere Strumenti per bitmap animate.
  • Per ulteriori informazioni su tutte le immagini che è possibile personalizzare in IEAK, vedere Creazione di immagini personalizzate.
  • Per un'illustrazione su come viene eseguita la marcatura del browser personalizzato, vedere Funzionamento della personalizzazione.


URL importanti

È possibile specificare gli URL della pagina iniziale, della pagina di ricerca e di quella del servizio di supporto in linea.

Indirizzo della pagina iniziale
La pagina iniziale, denominata anche home page, viene visualizzata quando si sceglie il pulsante Pagina iniziale. In Internet Explorer è possibile visualizzare una pagina iniziale predefinita oppure specificare un URL per la propria pagina iniziale personalizzata.

Nella casella URL pagina iniziale digitare l'URL della pagina iniziale che si desidera utilizzare. Se si desidera utilizzare la pagina iniziale predefinita di Internet Explorer, fare clic sul pulsante Usa pagina predefinita.

URL della barra di ricerca
La barra di ricerca viene visualizzata nella barra di Explorer nella parte sinistra dello schermo e consente di visualizzare contemporaneamente la ricerca effettuata e i relativi risultati. Contiene inoltre diversi motori di ricerca. Se si desidera, è possibile modificare l'URL di questa pagina. Per ulteriori informazioni, vedere Personalizzazione della barra di ricerca e di Search Assistant.
URL della pagina per il supporto in linea
Per disporre del servizio di supporto in linea in Internet Explorer, scegliere Supporto tecnico dal menu ? Si consiglia di creare sempre una pagina del servizio di supporto in linea per gli utenti.

Nella casella URL della pagina del servizio di supporto in linea digitare l'URL della pagina del servizio di supporto personalizzata. Se si desidera utilizzare la pagina iniziale predefinita di Internet Explorer, fare clic sul pulsante Usa pagina predefinita.


Preferiti e collegamenti

È possibile personalizzare la cartella Preferiti e la barra dei collegamenti aggiungendo collegamenti a siti che abbiano attinenza con la propria società o con i servizi offerti. Un ICP specializzato nel settore dell'intrattenimento potrà ad esempio creare collegamenti a siti relativi a questo argomento.

In base all'impostazione predefinita, la barra dei collegamenti viene visualizzata nella parte superiore dello schermo e contiene una serie di collegamenti predefiniti. È possibile aggiungere collegamenti alle cartelle predefinite oppure aggiungere nuove cartelle. Quando un utente fa clic su Preferiti, nella parte sinistra della finestra viene visualizzato l'elenco Preferiti.

Collocazione dei Preferiti in cima all'elenco nell'ordine specificato
Selezionare questa casella di controllo per specificare che i Preferiti selezionati vengano spostati nella parte superiore dell'elenco Preferiti, per facilitarne la ricerca. Quando si seleziona questa opzione, verranno resi disponibili i pulsanti Su e Giù.
Eliminazione di Preferiti e Collegamenti, se presenti (solo per amministratori delle reti intranet)
Selezionare questa casella di controllo per eliminare l'oggetto dall'elenco Preferiti e Collegamenti degli utenti. Si consiglia di utilizzare questa impostazione con cautela, poiché provoca l'eliminazione dei collegamenti e dei siti preferiti impostati dagli utenti.
Eliminazione dei Preferiti creati dall'amministratore (solo per amministratori delle reti intranet)
Selezionare questa casella di controllo per eliminare solo gli oggetti creati dall'amministratore dall'elenco Preferiti e Collegamenti degli utenti.

Per informazioni su come vengono applicati al browser personalizzato la marcatura e i collegamenti personalizzati, vedere Funzionamento della personalizzazione.

Come aggiungere manualmente una cartella all'elenco Preferiti o alla barra dei collegamenti

  1. Fare clic su Preferiti, Collegamenti o una delle relative sottocartelle, quindi scegliere il pulsante Aggiungi cartella.
  2. Digitare il nome della cartella nella casella Nome. È possibile utilizzare un nome breve che consenta di ricordare con facilità i collegamenti contenuti nella cartella.

Nota

  • Nei nomi delle cartelle non è consentito utilizzare punti e virgola (;) e barre (/).

Come aggiungere una cartella all'elenco Preferiti o alla barra dei collegamenti

  1. Fare clic su Preferiti, Collegamenti o una delle relative sottocartelle, quindi scegliere il pulsante Importa.
  2. Nella casella di dialogo Sfoglia cartella, individuare nel computer la cartella dei collegamenti desiderati. Quasi certamente questi collegamenti si trovano nella cartella \Windows\Favorites.

Come aggiungere una pagina Web all'elenco Preferiti o alla barra dei collegamenti

  1. Fare clic su Preferiti, Collegamenti o una delle relative sottocartelle, quindi scegliere il pulsante Aggiungi URL.
  2. Nella finestra di dialogo Dettagli, digitare un nome per la pagina Web nella casella Nome. È possibile utilizzare un nome breve che consenta di ricordare con facilità il contenuto di un collegamento.
  3. Digitare il percorso del collegamento nella casella Indirizzo.
  4. Per specificare un'icona personalizzata con dimensioni pari a 16 x 16 pixel, digitare il nome del file nella casella Icona.

    Per ulteriori informazioni, vedere Creazione di grafica personalizzata.

  5. Un amministratore delle reti intranet può fare in modo che la pagina sia disponibile agli utenti anche quando non sono connessi a Internet, selezionando la casella di controllo Disponibile in modalità non in linea. Questa opzione risulta particolarmente utile per chi dispone di computer portatili.
  6. Scegliere OK per chiudere la finestra dialogo Dettagli.

Note

  • Per verificare un collegamento, selezionare l'URL dall'elenco, quindi scegliere il pulsante Prova URL.
  • È possibile aggiungere un numero massimo di 200 collegamenti alla cartella Preferiti.
  • Per rimuovere una voce dall'elenco Preferiti o da una barra dei collegamenti, fare clic con il pulsante destro del mouse sulla voce, quindi scegliere il pulsante Elimina.


Pagina iniziale

Internet Explorer visualizza una pagina iniziale quando il browser viene avviato per la prima volta. È possibile visualizzare la pagina iniziale predefinita di Internet Explorer o specificare l'URL di una pagina iniziale personalizzata.

Visualizza la pagina iniziale di Microsoft Internet Explorer
Selezionare questa opzione per visualizzare la pagina iniziale predefinita di Internet Explorer.
Non visualizzare la pagina iniziale
Selezionare questa opzione se non si desidera visualizzare una pagina iniziale. La prima pagina visualizzata sarà la pagina iniziale dell'utente.
Utilizza una pagina iniziale personalizzata
Selezionare questa opzione per utilizzare una pagina iniziale personalizzata, quindi digitare l'URL nell'apposita casella.

Nota

  • All'utente non viene visualizzata una pagina iniziale se non vi è una connessione Internet o intranet attiva.


Canali

È possibile aggiungere un canale o una categoria di canali personalizzati (cartella) oppure importare le impostazioni dei canali dal proprio computer. Quando si importano i canali, è possibile personalizzarli ulteriormente, importando ad esempio le relative impostazioni, ma eliminando uno dei canali importati.

Per aggiungere dei canali, è necessario disporre delle informazioni sul canale o sulla categoria dei canali, quali il percorso delle immagini grafiche e i titoli da utilizzare. È inoltre necessario disporre di un file di definizione dei canali (cdf) per ciascun canale.

Se il pacchetto personalizzato di Internet Explorer viene installato su un computer su cui non è installato Internet Explorer 4 e si intende far utilizzare i canali agli utenti, è necessario assicurarsi che in ogni opzione di installazione del pacchetto personalizzato sia incluso il Modulo per l'esplorazione non in linea. Se si consente agli utenti di personalizzare l'installazione, sarà necessario specificare che questa opzione non verrà visualizzata come scelta di installazione personalizzata. Per eseguire questa operazione, deselezionare la casella di controllo Esplorazione non in linea nella schermata Opzioni di installazione avanzate. Quindi, in Installazione di Windows Update, Forza installazione verrà visualizzato nella colonna destra di questo componente.

Elimina canali esistenti
Selezionando questa casella di controllo gli amministratori delle reti intranet potranno eliminare i canali esistenti nei computer degli utenti.
Attiva la Barra canali sul deskyop (predefinita)
Gli amministratori delle reti intranet che stanno installando l'Aggiornamento desktop di Windows o Internet Explorer 5 in computer che eseguono Windows 98 potranno impostare la Barra canali sul desktop in base all'impostazione predefinita.
Aggiungi canale
Per aggiungere un canale, fare clic su Aggiungi canale, quindi specificare le seguenti informazioni:
Titolo canale (obbligatorio)
Specificare il titolo del canale. Verrà visualizzato nella lista Preferiti.
URL file di definizione canale nel server Web (obbligatorio)
Digitare l'URL del file cdf relativo al canale desiderato. Il file cdf fornisce informazioni relative ai tempi e alle modalità di aggiornamento del contenuto.
Percosrso file di definizione canale
Digitare il percorso (su disco rigido o in rete) in cui si trova il file cdf oppure scegliere il pulsante Sfoglia per individuarlo.
Percorso immagine ridotta canale
Digitare il percorso per l'immagine ridotta del canale oppure scegliere il pulsante Sfoglia per individuarlo.
Percorso icona canale
Digitare il percorso per l'immagine ridotta del canale oppure scegliere il pulsante Sfoglia per individuarlo.
Disponibile in modalità non in linea
Selezionare questa casella di controllo per rendere disponibile il canale in modalità non in linea. Se il contenuto è disponibile in modalità non in linea, gli utenti potranno leggerlo anche quando non saranno connessi a Internet. Potranno per esempio visualizzare il contenuto in un computer portatile pur non essendo connessi in rete o a Internet.

Note

  • Quando si specifica un file cdf per un canale personalizzato, il file cdf non deve contenere il LOGO con il parametro IMAGE o ICON.
  • Se si aggiunge un canale in una categoria di canali, utilizzare la seguente sintassi:
    <nome categoria>\<nome canale>

    Esempio
    Categoria\Canale

Aggiunta di una categoria o cartella di canali
Per aggiungere una categoria di canali, fare clic su Aggiungi categoria, quindi specificare le seguenti informazioni:
Titolo categoria
Digitare il titolo della categoria dei canali.
Pagina HTML categoria
Digitare l'URL della pagina HTML della categoria.
Percorso immagine ridotta categoria
Digitare il percorso dell'immagine ridotta della categoria. Per ulteriori informazioni, vedere Creazione di immagini personalizzate.
Percorso icona categoria
Digitare il percorso dell'icona da visualizzare per la categoria.
Modifica di un canale
Per modificare un canale o una categoria di canali aggiunta o importata, scegliere il pulsante Modifica. Verrà visualizzata una finestra di dialogo contenente le impostazioni dell'immagine e del percorso.
Rimozione di un canale
Per rimuovere un canale o una categoria aggiunta o importata, selezionare l'elemento desiderato, quindi scegliere il pulsante Rimuovi.
Importazione di canali
Per importare le impostazioni dei canali dal proprio computer, fare clic su Importa. Se si desidera modificare le impostazioni dei canali prima di importarle, non è necessario chiudere il programma di personalizzazione. È sufficiente passare al browser, modificare le impostazioni dei canali, quindi tornare al programma di personalizzazione.
Elimina il collegamento Visualizza canali dalla barra di avvio veloce
Se si seleziona questa casella di controllo, il collegamento Visualizza canali verrà rimosso dalla barra di avvio veloce.


Active Desktop

L'Active Desktop consente di memorizzare il contenuto delle pagine Web sul desktop, ad esempio mappe meteorologiche regolarmente aggiornate. È possibile importare le impostazioni relative al desktop come impostazioni standard della società in modo che tutti gli utenti abbiano lo stesso desktop. Nella fase successiva della procedura guidata sarà possibile stabilire se gli utenti possono modificare queste impostazioni.

Per importare le impostazioni dell'Active Desktop, è necessario includere l'Aggiornamento desktop di Windows nel pacchetto del browser ed eseguire il desktop nel computer in uso.

Per utilizzare le impostazioni correnti come impostazioni standard della società, selezionare Importa i componenti correnti dell'Active Desktop. Per modificare le impostazioni correnti per l'importazione, scegliere il pulsante Modifica impostazioni . Se non si desidera personalizzare i desktop, selezionare Non personalizzare l'Active Desktop.


Barre degli strumenti del desktop

Con il nuovo desktop è possibile aggiungere barre degli strumenti alla barra delle applicazioni di Windows nel pacchetto IEAK, agevolando l'accesso a programmi, file, cartelle, abbonamenti e pagine Web preferite. È inoltre possibile posizionare e ridimensionare le barre degli strumenti in qualsiasi punto del desktop.

Per specificare le barre degli strumenti del desktop, è necessario includere l'Aggiornamento desktop di Windows nel pacchetto del browser ed eseguire il desktop nel computer in uso.

È possibile importare le impostazioni correnti selezionando Importa le impostazioni correnti della barra degli strumenti del desktop. Se si desidera mantenere le impostazioni predefinite della barra degli strumenti, fare clic su Non personalizzare le barre degli strumenti del desktop.

È possibile aggiungere le quattro barre degli strumenti elencate di seguito nel punto desiderato:

  • La barra di avvio rapido fornisce collegamenti a diverse caratteristiche di Internet Explorer utilizzate di frequente: il desktop, il browser Web, Outlook Express e i canali.
  • La barra degli indirizzi consente di immettere un indirizzo Internet (URL) senza che sia necessario avviare il browser.
  • La barra degli strumenti Collegamenti fornisce collegamenti a importanti siti Web, ad esempio www.microsoft.com/italy/, in modo tale da visualizzarli senza che sia necessario avviare il browser.
  • La barra degli strumenti Desktop contiene tutti i collegamenti presenti sul desktop e li organizza per renderli di facile utilizzo.

Oltre alle barre degli strumenti già disponibili, è possibile creare altre barre degli strumenti con il contenuto di una qualsiasi cartella. È ad esempio possibile creare una barra degli strumenti del Pannello di controllo oppure una in cui siano visualizzate le icone per ogni report mensile sulle vendite.

Per creare una nuova barra degli strumenti

  1. Fare clic con il pulsante destro del mouse sulla barra delle applicazioni, scegliere Barre degli strumenti, quindi Nuova barra degli strumenti.
  2. Immettere il percorso della cartella o l'indirizzo del sito Internet che si desidera visualizzare come barra degli strumenti o selezionarlo dall'elenco.

Note

  • Per spostare una barra degli strumenti sul desktop, trascinarla nella posizione desiderata, quindi ridimensionarla in base alle proprie esigenze.
  • Per disporre di una barra degli strumenti di facile utilizzo contenente i collegamenti preferiti, creare una cartella sul disco rigido e inserirvi i collegamenti desiderati, quindi trasformare la cartella in una barra degli strumenti.


Visualizzazioni Web delle cartelle

È possibile personalizzare la visualizzazione Web del Pannello di controllo e di Risorse del computer nei computer della società personalizzando i file utilizzati come modello. Se è stato installato l'Aggiornamento desktop di Windows, sarà inoltre possibile visualizzare il Pannello di controllo e Risorse del computer sotto forma di pagine Web. La personalizzazione di queste cartelle consente di condividere con altri utenti istruzioni, un logo aziendale o collegamenti a siti aziendali o di supporto tecnico.

Per specificare le visualizzazioni Web delle cartelle, è necessario includere l'Aggiornamento desktop di Windows nel pacchetto del browser ed avere in esecuzione il desktop nel computer usato per la creazione del pacchetto.

Per eseguire questa operazione, utilizzare i seguenti file modello:

  • Mycomp.htt per Risorse del computer
  • Controlp.htt per il Pannello di controllo

Se è stato installato l'Aggiornamento desktop di Windows, questi file saranno contenuti nella cartella C:\Windows\Web o C:\WinNT. Per aprirli, utilizzare un editor di testo, quale il Blocco note o un editor HTML. Prima di utilizzare questi file, si consiglia di eseguire una copia di backup in modo da poter ripristinare, in caso di necessità, la versione originale.

È possibile modificare questi file in diversi modi a seconda delle necessità della società, aggiungendo i propri collegamenti o immagini, modificando i colori e anche specificando i contenuti (icone e nomi di file) visualizzati. È ad esempio possibile specificare di non visualizzare le icone del Pannello di controllo e di fornire invece pulsanti grafici da utilizzare solo per le impostazioni che si desidera rendere disponibili.

Questi file utilizzano script attivi, quale JavaScript, JScript o Visual Basic Scripting Edition (VB Script). I file Mycomp.htt e Controlp.htt e altri file relativi al desktop, ad esempio Folder.htt e Printers.htt, utilizzano JavaScript. È possibile modificare alcuni aspetti di questi file senza eseguire alcuno script. Se invece si ha familiarità con la creazione di script, sarà possibile modificare lo script in base alle proprie esigenze.

Questi file modello sono molto simili ai file .htm, fatta eccezione per tre variabili, ovvero %THISDIRNAME%, %THISDIRPATH%, e %TEMPLATEDIR%, che vengono elaborate tramite un filtro MIME e sostituite con le informazioni corrette relative al file o al percorso. Queste variabili sono utili quando si specificano collegamenti a file esterni, quali immagini grafiche. Sebbene i file modello siano contenuti nella cartella C:\Windows\Web o C:\WinNT, vengono elaborati nella cartella \Temp. È pertanto necessario immettere le informazioni relative al percorso per garantire il corretto funzionamento dei collegamenti agli altri elementi.

È importante assicurarsi che le impostazioni delle versioni personalizzate del Pannello di controllo e di Risorse del computer siano conformi a quelle relative alla risoluzione dello schermo degli utenti e che tali versioni vengano visualizzate correttamente. Per garantire un corretto ridimensionamento, utilizzare la sintassi che segue nei file Mycomp.htt e Controlp.htt:

<SCRIPT LANGUAGE="JavaScript">
  window.onresize = fixSize;
</SCRIPT>

Questi file utilizzano l'oggetto FileList per rappresentare i contenuti del Pannello di controllo e di Risorse del computer, cioè le icone e i nomi dei file. In Risorse del computer, un grafico a torta indicante lo spazio disponibile su disco è rappresentato dall'oggetto PieChart. Questi oggetti sono opzionali.

Per ulteriori informazioni sugli script, visitare il sito MSDN Online Web Workshop.

Nel Pannello di controllo e in Risorse del computer vengono visualizzate descrizioni rapide degli elementi del registro di configurazione sui quali l'utente posiziona il mouse. Le descrizioni rapide forniscono una breve spiegazione dell'oggetto.

È inoltre possibile modificare i file modello Printers.htt (stampanti) e Folders.htt (visualizzazione Web predefinita delle cartelle) contenuti nella cartella C:\Windows\Web o C:\Windows\NT del proprio computer o di quello degli utenti. Questi file non possono essere inclusi nel pacchetto di IEAK personalizzato.

Anziché modificare i file con estensione htt, è invece possibile fornire un file HTML. Per eseguire questa operazione, è necessario modificare i riferimenti PersistMoniker associati nel registro di configurazione in PersistFile e indirizzare i riferimenti al file personalizzato.

Nota

  • La modifica di valori al registro di configurazione può danneggiare il sistema. Modificare tali valori è a proprio rischio.


Componente del desktop personalizzato

È possibile aggiungere un componente personalizzato di Active Desktop ai desktop degli utenti. Questo componente può essere un canale (file cdf), una pagina Web (file HTML) oppure un'immagine in formato gif o bmp.

Per specificare un componente del desktop personalizzato è necessario includere l'Aggiornamento desktop di Windows nel pacchetto del browser e avere in esecuzione il desktop nel computer usato per la creazione del pacchetto.

URL o percorso del componente del desktop
Specificare il nome del file e il relativo percorso. Scegliere il pulsante Sfoglia per individuare il file. Se si desidera fare riferimento ad altri file da questo componente, ad esempio file gif o ad un'altra pagina Web, assicurarsi che si trovino nella stessa cartella del componente.


Stringa Agente utente

Alcune società effettuano delle statistiche sul proprio sito, ad esempio il numero di accessi e il tipo di browser Web. Le stringhe agente utente consentono di identificare il tipo di browser in uso.

Stringhe personalizzate da appendere alla stringa agente utente
Le stringhe digitate in questa casella vengono appese alla stringa agente utente per il browser personalizzato. Non è necessario personalizzare la stringa agente utente a meno che non si desideri tenere traccia dell'utilizzo del browser personalizzato e raccogliere statistiche da altri siti Internet. Anche altre società, che tengono traccia di queste statistiche, potranno visualizzare la stringa personalizzata.


Configurazione automatica

È possibile assegnare URL ai file che consentiranno di configurare automaticamente i browser personalizzati. Questa funzionalità è utile se si desidera controllare le impostazioni dei computer di vari utenti da una postazione centrale.

È inoltre possibile configurare le opzioni utilizzando file ins, conosciuti anche come Profili di IEAK. Usando i file ins, sarà possibile includere impostazioni standard per il proxy. È inoltre possibile specificare i file di script in formato js, jvs o pac per configurare e gestire le impostazioni avanzate del proxy.

I server di rete che usano Domain Name System (DNS) e Dynamic Host Configuration Protocol (DHCP) possono automaticamente rilevare e configurare le impostazioni di un browser al primo avvio in rete del browser. Per ulteriori informazioni, vedere Rilevazione e configurazione automatica delle impostazioni del browser.

Se si specificano degli URL sia per la configurazione automatica che per il proxy automatico, l'URL del proxy automatico verrà incorporato nel file ins. L'URL corretto è http://share/test.ins.

Per consentire la configurazione automatica, selezionare la casella di controllo Consenti configurazione automatica. Nella casella Configura automaticamente URL (file ins) digitare l'URL del file ins desiderato. Digitare l'URL della procedura per proxy automatico nella casella URL proxy automatico (file js, jvc o pac).

Per ulteriori informazioni sui file per proxy automatico, vedere File di esempio del proxy automatico in JavaScript o JScript. Per ulteriori informazioni sulla selezione dei server proxy e gli elenchi dei proxy da ignorare, vedere Uso degli elenchi Selezione dei server proxy e Proxy da ignorare.

Per rilevare automaticamente le impostazioni del browser, selezionare la casella di controllo Rileva automaticamente impostazioni di configurazione.

Configura automaticamente ogni xx minuti
È possibile specificare l'intervallo in minuti per la funzione di configurazione automatica. Se si specifica un valore pari a zero o se non si immette alcun valore, la configurazione automatica verrà eseguita solo quando il computer viene riavviato.


Impostazioni di connessione

È possibile preimpostare le impostazioni di connessione importando le impostazioni dal computer.

Per visualizzare le impostazioni da importare, scegliere Opzioni Internet dal menu Strumenti nel browser, quindi fare clic sulla scheda Connessioni. Per visualizzare le impostazioni della connessione remota, scegliere Impostazioni. Per visualizzare le impostazioni della rete, scegliere Impostazioni LAN. L'indirizzo per la configurazione automatica non viene tuttavia importato.

Non personalizzare le impostazioni di connessione
Scegliere questa opzione se non si desidera preimpostare le impostazioni dell'utente.
Importa le impostazioni di connessione corrente
Scegliere questa opzione se si desidera preimpostare le impostazioni dell'utente per utilizzare i valori importati dal computer. Se le impostazioni importate dal computer non corrispondono a quelle che si desidera utilizzare, scegliere Modifica impostazioni per modificarle.
Elimina le impostazioni della connessione di accesso remoto esistenti
Gli amministratori delle reti intranet possono eliminare le impostazioni esistenti nei computer degli utenti selezionando questa casella di controllo.
Annulla tutti i collegamenti e le icone della Connessione guidata Internet
Se si seleziona questa casella di controllo, i collegamenti alla Connessione guidata Internet non verranno visualizzati sulla barra di avvio veloce.

Nota

  • Gli amministratori delle reti intranet possono impostare anche criteri di protezione e restrizioni per determinare se consentire o meno agli utenti di modificare le proprie impostazioni di connessione. È possibile impostare i criteri di protezione e le restrizioni nella Fase 5 del programma di personalizzazione di Internet Explorer o utilizzando la configurazione automatica.


Impostazioni proxy

È possibile specificare i server proxy ai quali gli utenti possono connettersi. Un server proxy funge da intermediario tra l'utente di una workstation e Internet e consente il controllo amministrativo e servizi di memorizzazione.

Selezionare la casella di controllo Attiva impostazioni proxy se si desidera utilizzare i server proxy per i servizi elencati.

Immettere l' indirizzo del server proxy a destra dei servizi elencati. Immettere il numero della porta, che corrisponde in genere a 80, nelle caselle appropriate relative a Porta.

Per utilizzare le stesse impostazioni per tutti i servizi, selezionare la casella di controllo Usa lo stesso server proxy per tutti gli indirizzi.

In alcuni casi è possibile che non si desideri utilizzare un server proxy, ad esempio per gli indirizzi sulla rete intranet aziendale. In questo caso è possibile immettere degli indirizzi specifici nella casella Non usare il server proxy per gli indirizzi che iniziano per. Utilizzare il punto e virgola per separare le voci. Selezionare la casella di controllo Non usare il server proxy per indirizzi locali (intranet) per ignorare i server proxy relativi agli indirizzi della rete intranet.

Per ulteriori informazioni, vedere Uso degli elenchi Selezione dei server proxy e Proxy da ignorare.


Aggiunta di un certificato principale

Al pacchetto IEAK personalizzato è possibile aggiungere un certificato principale, immettendo l’URL nella casella Nuovo percorso certificato principale. Ciò assicura un livello di attendibilità che i certificati dei livelli inferiori della gerarchia possono ereditare. Ciascun certificato viene verificato da un certificato di livello superiore fino ad arrivare al certificato principale.


Modalità di abbonamento

Il provider di servizi Internet può decidere la modalità di abbonamento e di connessione a Internet.

Abbonamento tramite server usando Connessione guidata Internet (consigliata)
I metodi utilizzati dal server di abbonamento Internet assicurano una completa flessibilità e un adattamento dinamico alle varie opzioni di abbonamento. È possibile creare soluzioni server per lo scambio di informazioni con la Connessione guidata Internet. Per ulteriori informazioni, vedere Abbonamento a Internet con Connessione guidata Internet.
Abbonamento tramite server utilizzando la modalità presentazione continua a schermo intero
I metodi utilizzati dal server di abbonamento Internet assicurano una completa flessibilità e un adattamento dinamico alle varie opzioni di abbonamento È possibile creare soluzioni server per lo scambio di informazioni con il browser in modalità presentazione continua a schermo intero, senza la visualizzazione dei pulsanti della barra degli strumenti. Per ulteriori informazioni, vedere Impostazione di un server per l'abbonamento per la modalità presentazione continua a schermo intero.
Abbonamento senza server
L'abbonamento senza server non richiede un server. Se si seleziona questa opzione, il programma di personalizzazione di Internet Explorer richiederà le informazioni necessarie per controllare il processo di abbonamento. Se si sceglie questa opzione, verrà chiesto all'utente di immettere tutte le informazioni relative alla composizione, al gateway e alla password. È inoltre possibile provare la propria pagina di abbonamento dal programma di personalizzazione di Internet Explorer. Non è possibile utilizzare la modalità di abbonamento senza server per personalizzare la Connessione guidata Internet.
Nessun abbonamento
Selezionare questa opzione se non si desidera che gli utenti eseguano una procedura di abbonamento quando installano il browser personalizzato. Questa opzione può essere utile quando vengono utilizzati i modem via cavo.

Per un esempio del processo di abbonamento, vedere Processo di abbonamento per l'ISP.


File per l’abbonamento

Per consentire agli utenti di configurare i propri computer per connettersi ai server è necessario creare dei file personalizzati per l’abbonamento. Per ulteriori informazioni, vedere Impostazione di un server per l’abbonamento in modalità presentazione continua a schermo intero e Abbonamento a Internet con la Connessione guidata Internet.

Il primo file deve essere una pagina HTML contenente informazioni sui servizi forniti. Per abbonarsi ai servizi Internet nella modalità presentazione continua, il file deve essere denominato Signup.htm e deve includere un collegamento a una corrispondente pagina HTML sul server per l’abbonamento. Per abbonarsi ai servizi Internet con la Connessione guidata Internet, il file deve essere denominato Icwsign.htm.

Nella schermata dei file per l’abbonamento è visualizzata la cartella di lavoro dei file per l’abbonamento. Se si sono già modificati i file per l’abbonamento, scegliere Copia file per copiarli nella directory di lavoro. Per verificare o specificare le impostazioni nei file isp e ins utilizzando le schermate del programma di personalizzazione visualizzate più avanti nella Fase 4 del programma, selezionare la casella di controllo relativa alla verifica o modifica delle voci del file isp oppure quella relativa alla verifica o modifica delle voci del file ins.

Tutti i file per l’abbonamento, inclusi i file grafici, devono essere salvati nella stessa cartella. È necessario disporre dell’accesso in scrittura e lettura per questa cartella, perché durante l'esecuzione del programma di personalizzazione gli attributi di tutti i file verranno cambiati in lettura-scrittura.

Definizione di file personalizzati per l’abbonamento
Immettere il percorso della cartella contenente i file per l’abbonamento oppure scegliere il pulsante Sfoglia per trovare la cartella.

Nota

  • Per ulteriori informazioni sui file isp, vedere Creazione di un file isp.


Informazioni del server per l'abbonamento Internet e file per le impostazioni Internet

La schermata Informazioni Server per l’abbonamento Internet consente di configurarele connessioni di accesso remoto degli utenti in modo che possano effettuare una connessione con il server Internet.

La schermata File per le impostazioni Internet fornisce le impostazioni utilizzate dal programma di personalizzazione di Internet Explorer per generare file ins. È possibile inviare sul server il file ins o incorporarlo nel pacchetto personalizzato creato per l'abbonamento senza server.

Nome di connessione
Digitare il nome del server per l'abbonamento. È possibile utilizzare un nome breve.
Nome del file
Immettere il nome del file Per i parametri di abbonamento, il file deve avere un’estensione isp; per le impostazioni Internet, il file deve avere un’estensione ins.
Proprietà di connessione
Per connettersi immettere il prefisso, il numero telefonico, l'indicativo e l'ID del paese.
Numeri di telefono del Servizio Supporto
È possibile inserire il numero di telefono per il servizio di supporto tecnico agli utenti.
URL della prima pagina per l'abbonamento in linea.
Digitare l'URL della prima pagina nel processo di abbonamento.
Opzioni avanzate
Per impostare le seguenti impostazioni di composizione e di gateway, scegliere Opzioni avanzate.
Usa indirizzo DNS statico
Domain Name System (DNS) consiste in una serie di protocolli e servizi per le reti Transmission Control Protocol/Internet Protocol (TCP/IP). DNS consente di utilizzare nomi quali www.microsoft.com al posto degli indirizzi numerici. Per garantire che verrà effettuata una ricerca in tutti i server DNS per il mapping del nome all'indirizzo IP, selezionare questa casella di controllo e immettere manualmente un indirizzo principale e uno secondario.
Richiede accesso
Impostare questa opzione se è necessario verificare che l'autenticazione di accesso a Windows del computer dell'utente sia attivata. Fornire la password di Windows consente l'accesso alla memoria cache della password di Windows dove viene memorizzata la password per l'ISP. Questa opzione è molto utile per assegnare lunghe stringhe casuali come password Questa opzione è valida solo per i client di Windows 95 e Windows 98.
Negozia TCP/IP
Specifica se consentire la negoziazione TCP/IP quando si stabilisce la connessione Internet.
Disattiva LCP
Indica se utilizzare le estensioni LCP quando si stabilisce un collegamento di protocollo punto a punto. Se il server per l'abbonamento non è in grado di gestire le estensioni LCP, si consiglia di disabilitare il protocollo LCP sul computer client che deve effettuare la connessione. Questo valore è valido solo per i client di Windows NT 4.0.
Componi numero come da esempio
Impedisce l'impostazione di un prefisso predefinito È possibile che si desideri impostare questo flag se ad esempio alcuni utenti chiamano da un prefisso diverso da quello predefinito. Se gli utenti non sanno che il prefisso predefinito differisce dal proprio prefisso, è possibile che incorrano in consistenti addebiti inaspettati.
Usa crittografia password
Specifica che il computer può accettare o ricevere solo password crittate. Questo è utile se è necessaria una maggiore protezione della connessione. Affinché l'opzione abbia effetto è necessario che il computer a cui ci si connette supporti le password crittate.
Usa compressione software
Specifica se le informazioni in entrata o in uscita saranno compresse prima dell'invio. Questa opzione risulta utile per velocizzare il trasferimento delle informazioni. Per assicurare il corretto funzionamento della compressione, è necessario che il tipo di compressione utilizzato da entrambi i computer sia compatibile.
Utilizza compressione intestazione IP
La compressione dell'intestazione TCP/IP è stata progettata per migliorare l'efficienza dell'utilizzo dell'ampiezza di banda su collegamenti seriali a bassa velocità. Il trasferimento dei dati tra i computer risulta in genere ottimizzato.

Ricreando un'intestazione ridotta che identifichi la connessione e indichi i campi modificati, sarà possibile trasmettere un numero inferiore di byte. Per assicurare il corretto funzionamento della compressione, è necessario che i pacchetti arrivino in ordine. La compressione non consente talvolta di ottenere ottimi risultati. Se ad esempio si utilizzano dispositivi vecchi, può non essere possibile eseguire la compressione. Per garantire una corretta interoperabilità, i driver SLIP (Serial Line Internet Protocol) che consentono la compressione dell'intestazione devono includere flag configurabili dall'utente stesso per disattivare la compressione.

Usa gateway remoto predefinito
Specifica se, in base all'impostazione predefinita, il traffico relativo al protocollo Internet è indirizzato alla connessione WAN. Un gateway è una connessione o un punto di interscambio che connette due reti altrimenti incompatibili.
Opzione relativa all'applicazione di tutte le informazioni sulla marcatura al file
Selezionare questa casella di controllo per applicare tutte le informazioni sulla marcatura personalizzata specificate nel programma di personalizzazione per questo file per l'abbonamento.
Nome del file cab per la marcatura
Digitare un nome per il file cab che contiene le informazioni sulla marcatura. Fare attenzione quando si specifica un nome di file per non sovrascriverne uno già esistente.
URL del file cab per la marcatura
Immettere l'URL nel punto in cui verrà o viene inviato il file cab per la marcatura.

Nota

  • È possibile impedire che il codice predefinito di un'area venga impostato da una voce nel file isp. La sintassi di questa voce è:
    Dial_As_Is=Yes

    Per ulteriori informazioni, vedere Creazione di un file isp.


Connessione guidata Internet

È possibile specificare che gli utenti utilizzino la Connessione guidata Internet per abbonarsi ai servizi Internet. È possibile creare soluzioni per server per lo scambio di informazioni con le schermate della Connessione guidata Internet. Questa funzionalità non è disponibile con la modalità di abbonamento senza server.

Testo della barra del titolo
Selezionare questa casella di controllo per specificare che i clienti utilizzano la Connessione guidata Internet per abbonarsi ai servizi Internet.
Immagine a sinistra
Digitare il percorso del file bmp di 164 x 458 pixel visualizzato nella parte sinistra della schermata della Connessione guidata Internet.
Immagine in alto
Digitare il percorso del file bmp di 49 x 49 pixel visualizzato nell'angolo superiore destro della schermata della Connessione guidata Internet.

Note

  • Per avere la certezza che la Connessione guidata Internet interagisca con il server, è necessario includere nel pacchetto del browser il componente per il binding dei dati HTML dinamico. Tale componente consente di visualizzare nella schermata della procedura guidata l’elenco dei file ISP in Signup.txt. È possibile specificare che questa opzione non venga visualizzata come scelta di installazione personalizzata, che gli utenti possono scegliere di non installare. Per eseguire questa operazione, deselezionare la casella di controllo Binding dei dati HTML dinamico nella schermata Opzioni di installazione avanzate. Quindi, in Installazione di Windows Update, Forza installazione verrà visualizzato nella colonna destra di questo componente.
  • Per un esempio del processo di abbonamento, vedere Processo di abbonamento per l'ISP.


Protezione

Per gestire la protezione, è possibile utilizzare le autorità di certificazione e la tecnologia Authenticode™.

È possibile utilizzare le autorità di certificazione per controllare i siti da cui gli utenti possono scaricare determinati contenuti, ad esempio controlli ActiveX e applet Java. Le autorità dei siti consistono in un tipo di certificato digitale per un sito Internet che, utilizzando la tecnologia Authenticode, visualizzano da dove provengono i programmi e verificano che non siano stati alterati.

È possibile importare queste impostazioni dal computer. Per modificare le impostazioni che verranno applicate ai computer degli utenti, selezionare Importa autorità di certificazione correnti, quindi scegliere il pulsante Modifica impostazioni.

Utilizzando Gestore certificati è possibile visualizzare e gestire le informazioni sulle autorità di certificazione. I certificati sono applicabili all'autenticazione del server di rete, all'autenticazione del client di rete, alla autenticazione della posta elettronica e alla distribuzione del software.

Authenticode consente di classificare autori o distributori di software e agenzie di credenziali come attendibili. È inoltre possibile importare queste impostazioni dal proprio computer. Per modificare le impostazioni che verranno applicate ai computer degli utenti, selezionare Importa le informazioni correnti sulla protezione Authenticode, quindi scegliere il pulsante Modifica impostazioni.


Impostazioni di protezione

In qualità di amministratore delle reti intranet è possibile gestire le aree di protezione e le restrizioni del contenuto per la propria società. È inoltre possibile personalizzare le impostazioni per ciascuna area di protezione. Mediante le restrizioni del contenuto è infine possibile impedire che gli utenti visualizzino materiale considerato offensivo.

Aree di protezione
Per modificare le impostazioni che verranno installate nei computer degli utenti, fare clic su Importa le impostazioni per le aree di protezione correnti, quindi scegliere il pulsante Modifica impostazioni. Nella Fase 5 è inoltre possibile specificare se gli utenti possono modificare le impostazioni di protezione.
Restrizioni del contenuto
Microsoft Internet Explorer consente di controllare il tipo di contenuto al quale è possibile accedere su Internet. Le impostazioni possono essere adattate in modo che riflettano il contenuto più appropriato per le seguenti quattro aree: lingua, scene di nudo, sesso e violenza.

Per modificare le restrizioni di contenuto che verranno applicate ai computer degli utenti, selezionare il pulsante di opzione Importa le impostazioni per le restrizioni del contenuto correnti, quindi scegliere il pulsante Modifica impostazioni. È quindi possibile modificare le impostazioni utilizzando le restrizioni d'accesso.

Note

  • Le restrizioni d'accesso utilizzano standard di restrizione molto elevati quando vengono abilitate la prima volta. È possibile modificare queste impostazioni in base alle proprie esigenze.
  • Non tutto il contenuto di Internet è soggetto a restrizione. Tenere presente che, se si consente agli utenti l'accesso a siti privi di restrizioni del contenuto, potrebbe essere visualizzato materiale non adeguato.


Fase 4, cenni preliminari: personalizzazione del browser

Programma di personalizzazione

Fase 4: personalizzazione del browser

In questa fase del programma di personalizzazione di Microsoft Internet Explorer, è possibile personalizzare l'aspetto e il funzionamento di Internet Explorer.

Le opzioni disponibili dipenderanno dalla qualifica dell'autore:

  • Provider di contenuti Internet
  • Provider di servizi Internet
  • Amministratore delle reti intranet

Nota

  • La disponibilità di alcune opzioni, ad esempio la possibilità di personalizzare il logo, dipende anche dal contratto di licenza. Per ulteriori informazioni, consultare il contratto.


Assegnazione criteri di protezione e restrizioni

Una gestione centralizzata dei criteri di sistema e delle restrizioni consente di mantenere un ambiente desktop uniforme in tutta l'organizzazione e di ridurre i conseguenti costi di assistenza tecnica.

I criteri di sistema e le restrizioni che è possibile impostare nel programma di personalizzazione di IEAK e gestire successivamente in Gestione profili di IEAK possono essere configurati per gli utenti dei sistemi operativi Windows 95, Windows 98 e Windows Millennium Edition.

Tuttavia, per gli utenti che non dispongono dei privilegi di amministrazione sulle piattaforme Windows NT o Windows 2000 è possibile configurare soltanto un sottoinsieme di questi criteri di sistema e restrizioni. Al contrario, per configurare i criteri e le restrizioni rimanenti si consiglia di utilizzare l'editor dei criteri di Windows NT o i criteri di gruppo di Windows 2000. Per ulteriori informazioni, vedere Amministrazione di Microsoft Internet Explorer in Windows 2000.

Visualizza tutti i criteri di protezione IEAK
L'intero insieme di criteri di sistema e restrizioni può essere configurato per tutti gli utenti dei sistemi operativi Windows 95, Windows 98 e Windows Millennium Edition e per gli utenti con i privilegi di amministratore su Windows NT e Windows 2000.
Visualizza il sottoinsieme dei criteri di protezione IEAK applicabili agli utenti non Admin
Scegliere questa opzione per visualizzare e configurare un sottoinsieme di criteri di protezione e restrizioni applicabili agli utenti dei sistemi operativi Windows NT e Windows 2000, che non dispongono dei privilegi di amministratore.


Programmi

È possibile importare le impostazioni del programma predefinito, come i programmi specifici di posta elettronica e i programmi per modificare i file HTML. Tali impostazioni si trovano nella scheda Programmi della finestra di dialogo Opzioni Internet.

Se non si desidera preimpostare le impostazioni dell’utente, selezionare Non personalizzare le impostazioni di connessione. Per importare le proprie impostazioni senza modificarle, selezionare Importa le impostazioni di connessione correnti. Per modificare le impostazioni e poi importarle, selezionare Importa le impostazioni di connessione correnti, quindi scegliere Modifica impostazioni.


Server e account Outlook Express

Per ulteriori informazioni sui server e sugli account Outlook Express, vedere quanto riportato di seguito.

Server

È possibile specificare i server della posta elettronica e delle news per Outlook Express e richiedere agli utenti di accedere al server eseguendo la connessione mediante l'autenticazione della password di protezione (SPA, Secure Password Authentication).

Scegliere il tipo di server della posta
Selezionare il protocollo in esecuzione sui server della posta elettronica. È possibile selezionare POP3, utilizzato dalla maggior parte degli utenti Internet sottoscritti per la posta elettronica, o IMAP, utilizzato principalmente da utenti di reti aziendali che desiderano leggere le posta elettronica da una posizione remota. Mentre i server POP3 consentono di accedere a una singola cartella Posta in arrivo, i server IMAP offrono l'accesso a più cartelle sul lato server.
Server della posta in arrivo
Nella casella di testo digitare l'indirizzo completo del server, ad esempio pop01.microsoft.com. Quindi scegliere Accesso tramite autenticazione password di protezione (SPA) (Secure Password Authentication) se il server POP3 o IMAP richiede l'autenticazione da parte di un provider SSPI come NTLM.
Server posta in uscita (SMTP)
Un server SMTP è il server della posta in uscita. In alcuni casi il server SMTP può avere lo stesso nome del server POP3, ad esempio smtp. microsoft.com. Nella casella di testo digitare l'indirizzo completo del server SMTP, quindi scegliere Accesso tramite autenticazione password di protezione (SPA) (Secure Password Authentication) se il server SMTP richiede l'autenticazione da parte di un provider SSPI come NTLM.
Server delle news (NNTP)
Il protocollo NNTP (Network News Transfer Protocol) viene utilizzato per distribuire i messaggi delle news di rete ai server NNTP e ai client NNTP (lettori delle news) su Internet. Nella casella di testo digitare l'indirizzo NNTP, ad esempio nntp.microsoft.com, quindi scegliere Accesso tramite autenticazione password di protezione (SPA) (Secure Password Authentication) se il server NNTP richiede l'autenticazione da parte di un provider SSPI come NTLM.

Account

Gli account utente, come la posta e le news, vengono configurati in base alle restrizioni specificate.

Rendi i nomi dei server di sola lettura
Selezionare questa opzione per creare impostazioni di account che gli utenti possono visualizzare ma non modificare.
Disabilita accesso agli account (impossibile aggiungere, rimuovere o modificare gli account)
Selezionare questa opzione per impedire l'eliminazione o la modifica di account preconfigurati o la creazione di ulteriori account. Questa opzione è consigliata solo per amministratori delle reti Intranet.


Impostazioni IMAP di Outlook Express

Utilizzare questa schermata per creare impostazioni IMAP predefinite per gli utenti. Tali impostazioni vengono preconfigurate per gli utenti quando creano gli account IMAP.

Percorso cartella principale
Il percorso della cartella principale è quello della cassetta postale che contiene tutte le cartelle degli utenti sul server IMAP. Per quanto riguarda i server Cyrus, tutte le cartelle degli utenti devono essere inserite nella cartella Posta in arrivo. Per quanto riguarda i server IMAP UNIX, la posta elettronica è in genere memorizzata in una sottocartella distinta della home directory dell'utente, ad esempio ~nomeutente/Posta. Si consiglia di non terminare il percorso della cartella principale con una barra (/). Il percorso ~nomeutente/Posta sarà infatti ritenuto valido, mentre il percorso ~nomeutente/Posta/ non lo sarà. Alcuni server IMAP, quali il server Microsoft Exchange, non richiedono un percorso della cartella principale.
Memorizza cartelle speciali sul server IMAP
Per specificare che le cartelle dei messaggi inviati e dei messaggi in avanzamento devono essere create sul server IMAP, selezionare Memorizza cartelle speciali sul server IMAP.
Percorso Posta inviata
Digitarte il percorso della cartella Posta inviata. Questo percorso verrà utilizzato da tutti gli utenti che creano account IMAP.
Percorso cartella Bozze
Digitarte il percorso della cartella Bozze. Questo percorso verrà utilizzato da tutti gli utenti per cui si configurano account IMAP.
Cerca nuovi messaggi in tutte le cartelle
Per eseguire automaticamente l'operazione di polling nelle cartelle sottoscritte per rilevare la presenza di nuovi messaggi all'avvio di Outlook Express e ad intervalli regolari di polling della posta, selezionare Cerca nuovi messaggi in tutte le cartelle. Se questa opzione non è selezionata, la ricerca di nuovi messaggi verrà effettuata solo nella cartella Posta in arrivo.


Contenuto personalizzato di Outlook Express

È possibile personalizzare l'interfaccia grafica di Outlook Express e visualizzare un messaggio di posta elettronica di benvenuto per i nuovi utenti.

Riquadro Informazioni

Il riquadro Informazioni di Outlook Express è un'area in cui i provider di contenuti possono inserire informazioni e collegamenti utili. È possibile personalizzare questo riquadro inserendo numeri di telefono di servizi di supporto tecnico, domande frequenti (FAQ) e informazioni sulla società.

Il riquadro Informazioni, la cui altezza è pari a 50 pixel, viene visualizzato nella parte inferiore della finestra principale di Outlook Express. È possibile personalizzare tale riquadro utilizzando un file HTML corrispondente a un file locale o a un indirizzo Internet (URL). Se si specifica un file locale, questo viene copiato nel pacchetto di distribuzione IEAK e quindi copiato sul computer dell'utente durante l'installazione.

Nota

  • Il riquadro Informazioni non viene visualizzato come parte dell'interfaccia utente di Outlook Express a meno che un URL o un file non sia specificato in IEAK.
URL
Digitare l'URL del file HTML da utilizzare per il riquadro Informazioni.
File locale
Se non si è specificato un URL nella casella di testo precedente, sarà possibile digitare il percorso del file HTML locale che si desidera utilizzare per il riquadro Informazioni oppure scegliere il pulsante Sfoglia per individuare il file. Se si specifica un file locale, sarà possibile specificare anche un'immagine da copiare.

Messaggio di benvenuto

È inoltre possibile fornire un messaggio di benvenuto come primo elemento della cartella Posta in arrivo di ciascun utente. Tale messaggio corrisponde a un file HTML. È inoltre necessario indicare il nome breve del mittente, ad esempio il nome della società o dell'organizzazione, e l'indirizzo di posta elettronica del destinatario.

Nota

  • IEAK non consente di inserire un'immagine nel messaggio di benvenuto. Tuttavia, se si modifica il messaggio di benvenuto al di fuori di IEAK, è possibile aggiungere un collegamento ad un'immagine presente sul Web.
Percorso file HTML
Digitare il percorso del file HTML da inviare o scegliere il pulsante Sfoglia per individuare il file.
Mittente
Digitare il nome della società o della persona che invia il messaggio di benvenuto, ad esempio Volcano Administration. Questo nome viene visualizzato nella riga Da del messaggio di benvenuto.
Indirizzo mittente per risposta
Digitare l'indirizzo di posta elettronica della società o della persona che invia il messaggio di benvenuto. In caso di dubbi o domande, l'utente può inviare messaggi di posta elettronica a questo indirizzo.


Impostazioni personalizzate di Outlook Express

Questa schermata consente di creare impostazioni valide per tutti gli utenti. È prevista l'impostazione di un client della posta e delle news predefinito. È inoltre possibile fornire informazioni utili agli utenti per ottenere ulteriori account di posta elettronica. È infine possibile fornire agli utenti un file predefinito per le regole dei messaggi.

Programmi di trasferimento messaggi predefiniti
Se si desidera che Outlook Express venga avviato ogni volta che un utente fa clic su un collegamento di posta elettronica in Internet Explorer, selezionare la casella di controllo Imposta Outlook Express come programma predefinito per: posta elettronica. L'impostazione relativa al client di posta predefinito viene anche utilizzata da molte applicazioni quando un utente invia dei documenti tramite posta elettronica. Questa impostazione sostituisce qualsiasi client della posta predefinito specificato dall'utente.

Se si desidera che Outlook Express venga avviato ogni volta che un utente fa clic su un collegamento delle news in Internet Explorer, selezionare la casella di controllo Imposta Outlook Express come programma predefinito per: news.

Newsgroup
In questa casella di testo digitare i nomi di uno o più newsgroup ai quali si desidera che gli utenti vengono sottoscritti automaticamente. È ad esempio possibile che un ISP o un'organizzazione disponga di diversi newsgroup che offrono assistenza e informazioni agli utenti. È possibile utilizzare tale caratteristica in modo che nuovi utenti sottoscrivano questi newsgroup.
Servizio per nuovi account
È possibile aggiungere una voce di menu che gli utenti possono utilizzare per ottenere un ulteriore account di posta elettronica dall'ISP. Questa voce viene aggiunta al menu Iscrizione a nuovo account in Outlook Express. Digitare il nome dell'ISP nella casella Nome servizio, ad esempio ISP Servizi telematici T.E.N., quindi digitare un URL nella casella URL servizio. Se l'utente sceglie questo nome di servizio dal menu, verrà visualizzata la pagina Web. Dopodiché verranno inviati all'ISP un numero di account, che può essere specificato nel file .ins, e un identificatore univoco.
Elimina tutti i collegamenti e le icone di Outlook Express
Se si seleziona questa casella di controllo, sul desktop o nel menu Avvio/Start non apparirà alcun collegamento al programma Outlook Express e le icone di Outlook Express verranno rimosse dalla barra di avvio veloce.


Impostazioni di visualizzazione di Outlook Express

È possibile personalizzare determinate visualizzazioni per stabilire se e come visualizzare elementi specifici di Outlook Express.

Generale
Utilizzare queste impostazioni per determinare gli elementi dell'interfaccia di Outlook Express da includere nella visualizzazione predefinita per i nuovi utenti.
  • Per includere la Barra cartelle come barra predefinita, selezionare la casella di controllo Barra cartelle.
  • Per visualizzare la barra di Outlook, una barra orizzontale che visualizza determinate cartelle, come Posta in arrivo, selezionare Barra di Outlook.
  • Per includere un elenco di cartelle di posta elettronica e di news nella colonna sinistra, selezionare la casella di controllo Elenco cartelle.
  • Per visualizzare la barra di stato che appare nella parte inferiore della finestra di Outlook Express, selezionare Barra di stato.
  • Per elencare i contatti inclusi in MSN Messenger Service, se installato e configurato, nonché gli indirizzi di posta elettronica corrispondenti, selezionare la casella di controllo Contatti.
  • Per visualizzare un suggerimento ad ogni avvio di Outlook Express, selezionare la casella di controllo Suggerimenti utili.
Barra degli strumenti
È possibile scegliere se visualizzare la barra degli strumenti per gli utenti e se includere del testo in essa. La barra degli strumenti viene visualizzata nella parte superiore della finestra di Outlook Express, contiene pulsanti che corrispondono a comandi di uso comune e può essere configurata dall'utente.
Riquadro di anteprima
È possibile includere un riquadro di anteprima dei messaggi nella visualizzazione predefinita dei messaggi di posta elettronica e news. Il riquadro di anteprima può essere rappresentato da un riquadro orizzontale situato al di sotto dell'elenco dei messaggi oppure un riquadro verticale accanto e a destra dell'elenco dei messaggi. Il riquadro di anteprima contiene un'area riservata all'intestazione che consente di visualizzare le informazioni dell'intestazione del messaggio, comprese le righe Da, A, Cc e Oggetto del messaggio.


Impostazioni di composizione di Outlook Express

Firme
È possibile apporre una firma predefinita, ad esempio la dichiarazione di non responsabilità della società, che verrà visualizzata nei messaggi di news o di posta elettronica di Outlook Express. La dichiarazione di non responsabilità viene spesso utilizzata per indicare che i messaggi inviati dai dipendenti di una società non rappresentano la politica aziendale ufficiale. La dimensione predefinita della firma è pari a 1 KB.

È possibile includere la firma digitale nei soli messaggi di news, nei soli messaggi di posta elettronica o in entrambi i tipi di messaggio.

Formato HTML e solo testo per i messaggi di posta elettronica e le news
In base all'impostazione predefinita, i messaggi di posta elettronica sono composti in formato HTML mentre la pubblicazione delle news è in formato solo testo. È comunque possibile ignorare tali impostazioni. In un ambiente caratterizzato da larghezza di banda limitata o in cui molti utenti dispongono di semplici applicazioni di posta elettronica che non sono in grado di interpretare il linguaggio HTML potrebbe ad esempio risultare utile impostare come predefinito il formato solo testo. Invece nel caso di un ambiente aziendale in cui tutti gli utenti utilizzano un lettore di news compatibile con il formato HTML, sarà utile modificare l'impostazione predefinita per la pubblicazione delle news in formato HTML.


Servizio di elenchi in linea della Rubrica di Windows

I servizi di elenchi in linea sono potenti strumenti di ricerca che consentono agli utenti di trovare persone e società in tutto il mondo. La Rubrica di Windows supporta il protocollo LDAP (Lightweight Directory Access Protocol) per l'accesso a tali servizi e consente di accedere ai servizi di elenchi in linea più noti. È possibile specificare i servizi LDAP per gli utenti.

Nome servizio
Digitare il nome del servizio LDAP. Questo sarà il nome che apparirà agli utenti.
Nome server
Digitare il nome del servizio di elenchi in linea che si desidera aggiungere, quale ldap.ISPTEN.it oppure ldap.centralino.it. Se per gli utenti che accedono a questi servizi si richiede l'autenticazione tramite un pacchetto SSPI quale NTLM, selezionare la casella di controllo Accesso tramite autenticazione password (SPA). La consueta autenticazione, con la combinazione di nome utente e password, può essere configurata utilizzando dei file .ins.
Sito Web servizio
Digitare l'URL della pagina iniziale del servizio di elenchi in linea.

Come visualizzare la pagina iniziale del servizio di elenchi in linea in Windows 95, Windows 98 o Windows NT

  1. In Windows, scegliere Avvio/Start, selezionare Trova, quindi Contatti.
  2. Nella finestra di dialogo Trova contatti, selezionare la pagina iniziale dell'elenco desiderato da Cerca in, quindi fare clic su Sito Web.

    Selezionare la pagina iniziale del servizio di elenchi in linea, quindi scegliere Sito Web.

Come visualizzare la pagina iniziale del servizio di elenchi in linea in Windows 2000 o Windows Millennium Edition

  1. In Windows, scegliere Avvio, selezionare Cerca, quindi Contatti.
  2. Nella finestra di dialogo Trova contatti, selezionare la pagina iniziale dell'elenco desiderato da Cerca in, quindi fare clic su Sito Web.
Base di ricerca
Conosciuta anche come radice o raggio d'azione, la base di ricerca è il livello gerarchico nel quale cercare un server LDAP specifico. La base di ricerca può essere un paese, un'organizzazione o un altro tipo di raggruppamento. In Outlook Express se non viene specificata alcuna base di ricerca, l'impostazione predefinita sarà "c=us." Per specificare una base di ricerca, digitare NULL.
Bitmap servizio
È possibile specificare un file .bmp personalizzato a 16 colori, di 134x38 pixel. Per ottenere una conversione dei colori uniforme, si consiglia di creare la bitmap utilizzando esclusivamente la tavolozza dei colori a 16 bit di Windows. Per individuare il file .bmp file nel computer in uso, scegliere il pulsante Sfoglia.
Timeout della ricerca
È possibile specificare la durata dell'attesa prima che si verifichi il timeout della richiesta di ricerca. Utilizzare il dispositivo di scorrimento per impostare un valore compreso tra 30 secondi e 5 minuti.
Numero massimo di corrispondenze
È possibile controllare il numero massimo di risultati da restituire agli utenti. Digitare il numero in questa casella.
Risoluzione nomi
Per fare in modo che Outlook Express risolva i nomi sul server quando vengono inviati i messaggi di posta elettronica, selezionare Verifica i nomi sul server all'invio di messaggi. Questa impostazione consente di cercare negli indirizzi di posta elettronica i nomi digitati in corrispondenza delle righe A, Cc e Ccn di un messaggio.


Criteri e restrizioni

Se il proprio ruolo lo consente, è possibile specificare impostazioni valide per l'intera organizzazione e applicabili ai vari aspetti delle macchine degli utenti, inclusi il desktop, i componenti Internet, il sistema operativo e la protezione.

I provider di contenuti Internet, i provider di servizi Internet e gli amministratori delle reti Intranet possono specificare le impostazioni predefinite per gli utenti. Inoltre, gli amministratori delle reti Intranet possono personalizzare e limitare numerose impostazioni, che spaziano dalla possibilità di consentire all'utente di eliminare le stampe alla possibilità di aggiungere elementi sul desktop.

Per ulteriori informazioni, vedere Impostazioni e restrizioni.

I criteri di sistema e le restrizioni che è possibile impostare nel programma di personalizzazione di IEAK e gestire successivamente in Gestione profili di IEAK possono essere configurati per gli utenti dei sistemi operativi Windows 95, Windows 98 e Windows Millennium Edition.

Tuttavia, per gli utenti che non dispongono dei privilegi di amministrazione sulle piattaforme Windows NT o Windows 2000 è possibile configurare soltanto un sottoinsieme di questi criteri di sistema e restrizioni. Al contrario, per configurare i criteri e le restrizioni rimanenti si consiglia di utilizzare l'editor dei criteri di Windows NT o i criteri di gruppo di Windows 2000. Per ulteriori informazioni, vedere Amministrazione di Microsoft Internet Explorer in Windows 2000.

È importante comprendere appieno le conseguenze delle impostazioni di protezione per gli utenti, specialmente nel caso di utenti con profili personali che condividono i computer con altri utenti. Per ulteriori informazioni, vedere la nota che segue.

Per impostare i criteri di protezione e le restrizioni

  1. Fare doppio clic su ciascuna categoria per visualizzare le relative opzioni.
  2. Selezionare o deselezionare le caselle di controllo desiderate.

Note

  • Le impostazioni visualizzate durante l'esecuzione del programma di personalizzazione sono contenute nei file di amministrazione (.adm) inclusi in IEAK. Se si è esperti di file .adm, è possibile utilizzare il programma di personalizzazione di Internet Explorer per impostare i criteri di protezione e le restrizioni forniti nei propri file .adm scegliendo Importa.

    Le scelte effettuate per queste impostazioni e restrizioni vengono memorizzate come file .ins. I file .ins vengono utilizzati per generare i file .inf necessari per il pacchetto personalizzato. Per ulteriori dettagli sulla relazione tra file .adm e file .inf, vedere Criteri di protezione e impostazioni.

  • Per accertarsi che l'impostazione Autori attendibili venga applicata alla sezione relativa alla protezione delle restrizioni Internet, è necessario verificare che le aree di protezione e i criteri di protezione siano impostati correttamente.

Le impostazioni utente possono essere memorizzate in una posizione centrale e rese disponibili per gli utenti che non si connettono sempre dallo stesso computer. Questa funzionalità è ad esempio utile nel caso di un utente che necessita di una protezione bassa, ma che accede a un computer che viene in genere utilizzato da un utente con impostazioni di protezione molto restrittive.

Personalizzazione delle impostazioni di protezione

È possibile consentire tre livelli di personalizzazione per le impostazioni di protezione.

  • Controllare o "bloccare" tutte le impostazioni.

    Per bloccare tutte le impostazioni

    1. Fare clic su Restrizioni d'accesso. Quindi, fare clic su Protezione.
    2. Selezionare la casella di controllo Utilizzare solo le impostazioni del computer per le aree di protezione.
  • Controllare le impostazioni utente consentendo al tempo stesso il download dei profili personali.

    È possibile specificare che le impostazioni non possono essere modificate senza impedire necessariamente l'accesso agli utenti con profili personali. Questa funzionalità di Windows consente agli utenti di scaricare le proprie impostazioni da un server.

    Per impedire a un utente di modificare i criteri di protezione di un'area

    1. Fare clic su Restrizioni d'accesso. Quindi, fare clic su Protezione.
    2. Selezionare la casella di controllo Non consentire agli utenti di modificare i criteri di protezione per le aree di protezione.

    Per impedire agli utenti di aggiungere o eliminare i siti

    1. Fare clic su Restrizioni d'accesso. Quindi, fare clic su Protezione.
    2. Selezionare la casella di controllo Non consentire agli utenti di aggiungere/eliminare i siti dall'area di protezione.
  • Personalizzare le impostazioni iniziali consentendo al tempo stesso agli utenti di modificarle.

    In questa fase del programma di personalizzazione è possibile personalizzare diverse impostazioni utente, inclusi i livelli di protezione e le restrizioni. La personalizzazione delle impostazioni in questa fase non implica necessariamente che gli utenti possano modificarle.


Marcatura di MSN Messenger Service

È possibile specificare un nome di prodotto per il client del servizio Messenger personalizzato e un URL per il download.

Nome del prodotto
Per il nome del prodotto, scegliere una delle seguenti opzioni.
  • Selezionare Opzione 1 per usare "MSN Messenger Service" come nome breve del prodotto. Digitare una stringa nella casella di testo che segue "MSN Messenger Service". Il nome completo del prodotto sarà da "MSN Messenger Service - [nome società]" Questa opzione è consigliata.
  • Selezionare Opzione 2 per specificare un nome breve univoco del prodotto. Digitare il nome breve del prodotto nella casella di testo Nome del prodotto. Il nome completo del prodotto sarà "[Nome univoco del prodotto] (basato su tecnologia MSN)". Notare che la società è responsabile unicamente per la scelta del nome e del logo del prodotto. Accertarsi di aver consultato il proprio legale per eventuali questioni riguardanti il nome e il logo selezionati.

Nel client personalizzato, il nome breve del prodotto viene visualizzato nella barra delle applicazioni, nell'elenco dei processi, nella Guida in linea e come testo in linea in altre finestre di dialogo di altri prodotti. Il nome completo del prodotto viene visualizzato nella finestra di dialogo ? Informazioni su, nella finestra principale della barra del titolo e nella barra del titolo della finestra di dialogo Accesso. Non usare i seguenti caratteri nel nome di un prodotto: + " % / \ : * ? < > | & .

Versioni internazionali e nome del prodotto
MSN Messenger Service è localizzato in 27 lingue, mentre IEAK lo è in un numero minore. In alcuni casi l'installazione guidata di IEAK potrebbe non visualizzare le stringhe localizzate in alcuni lingue, ma la risultante versione di installazione personalizzata conterrà comunque il nome localizzato corretto. Inoltre, la stringa "provided by" o "(powered by MSN)" verrà localizzata in 27 lingue anche se l'installazione guidata di IEAK non visualizza la stringa localizzata. Se l'installazione guidata di IEAK non localizza correttamente queste stringhe, aprire il file di configurazione msmsgs.in_ con un editor di testo e verificare che le stringhe complete siano corrette.
URL per il download
Digitare un URL per il download del client personalizzato. IEAK crea un pacchetto di installazione separato per il client del servizio Messenger personalizzato. Quando un utente esegue la procedura guidata Aggiungere un contatto nel client, può essere generata e inviata al nuovo contatto una e-mail di invito contenente il collegamento per il download. L'URL per il download fornito deve indirizzare a una pagina HTML del sito Web che spiega il client del servizio Messenger e come procedere all'installazione. La pagina HTML deve poi avere un collegamento, interno al sito, all'eseguibile personalizzato per l'installazione. Se non viene fornito un URL per il download, viene usata la pagina predefinita per l'installazione del sito Web di MSM Messenger Service.


Marcatura di MSN Messenger Service (supporto)

È possibile specificare un logo personalizzato da usare come immagine di marcatura in diverse aree del client di Messenger Service. È inoltre possibile specificare suoni personalizzati per gli eventi di posta. In alcuni casi, i nomi dei file specificati per gli eventi seguenti, devono essere nomi con soli caratteri ASCII. Nomi di file non ASCII verranno sostituiti da versioni ASCII predefinite.

Logo
Digitare l'indirizzo per l'immagine gif personalizzata oppure fare clic su Sfoglia per cercarla. Le dimensioni dell'immagine devono essere di 234 x 50 pixel. Il logo verrà visualizzato in aree con sfondo bianco, quindi anche il colore dello sfondo del logo deve essere bianco (valore RGB 255,255,255) senza layer di trasparenza. Il logo viene visualizzato nell'area Promozione, nella finestra di dialogo Informazioni su e nelle procedure guidate Aggiunta di un contatto e Nuovo utente. È vivamente consigliato l'inserimento di un logo personalizzato. Se il logo non viene fornito, verrà visualizzato quello di "MSN Messenger Service".
URL del logo
Digitare un URL, ad esempio la pagina iniziale del sito, da associare all'immagine gif del logo personalizzato. Se viene fatto clic sul logo nell'area Promozione del client di Messenger Service, verrà aperta una nuova finestra del browser all'indirizzo specificato. Se non viene fornito un ULR, l'immagine del logo non collega a nulla.
File sonori
Per Contatto in linea, Nuova posta, o Nuovo messaggio, digitare la posizione di un file wav oppure fare clic su Sfoglia per cercare un file sonoro. L'assegnazione di suoni a eventi di posta è opzionale. Se non sono specificati dei suoni, il client userà quelli predefiniti. I suoni possono anche essere selezionati dagli utenti nella scheda Generale della finestra di dialogo Opzioni La frequenza di campionamento di tali file wav deve essere di 11,025 kHz, 22,050 kHz o 44,100 kHz. Provare i suoni, accertandosi che la riproduzione frequente degli stessi durante il normale uso del prodotto non sia fastidiosa per l'utente.
Contatto in linea
Questo suono viene riprodotto quando una persona presente nell'Elenco contatti è in linea.
Nuova posta
Questo suono viene riprodotto quando un utente riceve nuova posta. Questa funzione al momento è disponibile solo per la posta MSN Hotmail.
Nuovo messaggio
Questo suono viene riprodotto quando un utente riceve un nuovo messaggio immediato o riceve un susseguente messaggio in una finestra di messaggio immediato nascosta.
File XML
Digitare l'URL del documento XML usato per generare i contenuti per l'area Promozione del client. Vedere Formato del file XML per la promozione di Messenger Service per dettagli e definizioni sul formato XML. Vedere Contenuti promozionali del client di Messenger Service personalizzato per informazioni generali. Se non è specificato un file XML, il client di Messenger Service visualizzerà il contenuto promozionale di MSN Messenger Service.


Account di MSN Messenger Service

Passport e connessione al servizio Messenger

È necessario che gli utenti che si apprestano ad effettuare il collegamento al server dispongano di un account Passport emesso da una delle autorità del dominio Passport. Per collegarsi non è necessario disporre del Passport rilasciato da un dominio specifico. Per ulteriori informazioni e domande su Passport, domini e account del servizio, vedere il sito Web Passport.

Dominio
Selezionare il dominio di emissione del Passport preferito dall'elenco. Il dominio verrà visualizzato nell'elenco dei domini quando compare la finestra di dialogo Accesso e nelle aree delle procedure guidate Aggiunta di un contatto e Nuovo utente. È utile specificare il dominio se si prevede che la gran parte degli utenti utilizzerà i Passport emessi da un'autorità spacifica. Si consiglia di utilizzare "hotmail.com" o "passport.com" come autorità di dominio.

Nota

  • In futuro potrebbero essere in linea altre autorità di dominio del Passport non incluse correntemente nell'elenco. Se un'autorità non è inclusa nella lista, digitare il nome dell'autorità direttamente nella casella di testo Dominio.
URL per l'abbonamento
Questo campo specifica l'URL contenuto in una finestra del browser quando si seleziona Abbonamento sulla scheda Account della casella di dialogo Opzioni del client. Non è necessario specificare l'URL se si è già specificato "hotmail.com" o "passport.com" nell'elenco Dominio. È invece obbligatorio se non si è provveduto a specificare un dominio esistente nella lista. Se non si è specificata l'URL né selezionato "hotmail.com" o "passport.com" nell'elenco Dominio , per accedere alle pagine relative alla registrazione del dominio utilizzare i pulsanti del client Richiedi Passport e Abbonamento. In caso contrario, l'URL consentirà di collegarsi direttamente alla pagina di registrazione dell'autorità di dominio del Passport o ad una pagina personalizzata che contiene spiegazioni sulla procedura di registrazione. Qusta pagina personalizzata includerà un collegamento alla pagina di registrazione di un'autorità.

Se il proprio sito dispone di un ID del Passport, è possibile aggiungerlo insieme all'URL che consente l'accesso al server di registrazione del Passport per consentire la marcatura. Per ulteriori informazioni su ID dei siti, co-marcatura e accesso alle pagine Web dell'autorità di dominio del Passport, vedere il Software Developer Kit (SDK) del Passport o il sito Web Passport developers.

Server di posta
Il client di Messenger Service può essere configurato per utilizzare server di posta differenti per determinate operazioni, in particolare per il pulsante Posta nella barra degli strumenti del client e l'opzione di menu Invia posta visualizzato quando ci si collega facendo doppio clic col pulsante destro del mouse. Il servizio di posta predefinito per un client di Messenger Service è MSN Hotmail. Nella versione corrente del client di Messenger Service le notifiche delle e-mail sono supportate soltanto dall'opzione Hotmail. Sono disponibili due ulteriori opzioni che supportano i server di posta nel client.
  • In caso di servizio e-mail su Web selezionare URL dell'home page di un servizio di e-mail. Digitare l'URL della pagina di composizione del servizio di posta nella casella di testo URL e-mail. Se si seleziona il pulsante Posta o si seleziona l'opzione Invia posta per inviare un messaggio ad un utente specifico, l'URL aprirà una nuova finestra del browser. Alle informazioni per l'utente che ha ricevuto il messaggio non si accederà tramite l'URL, a meno che il sistema di e-mail non sia basato su cookie e l'utente non si sia abbonato in precedenza. L'utente dovrà con molta probabilità immettere nuovamente le informazioni relative alla sua identificazione all'interno del computer dal quale il messaggio è stato inviato. Inoltre, l'indirizzo e-mail non potrà essere immesso automaticamente nella riga A: usando questa opzione. Per questo tipo di impostazione del servizio basato su Web non sono disponibili nuove notifiche di e-mail. Questa opzione è di solito adatta agli ICPs.
  • Selezionare Usa il client di posta predefinito sul computer dell'utente finale per utilizzare il client di posta predefinito del browser. Il client di posta predefinito è quello configurato nel registro per utilizzare il protocollo mailto. Si tratta solitamente di un client di posta POP3. Digitare il nome del server di della posta (POP3) nella casella di testo Server posta in arrivo. Selezionare Accesso tramite autenticazione password se il server della posta POP3 supporta le credenziali di SPA (Secure Password Authentication).

    Se si fa clic sul pulsante Posta o si seleziona l'opzione Invia posta per inviare un e-mail ad un altro utente, verrà considerata l'applicazione di posta predefinita. Il client di MSN Messenger Service versione 2.1 non supporta il controllo dei server POP3 esterni nelle notifiche relative alla nuova posta. Se si provvede ad un percorso del server della posta POP3 e all'impostazione Accesso tramite autentificazione password adeguata, verranno visualizzate nuove notifiche durante l'aggiornamento futuro del client di Messenger Service. Controllare il sito Web MSN Messenger Servicee > per gli aggiornamenti. Questa opzione è di solito adatta agli ISP.


Riepilogo del passaggio 5: Personalizzazione dei componenti

Programma di personalizzazione

Passaggio 5: Personalizzazione dei componenti

In questa fase del programma di personalizzazione di Internet Explorer, è possibile specificare le impostazioni, i criteri di protezione e le restrizioni per i componenti inclusi nel pacchetto personalizzato.

Le opzioni disponibili variano a seconda se si è un:

  • Provider di contenuti Internet
  • Provider di servizi Internet
  • Amministratore delle reti Intranet