Caratteristiche fondamentali dell'Utilità di pianificazione

Utilità di pianificazione

L'Utilità di pianificazione consente di pianificare l'esecuzione di comandi, applicazioni o script in momenti determinati:

  • Prima di impiegare l'Utilità di pianificazione, vedere Elenco di controllo.
  • Per ottenere informazioni relative a operazioni specifiche, vedere Procedure.
  • Per informazioni di carattere generale, vedere Concetti.
  • Per informazioni sulla risoluzione dei problemi, vedere Risoluzione dei problemi.


Elenco di controllo dell'Utilità di pianificazione

Elenco di controllo

La tabella riportata di seguito elenca le operazioni eseguite con maggiore frequenza mediante l'Utilità di pianificazione. Per un elenco completo delle informazioni sull'Utilità di pianificazione, vedere Procedure.

Istruzione | Riferimento
Prima di pianificare l'esecuzione di un'operazione, è necessario aggiungere l'operazione. | Pianificare una nuova operazione
Dopo aver creato le operazioni pianificate, è possibile modificare il programma, la pianificazione o le specifiche di una particolare operazione. | Modificare un'operazione pianificata
È possibile rimuovere completamente le operazioni pianificate che non sono più necessarie. | Rimuovere un'operazione pianificata
Se un'operazione pianificata viene eseguita durante le normali attività, è possibile interrompere l'esecuzione dell'operazione e riavviarla in seguito. | Interrompere l'esecuzione di un'operazione pianificata
È possibile arrestare o interrompere temporaneamente l'esecuzione di tutte le operazioni pianificate e riprenderla in seguito. | Interrompere temporaneamente tutte le operazioni pianificate


Procedure

  • Pianificare operazioni
  • Gestire l'Utilità di pianificazione


Pianificare operazioni
  • Avviare l'Utilità di pianificazione
  • Pianificare una nuova operazione
  • Modificare un'operazione pianificata
  • Rimuovere un'operazione pianificata
  • Interrompere l'esecuzione di un'operazione pianificata
  • Eseguire immediatamente un'operazione


Avviare l'Utilità di pianificazione

Per avviare l'utilità di pianificazione

  • Per avviare l'Utilità di pianificazione, fare doppio clic sull'icona Risorse del computer, quindi su Operazioni pianificate.
  • Fare doppio clic su Operazioni pianificate, quindi su Aggiungi operazione pianificata per aprire la Pianificazione guidata operazioni, che guida l'utente durante la pianificazione di un'operazione.


Pianificare una nuova operazione

Per pianificare una nuova operazione
  1. Avviare l'Utilità di pianificazione.
  2. Fare doppio clic su Aggiungi operazione pianificata.
  3. Seguire le istruzioni visualizzate durante la procedura guidata Aggiungi operazione pianificata.

Note

  • Se si desidera configurare le impostazioni avanzate per l'operazione, selezionare la casella di controllo Apri le proprietà avanzate per questa operazione quando si sceglie Fine nella schermata finale della procedura guidata.
  • Se si desidera che la nuova operazione venga eseguita più volte all'avvio, selezionare la casella di controllo Apri le proprietà avanzate per questa operazione quando si sceglie Fine nella schermata finale della procedura guidata, quindi fare clic sulla scheda Pianificazione e scegliere il pulsante Avanzate.
  • Se per l'operazione è richiesta l'impostazione di parametri, selezionare la casella di controllo Apri le proprietà avanzate per questa operazione quando si sceglie Fine nella schermata finale della procedura guidata, quindi fare clic sulla scheda Operazione e digitare i parametri nella casella Esegui dopo il percorso dell'operazione.
  • Assicurarsi che la data e l'ora di sistema siano corrette. Tali informazioni vengono infatti utilizzate per stabilire quando eseguire le operazioni pianificate. Per controllare o modificare la data e l'ora, fare doppio clic sull'ora visualizzata sulla barra delle applicazioni.


Modificare un'operazione pianificata

Per modificare un'operazione pianificata
  1. Avviare l'Utilità di pianificazione.
  2. Fare clic con il pulsante destro del mouse sull'operazione che si desidera modificare, quindi scegliere Proprietà.
  3. Eseguire almeno una delle seguenti operazioni:
    • Per cambiare l'applicazione da eseguire, digitare il percorso relativo alla nuova applicazione nella casella Esegui.
    • Per modificare la pianificazione di un'operazione, fare clic sulla scheda Pianificazione.
    • Per personalizzare le impostazioni dell'operazione, fare clic sulla scheda Impostazioni.

Note

  • Se si modifica l'account utente o si cambia l'applicazione in esecuzione, sarà necessario specificare la password per il nuovo account utente.
  • Se per l'esecuzione dell'applicazione è richiesta la specifica di opzioni della riga di comando, digitarle nella casella Esegui dopo il percorso dell'operazione.
  • Se il percorso relativo all'applicazione include spazi, racchiudere il percorso completo dell'operazione tra virgolette ("").
  • Assicurarsi che la data e l'ora di sistema siano corrette. Tali informazioni vengono infatti utilizzate per stabilire quando eseguire le operazioni pianificate. Per controllare o modificare la data e l'ora, fare doppio clic sull'ora visualizzata sulla barra delle applicazioni.


Rimuovere un'operazione pianificata

Per rimuovere un'operazione pianificata
  1. Avviare l'Utilità di pianificazione.
  2. Fare clic con il pulsante destro del mouse sull'operazione che si desidera rimuovere, quindi scegliere Elimina.

Note

  • La rimozione di un'operazione pianificata implica l'eliminazione dell'operazione solo dall'elenco delle pianificazioni. Il file di programma non viene rimosso dal disco rigido.
  • È anche possibile rimuovere un'operazione pianificata anche premendo il tasto CANC.


Interrompere l'esecuzione di un'operazione pianificata

Per interrompere l'esecuzione di un'operazione pianificata
  1. Avviare l'Utilità di pianificazione.
  2. Fare clic con il pulsante destro del mouse sull'operazione di cui si desidera interrompere l'esecuzione, quindi scegliere Termina operazione.

Note

  • Se un'operazione pianificata prevede l'avvio di un'altra applicazione, il comando consente di interrompere l'esecuzione solo dell'operazione originale e non dell'applicazione.
  • Per riavviare un'operazione interrotta, fare clic con il pulsante destro del mouse sull'operazione, quindi scegliere Esegui.


Eseguire immediatamente un'operazione

Per eseguire immediatamente un'operazione
  1. Avviare l'Utilità di pianificazione.
  2. Fare clic con il pulsante destro del mouse sull'operazione che si desidera avviare, quindi fare clic su Esegui.

Note

  • Per interrompere l'esecuzione di un'operazione, scegliere Termina operazione dal menu File.
  • Qualora un'operazione pianificata non venga eseguita, scegliere Visualizza registro dal menu Avanzate per esaminare il file registro dell'operazione.


Gestire l'Utilità di pianificazione
  • Visualizzare il registro di operazioni pianificate in precedenza
  • Visualizzare operazioni pianificate in computer remoti
  • Interrompere temporaneamente tutte le operazioni pianificate
  • Interrompere l'esecuzione dell'Utilità di pianificazione
  • Impostare l'Account del servizio AT


Visualizzare il registro di operazioni pianificate in precedenza

Per visualizzare il file registro di operazioni pianificate in precedenza
  1. Avviare l'Utilità di pianificazione
  2. Scegliere Visualizza registro dal menu Avanzate.


Visualizzazione di operazioni pianificate in computer remoti

Per visualizzare operazioni pianificate in computer remoti
  1. Sul desktop fare doppio clic su Risorse di rete.
  2. Fare doppio clic sull'icona del computer di cui si desidera visualizzare le operazioni pianificate.
  3. Fare clic su Operazioni pianificate.

Note

  • Solo l'amministratore del computer remoto che ha installato Windows può visualizzare le operazioni.
  • È possibile modificare le operazioni in un computer remoto in cui è in esecuzione Windows solo se è installato anche il software per il registro di configurazione remoto e se viene utilizzata la condivisione x$ dove x rappresenta il disco rigido in cui si trova la cartella Operazioni pianificate. È inoltre necessario che l'account utilizzato disponga dell'autorizzazione per l'accesso al registro di configurazione remoto. Per specificare l'utente che avrà l'accesso al registro di configurazione remoto di un computer in cui è installato Windows, fare clic sull'icona Password nel Pannello di controllo.


Interrompere temporaneamente tutte le operazioni pianificate

Per interrompere temporaneamente tutte le operazioni pianificate
  1. Avviare l'Utilità di pianificazione

  2. Scegliere Sospendi l'Utilità di pianificazione dal menu Avanzate.

Note

  • Utilizzare questo comando se si sta eseguendo un altro programma, quale un gioco o la procedura di installazione di un programma e non si desidera che le operazioni pianificate vengano eseguite contemporaneamente.
  • Se si interrompe l'esecuzione dell'Utilità di pianificazione, le operazioni stabilite non verranno eseguite fino all'orario previsto dalla pianificazione.
  • Per ripristinare le pianificazioni di tutte le operazioni, scegliere Ripristina l'Utilità di pianificazione dal menu Avanzate.


Interrompere l'esecuzione dell'Utilità di pianificazione

Per interrompere l'esecuzione dell'Utilità di pianificazione
  1. Avviare l'Utilità di pianificazione
  2. Scegliere Disattiva l'Utilità di pianificazione dal menu Avanzate.

Nota

  • Se si disattiva l'Utilità di pianificazione, le operazioni non verranno eseguite e l'Utilità non verrà avviata automaticamente all'avvio di Windows.


Impostare l'Account del servizio AT

Per impostare l'Account del servizio AT
  1. Avviare l'Utilità di pianificazione
  2. Scegliere Account servizio AT dal menu Avanzate.
  3. Fare clic su Account specifico, quindi digitare l'account utente che consentirà di eseguire le operazioni pianificate mediante il comando at.
  4. Nelle caselle Password e Conferma password digitare la password corretta.

Note

  • Il servizio AT è disponibile solo in Windows NT.
  • In alternativa è possibile fare clic su Account sistema. Se si seleziona questa opzione, le operazioni pianificate con il comando at utilizzando l'account del sistema locale che richiede diritti amministrativi.

  • L'account utente specificato necessita delle autorizzazioni appropriate per eseguire le operazioni pianificate mediante il comando at. Se ad esempio si pianifica l'esecuzione di programmi solo da parte degli amministratori, l'account utente specificato deve essere un account con privilegi amministrativi.


Concetti relativi all'Utilità di pianificazione

Concetti

Questa sezione fornisce informazioni di carattere generale sull'Utilità di pianificazione:

  • Introduzione all'Utilità di pianificazione
  • Utilizzo dell'Unità di pianificazione
  • Utilità di pianificazione e comando at
  • Utilità di pianificazione e protezione
  • Risoluzione dei problemi


Introduzione all'Utilità di pianificazione

L'Utilità di pianificazione consente di pianificare l'esecuzione di operazioni, quali l'Utilità di deframmentazione dischi, a intervalli specificati dall'utente. L'Utilità viene eseguita in secondo piano a ogni avvio del sistema.

L'Utilità di pianificazione consente di effettuare quanto segue:

  • Pianificare un'operazione perché venga eseguita ogni giorno, ogni settimana, ogni mese oppure in determinati momenti ad esempio all'avvio del sistema.
  • Modificare la pianificazione di un'operazione.
  • Terminare un'operazione pianificata.
  • Personalizzare la modalità di esecuzione di un'operazione a un'ora prestabilita.


Utilizzo dell'Utilità di pianificazione

Il sistema operativo Windows installa automaticamente l'Utilità di pianificazione. Per utilizzare il servizio di pianificazione, fare doppio clic sulla cartella Operazioni pianificate in Risorse del computer.

Per aggiungere operazioni, fare doppio clic su Aggiungi operazione pianificata. Verrà avviata la Pianificazione guidata operazioni. È possibile aggiungere operazioni trascinando script, programmi o documenti da Esplora risorse o dal desktop alla finestra dell'Utilità di pianificazione.

L'Utilità può anche essere utilizzata per modificare, eliminare, interrompere o arrestare le operazioni pianificate, per visualizzare il registri di operazioni pianificate in precedenza o per visualizzare operazioni pianificate in un computer remoto.

Per informazioni dettagliate sull'utilizzo dell'Utilità di pianificazione, vedere Procedure.

Informazioni utili relative all'Utilità di pianificazione

Nel sistema operativo Windows è possibile utilizzare l'Utilità di pianificazione per stabilire l'esecuzione di qualsiasi applicazione. Per trarre vantaggio da questa applicazione, assicurarsi che la data e l'ora di sistema siano corrette prima di aggiungere un'operazione.


Utilizzare l'Utilità di pianificazione e il comando at

L'Utilità di pianificazione e il comando at

Oltre all'Utilità di pianificazione, è anche possibile utilizzare il comando at per l'esecuzione automatica delle operazioni.

Il funzionamento dell'Utilità di pianificazione e del comando at non è identico, ma tali utilità consentono di ottenere lo stesso risultato. Un'operazione pianificata con il comando at viene riportata nell'elenco visualizzata nella finestra dell'Utilità di pianificazione.

L'Utilità di pianificazione consente di modificare le proprietà di un'operazione pianificata mediante il comando at. Se tuttavia si sceglie questa impostazione, non sarà più possibile accedere all'operazione con il comando at ma solo con l'Utilità di pianificazione.

Per specificare l'account utente che consentirà di eseguire le operazioni pianificate mediante il comando at in Risorse del computer fare clic sull'icona Operazioni pianificate e scegliere Account servizio AT dal menu Avanzate.

Nota

  • Il servizio AT è disponibile solo in Windows NT.


Protezione dell'Utilità di pianificazione

Utilità di pianificazione e protezione

All'interno dell'Utilità di pianificazione è possibile impostare la protezione assegnando un nome utente e una password a un'operazione specifica. Una volta fornite queste informazioni, l'operazione non potrà essere annullata o eliminata da un altro utente.

Note

  • La funzionalità di protezione è disponibile solo in Windows NT.
  • Per procedere, è necessario specificare un nome utente all'interno della Pianificazione guidata operazioni. Non sono richieste password.
  • È possibile modificare o impostare una nuova password selezionando la casella di controllo Apri le proprietà avanzate per questa operazione quando si sceglie Fine nella schermata finale della procedura guidata.


Risoluzione dei problemi relativi all'Utilità di pianificazione

Se un'operazione pianificata non viene eseguita nel momento prestabilito, fare clic con il pulsante destro del mouse sull'operazione, quindi scegliere Proprietà. Nella scheda Operazione verificare che la casella di controllo Attivata sia selezionata. Nella scheda Pianificazione verificare che la pianificazione sia impostata correttamente.

Se un'operazione non viene eseguita in modo corretto, potrebbe essere necessario aggiungere le opzioni della riga di comando. Per ulteriori informazioni su un particolare programma e sulle opzioni della riga di comando, provare a eseguire una delle seguenti operazioni:

  • Visualizzare la Guida in linea del programma, se disponibile.

  • Al prompt dei comandi, digitare la stringa seguente: (dove programma è il nome del programma)

    • programma /?


Componente di Windows NT non installato

Impossibile avviare il programma.

I motivi possibili sono:

    • Il programma è stato rimosso dall'amministratore di sistema.
    • L'amministratore di sistema ha modificato i criteri di protezione associati al file.
    • Il programma non è installato nel computer.
    • Il programma è stato casualmente eliminato.
    • Il file è danneggiato.

Se il computer è controllato da un amministratore di sistema, si consiglia di contattarlo per risolvere il problema del mancato avvio del programma.