Presentazione di Microsoft FrontPage Express

FrontPage Express è un editor completo che consente di creare e formattare pagine Web utilizzando l'efficiente linguaggio HTML (Hypertext Markup Language) e lavorando in una visualizzazione di tipo WYSIWYG ("what you see is what you get", "ciò che vedi è cio che ottieni"), grazie alla quale è possibile verificare l'aspetto delle pagine che si stanno creando.

In FrontPage Express è inoltre possibile personalizzare le cartelle utilizzando la procedura guidata Personalizza cartella, che è possibile avviare scegliendo il comando corrispondente dal menu Visualizza di Risorse del computer.

Le caratteristiche offerte sono di semplice utilizzo e consentono di creare pagine Web di grande impatto. È ad esempio possibile:

  • Applicare i tag HTML selezionando gli stili corrispondenti dalla casella di riepilogo a discesa sulla barra degli strumenti, senza la necessità di digitarli.

  • Formattare e allineare il testo o i paragrafi selezionati semplicemente facendo clic su un pulsante della barra degli strumenti.

  • Inserire immagini create dall'utente o ClipArt contenute nelle raccolte delle immagini preferite (le raccolte non vengono fornite con FrontPage Express).

  • Visualizzare pagine Web esistenti direttamente dal Web, se è stata installata la Pubblicazione guidata sul Web, o da un file sul computer o su una rete.

  • Salvare il lavoro direttamente nel Web, utilizzando la Pubblicazione guidata sul Web, o in un file.

  • Aggiungere del testo scorrevole.

FrontPage Express offre, in un pacchetto di dimensioni ridotte, molte delle caratteristiche di Microsoft FrontPage Editor. Sarà pertanto possibile passare a FrontPage, che riunisce le caratteristiche di FrontPage Editor e di FrontPage Explorer, senza la necessità di apprendere l'utilizzo di un nuovo programma o di un nuovo metodo per la creazione di pagine Web.


Personalizzazione delle cartelle in base allo stile Web

È possibile utilizzare qualsiasi cartella disponibile sul disco rigido come se fosse una pagina Web.

Se si visualizza il contenuto del computer utilizzando lo stile Web, è possibile scegliere Personalizza cartella dal menu Visualizza di Risorse del computer per avviare una procedura guidata che consente di personalizzare lo sfondo di qualunque cartella e, utlizzando FrontPage Express, di trasformarla in una pagina Web.

Dopo aver trasformato una cartella in una pagina Web, è possibile aggiungervi collegamenti a Outlook Express e ad altri componenti, inserire controlli ActiveX, personalizzare lo stile e la dimensione dei caratteri e aggiungere elementi decorativi. Questa caratteristica consente quindi di creare cartelle in base alle esigenze personali, qualunque sia lo scopo per il quale si desidera utilizzarle.


Caratteristiche avanzate di FrontPage Express

Le caratteristiche di FrontPage Express, di semplice utilizzo, consentono di creare pagine Web di grande impatto. È infatti possibile:

  • Aggiungere colori di sfondo ed elementi decorativi.

  • Inserire componenti WebBot che consentono di aggiungere efficienti funzionalità senza la necessità di utilizzare complessi linguaggi di programmazione. I componenti WebBot sono "oggetti dinamici" di una pagina Web che vengono eseguiti quando la pagina viene salvata dall'autore sul server Web o, in alcuni casi, quando viene visualizzata dall'utente. In FrontPage Express sono disponibili componenti WebBot per l'aggiunta alle pagine Web di indicatori orari, di URL e di funzioni di ricerca. Per utilizzare l'intera gamma dei componenti WebBot, quali i gestori dei moduli e le barre di esplorazione, è necessario eseguire l'aggiornamento a Microsoft FrontPage.

  • Utilizzare i controlli ActiveX per migliorare l'efficienza di una pagina Web.

  • Inserire i nuovi tag HTML, quando disponibili, utilizzando il comando Tag HTML.

  • Visualizzare e modificare i tag HTML direttamente sulla pagina Web. I codici a colori consentono di distinguere facilmente i tag dal contenuto.


Passaggio a FrontPage

Passaggio a Microsoft FrontPage

Se si desidera creare pagine Web più sofisticate, è possibile eseguire l'aggiornamento da FrontPage Express a Microsoft FrontPage, il cui aspetto risulterà immediatamente familiare. La struttura di FrontPage Express si basa infatti su quella del componente FrontPage Editor di Microsoft FrontPage.

Per gli autori di pagine Web e per gli amministratori di siti Web, Microsoft FrontPage costituisce un pacchetto completo. FrontPage Express e FrontPage rappresentano una perfetta combinazione per società le cui esigenze spaziano dalla semplice visualizzazione e dalle operazioni fondamentali di modifica di pagine Web (FrontPage Express) a operazioni più avanzate e all'amministrazione di siti Web (FrontPage).

I componenti di FrontPage, descritti di seguito, ne fanno un ambiente completo per la creazione e la modifica di pagine Web.

  • FrontPage Editor consente di creare, visualizzare e salvare documenti HTML e include modelli, procedure guidate e componenti WebBot che semplificano la creazione di pagine Web avanzate. Questo editor con funzione di browser può inoltre essere utilizzato per importare pagine da Internet o da qualsiasi rete Intranet.

  • FrontPage Explorer consente di amministrare, visualizzare e gestire siti Web, nonché svilupparli e verificarli sul proprio computer e successivamente copiarli su un server Web. Questo componente può inoltre essere utilizzato come server Web personale per eseguire un sito direttamente dal proprio desktop, condividendolo sia su una rete Intranet che come sito pubblico sul World Wide Web.