Tehtävien ajoittaminen säännöllisesti suoritettaviksi

Tehtävien ajoituksen avulla voit suorittaa ohjelmia (kuten Levyn eheytys) säännöllisesti sinulle parhaiten sopivana ajankohtana. Tehtävien ajoitus käynnistyy aina, kun avaat Windowsin, ja se on käynnissä taustalla.

Voit käynnistää Tehtävien ajoituksen napsauttamalla Käynnistä-painiketta, valitsemalla Ohjelmat, valitsemalla Apuohjelmat, valitsemalla Järjestelmätyökalut ja valitsemalla sitten Ajoitetut tehtävät.

Avaamalla Tehtävien ajoituksen voit

  • ajoittaa tehtävän suoritettavaksi päivittäin, viikoittain, kuukausittain tai muina määrättyinä aikoina, esimerkiksi silloin kun käynnistät tietokoneen tai et käytä sitä
  • muuttaa tehtävän aikataulua tai peruuttaa tehtävän
  • mukauttaa aikataulun mukaista tehtävän suoritustapaa.


Uusien tehtävien ajoittaminen

Voit ajoittaa uusia tehtäviä seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Kaksoisnapsauta Lisää ajoitettu tehtävä -kuvaketta.
  3. Noudata ohjatun tehtävän ajoittamisen ohjeita.

    4. Jos haluat määrittää tehtävälle lisämäärityksiä (kuten määrittää sen toistuvaksi), valitse ohjatun toiminnon viimeisessä näytössä Avaa tämän tehtävän lisäominaisuudet -valintaruutu.

Huomautuksia

  • Jos tehtäväohjelma pyytää parametreja, valitse ohjatun toiminnon viimeisessä näytössä Avaa tämän tehtävän lisäominaisuudet -valintaruutu, valitse sitten Valmis-painike, valitse Tehtävä-välilehti ja kirjoita parametrit Suorita-ruutuun ohjelmatiedoston polun jälkeen.
  • Ajoitettu tehtävä suoritetaan siitä riippumatta, onko joku kirjautuneena Windowsiin, kunhan tietokoneeseen on kytketty virta. Jos et halua suorittaa tehtäviä siinä tapauksessa, että ketään ei ole kirjautuneena tietokoneeseen, avaa Ajoitetut tehtävät -kansio, ennen kuin kirjaudut ulos tietokoneesta, ja valitse Lisäasetukset-valikosta Lopeta Tehtävien ajoituksen käyttö. Voit palauttaa tehtävien ajoituksen käyttöön avaamalla Ajoitetut tehtävät -kansion ja valitsemalla Lisäasetukset-valikosta Ota Tehtävien ajoitus käyttöön.
  • Varmista, että päivämäärä ja kellonaika ovat tietokoneessasi oikein. Tehtävien ajoitus suorittaa tehtävät niiden perusteella. Voit muuttaa tietokoneesi päivämäärän tai kellonajan kaksoisnapsauttamalla työkalurivillä näkyvää kellonaikaa.

Aiheeseen liittyviä ohjeita


Ajoitetun tehtävän muokkaaminen

Voit muokata ajoitettua tehtävää seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jonka asetuksia haluat muuttaa, ja valitse sitten Ominaisuudet.
  3. Tee haluamasi seuraavista toimista:
    • Voit vaihtaa suoritettavan ohjelman kirjoittamalla ohjelmatiedoston polun Suorita-ruutuun tai valitsemalla Selaa.
    • Voit muuttaa tehtävän ajoitusta Ajoitus-välilehdessä.
    • Voit mukauttaa tehtävän asetuksia Asetukset-välilehdessä.

Huomautuksia

  • Jos suoritettava ohjelma vaatii parametreja, kirjoita ne Suorita-ruutuun ohjelman polun jälkeen.
  • Jos suoritettavan ohjelman polku sisältää välilyöntejä, kirjoita tehtäväpolun molemmille puolille lainausmerkit (").


Ajoitetun tehtävän poistaminen

Voit poistaa ajoitetun tehtävän seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Napsauta poistettavaa tehtävää hiiren kakkospainikkeella ja valitse sitten Poista.

Huomautus

  • Ajoitetun tehtävän poistaminen poistaa tehtävän Ajoitetut tehtävät -kansiosta. Tehtävään liittyvää ohjelmaa ei poisteta tietokoneesta.


Käynnissä olevan ajoitetun tehtävän lopettaminen

Voit lopettaa käynnissä olevan ajoitetun tehtävän seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Napsauta lopetettavaa tehtävää hiiren kakkospainikkeella ja valitse sitten Lopeta tehtävä.

Huomautuksia

  • Jos ajoitettu tehtävä käynnistää toisen ohjelman, tämä komento lopettaa ainoastaan alkuperäisen ajoitetun tehtävän, mutta ei toista tehtävää.
  • Voit käynnistää tehtävän uudelleen napsauttamalla tehtävää hiiren kakkospainikkeella ja valitsemalla sitten Suorita.
  • Ajoitettu tehtävä suoritetaan siitä riippumatta, onko joku kirjautuneena Windowsiin, kunhan tietokoneeseen on kytketty virta. Jos et halua suorittaa tehtäviä siinä tapauksessa, että ketään ei ole kirjautuneena tietokoneeseen, avaa Ajoitetut tehtävät -kansio, ennen kuin kirjaudut ulos tietokoneesta, ja valitse Lisäasetukset-valikosta Lopeta Tehtävien ajoituksen käyttö. Voit palauttaa tehtävien ajoituksen käyttöön avaamalla Ajoitetut tehtävät -kansion ja valitsemalla Lisäasetukset-valikosta Ota Tehtävien ajoitus käyttöön.


Tehtävän suorittaminen heti

Voit suorittaa tehtävän heti seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Napsauta hiiren kakkospainikkeella tehtävää, jonka haluat käynnistää, ja valitse sitten Suorita.

Huomautuksia

  • Voit lopettaa tehtävän valitsemalla Tiedosto-valikosta Lopeta ajoitettu tehtävä.
  • Jos suoritettavaksi valittu tehtävä ei käynnisty, tarkista syy lokitiedostosta. Valitse Lisäasetukset-valikosta Näytä loki.


Aiemmin suoritettujen ajoitettujen tehtävien lokien tarkasteleminen

Voit tarkastella aiemmin suoritettujen ajoitettujen tehtävien lokeja seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Valitse Lisäasetukset-valikosta Näytä loki.


Ajoitettujen tehtävien tarkasteleminen etätietokoneesta

Voit tarkastella ajoitettuja tehtäviä etätietokoneesta seuraavasti:

  1. Kaksoisnapsauta Verkkoympäristö-kuvaketta.
  2. Kaksoisnapsauta tietokonetta, jonka ajoitettuja tehtäviä haluat tarkastella.
  3. Kaksoisnapsauta Ajoitetut tehtävät -kansiota.

Huomautus

  • Voit muokata etätietokoneen tehtäviä vain, jos etätietokoneessa on etärekisteriohjelma ja etätietokoneessa on jaettu x$-resurssi, jossa x on Ajoitetut tehtävät -kansion sisältävä kiintolevy. Käyttäjätililläsi tulee olla etärekisterin muokkausoikeus etätietokoneessa. Voit määrittää käyttäjät, joilla on oikeus muokata tietokoneen rekisteriä etäyhteyden kautta, kaksoisnapsauttamalla Ohjauspaneelin Salasanat-kuvaketta.


Kaikkien ajoitettujen tehtävien poistaminen käytöstä tilapäisesti

Voit poistaa kaikki ajoitetut tehtävät käytöstä tilapäisesti seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Valitse Lisäasetukset-valikosta Keskeytä Tehtävien ajoitus.

    Toiminto on hyödyllinen, jos jokin toinen ohjelma (kuten peli) tai asennusohjelma on käynnissä, etkä halua suorittaa ajoitettuja tehtäviä samanaikaisesti kyseisen ohjelman kanssa.

Huomautuksia

  • Tehtävät, jotka olisi suoritettu Tehtävien ajoituksen ollessa keskeytettynä, suoritetaan vasta seuraavalla aikataulun mukaisella kerralla.
  • Voit jatkaa kaikkien tehtävien ajoittamista valitsemalla Lisäasetukset-valikosta Jatka Tehtävien ajoituksen käyttämistä.


Tehtävien ajoituksen poistaminen käytöstä

Voit poistaa tehtävien ajoituksen käytöstä seuraavasti:

  1. Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.
  2. Valitse Lisäasetukset-valikosta Lopeta Tehtävien ajoituksen käyttö.

Huomautus

  • Kun poistat Tehtävien ajoituksen käytöstä, ajoitetut tehtävät eivät käynnisty eikä Tehtävien ajoitus käynnisty automaattisesti käynnistäessäsi Windowsin seuraavalla kerralla.


Tehtävien ajoituksen vianmääritys

Jos ajoittamasi tehtävä ei käynnisty silloin, kun pitäisi, napsauta tehtävää tehtäväluettelossa hiiren kakkospainikkeella ja valitse sitten Ominaisuudet. Valitse Tehtävät-välilehti ja tarkista, että Käytössä-valintaruutu on valittu. Varmista, että ajoituksen asetukset ovat oikein Ajoitus-välilehdessä.

Jos tehtäväohjelma ei toimi oikein, sinun on ehkä lisättävä joitakin parametreja. Saat lisätietoja ohjelmasta ja sen parametreista

  • katsomalla käytönaikaisesta ohjeesta, jos ohjelmassa on sellainen
  • kirjoittamalla kehotteen jälkeen seuraavan rivin, jossa ohjelma on ohjelman nimi:
    ohjelma /?


Ajoitetut tehtävät -kansion avaaminen

Voit avata Ajoitetut tehtävät -kansion seuraavasti:

  • Napsauta Käynnistä-painiketta, valitse Ohjelmat, valitse Apuohjelmat, valitse Järjestelmätyökalut ja valitse sitten Ajoitetut tehtävät.