Microsoft FrontPage Expressin esittely

FrontPage Express on Web-sivueditori, jonka avulla voit käyttää kaikkia HTML-kielen (Hypertext Markup Language) ominaisuuksia. FrontPage Expressin avulla voit luoda ja muotoilla Web-sivuja WYSIWYG ("what you see is what you get") -näkymässä, jossa näet Web-sivujen lopullisen muotoilun ja asettelun.

FrontPage Express toimii myös yhdessä Ohjattu kansion mukauttaminen -toiminnon kanssa (valitse Oma tietokone -ikkunassa Näytä), joten voit helposti mukauttaa kansioiden ulkoasua.

FrontPage Expressin helppokäyttöisten ominaisuuksien avulla voit luoda tyylikkäitä ja tehokkaita Web-sivuja. Voit esimerkiksi

  • käyttää HTML-tunnisteita työkalurivin luettelosta, eikä sinun tarvitse kirjoittaa niitä käsin
  • valita tekstiä tai kappaleita ja määrittää niihin muotoilun ja kohdistuksen napsauttamalla työkalurivin painiketta
  • liittää itse luomiasi kuvia tai leikekuvia suosikkikokoelmistasi (FrontPage Expressiin ei sisälly kokoelmia)
  • avata Web-sivuja suoraan Webistä (jos Ohjattu Web-julkaiseminen -toiminto on asennettu) tai tietokoneesi tiedostoista tai verkosta
  • tallentaa työsi suoraan Webiin (Ohjattu Web-julkaiseminen -toiminnon avulla) tai tiedostoon
  • lisätä vierivää tekstiä.

FrontPage Express sisältää monia Microsoft FrontPage Editorin toimintoja. Voit siirtyä helposti käyttämään FrontPagea, ilman että sinun tarvitsee opetella uutta ohjelmaa tai Web-sivun luontimenetelmää. FrontPage tarjoaa käyttöösi lisäominaisuuksia kuten FrontPage Editor ja FrontPage Explorer.


Kansioiden mukauttaminen Web-tyylin mukaisiksi

Kaiken sen, mitä voit tehdä Web-sivulla, voit tehdä myös kiintolevysi kansioille.

Kun esität tietokoneesi sisällön Web-tyylin mukaisena, voit mukauttaa kansioiden taustaa Ohjattu kansion mukauttaminen -toiminnon avulla (valitse Oma tietokone -ikkunassa Näytä). Voit jopa muuttaa minkä tahansa kansion Web-sivuksi ohjatun toiminnon ja FrontPage Expressin avulla.

Kun kansio on Web-sivu, voit liittää linkkejä Outlook Expressiin tai muihin sovelluksiin, lisätä ActiveX-komponentteja, mukauttaa fontin tyylejä ja kokoja tai lisätä vesileimoja. Tätä toimintoa voit kokeilla huviksesi tai voit käyttää sitä uusimman tiedon jakamiseen mukautetuissa yhteisissä kansioissa. Joka tapauksessa voit luoda kansioita, jotka vastaavat täsmälleen tarpeitasi.


FrontPage Expressin lisäominaisuudet

FrontPage Expressin helppokäyttöisten ominaisuuksien avulla saat Web-sivuistasi tyylikkäitä ja tehokkaita.

  • Voit lisätä taustavärejä ja vesileimoja.
  • WebBot-komponenttien avulla voit lisätä monipuolisia toimintoja ilman vaativaa ohjelmointia. WebBot on Web-sivulla oleva "dynaaminen objekti", joka käynnistyy, kun Web-sivun tekijä tallentaa sivun Web-palvelimelle tai tietyissä tapauksissa käyttäjän katsellessa sivua. FrontPage Expressiin kuuluu WebBot-komponentteja, jotka lisäävät Web-sivuille aikamäärite-, sisällytys- ja etsintäominaisuuksia. (Täydellisen valikoiman WebBot-komponentteja, esimerkiksi lomakkeiden käsittelyn ja siirtymistyökalurivin, saat päivittämällä Microsoft FrontPageen.)
  • ActiveX-komponenttien avulla voit tehostaa Web-sivujasi.
  • Kun uusia HTML-tunnisteita julkistetaan, saat ne käyttöön HTML-koodi-komennon avulla.
  • Voit katsella ja muokata kaikkia HTML-tunnisteita suoraan Web-sivulla. FrontPage Expressin värikoodauksen avulla tunnisteet on helppo erottaa sisällöstä.


Microsoft FrontPageen siirtyminen

Kun olet valmis luomaan kehittyneempiä Web-sivuja, Microsoft FrontPage Expressistä on helppo siirtyä Microsoft FrontPageen. Tuote on tutunnäköinen, koska FrontPage Express on suunniteltu Microsoft FrontPageen kuuluvan FrontPage Editorin pohjalta.

Microsoft FrontPage on täydellinen paketti Web-sivujen tekijöille ja Web-sivustojen järjestelmänvalvojille. FrontPage Express ja FrontPage sopivat yhdessä organisaatioille, joissa käyttötarpeet vaihtelevat pelkästä katselusta ja muokkaamisesta (FrontPage Express) rajoittamattomaan muokkaamiseen ja katseluun sekä Web-sivustojen hallintaan (FrontPage).

FrontPage tarjoaa täydellisen ympäristön Web-sivujen tekemiseen. Se sisältää seuraavat sisällön tuottamiseen liittyvät osat:

  • FrontPage Editorin avulla voit luoda, katsella ja tallentaa HTML-asiakirjoja. FrontPage Editor sisältää malleja, ohjattuja toimintoja ja WebBot-komponentteja, joiden avulla voit helposti luoda tehokkaita Web-sivuja. Koska FrontPage Editor toimii myös selaimena, voit avata sen avulla mitä tahansa Internetin tai intranetin sivuja.
  • FrontPage Explorer tarjoaa sinulle mahdollisuuden Web-sivustojen hallintaan, katseluun sekä niiden muokkaamiseen. Voit kehitellä ja testata Web-sivustoja omalla tietokoneellasi ja kopioida sitten sivustot Web-palvelimelle. Voit myös käyttää FrontPage Exploreria henkilökohtaisena Web-palvelimena ja ylläpitää suoraan työpöydältäsi käsin intranet- tai World Wide Web -sivustoa.


Saat uusimmat vastaukset teknisiin kysymyksiin Internetin kautta

Microsoftin online-tuotetuki

Jos et pysty ratkaisemaan ongelmaa Internet Explorerin Ohjeen avulla, siirry online-tukisivulle. (Tämä palvelu on ainoastaan englanninkielisenä.) Valitse vain haluamasi tuote ja kirjoita kysymyksesi. Sivusto tekee työn puolestasi. Online-tuki etsii puolestasi resurssit, joista vastaus ongelmaan todennäköisimmin löytyy. Näitä resursseja ovat esimerkiksi Microsoft Knowledge Base -tietokanta, ohjatut vianmääritystoiminnot ja ladattavat tiedostot.

Voit aloittaa etsinnän siirtymällä online-tukisivulle.