Windows Media Encoder

Microsoft® Windows Media® Encoder 9-Reihe ist ein leistungsfähiges Produktionstool zum Konvertieren von Live- und vorab aufgezeichneten Audio- und Videoinhalten in Windows Media-Dateien oder -Datenströmen. Die folgenden Abschnitte stellen Konzeptinformationen zum Codierungsvorgang vor und bieten schrittweise Anleitungen zum Verwenden von Windows Media Encoder.

  • Erste Schritte. Erläutert, wie Sie eine Codierungssitzung in wenigen Schritten durch Verwenden von Schnellstarts oder des Assistenten für neue Sitzungen einrichten können. Außerdem werden die Änderungen in Windows Media Encoder sowie die Systemanforderungen beschrieben, und es werden Informationen zu den verschiedenen Fensterbereichen zur Verfügung gestellt, aus denen die Benutzeroberfläche besteht.
  • Konzepte. Stellt allgemeine Informationen zum Arbeiten mit dem Encoder zur Verfügung.
  • Konfigurieren von Quellen. Stellt Informationen zu den vom Encoder unterstützten Eingabequellen zur Verfügung, z. B. zu Dateien, Geräten, Bildschirmen und Skriptbefehlen.
  • Anpassen einer Sitzung. Beschreibt das Konfigurieren einer neuen Codierungssitzung und das Anpassen einer vorhandenen Sitzung an die jeweiligen Anforderungen.
  • Ausgabeoptionen. Beschreibt die beim Codieren verfügbaren Ausgabeoptionen: Codieren in eine Datei oder Übertragen eines Liveereignisses (durch Push- oder Pullverteilung).
  • Systemkonfigurationsoptionen. Beschreibt die Systemkonfigurationsoptionen (Sicherheit für den Computer mit dem Encoder, Ausführen mehrerer Instanzen des Encoders auf einem Computer, Batchcodierung usw.) sowie die Schritte, die Sie zum Erzielen einer optimalen Systemleistung durchführen können.
  • Häufig gestellte Fragen (FAQ) und Problembehandlung. Stellt einen Hyperlink zur Microsoft-Website bereit, auf der Sie Vorschläge zum Beheben von Problemen finden können, die beim Verwenden des Encoders möglicherweise auftreten.
  • Eingabehilfen für Personen mit Behinderungen. Stellt Informationen zu Funktionen, Produkten und Diensten zur Verfügung, durch die Windows Media Encoder für Personen mit Behinderungen einfacher zu bedienen ist.
  • Glossar. Stellt Definitionen und Begriffe vor, die sich auf den Encoder beziehen.
© 2000-2002 Microsoft Corporation. Alle Rechte vorbehalten.


Erste Schritte

Dieser Abschnitt enthält Informationen zum Einrichten einer Codierungssitzung in wenigen Schritten durch Verwenden von Schnellstarts oder des Assistenten für neue Sitzungen. Er enthält außerdem Informationen zu den neuen Funktionen in dieser Version von Windows Media Encoder, den Funktionsanforderungen sowie den Hardware- und Softwareanforderungen. Zudem werden die verschiedenen Fensterbereiche beschrieben, aus denen die Benutzeroberfläche des Encoders besteht.

Verwandte Themen

  • Windows Media Encoder
  • Codieren mit Schnellstarts oder dem Assistenten für neue Sitzungen
  • Neues in dieser Version
  • Funktionsanforderungen
  • Hardware- und Softwareanforderungen
  • Informationen zu den Encoder-Ansichten
  • Informationen zu den Encoder-Dienstprogrammen
  • Konventionen in der Dokumentation


Codieren mit Schnellstarts oder dem Assistenten für neue Sitzungen

Bevor Sie Inhalte codieren können, müssen Sie eine Codierungssitzung einrichten. Die einfachste Vorgehensweise besteht im Verwenden von Schnellstarts oder dem Assistenten für neue Sitzungen. Schnellstarts sind Sitzungsdateien, die in Windows Media Encoder enthalten sind. Sie wurden für allgemeine Codierungsszenarien konzipiert und enthalten bereits den Großteil der Einstellungen, die für den Codierungsbeginn ohne Verzögerung erforderlich sind. Sie müssen einfach nur noch Einzelheiten zum betreffenden Inhalt angeben, z. B. Datei- oder Servernamen. Sie können auch den Assistenten für neue Sitzungen verwenden, der Sie schrittweise durch die Aufgaben führt, die für das Einrichten der vier gängigsten Codierungsszenarien erforderlich sind.

Die Schnellstarts und der Assistent stehen im aktivierten Dialogfeld Neue Sitzung zur Verfügung, das beim ersten Öffnen des Encoders angezeigt wird. Sie können darauf auch über das Encoder-Hauptfenster zugreifen, indem Sie auf der Symbolleiste auf Neue Sitzung klicken.

Nachdem Sie die Codierungssitzung eingerichtet haben, sind Sie für die Codierung von Inhalt bereit. Wenn Sie planen, die gleiche Sitzung noch einmal auszuführen, können Sie die Einstellungen in einer Sitzungsdatei speichern und die Sitzung dann zu einem späteren Zeitpunkt verwenden. Sitzungsdateien werden mit der Dateinamenerweiterung WME gespeichert.

Verwandte Themen

  • Erste Schritte
  • Verwenden von Schnellstarts für die Codierung
  • Verwenden des Assistenten für neue Sitzungen für die Codierung
  • Informationen zu Sitzungen
  • So öffnen Sie eine vorhandene Sitzung
  • So speichern Sie eine Sitzung


Verwenden von Schnellstarts für die Codierung

Schnellstarts sind Sitzungsdateien, die in Windows Media Encoder enthalten sind. Sie wurden für allgemeine Codierungsszenarien konzipiert und enthalten bereits den Großteil der Einstellungen, die für den Codierungsbeginn ohne Verzögerung erforderlich sind. Sie müssen einfach nur noch Einzelheiten zum betreffenden Inhalt angeben, z. B. Datei- oder Servernamen.

Folgende Schnellstarts sind verfügbar:

  • Liveinhalt für lokale Wiedergabe aufzeichnen. Zeichnet Liveinhalt von Audio- und Videogeräten auf und codiert diesen in einer Datei. Sie können den Inhalt verteilen, damit Benutzer diesen downloaden und lokal wiedergeben können.
  • Liveinhalt für Streamingvorgang aufzeichnen. Zeichnet Liveinhalt von Audio- und Videogeräten auf und codiert diesen in einer Windows Media-Datei.
  • Filminhalte in Videoformat konvertieren. Konvertiert dateibasierte Inhalte, die ursprünglich auf Film aufgenommen wurden, in das Windows Media-Format, damit Benutzer diese downloaden und lokal wiedergeben können.
  • Betriebsversammlung übertragen. Überträgt einen Datenstrom per Push an einen Publishingpoint auf einem Server, der Microsoft Windows Media-Dienste ausführt.

Wenn Sie eine Sitzung häufiger verwenden möchten, können Sie sie zur Liste der Schnellstarts hinzufügen.

Anmerkung Anmerkung

  • Um die Schnellstarts zu starten, klicken Sie auf der Symbolleiste auf Neue Sitzung, klicken Sie auf die Registerkarte Schnellstarts, und klicken Sie dann auf einen Schnellstart.

Verwandte Themen

  • Codieren mit Schnellstarts oder dem Assistenten für neue Sitzungen
  • So erstellen Sie einen benutzerdefinierten Schnellstart
  • Informationen zur CBR- oder VBR-Codierung


Verwenden des Assistenten für neue Sitzungen für die Codierung

Der Assistent für neue Sitzungen führt Sie schrittweise durch die Aufgaben, die für das Einrichten der vier gängigsten Codierungsszenarien erforderlich sind. Die folgenden vier allgemeinen Codierungsszenarien sind verfügbar:

  • Ein Liveereignis übertragen. Zeichnet Audio- oder Videoinhalte von Geräten auf, die auf Ihrem Computer installiert sind, und überträgt die Inhalte dann live. Dies geschieht durch das Übertragen des Datenstroms per Push auf einen Server, der Microsoft Windows Media-Dienste ausführt, oder durch das Aktivieren von Windows Media-Servern und -Playern für das Anfordern des Datenstroms per Pull direkt vom Encoder.
  • Audio- oder Videoinformationen aufzeichnen. Zeichnet Audio- oder Videoinformationen von Geräten auf, die auf Ihrem Computer installiert sind, und konvertiert die aufgezeichneten Inhalte dann zur späteren Verteilung in eine Windows Media-Datei.
  • Eine Datei konvertieren. Konvertiert eine Audio- oder Videodatei zur späteren Verteilung in das Windows Media-Format.
  • Bildschirm aufzeichnen. Zeichnet Bildschirminhalte auf dem Computer auf, z. B. Mauszeigerbewegungen. Sie können den gesamten Bildschirm, einen Bereich des Bildschirms oder ein bestimmtes Fenster aufzeichnen.

Um die Sitzungseigenschaften zu ändern, können Sie entweder den Assistenten für neue Sitzungen erneut ausführen oder den Fensterbereich Eigenschaften zum Bearbeiten der Einstellungen verwenden. Wenn Sie planen, die Sitzung erneut zu verwenden, speichern Sie die Einstellungen in einer Sitzungsdatei.

Anmerkung Anmerkung

  • Um den Assistenten für neue Sitzungen zu öffnen, klicken Sie auf der Symbolleiste auf Neue Sitzung, und klicken Sie dann auf einen der vier Assistenten. Sie können Benutzerdefinierte Sitzung verwenden, um eine benutzerdefinierte Codierungssitzung einzurichten.

Verwandte Themen

  • Codieren mit Schnellstarts oder dem Assistenten für neue Sitzungen
  • So speichern Sie eine Sitzung


Neues in dieser Version

Windows Media Encoder 9-Reihe umfasst Verbesserungen, die gleichzeitig leistungsfähig und einfach zu verwenden sind. Dieser Abschnitt fasst die Änderungen des Encoders in dieser Version zusammen.

  • Das Behandeln unterschiedlicher Codierungsszenarien wurde durch das Hinzufügen neuer Ziele vereinfacht. Außerdem stehen vier Schnellstarts zur Verfügung, durch die Sie ohne Verzögerung mit der Codierung beginnen können. Jeder Schnellstart wurde für ein allgemeines Codierungsszenario konzipiert.
  • Neue Codecs verbessern die Qualität codierter Audio- und Videoinhalte.
  • Durch Unterstützung für das Ziehen von Quell- und Sitzungsdateien in das Encoder-Fenster ist es ganz einfach, schnell mit der Codierung zu beginnen.
  • Neue CBR-Codierungsmodi (Constant Bit Rate, konstante Bitrate) und VBR-Codierungsmodi (Variable Bit Rate, variable Bitrate) ermöglichen das Optimieren der Einstellungen abhängig vom Wiedergabeszenario, das Sie anstreben.
  • Eine Gerätesteuerungsfunktion ermöglicht das Ausführen von Geräten direkt vom Encoder aus. (Das Gerät muss an einen digitalen Institute of Electrical and Electronics Engineers (IEEE) 1394-Videoanschluss angeschlossen sein, oder Sie können einen Videorecorder verwenden, der das Sony RS422-Protokoll unterstützt und über einen COM-Anschluss angeschlossen ist.) Sie können auch die integrierte Schnittliste (Edit Decision List, EDL) verwenden, um Clips in beliebiger Reihenfolge anzuordnen und zu codieren.
  • Mehrkanalaudiocodierung ist über die Windows Media Audio 9 Professional- und Windows Media Audio 9 Lossless-Codecs verfügbar.
  • Digital Rights Management (DRM) steht zum Schützen codierter Inhalte zur Verfügung.
  • Durch die neue Pushverteilungsfunktion können Sie die Verbindung mit einem Windows Media-Server vom Encoder aus initiieren.
  • Durch Sprachunterstützung können Sie die Sprache des Inhalts angeben.
  • Es sind vier Dienstprogramme enthalten, um zusätzliche Funktionen wie z. B. das Erstellen benutzerdefinierter Profile, das Aufteilen von Datenströmen auf und das Kombinieren von Datenströmen in verschiedenen Dateien sowie das Indizieren von Dateien nach der Codierung zur Verfügung zu stellen.
  • Das vorübergehende Speichern von Inhalt auf der Festplatte unterstützt Sie bei der Sicherstellung der Qualität codierter Inhalte.
  • Durch die Unterstützung von Transformations-Plug-Ins können Entwickler Plug-Ins schreiben, die Audio- und Videoinhalte ändern. Sie können diese Plug-Ins verwenden, um während der Codierung Spezialeffekte hinzuzufügen.
  • Unterstützung für weitere Quelldateiformate wurde implementiert.
  • Durch Unterstützung für die Ausgabe nicht quadratischer Pixel wird das Codieren von Inhalt im Letterboxformat vereinfacht, das Seitenverhältnis des Quellvideos bleibt dabei erhalten.
  • Suche auf Frameebene kann durch Erstellen oder Speichern von Zeitcodes für einige Quellen implementiert werden.
  • MBR-Inhalt (Multiple Bit Rate, mehrere Bitraten) unterstützt nun mehrere Audioformate und Videoauflösungen.
  • Unterstützung für die Plug & Play-Funktion von Microsoft Windows® XP ermöglicht, dass ausgeführte Geräte vom Encoder automatisch erkannt werden. Außerdem wird der Encoder automatisch gestartet, wenn ein neues Gerät an den Computer angeschlossen wird.

Verwandte Themen

  • Erste Schritte
  • Verwenden von Schnellstarts für die Codierung
  • Grundlegendes zu Codecs
  • Informationen zur CBR- oder VBR-Codierung
  • Verwenden von Geräten als Quelle
  • Verwenden von Mehrkanal-Audiodateien als Quelle
  • Verwenden von Digital Rights Management zum Schützen von Inhalt
  • Übertragen von Liveinhalt
  • Informationen zu den Encoder-Dienstprogrammen


Funktionsanforderungen

Die folgende Tabelle stellt Informationen zu den Funktionen von Windows Media Encoder zur Verfügung, die besondere Anforderungen an Microsoft Windows Media Player, Betriebssysteme oder Codecs aufweisen.

Funktion | Windows Media Player |  |  | Betriebssysteme | Codecs
 | 6.4 | 7.1/Windows XP | 9-Reihe |  |
Ausgabevideo mit Zeilensprüngen |  |  | X | Microsoft Windows XP | Windows Media Video 9
Ausgabe nicht quadratischer Pixel |  |  | X |  |
Mehrere Bitraten (Multiple Bit Rate, MBR)-Inhalt mit Mehrfachauflösung |  |  | X |  |
MBR-Audio |  |  | X |  |
DRM-Unterstützung | X | X | X |  |
Mehrkanalaudio |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional oder Windows Media Audio 9 Lossless
Hochauflösendes Audioformat (24 Bit, 96 kHz)1 |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
Dynamische Bereichssteuerung |  |  | X | Microsoft Windows XP | Windows Media Audio 9 Professional
CBR-Codierung (ein oder zwei Durchläufe) | X | X | X |  | Weitere Informationen finden Sie in der folgenden Tabelle.
Qualitätsbasiertes VBR |  | X | X |  | Weitere Informationen finden Sie in der folgenden Tabelle.
Bitratenbasiertes VBR |  | X | X |  | Weitere Informationen finden Sie in der folgenden Tabelle.
Auf maximalen Bitraten basierendes VBR |  | X | X |  | Weitere Informationen finden Sie in der folgenden Tabelle.

1 Ältere Player oder frühere Betriebssysteme geben Inhalte mit 16 Bit und 48 kHz wieder.

Beachten Sie, dass Inhalte, die mit den Codecs von Windows Media Audio und Video 9-Reihe (mit Ausnahme des Windows Media Audio 9-Codecs) codiert wurden, in Windows Media Player, Version 6.4, nicht unterstützt werden. Für Windows Media Player, Version 7.1, und Windows Media Player für Windows XP müssen Benutzer den Codec vor der Wiedergabe von Inhalten, die mit einem dieser Codecs codiert wurden, downloaden. Inhalte, die mit VBR-Codierung mit dem Windows Media Audio 9-Codec codiert wurden, weisen möglicherweise Störungen oder Tonausfälle auf, wenn sie in Windows Media Player, Version 6.4, wiedergegeben werden. Für Windows Media Player, Version 7.1, und Windows Media Player für Windows XP müssen Benutzer den Codec nicht downloaden, um Inhalte, die mit dem Windows Media Audio 9-Codec codiert wurden, wiedergeben zu können.

Die folgende Tabelle listet die unterstützten Codierungsmethoden für die Codecs auf, die im Encoder enthalten sind.

Codec | CBR mit einem Durchlauf | CBR mit zwei Durchläufen | Qualitätsbasiertes VBR | Bitratenbasiertes VBR | Auf maximalen Bitraten basierendes VBR
Windows Media Audio 9 Professional | Ja | Ja | Ja | Ja | Ja
Windows Media Audio 9 Lossless | Nein | Nein | Ja | Nein | Nein
Windows Media Audio 9 | Ja | Ja | Ja1 | Ja1 | Ja1
Windows Media Audio 9 Voice | Ja | Nein | Nein | Nein | Nein
Windows Media Video 9 | Ja | Ja | Ja | Ja | Ja
Windows Media Video 8.1 | Ja | Ja | Ja | Ja | Ja
Windows Media Video 7 | Ja | Ja | Ja | Ja | Ja
Windows Media Video 9 Screen | Ja | Nein | Ja | Nein | Nein

1 Während der Wiedergabe in Windows Media Player, Version 6.4, treten möglicherweise Störungen oder Tonausfälle auf.

Verwandte Themen

  • Erste Schritte
  • Informationen zur CBR- oder VBR-Codierung


Hardware- und Softwareanforderungen

Aktuelle Informationen zu den Hardware- und Softwareanforderungen finden Sie auf mehreren Websites:

  • Weitere Informationen zu den Systemanforderungen finden Sie auf der Systemanforderungsseite der Microsoft-Website.
  • Eine Liste der unterstützten Audio- und Videoaufnahmekarten finden Sie auf der Hardwareanbieterseite der Microsoft-Website.
  • Eine Liste der unterstützten tragbaren Geräte finden Sie auf der Seite für tragbare Geräte der Microsoft-Website.

Verwandte Themen

  • Erste Schritte


Informationen zu den Encoder-Ansichten

Das Hauptfenster von Windows Media Encoder weist zahlreiche Fensterbereiche auf, die Informationen zur aktuellen Sitzung bieten. Die bei der Codierung angezeigten Fensterbereiche hängen von der Art des codierten Inhalts, der Anzahl der für die aktuelle Sitzung eingerichteten Quellen und Ihren persönlichen Vorlieben ab. Sie können zusätzliche Fensterbereiche anzeigen oder die angezeigten Fensterbereiche ausblenden. Alle Änderungen, die Sie am Fenster vornehmen, werden am Ende der Sitzung gespeichert.

  • Eigenschaften. Enthält Eigenschaften, die Sie zum Anpassen der Einstellungen der aktuellen Sitzung oder zum Einrichten einer benutzerdefinierten Sitzung verwenden können.
  • Video. Zeigt den Inhalt an, den Sie codieren. Abhängig von der Art des Inhalts können Sie den Fensterbereich so anpassen, dass nur der vorab codierte Inhalt, der codierte Inhalt oder beide angezeigt werden. In einigen Fällen wird der Quellinhalt oder die codierte Ausgabe während der Codierung nicht angezeigt.
  • Quelle. Listet alle Quellen in der aktuellen Sitzung auf. Sie können während der Codierung zwischen Quellen wechseln, indem Sie auf die entsprechende Schaltfläche für die Quelle klicken.
  • Audio. Enthält Steuerelemente zum Überwachen und Anpassen der Größe des Audiodatenstroms, den Sie codieren.
  • Geräte. Wird angezeigt, wenn ein Gerät über einen Institute of Electrical and Electronics Engineers (IEEE) 1394-Anschluss oder einen COM-Anschluss angeschlossen ist und ein Videorecorder verwendet wird, der das Sony RS422-Protokoll unterstützt. Sie können die Funktionen Wiedergabe, Anhalten, Stopp, Schneller Vorlauf, Rücklauf und Auswerfen für das Gerät in diesem Fensterbereich steuern. Sie können auch eine Schnittliste (Edit Decision List, EDL) erstellen, um bestimmte Zeitsegmente des Inhalts auf einem oder mehreren Videobändern automatisch zu codieren.
  • Monitor. Enthält Statusinformationen zur Sitzung.
  • Skript. Wird angezeigt, wenn Sie beim Einrichten der aktuellen Sitzung Skripts als Quelltyp aktiviert haben. Sie können während der Codierung in diesem Fensterbereich einen Skriptbefehl in den Datenstrom einfügen.

Um einen Fensterbereich anzuzeigen oder auszublenden, klicken Sie im Menü Ansicht auf den Fensterbereich, den Sie anzeigen oder ausblenden möchten.

Verwandte Themen

  • Erste Schritte


Informationen zu den Encoder-Dienstprogrammen

In Windows Media Encoder sind vier Dienstprogramme enthalten:

  • Profil-Editor für Windows Media. Verwenden Sie diesen Editor zum Erstellen benutzerdefinierter Profile für Codierungssitzungen.
  • Datei-Editor für Windows Media. Dieses Dienstprogramm hieß früher Windows Media ASF Indexer. Sie können dieses Tool zum Bearbeiten einer Windows Media-Datei verwenden. Sie können z. B. die Start- und Endpunkte einer Datei schneiden, Markierungen und Skriptbefehle hinzufügen, den dynamischen Bereich von Audioinhalten steuern und für Mehrkanal-Audiodateien steuern, wie die Kanäle für Stereowiedergabe gewandelt werden.
  • Datenstrom-Editor für Windows Media. Sie können dieses Tool zum Aufteilen von Datenströmen auf oder zum Kombinieren von Datenströmen in vorhandenen Windows Media-Dateien verwenden, um eine Datei zu erstellen. Sie können z. B. eine Mehrere Bitraten (Multiple Bit Rate, MBR)-Datei in mehrere SBR-Dateien (Single-Bit-Rate) aufteilen. Sie können auch mehrere Dateien erstellen, von denen jede den gleichen Videodatenstrom mit einem unterschiedlichen Audiodatenstrom enthält (um z. B. eine Datei mit mehreren Sprachen zu erstellen).
  • Windows Media-Codierungsskript. Dieses Skript wurde früher als Windows Media-Codierungsdienstprogramm bezeichnet; Sie können dieses Befehlszeilen-Dienstprogramm (Wmcmd.vbs) zum Codieren und Übertragen von Inhalten verwenden. Dieses Dienstprogramm wird standardmäßig im gleichen Ordner wie der Encoder installiert (C:\Programme\Windows Media-Komponenten\Encoder).

Verwandte Themen

  • Erste Schritte
  • So greifen Sie auf ein Encoder-Dienstprogramm zu


So greifen Sie auf ein Encoder-Dienstprogramm zu

  1. Klicken Sie zu diesem Zweck auf Start, zeigen Sie auf Programme, auf Windows Media und dann auf Dienstprogramme.
  2. Klicken Sie auf das Dienstprogramm, das Sie verwenden möchten.

Anmerkung Anmerkung

  • Sie können im gleichen Ordner auf die Hilfe zu Windows Media-Codierungsskript zugreifen.

Verwandte Themen

  • Informationen zu den Encoder-Dienstprogrammen


Konventionen in der Dokumentation

Die folgenden Konventionen werden in diesem Hilfesystem verwendet:

Konvention | Bedeutung
Fett | Text, der in der Benutzeroberfläche angezeigt wird oder exakt wie in der Dokumentation dargestellt in die Benutzeroberfläche eingegeben werden muss.
Kursiv | Platzhaltertext, den Sie entsprechend der Umgebung durch Text ersetzen müssen.
Code | Beispielcode, den Sie entsprechend der Umgebung durch Code ersetzen müssen.

Verwandte Themen

  • Erste Schritte


Konzepte

Dieser Abschnitt stellt allgemeine Informationen zum Arbeiten mit Windows Media Encoder 9-Reihe zur Verfügung.

Verwandte Themen

  • Windows Media Encoder
  • Grundlegendes zu Codecs
  • Informationen zu Sitzungen
  • Vergleichen von Windows Media-Servern und Webservern
  • Informationen zur CBR- oder VBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen


Grundlegendes zu Codecs

Unkomprimierte Audio- und Videoinhalte können bei der Ausstrahlung sehr viel Bandbreite beanspruchen oder zu großen Dateien führen. Indem der Inhalt komprimiert wird, kann er über die üblichen Internetbandbreiten übertragen oder in einer Windows Media-Datei vertretbarer Größe gespeichert werden. Sie können Inhalt durch Anwenden von Komprimierungsalgorithmen auf die Daten komprimieren, wobei Sie die gewünschte Ausgabequalität und die verfügbare Bandbreite berücksichtigen sollten. Vor der Wiedergabe wird der Inhalt mithilfe von Dekomprimierungsalgorithmen dekomprimiert. Diese Komprimierungs- und Dekomprimierungsalgorithmen werden als Codecs bezeichnet. Die folgende Tabelle enthält ausführliche Informationen zu den in Windows Media Encoder verfügbaren Codecs.

Codec | Beschreibung
Windows Media Audio 9 Professional | Bietet ein Klangerlebnis in Vollsurround und die Steuerung des dynamischen Bereichs. Wandelt eigenständig Mehrkanalaudio abhängig von der Lautsprecherkonfiguration des Wiedergabegeräts in 2 Kanäle (Stereo) oder 1 Kanal (Mono) um. Geeignet für Datenraten von 128 bis 768 Kbit/s.
Windows Media Audio 9 Lossless | Stellt verlustfreie Codierung von Audioinhalten zur Verfügung. Unterstützt Mehrkanal-Audiocodierung und Steuerung dynamischer Bereiche.
Windows Media Audio 9 | Bietet bei der Komprimierung eine Verbesserung von 20 % gegenüber dem Windows Media Audio 8-Codec. Unterstützt VBR-Audiocodierung.
Windows Media Audio 9 Voice | Bietet ausgezeichnete Qualität für Audioinhalte mit dem Schwerpunkt Sprache. Ermöglicht Codierung von Sprache und Musik im gemischten Modus. Geeignet für die Wiedergabe mit Bitraten bis 20 Kbit/s.
Windows Media Video 9 | Erstellt qualitativ hochwertige Videoinhalte für die Ausstrahlung, das Downloaden, die Wiedergabe und physische Formatübermittlungsszenarien. Bietet bei der Komprimierung eine Verbesserung von 15 bis 50 % gegenüber dem Windows Media Video 8.1-Codec; die signifikanteste Verbesserung erfolgt bei höheren Bitraten. Ermöglicht die Wiedergabe von Inhalten mit Zeilensprüngen auf Fernsehgeräten und Set-Top-Boxen.
Windows Media Video 8.1 | Unterstützt eine Vielzahl von Netzwerkbandbreiten. Entfernt vor der Codierung die Zeilensprünge aus Inhalten mit Zeilensprüngen.
Windows Media Video 7 | Ermöglicht Benutzern von Windows Media Player 7 das Anzeigen codierter Videoinhalte, ohne zuerst die aktuellsten Codecs downloaden zu müssen. Dieser Codec ist die beste Wahl, wenn der Computer mit dem Encoder die Leistungsanforderungen der neueren Windows Media Video-Codecs nicht unterstützt.
Windows Media Video 9 Screen | Bietet verbesserte Verarbeitung von abgeblendeten Bildern, Bewegungen auf dem Bildschirm und Bildläufen für das Aufzeichnen von Bildschirminhalten. Unterstützt CBR mit einem Durchlauf und VBR-Codierung ohne Überspringen von Frames. Dieser Codec ist sowohl für Ausstrahlungs- als auch für Download und Wiedergabeszenarien vollständig optimiert.

Anmerkung Anmerkung

  • In einigen Fällen wird der ACELP-Codec von Sipro Labs in der Liste der Codecs angezeigt. Dies ist z. B. dann der Fall, wenn Sie ein Profil importieren, das mit Windows Media Encoder, Version 7.1, erstellt wurde. Unter diesen Umständen sollten Sie stattdessen den Windows Media Audio 9 Voice-Codec verwenden.

Verwandte Themen

  • Konzepte


Informationen zu Sitzungen

Bevor Sie Inhalte codieren können, müssen Sie eine Codierungssitzung einrichten. Beim Einrichten der Sitzung müssen Sie die folgenden Aufgaben durchführen:

  • Angeben der Quelle der Audio- oder Videoinhalte. Sie können Geräte, Dateien oder auch beides als Quelle verwenden. Sie können Bildschirme direkt von Ihrem Desktop aus aufzeichnen.
  • Auswählen der Ausgabeoption. Wählen Sie aus, ob der Inhalt übertragen oder in einer Datei codiert werden soll. Wenn Sie den Inhalt übertragen, können Sie den Datenstrom per Push auf einen Windows Media-Server übertragen, und Sie können Windows Media-Server und -Player für das Anfordern des Datenstroms per Pull vom Encoder aktivieren. Sie können wahlweise auch eine Kopie der Übertragung zur späteren Verwendung archivieren.

Außerdem sollten Sie die Komprimierungs- und Qualitätseinstellungen vor der Codierung überprüfen. Es werden die Standardeinstellungen angewendet, es kann jedoch erforderlich sein, die Einstellungen an Ihre Anforderungen anzupassen. Wenn Sie z. B. die Verteilung des Inhalts für Download und Wiedergabe auf einem Computer planen, möchten Sie möglicherweise bitratenbasierte Variable Bitrate (Variable Bit Rate, VBR)-Codierung verwenden und die Video- und Audioqualitätsstufe auf eine höhere Bitrate festlegen.

Nachdem Sie die Quelle des Inhalts identifiziert und die Ausgabe angegeben haben, stehen mehrere Optionen zum Anpassen einer Sitzung zur Verfügung. Sie können z. B. die Audio- und Videoinformationen optimieren, um die Qualität des codierten Inhalts zu verbessern.

Nachdem Sie die Sitzung gemäß Ihren Anforderungen konfiguriert haben, können Sie mit der Codierung beginnen. Wenn Sie die gleiche Sitzung erneut ausführen möchten, können Sie die Sitzung vor oder nach der Codierung in einer Sitzungsdatei speichern.

Anmerkung Anmerkung

  • Es ist nicht erforderlich, bei jeder Codierung eine Sitzung zu erstellen. Der Encoder enthält Schnellstarts sowie den Assistenten für neue Sitzungen, die allgemeine Codierungsszenarien berücksichtigen.

Verwandte Themen

  • Konzepte
  • Konfigurieren von Quellen
  • Ausgabeoptionen
  • Anpassen einer Sitzung
  • Codieren mit Schnellstarts oder dem Assistenten für neue Sitzungen
  • So speichern Sie eine Sitzung


Vergleichen von Windows Media-Servern und Webservern

Sie können Inhalte von einem Server, der Windows Media-Dienste ausführt, oder von einem Webserver an einen Player übermitteln. Der Server und der Player können sich im Internet oder in einem Intranet befinden, und sie können durch einen Firewall getrennt sein. Ein Windows Media-Server ist im Gegensatz zu einem Standardwebserver speziell dafür ausgelegt, Windows Media-basierten Inhalt auszustrahlen. Wenn Sie sich zur Verwendung eines Webservers entschließen, sollten Sie die Unterschiede in der Art der Inhaltsübermittlung beachten, die sich auf die Wiedergabequalität auswirken können.

Windows Media-Server

Ein Windows Media-Server misst die Übermittlung von Paketen anhand der Feedbackinformationen, die er beim Senden eines Datenstroms an einen Player empfängt. Wenn ein Player Pakete auf diese Weise empfängt, ist es sehr viel wahrscheinlicher, dass die Darstellung nahtlos erfolgt. Da die Nutzung der Bandbreite gesteuert wird, können mehrere Benutzer gleichzeitig eine Verbindung zu Ihrer Site herstellen und trotzdem unterbrechungsfreie Datenströme empfangen.

Wenn Sie planen, die Inhalte als einen Unicastdatenstrom von einem Windows Media-Server zu übermitteln, können Sie einen Mehrere Bitraten (Multiple Bit Rate, MBR)-Datenstrom (Multiple Bit Rate, mehrere Bitraten) codieren. Auf diese Weise stellen Sie Benutzern Inhalte mit besserer Qualität zur Verfügung, wenn das Netzwerk ausgelastet ist. Wenn MBR-Inhalte von einem Player empfangen werden, wird nur die Bitrate vom Server ausgestrahlt, die am geeignetsten für die Netzwerk-Bandbreitenbedingungen ist. Der Vorgang des Auswählens des entsprechenden Datenstroms wird vom Windows Media-Server und dem Player durchgeführt, und ist für den Benutzer unsichtbar.

Wenn SBR-Datenströme (Single-Bit-Rate) oder Dateien ausgestrahlt werden, kann ein Windows Media-Server die erhöhte Netzwerklast reibungslos verarbeiten. Wenn während der Übertragung eine erhöhte Netzwerklast auftritt, wird der Datenstrom „ausgedünnt“, d. h., die Framerate wird verringert. Wenn dies nicht ausreicht, wird die Ausstrahlung der Videokomponente des Datenstroms unterbrochen und nur die Audiokomponente ausgestrahlt.

Webserver

Ein Webserver ist so ausgelegt, dass er möglichst viele Daten so schnell wie möglich downloadet. Dies ist die bevorzugte Methode beim Senden von Paketen, die statische Bilder, Text und Webseitenskripts enthalten. Für das Senden von Paketen, die Streaming Media-Inhalte enthalten, ist dies jedoch nicht die optimale Methode. Streaming Media sollten in Echtzeit und nicht im Burstmodus übermittelt werden, und der Player sollte Pakete unmittelbar vor deren Wiedergabe erhalten.

Webserver unterstützen keine MBR-Datenströme. Wenn eine Datei von einem Webserver ausgestrahlt wird, wird die Qualität der Übermittlung nicht überwacht, und es können keine Anpassungen der Bitrate vorgenommen werden. User Datagram Protocol (UDP) ist das für die Ausstrahlung von Medien bevorzugte Übermittlungsprotokoll. Da Webserver dieses Protokoll nicht verwenden können, erhöht sich die Wahrscheinlichkeit, dass die Übermittlung eines Datenstroms durch Ruheperioden unterbrochen wird, während der Player Daten zwischenspeichert. Außerdem unterstützen Webserver weder Liveübertragung noch Multicastdatenströme.

Anmerkung Anmerkung

  • Windows Media-Dienste 9-Reihe unter Windows .NET Server 2003 enthält mehrere Funktionen, die als schnelle Ausstrahlung bezeichnet werden. Die schnelle Ausstrahlung kann einige der Vorteile von Downloaden und Ausstrahlen kombinieren. Weitere Informationen zur schnellen Ausstrahlung finden Sie in der Hilfe zu Windows Media-Dienste.

Verwandte Themen

  • Konzepte
  • Ausgabeoptionen


Informationen zur CBR- oder VBR-Codierung

Mit Windows Media Encoder können Sie Audio- und Videoinhalte entweder mit konstanter Bitrate (Constant Bit Rate, CBR) oder mit variabler Bitrate (Variable Bit Rate, VBR) codieren.

CBR-Codierung

Die CBR-Codierung funktioniert am effizientesten in einem Ausstrahlungsszenario. Bei der CBR-Codierung bleibt die Bitrate im Verlauf des Datenstroms relativ konstant und nahe der Zielbitrate innerhalb eines kleinen Zeitfensters, das durch die Puffergröße festgelegt wird. Der Nachteil der CBR-Codierung liegt darin, dass die Qualität des codierten Inhalts nicht konstant ist. Da einige Komponenten des Inhalts schwieriger als andere zu komprimieren sind, besitzen einige Teile des CBR-Datenstroms eine niedrigere Qualität als andere. Außerdem führt CBR-Codierung von einem Datenstrom zum nächsten zu inkonsistenter Qualität. Im Allgemeinen sind die Qualitätsabweichungen bei niedrigeren Bitraten deutlicher.

VBR-Codierung

Verwenden Sie die VBR-Codierung, wenn Sie den Inhalt zum Downloaden, zur lokalen Wiedergabe oder zur Wiedergabe auf einem Gerät mit einer begrenzten Lesegeschwindigkeit (z. B. einem CD- oder DVD-Player) verteilen möchten. (Sie können den auf maximalen Bitraten basierenden VBR-Codierungsmodus auch verwenden, wenn Sie die Ausstrahlung des Inhalts planen.) VBR-Codierung eignet sich am besten zum Codieren von Inhalt, der eine Mischung aus einfachen und komplexen Daten darstellt. Dies gilt z. B. für ein Video, das zwischen langsamer und schneller Bewegung wechselt. Mit VBR-Codierung werden weniger Bits automatisch weniger komplexen Teilen des Inhalts zugewiesen. So bleiben ausreichend Bits verfügbar, um eine gute Qualität für komplexere Teile zu erreichen. Dies bedeutet, dass Inhalte mit konsistenter Komplexität (z. B. eine Reportage) von VBR-Codierung nicht profitieren. VBR-Codierung führt bei gemischten Inhalten im Vergleich zur CBR-Codierung zu einer viel besseren codierten Ausgabe bei gleicher Dateigröße. In einigen Fällen kann das Ergebnis eine VBR-codierte Datei sein, die die gleiche Qualität wie eine CBR-codierte Datei bei halber Dateigröße aufweist.

Codierungsmodusoptionen

Mit CBR-Codierung können Sie Codierung mit Codierung mit einem Durchlauf oder Codierung mit zwei Durchläufen verwenden. Die folgenden drei VBR-Codierungsoptionen stehen zur Verfügung: qualitätsbasiertes VBR (ein Durchlauf), bitratenbasiertes VBR (zwei Durchläufe) und auf maximalen Bitraten basierendes VBR (zwei Durchläufe). Nicht alle Codecs unterstützen die CBR-Codierung mit zwei Durchläufen oder die VBR-Codierung.

Verwandte Themen

  • Konzepte
  • Verwenden der CBR-Codierung
  • Verwenden der VBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen
  • Funktionsanforderungen


Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen

Mit Windows Media Encoder können Sie Codierung mit einem oder zwei Durchläufen durchführen, entweder mit CBR- oder mit VBR-Codierung. (Der qualitätsbasierte VBR-Codierungsmodus verwendet einen Durchlauf, die bitratenbasierten VBR- und auf maximalen Bitraten basierenden VBR-Codierungsmodi verwenden zwei Durchläufe.)

Bei der Codierung mit einem Durchlauf durchläuft der Inhalt den Encoder einmal, und die Komprimierung wird unmittelbar auf den Inhalt angewendet. Bei der Codierung mit zwei Durchläufen wird der Inhalt im ersten Durchlauf analysiert und dann im zweiten Durchlauf basierend auf den im ersten Durchlauf ermittelten Daten codiert. Codierung mit zwei Durchläufen kann zu einer besseren Qualität des Inhalts führen, da dem Encoder die Zeit zum Ermitteln der optimalen Kombination von Bitrate, Framerate, Puffergröße und Bildqualität basierend auf der Szenenzusammensetzung zur Verfügung steht. Codierung mit zwei Durchläufen dauert jedoch länger, da der Encoder den gesamten Inhalt zweimal durchläuft.

In bestimmten Situationen steht die Codierung mit zwei Durchläufen nicht zur Verfügung:

  • Der Datenstrom wird übertragen.
  • Es sind mehrere Quellen in einer Sitzung vorhanden.
  • Für die Quelle ist Schleife festgelegt.
  • Im Datenstrom sind Skriptbefehle enthalten.
  • Der Quellinhalt stammt von Geräten (es sei denn, Sie haben die Gerätesteuerung aktiviert).
  • Die Quelldatei hat die Dateinamenerweiterung BMP.

Außerdem steht die Codierung mit zwei Durchläufen nur für bestimmte Codecs zur Verfügung. Eine Liste der Codecs, die Codierung mit zwei Durchläufen unterstützen, finden Sie unter Funktionsanforderungen.

Anmerkung Anmerkung

  • Wenn Sie Codierung mit zwei Durchläufen verwenden, wird das Ausgabevideo im ersten Durchlauf nicht im Encoder angezeigt.

Verwandte Themen

  • Konzepte
  • Informationen zur CBR- oder VBR-Codierung
  • Aktivieren der Gerätesteuerung


Konfigurieren von Quellen

Mit Windows Media Encoder können Sie Liveinhalte in Echtzeit und gespeicherte Inhalte codieren oder Bildschirme aufzeichnen. Echtzeitinhaltsquellen sind jegliche Geräte, die an die Audio- oder Videokarte angeschlossen werden können, beispielsweise CD-Player, Mikrofone, Videorecorder, Videokameras, Videoabspielgeräte oder Fernsehgeräte. Gespeicherte Quellen sind Audio- oder Videodateien. Sie können auch Bildschirme direkt von Ihrem Desktop aus aufzeichnen und bei der Codierung Skriptbefehle einfügen.

Denken Sie daran, dass die Qualität des Ausgabeinhalts umso höher ist, je höher die Qualität des Quellinhalts ist. Sie sollten also mit einer Quelldatei in höchster Qualität beginnen. Wenn ein Gerät die Quelle ist, legen Sie für das Gerät die Aufzeichnung in bestmöglicher Qualität fest.

Beim Konfigurieren einer Quelle identifizieren Sie zuerst die Quelltypen (Audio, Video oder Skript), aus denen die Quelle besteht. Eine Quelle muss aus mindestens einem Audio- oder Videoquelltyp bestehen. Sie können vor oder nach Beginn der Codierung eine unbeschränkte Anzahl von Quellen zu einer Codierungssitzung hinzufügen. Jede nachfolgende Quelle basiert jedoch auf der Kombination der Quelltypen, die Sie in der Sitzung erstellt haben. Wenn die erste Quelle z. B. nur Audio enthält, basieren alle nachfolgenden Quellen in der Sitzung ebenfalls nur auf Audio. Für Mehrfachquellensitzungen wird empfohlen, die erste Quelle für die Verwendung aller drei Quelltypen zu konfigurieren. Wenn zusätzliche Quellen einen Quelltyp nicht verwenden, können Sie einen leeren Datenstrom für diesen Quelltyp codieren.

Verwandte Themen

  • Windows Media Encoder
  • Verwenden einer Datei als Quelle
  • Verwenden von Mehrkanal-Audiodateien als Quelle
  • Verwenden von Geräten als Quelle
  • Aufzeichnen von Bildschirmen
  • Einfügen von Skriptbefehlen
  • Verwenden von mehreren Quellen in einer Sitzung


Verwenden einer Datei als Quelle

Mit Windows Media Encoder können Sie Dateien mit der Dateinamenerweiterung WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP und JPG als Quelle verwenden. (Wenn Sie eine Datei mit der Dateinamenerweiterung MPG als Quelle verwenden möchten, ist ein kompatibler MPEG-2-Decoder auf dem Computer mit dem Encoder erforderlich.)

Wenn Sie eine Windows Media-Datei codieren, gehen bei diesem Vorgang alle mit der Datei verknüpften Headerattribute verloren (Markierungen, Skriptbefehle usw.). Sie können den Datei-Editor für Windows Media verwenden, um die folgenden Attribute zur Datei erneut hinzuzufügen: Titel, Autor, Copyright und Beschreibung.

Wenn eine Datei als Quelle verwendet wird, können Sie durch das Kürzen der Start- und Endzeiten der Datei sicherstellen, dass nur der gewünschte Teil der Datei codiert wird.

Weitere Informationen zum Abrufen eines MPEG-2-Decoders finden Sie auf der Microsoft-Website.

Anmerkung Anmerkung

  • Dateien, die Bilder mit ungeraden Abmessungen enthalten, werden nicht unterstützt. Ein Bild, das z. B. 300 × 321 Pixel groß ist, wird nicht unterstützt, ein Bild mit 300 × 320 Pixeln hingegen schon.

Weitere Informationen zum Abrufen eines MPEG-2-Decoders finden Sie auf der Microsoft-Website.

Verwandte Themen

  • Konfigurieren von Quellen
  • So verwenden Sie eine Datei als Quelle


So verwenden Sie eine Datei als Quelle

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Datei.

    - Oder -

    Klicken Sie auf Gerät und Datei, um zwei unterschiedliche Dateien als Quelle für Audio- bzw. Videoinhalt zu verwenden.

  3. Um die Quelldatei zu suchen, klicken Sie auf Durchsuchen.
  4. Wenn Sie den Anfang oder das Ende der Datei kürzen möchten, klicken Sie auf Anfang/Ende. Nur der verbleibende Teil der Datei wird codiert.
  5. Wenn Sie nur die Audio- oder die Videokomponente einer Datei codieren möchten, deaktivieren Sie das Kontrollkästchen Video bzw. Audio.

Anmerkung Anmerkung

  • Sie können auch eine Quelldatei in den Encoder ziehen.

Verwandte Themen

  • Verwenden einer Datei als Quelle


Verwenden von Mehrkanal-Audiodateien als Quelle

Mit Windows Media Encoder können Sie Mehrkanalaudio codieren, d. h., Sie können Audio für eine Surroundsound-Wiedergabe über sechs (5.1-Audio) oder acht (7.1-Audio) Kanäle codieren. Dieses Format wurde speziell für CD, DVD, hoch auflösendes Fernsehen und digitale Kinoaudioprogramme konzipiert. Die Inhaltsquelle muss eines der folgenden Formate besitzen:

  • Eine einzelne 6-Kanal- oder 8-Kanaldatei, die das Format WAVE_FORMAT_EXTENSIBLE aufweist. Weitere Informationen finden Sie auf der Microsoft-Website. Wenn es sich bei der Quelle um eine 8-Kanaldatei handelt, sollten die Abtastrate und die Bits pro Sample der Quelldatei und des codierten Inhalts unbedingt übereinstimmen.
  • Sechs WAV-Monokanaldateien. Zum Erstellen der Dateien verwenden Sie ein Audiobearbeitungsprogramm, um die Audioinformationen auf sechs Dateien zu verteilen – eine Datei für jeden Kanal. Wenn Sie die Quelle im Encoder einrichten, geben Sie an, welchem Kanal jede der Dateien zugeordnet ist. Die einzelnen WAV-Dateien dürfen maximal 2 GB groß sein. Diese Option ist mit 7.1-Audio nicht verfügbar.
  • Eine vorhandene Windows Media-Mehrkanal-Audiodatei. Verwenden Sie eine vorhandene Datei zum Codieren der Datei mit einer anderen Bitrate. Es ist nicht möglich, eine vorhandene Windows Media-Mehrkanal-Audiodatei zu codieren, wenn sich der Encoder auf einem Computer unter Windows 2000 befindet.

Sie müssen entweder den Windows Media Audio 9 Professional-Codec oder den Windows Media Audio 9 Lossless-Codec und ein Audioformat verwenden, das Mehrkanalcodierung unterstützt, wenn Sie Mehrkanalinhalte codieren. Außerdem muss der Benutzer, der den Inhalt wiedergibt, über Microsoft Windows XP und einen Player verfügen, der auf dem SDK (Software Development Kit) von Windows Media Format 9-Reihe basiert. Andernfalls werden die Audioinformationen automatisch für die Wiedergabe mit Stereolautsprechern auf zwei Kanäle gewandelt.

Der Encoder verwendet für die Wiedergabe mit Stereolautsprechern automatisch zwei Kanäle. Wenn Sie 5.1-Audio codieren, können Sie die Fold-Down-Verteilung der Informationen auf die Surround-, Center- und Subwooferkanäle auf der Registerkarte Verarbeitung des Fensterbereichs Eigenschaften steuern. Wenn Sie den Inhalt in einer Datei codiert haben, können Sie auch den Datei-Editor für Windows Media zum Steuern der Fold-Down-Verteilung der Informationen in der Ausgabedatei verwenden.

Verwandte Themen

  • Konfigurieren von Quellen
  • So verwenden Sie Mehrkanal-Audiodateien als Quelle
  • So verwenden Sie eine Datei als Quelle


So verwenden Sie Mehrkanal-Audiodateien als Quelle

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Klicken Sie unter Audio auf WAV-Mehrkanalquelle, und klicken Sie dann auf Konfigurieren.
  4. Geben Sie für jeden Kanal die WAV-Quelldatei ein.
  5. Klicken Sie auf die Registerkarte Komprimierung.
  6. Klicken Sie abhängig vom Wiedergabeszenario unter Ziel entweder auf Dateidownload, Hardwaregeräte, Windows Media-Server oder Webserver.
  7. Klicken Sie unter Audio auf Mehrkanalaudio (CBR).
  8. Klicken Sie auf Bearbeiten und dann auf die Registerkarte mit der Bitrateangabe.
  9. Klicken Sie unter Audioformat auf das gewünschte 5.1- oder 7.1-Audioformat.

Anmerkung Anmerkung

  • Der Encoder verwendet für die Wiedergabe mit Stereolautsprechern automatisch zwei Kanäle. Beim Codieren von 5.1-Audio können Sie die Standardverteilung der Audioinformationen auf der Registerkarte Verarbeitung ändern.

Verwandte Themen

  • Verwenden von Mehrkanal-Audiodateien als Quelle


Verwenden von Geräten als Quelle

Wenn Sie Geräte als Quelle für Inhalte verwenden, müssen Sie zuerst die gewünschten Audio- oder Videogeräte auswählen. Nachdem Sie die Geräte ausgewählt haben, können Sie deren Eigenschaften direkt vom Encoder aus festlegen. Die Eigenschaften für einige Geräte, wie z. B. Audio- und Videokarten, sind global und gelten nicht nur für alle Quellen in der Codierungssitzung, sondern auch für alle Programme auf dem Computer (beispielsweise Helligkeit, Kontrast, Aufzeichnungsdimensionen und Einstellungen für den Audiomixer.)

Sie können Geräte und Videoaufnahmekarten in einer Sitzung nur einmal verwenden. Wenn Sie z. B. zwei Quellen erstellen – eine Quelle ist ein Liveereignis, bei dem ein Sprecher ein neues Video vorstellt, und die zweite Quelle ist das Video –, benötigen Sie eine separate Karte und ein eigenes Gerät für jede Quelle.

Einige Geräte können direkt vom Encoder aus gesteuert werden. Wenn Sie Gerätesteuerung aktiviert haben, können Sie eine Schnittliste (Edit Decision List, EDL) einrichten, in der Sie die zu codierenden Bandteile angeben.

Sie können die Eigenschaften des Audio- oder Videogeräts konfigurieren, indem Sie den Assistenten für neue Sitzungen, den Fensterbereich Eigenschaften oder den Befehl Geräte konfigurieren im Menü Extras verwenden. Die Geräte müssen auf dem Computer bereits installiert sein, damit sie im Encoder konfiguriert werden können. Sie können den Encoder nicht zum Hinzufügen oder Entfernen von Hardware verwenden; verwenden Sie zu diesem Zweck die Systemsteuerung.

Wenn Sie eine unterstützte TV-Tunerkarte installiert haben, können Sie die TV-Kanäle mit dem Encoder ändern.

Verwandte Themen

  • Konfigurieren von Quellen
  • Aktivieren der Gerätesteuerung
  • Einrichten einer Schnittliste
  • So verwenden Sie Geräte als Quelle
  • So ändern Sie den zu codierenden TV-Kanal


So verwenden Sie Geräte als Quelle

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Klicken Sie unter Video und Audio auf die Geräte, die als Quelle verwendet werden sollen.

Verwandte Themen

  • Verwenden von Geräten als Quelle


So ändern Sie den zu codierenden TV-Kanal

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Klicken Sie unter Video auf die TV-Tunerkarte, die als Quelle verwendet werden soll.
  4. Klicken Sie auf Konfigurieren.
  5. Geben Sie unter Kanal den Kanal ein, der codiert werden soll.
  6. Wählen Sie unter Eingänge die Tuneroption aus, und klicken Sie dann auf OK.
  7. Klicken Sie unter Audio auf die Videoaufzeichnungskarte, die Sie für die Verwendung mit der TV-Tunerkarte konfiguriert haben.

Verwandte Themen

  • Verwenden von Geräten als Quelle


Aktivieren der Gerätesteuerung

Mithilfe der Gerätesteuerungsfunktion können Sie bestimmte Geräte direkt vom Encoder aus ausführen. Die Gerätesteuerung ermöglicht das Steuern der Funktionen Wiedergabe, Anhalten, Stopp, Schneller Vorlauf, Rücklauf und Auswerfen für das Gerät vom Encoder aus. Um Gerätesteuerung zu aktivieren, muss das Gerät an einen digitalen Institute of Electrical and Electronics Engineers (IEEE) 1394-Videoanschluss angeschlossen sein, oder Sie können einen Videorecorder verwenden, der das Sony RS422-Protokoll unterstützt und über einen COM-Anschluss angeschlossen ist. Sie können auch die integrierte Schnittliste (Edit Decision List, EDL) der Gerätesteuerungsfunktion verwenden, um Clips in beliebiger Reihenfolge anzuordnen und zu codieren.

Wenn Sie Gerätesteuerung aktiviert haben, können Sie unter den folgenden Umständen Codierung mit zwei Durchläufen verwenden:

  • Sie haben sich entschieden, in eine Datei zu codieren.
  • Sie haben sich entschieden, den Inhalt vorübergehend zu speichern.
  • Sie haben eine Schnittliste für den Inhalt eingerichtet.

Anmerkung Anmerkung

  • Wenn ein in der Sitzung verwendetes Gerät nicht im Dialogfeld Geräte konfigurieren angezeigt wird, schließen Sie das Dialogfeld, klicken Sie auf Übernehmen, und öffnen Sie das Dialogfeld dann erneut.

Verwandte Themen

  • Verwenden von Geräten als Quelle
  • Einrichten einer Schnittliste
  • So speichern Sie aufgezeichneten Inhalt vorübergehend
  • So aktivieren Sie die Gerätesteuerung


So aktivieren Sie die Gerätesteuerung

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Klicken Sie unter Video und Audio auf das Gerät, das als Quelle verwendet werden soll.

    Wenn das Gerät nicht in der Liste angezeigt wird, überprüfen Sie, ob das Gerät eingeschaltet ist. Es kann erforderlich sein, den Encoder zu beenden und nach dem Einschalten des Geräts erneut zu starten.

  4. Klicken Sie auf Übernehmen.
  5. Klicken Sie im Fensterbereich Geräte auf Einrichten.
  6. Wählen Sie in der Liste das Gerät oder den COM-Anschluss aus, über den das Gerät angeschlossen ist, und klicken Sie dann auf OK.
  7. Verwenden Sie die Steuerelemente des Fensterbereichs, um das Gerät zu steuern.

Anmerkung Anmerkung

  • Um ein digitales Gerät vom Encoder aus zu steuern, muss sich das Gerät im Videorecordermodus befinden; für Videorecorder muss der TC-Modus festgelegt werden.

Verwandte Themen

  • Aktivieren der Gerätesteuerung


Einrichten einer Schnittliste

Wenn Sie Gerätesteuerung aktiviert haben, können Sie über den Zeitstempel die genaue Position im Audio- oder Videoinhalt angeben, an der die Codierung beginnen und enden soll. Zu diesem Zweck müssen Sie eine Schnittliste (Edit Decision List, EDL) erstellen, welche die zu codierenden Bandteile angibt.

Das Verwenden einer Schnittliste für eine Übertragung wird nicht empfohlen, da der Encoder zusätzliche Zeit benötigt, um die Schnittlistenpunkte während der Codierung zu suchen. Während einer Übertragung kann dies zu exzessiver Pufferung auf dem Player führen.

Sie können so viele Schnittlisteneinträge wie gewünscht in beliebiger Reihenfolge hinzufügen. Die Reihenfolge muss nicht dem Auftreten auf dem Band entsprechen. Sie können auch eine Schnittliste einrichten, die mehrere Bänder als Quelle verwendet. Während der Codierungssitzung fordert der Encoder Sie bei Bedarf zum Wechseln des Bands auf.

Sie sollten beim Einrichten einer Schnittliste ein Band verwenden, das Prestriping aufweist. Um das Band mit Prestriping zu versehen, können Sie das Band direkt nach dem Kauf durchgehend von Anfang bis Ende aufzeichnen lassen. Auf diese Weise wird sichergestellt, dass der Zeitcode auf dem Band kontinuierlich ist. Wenn das Band nicht auf diese Weise vorbehandelt wurde, generiert das Gerät bei jedem Einrichten einer Schnittliste für das Gerät einen neuen Zeitcode.

Verwandte Themen

  • Verwenden von Geräten als Quelle
  • Aktivieren der Gerätesteuerung
  • So richten Sie eine Schnittliste ein


So richten Sie eine Schnittliste ein

  1. Richten Sie eine Gerätesteuerungssitzung ein, die in eine Datei codiert.
  2. Klicken Sie im Menü Ansicht auf Monitor und dann auf die Registerkarte Schnittliste.
  3. Klicken Sie auf Schnittliste bearbeiten.
  4. Klicken Sie im Bereich Gerät auf Wiedergabe, um mit der Wiedergabe des Bands zu beginnen.

    Sie können die Wiedergabe des Bands an einem bestimmten Punkt auch starten, indem Sie andere Steuerelemente für die Wiedergabe verwenden, z. B. die Schaltflächen Springen zu und Schneller Vorlauf.

  5. Nachdem Sie den gewünschten Frame gefunden haben, klicken Sie auf Anfang, um diesen Frame als Startpunkt des Clips anzugeben.

    Das Band wird auch weiterhin wiedergegeben.

  6. Klicken Sie bei dem Frame auf Ende, der als Endpunkt des Clips dienen soll.
  7. Wenn Sie mehrere Bänder verwenden, stellen Sie eine eindeutige ID (beispielsweise 1, 2, 3 oder A, B, C) unter Band-ID zur Verfügung.
  8. Klicken Sie auf EDL-Eintrag hinzufügen, um den Clip zur Schnittliste hinzuzufügen.
  9. Klicken Sie in der Liste, um den Clip zu bearbeiten, und klicken Sie dann auf die Schaltfläche Bearbeiten.
  10. Wiederholen Sie die Schritte 4 bis 8, um weitere Clips hinzuzufügen.
  11. Wenn die Liste Ihren Vorstellungen entspricht, klicken Sie auf OK. Klicken Sie dann auf der Symbolleiste auf Codierung starten.

    Während der Codierung zeigt die Registerkarte Schnittliste des Fensterbereichs Monitor Statusinformationen für die Clips an.

Verwandte Themen

  • Einrichten einer Schnittliste
  • So aktivieren Sie die Gerätesteuerung
  • So codieren Sie in eine Datei


Aufzeichnen von Bildschirmen

Sie können den gesamten Desktopbildschirm, einzelne Fenster oder einen Bereich des Bildschirms aufzeichnen und den Bildschirm dann übertragen oder wie jeden anderen Inhalt in einer Datei codieren. Sie können die Dateiaufzeichnungsfunktion für Folgendes verwenden:

  • Aufzeichnen aus AVI-Dateien, die mit einem Bildschirmaufzeichnungsprogramm eines Drittanbieters erstellt wurden.
  • Aufzeichnen eines Fensters (oder des gesamten Desktops) direkt von Ihrem Desktop aus.
  • Aufzeichnen von einer Karte, die an ein Scanconvertergerät angeschlossen ist.

Wenn Sie ein Fenster aufzeichnen, können Sie die Sitzung auch zur späteren Verwendung speichern. Denken Sie jedoch daran, dass der Titel des Fensters und seine Koordinaten zusammen mit den anderen Konfigurationsinformationen in der Sitzungsdatei gespeichert werden. Wenn Sie die Sitzungsdatei für eine nachfolgende Bildschirm-Aufzeichnungssitzung erneut laden, sucht der Encoder nach einem Fenster, das dem gespeicherten Titel entspricht. Wenn der Encoder ein solches Fenster nicht findet, zeichnet er ein Fenster auf, das den gespeicherten Koordinaten entspricht.

Wenn Sie den gesamten Desktop aufzeichnen und die Sitzung speichern, werden die Auflösung und die Farbeinstellungen für Ihren Monitor in der Sitzungsdatei gespeichert. Wenn Sie sich nach dem Speichern der Sitzung die Bildschirmauflösung oder die Farben ändern, müssen Sie eine neue Sitzung erstellen, um diese Einstellungen zu erfassen.

Wenn der Bildschirmschoner während der Aufzeichnung eines Fensters oder des gesamten Desktops angezeigt wird, wird der Bildschirmschoner codiert. Aus diesem Grund wird empfohlen, den Bildschirmschoner beim Aufzeichnen eines Fensters oder des gesamten Desktops zu deaktivieren.

Anmerkung Anmerkungen

  • Verzerrungen können erzeugt werden, wenn ein analoges Signal einen Scanconverter durchläuft und in das NTSC-Format (National Television Standards Committee) konvertiert wird. Diese Verzerrungen werden während der Codierung verstärkt und können die Qualität des codierten Videos verschlechtern.
  • Wenn Sie das Aufzeichnen eines Bildschirms abgeschlossen haben, stellen Sie sicher, dass Sie auf der Symbolleiste auf Stopp klicken. Das einfache Minimieren des aufgezeichneten Fensters beendet die Codierungssitzung nicht.

Verwandte Themen

  • Konfigurieren von Quellen
  • Verbessern der Leistung beim Codieren von Bildschirmen
  • So codieren Sie eine AVI-Datei, die Bildschirminhalt enthält
  • So zeichnen Sie einen Bildschirm auf dem Desktop auf


Verbessern der Leistung beim Codieren von Bildschirmen

Durch die bearbeitete Datenmenge und die benötigte CPU-Leistung ist das Aufzeichnen von Bildschirmen ein leistungsintensiver Vorgang. Stellen Sie durch das Befolgen der folgenden Richtlinien sicher, dass das aufgezeichnete Bildschirmabbild codiert und korrekt wiedergegeben werden kann:

  • Verwenden Sie einen schnellen Prozessor.
  • Verwenden Sie den Windows Media Video 9 Screen-Codec.
  • Stellen Sie den Monitor so ein, dass eine geringere Auflösung verwendet wird. Wenn Sie z. B. mit einer Auflösung von 1024 × 768 aufzeichnen, ist die Datenmenge größer als bei einer Aufzeichnung mit der Auflösung 640 × 480.
  • Stellen Sie die Farbwiedergabe auf 16-Bit- oder 8-Bit-Farbtiefe ein. Um die CPU-Verwendung weiter zu verbessern, können Sie den Encoder auch so einstellen, dass er im 256-Farben-Modus ausgeführt wird. Denken Sie daran, dass die Ausführung im 256-Farben-Modus zu einer Palettenänderung führen kann, wenn Sie zwischen Programmen mit unterschiedlichen Farbschemas wechseln. Der Encoder unterstützt für Echtzeit-Bildschirmaufzeichnungen keine Palettenänderungen. Aus diesem Grund sollten Sie 16-Bit-Farbtiefe verwenden oder zuerst in einer AVI-Datei aufzeichnen und dann den Encoder zum Konvertieren der Datei in das Windows Media-Format verwenden.
  • Verwenden Sie eine niedrige Framerate. Sie müssen möglicherweise mit der Einstellung experimentieren, um die Framerate zu bestimmen, die Ihren Anforderungen entspricht.
  • Zeichnen Sie ein kleineres Abbild auf.
  • Verwenden Sie eine höhere Bitrate.
  • Vermeiden Sie mehrere Szenenwechsel, z. B. das Öffnen und Schließen von Fenstern in rascher Abfolge während der Aufzeichnung.
  • Zeichnen Sie Bildschirme oder Bereiche nur vom Hauptmonitor auf, wenn Sie ein Szenario mit zwei Monitoren verwenden.
  • Deaktivieren Sie Hardwarebeschleunigung. (Aktivieren Sie die Hardwarebeschleunigung jedoch nach Fertigstellung der Bildschirmaufzeichnung erneut, um die besten Ergebnisse mit anderen Programmen zu erzielen.)
  • Beenden Sie alle nicht verwendeten Videoprogramme.
  • Richten Sie den Ausgabeframe und die Quelle mit identischer Größe ein. Verwenden Sie den Encoder nicht zum Ändern der Größe des Quellvideos.

Verwandte Themen

  • Aufzeichnen von Bildschirmen
  • Hardware- und Softwareanforderungen


So codieren Sie eine AVI-Datei, die Bildschirminhalt enthält

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Datei, und geben Sie dann den Namen der AVI-Datei ein.
  3. Klicken Sie auf die Registerkarte Komprimierung.
  4. Klicken Sie abhängig vom Wiedergabeszenario unter Ziel entweder auf Windows Media-Server oder Webserver.
  5. Klicken Sie unter Video auf Bildschirmaufzeichnung.
  6. Klicken Sie auf Übernehmen und dann auf der Symbolleiste auf Codierung starten.

Anmerkung Anmerkung

  • Wenn Sie aus AVI-Dateien aufzeichnen, die mithilfe eines Bildschirmaufzeichnungsprogramms eines Drittanbieters erstellt wurden, verwenden Sie RLE-Komprimierung (Run-Length Encoding) oder unkomprimierte RGB-Formate für Dateien, deren Konvertierung durch den Encoder zu einem späteren Zeitpunkt geplant ist.

Verwandte Themen

  • Aufzeichnen von Bildschirmen


So zeichnen Sie einen Bildschirm auf dem Desktop auf

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Klicken Sie unter Video auf Bildschirmaufzeichnung, und klicken Sie dann auf Konfigurieren, um das Fenster oder den Ausschnitt des Bildschirms für die Aufzeichnung anzugeben.
  4. Klicken Sie auf die Registerkarte Komprimierung.
  5. Klicken Sie abhängig vom Wiedergabeszenario unter Ziel entweder auf Windows Media-Server oder Webserver.
  6. Klicken Sie unter Video auf Bildschirmaufzeichnung.
  7. Klicken Sie auf Übernehmen und dann auf der Symbolleiste auf Codierung starten.

    Das Encoder-Fenster wird minimiert, während Sie codieren. Wenn Sie eine Datei codieren, führt das Wiederherstellen des Encoder-Fensters normalerweise dazu, dass der Encoder angehalten wird. Wenn die Bildschirmaufzeichnungssitzung jedoch ebenfalls Audioinhalt aus einer Datei als Quelle verwendet, wird der Encoder durch das Wiederherstellen des Encoder-Fensters nicht angehalten. Bei einer Übertragungssitzung wird die Codierung selbst dann fortgesetzt, wenn Sie das Encoder-Fenster wiederherstellen. Um die Codierung zu beenden oder anzuhalten, klicken Sie auf der Taskleiste auf die Encoder-Schaltfläche. Klicken Sie dann auf der Symbolleiste auf Stopp oder auf Anhalten.

Verwandte Themen

  • Aufzeichnen von Bildschirmen


Einfügen von Skriptbefehlen

Sie können während der Codierung Skriptbefehle in einen Datenstrom einfügen. Der Encoder unterstützt die folgenden Skriptbefehltypen:

  • Beschriftungen. Formfreie Textzeichenfolgen, die in einem Player zusammen mit dem codierten Inhalt angezeigt werden. Damit die Beschriftungen sichtbar sind, müssen Benutzer sie in ihrem Player aktivieren.
  • Geschlossene Beschriftungen. Wenn Ihre Videoaufzeichnungskarte das Aufzeichnen geschlossener Beschriftungsdaten unterstützt, können Sie die geschlossenen Beschriftungen codieren.
  • URLs. Wenn URLs in einen Datenstrom eingefügt wurden, wird der Standardbrowser des Benutzers geöffnet, und der angeforderte URL wird in den Browser geladen. Wenn Sie den Player in einen Browser eingebettet haben, ersetzt der angeforderte URL den Player, und Benutzer können den Rest des Datenstroms nicht anzeigen. Sie können dies umgehen, indem Sie entweder den angeforderten URL in einem separaten Frame in derselben Browserinstanz anzeigen oder eine zusätzliche Browserinstanz öffnen.
  • Benutzerdefinierte Skriptbefehle. Neben der Unterstützung von Beschriftungen und URLs verarbeitet ein Player automatisch die Skriptbefehle FILENAME, EVENT und OPENEVENT. Sie können den Befehl FILENAME zum Öffnen einer bestimmten digitalen Mediendatei zum angegebenen Zeitpunkt verwenden. Sie können den Befehl EVENT zum Erstellen benutzerdefinierter Skriptbefehle verwenden. Sie können z. B. eine Anzeige in den Datenstrom einfügen. Beachten Sie, dass der Code für das angegebene Ereignis in der Windows Media-Metadatei für den Datenstrom definiert sein muss, damit der Player das angegebene Ereignis ausführt. Der Befehl OPENEVENT geht dem tatsächlichen Befehl EVENT voraus. Der Befehl OPENEVENT ermöglicht dem Player das vorab Puffern des Inhalts. Wenn das angegebene Ereignis dann eintritt, scheint der Wechsel zwischen den Datenströmen nahtlos zu sein.

Ausführliche Informationen zu den von Windows Media Player 9-Reihe unterstützten Skriptbefehlen finden Sie im SDK (Software Development Kit) von Windows Media Player 9-Reihe. Informationen zu den von Windows Media-Dienste 9-Reihe unterstützten Skriptbefehlen finden Sie im SDK (Software Development Kit) von Windows Media-Dienste.

Da Skriptbefehle im Datenstrom gespeichert werden, sind sie nicht für die Bearbeitung verfügbar.

Für das Einfügen von Skriptbefehlen in eine Codierungssitzung ist es erforderlich, dass Sie beim Einrichten der Sitzung Skripts als Quelltyp auswählen. Sie können keine Skripts einschließen, wenn Sie eine Sitzung mit dem Assistenten für neue Sitzungen einrichten. Sie können Skripts jedoch über die Registerkarte Quellen des Fensterbereichs Eigenschaften zur Sitzung hinzufügen.

Verwandte Themen

  • Konfigurieren von Quellen
  • So fügen Sie während der Codierung Skriptbefehle ein
  • So codieren Sie geschlossene Beschriftungsdaten


So fügen Sie während der Codierung Skriptbefehle ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.

    - Oder -

    Klicken Sie während des Verwendens einer Datei als Quelle auf Gerät und Datei, um Skriptbefehle einzufügen.

  3. Aktivieren Sie das Kontrollkästchen Skript, und klicken Sie dann auf Skript.
  4. Klicken Sie auf Übernehmen, und klicken Sie dann auf Codierung starten.
  5. Klicken Sie im Fensterbereich Skript auf die Schaltfläche für die Skriptart, die Sie einfügen möchten. Sie können eine Beschriftung (Textzeichenfolge), einen URL oder einen benutzerdefinierten Skriptbefehl einfügen.
  6. Führen Sie eine der folgenden Aktionen aus:
    • Wenn Sie eine Beschriftung oder einen URL einfügen, geben Sie den Text oder URL ein, der eingefügt werden soll.
    • Wenn Sie ein benutzerdefiniertes Skript einfügen, geben Sie den Skriptbefehltyp und -wert ein.
  7. Klicken Sie an der Position auf Einfügen, an der das Skript in den Datenstrom eingefügt werden soll. Der Eintrag Skripts insgesamt im Fensterbereich Monitor wird mit jedem eingefügten Skriptbefehl inkrementiert.

Verwandte Themen

  • Einfügen von Skriptbefehlen


So codieren Sie geschlossene Beschriftungsdaten

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie unter Quelle auf Geräte.
  3. Aktivieren Sie das Kontrollkästchen Skript, und klicken Sie dann auf den Namen der Videoaufzeichnungskarte, die geschlossene Beschriftungen unterstützt.
  4. Wenn Sie die Karte konfigurieren möchten, klicken Sie auf Konfigurieren.

Verwandte Themen

  • Einfügen von Skriptbefehlen


Verwenden von mehreren Quellen in einer Sitzung

Sie können in einer Sitzung mehrere Quellen verwenden. Zwar wird nur jeweils eine Quelle gleichzeitig ausgestrahlt, beim Codieren können Sie jedoch zwischen Quellen wechseln, um verschiedene Inhalte auszustrahlen. Bevor Sie z. B. eine Betriebsversammlung übertragen, können Sie Quellen für den Hauptinhalt sowie für Willkommens-, Unterbrechungs- und Verabschiedungsinhalte einrichten. Wenn Sie das Ereignis übertragen, können Sie mit der Willkommenquelle beginnen, dann zum Hauptsprecher wechseln, während einer Pause zur Unterbrechungsquelle umschalten und schließlich die Verabschiedungsquelle verwenden, wenn das Ereignis abgeschlossen wird.

Wenn Sie den Windows Media Audio 9 Voice-Codec in einer Mehrfachquellensitzung verwenden, legt der Modus (nur Sprache oder eine Mischung aus Sprache und Musik) der ersten Quelle den Modus der nachfolgenden Quellen fest. Wenn Sie z. B. den Modus Nur Sprache oder den Mischmodus für die erste Quelle ausgewählt haben, werden nachfolgende Quellen im gleichen Modus codiert. Wenn Sie jedoch den Mischmodus für die erste Quelle angeben und eine Definitionsdatei für Optimierung für diese Quelle einrichten, werden nachfolgende Quellen in der Sitzung im Modus Nur Sprache codiert.

Verwandte Themen

  • Konfigurieren von Quellen
  • So wechseln Sie bei der Codierung zwischen mehreren Quellen
  • So legen Sie die Reihenfolge für mehrere Quellen fest


So wechseln Sie bei der Codierung zwischen mehreren Quellen

  1. Klicken Sie im Menü Ansicht auf Quelle.
  2. Klicken Sie im Fensterbereich Quelle auf die Quelle, mit der Sie beginnen möchten, und klicken Sie dann auf Codierung starten.
  3. Um zu einer anderen Quelle zu wechseln, klicken Sie im Fensterbereich Quelle auf die Schaltfläche für die betreffende Quelle.

Verwandte Themen

  • Verwenden von mehreren Quellen in einer Sitzung


So legen Sie die Reihenfolge für mehrere Quellen fest

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Quellen.
  2. Klicken Sie in der Liste der Quellen auf die zu verschiebende Quelle, und klicken Sie dann auf die Schaltfläche Pfeil nach oben oder Pfeil nach unten.

Verwandte Themen

  • Verwenden von mehreren Quellen in einer Sitzung


Anpassen einer Sitzung

Dieser Abschnitt stellt Informationen zu den Optionen zur Verfügung, die für das Anpassen einer Codierungssitzung an die jeweiligen Anforderungen bestehen. Wenn Sie eine Sitzung anpassen und regelmäßig erneut verwenden möchten, können Sie die Sitzung in einer Sitzungsdatei speichern und zur Liste der Schnellstarts hinzufügen.

Verwandte Themen

  • Windows Media Encoder
  • So öffnen Sie eine vorhandene Sitzung
  • So speichern Sie eine Sitzung
  • So beginnen bzw. beenden Sie die Codierung oder halten die Codierung an
  • So erstellen Sie einen benutzerdefinierten Schnellstart
  • Zuschneiden des Videos und Ändern der Videogröße vor der Codierung
  • Beibehalten des Pixelseitenverhältnisses des Videos
  • Optimieren von Video und Audio
  • Angeben einer Sprache für den Inhalt
  • Anwenden der Zeitkomprimierung auf den Inhalt
  • Verwenden der CBR-Codierung
  • Verwenden der VBR-Codierung
  • Einrichten eines MBR-Datenstroms
  • Verwenden von Digital Rights Management zum Schützen von Inhalt
  • Einbetten eines Wasserzeichens in den Inhalt
  • Verwenden von Hardwareprofilen
  • Verwenden von Transformations-Plug-Ins


So öffnen Sie eine vorhandene Sitzung

  1. Klicken Sie im Menü Datei auf Öffnen.
  2. Geben Sie im Feld Dateiname den Namen und Speicherort der Sitzungsdatei ein, die Sie öffnen möchten.

    Sitzungsdateien weisen die Dateinamenerweiterung WME auf.

  3. Klicken Sie auf Öffnen.

Anmerkung Anmerkung

  • Sie können eine Sitzungsdatei auch öffnen, indem Sie sie in den Encoder ziehen.

Verwandte Themen

  • Anpassen einer Sitzung


So speichern Sie eine Sitzung

  1. Klicken Sie im Menü Datei auf Speichern.
  2. Geben Sie im Feld Dateiname einen Namen und Speicherort für die Datei ein, und klicken Sie dann auf Speichern.

Verwandte Themen

  • Anpassen einer Sitzung


So beginnen bzw. beenden Sie die Codierung oder halten die Codierung an

  • Klicken Sie auf der Symbolleiste auf Codierung starten, um mit der Codierung zu beginnen. Eine Meldung benachrichtigt Sie darüber, dass die Codierung begonnen hat.

    - Oder -

    Klicken Sie auf der Symbolleiste auf Stopp, um die Codierung zu beenden. Eine Meldung benachrichtigt Sie, wenn die Codierung beendet wurde. Eine Zusammenfassung der Sitzungsergebnisse steht im Dialogfeld Codierungsergebnisse zur Verfügung.

    - Oder -

    Klicken Sie auf der Symbolleiste auf Anhalten, um die Codierung anzuhalten. Beachten Sie, dass das Anhalten der Codierung nur möglich ist, wenn Sie Geräte oder Bildschirmaufzeichnungen als Quelle verwenden und in eine Datei codieren. Wenn eine der Quellen der Sitzung eine Datei ist, kann die Codierung nicht angehalten werden.

Verwandte Themen

  • Anpassen einer Sitzung


So erstellen Sie einen benutzerdefinierten Schnellstart

  1. Erstellen Sie eine Sitzung, die Ihre Codierungsanforderungen erfüllt, und speichern Sie diese Sitzung.
  2. Speichern Sie die Sitzungsdatei im Verzeichnis Templates, das sich am gleichen Speicherort wie Windows Media Encoder befindet. Standardmäßig handelt es sich um das Verzeichnis C:\Programme\Windows Media-Komponenten\Encoder\Templates.

    Der Schnellstart wird in der Liste der Schnellstarts im Dialogfeld Neue Sitzung angezeigt.

Verwandte Themen

  • Anpassen einer Sitzung
  • Verwenden von Schnellstarts für die Codierung


Zuschneiden des Videos und Ändern der Videogröße vor der Codierung

Mit Windows Media Encoder können Sie die Ränder des Eingabevideobilds zuschneiden. Rauschen tritt z. B. häufig an den Rändern eines Bilds auf, und Sie können aus diesem Grund einen oder mehr Ränder zuschneiden, um die betroffenen Zeilen zu entfernen. Sie können angeben, wie viel an jeder Seite eines Bilds abgeschnitten werden soll, oder Sie können Standardwerte für das Zuschneiden verwenden. Nach dem Zuschneiden können Sie die Höhe und Breite des Ausgabevideos ändern. Standardmäßig wird das Ausgabevideobild gestreckt, um der im Profil angegebenen Framegröße zu entsprechen. Sie können die Größe des Videos jedoch auch so verändern, dass das Ausgabebild den Abmessungen des zugeschnittenen Bilds entspricht. Sie können die Größe des Videos auch automatisch verändern, um die im Profil angegebene Bandbreite zu verwenden. Außerdem können Sie auch benutzerdefinierte Abmessungen für die Größenänderung angeben.

MBR-Video und mehrere Quellen

Wenn Sie Mehrere Bitraten (Multiple Bit Rate, MBR)-Video codieren, können Sie die Größe der Ausgabeframes für jede Bitrate separat anpassen. Dies bedeutet, dass eine MBR-Datei oder ein MBR-Datenstrom Videobilder mit unterschiedlichen Größen enthalten kann.

Wenn in einer Sitzung mehrere Quellen verwendet werden, legen die Ausgabeabmessungen der ersten Quelle die Abmessungen der nachfolgenden Quellen fest. Aus diesem Grund ist es nur möglich, die Größe der ersten Quelle in einer Mehrfachquellensitzung zu ändern.

Erkennen der Eingabegröße

Wenn Sie eine Datei als Quelle verwenden, kann der Encoder die Größe des Quellvideos vor Beginn der Codierung erkennen. Wenn Geräte oder Bildaufzeichnungen als Quelle verwendet werden, kann die Eingabegröße vor der Codierung nicht erkannt werden. Aus diesem Grund sollten Sie die Eingabegröße angeben, wenn Sie Geräte oder Bildaufzeichnungen als Quelle verwenden und Videoinhalte zuschneiden oder in der Größe ändern möchten. Wenn Sie auf diese Weise vorgehen, erkennt der Encoder die tatsächliche Eingabegröße bei Beginn der Codierung. Wenn sich die tatsächliche Eingabegröße von der von Ihnen angegebenen Eingabegröße unterscheidet, wird der angegebene Prozentwert für das Zuschneiden (statt der tatsächlichen Pixelwerte) auf die tatsächliche Eingabegröße angewendet.

Angenommen, Sie haben beispielsweise 100 x 200 Pixel für die Eingabegröße angegeben und die folgenden Werte für das Zuschneiden definiert:

  • Oben: 4 (2 Prozent der Höhe)
  • Unten: 4 (2 Prozent der Höhe)
  • Links: 10 (10 Prozent der Breite)
  • Rechts: 10 (10 Prozent der Breite)

Wenn der Encoder erkennt, dass die tatsächliche Eingabegröße 200 x 400 beträgt, entsprechen die tatsächlichen Werte für das Zuschneiden dem Prozentsatz des Zuschneidens wie folgt:

  • Oben: 8 (2 Prozent der Höhe)
  • Unten: 8 (2 Prozent der Höhe)
  • Links: 20 (10 Prozent der Breite)
  • Rechts: 20 (10 Prozent der Breite)

Hardwarezuschneidung

Wenn Ihre Videoaufzeichnungskarte Hardwarezuschneidung unterstützt, sollten Sie die Hardware zum Zuschneiden des Videos verwenden. Weitere Informationen zur Hardwarezuschneidung finden Sie in der Dokumentation zu Ihrer Aufnahmekarte.

Wenn Ihre Aufnahmekarte Hardwarezuschneidung nicht unterstützt oder eine Datei als Quelle verwendet wird, wird der zugeschnittene Videoinhalt erst im Bereich Eingabe im Fensterbereich Video angezeigt, wenn Sie mit der Codierung beginnen.

Ändern der Größe

Um die bestmöglichen Ergebnisse zu erzielen, sollte die Größe des Ausgabevideos nicht geändert werden. Das Ändern der Größe kann zu einer Ausgabe führen, die nicht optimal ist. Wenn Sie jedoch in eine Datei codieren, indem Sie den Windows Media Video 9-Codec verwenden, und die für die Codierung benötigte Zeit unwesentlich ist, können Sie die Qualität des in der Größe geänderten Inhalts verbessern, indem Sie die Leistungseinstellung des Encoders für die Option In Datei codieren auf eine bessere Qualität festlegen. Beachten Sie, dass die Codierungszeit erheblich zunimmt, wenn Sie dieses Verfahren verwenden.

Vorsicht Vorsicht

  • Sie sollten die Größe des Bilds nicht verändern, wenn Sie einen Bildschirm codieren, da in diesem Fall eine schlechte Qualität des codierten Inhalts das Ergebnis sein kann.

Verwandte Themen

  • Anpassen einer Sitzung
  • Anpassen von Leistungseinstellungen des Encoders
  • So schneiden Sie Videoinhalte zu und ändern ihre Größe
  • So passen Sie die Framegröße des Quellvideos an


So passen Sie die Framegröße des Quellvideos an

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie auf Bearbeiten und dann auf die Registerkarte mit der Bitrateangabe.
  3. Aktivieren Sie das Kontrollkästchen Wie Videoeingang.

Verwandte Themen

  • Zuschneiden des Videos und Ändern der Videogröße vor der Codierung


So schneiden Sie Videoinhalte zu und ändern ihre Größe

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Videogröße.
  2. Klicken Sie in der Quellliste auf die Quelle, die Sie zuschneiden möchten. (Nur für Mehrfachquellensitzungen erforderlich.)
  3. Wenn Sie Geräte oder Bildaufzeichnungen als Quelle verwenden, geben Sie unter Zuschneiden die Eingabegröße ein.
  4. Klicken Sie unter Zuschneiden, Methode auf Benutzerdefiniert oder auf einen der Standardwerte für die Zuschneidung.
  5. Wenn Sie benutzerdefiniertes Zuschneiden ausgewählt haben, geben Sie die Anzahl der oben, unten, links und rechts vom Videoinhalt abzuschneidenden Pixel ein.
  6. Klicken Sie unter Größe ändern, Methode auf eine der folgenden Optionen:
    • Wie Profil. Streckt die Abmessungen des Ausgabevideos, um der im Profil angegebenen Framegröße zu entsprechen.
    • Keine Größenanpassung. Die Abmessungen des Ausgabevideos entsprechen den Abmessungen des zugeschnittenen Eingabevideos.
    • Automatisch. Wenn die Quelle eine Datei ist, werden die Abmessungen des Ausgabevideos so angepasst, dass die im Profil angegebene Bandbreite verwendet wird. Gleichzeitig wird versucht, das Seitenverhältnis des zugeschnittenen Eingabebilds zu erhalten. Wenn die Eingabegröße, die Sie in Schritt 4 angegeben haben, nicht der tatsächlichen Eingabegröße entspricht, dann entsprechen die Abmessungen des Ausgabevideos den Abmessungen des zugeschnittenen Eingabevideos.
    • Benutzerdefiniert. Diese Option ermöglicht das Angeben benutzerdefinierter Abmessungen für das Ausgabevideo.
  7. Wenn Sie MBR-Inhalt codieren, klicken Sie auf eine andere Bitrate, und ändern Sie dann die Größe. (Diese Option ist nur verfügbar, wenn Sie die Größenänderungsmethoden Benutzerdefiniert oder Wie Profil für die erste Bitrate ausgewählt haben.)

Anmerkung Anmerkung

  • Wenn Sie Inhalt zuschneiden, aus dem außerdem Zeilensprünge entfernt oder auf den der Filter für umgekehrte Filmabtastung (Inverse Telecine) angewendet wird, müssen die Zuschneidewerte für die oberen und unteren Ränder jeweils ohne Rest durch 2 teilbar sein.

Verwandte Themen

  • Zuschneiden des Videos und Ändern der Videogröße vor der Codierung
  • Optimieren von Video und Audio


Beibehalten des Pixelseitenverhältnisses des Videos

Wenn die Videoquelle nicht quadratische Pixel aufweist, können Sie die Pixelseitenverhältnisse beibehalten. Überprüfen Sie in der Dokumentation zu Ihrem Videogerät, ob dieses nicht quadratische Pixel verwendet.

Das Pixelseitenverhältnis ist die Breite (x) des Pixels im Verhältnis zu seiner Höhe (y). Ein quadratisches Pixel besitzt ein Seitenverhältnis von 1:1, bei einem nicht quadratischen (rechteckigen) Pixel ist die Höhe nicht gleich der Breite. Dieses Konzept ähnelt dem Frameseitenverhältnis, das die Gesamtbreite eines Bilds im Verhältnis zu seiner Höhe angibt. Diese Seitenverhältnisse hängen jedoch nicht notwendigerweise zusammen. Ein Widescreenbild mit einem Seitenverhältnis von 16:9 kann z. B. aus quadratischen oder nicht quadratischen Pixeln bestehen.

Das gleiche Frameseitenverhältnis mit unterschiedlichen Pixelseitenverhältnissen.

Wenn Sie eine Videoquelle mit nicht quadratischen Pixeln so codieren, als wären die Pixel quadratisch, wird die Ausgabe verzerrt, wie die folgende Abbildung zeigt.

Codieren eines Bilds mit nicht quadratischen Pixeln ohne Beibehaltung des Seitenverhältnisses.

Wenn Sie das Frameseitenverhältnis (Ix:Iy) und die genaue Höhe und Breite der Bildquelle kennen, können Sie die folgende Formel zum Ermitteln der Werte für x und y des Pixelseitenverhältnisses verwenden.

PixelseitenverhältnisX / PixelseitenverhältnisY = (Ix * Höhe) / (Iy * Breite)

Wenn das Bild beispielsweise 720 x 360 Pixel groß ist und das Frameseitenverhältnis Widescreen (16:9) entspricht, ist PixelseitenverhältnisX=8 und PixelseitenverhältnisY=9:

PixelseitenverhältnisX / PixelseitenverhältnisY = (16*360) / (9*720) = 8/9

Anmerkung Anmerkungen

  • Wenn Sie die Größe des Ausgabevideos gleich der Größe des Quellvideos festlegen und das Quellvideo weist nicht quadratische Pixel auf, bleibt das Pixelseitenverhältnis des Quellvideos automatisch im Ausgabevideo erhalten.
  • Das Erhalten des Pixelseitenverhältnisses von Videoinhalt erhöht die Dateigröße oder Ausstrahlungsbitrate.

Verwandte Themen

  • Anpassen einer Sitzung
  • So behalten Sie das Pixelseitenverhältnis von Video bei
  • So passen Sie die Framegröße des Quellvideos an


So behalten Sie das Pixelseitenverhältnis von Video bei

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften, klicken Sie auf die Registerkarte Komprimierung, und klicken Sie dann auf Bearbeiten.
  2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Ausgabe nicht quadratischer Pixel zulassen, und klicken Sie dann auf OK.
  3. Klicken Sie auf die Registerkarte Videogröße, und geben Sie dann unter Seitenverhältnis für Pixel das Pixelseitenverhältnis des Eingabevideos an. Wenn Sie ein benutzerdefiniertes Seitenverhältnis für Pixel verwenden, müssen die eingegebenen Werte zwischen 1 und 255 liegen.

Verwandte Themen

  • Beibehalten des Pixelseitenverhältnisses des Videos


Optimieren von Video und Audio

Sie können Windows Media Encoder zum Entfernen von Zeilensprüngen aus einem Quellvideo verwenden, das Zeilensprünge aufweist, einen Filter für die umgekehrte Filmabtastung (Inverse Telecine) auf Inhalt anwenden, für den die Telecine (Filmabtastung) gilt, oder die Zeilensprünge im Quellvideo beibehalten.

Wenn Sie nicht sicher sind, ob der Quellinhalt Zeilensprünge aufweist oder Telecine verwendet, können Sie den Encoder zum Erkennen des Formats verwenden, indem Sie im Fensterbereich Eigenschaften auf der Registerkarte Verarbeitung auf Erkennen klicken.

Wenn der Audioinhalt hauptsächlich aus Sprache in Kombination mit etwas Musik besteht, können Sie den Windows Media Audio 9 Voice-Codec verwenden und den Inhalt für Sprache optimieren.

Verwandte Themen

  • Anpassen einer Sitzung
  • Entfernen von Zeilensprüngen oder Beibehalten von Zeilensprüngen in Videos
  • Anwenden des Filters für umgekehrte Filmabtastung auf Videoinhalte
  • Optimieren von Audio für Sprachaufnahmen


Entfernen von Zeilensprüngen oder Beibehalten von Zeilensprüngen in Videos

Ein Videoframe kann Zeilensprünge aufweisen oder progressiv sein. Ein Videoframe mit Zeilensprüngen enthält zwei Felder pro Frame, die zu verschiedenen Zeitpunkten aufgezeichnet wurden. Wenn das Video dargestellt wird, werden die Zeilen des einen Felds zuerst angezeigt. Danach werden die Zeilen des zweiten Felds angezeigt. Im Gegensatz dazu werden die Zeilen bei einem progressiven Videoframe in jedem Frame nacheinander gezeichnet. Inhalt mit Zeilensprüngen ist häufig, da die NTSC- und PAL-Standards Videosignale mit Zeilensprüngen verwenden.

Entfernen von Zeilensprüngen aus Video

Wenn Videoinhalt mit Zeilensprüngen mit einer progressiven Abtastanzeige, z. B. einem Computer, wiedergegeben wird, flimmert das Bild möglicherweise bei der Darstellung der Felder. Das Entfernen von Zeilensprüngen besteht im Erstellen eines progressiven Videoframes aus einem Frame mit Zeilensprüngen; das Flimmern wird auf diese Weise verringert. Der Encoder verfügt über drei Filter zum Entfernen von Zeilensprüngen. Der vom Encoder verwendete Filter hängt vom Unterschied zwischen der Eingabe- und Ausgabeframegröße und der Framerate ab.

  • Normales Entfernen von Zeilensprüngen. Der Standardfilter, der beim Auswählen der Option zum Entfernen von Zeilensprüngen verwendet wird. Dieser Filter überblendet die geraden und ungeraden Felder eines Frames mit Zeilensprüngen, um einen progressiven Frame zu erstellen, wie die folgende Abbildung zeigt.

    Normales Entfernen von Zeilensprüngen

  • Entfernen von Zeilensprüngen mit halber Größe. Dieser Filter wird verwendet, wenn die Anzahl der für das Ausgabevideo angegebenen Zeilen halb so groß wie (oder kleiner als) die Anzahl der Zeilen des Eingabevideos ist. Dieser Filter wird z. B. verwendet, wenn die Auflösung der Eingabevideoframes 640 × 480 Pixel und die Ausgabeauflösung 320 × 240 Pixel beträgt. Dieser Filter verwendet einen Algorithmus, der die Felder überblendet und nicht einfach ein Datenfeld entfernt. Das Ergebnis ist ein Ausgabevideo mit höherer Qualität.
  • Entfernen von Zeilensprüngen mit halber Größe und doppelter Framerate. Dieser Filter wird verwendet, wenn die Anzahl der für das Ausgabevideo angegebenen Zeilen halb so groß wie (oder kleiner als) die Anzahl der Zeilen des Eingabevideos und die Ausgabeframerate doppelt so hoch wie die Eingabeframerate ist. Dieser Filter erzeugt einen Frame aus jedem Feld der Videosequenz, wie die folgende Abbildung zeigt.

    Entfernen von Zeilensprüngen mit halber Größe und doppelter Framerate

    Die Vorteile dieses Filters bestehen darin, dass er progressive Frames mit hoher Qualität generiert, weil es nicht erforderlich ist, Informationen feldübergreifend zu überblenden. Außerdem bleibt der gesamte Bewegungsablauf der Felder mit Zeilensprüngen erhalten. Dieser Filter besitzt jedoch höhere Leistungs- und Bitratenanforderungen.

Das Entfernen von Zeilensprüngen wird nicht für Quellen unterstützt, die zuvor keine Zeilensprünge aufwiesen.

Beibehalten der Zeilensprünge im Quellvideo

Das Beibehalten der Zeilensprünge im Video ist sinnvoll, wenn dieses auf Wiedergabegeräten mit Zeilensprüngen angezeigt wird, z. B. auf Fernsehgeräten. Sie müssen den Windows Media Video 9-Codec verwenden, um diese Option verwenden zu können. Außerdem muss der Benutzer, der den Inhalt wiedergibt, über Microsoft Windows XP, einen auf dem SDK (Software Development Kit) von Windows Media Format 9-Reihe basierenden Player sowie eine Grafikkarte verfügen, die Zeilensprünge unterstützt. Anderenfalls werden die Zeilensprünge automatisch aus dem Inhalt entfernt.

Wenn das Quellvideo gemischt (progressiv und mit Zeilensprünge) ist und Sie die Option Zeilensprünge beibehalten auswählen, ist das Ausgabevideo ebenfalls gemischt.

Anmerkung Anmerkungen

  • Einige Videoaufzeichnungskarten unterstützen hardwaregestützte Entfernung von Zeilensprüngen. Sie sollten nach Möglichkeit hardwaregestützte Entfernung von Zeilensprüngen verwenden.
  • Das Beibehalten von Zeilensprüngen im Quellvideo bei der Codierung mit einer niedrigen Framerate (beispielsweise 15 F/s) kann zu unerwünschten Verzerrungen im codierten Inhalt führen. Wenn Sie mit einer niedrigen Framerate codieren, wird aus diesem Grund empfohlen, die Zeilensprünge selbst dann aus dem Video zu entfernen, wenn der Inhalt für die Anzeige auf einem Wiedergabegerät mit Zeilensprüngen gedacht ist.

Verwandte Themen

  • Optimieren von Video und Audio
  • So entfernen Sie Zeilensprünge aus Video
  • So behalten Sie die Zeilensprünge in Video bei


So entfernen Sie Zeilensprünge aus Video

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Verarbeitung.
  2. Klicken Sie auf die Quelle, aus der die Zeilensprünge entfernt werden sollen. (Nur für eine Mehrfachquellensitzung erforderlich.)
  3. Klicken Sie auf Zeilensprünge entfernen.

Anmerkung Anmerkungen

  • Verwenden Sie den Filter zum Entfernen von Zeilensprüngen nur für eine Videoquelle, die zuvor Zeilensprünge aufwies.
  • Verwenden Sie den Filter zum Entfernen von Zeilensprüngen nicht, wenn Sie Bildschirme aufzeichnen.

Verwandte Themen

  • Entfernen von Zeilensprüngen oder Beibehalten von Zeilensprüngen in Videos


So behalten Sie die Zeilensprünge in Video bei

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie auf Bearbeiten, und aktivieren Sie dann das Kontrollkästchen Verarbeitung mit Zeilensprüngen zulassen.
  3. Klicken Sie auf die Registerkarte Verarbeitung.
  4. Klicken Sie auf die Quelle, für die die Zeilensprünge beibehalten werden sollen. (Nur für eine Mehrfachquellensitzung erforderlich.)
  5. Klicken Sie auf Zeilensprünge beibehalten.
  6. Wenn Sie wissen, welches Feld im Inhalt das erste ist, klicken Sie entweder auf Zuerst oben oder auf Zuerst unten. Wenn Sie nicht sicher sind, welches Feld das erste ist, klicken Sie auf Automatisch.

Anmerkung Anmerkung

  • Sie müssen den Windows Media Video 9-Codec verwenden, um die Zeilensprünge im Videoinhalt beizubehalten.

Verwandte Themen

  • Entfernen von Zeilensprüngen oder Beibehalten von Zeilensprüngen in Videos


Anwenden des Filters für umgekehrte Filmabtastung auf Videoinhalte

Der Vorgang der umgekehrten Filmabtastung (Inverse Telecine) entfernt Frames, die während Telecine (Filmabtastung) hinzugefügt wurden, als Film (24 F/s) in NTSC-Video (29,97 oder 30 F/s) konvertiert wurde. Der Filter für umgekehrte Filmabtastung entfernt Verzerrungen und verbessert die Qualität codierter Inhalte, insbesondere bei niedrigen Bitraten.

Telecine wird auf Inhalt mit einem Muster namens 3:2-Pulldown angewendet; dies bezieht sich auf den Vorgang, der zum Erstellen der zusätzlichen Frames verwendet wird. Wenn das 3:2-Pulldownmuster im gesamten Quellvideo konsistent ist, wird das Video als kohärent bezeichnet. Videoinhalte sind jedoch häufig nicht kohärent, und es finden sich Unterbrechungen im 3:2-Pulldownmuster. Musterunterbrechungen oder Inkohärenzen können z. B. beim Bearbeiten des Videos entstehen. Wenn Ihr Inhalt kohärent ist, können Sie den genauen Frame auswählen, mit dem das 3:2-Pulldownmuster beginnt. Sie können sich auch dafür entscheiden, das Muster automatisch erkennen zu lassen.

Umgekehrte Filmabtastung wird für folgende Quellen nicht unterstützt:

  • Eine NTSC-Quelle, für die zuvor kein Telecine stattgefunden hat.
  • Inhalt, auf den Zeitkomprimierung angewendet wird.
  • Inhalt, für den Sie einen Zeitcode beibehalten oder erstellen.

Verwandte Themen

  • Optimieren von Video und Audio
  • So wenden Sie einen Filter für umgekehrte Filmabtastung auf Videoinhalte an


So wenden Sie einen Filter für umgekehrte Filmabtastung auf Videoinhalte an

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Verarbeitung.
  2. Klicken Sie auf die Quelle, auf die Sie den Filter für umgekehrte Filmabtastung anwenden möchten. (Nur für eine Mehrfachquellensitzung erforderlich.)
  3. Klicken Sie auf Umgekehrte Filmabtastung.
  4. Wenn der Inhalt kohärent ist und Sie Anpassungen für die Musterunterbrechung einschränken möchten, klicken Sie in der Liste auf den Frame, mit dem Ihre Aufnahme beginnt.

Anmerkung Anmerkungen

  • Verwenden Sie den Filter für umgekehrte Filmabtastung nur für eine Videoquelle, für die zuvor Telecine mit einer Framerate von 30 F/s durchgeführt wurde.
  • Verwenden Sie den Filter für umgekehrte Filmabtastung nicht, wenn Sie Bildschirme aufzeichnen.

Verwandte Themen

  • Anwenden des Filters für umgekehrte Filmabtastung auf Videoinhalte


Optimieren von Audio für Sprachaufnahmen

Wenn Sie Audioinhalte als Quelle verwenden, die ganz oder größtenteils aus Sprache bestehen, sollten Sie den Windows Media Audio 9 Voice-Codec verwenden, der zum Codieren von Sprache konzipiert wurde. Sie können das Codecverhalten optimieren, indem Sie feststellen, ob der Inhalt nur aus Sprache besteht oder auch etwas Musik umfasst. Wenn es sich bei dem Audioinhalt um eine Mischung aus Sprache und Musik handelt, verwendet der Codec beim Codieren automatisch den richtigen Algorithmus, um die Codierung für den Inhalt zu optimieren (Sprache oder Musik). Sie können auch eine Definitionsdatei für Optimierung erstellen. Dabei handelt es sich um eine Textdatei, die die Stellen in der Datei angibt, an denen Musik beginnt und endet. Die nicht angegebenen Teile in der Datei werden als Sprache behandelt.

Wenn Sie den Windows Media Audio 9 Voice-Codec in einer Mehrfachquellensitzung verwenden, finden Sie Informationen zur Funktionsweise von Codecs unter Verwenden von mehreren Quellen in einer Sitzung.

Verwandte Themen

  • Optimieren von Video und Audio
  • So optimieren Sie Audioinhalt für Sprache
  • So erstellen Sie eine Definitionsdatei für Audiooptimierung


So optimieren Sie Audioinhalt für Sprache

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie auf Bearbeiten, und klicken Sie dann unter Modus auf CBR.
  3. Klicken Sie unter Codec auf Windows Media Audio 9 Voice, und klicken Sie dann auf OK.
  4. Klicken Sie auf die Registerkarte Verarbeitung, und klicken Sie dann auf Nur Sprache oder auf Audio (Schwerpunkt Sprache).

    Für Audio mit Schwerpunkt auf Sprache besteht die Möglichkeit, eine Definitionsdatei für Optimierung zu erstellen, die die Stellen im Audioinhalt angibt, an denen Musik beginnt und endet.

  5. Wenn Sie eine Definitionsdatei für Optimierung erstellt haben, geben Sie den Namen der Datei ein.

Verwandte Themen

  • Optimieren von Audio für Sprachaufnahmen
  • So erstellen Sie eine Definitionsdatei für Audiooptimierung


So erstellen Sie eine Definitionsdatei für Audiooptimierung

  1. Verwenden Sie einen Texteditor, z. B. Editor, um eine Textdatei zu erstellen.
  2. Geben Sie die Versionsnummer und die Anzahl der Musiksegmente ein, die die Datei enthält.

    Die Versionsnummer sollte immer die Zahl 1 aufweisen.

  3. Geben Sie die Start- und Endzeit (in Millisekunden) für jedes Segment ein, und trennen Sie die einzelnen Start- und Endzeiten mit einem Komma voneinander.

    Die Eingabe von 3, 0, 10000, 50000, 80000, 150000 und 200000 weist z. B. auf drei Musiksegmente hin. Der Codec wechselt bei 0 bis 10 Sekunden, 50 bis 80 Sekunden und 150 bis 200 Sekunden in den Musikmodus.

  4. Codieren Sie die Textdatei in Unicode.

    Wenn Sie die Datei mit Editor erstellen, können Sie die Datei als Unicode speichern, indem Sie im Menü Datei den Befehl Speichern unter verwenden und dann unter Codierung auf Unicode klicken.

Verwandte Themen

  • Optimieren von Audio für Sprachaufnahmen


Angeben einer Sprache für den Inhalt

Wenn Sie Inhalt codieren, wird diesem automatisch eine Sprache zugeordnet. Sie können Inhalt auch in verschiedene Sprachen codieren. Sie können den Datenstrom-Editor für Windows Media verwenden, um Inhalte verschiedener Sprachen in einer Datei einzufügen. Anschließend können die Benutzer die Sprache auswählen, die sie zur Wiedergabe der Datei verwenden möchten.

Verwandte Themen

  • So geben Sie eine Sprache für den Inhalt an


So geben Sie eine Sprache für den Inhalt an

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie auf Bearbeiten.
  3. Klicken Sie unter Sprache auf eine Sprache in der Liste.

Verwandte Themen

  • Angeben einer Sprache für den Inhalt


Anwenden der Zeitkomprimierung auf den Inhalt

Durch Anwenden von Zeitkomprimierung auf den Inhalt bei der Codierung können Sie den Inhalt während der Wiedergabe beschleunigen oder verlangsamen. Das Beschleunigen des Inhalts verringert die für das Anzeigen des gesamten Videos oder das Hören der gesamten Audiodatei erforderliche Zeit; dies ist sinnvoll, wenn Inhalt in ein bestimmtes Zeitfenster passen muss. Das Verlangsamen des Inhalts kann das Verständnis in Situationen verbessern, in denen das Material hochgradig technisch oder die Sprache nicht die Muttersprache der Benutzer ist. Die folgenden Anforderungen treffen auf das Verwenden von Zeitkomprimierung zu:

  • Die Quelle muss Audioinhalt umfassen.
  • Jede Quelle in der Sitzung muss eine Datei sein.
  • Sie müssen in eine Datei codieren. (Zeitkomprimierung wird für Übertragung nicht unterstützt.)
  • Sie müssen einen Codierungsmodus mit einem Durchlauf verwenden (entweder CBR mit einem Durchlauf oder qualitätsbasiertes VBR).
  • Sie können den Filter für umgekehrte Filmabtastung nicht zusammen mit Zeitkomprimierung verwenden.
  • Sie können die Schleifenfunktion nicht zusammen mit Zeitkomprimierung verwenden.
  • Sie können keine Zeitkomprimierung anwenden, wenn Mehrkanalaudio die Quelle ist.

Wenn Sie unterschiedliche Dateien als Quelle für Audio- bzw. Videoinhalt verwenden, wird die Codierung beendet, sobald das Ende der Datei mit der kürzeren Dauer erreicht ist.

Windows Media Encoder verfügt über zwei Zeitkomprimierungsfunktionen, die Sie unabhängig voneinander oder zusammen verwenden können:

  • Beschleunigen oder Verlangsamen von Audio und Videoframes. Das Beschleunigen oder Verlangsamen hat keine Auswirkungen auf die Tonhöhe des Audiodatenstroms.
  • Erkennen und Entfernen von Pausen in Sprachaufzeichnungen oder Aktionen. Ruhepausen werden aus dem Audioinhalt und Frames aus dem Videoinhalt entfernt. Wenn Sie eine Protokolldatei erstellen, werden die Start- und Endzeiten der entfernten Segmente in dieser Datei aufgelistet, so dass Sie über ein dauerhaftes Protokoll verfügen.

Vor dem Verwenden der Zeitkomprimierung sollten Sie sicherstellen, dass Sie mit Audioinhalt beginnen, der die bestmögliche Qualität aufweist. Verzerrungen oder Rauschen im Quellinhalt werden auffälliger, wenn der Inhalt beschleunigt wird. Rauschen im Quellinhalt verringert außerdem die Genauigkeit, mit der Pausen entfernt werden.

Testen Sie immer den Inhalt, damit sichergestellt wird, dass die gewünschten Ergebnisse erzielt werden. Codieren Sie zum Ausführen eines Tests ein wenig Inhalt mit Zeitkomprimierung, und geben Sie diesen dann wieder. Wenn die Ergebnisse unbefriedigend sind, passen Sie die Zeitkomprimierungseinstellungen an, und codieren Sie den Inhalt dann erneut.

Verwandte Themen

  • Anpassen einer Sitzung
  • So beschleunigen oder verlangsamen Sie Audio und Videoframes
  • So entfernen Sie Pausen aus dem Inhalt


So beschleunigen oder verlangsamen Sie Audio und Videoframes

  1. Richten Sie eine Sitzung ein, die Dateien als Quelle verwendet.
  2. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  3. Aktivieren Sie das Kontrollkästchen Zeitkomprimierung, und klicken Sie dann auf Eigenschaften.
  4. Bewegen Sie den Schieberegler, um den Grad der Beschleunigung anzupassen, der auf den Inhalt angewendet wird. Sie können den Inhalt bis zu 50 % verlangsamen und bis zu 250 % beschleunigen.

Verwandte Themen

  • Anwenden der Zeitkomprimierung auf den Inhalt
  • So verwenden Sie eine Datei als Quelle


So entfernen Sie Pausen aus dem Inhalt

  1. Richten Sie eine Sitzung ein, die Dateien als Quelle verwendet.
  2. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  3. Aktivieren Sie das Kontrollkästchen Zeitkomprimierung, und klicken Sie dann auf Eigenschaften.
  4. Aktivieren Sie das Kontrollkästchen Pausenentfernung aktivieren.
  5. Wenn Sie eine Protokolldatei erstellen möchten, die die entfernten Segmente mit einem Zeitstempel auflistet, klicken Sie auf Optionen, und geben Sie dann den Namen der Protokolldatei ein.

Verwandte Themen

  • Anwenden der Zeitkomprimierung auf den Inhalt
  • So verwenden Sie eine Datei als Quelle


Verwenden der CBR-Codierung

Bei CBR-Codierung geben Sie die Bitrate an, die verwendet werden soll, und legen dann die Größe des Puffers fest. Die Bitrate schwankt für den Datenstrom; diese Schwankungen werden jedoch durch die Puffergröße beschränkt. Die Qualität des Inhalts schwankt ebenfalls, damit sichergestellt ist, dass der Puffer keinen Über- oder Unterlauf erfährt. (Wenn Sie die Qualität der codierten Ausgabe auf jeden Fall sicherstellen möchten, verwenden Sie qualitätsbasierte VBR-Codierung.) Die Größe des Puffers bestimmt bei der Wiedergabe des Inhalts den Umfang der anfänglichen Verzögerung. Durch Verwenden von CBR-Codierung wird jedoch sichergestellt, dass der Inhalt nahtlos ausgestrahlt wird, wenn die Bitrate kompatibel mit der Verbindungsgeschwindigkeit des Clients ist. Verwenden Sie nach Möglichkeit CBR-Codierung mit zwei Durchläufen, um eine höhere Qualität zu erzielen, ohne die Vorteile der CBR-Codierung zu verlieren. Für bestimmte Szenarien wird die Codierung mit zwei Durchläufen nicht unterstützt.

Verwandte Themen

  • Anpassen einer Sitzung
  • Informationen zur CBR- oder VBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen
  • Funktionsanforderungen
  • So richten Sie eine CBR-Codierungssitzung ein


So richten Sie eine CBR-Codierungssitzung ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf ein Ziel, das CBR-Codierung unterstützt und Ihrem Wiedergabeszenario entspricht.
  3. Wählen Sie unter Video und Audio die gewünschten Video- und Audioeinstellungen aus.
  4. Wenn Sie CBR-Codierung mit zwei Durchläufen aktivieren möchten, aktivieren Sie das Kontrollkästchen Codierung mit zwei Durchläufen.

Anmerkung Anmerkung

  • Für bestimmte Szenarien steht die Codierung mit zwei Durchläufen nicht zur Verfügung.

Verwandte Themen

  • Verwenden der CBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen
  • Funktionsanforderungen


Verwenden der VBR-Codierung

Windows Media Encoder unterstützt drei VBR-Codierungsmodi:

  • Qualitätsbasiertes VBR. Bei qualitätsbasierter VBR-Codierung geben Sie den gewünschten Qualitätsgrad (von 0 bis 100) an. Die Bitrate schwankt dann während der Codierung gemäß der Komplexität des Datenstroms. Eine höhere Bitrate wird für viele Details oder schnelle Bewegungen verwendet, eine niedrigere Bitrate für einfachere Inhalte. Der Vorteil qualitätsbasierter VBR-Codierung liegt darin, dass die Qualität über alle Datenströme hinweg konsistent bleibt, für die Sie die gleiche Qualitätseinstellung angeben. Der Nachteil besteht darin, dass Sie vor der Codierung weder die Dateigröße noch die Bandbreitenanforderungen des codierten Inhalts vorhersagen können. Qualitätsbasierte VBR-Codierung verwendet Codierung mit einem Durchlauf. Dieser Modus eignet sich gut zum Archivieren von Inhalt.

    Wenn Sie Audioinhalt mit diesem Codierungsmodus codieren, können Sie auch den Windows Media Audio 9 Lossless-Codec verwenden. Verlustfreie Codierung führt zu Ergebnissen mit hervorragender Qualität und bietet außerdem eine gewisse Komprimierung der Daten.

  • Bitratenbasiertes VBR. Bei bitratenbasierter VBR-Codierung geben Sie die gewünschte durchschnittliche Bitrate an. Die Bitrate kann die durchschnittliche Bitrate jederzeit überschreiten, die Gesamtbitrate überschreitet jedoch die durchschnittliche Bitrate nicht. Bitratenbasierte VBR-Codierung verwendet Codierung mit zwei Durchläufen. Im ersten Durchlauf wird die Datenkomplexität analysiert. Im zweiten Durchlauf wird dann der Qualitätsgrad so festgelegt, dass die durchschnittliche Bitrate erreicht wird. Der Vorteil bitratenbasierter VBR-Codierung besteht darin, dass der komprimierte Datenstrom den höchstmöglichen Qualitätsgrad erreicht und gleichzeitig in einer vorhersagbaren durchschnittlichen Bandbreite bleibt.
  • Auf maximalen Bitraten basierendes VBR. Auf maximalen Bitraten basierende VBR-Codierung ähnelt dem bitratenbasierten Modus, es wird nur außerdem die maximale Bitrate angegeben. Der Encoder bestimmt die Bildqualität, die ohne Überschreiten der maximalen Bitrate erreicht werden kann. Die Bitrate schwankt während der Codierung, überschreitet jedoch nicht die angegebene maximale Bitrate. Verwenden Sie diese Option, wenn Sie den Inhalt zur Wiedergabe auf einem Gerät mit einer begrenzten Lesegeschwindigkeit (z. B. einem CD- oder DVD-Player) verteilen möchten. Auf maximalen Bitraten basierte VBR-Codierung verwendet Codierung mit zwei Durchläufen.

Anmerkung Anmerkungen

  • Nur bestimmte Codecs unterstützen VBR-Codierung.
  • Die qualitätsbasierten und bitratenbasierten VBR-Codierungsmodi werden aufgrund der hohen Bitratenspitzen im Inhalt nicht für die Verwendung in einem Ausstrahlungsszenario empfohlen. In einem Ausstrahlungsszenario entsteht eine große Bedarfsspitze, wenn alle Player ungefähr gleichzeitig den Punkt im Datenstrom mit einer hohen Bitrate erreichen. Diese Spitze kann die Netzwerkkapazität überschreiten und zu einem negativen Wiedergabeerlebnis führen.

Verwandte Themen

  • Anpassen einer Sitzung
  • Informationen zur CBR- oder VBR-Codierung
  • Verwenden der CBR-Codierung
  • Funktionsanforderungen
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen
  • So richten Sie eine qualitätsbasierte VBR-Codierungssitzung ein
  • So codieren Sie Audioinhalt verlustfrei
  • So richten Sie eine bitratenbasierte VBR-Codierungssitzung ein
  • So richten Sie eine auf maximalen Bitraten basierende VBR-Codierungssitzung ein


So richten Sie eine qualitätsbasierte VBR-Codierungssitzung ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Dateiarchiv.
  3. Wählen Sie unter Video und Audio die für Video und Audio gewünschten Qualitätseinstellungen aus.

    - Oder -

    Klicken Sie auf Bearbeiten, klicken Sie auf die Registerkarte Qualitätsbasiert, und geben Sie dann unter Videoqualität die gewünschte Qualitätseinstellung ein. Diese Einstellung kann Werte zwischen 0 und 100 aufweisen, wobei 100 die höchste Qualität ist.

Verwandte Themen

  • Verwenden der VBR-Codierung


So codieren Sie Audioinhalt verlustfrei

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Dateiarchiv.
  3. Klicken Sie unter Audio auf Verlustfreie Audioqualität.

Verwandte Themen

  • Verwenden der VBR-Codierung


So richten Sie eine bitratenbasierte VBR-Codierungssitzung ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Dateidownload.
  3. Wählen Sie unter Video und Audio die für Video und Audio gewünschten Einstellungen aus.

    - Oder -

    Geben Sie Ihre eigenen Einstellungen an, indem Sie auf Bearbeiten klicken.

Anmerkung Anmerkung

  • Dieser VBR-Modus verwendet die Codierung mit zwei Durchläufen. Für bestimmte Szenarien steht die Codierung mit zwei Durchläufen nicht zur Verfügung.

Verwandte Themen

  • Verwenden der VBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen


So richten Sie eine auf maximalen Bitraten basierende VBR-Codierungssitzung ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Hardwaregeräte.
  3. Wählen Sie unter Video und Audio die für Video und Audio gewünschten Einstellungen aus.

    - Oder -

    Geben Sie Ihre eigenen Einstellungen an, indem Sie auf Bearbeiten klicken.

Anmerkung Anmerkung

  • Dieser VBR-Modus verwendet die Codierung mit zwei Durchläufen. Für bestimmte Szenarien steht die Codierung mit zwei Durchläufen nicht zur Verfügung.

Verwandte Themen

  • Verwenden der VBR-Codierung
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen


Einrichten eines MBR-Datenstroms

Wenn Sie planen, die Inhalte als einen Unicastdatenstrom von einem Server zu übermitteln, der Microsoft Windows Media-Dienste ausführt, können Sie einen Mehrere Bitraten (Multiple Bit Rate, MBR)-Datenstrom (Multiple Bit Rate, mehrere Bitraten) codieren, damit Benutzern bei Auslastung des Netzwerks Inhalt mit besserer Qualität zur Verfügung gestellt wird. Wenn Sie einen MBR-Datenstrom einrichten, wird der Inhalt mit jeder Bitrate codiert, die Sie angeben. Wenn ein Player einen MBR-Datenstrom empfängt, wird nur der Datenstrom wiedergegeben, der für die aktuellen Netzwerkbedingungen am geeignetsten ist. Der Windows Media-Server und der Windows Media-Player führen das Auswählen des entsprechenden Datenstroms durch. Dieser Vorgang ist für den Benutzer nicht sichtbar. Da ein MBR-Datenstrom nur für die Verwendung in einem Ausstrahlungsszenario vorgesehen ist, können Sie beim Codieren eines MBR-Datenstroms nur CBR-Codierung verwenden.

Sie können einen MBR-Datenstrom für Audio- und Videoinhalte codieren. Es ist jedoch nicht erforderlich, MBR-Codierung sowohl für Audio- als auch für Videoinhalte in einem Datenstrom zu verwenden. Sie können Audio beispielsweise mit einer Bitrate ausstrahlen und mit mehreren Bitraten für den Videoanteil des Datenstroms arbeiten.

Denken Sie beim Einrichten eines MBR-Datenstroms daran, dass die kumulierte Bandbreite für Live-Datenstromverteilung vom Encoder auf einen Windows Media-Server um so größer ist, je mehr Bitraten Sie auswählen. Um die kumulierte Bandbreite eines MBR-Profils zu schätzen, berechnen Sie die Summen der einzelnen Audio- und Videobitraten sowie der Skriptbitrate. Bedenken Sie außerdem, dass für das Codieren eines MBR-Datenstroms mehr Verarbeitungsleistung für den Computer mit dem Encoder erforderlich ist.

Wenn Sie den Windows Media Audio 9 Voice-Codec in einer MBR-Sitzung verwenden und den Mischmodus aus Sprache und Musik angeben, wird empfohlen, keine Bitraten unter 8 Kbit/s in der Sitzung zu verwenden. Der Grund hierfür ist, dass Bitraten unter 8 Kbit/s im Modus Nur Sprache codiert werden. Dies kann zu einer nicht optimalen Qualität des Audioinhalts führen.

Verwandte Themen

  • Anpassen einer Sitzung
  • So codieren Sie einen MBR-Datenstrom
  • So codieren Sie Audio mit einer Bitrate mit MBR-Video
  • So codieren Sie Video mit einer Bitrate mit MBR-Audio


So codieren Sie einen MBR-Datenstrom

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Windows Media-Server.
  3. Klicken Sie unter Video und Audio auf die gewünschten Qualitätseinstellungen.
  4. Wählen Sie unter Bitraten die Bitraten aus, mit denen Sie ausstrahlen möchten.

    - Oder -

    Klicken Sie auf Bearbeiten und dann auf Hinzufügen. Das Dialogfeld Bitrate hinzufügen wird angezeigt. Geben Sie eine Bitrate ein, die für den MBR-Datenstrom verwendet werden soll.

Anmerkung Anmerkungen

  • Wählen Sie einen Bereich von Bitraten aus, von dem Sie annehmen, dass er die Wiedergabeanforderungen Ihres Zielpublikums erfüllt.
  • Es ist nicht erforderlich, MBR-Codierung sowohl für Audio- als auch für Videoinhalte in einem Datenstrom zu verwenden. Sie können Audio beispielsweise mit einer Bitrate ausstrahlen und für den Videoanteil des Datenstroms mit mehreren Bitraten arbeiten.

Verwandte Themen

  • Einrichten eines MBR-Datenstroms
  • So codieren Sie Audio mit einer Bitrate mit MBR-Video
  • So codieren Sie Video mit einer Bitrate mit MBR-Audio


So codieren Sie Audio mit einer Bitrate mit MBR-Video

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Windows Media-Server.
  3. Klicken Sie unter Video und Audio auf die zu verwendenden Qualitätseinstellungen.
  4. Wählen Sie unter Bitraten die Bitraten aus, mit denen Sie ausstrahlen möchten.
  5. Klicken Sie auf Bearbeiten, und wählen Sie dann auf allen Registerkarten mit der Angabe zur Bitrate die gleiche Einstellung unter Audioformat aus.

Verwandte Themen

  • Einrichten eines MBR-Datenstroms
  • So codieren Sie Video mit einer Bitrate mit MBR-Audio


So codieren Sie Video mit einer Bitrate mit MBR-Audio

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Windows Media-Server.
  3. Klicken Sie unter Video und Audio auf die zu verwendenden Qualitätseinstellungen.
  4. Wählen Sie unter Bitraten die Bitraten aus, mit denen Sie ausstrahlen möchten.
  5. Klicken Sie auf Bearbeiten, und wählen Sie dann auf allen Registerkarten mit der Angabe zur Bitrate die gleiche Einstellung im Videobereich aus. (Alle Einstellungen müssen gleich sein, andernfalls werden mehrere Videobitraten während der Codierung verwendet.)

Verwandte Themen

  • Einrichten eines MBR-Datenstroms
  • So codieren Sie Audio mit einer Bitrate mit MBR-Video


Verwenden von Digital Rights Management zum Schützen von Inhalt

Sie können die Verwendung des codierten Inhalts steuern, indem Sie ihn während der Codierung mit DRM-Technologie (Digital Rights Management) schützen. Sie können DRM beim Codieren in eine Datei und beim Übertragen des Datenstroms verwenden. Der Inhalt wird codiert und mit einem Schlüssel verschlüsselt. Anschließend ist eine Lizenz erforderlich, damit Benutzer den Inhalt wiedergeben können. Diese Lizenz enthält den Schlüssel zum Entsperren des Inhalts und die Rechte, die für seine Verwendung gelten. Die Lizenz bestimmt z. B., wie oft ein Benutzer den Inhalt wiedergeben kann oder wann die Lizenz abläuft.

Wichtig Wichtig

  • Lizenzen werden von einem Lizenzdrittanbieter ausgestellt. Aus diesem Grund müssen Sie ein Konto bei einem dieser Drittanbieter einrichten, bevor Sie den Inhalt schützen können.

Für die Verwendung von DRM erforderliche Schritte

Die folgenden grundlegenden Schritte sind bei der Verwendung von DRM erforderlich:

  1. Richten Sie eine Codierungssitzung ein.
  2. Richten Sie bei Bedarf ein Konto bei einem Lizenzanbieter ein, und erstellen Sie ein DRM-Profil.
  3. Geben Sie in der Sitzung das DRM-Profil an, das für den Inhalt verwendet werden soll.
  4. Codieren und verteilen Sie den Inhalt, indem Sie ihn entweder ausstrahlen oder Dateien für den Download zur Verfügung stellen.
  5. Wenn Benutzer den geschützten Inhalt wiedergeben, besorgt sich der Player eine Lizenz, die von dem gewählten Lizenzanbieter ausgestellt wird. Der Benutzer kann den Inhalt dann entsprechend den in der Lizenz enthaltenen Rechten wiedergeben.

    Damit Benutzer geschützten Inhalt wiedergeben können, müssen sie einen Player verwenden, der die Microsoft DRM-Technologie unterstützt. Eine Liste der geeigneten Player finden Sie auf der Microsoft-Website.

Erneutes Verwenden von DRM-Profilen

Nachdem Sie ein DRM-Profil erstellt haben, können Sie dieses in zukünftigen Sitzungen erneut verwenden. Sie können das Profil exportieren, damit Sie es für die Verwendung auf einem anderen Computer mit Encoder importieren können. Ebenso können Sie ein DRM-Profil von einem anderen Computer importieren. Um die Sicherheit zu gewährleisten, werden DRM-Profile auf Benutzerbasis verwaltet. Auf diese Weise wird verhindert, dass andere Benutzer die von Ihnen erstellten DRM-Profile anzeigen, bearbeiten und verwenden können. DRM-Profile weisen die Dateinamenerweiterung DRM auf.

Verwandte Themen

  • Anpassen einer Sitzung
  • Einrichten eines Kontos mit einem Lizenzanbieter
  • So schützen Sie Ihren Inhalt mit DRM


So schützen Sie Ihren Inhalt mit DRM

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Sicherheit.
  2. Richten Sie ggf. ein Konto bei einem Lizenzanbieter ein, und erstellen Sie dann ein Profil.
  3. Aktivieren Sie das Kontrollkästchen DRM verwenden, um den Inhalt vor unberechtigtem Zugriff zu schützen.
  4. Wählen Sie unter DRM-Profil das Profil in der Liste aus, das in dieser Sitzung verwendet werden soll.

    Wenn Sie mit der Codierung beginnen, wird der Inhalt geschützt.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt
  • Einrichten eines Kontos mit einem Lizenzanbieter


Einrichten eines Kontos mit einem Lizenzanbieter

Ein Lizenzanbieter muss die Lizenzen für die Inhalte ausstellen, die Sie schützen. Sie müssen ein Konto bei einem Lizenzanbieter einrichten, der Windows Media Encoder 9-Reihe unterstützt. Als Teil der Kontoeinrichtung fordert der Lizenzanbieter Sie auf, die Rechte auszuwählen, die in den Lizenzen enthalten sein sollen. Abhängig vom Lizenzserver werden Sie möglicherweise auch aufgefordert, weitere Einstellungen anzugeben, z. B., wie Lizenzen ausgestellt werden sollen.

Nachdem Sie ein Konto eingerichtet haben, erstellt der Lizenzanbieter ein DRM-Profil und speichert dieses auf Ihrem lokalen Computer. Anschließend können Sie das Profil zum Schützen von Inhalten verwenden. Das Profil enthält die folgenden Informationen:

  • Eine DRM-Profil-ID.
  • Einen Namen und eine Beschreibung.
  • Attribute (Name/Wert-Paare).
  • Den URL für die Website des Lizenzanbieters.
  • Die Lizenzerwerbs-URLs.

    Player können verschiedene Versionen der Microsoft DRM-Technologie unterstützen: Windows Media Rights Manager, Version 1 oder 7. Aus diesem Grund werden Lizenzerwerbs-URLs verwendet, die der betreffenden Version entsprechen. Jeder Lizenzerwerbs-URL verweist auf die Seite auf der Website des Lizenzanbieters, auf der eine Lizenz erworben werden kann, und ist im Header des geschützten Inhalts enthalten. Wenn der Benutzer den geschützten Inhalt wiedergibt, öffnet der Player die entsprechende Lizenzerwerbs-URL, um eine Lizenz abzurufen.

Wenn ein DRM-Profil erstellt wird, werden die folgenden Werte ebenfalls erstellt und auf dem lokalen Computer gespeichert:

  • Öffentliche und private Signaturschlüssel. Der Lizenzanbieter benötigt den öffentlichen Signaturschlüssel, um Lizenzen auszustellen. Der private Signaturschlüssel wird nicht zurückgegeben.
  • Ein Lizenz-Ausgangswert. Für jede Datei und jeden Datenstrom, die oder den Sie schützen möchten, wird der Ausgangswert zum Generieren eines Schlüssels für das Verschlüsseln des Inhalts verwendet. Dieser Wert wird außerdem vom Lizenzanbieter zum erneuten Erstellen dieses Schlüssels und zum Einfügen in eine Lizenz verwendet, die vom Player des Benutzers für das Entschlüsseln des Inhalts verwendet wird.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt
  • So richten Sie ein Konto mit einem Lizenzanbieter ein


So richten Sie ein Konto mit einem Lizenzanbieter ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Sicherheit.
  2. Klicken Sie auf Neu, und klicken Sie dann auf Hinzufügen.
  3. Führen Sie eine der folgenden Aktionen aus:
    • Klicken Sie auf den Namen und den URL des Anbieters, den Sie verwenden möchten.
    • Klicken Sie auf Anbieter suchen, um zu einer Website mit einer Liste der Anbieter zu wechseln, unter denen Sie auswählen können.

    Wenn Sie einen Anbieter angegeben haben, wird das Dialogfeld Neues Profil angezeigt.

  4. Klicken Sie in der Liste auf den Anbieternamen, und klicken Sie dann auf Generieren.

    Die Benutzeroberfläche, die vom Anbieter zur Verfügung gestellt wird, wird angezeigt.

  5. Folgen Sie den Anweisungen, um ein DRM-Profil für Ihren Inhalt zu erstellen. Nachdem Sie das Profil erstellt haben, können Sie dieses zum Schützen des Inhalts verwenden.

Verwandte Themen

  • Einrichten eines Kontos mit einem Lizenzanbieter
  • So schützen Sie Ihren Inhalt mit DRM


Einbetten eines Wasserzeichens in den Inhalt

Sie können ein digitales Wasserzeichen in einen Datenstrom einbetten. Wasserzeichen sind ein Verfahren zum Hinzufügen von Informationen, wie z. B. Copyrightinformationen oder dem Namen eines Künstlers, zum Audio- und Videodatenstrom. Wasserzeichen sind jedoch für den Benutzer nicht hörbar oder sichtbar. Das Wasserzeichen wird in der codierten Datei oder dem Datenstrom gespeichert und kann nicht entfernt werden. Das Wasserzeichen kann selbst dann zum Identifizieren von Inhalt verwendet werden, wenn dieser kopiert oder bearbeitet wird.

Sie müssen sich ein Plug-In eines Drittanbieters besorgen und dieses registrieren, um mit Wasserzeichen arbeiten zu können. Weitere Informationen zum Erhalten eines Wasserzeichen-Plug-Ins finden Sie auf der Microsoft-Website.

Verwandte Themen

  • Anpassen einer Sitzung
  • So fügen Sie ein Wasserzeichen zum Inhalt hinzu


So fügen Sie ein Wasserzeichen zum Inhalt hinzu

  1. Registrieren Sie bei Bedarf das Wasserzeichen-Plug-In, dessen Verwendung Sie planen.
  2. Starten Sie den Encoder, und klicken Sie dann im Menü Ansicht auf Eigenschaften.
  3. Klicken Sie auf die Registerkarte Sicherheit.
  4. Wenn Sie ein Wasserzeichen zum Videoinhalt hinzufügen möchten, aktivieren Sie das Kontrollkästchen Video, und klicken Sie dann in der Liste auf das Plug-In, das Sie verwenden möchten.
  5. Wenn Sie ein Wasserzeichen zum Audioinhalt hinzufügen möchten, aktivieren Sie das Kontrollkästchen Audio, und klicken Sie dann in der Liste auf das Plug-In, das Sie verwenden möchten.

Anmerkung Anmerkung

  • Wenn für das verwendete Wasserzeichen-Plug-In eine Konfigurationsdatei erforderlich ist, klicken Sie auf Konfigurieren, um die Datei anzugeben.

Verwandte Themen

  • Einbetten eines Wasserzeichens in den Inhalt


Verwenden von Hardwareprofilen

Auf Windows Media basierender Inhalt kann auch auf anderen Geräten als Computern wiedergegeben werden. Vielmehr gibt es einen steigenden Bedarf im Zusammenhang mit der Wiedergabe von Inhalten auf den unterschiedlichsten Hardwaregeräten, z. B. auf Set-Top-Boxen, Mobiltelefonen und DVD-Playern. Wenn Sie sicherstellen möchten, dass der Inhalt auf einem bestimmten Hardwaregerätetyp wiedergegeben werden kann, können Sie den Inhalt mithilfe eines Hardwareprofils codieren. Windows Media Encoder enthält mehrere Hardwareprofile, die einen ganzen Bereich von Codierungsanforderungen abdecken sollen.

Selbst wenn Sie kein Hardwareprofil zum Codieren von Inhalt verwenden, können Sie den Typ des Hardwaregeräts ermitteln, das den Inhalt wiedergeben kann. Der gesamte codierte Inhalt wird einem Hardwareprofil zugeordnet. Das zum Codieren verwendete Profil wird im Dialogfeld Codierungsergebnisse (unter Profilübereinstimmung) angezeigt, das nach Abschluss der Codierung geöffnet wird.

Videoprofile

Windows Media Encoder enthält die folgenden Hardwareprofile: Einfaches Videoprofil - Niedrig, Einfaches Videoprofil - Mittel, Hauptvideoprofil - Niedrig, Hauptvideoprofil - Mittel und Hauptvideoprofil - Hoch. Weitere Informationen zu den einzelnen Profilen finden Sie unter Hardwareprofile für Video. Ein bestimmtes Profil und eine Ebene unterstützen immer untergeordnete Profile und Ebenen. Ein Gerät, das das Hauptprofil, mittlere Ebene, unterstützt, unterstützt z. B. auch das Hauptprofil, niedrige Ebene, sowie alle Ebenen im einfachen Profil.

Audioprofile

Die folgende Tabelle listet in aufsteigender Reihenfolge die Hardwareprofile für Audioinhalte auf, die im Encoder enthalten sind.

Audioprofil | Beschreibung
L1 | Für Audiobitraten von 4 Kbit/s bis 128 Kbit/s (verwendet den Windows Media Audio 9-Codec)
L2 | Für Audiobitraten, die kleiner als oder gleich 160 Kbit/s sind (verwendet den Windows Media Audio 9-Codec)
L3 | Für Audiobitraten, die kleiner als oder gleich 384 Kbit/s sind (verwendet den Windows Media Audio 9-Codec)
L | Unterstützt alle Bitraten; dient zur Darstellung der Codecfunktionen bei der Wiedergabe auf Computern (verwendet den Windows Media Audio 9-Codec)
S1 | Für Audiobitraten, die kleiner als oder gleich 20 Kbit/s sind (verwendet den Windows Media Audio 9 Voice-Codec)

Es ist nicht möglich, die in der folgenden Tabelle aufgelisteten Profile auszuwählen, wenn eine Sitzung eingerichtet wird. Wenn der codierte Audioinhalt jedoch den in der Tabelle aufgeführten Parametern entspricht, wird der Inhalt dem entsprechenden Hardwareprofil zugeordnet.

Audioprofil | Beschreibung
S2 | Für Audiobitraten, die kleiner als oder gleich 20 Kbit/s sind, für Inhalte mit einer Mischung aus Sprache und Musik (verwendet den Windows Media Audio 9 Voice-Codec)
L2 | Für Audiobitraten, die kleiner als oder gleich 160 Kbit/s sind (verwendet den Windows Media Audio 9-Codec)
M1 | Für Audiobitraten, die kleiner als oder gleich 384 Kbit/s sind, Abtastraten, die kleiner als oder gleich 48 KHz sind, und 5,1 oder weniger Kanäle; empfohlen für Surroundsound für Filme mit Standardauflösung (verwendet den Windows Media Audio 9 Professional-Codec)
M2 | Für Audiobitraten, die kleiner als oder gleich 768 Kbit/s sind, Abtastraten, die kleiner als oder gleich 96 KHz sind, und 5,1 oder weniger Kanäle; empfohlen für Surroundsound für hoch auflösende Filme (verwendet den Windows Media Audio 9 Professional-Codec)
M | Unterstützt alle Bitraten, Abtastraten und Kanäle; dient zur Darstellung der Codecfunktionen bei der Wiedergabe auf Computern (verwendet den Windows Media Audio 9 Professional-Codec)

Kombinieren von Video- und Audioprofilen

Die folgende Tabelle listet die empfohlenen Kombinationen von Video- und Audiohardwareprofilen auf.

Video | Audio
Einfaches Videoprofil - Niedrig | L2 oder S2
Einfaches Videoprofil - Mittel | L2 oder S2
Hauptvideoprofil - Niedrig | L2 oder S2
Hauptvideoprofil - Mittel | L3, S2 oder M1
Hauptvideoprofil - Hoch | L3, S2 oder M2

Verwandte Themen

  • Anpassen einer Sitzung
  • So richten Sie ein Hardwareprofil ein
  • Hardwareprofile für Video


So richten Sie ein Hardwareprofil ein

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel auf Hardwaregeräte.
  3. Klicken Sie unter Video und Audio auf das Profil und die Ebene, auf der Sie codieren möchten.

Verwandte Themen

  • Verwenden von Hardwareprofilen


Hardwareprofile für Video

Dieser Abschnitt enthält ausführliche Informationen zu den für Videoinhalt verfügbaren Hardwareprofilen, die mit Windows Media Encoder installiert werden.

Einfaches Videoprofil - Niedrig (SP@LL)

Element | Wert
Zielhardwaregeräte | Mobiltelefone
Maximale Auflösung | 176 x 144
Maximale Framerate | 15 F/S
Maximale Bitrate | 96 Kbit/s
Maximale Puffergröße | Ungefähr 3,4 Sekunden bei maximaler Bitrate

Einfaches Videoprofil - Mittel (SP@ML)

Element | Wert
Zielhardwaregeräte | Handheldcomputer, PDAs (Personal Data Assistants) und hochleistungsfähige Mobiltelefone
Maximale Auflösung | 352 x 288
Maximale Framerate | 15 F/s bei 352 × 288 24 F/s bei 320 × 240
Maximale Bitrate | 384 Kbit/s
Maximale Puffergröße | Ungefähr 3,3 Sekunden bei maximaler Bitrate

Hauptvideoprofil - Niedrig (MP@LL)

Element | Wert
Zielhardwaregeräte | Set-Top-Boxen (Low-End)
Maximale Auflösung | 352 x 288
Maximale Framerate | 30 F/S
Maximale Bitrate | 2 Mbit/s
Maximale Puffergröße | Ungefähr 2,5 Sekunden bei maximaler Bitrate

Einfaches Videoprofil - Mittel (MP@ML)

Element | Wert
Zielhardwaregeräte | Hochleistungsfähige Set-Top-Boxen; DVD-Player und DirectX Video Acceleration-fähige (DirectX VA) Grafikkarten
Maximale Auflösung | 720 × 576
Maximale Framerate | 30 F/s bei 720 × 576 (NTSC) 25 F/s bei 720 × 576 (PAL)
Maximale Bitrate | 10 Mbit/s
Maximale Puffergröße | Ungefähr 1 Sekunde bei maximaler Bitrate

Einfaches Videoprofil - Hoch (MP@HL)

Element | Wert
Zielhardwaregeräte | DVD-Player; DirectX VA-fähige Grafikkarten und digitales Kino
Maximale Auflösung | 1920 × 1080
Maximale Framerate | 30 F/s bei 1920 × 1080 60 F/s bei 1280 × 720
Maximale Bitrate | 20 Mbit/s
Maximale Puffergröße | Ungefähr 2 Sekunden bei maximaler Bitrate

Verwandte Themen

  • Verwenden von Hardwareprofilen


Verwenden von Transformations-Plug-Ins

Windows Media Encoder besitzt eine anpassbare Benutzeroberfläche, mit deren Hilfe Entwickler Transformations-Plug-Ins schreiben können, die auf Codierungsfunktionen basieren und diese anpassen. Der Encoder unterstützt Microsoft DirectShow® und DirectX® Media Object DMO-Transformationsfilter. Sie können Plug-Ins auf Quellenbasis konfigurieren.

Weitere Informationen zu DirectShow finden Sie auf der Microsoft-Website. Informationen zu DirectX Media Object (DMO) finden Sie auf der Microsoft-Website.

Verwandte Themen

  • Anpassen einer Sitzung
  • So verwenden Sie ein Transformations-Plug-In


So verwenden Sie ein Transformations-Plug-In

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Plug-Ins.
  2. Klicken Sie unter Typ des Transformations-Plug-Ins auf Video oder auf Audio.
  3. Klicken Sie auf die Quelle, mit der Sie das Plug-In verwenden möchten. (Nur für eine Mehrfachquellensitzung erforderlich.)
  4. Wenn in der Liste der verfügbaren Plug-Ins keine Plug-Ins angezeigt werden, klicken Sie auf Registrieren, und aktivieren Sie dann die Kontrollkästchen für die gewünschten Plug-Ins. (Um die Registrierung eines Plug-Ins aufzuheben, deaktivieren Sie das Kontrollkästchen für das Plug-In.)

    Für die Registrierung eines Plug-Ins benötigen Sie die Anmeldeinformationen für den Administrator auf dem Computer mit dem Encoder.

  5. Klicken Sie in der Liste der verfügbaren Plug-Ins auf ein Plug-In, und klicken Sie dann auf die Schaltfläche Nach rechts verschieben (>>), um das Plug-In zur Liste der Plug-Ins für die Quelle hinzuzufügen.
  6. Klicken Sie auf Konfigurieren, um das ausgewählte Plug-In zu konfigurieren.

Vorsicht Vorsicht

  • Im Dialogfeld Transformations-Plug-Ins für die Registrierung und Aufhebung der Registrierung werden alle Transformations-Plug-Ins aufgelistet, die auf dem Computer mit dem Encoder zur Verfügung stehen. Einige der Plug-Ins sind möglicherweise für die Verwendung mit dem Encoder nicht geeignet und führen zu unerwarteten Ergebnissen, falls Sie sie mit dem Encoder verwenden.

Verwandte Themen

  • Verwenden von Transformations-Plug-Ins


Ausgabeoptionen

Sie können Inhalt zur späteren Verwendung in eine Datei codieren, oder Sie können den Inhalt live übertragen. Wenn Sie den Inhalt übertragen, können Sie den Datenstrom per Push auf einen Server übertragen, der Windows Media-Dienste ausführt, oder Sie können Windows Media-Server und -Player für das Anfordern des Datenstroms per Pull direkt vom Encoder aktivieren. Sie können eine Kopie der Übertragung in einer Datei archivieren. Vor oder nach der Codierung können Sie Folgendes durchführen:

  • Ändern des Ausgabeanschlusses für eine Übertragung.
  • Auswählen der Archivierung in einer Datei oder Abbrechen des Archivierungsvorgangs.
  • Ändern des Namens oder des Speicherorts der Ausgabedatei.

Während der Codierung können Sie Folgendes durchführen:

  • Auswählen der Archivierung in eine Datei oder Abbrechen des Archivierungsvorgangs.
  • Ändern des Namens der Archivdatei, wenn Sie aktuell nicht archivieren.

Während der Codierung können Sie Folgendes nicht durchführen:

  • Ändern der Portnummer.
  • Ändern des Modus von einer Übertragungssitzung in eine Sitzung, die in eine Datei codiert.

Verwandte Themen

  • Windows Media Encoder
  • Codieren oder Archivieren einer Übertragung in einer Datei
  • Codieren von unkomprimierten Audio- und Videodateien
  • Übertragen von Liveinhalt
  • Testen des Inhalts


Codieren oder Archivieren einer Übertragung in einer Datei

Sie können Inhalt in eine Datei codieren, und Sie können ein Liveereignis in einer Datei zur späteren Verwendung archivieren.

Archivieren auf einem Windows Media-Server im Vergleich zum Archivieren auf dem Computer mit dem Encoder

Wenn Sie die Übertragung über einen Windows Media-Server durchführen, können Sie die Übertragung auf dem Server statt auf dem Computer mit dem Encoder archivieren. In den folgenden Fällen ist das Archivieren auf dem Windows Media-Server die beste Lösung:

  • Das Archiv soll sofort für die Anzeige verfügbar sein.
  • Die Ressourcen des Computers mit dem Encoder werden größtenteils zum Codieren verwendet.
  • Auf dem Server steht mehr freier Speicherplatz auf der Festplatte zur Verfügung als auf dem Computer mit dem Encoder.

Wenn Sie sich für die Archivierung der Übertragung auf dem Computer mit dem Encoder entscheiden, werden alle Quellen, die Sie in der Übertragungssitzung einrichten, automatisch archiviert. Das Archivieren aller Quellen ist jedoch nicht immer wünschenswert. Wenn eine der Quellen z. B. eine Anzeige ist, soll diese möglicherweise nicht archiviert werden. Sie können den Encoder automatisch eine Pause bei der Archivierung für Quellen machen lassen, die Sie angeben.

Aktivieren der Suchfunktion in der Ausgabedatei

Die Indizierung bei jedem Schlüsselframe wird bei jeder Archivierung in einer Datei oder jeder Codierung in eine Datei standardmäßig aktiviert, wenn die Quelle Video umfasst. Indem der Inhalt indiziert wird, können Benutzer die Funktionen Schneller Vorlauf und Rücklauf eines Players bei der Anzeige codierter Inhalte verwenden. (Indizierung ist für Übertragungen nicht verfügbar.) Sie können auch Suche auf Frameebene in einer Ausgabedatei aktivieren, indem Sie einen Zeitcode generieren (oder den im Quellvideo bereits vorhandenen Zeitcode beibehalten). Sie können einen Zeitcode generieren, wenn Ihre Quelle Video enthält und Sie digitale Videodateien (DV-Dateien) im AVI-Format (Audio-Video Interleaved) sowie Aufnahme- und Digitalgeräte als Quelle verwenden. Sie können einen Zeitcode beibehalten, wenn Ihre Quelle Video enthält und Sie digitale Videodateien (DV-Dateien) im AVI-Format oder Digitalgeräte als Quelle verwenden. Um den Zeitcode für einen Videorecorder beizubehalten, müssen Sie eine Schnittliste (Edit Decision List, EDL) für die Sitzung einrichten. Sie können keinen Zeitcode beibehalten oder erstellen, wenn Sie den Filter für die umgekehrte Filmabtastung (Inverse Telecine) verwenden.

Vorübergehendes Speichern von Inhalt

Wenn Sie mit Geräten als Quelle in eine Datei codieren, fällt der Codierungsvorgang möglicherweise hinter den Aufzeichnungsvorgang zurück, wodurch sich die Qualität des codierten Inhalts verschlechtert. Um dies zu verhindern, können Sie den aufgezeichneten Inhalt vorübergehend speichern und anschließend in eine Datei codieren. Bei Auswahl dieser Option finden Aufzeichnung und Codierung gleichzeitig statt, und die Daten werden nur vorübergehend gespeichert, wenn die Codierung hinter die Aufzeichnung zurückfällt. Sie können den Inhalt wahlweise zuerst aufzeichnen und erst nach der Aufzeichnung codieren, um die bestmögliche Qualität insbesondere dann zu erzielen, wenn Sie große Datenmengen aufzeichnen. (Diese Option ist nicht verfügbar, wenn die Quelle ein digitales Gerät ist. Außerdem ist es nicht möglich, Inhalt zuerst aufzuzeichnen und dann zu codieren, wenn gleichzeitig die Größe oder Dauer der Ausgabedatei beschränkt wird.)

Wenn Sie diese Funktion in einer Mehrfachquellensitzung aktivieren (einschließlich der Option, zuerst aufzuzeichnen und dann zu codieren), sollten Sie mit dem Beenden der Codierung warten, bis alle Daten von der ersten Quelle empfangen wurden. Angenommen, Sie besitzen z. B. zwei Quellen, und Sie möchten nur einen Teil der zweiten Quelle aufzeichnen. Sie können während der Codierung zur zweiten Quelle wechseln. Sie sollten jedoch warten, bis die Videovorschau/-nachbetrachtung (im Fensterbereich Video) oder der Bereich Eingabe (Registerkarte Allgemein des Fensterbereichs Monitor) anzeigt, dass die erste Quelle das Senden aller Daten abgeschlossen hat, bevor Sie die Codierung beenden. Auf diese Weise wird sichergestellt, dass der gesamte gewünschte Inhalt aufgezeichnet wird.

Verwandte Themen

  • Ausgabeoptionen
  • Informationen zu den Dateinamenerweiterungen ASF, WMA und WMV
  • Einrichten einer Schnittliste
  • So codieren Sie in eine Datei
  • So legen Sie Archivoptionen für die einzelnen Quellen fest
  • So aktivieren oder deaktivieren Sie die Indizierung
  • So aktivieren Sie die Suche auf Frameebene
  • So speichern Sie aufgezeichneten Inhalt vorübergehend
  • Codieren von unkomprimierten Audio- und Videodateien


Informationen zu den Dateinamenerweiterungen ASF, WMA und WMV

Die Dateinamenerweiterungen ASF, WMA und WMV stellen das Standarddateiformat von Windows Media dar. Die Dateinamenerweiterung ASF wird normalerweise mit auf Windows Media basierendem Inhalt verwendet, der mit den Windows Media-Tools 4.0 erstellt wurde. Die Dateinamenerweiterungen WMA und WMV wurden als Standardnamenkonventionen mit Windows Media Encoder 7 eingeführt, damit Benutzer auf einfache Weise zwischen Nur-Audiodateien (WMA-Dateien) und Videodateien (WMV-Dateien) unterscheiden können. Die drei Dateinamenerweiterungen können jedoch auch untereinander ausgetauscht werden. Einige Dienste und Tools, die für die Verwendung mit früheren Versionen der Windows Media-Technologien erstellt wurden, erfordern die Dateinamenerweiterung ASF, um den Inhalt zu akzeptieren. Sie können WMA- oder WMV-Dateien einfach umbenennen und die Dateinamenerweiterung ASF verwenden, um diese Dateien mit diesen Tools zu verarbeiten. (Es wird jedoch empfohlen, nach Möglichkeit das aktuellste Tool oder den aktuellsten Dienst zu verwenden.)

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


So codieren Sie in eine Datei

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Deaktivieren Sie die Kontrollkästchen Auf den Server übertragen und Vom Encoder anfordern.
  3. Aktivieren Sie das Kontrollkästchen In Datei codieren.
  4. Geben Sie unter Dateiname den Dateinamen der Ausgabedatei ein.
  5. Wenn Sie die Größe der Ausgabedatei beschränken möchten, klicken Sie auf Größe beschränken, und geben Sie dann die maximale Dateigröße, gefolgt von einem K, M oder G für Kilobyte, Megabyte bzw. Gigabyte an.
  6. Wenn Sie die Dauer der Ausgabedatei beschränken möchten, klicken Sie auf Dauer beschränken, und geben Sie dann die maximale Dauer der Datei im Format hh:mm:ss an. Beispiel: 01:30:00.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


So legen Sie Archivoptionen für die einzelnen Quellen fest

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Wählen Sie eine Übertragungsmethode (Übertragen per Push oder Anfordern per Pull) aus, und aktivieren Sie dann das Kontrollkästchen In Datei archivieren.
  3. Geben Sie unter Dateiname einen Namen für die Archivdatei ein.
  4. Wenn Sie die Größe der Archivdatei beschränken möchten, klicken Sie auf Größe beschränken, und geben Sie dann die maximale Dateigröße, gefolgt von einem K, M oder G für Kilobyte, Megabyte bzw. Gigabyte an.
  5. Wenn Sie die Dauer der Archivdatei beschränken möchten, klicken Sie auf Dauer beschränken, und geben Sie dann die maximale Dauer der Datei im Format hh:mm:ss an. Beispiel: 01:30:00.
  6. Wenn nicht alle Quellen der Übertragung archiviert werden sollen, klicken Sie auf die Registerkarte Quellen, und klicken Sie dann in der Liste der Quellen auf die Quelle, die Sie nicht archivieren möchten.
  7. Klicken Sie unter Archivierung auf Pause oder Stopp, um zu verhindern, dass die Quelle archiviert wird.

    Sie können diese Einstellungen außer Kraft setzen, indem Sie Manuelles Archivsteuerelement im Menü Steuerung verwenden.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


So aktivieren oder deaktivieren Sie die Indizierung

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Aktivieren Sie das Kontrollkästchen In Datei codieren oder In Datei archivieren.
  3. Aktivieren oder deaktivieren Sie das Kontrollkästchen Indexdatei, um die Indizierung zu aktivieren bzw. zu deaktivieren.

Anmerkung Anmerkung

  • Durch die Indizierung wird die Suche nach Schlüsselframes ermöglicht. Für einige Inhalte können Sie eine Suchfunktion auf Frameebene aktivieren.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei
  • So aktivieren Sie die Suche auf Frameebene


So aktivieren Sie die Suche auf Frameebene

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Weitere Optionen.
  2. Aktivieren Sie das Kontrollkästchen Zeitcode.
  3. Wenn das Quellvideo bereits über einen Zeitcode verfügt, klicken Sie auf Original beibehalten.

    - Oder -

    Um einen Zeitcode zu generieren, klicken Sie auf Zeitcode erstellen, und geben Sie dann unter Startzeit die Uhrzeit, zu der der Zeitcode starten soll, im Format hh:mm:ss:fm ein. Wählen Sie außerdem unter Videoformat das Format des Quellvideos aus.

Anmerkung Anmerkung

  • Sie können einen Zeitcode generieren, wenn Ihre Quelle Video enthält und Sie digitale Videodateien (DV-Dateien) im AVI-Format (Audio-Video Interleaved) sowie Aufnahme- und Digitalgeräte als Quelle verwenden. Sie können einen Zeitcode beibehalten, wenn Ihre Quelle Video enthält und Sie digitale Videodateien (DV-Dateien) im AVI-Format oder Digitalgeräte als Quelle verwenden. Um den Zeitcode für einen Videorecorder beizubehalten, der über einen COM-Anschluss mithilfe des Sony RS422-Protokolls angeschlossen ist, müssen Sie eine Schnittliste (Edit Decision List, EDL) für die Sitzung einrichten. Sie können keinen Zeitcode beibehalten oder erstellen, wenn Sie den Filter für die umgekehrte Filmabtastung (Inverse Telecine) verwenden.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


So speichern Sie aufgezeichneten Inhalt vorübergehend

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Weitere Optionen.
  2. Aktivieren Sie das Kontrollkästchen Inhalt vorübergehend auf Festplatte speichern.
  3. Um den Inhalt zuerst aufzuzeichnen und dann zu codieren, aktivieren Sie das Kontrollkästchen Auf Festplatte aufzeichnen, dann codieren.

Anmerkung Anmerkung

  • Die Option Auf Festplatte aufzeichnen, dann codieren ist nicht verfügbar, wenn die Quelle ein digitales Gerät ist.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


Codieren von unkomprimierten Audio- und Videodateien

Mit Windows Media Encoder können Sie Inhalte mit hoher Qualität aufzeichnen und zur späteren Verwendung in einer Archivdatei archivieren. In den meisten Situationen ist die Option Dateiarchiv, die qualitätsbasierte VBR-Codierung verwendet, am geeignetsten. Wenn Sie jedoch planen, den Inhalt zu einem späteren Zeitpunkt zu bearbeiten, können Sie auch das Codieren unkomprimierter Dateien in Erwägung ziehen.

Die Speicheranforderungen für unkomprimierte Dateien sind erheblich höher als für andere Dateien, auf die Komprimierung angewendet wurde. Es wird empfohlen, den Inhalt auf einem NTFS-Datenträger zu speichern. Das FAT32-Dateisystem besitzt eine Begrenzung der Dateigröße auf 4 GB. Wenn Sie erwarten, dass der Inhalt 4 GB übersteigt, sollten Sie die Festplatte für die Verwendung von NTFS neu konfigurieren.

Wenn Sie unkomprimierte Inhalte von einem Gerät aufzeichnen, z. B. von einer Kamera oder einem Videorecorder, wird das sich ergebende Video im YUV-Format YV12 erstellt, und zwar unabhängig vom auf dem Gerät oder im Profil angegebenen Pixelformat. Der Windows Media Video 9-Codec ist für YUV optimiert, daher ist es das bevorzugte Format hinsichtlich Qualität, Dateigröße und Leistung. Der sich ergebende Audioinhalt wird im Pulscodemodulation (PCM)-Format erstellt.

Gehen Sie folgendermaßen vor, um beim Aufzeichnen unkomprimierter Inhalte die bestmöglichen Ergebnisse zu erzielen:

  • Verwenden Sie eine schnelle Festplatte, die Codierung bei hohen Bitraten ermöglicht.
  • Verwenden Sie 15 F/s beim Aufzeichnen mit einer Auflösung von 640 x 480.
  • Verwenden Sie 30 F/s beim Aufzeichnen mit einer Auflösung von 320 x 240.

Verwandte Themen

  • Ausgabeoptionen
  • So verwenden Sie die Option "Dateiarchiv"
  • So codieren Sie unkomprimierten Inhalt


So verwenden Sie die Option "Dateiarchiv"

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Deaktivieren Sie die Kontrollkästchen Auf den Server übertragen und Vom Encoder anfordern, und aktivieren Sie dann das Kontrollkästchen In Datei codieren.
  3. Klicken Sie auf die Registerkarte Komprimierung, und klicken Sie dann unter Ziel auf Dateiarchiv.
  4. Wählen Sie unter Video und Audio die gewünschten Qualitätseinstellungen aus.

Verwandte Themen

  • Codieren von unkomprimierten Audio- und Videodateien


So codieren Sie unkomprimierten Inhalt

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Komprimierung.
  2. Klicken Sie unter Ziel entweder auf Windows Media-Server oder auf Webserver.
  3. Wenn Sie Audioinhalt codieren, klicken Sie auf Bearbeiten, aktivieren Sie das Kontrollkästchen Audio, und klicken Sie dann unter Codec auf Keine (PCM).
  4. Wenn Sie Videoinhalt codieren, aktivieren Sie das Kontrollkästchen Video, und klicken Sie dann unter Codec auf Vollständige Frames (unkomprimiert).

Anmerkung Anmerkungen

  • Wenn Sie sowohl Audio- als auch Videoinhalte codieren, müssen Sie die Option für unkomprimierte Codierung für beide Inhaltstypen verwenden.
  • Es ist nicht möglich, unkomprimierten Inhalt in einen MBR-Datenstrom zu codieren.

Verwandte Themen

  • Codieren von unkomprimierten Audio- und Videodateien


Übertragen von Liveinhalt

Wenn Sie Inhalt live übertragen möchten, können Sie den Datenstrom per Push vom Encoder auf einen Windows Media-Server übertragen, oder Sie können Clients (Windows Media-Server und -Player) für das Anfordern des Datenstroms per Pull aktivieren. Das verwendete Verfahren hängt von der jeweiligen Situation ab.

Pushszenarien

Das Übertragen des Datenstroms vom Encoder per Push ist sinnvoll, wenn sich der Encoder hinter einem Firewall befindet oder wenn Sie die Verbindung vom Encoder aus initiieren möchten. Angenommen, Sie haben z. B. in letzter Minute erfahren, dass der Geschäftsführer Ihres Unternehmens eine Ansprache an die Mitarbeiter ausstrahlen möchte. Der Windows Media-Server befindet sich an einem Remotestandort außerhalb des Unternehmensfirewalls. Für den Serveradministrator ist es mitten in der Nacht. Indem Sie den Datenstrom per Push vom Encoder übertragen, können Sie den Datenstrom hinter den Firewall übermitteln, die Anforderung des Geschäftsführers erfüllen und einen Notfallanruf beim und das direkte Erscheinen des Administrator vermeiden. Die Pushverteilung steht nur mit Windows Media-Dienste 9-Reihe unter Windows .NET Server 2003 zur Verfügung.

Pullszenarien

Das Aktivieren von Windows Media-Servern für das Anfordern des Datenstroms per Pull bietet sich in mehreren Szenarien an. Bei Verwendung mehrerer Verteilungsserver, die alle zu unterschiedlichen Zeiten eine Verbindung herstellen, kann jeder Server die Verbindung mit dem Encoder initiieren, sobald der Server zur Ausstrahlung bereit ist. Zudem ist das Anfordern eines Datenstroms von einem Server per Pull sinnvoll, wenn die Verwendung von Bandbreite zwischen dem Server und dem Encoder minimiert werden soll. Der Serveradministrator kann z. B. einen Publishingpoint hinzufügen und so konfigurieren, dass er bei Clientanfragen automatisch gestartet wird. Der Server initiiert also die Verbindung zum Encoder erst, wenn der erste Client eine Verbindung herstellt. Dadurch wird die Verwendung unnötiger Bandbreite zwischen Server und Encoder vermieden. (Dieses Szenario steht nur mit Windows Media-Dienste unter Windows .NET Server 2003 zur Verfügung.) Schließlich ist das Anfordern per Pull sinnvoll, wenn sich der Server hinter einem Firewall befindet. Angenommen, Sie haben den Encoder in einem öffentlichen Netzwerk eingerichtet, weil Sie Ereignisse im Zusammenhang mit einer Konferenz ausstrahlen. Sie müssen den Datenstrom an einen Verteilungsserver im geschützten Netzwerk übermitteln. Der Serveradministrator kann den Datenstrom per Pull durch den Firewall anfordern.

Das Aktivieren von Playern für das Anfordern des Datenstroms per Pull ist sinnvoll, wenn Sie erwarten, dass nur wenige Clients den Datenstrom anzeigen. Windows Media Encoder ermöglicht bis zu fünf Clients das direkte Herstellen einer Verbindung während einer Übertragung. Wenn Sie Clients das Anfordern des Datenstroms per Pull ermöglichen, können Sie den Zugriff auf den Inhalt durch die IP-Adresse oder durch Gruppen von IP-Adressen einschränken.

Verwandte Themen

  • Ausgabeoptionen
  • Vergleichen von Windows Media-Servern und Webservern
  • Übertragen eines Datenstroms vom Encoder
  • Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull
  • Erstellen einer Ankündigung für ein Multicast
  • Beschränken des Zugriffs auf eine Übertragung


Übertragen eines Datenstroms vom Encoder

Beim Übertragen eines Datenstroms per Push vom Encoder müssen Sie den Windows Media-Server angeben, zu dem ausgestrahlt werden soll, sowie den Übertragungspublishingpoint (neu oder vorhanden), über den ausgestrahlt werden soll. Auf dem Windows Media-Server stehen mehrere Optionen zum Konfigurieren eines Publishingpoints zur Verfügung, z. B. das Festlegen der maximalen Anzahl von Playern, die den Datenstrom anzeigen können, das Steuern des Zugriffs auf Inhalt und das Einrichten von Protokollierung. Wenn Sie eine vorhandene Konfiguration wiederholt verwenden möchten, können Sie einen Übertragungspublishingpoint auf dem Server hinzufügen, diesen gemäß Ihren Anforderungen konfigurieren und dann die Einstellungen von diesem Publishingpoint bei jedem Übertragen eines Datenstroms an den Server kopieren. Weitere Informationen zum Konfigurieren von Übertragungspublishingpoints finden Sie in der Hilfe zu Windows Media-Dienste. Die Pushverteilung steht nur mit Windows Media-Dienste 9-Reihe in Windows .NET Server 2003 zur Verfügung.

Inhalt kann von einem Windows Media-Server entweder als Multicast- oder als Unicastdatenstrom übermittelt werden.

Erforderliche Ankündigung für einen Multicastdatenstrom

Wenn Sie planen, Inhalt als Multicastdatenstrom vom Server zu übermitteln, müssen Sie vor dem Codierungsbeginn eine Ankündigung erstellen und verteilen. Eine Ankündigung ist das Mittel, durch das Sie mitteilen, dass der Inhalt für Player verfügbar ist. Sie können den Assistenten zum Erstellen von Multicastankündigungen im Encoder zum Erstellen der Ankündigung verwenden. Alternativ können Sie die Ankündigung auch auf dem Server erstellen. Für das Erstellen der Ankündigung auf dem Encoder ist es erforderlich, dass Sie über Zugriffsberechtigungen für Windows Media-Dienste über die verteilte Version von DCOM (Distributed Component Object Model) verfügen. Wenn Sie Änderungen an der Sitzungskonfiguration vornehmen, nachdem Sie die Ankündigung erstellt haben, müssen Sie vor dem Codierungsbeginn eine weitere Ankündigung erstellen.

Zugreifen auf den Windows Media-Server

Um einen Datenstrom auf einen Windows Media-Server per Push zu übertragen, muss das Plug-In WM-HTTP-Serversteuerungsprotokoll auf dem Server aktiviert sein. Außerdem müssen Sie über Schreibzugriff auf dem Server über das Plug-In WM-Publishingpoints-ACL-Autorisierung verfügen. Zusätzlich müssen Sie über Zugriffsberechtigungen zum Erstellen für das Plug-In verfügen, wenn Sie den Publishingpoint vom Encoder und nicht vom Server aus hinzufügen möchten. Die Berechtigungen müssen sowohl auf Server- als auch auf Publishingpointebene festgelegt werden. Um das Plug-In konfigurieren zu können, müssen Sie über Zugriff auf Windows Media-Dienste über DCOM verfügen.

Lokale Administratoren auf dem Server besitzen automatisch sowohl Schreib- als auch Erstellungszugriff auf dem Server.

Wenn Sie mit der Codierung beginnen, initiiert der Encoder die Verbindung zum Server.

Sie können den Assistenten für neue Sitzungen oder den Übertragungsschnellstart zum Übertragen von Inhalt per Push zu einem Windows Media-Server verwenden, oder Sie können eine Pushsitzung im Fensterbereich Eigenschaften einrichten.

Weitere Informationen zum Einrichten eines Unicast- oder Multicastdatenstroms von einem Windows Media-Server finden Sie in der Hilfe zu Windows Media-Dienste.

Verwandte Themen

  • Übertragen von Liveinhalt
  • Erstellen einer Ankündigung für ein Multicast
  • So übertragen Sie einen Datenstrom per Push an einen Windows Media-Server


So übertragen Sie einen Datenstrom per Push an einen Windows Media-Server

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Aktivieren Sie das Kontrollkästchen Auf den Server übertragen, und deaktivieren Sie das Kontrollkästchen Vom Encoder anfordern.
  3. Geben Sie unter Servername den Namen des Windows Media-Servers ein, von dem aus Sie den Inhalt verteilen möchten. Sie können den NetBIOS-Namen (Network Basic Input/Output System), die IP-Adresse oder den DNS-Namen (Domain Name System) des Servers verwenden.

    Der Encoder verwendet für die Ausstrahlung an den Server das HTTP-Protokoll. Standardmäßig verwendet der Server Port 80 für das HTTP-Protokoll. Wenn der Server für die Verwendung einer anderen Portnummer konfiguriert ist, muss der Encoder die entsprechende Portnummer verwenden. Sie können entweder das Format Servername:Portnummer unter Servername verwenden, oder die Portnummer wird automatisch erkannt, wenn Sie Zugriffsberechtigungen für Windows Media-Dienste über DCOM besitzen.

  4. Geben Sie unter Publishingpoint den Namen eines vorhandenen oder neuen Publishingpoints ein, über den der Datenstrom ausgestrahlt werden soll. Wenn Sie einen Publishingpoint erstellen, verwenden Sie ausschließlich alphanumerische Zeichen. Außerdem sind die folgenden Zeichen in einem Publishingpointnamen nicht zulässig: * < > \ ? % & # " { } | ^ [ ] `

    Wenn Sie einen Publishingpoint vom Encoder aus erstellen möchten, müssen Sie über Zugriffsberechtigungen zum Erstellen über das Plug-In WM-Publishingpoints-ACL-Autorisierung (sowohl auf Server- als auch Publishingpointebene) auf dem Windows Media-Server verfügen.

  5. Beim Erstellen eines Publishingpoints können Sie die Konfiguration des Standardpublishingpoints verwenden, oder Sie können die Konfiguration eines vorhandenen Publishingpoints in den neu erstellten Publishingpoint kopieren. Geben Sie zu diesem Zweck unter Einstellungen kopieren aus den Namen des vorhandenen Publishingpoints ein, der die Konfiguration besitzt, die Sie kopieren möchten.
  6. Wenn Sie den Publishingpoint, über den Sie den Datenstrom ausstrahlen, nach dem Schließen des Encoders entfernen möchten (oder nach einer Zeitüberschreitung von mehreren Minuten), aktivieren Sie das Kontrollkästchen Automatisch entfernen.

    Die Zeitüberschreitung ermöglicht das Beenden und anschließende Neustarten der Codierung, ohne den Publishingpoint erstellen zu müssen. Dies ist z. B. dann sinnvoll, wenn Sie die Einstellungen in der Sitzung anpassen und anschließend mit der Codierung fortfahren möchten.

Anmerkung Anmerkung

  • Wenn Sie planen, den Inhalt als Multicastdatenstrom zu übermitteln, müssen Sie außerdem eine Ankündigung erstellen.

Verwandte Themen

  • Übertragen eines Datenstroms vom Encoder
  • Erstellen einer Ankündigung für ein Multicast


Erstellen einer Ankündigung für ein Multicast

Wenn Sie einen Datenstrom per Push an einen Windows Media-Server übertragen und als Multicastdatenstrom verteilen, müssen Sie eine Ankündigung (ASX-Datei) sowie eine Multicastinformationsdatei (NSC-Datei) erstellen. Die Ankündigungsdatei ist eine Windows Media-Metadatei, die Player auf die Multicastinformationsdatei verweist. Die Multicastinformationsdatei enthält Informationen, die Player zum Zugreifen auf und Entschlüsseln von Multicastdatenströmen benötigen, wie etwa die IP-Adresse, den Port und Informationen zum Datenstromformat.

Erstellen einer Ankündigung

Sie können den Assistenten zum Erstellen von Multicastankündigungen im Encoder zum Erstellen der Ankündigung verwenden, oder Sie können sie auf dem Windows Media-Server erstellen. Für das Erstellen der Ankündigung auf dem Encoder ist es erforderlich, dass Sie über Zugriffsberechtigungen auf Windows Media-Dienste über DCOM (Distributed Component Object Model) verfügen. Wenn Sie Änderungen an der Sitzungskonfiguration vornehmen, nachdem Sie die Ankündigung erstellt haben, müssen Sie vor dem Codierungsbeginn eine weitere Ankündigung erstellen.

Wenn Sie den Assistenten im Encoder ausführen, erstellen Sie die Ankündigungsdatei, die Multicastinformationsdatei sowie eine Webseite, die einen eingebetteten Player und einen Hyperlink für die Ankündigung enthält. Sie werden aufgefordert, einen Namen für die Dateien anzugeben und die Dateien dann an einem Speicherort zu speichern, auf den Player zugreifen können (oder einen vorübergehenden Speicherort auszuwählen, wenn Sie die Übertragung zu einem späteren Zeitpunkt planen). Der Speicherort kann sich entweder auf dem Webserver für HTTP-Zugriff oder auf einer öffentlichen Freigabe befinden, wenn Sie Zugriff über einen UNC-Pfad (Universal Naming Convention) zur Verfügung stellen. Wenn Sie die Dateien auf Ihrem Webserver zur Verfügung stellen, sollten Sie den Webserver unbedingt so konfigurieren, dass er ein Zwischenspeichern der Datei nicht zulässt oder eine Aktualitätsprüfung erfordert, wenn ein Client die Datei zwischengespeichert hat, damit verhindert wird, dass Player veraltete Multicastinformationen verwenden.

Verteilen der Ankündigungsdatei

Es stehen mehrere Optionen für das Bereitstellen des Multicastdatenstroms für Benutzer zur Verfügung. Sie können einen Hyperlink für die Ankündigungsdatei auf einer Webseite platzieren, eine Ankündigung in einem freigegebenen Ordner zur Verfügung stellen oder eine Ankündigung in einer E-Mail-Nachricht senden. Benutzer können auf die jeweilige Ankündigung zugreifen, indem sie auf der Webseite auf den Hyperlink für die Ankündigung klicken oder die Ankündigung direkt öffnen. Wenn Benutzer die Ankündigungsdatei (ASX-Datei) im Player öffnen, extrahiert der Player einen URL aus der Ankündigungsdatei. Dieser URL verweist auf die Multicastinformationsdatei. Der Player downloadet dann die Multicastinformationsdatei mit dem URL und beginnt mit der Wiedergabe des Inhalts.

Verwandte Themen

  • Übertragen von Liveinhalt
  • So greifen Sie auf den Assistenten zum Erstellen von Multicastankündigungen zu


So greifen Sie auf den Assistenten zum Erstellen von Multicastankündigungen zu

  1. Richten Sie eine Pushsitzung mit einem Windows Media-Server ein, der Inhalt als Multicastdatenstrom verteilt.
  2. Klicken Sie im Menü Extras auf Übertragung ankündigen.
  3. Folgen Sie den Anweisungen des Assistenten, um die Dateien für die Sitzung zu erstellen.

Verwandte Themen

  • Übertragen eines Datenstroms vom Encoder
  • Erstellen einer Ankündigung für ein Multicast


Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull

Um Clients für das Anfordern des Datenstroms vom Encoder per Pull zu aktivieren, richten Sie einfach eine Sitzung ein und beginnen mit der Übertragung direkt vom Encoder aus. Clients (Windows Media-Server oder Windows Media-Player) können jederzeit eine Verbindung zum Datenstrom herstellen, indem sie das folgende URL-Format verwenden: http://IP_Adresse:Port (für Internetverbindungen) oder http://Name_des_codierenden_Computers:Port (für LAN-Verbindungen). Der Encoder unterstützt standardmäßig bis zu fünf direkte Verbindungen während einer Übertragung. Sie können diese Anzahl bis auf maximal 50 erhöhen, indem Sie einen Schlüssel in der Registrierung bearbeiten. (Für das Bearbeiten des Schlüssels sind Administratoranmeldeinformationen auf dem Computer mit dem Encoder erforderlich.)

Erforderliches Datenstromformat für eine Multicastübertragung

Wenn Sie Inhalt als Multicastdatenstrom von einem Windows Media-Server übermitteln möchten, muss der Server in der Lage sein, das Datenstromformat vom Encoder zu erkennen. Das Datenstromformat enthält Informationen, die von Playern zum Entschlüsseln eines Multicastdatenstroms verwendet werden, z. B. die Codecs, die Bitraten und Framegrößen. Das Format wird im Header des Datenstroms gespeichert. Wenn Sie mit der Codierung beginnen, bevor der Server die Verbindung mit dem Encoder initiiert, erkennt der Server automatisch das Datenstromformat. Wenn Sie jedoch nicht zuerst mit der Codierung beginnen möchten, können Sie eine Datei im Datenstromformat erstellen und diese dann dem Serveradministrator zur Verfügung stellen. Der Administrator kann die Datei zur Liste der unterstützten Datenstromformate auf dem Serverpublishingpoint hinzufügen. Dateien im Datenstromformat besitzen die Dateinamenerweiterung ASF.

Vorsicht Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung kann Ihr System schwerwiegend beschädigt werden. Ehe Sie Änderungen an der Registrierung vornehmen, sollten Sie alle wichtigen Daten auf dem Computer sichern.

Anmerkung Anmerkung

  • Dieser Abschnitt beschreibt nur die mit dem Encoder durchzuführenden Schritte, wenn ein Windows Media-Server den Datenstrom initiiert. Ausführliche Informationen zu den durchzuführenden Schritten auf dem Windows Media-Server finden Sie in der Hilfe zu Windows Media-Dienste.

Verwandte Themen

  • Übertragen von Liveinhalt
  • So aktivieren Sie Clients für das Anfordern eines Datenstroms vom Encoder per Pull
  • So erstellen Sie eine Datei im Datenstromformat
  • Vergleichen von Windows Media-Servern und Webservern
  • So vergrößern Sie die maximale Anzahl direkter Verbindungen


So aktivieren Sie Clients für das Anfordern eines Datenstroms vom Encoder per Pull

  1. Klicken Sie auf der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Ausgabe.
  2. Aktivieren Sie das Kontrollkästchen Vom Encoder anfordern.

Verwandte Themen

  • Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull


So erstellen Sie eine Datei im Datenstromformat

  1. Richten Sie eine Sitzung ein, die einen Windows Media-Server für das Anfordern des Datenstroms vom Encoder per Pull aktiviert.
  2. Klicken Sie im Menü Extras auf Formatdatei für Datenstrom generieren.
  3. Geben Sie unter Dateiname einen Namen und Speicherort für die Datei ein, und klicken Sie dann auf Speichern.
  4. Stellen Sie die Datei dem Windows Media-Serveradministrator zur Verfügung.

Anmerkung Anmerkung

  • Wenn Sie eine der Einstellungen in der Encoderkonfiguration ändern, müssen Sie eine weitere Datei im Datenstromformat erstellen und diese dann dem Windows Media-Serveradministrator zur Verfügung stellen.

Verwandte Themen

  • Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull
  • So aktivieren Sie Clients für das Anfordern eines Datenstroms vom Encoder per Pull


So vergrößern Sie die maximale Anzahl direkter Verbindungen

  1. Verwenden Sie im Registrierungs-Editor die Strukturansicht, um zu folgendem Unterschlüssel zu navigieren: HKEY_CLASSES_ROOT\Software\Microsoft\Windows Media Tools\Encoder\MaxClientConnections.
  2. Bearbeiten Sie den Unterschlüssel so, dass er die maximale Anzahl der direkten Verbindungen angibt, die zulässig sind. Die maximal mögliche Anzahl sind 50 Verbindungen.

Vorsicht Vorsicht

  • Durch eine fehlerhafte Bearbeitung der Registrierung kann Ihr System schwerwiegend beschädigt werden. Ehe Sie Änderungen an der Registrierung vornehmen, sollten Sie wichtige Daten auf dem Computer sichern.

Verwandte Themen

  • Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull


Beschränken des Zugriffs auf eine Übertragung

Wenn Sie Clients das Anfordern eines Datenstroms vom Encoder per Pull ermöglichen, können Sie den Zugriff auf die Übertragung auf der Basis einer statischen IP-Adresse oder von Gruppen von IP-Adressen gewähren oder verweigern. Standardmäßig ist es keinem Client untersagt, eine Verbindung zur Übertragung herzustellen. Wenn Sie die Clients angeben möchten, die Verbindungen herstellen dürfen, können Sie die IP-Adressen zur Zulassen-Liste hinzufügen. Auf diese Weise verhindern Sie, dass nicht aufgelistete Clients eine Verbindung herstellen können. Wenn Sie verhindern möchten, dass ein bestimmter Client auf die Übertragung zugreift, können Sie die IP-Adresse dieses Clients zur Verweigern-Liste hinzufügen.

Wenn Sie während der Codierung Änderungen an der IP-Adressliste vornehmen, werden diese Änderungen nur für Clients wirksam, die eine Verbindung herstellen, nachdem Sie die Änderungen übernommen haben. Wenn Sie z. B. eine IP-Adresse zur Verweigern-Liste hinzufügen, während der betreffende Client verbunden ist, wird der Client nicht getrennt. Wenn der Client jedoch die Verbindung trennt und dann versucht, eine erneute Verbindung mit der gleichen Übertragung herzustellen, wird ihm der Zugriff verweigert. Wenn es wichtig ist, einen Client sofort zu trennen, können Sie die Codierung beenden.

Die folgende Tabelle nennt Beispiele für die Reihenfolge, in der IP-Adressen abhängig von den von Ihnen eingerichteten Beschränkungen der Zugriff gewährt oder verweigert wird.

Zulassen-Liste | Verweigern-Liste | Ergebnis
Leer | Leer | Allen IP-Adressen wird der Zugriff gewährt.
Leer | IP-Adresse 1 | IP-Adresse 1 den Zugriff verweigern, allen anderen IP-Adressen den Zugriff gewähren.
IP-Adresse 1 | Leer | IP-Adresse 1 den Zugriff gewähren, allen anderen IP-Adressen den Zugriff verweigern.
IP-Adresse 1 | IP-Adresse 2 | IP-Adresse 1 den Zugriff gewähren, allen anderen IP-Adressen den Zugriff verweigern.
IP-Adresse 1 | IP-Adresse 1 | Allen IP-Adressen den Zugriff verweigern.
IP-Adresse 1, IP-Adresse 2 | IP-Adresse 1 | IP-Adresse 2 den Zugriff gewähren, allen anderen IP-Adressen den Zugriff verweigern.

Wenn Sie den Zugriff auf eine Übertragung über die IP-Adresse einschränken, können Sie Adressen im Format Internet Protocol, Version 6 (IPv6) sowie IPv4 (Internet Protocol, Version 4) angeben. IPv6 ist die aktuellste Version von Internet Protocol und wurde entwickelt, um dem schnell wachsenden Bedarf nach eindeutigen IP-Adressen gerecht zu werden. IPv6 erhöht die IP-Adressengröße von 32 Bit auf 128 Bit, damit mehr Hierarchieebenen für die Adressierung und eine größere Anzahl adressierbarer Knoten unterstützt werden können. Weitere Informationen zu IPv6 finden Sie auf der IPv6-Seite der Microsoft-Website.

Anmerkung Anmerkung

  • Sie können nachverfolgen, welche IP-Adressen Verbindungen zu Ihren Übertragungen herstellen, indem Sie die Protokollierung in eine Datei auf der Registerkarte Ereignisprotokoll im Fensterbereich Monitor aktivieren.

Verwandte Themen

  • Übertragen von Liveinhalt
  • So gewähren oder verweigern Sie den Zugriff auf eine Übertragung


So gewähren oder verweigern Sie den Zugriff auf eine Übertragung

  1. Klicken Sie im Menü Extras auf Übertragungssicherheit.
  2. Führen Sie eine der folgenden Aktionen aus:
    • Um den Zugriff auf einen Computer mit dem Encoder zu gewähren, klicken Sie unter Zulassen auf Hinzufügen.
    • Um den Zugriff auf einen Computer mit dem Encoder zu verweigern, klicken Sie unter Verweigern auf Hinzufügen.
  3. Geben Sie unter IP-Adresse die IP-Adresse des Computers ein, für den Sie den Zugriff zulassen oder verweigern möchten.

    - Oder -

    Geben Sie unter IP-Maske einen Bereich von IP-Adressen ein, für den Sie den Zugriff zulassen oder verweigern möchten.

  4. Klicken Sie auf Hinzufügen.
  5. Wiederholen Sie die Schritte 3 und 4, bis alle IP-Adressen hinzugefügt wurden.

Verwandte Themen

  • Beschränken des Zugriffs auf eine Übertragung


Testen des Inhalts

Es ist immer eine sinnvolle Entscheidung, den Inhalt zu testen, bevor Sie ihn Benutzern zur Verfügung stellen. Konfigurieren Sie zum Durchführen eines Tests eine Sitzung, und codieren Sie dann ein wenig Inhalt. Während der Inhalt codiert wird, verwenden Sie den URL, der auf der Registerkarte Verbindungen des Fensterbereichs Monitor angegeben wurde, um den Player mit dem Encoder zu verbinden und den Datenstrom anzuzeigen. Wenn Sie in eine Datei codieren, beenden Sie den Encoder, und geben Sie die Ausgabedatei dann wieder.

Wenn Sie die Verteilung des Inhalts über einen Windows Media-Server planen, können Sie einen End-to-End-Test durchführen. Richten Sie zu diesem Zweck den Windows Media-Server so ein, dass die Verbindung zum Encoder über den auf der Registerkarte Verbindungen im Fensterbereich Monitor angegebenen URL erfolgt.

Überprüfen Sie beim Anzeigen des Datenstroms Folgendes:

  • Sie erhalten die erwartete Framerate.
  • Der Bandbreitendurchsatz ist akzeptabel.
  • Sie erhalten einen Audio- und Videodatenstrom, und die Qualität beider Datenströme ist akzeptabel.

Weitere Informationen zum Ausstrahlen über einen Windows Media-Server finden Sie in der Hilfe zu Windows Media-Dienste.

Verwandte Themen

  • Ausgabeoptionen


Systemkonfigurationsoptionen

Dieser Abschnitt stellt Informationen zu den Optionen zur Verfügung, die zum Konfigurieren des Codierungssystems verfügbar sind (z. B. Informationen zum Sichern des Computers mit dem Encoder und zum Schützen des codierten Inhalts, Schritte zum Erzielen optimaler Systemleistung, Informationen zum Ausführen mehrerer Instanzen des Encoders auf einem Computer und zur Batchcodierung).

Verwandte Themen

  • Windows Media Encoder
  • Sicherheit und Windows Media Encoder
  • Erzielen optimaler Systemleistung
  • Empfohlene Vorgehensweisen bei den Komprimierungseinstellungen
  • Ausführen mehrerer Encoder auf einem Computer
  • Batchcodierung


Sicherheit und Windows Media Encoder

Sicherheitserwägungen für Windows Media Encoder umfassen sowohl Sicherheit für den Computer mit dem Encoder als auch das Schützen des Inhalts bei der Codierung. Wenn Sie mehr zu den Sicherheitsaspekten erfahren möchten, die sich auf den Computer mit dem Encoder beziehen, lesen Sie den Sicherheitsabschnitt der Dokumentation zum Betriebssystem.

Um den Inhalt zu schützen, können Sie während der Codierung DRM (Digital Rights Management) verwenden.

Wenn Sie einen Datenstrom übertragen, können Sie den Zugriff auf den Encoder auf der Grundlage von IP-Adressen einschränken. Außerdem können Sie IPSec (Internet Protocol Security) verwenden, eine Sammlung von Industriestandards, die Daten auf IP-Paketebene überprüft, authentifiziert und verschlüsselt. Weitere Informationen zu IPSec finden Sie im Windows-Hilfe und -Supportcenter.

Wenn Sie Inhalt für die Übertragung von einem Windows Media-Server codieren, finden Sie Informationen zu Sicherheit und Windows Media-Server in der Hilfe zu Windows Media-Dienste.

Verwandte Themen

  • Systemkonfigurationsoptionen
  • Verwenden von Digital Rights Management zum Schützen von Inhalt
  • Beschränken des Zugriffs auf eine Übertragung


Erzielen optimaler Systemleistung

So erzielen Sie eine optimale Systemleistung:

  • Verwenden Sie einen Computer mit einem schnellen oder mehreren Prozessoren. Da für das Codieren mit hoher Qualität eine größere Verarbeitungsleistung erforderlich ist, sollten Sie einen Computer mit einem schnellen Prozessor oder mehreren Prozessoren verwenden, insbesondere für Liveereignisse. Windows Media Encoder kann bis zu zwei Prozessoren für Audioinhalt und bis zu vier Prozessoren für Videoinhalt verwenden, um die Codierungslast effizient zu verteilen. Wenn Sie den Windows Media Video 9-Codec verwenden, können Sie die Leistungseinstellungen ebenfalls anpassen, um den Codierungserfolg sicherzustellen. Als allgemeine Regel sollten Sie das Aufrüsten des Computers in Betracht ziehen, wenn Sie regelmäßig 80 % der CPU-Auslastung erreichen oder überschreiten (diese Auslastung wird auf der Registerkarte Allgemein im Fensterbereich Monitor angezeigt).
  • Verwenden Sie unterstützte Audio- und Videoaufnahmekarten. Eine vollständige Liste der unterstützten Aufnahmekarten finden Sie auf der Microsoft-Website.
  • Verwenden Sie Microsoft Windows XP Professional. Windows XP Professional nutzt alle Vorteile von Mehrprozessorcomputern durch automatisches Erzeugen separater Threads, so dass Prozesse verschiedene Teile ihrer Programme auf verschiedenen Prozessoren gleichzeitig ausführen können. Diese Zerlegung der Aufgaben ermöglicht das Ausführen von High-End-Codierungsaufgaben, ohne die CPU-Verwendung zu maximieren.
  • Überprüfen Sie die Netzwerkbandbreite. Sie werden nur selten einen Durchsatz von 100 % erreichen, wenn Sie Inhalt über ein Netzwerk senden. Stellen Sie für optimale Ergebnisse sicher, dass das Netzwerk die Gesamtbandbreite zur Verfügung stellen kann, die für die Übertragungssitzung benötigt wird, sowie den Overhead für HTTP.
  • Verwenden Sie eine Hochleistungsfestplatte. Verwenden Sie zur Archivierung oder Dateikonvertierung eine Hochleistungsfestplatte, z. B. eine SCSI-Festplatte (Small Computer System Interface) mit 15.000 Umdrehungen pro Minute. Das Verwenden einer Hochleistungsfestplatte kann das Verlagern der Leistungsanforderungen vom Zentralprozessor (Central Processing Unit, CPU) unterstützen und auf diese Weise eine größere Verarbeitungsleistung für die Codierung freigeben. Außerdem ist es sinnvoll, die Festplatte ausschließlich zu Codierungszwecken zu verwenden.
  • Führen Sie den Encoder auf einem dedizierten Computer aus. Wenn Sie Inhalt von einem Server ausstrahlen, der Windows Media-Dienste ausführt, sollten Sie den Encoder auf einem anderen Computer als dem Windows Media-Server auszuführen.
  • Deaktivieren Sie Videovorschau und -nachbetrachtung. Die Bereiche Eingabe und Ausgabe im Hauptfenster des Encoders zeigen, wie der Inhalt vor und nach der Codierung aussieht. Wenn Sie diese Anzeigen deaktivieren, wird die Codierungsleistung verbessert. Um eine kleine Leistungsverbesserung zu erzielen, können Sie die Ansichten auch verkleinern.
  • Speichern Sie aufgezeichneten Inhalt vorübergehend. Wenn Sie mit Geräten als Quelle in eine Datei codieren, speichern Sie den Inhalt vorübergehend auf einer Festplatte. Verwenden Sie außerdem eine andere Festplatte als die, die für Codierung reserviert wurde.

Verwandte Themen

  • Systemkonfigurationsoptionen
  • Anpassen von Leistungseinstellungen des Encoders
  • So deaktivieren oder verkleinern Sie die Videovorschau
  • Verbessern der Leistung beim Codieren von Bildschirmen
  • So speichern Sie aufgezeichneten Inhalt vorübergehend


So deaktivieren oder verkleinern Sie die Videovorschau

  1. Klicken Sie im Menü Ansicht auf Video.
  2. Um die Videovorschau zu deaktivieren, klicken Sie unter Anzeige auf Ausgabe.

    - Oder -

    Um die Größe der Vorschau zu verkleinern, klicken Sie unter Zoom auf 50%.

Verwandte Themen

  • Erzielen optimaler Systemleistung


Anpassen von Leistungseinstellungen des Encoders

Das Codieren von Inhalt ist ein CPU-intensiver Vorgang. Wenn Sie die Kapazität des Computers mit dem Encoder laufend überschreiten, können Sie die aktuellsten Hardware- und Softwareanforderungen zu Rate ziehen und ermitteln, ob Sie auf einen leistungsfähigeren Computer aufrüsten sollten. Wenn eine Aufrüstung nicht möglich ist, können Sie die Leistungseinstellungen des Encoders anpassen, um den Codierungserfolg sicherzustellen. (Diese Einstellungen gelten nur für Sitzungen, in denen Sie den Windows Media Video 9-Codec verwenden.) Die Auswahlmöglichkeiten zur Leistung beziehen sich auf den Schwerpunkt bessere Leistung oder bessere Qualität. Eine bessere Leistungseinstellung entspricht einer geringeren CPU-Verwendung; eine bessere Qualitätseinstellung entspricht einer höheren Auslastung der CPU-Leistung. Sie sollten folgende Punkte beachten, wenn Sie Leistungseinstellungen auswählen.

  • Wenn die für die Codierung benötigte Zeit nicht wichtig ist, können Sie die Einstellung für bessere Qualität verwenden. Diese Auswahl eignet sich am besten für ein Szenario, in dem Sie eine Datei als Quelle verwenden und in eine Datei codieren. Der Encoder codiert in dem Tempo, das für die Codierung erforderlich ist.
  • Wenn es wichtig ist, dass die Codierung mit der Aufzeichnung Schritt hält, verwenden Sie die Einstellung für bessere Leistung. Diese Auswahl eignet sich am besten für ein Szenario, in dem Sie Inhalt übertragen, oder für ein Szenario, in dem Sie Geräte als Quelle verwenden und in eine Datei codieren. Für das Szenario, in dem in eine Datei codiert wird, können Sie auch vorübergehende Speicherung des aufgezeichneten Inhalts aktivieren. Bei der vorübergehenden Speicherung werden die aufgezeichneten Daten vorübergehend gespeichert, wenn der Codierungsvorgang hinter den Aufzeichnungsvorgang zurückfällt.

Für alle genannten Szenarien können Sie verschiedene Leistungseinstellungen ausprobieren, um ein ausgewogenes Verhältnis zwischen Qualität und Leistung für Ihren Computer zu ermitteln. Denken Sie daran, dass auch andere Faktoren die CPU-Auslastung während der Codierung beeinflussen. Sitzungseinstellungen (wie z. B. die Framerate, Bitrate und Framegröße) beeinflussen, welche Leistung die CPU zum Durchführen der Codierung erbringen muss. Außerdem verbleibt durch andere Programme, die auf dem Computer mit dem Encoder ausgeführt werden, weniger Verarbeitungsleistung für den Encoder.

Verwandte Themen

  • Erzielen optimaler Systemleistung
  • Hardware- und Softwareanforderungen
  • Codieren oder Archivieren einer Übertragung in einer Datei
  • So passen Sie die Leistungseinstellungen an
  • So speichern Sie aufgezeichneten Inhalt vorübergehend


So passen Sie die Leistungseinstellungen an

  1. Klicken Sie im Menü Extras auf Optionen und dann auf die Registerkarte Leistung.
  2. Verschieben Sie unter Bei der Übertragung den Schieberegler auf die gewünschte Einstellung.
  3. Verschieben Sie unter Beim Codieren in eine Datei den Schieberegler auf die gewünschte Einstellung.

Verwandte Themen

  • Anpassen von Leistungseinstellungen des Encoders


Empfohlene Vorgehensweisen bei den Komprimierungseinstellungen

Zwischen mehreren Komprimierungseinstellungen besteht ein Gleichgewicht. Der Encoder enthält viele vordefinierte Ziel-, Video- und Audioeinstellungen (Profile), bei denen dieses Gleichgewicht bereits berücksichtigt wurde. Sie können mit einem vordefinierten Profil auf einfache Weise eine Codierungssitzung einrichten. Wenn Sie die Einstellungen jedoch anpassen möchten, stellen die folgenden Abschnitte Informationen zu den Einstellungen zur Verfügung und nennen außerdem einige der Nachteile, die berücksichtigt werden sollten.

  • Puffer. Ein größerer Puffer kann eine bessere Bildqualität ermöglichen, der Benutzer muss jedoch länger auf den Start des Videos warten, weil der Player mit der Wiedergabe wartet, bis der Puffer gefüllt ist. Normalerweise entspricht die Pufferverzögerung der Zeit (in Sekunden) der Puffergröße, die im Encoder festgelegt wurde. Wenn Sie die Ausstrahlung jedoch von einem Windows Media-Server planen, können Sie im Encoder eine größere Puffergröße festlegen. Schnellstart, eine Funktion von Windows Media-Dienste, ermöglicht einem Player das Füllen des Puffers schneller als in Echtzeit, wenn ausreichend Bandbreite verfügbar ist. Dies bedeutet, dass die anfängliche Pufferverzögerung möglicherweise viel kürzer ist. Wenn ein Benutzer z. B. versucht, mit 56 Kbit/s codierten Inhalt mit einem DSL- oder Kabelmodem wiederzugeben, kann die Startverzögerung selbst dann, wenn die während der Codierung festgelegte Puffergröße viel länger war, nur eine oder zwei Sekunden betragen. Weitere Informationen zum Schnellstart finden Sie in der Hilfe zu Windows Media-Dienste.

    Wenn Sie eine Sitzung eingerichtet haben, die auf maximalen Bitraten basierende VBR-Codierung für Audioinhalt verwendet, sollte die maximale Puffergröße für Audio niedriger als die Puffergröße für Video (wenn Sie CBR-Codierung für Video verwenden) oder die maximale Puffergröße für Video (wenn Sie auf maximalen Bitraten basierende VBR-Codierung für Video verwenden) sein.

  • Bitrate. Eine höhere Bitrate erzielt eine bessere Bildqualität. Wenn die Bitrateneinstellung zu niedrig ist, verwirft der Codec Frames, um ein Bild mit höherer Qualität zu erzeugen. Diese Vorgehensweise ist für den Betrachter möglicherweise nicht sichtbar. (Beachten Sie, dass die tatsächliche Bitrate beim Codieren von Video mit wenig Bewegung erheblich niedriger als die erwartete Bitrate sein kann.)
  • Framerate. Zwischen Bildqualität und Framerate besteht insofern eine Beziehung, als die Framerate bei zunehmender Bildqualität abnimmt. Wenn das Beibehalten der Framerate wichtiger ist, können Sie die Einstellung für die Bildqualität verringern.
  • Bildqualität (Gleichmäßigkeit). Sie können die Bildqualität hinsichtlich Gleichmäßigkeit oder Schärfe anpassen. Eine größere Schärfe kann sich je nach Video auf die Framerate auswirken. Wenn Ihr Video beispielsweise sehr viel Bewegung enthält, wird durch Erhöhen der Schärfe möglicherweise die Framerate verringert. Außerdem führt das Erhöhen der Schärfe zu einer höheren Bitratenanforderung und kann möglicherweise auch das Erhöhen der Puffergröße erfordern.
  • Framegröße. Je größer die Framegröße ist, desto höher ist die Bitratenanforderung.
  • Schlüsselframes. Wenn Sie einen längeren Schlüsselframeabstand verwenden, werden bei Bedarf zusätzliche Schlüsselframes eingefügt, z. B. dann, wenn sich eine Szene ändert. Für Inhalt mit wenig Bewegung ist normalerweise eine Einstellung von 20 Sekunden geeignet. Für Inhalt mit einer höheren Bitrate sollten Sie den Schlüsselframeabstand verringern.
  • Codecs. Verwenden Sie den geeigneten Codec für die Sitzung. Wenn die Audioquelle z. B. Sprache oder hauptsächlich Sprache ist, verwenden Sie den Windows Media Audio 9 Voice-Codec. Für eine Bildschirmaufzeichnungssitzung verwenden Sie den Windows Media Video 9 Screen-Codec.
  • Codierung mit zwei Durchläufen. Sie erzielen normalerweise eine bessere Qualität bei Codierung mit zwei Durchläufen, weil der Encoder die Möglichkeit zum Analysieren des Inhalts während des ersten Durchlaufs besitzt.
  • Videogrößenanpassung. Richten Sie für den Ausgabeframe und den Eingabeframe die gleiche Größe ein. Verwenden Sie nicht den Encoder, um die Größe des Quellvideos zu ändern.

Verwandte Themen

  • Systemkonfigurationsoptionen
  • Erzielen optimaler Systemleistung
  • Optimieren von Audio für Sprachaufnahmen
  • Verbessern der Leistung beim Codieren von Bildschirmen
  • Grundlegendes zu Codecs
  • Informationen zu Codierungen mit einem Durchlauf oder zwei Durchläufen
  • So passen Sie die Framegröße des Quellvideos an


Ausführen mehrerer Encoder auf einem Computer

Sie können mehrere Instanzen von Windows Media Encoder auf einem Computer ausführen, wenn der Computer leistungsfähig genug ist, um diese Vorgehensweise zu unterstützen. Indem Sie mehrere Instanzen des Encoders ausführen, können Sie folgende Aufgaben durchführen:

  • Gleichzeitiges Übertragen separater Datenströme mit verschiedenen Bitraten.
  • Gleichzeitiges Konvertieren mehrerer Dateien in das Windows Media-Format.
  • Verwenden eines Geräts mit mehreren Anschlüssen als Quelle und anschließendes Ausstrahlen des codierten Inhalts von jedem Anschluss an verschiedene Orte.

Wenn Sie sich entscheiden, mehrere Encoder auf einem Computer auszuführen, denken Sie daran, dass Eingabegeräte nur von jeweils einem Prozess gleichzeitig verwendet werden können. Aus diesem Grund sollten Sie die Installation mehrerer Audio- und Videoaufzeichnungskarten in Betracht ziehen. Verwenden Sie einen Computer mit zwei oder mehr Prozessoren, um die optimale Leistung zu erzielen.

Verwandte Themen

  • Systemkonfigurationsoptionen


Batchcodierung

Wenn Sie mehrere Audio- und Videodateien codieren möchten, können Sie Windows Media-Codierungsskript verwenden, das in Windows Media Encoder enthalten ist. Sie können den Encoder auch für Batchcodierung automatisieren, indem Sie ein Skript und Windows Script Host verwenden.

Weitere Informationen zu Windows Script Host und Batchcodierung finden Sie im SDK (Software Development Kit) von Windows Media Encoder 9-Reihe.

Verwandte Themen

  • Systemkonfigurationsoptionen
  • Informationen zu den Encoder-Dienstprogrammen


Häufig gestellte Fragen (FAQ) und Problembehandlung

Aktuelle Informationen zum Verwenden des Encoders finden Sie auf der Windows Media-Seite der Microsoft-Website.


Eingabehilfen für Personen mit Behinderungen

Microsoft hat es sich zur Aufgabe gemacht, die Handhabung der Produkte und Dienste für jeden möglichst einfach zu gestalten. Die folgenden Themen enthalten Informationen zu den Features, Produkten und Diensten, mit denen Microsoft Windows Media Encoder für Personen mit Behinderungen einfacher einzusetzen ist.

  • Eingabehilfen in Windows Media Encoder
  • Eingabehilfen in der Hilfe zu Windows Media Encoder
  • Verfügbare Produkte und Dienste von Microsoft

Anmerkung Anmerkung

  • Die Informationen in diesem Abschnitt gelten nur für Benutzer, die in den USA eine Lizenz für Microsoft-Produkte erworben haben. Wenn Sie dieses Produkt außerhalb der USA erworben haben, ist in der Verpackung ein Informationsblatt der Niederlassung in Ihrer Nähe mit den Telefonnummern und Adressen von Microsoft Support Services enthalten. Bei dieser Niederlassung können Sie auch erfahren, ob die in diesem Abschnitt genannten Produkte und Dienste in Ihrer Region verfügbar sind. Die Informationen zu Eingabehilfen stehen auch in einigen anderen Sprachen zur Verfügung, u. a. auf Japanisch und Französisch. Weitere Informationen finden Sie auf der Microsoft-Website.


Eingabehilfen in Windows Media Encoder

Zusätzlich zu den Eingabehilfen und Dienstprogrammen in Windows erleichtern die folgenden Features Personen mit Behinderungen den Umgang mit Windows Media Encoder-Diensten:

  • Verwenden von Tastenkombinationen

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Verwenden von Tastenkombinationen

Mithilfe der folgenden Tastenkombinationen in Windows Media Encoder können Sie schnell zahlreiche allgemeine Aufgaben ausführen.

Zweck | Tastenkombination
Anzeigen der kontextbezogenen Hilfe | F1
Vorwärtsblättern durch die Optionen in einem Dialogfeld oder Eigenschaftenblatt | TAB
Rückwärtsblättern durch die Optionen in einem Dialogfeld oder Eigenschaftenblatt | UMSCHALT+TAB
Bildlauf nach oben um ein Element in einem Drehfeld oder in einer Dropdownliste | NACH-OBEN-TASTE
Bildlauf nach unten um ein Element in einem Drehfeld oder in einer Dropdownliste | NACH-UNTEN-TASTE
Bildlauf vorwärts durch Registerkarten | NACH-RECHTS-TASTE
Bildlauf rückwärts durch Registerkarten | NACH-LINKS-TASTE
Aktualisieren des aktuellen Dialogfelds oder Steuerelements (Aktualisieren der Plug-In-Liste, Aktualisieren der Wiedergabeliste) | F5 oder STRG+R
Schließen eines Eigenschaftenblatts oder Dialogfelds bzw. Abbrechen eines Assistenten | ESC
Durchführen des Befehls für die aktive Option oder Schaltfläche | EINGABETASTE
Ausschneiden der markierten Elemente und Kopieren dieser Elemente in die Zwischenablage | STRG+X
Kopieren der markierten Elemente in die Zwischenablage | STRG+C
Einfügen des Inhalts der Zwischenablage an der ausgewählten Position | STRG+V
Anzeigen oder Ausblenden des Fensterbereichs Sitzungseigenschaften | ALT+EINGABETASTE
Schließen des aktuellen Fensters | ALT+F4
Anzeigen des Kontextmenüs | UMSCHALT+F10
Markieren oder Löschen der Markierung eines Elements | LEERTASTE
Anzeigen des Kontextmenüs | Anwendungstaste
Wechseln in den Kontrastmodus | LINKE ALT-TASTE+LINKE UMSCHALTTASTE+DRUCK-TASTE

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Eingabehilfen in der Hilfe zu Windows Media Encoder

Die Hilfe zu Windows Media Encoder stellt Features bereit, mit denen das Programm einer größeren Gruppe von Benutzern zur Verfügung gestellt werden kann. Zu diesen Benutzern zählen auch Personen mit eingeschränkter Beweglichkeit, Sehstörungen oder anderen Behinderungen.

Zudem steht die Hilfe zu Windows Media Encoder auch im Internet auf der Microsoft-Website zur Verfügung.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Tastenkombinationen für die Verwendung des Hilfefensters

Mithilfe der folgenden Tastenkombinationen in der Hilfe können Sie schnell zahlreiche allgemeine Aufgaben ausführen.

Zweck | Tastenkombination
Anzeigen des Hilfefensters | F1
Wechseln zwischen dem Hilfethema und den Registerkarten Inhalt, Suchen und Index | F6
Markieren des nächsten verborgenen Textes oder Hyperlinks | TAB
Markieren des vorherigen verborgenen Textes oder Hyperlinks | UMSCHALT+TAB
Durchführen der Aktion für die markierte Option Alle anzeigen, Alle ausblenden bzw. für ausgeblendeten Text oder Hyperlinks | EINGABETASTE
Anzeigen des Menüs Optionen für den Zugriff auf einen Symbolleistenbefehl der Hilfe | ALT+O
Ein- oder Ausblenden des Bereichs mit den Registerkarten Inhalt, Suchen und Index | ALT+O, anschließend T
Anzeigen des zuvor angezeigten Themas | ALT+O, anschließend Z
Anzeigen des nächsten Themas in einer zuvor angezeigten Folge von Themen | ALT+O, anschließend V
Zurückkehren zur angegebenen Homepage | ALT+O, anschließend S
Anhalten des Vorgangs, bei dem die Hilfe ein Hilfethema öffnet (nützlich, wenn Sie das Downloaden einer Webseite abbrechen möchten) | ALT+O, anschließend A
Öffnen des Dialogfelds Internetoptionen für Microsoft Internet Explorer, in dem die Einstellungen für die Eingabehilfen geändert werden können | ALT+O, anschließend I
Aktualisieren des Themas (nützlich, wenn eine Verbindung zu einer Webseite hergestellt wurde) | ALT+O, anschließend K
Drucken aller Themen in einem Buch oder nur eines ausgewählten Themas | ALT+O, anschließend D
Schließen des Hilfefensters | ALT+F4

Verwandte Themen

  • Eingabehilfen in der Hilfe zu Windows Media Encoder


So ändern Sie die Darstellung eines Hilfethemas

  1. Wenn Sie die in der Hilfe verwendeten Farben, Schriftarten und Schriftgrade anpassen möchten, öffnen Sie das Hilfefenster.
  2. Klicken Sie auf Optionen, und klicken Sie dann auf Internetoptionen.
  3. Klicken Sie auf der Registerkarte Allgemein auf Eingabehilfen. Wählen Sie die Optionen Farbangaben auf Webseiten ignorieren, Schriftartangaben auf Webseiten ignorieren und Schriftgradangaben auf Webseiten ignorieren. Sie können auch angeben, dass die auf Ihrem eigenen Stylesheet angegebenen Einstellungen verwendet werden sollen.
  4. Informationen zum Ändern der in der Hilfe verwendeten Farben finden Sie unter So ändern Sie die Hintergrund- oder Textfarbe in der Hilfe. Informationen zum Ändern der Schriftart finden Sie unter So ändern Sie die Schriftart in der Hilfe.

Verwandte Themen

  • Eingabehilfen in der Hilfe zu Windows Media Encoder


So ändern Sie die Hintergrund- oder Textfarbe in der Hilfe

  1. Öffnen Sie das Hilfefenster.
  2. Klicken Sie auf Optionen, und klicken Sie dann auf Internetoptionen.
  3. Klicken Sie auf der Registerkarte Allgemein auf Eingabehilfen. Wählen Sie dann die Option Farbangaben auf Webseiten ignorieren. Sie können auch angeben, dass die auf Ihrem eigenen Stylesheet angegebenen Einstellungen verwendet werden sollen.
  4. Wenn Sie die in der Hilfe verwendeten Farben anpassen möchten, klicken Sie auf der Registerkarte Allgemein auf Farben. Deaktivieren Sie das Kontrollkästchen Windows-Farben, und wählen Sie dann die gewünschte Schriftart und die gewünschten Hintergrundfarben aus.

Anmerkung Anmerkung

  • Wenn Sie die Hintergrundfarbe für die Hilfethemen im Hilfefenster ändern, wirkt sich diese Änderung auch auf die Hintergrundfarbe aus, die beim Anzeigen einer Webseite in Microsoft Internet Explorer verwendet wird.

Verwandte Themen

  • Eingabehilfen in der Hilfe zu Windows Media Encoder


So ändern Sie die Schriftart in der Hilfe

  1. Öffnen Sie das Hilfefenster.
  2. Klicken Sie auf Optionen, und klicken Sie dann auf Internetoptionen.
  3. Klicken Sie auf der Registerkarte Allgemein auf Eingabehilfen. Wenn Sie dieselben Einstellungen wie in Ihrer Instanz von Microsoft Internet Explorer verwenden möchten, aktivieren Sie Schriftartangaben auf Webseiten ignorieren und Schriftgradangaben auf Webseiten ignorieren. Sie können auch angeben, dass die auf Ihrem eigenen Stylesheet angegebenen Einstellungen verwendet werden sollen.
  4. Wenn Sie den in der Hilfe verwendeten Schriftschnitt ändern möchten, klicken Sie auf der Registerkarte Allgemein auf Schriftarten, und klicken Sie dann auf den gewünschten Schriftschnitt.

Anmerkung Anmerkung

  • Wenn Sie die Schriftart für die Hilfethemen im Hilfefenster ändern, wirkt sich diese Änderung auch auf die Schriftart aus, die beim Anzeigen einer Webseite in Microsoft Internet Explorer verwendet wird.

Verwandte Themen

  • Eingabehilfen in der Hilfe zu Windows Media Encoder


Verfügbare Produkte und Dienste von Microsoft

Diese Hilfedatei enthält Informationen zu den folgenden Features, Produkten und Diensten, mit denen dieses Microsoft-Produkt für Personen mit Behinderungen einfacher zu verwenden ist.

  • Eingabehilfen in Microsoft Windows
  • Anpassen von Microsoft-Produkten für Personen mit Behinderungen
  • Kostenlose Lernprogramme mit schrittweiser Anleitung
  • Microsoft-Dokumentation in alternativen Formaten
  • Unterstützende Technologien für Windows
  • Microsoft-Dienste für Gehörlose oder Hörgeschädigte
  • Weitere Informationen zu Eingabehilfen

Anmerkung Anmerkung

  • Die Informationen in diesem Abschnitt gelten nur für Benutzer, die in den USA eine Lizenz für Microsoft-Produkte erworben haben. Wenn Sie dieses Produkt außerhalb der Vereinigten Staaten gekauft haben, enthält Ihr Paket eine Karte mit Informationen der Niederlassung, auf der Telefonnummern und Adressen der Microsoft Support-Dienste angegeben sind. Sie können sich an eine Niederlassung wenden, um herauszufinden, ob die in dieser Hilfedatei beschriebenen Produkte und Dienste in Ihrer Region erhältlich sind. Die Informationen zu Eingabehilfen stehen auch in einigen anderen Sprachen zur Verfügung, unter anderem auf Japanisch und Französisch. Weitere Informationen finden Sie auf der Microsoft-Website.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Eingabehilfen in Microsoft Windows

Ab Windows 95 sind Eingabehilfen im Lieferumfang von Windows enthalten. Diese Features sind hilfreich für Personen, die Probleme bei der Eingabe oder im Umgang mit der Maus haben, sowie für Personen mit leichten Sehstörungen oder Gehörlose und Hörgeschädigte. Diese Features können während des Setups installiert werden. Weitere Informationen zu den verschiedenen Eingabehilfen von Microsoft-Produkten, wie Microsoft Windows XP Professional, Windows XP Home Edition, Windows Millennium Edition, Windows 2000, Windows 98 und Windows 95 finden Sie auf der Microsoft-Website.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Anpassen von Microsoft-Produkten für Personen mit Behinderungen

Viele Microsoft-Produkte enthalten Optionen und Features zu Eingabehilfen, u. a. das Windows-Betriebssystem. Diese Optionen und Features zu Eingabehilfen sind hilfreich für Personen, die Probleme bei der Eingabe oder im Umgang mit der Maus haben, sowie für Personen mit leichten Sehstörungen oder Gehörlose und Hörgeschädigte.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Kostenlose Lernprogramme mit schrittweiser Anleitung

Microsoft bietet eine Reihe von Lernprogrammen mit schrittweiser Anleitung, mit deren Hilfe Sie die Optionen und Einstellungen der Eingabehilfen auf Ihrem Computer anpassen können. Die Lernprogramme enthalten ausführliche Verfahren, wie Optionen, Features und Einstellungen angepasst werden, um den Anforderungen von Personen mit Behinderungen gerecht zu werden. Diese Informationen werden Seite für Seite angezeigt, so dass Sie auf einen Blick sehen können, wie die Maus, die Tastatur oder eine Kombination aus beidem verwendet wird.

Lernprogramme mit schrittweiser Anleitung für Microsoft-Produkte finden Sie im Abschnitt "Accessibility" auf der Microsoft-Website.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Microsoft-Dokumentation in alternativen Formaten

Neben den standardmäßigen Dokumentationsformaten sind viele Microsoft-Produkte auch in anderen Formaten erhältlich, um den Zugriff auf diese Produkte zu erleichtern.

Sollten Sie Sehstörungen oder Schwierigkeiten beim Umgang mit gedruckter Dokumentation haben, können Sie viele Veröffentlichungen von der Bundesarbeitsgemeinschaft Hilfe für Behinderte beziehen.
Die Bundesarbeitsgemeinschaft wird Ihnen direkte Ansprechpartner nennen oder Sie an eine regionale Organisation verweisen. Der deutsche Blindenverband e.V. bietet Ihnen z. B. die Möglichkeit, gedruckte Informationen auf Audiokassette o. ä. über sein BIT-Zentrum besprechen zu lassen.

Wenden Sie sich unter der folgenden Adresse und Telefonnummer an die Bundesarbeitsgemeinschaft Hilfe für Behinderte oder an eine der untergeordneten Organisationen, um weitere Informationen zum Bezug dieser Produkte und die Verfügbarkeit von Microsoft-Produktdokumentationen und -Büchern zu erfahren:

Bundesarbeitsgemeinschaft Hilfe für Behinderte Kirchfeldstraße 149 40215 Düsseldorf | Telefon: Fax: World Wide Web: | 0211-310060 0211-64004-20 http://www.paritaet.org/bvkm
Deutscher Blindenverband e.V. Bismarckallee 30 53173 Bonn | Telefon: | 0228-955820
Bit-Zentrum des bayrischen Blindenbundes Umsetzung in Blindenschrift, Maxidruck, Audio | Telefon: Fax: World Wide Web: E-Mail: | 089-559880 089-55988266 http://www.bayer-blindenbund.de LG@bayer-blindenbund.de
VdK Deutschland Wurzerstr. 4A 53175 Bonn | Telefon: Fax: World Wide Web: | 0228-820930 0228-8209343 http://www.vdk.de
Deutsche Zentralbücherei für Blinde zu Leipzig (DZB) Gustav-Adolf-Straße 7 04105 Leipzig | Telefon: | 0341-71130

Webadressen können sich ändern, daher können beim Herstellen einer Verbindung zu den hier genannten Websites Probleme auftreten.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Unterstützende Technologien für Windows

Es steht eine Reihe von Eingabehilfen oder Produkten für unterstützende Technologien zur Verfügung, damit Computer für Personen mit Behinderungen einfacher einzusetzen sind.

Microsoft bietet im Abschnitt "Accessibility" auf der Microsoft-Website einen durchsuchbaren Katalog mit Eingabehilfen, die unter Microsoft Windows-Betriebssystemen ausgeführt werden.

Zu den verfügbaren Produkten für die Betriebssysteme MS-DOS, Windows und Windows NT gehören u. a.:

  • Programme, die die angezeigten Informationen vergrößern oder die Farbe der auf dem Bildschirm dargestellten Informationen für Personen mit Sehstörungen verändern.
  • Programme, die die Informationen auf dem Bildschirm in Braille schreiben, oder künstliche Sprache für Personen, die blind sind oder Schwierigkeiten beim Lesen haben.
  • Hardware- und Softwaredienstprogramme, die das Verhalten von Maus und Tastatur verändern.
  • Programme, die Personen das Tippen durch die Verwendung einer Maus oder ihrer Stimme erleichtern.
  • Wort- oder Ausdruckvorhersagesoftware, die Benutzern ein schnelleres Tippen mit weniger Tastenanschlägen ermöglicht.
  • Alternative Eingabegeräte, wie Maus-Simulatoren oder Saug- und Blasgeräte für Personen, die keine Maus oder Tastatur verwenden können.

Aktualisierung

Wenn Sie bei der Aktualisierung Ihrer Software oder Hardware unterstützende Technologien verwenden, müssen Sie sich an Ihren Händler für unterstützende Technologien wenden, um die Kompatibilität mit den auf Ihrem Computer verwendeten Produkten zu prüfen. Ihr Händler für unterstützende Technologien unterstützt Sie auch in der Anpassung Ihrer Einstellungen für eine Optimierung der Kompatibilität mir Ihrer Windows-Version oder anderen Microsoft-Produkten.


Microsoft-Dienste für Gehörlose oder Hörgeschädigte

Gehörlose oder Hörgeschädigte haben über einen Texttelefondienst (TT/TDD) Zugriff auf alle Produkt- und Kundendienste von Microsoft.

Vertriebsinformationen

Sie können sich per Texttelefon an das Microsoft Sales Information Center (Microsoft-Zentrum für Vertriebsinformationen) wenden, indem Sie zwischen 6:30 und 17:30 (Pacific Time) die Nummer (001-800) 892-5234 wählen.

Technischer Kundendienst

Für technischen Kundendienst in den USA können Sie sich in den USA per Texttelefon an das Microsoft Support Network unter der Rufnummer (001-425) 635-4948 zwischen 6:00 und 18:00 Uhr (Pacific Time) von Montag bis Freitag (Feiertage ausgenommen) wenden. In Kanada gilt die Rufnummer (001-905) 568-9641 zwischen 8:00 und 20:00 Uhr (Eastern Time), Montag bis Freitag (Feiertage ausgenommen). Für den technischen Kundendienst von Microsoft gelten die zum jeweiligen Zeitpunkt geltenden Preise, Bestimmungen und Bedingungen.

Die Bundesarbeitsgemeinschaft Hilfe für Behinderte kann Ihnen lokale Ansprechpartner nennen oder Sie an eine regionale Organisation verweisen.

Wenden Sie sich unter der folgenden Adresse und Telefonnummer an die Bundesarbeitsgemeinschaft Hilfe für Behinderte oder an eine der weiterführenden Organisationen, um weitere Informationen zu erhalten:

Bundesarbeitsgemeinschaft Hilfe für Behinderte Kirchfeldstrasse 149 40215 Düsseldorf | Telefon: Fax: | 0211-310060 0211-3100648
Deutscher Gehörlosenbund Paradeplatz 3 24768 Rendsburg | Telefon/Texttelefon: | 04331-589722
Deutscher Schwerhörigenbund Breite Str. 3 13187 Berlin | Telefon: | 030-47541114
VdK Deutschland Wurzerstr. 4A 53175 Bonn | Telefon: Fax: World Wide Web: | 0228-820930 0228-8209343 http://www.vdk.de

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Weitere Informationen zu Eingabehilfen

Der Abschnitt "Accessibility" auf der Microsoft-Website bietet Informationen zu den Technologien, die die Lebensumstände von Personen mit Behinderungen verbessern sollen, indem Computer auf dem Arbeitsmarkt sowie im Bildungs- und Freizeitbereich positiv eingeführt werden. Die Informationen auf dieser Website sind hilfreich für Personen mit Behinderungen und deren Freunde und Familienmitglieder sowie für Personen in abgelegenen Unternehmen, Schulungsbeauftragte und Anwälte.

Über E-Mail erhalten Sie einen kostenlosen monatlichen Newsletter, der Sie immer über die aktuellsten Themen zu Eingabehilfen über Microsoft-Produkte informiert, die Sie im Abschnitt "Accessibility" auf der Microsoft-Website erwerben können.

Verwandte Themen

  • Eingabehilfen für Personen mit Behinderungen


Glossar

Um einen Begriff im Glossar zu finden, klicken Sie auf den Buchstaben, der dem ersten Buchstaben des gesuchten Begriffs entspricht.

Sie können auch Glossarbegriffe innerhalb der Hilfe nachlesen, indem Sie auf die unterstrichenen Hyperlinks für die Glossareinträge klicken. Wenn Sie auf einen Glossarhyperlink geklickt haben, werden der Glossarbegriff und die entsprechende Definition in einem Popupfenster angezeigt. Zum Schließen des Fensters klicken Sie auf eine beliebige Stelle in diesem Fenster.

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Abtasten

Der Prozess des Messens der Amplitude eines analogen Signals in regelmäßigen Abständen zum Zweck der Signalkonvertierung in ein digitales Format.

Abtastrate

Die Häufigkeit des Abtastens. Je höher die Abtastrate (d. h., je mehr Proben pro Zeiteinheit genommen werden), desto ähnlicher ist das digitalisierte Ergebnis dem Original.

Ankündigung

Eine Windows Media-Metadatei, die einem Player die Informationen zum Empfangen von Inhalt liefert. Ankündigungsdateien enthalten XML-Skripts (Extensible Markup Language).

Audio Video Interleaved (AVI)

Ein Multimedia-Dateiformat zum Speichern von Ton und bewegten Bildern im RIFF-Format.

AVI

Siehe die Definition für: Audio Video Interleaved (AVI)

Nach oben

B

Bandbreite

Die Fähigkeit eines Netzwerks, eine bestimmte Datenmenge in einem bestimmten Zeitraum zu übertragen.

Bitrate

Die Anzahl der Bits, die pro Sekunde übertragen werden.

Nach oben

C

CBR

Siehe die Definition für: Konstante Bitrate (Constant Bit Rate, CBR)

Codec

Eine Abkürzung für Compressor/Decompressor. Software oder Hardware, mit der digitale Medien komprimiert und dekomprimiert werden.

Codieren

Beim Codieren wird Audio- und Videoinhalt in das angegebene digitale Format konvertiert.

Codierung mit einem Durchlauf

Eine Codierungsmethode, bei der Inhalt im Encoder in einem Durchlauf analysiert und komprimiert wird.

Siehe auch: Codierung mit zwei Durchläufen

Codierung mit zwei Durchläufen

Eine Codierungsmethode, bei der Inhalt im Encoder im ersten Durchlauf analysiert und dann im zweiten Durchlauf komprimiert wird.

Siehe auch: Codierung mit einem Durchlauf

Nach oben

D

Datei im Datenstromformat

Eine Datei, die ein Player zum Entschlüsseln eines Multicastdatenstroms verwendet.

Siehe auch: Datenstromformat

Datenstrom

Digitale Medien, die in einem ununterbrochenen Datenfluss in einem Netzwerk übermittelt werden.

Datenstromformat

Informationen zu den Eigenschaften eines Datenstroms, wie z. B. die verwendeten Codecs, die Framerate und die Framegröße. Ein Player verwendet Informationen zum Datenstromformat, um einen Datenstrom zu entschlüsseln.

Deltaframe

Ein Videoframe, der lediglich die Änderungen des vorherigen Frames enthält. Im Gegensatz dazu enthält ein Schlüsselframe alle zum Erstellen dieses Frames erforderlichen Daten.

Dynamischer Bereich

Der Unterschied (in Dezibel) zwischen den leisesten und lautesten Tönen in einem Stück Audioinhalt.

Nach oben

F

Framerate

Die Anzahl der Videoframes, die pro Sekunde angezeigt werden. Eine höhere Framerate erzeugt im Allgemeinen weichere Bildbewegungen.

Nach oben

H

Header

Ein Dateistrukturelement, das Informationen für eine Anwendung zum Dekomprimieren und Wiedergeben des Inhalts enthält. Der Header in einer geschützten Datei enthält außerdem die erforderlichen Informationen zum Erwerben einer Lizenz.

Nach oben

I

IEEE 1394

Siehe die Definition für: Institute of Electrical and Electronics Engineers (IEEE) 1394

Inhalt

Audio-, Video-, Bild-, Text- oder sonstige Daten, die in einer digitalen Mediendatei oder einem Datenstrom enthalten sind.

Institute of Electrical and Electronics Engineers (IEEE) 1394

Ein serieller Hochgeschwindigkeits-Busstandard, der eine höhere Computerkonnektivität für eine größere Anzahl von Geräten bietet, einschließlich Audio-/Videokomponenten (A/V) der Verbraucherelektronikindustrie, Speicherperipheriegeräte, andere Computer und tragbare Geräte.

Intelligente Ausstrahlung

Ein Ausstrahlungstyp, der Netzwerkbedingungen erkennt und die Eigenschaften eines Video- oder Audiodatenstroms anpasst, um eine optimale Qualität zu ermöglichen.

Internet Protocol Version 6 (IPv6)

Eine aufgrund des schnellen Wachstums im Internet überarbeitete Version von Internet Protocol (IP). Zu den Verbesserungen zählen die IP-Adressengröße von 128 Bit, erweiterte Routingfunktionen und die Unterstützung von Authentifizierung und Datensicherheit.

IPv6

Siehe die Definition für: Internet Protocol Version 6 (IPv6)

Nach oben

K

Komprimierung

Bei der Komprimierung werden redundante Daten aus einer digitalen Mediendatei oder einem Datenstrom entfernt, um deren bzw. dessen Größe oder die verwendete Bandbreite zu reduzieren.

Konfigurationsdatei

Eine von Windows Media-Codierungsskript verwendete Datei, die den zu codierenden Inhalt und die aufzurufenden Befehlszeilenoptionen angibt.

Konstante Bitrate (Constant Bit Rate, CBR)

Eine Eigenschaft eines Datenstroms, in dem die Bitrate für die Dauer des Datenstroms fast einheitlich bleibt.

Siehe auch: Variable Bitrate (Variable Bit Rate, VBR)

Nach oben

L

Letterbox

Ein Videoanzeigeformat, bei dem bei der Wiedergabe schwarze Balken über und unter dem Videobild angezeigt werden. Das Letterboxformat behält das ursprüngliche Seitenverhältnis eines Bilds bei, wenn es mit einem anderen Seitenverhältnis in einem Fenster angezeigt wird.

Lizenz

Mit geschütztem Inhalt verbundene Daten, die beschreiben, wie der Inhalt verwendet werden kann.

Nach oben

M

Markierung

Eine Textzeichenfolge, die mit einer festgelegten Zeit in Windows Media-basiertem Inhalt verknüpft ist. Markierungen bezeichnen häufig hilfreiche Punkte, um mit der Wiedergabe zu beginnen, wie den Beginn einer neuen Szene.

MBR

Siehe die Definition für: Mehrere Bitraten (Multiple Bit Rate, MBR)

Mehrere Bitraten (Multiple Bit Rate, MBR)

Ein Merkmal eines Datenstroms, bei dem derselbe Inhalt mit verschiedenen Bitraten codiert wird, um die Inhaltsübermittlung zu optimieren.

Mehrkanalaudio

Ein Audio-Reproduktionssystem, das mehrere, in der Regel mehr als zwei Tonkanäle verarbeitet. 5.1-Mehrkanalaudio bezieht sich z. B. auf ein Surroundsoundsystem, in dem es fünf primäre Kanäle und einen Subwooferkanal gibt.

Metadaten

Daten zu Daten. Beispiele für Metadaten einer Datei sind Titel, Betreff, Autor und Größe.

Mit Zeilensprung

Anzeigen eines Videoframes in zwei Feldern. Ein Feld enthält die geraden Zeilen des Frames, das andere Feld die ungeraden. Während der Wiedergabe werden die Zeilen in einem Feld zuerst angezeigt und dann die Zeilen im zweiten Feld.

Multicast

Eine Inhaltsübermittlungsmethode, bei der ein einziger Datenstrom von einem Medienserver an mehrere Clients übertragen wird. Die Clients haben keine Verbindung zum Server. Stattdessen sendet der Server im Netzwerk eine Kopie des Datenstroms an multicastfähige Router, die die Daten replizieren. Clients können dann den Datenstrom empfangen, indem sie eine bestimmte Multicast-IP-Adresse und einen bestimmten Multicast-IP-Port überwachen.

Nach oben

N

National Television Standards Committee (NTSC)

Der bedeutendste Fernsehstandard in den USA und Japan. NTSC liefert 30 Frames mit Zeilensprung pro Sekunde bei einer Auflösung von 525 Zeilen.

NTSC

Siehe die Definition für: National Television Standards Committee (NTSC)

Nach oben

P

PAL

Siehe die Definition für: Phase Alternating Line (PAL)

PCM

Siehe die Definition für: Pulscodemodulation (PCM)

Phase Alternating Line (PAL)

Der bedeutendste Fernsehstandard in Europa und China. PAL liefert 25 Frames mit Zeilensprung pro Sekunde bei einer Auflösung von 625 Zeilen.

Pixelformat

Die Größe und Anordnung von Pixelfarbkomponenten. Das Format ist durch die Bitgesamtanzahl angegeben, die pro Pixel verwendet wird, sowie durch die Anzahl der Bits, die zum Speichern der roten, grünen, blauen und Alphakomponenten der Pixelfarbe verwendet werden.

Postroll

Erweitern der Menge codierter Videos um eine angegebene Anzahl von Frames.

Preroll

Aufzeichnen oder Wiedergeben einiger Videoframes oder eines Teils der Audiodaten, bevor die Codierung oder Wiedergabe beginnt, damit sich das Quellgerät stabilisieren kann. Wird auch verwendet, um den Teil der Daten zu beschreiben, für die ein Preroll ausgeführt werden muss.

Profil

Eine Gruppe von Einstellungen, die dem Inhaltstyp und der Bitrate entsprechende Audio- und Video-Codecs zuweisen.

Profil-Editor

Ein Programm, das mit Windows Media Encoder mitgeliefert wird und mit dem Codierungsprofile erstellt und bearbeitet werden.

Siehe auch: Profil

PRX

Die Dateinamenerweiterung eines Profils.

Publishingpoint

Ein Publishingpoint ist eine festgelegte Adresse im Arbeitsspeicher, die eine Clientanforderung für Inhalt in einen physischen Pfad auf dem Server übersetzt, auf dem sich der Inhalt befindet. Ein Publishingpoint dient im Wesentlichen zum Umleiten.

Pull

Übermitteln von Daten an einen Client nur bei Clientanforderung.

Pulscodemodulation (PCM)

Eine Technik zur Digitalisierung von Audiomaterial in ein umkomprimiertes Format, wobei zu festgelegten Intervallen der Amplitude des Signals ein Wert zugewiesen wird.

Push

Übertragen von Daten an einen Client ohne Clientanforderung der Daten.

Nach oben

Q

Quelle

Audio- und Videoinhalt, der mit Geräten aufgezeichnet und codiert werden kann, die auf Ihrem Computer oder von einer Datei installiert sind.

Nach oben

R

RGB

Ein Farbmodell, das die Farbinformationen hinsichtlich der roten (R), grünen (G) und blauen (B) Intensitäten beschreibt, aus denen die Farbe besteht.

Nach oben

S

Schleife

Die Endloswiederholung eines Datenstroms.

Schlüsselframe

Ein Videoframe, der alle zum Erstellen eines Bilds erforderlichen Daten enthält, ohne Verweis auf vorherige Frames.

Siehe auch: Deltaframe

Seitenverhältnis

Das Verhältnis der Breite eines Bilds zu seiner Höhe.

Skriptbefehle

Benannte Daten, die mit einer bestimmten Uhrzeit in Windows Media-basiertem Inhalt verknüpft ist. Player können anhand dieser Daten eine bestimmte Aktion ausführen, wie z. B. das Anzeigen einer Webseite.

Nach oben

T

Telecine

Das Film-zu-Video-Konvertierungssystem, das dem Videobild Frames hinzufügt, um die Unterschiede in den Frameraten zwischen Film und Video zu kompensieren.

Titel/Untertitel

Text, der Bilder oder Videos als zusätzliche Beschreibung oder als Untertitel begleitet.

Nach oben

U

UDP

Siehe die Definition für: User Datagram Protocol (UDP)

Umgekehrte Filmabtastung (Inverse Telecine)

Der Prozess, bei dem die Frames entfernt werden, die hinzugefügt wurden, als der 24-F/s-Film in einen 30-F/s-Videoinhalt konvertiert wurde.

UNC

Siehe die Definition für: Universal Naming Convention (UNC)

Unicast

Eine von Windows Media-Servern verwendete Methode zum Bereitstellen von Inhalt für verbundene Clients, wobei jeder Client einen eigenen Datenstrom empfängt. Kein anderer Client hat Zugriff auf diesen Datenstrom.

Universal Naming Convention (UNC)

Der vollständige Name einer Ressource in einem Netzwerk. Die verwendete Syntax lautet \\Servername\Freigabename, wobei Servername dem Namen des Servers und Freigabename dem Namen der freigegebenen Ressource entspricht. UNC-Namen für Verzeichnisse oder Dateien können im Freigabenamen auch den Verzeichnispfad gemäß folgender Syntax enthalten: \\Servername\Freigabename\Verzeichnis\Dateiname.

User Datagram Protocol (UDP)

Ein verbindungsloses Transportprotokoll im TCP/IP-Protokollstapel, das verwendet wird, wenn ein gewisser Paketverlust akzeptabel ist, wie z. B. bei digitalen Mediendatenströmen.

Nach oben

V

Variable Bitrate (Variable Bit Rate, VBR)

Eine Eigenschaft eines Datenstroms, in dem die Bitrate je nach Datenkomplexität für die Dauer des Datenstroms schwankt.

VBR

Siehe die Definition für: Variable Bitrate (Variable Bit Rate, VBR)

Verlustbehaftete Komprimierung

Ein Prozess zur Komprimierung von Daten, bei dem als unnötig erachtete Informationen entfernt werden und nach der Dekomprimierung nicht mehr wiederhergestellt werden können. Wird in der Regel mit Audio- und Videodaten verwendet, bei denen eine leichte Qualitätsverschlechterung akzeptabel ist.

Verlustfreie Komprimierung

Ein Prozess zur Komprimierung von Daten, bei dem Informationen in komprimierterer Form angeordnet und nach der Dekomprimierung im Originalzustand wiederhergestellt werden.

Nach oben

W

Wartezeit

Die Verzögerung, die beim Verarbeiten oder Übermitteln von Daten auftritt.

WEU

Die Dateinamenerweiterung einer Konfigurationsdatei, die vom Windows Media-Codierungsskript verwendet wird.

Windows Media Audio-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung von Audiodatenströmen verwendet wird.

Windows Media-Datei

Eine Windows Media-Datei enthält im Windows Media-Format gespeicherte Audio-, Video- oder Skriptdaten. Je nach Inhalt und Zweck verwenden Windows Media-Dateien eine Vielzahl von Dateinamenerweiterungen: WMA, WME, WMS, WMV, WMX, WMZ oder WVX.

Windows Media-Format

Das Format, das von Microsoft Windows Media Technologies (oder einem Produkt eines Drittanbieters, das eine lizenzierte Windows Media-Technologie beinhaltet) verwendet wird, um auf Zeitvorgaben beruhenden Inhalt zu erstellen, zu speichern, zu bearbeiten, zu verteilen, auszustrahlen oder wiederzugeben.

Windows Media-Metadatei

Eine Windows Media-Metadatei ist in Windows Media Technologies eine Datei, die Informationen zu Windows Media-Dateien und deren Präsentation liefert. Zu den Dateinamenerweiterungen für Windows Media-Metadateien zählen ASX, WAX, WVX, WMX und NSC.

Windows Media Screen-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung der Sequenzen von Bildschirmbereichen verwendet wird.

Windows Media Video-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung von Videodatenströmen verwendet wird.

WMA

Die Dateinamenerweiterung einer Audiodatei im Windows Media-Format. Der Audioinhalt der Datei ist mit dem Codec von Windows Media Audio codiert.

WME

Die Dateinamenerweiterung für eine Windows Media Encoder-Sitzungsdatei.

WMV

Die Dateinamenerweiterung einer Videodatei im Windows Media-Format.

Nach oben

Y

YUV

Ein Farbmodell, das die Farbinformationen hinsichtlich Helligkeit (Leuchtdichte oder Y) und Farbe (Chrominanz oder U und V) beschreibt.

Nach oben

Z

Zeilensprünge entfernen

Kombinieren der Felder in einem Videoframe mit Zeilensprung, so dass die Linien des Videoframes während der Wiedergabe nacheinander gezeichnet werden.

Siehe auch: Mit Zeilensprung

Zeitcode

Ein auf einen Datenstrom angewendetes digitales Signal. Das Signal weist jedem Videoframe eine Zahl zu, die die Stunden, Minuten, Sekunden und Frames darstellt.

Nach oben


Anbieter hinzufügen

Geben Sie einen Lizenzdienstanbieter an, den Sie hinzufügen möchten.

  • Name. Geben Sie einen eindeutigen Namen für den Anbieter ein.
  • URL. Geben Sie den URL für die Website des Anbieters an.
  • Anbieter suchen. Klicken Sie auf diese Option, um auf eine Website zu wechseln, die eine Liste mit Anbietern zum Auswählen enthält.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt


Videogröße

Schneiden Sie das Pixelseitenverhältnis Ihres Quellvideos zu, ändern Sie die Größe, und behalten Sie das Verhältnis bei.

  • Zuschneiden. Klicken Sie auf eine Standardmethode, mit der Sie die Videoeingabe zuschneiden möchten, oder klicken Sie auf Benutzerdefiniert, um das Videobild manuell zuzuschneiden. Die zugeschnittene Breite und Höhe muss eine gerade Anzahl Pixel aufweisen (beispielsweise 300 × 320 Pixel, 300 × 321 Pixel hingegen nicht).

    Wenn Sie eine Datei als Quelle verwenden, kann der Encoder die Größe des Quellvideos vor dem Beginn der Codierung erkennen. Wenn Geräte oder Bildaufzeichnungen als Quelle dienen, kann die Eingabegröße nicht vor dem Codieren erkannt werden. Aus diesem Grund sollten Sie, wenn Sie Geräte oder Bildaufzeichnungen als Quelle verwenden, die Eingabegröße beim Zuschneiden und beim Anpassen der Größe von Videomaterial angeben. In diesem Fall kann der Encoder die tatsächliche Eingabegröße vor dem Codieren erkennen. Wenn sich die tatsächliche Eingabegröße von der von Ihnen angegebenen Größe unterscheidet, wird der Prozentsatz, den Sie für das Zuschneiden angegeben haben (und nicht der tatsächliche Pixelwert), auf die aktuelle Eingabegröße angewendet.

    Wenn Sie Ihre Änderungen auf die Sitzung anwenden, jedoch mit der Codierung noch nicht begonnen haben, wird das zuvor zugeschnittene Bild im Hauptfenster des Encoders im Fensterbereich Video im Bereich Eingabe angezeigt. (Es sei denn, der Inhalt stammt von einem Aufnahmegerät, das den Vorgang des Zuschneidens unterstützt. In diesem Fall wird das zugeschnittene Bild angezeigt.) Während der Codierung wird das zugeschnittene Bild im Bereich Eingabe und Ausgabe angezeigt.

  • Seitenverhältnis für Pixel. Wählen Sie einen Wert aus, der dem Seitenverhältnis Ihrer Quelle entspricht, oder wählen Sie Benutzerdefiniert aus. Die codierte Ausgabe entspricht dem angegebenen Seitenverhältnis. (Bei DV- und anamorphotischen Optionen stellen diese Werte das Frameseitenverhältnis und das Pixelseitenverhältnis dar, die in Klammern angegeben werden.) Dieses Feld steht zur Verfügung, wenn Sie im Dialogfeld Benutzerdefinierte Codierungseinstellungen das Kontrollkästchen Ausgabe nicht quadratischer Pixel zulassen aktivieren, auf das Sie über die Registerkarte Komprimierung zugreifen können.
  • Größe ändern. Wenn Sie Videoinhalt als Quelle verwenden, für den die Eingabegröße erkannt werden kann (Dateiquelle), klicken Sie auf Automatisch, damit die Größe des Videos automatisch basierend auf dem durchgeführten Zuschnitt und der im Profil angegebenen Bandbreitenverfügbarkeit geändert wird. (Wenn Geräte als Quelle verwendet werden, funktioniert die Option Automatisch auf dieselbe Weise wie Keine Größenanpassung.) Klicken Sie auf Keine Größenanpassung, wenn das Ausgabebild den Abmessungen des zugeschnittenen Eingabebilds entsprechen soll. Klicken Sie auf Wie Profil, wenn das Ausgabebild vergrößert werden soll, um den auf der Registerkarte Bitrate angegebenen Abmessungen zu entsprechen. (Zum Zugreifen auf die Registerkarte Bitrate klicken Sie auf die Registerkarte Komprimierung, dann auf Bearbeiten und anschließend auf die Registerkarte für die Bitrate, deren Größe Sie ändern möchten.) Wenn Sie MBR-Inhalt codieren, können Sie die Bitrate in der Liste Bitrate auswählen und dann die Größe der einzelnen Bitraten ändern. (Sie können die Bitrate nur dann ändern, wenn Sie die Größenänderungsoptionen Benutzerdefiniert oder Wie Profil ausgewählt haben.)

Verwandte Themen

  • Zuschneiden und Ändern der Größe von Videobildern vor der Codierung


Abgebrochene Ankündigung

Wenn Sie Inhalt als Multicastdatenstrom von dem Server mit Windows Media-Dienste aus verteilen möchten, müssen Sie zunächst eine Ankündigung für den Datenstrom erstellen. Wenn Sie für den Windows Media-Dienst über DCOM Zugriffsrechte besitzen, können Sie den Multicastankündigungs-Assistenten im Encoder zum Erstellen der Ankündigung verwenden. Andernfalls müssen Sie die Ankündigung auf dem Windows Media-Server erstellen. Informationen zum Erstellen einer Ankündigung mit dem Encoder finden Sie unter Erstellen einer Ankündigung für ein Multicast. Informationen zum Erstellen einer Ankündigung auf dem Server finden Sie in der Hilfe zu Windows Media-Dienste.

Wenn Sie Inhalt als Unicastdatenstrom vom Windows Media-Server aus verteilen möchten, müssen Sie keine Ankündigung erstellen.


HTTP-Format erforderlich

HTTP-URLs haben folgendes Format: http://Webservername.


UNC-Format erforderlich

UNC-Pfade (Universal Naming Convention) haben folgendes Format: \\Computername\Ordnername.


Veröffentlichen von Dateien

Geben Sie den temporären Speicherort für die Dateien an. Nach Abschluss des Multicastankündigungs-Assistenten können Sie die Dateien auf dem Webserver speichern und dann mit dem Ausstrahlen der Übertragung beginnen.


Erstellen einer Ankündigung

Sie haben einen Publishingpoint erstellt, der Inhalt als Multicastdatenstrom vom Server mit Windows Media-Dienste aus verteilt. Bevor Sie mit dem Ausstrahlen vom Server beginnen können, müssen Sie eine Ankündigung für den Datenstrom erstellen. Sie können den Multicastankündigungs-Assistenten im Encoder zum Erstellen der Ankündigung verwenden oder die Ankündigung auf dem Windows Media-Server erstellen. Informationen zum Erstellen einer Ankündigung mit dem Encoder finden Sie unter Erstellen einer Ankündigung für ein Multicast. Informationen zum Erstellen einer Ankündigung auf dem Server finden Sie in der Hilfe zu Windows Media-Dienste.


Starten der Archivierung während einer Übertragung

Wenn Sie die Archivierung einrichten, bevor Sie mit der Codierung einer Übertragungssitzung beginnen, wird die Archivierung automatisch beim Beginn der Codierung gestartet. Wenn Sie die Archivierung jedoch erst nach dem Beginn der Codierung einer Übertragungssitzung starten möchten, müssen Sie die Archivierung manuell starten, indem Sie im Menü Steuerung auf Archivierung starten klicken.


Audio (Fensterbereich)

Der Fensterbereich Audio enthält Steuerelemente zum Überwachen und Anpassen der Lautstärke des codierten Audiodatenstroms. Dazu gehören u. a. folgende Steuerelemente:

  • Aufnahmepegel (Anzeige). Zeigt den Klangpegel des Inhalts bei der Codierung in visueller Form an. Bei zunehmendem Klangpegel wechselt die Farbe in der Anzeige von Grün über Gelb zu Rot. Aufnahmen mit einem zu hohen oder zu niedrigen Pegel (Anzeige hauptsächlich im roten bzw. im grünen Bereich) führen zu unbefriedigenden Ergebnissen. Optimale Ergebnisse erzielen Sie mit einem möglichst konstanten Aufnahmepegel.
  • Aufnahmepegel (Steuerelement). Dieses Steuerelement ähnelt dem Hauptsteuerelement zur Regelung des Aufnahmepegels in der Mixeranwendung, die im Lieferumfang Ihrer Audiokarte enthalten ist. Bewegen Sie den Schieberegler, um den Audiopegel des zu codierenden Inhalts anzupassen. Wenn Sie das Steuerelement im Encoder anpassen, wird das Steuerelement in der Mixeranwendung dieser Einstellung entsprechend angepasst. Wenn die Treiber Ihrer Audiokarte kein Hauptsteuerelement zur Regelung des Aufnahmepegels unterstützen, ist dieses Steuerelement nicht verfügbar.
  • Ton aus (Schaltfläche). Klicken Sie auf diese Schaltfläche, um die Audiowiedergabe bei der Codierung stumm zu schalten. Die Verfügbarkeit dieser Schaltfläche ist von der Aufnahmekarte abhängig. Wenn die Karte nicht über ein Steuerelement zur Stummschaltung verfügt, ist die Schaltfläche Ton aus im Encoder nicht verfügbar.
  • Mixer (Schaltfläche). Klicken Sie auf diese Schaltfläche, um die Lautstärke für verschiedene Eingaben anzupassen, u. a. von Kameras, Mikrofonen und CDs. Sie können auch das Hauptsteuerelement verwenden, um die Lautstärke aller Eingaben anzupassen. Durch Klicken auf die Schaltfläche Mixer wird die Aufnahmemixeranwendung gestartet, die im Lieferumfang Ihrer Aufnahmekarte enthalten ist. Die Schaltfläche Mixer ist nur verfügbar, wenn Sie ein Audiogerät ausgewählt haben.


Format ist ungültig

Mindestens eine Einstellung in dieser Sitzung ist nicht mit dem verwendeten Codec kompatibel. Ein denkbarer Grund ist, dass die Breite und Höhe der Quellvideodaten bei dem verwendeten Codec gleichmäßige Abmessungen aufweisen müssen (beim Zuschneiden gilt dies für die Ausgabevideodaten). Eine andere Möglichkeit ist, dass das ausgewählte Audioformat nicht mit dem Codec kompatibel ist. Wenn Sie z. B. den Windows Media Audio 9 Professional-Codec mit dem qualitätsbasierten VBR-Codierungsmodus verwenden, kann die Qualität maximal auf 98 festgelegt werden. Möglicherweise wird auch ein 5.1-Kanal-Audioformat verwendet, während die Quellaudiodaten in zwei Kanälen vorliegen. Klicken Sie zum Ändern des Audioformats im Fensterbereich Eigenschaften auf der Registerkarte Komprimierung auf Bearbeiten. Klicken Sie dann auf die Registerkarte mit der Bitrateangabe, und wählen Sie in der Liste unter Audioformat ein Audioformat aus.


Ändern der Zuschnittsränder

Die zugeschnittene Höhe und Breite des Videos müssen jeweils mehr als 16 Pixel betragen.


Eingeben eines Publishingpointnamens

Geben Sie den Namen eines vorhandenen oder neuen Publishingpoints ein, über den die Ausstrahlung erfolgen soll.

Verwandte Themen

  • Übertragen eines Datenstroms vom Encoder


Multicastankündigung ist möglicherweise erforderlich

Wenn Sie Inhalt als Multicastdatenstrom von einem Server mit Windows Media-Dienste aus verteilen möchten, müssen Sie zunächst eine Ankündigung für den Datenstrom erstellen. Wenn Sie für den Windows Media-Dienst über DCOM Zugriffsrechte besitzen, können Sie den Multicastankündigungs-Assistenten im Encoder zum Erstellen der Ankündigung verwenden. Andernfalls müssen Sie die Ankündigung auf dem Windows Media-Server erstellen. Informationen zum Erstellen einer Ankündigung mit dem Encoder finden Sie unter Erstellen einer Ankündigung für ein Multicast. Informationen zum Erstellen einer Ankündigung auf dem Server finden Sie in der Hilfe zu Windows Media-Dienste.

Wenn Sie Inhalt als Unicastdatenstrom von einem Windows Media-Server aus verteilen möchten, müssen Sie keine Ankündigung erstellen.


Geräte konfigurieren

Hier werden alle Geräte aufgeführt, die in der aktuellen Sitzung verwendet werden. Geräte, die auf Ihrem Computer installiert, gegenwärtig aber nicht in Verwendung sind, werden nicht angezeigt. Geräte können pro Sitzung nur von einer Quelle verwendet werden.

Um die Eigenschaften eines Geräts zu bearbeiten, wählen Sie das Gerät aus, klicken Sie auf Konfigurieren, und bearbeiten Sie dann die Eigenschaften nach Bedarf. Welche Eigenschaften Sie bearbeiten können, hängt von der Marke des verwendeten Geräts ab.

Anmerkung Anmerkung

  • Bildschirmaufzeichnungsgeräte werden nicht aufgeführt. Bildschirmaufzeichnungsgeräte können im Fensterbereich Eigenschaften konfiguriert werden.


Abschließen des Multicastankündigungs-Assistenten

Klicken Sie auf Fertig stellen, um den Assistenten abzuschließen. Der Assistent erstellt möglicherweise die folgenden Dateitypen:

  • Multicastinformationsdatei (NSC). Die Datei enthält Informationen zum Datenstromformat sowie die Multicastadresse.
  • Ankündigungsdatei (ASX). Die Umleitungsdatei, die den Player zur Multicastinformationsdatei leitet.
  • (Optional) Webseite (HTM). Die Webseite mit dem eingebetteten Player und einem Hyperlink zur Ankündigungsdatei.


Komprimierungseinstellungen für Mehrkanalaudio

Beim Codieren von Mehrkanalaudio müssen Sie den Windows Media Audio 9 Professional- oder den Windows Media Audio 9 Lossless-Codec zusammen mit einem Audioformat verwenden, das mehrere Kanäle unterstützt.

Verwandte Themen

  • Verwenden von Mehrkanal-Audiodateien als Quelle


Komprimierungseinstellungen für Bildschirmaufzeichnungen

Beim Aufzeichnen von Bildschirmen sollten Sie ein Bildschirmaufzeichnungsprofil verwenden. Das Profil verwendet Einstellungen, die für die Bildschirmaufzeichnung optimiert sind, wie z. B. den Windows Media-Videobildschirmcodec. Klicken Sie auf die Registerkarte Komprimierung, um ein Bildschirmaufzeichnungsprofil zu verwenden. Klicken Sie unter Ziel auf Windows Media-Server oder Webserver und anschließend auf Bildschirmaufzeichnung.

Sie haben mehrere Möglichkeiten zum Konfigurieren der Codierungssitzung und des Computers, um die Leistung bei der Bildschirmaufzeichnung zu verbessern. Weitere Informationen finden Sie unter Verwenden von Windows Media-Leistungsindikatoren.


Verbindungen (Registerkarte)

Auf der Registerkarte Verbindungen werden die IP-Adressen aller Clients angezeigt, die momentan mit dem Encoder verbunden sind, wenn die Übertragung direkt von dort vorgenommen wird. Bei den Clients kann es sich um Windows Media-Server, Webserver oder Player handeln.

Klicken Sie auf Internet-URL kopieren oder auf LAN-URL kopieren, um die IP-Adresse oder den LAN-URL des Computers mit dem Encoder auf einen Player zu kopieren. Der Player verwendet den URL, um eine Verbindung mit dem Encoder herzustellen, so dass Sie den Datenstrom testen können.


Erstellen von Dateien

Geben Sie einen Namen für die Dateien an, die mit dem Assistenten erstellt werden. Alle Dateien erhalten denselben Namen, an den jedoch jeweils die geeignete Dateinamenerweiterung angefügt wird. Der Multicastankündigungs-Assistent erstellt mindestens eine Ankündigungsdatei (ASX) und eine Multicastinformationsdatei (NSC). Die Ankündigungsdatei ist eine Windows Media-Metadatei, die Player zur Multicastinformationsdatei leitet. Die Multicastinformationsdatei enthält Informationen, die Playern den Zugriff auf den Multicastdatenstrom sowie dessen Entschlüsselung ermöglichen. Dies schließt u. a. die IP-Adresse, den Port und das Datenstromformat ein.

Wählen Sie aus, ob eine Webseite (HTM) erstellt werden soll, die einen Hyperlink zur Ankündigung sowie einen eingebetteten Player enthält.


Einrichten

In diesem Dialogfeld können Sie das Gerät auswählen, das in dieser Gerätesteuerungssitzung verwendet werden soll.


Gerät (Fensterbereich)

Der Fensterbereich Gerät enthält Schaltflächen zur Steuerung von Geräten, für die die Gerätesteuerung aktiviert wurde.

Verwandte Themen

  • Aktivieren der Gerätesteuerung
  • Einrichten einer Schnittliste


Geräteeinstellungen

Dieses Dialogfeld bietet erweiterte Optionen zur Einrichtung einer Schnittliste (Edit Decision List, EDL).

  • Vorlauf. Gibt in Bezug zum Zeitpunkt der Einstiegsmarkierung die Anzahl der Frames an, die das Gerät vor dem Codierungsbeginn abspielen soll. Durch den Vorabdurchlauf wird das Band stabilisiert, so dass keine Linien, Jitter oder Verzerrungen codiert werden, die beim Start des Geräts auftreten. Der Vorabdurchlauf sollte vor der Startwartezeit durchgeführt werden. Beachten Sie daher bei der Berechnung der Vorlaufframes die Wartezeit des Systems.
  • Wartezeit beenden. Gibt in Bezug zum Zeitpunkt der Ausstiegsmarkierung die Anzahl der Frames an, die das Gerät über diesen Zeitpunkt hinweg codieren soll. Dadurch wird sichergestellt, dass der Encoder den letzten Frame des Clips aufzeichnet, bevor er beendet wird.
  • Wartezeit starten. Gibt in Bezug zum Zeitpunkt der Einstiegsmarkierung die Anzahl der Frames an, die der Encoder vor dem Ende der Wartezeit codieren soll. Diese Einstellung kompensiert die Wartezeit, die nach der Ausgabe des Startbefehls auftritt, bevor die Codierung beginnt. Sie müssen verschiedene Einstellungen ausprobieren, um die Wartezeit des Systems in Frames zu ermitteln. Wenn Sie die Länge dieser Verzögerung in Frames ermittelt haben, können Sie den Encoder frühzeitig starten, so dass die Codierung zum Zeitpunkt der Einstiegsmarkierung abzüglich der ermittelten Anzahl von Frames beginnt. Wenn der Computer z. B. nach 10 Frames mit der Codierung beginnt und die Codierung bei Frame 1 starten soll, stellen Sie eine Startwartezeit von -9 ein (9 Frames vor dem tatsächlichen Startframe).
  • Videoformat. Gibt das Format des Quellvideos an.


DRM-Datensicherheit

Zum Erstellen oder Bearbeiten eines DRM-Profils (Digital Rights Management) greifen Sie über das Internet auf das System eines Drittanbieters zu. Im Rahmen der Profilerstellung werden Sie vom System des Drittanbieters möglicherweise zur Angabe von persönlichen Daten, z. B. zur Rechnungserstellung, aufgefordert. Bevor Sie diese Angaben machen, sollten Sie unbedingt sicherstellen, dass die Website des Anbieters über eine sichere Verbindung verfügt.

Nach dem Erstellen oder Bearbeiten des Profils können Sie das Profil zum Schützen von Inhalt bei der Codierung verwenden.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt


Schnittliste (Edit Decision List, EDL)

Mit diesem Dialogfeld können Sie unter Verwendung von Zeitstempeln die genaue Stelle in Audio- oder Videoinhalten angeben, an der die Codierung beginnen und enden soll.

Klicken Sie im Bereich Gerät auf die Abspielschaltfläche, um mit der Wiedergabe des Inhalts vom Gerät zu beginnen. Verwenden Sie die Schaltflächen für schnellen Vorlauf oder Rücklauf, oder klicken Sie auf Vorh. Frame oder Nächst. Frame, um zu dem Frame zu gelangen, der als Start- oder Endpunkt verwendet werden soll.

Wählen Sie Sehr langsam, Langsam, Normal, Schnell oder Sehr schnell, um die Suchgeschwindigkeit des Geräts festzulegen. Das Gerät unterstützt möglicherweise nicht alle aufgeführten Geschwindigkeiten. Wenn Sie den Zeitstempel des gewünschten Frames kennen, geben Sie ihn unter Springen zu ein, und klicken Sie anschließend auf Los!

Klicken Sie auf die Pfeilschaltflächen, um die Reihenfolge der Schnittlisteneinträge zu verändern.

Wenn Sie mit der Einrichtung der Schnittliste fertig sind, können Sie mit der Codierung beginnen. Klicken Sie dazu auf der Symbolleiste auf Codierung starten.


EDL (Registerkarte)

Auf der Registerkarte EDL werden die Zeiten der Einstiegs- und Ausstiegsmarkierung für alle Clips in der Schnittliste (Edit Decision List, EDL) angezeigt. Außerdem wird für jeden Clip in der Liste angezeigt, wie viel Prozent bereits fertig gestellt sind.


Ereignisprotokoll (Registerkarte)

Auf der Registerkarte Ereignisprotokoll werden alle Ereignisse aufgeführt, die während der aktuellen Codierungssitzung aufgetreten sind.

Wenn Sie die Protokollinformationen in einer Datei speichern möchten, müssen Sie einen Dateinamen für die Protokolldatei angeben. Wenn Sie den Codierungsvorgang beenden und dann erneut starten, werden neue Ereignisse am Ende der Protokolldatei angefügt.

Wenn die maximale Größe der Protokolldatei erreicht ist (1.024 Zeichen), werden keine weiteren Ereignisse in der Protokolldatei protokolliert. Um die Protokollierung fortzusetzen, müssen Sie eine neue Protokolldatei erstellen, indem Sie das Kontrollkästchen In Datei protokollieren deaktivieren und anschließend wieder aktivieren.


Allgemein (Registerkarte)

Auf der Registerkarte Allgemein werden folgende Informationen angezeigt:

  • Eingang. Identifiziert die aktuell ausgewählte Quelle.
  • Codierung. Liefert Informationen zu den in der Sitzung verwendeten Codierungseinstellungen, der Größe des Videobilds, der Bitrate, der erwarteten und tatsächlichen (durchschnittlichen) Framerate und der Gesamtanzahl von Skriptbefehlen im Datenstrom. Außerdem wird hier angegeben, ob der Inhalt mit DRM geschützt wurde und ob Vorverarbeitungsfilter angewendet wurden.
  • Ausgabe. Listet die bei Codierungs- oder Archivierungssitzungen erstellten Dateien auf (wenn es sich um Sitzungen handelt, bei denen in eine Datei codiert bzw. archiviert wird). Bei Übertragungen wird hier der Übertragungsport und die Anzahl der verbundenen Clients aufgelistet. Bei Übertragungen über einen Windows Media-Server wird der URL aufgeführt, der von den Clients zum Verbinden zur Übertragung vom Server verwendet wird.
  • Status. Gibt die Zeit an, die seit dem Beginn der Codierung verstrichen ist. Bei Dateiquellen wird hier die geschätzte verbleibende Zeit bis zum Abschluss der Codierung des Inhalts angegeben. Außerdem wird angezeigt, wie viel Prozent bereits fertig gestellt sind.
  • System. Gibt den freien Speicherplatz auf Ihrer Festplatte, den Prozentsatz der CPU-Ressourcen, die für die Sitzung verwendet werden, und die verbleibende Zeit bis zur vollständigen Belegung des freien Speicherplatzes auf Ihrer Festplatte an.


Ausgabe

Wählen Sie eine Option zur Verteilung des Inhalts aus:

  • Auf einen Windows Media-Server übertragen. Wählen Sie aus, ob der Encoder die Verbindung mit einem Server initiieren soll, auf dem Windows Media-Dienste ausgeführt wird. Sie müssen den Namen des Servers und des Publishingpoints angeben. Wenn der Publishingpoint nicht bereits auf dem Server vorhanden ist, wird er automatisch erstellt. Dies richtet sich danach, ob Sie die richtigen Zugriffsberechtigungen für den Windows Media-Server besitzen. (Wenn Sie einen Publishingpoint erstellen, dürfen Sie lediglich alphanumerische Zeichen verwenden. Außerdem sind die folgenden Zeichen in einem Publishingpointnamen nicht zulässig: * < > \ ? % & # " { } | ^ [ ] `) Wenn Sie Eigenschaften verwenden möchten, die bereits in einem anderen Publishingpoint festgelegt wurden, können Sie den Namen des vorhandenen Publishingpoints unter Einstellungen kopieren aus (optional) angeben. Klicken Sie auf Automatisch entfernen, um den Publishingpoint vom Server zu entfernen, nachdem Sie den Encoder beendet haben oder nach einer Inaktivität von mehreren Minuten. (Mithilfe des Timeouts für Inaktivität können Sie die Codierung zunächst anhalten und dann neu starten, ohne den Publishingpoint erstellen zu müssen. Diese Option ist hilfreich, wenn Sie in der Sitzung Einstellungen anpassen und dann mit der Codierung fortfahren möchten.)
  • Vom Encoder anfordern. Wählen Sie aus, ob ein Windows Media-Server oder ein Player die Verbindung mit dem Encoder initiieren soll, indem das HTTP-Protokoll verwendet wird. Es wird standardmäßig Port 8080 verwendet. Der Encoder unterstützt bis zu fünf direkte Verbindungen. Auf der Registerkarte Verbindungen im Fensterbereich Monitor werden die URLs aufgelistet, die von den Clients zur Verbindung mit dem Encoder verwendet werden können.
  • In Datei codieren. Wählen Sie aus, ob Sie den Inhalt zu einem späteren Zeitpunkt verteilen oder eine Kopie einer Übertragung archivieren möchten. Sie können die Größe oder Dauer der Datei beschränken. Die Beschränkung wird auf die Ausgabedatei und nicht auf die Quelldatei angewendet. Wenn Sie die Dateigröße beschränken, geben Sie die gewünschte Größe gefolgt von einem K (Kilobytes), M (Megabytes) oder G (Gigabytes) ein. Wenn Sie die Dauer der Datei beschränken, geben Sie die Dauer der Ausgabedatei in Stunden, Minuten und Sekunden ein. Die Datei wird standardmäßig für jeden Schlüsselframe indiziert, mit dem Benutzer Inhalt zu einem bestimmten Zeitpunkt wiedergeben können, indem sie die Suchfunktion in einem Player verwenden. Sie können ändern, wann Sie vom Encoder gewarnt werden möchten, dass der verfügbare Festplattenspeicher zu gering ist. Der Standardwert beträgt 1 MB. Geben Sie unter Warnung bei zu wenig Festplattenspeicher eine Zahl gefolgt von K, M oder G für Kilobytes, Megabytes oder Gigabytes ein.

    Anmerkung Anmerkung

    • Wenn Sie die Dauer Ihrer Ausgabedatei beschränken und zudem die Zeitkomprimierungsfunktion in der Sitzung verwenden, kann die Ausgabedatei mehr oder weniger Inhalt als erwartet enthalten. Wenn Sie die Ausgabedatei z. B. auf 30 Minuten beschränken und dann die Wiedergabe der Datei um einen Faktor von 2 beschleunigen, dauert die Ausgabedatei 30 Minuten, enthält aber 60 Minuten Inhalt.

Verwandte Themen

  • Ausgabeoptionen
  • Anwenden der Zeitkomprimierung auf Ihren Inhalt


Benutzerdefinierte Codierungseinstellungen - Allgemein

Windows Media Encoder-Bannergrafik

Benutzerdefinierte Codierungseinstellungen – Allgemein

Anzeigen oder Ändern der allgemeinen Einstellungen für das Profil.

  • Name und Beschreibung. Geben Sie beim Erstellen eines Profils einen Namen für das Profil ein. Fügen Sie in den Namen keinen Stern (*) ein. Die Beschreibung ist optional.
  • Sprache. Wählen Sie die Sprache des Inhalts aus. (Der Standardwert ist der Sprachsatz auf dem Computer mit dem Encoder.) Wenn Sie Inhalt in verschiedenen Sprachen codieren, können Benutzer ihre Sprache während der Wiedergabe auswählen.
  • Importieren und Exportieren. Klicken Sie auf Importieren, um ein vorhandenes Profil zur Bearbeitung zu importieren. Profile weisen die Dateinamenerweiterung PRX auf. Klicken Sie auf Exportieren, um die von Ihnen vorgenommenen Änderungen in einem Profil zu speichern.
  • Medientypen. Geben Sie die Kombination der Quelltypen an, die von diesem Profil unterstützt werden sollen. Beim Auswählen von Skripts können Sie während der Codierung Skriptbefehle in einen Datenstrom einfügen. Jeder Quelltyp belegt einen Teil der beim Codieren verwendeten Bandbreite. Wählen Sie den für Audio und Video zu verwendenden VBR-Modus aus der Liste aus. Wenn Sie die CBR-Codierung mit einem Durchlauf verwenden möchten, klicken Sie auf CBR. (Wenn Sie die CBR-Codierung mit zwei Durchläufen verwenden möchten, müssen Sie auf der Registerkarte Komprimierung das Kontrollkästchen Codierung mit zwei Durchläufen aktivieren.) Sie können auch die gewünschten Codecs auswählen. Beachten Sie, dass nicht alle Codecs den VBR-Modus oder die CBR-Codierung mit zwei Durchläufen unterstützen.
  • Zielbitraten. Listet die derzeit ausgewählten Bitraten auf (mit Ausnahme der qualitätsbasierten VBR-Codierung, da die Bitrate nicht im Voraus ermittelt werden kann). Wenn Sie für Ihren Inhalt eine andere Bitrate festlegen möchten, klicken Sie auf Hinzufügen. (Im VBR-Codierungsmodus steht diese Option nicht zur Verfügung, wenn die Liste eine vorhandene Bitrate enthält.) Wenn Sie eine Bitrate anpassen möchten, wählen Sie die Bitrate aus, und klicken Sie dann auf Bearbeiten. Sie müssen mindestens eine Bitrate auswählen.
  • Videoformat. Geben Sie das Format Ihres Quellvideos an (entweder NTSC oder PAL). Wenn Sie die Framerate oder Videogröße auf eine Einstellung ändern, die nicht dem Standard entspricht, wird das Format automatisch als Benutzerdefiniert markiert.
  • Verarbeitung mit Zeilensprüngen zulassen. Wählen Sie diese Option aus, wenn Ihr Inhalt Zeilensprünge enthält und die codierte Ausgabe so erhalten bleiben soll. (Sie müssen außerdem auf der Registerkarte Verarbeitung die Option Zeilensprünge beibehalten auswählen.)
  • Ausgabe nicht quadratischer Pixel zulassen. Wählen Sie aus, ob für das Quellvideo rechteckige Pixel verwendet werden sollen (wenn Ihre Quelle beispielsweise digitales Video ist) oder ob das Quellvideo ein anderes Seitenverhältnis als 4:3 aufweist und Sie das Seitenverhältnis in der codierten Ausgabe beibehalten möchten. Das Seitenverhältnis können Sie auf der Registerkarte Videogröße kontrollieren.

Verwandte Themen

  • NTSC- und PAL-Standardeinstellungen
  • Informationen zur CBR- oder VBR-Codierung
  • Optimieren von Video- und Audiomaterial
  • Beibehalten des Pixelseitenverhältnisses des Videos


Komprimierung

Wählen Sie das Ziel sowie die Video- und Audioeinstellungen aus, die Sie in dieser Codierungssitzung verwenden möchten.

  • Ziel, Audio und Video. Wählen Sie das Verteilungsszenario aus, das Sie als Ziel bestimmt haben. Ihre Auswahl legt die Einstellungen fest, die in Audio und Video zur Verfügung stehen. Ihre Auswahl insgesamt legt fest, welche Einstellungen (z. B. Codierungsmodus, Komprimierungsmenge, Codecs, Bitrate und Framerate) in der Sitzung verwendet werden. Die Sammlung dieser Einstellungen wird Profil genannt. Wenn Sie das Profil anpassen oder ein Profil importieren oder exportieren möchten, klicken Sie auf Bearbeiten.
  • Bitraten. Listet die Bitraten auf, die derzeit ausgewählt sind. (Für die Ziele Dateiarchiv und Dateidownload wird die Videoqualitätseinstellung angezeigt.) Wenn unter Ziel die Option Windows Media-Server ausgewählt ist, können Sie auf mehr als eine Bitrate klicken, um eine MBR-Sitzung einzurichten.
  • Codierung mit zwei Durchläufen. Ist je nach dem in einer Sitzung ausgewählten Ziel automatisch ausgewählt. Sie können auch die Codierung mit zwei Durchläufen auswählen, wenn Sie eine CBR-Codierungssitzung mit zwei Durchläufen einrichten möchten. Beachten Sie, dass die Codierung mit zwei Durchläufen in bestimmten Situationen nicht geeignet ist.
  • Zeitkomprimierung. Wählen Sie diese Option aus, um den Inhalt während der Wiedergabe zu beschleunigen oder zu verlangsamen. Wenn Sie den Grad der Beschleunigung oder Verlangsamung für den Inhalt festlegen oder Pausen im Audioinhalt entfernen möchten, klicken Sie auf Eigenschaften. Es ist nicht möglich, die Zeitkomprimierung auf eine reine Videoquelle anzuwenden.

    Wenn Sie die Zeitkomprimierung zusammen mit der Option Dauer beschränken auf der Registerkarte Ausgabe verwenden, müssen Sie beachten, dass die Beschränkung für die Ausgabedatei gilt und nicht für die Quelle. Deshalb ist es möglich, dass die Ausgabedatei mehr oder weniger Inhalt als erwartet enthalten kann. Wenn Sie die Ausgabedatei z. B. auf 30 Minuten beschränken und dann die Wiedergabe der Datei um einen Faktor von 2 beschleunigen, dauert die Ausgabedatei 30 Minuten, enthält aber 60 Minuten Inhalt.

Verwandte Themen

  • Informationen zu Codierungen mit einem oder zwei Durchläufen
  • Anwenden der Zeitkomprimierung auf Ihren Inhalt


Quellen

Fügen Sie neue Quellen zur aktuellen Codierungssitzung hinzu, bearbeiten Sie die Eigenschaften der vorhandenen Quellen, oder entfernen Sie Quellen, die Sie in der Sitzung nicht verwenden möchten.

  • Name. Geben Sie einen Namen für die Quelle ein. Klicken Sie auf Entfernen, wenn Sie die Quelle in der Sitzung nicht mehr verwenden möchten. (Beachten Sie, dass für eine Sitzung mindestens eine Quelle erforderlich sein muss.)
  • Quelle. Wählen Sie die Quelle (Geräte, Datei oder beides) und dann den zu codierenden Quelltyp (Video, Audio und Skript) aus. Wenn Sie von einem digitalen Gerät codieren, muss das Gerät eingeschaltet sein. Andernfalls wird es nicht in der Geräteliste angezeigt. Nachdem Sie einer Quelle ein Gerät zugewiesen haben, können Sie es nicht für eine beliebige andere Quelle der Sitzung verwenden.
  • Am Ende. Wenn die Sitzung mehrere Quellen enthält, wählen Sie die Aktion aus, die nach dem Ende einer Quelle auftreten soll. (Diese Option steht nur zur Verfügung, wenn es sich bei der Quelle um eine Datei mit der Dateinamenerweiterung AVI, WAV, WMV, WMA oder MP3 handelt.) Sie können eine Quelle entweder in Schleifen wiederholen oder zur nächsten oder zur ersten Quelle in der Liste gehen, wenn das Ende der Quelle erreicht ist. Die Codierung wird standardmäßig angehalten, wenn das Ende einer Quelle erreicht ist.
  • Anfang/Ende (nur Dateiquellen). Klicken Sie hier, um anzugeben, wo in der Datei die Codierung beginnen und enden soll.
  • Archivierung. Wenn Sie eine Übertragung codieren oder eine Kopie der Übertragung archivieren möchten und in der Sitzung mehrere Quellen verwendet werden, klicken Sie auf die für jede Quelle gewünschte Archivierungsoption. Unter Umständen möchten Sie beispielsweise das Hauptereignis archivieren und die Archivierung während der Pause anhalten.

Sie können Quellen hinzufügen, bevor oder nachdem Sie mit der Codierung beginnen. Wenn Sie die Reihenfolge neu anordnen möchten, in der die Quellen im Hauptfenster des Encoders angezeigt werden, wählen Sie eine Quelle aus, und klicken Sie dann auf die NACH-OBEN- NACH-OBEN-TASTE oder NACH-UNTEN-TASTE.

Verwandte Themen

  • Verwenden einer Datei als Quelle


Qualitätsbasiertes VBR (Registerkarte)

Die folgenden Einstellungen gelten für ein Profil, das die qualitätsbasierte VBR-Codierung verwendet.

  • Audioformat. Klicken Sie auf die Qualitätsstufe, die Sie für den Audioinhalt beibehalten möchten. Diese Einstellung bestimmt die Abtastrate und ob der Ton von Mono- oder Stereolautsprechern wiedergegeben werden soll. Eine Einstellung höherer Qualität führt zu Audio höherer Qualität, erhöht jedoch die Größe der Ausgabedatei.
  • Videogröße. Geben Sie die Größe (in Pixel) an, die Sie für das codierte Video verwenden möchten. Verwenden Sie Zahlen von 16 bis 2.000. Die Framegröße des codierten Video wird so geändert, dass Sie der von Ihnen angegebenen Größe entspricht. Aktivieren Sie das Kontrollkästchen Wie Videoeingang, um die Framegröße des Quellvideos anzupassen.
  • Framerate. Geben Sie für den Videoinhalt die Frames pro Sekunde (F/s) an. Die Menge, auf die Sie diesen Wert anpassen, richtet sich nach der Geschwindigkeit Ihres Computerprozessors und danach, ob Sie ein Video mit sehr viel oder sehr wenig Bewegung codieren. Ein Video mit sehr viel Bewegung sieht in der Regel natürlicher aus, wenn Sie eine höhere Framerate verwenden. Eine höhere Framerate führt jedoch zu einer höheren Prozessorbelastung. Die von Ihnen angegebene Einstellung ist die maximale Framerate pro Sekunde. Aufgrund verschiedener Faktoren, wie die Einstellung für die Videogröße und die Codec-Qualität, kann die tatsächlich erreichte Framerate pro Sekunde niedriger sein.
  • Schlüsselframeintervall. Geben Sie die Anzahl der Sekunden ein, die als Abstand zwischen Schlüsselframes verwendet werden soll. Alle Frames zwischen Schlüsselframes sind Deltaframes, die weitaus kleiner sind als Schlüsselframes, jedoch eine schlechte Bildqualität aufweisen. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes erhöhen, wird die Videogröße (in Bytes) kleiner, da weniger Schlüsselframes verwendet werden. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes verringern, nimmt die Videogröße zu. Erhöhen Sie das Schlüsselframeintervall für Inhalt mit einem statischen Hintergrund, beispielsweise für Cartoons. Verringern Sie das Schlüsselframeintervall für Inhalt mit viel Bewegung, beispielsweise ein Sportereignis.
  • Videoqualität. Geben Sie die Bildqualität ein, die Sie beibehalten möchten, indem Sie einen Wert von 0 bis 100 eingeben. Während der Codierung wird die Bitrate wie erforderlich angepasst, um die von Ihnen angegebene Qualitätsstufe ohne das Verwerfen von Frames zu erreichen. Derzeit gibt es 30 unterschiedliche Qualitätseinstellungen. Deshalb beziehen sich auf jede Qualitätseinstellung mehrere Qualitätsstufen. Die folgenden Qualitätsstufen entsprechen bestimmten Qualitätseinstellungen: 1, 4, 8, 11, 15, 18, 22, 25, 29, 33, 36, 40, 43, 47, 50, 54, 58, 61, 65, 68, 72, 75, 79, 83, 86, 90, 93, 97 und 100. Die Zahlen zwischen zwei Werten entsprechen derselben Qualitätseinstellung wie die niedrigere Zahl. 2 und 3 entsprechen beispielsweise derselben Qualitätseinstellung wie 1.
  • Decoderkomplexität. Wenn Sie ein anderes Hardwaregerät als einen Computer verwenden möchten, können Sie eine Komplexitätskategorie für den codierten Inhalt angeben. Einige Hardwaregeräte unterstützen nur bestimmte Kategorien. (Weitere Informationen finden Sie in der Dokumentation zu Ihrem Gerät.) Beachten Sie, dass die Option Komplex für die Wiedergabe auf Computern vorgesehen ist. In der Regel sollten Sie Automatisch auswählen, wodurch die richtige Komplexitätseinstellung während der Codierung automatisch ausgewählt werden kann.
  • Skriptbitrate. Geben Sie die Bitrate (in Bit/s) ein, die Sie für Skripts verwenden möchten. Der Wert muss zwischen 1.000 B/s und 10.000 B/s liegen. Geben Sie K für Kilobit ein.


Attribute

Attribute sind eine Sammlung von optionalen Einträgen, auch Metadaten genannt, die Informationen zu Ihrem Inhalt liefern. Die Attribute sind im codierten Datenstrom enthalten und können mit Suchtools oder benutzerdefinierten Anwendungen extrahiert werden, die auf dem SDK (Software Development Kit) von Microsoft Windows Media Format basieren. Zu den Standardattributen gehören Titel, Autor, Copyright und Beschreibung des Inhalts. Diese Attribute werden angezeigt, wenn der Inhalt in Windows Media Player und anderen Playeranwendungen wiedergegeben wird, die auf dem SDK von Windows Media Format basieren. Sie können benutzerdefinierte Attribute erstellen, wie z. B. das Datum, an dem der Inhalt bearbeitet wurde, der Name des Erstellers usw. Benutzerdefinierte Attribute werden in Windows Media Player nicht angezeigt, können jedoch mithilfe von Suchtools oder anderen benutzerdefinierten Programmen extrahiert werden, die mit dem SDK von Windows Media Format erstellt werden.

Klicken Sie auf Hinzufügen, um ein Attribut zu erstellen. Wenn Sie ein Attribut bearbeiten oder löschen möchten, wählen Sie ein Attribut aus der Liste aus, und klicken Sie dann entsprechend auf Bearbeiten oder Entfernen.


Hinzufügen der Bitrate

Geben Sie eine Bitrate in Bit/s ein. Geben Sie K für Kilobit, M für Megabit und G für Gigabit ein. Beachten Sie, dass die tatsächliche Bitrate etwas höher sein wird als die von Ihnen angegebene Zahl, da zur Bitrate noch der Overhead addiert wird.


Legal Notice

Windows Media Encoder-Bannergrafik

Rechtliche Hinweise

Die in diesen Unterlagen enthaltenen Angaben und Daten, einschließlich URLs und anderen Verweisen auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Die in den Beispielen verwendeten Firmen, sonstigen Namen und Daten sind frei erfunden, soweit nichts anderes angegeben ist. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Personen oder Ereignissen ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieses Dokuments für irgendwelche Zwecke vervielfältigt, in einem Datenempfangssystem gespeichert oder darin eingelesen werden oder übertragen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen usw.) dies geschieht.

Es ist möglich, dass Microsoft Rechte an Patenten bzw. angemeldeten Patenten, an Marken, Urheberrechten oder sonstigem geistigen Eigentum besitzt, die sich auf den fachlichen Inhalt dieses Dokuments beziehen. Das Bereitstellen dieses Dokuments gibt Ihnen jedoch keinen Anspruch auf diese Patente, Marken, Urheberrechte oder auf sonstiges geistiges Eigentum, es sei denn, dies wird ausdrücklich in den schriftlichen Lizenzverträgen von Microsoft eingeräumt.

© 2000-2002 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 und Win32s sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Andere in diesem Dokument aufgeführte Produkt- und Firmennamen sind möglicherweise Marken der jeweiligen Eigentümer.


Codierung mit zwei Durchläufen von Geräten

Wenn Geräte als Quelle dienen, können Sie die Codierung mit zwei Durchläufen unter den folgenden Bedingungen verwenden:

  • Gerätesteuerung ist aktiviert
  • Eine Datei wird codiert
  • Inhalt wird temporär gespeichert
  • EDL wird für den Inhalt eingerichtet

Verwandte Themen

  • Aktivieren der Gerätesteuerung


Neues Profil

Verwalten von Lizenzdienstanbietern und Generieren eines neuen Profils.

  • Hinzufügen oder Entfernen. Klicken Sie hier, um einen Anbieter hinzuzufügen oder zu entfernen.
  • Generieren. Nachdem Sie einen Anbieter aus der Liste ausgewählt haben, klicken Sie auf diese Option, um ein DRM-Profil zu generieren.

Anmerkung Anmerkung

  • Profile werden von Drittanbietern ausgegeben. Die von Ihnen beim Erstellen oder Bearbeiten eines Profils angegebenen Informationen werden über das Internet ausgetauscht.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt


Encoder bietet keine Unterstützung für Dateiübertragung

Die geladene Sitzungsdatei wurde von einem Dateiübertragungsprogramm erstellt. Der Encoder bietet keine Unterstützung für Dateiübertragung. Um Inhalt mit dieser Sitzungsdatei zu codieren, sollten Sie daher das Dateiübertragungsprogramm verwenden, mit dem die Sitzungsdatei erstellt wurde.


Ausgabeoption muss ausgewählt werden

Der codierte Inhalt muss in einer Datei oder einer Übertragung gespeichert werden.

Verwandte Themen

  • Ausgabeoptionen


Eingeben eines Servernamens

Geben Sie einen gültigen Windows Media-Servernamen ein. Sie können den NetBIOS-Namen (Network Basic Input/Output System), die IP-Adresse oder den DNS-Namen (Domain Name System) des Servers verwenden.

Verwandte Themen

  • Übertragen eines Datenstroms vom Encoder


NTSC- und PAL-Standardeinstellungen

Die folgende Tabelle enthält Informationen zu den mit dem NTSC-Standard kompatiblen Frameraten und Videogrößen.

Einstellung | Mögliche Werte
Framerate in Frames pro Sekunde (F/s) | 60; 30; 15; 10 und 7,5
Framegröße | 160 × 120 176 × 120 240 × 180 320 × 240 352 × 240 640 × 480 720 × 480

Die folgende Tabelle enthält Informationen zu den mit dem PAL-Standard kompatiblen Frameraten und Videogrößen.

Einstellung | Mögliche Werte
Framerate in F/s | 50; 25; 12,5; 8,3 und 6,25
Framegröße | 176 × 144 192 × 144 288 × 216 352 × 288 384 × 288 720 × 576 768 × 576

Verwandte Themen

  • Benutzerdefinierte Codierungseinstellungen – Allgemein


Optimieren der Leistung

Zum Erzielen der optimalen Systemleistung bei der Codierung stehen verschiedene Möglichkeiten zur Verfügung.

Verwandte Themen

  • Erzielen optimaler Systemleistung


Bitrate VBR (Höchstwert) (Registerkarte)

Die folgenden Einstellungen gelten für ein Profil, das eine auf maximalen Bitraten basierende VBR-Codierung verwendet.

  • Audioformat. Klicken Sie für den Audioinhalt auf eine Einstellung. Die Einstellung bestimmt die Zielaudiobitrate, die Abtastrate und ob der Ton von Mono- oder Stereolautsprechern wiedergegeben werden soll. Eine höhere Abtastrate führt zu Audio höherer Qualität, benötigt jedoch mehr Bandbreite oder führt zu einer größeren Datei. Im Idealfall möchten Sie die richtige Balance zwischen Bitrate und Abtastrate erreichen.
  • Audio-Peakbitrate. Geben Sie die maximale Bitrate ein, die Sie für den Audioinhalt verwenden möchten. Während der Codierung bestimmt der Encoder die Audioqualität, die ohne Überschreiten der maximalen Bitrate erreicht werden kann.
  • Peakpuffergröße. Geben Sie die maximale Puffergröße (in Sekunden) ein, die der Client warten soll, bevor der mit der Audio-Peakbitrate codierte Inhalt wiedergegeben wird. Wenn Sie die Codierung für die Wiedergabe auf einem Hardwaregerät durchführen, geben Sie die Puffergröße in Sekunden ein, die der Puffergröße dieses Geräts entspricht. Die Standardpuffergröße beträgt 3 Sekunden. Für optimale Ergebnisse sollte diese Zahl immer gleich oder kleiner als die Puffergröße sein (bei Verwendung von CBR-Codierung für Video) oder der Peakpuffergröße für Video entsprechen (bei Verwendung der auf maximalen Bitraten basierenden Codierung für Video).
  • Videogröße. Geben Sie die Größe (in Pixel) an, die Sie für das codierte Videomaterial verwenden möchten. Verwenden Sie Zahlen von 16 bis 2.000. Die Framegröße des codierten Videos wird so geändert, dass Sie der von Ihnen angegebenen Größe entspricht. Aktivieren Sie das Kontrollkästchen Wie Videoeingang, um die Framegröße des Quellvideos anzupassen.
  • Framerate. Geben Sie für den Videodatenstrom die Anzahl der Frames pro Sekunde (F/s) an. Die Menge, auf die Sie diesen Wert anpassen, richtet sich nach der Geschwindigkeit Ihres Computerprozessors und danach, ob Sie ein Video mit sehr viel oder sehr wenig Bewegung codieren. Ein Video mit sehr viel Bewegung sieht in der Regel natürlicher aus, wenn Sie eine höhere Framerate verwenden. Eine höhere Framerate führt jedoch zu einer höheren Prozessorbelastung. Die von Ihnen angegebene Einstellung stellt den maximalen F/s-Wert dar; der tatsächliche F/s-Wert kann niedriger sein.
  • Schlüsselframeintervall. Geben Sie die Anzahl der Sekunden ein, die als Abstand zwischen Schlüsselframes verwendet werden soll. Alle Frames zwischen Schlüsselframes sind Deltaframes, die weitaus kleiner sind als Schlüsselframes, jedoch eine schlechte Bildqualität aufweisen. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes erhöhen, wird die Videogröße (in Bytes) kleiner, da weniger Schlüsselframes verwendet werden. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes verringern, nimmt die Videogröße zu. Erhöhen Sie das Schlüsselframeintervall für Inhalt mit einem statischen Hintergrund, beispielsweise für Cartoons. Verringern Sie das Schlüsselframeintervall für Inhalt mit viel Bewegung, beispielsweise ein Sportereignis.
  • Videobitrate (durchschnittlich). Geben Sie die durchschnittliche Bitrate (in Bit/s) ein, die Sie für den Videoanteil Ihres Inhalts verwenden möchten. Geben Sie K für Kilobit, M für Megabit und G für Gigabit ein. Die Bitrate kann die durchschnittliche Bitrate jederzeit überschreiten, die Gesamtbitrate überschreitet jedoch die durchschnittliche Bitrate nicht.
  • Maximale Videobitrate. Geben Sie die maximale Bitrate (in Bit/s) ein, die Sie für den Videoinhalt verwenden möchten. Während der Codierung bestimmt der Encoder die Bildqualität, die ohne Überschreiten der maximalen Bitrate erreicht werden kann. Wenn Sie die Codierung für die Wiedergabe auf einem Hardwaregerät durchführen, beispielsweise auf einem DVD-Player, geben Sie die Lesegeschwindigkeit des Hardwaregeräts an.
  • Peakpuffergröße. Geben Sie die maximale Puffergröße (in Sekunden) ein, die der Client warten soll, bevor der mit der maximalen Videobitrate codierte Inhalt wiedergegeben wird. Wenn Sie die Codierung für die Wiedergabe auf einem Hardwaregerät durchführen, geben Sie die Puffergröße in Sekunden ein, die der Puffergröße dieses Geräts entspricht. Die Standardpuffergröße ist 5 Sekunden.
  • Decoderkomplexität. Wenn Sie ein anderes Hardwaregerät als einen Computer verwenden möchten, können Sie eine Komplexitätskategorie für den codierten Inhalt angeben. Einige Hardwaregeräte unterstützen nur bestimmte Kategorien. (Weitere Informationen finden Sie in der Dokumentation zu Ihrem Gerät.) In der Regel sollten Sie Automatisch auswählen, wodurch die richtige Komplexitätseinstellung während der Codierung automatisch ausgewählt werden kann.
  • Skriptbitrate. Geben Sie die Bitrate (in Bit/s) ein, die Sie für Skripts verwenden möchten. Der Wert muss zwischen 1.000 B/s und 10.000 B/s liegen. Geben Sie K für Kilobit ein.


Einstellungen pro Bitrate, reine Audiodatenströme

Die folgenden Einstellungen gelten für ein Profil, das einen reinen Audiodatenstrom codiert.

Klicken Sie für den Audioinhalt auf eine Einstellung. Eine höhere Abtastrate führt zu Audio höherer Qualität, jedoch auch zu einer höheren Bandbreite.

Geben Sie für Audioinhalt, den Sie mit der auf maximalen Bitraten basierenden VBR-Codierung codieren, die gewünschte maximale Bitrate (in Bit/s) ein. Geben Sie K für Kilobit, M für Megabit und G für Gigabit ein. Während der Codierung bestimmt der Encoder die Audioqualität, die ohne Überschreiten der maximalen Bitrate erreicht werden kann. Legen Sie zudem die maximale Puffereinstellung fest.


Einstellungen pro Bitrate (Registerkarte "CBR")

Die folgenden Einstellungen gelten für ein Profil, das die CBR-Codierung verwendet.

  • Audioformat. Klicken Sie für den Audioinhalt auf eine Einstellung. Diese Einstellung bestimmt die Zielaudiobitrate, die Abtastrate und ob der Ton von Mono- oder Stereolautsprecher wiedergegeben werden soll. Eine höhere Abtastrate führt zu Audio höherer Qualität, benötigt jedoch mehr Bandbreite oder führt zu einer größeren Datei. Im Idealfall möchten Sie die richtige Balance zwischen Bitrate und Abtastrate erreichen. Beachten Sie, dass der Audiodatenstrom die verfügbare Netzwerkbandbreite mit anderen Video- und Skriptdatenströmen gemeinsam nutzen muss.
  • Videogröße. Geben Sie die Größe (in Pixel) an, die Sie für das codierte Video verwenden möchten. Verwenden Sie Zahlen von 16 bis 2.000. Die Framegröße des codierten Videos wird so geändert, dass sie der von Ihnen angegebenen Größe entspricht. Aktivieren Sie das Kontrollkästchen Wie Videoeingang, um die Framegröße des Quellvideos anzupassen.
  • Framerate. Geben Sie für den Videodatenstrom die Frames pro Sekunde (F/s) an. Die Menge, auf die Sie diesen Wert anpassen, richtet sich nach der Geschwindigkeit des Computerprozessors und danach, ob Sie ein Video mit sehr viel oder sehr wenig Bewegung codieren. Ein Video mit sehr viel Bewegung sieht in der Regel natürlicher aus, wenn Sie eine höhere Framerate verwenden. Eine höhere Framerate führt jedoch zu einer höheren Prozessorbelastung. Die von Ihnen angegebene Einstellung ist die maximale Framerate pro Sekunde (F/s). Aufgrund verschiedener Faktoren, wie die Einstellung für die Videogröße und die verfügbare Bandbreite, kann die tatsächlich erreichte Framerate pro Sekunde niedriger sein.
  • Schlüsselframeintervall. Geben Sie die Anzahl der Sekunden ein, die als Abstand zwischen Schlüsselframes verwendet werden soll. Alle Frames zwischen Schlüsselframes sind Deltaframes, die weitaus kleiner sind als Schlüsselframes, jedoch eine schlechte Bildqualität aufweisen. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes erhöhen, wird die Videogröße (in Bytes) kleiner, da weniger Schlüsselframes verwendet werden. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes verringern, nimmt die Videogröße zu. Erhöhen Sie das Schlüsselframeintervall für Inhalt mit einem statischen Hintergrund, beispielsweise für Cartoons. Verringern Sie das Schlüsselframeintervall für Inhalt mit viel Bewegung, beispielsweise ein Sportereignis.
  • Videobitrate. Geben Sie die Bitrate (in Bit/s) ein, die Sie für den Videoanteil Ihres Inhalts verwenden möchten. Geben Sie K für Kilobit, M für Megabit und G für Gigabit ein. Die Angabe schließt den Overhead aus, der für den Netzwerkverkehr benötigt wird. Beachten Sie, dass der Videodatenstrom die verfügbare Netzwerkbandbreite mit den Audio- und Skriptdatenströmen gemeinsam nutzen muss.
  • Puffergröße. Geben Sie die Anzahl der Sekunden ein, die der Inhalt gespeichert werden soll, bevor die Codierung beginnt. Ein größerer Puffer führt zu Inhalt höherer Qualität, belegt jedoch mehr Speicherplatz. Beim Codieren von Inhalt wird der Codierungsprozess um den Zeitraum verzögert, der im Puffer angegeben ist. Der Inhalt wird auch beim Ausstrahlen an einen Player um denselben Zeitraum verzögert. Beim Ausstrahlen einer Übertragung läuft der im Player wiedergegebene Inhalt um den Zeitraum hinter dem Liveereignis versetzt, der unter Puffergröße angegeben wurde. Die Standardpuffergröße beträgt 5 Sekunden.
  • Qualität der Videowiedergabe. Geben Sie eine Zahl von 0 bis 100 ein, wobei 0 das natürlichste und 100 das schärfste Bild darstellt. Das Videobild erscheint natürlich, wenn Objekte auf dem Bildschirm problemlos von einer Position an eine andere verschoben werden und die Kanten der Objekte regelmäßig sind. Das Videobild erscheint klar, wenn Bilder und Bewegung gut definiert und klar umrissen sind. Je höher die Klarheit, desto unnatürlicher wirkt das Videobild. Vergessen Sie nicht, dass sich eine höhere Klarheit je nach Video auf die Framerate auswirken kann. Wenn Ihr Video beispielsweise sehr viel Bewegung enthält, werden durch Erhöhen der Klarheit möglicherweise die Frames pro Sekunde verringert.
  • Decoderkomplexität. Wenn Sie ein anderes Hardwaregerät als einen Computer verwenden möchten, können Sie eine Komplexitätskategorie für den codierten Inhalt angeben. Einige Hardwaregeräte unterstützen nur bestimmte Kategorien. (Weitere Informationen finden Sie in der Dokumentation zu Ihrem Gerät.) Beachten Sie, dass die Option Komplex für die Wiedergabe auf Computern vorgesehen ist. In der Regel sollten Sie Automatisch auswählen, wodurch die richtige Komplexitätseinstellung während der Codierung automatisch ausgewählt werden kann.
  • Skriptbitrate. Geben Sie die Bitrate (in Bit/s) ein, die Sie für Skripts verwenden möchten. Der Wert muss zwischen 1.000 B/s und 10.000 B/s liegen. Geben Sie K für Kilobit ein.


Plug-Ins

Wählen Sie aus, welche Transformations-Plug-Ins Sie mit den Quellen in einer Sitzung verwenden möchten.

  • Liste der Quellen. Wählen Sie die Quelle aus, zu der Sie das Plug-In hinzufügen möchten. (Nur erforderlich bei Mehrfachquellensitzungen.)
  • Typ des Transformations-Plug-Ins. Klicken Sie auf Audio oder Video, um die Transformations-Plug-Ins anzuzeigen, die derzeit auf dem Computer mit dem Encoder installiert und registriert sind.
  • Registrieren. Klicken Sie auf diese Option, um das Dialogfeld Transformations-Plug-Ins für die Registrierung und Aufhebung der Registrierung anzuzeigen. Im Dialogfeld werden die Transformations-Plug-Ins angezeigt, die derzeit auf dem Computer mit dem Encoder installiert sind. Sie müssen ein Plug-In zunächst registrieren, bevor Sie es verwenden können. Wenn Sie ein Plug-In registrieren möchten, wählen Sie es im Dialogfeld aus, und klicken Sie auf OK.
  • Nach rechts bewegen und Nach links bewegen. Klicken Sie auf die Schaltfläche Nach rechts bewegen (>>), um ein Plug-In zu einer Quelle hinzuzufügen. Klicken Sie auf die Schaltfläche Nach links bewegen (<<), um ein Plug-In aus einer Quelle zu entfernen. Verwenden Sie die NACH-UNTEN- und NACH-OBEN-TASTE, um die Reihenfolge neu anzuordnen, in der die Plug-Ins auf die Quelle angewendet werden.
  • Konfigurieren. Klicken Sie auf diese Option, um die Eigenschaften des ausgewählten Plug-Ins zu bearbeiten.

    Vorsicht Vorsicht

    • Im Dialogfeld Transformations-Plug-Ins für die Registrierung und Aufhebung der Registrierung werden alle Transformations-Plug-Ins aufgelistet, die auf dem Computer mit dem Encoder zur Verfügung stehen. Einige der Plug-Ins sind möglicherweise für die Verwendung mit dem Encoder nicht geeignet und führen zu unerwarteten Ergebnissen, falls Sie sie mit dem Encoder verwenden.


Sicherheit

Legen Sie fest, ob Sie Digital Rights Management zum Schützen Ihres Inhalts oder zum Einbetten eines Wasserzeichens in Ihren Inhalt verwenden möchten.

  • DRM verwenden, um den Inhalt vor unberechtigtem Zugriff zu schützen. Wählen Sie den Schutz Ihres Inhalts mithilfe von DRM. Sie müssen ein Profil erstellen, bevor Sie DRM verwenden können.
  • DRM-Profil. Klicken Sie auf das DRM-Profil, das Sie für den Inhalt verwenden möchten, den Sie in dieser Sitzung codieren. Ein DRM-Profil enthält den Schlüssel, die Schlüssel-ID, den URL für den Lizenzserver, die Inhalts-ID und andere zur Inhaltsverschlüsselung erforderlichen Informationen. Wenn Ihnen nicht bereits ein Profil zur Verfügung steht oder wenn Sie ein Profil erstellen möchten, klicken Sie auf Neu. Wenn Sie ein vorhandenes Profil entfernen möchten, klicken Sie auf Löschen. Wenn Sie das Profil bearbeiten möchten, klicken Sie auf Bearbeiten. Wenn Sie ein Profil verwenden möchten, das sich auf einem anderen Computer befindet, klicken Sie auf Importieren, und geben Sie dann den Pfad des Profils ein, das Sie verwenden möchten. Wenn Sie ein Profil mit einem anderen Computer gemeinsam nutzen möchten, klicken Sie auf Exportieren, und geben Sie dann den entsprechenden Pfad ein.
  • Schlüssel-ID. Die Schlüssel-ID wird nur angezeigt, wenn Sie ein Profil erstellen. Diese ID kann nicht bearbeitet werden. Die Schlüssel-ID befindet sich in einer Headerdatei, die mit dem codierten Inhalt verbunden ist. Ein Player liest die Headerdatei, sucht die Schlüssel-ID und teilt diese dem Lizenzserver mit. Wenn der Lizenzserver die Schlüssel-ID erkennt, wird eine Lizenz ausgestellt.
  • Digitales Wasserzeichen einbetten. Wählen Sie aus, ob ein Wasserzeichen zum Audiodatenstrom, Videodatenstrom oder zu beiden Datenströmen hinzugefügt werden soll. Ein Wasserzeichen bettet einen digitalen Fingerabdruck in einen Datenstrom ein. Diese Informationen können von verschiedenen Softwareprogrammen entschlüsselt werden, um Informationen, wie Copyright, Bestimmungen zur Verwendung und Autor, anzuzeigen. Ein Wasserzeichen zeigt die Authentizität des Audio- oder Videoinhalts an. Sie müssen ein Drittanbieter-Plug-In erwerben und registrieren, um mit Wasserzeichen arbeiten zu können. Weitere Informationen zum Erwerben eines Wasserzeichen-Plug-Ins erhalten Sie auf der Microsoft-Website.
  • Konfigurieren. Klicken Sie auf diese Option, falls Sie für das von Ihnen verwendete Wasserzeichen-Plug-In eine Konfigurationsdatei angeben müssen.

Verwandte Themen

  • Verwenden von Digital Rights Management zum Schützen von Inhalt


Übertragungskennwort

Geben Sie Ihren Benutzernamen und das Kennwort zum Zugreifen auf den Windows Media-Server ein. Sie müssen diese Anmeldeinformationen angeben, wenn Sie einen Datenstrom per Push an einen Windows Media-Server übertragen, auf dem ein Authentifizierungs-Plug-In aktiviert ist.


Veröffentlichen von Dateien

Wenn Sie nach Abschluss des Assistenten zum Ausstrahlen des Inhalts bereit sind, können Sie die Dateien direkt in einem freigegebenen Ordner speichern. Anderenfalls können Sie die Dateien an einem temporären Speicherort speichern. Kopieren Sie die Dateien in diesem Fall vor dem Beginn der Ausstrahlung in den freigegebenen Ordner.


Übertragungssicherheit

Windows Media Encoder unterstützt bis zu fünf direkte Verbindungen zu einer Übertragung. Sie können den Zugriff auf eine Übertragung einschränken, indem Sie die IP-Adressen angeben, die auf die Übertragung zugreifen bzw. nicht zugreifen dürfen.

Verwandte Themen

  • Beschränken des Zugriffs auf eine Übertragung


Plug-In-Registrierung

In diesem Dialogfeld werden die Plug-Ins aufgelistet, die auf Ihrem Computer zur Verfügung stehen. Nicht alle Plug-Ins sind zur Verwendung mit Windows Media Encoder geeignet.

Für die Registrierung eines Plug-Ins benötigen Sie die Anmeldeinformationen des Administrators für den Computer mit dem Encoder.


Skript (Fensterbereich)

Der Fensterbereich Skript enthält Steuerelemente, mit denen bei der Codierung Skriptbefehle in den Datenstrom eingefügt werden können. Diese Befehle schließen z. B. Beschriftungen (Textzeichenfolgen), URLs und benutzerdefinierte Skriptbefehle ein. Der Eintrag Skripts insgesamt im Fensterbereich Monitor nimmt mit jedem eingefügten Skript zu.


Übertragungssicherheit

Windows Media Encoder unterstützt bis zu fünf direkte Verbindungen bei einer Übertragung. Sie können angeben, welcher Computer bzw. welche Gruppe von Computern auf den Encoder zugreifen kann. Verwenden Sie die IP-Adresse, um den Zugriff für einzelne Computer zu gewähren oder zu verweigern. Verwenden Sie die IP-Maske, um den Zugriff für eine Gruppe von Computern zu gewähren oder zu verweigern.

Wenn Sie den Zugriff auf eine Übertragung mithilfe der IP-Adresse beschränken, können Sie IPv6-Adressen (Internet Protocol, Version 6) und IPv4-Adressen (Internet Protocol, Version 4) angeben. IPv6 ist die neueste Version von Internet Protocol und wurde entwickelt, um dem schnell wachsenden Bedarf nach eindeutigen IP-Adressen gerecht zu werden. IPv6 erhöht die IP-Adressengröße von 32 Bit auf 128 Bit, damit mehr Hierarchieebenen für die Adressierung und eine größere Anzahl adressierbarer Knoten unterstützt werden können. Weitere Informationen zu IPv6 finden Sie auf der IPv6-Seite der Microsoft-Website.

Zum Festlegen eines Adressbereichs wird jedes Bit in einer IP-Maske mit dem entsprechenden Bit in der IP-Adresse verglichen. Beträgt der Wert in der Maske 1, wird das entsprechende Bit in der IP-Adresse zum Bereich hinzugefügt. Beträgt der Wert in der Maske 0, wird jeder Wert akzeptiert. Wenn z. B. in Dezimalschreibweise die IP-Adresse in der Liste 134.123.123.20 und die Maske 255.255.255.0 lautet, gehören alle IP-Adressen von 134.123.123.0 bis 134.123.123.255 zum Bereich. Mit einer Maske von 255.255.255.128 gehören alle IP-Adressen von 134.123.123.0 bis 134.123.123.127 zum Bereich. Wenn Sie eine ungültige Maske angeben, wird die IP-Adresse ignoriert.


Leistung (Registerkarte)

Wenn Sie die Leistungsfähigkeit des Computers mit dem Encoder bei der Codierung permanent überschreiten, können Sie mit den Einstellungen auf dieser Registerkarte eine erfolgreiche Codierung sicherstellen. Sie können auswählen, ob der Schwerpunkt auf besserer Leistung oder auf besserer Qualität des Inhalts liegen soll. Bei der Einstellung für bessere Qualität wird mehr CPU-Leistung in Anspruch genommen, bei der Einstellung für bessere Leistung weniger. Diese Einstellungen gelten für Sitzungen, die den Windows Media Video 9- oder den Windows Media Video 8.1-Codec verwenden.

Möglicherweise müssen Sie verschiedene Einstellungskombinationen ausprobieren, um ein optimales Gleichgewicht von Qualität und Leistung zu erreichen. Aktivieren Sie das Kontrollkästchen Standardeinstellungen verwenden, wenn Sie zu den von den Codecs verwendeten Einstellungen zurückkehren möchten.

Sie können die Änderungen auf alle Sitzungen anwenden oder Einstellungen nur für die aktuelle Sitzung ändern.

Anmerkung Anmerkung

  • Zum Erzielen der optimalen Leistung bei der Codierung stehen verschiedene weitere Möglichkeiten zur Verfügung.

Verwandte Themen

  • Erzielen optimaler Systemleistung


Server (Registerkarte)

Auf der Registerkarte Server werden beim Übertragen eines Datenstroms über einen Windows Media-Server per Push Statusinformationen zu einem Windows Media-Server angezeigt. Außerdem enthält die Registerkarte Angaben zur Anzahl der Player, die momentan mit dem Windows Media-Server verbunden sind (nur bei Unicastdatenströmen).

Sie müssen über Berechtigungen zum Zugreifen auf Windows Media-Dienste über DCOM verfügen, um die Statusinformationen zu erhalten.


Weitere Optionen

Ändern Sie den Namen des Encoders, verwenden Sie eine benutzerdefinierte Paketgröße, erstellen Sie einen Zeitcode, oder aktivieren Sie einen temporären Speicher für den Inhalt.

  • Identifikationsname. Ein Encodername wird automatisch zugewiesen. Sie können den Namen jedoch gegebenenfalls bearbeiten. Der Name wird verwendet, um Encoder zu unterscheiden, wenn auf demselben Computer mehrere Instanzen ausgeführt werden.
  • Maximale Paketgröße. Gibt die maximale Größe in Bytes von UDP-Paketen (User Datagram Protocol) an, die über das Netzwerk ausgestrahlt werden. Diese Einstellung wird auf einzelnen Bitrateninhalt angewendet, der von einem Windows Media-Server ausgestrahlt wird. Die maximale Standardpaketgröße ist 16.000 Bytes. Die tatsächliche Paketgröße wird während der Codierung berechnet. Wenn Sie feststellen, dass Pakete während der Übertragung verloren gehen oder fragmentiert werden, können Sie die Option Benutzerdefiniert verwenden, um die maximale Größe der Pakete zu reduzieren. Beachten Sie, dass Sie beim Codieren von Audioinhalt zu hohen Bitraten die maximale Paketgröße überschreiten können.
  • Zeitcode. Wählen Sie diese Option aus, wenn Sie die Suche auf Frameebene aktivieren möchten. Sie können den bereits im Quellvideo vorhandenen Zeitcode beibehalten oder einen Zeitcode erstellen. Wenn Sie einen Zeitcode erstellen, können Sie die Uhrzeit im Format hh:mm:ss:fm eingeben, zu der der Zeitcode beginnen soll. Außerdem können Sie das Format des Quellvideos (beispielsweise NTSC) auswählen.
  • Inhalt vorübergehend auf Festplatte speichern. Wenn Sie von Geräten in eine Datei aufzeichnen, können Daten temporär gespeichert werden, falls die Codierung mit dem Aufnahmeprozess nicht Schritt halten kann. Aktivieren Sie das Kontrollkästchen Auf Festplatte aufzeichnen, dann codieren, um alle Daten in einem Schritt zu erfassen und in einem zweiten Schritt zu codieren. So gehen beim Aufzeichnen einer großen Datenmenge keine Frames verloren. Die Codierung wird angehalten, wenn der freie Mindestspeicherplatz erreicht ist. Um Daten im Umfang von einer Stunde, denen ein digitales Gerät als Quelle dient, zu speichern, werden ungefähr 15 GB Speicherplatz benötigt. Die Codierung wird automatisch angehalten, wenn der niedrige Festplattenspeicherbetrag erreicht ist.

Verwandte Themen

  • Codieren oder Archivieren einer Übertragung in einer Datei


Allgemein (Registerkarte)

Die im Folgenden aufgeführten Optionen betreffen das Aussehen des Encoder-Hauptfensters. Viele dieser Optionen sind standardmäßig ausgewählt. Sie können die Optionen jedoch je nach Bedarf aktivieren oder deaktivieren.

  • Automatisch die benötigten Fensterbereiche für die aktuelle Sitzung anzeigen. Aktivieren Sie dieses Kontrollkästchen, um im Encoder-Hauptfenster basierend auf der im Assistenten für neue Sitzungen getroffenen Auswahl Fensterbereiche anzuzeigen. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie das Menü Ansicht im Encoder-Hauptfenster verwenden möchten, um die anzuzeigenden Fensterbereiche auszuwählen.
  • Größe des Hauptfensters anpassen, wenn Videozoomfaktor zu hoch ist. Aktivieren Sie dieses Kontrollkästchen, um die Größe des Encoder-Hauptfensters bei Vergrößerung der Ein- und Ausgabeanzeigen anzupassen. Wenn Sie dieses Kontrollkästchen deaktivieren, werden die Anzeigen möglicherweise zum Teil verdeckt dargestellt. Diese Einstellung hat keine Auswirkung auf die codierte Bildgröße.

    Anmerkung Anmerkung

    • Große Ein- und Ausgabeanzeigen können eine negative Auswirkung auf die CPU-Leistung bei der Codierung haben.
  • Während der Bildschirmaufzeichnung Encoder-Fenster minimieren. Aktivieren Sie dieses Kontrollkästchen, um den Encoder automatisch zu minimieren, wenn Sie einen Bildschirm aufzeichnen. Bei einer Sitzung zur Codierung in eine Datei wird der Encoder beim Wiederherstellen des Encoder-Fensters angehalten. Bei einer Übertragungssitzung wird die Codierung auch dann fortgesetzt, wenn Sie das Encoder-Fenster wiederherstellen.
  • Vor dem Beenden der Codierung warnen. Aktivieren Sie dieses Kontrollkästchen, damit jedes Mal eine Warnmeldung gesendet wird, wenn der Encoder beendet wird.
  • Dialogfeld "Neue Sitzung" beim Start anzeigen. Aktivieren Sie dieses Kontrollkästchen, um das Dialogfeld beim Start des Encoders anzuzeigen. Im Dialogfeld Neue Sitzung steht eine Reihe von Assistenten oder Vorlagen zur Auswahl, die beim Einrichten von Sitzungen hilfreich sind.
  • Dialogfeld "Codierungsergebnisse" am Ende der Codierung anzeigen. Aktivieren Sie dieses Kontrollkästchen, um nach dem Abschluss der Codierung automatisch das Dialogfeld Codierungsergebnisse anzuzeigen. Wenn Sie dieses Kontrollkästchen deaktivieren, können Sie die Ergebnisse mit dem Befehl Codierungsergebnisse im Menü Ansicht anzeigen.
  • Alle Tipps anzeigen. Klicken Sie auf diese Schaltfläche, wenn Sie Tipps anzeigen möchten.
  • Standardvideoformat. Wählen Sie das Videoformat (NTSC oder PAL) aus, das bei der Codierung verwendet werden soll. Diese Option gilt für die Einstellungen für Ziel, Video und Audio auf der Registerkarte Komprimierung im Fensterbereich Eigenschaften.


Verarbeitung

Wählen Sie aus, welche Optionen Sie für die Vorverarbeitung von Inhalt verwenden möchten, um die Qualität des codierten Inhalts zu verbessern.

Video

  • Keine. Klicken Sie auf diese Option, wenn Sie keine Filter zur Vorverarbeitung des Inhalts anwenden möchten. Sie sollten diese Option nur dann verwenden, wenn der Inhalt bereits im progressiven Scananzeigeformat vorliegt.
  • Zeilensprünge entfernen. Klicken Sie auf diese Option, um die Felder des Videos, die Zeilensprünge enthalten, in einzelne Frames aufzuteilen. Dies kann zu einem natürlicheren Videobild führen.
  • Umgekehrte Filmabtastung (Inverse Telecine). Wenn Ihr Quellvideo mit Telecine (Filmabtastung) erstellt wurde, klicken Sie auf diese Option, um die zusätzlichen Frames zu entfernen, die während der Filmabtastung hinzugefügt wurden. Klicken Sie auf Automatisch, damit das Telecine-Muster automatisch erkannt wird. Wenn das Telecine-Muster im Inhalt kohärent ist, klicken Sie in der Liste auf die Einstellung, die dem ersten Frame im Quellvideo entspricht.
  • Zeilensprünge beibehalten. Klicken Sie auf diese Option, wenn das Quellvideo Zeilensprünge enthält und Sie die Zeilensprünge im codierten Video beibehalten möchten.
  • Erkennen. Klicken Sie auf diese Option, wenn Sie nicht wissen, ob der Inhalt Zeilensprünge enthalten hat oder ob Telecine (Filmabtastung) auf den Inhalt angewendet wurde. Der Encoder analysiert den Inhalt und empfiehlt die Anwendung des geeigneten Filters.
  • Pixelformat. Wählen Sie ein zu verwendendes Pixelformat aus.
  • Vertikal kippen. Wählen Sie aus, ob das Videobild umgedreht sein soll. Umgedrehte Videobilder können durch die Verwendung eines Aufnahmegeräts zum Erstellen von AVI-Dateien zustande kommen, die nicht völlig mit den veröffentlichten Spezifikationen übereinstimmen. Umgekehrte Videobilder beziehen sich in der Regel auf das vom Gerät verwendete Pixelformat.

Audio

  • Optimierung von Voicecodec. Wenn Sie den Codec von Windows Media Audio 9 Voice verwenden, können Sie das Verhalten des Codecs optimieren, indem Sie angeben, ob der Inhalt nur aus Sprache besteht oder auch Musikanteile enthält. Klicken Sie auf Audio (Schwerpunkt Sprache), wenn Ihr Inhalt sowohl Sprache als auch Musik enthält. Während der Codierung verwendet der Codec automatisch den geeigneten Algorithmus, um die Codierung für den Inhalt (Sprache oder Musik) zu optimieren. Oder Sie erstellen eine Optimierungsdefinitionsdatei, mit der der Audioinhalt optimiert wird, indem Sie die Stellen in der Datei angeben, an denen die Musik beginnt und endet.
  • 5.1-Audio. Wenn Sie Mehrkanal-Audioinhalt codieren, werden die Kanäle automatisch in zwei Kanäle für die Wiedergabe mit Stereolautsprechern gewandelt. Sie können jedoch die Einstellungen in diesem Bereich verwenden, um die Fold-Down-Verteilung anzupassen. Bei den von Ihnen angegebenen Werten handelt es sich nicht um absolute Werte. Stattdessen wird die Verstärkung der Kanäle standardisiert, um eine Verzerrung zu vermeiden. Die von Ihnen angegebenen Werte müssen zwischen 0 und -144 Dezibel liegen. (Diese Option steht nicht zur Verfügung, wenn Sie 7.1-Audio codieren.)

Verwandte Themen

  • Optimieren von Video- und Audiomaterial
  • Verwenden von Mehrkanal-Audiodateien als Quelle


Quelle (Fensterbereich)

Im Fensterbereich Quelle werden alle Quellen in der aktuellen Sitzung aufgeführt. Sie können während der Codierung zwischen Quellen wechseln, indem Sie auf die entsprechende Schaltfläche für die Quelle klicken.


Statistik (Registerkarte)

Auf der Registerkarte Statistik werden Informationen zu den Audio- und Videodaten bei der Ein- und Ausgabe angezeigt. Dazu gehören u. a. die Anzahl der Kanäle, die Abtastrate, die Framerate, verworfene Frames, die durchschnittliche Bitrate usw.


Beenden während der Codierung des zweiten Durchlaufs

Die aktuelle Codierungssitzung verwendet Codierung mit zwei Durchläufen. Wenn Sie die Codierung jetzt beenden, wird der zweite Durchlauf nicht abgeschlossen. Der codierte Inhalt ist in diesem Fall möglicherweise nicht gültig.

Verwandte Themen

  • Informationen zu Codierungen mit einem oder zwei Durchläufen


Erstellen einer Datei im Datenstromformat

Dateien im Datenstromformat enthalten Informationen, die Player zum Entschlüsseln eines Multicastdatenstroms benötigen. Sie müssen diese Datei nur generieren, wenn Sie mit dem Beginn der Codierung warten möchten, bis der Server die Verbindung zum Encoder initiiert hat. (Wenn Sie mit der Codierung beginnen, bevor der Server die Verbindung zum Encoder initiiert hat, muss keine Datei im Datenstromformat generiert werden, da der Server das Datenstromformat automatisch erkennt.) Nach dem Generieren der Datei müssen Sie sie an den Serveradministrator übermitteln. Im Rahmen der Einrichtung der Multicastankündigung für die Übertragung identifiziert der Serveradministrator die Datei als Speicherort der Datenstromformate für den Datenstrom. Dateien im Datenstromformat verfügen über die Dateinamenerweiterung ASF.

Verwandte Themen

  • Aktivieren von Clients für das Anfordern eines Datenstroms vom Encoder per Pull


Skript (Fensterbereich)

Dieser Fensterbereich wird angezeigt, wenn Sie eine Codierungssitzung zum Verwenden des Skriptquelltyps konfiguriert haben. Verwenden Sie die Registerkarte Quellen im Fensterbereich Eigenschaften, um Skripts zur Sitzung hinzuzufügen.

Verwandte Themen

  • Einfügen von Skriptbefehlen


Quelle (Fensterbereich)

Dieser Fensterbereich wird angezeigt, wenn Sie eine Codierungssitzung mit mehreren Quellen konfiguriert haben. Sie können während der Codierung zwischen den Quellen wechseln.


Peakbitrate VBR (Registerkarte)

Die folgenden Einstellungen gelten für ein Profil, das eine auf Bitraten basierende VBR-Codierung verwendet.

  • Audioformat. Klicken Sie für den Audioinhalt auf eine Einstellung. Diese Einstellung bestimmt die Zielaudiobitrate, die Abtastrate und ob der Ton von Mono- oder Stereolautsprechern wiedergegeben werden soll. Eine höhere Abtastrate führt zu Audio höherer Qualität, jedoch auch zu einer größeren Datei.
  • Videogröße. Geben Sie die Größe (in Pixel) an, die Sie für das codierte Video verwenden möchten. Verwenden Sie Zahlen von 16 bis 2.000. Die Framegröße des codierten Videos wird so geändert, dass Sie der von Ihnen angegebenen Größe entspricht. Aktivieren Sie das Kontrollkästchen Wie Videoeingang, um die Framegröße des Quellvideos anzupassen.
  • Framerate. Geben Sie für den Videodatenstrom die Anzahl der Frames pro Sekunde (F/s) an. Die Menge, auf die Sie diesen Wert anpassen, richtet sich nach der Geschwindigkeit Ihres Computerprozessors und danach, ob Sie ein Video mit sehr viel oder sehr wenig Bewegung codieren. Ein Video mit sehr viel Bewegung sieht in der Regel natürlicher aus, wenn Sie eine höhere Framerate verwenden. Eine höhere Framerate führt jedoch zu einer höheren Prozessorbelastung. Die von Ihnen angegebene Einstellung stellt den maximale F/s-Wert dar; der tatsächliche F/s-Wert kann niedriger sein.
  • Schlüsselframeintervall. Geben Sie die Anzahl der Sekunden ein, die als Abstand zwischen Schlüsselframes verwendet werden soll. Alle Frames zwischen Schlüsselframes sind Deltaframes, die weitaus kleiner sind als Schlüsselframes, jedoch eine schlechte Bildqualität aufweisen. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes erhöhen, wird die Videogröße (in Bytes) kleiner, da weniger Schlüsselframes verwendet werden. Wenn Sie den zeitlichen Abstand zwischen Schlüsselframes verringern, nimmt die Videogröße zu. Erhöhen Sie das Schlüsselframeintervall für Inhalt mit einem statischen Hintergrund, beispielsweise für Cartoons. Verringern Sie das Schlüsselframeintervall für Inhalt mit viel Bewegung, beispielsweise ein Sportereignis.
  • Videobitrate (durchschnittlich). Geben Sie die durchschnittliche Bitrate (in Bit/s) ein, die Sie für den Videoanteil Ihres Inhalts verwenden möchten. Geben Sie K für Kilobit, M für Megabit und G für Gigabit ein. Die Bitrate kann die durchschnittliche Bitrate jederzeit überschreiten, die Gesamtbitrate überschreitet jedoch die durchschnittliche Bitrate nicht.
  • Decoderkomplexität. Wenn Sie ein anderes Hardwaregerät als einen Computer verwenden möchten, können Sie eine Komplexitätskategorie für den codierten Inhalt angeben. Einige Hardwaregeräte unterstützen nur bestimmte Kategorien. (Weitere Informationen finden Sie in der Dokumentation zu Ihrem Gerät.) In der Regel sollten Sie Automatisch auswählen, wodurch die richtige Komplexitätseinstellung während der Codierung automatisch ausgewählt werden kann.
  • Skriptbitrate. Geben Sie die Bitrate (in Bit/s) ein, die Sie für Skripts verwenden möchten. Der Wert muss zwischen 1.000 B/s und 10.000 B/s liegen. Geben Sie K für Kilobit ein.


URL zu den Dateien

Player müssen auf die Dateien zugreifen können. Die Dateien müssen daher entweder auf dem Webserver abgelegt werden, wenn der Zugriff über HTTP erfolgen soll, oder in einem freigegebenen Ordner, wenn Sie den Zugriff über einen UNC-Pfad (Universal Naming Convention) bereitstellen. Wenn Sie einen UNC-Pfad angeben, muss der Player für diesen Pfad mindestens die Leseberechtigung haben.


Video (Fensterbereich)

Im Fensterbereich Video wird der zu codierende Inhalt angezeigt. Je nach Inhaltstyp können Sie die Anzeige anpassen, so dass nur der vorab codierte Inhalt, nur der codierte Inhalt oder beides angezeigt wird. In den folgenden Fällen ist die Anzeige von vorab codiertem Inhalt im Bereich Eingabe nicht möglich:

  • Sie zeichnen einen Bildschirm auf.
  • Sie verwenden die Funktion zur Zeilensprungvermeidung mit AVI- oder MPG-Dateien.
  • Sie verwenden eine Windows Media-Datei mit der Dateinamenerweiterung WMV oder ASF als Eingabe, die dieselben Eigenschaften wie die Ausgabe aufweist.
  • Sie verwenden eine Videoaufnahmekarte, die die Anzeige einer Bildvorschau vor dem Codieren nicht unterstützt.
  • Sie haben sich entschlossen, Inhalt vorübergehend auf der Festplatte zu speichern, und dabei möchten Sie Inhalt zuerst auf der Festplatte aufzeichnen und dann codieren. (Der Inhalt wird jedoch bei Beendigung der Codierung angezeigt.)

In den folgenden Fällen ist die Anzeige von codiertem Inhalt im Bereich Ausgabe nicht möglich:

  • Sie verwenden ein Bildschirmaufzeichnungsprofil oder ein nicht komprimiertes Profil.
  • Sie verwenden eine Windows Media-Datei mit der Dateinamenerweiterung WMV oder ASF als Eingabe, die dieselben Eigenschaften wie die Ausgabe aufweist.
  • Sie führen eine Codierung mit zwei Durchläufen aus, und der Encoder befindet sich im ersten Durchlauf.
  • Sie haben sich entschlossen, Inhalt vorübergehend auf der Festplatte zu speichern, und dabei möchten Sie Inhalt zuerst auf der Festplatte aufzeichnen und dann codieren. (Der Inhalt wird jedoch bei Beendigung der Codierung angezeigt.)

Anmerkung Anmerkungen

  • Das im Bereich Ausgabe angezeigte Video weist möglicherweise einen stärkeren Blockeffekt auf als bei der Wiedergabe in Windows Media Player, da der Player Blockentfernungsfilter enthält, die im Bereich Ausgabe nicht zur Verfügung stehen. Der Blockeffekt ist normal und hat keine Auswirkungen auf die Qualität des codierten Inhalts.
  • Wenn Sie ein Video für mehrere Bitraten codieren, können Sie die Qualität bei jeder Bitrate überprüfen, indem Sie die gewünschte Bitrate im Feld Vorschau auswählen.


Codierungsergebnisse

In diesem Dialogfeld werden Informationen zu der soeben codierten Sitzung angezeigt. Dazu gehören u. a. die Codierungsart (Übertragung oder Codierung in eine Datei), die ausgewählten Geräte und die für die Codierungssitzung erwarteten und erzielten Durchschnittsbitraten. Durch die Ergebnisse erhalten Sie eine direkte Rückmeldung zum Verlauf der Sitzung, was insbesondere für Testzwecke hilfreich ist. Nach dem Überprüfen der Durchschnittsbitrate einer Codierungssitzung könnten Sie z. B. beschließen, die Bitrate zu reduzieren. Sie könnten die Sitzungskonfiguration ändern, den Inhalt erneut codieren und dann die Zusammenfassung der Ergebnisse untersuchen, um zu ermitteln, ob die gewünschte Bitrate erzielt wurde.


Fehlerprotokoll

In der Liste werden die Fehlermeldungen angezeigt, die Sie während der Codierungssitzung erhalten haben. Für jede Meldung wird das Datum und die Uhrzeit der Ankunft angegeben. Um das Protokoll manuell zu löschen, klicken Sie auf Jetzt löschen. Das Fehlerprotokoll wird jedes Mal gelöscht, wenn Sie den Encoder neu starten. Auf das Protokoll kann nur über die Encoder-Benutzeroberfläche zugegriffen werden.


Funktionsweise des Multicastankündigungs-Assistenten

Wenn Sie Inhalt als Multicastdatenstrom über einen Server mit Windows Media-Dienste übermitteln, müssen Sie eine Ankündigungsdatei (ASX) und eine Multicastinformationsdatei (NSC) erstellen. Sie müssen über die Berechtigung zum Zugreifen auf Windows Media-Dienste über DCOM (Distributed Component Object Mode) verfügen, um die Dateien auf dem Computer mit dem Encoder erstellen zu können. Wenn Sie nicht über Zugriffsberechtigungen für den Dienst verfügen, müssen Sie die Dateien auf dem Server erstellen.

Wenn Sie Inhalt als Unicastdatenstrom über einen Windows Media-Server übermitteln, müssen Sie keine Ankündigung erstellen.