Windows Media-Codierungsskript

Microsoft® Windows Media®-Codierungsskript ist ein Befehlszeilentool, mit dem Sie Liveinhalt und vorab aufgezeichneten Audio- und Videoinhalt in Windows Media-Dateien oder Datenströme konvertieren können. Mit Windows Media-Codierungsskript können Sie folgende Aufgaben ausführen:

  • Konvertieren von Dateien mit den Dateinamenerweiterungen WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP und JPG.
  • Aufzeichnen eines Liveereignisses von Geräten.
  • Übertragen der codierten Dateien bzw. des Liveereignisses.
  • Anpassen der codierten Sitzung. Dies schließt das Angeben eines Profils, das Codieren von bestimmten Teilen einer Datei sowie das Schneiden und Anpassen der Größe des Quellvideos ein.

In dieser Dokumentation wird die Verwendung von Windows Media-Codierungsskript erläutert. Die Dokumentation ist in folgende Abschnitte unterteilt:

  • Codieren von Dateien und Liveereignissen. Beschreibt die Ausführung grundlegender Codierungsaufgaben unter Verwendung einiger häufig verwendeter Befehlszeilenoptionen.
  • Verwenden von Profilen. Erläutert die Verwendung von Profilen. Außerdem werden alle in Windows Media-Codierungsskript verfügbaren Profile aufgelistet.
  • Erweiterte Codierungstechniken. Stellt die Codierungsfilter vor, mit denen Sie die Videoqualität verbessern können. Außerdem werden in diesem Abschnitt alle Befehlszeilenoptionen aufgelistet, die in Windows Media-Codierungsskript zur Verfügung stehen.
  • Häufig gestellte Fragen (FAQs). Bietet Antworten zu häufig gestellten Fragen (Frequently Asked Questions, FAQs) zu Windows Media-Codierungsskript.
  • Glossar. Definiert Begriffe, die im Zusammenhang mit Windows Media-Codierungsskript von Bedeutung sind.
© 2000-2002 Microsoft Corporation. Alle Rechte vorbehalten.


Codieren von Dateien und Liveereignissen

Mit Windows Media-Codierungsskript können Sie Dateien mit den Dateinamenerweiterungen WMA, WMV, ASF, AVI, WAV, MPG, MP3, BMP und JPG in das Windows Media-Format konvertieren. Sie können einzelne Dateien oder alle Dateien in einem Ordner oder Unterordner konvertieren oder eine Batchdatei zur Konvertierung bestimmter, von Ihnen angegebener Dateien verwenden. Sie können mit Windows Media-Codierungsskript auch Liveereignisse von Geräten aufzeichnen. Der Inhalt kann entweder in eine Datei ausgegeben oder übertragen werden.

Windows Media-Codierungsskript wird im selben Ordner wie Windows Media Encoder installiert. Standardmäßig handelt es sich dabei um den Ordner Programme\Windows Media-Komponenten\Encoder.

In den folgenden Beispielen wird aufgezeigt, wie Sie mithilfe von Befehlen mit einfacher Syntax verschiedene Aufgaben über die Befehlszeile ausführen können:

So verwenden Sie eine Datei als Quelle und codieren eine Datei:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv

Sie können auch einen Universal Naming Convention (UNC)-Pfad angeben.

So codieren Sie alle Dateien in einem Ordner:

cscript.exe wmcmd.vbs –input C:\Meine-Clips –output C:\Meine-Clips-coded

So verwenden Sie ein Gerät als Quelle und codieren eine Datei:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –output C:\Meine-Clips-coded\MeineDatei.wmv -duration 620

So übertragen Sie ein Liveereignis:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 2 –broadcast 8080 -duration 480

Am Ende des Basisbefehls können jeweils zusätzliche Befehlszeilenoptionen angefügt werden. Sie können z. B. angeben, dass CBR-Codierung (Costant Bit Rate, konstante Bitrate) oder VBR-Codierung (Variable Bit Rate, variable Bitrate) verwendet werden soll, einen Filter zum Entfernen von Zeilensprüngen auf das Quellvideo anwenden, ein zu verwendendes Profil angeben usw. Die Befehlszeilenoptionen können in beliebiger Reihenfolge zu den Befehlen hinzugefügt werden.

Verwandte Themen

  • Windows Media-Codierungsskript
  • Verwenden von Befehlszeilenoptionen
  • So öffnen Sie ein Eingabeaufforderungsfenster
  • So codieren Sie eine Datei
  • So codieren Sie alle Dateien in einem Ordner
  • So zeichnen Sie ein Liveereignis auf
  • Batchcodierung


So öffnen Sie ein Eingabeaufforderungsfenster

  1. Klicken Sie auf Start.
  2. Zeigen Sie auf Programme.
  3. Zeigen Sie auf Zubehör, und klicken Sie dann auf Eingabeaufforderung.

Verwandte Themen

  • Codieren von Dateien und Liveereignissen


So codieren Sie eine Datei

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners an, in dem sich die Datei Wmcmd.vbs befindet. Beispiel:
    cd \Programme\Windows Media-Komponenten\Encoder
  3. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE.
    cscript.exe wmcmd.vbs –input Laufwerk:\Pfad\Ausgabedateiname -output Laufwerk:\Pfad\Eingabedateiname

    - Oder -

    cscript.exe wmcmd.vbs –input Laufwerk:\Pfad\Eingabedateiname -broadcast Portnummer

    Beispiel:

    cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv

    - Oder -

    cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –broadcast 9090

Note image Anmerkungen

  • Wenn Sie keine Dateinamenerweiterung für die Ausgabedatei angeben, wird automatisch eine Erweiterung an den Dateinamen angefügt.
  • Schließen Sie Dateinamen, die Leerzeichen enthalten, in Anführungszeichen ein. Beispiel: "mein Beispiel.avi"

Verwandte Themen

  • Codieren von Dateien und Liveereignissen
  • So codieren Sie alle Dateien in einem Ordner
  • So zeichnen Sie ein Liveereignis auf


So codieren Sie alle Dateien in einem Ordner

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners ein, in dem sich die Datei Wmcmd.vbs befindet. Beispiel:
    cd \Programme\Windows Media-Komponenten\Encoder
  3. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE.
    cscript.exe wmcmd.vbs –input Laufwerk:\Eingabeordner -output Laufwerk:\Ausgabeordner

    Beispiel:

    cscript.exe wmcmd.vbs –input C:\Meine-Titel –output C:\Meine-Titel-coded

Note image Anmerkungen

  • Wenn der Ausgabeordner nicht bereits vorhanden ist, wird er für Sie erstellt.
  • Schließen Sie Ordner, die Leerzeichen enthalten, in Anführungszeichen ein. Beispiel: "Mein Ordner"

Verwandte Themen

  • Codieren von Dateien und Liveereignissen
  • So codieren Sie eine Datei
  • So zeichnen Sie ein Liveereignis auf


So zeichnen Sie ein Liveereignis auf

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners an, in dem sich die Datei Wmcmd.vbs befindet. Beispiel:
    cd \Programme\Windows Media-Komponenten\Encoder
  3. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE.
    cscript.exe wmcmd.vbs -adevice Audioaufnahmegerät-Nummer -vdevice Videoaufnahmegerät-Nummer -output Laufwerk:\Pfad\Ausgabedateiname -duration Zeit

    - Oder -

    cscript.exe wmcmd.vbs -adevice Audioaufnahmegerät-Nummer -vdevice Videoaufnahmegerät-Nummer - broadcast Portnummer -duration Zeit

    Beispiel:

    cscript.exe wmcmd.vbs –adevice 1 -vdevice 4 –output C:\Meine-Clips\MeineDatei.wmv -duration 620

    - Oder -

    cscript.exe wmcmd.vbs –adevice 1 -vdevice 4 –broadcast 8080 -duration 620

Note image Anmerkung

  • Sie können die Option -devices verwenden, um die Gerätenummern für die Audio- und Videoaufnahmegeräte auf dem Computer mit dem Encoder zu bestimmen.

Verwandte Themen

  • Codieren von Dateien und Liveereignissen
  • So codieren Sie eine Datei
  • So codieren Sie alle Dateien in einem Ordner


Batchcodierung

Mit der Batchcodierung können Sie zahlreiche Dateien in schneller Folge codieren und müssen nicht für jede Datei einen separaten Codierungsbefehl ausgeben. Für die Batchcodierung erstellen Sie eine Batchdatei (bzw. eine Textdatei mit der Dateinamenerweiterung BAT), die alle gewünschten Codierungsbefehle enthält. Dabei kann es sich z. B. um die Namen der Ein- und Ausgabedateien handeln, um zu verwendende Profile und um andere anzuwendende Befehlszeilenoptionen. Die Anzahl der Befehle, die in eine Batchdatei eingeschlossen werden können, ist unbegrenzt; und da es sich um eine einfache Textdatei handelt, kann die Datei auf einfache Weise bearbeitet werden.

Wenn Sie zur Ausführung der Batchdatei bereit sind, wechseln Sie zu dem Ordner, in dem Windows Media-Codierungsskript installiert ist, und geben Sie den Namen der Batchdatei ein. Beispiel: MeineBatchdatei.bat

Im folgenden Beispiel finden Sie einige Befehle, die in einer Batchdatei enthalten sein können. In diesem Beispiel wird gezeigt, wie Sie mit Befehlen eine 24-F/s-Filmquelle im Format 640 × 480, die durch Telecine (Filmabtastung) in 30 F/s umgewandelt wurde, mithilfe eines Filters für umgekehrte Filmabtastung (Inverse Telecine) vor der Codierung in 24 F/s konvertieren können. Mit den ersten beiden Befehlen wird das Tool angewiesen, eine qualitätsbasierte variable Bitrate (Variable Bit Rate, VBR) (-v_mode 2) zu verwenden, um die Quelle mit einer Qualitätseinstellung von 95 bzw. 97 zu codieren. Mit den letzten beiden Befehlen wird das Tool angewiesen, eine Codierung mit konstanter Bitrate (Constant Bit Rate, CBR) in zwei Durchläufen (-v_mode 1) zu verwenden, um die Quelle mit 1 Mbit/s bzw. 500 Kbit/s zu codieren.

cscript.exe wmcmd.vbs -input C:\Meine-Clips\MeinVideo.avi -output C:\Meine-Clips-coded\MeinVideo-640x480-vbr095.wmv -v_mode 2 -v_quality 95 -v_keydist 30 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Meine-Clips\MeinVideo.avi -output C:\Meine-Clips-coded\MeinVideo-320x240-vbr097.wmv -v_mode 2 -v_quality 97 -v_keydist 30 -v_preproc 5 -v_width 320 -v_height 240
cscript.exe wmcmd.vbs -input C:\Meine-Clips\MeinVideo.avi -output C:\Meine-Clips-coded\MeinVideo-640x480-cbr2.wmv -v_mode 1 -v_bitrate 1000000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5
cscript.exe wmcmd.vbs -input C:\Meine-Clips\MeinVideo.avi -output C:\Meine-Clips-coded\MeinVideo-320x240-cbr2.wmv -v_mode 1 -v_bitrate 500000 -v_keydist 30 -v_buffer 10000 -v_quality 100 -v_preproc 5 -v_width 320 -v_height 240

  • Codieren von Dateien und Liveereignissen


Verwenden von Profilen

Ein Profil ist eine Sammlung von Befehlszeilenoptionen, die auf die Art des zu codierenden Inhalts, die Verbindungsgeschwindigkeit der Zielgruppe und die gewünschte Bildqualität der Ausgabe zugeschnitten ist. Wenn Sie für eine Sitzung kein Profil angeben, werden die folgenden Standardoptionen für das Profil verwendet:

  • Windows Media Audio 9- und Windows Media Video 9-Codec
  • Konstante Bitrate (Constant Bit Rate, CBR)-Codierung mit einem Durchlauf
  • Framerate von 30 F/s
  • Höhe und Breite entsprechend der Eingabequelle
  • Stereokanalaudio
  • Abtastrate von 44.100 Hz
  • Puffer von 5.000 Millisekunden
  • Wiedergabequalitätseinstellung von 75
  • Schlüsselframeabstand von 10 Sekunden
  • Audio- und Videobitraten von 64 bzw. 250 Kbit/s

Sie können die Standardoptionen nach Bedarf außer Kraft setzen, indem Sie andere Befehlszeilenoptionen an den Befehl anfügen.

Sie können auch ein benutzerdefiniertes Profil erstellen, indem Sie alle im Befehl zu verwendenden Optionen angeben. Fügen Sie dann die Option -saveprofile an den Befehl an, um das Profil zur späteren Wiederverwendung zu speichern. Anschließend können Sie die Option -loadprofile verwenden, um das Profil erneut zu verwenden oder um Inhalt mithilfe eines Windows Media Encoder-Profils zu codieren. Profile weisen die Dateinamenerweiterung PRX auf.

Windows Media-Codierungsskript enthält eine Reihe von vordefinierten Profilen, die Sie in einer Sitzung verwenden können (geben Sie dazu die Option -profile an).

Verwandte Themen

  • Windows Media-Codierungsskript
  • So geben Sie ein Profil für eine Sitzung an
  • Audio- und Videoprofile
  • Reine Audioprofile
  • Reine Videoprofile
  • Verwenden von Konfigurationsdateien
  • Verwenden von Befehlszeilenoptionen


So geben Sie ein Profil für eine Sitzung an

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners an, in dem sich die Datei Wmcmd.vbs befindet. Geben Sie z. B. Folgendes ein:
    cd \Programe\Windows Media-Komponenten\Encoder
  3. Führen Sie eine der folgenden Aktionen aus:
    • Um ein Profil anzugeben, das in Windows Media-Codierungsskript enthalten ist, geben Sie den folgenden Befehl ein, und drücken Sie anschließend die EINGABETASTE:
      cscript.exe wmcmd.vbs –input Laufwerk:\Pfad\Eingabedateiname -output Laufwerk:\Pfad\Ausgabedateiname -profile Profilnummer

      Beispiel:

      cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –profile av100
    • Um ein Windows Media Encoder-Profil oder ein von Ihnen erstelltes benutzerdefiniertes Profil anzugeben, geben Sie den folgenden Befehl ein, und drücken Sie anschließend die EINGABETASTE:
      cscript.exe wmcmd.vbs –input Laufwerk:\Pfad\Eingabedateiname -output Laufwerk:\Pfad\Ausgabedateiname -loadprofile Laufwerk:\Pfad\Profil-Dateiname

      Beispiel:

      cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -loadprofile C:\Meine-Profile\500kbps_peakVBR.prx

  • Verwenden von Profilen


Audio- und Videoprofile

Windows Media-Codierungsskript enthält 14 Systemprofile zum Codieren von Inhalt mit Audio- und Videoanteilen. Die folgende Tabelle enthält eine kurze Beschreibung der einzelnen Profile.

Profilname | Bitrate (KB/s) | Beschreibung
av20 | 20 | 28-KB/s-Modem
av32 | 32 | 56-KB/s-Modem
av100 | 100 | Lokales Netzwerk (Local Area Network, LAN)
av225 | 225 | LAN
av350 | 350 | LAN und DSL (Digital Subscriber Line)
av450 | 450 | LAN und DSL
av700 | 700 | Annähernd Übertragungsqualität gemäß National Television Standards Committee (NTSC)
av1400 | 1.400 | Annähernd Übertragungsqualität gemäß NTSC
av350pal | 350 | Breitband gemäß Phase Alternating Line (PAL)
av700pal | 700 | Annähernd Übertragungsqualität gemäß PAL
av100_2p | 100 | LAN und konstante Bitrate (Constant Bit Rate, CBR) in zwei Durchläufen
av350_2p | 350 | LAN, DSL und CBR in zwei Durchläufen
av600vbr | 600 | Film, CBR (Audio) und maximale variable Bitrate (Variable Bit Rate, VBR) (Video)
avq97vbr | -- | Film, CBR (Audio) und qualitätsbasierte VBR (Video)

  • Verwenden von Profilen


av20

  • Name: av20 (Profile_AudioVideo_Modem_28K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 5.000 B/s
  • Abtastrate: 8.000 Hz
  • Anzahl der Kanäle: 1
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 15.000 B/s
  • Framebreite: 160 Pixel
  • Framehöhe: 120 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 20.000 B/s

  • Audio- und Videoprofile


av32

  • Name: av32 (Profile_AudioVideo_Modem_56K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 10.168 B/s
  • Abtastrate: 11.025 Hz
  • Anzahl der Kanäle: 1
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 22.000 B/s
  • Framebreite: 176 Pixel
  • Framehöhe: 144 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 32.168 B/s

  • Audio- und Videoprofile


av100

  • Name: av100 (Profile_AudioVideo_LAN_100K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 16.000 B/s
  • Abtastrate: 16.000 Hz
  • Anzahl der Kanäle: 1
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 84.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 100.000 B/s

  • Audio- und Videoprofile


av225

  • Name: av225 (Profile_AudioVideo_LAN_256K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 40.000 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 185.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 225.000 B/s

  • Audio- und Videoprofile


av350

  • Name: av350 (Profile_AudioVideo_LANDSL_384K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 48.000 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 302.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 350.000 B/s

  • Audio- und Videoprofile


av450

  • Name: av450 (Profile_AudioVideo_LANDSL_768K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 386.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 450.040 B/s

  • Audio- und Videoprofile


av700

  • Name: av700 (Profile_AudioVideo_NearBroadCast_700K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 636.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 700.040 B/s

  • Audio- und Videoprofile


av1400

  • Name: av1400 (Profile_AudioVideo_NearBroadCast_1400K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 128.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 1.272.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 1.400.040 B/s

  • Audio- und Videoprofile


av350pal

  • Name: av350pal (Profile_AudioVideo_Broadband_PAL_384K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 48.000 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 302.000 B/s
  • Framebreite: 384 Pixel
  • Framehöhe: 288 Pixel
  • Framerate: 25 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 350.000 B/s

  • Audio- und Videoprofile


av700pal

  • Name: av700pal (Profile_AudioVideo_NearBroadCast_PAL_700K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 636.000 B/s
  • Framebreite: 384 Pixel
  • Framehöhe: 288 Pixel
  • Framerate: 25 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 700.040 B/s

  • Audio- und Videoprofile


av100_2p

  • Name: av100_2p (Profile_AudioVideo_LAN_100K_2Pass)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 16.000 B/s
  • Abtastrate: 16.000 Hz
  • Anzahl der Kanäle: 1
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit zwei Durchläufen
  • Videooptimierung: Keine
  • Videobitrate: 84.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 100.000 B/s

  • Audio- und Videoprofile


av350_2p

  • Name: av350_2p (Profile_AudioVideo_LANDSL_384K_2Pass)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 48.000 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit zwei Durchläufen
  • Videooptimierung: Keine
  • Videobitrate: 302.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 30 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 350.000 B/s

  • Audio- und Videoprofile


av600vbr

  • Name: av600vbr (Profile_AudioVideo_FilmVBR_600K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: Auf maximalen Bitraten basierendes VBR (Video) und CBR (Audio)
  • Videooptimierung: Umgekehrte Filmabtastung
  • Videobitrate: 536.000 B/s
  • Maximale Videobitrate: 804.000 B/s
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 24 F/S
  • Maximaler Puffer: 5.000 ms
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 600.040 B/s

  • Audio- und Videoprofile


avq97vbr

  • Name: avq97vbr (Profile_AudioVideo_FilmVBR_Quality97)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.040 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: Qualitätsbasiertes VBR (Video) und CBR (Audio)
  • Videooptimierung: Umgekehrte Filmabtastung
  • Framebreite: 320 Pixel
  • Framehöhe: 240 Pixel
  • Framerate: 24 F/S
  • Qualität: 97
  • Abstand der Schlüsselframes: 10 Sek

  • Audio- und Videoprofile


Reine Audioprofile

Windows Media-Codierungsskript enthält sieben Systemprofile zum Codieren von reinem Audioinhalt (ohne Videoanteile). Die folgende Tabelle enthält eine kurze Beschreibung der einzelnen Profile.

Profilname | Bitrate (KB/s) | Beschreibung
a20_1 | 20 | UKW-Radio (Mono)
a20_2 | 20 | UKW-Radio (Stereo)
a32 | 32 | 56-KB/s-Modem
a48 | 48 | Annähernd CD-Qualität
a64 | 64 | CD-Qualität
a96 | 96 | HiFi-CD-Qualität
a128 | 128 | HiFi-CD-Qualität

  • Verwenden von Profilen


a20_1

  • Name: a20_1 (Profile_AudioOnly_FMRadioMono_28K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 20.008 B/s
  • Abtastrate: 22.050 Hz
  • Anzahl der Kanäle: 1
  • Gesamte Bitrate: 20.008 B/s

  • Reine Audioprofile


a20_2

  • Name: a20_2 (Profile_AudioOnly_FMRadioStereo_28K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 20.008 B/s
  • Abtastrate: 22.050 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 20.008 B/s

  • Reine Audioprofile


a32

  • Name: a32 (Profile_AudioOnly_Modem_56K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 32.000 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 32.000 B/s

  • Reine Audioprofile


a48

  • Name: a48 (Profile_AudioOnly_NearCDQuality_48K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 48.024 B/s
  • Abtastrate: 32.000 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 48.024 B/s

  • Reine Audioprofile


a64

  • Name: a64 (Profile_AudioOnly_CDQuality_64K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 64.016 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 64.016 B/s

  • Reine Audioprofile


a96

  • Name: a96 (Profile_AudioOnly_CDAudiophileQuality_96K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 96.024 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 96.024 B/s

  • Reine Audioprofile


a128

  • Name: a128 (Profile_AudioOnly_CDAudiophileQuality_128K)
  • Audiocodec: Windows Media Audio 9
  • Audiobitrate: 128.016 B/s
  • Abtastrate: 44.100 Hz
  • Anzahl der Kanäle: 2
  • Gesamte Bitrate: 128.016 B/s

  • Reine Audioprofile


Reine Videoprofile

Windows Media-Codierungsskript enthält zwei Systemprofile zum Codieren von reinem Videoinhalt (ohne Audioanteile). Die folgende Tabelle enthält eine kurze Beschreibung der einzelnen Profile.

Profilname | Bitrate (KB/s) | Beschreibung
v20 | 20 | Reines 28-KB/s-Videomodem
v32 | 32 | Reines 56-KB/s-Videomodem

  • Verwenden von Profilen


v20

  • Name: v20 (Profile_VideoOnly_Modem_28K)
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 20.000 B/s
  • Framebreite: 176 Pixel
  • Framehöhe: 144 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 20.000 B/s

  • Reine Videoprofile


v32

  • Name: v32 (Profile_VideoOnly_Modem_56K)
  • Videocodec: Windows Media Video 9
  • Codierungsmodus: CBR mit einem Durchlauf
  • Videooptimierung: Keine
  • Videobitrate: 32.000 B/s
  • Framebreite: 240 Pixel
  • Framehöhe: 176 Pixel
  • Framerate: 15 F/S
  • Puffer: 5.000 ms
  • Qualität der Wiedergabe: 75
  • Abstand der Schlüsselframes: 10 Sek
  • Gesamte Bitrate: 32.000 B/s

  • Reine Videoprofile


Erweiterte Codierungstechniken

Mit Windows Media-Codierungsskript stehen Ihnen verschiedene Optionen zur Feinabstimmung von Codierungseinstellungen zur Verfügung. In diesem Abschnitt werden diese Optionen und ihre Verwendung beschrieben.

Verwandte Themen

  • Windows Media-Codierungsskript
  • Optimieren von Video und Audio
  • Verwenden der CBR- oder VBR-Codierung
  • Verwenden von Mehrkanal-Audiodateien als Quelle
  • Verwenden von Konfigurationsdateien
  • Verwenden von Befehlszeilenoptionen


Optimieren von Video und Audio

Windows Media-Codierungsskript enthält Filter, mit denen Sie die Qualität von Inhalten mit Telecine (Filmabtastung) und mit Zeilensprüngen zur Wiedergabe auf progressiven Abtastanzeigen verbessern oder die Zeilensprünge im Inhalt auf entsprechenden Wiedergabegeräten beibehalten können. Standardmäßig werden keine Filter angewendet (-v_preproc 0). Bei Inhalt, der sich bereits in einem progressiven Scanformat befindet und auf einer progressiven Scananzeige wiedergegeben werden soll, sollten Sie den Befehl zur Nichtanwendung von Filtern verwenden.

Wenn es sich bei dem Audioinhalt hauptsächlich um Sprache mit einigen Musikanteilen handelt, können Sie die Optionen -a_content und -a_contentedl verwenden, um den Inhalt für Sprache zu optimieren.

Verwandte Themen

  • Erweiterte Codierungstechniken
  • Filter zum Entfernen von Zeilensprüngen
  • Filter für die umgekehrte Filmabtastung (Inverse Telecine)
  • Filter für Zeilensprünge
  • Optimieren von Sprachaufnahmen


Filter zum Entfernen von Zeilensprüngen

Der Filter zum Entfernen von Zeilensprüngen konvertiert Videodaten mit Zeilensprüngen in das progressive Scanformat. In der folgenden Tabelle werden die Befehle beschrieben, die beim Anwenden des Filters zum Entfernen von Zeilensprüngen auf das Video zur Verfügung stehen.

Befehl | Beschreibung
-v_preproc 1 | Behält die Größe des Quellvideos bei. Video mit 640 × 480 Pixel und 30 F/s wird beispielsweise mit 640 × 480 Pixel und 30 F/s codiert.
-v_preproc 2 | Das Ausgabevideo ist halb so groß wie das ursprüngliche Video. Video mit 640 × 480 Pixel und 30 F/s wird beispielsweise mit 320 × 240 Pixel und 30 F/s codiert.
-v_preproc 3 | Das Ausgabevideo ist halb so groß wie das ursprüngliche Video, und die Framerate wird verdoppelt. Video mit 640 × 480 Pixel und 30 F/s wird beispielsweise mit 320 × 240 Pixel und 60 F/s codiert.
-v_preproc 4 | Das Ausgabevideo ist halb so hoch wie das ursprüngliche Video, und die Framerate wird verdoppelt. Video mit 320 × 480 Pixel und 30 F/s wird beispielsweise mit 320 × 240 Pixel und 60 F/s codiert.

Verwandte Themen

  • Optimieren von Video und Audio
  • Filter für die umgekehrte Filmabtastung (Inverse Telecine)
  • Filter für Zeilensprünge
  • So wenden Sie einen Filter auf Ihren Inhalt an


Filter für die umgekehrte Filmabtastung (Inverse Telecine)

Der Filter für die umgekehrte Filmabtastung konvertiert Video von 30 F/s in 24 F/s. In der folgenden Tabelle werden die Befehle beschrieben, die beim Anwenden des Filters für die umgekehrte Filmabtastung auf das Video zur Verfügung stehen.

Befehl | Beschreibung
-v_preproc 5 | Verwenden Sie diesen Befehl, wenn der Inhalt nicht kohärent ist oder wenn Sie nicht wissen, mit welchem Frame der Inhalt beginnt.
-v_preproc 6 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das obere (ungerade) Feld mit dem Filmabtastungsmuster AA ist.
-v_preproc 7 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das obere (ungerade) Feld mit dem Filmabtastungsmuster BB ist.
-v_preproc 8 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das obere (ungerade) Feld mit dem Filmabtastungsmuster BC ist.
-v_preproc 9 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das obere (ungerade) Feld mit dem Filmabtastungsmuster CD ist.
-v_preproc 10 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das obere (ungerade) Feld mit dem Filmabtastungsmuster DD ist.
-v_preproc 11 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das untere (gerade) Feld mit dem Filmabtastungsmuster AA ist.
-v_preproc 12 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das untere (gerade) Feld mit dem Filmabtastungsmuster BB ist.
-v_preproc 13 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das untere (gerade) Feld mit dem Filmabtastungsmuster BC ist.
-v_preproc 14 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das untere (gerade) Feld mit dem Filmabtastungsmuster CD ist.
-v_preproc 15 | Verwenden Sie diesen Befehl, wenn das erste Feld im Frame das untere (gerade) Feld mit dem Filmabtastungsmuster DD ist.

Verwandte Themen

  • Optimieren von Video und Audio
  • Filter zum Entfernen von Zeilensprüngen
  • Filter für Zeilensprünge
  • So wenden Sie einen Filter auf Ihren Inhalt an


Filter für Zeilensprünge

Der Filter für Zeilensprünge behält die Zeilensprünge im Quellvideo bei. In der folgenden Tabelle werden die Befehle beschrieben, die beim Anwenden des Filters für Zeilensprünge auf das Video zur Verfügung stehen.

Befehl | Beschreibung
-v_preproc 16 | Behält den Zeilensprung im Quellvideo bei.
-v_preproc 17 | Behält den Zeilensprung im Quellvideo bei. Verwenden Sie diese Option, wenn das erste Feld, das codiert wird, das obere (ungerade) Feld ist.
-v_preproc 18 | Behält den Zeilensprung im Quellvideo bei. Verwenden Sie diese Option, wenn das codierte Feld, das codiert wird, das untere (gerade) Feld ist.

Verwandte Themen

  • Optimieren von Video und Audio
  • Filter zum Entfernen von Zeilensprüngen
  • Filter für die umgekehrte Filmabtastung (Inverse Telecine)
  • So wenden Sie einen Filter auf Ihren Inhalt an


So wenden Sie einen Filter auf Ihren Inhalt an

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners an, in dem sich die Datei Wmcmd.vbs befindet. Geben Sie beispielsweise Folgendes ein
    cd \Programme\Windows Media-Komponenten\Encoder
  3. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE.
    cscript.exe wmcmd.vbs –input Laufwerk:\Pfad\Eingabedateiname -output Laufwerk:\Pfad\Ausgabedateiname -v_preproc Filter

    Beispiel:

    cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -v_preproc 3

  • Optimieren von Video und Audio


Optimieren von Sprachaufnahmen

Wenn Sie Audiodaten als Quelle verwenden, die ausschließlich oder hauptsächlich aus Sprache bestehen, können Sie die Option -a_content und den Windows Media Audio 9 Sprachcodec verwenden, um die Codierung für Sprache zu optimieren. Sie können das Codecverhalten optimieren, indem Sie identifizieren, ob der Inhalt nur aus Sprache (-a_content 1) oder auch aus Musikanteilen (-a_content 2) besteht. Wenn es sich bei dem Audioinhalt um eine Mischung aus Sprache und Musik handelt, verwendet der Codec bei der Codierung automatisch den richtigen Algorithmus, um die Codierung für den Inhalt zu optimieren (Sprache oder Musik). Sie können auch eine Optimierungsdefinitionsdatei (-a_contentedl) erstellen. Dies ist eine Textdatei, die die Stellen in der Datei identifiziert, an denen die Musik beginnt und endet. Die nicht angegebenen Teile in der Datei werden als Sprache behandelt. Im folgenden Beispiel handelt es sich um Audioinhalt, der nur aus Sprache besteht.

cscript.exe wmcmd.vbs –input C:\Meine-Reden\MeineRede.wav –output C:\Meine-Reden-coded\MeineRede.wma -a_codec WMSP9 -a_content 1

Im folgenden Beispiel ist der Audioinhalt eine Mischung aus Sprache und Musik, und es wurde eine Optimierungsdefinitionsdatei erstellt.

cscript.exe wmcmd.vbs –input C:\Meine-Reden\MeineRede.wav –output C:\Meine-Reden-coded\MeineRede.wma -a_codec WMSP9 -a_content 2 -a_contentedl c:\Meine-Reden\Meine_Inhaltedl.txt

Verwandte Themen

  • Optimieren von Video und Audio
  • So erstellen Sie eine Definitionsdatei für die Audiooptimierung


So erstellen Sie eine Definitionsdatei für die Audiooptimierung

  1. Verwenden Sie einen Texteditor, z. B. Editor, um eine Textdatei zu erstellen.
  2. Geben Sie die Versionsnummer und die Anzahl der Musiksegmente ein, die die Datei enthält.

    Die Versionsnummer sollte immer die Zahl 1 aufweisen.

  3. Geben Sie die Start- und Endzeit (in Millisekunden) für jedes Segment ein, und trennen Sie die einzelnen Start- und Endzeiten mit einem Komma voneinander.

    Die Eingabe von 3, 0, 10000, 50000, 80000, 150000 und 200000 weist z. B. auf drei Musiksegmente hin. Der Codec wechselt bei 0 bis 10 Sekunden, 50 bis 80 Sekunden und 150 bis 200 Sekunden in den Musikmodus.

  4. Codieren Sie die Textdatei in Unicode.

    Wenn Sie die Datei mit Editor erstellen, können Sie die Datei als Unicode speichern, indem Sie im Menü Datei den Befehl Speichern unter verwenden und dann unter Codierung auf Unicode klicken.

  • Optimieren von Sprachaufnahmen


Verwenden der CBR- oder VBR-Codierung

Sie können Audio- und Videoinhalt mit konstanter Bitrate (Constant Bit Rate, CBR) oder mit variabler Bitrate (Variable Bit Rate, VBR) codieren. Verwenden Sie die CBR-Codierung, wenn Sie den Inhalt ausstrahlen möchten. Verwenden Sie die VBR-Codierung, wenn Sie den Inhalt zum Downloaden oder zur lokalen Wiedergabe oder Wiedergabe auf einem Gerät mit einer begrenzten Lesegeschwindigkeit (z. B. einem CD- oder DVD-Player) verteilen möchten.

  • CBR-Codierung. Mit dieser Option werden Bitratenschwankungen bei der Codierung durch die Puffergröße beschränkt. Die Bildqualität schwankt, um sicherzustellen, dass es nicht zu einem Pufferüberlauf oder -unterlauf kommt. Bei der CBR-Codierung können Sie die Codierung in einem Durchlauf oder in zwei Durchläufen durchführen.
  • Qualitätsbasierte VBR-Codierung. Mit dieser Option wird der Inhalt mit einer bestimmten Qualitätseinstellung codiert (von 0 bis 100). Die Bitrate schwankt bei der Codierung, um sicherzustellen, dass die angegebene Qualität erzielt wird. Verwenden Sie diese Option, wenn die Bitrate für Sie nicht von Bedeutung ist, Sie jedoch die Qualität der Ausgabe sicherstellen möchten. Diese Option verwendet die Codierung mit einem Durchlauf.
  • Bitratenbasierte VBR-Codierung. Mit dieser Option wird der Inhalt mit einer durchschnittlichen Bitrate codiert. Die Bitrate kann die angegebene durchschnittliche Bitrate jederzeit überschreiten. Die Gesamtbitrate entspricht jedoch der durchschnittlichen Bitrate. In diesem Modus werden keine Frames verworfen. Diese Option verwendet die Codierung mit zwei Durchläufen.
  • Auf maximalen Bitraten basierende VBR-Codierung. Diese Option ähnelt der Option für die bitratenbasierte VBR-Codierung, mit der Ausnahme, dass hierbei die Bitratenschwankungen die maximale Bitrate nicht überschreiten. Verwenden Sie diese Option, wenn der Inhalt auf einem Gerät mit begrenzter Lesegeschwindigkeit wiedergegeben wird (z. B. einem CD- oder DVD-Player). Diese Option verwendet die Codierung mit zwei Durchläufen.

    Note image Anmerkung

    • Wenn Sie Inhalt mithilfe eines Profils codieren, in dem nicht festgelegt ist, ob die CBR- oder die VBR-Codierung verwendet werden soll, oder wenn Sie eine benutzerdefinierte Codierungssitzung einrichten und weder CBR- noch VBR-Codierung angeben, wird standardmäßig die CBR-Codierung mit einem Durchlauf verwendet.

Verwandte Themen

  • Erweiterte Codierungstechniken
  • Implementieren eines CBR- oder VBR-Codierungsmodus


Implementieren eines CBR- oder VBR-Codierungsmodus

Beim Implementieren eines CBR- oder VBR-Codierungsmodus ist der einzige erforderliche Parameter die Option -v_mode bzw. die Option -a_mode zur Angabe des Modus. Für jeden Modus gibt es jedoch optionale Parameter, die Sie angeben können. Wenn Sie den Parameter nicht angeben, werden Standardwerte verwendet.

In der folgenden Tabelle finden Sie eine Übersicht über die Befehlszeilenoptionen, die Sie beim Implementieren eines CBR- oder VBR-Codierungsmodus für Videoinhalt verwenden können.

Modus | Optionale Parameter
CBR mit einem Durchlauf (-v_mode 0) | -v_bitrate und -v_buffer
CBR mit zwei Durchläufen (-v_mode 1) | -v_bitrate und -v_buffer
Qualitätsbasiertes VBR (ein Durchlauf, -v_mode 2) | -v_quality (Standard ist 95)
Bitratenbasiertes VBR (zwei Durchläufe, -v_mode 3) | -v_bitrate
Auf maximalen Bitraten basierendes VBR (zwei Durchläufe, -v_mode 4) | -v_bitrate, -v_peakbitrate und -v_peakbuffer

In der folgenden Tabelle finden Sie eine Übersicht über die Befehlszeilenoptionen, die Sie beim Implementieren eines CBR- oder VBR-Modus für Audioinhalt verwenden können.

Modus | Optionale Parameter
CBR mit einem Durchlauf (-a_mode 0) | -a_setting
CBR mit zwei Durchläufen (-a_mode 1) | -a_setting
Qualitätsbasiertes VBR (ein Durchlauf, -a_mode 2) | -a_setting (weitere Informationen finden Sie in den folgenden Abschnitten)
Bitratenbasiertes VBR (zwei Durchläufe, -a_mode 3) | -a_setting
Auf maximalen Bitraten basierendes VBR (zwei Durchläufe, -a_mode 4) | -a_setting, -a_peakbitrate und -a_peakbuffer

Sie können in einer Sitzung verschiedene Codierungsmodi verwenden. Sie können z. B. die CBR-Codierung mit zwei Durchläufen für Audio und die qualitätsbasierte VBR-Codierung für Video verwenden.

Verwenden der qualitätsbasierten VBR-Codierung für Audio

Wenn Sie die qualitätsbasierte VBR-Codierung für Audio verwenden, können Sie mit -a_setting unter Verwendung des Formats QWert_Abtastrate_Kanal die Zielqualität darstellen. Die Standardeinstellung ist Q75_44_2, wenn Sie nicht zusätzlich den Windows Media Audio 9 Professional-Codec angeben (in diesem Fall ist die Standardeinstellung Q75_44_2_24). Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma -a_codec WMA9PRO -a_mode 2 –a_setting Q98_48_2_24

Sie können auch den Windows Media Audio 9 Lossless-Codec verwenden, für den die qualitätsbasierte VBR-Codierung mit einer Qualitätseinstellung von 100 erforderlich ist. Der Standardwert für -a_setting ist Q100_44_2_16. Im folgenden Beispiel wird verdeutlicht, wie Sie einen Befehl zur Verwendung von verlustfreier Komprimierung mit einer Abtastrate von 48 KHz, zwei Kanälen und 24-Bit-Codierung einrichten können:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma -a_codec WMA9LSL -a_mode 2 –a_setting Q100_48_2_24

  • Verwenden der CBR- oder VBR-Codierung


Verwenden von Mehrkanal-Audiodateien als Quelle

Mit Windows Media-Codierungsskript können Sie Mehrkanalaudio codieren. Das bedeutet, dass Sie Audio für eine Surroundsoundwiedergabe über sechs oder acht Kanäle codieren können. Als Inhaltsquelle muss eine 6- oder 8-Kanaldatei im Format WAVE_FORMAT_EXTENSIBLE verwendet werden. Alternativ können Sie auch sechs Monokanal-WAV-Dateien als Quelle verwenden.

Um eine einzelne Datei als Quelle zu verwenden, richten Sie einen Befehl ein, der die Datei als Eingabe identifiziert. Außerdem müssen Sie den Windows Media Audio 9 Professional-Codec angeben. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Quelldateien\6_Kanal.wav -output C:\Mein_Titel.wma -a_codec WMA9PRO -a_setting 640_48_6_24

- Oder -

cscript.exe wmcmd.vbs –input C:\Meine-Quelldateien\8_Kanal.wav -output C:\Mein_Titel.wma -a_codec WMA9PRO -a_setting 384_48_8_24

Die Verwendung von sechs Monokanal-WAV-Dateien als Quelle direkt von Windows Media-Codierungsskript aus ist nicht möglich. Sie können stattdessen eine Mehrkanal-Audiositzung mit Windows Media Encoder einrichten. Anschließend können Sie die Sitzung speichern und im Befehl auf die Sitzungsdatei verweisen. Beispiel:

cscript.exe wmcmd.vbs –wme C:\Meine_Mehrkanal_Sitzung.wme

Beim Verwenden von Mehrkanalaudio als Quelle können Sie auch den Parameter -a_folddown6to2 in den Befehl einschließen. Dieser Parameter gibt an, wie die sechs Kanäle zur Wiedergabe auf Stereolautsprechern zu zwei Kanälen gewandelt werden.

Bei der Wiedergabe des Inhalts muss Microsoft Windows XP verwendet werden. Außerdem ist ein Player erforderlich, der auf dem SDK (Software Development Kit) von Windows Media Format 9-Reihe basiert. Anderenfalls werden die Audiodaten zur Wiedergabe auf Stereolautsprechern automatisch zu zwei Kanälen gewandelt.

  • Erweiterte Codierungstechniken


Verwenden von Konfigurationsdateien

Wenn Sie eine Gruppe von Befehlszeilenoptionen erstellt haben, die Sie in Zukunft erneut verwenden möchten, können Sie die Optionen in einer Datei, der so genannten Konfigurationsdatei, speichern. Eine Konfigurationsdatei ist eine Textdatei, die die Namen und Werte der Befehlszeilenoptionen enthält, die Sie in einer Codierungssitzung verwenden möchten. Anstatt jede Option einzeln an der Eingabeaufforderung anzugeben, können Sie die Optionen in einer Konfigurationsdatei zusammenfassen und dann bei Ausführung von Windows Media-Codierungsskript die Konfigurationsdatei aufrufen.

Die Konfigurationsdatei kann Informationen wie z. B. den Namen der Eingabedatei, Audio- und Videogeräte oder das Profil enthalten sowie alle anderen Optionen, die Sie angeben möchten. Sie können die Einstellungen in der Konfigurationsdatei außer Kraft setzen, indem Sie einzelne Optionen in der Befehlszeile eingeben.

Sie können Konfigurationsdateien mit einem Texteditor oder über die Befehlszeile durch Anfügen der Option -s_config an den Befehl erstellen. Wenn Sie die Option -s_config anfügen, geben Sie einen Dateinamen an, und alle Optionen im Befehl werden zusammengefasst und in dieser Konfigurationsdatei gespeichert. Konfigurationsdateien weisen die Dateinamenerweiterung WEU auf. Wenn Sie bei der Erstellung der Konfigurationsdatei keine Dateinamenerweiterung angeben, wird die Erweiterung automatisch an den Dateinamen angefügt.

Verwandte Themen

  • Erweiterte Codierungstechniken
  • So rufen Sie eine Konfigurationsdatei auf


So rufen Sie eine Konfigurationsdatei auf

  1. Öffnen Sie ein Eingabeaufforderungsfenster.
  2. Geben Sie an der Eingabeaufforderung den Pfad des Ordners an, in dem sich die Datei Wmcmd.vbs befindet. Geben Sie beispielsweise Folgendes ein:
    cd \Programme\Windows Media-Komponenten\Encoder
  3. Geben Sie den folgenden Befehl ein, und drücken Sie die EINGABETASTE.
    cscript.exe wmcmd.vbs –config Laufwerk:\Pfad\Konfigurations-Dateiname

    Beispiel:

    cscript.exe wmcmd.vbs –config C:\Konfig-Dateien\MeineVideos.weu

  • Verwenden von Konfigurationsdateien


Verwenden von Befehlszeilenoptionen

Im Folgenden sind alle Befehlszeilenoptionen aufgeführt, die Sie an Befehle anfügen können, um bestimmte Codierungsergebnisse zu erzielen. Wenn Sie zusätzlich zu diesen Optionen auch ein Profil angegeben haben, haben diese Optionen Vorrang.

Um von der Befehlszeile aus auf die Direkthilfe zuzugreifen, geben Sie cscript.exe wmcmd.vbs ein, und drücken Sie dann die EINGABETASTE.

-a_codec Codecindex

Gibt den Audiocodec an. Wenn Sie keinen Codec angeben, wird der Windows Media Audio 9-Codec verwendet. Mit der Option -a_codecs können Sie die Codecs und Codecindizes (beispielsweise WMA9STD) ermitteln, die auf dem Computer mit dem Encoder installiert sind.

-a_codecs

Zeigt eine Liste der Audiocodecs, Codecindizes und Codierungsmodi (CBR und VBR) an, die für die auf dem Computer mit dem Encoder installierten Codecs unterstützt werden.

-a_content Modusnummer

Gibt an, ob es sich bei dem Audioinhalt hauptsächlich um Sprache (-a_content 1) oder um gemischten Inhalt (-a_content 2) handelt. Standardmäßig wird die neutrale Einstellung -a_content 0 verwendet. Sie müssen den Windows Media Audio 9 Voice-Codec angeben, wenn Sie die Option -a_content verwenden. Weitere Informationen finden Sie unter Optimieren von Sprachaufnahmen.

-a_contentedl Dateiname

Wenn es sich bei dem Audioinhalt um eine Mischung aus Sprache und Musik handelt, können Sie mit dieser Option die Stellen im Inhalt angeben, an denen die Musik beginnt und endet. Sie müssen den Windows Media Audio 9 Voice-Codec sowie -a_content 2 angeben, wenn Sie die Option -a_contentedl verwenden. Weitere Informationen finden Sie unter Optimieren von Sprachaufnahmen.

-adevice Nummer_des_Audiogeräts

Gibt das Audiogerät an, das als Quelle verwendet werden soll. Beispiel:

cscript.exe wmcmd.vbs –adevice 1 -vdevice 4 –broadcast 8080 -duration 480

Verwenden Sie die Option -devices, um die Gerätenummern für die Audio- und Videoaufnahmegeräte auf dem Computer mit dem Encoder zu erfahren. Die Option -duration wird benötigt, wenn das Aufzeichnen von Geräten erfolgt.

-a_folddown6to2 Surroundkanal Centerkanal Niedrigfrequenzkanal

Gibt bei Mehrkanalaudio-Codierungen an, wie die sechs Kanäle zur Wiedergabe auf Stereolautsprechern automatisch zu zwei Kanälen gewandelt werden. Verwenden Sie nur ganze Zahlen. Die Werte, die zwischen 0 und 144 Dezibel liegen müssen, werden in negative Zahlen konvertiert. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma -a_codec WMA9PRO -a_mode 2 –a_setting 640_48_6_24 -a_folddown6to2 3 3 12

-a_formats

Zeigt eine Liste der Audioformate (Bitrate, Abtastrate und Kanäle) an, die von den einzelnen Codecs unterstützt werden.

-a_mode Modusnummer

Gibt den Codierungsmodus für Audioinhalt an. Sie können die CBR-Codierung mit einem oder zwei Durchläufen (-a_mode 0 bzw. -a_mode 1) oder einen der folgenden VBR-Codierungsmodi verwenden: qualitätsbasiert (-a_mode 2), bitratenbasiert (-a_mode 3) oder auf maximalen Bitraten basierend (-a_mode 4). Weitere Informationen finden Sie unter Verwenden der CBR- oder VBR-Codierung.

-a_peakbitrate Maximale Bitrate

Gibt die maximale Bitrate für die auf maximalen Bitraten basierende VBR-Codierung für Audioinhalt an (in Bit/s). Der Standardwert ist das Anderthalbfache der Audiobitrate. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Musik\MeinTitel.wav –output C:\Meine-Musik-coded\MeinTitel.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_peakbuffer Maximale Puffergröße

Gibt den Zeitraum (in Millisekunden) an, für den Audioinhalt zwischengespeichert wird. Diese Option wird mit der auf maximalen Bitraten basierenden VBR-Codierung für Audioinhalt verwendet. Der Standardwert ist 3.000 Millisekunden. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Musik\MeinTitel.wav –output C:\Meine-Musik-coded\MeinTitel.wma -a_mode 4 -a_setting 80_44_2 -a_peakbitrate 300000 -a_peakbuffer 8000

-a_setting Bitrate_Abtastrate_Kanal

Gibt die Audiobitrate, die Abtastrate und den Kanal für die Codierung an. Wenn Sie den Windows Media Audio 9 Professional- oder den Windows Media Audio 9 Lossless-Codec verwenden, gibt -a_setting außerdem an, ob eine 16- oder 24-Bit-Codierung durchgeführt werden soll. Dies geschieht mit dem Wert Bitrate_Abtastrate_Kanal_BitsproAbtastung. Mit der Option -a_formats können Sie die Einstellungen anzeigen, die für die einzelnen Codecs unterstützt werden. Bei Verwendung des Windows Media Audio 9 Voice-Codec ist der Standardwert 12_16_1. Bei Verwendung des Windows Media Audio 9 Professional-Codec ist der Standardwert 128_44_2_24, wenn Sie nicht zusätzlich eine qualitätsbasierte VBR-Sitzung implementieren (in diesem Fall ist der Standardwert Q75_44_2_24). Bei Verwendung des Windows Media Audio 9 Lossless-Codec ist der Standardwert Q100_44_2_16. Beim Codieren von nicht komprimiertem Inhalt ist der Standardwert 705_22_2. In allen anderen Fällen ist der Standardwert 64_44_2. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma –a_setting 32_44_2

Weitere Informationen zur Verwendung der Option -a_setting mit der qualitätsbasierten VBR-Codierung für Audio finden Sie unter Implementieren eines CBR- oder VBR-Codierungsmodus.

-audioonly

Bei Verwendung einer Datei als Quelle, die sowohl Audio- als auch Videoinhalt enthält, wird mit diesem Parameter festgelegt, dass nur die Audioanteile codiert werden.

-author Zeichenfolge

Gibt den Autor des Inhalts an. Diese Information wird bei der Wiedergabe des Inhalts angezeigt. Wenn die Zeichenfolge Leerzeichen enthält, müssen Sie diese in Anführungszeichen einschließen. Die maximale Zeichenfolgenlänge beträgt 255 Zeichen. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma –author "David Johnson"

-broadcast Portnummer

Gibt den für die Übertragung verwendeten HTTP-Port an. Der Standardwert ist 8080. Beim Verwenden von Geräten als Quelle müssen Sie außerdem die Option -duration angeben. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\MeinTitel1.wav –broadcast 9090
cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 9090 –duration 620

-config Dateiname

Gibt die Konfigurationsdatei an, die bei der Codierungssitzung verwendet werden soll. Konfigurationsdateien weisen die Dateinamenerweiterung WEU auf. Verwenden Sie die Option -s_config oder einen Texteditor, um eine Konfigurationsdatei zu erstellen. Weitere Informationen finden Sie unter Verwenden von Konfigurationsdateien. Beispiel:

cscript.exe wmcmd.vbs –config C:\Meine-Konfig-Dateien\MeineKonfig_Datei.weu

-copyright Zeichenfolge

Gibt Copyrightinformationen zum Inhalt an. Diese Informationen werden bei der Wiedergabe des Inhalts angezeigt. Wenn die Zeichenfolge Leerzeichen enthält, müssen Sie diese in Anführungszeichen einschließen. Die maximale Zeichenfolgenlänge beträgt 255 Zeichen. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma –copyright "David Johnson 2001"

-description Zeichenfolge

Gibt eine Beschreibung des Inhalts an. Diese Information wird bei der Wiedergabe des Inhalts angezeigt. Wenn die Zeichenfolge Leerzeichen enthält, müssen Sie diese in Anführungszeichen einschließen. Die maximale Zeichenfolgenlänge beträgt 255 Zeichen. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma –description "Eine Sammlung meiner Lieblingsmusik"

-devices

Zeigt eine Liste der Audio- und Videogeräte (und der entsprechenden Gerätenummern) auf dem Computer mit dem Encoder an. Sie können die Gerätenummern verwenden, wenn Sie ein Liveereignis aufzeichnen. (Weitere Informationen finden Sie in den Erläuterungen zu den Optionen -adevice und -vdevice.)

-duration Zeit

Gibt die Codierungsdauer in Sekunden an. Verwenden Sie diese Option, wenn Sie Geräte als Quelle verwenden. Die Codierung beginnt am Anfang der Übertragung und endet, wenn die angegebene Dauer erreicht ist. Die tatsächliche Codierungsdauer weicht um wenige Sekunden von der angegebenen Dauer ab. Beispiel:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

-input Dateiname oder Ordnername

Gibt den Namen der Datei oder des Ordners an. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv
cscript.exe wmcmd.vbs –input C:\Meine-Clips –output C:\Meine-Clips-coded

Schließen Sie Datei- oder Ordnernamen, die Leerzeichen enthalten, in Anführungszeichen ein. Beispiel: "mein Beispiel.avi"

Sie können Statistikinformationen zu einer Quelldatei anzeigen, indem Sie nur die Quelldatei in einem Befehl angeben. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi

-loadprofile Profildateiname

Gibt den Dateinamen des Windows Media Encoder- oder benutzerdefinierten Profils an, das Sie in der Codierungssitzung verwenden möchten. Profile weisen die Dateinamenerweiterung PRX auf. (Verwenden Sie die Option -profile, wenn Sie eines der vordefinierten Profile verwenden möchten, die im Lieferumfang von Windows Media-Codierungsskript enthalten sind.) Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -loadprofile C:\Meine-Profile\500kbps_peakVBR.prx

Weitere Informationen zum Erstellen eines Profils finden Sie unter Verwenden von Profilen.

-output Dateiname oder Ordnername

Gibt den Namen der Ausgabedatei oder des Ausgabeordners an. Wenn der angegebene Ordner nicht vorhanden ist, wird er erstellt. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Meine-Titel.wma
cscript.exe wmcmd.vbs –input C:\Meine-Titel –output C:\Meine-Titel-coded

-outputstring Zeichenfolge

Beim Codieren von Dateien in einen Ordner fügt dieser Befehl den für Zeichenfolge eingegebenen Text an den Dateinamen aller Ausgabedateien an. Diese Zeichenfolge steht vor der Dateinamenerweiterung WMA oder WMV. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel –output C:\Meine-Titel-coded –outputstring coded

-pixelratio x y

Gibt das Pixelseitenverhältnis des codierten Videos an. Verwenden Sie diese Option, wenn die Videoquelle nicht quadratische Pixel aufweist und Sie das Pixelseitenverhältnis des Quellvideos beibehalten möchten. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -pixelratio 8 9

-pixelformat Format

Gibt das Pixelformat des codierten Videos an. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -pixelformat RGB32

Eine Liste mit Pixelformaten finden Sie unter Unterstützte Pixelformate.

-profile Profilindex

Gibt das vordefinierte Profil für die Codierungssitzung an. (Verwenden Sie die Option -loadprofile, wenn Sie ein benutzerdefiniertes Profil verwenden möchten.) Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -profile av700pal

Eine Liste mit Profilen finden Sie unter Verwenden von Profilen.

-rating Zeichenfolge

Gibt die Bewertung des Inhalts an. Diese Information wird bei der Wiedergabe des Inhalts angezeigt. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –rating PG

-saveprofile Profilname

Speichert die anderen in einem Befehl angegebenen Optionen zur späteren Verwendung als Profil. Profile weisen die Dateinamenerweiterung PRX auf. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi -output C:\Meine-Clips-coded\MeineDatei.wmv –v_clip 4 6 2 8 –v_codec WMV8 -v_bitrate 100000 –v_keydist 20 –v_framerate 24 -saveprofile C:\Meine-Profile\100kbps.prx

Weitere Informationen zum Erstellen eines Profils finden Sie unter Verwenden von Profilen.

-silent

Verhindert, dass nach dem Codierungsvorgang Codierungsstatistikinformationen angezeigt werden.

-s_config Dateiname

Erstellt eine Konfigurationsdatei. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –s_config C:\Konfig-Dateien\MeineVideos.weu

Sie können auch einen Texteditor verwenden, um eine Konfigurationsdatei zu erstellen. Wenn Sie die Konfigurationsdatei erstellt haben, können Sie die Datei mit der Option -config aufrufen. Weitere Informationen finden Sie unter Verwenden von Konfigurationsdateien.

-time Startzeit Endzeit

Gibt die Zeitpunkte innerhalb der Eingabedatei an (in Millisekunden), an denen die Codierung gestartet und beendet werden soll. (Verwenden Sie die Option -time, wenn Sie eine Datei als Quelle verwenden. Verwenden Sie die Option -duration, wenn Sie ein Liveereignis von Geräten aufzeichnen.) Wenn Ihnen der genaue Endzeitpunkt nicht bekannt ist, geben Sie statt der Endzeit den Wert end ein. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –time 10000 20000
cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –time 10000 end

-title Zeichenfolge

Gibt einen Titel für den Inhalt an. Diese Information wird bei der Wiedergabe des Inhalts angezeigt. Wenn die Zeichenfolge Leerzeichen enthält, müssen Sie diese in Anführungszeichen setzen. Die maximale Zeichenfolgenlänge beträgt 255 Zeichen. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Titel\Titel1.wav –output C:\Meine-Titel-coded\Titel1.wma –title "Meine Lieblingsmusik"

-videoonly

Bei Verwendung einer Datei als Quelle, die sowohl Audio- als auch Videoinhalt enthält, wird mit diesem Parameter festgelegt, dass nur die Videoanteile codiert werden.

-v_bitrate Bitrate

Gibt die gewünschte Bitrate in Bit/s an. Der Standardwert lautet 250.000. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_bitrate 100000

-v_buffer Größe

Gibt den Anteil des Videos an (in Millisekunden), der vor der Wiedergabe im Arbeitsspeicher platziert wird. Der Standardwert ist 5.000 Millisekunden. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_buffer 1000

-v_clip links oben rechts unten

Gibt den Bildbereich an, der an den Rändern des Quellvideos entfernt werden soll. Wenn der Wert für die rechte Seite 0 oder größer als die Breite ist, wird der Wert ignoriert und als Breitenwert verwendet. Wenn der Wert für die untere Seite 0 oder größer als die Höhe ist, wird der Wert ignoriert und als Höhenwert verwendet. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_clip 4 6 2 8

-v_codec Codecindex

Gibt den Videocodec an. Wenn Sie keinen Codec angeben, wird der Windows Media Video 9-Codec verwendet. Mit der Option -v_codecs können Sie die Codecs und Codecindizes (beispielsweise WMS9) ermitteln, die auf dem Computer mit dem Encoder installiert sind.

-v_codecs

Zeigt eine Liste der Videocodecs und Codecindizes an, die auf dem Computer mit dem Encoder installiert sind.

-vdevice Nummer des Videogeräts

Gibt das Videogerät an, das als Quelle verwendet werden soll. Beispiel:

cscript.exe wmcmd.vbs -adevice 1 -vdevice 4 –broadcast 8080 –duration 480

Verwenden Sie die Option -devices, um die Gerätenummern für die Audio- und Videoaufnahmegeräte auf dem Computer mit dem Encoder zu erfahren. Die Option -duration wird benötigt, wenn das Aufzeichnen von Geräten erfolgt.

-v_framerate Rate

Gibt die Framerate für die Codierung des Videos an. Die Rate kann als ganze Zahl oder als Gleitkommawert angegeben werden. Der Standardwert ist 30 F/s. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_framerate 24

-v_height Höhe

Gibt die Höhe des Frames in Pixeln an, die codiert werden sollen. Der Standardwert ist die Höhe des Quellvideos. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_height 480

-v_keydist Zeit

Gibt die Anzahl der Sekunden zwischen Schlüsselframes an. Der Standardwert ist 10 Sekunden.

-v_mode Modusnummer

Gibt den Codierungsmodus für Videoinhalt an. Sie können die CBR-Codierung mit einem oder zwei Durchläufen (-v_mode 0 bzw. -v_mode 1) oder einen der folgenden VBR-Codierungsmodi verwenden: qualitätsbasiert (-v_mode 2), bitratenbasiert (-v_mode 3) oder auf maximalen Bitraten basierend (-v_mode 4). Weitere Informationen finden Sie unter Verwenden der CBR- oder VBR-Codierung.

-v_peakbitrate Maximale Bitrate

Gibt die maximale Bitrate für die auf maximalen Bitraten basierende VBR-Codierung für Videoinhalt an (in Bit/s). Die Standardeinstellung ist das Anderthalbfache der Videobitrate. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_peakbuffer Maximale Puffergröße

Gibt den Zeitraum an, für den der Videoinhalt bei der auf maximalen Bitraten basierenden VBR-Codierung zwischengespeichert wird (in Millisekunden). Der Standardwert ist 5.000 Millisekunden. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv -v_mode 4 -v_bitrate 100000 -v_peakbitrate 300000 -v_peakbuffer 8000

-v_performance Nummer

Gibt die Hardwareleistungseinstellung für den Computer mit dem Encoder an. Diese Option sollte bei der Codierung mit dem Windows Media Video 9-Codec verwendet werden. Wenn Sie keinen Wert angeben, werden Codecstandardwerte verwendet. Die möglichen Werte sind 0, 20, 40, 60, 80 und 100, wobei 100 für die beste Qualität steht. Weitere Informationen zu Leistungseinstellungen finden Sie in der Hilfe zu Windows Media Encoder.

-v_preproc Filternummer

Gibt den Vorverarbeitungsfilter an, der auf den Inhalt angewendet werden soll. Eine Liste der möglichen Werte finden Sie unter Optimieren von Video und Audio.

-v_profile Geräteübereinstimmungsindex

Gibt die Komplexitätskategorie des codierten Inhalts an. Verwenden Sie diese Option, wenn der Inhalt zur Wiedergabe auf anderen Hardwaregeräten als Computern vorgesehen ist. Einige Hardwaregeräte unterstützen nur bestimmte Kategorien. (Weitere Informationen finden Sie in der Dokumentation zu Ihrem Gerät.) Wenn Sie die Option -v_profile nicht hinzufügen, wird die korrekte Komplexitätseinstellung automatisch bei der Codierung ausgewählt. Mögliche Werte sind SP (einfach), MP (Standard) oder CP (komplex). Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_profile SP

Windows Media Encoder enthält Hardwareprofile, die auf bestimmte Arten von Hardwaregeräten ausgerichtet sind. Weitere Informationen zu diesen Profilen finden Sie in der Hilfe zu Windows Media Encoder.

-v_quality Qualitätsnummer

Gibt die Bildqualität des codierten Videos an. Mögliche Bildqualitätswerte sind die Werte 0 bis 100. Bei den CBR-Videomodi (-v_mode 0 oder –v_mode 1) ist 0 die optimale Einstellung für natürliche Bewegungen und 100 die optimale Einstellung für die Bildschärfe. Der Standardwert lautet 75. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_mode 0 –v_quality 40

Im qualitätsbasierten VBR-Modus für Video (-v_mode 2) gibt dieser Wert die Zielbildqualität für die gesamte Sequenz an. Der Standardwert lautet 95. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_mode 2 –v_quality 95

-v_width Breite

Gibt die Breite des Frames in Pixeln an, die codiert werden sollen. Der Standardwert ist die Breite des Quellvideos. Beispiel:

cscript.exe wmcmd.vbs –input C:\Meine-Clips\MeineDatei.avi –output C:\Meine-Clips-coded\MeineDatei.wmv –v_width 640

-wme Dateiname

Gibt eine vorhandene Codierungssitzungsdatei an. Beispiel:

 cscript.exe wmcmd.vbs –wme C:\Meine-Sitzungen\Meine_Sitzungsdatei.wme

  • Erweiterte Codierungstechniken


Unterstützte Pixelformate

Wenn Sie die Option –pixelformat verwenden, müssen Sie eines der im Folgenden aufgeführten Pixelformate angeben.

  • I420
  • IYUV
  • RGB24
  • RGB32
  • RGB555
  • RGB565
  • RGB8
  • UYVY
  • YUY2
  • YV12
  • YVU9
  • YVYU

  • Verwenden von Befehlszeilenoptionen


Häufig gestellte Fragen (FAQs)

  1. Können Dateien im erweiterten AVI-Format mit Windows Media-Codierungsskript verwendet werden?

    Ja. Windows Media-Codierungsskript unterstützt das erweiterte AVI-Format und kann AVI-Dateien codieren, die größer als 2 Gigabyte (GB) sind.

  2. Können komprimierte Windows Media-Dateien mit den Dateinamenerweiterungen WMA und WMV codiert werden, um eine andere Bitrate zu erzielen?

    Ja. Bessere Ergebnisse erzielen Sie jedoch, wenn Sie die ursprüngliche Quelldatei erneut codieren und die gewünschte Bitrate mit der Option –v_bitrate (für Video) bzw. der Option –a_setting (für Audio) angeben.

  3. Bei Einstellung von –v_bitrate im CBR-Modus mit einem und zwei Durchläufen sowie in den bitratenbasierten VBR-Modi (-v_mode 0, 1 und 3) ist die Bitrate des komprimierten Clips deutlich geringer als bei der Einstellung angegeben. Handelt es sich dabei um einen Fehler?

    Nein. Wenn der Clip oder ein Segment des Clips für die Zielbitrate leicht zu codieren ist (wenn z. B. die Bitrateneinstellung sehr hoch und die Auflösung gering ist), benötigt der Codec nicht die gesamte verfügbare Bandbreite zum Komprimieren des Inhalts.

  4. Bei Einstellung von –v_bitrate im bitratenbasierten VBR-Modus (-v_mode 3) ist die Bitrate des komprimierten Clips deutlich höher als bei der Einstellung angegeben. Handelt es sich dabei um einen Fehler?

    Nein. Wenn Sie Inhalt unter Verwendung der Option –v_mode 3 codieren, werden keine Frames verworfen. Wenn der Clip oder ein Segment des Clips für die Zielbitrate schwierig zu codieren ist (wenn z. B. die Bitrateneinstellung niedrig und die Auflösung hoch ist), benötigt der Codec mehr Bandbreite zum Komprimieren des Inhalts.

  5. In welcher Reihenfolge führt Windows Media-Codierungsskript das Schneiden, die Vorverarbeitung und die Größenveränderung des Inhalts durch?

    Das Schneiden ist der erste Schritt. Dieser Schritt wird an der Quelle ausgeführt. Wenn das Schneiden zuerst erfolgt, ist der Codierungsvorgang effizienter, da nicht benötigte Teile des Videos vor der Codierung entfernt werden. Die Vorverarbeitung, die z. B. im Anwenden von Filtern zum Entfernen von Zeilensprüngen oder von Filtern für die umgekehrte Filmabtastung (Inverse Telecine) besteht, ist der zweite Schritt, gefolgt vom Festlegen der Ausgabegröße des codierten Videos.

  6. Kann Windows Media-Codierungsskript zum Codieren einer MBR-Datei (Multiple Bit Rate, mehrere Bitraten) verwendet werden, um Inhalt für Benutzer mit unterschiedlichen Verbindungsgeschwindigkeiten auszustrahlen?

    MBR-Dateien können unter Verwendung von MBR-Profilen codiert werden, die mit Windows Media Encoder erstellt wurden.

  7. Bei Verwendung von -v_quality zum Festlegen der Bildqualität auf 95 und dann 96 wurde bei beiden Einstellungen dasselbe Ergebnis erzielt. Ist dieses Phänomen normal?

    Ja. Einige -v_quality-Einstellungen werden intern denselben Bildqualitätswerten zugeordnet. Um eine sichtbare Veränderung der Bildqualität zu erzielen, verändern Sie die für -v_quality angegebenen Werte in größeren Abständen.

  • Windows Media-Codierungsskript


Glossar

Um einen Begriff im Glossar zu finden, klicken Sie auf den Buchstaben, der dem ersten Buchstaben des gesuchten Begriffs entspricht.

Sie können auch Glossarbegriffe innerhalb der Hilfe nachlesen, indem Sie auf die unterstrichenen Hyperlinks für die Glossareinträge klicken. Wenn Sie auf einen Glossarhyperlink geklickt haben, werden der Glossarbegriff und die entsprechende Definition in einem Popupfenster angezeigt. Zum Schließen des Fensters klicken Sie auf eine beliebige Stelle in diesem Fenster.

A | B | C | D | E | F | G | H | I | J | K | L | M
N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Abtasten

Der Prozess des Messens der Amplitude eines analogen Signals in regelmäßigen Abständen zum Zweck der Signalkonvertierung in ein digitales Format.

Abtastrate

Die Häufigkeit des Abtastens. Je höher die Abtastrate (d. h., je mehr Proben pro Zeiteinheit genommen werden), desto ähnlicher ist das digitalisierte Ergebnis dem Original.

Ankündigung

Eine Windows Media-Metadatei, die einem Player die Informationen zum Empfangen von Inhalt liefert. Ankündigungsdateien enthalten XML-Skripts (Extensible Markup Language).

Audio Video Interleaved (AVI)

Ein Multimedia-Dateiformat zum Speichern von Ton und bewegten Bildern im RIFF-Format.

AVI

Siehe die Definition für: Audio Video Interleaved (AVI)

Nach oben

B

Bandbreite

Die Fähigkeit eines Netzwerks, eine bestimmte Datenmenge in einem bestimmten Zeitraum zu übertragen.

Bitrate

Die Anzahl der Bits, die pro Sekunde übertragen werden.

Nach oben

C

CBR

Siehe die Definition für: Konstante Bitrate (Constant Bit Rate, CBR)

Codec

Eine Abkürzung für Compressor/Decompressor. Software oder Hardware, mit der digitale Medien komprimiert und dekomprimiert werden.

Codieren

Beim Codieren wird Audio- und Videoinhalt in das angegebene digitale Format konvertiert.

Codierung mit einem Durchlauf

Eine Codierungsmethode, bei der Inhalt im Encoder in einem Durchlauf analysiert und komprimiert wird.

Siehe auch: Codierung mit zwei Durchläufen

Codierung mit zwei Durchläufen

Eine Codierungsmethode, bei der Inhalt im Encoder im ersten Durchlauf analysiert und dann im zweiten Durchlauf komprimiert wird.

Siehe auch: Codierung mit einem Durchlauf

Nach oben

D

Datei im Datenstromformat

Eine Datei, die ein Player zum Entschlüsseln eines Multicastdatenstroms verwendet.

Siehe auch: Datenstromformat

Datenstrom

Digitale Medien, die in einem ununterbrochenen Datenfluss in einem Netzwerk übermittelt werden.

Datenstromformat

Informationen zu den Eigenschaften eines Datenstroms, wie z. B. die verwendeten Codecs, die Framerate und die Framegröße. Ein Player verwendet Informationen zum Datenstromformat, um einen Datenstrom zu entschlüsseln.

Deltaframe

Ein Videoframe, der lediglich die Änderungen des vorherigen Frames enthält. Im Gegensatz dazu enthält ein Schlüsselframe alle zum Erstellen dieses Frames erforderlichen Daten.

Dynamischer Bereich

Der Unterschied (in Dezibel) zwischen den leisesten und lautesten Tönen in einem Stück Audioinhalt.

Nach oben

F

Framerate

Die Anzahl der Videoframes, die pro Sekunde angezeigt werden. Eine höhere Framerate erzeugt im Allgemeinen weichere Bildbewegungen.

Nach oben

H

Header

Ein Dateistrukturelement, das Informationen für eine Anwendung zum Dekomprimieren und Wiedergeben des Inhalts enthält. Der Header in einer geschützten Datei enthält außerdem die erforderlichen Informationen zum Erwerben einer Lizenz.

Nach oben

I

IEEE 1394

Siehe die Definition für: Institute of Electrical and Electronics Engineers (IEEE) 1394

Inhalt

Audio-, Video-, Bild-, Text- oder sonstige Daten, die in einer digitalen Mediendatei oder einem Datenstrom enthalten sind.

Institute of Electrical and Electronics Engineers (IEEE) 1394

Ein serieller Hochgeschwindigkeits-Busstandard, der eine höhere Computerkonnektivität für eine größere Anzahl von Geräten bietet, einschließlich Audio-/Videokomponenten (A/V) der Verbraucherelektronikindustrie, Speicherperipheriegeräte, andere Computer und tragbare Geräte.

Intelligente Ausstrahlung

Ein Ausstrahlungstyp, der Netzwerkbedingungen erkennt und die Eigenschaften eines Video- oder Audiodatenstroms anpasst, um eine optimale Qualität zu ermöglichen.

Internet Protocol Version 6 (IPv6)

Eine aufgrund des schnellen Wachstums im Internet überarbeitete Version von Internet Protocol (IP). Zu den Verbesserungen zählen die IP-Adressengröße von 128 Bit, erweiterte Routingfunktionen und die Unterstützung von Authentifizierung und Datensicherheit.

IPv6

Siehe die Definition für: Internet Protocol Version 6 (IPv6)

Nach oben

K

Komprimierung

Bei der Komprimierung werden redundante Daten aus einer digitalen Mediendatei oder einem Datenstrom entfernt, um deren bzw. dessen Größe oder die verwendete Bandbreite zu reduzieren.

Konfigurationsdatei

Eine von Windows Media-Codierungsskript verwendete Datei, die den zu codierenden Inhalt und die aufzurufenden Befehlszeilenoptionen angibt.

Konstante Bitrate (Constant Bit Rate, CBR)

Eine Eigenschaft eines Datenstroms, in dem die Bitrate für die Dauer des Datenstroms fast einheitlich bleibt.

Siehe auch: Variable Bitrate (Variable Bit Rate, VBR)

Nach oben

L

Letterbox

Ein Videoanzeigeformat, bei dem bei der Wiedergabe schwarze Balken über und unter dem Videobild angezeigt werden. Das Letterboxformat behält das ursprüngliche Seitenverhältnis eines Bilds bei, wenn es mit einem anderen Seitenverhältnis in einem Fenster angezeigt wird.

Lizenz

Mit geschütztem Inhalt verbundene Daten, die beschreiben, wie der Inhalt verwendet werden kann.

Nach oben

M

Markierung

Eine Textzeichenfolge, die mit einer festgelegten Zeit in Windows Media-basiertem Inhalt verknüpft ist. Markierungen bezeichnen häufig hilfreiche Punkte, um mit der Wiedergabe zu beginnen, wie den Beginn einer neuen Szene.

MBR

Siehe die Definition für: Mehrere Bitraten (Multiple Bit Rate, MBR)

Mehrere Bitraten (Multiple Bit Rate, MBR)

Ein Merkmal eines Datenstroms, bei dem derselbe Inhalt mit verschiedenen Bitraten codiert wird, um die Inhaltsübermittlung zu optimieren.

Mehrkanalaudio

Ein Audio-Reproduktionssystem, das mehrere, in der Regel mehr als zwei Tonkanäle verarbeitet. 5.1-Mehrkanalaudio bezieht sich z. B. auf ein Surroundsoundsystem, in dem es fünf primäre Kanäle und einen Subwooferkanal gibt.

Metadaten

Daten zu Daten. Beispiele für Metadaten einer Datei sind Titel, Betreff, Autor und Größe.

Mit Zeilensprung

Anzeigen eines Videoframes in zwei Feldern. Ein Feld enthält die geraden Zeilen des Frames, das andere Feld die ungeraden. Während der Wiedergabe werden die Zeilen in einem Feld zuerst angezeigt und dann die Zeilen im zweiten Feld.

Multicast

Eine Inhaltsübermittlungsmethode, bei der ein einziger Datenstrom von einem Medienserver an mehrere Clients übertragen wird. Die Clients haben keine Verbindung zum Server. Stattdessen sendet der Server im Netzwerk eine Kopie des Datenstroms an multicastfähige Router, die die Daten replizieren. Clients können dann den Datenstrom empfangen, indem sie eine bestimmte Multicast-IP-Adresse und einen bestimmten Multicast-IP-Port überwachen.

Nach oben

N

National Television Standards Committee (NTSC)

Der bedeutendste Fernsehstandard in den USA und Japan. NTSC liefert 30 Frames mit Zeilensprung pro Sekunde bei einer Auflösung von 525 Zeilen.

NTSC

Siehe die Definition für: National Television Standards Committee (NTSC)

Nach oben

P

PAL

Siehe die Definition für: Phase Alternating Line (PAL)

PCM

Siehe die Definition für: Pulscodemodulation (PCM)

Phase Alternating Line (PAL)

Der bedeutendste Fernsehstandard in Europa und China. PAL liefert 25 Frames mit Zeilensprung pro Sekunde bei einer Auflösung von 625 Zeilen.

Pixelformat

Die Größe und Anordnung von Pixelfarbkomponenten. Das Format ist durch die Bitgesamtanzahl angegeben, die pro Pixel verwendet wird, sowie durch die Anzahl der Bits, die zum Speichern der roten, grünen, blauen und Alphakomponenten der Pixelfarbe verwendet werden.

Postroll

Erweitern der Menge codierter Videos um eine angegebene Anzahl von Frames.

Preroll

Aufzeichnen oder Wiedergeben einiger Videoframes oder eines Teils der Audiodaten, bevor die Codierung oder Wiedergabe beginnt, damit sich das Quellgerät stabilisieren kann. Wird auch verwendet, um den Teil der Daten zu beschreiben, für die ein Preroll ausgeführt werden muss.

Profil

Eine Gruppe von Einstellungen, die dem Inhaltstyp und der Bitrate entsprechende Audio- und Video-Codecs zuweisen.

Profil-Editor

Ein Programm, das mit Windows Media Encoder mitgeliefert wird und mit dem Codierungsprofile erstellt und bearbeitet werden.

Siehe auch: Profil

PRX

Die Dateinamenerweiterung eines Profils.

Publishingpoint

Ein Publishingpoint ist eine festgelegte Adresse im Arbeitsspeicher, die eine Clientanforderung für Inhalt in einen physischen Pfad auf dem Server übersetzt, auf dem sich der Inhalt befindet. Ein Publishingpoint dient im Wesentlichen zum Umleiten.

Pull

Übermitteln von Daten an einen Client nur bei Clientanforderung.

Pulscodemodulation (PCM)

Eine Technik zur Digitalisierung von Audiomaterial in ein umkomprimiertes Format, wobei zu festgelegten Intervallen der Amplitude des Signals ein Wert zugewiesen wird.

Push

Übertragen von Daten an einen Client ohne Clientanforderung der Daten.

Nach oben

Q

Quelle

Audio- und Videoinhalt, der mit Geräten aufgezeichnet und codiert werden kann, die auf Ihrem Computer oder von einer Datei installiert sind.

Nach oben

R

RGB

Ein Farbmodell, das die Farbinformationen hinsichtlich der roten (R), grünen (G) und blauen (B) Intensitäten beschreibt, aus denen die Farbe besteht.

Nach oben

S

Schleife

Die Endloswiederholung eines Datenstroms.

Schlüsselframe

Ein Videoframe, der alle zum Erstellen eines Bilds erforderlichen Daten enthält, ohne Verweis auf vorherige Frames.

Siehe auch: Deltaframe

Seitenverhältnis

Das Verhältnis der Breite eines Bilds zu seiner Höhe.

Skriptbefehle

Benannte Daten, die mit einer bestimmten Uhrzeit in Windows Media-basiertem Inhalt verknüpft ist. Player können anhand dieser Daten eine bestimmte Aktion ausführen, wie z. B. das Anzeigen einer Webseite.

Nach oben

T

Telecine

Das Film-zu-Video-Konvertierungssystem, das dem Videobild Frames hinzufügt, um die Unterschiede in den Frameraten zwischen Film und Video zu kompensieren.

Titel/Untertitel

Text, der Bilder oder Videos als zusätzliche Beschreibung oder als Untertitel begleitet.

Nach oben

U

UDP

Siehe die Definition für: User Datagram Protocol (UDP)

Umgekehrte Filmabtastung (Inverse Telecine)

Der Prozess, bei dem die Frames entfernt werden, die hinzugefügt wurden, als der 24-F/s-Film in einen 30-F/s-Videoinhalt konvertiert wurde.

UNC

Siehe die Definition für: Universal Naming Convention (UNC)

Unicast

Eine von Windows Media-Servern verwendete Methode zum Bereitstellen von Inhalt für verbundene Clients, wobei jeder Client einen eigenen Datenstrom empfängt. Kein anderer Client hat Zugriff auf diesen Datenstrom.

Universal Naming Convention (UNC)

Der vollständige Name einer Ressource in einem Netzwerk. Die verwendete Syntax lautet \\Servername\Freigabename, wobei Servername dem Namen des Servers und Freigabename dem Namen der freigegebenen Ressource entspricht. UNC-Namen für Verzeichnisse oder Dateien können im Freigabenamen auch den Verzeichnispfad gemäß folgender Syntax enthalten: \\Servername\Freigabename\Verzeichnis\Dateiname.

User Datagram Protocol (UDP)

Ein verbindungsloses Transportprotokoll im TCP/IP-Protokollstapel, das verwendet wird, wenn ein gewisser Paketverlust akzeptabel ist, wie z. B. bei digitalen Mediendatenströmen.

Nach oben

V

Variable Bitrate (Variable Bit Rate, VBR)

Eine Eigenschaft eines Datenstroms, in dem die Bitrate je nach Datenkomplexität für die Dauer des Datenstroms schwankt.

VBR

Siehe die Definition für: Variable Bitrate (Variable Bit Rate, VBR)

Verlustbehaftete Komprimierung

Ein Prozess zur Komprimierung von Daten, bei dem als unnötig erachtete Informationen entfernt werden und nach der Dekomprimierung nicht mehr wiederhergestellt werden können. Wird in der Regel mit Audio- und Videodaten verwendet, bei denen eine leichte Qualitätsverschlechterung akzeptabel ist.

Verlustfreie Komprimierung

Ein Prozess zur Komprimierung von Daten, bei dem Informationen in komprimierterer Form angeordnet und nach der Dekomprimierung im Originalzustand wiederhergestellt werden.

Nach oben

W

Wartezeit

Die Verzögerung, die beim Verarbeiten oder Übermitteln von Daten auftritt.

WEU

Die Dateinamenerweiterung einer Konfigurationsdatei, die vom Windows Media-Codierungsskript verwendet wird.

Windows Media Audio-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung von Audiodatenströmen verwendet wird.

Windows Media-Datei

Eine Windows Media-Datei enthält im Windows Media-Format gespeicherte Audio-, Video- oder Skriptdaten. Je nach Inhalt und Zweck verwenden Windows Media-Dateien eine Vielzahl von Dateinamenerweiterungen: WMA, WME, WMS, WMV, WMX, WMZ oder WVX.

Windows Media-Format

Das Format, das von Microsoft Windows Media Technologies (oder einem Produkt eines Drittanbieters, das eine lizenzierte Windows Media-Technologie beinhaltet) verwendet wird, um auf Zeitvorgaben beruhenden Inhalt zu erstellen, zu speichern, zu bearbeiten, zu verteilen, auszustrahlen oder wiederzugeben.

Windows Media-Metadatei

Eine Windows Media-Metadatei ist in Windows Media Technologies eine Datei, die Informationen zu Windows Media-Dateien und deren Präsentation liefert. Zu den Dateinamenerweiterungen für Windows Media-Metadateien zählen ASX, WAX, WVX, WMX und NSC.

Windows Media Screen-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung der Sequenzen von Bildschirmbereichen verwendet wird.

Windows Media Video-Codec

Ein Codec, der zur Komprimierung und Dekomprimierung von Videodatenströmen verwendet wird.

WMA

Die Dateinamenerweiterung einer Audiodatei im Windows Media-Format. Der Audioinhalt der Datei ist mit dem Codec von Windows Media Audio codiert.

WME

Die Dateinamenerweiterung für eine Windows Media Encoder-Sitzungsdatei.

WMV

Die Dateinamenerweiterung einer Videodatei im Windows Media-Format.

Nach oben

Y

YUV

Ein Farbmodell, das die Farbinformationen hinsichtlich Helligkeit (Leuchtdichte oder Y) und Farbe (Chrominanz oder U und V) beschreibt.

Nach oben

Z

Zeilensprünge entfernen

Kombinieren der Felder in einem Videoframe mit Zeilensprung, so dass die Linien des Videoframes während der Wiedergabe nacheinander gezeichnet werden.

Siehe auch: Mit Zeilensprung

Zeitcode

Ein auf einen Datenstrom angewendetes digitales Signal. Das Signal weist jedem Videoframe eine Zahl zu, die die Stunden, Minuten, Sekunden und Frames darstellt.

Nach oben


Legal Notice

Windows Media Encoder-Bannergrafik

Rechtliche Hinweise

Die in diesen Unterlagen enthaltenen Angaben und Daten, einschließlich URLs und anderen Verweisen auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Die in den Beispielen verwendeten Firmen, sonstigen Namen und Daten sind frei erfunden, soweit nichts anderes angegeben ist. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Personen oder Ereignissen ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieses Dokuments für irgendwelche Zwecke vervielfältigt, in einem Datenempfangssystem gespeichert oder darin eingelesen werden oder übertragen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen usw.) dies geschieht.

Es ist möglich, dass Microsoft Rechte an Patenten bzw. angemeldeten Patenten, an Marken, Urheberrechten oder sonstigem geistigen Eigentum besitzt, die sich auf den fachlichen Inhalt dieses Dokuments beziehen. Das Bereitstellen dieses Dokuments gibt Ihnen jedoch keinen Anspruch auf diese Patente, Marken, Urheberrechte oder auf sonstiges geistiges Eigentum, es sei denn, dies wird ausdrücklich in den schriftlichen Lizenzverträgen von Microsoft eingeräumt.

© 2000-2002 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, MS-DOS, Windows, Windows Media, Windows NT, ActiveSync, ActiveX, Direct3D, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, FrontPage, JScript, Microsoft Press, MSN, NetShow, Outlook, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Visual Studio, WebTV, Win32 und Win32s sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Andere in diesem Dokument aufgeführte Produkt- und Firmennamen sind möglicherweise Marken der jeweiligen Eigentümer.