Добавление нового PortServer

Примечание. Необходимо знать IP-адрес и номер TCP-порта добавляемого PortServer. Используйте команду PortServer set config, для получения этих сведений.

Windows NT 4.0

  1. Выберите значок системы в окне «Установка службы Digi RealPort».

  2. Нажмите кнопку «Добавить», чтобы запустить мастер добавления PortServer.

  3. Используйте мастер и интерактивную справку для помощи в добавлении PortServer.

Windows 2000 или Windows XP

  1. Нажмите кнопку «Пуск», выберите команду «Настройка», затем «Панель управления», откройте компонент «Установка и удаление программ» (в Windows 2000) или «Установка оборудования» (в Windows XP) и нажмите кнопку «Далее».

  2. Выберите параметр «Добавить/провести диагностику устройства» и нажмите кнопку «Далее».

  3. Когда система определяет, что устройство не найдено, и отображает список устройств, выберите параметр «Добавление нового устройства» и нажмите кнопку «Далее».

  4. В ответ на запрос выберите вариант «Нет, выбрать оборудование из списка» и нажмите кнопку «Далее».

  5. Выберите тип «Многопортовые последовательные адаптеры» и нажмите кнопку «Далее».

  6. Из списка «Изготовители» выберите компанию Digi International, а из списка «Модели» выберите вариант Digi PortServer.

  7. Нажмите кнопку «Далее» дважды.

  8. Используйте мастер добавления PortServer и интерактивную справку для завершения установки и настройки.

  9. Закройте мастер установки/удаления оборудования или мастер установки оборудования после завершения установки.

См. также


Добавление порта в существующий PortServer

  1. Выберите PortServer, к которому требуется добавить порт.

  2. Нажмите кнопку «Добавить», чтобы отобразилось окно «Добавление порта».

  3. Сохраните настройки по умолчанию, нажав кнопку «OK», или измените нужные поля, а затем нажмите кнопку «OK».

Дополнительные сведения о портах


Просмотр и изменение свойств PortServer

  1. Выберите требуемый PortServer и нажмите кнопку «Свойства». Отображается окно «Свойства PortServer».

  2. Внесите требуемые изменения в параметры порта и нажмите кнопку «OK».


Просмотр и изменение свойств порта

  1. Выберите требуемый порт и нажмите кнопку «Свойства». Отображается окно «Свойства порта».

  2. Измените имя порта (если необходимо) и нажмите кнопку «OK».


Удаление PortServer

Примечание.Если удалить используемый PortServer, то все пользователи будут отключены без предупреждения.

Windows NT 4.0

  1. Выделите удаляемый PortServer.

  2. Нажмите кнопку «Удалить».

Windows 2000 или Windows XP

  1. В диспетчере устройств выберите PortServer, который требуется удалить.

  2. В меню «Действие» выберите команду «Удалить» и нажмите кнопку «OK».


Удаление порта

  1. Выберите порт, который требуется удалить.

  2. Нажмите кнопку «Удалить».

Примечание. Если устройство, подключенное к удаляемому порту, в данный момент используется, все процессы будут прерваны без предупреждения.


Переименование PortServer или порта

  1. Выберите требуемый порт или PortServer и нажмите кнопку «Свойства».

  2. Измените имя и нажмите кнопку «OK».


Имя

В этом поле отображается текущее имя PortServer при данном IP-адресе. Имя можно изменить путем ввода нового имени в это поле.

Надо использовать имя, которое однозначно определяет PortServer. Например в качестве имени можно указывать расположение или функцию PortServer.


TCP-порт

В этом поле необходимо указать номер TCP-порта PortServer. Номер TCP-порта по умолчанию — 771.

Если возникают проблемы с подключением к PortServer при использовании значения по умолчанию 771, проверьте номер реального TCP-порта на PortServer. Используйте команду PortServer «set config» для получения необходимых сведений. Найдите номер в строке «realport» (PortServer II) или «netcx» (PortServer).

Примечание. Номер TCP-порта можно изменить, отправив команды «set config realport» (PortServer II) или «set config netcx» (PortServer) через терминал, подключенный к порту 1.


Цикл опроса

Цикл опроса — число миллисекунд, в течение которых служба RealPort будет ожидать дополнительных данных для составления полного пакета, определенного параметром «Наибольший размер пакета», перед отправкой пакета в PortServer. Если время цикла опроса превышено, то пакет отправляется в любом случае.

В зависимости от настроек данной системы можно увеличить значение по умолчанию, чтобы уменьшить сетевой трафик.

Допустимый диапазон значений цикла опроса от 10 до 1000 миллисекунд.


Наибольший размер пакета

По умолчанию наибольший размер пакета 1460. Данный параметр позволяет оптимизировать работу службы RealPort в Ethernet по протоколу TCP/IP. Изменяйте значение по умолчанию только при работе с носителем отличным от Ethernet.

Наибольший размер пакета — это количество байт данных, помещаемых в пакет службой RealPort. Чтобы свести эту величину к минимуму, надо, чтобы она была равной или меньшей, чем часть наибольшего размера передаваемых данных (Maximum Transmission Unit, MTU) носителя, передающий пакеты в PortServer. (Если наибольший размер пакета превышает часть MTU, то все данные в пакете RealPort не поместятся в один пакет носителя и дополнительные данные придется отравлять вторым пакетом, что увеличит сетевой трафик.)

Пример структуры пакета MTU для Ethernet.

MAC | 14 байт
IP(V4) | 20 байт
протокол TCP | 20 байт
Данные TCP | 1460 байт
FCS | 04 байт

Суммарный размер MTU = 1518 байт

Допустимый диапазон значений наибольшего размера пакета от 3 до 65 535 байт.


IP-адрес

В этом поле необходимо указать IP-адрес PortServer.

Чтобы узнать IP-адрес, отправьте команду «set config» через терминал, подключенный к порту 1 PortServer. Отобразиться список параметров настройки.


Сведения об IP-адресе PortServer

IP-адрес присваивается PortServer командой set config из терминала, подключенного к PortServer.

Чтобы определить IP-адрес PortServer введите команду set config. Все сведения о конфигурации, включая IP-адрес, будут отображены на терминале.


Сведения о номере TCP-порта PortServer

Номер TCP-порта по умолчанию, т. е. установленный производителем, 771.

Чтобы определить текущий параметр, используйте команду set config. Найдите значения параметров рядом с записями «realport» (PortServer II) или «netcx» (PortServer).

Примечание. Номер TCP-порта может быть изменен с помощью одной из следующих команд из терминала, подключенного к PortServer:

  • set config realport (PortServer II)

  • set config netcx (PortServer)


Использование порта

Можно добавить порт или изменить, назначенное по умолчанию имя порта в любое время.

  • Чтобы изменить имя существующего порта, выполните следующие действия.

Введите новое имя в поле «Имя».

Например, если к порту 5 подключен принтер, то имя этого порта можно изменить на «Принтер».

  • Чтобы добавить дополнительный порт, выполните следующие действия.

Введите номер порта в поле «Порт» и имя порта в поле «Имя» (или используйте свойства по умолчанию, нажав кнопку «OK»).

  • Чтобы найти устройства, подключенные к порту, выполните следующие действия.

Операционная система Windows периодически проверяет последовательные порты на наличие подключенного устройства. Имеется возможность настроить частоту этих проверок в интервале от одной секунды до одной минуты. Если этому параметру присвоено значение Вручную (т.е. значение по умолчанию), автоматическая проверка отключена и требуется использовать панель управления для добавления новых устройств.

Примечание. Изменение этих полей при помощи кнопки «Свойства» ведет к изменению параметров существующего порта, но новый порт при этом не добавляется.

Дополнительные сведения о портах


Установка службы Digi RealPort

Это окно содержит все настроенные для данной системы PortServers и порты каждого PortServer. Щелкните значок +, чтобы развернуть список. Щелкните значок -, чтобы свернуть список.

Добавление нового PortServer

Добавление порта в существующий PortServer

Удаление PortServer

Удаление порта

Просмотр свойств PortServer

Просмотр и изменение свойств порта

Переименование PortServer или порта


Свойства портов PortServer

Это окно содержит нумерованный список портов доступных на PortServer и имена портов, соответствующие номеру порта. Обратите внимание, что этот список отличается от главного окна, содержащего только список имен портов.

  • Чтобы изменить имена портов, нажмите кнопку «Свойства» и введите новое имя в поле отображаемого окна «Имя» .

  • Чтобы добавить порт, нажмите кнопку «Добавить».

  • Чтобы удалить порт, выберите требуемый порт и нажмите кнопку «Удалить».


Свойства PortServer

Имя

IP-адрес

TCP-порт

Цикл опроса

Наибольший размер пакета


IP-адрес и TCP-порт PortServer

Мастер попытается подключится к PortServer по указанному адресу и номеру TCP-порта. Если попытка подключиться будет неудачной, на экране появится ряд сообщений об ошибках, но настройку драйвера RealPort можно будет продолжить. Однако перед началом работы с драйвером RealPort, надо установить причину, по которой мастер не смог подключится.

  • Убедитесь, что IP-адрес и номер TCP-порта правильны.

  • Проверьте журнал событий на наличие записи об ошибке.

IP-адрес

TCP-порт


Имя PortServer и число портов

Данное окно позволяет выполнять следующие действия.

  • Назначать имя PortServer, к которому осуществляется подключение при помощи драйвера RealPort.

  • Если пользователь не вводит имя, то оно назначается мастером по умолчанию. Позднее имя можно изменить в окне «Свойства PortServer».

  • Изменять число используемых портов.

  • Число портов, найденных на данном PortServer, отображается. Можно изменить это значение на число меньшее фактического числа портов, если отсутствует необходимость в использовании всех доступных портов, при помощи службы RealPort. Позднее порты можно добавить или удалить в окне «Свойства PortServer».

Примечание. Можно указать больше портов, чем существует на данном PortServer, но их нельзя будет использовать.


Предполагаемые дальнейшие действия

Завершение настройки.

  • Нажмите кнопку «Готово», чтобы перейти в окно мастера установки службы Digi RealPort.

  • Чтобы немедленно изменить имена портов PortServer, щелкните нужный порт и введите новое имя, а затем нажмите кнопку «Готово».

  • Чтобы изменить имя PortServer, число портов и/или IP-адрес и номер порта нажмите кнопку «Назад», для возвращения в предыдущее окно, или нажмите кнопку «Готово» а позднее внесите изменения в окне свойств PortServer.


Дополнительные сведения о портах

  • Рядом с разъемом каждого порта есть номер, начиная с 1. PortServer содержит 16 портов которые можно увеличить до 64, добавив модули расширения. Каждому из портов PortServer присваивается по умолчанию системное имя во время установки RealPort — COM2, COM3, COM4 и т. д.

  • Порты не надо добавлять и настраивать по порядку. Можно изменить поле «Порт» на любой допустимый номер порта. Например, можно зарезервировать порты с 1 по 8 для модемов и порт 26 для принтера. При использовании только этих портов можно сократить список, удалив ненужные порты.