How To Order

Ordering Info

What you get when you order:
  1. Unlimited use of the program.
  2. No more nag screens or waiting.
  3. Free updates to all future versions.
  4. And you also will make it possible for me to continue developing future versions of this program, as well as others.

How to order:

Ordering Bash HTML Editor is cheap and easy. All you need to do fill out and print this order form and send it along with your payment to:

Jeremy Bash
4426 West River Road
Huntington, WV 25704

The very same day that your payment is received you will be sent a registration number to unlock your program (via email if you provided one, or by snail mail if you didn't). Registration costs only $20 (U.S.) and payment may be made by personal check, money order, or simply in cash (though it is not recommended).

You can also save by ordering more than one product at a time. Currently, there are two special software bundles, each saving you nearly 17%. You can order either Bash HTML Editor and TaskForce, or Bash HTML Editor and Deskbolt, for only $25 per bundle. To order one of these specials, click the corresponding link below:

Bash HTML Editor and Deskbolt
Bash HTML Editor and TaskForce


Bash HTML Editor Order Form

Product: Bash HTML Editor
Name*:
Email*:
Website:
Comments/
Suggestions:
* = Required


HTML Tutorial

This tutorial will teach you the very basics of HTML coding. For more info on each individual tag, click the help icon in that tag's insert window.

HTML, which stands for Hypertext Markup Language, is the language which websites are made from, and is actually fairly easy to learn. HTML instructions are called "tags", and are enclosed in "less than" and "greater than" symbols, looking like this: <tag>. Most html tags require that you use both opening and closing tags so that the browser will know where it begins and ends. Closing tags are exactly the same except for a forwared slash which comes after the less than sign. For example <b>some text</b> will make the words "some text" bold. Without the ending tag the bold effect would never be turned off and all text after the initial <b> would be bold. Things which don't necessarily have a beginning and an end, such as an image or a linebreak, don't require closing tags. A simple <br> will create a linebreak.

When writing an html document you may space the tags out in any manner which you like, to make it the most readable for you. For example you could write all of your code onto one line, and even though it would still display the same in the browser, it would be very difficult to read and edit.

Now that you understand the basic format that you use in writing HTML, let's begin an html document. There are a few basic html tags which all webpages need. First you use the <html> tag to signal the beginning of the document, followed by the <head> tag where you can place descriptive information for search engines, or other special code such as CSS properties and javascripts (which will be explained later). Next you use the <title> tag to give your page a name, closing it with a </title> tag. Then you use the <body> tag which is where most of your code will go. When you are finished coding your page, you should end it by closing any open tags, so you will need to use </body> and </html> to signal the end of the file. Therefore an html page in it's most basic form is as follows: <html> <head> <title>My Website</title> </head> <body> The majority of your code goes here. </body> </html>
Now that you have the basic framework of your html page, you can begin designing it. Use the Insert menu and click the help icon in each object's window when you need an explination of a tag's use or syntax.

Along with HTML there are several other languages and methods you can incorporate into your pages, below are the most common.

CSS
CSS, which stands for Cascading Style Sheet, is used to set attributes which are not exposed by standard HTML. With CSS properties you can hide underlines from your links, add colors or images to form objects, change the border style on objects, and much more. There are a few different ways in which you can set CSS properties, which are explained under the "General Info" tab of the CSS window.

Javascript
Javascript is a language used to perform functions on a webpage. You can use javascript to create effects and show popup windows or message boxes, among many other things. Like CSS, you can either place the script in your <head> section or save it to a seperate file (usually .js) and refer back to it. Unless you really need to write your own custom javascripts, you will most likely just use a script written by someone else, because javascript is much more complex than html and requires more time to learn.

Flash
Flash is used to create interactive websites and display complex animations at very small filesizes. With Flash you can create anything from menu systems to fancy intros to web-based games. Flash accomplishes small file sizes by mostly using vector graphics, instead of raster images. A vector graphic is drawn from a set of instructions rather than being already saved to a file. For example the image of a square saved to a raster image (such as bmp, gif, or jpeg) contains color information for every single pixel (a 100x100 pixel image has a whopping 10,000 pixels), but that same square drawn with vector graphics only needs the one color of the entire square and the square's dimensions. For more information visit the Macromedia website at macromedia.com.

CGI
CGI, which stands for Common Gateway Interface, is used to process information. You can use scripts to process forms, redirect users, or create hit counters. CGI scripts are usually written in Perl and to use them you will need a host that supports them. Most free webservers do not allow custom CGI scripts to be installed. As an alternative, you can use remotely hosted CGI scripts offered by some websites. To find CGI scripts, simply do a search on Google, or try this site, but know that a lot of the scripts provided there are not free.


HTML Tutorial

FTP Tutorial

This tutorial will teach you the basics of FTP. FTP stands for File Transfer Protocol, and as you can probably guess, it is used to transfer files across the web. With the built-in FTP access of this program you can upload webpages you have written, along with images or any other file type, to your webserver.

First, you need to find out if your webserver supports FTP access, and if so what your logon details are. You should be able to find this out from your host's website. If you are using free webspace your username and password are usually the same as those you use to logon to that service's web-based file manager. Your URL is more than likely ftp.domain.com, in other words if your website is hosted at angelfire.com, then your ftp address would be ftp.angelfire.com. Also, The port is almost always 21.

When transferring files, you need to make sure you are using the correct transfer mode. Use ASCII when transferring text-based files, such as html files, and use binary for all other file types, such as images and programs.

This program's limitations: The FTP client included with this program does not feature CHMOD abilities. CHMOD is used to set permissions on your files, usually for CGI files. Look in the Resources section of this help file for more full-featured FTP programs.


Free Webspace Providers

Angelfire
Free Space: 20 MB
Ads: On page or in popup
Access: HTTP or FTP
CGI Support: No
URL: http://www.angelfire.com

Netfirms
Free Space: 25 MB
Ads: On page
Access: FTP only
CGI support: Yes
URL: http://www.netfirms.com

Geocities
Free Space: 15 MB
Ads: On page, in collapsible mini-window
Access: ???
CGI Support: No
URL: http://www.geocities.com


Free Services

Bravenet
Services Available:
Message Boards
Polls
Hit Counters
Mailing Lists
Guestbooks
And More
URL: http://www.bravenet.com

Kickme.to
Services Available:
Short URLs
URL: http://kickme.to

V3
Services Available:
Short URLs
URL: http://www.v3.com

CgiSpy
Services Available:
Remotely Hosted CGI Scripts
URL: http://www.cgispy.com

AddMe
Services Available:
Adds your site to many different search engines
URL: http://www.addme.com

DK3
Services Available:
Free, hosted forums
Banner Exchange
Hit Counters
Mailing Lists
URL: http://www.dk3.com


Utilities

FTP Clients

Cute FTP / CuteFTP Pro
Price: Shareware ( $40 / $60 )
URL: http://www.globalscape.com

SmartFTP
Price: Free
URL: http://www.smartftp.com

Graphics

Flash MX
Usage: Create interactive websites with Flash animation
Price: Shareware ( $500 )
URL: http://www.macromedia.com

Paint Shop Pro
Usage: Create graphics in several formats including gif and jpeg.
Price: Shareware ( $100 )
URL: http://www.jasc.com

Misc.

WinRar
Usage: Handles .zip, .rar, .ace, .iso, and many other compressed file formats.
Price: Shareware ( $30 )
URL: http://www.rarlab.com


Free Scripts

PageResource
Tutorials on HTML, Javascript, and other web languages
URL: http://www.pageresource.com

DynamicDrive
Free copy and paste DHTML and Javascript code
URL: http://www.dynamicdrive.com


Support

Customer Support
If you have any questions or comments concerning any of the software, email support@bashsoftware.tk. You do not have to be a registered customer to receive support and most email will be answered within 24 hours.

Lost Registration Key
If you have lost your registration key, simply send an email to the address above and include the product name, version, and the name that you registered with (which can be found in the About box). I will send you your serial number again.


Bash HTML Editor & Deskbolt Bundle Order Form

Products: Bash HTML Editor & Deskbolt
Name*:
Email*:
Website:
Comments/
Suggestions:
* = Required


Bash HTML Editor & TaskForce Bundle Order Form

Products: Bash HTML Editor & TaskForce
Name*:
Email*:
Website:
Comments/
Suggestions:
* = Required