Objects

VOB Computersysteme GmbH
SDK Objects

App
Devices
CDRomDevice
CDRDevice
CDInformation
TrackInformation
Projects
JukeBox
VirtualCD
VCDTrack
VCDImageTrack
VCDAudioTrack
VCDDataTrack
CDText
Folder
Folders
FileCollection
File
CDRInformation
WriteSupportInfo


Devices

Object App
Devices Propert y

Description

Returns the Devices object that is used to gain and set information about the connected CD-ROM and CD-W / CD-RW devices.

Syntax

object.Devices


Object_App

VoB Computersysteme GmbH
Object A pp

Description

App is the main object. You can use it to access the other objects in the hierarchy.


Projects

Object App
Projects Propert y

Description

Projects enables access to the individual CD Projects (Virtual CDs).

Syntax

object.Projects


Version

Object App
Version Propert y

Description

Returns the version of the Application Server

Syntax

object.Version


DiscSize

Objec t CDinformation
DiscSize Propert y

Description

Size of the inserted disc in sectors.

Syntax

object.DiscSize


DiscStatus

Objec t CDInformation
DiscStatus Propert y

Description

Status of the inserted CD. Status indicates if the CD is blank, recordable or unrecordable.

Syntax

object.DiscStatus

Remarks

DiscStatus can have the following values:

Value | Meaning
dsBlankDisc = 0 | CD is a recordable, blank disc
dsRecordable = 1 | CD is recordable
dsUnRecordable = 2 | CD is not recordable (closed)


DiscType

Objec t CDInformation
DiscType Propert y

Description

Returns the Mode of the inserted CD.

Syntax

object.DiscType

Remarks

Value | Meaning
dtCDRom = 0 | Data CD-ROM with Mode 1 Track(s)
dtCDDA = 8 | Audio CD
dtCDI = 16 | CD-I
dtMode2XA = 32 | Data CD-ROM with Mode 2 Track(s)


NextRecordableAdr

Objec t CDInformation
Next RecordableAdr Propert y

Description

NextRecordableAdr returns the position in sectors where additional data can be written on the inserted CD.

Syntax

object.NextRecordableAdr

Remarks

NextRecordableAdr is only meaningful for a recordable CD. In other cases, NextRecordableAdr is set to -1. For retrieving the possible disc status, read the DiscStatus property.


Object_CDInformation

VoB Computersysteme GmbH
Object CDInformation

Description

CDInformation contains data about the CD inserted in a CD-ROM or CD-R device.


SessionCount

Objec t CDInformation
SessionCount Propert y

Description

SessionCount returns the number of Sessions on the inserted CD.

Syntax

object.SessionCount


TrackCount

Objec t CDInformation
TrackCount Propert y

Description

TrackCount returns the number of tracks of the inserted CD.

Syntax

object.TrackCount

Remarks

TrackCount is in the Range 0 to 99.


CDRInfo

Object CDRDevice
CDRInfo Property

Description

CDRInfo returns a CDRInformation object that can be used to get information about the CD-R Device.

Syntax

object.CDRInfo


Object_CDRDevice

VoB Computersysteme GmbH
Object CDRDevice

Description

Object for getting information abou a recording device.

Remarks

A CDRDevice object is a descendant of the CDROMDevice, thus sharing all the properties and methods of that object.
A CD-R Drive is recognized as a CD-R by the program if a driver is assigned to the device. A CD-R Drive that is not registered in the driver library will be shown as a CD-ROM.


CloseTrackSupport

Objec t CDRInformation
CloseTrackSupport Propert y

Description

CloseTrackSupport is a boolean property indicating if the CD-R Device can close a track.

Syntax

object.CloseTrackSupport

Remarks

CloseTrackSupport refers to the capability of some devices to close a track, if the write process failed.
This is also called track repair.


CurrentWriteSpeed

Objec t CDRInformation
Cur rentWriteSpeed Propert y

Description

CurrentWriteSpeed sets and returns the write speed of the CDR-Device.

Syntax

object.CurrentWriteSpeed

Remarks

The possible writespeeds can be retrieved by reading the property SupportedWriteSpeed.

Example

The following example sets the write speed to 4x:

CDRInfo.CurrentWriteSpeed = 4;


DAO_Info

Objec t CDRInformation
DAO_Info Propert y

Description

DAO_Info returns an object of type WriteSupportInfo

Syntax

object.DAO_Info

Remarks

DAO_Info, like SAO_Info and TAO_Info is used to get information about the features that are supported by the CD-R Device for a specific write mode.


DirectWriteSupport

Objec t CDRInformation
DirectWriteSupport Propert y

Description

Indicates if the CD-R Device supports the Direct Write feature.

Syntax

object.DirectWriteSupport

Remarks

DirectWrite allows to burn oversized CDs. Some CD-Rs can hold more data than what CDInformation returns.
Only CD-R Devices supporting Disc-At-Once might support DirectWrite.


DriverName

Objec t CDRInformation
Dri verName Propert y

Description

Name of the assigned driver.

Syntax

object.DriverName

Remarks

Every CD-R Device has a driver assigned to it. DriverName gives is used to determine, which driver is assigned.


DriverVersion

Objec t CDRInformation
DriverVersion Propert y

Description

Version of the assigned driver

Syntax

object.DriverVersion


ErasableSupport

Objec t CDRInformation
ErasableSupport Propert y

Description

Indicates if the CDR-Device can erase a CDRW-Medium

Syntax

object.ErasableSupport

Remarks

A CDRW-Device is treated as a CD-R device. If ErasableSupport is true, the device is a CDRW device.


Object_CDRInfomation

VoB Computersysteme GmbH
Objec t CDRInformation

Description

Object that contains information about the capabilities of a CD-R device.


RecoverSupport

Objec t CDRInformation
RecoverSupport Propert y

Description

Indicates that the CD-R can be recovered after an unsuccessful write operation.

Syntax

object.RecoverSupport

Remarks

Some writers automatically recover a track if the write operation has been interrupted.


SAO_Info

Objec t CDRInformation
SAO_Info Propert y

Description

SAO_Info returns an object of type WriteSupportInfo

Syntax

object.SAO_Info

Remarks

SAO_Info is used to get information about the features that are supported by the CD-R Device when using the Session-At-Once write mode.


SupportedWriteSpeed

Objec t CDRInformation
SupportedWriteSpeed Propert y

Description

Bitfield that represents the supported write speeds.

Syntax

object.SupportedWriteSpeed

Remarks

SupportedWriteSpeed is a 32bit integer.

Bit | Speed
0 | 1x
1 | 2x
2 | 3x
3 | 4x
4 | 5x
5 | 6x
6 | 7x
7 | 8x


TAO_Info

Objec t CDRInformation
TAO_Info Propert y

Description

TAO_Info returns an object of type WriteSupportInfo

Syntax

object.TAO_Info

Remarks

TAO_Info is used to get information about the features that are supported by the CD-R Device when using the Track-At-Once write mode.


TAO_PauseSupport

Objec t CDRInformation
TAO_PauseSupport Propert y

Description

Indicates if the writer supports the setting of pauses other than the default values.

Syntax

object.TAO_PauseSupport

Remarks

Normally when writing CDs in the Track-At-Once write mode the pregap and postgap length is fixed. Some


Eject

Object CDR OMDevice
Eject Method e

Description

Ejects the inserted CD.

Syntax

object.Eject

Remarks

This method sends the eject command to the device. If no CD is inserted the command is ignored.


GetCDInfo

Object CDR OMDevice
GetCDInfo Method e

Description

Returns an object of type CDInformation

Syntax

object.GetCDInfo


GetTrackInfo

Object CDR OMDevice
GetTrackInfo Method e

Description

Retrurns a TrackInformation object containing information about the specified track.

Syntax

object.GetTrackInfo(TrackNr)

Part | Description
object | An object expression that evaluates to a CDROMDevice object.
TrackNr | Number of the track

Remarks

If TrackNr is bigger than the number of tracks on the CD, GetTrackInfo returns nil.


IDString

Objec t CDR OMDevice
IDString Propert y

Description

Identifier string of the device.

Syntax

object.IDString

Remarks

IDString contains the Vendor name and the device name.


Object_CDROMDevice

VoB Computersysteme GmbH
Object CDROMDevice

Description

Object representing a CDROM device attached to the computer.


TargetID

Objec t CDR OMDevice
TargetID Propert y

Description

Target ID of the Device.

Syntax

object.TargetID

Remarks

Target ID is valid for SCSI and ATAPI devices.


_Message

Objec t CDText
_Message Propert y

Description

Contains the additional message text as defined by the CD-Text standard.

Syntax

object._Message


Arranger

Objec t CDText
Arranger Propert y

Description

Contains the arranger text as defined by the CD-Text standard.

Syntax

object.Arranger


Composer

Objec t CDText
Composer Propert y

Description

Contains the composer text as defined by the CD-Text standard.

Syntax

object.Composer


Object_CDText

VoB Computersysteme GmbH
Object CDText

Description

This objects is used to set and retrive CD Text information for a CD or a single track.


Performer

Objec t CDText
Performer Propert y

Description

Contains the performer text as defined by the CD-Text standard.

Syntax

object.Performer


Songwriter

Objec t CDText
Songwriter Propert y

Description

Contains the songwriter text as defined by the CD-Text standard.

Syntax

object.Songwriter


Titel

Objec t CDtext
Title Propert y

Description

Contains the title text as defined by the CD-Text standard.

Syntax

object.Title


Count

Objec t Devices
Coun t Propert y (read-only)

Description

Count returns the number of devices actually attached and recognized by CD Wizard

Syntax

object.Count

Remarks

Devices maintains a list of all SCSI and ATAPI devices that identify themselves as CD-ROM or CD-WORM devices.


GetDevice

Object Device s
GetDevice Method e

Description

IDispatch

Syntax

object.GetDevice(DeviceNum)

Remarks


GetDeviceByID

Object De vices
GetDeviceByID Method e

Description

CDRomDevice

Syntax

object.GetDeviceByID(HaID, TargetID, Lun)

Part | Description
HaID | ID number of the Hostadapter to which the device is connected
TargetID | Target ID of the device
Lun | Logical unit number of the device

Remarks

This method returns a CDRomDevice or CDRDevice object depending on the selected device. If a driver is assigned to the device, a CDRDevice object is returned.

If there is no device found at the given SCSI-Address the function returns nil.


GetDeviceByPath

Object Devices
GetDeviceByPath Method e

Description

CDRomDevice

Syntax

object.GetDeviceByPath(Path)

Part | Description
object | An object expression that evaluates to a Devices object
Path | Path of the CD-ROM Drive

Remarks

Example

Device = Devices.GetDeviceByPath("D:\\"); // get the CDRomDevice object for the drive with drive letter D:


Object_Devices

VoB Computersysteme GmbH
Object Devices

Description

Collection of the CD-ROM and CD-R devices that are recognized by the application.


Refresh

Objec t Devices
Refresh Methode

Description

Rebuilds the list of CDROM and CDR devices.

Syntax

object.Refresh

Remarks

Call this method if devices have been detached from or attached to the computer.


Copy

Object File
Copy Method e

Description

Copies the actual File to a new Folder.

Syntax

object.Copy(Destination,OverWriteFiles)

Part | Description
object | An object expression that evaluates to a File object
Destination | Destination path
OverWriteFiles | Overwrite if file exists in Destination


DateCreated

Objec t File
Date Created Propert y

Description

Date of creation for the file.

Syntax

object.DateCreated


DateLastAccessed

Objec t File
DateLast Access ed Propert y

Description

Last access date and time fort the file.

Syntax

object.DateLastAccessed


DatelastModified

Objec t File
DateLastModified Propert y

Description

Last modification date and time of the file

Syntax

object.DateLastModified


Delete

Object File
Delete Method e

Description

Deletes the selected File

Syntax

object.Delete(Force)

Part | Description
object | An object expression that evaluates to a File object
Force | If true, there will be no confirmation message

Remarks

After deletion of the file, the object is no longer valid.


Move

Object File
Move Method e

Description

Moves the file to another directory

Syntax

object.Move(Destination)

Part | Description
object | An object expression that evaluates to a File object
Destination | Destination path


Name

Objec t File
Name Propert y

Description

Long name of the file

Syntax

object.Name


Object_File

VoB Computersysteme GmbH
Object File

Description

This objects gives access to a single file stored in a Virtual CD.


ParentFolder

Objec t File
ParentFolder Propert y

Description

Folder that contains the file.

Syntax

object.Parentfolder


Path

Objec t File

Path Propert y

Description

Complete path of the file.

Syntax

object.Path


ShortName

Objec t File
ShortName Propert y

Description

Shortname (DOS 8.3) of the file

Syntax

object.Shortname


Shortpath

Objec t File
Short Path Propert y

Description

Short path (DOS 8.3) of the file

Syntax

object.Shortpath


Size

Objec t File
Size Propert y

Description

Size of the file in bytes.

Syntax

object.Size


Type_

Objec t File
Type_ Propert y

Description

String containing the file type as returned by Windows.

Syntax

object.Type_


Add

Object FileCollection
Add Method e

Description

Add a File to the current folder.

Syntax

object.Add(Path)

Part | Description
object | An object expression that evaluates to a File object
Path | Path of the file on disc.


Count

Objec t FileCollection
Count Propert y

Description

Number of files in the file collection.

Syntax

object.Count


Item

Objec t FileCollection
Item Propert y

Description

Returns a File object.

Syntax

object.Item[Index]

Part | Description
object | An object expression that evaluates to a FileCollection object
Index | Index of the file

Remarks

Index must be in the range 0 to FileCollection.Count -1. If Index is invalid, the property will have the value nil.


Object_FileCollection

VoB Computersysteme GmbH
Object FileCollection

Description

Collection of the files in a folder.


DataTrack

Objec t Folder
DataTrack Propert y

Description

Reference to the datatrack that contains this Folder.

Syntax

object.DataTrack


DateCreate

Objec t Folder
Date Create Propert y

Description

Date of creation of a folder.

Syntax

object.DateCreate


Files

Objec t Folder
Files Propert y

Description

Returns a file collection with all the files in the current folder.

Syntax

object.Files


Object_Folder

VoB Computersysteme GmbH
Object Folder

Description

Object that stores information about a folder and gives access to the files and folders contained in that folder.


Parentfolder

Objec t Folder
Parent folder Propert y

Description

Returns the Parentfolder of the current folder.

Syntax

object.Parentfolder

Remarks

This property returns nil for the root folder.


Path

Objec t Folder
Path Propert y

Description

Returns the full path of the current folder.

Syntax

object.Path


Shortname

Objec t Folder
ShortName Propert y

Description

Returns the short name (DOS 8.3) of the current folder.

Syntax

object.Shortname


Size

Objec t Folder
Size Propert y

Description

Size of the current Folder.

Syntax

object.Size

Remarks

Size is the sum of the sizes of all files and subfolders (including all files).


SubFolder

Objec t Folder
SubFolder Propert y

Description

Returns a collection of all sub folders of the current folder.

Syntax

object.SubFolders


Add

Object Folders
Add Method e

Description

Adds an existing folder to the collection of folders.

Syntax

object.Add(Name)

Part | Description
object | An object expression that evaluates to a Folders object
Name | Source name of the Folder

Remarks

This method adds an existing folder (e.g. on the hard disk) including all files and folders to the Vitual CD. If you want to create a new Folder that does not already exist, use the new method instead.


Count

Objec t Folders
Count Propert y

Description

Returns the number of Folders maintained by the current folder collection.

Syntax

object.Count


Folders

VoB Computersysteme GmbH
Object Folders

Description

Collection that maintains Folder objects. The subfolders property of a folder is such a collection.


Item

Objec t Folders
Item Propert y

Description

Returns a fodler object.

Syntax

object.Item[Index]

Part | Description
object | An object expression that evaluates to a Folders object
Index | Index of the folder

Remarks


New

Object Folder
New Method e

Description

Creates a new folder and returns its Folder object.

Syntax

object.New

Remarks

You can set the properties of the newly created folder by setting the properties of the returned Folder object.


JukeBox

VoB Computersysteme GmbH
Object JukeBox

Description

Object that gives access to jukebox.


MoveTo

Object JukeBox
MoveTo Method e

Description

Moves a CD from one slot/drive to another slot/drive

Syntax

object.MoveTo(SrcSlot,DestSlot)


Add

Projects Object
Add Method

Description

Creates a new Virtual CD and returns an object of type VirtualCD.

Syntax

Result = object.Add(Name);

Part | Description
Result | An object expression that evaluates to a VirtualCD object
object | An object expression that evaluates to a Projects object
Name | Path of the new Virtual CD

Remarks

The parameter Name should contain the complete path of the file that will store the data for the new project.
The project is added to the list of all projects that are recognized by CD Wizard.

Example

VCD = Project.Add("C:\\My Documents\\Test.VCD");


Count

Projects Object
Count Propert y

Description

Count is the number of all Virtual CDs that are known to the application.

Syntax

object.Count

Remarks

Count includes only the Virtual CDs that can also be seen in the Wizard UI.
Other Virtual CDs must be added before you can access them.


Items

Projects Object
Item Property

Description

Item gives access to an individual project.

Syntax

object.Item(Number);

Part | Description
object | An object expression that evaluates to a Projects object
Number | Index of the Virtual CD

Remarks

Number must be in the range 0 to Projects.Count - 1.
If the Project cannot be found, the value of the property will be nil.


Projects

VoB Computersysteme GmbH
Object Projects

Description

Projects is the collection of all Virtual CDs that are also visible in the CD Wizard user interface.
You can also create new Virtual CDs.


Format

TrackInformation Objec t
Format Propert y

Description

Returns the mode of the current track.

Syntax

object.Format

Remarks


Length

TrackInformation Objec t
Length Propert y

Description

Returns the length of the current track.

Syntax

object.Length

Remarks

Length is returned in sectors.


Position

TrackInformation Objec t
Position Propert y

Description

Position in sectors of the track on the CD.

Syntax

object.Position


Postgap

TrackInformation Objec t
Postgap Propert y

Description

Postgap in sectors of the current track.

Syntax

object.PostGap


Pregap

TrackInformation Objec t
Pregap Propert y

Description

Postgap in sectors of the current track.

Syntax

object.PreGap


Status

TrackInformation Objec t
Status Propert y

Description

Returns the status of the current track on the CD.

Syntax

object.Status

Remarks


TrackInformation

VoB Computersysteme GmbH
Object TrackInformation

Description

Object that returns information about a track on the CD.


Object_VCDAudioTrack

VoB Computersysteme GmbH
Object VCDAudioTrack

Description

Object for setting and reading the properties of an Audiotrack in a virtual CD.


Postgap

VCDAudioTrack Objec t
Postgap Propert y

Description

Postgap of the audio track.

Syntax

object.PostGap

Remarks

This setting is only used for disc-at-once recording.


Pregap

VCDAudioTrack Objec t
Pregap Propert y

Description

Pregap of the audio track

Syntax

object.Pregap

Remarks

The pregap will only be set according to this property if the writer supports the setting of gaps.


SectorSize

VCDAudioTrack Objec t
SectorSize Propert y

Description

Returns the sectorsize for the track in bytes.

Syntax

object.SectorSize

Remarks

The sectorsize for audio tracks is 2352 by default.


TrackFlags

VCDAudioTrack Objec t
TrackFlags Propert y

Description

Use this property to set and read the track flags.

Syntax

object.TrackFlags

Remarks

TrackFlags includes the copy protection bit, pre-emphasis.


TrackLength

VCDAudioTrack Objec t
TrackLength Propert y

Description

Length of the current audio track in sectors.

Syntax

object.TrackLength


TrackNr

VCDAudioTrack Objec t
TrackNr Propert y

Description

Number of the current track in the Virtual CD.

Syntax

object.TrackNr

Remarks

The TrackNr property determines the ordering of the tracks on the CD.


TrackType

VCDAudioTrack Objec t
TrackType Propert y

Description

Returns the TrackType for the current track.

Syntax

object.TrackType

Remarks

The TrackType returns ttAudio for a VCDAudioTrack object.


AbstractFile

VCDDataTrack Objec t
AbstractFile Propert y

Description

Name of the file on the CD that contains the abstract.

Syntax

object.AbstractFile

Remarks

See ISO9660 documentation for information about this field. The program does not check if the file exists on the CD.


ApplicationName

VCDDataTrack Objec t
ApplicationName Propert y

Description

Name of the appliction that the data on the CD refers to.

Syntax

object.ApplicationName

Remarks

This field is set for information of the user of the CD only. It does not affect the way how the CD is written.


BibliographFile

VCDDataTrack Objec t
BibliographFile Propert y

Description

Name of the file on the CD that contains bibliographic information.

Syntax

object.BibliographFile

Remarks

See ISO9660 documentation for information about this field. The program does not check if the file exists on the CD.


BootImageFile

VCDDataTrack Objec t
BootImageFile Propert y

Description

Name of the bootimage file.

Syntax

object.BootImageFile

Remarks

If you want to create a bootable CD you can enter the name of a file that contains the boot image.


Charset

VCDDataTrack Objec t
Charset Propert y

Description

Set or read the valid charset for this track.

Syntax

object.CharSet


CopyrightFile

VCDDataTrack Objec t
CopyrightFile Propert y

Description

Name of the file on the CD that contains copyright information.

Syntax

object.CopyrightFile

Remarks

See ISO9660 documentation for information about this field. The program does not check if the file exists on the CD.


EmulationType

VCDDataTrack Objec t
EmulationType Propert y

Description

Set or read the emulation type for a bootable CD.

Syntax

object.EmulationType

Remarks

You can set the emulation type to floppy or hard disk.


EnableBoot

VCDDataTrack Objec t
EnableBoot Propert y

Description

Enables or disables the Boot CD feature.

Syntax

object.EnableBoot

Remarks

Use this value to determine if the CD will be created as a bootable CD.


Filesystems

VCDDataTrack Objec t
Filesystems Propert y

Description

Filesystems that will be written on the CD.

Syntax

object.FileSystems

Remarks

Possible filesystems are ISO9660, Joliet and UDF 1.50. CDs for Windows 95 and Windows NT contain ISO9660 with Joliet extensions.


ISRC

VCDDataTrack Objec t
ISRC Propert y

Description

Set or read the ISRC for the current data track.

Syntax

object.ISRC

Remarks

Not all writers support writing of ISRC codes.


Postgap

VCDDataTrack Objec t
Postgap Propert y

Description

Postgap of the data track.

Syntax

object.PostGap

Remarks

This setting is only used for disc-at-once recording.


Pregap

VCDDataTrack Objec t
Pregap Propert y

Description

Pregap of the data track

Syntax

object.Pregap

Remarks

The pregap will only be set according to this property if the writer supports the setting of gaps.


Publisher

VCDDataTrack Objec t
Publisher Propert y

Description

Set and read the publisher of the data track.

Syntax

object.Publisher

Remarks

This value is used only for informational purposes.


SectorSize

VCDDataTrack Objec t
SectorSize Propert y

Description

Returns or sets the sectorsize for the track in bytes.

Syntax

object.SectorSize

Remarks

The sectorsize for data tracks in mode 1 is 2048 by default.


SystemName

VCDDataTrack Objec t
SystemName Propert y

Description

Name of the operating system for that the data track will be written.

Syntax

object.SystemName

Remarks

This value is used only for informational purposes.


TrackFlags

VCDDataTrack Objec t
TrackFlags Propert y

Description

Use this property to set and read the track flags.

Syntax

object.TrackFlags

Remarks

TrackFlags includes the copy protection bit.


TrackLength

VCDDataTrack Objec t
TrackLength Propert y

Description

Length of the current data track in sectors.

Syntax

object.TrackLength


TrackNr

VCDDataTrack Objec t
TrackNr Propert y

Description

Number of the current track in the Virtual CD.

Syntax

object.TrackNr

Remarks

The TrackNr property determines the ordering of the tracks on the CD.


Tracktitle

VCDDataTrack Objec t
Tracktitle Propert y

Description

Title of the current data track.

Syntax

object.TrackTitle

Remarks


TrackType

VCDDataTrack Objec t
TrackType Propert y

Description

Returns the TrackType for the current track.

Syntax

object.TrackType

Remarks

The TrackType returns ttData for a VCDDataTrack object. This value is used to determine what kind of object is returned by the VirtualCD.Track property.


VCDDataTrack

VoB Computersysteme GmbH
Object VCDDataTrack

Description

Object for setting and reading the properties of a data track in a virtual CD.


VolumeSetName

VCDDataTrack Objec t
VolumeSetName Propert y

Description

Name of the volume set

Syntax

object.VolumeSetName

Remarks

This value is used only for informational purposes.


Postgap

VCDImageTrack Objec t
Postgap Propert y

Description

Postgap of the image track.

Syntax

object.PostGap

Remarks

This setting is only used for disc-at-once recording.


Pregap

VCDImageTrack Objec t
Pregap Propert y

Description

Pregap of the image track

Syntax

object.Pregap

Remarks

The pregap will only be set according to this property if the writer supports the setting of gaps.


SectorSize

VCDImageTrack Objec t
SectorSize Propert y

Description

Returns or sets the sectorsize for the track in bytes.

Syntax

object.SectorSize

Remarks

The sectorsize depends on the kind of image you are using. Image tracks can be mode 1, mode 2, audio etc..


TrackFlags

VCDImageTrack Objec t
TrackFlags Propert y

Description

Use this property to set and read the track flags.

Syntax

object.TrackFlags

Remarks

TrackFlags includes the copy protection bit, pre-emphasis.


TrackLength

VCDImageTrack Objec t
TrackLength Propert y

Description

Length of the current image track in sectors.

Syntax

object.TrackLength


TrackType

VCDImageTrack Objec t
TrackType Propert y

Description

Returns the TrackType for the current track.

Syntax

object.TrackType

Remarks

The TrackType returns ttImage for a VCDDataTrack object. This value is used to determine what kind of object is returned by the VirtualCD.Track property.


VCDImageTrack

VoB Computersysteme GmbH
Object VCDImageTrack

Description

Object for setting and reading the properties of a image track in a virtual CD.


VCDTrack

VoB Computersysteme GmbH
Object VCDTrack

Description

VCDTrack is the basic object for the three Track objects VCDImageTrack, VCDDataTrack and VCD AudioTrack.

Remarks

Do not use this object directly. VitualCD.Track returns an object of one of the three types VCDImageTrack, VCDDataTrack and VCD AudioTrack. VCDTrack defines the common properties.


AddTrack

VirtualCD Object
AddTrack Method e

Description

Adds a new track to the Virtual CD.

Syntax

object.AddTrack(TrackTypeConst)

Part | Description
object | An object expression that evaluates to a VirtualCD object
TrackTypeConst | Kind of track that is to be created.


CDText

VirtualCD Objec t
CDText Propert y

Description

Returns a CDText object that can be used to read and set the CD Text data for the Virtual CD

Syntax

object.CDText


Close

VirtualCD Object
Close Method e

Description

Closes the currently open Virtual CD

Syntax

object.Close


CreateCD

VirtualCD Object
CreateCD Method e

Description

Creates a CD with the settings of the current Virtual CD

Syntax

object.CreateCD

Remarks

This function writes the virtual CD without user interaction. If you want the user to select a device and device settings such as speed and write mode, use CreateCDDialog instead.


CreateCDDialog

VirtualCD Object
CreateCDDialog Method e

Description

Creates a CD with the settings of the current Virtual CD

Syntax

object.CreateCDDialog

Remarks

This function writes the virtual CD with user interaction. If you do not want the user change write settings, use CreateCD instead.


Open

VirtualCD Object
Open Method e

Description

Opens a Virtual CD.

Syntax

object.open

Remarks

You must open a Virtual CD before you can access the tracks of it. Open loads the file containing the information in memory and initializes the track objects.


Track

VirtualCD Objec t
Track Propert y

Description

Get the object for a track in the Virtual CD.

Syntax

object.Track[TrackNr]

Part | Description
object | An object expression that evaluates to a VirtualCD object
TrackNr | Number of the track.

Remarks

The property gives access to a descendant of a VCDTrack object.


TrackCount

VirtualCD Objec t
TrackCount Propert y

Description

Number of Tracks in a virtual CD

Syntax

object.TrackCount


VirtualCD

VoB Computersysteme GmbH
Object VirtualCD

Description

Object that gives access to a Virtual CD and its tracks.


IndexSupport

WriteSupportInfo Objec t
IndexSupport Propert y

Description

Indicates if the device allows writing of indices in audio tracks for the selected write mode

Syntax

object.IndexSupport


ISRCWriteSupport

WriteSupportInfo Objec t
ISRCWriteSupport Propert y

Description

Indicates if the device allows writing of ISRC codes for the selected write mode

Syntax

object.ISRCWriteSupport


SectorModeSupport

WriteSupportInfo Objec t
SectorModeSupport Propert y

Description

Returns the sector modes that can be used for the specific write mode.

Syntax

object.SectorModeSupport

Remarks


SimulationSupport

WriteSupportInfo Objec t
SimulationSupport Propert y

Description

Indicates if the device allows simulation of the write process for the selected write mode

Syntax

object.SimulationSupport


UPCWriteSupport

WriteSupportInfo Objec t
UPCWriteSupport Propert y

Description

Indicates if the device allows writing of UPC codes for the selected write mode

Syntax

object.UPCWriteSupport


WriteSupportInfo

VoB Computersysteme GmbH
Object WriteSupportInfo

Description

WriteSupportInfo contains information about the capabilities of a recording device for a specific write mode.


Wordbool

Objec t CDR OMDevice

Readonly Propert y

Description

Indicates if the device is a CD-rom or CD-writer .

Syntax

object.ReadOnly

Remarks

ReadOnly is true, if the device is not recognized as a CD-writer.


_NewEnum

Objec t Folders
_NewEnum Propert y

Description

Syntax

object._NewEnum

Remarks


Count

TrackInformation Objec t
Count Propert y

Description

Syntax

object.Count

Remarks


ReadTrack

TrackInformation Object
ReadTrack Method e

Description

Syntax

object.ReadTrack

Remarks


TrackNr

VirtualCD Objec t
TrackNr Propert y

Description

Syntax

object.TrackNr

Remarks