Startup

SENTINEL "Adding Vigilance to your Network Services"

Welcome to Sentinel

Sentinel uses advanced diagnostics methodologies to continuously monitor and test your servers, routers and other network devices. Network Operation centers can rarely monitor every service it provides. Troubleshooting intermittent failures using traditional log files are often ineffective or impossible. Sentinel attempts to solve both problems by testing the functionality of your network services using over twenty different protocols, logging the test results to a standard database and giving you several options for failure notification.

  • What's New

  • License Agreement

  • Using Online Registration

  • Using Online Feature Wish-List

  • Getting Started

  • Tips for Windows 95 Users

  • Appendix A: Protocol Reference

  • Appendix B: Winsock Reference

  • Appendix C: Credits

Copyright ©2000 Exponential Networks All Rights Reserved


Getting Started

How To Index:

  • How To: Set Up E-Mail Notification
  • How To: Set Up failure Notification Sensitivity
  • How To: Up Pager Notification
  • How To: Set Up Sound Notification


License Agreement

Sentinel License Agreement

END-USER LICENSE AGREEMENT FOR EXPONENTIAL NETWORKS SOFTWARE

IMPORTANT-READ CAREFULLY:
This Exponential Networks End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and Exponential Networks for the Exponential Networks software product identified above, which includes computer software and associated media and printed materials, and may include "online" or electronic documentation ("SOFTWARE PRODUCT" or "SOFTWARE"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this EULA. If you do not agree to the terms of this EULA, do not install, copy, or use the SOFTWARE PRODUCT.

SOFTWARE PRODUCT LICENSE
The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold.

1. GRANT OF LICENSE.
This EULA grants you the following non-exclusive rights:

* Software Product. You may install and use the enclosed SOFTWARE PRODUCT on a single computer to monitor host services.

2. COPYRIGHT. All rights, title, and copyrights in and to the SOFTWARE PRODUCT (including, but not limited to, any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the SOFTWARE PRODUCT) and any copies of the SOFTWARE PRODUCT are owned by Exponential Networks or its suppliers.

You may not copy the printed materials, if any, accompanying the SOFTWARE PRODUCT.

3. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.
* Limitations on Reverse-Engineering, Decompilation, and Disassembly. You may not reverse- engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.
* Rental. You may not rent or lease the SOFTWARE PRODUCT.
* Software Transfer. You may permanently transfer all of your rights under this EULA, provided you retain no copies, you transfer all of the SOFTWARE PRODUCT (including all component parts, the media and printed materials, any upgrades, this EULA, and, if applicable, the Certificate of Authenticity), and the recipient agrees to the terms of this EULA. If the SOFTWARE PRODUCT is an upgrade, any transfer must include all prior versions of the SOFTWARE PRODUCT.
* Termination. Without prejudice to any other rights, Exponential Networks may terminate this EULA if you fail to comply with the terms and conditions of this EULA. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

4. EXPORT RESTRICTIONS.
You agree that neither you nor your customers intend to or will, directly or indirectly, export or transmit (a) the SOFTWARE PRODUCT or related documentation and technical data, or (b) your Application as described in Section 1 of this EULA (or any part thereof), or process, or service that is the direct product of the SOFTWARE PRODUCT to any country to which such export or transmission is restricted by any applicable U.S. regulation or statute, without the prior written consent, if required, of the Bureau of Export Administration of the U.S. Department of Commerce, or such other governmental entity as may have jurisdiction over such export or transmission.

5. U.S. GOVERNMENT RESTRICTED RIGHTS.
The SOFTWARE PRODUCT and documentation are provided with RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights at 48 CFR 52.227-19, as applicable. Manufacturer is Exponential Networks 403 Research Drive, Manhattan, KS 66506.

MISCELLANEOUS
If you acquired this product in the United States, this EULA is
governed by the laws of the State of Kansas. If this product was acquired outside the United States, local law may apply.

Should you have any questions concerning this EULA, or if you desire to contact Exponential Networks for any reason, please write: Exponential Networks Customer Sales and Service 403 Research Drive Manhattan, Ks USA 66503.

NO WARRANTIES.
To the maximum extent permitted by applicable law, Exponential Networks expressly disclaims any warranty for the SOFTWARE PRODUCT. The SOFTWARE PRODUCT and any related documentation are provided "as is" without warranty of any kind, either express or implied, including, without limitation, the implied warranties of merchantability or fitness for a particular purpose. The entire risk arising out of use or performance of the SOFTWARE PRODUCT remains with you.

LIMITATION OF LIABILITY.
Exponential Networks entire liability and your exclusive remedy under this EULA shall not exceed five dollars (US$5.00).

NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
To the maximum extent permitted by applicable law, in no event shall Exponential Networks or its suppliers be liable for any damages whatsoever (including, without limitation, damages for loss of business profit, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of, or inability to use, this Exponential Networks product, even if Exponential Networks has been advised of the possibility of such damages. Because some states/jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitation may not apply to you.


How-To Set Up Sound Notification

How to: Set Up Sound Notification

Sentinel can send play a sound to notify you of service failures.

  • Requirements: Sound Card, speakers
  • Step 2: Enable Float Errors (required for ALL notification methods)
  • Step 3: Enable Notification (required for ALL notification methods)
  • Step 4: Enable Sound Notification
  • Step 5: Select your sound file
  • Step 7: Test

Related Topics

  • Getting Started


How-To Set Up Pager Notification

How to: Set Up Pager Notification

Sentinel can use a standard modem to call your pager service to notify you of service failures. You may program the message sent to the pager to fit your needs. Example: If your email server is not responding Sentinel can dial your pager using a modem. Sentinel will send you a numeric code of your choosing to identify the host service which is not responding.

  • Requirements: Standard internal or external modem, paging service and a pager.
  • Step 1: Enable float errors (required for ALL notification methods)
  • Step 2: Enable Notification (required for ALL notification methods)
  • Step 3: Enable Pager Notification
  • Step 4: Specify pager phone number and pager codes
  • Step 5: Test

Related Topics

  • Getting Started


How-To Set Up Failure Notification Sensitivity

How to: Set Up Failure Notification Sensitivity

Sentinel can alert you to service failures using onscreen, email, sound, or pager notification. You may program the message sent to the pager to fit your needs. Example: If your email server is not responding Sentinel can dial your pager using a modem. Sentinel will send you a numeric code of your choosing to identify the host service which is not responding

  • Requirements: Standard internal or external modem, paging service and a pager.
  • Step 1: Enable float errors (required for ALL notification methods)
  • Step 2: Enable Notification (required for ALL notification methods)
  • Step 3: Enable Pager Notification
  • Step 4: Specify pager phone number and pager codes
  • Step 5: Test

Related Topics

  • Getting Started


How-To Set Up Email Notification

How to: Set Up E-Mail Notification

Sentinel can send you email to notify you of service failures.

The email subject line contains:

  • Host name
  • IP address
  • Nickname
  • Up/Down Status

This text notification is perfect for use with text pagers.

The e-mail message contains:

  • Host name
  • IP address
  • Nickname
  • Number of poles
  • Number of errors
  • Percentage of errors
  • Last error message
  • Trace Route to the host: Trace Route is a diagnostic technique used to find out if the error is caused by the server or network equipment between the sentinel computer and the host being tested. If the fault is in the network equipment, then Trace Route will tell you where that fault lies.

  • Requirements: Access to a SMTP email server that will relay mail
  • Step 1: Configure Mail From Option
  • Step 2: Enable Float Errors (required for ALL notification methods)
  • Step 3: Enable Notification (required for ALL notification methods)
  • Step 4: Enable E-mail Notification
  • Step 5: Configure Mail To Option
  • Step 6: Configure SMTP server option
  • Step 7: Test

Related Topics

  • Getting Started


Appendix-A Protocols

Appendix A: Protocols

  • CHARACTER GENERATOR
  • DAYTIME
  • DNS
  • ECHO
  • ESMTP
  • FTP
  • HTTP
  • IMAP4
  • NNTP
  • NTP
  • POP3
  • QUOTE OF THE DAY
  • SMTP
  • SYSLOG
  • TELNET
  • TFTP
  • TIME
  • WHOIS
  • WHOIS++
  • RWHOIS

Related Topics

  • Internet Engineering Task Force (IETF)
  • The Internet Engineering Steering Group (IESG)
  • Internet Architecture Board (IAB)
  • Internet Society (ISOC)


Appendix-A CHARACTER GENERATOR

Appendix A: Character Generator Protocol

The Character Generator Protocol allows a client computer to connect to a Character Generator Service running on a host. When a connection is made the host spews forth a stream of ASCII in the order they appear in the ASCII character set. The process continues until the client computer disconnects. The Character Generator Protocol was used at a network troubleshooting tool to visual check a networks health by loading the network with traffic.

Taken from the RFC...

...A useful debugging and measurement tool is a character generator service. A character generator service simply sends data without regard to the input...

...A server listens for TCP connections on TCP port 19. Once a connection is established a stream of data is sent out the connection (and any data received is thrown away). This continues until the calling user terminates the connection...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0864
  • Appendix-A: Protocol Reference


Appendix-A DAYTIME

Appendix A: DAYTIME Protocol

The DAYTIME Protocol allows a client computer to query a DAYTIME server for the date and time the server thinks is correct.

Taken from the RFC...

...A useful debugging and measurement tool is a daytime service. A daytime service simply sends a the current date and time as a character string without regard to the input...

...One daytime service is defined as a connection based application on TCP. A server listens for TCP connections on TCP port 13. Once a connection is established the current date and time is sent out the connection as a ascii character string (and any data received is thrown away). The service closes the connection after sending the quote...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0867


Appendix-A DNS

Appendix A: DNS Protocol (Directory Name Service)

The DNS Protocol allows a client to query a DNS server for the IP address associated with a host name or query for the host name given an IP address. This process is called address resolution.

Taken from the RFC...

...The domain servers store information as a series of resource records (RRs), each of which contains a particular piece of information about a given domain name (which is usually, but not always, a host). The simplest way to think of a RR is as a typed pair of datum, a domain name matched with relevant data, and stored with some additional type information to help systems determine when the RR is relevant. For the purposes of message routing, the system stores RRs known as MX RRs. Each MX matches a domain name with two pieces of data, a preference value (an unsigned 16-bit integer), and the name of a host...

...In addition to mail information, the servers store certain other types of RR's which mailers may encounter or choose to use. These are: the canonical name (CNAME) RR, which simply states that the domain name queried for is actually an alias for another domain name, which is the proper, or canonical, name; and the Well Known Service (WKS) RR, which stores information about network services (such as SMTP) a given domain name supports...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0974


Appendix-A ECHO

Appendix A: ECHO (A.K.A. Protocol PING)

Also known as PING, ECHO is typically used to test communications between two hosts. An ICMP datagram is sent from Host A to Host B then back to Host A. The time required for the round trip is calculated and can be compared against previous tests. If successful, both hosts are on, and the communications equipment between the hosts is working.

Taken from the RFC...

...A very useful debugging and measurement tool is an echo service. An echo service simply sends back to the originating source any data it receives.

One echo service is defined as a connection based application on TCP. A server listens for TCP connections on TCP port 7. Once a connection is established any data received is sent back. This continues until the calling user terminates the connection...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC0862


Appendix-A ESMTP

Appendix A: ESMTP (Enhanced Simple Mail Transport Protocol)

ESMTP is an extension to the SMTP standard and is used to accept mail for delivery from workstations and deliver mail between mail servers. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the ESMTP server is running, server is accepting additional connections and is ready to receive email for delivery.

Taken from the RFC...

...Although SMTP is widely and robustly deployed, some parts of the Internet community might wish to extend the SMTP service. This memo defines a means whereby both an extended SMTP client and server may recognize each other as such and the server can inform the client as to the service extensions that it supports...

....The SMTP content is sent in the SMTP DATA protocol unit and has two parts: the headers and the body. The headers form a collection of field/value pairs structured according to RFC 822 [2], whilst the body, if structured, is defined according to MIME [3]. The content is textual in nature, expressed using the US ASCII repertoire (ANSI X3.4-1986). Although extensions (such as MIME) may relax this restriction for the content body, the content headers are always encoded using the US ASCII repertoire. The algorithm defined in [4] is used to represent header values outside the US ASCII repertoire, whilst still encoding them using the US ASCII repertoire...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC1869
  • Appendix-A: IMAP4
  • Appendix-A: SMTP
  • Appendix-A: POP3


Appendix-A FTP

Appendix A: FTP (File Transport Protocol)

FTP is used to transfer files to and from remote hosts. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the FTP server is running, communications to and from the server are operational. If a login is required, the FTP server is allowing additional connections and authentication is working.

Taken from the RFC...

...The objectives of FTP are 1) to promote sharing of files (computer programs and/or data), 2) to encourage indirect or implicit (via programs) use of remote computers, 3) to shield a user from variations in file storage systems among hosts, and 4) to transfer data reliably and efficiently. FTP, though usable directly by a user at a terminal, is designed mainly for use by programs...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC0959


Appendix-A HTTP

Appendix A: HTTP (Hyper Text Transport Protocol)

HTTP is used to transfer web pages, files and multimedia content between a workstation and a web server. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the web server is running, web server is serving pages, communications to and from the server are operational and if a login is required than authentication is working.

Taken from the RFC...
...The Hypertext Transfer Protocol (HTTP) is an application-level protocol for distributed, collaborative, hypermedia information systems. It is a generic, stateless, object-oriented protocol which can be used for many tasks, such as name servers and distributed object management systems, through extension of its request methods. A feature of HTTP is the typing and negotiation of data representation, allowing systems to be built independently of the data being transferred...

...HTTP has been in use by the World-Wide Web global information initiative since 1990. This specification defines the protocol referred to as "HTTP/1.1"...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC2068


Appendix-A IMAP4

Appendix A: IMAP4 (Internet Mail Access Protocol)

More capable than POP3, IMAP4 is also used by workstations to dynamically access mail from a mailbox server. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the IMAP4 server is running, server is accepting additional connections, the logged in user has a valid mailbox, and since login is required, than authentication is also working.

Taken from the RFC...
...The Internet Message Access Protocol, Version 4rev1 (IMAP4rev1) allows a client to access and manipulate electronic mail messages on a server. IMAP4rev1 permits manipulation of remote message folders, called "mailboxes", in a way that is functionally equivalent to local mailboxes. IMAP4rev1 also provides the capability for an offline client to resynchronize with the server (see also [IMAP-DISC])...

...IMAP4rev1 includes operations for creating, deleting, and renaming mailboxes; checking for new messages; permanently removing messages; setting and clearing flags; [RFC-822] and [MIME-IMB] parsing; searching; and selective fetching of message attributes, texts, and portions thereof. Messages in IMAP4rev1 are accessed by the use of numbers. These numbers are either message sequence numbers or unique identifiers...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC2060
  • Appendix-A: POP3
  • Appendix-A: SMTP
  • Appendix-A: ESMTP


Appendix-A NNTP

Appendix A: NNTP (Network News Transport Protocol)

NNTP specifies a protocol for the distribution, inquiry, retrieval, and posting of news articles. NNTP is designed so that news articles are stored in a central database allowing a subscriber to select only those items he wishes to read. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the NNTP server is running, server is accepting additional connections.
Taken from the RFC...
...The Internet community distributes news by the use of mailing lists. These are lists of subscriber's mailbox addresses and remailing sublists of all intended recipients. These mailing lists operate by remailing a copy of the information to be distributed to each subscriber on the mailing list. Such remailing is inefficient when a mailing list grows beyond a dozen or so people, since sending a separate copy to each of the subscribers occupies large quantities of network bandwidth, CPU resources, and significant amounts of disk storage at the destination host. There is also a significant problem in maintenance of the list itself: as subscribers move from one job to another; as new subscribers join and old ones leave; and as hosts come in and out of service...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC0977


Appendix-A NTP

Appendix A: NTP (Network Time Protocol)

NTP is an Internet standard protocol which enables client computers to maintain system time synchronization to the US Naval Observatory Master Clocks in Washington, DC and Colorado Springs, CO. NTP runs as a client program on a computer. It sends periodic time requests to one or more servers, obtaining server time stamps and using them to adjust the client's clock. If the test is successful, the NTP server is running, server is accepting additional connections and is reporting the time.

Taken from the RFC...
...This protocol provides a site-independent, machine readable date and time. The Time service sends back to the originating source the time in seconds since midnight on January first 1900...

...One motivation arises from the fact that not all systems have a date/time clock, and all are subject to occasional human or machine error. The use of time-servers makes it possible to quickly confirm or correct a system's idea of the time, by making a brief poll of several independent sites on the network...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC868


Appendix-A POP3

Appendix A: POP3 (Post Office Protocol)

POP3 is a simple method for workstations to dynamically access mail from a mailbox server. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the POP3 server is running, server is accepting additional connections, the logged in user has a valid mailbox, and since login is required, authentication is also working.

Taken from the RFC...
...On certain types of smaller nodes in the Internet it is often impractical to maintain a message transport system (MTS). For example, a workstation may not have sufficient resources (cycles, disk space) in order to permit a SMTP server and associated local mail delivery system to be kept resident and continuously running. Similarly, it may be expensive (or impossible) to keep a personal computer interconnected to an IP-style network for long amounts of time (the node is lacking the resource known as "connectivity")...

...Despite this, it is often very useful to be able to manage mail on these smaller nodes, and they often support a user agent (UA) to aid the tasks of mail handling. To solve this problem, a node which can support an MTS entity offers a maildrop service to these less endowed nodes. The Post Office Protocol - Version 3 (POP3) is intended to permit a workstation to dynamically access a maildrop on a server host in a useful fashion. Usually, this means that the POP3 is used to allow a workstation to retrieve mail that the server is holding for it...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC1081
  • Appendix-A: IMAP4
  • Appendix-A: SMTP
  • Appendix-A: ESMTP


Appendix-A QUOTE OF THE DAY

Appendix A: QUOTE OF THE DAY Protocol

May unix hosts us the QUOTE OF THE DAY Protocol to display a unique quote to users when they login to a unix host. The QUOTE OF THE DAY Protocol allows a client computer to query the host for a quote.

Taken from the RFC...
...A useful debugging and measurement tool is a quote of the day service. A quote of the day service simply sends a short message without regard to the input...

...One quote of the day service is defined as a connection based application on TCP. A server listens for TCP connections on TCP port 17. Once a connection is established a short message is sent out the connection (and any data received is thrown away). The service closes the connection after sending the quote...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0865


Appendix-A RWHOIS

Appendix A: RWHOIS Protocol (Reference WHOIS)

The RWHOIS protocol allows a client to query a RWHOIS host for various information from a WHOIS database. Internet Domain Registrars use WHOIS databases to record the information on .com, .net, etc. domains. RWHOIS is unique from other WHOIS protocols because the RWHOIS host can refer the client to another WHOIS, WHOIS+, or RWHOIS host if it does not have the information being queried.

Taken from the RFC...
...This memo describes Version 1.5 of the client/server interaction of RWhois. RWhois provides a distributed system for the discovery, retrieval, and maintenance of directory information. This system is primarily hierarchical by design. It allows for the deterministic routing of a query based on hierarchical tags, referring the user closer to the maintainer of the information. While RWhois can be considered a generic directory services protocol, it distinguishes itself from other protocols by providing an integrated, hierarchical architecture and query routing mechanism...

...Early in the development of the ARPANET, the SRI-NIC established a centralized Whois database that provided host and network information about the systems connected to the network and the electronic mail (email) addresses of the users on those systems [RFC 954]. The ARPANET experiment evolved into a global network, the Internet, with countless people and hundreds of thousands of end systems. The sheer size and effort needed to maintain a centralized database necessitates an alternate, decentralized approach to storing and retrieving this information...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_2167


Appendix-A SMTP

Appendix A: SMTP (Simple Mail Transport Protocol)

SMTP is used to accept mail for delivery from workstations and deliver mail between mail servers. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the SMTP server is running, server is accepting additional connections and is ready to receive email for delivery.

Taken from the RFC...
...The objective of Simple Mail Transfer Protocol (SMTP) is to transfer mail reliably and efficiently.

SMTP is independent of the particular transmission subsystem and requires only a reliable ordered data stream channel. Appendices A, B, C, and D describe the use of SMTP with various transport services. A Glossary provides the definitions of terms as used in this document.

An important feature of SMTP is its capability to relay mail across transport service environments. A transport service provides an interprocess communication environment (IPCE). An IPCE may cover one network, several networks, or a subset of a network. It is important to realize that transport systems (or IPCEs) are not one-to-one with networks. A process can communicate directly with another process through any mutually known IPCE. Mail is an application or use of interprocess communication. Mail can be communicated between processes in different IPCEs by relaying through a process connected to two (or more) IPCEs. More specifically, mail can be relayed between hosts on different transport systems by a host on both transport systems...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC821
  • Appendix-A: IMAP4
  • Appendix-A: POP3
  • Appendix-A: ESMTP


Appendix-A SYSLOG

Appendix A: SYSLOG (SYSLOG Protocol)

SYSLOG is a de-facto standard for logging system events. However, the protocol of this event logging system has not been formally documented by the IETF (Internet Engineering Task Force). SYSLOG is used by Unix systems, routers, firewalls, and network appliances to notify network administrators of network related events. SYSLOG messages contain a priority code, a service code, and a text message. Priority codes range from the most important to the least, starting at 0 (emergency) to 7 (informational). The service code identifies the system/subsystem the message is from such as UUCP, KERNEL, authentication. etc... Host monitor will capture SYSLOG messages and capture them to to database. Host Monitor will keep up with large message bursts from many hosts.

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: SYSLOG IETF Working Group


Appendix-A TELNET

Appendix A: TELNET Protocol

TELNET client have been used as a mainframe terminal emulation programs allowing a client to connect to a TELNET host.

Taken from the RFC...
...The purpose of the TELNET Protocol is to provide a fairly general, bi-directional, eight-bit byte oriented communications facility. Its primary goal is to allow a standard method of interfacing terminal devices and terminal-oriented processes to each other. It is envisioned that the protocol may also be used for terminal-terminal communication ("linking") and process-process communication (distributed computation)...

...When a TELNET connection is first established, each end is assumed to originate and terminate at a "Network Virtual Terminal", or NVT. An NVT is an imaginary device which provides a standard, network-wide, intermediate representation of a canonical terminal. This eliminates the need for "server" and "user" hosts to keep information about the characteristics of each other's terminals and terminal handling conventions. All hosts, both user and server, map their local device characteristics and conventions so as to appear to be dealing with an NVT over the network, and each can assume a similar mapping by the other party. The NVT is intended to strike a balance between being overly restricted (not providing hosts a rich enough vocabulary for mapping into their local character sets), and being overly inclusive (penalizing users with modest terminals)...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0854


Appendix-A TIME

Appendix A: TIME Protocol

TIME is an Internet standard protocol which enables client computers to query the current time and date of a host. If the test is successful, the TIME server is running, server is accepting additional connections and is reporting the time.

Taken from the RFC...
...This protocol provides a site-independent, machine readable date and time. The Time service sends back to the originating source the time in seconds since midnight on January first 1900...

...One motivation arises from the fact that not all systems have a date/time clock, and all are subject to occasional human or machine error. The use of time-servers makes it possible to quickly confirm or correct a system's idea of the time, by making a brief poll of several independent sites on the network...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_868


Appendix-A TFTP

Appendix A: TFTP (Trivial File Transport Protocol)

TFTP is used to transfer files to and from remote hosts. The time required to establish a connection and complete the test is calculated and can be compared against previous tests. If the test is successful, the TFTP server is running, communications to and from the server are operational.

Taken from the RFC...
...TFTP is a very simple protocol used to transfer files. It is from this that its name comes, Trivial File Transfer Protocol or TFTP. Each nonterminal packet is acknowledged separately. This document describes the protocol and its types of packets. The document also explains the reasons behind some of the design decisions...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_1350


Appendix-A WHOIS

Appendix A: WHOIS Protocol

The WHOIS protocol allows a client to query a WHOIS host for various information from a WHOIS database. Internet Domain Registrars use WHOIS databases to record the information on .com, .net, etc. domains.

Taken from the RFC...
...The NICNAME/WHOIS Server is a TCP transaction based query/response server, running on the SRI-NIC machine (26.0.0.73 or 10.0.0.51), that provides netwide directory service to internet users. It is one of a series of internet name services maintained by the DDN Network Information Center (NIC) at SRI International on behalf of the Defense Communications Agency (DCA). The server is accessible across the Internet from user programs running on local hosts, and it delivers the full name, U.S. mailing address, telephone number, and network mailbox for DDN users who are registered in the NIC database...

...This server, together with the corresponding WHOIS Database can also deliver online look-up of individuals or their online mailboxes, network organizations, DDN nodes and associated hosts, and TAC telephone numbers. The service is designed to be user-friendly and the information is delivered in human-readable format. DCA strongly encourages network hosts to provide their users with access to this network service...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_0954


Appendix-A WHOIS++

Appendix A: WHOIS++ Protocol

The WHOIS++ protocol allows a client to query a WHOIS++ host for various information from a WHOIS database. Internet Domain Registrars use WHOIS databases to record the information on .com, .net, etc. domains.

Taken from the RFC...
...This document describes WHOIS++, an extension to the trivial WHOIS service described in RFC 954 to permit WHOIS-like servers to make available more structured information to the Internet. We describe an extension to the simple WHOIS data model and query protocol and a companion extensible, distributed indexing service. A number of options have also been added such as the use of multiple languages and character sets, more advanced search expressions, structured data and a number of other useful features. An optional authentication mechanism for protecting all or part of the associated WHOIS++ information database from unauthorized access is also described...

...The basic architecture of WHOIS++ allows distributed maintenance of the directory contents and the use of the WHOIS++ indexing service for locating additional WHOIS++ servers. Although a general overview of this service is included for completeness, the indexing extensions are described in a separate paper...

Related Topics

  • Internet Engineering Task Force (IETF)
  • IETF: RFC_1835


Appendix-B Winsock Resources

Appendix B: WINSOCK

The Windows Sockets specification is an API ("Application Programming Interface") for network programming in the Microsoft Windows family of operating systems. Windows Sockets is directly based on the Unix "Socket" API. Windows Sockets provides functions compatible with Unix Sockets for portability but also contains extension specific to Windows Sockets.

You can get a copy of the WINSOCK API specification here.

Related Topics

  • The WinSock Programmers FAQ
  • The WinSock channel
  • WinSock Development Information: www.sockets.com
  • Stardust Technologies WinSock Resource Center
  • Promiscuous mode stuff.
  • Internet Assigned Numbers Authority
  • Internet Engineering Task Force (IETF)
  • The Internet Engineering Steering Group (IESG)
  • Internet Architecture Board (IAB)
  • Internet Society (ISOC)


Appendix-C Credits

Appendix B: Credits

About the Author

Will Baldwin has been involved in the Internet community since 1989. He was first employed in the Engineering Computer Center working with Harris mainframes for the College of Engineering, Kansas State University. After leaving the College of Engineering, Will served as the Information Systems Analyst for the College of Architecture at KSU. In 1994, he began serving as a Systems Engineer and Software Engineering Coordinator for K-State Research and Extension. In 1998, while continuing to work for KSU, he founded Exponential Networks, a company specializing in software engineering and network technologies.

Distinguished Contributors:

  • LaVerne Bitsie-Baldwin
  • Jennifer Bitsie
  • Kathryn Burton
  • Larry Havenstein
  • Richard Wear
  • Rachael Springer
  • Charles Gould


Overview of Failure Notification

Overview: Failure Notification

Sentinel can alert you to service failures using onscreen, email, sound, or pager notification.

  • On Screen: Each fault encountered will turn the colored dot indicator more red. Each success will turn the colored dot more green. If a thread is always a shade of yellow then the fault is intermittent. Any host which reaches the eleventh failure threshold will be sorted to the top of the list.
  • E-Mail: Send administrators email to notify of service failures with TRACERT diagnostic information enclosed.
  • Sound: Play a sound file of your choosing to alert staff of service failures.
  • Pager: Dial your network administrator's pager service to alert them to service failures.

  • Step 1: Enable float errors (required for ALL notification methods)
  • Step 2: Enable Notification (required for ALL notification methods)

Related Topics

  • Getting Started

Copyright ©2000 Exponential Networks All Rights Reserved

service