00-Intro

About MultiExtractor
Forward

MultiExtractor is an application that allows you to extract/recover multimedia files. MultiExtractor is different from other extractors because:

  • It extracts image/audio/video files (BMP, JPG, GIF, PNG, PCX, TGA, ICO, CUR, TIFF, EMF, WMF, XM, MOD, WAV, OGG, MP3, MID, S3M, AVI, MPG, DAT, ASF, MOV, SWF, BIK, SMK)
  • It has a conversion support (PNG [ New ], BMP, JPG, ICO, Vista icons)
  • It can extract files stored in Microsoft® Office files, Portable Document Format, Databases, raw or binary files (like *.doc, *.docx, *.ppt, *.pptx, *.xls, *.xlsx, *.pdf, *.db, *.raw, *.bin, *.hex...)
  • It can also extract multimedia (stored as resources or binaries ) from PE files (*.exe, *.scr, *.dll, *.ocx, *.ax...)
  • It can unpack archives (ZIP, RAR, CAB+InstallShield Cabinets, JAR, CHM) and extract data from them
  • It has a dynamic explorer (all data is mapped)
  • It has a very strong filtering options (like icon properties, image properties, size of files)
  • It can extract encrypted/packed resources of executable file
  • It uses drag&drop interface and clipboard.

Please send any bug report, suggestion, question and comment to the author at following address: support@multiextractor.com.

Copyright © 2005-2007 Maciej Drobinski
http://www.multiextractor.com
Forward


01-Features

MultiExtractor Features
  • Extraction to BMP, JPG, GIF, PNG, PCX, TGA, ICO, CUR, TIFF, EMF, WMF, XM, MOD, WAV, OGG, MP3, MID, S3M, AVI, MPG, DAT, ASF, MOV, SWF, BIK [ New ], SMK [ New ]
  • MP3:
    • MPEG 1.0, 2.0, 2.5
    • Layers I-III
    • CBR (constant bitrate)
    • VBR (variable bitrate)
    • TAG header
    • ID3 header
  • MULTIMEDIA EXPLORER (allows to play/view/copy image/audio/video files)
    • Conversion support (PNG [ New ], BMP, JPG, ICO, Vista ICO)
    • Drag&Drop (importing and exporting of resource through drag and drop interface)
    • Clipboard
    • Resource importing (patching of resources)
    • Resource direct edit (you can modify the resource by defined application - editor of music, graphic...)
    • Fast displaying of images
    • Two modes of stretching images (smooth/fast)
    • Transparent mode
    • JPEG preview displaying (faster)
    • Icon-shading (supported 32BPP icons)
    • Mapping mode (saves a lot of time for extract data)
    • Multi-selection model (allows to save many selected files)
    • Rename resource option
    • Dynamic extraction (map files)
  • Extraction of resources from MSI installers [ New ]
  • Extraction of icons from ICL files (icon libraries) [ New ]
  • Detection and unpack of archives (possible extraction of multimedia from ZIP, RAR, CHM, CAB+InstallShiled Cabinets, JAR archives) [ New ]
  • Detection of packed exe/scr/dll files (UPX, ASPack, ASProtect, FSG and many others)
  • Memory-Scan engine (allows to dump crypted/packed executable/dll data)
  • Optimized scan algorithm: NCBS (No Compare Byte Scan)
  • Directories extraction
  • Quick extraction from CONTEXT MENU
  • Language support
  • GUI skin engine (allows to design interface of MultiExtractor)
  • Extraction of more than one format at only one scan session (SCAN AT ONCE )
  • Checking integrity of formats
  • Fixing size of files with garbage data
  • PE-Scan engine (allows to extract icons and bitmaps stored in exe-files)
  • Supported PE32+ files (64 bit processors)
  • Extended naming of dumped files (retrieves original file name or creates file name with additional informations)
  • Logging of extraction process
  • FILTERING of data to extract:
    • Input file extensions
    • Icon properties (size and depth sieve)
    • Image properties (width, height, depth)
    • Input and output size of files
  • Save/Load settings option
  • Auto-complete of output path (directory with source data)
  • Pause extraction option
  • Skip file option (you can manually skip extraction of the big file)
  • Extraction status (count of extracted files, summary sizes, ratios)
  • Multithread model (for optimize work beetwen system and application)
  • ASM-Extract kernel (the kernel was written in win32 assembler)
  • Optimized usage of processor (MMX instructions)
  • Anti circular extraction
  • User-friendly interface
  • Compatibility with operating systems Windows 95/98/ME/NT/2K/XP/2003/Vista


02-Requirements

MultiExtractor System Requirements
  • Microsoft Windows® 95/98/ME/NT/2000/XP/Vista
  • Pentium 133 MHz or faster processor (recommended: Pentium 250 MHz)
  • 32MB or more RAM (recommended: 64MB)
  • A hard disk with at least 5 MB free space (recommended: 50 MB)
  • Microsoft HTML Help Update, Rich Edit Update v3.0


03-License

License

Your use, distribution, or installation of a software product indicates your acceptance of this license agreement. If you do not agree to any of the terms, then do not install, distribute or use the product.

A demo version may be only used for evaluation purposes. Purchasing personal license authorizes you to install one copy of the full version of the software on a single machine. Site license authorize you to install copies of the full version on machines in your company/organization.

This software, and all accompanying files, data, and materials, are distributed “as is” and with no warranties of any kind, whether express or implied, to the maximum extent permitted by applicable law.

You may not rent, lease, modify, translate, reverse-engineer, decompile or disassemble the software or create derivative works based on it without prior explicit permission. All rights of any kind in the software product which are not expressly granted in this license agreement are entirely and exclusively reserved to and by Maciej Drobinski.

Copyright © 2005-2007 Maciej Drobinski


04-MainWindow

Main Window

BUTTON | DESCRIPTION
 | Open file to extract (any file can be opened).
 | Open dir to extract (include main directory).
 | Exctract file/dir (displays Mode Window).
 | Extraction options (displays Options Window).
 | Application Help (displays MultiExtractor help).
 | Menu (displays Menu).
 | About application (displays about window).

Main Menu

MENU ITEM | DESCRIPTION
Recent Files | List of recent files (you can open file)
Recent Dirs | List of recent dirs (you can open dir)
Skin | Interface change
Language | List of supported languages
Help | Opens MultiExtractor HelpFile
Register | Registration informations


12-OptionsWindow

Options Window

On left side of the Options Window is a Topic-Tree. Options of selected topic are viewed beside the Topic-Tree. You can select one of the following topic:

  • General
    • Formats
  • Filtering
    • Image properties
    • Icon properties
    • Size of files

General

OPTION | DESCRIPTION
Detect and unpack archives (zip, rar, chm, cab, jar) | Use this option to search multimedia in archives. This option detects ZIP, RAR, CHM, CAB, JAR archives (files with any extension).
Detect packed *.exe, *.scr, *.dll files (auto unpack) | Auto-Unpack of *.exe, *.scr, *.dll files packed by UPX, ASProtect, FSG, ASPack and many others exepackers/exeprotectors.
Timeout for process scan | This option enables timeout for scan process (executable loaded into memory). You can set value of timeout in milliseconds (deafult is 2500).
Include unstored files | Include clean files (like photo.jpg, top.bmp, sound.wav).
Create log file | Enables logging of the extraction.
Extended naming of dumped files | Retrieves original file name or creates name with additonal informations.
Associations | Edit Associations of MultiExtractor Resource Explorer. for example: MP3=C:\Program Files\coolpro2\coolpro2.exe
Config | Edit configuration file of MultiExtractor (settings.ini)

Formats

In this topic you're selecting the formats which you want to be extracted.

Filtering

This section allows to add input file extensions and it's useful for directories extraction. MultiExtractor scans all files with specified extensions during extraction (or skips these files while "Exclude mode" is checked). If list ("Filter type") is empty, then application will scan all files.

Image Properties

Sometimes it's necessary to extract images with specified properties. MultiExtractor allows to extract images with specified width, height and depth. The width and height can be equal/not equal/above/below to specified value. Depth of extracted image can be 1/4/8/16/24/32 bits per pixel. If depth of found image is else, then image will be also extracted. For sign "=" or "!" (not equal) you can set the tolerance value (in percents) to find/exclude images with width/height near to defined values.

Icon Properties

MultiExtractor allows to extract icons (and cursors) with defined size (width and height). Filtering of icons is based on sieve. You can select/deselect size of icon (16x16, 24x24, 32x32, 48x48...). Yo can also choose a depth (quality) of icon (1 BPP, 4BPP, 8BPP, 16BPP, 24 BPP, 32BPP). Grouped icons (storage of icons) are also filtered/dumped!

Size of Files

This section is useful while you need to extract files with defined size. Input size means size of source file. Output size means size of extracted output file. You can set the size in bytes (B), kilobytes (kB) and megabytes (MB). As like in image properties you can set the tolerance value to extract/exclude files with size near to defined value.


13-ModeWindow

Mode Window

BUTTON/OPTION | DESCRIPTION
Explore mode | Mode that allows you to choose and extract resources. It's faster than standard mode because results are not saved to disk. This mode uses default temporary directory to list data that allows to search and dump resources.
Standard mode | It's typical extract mode. After start you must select a destination folder (Extract Window).
Scan temporary resources | Only for *.EXE and *.SCR files. After launch of application, MultiExtractor scans tempoary directory. You must abort extraction to stop scan.
Recurse subfolders | Recurses subfolders in selected dir.
Force unpack for *.exe, *.scr, dll files | Use this option if detection of packed files fails. With this option MultiExtractor launches all executable/screensaver files (with timeout) and loads all dll's into memory for unpack/decrypt packed/protected files.
Overwrite all files | All files with same name will be overwritten.
Launch MS Explorer after | Enable to explore results after extraction.


14-ExtractWindow

Extract Window

BUTTON | DESCRIPTION
Browse | Allows to browse for destination folder.
Extract | Starts extraction.
Cancel | Cancels extraction (close this window).


15-StatusWindow

Extraction Status Window

BUTTON | DESCRIPTION
Pause+Resume+ Save as... | Pauses or resumes the extraction process. After extraction this button have "Save as..." caption and allows to save dynamic map files (*.mxm). After double click on this file you will see exactly same results like after scanning.
Abort | Aborts the extraction process.
Skip File | Skips extraction of the current file (available only in directory extraction).
View Log | Views the log of extraction process.

The MultiExtractor Status Window displays some useful informations about extraction process and receives commands from user. The window have got 3 primary elements:

  • Explore Tree
  • Details Table
  • Status Bar

Explore Tree

This tree allows to explore content of extracted data (virtual folders with extracted formats). Control Panel node directs to panel of stats and command buttons (above picture).

Details Table

COLUMN | DESCRIPTION
Format | Type of format.
Extracted | Number of extracted (found) files.
Ratio | Ratio of extracted files count.
Summary Size | Summary size of extracted files.
Ratio | Ratio of summary size.
Hit | Number of files saved to disk (only in Explore Mode).

Status Bar

This bar displays the status of currnet action, disk free space, count of dumped files ('ALL'), current state of file operation (LED).

LED | DESCRIPTION
 | NULL.
 | Reading file.
 | Writting to file.
 | Pause.
 | Skipping data.
 | Unpacking archive.


16-ExploringData

Exploring Data

POPUP MENU OPTION | SHORTCUT | ALTRERNATIVE KEYS | DESCRIPTION
Play | F5 | ENTER | Plays audio/video file.
Open | ALT+O | F6 | Open file via shell (file must be associated).
Extract to... | ALT+E | NONE | Allows to save file(s) to dedicated folder.
Import from... | ALT+I | NONE | Modifes resource by import another...
Reverse changes | ALT+R | NONE | Restores original resource data (backup)
Copy | CTRL+C | NONE | Copies data into clipboard.
Rename | F2 | NONE | Allows to rename resource.
Info | F1 | NONE | Displays resource informations (offset, size).
Full mode | CTRL+F | F11 | -
View as | NONE | NONE | Submenu that allows to choose conversion mode (ICO, BMP, JPG). "ICO (Vista)" mode is available only for PNG formats! For example ypu can convert BMP into ICO or ICO into BMP format...
Maximum displayed size | NONE | NONE | Use this submenu to set maximum possible displayed size of icon/cursor.
Maximum BPP | NONE | NONE | Use this submenu to set maximum possible BPP of displayed icon/cursor.
Transparent mode | F9 | NONE | Displays images transparently.
Background color... | F10 | NONE | Use this option to set background color of images. Transparent mode must be activated!
Smooth resize | F8 | NONE | Better quality of stretched images (it's slower).
Numbering | ALT+N | NONE | Set name of elements through numbering...
Select | SPACE | SHIFT+UP/DOWN/ LEFT/RIGHT | Selects resource.
Select All | CTRL+A | NONE | Selects all resources in folder.
Unselect All | CTRL+Z | NONE | Unselects all resources in folder.
Swap Selection | * | NONE | Swaps selection.


21-DemoVersion

Demo Version

Program MultiExtractor is distributed as DEMO version, that means it allows to use only part of its functions. All functions are available after buying full version.

Limitations of DEMO version:

  • Extraction to GIF, ICO, CUR, XM, ASF formats (21 formats are disabled)
  • Disabled SAVING of EXEPACKED and ARCHIVED RESOURCES
  • Disabled patching of all resources (importing)
  • Limited standard mode of extraction (files with zero size)
  • Watermarks of limited resources (text: 'DEMO VERSION')
  • 30 days trial period.


22-Order

How To Order

Why you should buy MultiExtractor?

  • Users that bought full version of MultiExtractor are entitled to receive free updates
  • The price is very small (in PRO version for one format you pay only 2$).

MultiExtractor is available in many types. Sale is made through ShareIt! using secure connection.

PACKAGE | Pro | Basic | Gfx | Audio | Video
FORMATS | ALL | GIF, ICO, CUR, XM, ASF, BMP, JPG, PNG, MID, WAV, MP3, AVI, SWF | GIF, ICO, CUR, XM, ASF, BMP, JPG, PNG, PCX, TGA,TIFF, EMF, WMF | GIF, ICO, CUR, XM, ASF, MOD, WAV, OGG, MP3, MID, S3M | GIF, ICO, CUR, XM, ASF, AVI, MPG, DAT, MOV, SWF, BIK, SMK
PRICE (Personal/Site) | 49$ / 69$ | 35$ / 55$ | 25$ / 45$ | 15$ / 35$ | 15$ / 35$

Plus Licenses (GIF, ICO, CUR, XM, ASF+...):

  • Personal (10$): +JPG,+PNG, +MP3.
  • Site (30$): +JPG,+PNG, +MP3.

Note: All features of application are available in Pro/Gfx/Audio/Video/Plus version. Not specified formats are locked! Exploring of locked formats is possible but dumping or opening is disabled (like in demo version).

In case of any doubt feel free to contact me.

License Agreement

Your use, distribution, or installation of a software product indicates your acceptance of this license agreement. If you do not agree to any of the terms, then do not install, distribute or use the product.

A demo version may be only used for evaluation purposes. Purchasing personal license authorizes you to install one copy of the full version of the software on a single machine. Site license authorize you to install copies of the full version on machines in your company/organization.

This software, and all accompanying files, data, and materials, are distributed “as is” and with no warranties of any kind, whether express or implied, to the maximum extent permitted by applicable law.

You may not rent, lease, modify, translate, reverse-engineer, decompile or disassemble the software or create derivative works based on it without prior explicit permission. All rights of any kind in the software product which are not expressly granted in this license agreement are entirely and exclusively reserved to and by Maciej Drobinski.

Copyright © 2005-2007 Maciej Drobinski


23-Updates

MultiExtractor Updates
Back

User that bought full version of MultiExtractor are entitled to receive free updates of current version, that means, that user that bought version 2.xx will be receiving new version marked 2.11, 2.97, but when new version marked with number 3.xx comes out in order to receive updates users has to buy new version of this program.

Back


Credits

Bartosz Wojcik - beta testing, support and program protection (http://www.pelock.com). Author of MultiExtractor skins: "mxWood", "mxModern", "mxVistaBasic" and "mxMediaPlayer".

Lukasz Cybula - my right hand and good friend. "Co ja bym bez ciebie zrobil?" :)

Jan Mejstrik - czech translation

Cristi Cuturicu - JPEG documentation

Fredrik Huss - XM documentation

Pawel Sulkowski - thanks for his website (http://www.softhard.com.pl/sulek)


F.A.Q

F.A.Q (Frequently Asked Questions)

Q: Does MultiExtractor converts all supported images into BMP/JPG/ICO/PNG formats?
A: Yes! For example you can convert ICO into BMP or BMP into ICO or ICO into JPG or JPG into ICO.

Q: Does MultiExtractor supports full transparency (alpha blending) in Icon to PNG and PNG to Icon conversion?
A: Yes! All you need is to set "View as" option in Explore Window to PNG (conversion from ICO to PNG) or ICO (conversion from PNG to ICO) and extract these elements into specifed location. Registered version is required.

Q: Does MultiExtractor extracts data from EXE files packed by UPX, AsPack or other packers?
A: Absolutely yes, but you must SWITCH ON detection of exepacked files (General Options) or process forced exe unpack (unpack of exe if detection fails - Mode Window). Registered version is required.

Q: Does MultiExtractor extracts data from DLL files packed by UPX or other packers?
A: Yes, see point before. Registered version is required.

Q: Does MultiExtractor extracts any data from SWF files?
A: MultiExtractor extracts high compressed SWF resources (JPG photos and MP3 music). Important: You must uncheck SWF format in options!

Q: How to extract Extra Large Icons (Vista) into standard icon format?
A: If icons are stored in exe or dll files, you must extract these icons (save them to disk). After that you should check PNG format, uncheck ICO format and process extraction on directory with these icons. Now you can convert PNG images (layers of the icons) into standard icons (in popup menu of MultiExtractor explorer set "View as" option to "ICO").