Planificateur de tâches

Vous pouvez utiliser le Planificateur de tâches pour programmer l'exécution de commandes, de programmes ou de scripts à des heures spécifiées :

  • Avant d'utiliser le Planificateur de tâches, consultez Liste.
  • Pour obtenir de l'aide sur des tâches spécifiques, consultez Procédures.
  • Pour des informations d'ordre général, consultez Concepts.
  • Pour obtenir des instructions sur la résolution des problèmes, consultez Dépannage.


Liste du Planificateur de tâches

Liste

Le tableau suivant répertorie les actions que vous exécutez le plus souvent à l'aide du Planificateur de tâches. Pour une liste complète des instructions du Planificateur de tâches, consultez Procédures.

Étape | Référence
Vous devez ajouter une tâche avant de pouvoir en planifier l'exécution. | Planifier une nouvelle tâche
Une fois les tâches planifiées créées, vous pouvez modifier le programme, la planification ou les caractéristiques d'une tâche particulière. | Modifier une tâche planifiée
Vous pouvez supprimer totalement des tâches planifiées qui ne sont plus nécessaires. | Supprimer une tâche planifiée
Dans le cas où une tâche planifiée démarre pendant que vous utilisez votre ordinateur, vous pouvez arrêter la tâche et la redémarrer ultérieurement. | Arrêter l'exécution d'une tâche planifiée
Vous pouvez arrêter ou suspendre temporairement l'exécution de toutes les tâches planifiées, puis la reprendre ultérieurement. | Arrêter temporairement toutes les tâches planifiées


Procédures

  • Planifier des tâches
  • Gérer le Planificateur de tâches


Planification des tâches

Pour planifier des tâches
  • Démarrer le Planificateur de tâches
  • Planifier une nouvelle tâche
  • Modifier une tâche planifiée
  • Supprimer une tâche planifiée
  • Arrêter l'exécution d'une tâche planifiée
  • Exécuter immédiatement une tâche


Démarrage du Planificateur de tâches

Pour démarrer le Planificateur de tâches

  • Vous pouvez démarrer le Planificateur de tâches en double-cliquant sur Poste de travail, puis sur Tâches planifiées.
  • Double-cliquez sur Tâches planifiées, puis sur Création d'une tâche programmée pour ouvrir l'Assistant Tâche planifiée qui vous guidera dans les différentes étapes de planification d'une tâche.


Planification d'une nouvelle tâche

Pour planifier une nouvelle tâche
  1. Démarrez le Planificateur de tâches.
  2. Double-cliquez sur Ajouter une tâche programmée.
  3. Suivez les instructions de l'Assistant Création d'une tâche planifiée.

Remarques

  • Si vous voulez définir des paramètres avancés pour la tâche, activez la case à cocher Ouvrir les propriétés avancées de la tâche du dernier écran de l'Assistant.
  • Si vous voulez que la nouvelle tâche s'exécute de façon répétée à chaque exécution, activez la case à cocher Ouvrir les propriétés avancées de la tâche du dernier écran de l'Assistant, cliquez sur l'onglet Calendrier, puis sur Avancées.
  • Si le programme de tâche nécessite l'ajout de paramètres, activez la case à cocher Ouvrir les propriétés avancées de la tâche du dernier écran de l'Assistant, cliquez sur l'onglet Tâche, puis tapez-les dans la zone Exécuter à la suite du chemin d'accès de la tâche.
  • Assurez-vous que la date et l'heure système de votre ordinateur sont correctes. Le Planificateur de tâches prend en compte ces informations pour savoir à quel moment exécuter les tâches planifiées. Pour vérifier ou régler la date et l'heure, double-cliquez sur l'horloge dans la barre des tâches.


Modification d'une tâche planifiée

Pour modifier une tâche planifiée
  1. Démarrez le Planificateur de tâches.
  2. Cliquez avec le bouton droit sur la tâche que vous souhaitez modifier, puis cliquez sur Propriétés.
  3. Effectuez ensuite une ou plusieurs des actions suivantes :
    • Pour modifier le programme exécuté, dans la zone Exécuter, tapez le chemin d'accès du nouveau programme.
    • Pour modifier la planification de la tâche, cliquez sur l'onglet Calendrier.
    • Pour personnaliser les paramètres de la tâche, cliquez sur l'onglet Paramètres.

Remarques

  • Si vous modifiez le compte d'utilisateur ou le programme exécuté, vous devez fournir le mot de passe du compte d'utilisateur.
  • Si le programme de tâche nécessite des options de ligne de commande, tapez-les dans la zone Exécuter à la suite du chemin d'accès de la tâche.
  • Si le chemin d'accès du programme de la tâche comprend des espaces, placez le chemin d'accès de la tâche dans sa totalité entre guillemets doubles ("").
  • Assurez-vous que la date et l'heure système de votre ordinateur sont correctes. Le Planificateur de tâches prend en compte ces informations pour savoir à quel moment exécuter les tâches planifiées. Pour vérifier ou régler la date et l'heure, double-cliquez sur l'horloge dans la barre des tâches.


Suppression d'une tâche planifiée

Pour supprimer une tâche planifiée
  1. Démarrez le Planificateur de tâches.
  2. Cliquez avec le bouton droit sur la tâche que vous voulez supprimer, puis cliquez sur Supprimer.

Remarques

  • La suppression d'une tâche planifiée ne supprime que la planification correspondante de la liste des planifications. Le fichier de programme n'est pas supprimé du disque dur.
  • Vous pouvez également supprimer une tâche planifiée en appuyant sur SUPPR.


Arrêt d'une tâche planifiée en cours d'exécution

Pour arrêter une tâche planifiée en cours d'exécution
  1. Démarrez le Planificateur de tâches.
  2. Cliquez avec le bouton droit sur la tâche que vous voulez arrêter, puis cliquez sur Terminer la tâche.

Remarques

  • Si une tâche planifiée lance l'exécution d'un autre programme, cette commande n'arrête que la tâche planifiée initiale et non la seconde tâche.
  • Pour relancer l'exécution d'une tâche, cliquez avec le bouton droit sur la tâche, puis cliquez sur Exécuter.


Exécution immédiate d'une tâche

Pour exécuter immédiatement une tâche
  1. Démarrez le Planificateur de tâches.
  2. Cliquez avec le bouton droit sur la tâche que vous voulez démarrer, puis cliquez sur Exécuter.

Remarques

  • Vous pouvez arrêter la tâche en cliquant dans le menu Fichier sur Terminer la tâche.
  • Si une tâche ne s'est pas exécutée alors qu'elle aurait dû, vérifiez le journal en cliquant sur Afficher le journal dans le menu Avancé.


Gestion du Planificateur de tâches

Pour gérer le Planificateur de tâches
  • Afficher le journal des précédentes tâches planifiées
  • Afficher les tâches planifiées sur des ordinateurs distants
  • Arrêter temporairement toutes les tâches planifiées
  • Suspendre le Planificateur de tâches
  • Définir le compte de service AT


Affichage du journal des précédentes tâches planifiées

Pour afficher le journal des précédentes tâches planifiées
  1. Démarrez le Planificateur de tâches.
  2. Dans le menu Avancé, cliquez sur Afficher le journal.


Affichage des tâches planifiées sur des ordinateurs distants

Pour afficher les tâches planifiées sur des ordinateurs distants
  1. Sur le Bureau, double-cliquez sur Voisinage réseau.
  2. Double-cliquez sur l'ordinateur dont vous voulez afficher les tâches planifiées.
  3. Cliquez sur Tâches planifiées.

Remarques

  • Vous ne pouvez afficher les tâches sur un ordinateur distant exécutant Windows que si vous êtes un administrateur de cet ordinateur distant.
  • Vous ne pouvez modifier les tâches sur un ordinateur distant exécutant Windows que si le logiciel de registre distant est installé sur cet ordinateur et que ce dernier dispose d'un partage x$, où x représente le disque dur sur lequel se trouve le dossier Tâches planifiées. L'ordinateur exécutant Windows doit également répertorier de manière spécifique votre compte d'utilisateur comme disposant de l'accès registre distant. Vous pouvez spécifier quels utilisateurs disposent de l'accès registre distant pour un ordinateur exécutant Windows en cliquant sur Mots de passe dans le Panneau de configuration.


Arrêt temporaire de toutes les tâches planifiées

Pour arrêter temporairement toutes les tâches planifiées
  1. Démarrez le Planificateur de tâches.

  2. Dans le menu Avancé, cliquez sur Suspendre le Planificateur de tâches.

Remarques

  • Cette commande est utile si vous exécutez un autre programme (un jeu, par exemple) ou si vous installez un logiciel et que vous ne voulez pas que des tâches planifiées s'exécutent en même temps.
  • Les tâches qui auraient dû s'exécuter pendant la suspension du Planificateur de tâches ne sont pas exécutées avant leur prochaine date planifiée d'exécution.
  • Pour reprendre les planifications pour toutes les tâches, cliquez dans le menu Avancé sur Continuer le planificateur de tâches.


Suspension du Planificateur de tâches

Pour suspendre le Planificateur de tâches
  1. Démarrez le Planificateur de tâches.
  2. Dans le menu Avancé, cliquez sur Suspendre le Planificateur de tâches.

Remarque

  • Lorsque le Planificateur de tâches est désactivé, vos tâches planifiées ne sont pas exécutées et le Planificateur de tâches ne démarre pas automatiquement au prochain démarrage de Windows.


Définition du compte de service AT

Pour définir le compte de service AT
  1. Démarrez le Planificateur de tâches.
  2. Dans le menu Avancé, cliquez sur Compte de service AT.
  3. Cliquez sur Ce compte, puis tapez le compte d'utilisateur qui permet d'exécuter les tâches planifiées à l'aide de la commande at.
  4. Dans Mot de passe et Confirmer le mot de passe, tapez le mot de passe correct du compte.

Remarques

  • Le service AT n'est disponible que sous Windows NT.
  • Vous pouvez facultativement cliquer sur Compte du système. Dans ce cas, le Planificateur de tâches exécute les tâches de commande at en utilisant le compte LocalSystem, qui nécessite des droits d'administration.

  • Le compte d'utilisateur que vous spécifiez doit avoir les permissions appropriées pour exécuter n'importe quelle tâche que vous planifiez en utilisant la commande at. Par exemple, si vous planifiez des programmes qui ne peuvent être exécutés que par des administrateurs, le compte que vous indiquez doit être celui d'un administrateur.


Concepts du Planificateur de tâches

Concepts

Cette section fournit des informations d'ordre général concernant le Planificateur de tâches :

  • Introduction au Planificateur de tâches
  • Utilisation du Planificateur de tâches
  • Planificateur de tâches et commande AT
  • Planificateur de tâches et sécurité
  • Dépannage


Introduction au Planificateur de tâches

Le Planificateur de tâches est un outil qui vous permet de planifier l'exécution de tâches (par exemple, le Défragmenteur de disque) au moment qui vous convient le mieux. Le Planificateur de tâches démarre chaque fois que vous démarrez Windows et s'exécute en arrière-plan.

Avec le Planificateur de tâches, vous pouvez :

  • Planifier une tâche à exécuter chaque jour, chaque semaine, chaque mois ou à certaines moments (par exemple, au démarrage du système).
  • Modifier la planification d'une tâche.
  • Arrêter une tâche planifiée.
  • Personnaliser le mode d'exécution d'une tâche à une heure prévue.


Utilisation du Planificateur de tâches

Pour utiliser le Planificateur de tâches

Le système d'exploitation Windows installe automatiquement le Planificateur de tâches. Pour utiliser le service de planification, double-cliquez sur le dossier Tâches planifiées de Poste de travail.

Vous pouvez ajouter des tâches en double-cliquant sur Création d'une tâche programmée, qui démarre l'Assistant Tâche planifiée. Vous pouvez ajouter des tâches en faisant glisser des scripts, des programmes ou des documents à partir de l'Explorateur Windows ou du bureau vers la fenêtre Tâches planifiées.

Vous pouvez également utiliser le Planificateur de tâches pour modifier, supprimer, suspendre ou arrêter l'exécution des tâches que vous avez planifiées, pour afficher un journal des précédentes tâches planifiées ou pour afficher les tâches planifiées sur un ordinateur distant.

Pour des instructions détaillées concernant l'utilisation du Planificateur de tâches, consultez Procédures.

Utilisations optimales du Planificateur de tâches

Dans le système d'exploitation Windows, vous pouvez utiliser le Planificateur de tâches pour programmer l'exécution de n'importe quelle application. Pour tirer le meilleur parti du Planificateur de tâches, veillez à ce que la date et l'heure système de votre ordinateur soient exactes avant d'ajouter une tâche.


Utilisation du Planificateur de tâches et de la commande AT

Planificateur de tâches et commande AT

Outre le Planificateur de tâches, vous pouvez utiliser la commande AT pour exécuter les tâches automatiquement.

Le Planificateur de tâches est différent de la commande AT, mais les deux fonctionnent ensemble. Lorsque vous planifiez une tâche à l'aide de la commande AT, elle apparaît dans la liste des tâches de la fenêtre du Planificateur de tâches.

Vous pouvez utiliser le Planificateur de tâches pour modifier les propriétés d'une tâche planifiée à l'aide de la commande AT. Dans ce cas, toutefois, vous devez continuer d'utiliser le Planificateur de tâches pour accéder à cette tâche. Vous ne pouvez plus y accéder à l'aide de la commande AT.

Pour spécifier le compte d'utilisateur qui permet d'exécuter les tâches planifiées par la commande AT, cliquez dans Poste de travail sur Tâches planifiées, puis dans le menu Avancé sur Compte de service AT.

Remarque

  • Le service AT n'est disponible que sous Windows NT.


Sécurité du Planificateur de tâches

Planificateur de tâches et sécurité

Dans le Planificateur de tâches, vous pouvez définir une sécurité en affectant un nom d'utilisateur et un mot de passe à une tâche particulière. Une fois le nom d'utilisateur et le mot de passe définis, la tâche ne peut pas être annulée ou supprimée par un autre utilisateur.

Remarques

  • Cette fonctionnalité de sécurité n'est disponible que sous Windows NT.
  • Vous devez saisir un nom d'utilisateur dans l'Assistant Tâche planifiée avant de poursuivre la planification d'une tâche. Le mot de passe n'est pas obligatoire.
  • Vous pouvez modifier un mot de passe ou en définir un nouveau en activant la case à cocher Ouvrir les propriétés avancées de cette tâche quand je cliquerai sur Terminer dans le dernier écran de l'Assistant.


Dépannage du Planificateur de tâches

Pour dépanner le Planificateur de tâches

Si une tâche que vous avez planifiée ne s'exécute pas au moment prévu, cliquez avec le bouton droit sur cette tâche, puis cliquez sur Propriétés. Sous l'onglet Tâche, vérifiez que la case à cocher Activé est activée. Sous l'onglet Calendrier, vérifiez que la planification est correctement définie.

Si un programme ne s'exécute pas correctement, il peut être nécessaire d'ajouter des options de ligne de commande. Pour en savoir plus sur un programme particulier et sur ses options de ligne de commande, procédez d'une des manières suivantes :

  • Consultez l'aide en ligne du programme, si celle-ci est disponible.

  • Tapez la commande suivante à l'invite de commandes : (programme étant le nom du programme)

    • programme /?


Composant Windows NT non installé

Ce programme n'a pas pu démarrer.

Les causes possibles sont :

    • Le programme a été supprimé par l'administrateur système.
    • L'administrateur système a modifié la stratégie associée au fichier.
    • Le programme n'est pas installé sur votre ordinateur.
    • Il a été effacé accidentellement.
    • Le fichier est endommagé.

Si votre ordinateur est contrôlé par un administrateur système, vous devez contacter ce dernier pour savoir pourquoi vous ne pouvez pas exécuter le programme.