NGWS SDK Developers Guide

This section contains everything you need to know to create, configure, deploy, and debug an NGWS application.

This section contains:

Section | Description
Getting Started with the NGWS Frameworks and Runtime | For those new to NGWS, this is the ideal place to start.
Inside the NGWS Frameworks and Runtime | Contains an overview of the architecture of the NGWS runtime, and the services provided by the NGWS frameworks.
Building NGWS Applications | Describes how you create NGWS applications.
Debugging, Optimizing, and Profiling Your NGWS Application | Contains information on debugging and optimizing your NGWS application.
Configuring and Deploying Your NGWS Application | Includes details about configuring and deploying NGWS applications.

© 2000 Microsoft Corporation. All rights reserved.


NGWS SDK Documentation

This is preliminary documentation and subject to change.
To comment on this topic, please send us email at ngwssdk@microsoft.com. Thanks!

NGWS SDK Frameworks Reference

This section contains the complete reference to the NGWS frameworks.


NGWS SDK Samples and Tutorials

This section contains:

Section | Description
Samples | Contains information about the samples, QuickStarts, and How-Tos provided with the NGWS SDK.
Developing Applications using the NGWS SDK: An Introduction | Demonstrates how to create NGWS applications and components using the tools included with the NGWS SDK.


NGWS SDK Tools and Debugger

This section contains information about the tools and GUI debugger that are included with the NGWS SDK.

This section contains:

Section | Description
Tools | Contains detailed information about the tools that are shipped with the NGWS SDK.
NGWS SDK Debugger | Describes the GUI debugger.


NGWS SDK Compiler and Language Reference

The NGWS SDK includes four compilers that support or were built for the NGWS runtime. This section contains reference documentation for those compilers, including language references, compiler options, and compiler error/warning descriptions.

  • C#
  • Visual Basic
  • JScript
  • Managed Extensions to C++


NGWS SDK Developer Specifications

The PDC Tech Preview release of the NGWS SDK documentation is a work-in-progress. The specifications included in this section are provided to cover those areas for which documentation has not yet been written. Here you will find detailed architectural and functional specifications about the NGWS frameworks and runtime.


Topic Not Found

No matching topic was found. The link may be out of date, incorrectly authored, or the topic may not be available in this release.

You may be able to find the topic by using the index or search tab instead.


Copyright

NGWS SDK Documentation

This is a preliminary document and may be changed substantially prior to final commercial release. This document is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document, including URL and other Internet Web site references, is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. Unless otherwise noted, the example companies, organizations, products, people and events depicted herein are fictitious and no association with any real company, organization, product, person or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

Unpublished work. © 1999 - 2000 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, Active Directory, ActiveX, Authenticode, FrontPage, IntelliSense, JScript , Outlook, Visual Basic, Visual Basic Scripting Edition (VBScript), Visual C++, Visual Studio, and Win32 are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Welcome to the NGWS SDK

Welcome to the documentation for the NGWS SDK! The documentation contains the following sections:

Section | Description
Developers Guide Describes how to create, deploy, configure, and debug NGWS applications.

This section includes:

  • Getting Started with the NGWS Frameworks and Runtime
  • Inside the NGWS Frameworks and Runtime
  • Building NGWS Applications
  • Configuring and Deploying NGWS Applications
Frameworks Reference | Provides a complete reference for the entire NGWS frameworks.
Samples and Tutorials Contains a guide to the samples and tutorials available with the NGWS SDK.

This section includes:

  • Developing with NGWS: An Introduction
Tools | Provides detailed help for each of the tools that ship with the NGWS SDK.
Compiler and Language Reference | Contains compiler references – including command-line options and warning/error codes – and language references for the four compilers that are included in the NGWS SDK: C#, Visual Basic, JScript, and Managed Extensions to C++.
Developer Specifications | Includes detailed architectural and functional specifications for the NGWS frameworks and runtime.