Nó superior do Agendador de tarefas

Agendador de tarefas

Você pode usar o Agendador de tarefas para agendar comandos, programas ou scripts para serem executados em horas especificadas.

  • Antes de usar o Agendador de tarefas, consulte Lista de verificação.
  • Para obter Ajuda em tarefas específicas, consulte Como.
  • Para obter informações básicas genéricas, consulte Conceitos.
  • Para obter instruções para a solução de problemas, consulte Solucionando problemas.


Lista de verificação do Agendador de tarefas

Lista de verificação

A tabela a seguir lista as ações que você executa com mais freqüência com o Agendador de tarefas. Para obter uma lista completa de instruções do Agendador de tarefas, consulte Como.

Etapa | Referência
Antes de poder agendar uma tarefa para ser executada, você deve adicionar a tarefa. | Agendar uma nova tarefa
Depois que as tarefas agendadas são criadas, você pode modificar o programa, a agenda ou as especificidades de uma determinada tarefa. | Modificar uma tarefa agendada
Você pode remover completamente tarefas agendadas que não sejam mais necessárias. | Remover uma tarefa agendada
No caso de uma tarefa agendada começar enquanto você estiver usando o computador, você pode interromper a tarefa e reinicia-la mais tarde. | Parar uma tarefa agendada que está sendo executada
Você pode interromper temporariamente ou fazer uma pausa na execução de todas as tarefas agendas e depois reiniciá-las mais tarde. | Interromper temporariamente todas as tarefas agendadas


Como fazer...

Como...

  • Agendar tarefas
  • Gerenciar o Agendador de tarefas


Agendar tarefas
  • Iniciar o Agendador de tarefas
  • Agendar uma nova tarefa
  • Modificar uma tarefa agendada
  • Remover uma tarefa agendada
  • Interromper uma tarefa agendada que está sendo executada
  • Executar uma tarefa imediatamente


Iniciar o Agendador de tarefas

Para iniciar o Agendador de tarefas

  • Você pode iniciar o Agendador de tarefas clicando duas vezes em Meu computador e depois clicando duas vezes em Tarefas agendadas.
  • Clique duas vezes em Tarefas agendadas e depois clique duas vezes em Adicionar tarefa agendada para abrir o Assistente para adicionar tarefas agendadas, que o conduz no agendamento de uma tarefa.


Agendar uma nova tarefa

Para agendar uma nova tarefa
  1. Inicie o Agendador de tarefas.
  2. Clique duas vezes em Adicionar tarefa agendada.
  3. Siga as instruções do Assistente para Adicionar tarefa agendada.

Observações

  • Se você desejar definir configurações avançadas para a tarefa, marque a caixa de seleção Abrir as propriedades avançadas desta tarefa ao clicar em Concluir na tela final do assistente.
  • Para que uma nova tarefa seja executada repetidamente, marque a caixa de seleção Abrir as propriedades avançadas desta tarefa ao clicar em Concluir na tela final do assistente, e depois clique na guia Agendamento e clique em Avançado.
  • Se o programa-tarefa exigir parâmetros, marque a caixa de seleção Abrir as propriedades avançadas desta tarefa ao clicar em Concluir na tela final do assistente e depois clique na guia Tarefa e digite os parâmetros em Executar, depois do caminho da tarefa.
  • Certifique-se de que a data e a hora do sistema do seu computador estejam exatas. O Agendador de tarefas se baseia nessas informações para saber quando executar as tarefas agendadas. Para verificar ou alterar a data e a hora, clique duas vezes na barra de tarefas.


Modificar uma tarefa agendada

Para modificar uma tarefa agendada
  1. Inicie o Agendador de tarefas.
  2. Clique com o botão direito do mouse a tarefa que você deseja modificar e depois clique em Propriedades.
  3. Faça um ou mais dos seguintes itens:
    • Para alterar o programa sendo executado, em Executar, digite o caminho do novo programa.
    • Para alterar a agenda da tarefa, clique na guia Agendamento.
    • Para personalizar as configurações da tarefa, clique na guia Configurações.

Observações

  • Se você alterar a conta de usuário ou o programa que está sendo executado, você deve fornecer a senha da conta de usuário.
  • Se o programa-tarefa exigir opções da linha de comando, digite-as em Executar, depois do caminho da tarefa.
  • Se o caminho para o programa-tarefa incluir espaços, coloque todo o caminho da tarefa entre aspas duplas ("").
  • Certifique-se que de a data e a hora do sistema estejam exatas, pois o Agendador de tarefas se baseia nessas informações para executar as tarefas agendadas. Para verificar ou alterar essas informações, clique duas vezes no indicador de hora da barra de tarefas.


Remover uma tarefa agendada

Para remover uma tarefa agendada
  1. Inicie o Agendador de tarefas.
  2. Clique com o botão direito do mouse na tarefa que você deseja remover e depois clique em Excluir.

Observações

  • Remover uma tarefa gendada só remove a agenda da lista de agendas. O arquivo do programa não é removido do disco rígido.
  • Você também pode remover uma tarefa agendada pressionando a tecla DELETE.


Parar uma tarefa agendada que está sendo executada

Para parar uma tarefa agendada que está sendo executada
  1. Inicie o Agendador de tarefas.
  2. Clique com o botão direito do mouse na tarefa que você deseja parar e depois clique em Finalizar a tarefa.

Observações

  • Se uma tarefa agendada inicia outro programa, esse comando pára apenas a tarefa agendada original, não a segunda tarefa.
  • Para reiniciar uma tarefa que foi interrompida, clique com o botão direito do mouse na tarefa e depois clique em Executar.


Executar uma tarefa imediatamente

Para executar uma tarefa imediatamente
  1. Inicie o Agendador de tarefas.
  2. Clique com o botão direito do mouse na tarefa que você deseja iniciar e depois clique em Executar.

Observações

  • Você pode parar a tarefa clicando em Finalizar a tarefa no menu Arquivo.
  • Se uma tarefa devesse ter sido executada e não foi, no menu Avançado, clique em Exibir log para examinar o log de tarefas.


Gerenciar o Agendador de tarefas
  • Visualizar um log de antigas tarefas agendadas
  • Visualizar tarefas agendas em computadores remotos
  • Interromper todas as tarefas temporariamente
  • Fazer uma pausa no Agendador de tarefas
  • Definir a conta de serviço At


Visualizar um log de antigas tarefas agendadas

Para visualizar um log das antigas tarefas agendadas
  1. Inicie o Agendador de tarefas.
  2. No menu Avançado, clique em Exibir log.


Visualizando tarefas agendadas em computadores remotos

Para visualizar tarefas agendadas em computadores remotos
  1. Na Área de trabalho, clique duas vezes em Ambiente de rede.
  2. Clique duas vezes no computador em que deseja visualizar as tarefas agendadas.
  3. Clique em Tarefas agendadas.

Observações

  • Você só pode visualizar tarefas em um computador remoto que esteja executando o Windows se você for um administrador em um computador remoto.
  • Você só pode editar tarefas em um computador remoto que esteja executando o Windows se o computador remoto tiver um software de Registro remoto instalado e compartilhar o compartilhamento x$, onde x for o disco rígido no qual a pasta Tarefas agendadas reside. O computador que está executando o Windows também deve listar especificamente a sua conta de usuário como tendo acesso ao Registro remoto. Você pode especificar que usuários têm acesso ao Registro remoto em um computador executando o Windows clicando em Senhas no Painel de controle.


Interromper temporariamente todas as tarefas agendadas

Para interromper temporariamente todas as tarefas agendadas
  1. Inicie o Agendador de tarefas.

  2. No menu Avançado, clique em Pausar o agendador de tarefas.

Observações

  • Esse comando é til se você estiver executando outro programa (como um jogo,) ou instalando software, e não desejar que as tarefas agendadas sejam executadas ao mesmo tempo.
  • As tarefas que seriam executadas enquanto o Agendador de tarefas está numa pausa não são executadas até a próxima vez agendada.
  • Para retomar as agendas de todas as tarefas, no menu Avançado, clique em Recomeçar o agendador de tarefas.


Pausar o Agendador de tarefas

Para pausar o Agendador de tarefas
  1. Inicie o Agendador de tarefas.
  2. No menu Avançado, clique em Parar de usar o agendador de tarefas.

Observação

  • Quando você desliga o Agendador de tarefas, as suas tarefas agendadas não são executadas e o Agendador de tarefas não é iniciado automaticamente a próxima vez que você inicia o Windows.


Definir a conta de serviço AT

Para definir a conta de serviço AT
  1. Inicie o Agendador de tarefas.
  2. No menu Avançado, clique em Conta de serviço AT.
  3. Clique em Esta conta e depois digite a conta de usuário que executará as tarefas agendadas usando o comando at.
  4. Em Senha e Confirmar senha, digite a senha correta da conta.

Observações

  • O serviço AT só está disponível no Windows NT.
  • Opcionalmente, você pode clicar em Conta do sistema. Se fizer isso, o Agendador de tarefas executa o comando at, que requer direitos administrativos.

  • A conta de usuário que você especificar deve ter as permissões adequadas para executar qualquer tarefa que você agendar usando o comando at. Por exemplo, se você agendar programas que só possam ser executados por administradores, a conta de usuário que você especificar deve ser uma conta de administrador.


Conceitos do Agendador de tarefas

Conceitos

Esta seção oferece informações básicas genéricas sobre o Agendador de tarefas:

  • Introdução ao Agendador de tarefas
  • Usando o Agendador de tarefas
  • O Agendador de tarefas e o comando at
  • O Agendador de tarefas e a segurança
  • Solucionando problemas


Introdução ao Agendador de tarefas

Usando o Agendador de tarefas, você pode agendar tarefas (como o Desfragmentador de discos) para serem executadas em uma hora mais conveniente para você. O Agendador de tarefas é iniciado sempre que você inicia o Windows, e é executado em segundo plano.

Com o Agendador de tarefas você pode:

  • Agendar uma tarefa para ser executada diariamente, semanalmente, mensalmente ou em determinadas horas (como, na inicialização do sistema).
  • Alterar a agenda de uma tarefa.
  • Parar a tarefa agendada.
  • Personalizar como uma tarefa é executada na hora agendada.


Usando o Agendador de tarefas

O sistema operacional Windows instala automaticamente o Agendador de tarefas. Para usar o serviço de agendamento, clique duas vezes na pasta Agendador de tarefas em Meu computador.

Você pode adicionar tarefas clicando duas vezes em Adicionar tarefa agendada, o que inicia o Assistente de tarefa agendada. Você pode adicionar todas as tarefas arrastando scripts, programas ou documentos do Windows Explorer ou da Área de trabalho para a janela Tarefas agendadas.

Você também pode usar o Agendador de tarefas para modificar, excluir, pausar ou parar as tarefas que você agendou, para visualizar um log de antigas tarefas agendadas ou para visualizar tarefas que são agendadas em um computador remoto.

Para obter instruções detalhadas sobre o uso do Agendador de tarefas, consulte Como.

As melhores práticas para o Agendador de tarefas

No sistema operacional Windows, você pode usar o Agendador de tarefas para agendar a execução de qualquer tarefa. Para tirar o melhor proveito do Agendador de tarefas, certifique-se que de a data e a hora do sistema estejam exatas antes de adicionar uma tarefa.


Usar o Agendador de tarefas e o comando at

O Agendador de tarefas e o comando at

Além de usar o Agendador de tarefas, você pode usar o comando at para executar tarefas automaticamente.

O Agendador de tarefas não é o mesmo que o comando at, mas os dois funcionam juntos. Quando você agenda uma tarefa usando o comando at, ela aparece na lista de tarefas na janela do Agendador de tarefas.

Você pode usar o Agendador de tarefas para modificar propriedades de uma tarefa que foi agendada com o comando at. No entanto, se o fizer, você deve continuar a usar o Agendador de tarefas para acessar a tarefa. Você não pode mais acessá-la usando o comando at.

Para especificar a conta de usuário que executará as tarefas agendadas com o comando at, em Meu computador, clique em Tarefas agendadas e, no menu Avançado, clique em Conta de serviço AT.

Observação

  • O serviço AT só está disponível no Windows NT.


Segurança do Agendador de tarefas

O Agendador de tarefas e a segurança

No Agendador de tarefas, você pode configurar a segurança atribuindo um nome de usuário e uma senha a uma determinada tarefa. Depois de definido o nome de usuário e uma senha, a tarefa não pode ser canceladas nem excluída por outro usuário.

Observações

  • Esse recurso de segurança só está disponível no Windows NT.
  • Você deve inserir um nome de usuário no assistente de tarefa agendada para poder continuar a agendar uma tarefa. Senhas não são exigidas.
  • Você pode alterar ou definir uma nova senha marcando a caixa de seleção Abrir as propriedades avançadas desta tarefa ao clicar em Concluir na tela final do assistente.


Solucionando problemas do Agendador de tarefas

Se uma tarefa agendadas não for executada como você espera, clique com o botão direito do mouse na tarefa e depois clique em Propriedades. Na guia Tarefa, verifique se a caixa de seleção Ativada está marcada. Na guia Agendamento, verifique se a agenda está definida corretamente.

Se um programa-tarefa não for executado corretamente, pode ser necessário adicionar opções de linha de comando. Para descobrir mais sobre um determinado programa e suas opções de linha de comando, experimente um dos seguintes:

  • Se estiver disponível, visualize a Ajuda do programa.

  • No prompt de comando, digite o seguinte: (onde programa é o nome do programa)

    • programa /?


Componente do Windows NT não instalado

Esse programa não pôde ser iniciado.

Possíveis motivos são:

    • Ele foi removido por um administrador de sistema.
    • O administrador de sistema alterou as diretivas associadas ao arquivo.
    • O programa não está instalado no seu computador.
    • Ele foi excluído acidentalmente.
    • O arquivo está corrupto.

Se um administrador de sistema controla a sua máquina, você deve entrar em contado com ele para descobrir por que você não consegue iniciar o programa.