Introduction

STARR PC & Internet Monitor

iOpus STARR TM ist die universelle, vielfach ausgezeichnete PC Überwachungssoftware. Seit einem Jahr auf Markt hat STARR bereits eine Vielzahl von Auszeichnungen erhalten und ist weltweit tausendfach bei kleinen und grossen Firmen, Schulen, Krankenhäusern und Privatanwendern im Einsatz. STARR ist auf Deutsch und Englisch erhältlich. Eine japanische Version ist in Vorbereitung.

STARR speichert im Hintergrund alle Aktivitäten die an einem Rechner ablaufen. Dabei werden das aktuell benutzte Programm, der Programmpfad, Tastatureingaben (inkl. Passwörter), besuchte Webseiten und vieles mehr in einer verschlüsselten Log-Datei abgespeichert. Diese Datei kann auf Wunsch auch unsichtbar über Email verschickt werden.

Ideal für Firmen und öffentliche Einrichtungen die die Benutzung ihrer PCs protokollieren müssen oder für verantwortungsvolle Eltern zur Kontrolle der Online-Aktivitäten Ihrer Kinder. Leicht zu installieren unter Win 95, 98, ME, NT und Win 2000.

STARR ist erhältlich als "HOME Edition" für Privatanwender und in der umfassenden "PRO Edition" für den Einstatz in Firmennetzwerken. Die Home-Version ist für die Benützung auf einzelnen (unvernetzten) PCs ausgelegt, während die PRO Version über alle Funktionen der HOME Version hinaus zusätzliche Netzwerk- und Managementfunktionen erhält. Ntürlich kann die PRO Version auch auf PCs ohne Netzwerkverbindung problemlos installiert werden. Einen detailierten Vergleich beider Versionen finden sie hier.

Wichtiger Hinweis für Deutschland*: Wir weisen darauf hin, das der STARR PC & Internet Monitor Überwachungsfunktionen besitzt, die der Genehmigung der zu überwachenden Personen bedarf. Bei Nichtachtung machen Sie sich im Sinne von §§201, 202 StGB strafbar. Dies gilt insbesondere für die Funktion "Tastaturmitschnitt" und "Screenshot". (*) Bei Verwendung der Software in anderen Ländern müssen Sie sich über die dortigen gesetzlichen Bestimmungen informieren und diese beachten.

starr.gif (350 Byte) Die beliebtesten iOpus STARR Funktionen:
 | Bildschirmaufzeichnung: Zeichnen Sie die Aktivitäten mit Bildschirmfotos automatisch auf.
 | Tasturmitmitschnitt
 | "WEB Spy" : Die Links zu allen besuchten Seiten werden aufgezeichnet
 | "CHAT Spy": BEIDE Seiten einer Chat-Unterhaltung aufgezeichnet (AOL Instant Messenger, ICQ, Microsoft Messenger, Yahoo Chat).
 | "AOL Spy": Aktivitäten in AOL werden protokolliert
 | Emailversand der Logdatei. [STARR PRO]
 | LAN Unterstützung: STARR lässt sich problemlos in Ihren Netzwerk installieren [STARR PRO]
 | STARR ist gegen Manipulation geschützt. Auf Wunsch verhält sich STARR "unsichtbar". Die Logdatei ist verschlüsselt und kann somit nicht manipuliert werden. Viele weitere Sicherheitsfeatures !
nn

Einige Auszeichnungen von iOpus STARR:
ZDNET 5 STAR AWARD | STARR wurde von ZDNET USA und Deutschland mit jeweils 5 Sternen [image] beurteilt - das ist höchstmögliche Bewertung.
Tucows! | STARR wurde von der führenden Webseite für Internetsoftware, Tucows, ebenfalls mit fünf Punkten ("Kühen") [image] bewertet.
 | Auch im grössten Archiv für Web Software erhielt STARR die Bestnote und war "Editor's Pick".
iOpus STARR wurde in vielen Zeitungen, Magazinen, Radio- und TV Show vorgestellt. Eine Auswahl: |
xx

Bemerkung: Einige Seiten dieses Benutzerhandbuches sind zur Zeit noch in der Orginalsprache (Englisch). Eine deutsche Übersetzung finden Sie im Online Benutzerhandbuch.


Invisible Installation

STARR Installation

Der STARR Installationsassistent hilft Ihnen automatisch bei der für Ihren Anwendungsfall richtigen Installation.

Zusätzlich unterstützt die PRO Version von STARR noch die Ferninstallation via LAN. Alle von STARR benützten Dateien sind vollständig dokumentiert.

  1. Unischtbare Installation

  2. Ferninstallation [PRO Version]

  3. Manuelle Installation [PRO Version]


Invisible Installation

"Unsichtbare" Installation von STARR

Die Standardinstallation von STARR erzeugt die üblichen Einträge im Programmenü zur einfachen Bedienung. Für bestimmte Anwendungen wird jedoch eine unsichtbare Installation von STARR bevorzugt.

Prinzipiell kann man zwischen zwei Möglichkeiten der unsichtbaren Installation unterscheiden:

  • Szenario 1: Die Überwachung einer Serie von (internetfähigen) PCs. Die Auswertung und Kontrolle erfolgt über einen separaten Administrator PC. Dies ist ein typisches Szenario für die Überwachung von Unternehmens oder Schulrechnern.
    Installation: Hier ist es empfehlenswert zunächst die Standardinstallation von STARR auf dem Administrator PC durchzuführen und sich mit der (einfachen!) Handhabung von STARR vertraut zu machen und dann die benötigten Files auf den zu überwachenden PC zu kopieren (Details siehe Tabelle).

  • Szenario 2: Überwachung und Auswertung erfolgt am gleichen PC. Eine typische Anwendung ist die Überwachung der PC Benutzung und des Internetzugriffs von Kindern durch die Eltern.
    Installation: Das Vorgehen entspricht dem für Fall 1 mit einer Erweiterung: Nachdem Sie sich mit der Handhabung von STARR vertraut gemacht haben sichern Sie eine wichtige Files (s. u. ) und entfernen Sie diese Installation wieder über die beigefügte Deinstallationsprogram. Danach wird das Programm wieder Manuel auf dem PC installiert. Die genauen Schritte sind in der Tabelle beschrieben: Der STARR Commander kann (aber muss nicht) auf dem PC
    verbleiben.


Network Settings

Local Area Network (LAN):

STARR Professional contains support for deployment and use on Local Area Networks (LAN).

A. Create individual log files (and reports)

You can create individual log files for each user and/or each PC by simply adding the <PC> and/or <USER> tags in the STARR log file name. Other available tags are <DATE>, <TIME>. STARR will automatically parse and replace the tags with the current PC name, user name, date or time.

Example:

You name the log file "log_<USER>.sys". Your users ( = user login name) are "PeterBrown", "AnnSmith" and "Administrator".

Starr creates the following log files:

  1. log_PeterBrown.sys

  2. log_AnnSmith.sys

  3. log_Administrator.sys

Note: On Win 9x/ME systems it is possible that a user does not log in. In this case, and for everything that happens before a login, the <USER> tag is replaced with "Nobody" so the recorded information can be examined separately.

Tech Tip 1: You can use the <...> tags not only as part of the file name but also the file path. If the specified folder does not exits, STARR will create it automatically when it attempts to write to the file.

Example: Your path name may look like this:

\\my-computer\reports\<USER>\log_<DATE>.sys

This will result in all log files for "Peter Brown" are written in the "Peter Brown" folder:

\\my-computer\reports\PeterBrown\log_2001-8-10.sys
\\my-computer\reports\PeterBrown\log_2001-8-11.sys
\\my-computer\reports\PeterBrown\log_2001-8-12.sys

Tech Tip 2: You can use the "Send report via LAN" feature in STARR PRO Edition to automatically create reports on the *local* hard disk as well! This allows you to easily test the STARR report generation. It is also a very neat feature if you use STARR to log activity on your PCs for later reference. Since the STARR logging engine creates the reports automatically, there is no need to start STARR Commander to view the reports. For security reasons the reports can be created as password-protected ZIP file.

B. Setup options for LAN networks

For log file storage and reporting there are two recommended options:

1. Store the STARR log file on a Administrator PC.

With this option no data is stored in the Client PCs. On the Administrator PC you can use the STARR Commander to create reports. For this option to work well the Client PC should have a permanent LAN connection. To rename the log file go to STARR Commander >> SETTINGS TAB >> Click ADVANCED SETTINGS. If it is not (e. g. laptops !) we recommend option 2:

2. Save the ready to use reports on the Administrator PC. With this option the STARR log itself is kept on the PC (unless you use option 1 as well). STARR sends the ready-to-use reports over the LAN to the Administrator PC. To rename the report file names go to STARR Commander >> EMAIL / LAN TAB >> Click LAN SETTINGS.

Note:
If you use option 2 you do not need to install the program on the Administrator PC (Server) but only on the workstations that you wish to monitor. If you have a peer-to-peer network without a server STARR will work equally well. The only requirement is a single shared folder that all machines have write access to (no read access required). To create a shared folder that other workstations cannot see, append a "$" character to the folder's share name (i.e. "STARR$"). This folder should be on the server but it can be on any machine on the network. The network transport protocol is unimportant. STARR clears old records on the CLIENT PC automatically and needs no maintenance.

By using a shared folder the STARR reports (and the STARR log file) is always available to the Administrator - even if the source machine has been shut down.

C. STARR Deployment

Deploying STARR in a network is done by cloning the settings of a SOURCE machine. Since STARR is written as a very compact software only a few files are needed. The installation is transparent and can be easily automated. The source machine can be any PC on the networking running STARR, including this PC.

Remote Deployment for Networks is available to all users with a multi-user or site-license.

Typically there are 3 ways to deploy STARR:

Option 1: Network install

Copy all logging engine files to the appropriate folders on the CLIENT PC. To automate the first startup, copy "starr.lnk" to the start-up folder of the machine:

Windows Version | Typical locations of the start-up folder:
Win 95, 98, ME | C:\WINDOWS\Start Menu\Programs\StartUp
Win NT, 2000, XP | C:\Documents and Settings\XXX\Start Menu\Programs\Startup [xxx = User Login Name, If this user has local Admin privileges STARR is automatically installed for ALL users on this machine. If this user has restricted rights STARR is only installed for this specific user]

Directly after the first start the logging engine completes the setup. This includes removing the start-up link and replacing by a more secure startup mechanism. Also, the "starr.ini" file is automatically deleted.

Option 2: Use Login Script

This is the best option for large networks and where file sharing is not practical. Your login scripts needs to copy all logging engine files to the target machine and start the logging engine. After it is started, the logging engine invisibly completes the setup and deletes the "starr.ini" file automatically.

Option 3: Manuall installation using a "Clone" disk or network path.

This is the most simple option and can be used where option 1 and 2 are not practical: Simply copy all logging engine files in the appropriate folder on the target machine and start the logging engine once. After it is started, the logging engine invisibly completes the setup and deletes the "starr.ini" file automatically.

Note 1: The table the complete list of all necessary files can be found here .

Note 2: When you need to update the settings, create a new "starr.ini" file and copy to the client PCs. The logging engine automatically picks it up, reads the settings and deletes it at the next start up.

D. How to store the settings ("starr.ini" file)

To create the starr.ini file (needed for option 1 - 3) and the "starr.lnk" (needed for option 1) start STARR Commander. Then go to EMAIL / LAN >> LAN SETTINGS and click "STORE SETTINGS": The ready-to-use files are created.

Note: For easy testing, not only the logging engine (wsys.exe) can read the "starr.ini" file but also the STARR Commander.

E. Notes to Network Administrators

1. Make sure that the network (or local) directory exists and has full access rights (read and write) for all users! If a directory does not exists, STARR will ask you to create it when you press the "TEST" button on the LAN options page.

2. There is no limit to the size or type of network that STARR is installed on, and there are no requirements for any particular transport protocols. STARR is currently running on small peer-to-peer office networks and multi-server networks with 100+ machines, with mixed operating systems including Windows 95/98/Me/NT/2000 and Novell.

3. All you need is one shared folder on the Network. STARR will work on any machine that can write to that folder. Create an invisible shared folder by adding a "$" sign to the share name so that the end users cannot see it in Network Neighborhood.

4. The number of Client PC installations ("logging engine") allowed on your network is embedded in your license key. Installation of the STARR Commander are unlimited

5, If the connection to the network folder is lost at any point, STARR will save all information locally and resends it once the network connection is established again. This is especially important for a laptop that may be disconnected for long periods.

6. To make sure you have the correct path, we recommend that you use the "Browse" button on the LAN options page. There must be a slash "\" at the end of the directory path. If you forget it, STARR will add it for you :-)

7. STARR Commander has a command line option "-convert" for an easy (automated) conversion of STARR log files into reports:

8. You can use the remote deployment also to disable a STARR installation: Disable "Autostart" in the STARR Commander and create a new "starr.ini" file. Once this file is placed in the same directory as the logging engine (wsys.exe) the logging engine will read this file at the next start and stop itself from running at the following PC start.

9. Share Name Hint: You can setup an "invisible share" by proceeding you share name with a dollar sign ($). An invisible share is not shown in the list of shares on your computer, but can still be accessed by the share name (example: \\my-computer\shared$ where "my-computer" is the name of your computer on the network an "shared$" is the name of your hidden share).


Manual Installation

Manuelle Installation

Überblick über die mitgelieferten Programme:

(Alle diese Dateien befinden sich im STARR Verzeichniss nach einer Standardinstallation.)

Dateiliste:

Dateiname

Beschreibung

Wo benötigt ?

Wo installieren ?

wsys.exe

STARR Recorder

Client PC

Kann in jedem Verzeichnis installiert werden, z.B. c:\windows . Nach dem Verschieben oder Umbenennen dieser Datei muss die Pfadangabe im STARR Commander angepasst werden

wsys.dll

STARR Recorder Ergänzung

Client PC

Siehe oben

starr.ini

STARR Voreinstellugen

Client PC

Wird vom STARR Commander für die Ferninstallation erzeugt und nach der Installation automatisch gelöscht.

see32.dll

Standard Windows Datei für Internetzugriff

Client und Admin PC

Installation im Windows Sytemverzeichnis: Typischerweise c:\windows\system bei Win 95 / 98 / ME oder c:\windows\system32 auf Win NT / Win 2000 .

see32z.dll (optional) | Standard Windows Datei für ZIP Komprimierung | Client und Admin PC | Wie see32.dll, muss aber nur installiert werden, wenn die ZIP Komprimierung gewünscht ist
see32u.dll (optional) | Standard Windows Datei für ZIP DEkomprimierung | Client und Admin PC | Wie see32.dll, muss aber nur installiert werden, wenn SCREENSHOTS benützt werden.

starrcmd.exe

STARR Commander zum Konfigurieren des STARR Wächter

Admin PC

Beliebiges Verzeichnis

starr-manual-chm
(optional)

diese Datei !

Admin PC

Gleiches Verzeichnis wie STARR Commander oder einfach ausdrucken

Bemerkung: Beachten Sie, das die meisten Dateimanager (z. B. Microsoft Windows Explorer) als Default "DLL" Dateien NICHT anzeigen. Sie müssen die Option "Systemdateien anzeigen" aktivieren, um diese Dateien sehen zu können


STARR Commander

Der STARR Commander

Mit dem STARR Commander nehmen Sie die Einstellungen zum Betrieb des STARR Monitors (= das Überwachungsprogramm, das unsichtbar im Hintergrund läuft) vor.

Im folgenden werden die einzelnen Seiten im Detail beschrieben:

  1. Zentrale

  2. Überwachung

  3. Sicherheit

  4. Email / Netzwerk [Nur PRO Version]

  5. Aktivierung <-- Hier können Sie Ihren Freischaltcode eingeben.

  6. Über <-- STARR Online Support


Dashboard

Zentrale:

Die Zentrale gibt die volle Kontrolle über den STARR Monitor (= das Überwachungsprogramm, das unsichtbar im Hintergrund läuft). Beachten Sie, das der eigentliche STARR Rekorder vollständig im Hintergrund abläuft und nicht im Windows "tray" oder in der Liste der laufenden Programme erscheint. Ein & ausschalten kann man den STARR Monitor nur über den STARR Commander.

Start / Stop startet / beendet den STARR Rekorder. Der aktuelle Zustand (laufend oder gestoppt) wird im Feld neben den Tasten angezeigt.

Ausgabedatei: Dies ist die lesbar aufbereite Datei, die von dem Starr Commander aus der Rohdatei erzeugt wird. Um die Ausgabedatei zu erzeugen, drücken Sie einfach "Ausgabedatei erzeugen". Danach kann die erzeugte Datei durch Drücken von "Anzeigen" angezeigt werden. Die Ausgabedatei kann wahlweise als farbig aufbereitete HTML-Datei, als Eingabefile für eine Tabellenkalkulation oder als gut lesbar aufbereitetes Textfile erzeugt werden. Als Standard empfehlen wir die HTML Anzeige im Browser. Je nach Ihrer Wahl startet STARR automatisch den Default-Browser, die Default-Tabellenkalkulation oder den Default-Texteditor auf Ihrem System.

Alles löschen beim Verlassen: Diese Option hilft Ihnen, die Logdateien nach der Benutzung des STARR Commanders automatisch zu löschen. Dies ist besonders sinnvoll, wenn die Auswertung der Datei direkt auf dem zu überwachenden Rechner erfolgt.

Bemerkung: Beachten Sie bitte, das Ihr Browser evtl. noch eine Kopie des angezeigten Logfiles im Cache hat. Auf diese Datei könnte dann auch noch zugegriffen werden, nachdem STARR die Orginaldatei gelöscht hat. Daher sollten Sie den Cache Ihres Browser bei Bedarf manuell löschen. Für Internet Explorer z.B.. gibt es dafür eine Funktion in den "Internet Einstellungen".

Teste Email: Diese Funktion dient zum Testen der eingebauten Email Funktionen. Wenn aktiviert, wird das aktuelle Rohdatei über Email verschickt.


Monitoring

Überwachungseinstellungen:

Auf dieser Seite können Sie festlegen, welche Informationen STARR aufzeichnen soll. STARR bietet Ihnen eine grosse Fülle von möglichen Informationen. Sofern Sie STARR auch zur Aufzeichnung von anderen Aktivitäten als Ihrer eigenen benutzen, müssen Sie unbedingt die deutschen Datenschutzvorschriften beachten. Insbesondere die Aufzeichnung von Tastatureingaben sollte mit Vorsicht eingesetzt werden, da damit auch die Passwörter der Benutzer im Klartext (!) in der späteren Ausgabedatei erscheinen.

Im folgenden werden die einzelnen Beispiele anhand eines Ausschnittes aus der HTML Ausgabedatei erläutert:

Visuelle Überwachung:

Bildschirmphotos: STARR nihmt in regelmässigen Abständen Bilder des aktuellen Bildschirminhaltes auf. Klicken Sie auf das verkleinerte Photo um es in Orginalgrösse anzuzeigen.
aaa

[05/15/2001 | 11:43:18] Screenshot:

Bildschirmphotos sind nur im HTML-verfügbar

.

Text Überwachung:

STARR zeichnet Transkipte der wichtigsten Aktivitäten auf.

1. Tastatur: Zeichnet Tastaturbenützung auf: Die Benützung der "Löschen" Taste wird durch <BS> angezeigt.
Sehr geehrte Damen und Herren,
hiermit bestellen wir 10<BS><BS>30 Lizenzen von SD<BS>TARR für unsere Firma.
MfG, Erika Mustermann
x
2. Anwendungen: Pfad der gerade aktiven Anwendung. Wird zB. für den Einsatz von STARR im Support-Bereich und Fehlersuche verwendet

[05/15/2001 | 15:17:06] [01:05] Microsoft Word: cv.doc

[05/15/2001 | 18:19:26] [00:17] Microsoft Word: resume.doc
x
2a. Anwendungspfad: Pfad (und "Klasse") der gerade aktiven Anwendung. Wird zB. für den Einsatz von STARR im Support-Bereich und Fehlersuche verwendet
Path: c:\Program Files\Office\msword.exe
x
2b. Window Klasse: Technische Option zB. für den Einstatz im Supportbereich
[Class: IEFrame]
x
3. Zeitstempel: STARR markiert die Logdatei periodisch mit der aktuellen Zeit, auch wenn der PC gerade nicht aktiv benutzt wird
Time Stamp: 12:17:45 / 02.14.2000
x
4. Popups Aufzeichnung des Textes von (Warn-)Meldungen und des Textes einfacher Texteditoren, zB. Notepad. Es werden jeweils die ersten 12 Zeichen aufgezeichnet.
Captured Popup Field(s)
503 123 4567
Ann Norris
San Francisco, CA
x
5. "Chat Spy". Beide Seiten einer Chatunterhaltung. Nach dem Ende einer Unterhaltung erscheint eine Zusammenfassung im Bericht.
Chat summary No. 1: Ann - Instant Message
Chat #1:
Ann says:
Did you test the latest STARR release yet ?
Peter says:
Yes, it's great ! Download it now from http://www.iopus.com/download.htm ;-)
Ann says:
Thanks ! Bye !
x
6. "AOL Spy": Zeichnet AOL Fenster auf.
AOL window summary No. 1: Email
Hi Ann,
I am currently using AOL and everything is recorded. Now we can keep an eye on our kids :-)
Peter
x
7. "WEB Spy" (Internetkontrolle): Zeichnet die Adressen der besuchten Webseiten auf. Im HTML log erscheinen diese als aktive Hyperlinks zu einfachen Benützung, zb. zur Kontrolle des Inhalts oder als Browser-unabhänige Gedächtnisstütze ("Wie hies die URL nochmal ?")

[05/15/2001 | 16:27:06] [00:55] iOpus Software - Microsoft Internet Explorer -

(Path: c:\program files\Internet explorer\iexplore.exe)

+ Link: http://www.iopus.com/

+ Link: http://www.iopus.com/overview.htm

+ Link: http://www.iopus.com/download.htm

+ Link: http://www.iopus.com/service/feedback.htm

Ann

ann@iopus.com

This is an example of captured keystrokes while I am at a feedback form.

+ Link: http://www.iopus.com/store.htm

+ Link: http://www.yahoo.com

...


Settings

Sicherheitseinstellungen:

STARR hat die Fähigkeit, bei Bedarf vollkommen unsichtbar im Hintergrund laufen zu können. Diese Eigenschaft wird gerne von IT Managern genützt, die ein Netzwerk überwachen müssen oder auch Eltern, die unbemerkt die PC Nutzung Ihrer Kinder aufzeichnen wollen.

Auf dieser Seite können Sie Details der Hintergrundaktivitäten von STARR
festlegen:

Popup: Das Popup ist eine bereits in STARR eingebaute Methode, um PC Benutzer darauf hinzuweisen, das Sie auf einem überwachten PC arbeiten. Die Datenschutzvorschriften verschiedener Länder verlangen verbindlich einen solchen Hinweis in vielen Fällen. Bitte informieren Sie sich hierzu über ihre lokalen Gesetze. Der Text des Popups kann frei festgelegt werden. Um die Verwendung des Popups für den Benutzer attraktiver zu machen, werden auch noch die Zeit und das Datum des letzten Logins angezeigt.

Wichtiger Hinweis für Deutschland*: Wir weisen darauf hin, das der STARR PC & Internet Monitor Überwachungsfunktionen besitzt, die der Genehmigung der zu überwachenden Personen bedarf. Bei Nichtachtung machen Sie sich im Sinne von §§201, 202 StGB strafbar. Dies gilt insbesondere für die Funktion "Tastaturmitschnitt" und "Screenshot". (*) Bei Verwendung der Software in anderen Ländern müssen Sie sich über die dortigen gesetzlichen Bestimmungen informieren und diese beachten.

Zurückdatieren: Eine Standardmethode um herauszufinden, was gerade auf dem PC passiert, ist es, nach allen Dateien zu suchen, die z.B.. in der letzten Stunde erstellt wurden. Um die Rohdatei vor dieser Manipulation zu schützen, wird das Datum der Datei automatisch auf einem alten Datum konstant gehalten.

Rohdatei Verschlüsselung: Die Rohdatei kann automatisch über ein Passwort verschlüsselt werden. Die Verschlüsselung ist ein wirksames Mittel gegen unerlaubte Manipulation des Logfiles. Beachten Sie, das für die Entschlüsselung der Datei genau das gleiche Passwort im STARR Commander eingeben sein muss. Bei einem falschen Passwort erscheint keine Fehlermeldung, aber das "entschlüsselte" Logfile wird weiterhin verschlüsselt und damit unlesbar sein. Das Passwort unterscheidet GROSS und klein - Schreibung !

Internen Buffer benutzen: Per Default, STARR benutzt den internen Puffer des Windows Systems für eine maximale Geschwindigkeit. Allerdings ist bei manchen PCs der zentrale Festplattenpuffer nicht eingeschaltet, so das z.B.. jeder einzelne Tastatureingabe unmittelbar auf die Festplatte geschrieben wird. Um dies zu verhindern, kann der STARR interne Puffer aktiviert. In diesem Fall sammelt STARR zuerst 200 Eingaben auf, bevor der Text auf die Festplatte geschrieben wird.

STARR Commander Passwort: Um nur autorisierten Personen den Zugriff auf den STARR Commander zu erlauben, kann hier ein Passwort eingegeben werden.

Pfadnamen: Der STARR Rekorder besteht aus zwei Programmteilen, einer sogenannten "EXE" und einer "DLL" Datei. Um eine Manipulation des STARR Rekorder zu verhindern, kann der Pfad und der Name der beiden Dateien kann vollständig verändert werden. So könnte wsys.exe z.B.. zu sommer.abc und wsys.dll zu herbst.123 umbenannt werden. Nach einer Veränderung von Name oder Pfad muss dieser dann hier im STARR Commander entsprechend angepasst werden. Anschließend das Speichern bitte nicht vergessen.

Backup Rohdatei größer als xxx Bytes: Für Anwendungen bei denen STARR für eine längere ununterbrochen läuft, kann das Logfile eine beachtliche Größe erhalten. Um zu verhindern, das dabei zuviel Festplattenplatz verbraucht wird, kann hier eine Maximalgröße eingegeben werden. Wird diese Größe erreicht, wir die alte Rohdatei vollautomatisch in die Backup Datei (Name <aktueller Name> + "2") verschoben und ein neue Rohdatei gestartet. Eine evtl. bereits bestehende Backup Datei wird dabei überschrieben. Dieses Verfahren stellt sicher, das die Rohdatei immer die aktuellsten Daten erhält und STARR wartungsfrei läuft. Die Größe der Rohdatei wird automatisch jede Minute von STARR überprüft.


Settings

Advanced Installation settings:

Here you can adjust details of your STARR installation, e.g. to prepare STARR for a manual installation.

STARR log file: This is the log file created during the logging process. It can be plain ASCII text (i.e. viewable with any text editor) or a totally scrambled text if you choose to encrypt it (-> security settings). You can enter a path directly or use the BROWSE button. If you transfer a STARR log file from another PC to your administrator PC, you need to load it into the STARR Commander as a STARR log file in order to decrypt and display it (see also the Email section).

Path names: The invisible activity monitoring module ("Logging engine") consists of an executable and a so-called dynamic link library which contains program code used by STARR. You are totally free to rename both files. You could rename "wsys.exe" to "nice.day" and "wsys.dll" to "sunshine.hot" to hide them even from someone who might know the STARR filenames themselves. Once you have changed the names of these two files and / or their directory, all you have to do is change two path names in the STARR Commander.

Tip: Renaming starrcmd.exe: The file starrcmd.exe (the STARR Commander) is copied to your Windows directory (typically c:\Windows or c:\WinNT). You can easily rename this file: Example: You rename the file to GoodMorning.exe. Then you need to type "GoodMorning" into the RUN menu in order to start the STARR Commander.

Auto-Name: STARR can automatically name the log file, the email attachment (STARR report) and the email subject individually. This helps you to automatically sort and group your reports correctly. The currently available tags are:

<PC> Adds PC name

<USER> Adds user name. If you insert this tag in the log file name, STARR creates separate log files for each user !

<DATE> Adds the start-up date to the log file name. For the email attachment, the date when the report is emailed is added.

<TIME> Adds the start-up time to the log file name. For the email attachment, the time when the report is emailed is added.

By default, all four tags are added to the email attachment file name.

Uninstall STARR: Click here to remove STARR from the PC.


Email Settings

Email / LAN Versand der Berichte:

STARR Pro kann die Berichte via LAN oder Email direkt an andere Rechnner versenden. Mit Hilfe der "Tags" (z. B. <PC>, <USER>, <DATE>, <TIME> ) können dabei automatisch eindeutige Reportnamen erzeugt werden.

1. Geben Sie ein WIE Sie die Berichte versenden wollen:

  • Kein Versand

  • Versand via Email <= Klicken für Details

  • Versand via LAN <= Klicken für Details

2. Entscheiden sie WAS der Bericht enthalten soll (mit / ohne Bildschirmbilder) und welches Format er haben soll.

3. Entscheiden Sie WANN der Bericht versand werden soll. Das kann entweder nach Zeit sein (z. B: alle 2 Stunden) oder nach Dateigrösse.


Email Settings

Berichte via Email:

Für einen ersten Test langt es, müssen Sie nur noch Ihre Emailadresse (an die die Berichte geschickt werden sollen) eingeben.

STARR kann die Berichte oder die Rohdatei automatisch an beliebige Emailadressen verschicken, sofern der zu überwachende PC zumindest zeitweilig mit dem Internet verbunden ist. Auf der oberen Hälfte der Seite können Sie eingeben, wann und wohin die Rohdatei verschickt werden soll. STARR wählt sich NICHT automatisch in das Internet ein, sondern wartet bis der PC "sowieso" mit dem Internet verbunden ist. Es können, über Kommas getrennt, auch mehrere Empfänger eingeben werden. Um den Emailversand zu beschleunigen, kann STARR die Rohdatei automatisch nach dem Standard ZIP Verfahren komprimieren. In der unteren Hälfte dieses Fenster erwartet STARR Angaben über den zu verwendenden Email Server. Für ein schnelles Testen von STARR stellt IOPUS einen bereits fertig konfigurierten Emailserver bereit. Wenn dieser benutzt werden soll, aktivieren Sie "Eingebaute Email". Soll der Versand über einen eigenes Emailkonto (z.B.. bei GMX oder Web.de) erfolgen, können Sie die zweite Option auswählen und über die Drucktaste ein Fenster zur Eingabe der Serverdaten öffnen.

a.) Eingebautes Emailkonto

Client PC STARR Rekorder installiert

»SMTP»

Email Konto von  IOPUS Software

»Internet»

Ihr Email Konto, zB von T-Online oder AOl. SMTP nicht notwendig

»POP3»

Admin PC (STARR Commander installiert)

  • Schnellste Option - Sie müssen keine eigenen Emaildaten im STARR Commander eingeben.

  • WICHTIG: IOPUS kann die dauerhafte Verfügbarkeit dieses "eingebauten" Emailversands nicht garantieren.

  • Daher: Wird STARR regelmäßig benützt, empfehlen wir jedoch, sich ein eigenes SMTP fähiges Emailkonto einzurichten. Eine Liste der besten kostenlosen Emailkonten mit SMTP und POP3 Fähigkeit finden Sie unter http://www.iopus.com/guides/bestpopsmtp.htm .

b.) Eigene Email Konto: Zwei Konten Methode

Client PC STARR Rekorder installiert

»SMTP»

Email Konto im Internet

»Internet»

Ihr Email Konto, zB von T-Online oder AOl. SMTP nicht notwendig.

»POP3»

Admin PC (STARR Commander installiert)

  • Vorteil: Ihr eigentliches Emailkonto muss keinen SMTP Zugriff unterstützen.

c.) Eigene Email Konto: Ein Konto Methode

Client PC STARR Rekorder installiert

»SMTP»

»Internet»

Ihr Email Konto. SMTP Zugriff möglich.

»POP3»

Admin PC (STARR Commander installiert)

  • Die Dateien werden direkt über SMTP auf Ihr Emailkonto übertragen.

Email einstellen leicht gemacht:

Allgemeiner Tip vorweg: Wen Sie nicht sicher sind welche Angaben Sie wo machen müssen, schauen Sie einfach in Ihr jetziges Emailprogramm (z.B. Outlook Express oder Eudora) , fragen Sie Ihren Systemadministrator oder verwenden Sie das bereits eingebaute Emailkonto.

SMTP: (immer notwendig)

(SMTP: steht für "Simple Message Transfer Protocol" und bezeichnet die Standardmethode Emails im Internet zu verschicken.)

Absender: Die Absenderadresse, zB: IhrName@gmx.de

SMTP server: Adresse des SMTP servers, hat üblicherweise die Form mail.provider.com oder smtp.provider.com .

POP3: Das Ausfüllen der POP3 Felder ist nur notwendig, wenn Ihr Emailprovider eine sogenannte "POP3 vor SMTP" Überprüfung durchführt, das heisst wenn Sie zuerst einmal von Ihrer Mailbox abholen müssen bevor sie welche verschicken können.

(POP3 : steht für "Post Office Protocol". Dies ist das Standard Internet Verfahren zum Empfang von Emails)

POP3 server: Adresse des POP Servers. Hat üblicherweise die Form pop3.provider.de oder mail.provider.de - manchmal das gleiche Format wie die SMTP Adresse.

POP3 Benutzername: Das ist meisten der erste Teil Ihrer Emailadresse, zB. "IhrName" von "IhrName@provider.de"

POP3 Passwort: Das Passwort des verwendeten Emailkontos. STARR speichert das
Passwort verschlüsselt ab.

Tip: Sie können die gemachten Einstellungen ganz einfach durch die Verwendung des Funktion "Sende Test Email" auf der ersten Seite des STARR Commanders testen.


Command Line Options

STARR Commander has a the -convert command line option for an easy conversion of STARR log files into reports:

Example:

1. slog.sys is STARR log that you want to convert

2. report.htm is the name of the report that STARR is going to create

Then you use:

  starrcmd -convert slog.sys report.htm

This instructs STARR Commander to convert slog.sys into the report with file name report.htm. If the starrcmd.exe is NOT in the same directory as the slog.sys file you need to specify full path names:

  starrcmd -convert c:\dir1\slog.sys c:\dir2\report.htm

Passwords and other settings are used as stored in STARR Commander.


Feature comparison chart

Funktionsvergleich
STARR Professional und Home Edition

Funktionen: | PRO Edition | Home Edition
Überwachung
Bildschirmphotos (Screenshots) |  |
"Searchable Screenshots™" |  |
Tastaturmitschnitt |  |
Anwendungsname Aufzeichung |  |
Anwendungspfad Aufzeichung |  |
"Web Spy" (URL Aufzeichung) |  |
"Chat Spy" (Chat Aufzeichnung*) |  |
"AOL Spy" (AOL Aufeichung) |  |
Pop-Up's Aufzeichung |  |
Zeitstempel |  |
Separate Lofiles für jeden Benutzer |  |
Sicherheit
Unsichtbarer Modus |  |
Passwortschutz Installation |  |
Passwortschutz Logdatei |  |
Logdatei Rückdatierung |  |
Wartungsfreier Betrieb |  |
Installation
Installationsassistent |  |
Ferinstallation im Netzwerk | ** | -
Manualle Installation |  | -
Berichte
Interaktiver Bericht (HTML basiert) |  |
Text Berichtt |  |
Excel-Export |  | -
STARR Logdatei Rohformat |  |
Netzwerkunterstützung
Emailversand der Berichte |  | -
ZIP Kompression |  | -
Logdatei via LAN |  | -
Bericht via LAN |  | -
Automatische Namen für Berichte |  | -
Weitere Funktionen
Win 95 / Win 98 / ME kompatibel |  |
Win NT / Win 2000 / Win XP kompatibel |  |
Ein Jahr kostenloser Emailsupport |  |
STARR online kaufen: | Hier klicken | Hier klicken

Beide Programme sind als KOSTENLOSE 30-Tage Testversion erhältlich. Aus technischen Gründen sollten Sie beide Versionen nicht gleichzeitig installieren.

(*) Beide Seiten einer Chatunterhaltung werden für AOL Chat, AOL Instant Messenger, ICQ, Microsoft Messenger und Yahoo Messenger aufgezeichnet.

(**) Die Ferinstallation ist in den Mehrplatzlizenzen enthalten.

Noch Fragen ? Wenden Sie sich an support@iopus.com !


Buy STARR now !

STARR Bestellung:

Um unseren Kunden maximale Sicherheit und Komfort bei der Bestellung unsere Software zur geben, wickeln wir alle Bestellungen über unseren Partner "Share-It" ab. Die Share-It AG ist ein bekanntes und renommiertes deutsches E-Commerce Unternehmen das weltweit die Abwicklung von Bestellungen für uns übernimmt. Über Share-It können können sie die Registrierungscodes für iOpus Software immer schnell und sicher bestellen:

Hier klicken um zu unserem Online-Shop zu gelangen

Wir sind von der Qualität unserer Software überzeugt ! Daher bieten wir für alle von uns verkaufte Software eine 30-Tage Geld zurück Garantie !

Es stehen Ihnen sowohl die schnelle und bequeme Kreditkartenzahlung sowie die "klassischen" Methoden (Überweisung, Scheck, Bar) zur Verfügung. Nach Zahlungseingang (was bei Kreditkartenzahlung oft nur wenige Sekunden dauert) wird Ihnen Ihre Lizenznummer zugeschickt. Nach Eingabe dieses Codes in das dafür vorgesehene Feld im Programm ist die Software sofort fertig registriert und einsatzbereit.

Software | Bestellnummer (Share-It!) | Preis (EURO) | Link zur Bestellformular
STARR *PRO Edition* | 143644 | 69.95 | Jetzt bestellen
STARR *HOME Edition* | 143643 | 39.95 | Jetzt bestellen
x

Falls Sie Mengenrabatt oder eine Generallizenz benötigen, setzen Sie sich bitte vor der Bestellung mit uns ( Email: support@iopus.com ) in Verbindung.

Handpntg.gif (182 Byte) Bei Fragen und für weitere Informationen zur Bestellabwicklung können sie sich direkt an unseren Partner Share-It wenden:

Share-It! European office: | Share-It! - US office:
ShareIt! element 5 AG Sachsenring 69 D-50677 Köln/Cologne Germany Phone: +49 - 221 - 2407279 Fax: +49 - 221 - 2407278 | ShareIt! Inc. P.O. Box 844 Greensburg PA 15601-0844 Phone: +1 - 724 - 850 8186 Fax: +1 - 724 - 850 8187
Homepage: http://www.shareit.com / Email: register@shareit.com


Frequently Asked Questions (FAQ)

1. Purchasing:

Q: I would like to purchase and download STARR on the computer I am currently using, but install it on another computer. Is this possible?

A: Yes. The STARR installation file is compact and will fit on a single floppy disk. You may purchase and download on a computer and copy it to floppy disk, and then later install on another computer. Please note that the single user software license for STARR allows for one installation per purchase. Please also note that you are only allowed to install STARR on a computer you own. If you would like to install STARR on more than one computer, we offer multi-user and site licenses with great discounts.

Q: How do you count the licenses for the multi-user license ?

A: The installations are counted by the "STARR logging engine". Example: You have 10 PC's with the logging engine running and two PC's with (only) the STARR Commander to convert and read the log file. In this case you need the 10-user license. Installations of STARR Commander are free.

2. Installing:

Q: Am I allowed to install this software on somebody else's computer?

A: You may only install STARR on a computer that you own. Before you install the software, you must agree to use it only on a computer you own.

Q. Should I inform my employees or others that they are being monitored?

A: Yes. Some countries may require this by law. STARR has a built-in popup for this.

3. Operation:

Q: Does STARR log every application title, path etc.?

A: Yes, to our knowledge, the title and path of every application is logged.

Q: Does STARR log every keystroke ?

A. STARR logs almost every keystroke, with a few exceptions. Some applications do not allow for keystrokes to be logged, but these are very rare. The only ones currently known of are: the password fields in Pretty Good Privacy (PGP) and the NT / Win 2000 logon screen. If you come across any others, please let us know.

Q: Is the Win 95 / 98 / ME logon password recorded ?

A. Yes, it is (Please make sure that only authorized persons have access to the log file).

Q: Is the Win NT / Win 2000 logon password recorded ?

A. No.

Q: I received the log file via email but it looks "weird". What is wrong ?

A. Probably nothing! You probably choose the option "send STARR log". In this case STARR sends the raw, probably encrypted STARR log file . Choose "HTML", "Spreadsheet" or "Plain text" in order to receive "ready-to-use" reports.

Q: The spreadsheet report is not imported correctly into Excel ?

A. Excel can import Text files, which are stored in the comma separated value (CSV) format. Such a file contains the data in lines, whilst the fields are separated by commas. In normal cases Excel reads and converts this format automatically. Unfortunately there is a problem with Excel. Depending on the local Windows settings the separator may be either a semicolon or a comma. In German Excel the CSV file must contain a semicolon as a separator, to import the fields within the records into different columns of the worksheet.

4. Email: [PRO Version]

Q: Can STARR also send the log files via AOL ?

A: Email options (a) and (b) work fine with AOL. AOL uses its own proprietary email protocol and unfortunately not the Internet standard SMTP. Therefore you can not use option (c).

Q: Can you recommend any free email accounts for use with STARR ?

A. Yes, check out our very popular TOP 5 list of free SMTP / POP3 Email accounts at http://www.iOpus.com/guides/bestpopsmtp.htm

5. Security:

Q: How discrete is STARR ? Can anyone detect it?

A. If you select the log file backdating it is VERY discrete and almost impossible to detect since it does not appear on the task bar or even in the task list. For an invisible manual installation [PRO Version] simply follow the step-by-step guide in this manual.

Q: If people know STARR is installed, can they circumvent or manipulate the software without me knowing ?

A: STARR has many security features to prevent this: When installed invisibly, STARR does not show up as an icon, does not appear in the Windows system tray, does not appear in Windows Programs, does not show up in the Windows task list, cannot be uninstalled without the STARR Commander password which you can specify, and STARR does not slow down the operation of the computer it is recording.

If the log file is emailed out or saved on a network server it is not accessible for the user of the local PC and can not be deleted. Even when stored locally, it is impossible to manipulate the log file without breaking the STARR encryption scheme first. But as with any filter, surveillance or security software, a computer expert could ultimately disable or delete the STARR installation, but this will not go unnoticed by you !

Q: Why is STARR so small ? Other apps which do similar things need a 7.0 MB download ?

A. STARR is written in "pure" C/C++ code, which can be compiled into very small, yet powerful executables (Remember, only about ten years ago a whole operating system did not need more then 16 Kbytes!). Secondly, STARR is designed to make as much use of the Windows operating system as possible. The advantages are obvious: The more we utilize the Windows operating system itself, the smaller and more discrete STARR becomes.

6. Miscellany:

Q: Where can I find more information ?

A: You can find more information on the iOpus homepage, for example:

  • STARR Online Frequently Asked Question

  • STARR Online Bug reports

  • STARR user feedback

  • Articles & Links about the PC & Privacy issue

  • The popular iOpus TOP5 list of the best free email accounts

  • And more ....


x

iOpus Software:

Software | Quick Overview
iOpus STARR Pro Edition | iOpus STARR PRO EDITION contains all the features of the HOME Edition plus the features you need in a professional environment: Flexible network functions allow you to send and receive reports via the Internet or the corporate LAN. It contains advanced setup and reporting functions and is prepared for remote deployment inside the local network. STARR PRO is employed frequently by small businesses, "Fortune 500" companies, schools, universities and the military alike. Compare with STARR Home Edition
STARR iOpus STARR Home Edition | iOpus STARR HOME EDITION is designed for the use on a stand-alone PC, e. g. for parental control or for recording your own work for later reference. STARR HOME is the best choice for parents who wish to monitor what their children are doing online. It is an excellent alternative to standard filtering and blocking software. Compare with STARR PRO
42 BEEE | iOpus BEEE, Better Email Enable Everything, is a unique internet email tool that allows you to supervise every kind of file & folder on your PC and email it automatically to your SMTP / POP3 email account. BEEE supports MAPI connections to your default email account, automatic ZIP-compression and command line options for an easy integration Great for office automation (email your invoices automatically etc.)
iOpus Internet-Macros | iOpus Internet Macros is the first macro recorder designed for the Web. Surfing the Web is fun. But many tasks about surfing the web are repetitious: Check on the same sites everyday, log in to various services, remembering passwords or testing your own web site. Internet Macros can do that for you! You record it once, and can replay it with one mouse click. Internet Macros can display slide shows of web sites, fill out forms, click buttons, clean the browser and much more. As often as you need it.

xx
Freeware | Quick Overview
123 Write All Stored Passwords (WASP) | Passwords: WASP displays all stored passwords of the currently logged on user that are hidden in the Microsoft PWL file. It allows the convenient supervision or deletion of this file to improve the security / privacy of your PC (for Win 95, 98, ME only).
123 Password Recovery | Passwords: Windows allows the storage of frequently used passwords. However, since you no longer enter the passwords manually, you tend to forget them. What are you to do when you need to know one of the saved passwords ? The password is staring right at you, but is hiding behind a row of "*****" asterisks. This nifty utility allows you to reclaim your password.
42 AC-Plug | 42 Always Connected "Plug": Usually Dial-In Internet provider disconnect users if they are not "actively surfing" for a certain period of time. This software prevents the disconnection from happening. The AC-Plug sends periodic signals that will keep your internet connection active until YOU decide to disconnect.

x
iOpus Software is designed to be Windows platform independent, i.e.. it runs on Win 95, Win 98, Win ME and Win NT/2000/XP unless stated otherwise.


Introduction

Email Newsletter

Wenn Sie über neue Software, Updates und Tips von IOPUS informiert werden wollen, dann abonnieren sie am besten - unverbindlich und kostenlos - unseren Email-Newsletter.
Zum Abonnieren besuchen bitte

http://www.iOpus.com/newsletter.htm

um die Nachrichten online zu abonnieren. Der Newsletter ist zur Zeit auf Englisch erhältlich.


x

Über iOpus Software GmbH:

Die iOpus Software GmbH ist auf die Entwicklung von Windows basierten Sicherheits- und Internetanwendungen spezialisiert. Wir vertreiben unsere Software von Heidelberg (Deutschland) aus nach dem "Try-before-you-buy" weltweit elektronisch über das Internet, mit zufriedenen Kunden in mehr als 20 Ländern und auf allen fünf Kontinenten!

Durch den Verzicht auf altmodische Kartonverpackungen und CD Versand können wir unsere Programme zu sehr günstigen Preisen anbieten. Darüber hinaus bietet der Vertrieb ausschließlich über den elektronischen Download dem Kunden den die Garantie, stets die aktuellste Version der Software zu besitzen. Auch wenn wir am Karton sparen, am Support sparen wir nicht: Der Kaufpreis unserer Software enthält immer 1 Jahr kostenfreien Support über Email. Weiterhin stellen wir auch auf unserer Webseite umfangreiche Dokumentation bereit.

Wenn Sie weitere Informationen benötigen, schreiben Sie uns einfach eine Email - Wir freuen uns auf Ihre Nachricht !

Unsere Anschrift:
Email | Fax
Verkauf: sales@iopus.com | USA: +1-253-679-0811
Technicher Support: support@iopus.com | UK: +44-870-831-9234
Presse: press@iopus.com | Deutschland (49) (0)6227-841-9605
Webmaster: webmaster@iopus.com |
.
Postanschrift
iOpus Software Gmbh, PO Box 1343, 69184 Walldorf, Deutschland