Registerkarte “Provider”

Verwenden Sie die Registerkarte Provider, um für den Typ der Daten, auf die Sie zugreifen möchten, den geeigneten OLE DB-Provider auszuwählen. Nicht für alle Anwendungen kann ein Provider festgelegt oder die aktuelle Auswahl geändert werden; diese Registerkarte wird nur angezeigt, wenn Ihre Anwendung es zulässt, dass die Auswahl des OLE DB-Providers bearbeitet wird. Eine Datenverknüpfung kann mit der Anwendung selbst oder als separate Datei gespeichert werden. Weitere Informationen zum Erstellen einer Datenverknüpfung finden Sie unter "Creating a Data Link" im Microsoft Data Access SDK.

Option | Beschreibung
OLE DB-Provider | Listet alle OLE DB-Provider auf, die auf dem Computer gefunden wurden. Weitere Informationen zu Providern finden Sie unter "Microsoft OLE DB Providers Overview" im Microsoft Data Access SDK.
Weiter | Öffnet die Registerkarte Verbindung für den ausgewählten OLE DB-Provider.

Anmerkung Durch Doppelklicken auf den gewünschten Provider können Sie die Registerkarte Verbindung direkt aufrufen. Weitere Informationen zu Datenverknüpfungen finden Sie in der Data Link API Reference.


Registerkarte “Weitere”

Verwenden Sie die Registerkarte Weitere, um weitere Initialisierungseigenschaften für die Daten anzuzeigen und festzulegen.

Die Registerkarte Weitere des Dialogfeldes Datenverknüpfungseigenschaften ist providerspezifisch und zeigt nur die Initialisierungseigenschaften an, die vom ausgewählten OLE DB-Provider benötigt werden. Weitere Informationen zu erweiterten Initialisierungseigenschaften finden Sie in der mit Ihrem OLE DB-Provider mitgelieferten Dokumentation.

In der folgenden Tabelle werden die meisten Initialisierungsoptionen beschrieben.

Option | Beschreibung
Ebene für Identitätswechsel Die Identitätswechselebene, die der Server verwenden darf, um die Identität des Clients anzunehmen. Diese Eigenschaft gilt nur für Netzwerkverbindungen, die keine Remoteprozeduraufruf (Remote Procedure Call, RPC)-Verbindungen sind; diese Identitätswechselebenen gleichen denen, die durch RPCs bereitgestellt werden. Die Werte für diese Eigenschaft entsprechen unmittelbar den Identitätswechselebenen, die sich für authentifizierte RPC-Verbindungen festlegen lassen, können jedoch auf andere als authentifizierte RPC-Verbindungen angewandt werden. Wählen Sie eine der folgenden Ebenen aus:
  • Anonym - Der Client ist für den Server anonym. Der Serverprozess kann keine Identifizierungsinformationen über den Client erhalten und nicht die Identität des Clients annehmen.

  • Delegieren - Der Prozess kann die Identität des Clients im Hinblick auf den Sicherheitskontext annehmen, während er im Auftrag des Clients handelt. Der Serverprozess kann auch ausgehende Aufrufe an andere Server vornehmen, während er im Auftrag des Clients handelt.

  • Identifizieren - Der Server kann die Identität des Clients erhalten. Der Server kann die Identität des Clients zur ACL-Prüfung (Access Control List, Zugriffssteuerungsliste) annehmen, jedoch nicht als der Client auf Systemobjekte zugreifen.

  • Identität annehmen - Der Serverprozess kann die Identität des Clients im Hinblick auf den Sicherheitskontext annehmen, während er im Auftrag des Clients handelt. Diese Informationen werden beim Herstellen einer Verbindung und nicht bei jedem einzelnen Aufruf erhalten.
Schutzebene Die Schutzebene für die Daten, die zwischen dem Client und dem Server ausgetauscht werden. Diese Eigenschaft gilt nur für Netzwerkverbindungen, die keine Remoteprozeduraufruf (Remote Procedure Call, RPC)-Verbindungen sind; diese Schutzebenen ähneln denen, die durch RPCs bereitgestellt werden. Die Werte dieser Eigenschaft entsprechen unmittelbar den Schutzebenen, die sich für authentifizierte RPC-Verbindungen festlegen lassen, können jedoch auf andere als authentifizierte RPC-Verbindungen angewandt werden. Wählen Sie eine der folgenden Ebenen aus:
  • Aufruf - Authentifiziert die Quelle der Daten am Anfang jeder Anforderung vom Client an den Server.

  • Verbinden - Führt nur dann eine Authentifizierung aus, wenn der Client die Verbindung mit dem Server herstellt.

  • Kein(e) - Führt keine Authentifizierung von Daten aus, die an den Server gesendet werden.

  • Paket - Authentifiziert, dass alle erhaltenen Daten vom Client stammen.

  • Paketintegrität - Authentifiziert, dass alle erhaltenen Daten vom Client stammen und während der Übertragung nicht geändert wurden.

  • Paketdatensicherheit – Authentifiziert, dass alle erhaltenen Daten vom Client stammen und während der Übertragung nicht geändert wurden, und schützt die Daten durch Verschlüsselung.
Verbindungstimeout | Legt die Zeit (in Sekunden) fest, die der OLE DB-Provider wartet, bis die Initialisierung abgeschlossen ist. Wenn das Timeout für die Initialisierung erreicht ist, wird ein Fehler gemeldet, und die Verbindung wird nicht hergestellt.
Zugriffsberechtigungen Aktivieren Sie eine oder mehrere der folgenden Berechtigungen:
  1. Read - Nur-Lesen.

  2. ReadWrite - Lesen und Schreiben.

  3. Share Deny None - Weder Lese- noch Schreibzugriff kann anderen Benutzern verwehrt werden.

  4. Share Deny Read - Hindert andere Benutzer am Öffnen im Lesemodus.

  5. Share Deny Write - Hindert andere Benutzer am Öffnen im Schreibmodus.

  6. Share Exclusive - Hindert andere Benutzer am Öffnen im Lese/Schreibmodus.

  7. Write - Nur Schreiben.

Anmerkung Weitere Informationen zu Datenverknüpfungsinitialisierungen finden Sie in der Data Link API Reference.


Registerkarte “Alle”

Verwenden Sie die Registerkarte Alle, um alle OLE DB-Initialisierungseigenschaften, die für Ihren OLE DB-Provider verfügbar sind, anzuzeigen und zu bearbeiten. Die Eigenschaften unterscheiden sich je nach dem verwendeten OLE DB-Provider. Weitere Informationen zu Initialisierungseigenschaften finden Sie in der mit Ihrem OLE DB-Provider mitgelieferten Dokumentation.

Option | Beschreibung
Liste der Initialisierungseigenschaften | Listet alle Eigenschaften und deren derzeit festgelegte Werte auf.
Wert bearbeiten | Öffnet das Dialogfeld Eigenschaftswert bearbeiten für die ausgewählte Eigenschaft.

Anmerkung Doppelklicken Sie auf die gewünschte Eigenschaft, um das Dialogfeld Eigenschaftswert bearbeiten zu öffnen. Weitere Informationen zu Datenverknüpfungsinitialisierungen finden Sie in der Data Link API Reference.


Registerkarte “Verbindung”

Verwenden Sie die Registerkarte Verbindung, um festzulegen, wie mithilfe eines OLE DB-Providers eine Verbindung zu den Daten hergestellt wird.

Die Registerkarte Verbindung des Dialogfeldes Datenverknüpfungseigenschaften ist providerspezifisch und zeigt nur die Verbindungseigenschaften an, die vom ausgewählten OLE DB-Provider benötigt werden. Mit den Verbindungseigenschaften können Sie angeben, wo Ihre Daten gespeichert sind und wie eine Verbindung zu den Daten hergestellt wird. Weitere Informationen finden Sie in der mit Ihrem OLE DB-Provider gelieferten Dokumentation.

In der folgenden Tabelle werden die meisten Verbindungsoptionen beschrieben.

Option | Beschreibung
Datenquelle | Geben Sie den Namen der Datenquelle ein, auf die Sie zugreifen möchten (dies ist normalerweise ein Servername).
Speicherort | Geben Sie den Speicherort der Datenquelle ein, auf die Sie zugreifen möchten (dies ist normalerweise ein Datenbankname).
Integrierte Sicherheit von Windows NT verwenden | Klicken Sie auf diese Option, wenn Sie einen Authentifizierungsdienst verwenden möchten, um sich zu identifizieren. Ihr OLE DB-Provider muss einen Authentifizierungsdienst unterstützen, damit Sie diese Funktion verwenden können. Ein Beispiel ist der OLE DB-Provider für SQL Server. Außerdem benötigen Sie Berechtigungen für die Datenquelle, um den Authentifizierungsdienst zu verwenden.
Spezifischen Benutzernamen und Kennwort verwenden | Klicken Sie auf diese Option, um einen angegebenen Benutzernamen und ein angegebenes Kennwort für die Authentifizierung der Anmeldeinformationen für die Datenquelle zu verwenden.
Benutzername | Geben Sie den Benutzernamen ein, der zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kennwort | Geben Sie das Kennwort ein, das zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kein Kennwort | Ermöglicht es dem angegebenen Provider, in der Verbindungszeichenfolge eine leere Zeichenfolge als Kennwort zurückzugeben.
Speichern des Kennworts zulassen | Ermöglicht das Speichern des Kennwortes zusammen mit der Verbindungszeichenfolge. Ob das Kennwort in die Verbindungszeichenfolge integriert wird, hängt von den Funktionen der aufrufenden Anwendung ab. Anmerkung Beim Speichern wird das Kennwort unverborgen und unverschlüsselt zurückgegeben und gespeichert.
Geben Sie den zu verwendenden Anfangskatalog ein | Geben Sie den Katalog ein, auf den Sie nach der Herstellung der Verbindung zugreifen möchten.
Verbindung testen | Klicken Sie auf diese Schaltfläche, um zu versuchen, eine Verbindung zur angegebenen Datenquelle herzustellen. Wenn die Verbindung fehlschlägt, sollten Sie prüfen, ob die Einstellungen richtig sind. Ursache für eine fehlgeschlagene Verbindung können z. B. Schreibfehler oder eine falsche Groß/Kleinschreibung sein.

Anmerkung Weitere Informationen zu Datenverknüpfungsverbindungen finden Sie in der Data Link API Reference.


Registerkarte Verbindung für Jet

Verwenden Sie die Registerkarte Verbindung, um festzulegen, wie eine Verbindung zu Daten von Microsoft Access hergestellt wird.

Diese Registerkarte ist providerspezifisch und zeigt nur die Verbindungseigenschaften an, die vom OLE DB-Provider für Microsoft Jet benötigt werden.

Option | Beschreibung
Datenbankname | Geben Sie den Dateinamen (mit der Erweiterung .mdb) der Microsoft Access-Datenbank ein, auf die Sie zugreifen möchten. Um nach der Datei zu suchen, klicken Sie auf die Schaltfläche mit den drei Punkten.
Benutzername | Geben Sie den Benutzernamen ein, der zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kennwort | Geben Sie das Kennwort ein, das zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kein Kennwort | Ermöglicht es dem angegebenen Provider, in der Verbindungszeichenfolge eine leere Zeichenfolge als Kennwort zurückzugeben.
Speichern des Kennworts zulassen | Ermöglicht das Speichern des Kennwortes zusammen mit der Verbindungszeichenfolge. Ob das Kennwort in die Verbindungszeichenfolge integriert wird, hängt von den Funktionen der aufrufenden Anwendung ab. Anmerkung Beim Speichern wird das Kennwort unverborgen und unverschlüsselt zurückgegeben und gespeichert.
Verbindung testen | Klicken Sie auf diese Schaltfläche, um zu versuchen, eine Verbindung zur angegebenen Datenquelle herzustellen. Wenn die Verbindung fehlschlägt, sollten Sie prüfen, ob die Einstellungen richtig sind. Ursache für eine fehlgeschlagene Verbindung können z. B. Schreibfehler oder eine falsche Groß/Kleinschreibung sein.

Anmerkung Weitere Informationen zu Datenverknüpfungsverbindungen finden Sie in der Data Link API Reference.


Registerkarte “Verbindung” für ODBC

Verwenden Sie die Registerkarte Verbindung, um festzulegen, wie eine Verbindung zu ODBC-Daten hergestellt wird.

Diese Registerkarte ist providerspezifisch und zeigt nur die Verbindungseigenschaften an, die vom Microsoft OLE DB-Provider für ODBC benötigt werden.

Option | Beschreibung
Datenquellenname verwenden | Wählen Sie den Namen der ODBC-Datenquelle (DSN, Data Source Name), auf die Sie zugreifen möchten, in der Liste aus, oder geben Sie ihn ein. Mit dem ODBC-Datenquellen-Administrator können weitere Datenquellen hinzugefügt werden. Klicken Sie auf Aktualisieren, um die Liste zu aktualisieren.
Verbindungszeichenfolge verwenden | Ermöglicht die Eingabe oder das Erstellung einer ODBC-Verbindungszeichenfolge, anstatt einen vorhandenen Datenquellennamen zu verwenden.
Erstellen Öffnet das Dialogfeld Datenquelle auswählen. Nachdem Sie eine Datenquelle ausgewählt haben, wird die Verbindungszeichenfolge dieser Datenquelle auf der Registerkarte Verbindung des Dialogfeldes Datenverknüpfungseigenschaften angezeigt.

Wenn Sie einen Datei-DSN auswählen, basiert die resultierende ODBC-Verbindungszeichenfolge nicht auf einem DSN. Die ODBC-Verbindungszeichenfolge wird in der Datenverknüpfungsdatei (mit der Erweiterung .udl) beständig gespeichert und beruht nicht auf dem ausgewählten Datei-DSN.

Wenn Sie einen Computer-DSN auswählen, basiert die resultierende ODBC-Verbindungszeichenfolge auf einem DSN. Die ODBC-Verbindungszeichenfolge verweist auf den ausgewählten Computer-DSN. Wenn ein Benutzer auf einem anderen System versucht, auf die Datenverknüpfungsdatei (mit der Erweiterung .udl) zuzugreifen, muss auch dieser Benutzer den Computer-DSN installiert haben.
Benutzername | Geben Sie den Benutzernamen ein, der zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kennwort | Geben Sie das Kennwort ein, das zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kein Kennwort | Ermöglicht es dem angegebenen Provider, in der Verbindungszeichenfolge eine leere Zeichenfolge als Kennwort zurückzugeben.
Speichern des Kennworts zulassen Ermöglicht das Speichern des Kennwortes zusammen mit der Verbindungszeichenfolge. Ob das Kennwort in die Verbindungszeichenfolge integriert wird, hängt von den Funktionen der aufrufenden Anwendung ab.

Anmerkung Beim Speichern wird das Kennwort unverborgen und unverschlüsselt zurückgegeben und gespeichert.
Geben Sie den zu verwendenden Anfangskatalog ein | Geben Sie den Namen des Katalogs (oder der Datenbank) ein, oder wählen Sie ihn in der Dropdownliste aus.
Verbindung testen | Klicken Sie auf diese Schaltfläche, um zu versuchen, eine Verbindung zur angegebenen Datenquelle herzustellen. Wenn die Verbindung fehlschlägt, sollten Sie prüfen, ob die Einstellungen richtig sind. Ursache für eine fehlgeschlagene Verbindung können z. B. Schreibfehler oder eine falsche Groß/Kleinschreibung sein.

Anmerkung Weitere Informationen zu Datenverknüpfungsverbindungen finden Sie in der Data Link API Reference.


Registerkarte “Verbindung” für Oracle

Verwenden Sie die Registerkarte Verbindung, um festzulegen, wie eine Verbindung zu Oracle-Daten hergestellt wird.

Diese Registerkarte ist providerspezifisch und zeigt nur die Verbindungseigenschaften an, die vom Microsoft OLE DB-Provider für Oracle benötigt werden.

Option | Beschreibung
Servername | Geben Sie den Server ein, auf dem sich die Datenbank befindet, auf die Sie zugreifen möchten.
Benutzername | Geben Sie den Benutzernamen ein, der zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kennwort | Geben Sie das Kennwort ein, das zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kein Kennwort | Ermöglicht es dem angegebenen Provider, in der Verbindungszeichenfolge eine leere Zeichenfolge als Kennwort zurückzugeben.
Speichern des Kennworts zulassen | Ermöglicht das Speichern des Kennwortes zusammen mit der Verbindungszeichenfolge. Ob das Kennwort in die Verbindungszeichenfolge integriert wird, hängt von den Funktionen der aufrufenden Anwendung ab. Anmerkung Beim Speichern wird das Kennwort unverborgen und unverschlüsselt zurückgegeben und gespeichert.
Verbindung testen | Klicken Sie auf diese Schaltfläche, um zu versuchen, eine Verbindung zur angegebenen Datenquelle herzustellen. Wenn die Verbindung fehlschlägt, sollten Sie prüfen, ob die Einstellungen richtig sind. Ursache für eine fehlgeschlagene Verbindung können z. B. Schreibfehler oder eine falsche Groß/Kleinschreibung sein.

Anmerkung Weitere Informationen zu Datenverknüpfungsverbindungen finden Sie in der Data Link API Reference.


Registerkarte “Verbindung” für SQL Server

Verwenden Sie die Registerkarte Verbindung, um festzulegen, wie eine Verbindung zu Daten von Microsoft SQL Server hergestellt wird.

Diese Registerkarte ist providerspezifisch und zeigt nur die Verbindungseigenschaften an, die vom OLE DB-Provider für Microsoft SQL Server benötigt werden.

Option | Beschreibung
Servername | Wählen Sie in der Dropdownliste einen Server aus, oder geben Sie den Ort des Servers ein, auf dem sich die gewünschte Datenbank befindet. Die Auswahl der Datenbank auf dem Server ist ein separater Schritt. Klicken Sie auf Aktualisieren, um die Liste zu aktualisieren.
Integrierte Sicherheit von Windows NT verwenden | Klicken Sie auf diese Option, damit der Provider eine sichere (oder vertraute) Verbindung zu einem Computer mit SQL Server anfordert, auf dem Microsoft Windows NT ausgeführt wird. Bei aktivierter Option verwendet SQL Server die integrierte Anmeldungssicherheit, um Verbindungen mit dieser Datenquelle herzustellen, und zwar unabhängig vom aktuellen Ameldungssicherheitsmodus auf dem Server. Angegebene Login-IDs oder Kennwörter werden ignoriert. Der SQL Server-Systemadministrator muss Ihre Microsoft Windows-Netzwerk-ID mit einer SQL Server-Login-ID verknüpft haben.
Spezifischen Benutzernamen und Kennwort verwenden | Klicken Sie auf diese Option, um einen angegebenen Benutzernamen und ein angegebenes Kennwort für die Authentifizierung der Anmeldeinformationen für die Datenquelle zu verwenden.
Benutzername | Geben Sie den Benutzernamen ein, der zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kennwort | Geben Sie das Kennwort ein, das zur Authentifizierung verwendet werden soll, wenn Sie sich bei der Datenquelle anmelden.
Kein Kennwort | Ermöglicht es dem angegebenen Provider, in der Verbindungszeichenfolge eine leere Zeichenfolge als Kennwort zurückzugeben.
Speichern des Kennworts zulassen Ermöglicht das Speichern des Kennwortes zusammen mit der Verbindungszeichenfolge. Ob das Kennwort in die Verbindungszeichenfolge integriert wird, hängt von den Funktionen der aufrufenden Anwendung ab.

Anmerkung Beim Speichern wird das Kennwort unverborgen und unverschlüsselt zurückgegeben und gespeichert.
Datenbank auswählen Verwenden Sie eine der folgenden Methoden:
  1. Geben Sie den Namen der Datenbank ein, auf die Sie zugreifen möchten.

  2. Fügen Sie für SQL Server 7.0 eine SQL-Datenbankdatei als Datenbanknamen an. Geben Sie den Datenbanknamen ein, der für die angefügte SQL-Datenbankdatei verwendet werden soll.

  3. Geben Sie für SQL Server, Version 6.5 und früher, den anzufügenden Datenbankdateinamen ein. Geben Sie anschließend den Namen der Einzeldatei-Datenbankdatei ein. Um nach der Datei zu suchen, klicken Sie auf die Schaltfläche mit den drei Punkten.
Verbindung testen | Klicken Sie auf diese Schaltfläche, um zu versuchen, eine Verbindung zur angegebenen Datenquelle herzustellen. Wenn die Verbindung fehlschlägt, sollten Sie prüfen, ob die Einstellungen richtig sind. Ursache für eine fehlgeschlagene Verbindung können z. B. Schreibfehler oder eine falsche Groß/Kleinschreibung sein.

Anmerkung Weitere Informationen zu Datenverknüpfungsverbindungen finden Sie in der Data Link API Reference.


Data Link API Reference

Weitere Informationen über die Datenverknüpfungs-API finden Sie auf der Website msdn.microsoft.com. (Öffnen Sie MSDN Library Online und dann Plattform-SDK, um nach Microsoft Data Access SDK zu suchen; dieses Handbuch enthält die Data Link API Reference.)


Dialogfeld “Eigenschaftswert bearbeiten”

Verwenden Sie das Dialogfeld Eigenschaftswert bearbeiten, um die OLE DB-Initialisierungseigenschaft zu bearbeiten, die derzeit auf der Registerkarte Alle ausgewählt ist. Die Eigenschaften unterscheiden sich je nach dem verwendeten OLE DB-Provider.

Anmerkung Weitere Informationen zu providerspezifischen Eigenschaften finden Sie in der mit Ihrem OLE DB-Provider mitgelieferten Dokumentation.

Option | Beschreibung
Eigenschaftsbeschreibung | Zeigt die Beschreibung der ausgewählten Eigenschaft an.
Eigenschaftswert | Wählen Sie einen gültigen Wert aus.
Wert zurücksetzen | Setzt den Wert der ausgewählten Eigenschaft auf den OLE DB-Provider-Standardwert zurück.