Subject: Choosing a prefix

From: [email-masked] (Don Yacktman)
Date: Tue, 14 Sep 1993 15:39:54 -0600

One thing that needs to be decided upon is a prefix to add
to all the objects' names.  Currently, the prefix I have
been using is "DAY", derived from my initials.  Since I am
no longer to be the sole contributor, this must change to
something more general, but it must mot be so general that
it conflicts with stuff already in existence.  The obvious
prefix, "MK" for MiscKit, is already in use by the MusicKit.
Here are some suggestions that have been sent to me.  If
there is one that you really like, or you have a different
one you'd like to recommend, speak now or forever hold
your peace.  To avoid flooding the list, why don't we
just take votes on a prefix.  The simplest way to handle
this is to (1) send any suggestions for new prefixes to
the misckit list, (2) send your votes directly to me as
[email-masked], and (3) if you want to change a
vote (if some better prefix comes along or you have a
change of heart) let me know explicitly that you are
changing your vote.  Only one vote per person, please,
if you do send multiple votes, I'll accept the most recent.
Over the next week or so I'll post vote results periodically
until we've seemd to come to some sort of a consensus.
I doubt there will be a majority, so simply the prefix
with the most votes wins.

Here's the current contenders:

Contributed by David Lehn:
MO	Misc Objects
MKO	Misc Kit Objects
MKL	Misc Kit Library
NFO	Neat Foundation Objects
FOO	Foundation Objects Organization
FUN	Foundation Under NeXT
PLO	People's Little Objects
BOZ	Better Object Zoo
Or how about just DAY because most people could care less
if you use your name...  you should get credit for starting
it off/coordination/admin/everything else!!

[ed note:  I'd rather not use DAY because it seems too
egotistical for a public kit, and it's just "not me".
Besides, some of the less serious names above really tickle
my fancy... :-)  ]

Contributed by Sam Streeper:
FOO

Contributed by Christian Ratliff
CSNkit  (prefix CSN)
csnKit  (prefix csn)
.since it is really going to be a product of the USENET/csn
community.

Contributed by David Apfelbaum:
00	...since zeroes come first in an alphabetical
	listing... ;-)
pd	for public domain?
OOpd	Object oriented public domain

[ed note:  as per the current licensing questions, which I
will get around to replying to after a bit more thought, the
current kit is not PD, since there is an owner (me, right now).
Of course, if the group feels that the license issue is too
much bother and would rather go straight PD, that _is_ a
possibility.  I'm not sure if it really matters a whole lot in
the long run...]

Well, those are the suggestions I was able to dredge up quickly
from my e-mail archives.  If I've missed any, or you have other
ideas, do be sure to post then to the misckit list so everyone
gets a chance to consider them.

Later,
-don

---

From: Ken McGlothlen <[email-masked]>
Date: Wed, 15 Sep 1993 01:08:52 -0700

[email-masked]  (Don Yacktman) writes:

| One thing that needs to be decided upon is a prefix to add to all the
| objects' names.  [...]

Some time ago, I suggested "HAC", mainly because "HACKit" had a nice ring.

I'm pressed for an acronym, though.  Human-Assisted Coding?  Heterogenous
Appkit Complements?  Heuristically Analyzed Components?  Handy Additional
Creations?

I also considered

	UFO	User-Forged Objects

but that sounded bland in comparison.

				---Ken McGlothlen
				   [email-masked]
				   [email-masked]