Introducción

TextEd versión 3

Introducción

TextEd es un editor, no es un procesador de texto. Esta primera frase era necesaria para explicar completamente qué es TextEd. Algunos usuarios se han acostumbrado a usar procesadores y TextEd será bastante pobre desde su punto de vista. Por otra parte, muchos usuarios usan editores y espero que TextEd les ofrezca placer en su trabajo diario.

¿Por qué un editor y no un procesador de texto?

Los editores están hechos para manejar texto, no documentos complejos y en esa tarea son realmente rápidos, en parte porque son pequeños y rápidos cargando, en parte porque no tienen funciones de control complejas y objetos que manipulen montones de cosas como tablas de texto, formateos, correctores ortográficos y otras sofisticados elementos que usan un montón de tiempo del procesador y memoria. Cuando usted necesita una escritura o edición rápida, lo más rápido y más fácil es usar un editor.

¿Por qué TextEd?

Windows ofrece un editor llamado "Bloc de Notas" con la instalación de Windows que todos nosotros conocemos al dedillo. También conocemos cómo es de pobre y limitado. Por consiguiente, un montón de programadores han resuelto escribir sus propios editores para mejorar las deficiencias del Bloc de Notas estándar. Desafortunadamente, el 90 % ha fracasado al no mostrar avances cruciales.
TextEd no es el único que es ilimitado y gratuito. Está entre los que ofrecen una excelente relación entre potencia/facilidad de uso y ciertamente está entre los muy pocos que le dan total control sobre el texto, la edición y el envío por correo.
Además, es el único del mercado que puede ser encontrado en forma de DLL, en condiciones de ser usado por los desarrolladores de software en sus propias aplicaciones.

Y como mejor característica, TextEd es gratis en la completa acepción de la palabra "gratis".
Usted lo puede instalarlo dondequiera que desee, dárselo a quienquiera a usted le parezca, usarlo en los propósitos que quiera. No solicitamos registro, aunque su e-mail, o cualquier clase de datos, alias o informes serian apreciados.
Si le gusta, tiene sugerencias, críticas, etc., estaremos felices de recibirlas. Su contribución en esta materia mejorará en gran manera las futuras versiones de TextEd.


 Interfaz de usuario

La pantalla principal TextEd consta de menú, barra de herramientas, cuaderno de apuntes tabulado y barra de información.

El menú tiene todas las opciones disponibles en TextEd con accesos directos de teclado. Estos accesos son accesos directos estándar de Windows excepto aquellos que hay en TextEd y que no existen en Windows.

La barra de herramientas contiene botones que representan la mayoría de funciones comúnmente usadas. Si usted encuentra que la barra de herramientas ocupa mucho espacio, la puede esconder. La barra de herramientas no es necesaria para un funcionamiento correcto.

El cuaderno de apuntes tabulado contiene el editor en sí mismo. Puede contener sobre 2 billones de editores con contenidos diferentes. Permite la edición de múltiples archivos a la misma vez. Cada etiqueta contiene un icono que cambia para mostrar si el texto es modificado o no y el nombre de archivo del texto actual.

La barra de información contiene varios paneles utilizables. La primera parte muestra la línea actual, la columna y la posición del carácter para posibilitar una navegación fácil a través de texto. La segundo parte muestra si el texto actual está modificado o no. Los paneles CAPS, INS y SCR muestran si están las Mayúsculas Bloqueadas (CAPS) o si está activado el Bloqueo de Desplazamiento (SCR), así como también si el texto está en Modo Insertar (INS) o en Modo Sobrescribir (OVR).


 Preferencias

Configuración SMPT y e-mail

La configuración del servidor es bastante sencilla. Coloque los datos del servidor en los campos apropiados. Si usted no sabe su configuración de servidor SMTP, entonces cópielos de su cliente de correo predeterminado o pregunte a su Proveedor/Administrador de Servicios.

Sigue la parte "Mostrar":
  • "De: nombre" será el nombre mostrado para cualquiera que reciba su mensaje (ej. John Smith).
  • "De: dirección" será la dirección de correo electrónico que el receptor del mensaje y su remitente automático de correo verá.
  • "Archivo de firma" es cualquier archivo de texto cuyos contenidos serán agregados al final de su mensaje como su firma.
Configuración Editor

Botones:
  • Botón fuente: Cambia la fuente predeterminada para TextEd, su tamaño, estilo y color
  • Botón color: Cambia el color de fondo de TextEd
  • Botón limpieza: Quitará todos los archivos recientemente abiertos (limpia el menú "Reabrir")
  • Botón puente: Puede establecer las extensiones de archivo (tipos) que aparecerán en los diálogos de Abrir y Guardar
Marcado Habilitar Menú estilo XP, cambiará la apariencia de todos los menús al "fino" estilo XP. Al quitar la marca, se devolverá la apariencia del menú al predeterminado de Windows. Algunas veces, la apariencia XP puede interferir con algunas tarjetas VGA y el menú se verá mal. En este caso, vuelva al estilo estándar.

Sangrar espacios en "Formatear en Párrafo" añadirá el número deseado de espacios antes de la primera palabra de la frase cuando "Formatear en Párrafo", del menú "Formato", esté pulsado.
Valor por defecto: 3

El número de milímetros en el Margen Izq. impresora determinará el margen izquierdo (en milímetros) cuando el texto es impreso. Consecuentemente, el ajuste derecho del margen de la impresora presentará el punto, en milímetros, dónde el texto se desplazará en el papel.

Abrir el nuevo fichero al final controla donde situar el cursor tras la apertura de un nuevo archivo. Si está marcado, el cursor automáticamente irá al final del archivo. Si no está marcado, se quedará al principio del archivo.

Asociaciones de ficheros

TextEd le ofrece ser el visualizador predeterminado de unos cuantos tipos de archivo. El tipo predeterminado (extensión de archivo) para TextEd es TXT. Usted puede escoger otros de la lista o puede añadir un tipo nuevo por usted mismo.
A seleccionar un tipo, cuándo en este archivo se haga doble click, TextEd se abrirá por defecto y lo cargará.

Auto Actualización

Aquí puede especificar cómo debe comprobar TextEd la existencia de nuevas versiones. Si está marcado Comprobrar automáticamente las actualizaciones, TextEd automáticamente tratará de descargar la nueva versión de programa, si hay alguna disponible.
También puede especificar el proxy que TextEd debe usar durante este proceso.


 Funciones no-estándar del menú Archivo

Nuevo (Ctrl+N)

Ésta es una función estándar pero trabaja de una forma ligeramente no-estándar.
Cuando TextEd arranca, por defecto, abre una etiqueta con el editor. El archivo es llamado "Sintítulo". Éste es un archivo de memoria predeterminado. Al pulsar el botón "Nuevo" no se abrirá una nueva etiqueta con otro "Sintítulo".
Esto ocurre porque "Sintítulo" es ya un nuevo archivo. Tan pronto como usted escriba una letra en él, al pulsar el botón "Nuevo" se abrirá un nuevo archivo vacío, "Sintítulo". La diferencia entre estos dos casos es que en el primero, el texto no fue modificado y en el segundo caso sí lo fue.

Reabrir

Reabrir es usado para una rápido acceso a los archivos recientes.
Al ejecutar TextEd por primera vez tendrá el menú Reabrir bloqueado al estar vacío. Cuando abra cualquier archivo, Reabrir será cargado con un acceso directo a ese archivo. Pueden manejarse los últimos 10 archivos.

Cerrar (Ctrl + F4)

Cerrar cerrará el actual archivo activo. Si hay un único archivo abierto, entonces lo quitará y colocará un "Sintítulo" tal como TextEd estaba cuando fue abierto por primera vez.
Preguntará para guardar si el archivo fue modificado.

Cerrar todas las páginas (Shift+ Ctrl + F4)

Cerrar todas las páginas cerrará todos los archivos abiertos advirtiéndole para guardar los cambios en cada archivo que haya sido modificado.

Renovar desde Disco (F4)

Recargará el archivo desde el disco. Si se ha hecho cualquier modificación, avisará para confirmar.

Enviar por e-mail

Copiará el texto entero del editor activo y lo pondrá dentro del Mailer (remitente de correo)

Guardar Todo

Guardar todo guardará todos los textos abiertos y modificados

Añadir a fichero

Añadir a fichero abrirá un diálogo para escoger el archivo que usted quiera anexar. El diálogo de aviso aparecerá y después de su confirmación, el texto activo será añadido y guardado al final del archivo seleccionado.


 Menú Editar (sólo relacionadas las funciones no-estándar)

Deshacer/Rehacer

Deshacer (Ctrl + Z), devolverá una acción anterior, mientras Rehacer (Ctrl + R) devolverá la acción que fue deshecha con Deshacer. Un clic ocasionará una acción hacia atrás o hacia adelante.
Deshacer/Rehacer tiene un límite de 99 acciones, hasta que el texto es guardado. Al guardarse el texto, la lista deshacer/rehacer es despejada.

Nota importante:
Al operar desde el diálogo de "Buscar y Reemplazar", hay sólo UN paso para deshacer y Rehacer no funciona.
Deshacer devolverá texto al estado en que estaba antes de que el diálogo "Buscar y Reemplazar" realizase cualquier acción y la lista de Deshacer está vacia.
Gracias a este comportamiento, el reemplazo y las acciones avanzadas de reemplazo son aceleradas por encima de, aproximadamente, 30 (treinta) veces.

Borrar línea actual

Borrar línea actual (Ctrl + Y) despejará una línea en la posición del cursor. No quitará una frase, sólo una línea independientemente de que la función "Desplazar Palabras" esté activada o no.

Limpiar texto

Limpiar texto (Shift+Del) quitará el texto completo de la pantalla y también de la memoria.
Un diálogo de Advertencia/Confirmación es mostrado al no funcionar Deshacer aquí. Esto está hecho con el propósito de descargar la memoria ocupada, quitar texto y posibilitar la escritura de un nuevo texto en el archivo (si previamente se abrió o guardó).

Saltar a línea

Saltar a línea abrirá una caja de edición para ingresar el número de la línea a la que usted quiere que TextEd salte. Siempre saltará al primer carácter de la línea seleccionada. El control de la línea puede verse en barra de estado.

Buscar y Reemplazar

Abrirá el diálogo "Buscar y Reemplazar" (Ctrl + F). No importar si usted quiere sólo buscar o hacer simples reemplazos o borrados, el mismo diálogo aparecerá.

Preferencias

En el diálogo "Preferencias", puede ver o cambiar varias opciones de TextEd.


 Funciones no-estándar del menú Ver

Lista Para Hacer

"Lista Para Hacer" es una lista de características que a usted u otras personas le gustaría ver incluido en futuras versiones de TextEd.

Minimizar a bandeja de sistema

La opción Minimizar a bandeja de sistema pondrá a TextEd en la bandeja de sistema cuando sea cerrado. TextEd residirá en memoria, pero fuera del Escritorio. Si esta opción está marcada, la única forma de cerrar TextEd será hacer clic derecho en el icono de la bandeja y seleccionar "Cerrar". Esta opción es útil si TextEd es usado frecuentemente. En este modo, TextEd guarda los textos en él, pero no consume mucha memoria porque todos los textos ya están guardados en la memoria virtual de Windows.
TextEd recuerda esta configuración. Una vez puesta estará funcionando hasta que sea quitada, aunque TextEd esté cerrado.

Modo Experto

El modo experto esconderá la barra de herramientas, dejando más espacio para el editor. Es útil si usted tiene un monitor de baja resolución (digamos 14 " en modo 800x600 o menos) y usted necesita cada milímetro de espacio. TextEd recuerda esta configuración.

* El modo experto no funciona con el Mailer.


 Menú Formato

Mayúscula

Mayúscula cambiará todo el texto (o el seleccionado) a letra MAYUSCULA.

Minúscula

Minúscula cambiará todo el texto (o el seleccionado) a letra minúscula.

Iniciales

Iniciales cambiará todo el texto (o el seleccionado) en Iniciales, que quiere decir que la primera letra de todas las palabras estará en letra mayúscula mientras que las demás letras estarán en letra minúscula.

Al Contrario

Al Contrario invertirá el tipo de letra en todo el texto (o en el seleccionado) (ej. TextEd se convertirá en tEXTeD).

Formatear en Párrafo

Formatear en Párrafo añadirá un número de áreas de sangrado (determinado en Preferencias) al comienzo de cada párrafo. También le quitará todos los dobles "Enters" (Retorno de Carro) en uno simple, así el texto tendrá la apariencia que deben tener los documentos.

Formatear en Párrafo Real

Formatear en Párrafo Real va a realizar un "parrafada" real en el sentido del ordenador. No insertará ningún sangrado pero quitará todos los doble "Enters" en uno sólo.
Esto es útil para software DTP como QuarkXPress, PageMill o similares ya que estos programas tienen normas de formato de texto y sangrado en sus hojas predefinidas de estilo.

Extraer e-mails

Extraer e-mails extraerá cualquier dirección de correo electrónico válida dentro de un texto (si las hay) y creará una nueva etiqueta en el editor con la lista de emails.

Desplazar Palabras

Desplazar Palabras, si está marcado, partirá las líneas al final de la superficie de edición.


 Menú Herramientas

Enviar contenidos al Navegador Web (F9) copia los contenidos del texto activo en un archivo temporal HTML y lanza el navegador web para previsualizarlo. Es muy útil si escribe páginas web u otro documento, los cuales le gustaría ver en su navegador web.

Encriptación y Desencriptación necesita una contraseña de bloqueo con la que el texto base será encriptado o desencriptado. Para descifrar el texto correctamente, la contraseña de bloqueo debe ser la misma.
El proceso de Desencriptado no le notificará si la contraseña de bloqueo es diferente a la que encriptó el texto, sólo lo hará. En ese caso, el texto será re-encriptado, convirtiéndolo en una basura binaria inutilizable (el proceso de recuperación necesitaria encriptarlo con la contraseña errónea que ha usado para descifrarlo, y después desencriptarlo con la contraseña correcta, pero no hay garantías de que funcione).

Cuando el texto está encriptado, TextEd lo marcará como "Solo lectura" no permitiendo cambiar nada de él, excepto para guardarlo.

La encriptación usa un algoritmo "BlowFish" 448-bit. Su contraseña de bloqueo no es una llave real sino una parte del proceso que construye la llave. Su texto será medianamente seguro, pero no in-crackeable. Si los expertos en encriptación quieren realmente descifrar el código para leer su mensaje, lo harán. Esté absolutamente convencido. En caso de que usted necesite un producto de seguridad real, pida más información acerca de nuestro producto aún en desarrollo: VGS (Very Good Security)

*** El método de encriptación que TextEd usa NO está pensado para el uso gubernamental, militar o de corporaciones secretas o para otras informaciones de alta clasificación.

La Codificación/Decodificación MIME es un nombre nuevo para Base64 que es usado por muchos remitentes automáticos de correo y navegadores de Internet para transferir archivos. La codificación MIME usa un algoritmo para convertir bytes que están fuera de un rango de carácter (no de A..Z, a..z y 0-9) y convertirlos en texto puro. Aunque se parece a la encriptación, no lo es, así es que no lo use de esa manera. Puede usarse para codificar un archivo y enviarlo como mensaje para un correo electrónico.


 Diálogo de Buscar y Reemplazar

El diálogo consta de dos (o tres en el modo avanzado) paneles. El panel Buscar (marcado con la "A"), el panel Reemplazar (marcado con la "B") y en el modo avanzado, el panel adicional marcado con la "C".
Estas marcas son necesarias para el modo avanzado, para entender qué va con qué.
Los paneles Buscar (A) y Reemplazar (B) recuerdan las últimas entradas. Estas entradas son quitadas cuando usted cierra la aplicación TextEd.

Búsqueda/Reemplazo estándar

Opciones de búsqueda:
  • Sensible a Máyúsculas/Minúsculas - realiza la búsqueda sólo de las palabras con el tipo de letra exacto
  • Sólo palabras enteras - busca palabras enteras, no parciales
Origen:
  • Inicio de documento - realiza la búsqueda desde el principio del texto
  • Posición de cursor - realiza la búsqueda empezando desde la actual posición de cursor
Caracter especial:

Carácter especial incluye el cambio de línea CRLF, sólo el salto "Enter" [CR], sólo el cambio línea [LF] y el carácter Tabulador TAB]. Estos códigos existen y en su estado actual es imposible introducirlos en los paneles de buscar y reemplazar con el teclado.
Dependiendo de qué control está establecido en ese momento (panel Buscar o panel Reemplazar), cuándo algún carácter especial es seleccionado, será agregado automáticamente en la caja establecida.
Por ejemplo, si usted quiere buscar la palabra "día." que está al final de una frase, buscará "día.[CRLF] ". Así no habrá ninguna confusión con una palabra "día." que no es el final exacto de una frase tras la cual no viene una nueva línea.

Clase de reemplazo:

  • Reemplazo estándar - muestra el panel de diálogo como está (predeterminado)
  • Procesos avanzados - expande el panel de diálogo haciendo disponibles las funciones avanzadas
Como usar el reemplazo estándar:

Si desea encontrar cierta palabra o expresión, necesita introducirla en la caja de búsqueda (A). Para encontrar la primera coincidencia necesita que el botón "Buscar" sea pulsado (el botón predeterminado es "ENTER"). Cuando la palabra/frase es encontrada, debe usar el botón "Buscar Siguiente" (F3).
La búsqueda del texto sucede simultáneamente así es que puede ver los resultados directamente en el editor aun mientras el diálogo es mostrado. El diálogo recuerda la última posición así que usted puede moverlo donde quiera para no molestarle mientras ve lo que lo que ocurre en el texto.

Nota: Si alguna frase o el bloque está seleccionada en el editor, todas las funciones del Reemplazo Estándar funcionarán dentro de esa frase/bloque seleccionado. Si no hay nada seleccionado, la operación es aplicada al texto entero.

Si desea realizar un único/múltiple reemplazo de una palabra con otra, introduzca la palabra a ser reemplazada en la caja de Buscar (A) y la palabra que la reemplazará en la caja Reemplazar (B). Pulse el botón "Reemplazar". Se buscará la primera coincidencia de la palabra deseada y la reemplazará. Puede seguir pulsando para reemplazar las siguientes coincidencias.
Si desea reemplazar todas las coincidencias, pulse el botón "Reemplazar Todo".

Nota: Sólo se puede Deshacer en el diálogo Buscar y Reemplazar una única vez, y se devolverá el texto a la condición en que estaba antes de que el diálogo Buscar y Reemplazar fuera abierto.


 Funciones Avanzadas de Buscar Y Reemplazar

Cuándo seleccione Procesos avanzados en el botón "Clase de reemplazo" advertirá, además de que el diálogo ha sido expandido, que "Sensible a May./Min." se activa y no puede desactivarse. Esto es necesario porque la funciones avanzadas operan como una función Sensible a Mayúsculas y Minúsculas, haciendo los ajustes de texto más precisos.
Usted debe olvidarse ahora de lo que está escrito en la cajas de lista/edición. Recuerde que la primera caja es A, la segunda B y la adicional es C.

Por favor, tenga en cuenta que, cuando se trabaja con textos grandes (sobre 1 MB), los reemplazos avanzados pueden ir lentos, dependiendo de la complejidad de la operación. Lo hemos optimizado para mejorar de velocidad en un 1530 % (15.3 veces) con respecto a la versión versión 2.1, pero no es sorprendente que en máquinas lentas, el proceso tarde 20 segundos o más.

Extraer texto entre A y B

Esta función extraerá todo el texto en todas las coincidencias que estén entre las palabras/frases que usted ponga en la caja A (Buscar) y la caja B (Reemplazar) y los pone en un archivo separado de texto que se abrirá automáticamente en el editor si se produce alguna extracción.

Ejemplo: quiere extraer todo el texto entre las palabras DIA Y NOCHE en la siguiente frase:
"Cuando el DIA viene y la NOCHE se vá. Me gusta el DIA más que la NOCHE."

El texto extraído parecerá como sigue:
viene y la

más que la

Reemplazar texto entre A y B con C, INC
(inclusivo)

Esta función reemplazará todas las coincidencias de un texto que están entre la palabra/frase que usted pone en la caja A y la palabra/frase que usted pone en la caja B, con la palabra/frase que está dentro de la caja C, INCLUYENDO las palabras/frases que están en la caja A y la caja B.

Ejemplo: desea reemplazar todo lo que esté entre "+" y "-" con "HOLA" en un texto
"Caja + 20 botellas - botella de Coca Cola
+ 10 botellas - vino"

Resultado:
"Caja HOLA botella de Coca Cola
HOLA vino"

Reemplazar texto entre A y B con C, EXC
(exclusivo)

Igual que el de arriba, excepto que las palabras/frases de las cajas A y B quedan intactas - no son borradas o reemplazadas.

Convertir códigos escape de cadena en códigos escape

Esta función reemplazará todos los códigos de escape representados como cadena en códigos de escape.
Por ejemplo, \r\n serán reemplazados con [CRLF] (invisible).
Vea la tabla de códigos de escape de cadena. La función reemplaza el código de escape a su valor.

Carácter | Valor | Constante | Descripción
\a | #7 | BELL | Bell
\b | #8 | BACKSPACE | Backspace
\f | #12 | FF | Form Feed
\n | #10 | LF | Line Feed
\r | #13 | CR | Carrage Return
\t | #9 | TAB | Tabulator
\v | #11 | VT | Vertical Tabulator

Quitar códigos HTML

Esta función suprimirá todos los comandos HTML. Es útil para limpiar un archivo fuente de página web para poder leer el texto que está escrito más claramente.
La función actualmente, realiza las funciones "Inclusivas", retirando todo el texto que está entre "<" y ">".

Reemplazar en todos los documentos abiertos

Esta función reemplazará el texto no sólo en el documento activo, sino también en todos los abiertos.
Tenga en cuenta que cuando use esta función la opción Deshacer no estará disponible.


 Teclas de acceso rápido

La función Teclas de acceso rápido sirve como ayuda adicional y agiliza su trabajo. Su funcionamiento es una combinación de portapapeles múltiple y plantillas.
Cualquier texto en pantalla puede ser seleccionado y almacenado en las teclas 0-9. Más tarde podemos insertar ese texto en el editor. Esto se asemeja al "funcionamiento del portapapeles". Y digo que tiene elementos de "comportamiento de plantilla" porque los valores almacenados no se pierden cuando cerramos TextEd.
Es importante recordar que sólo las teclas 1,2,3,4,5,6,7,8,9 y 0 del TECLADO pueden usarse. La teclas de la parte NUMÉRICA de un teclado no funcionan.

Como usarlo:

En el siguiente texto, cuando digo TECLA, sólo me refiero a las teclas del 0-9.

  • Para almacenar un texto, use Ctrl+Shift+TECLA
  • Para insertar un texto en pantalla, use Ctrl+TECLA
  • Para borrar una TECLA, no debe estar seleccionado ningún texto y pulsado Ctrl+Shift+TECLA. El diálogo de confirmación será mostrado. Actualmente no almacena ' nada ' en una tecla seleccionada.
Los datos de las teclas de acceso rápido son almacenados en el archivo "qclip.dat". Al perder este archivo, los valores almacenados serán borrados. Se puede usar este método para borrar todas las teclas a la vez. Cuando TextEd es cargado, el archivo es creado de nuevo.

CUIDADO: Los valores de texto para estas 10 teclas se guardan en la memoria. No son cargados bajo demanda. Si usted almacena 10 textos grandes, todos serán cargados en la memoria cuando TextEd se inicie. Windows los manejarán correctamente, usando archivos de página si usted se queda sin RAM, pero puede relentizarse.
(por textos grandes, me refiero a 250 KB o más - usualmente nunca sucederá)


 Notas rápidas

Seguro que muchas veces, durante su trabajo, ha necesitado abrir algún archivo sólo para obtener alguna simple información. Vino a mi mente implementar esto cuando escribía una historia que tenia muchos personajes de los que no podía recordar el nombre, apellidos, origen, etcétera.
Necesitaba mantener siempre este archivo a mano. Esto ya no es necesario. ¡Las notas rápidas han llegado!

Parecido a "Lista Para Hacer", cuando está abierto (Ctrl Shift + Q), exhibe una lista de elementos, tiene una pequeña barra de herramientas (esta vez encima, sólo para ser diferente de la Lista Para Hacer), y una barra de estado debajo que le informa del número de registros de la lista cuyo número está limitado sólo por el espacio de su disco duro.

Las notas rápidas tienen pocos campos: la ID Nota, está la nota predeterminada, la descripción corta y un campo de texto. El campo de texto no es mostrado en la lista y debe ser llamado, o desde el Editor, o con el botón Editar. Debe recordar que SOLO UNA nota puede ser la predeterminada. Esto permite llamarla rápidamente desde el Editor.

Sus múltiple registros pueden convertir las Notas Rápidas en un portapapeles múltiple, pero ésta no es su función primaria. Cuando la nota es marcada como predeterminada, pulsando F12 desde TextEd (en cualquier documento) se lanzará un visualizador, la nota será mostrada y puede ser modificada de inmediato. Para cambiar la nota predeterminada, entre en Notas Rápidas, seleccione la nota deseada, presione el botón Editar y cámbiela a predeterminada marcando la casilla de verificación "predeterminado".


 Lista Para Hacer

La Lista Para Hacer es herramienta muy manejable que puede seguir la pista al trabajo que necesita ser hecho. Ha sido implementado en TextEd desde la versión 3.0.

La Lista Para Hacer consta de una pantalla principal de lista donde todos los elementos son mostrados y ordenados por prioridad. Unas barra de herramientas pequeña en la parte inferior le permite insertar, editar, suprimir y ver elementos.
Todas las opciones están disponibles en un menú emergente, también haciendo doble clic sobre un elemento de la lista se mostrará la descripción igual que si hubiera presionado el botón Ver.

El uso de la Lista Para Hacer es francamente sencillo y no necesita más explicaciones. Puede llamarla con el teclado pulsando Ctrl+Shift+D.


 Mailer de TextEd

Al abrir el remitente automático de correo (mailer), el texto activo en el editor será copiado en él. Si la configuración de su servidor SMTP no está establecida, se abrirá automáticamente las preferencias para que pueda introducir los datos correctos del servidor SMTP.

El DUN (Dial-Up Networking) es automático. Si tiene un acceso permanente a Internet, como ADSL, LAN, etc, nunca aparecerá. Consecuentemente, si usted tiene un modem para acceder a Internet, al intentar enviar correo cuando trabaje sin conexión, se invocará automáticamente la conexión.

El Mailer envía el texto en formato de Txt puro. Es decir, que usted no puede enviar mensajes en formato HTML. Debe recordar que el remitente automático de correo de TextEd es simplemente una herramienta asequible para que rápidamente puede enviar el texto a alguien y no una herramienta del envío automático de correo para usar en todas las condiciones.


Agenda

Al arrancar la primera vez, se abrirá un Asistente de creación de "Agenda". Usted debe crear al menos una Agenda para poder usarlo.
Cuando sea creada la agenda predeterminada, un menú de arbol aparecerá con un contacto vacio. Se sugiere modificar ese contacto, no suprimirlo puesto que una Agenda debe tener, al menos, un contacto en ella.

Ahora usted puede crear otras agendas para guardar sus contactos organizados.
Cada agenda es creada en archivo separado. Ese archivo no es una tabla de base de datos, sino un buffer parecido una tabla con capacidades limitadas de búsqueda y organización.

Usar la Agenda es bastante fácil. Le permite añadir, modificar y suprimir contactos, así como también añadirlos a los campos PARA o CC del remitente automático de correo (Mailer) pulsando el botón apropiado.
Al pulsar en un contacto, se pueden ver sus propiedades abriendo un menú emergente con el botón derecho del ratón.


 Información técnica

El cuaderno de apuntes tabulado puede abrir un MaxInt - 1 número de etiquetas (2,147,483,646), cada uno conteniendo un editor. El editor es de clase RxRichEdit que soporta capacidad de un MaxInt - 1 número de bytes, que son las letras y los carácteres especiales (2,147,483,646 bytes = 2 GB). Eso quiere decir que, virtualmente, TextEd podría abrir a 2 billones de Editores cada uno conteniendo 2 GB de texto. En la práctica, esto no es posible en los ordenadores domésticos actuales porque excede la capacidad de almacenamiento de discos y memorias comunes, pero es para saber que usted no ha preocuparse por número y largo de los archivos.

Cuando, debido al largo de los textos y número de editores se esté a punto de exceder la memoria disponible, el control de memoria es trasmitido a Windows que volcará la mayor parte de la memoria usada a un archivo de página (RAM virtual). El canje está completamente bajo control del Sistema Operativo.
Los usuarios avanzados advertirán que TextEd es mucho más rápido en Windows NT/2000/XP debido a la mucho mejor administración de memoria que la de Windows 95/98/ME.

El editor tiene la configuración de "Texto Puro" establecida en TRUE que quiere decir que no soporta las capacidades de formato RichText, pero lo acelera más que 10 veces.

Actualmente, TextEd puede abrir y ver RichText estándar (RTF) y puede guardarlo, como está o con edición simple, pero no lo puede guardar como otro archivo RTF. Si "Guardar Como..." es invocado, TextEd ofrecerá formatos comunes de texto puro y el archivo RTF será convertido a automáticamente al formato de texto estándar.


Solución de Problemas

Problema:
El menú asoma hasta la mitad. Los elementos de menú son visibles sólo cuando paso el puntero del ratón sobre ellos.

Solución:
Usted opera en un modo de color bajo, 256 colores o menos mientras el mínimo para el menú estilo XP es de 65536 colores (16 bits). Si este no es el caso, la apariencia XP excede las capacidades de su tarjeta VGA.
Debe ir a Preferencias, a la etiqueta de Configuración Editor y quitar la marca de "Habilitar Menú estilo XP". El menú volverá a tener la apariencia estándar de Windows.

Problema:
Uso modem y no estoy conectado. Deseo enviar un correo electrónico o registro pero no aparece el marcado automáticamente.

Solución:
El problema puede deberse a una antigua versión de Windows o a un modem antiguo. No hay ayuda en este caso. Conecte manualmente antes de intentar enviar correos o registros.

Problema:
Cuando TextEd arranca, informa que RASAPI32.DLL falta y se cierra.

Solución:
Rasapi32.dll es parte integral de cualquier SO Windows y es simplemente imposible no tenerlo, excepto si fue borrado.
Debería estar en el directorio
\Windows\System32 o \WINNT\System32 .
Doy por supuesto que el directorio de sistema está definido en el PATH.

Si no hay presencia de este archivo en ningún sitio del ordenador, reinstale el Marcado de Red o cualquier parte de la red que incluya TCP/IP.
Puede hacer esto desde el Panel de Control > Agregar/Borrar programas. Si encuentra ese archivo en alguna otra parte, cópielo en el directorio de sistema y haga lo descrito en el párrafo de abajo.

Si hay presencia de este archivo, abra en modo MS-DOS (MS-DOS prompt) y cámbielo de directorio, por ejemplo, escriba:
C: (o D:)
cd Windows (o Winnt)
cd system32

escriba la siguiente línea:
regsvr32 rasapi32.dll

Si no se puede registrar la DLL por alguna razón, cópiela en el directorio de TextEd.


 Registro

El registro de TextEd no es requerida en ningún sentido. Usted es usuario legal tan sólo por poseer TextEd (no modificado por nadie excepto por Green House multimedia).

Sin embargo, el registro tiene sus ventajas:
  • Será avisado de las actualizaciones de TextEd, así como también de otros productos GH, si usted ha escogido ser informado, por supuesto
  • Puede tener descuentos sobre nuevos productos comerciales
  • Puede convertirse en Beta Tester de los nuevos productos GH lo que puede conducir a significativos descuentos en productos comerciales. Dependiendo de su actividad como probador, usted puede convertirse en un beta-tester oficial y puede ser recompensado con aplicaciones completas libres de cargo
  • Dependiendo del número de usuarios de habla no-inglesa, podemos empezar a traducir productos a su lengua nativa
Nosotros también nos beneficiaremos:
  • Sus comentarios e informes harán nuestros productos mejores