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Animations: Animator Pro
A Virtus WalkThrough Snapshot can be written in Animator Pro format. Animator Pro 
players allow frames to be played in rapid succession, producing an animation. 
Considerations 
How to... 



Considerations
Before you can output a Snapshot to Animator Pro format, you must first record a walk 
path. In the recording stage there are several factors to consider.
The first rule to learn when working with animations is that the files tend to be large. For 
example, a 300-frame file can easily require several megabytes of storage space--even 
with compression. It depends on what the frame-to-frame data is. With this in mind, you 
have to carefully consider what you want to record and how you want to present it.
With most computer graphics processes, there is a trade-off between speed and detail. 
When recording a walk path for a snapshot, you should try to keep the number of frames 
at the minimum required within the constraints of what you are trying to record. For 
example, if you have constructed an office building and your goal is to present the new 
layout of a particular floor, do not start recording outside the building and then walk up 
several flights of stairs to get to the floor you want to present. This could add hundreds 
of unnecessary frames to your recording.
Once you have determined the walk path you wish to record, you must next consider the 
size of steps to take when recording. Each time you move in the Walk View, the screen 
redraws and a frame is recorded. The size of steps is determined by how far off the cross 
hair the pointer is positioned as you walk through your model. The question is should you
take small steps and greatly increase the number of frames recorded? Or should you 
take large steps and end up with fewer frames but a jerky walk path? Or should you vary 
the size of your steps? There is no answer except to experiment.



How to...
Before you can take a snapshot in Animator Pro you must first record a walk path. After 
you have recorded your walk path, save your model. This will save the recorded walk 
path with your model.
In the Animator Pro dialog are options for the snapshot. The first option allows you to 
select a range of frames. The full range, from 1 to X, is the default. 
Another option is Smoothing. Smoothing compares frames and if it finds the difference 
between the frames to be beyond a certain tolerance, it inserts new frames between 
them, thus creating a smoother output. The downside to this is that it can make the file 
size larger; however, depending on how you recorded the walk path, smoothing may 
have no effect.
The Colors option allows you to select a bit depth (range of color) for the output. Color 
adds more realism to a file, but the effect of color on file size is negligible.
Frame size is a very important factor to consider. The larger the frame size of the output, 
the larger the file, but also the higher the resolution. If you make the output frame size 
smaller, the resolution will be less, but the savings in file size will be more. Full screen 
presentations are impressive, but hungry: you have to feed them processor power, 
memory and disk space. There are several standard frame size options to choose from, 
or you may customize your frame size. True Animator format is a frame size of 320x200. 
Any other frame size is considered Animator Pro format. Animator Pro offers better 
compression of file sizes, but you may have a player that can play only Animator files; 
therefore, you may be limited to a 320x200 frame size.
After your walk path is recorded and saved and you have selected your desired Snapshot
options, Virtus WalkThrough will write the walk path in the format you specified. 
Depending on the speed of your machine, the amount of RAM, and the number of frames
in the walk path, this process can take time. Be patient.
If the process fails, the first thing to check is the amount of free disk space. As much of 
the file that can be written will be written, so you should be able to tell if you ran out of 
disk space by the amount of free space left.



Common Problems
This is a the Virtus Corporation Technical Support Department's list of of frequently asked
questions and    answers.
Design View Q&A 
Miscellaneous Q&A 
Walk View Q&A 



Design View Q&A
Why can't I select an object? 
Why can't I add a handle to an object? 
Why can I see some objects in the Walk View but not in the Design View? 
Why don't objects inflate to the depth I set with the left ruler Depth Control? 
Why can't I make the slice exactly where I want it in the Tumble Editor? 



Walk View Q&A
How can I speed up the walk through? 
Why are my Library items floating in the air when I paste them into a model? 
Why can't I see the surface feature I just created? 
Why do colors I pick look different shades in the Walk View? 
Why do objects disappear then reappear between steps? 
Why can't I see anything in the Walk View when the Observer is in the center of the 
objects? 



Miscellaneous Q&A
Why won't my CAD package read the 3D DXF file I exported? 



Short Cuts
Cntrl Key Techniques 
Double-Clicking Techniques 
Shift Key Techniques 



Shift Key Techniques
Hold down the Shift key...
... and rotate an object with the Rotate Object Tool.

Result: Object rotation is constrained to 15° increments.
... and edit an object.

Result: All edits are constrained to vertical, horizontal or 45° 
increments.

... in the Tumble Editor.
Result: Tumbling is constrained to the relative X, Y or Z dimension.



Control Key Techniques
Hold down the Cntrl key...
... and drag a handle.

Result: The objects type is broken.
... and drag a handle.

Result: Only the handle moves. The object stays in place.
... and point to the center of the Observer, then drag in any direction.

Result: The Observers viewing direction changes.
... in the Tumble Editor.

Result: The object and the Orientation Cube become disassociated, thus allowing 
you to tumble faster.
... and drag a slice.

Result: The direction of the slice is reversed.
... and click the Depth Control track (the alley) in a ruler.

Result: The Depth Control is summoned to the position where you clicked.
... when using the Hide Objects Tool.

Result: Objects or surface features are hidden in the Walk View. (Cntrl-double-click 
makes them visible again.)
... and click the Lock Object Tool.

Result: Locked objects or surface features are unlocked.
... and drag from any Dock.

Result: The ruler Origin is pulled to the location of the pointer.



Double-Clicking Techniques
Double-click...
... the Hide Object Tool.

Result: All hidden objects are displayed. (Same as selecting Show All under the Edit 
menu.)
... the Select Object Tool.

Result: All objects are selected. (Same as selecting Select All under the Edit menu.)
... the Lock Object Tool.

Result: All locked objects are unlocked. (Same as selecting Unlock All under the Edit 
menu.)
... the Create N-Sided Object Tool.

Result: The Default Settings dialog box is displayed. (Same as selecting Preferences,
Defaults under the Edit menu or Sides and Levels

under the Modify Selected submenu of the Edit menu.)
... the Rotate Object Tool.

Result: Selected objects are unrotated (same as selecting UnRotate in the Modify 
Selected submenu under the Edit menu).
... the Scale Object Tool.

Result: Selected objects are unscaled. (Same as selecting UnScale in the Modify 
Selected submenu under the Edit menu.)
... the Skew Object Tool.

Result: Selected objects are unskewed. (Same as selecting UnSkew in the Modify 
Selected submenu under the Edit menu.)
... the Lighting Editor Tool.

Result: The World Lighting Editor is displayed.
Double-click...
... an Inflation, Opacity or Placement Modifier.

Result: The inflation, opacity, or placement of the selected object, surface or surface
feature is changed.
... a layer name in the Layer List.

Result: Selected objects are transferred to that layer.
... the Color Bar.

Result: The default color is applied to selected objects, surfaces or surface features.
... the Depth Control in a ruler.

Result: Selected objects inflated along the Depth Controls axis are re-inflated to the 
Depth Control values.
... a surface in the Tumble Editor (or the Orientation Cube) or a surface of the Subject 
Cube in the Lighting Editor.

Result: The surface you double-click faces planar to the view.







Are you using the Select Object Tool? If you have been using different tools, you may 
have forgotten to click on the Select Object Tool before trying to select the object. (See 
Select Object Tool .) 
Are you selecting another object which may be obstructing your view of the desired 
object? A pattern of dots indicates a selected object. If you see a dot pattern, you have 
selected an object, but it might not be the object you wanted. If a dot pattern is visible, 
try hiding the object you have selected with the Hide Object Tool or try selecting the 
desired object from another view.
Is the desired object locked? If the lines representing the objects polygonal outline in the 
Design View are dotted, the object is locked. (See Layer Menu and Lock Object Tool .)



You probably have hidden objects. Objects can be hidden by layer (see Layer menu ) or 
with the Hide Object Tool.



Handles can only be added in the view (or opposite view) in which the object was 
originally drawn. Are you in the correct view? (See Add/Remove Handle Tool .)
Try pulling the handle slightly outward. The program may be interpreting your adding a 
new handle as trying to create a non-convex object. If this is the problem, you can drag 
the handle back to where you want it after it is added.



Because you have to set the Depth Control in a perpendicular view or in the Depth 
Window. The Depth Controls that appear on the left and top rulers of the active Design 
View do not affect what is drawn in that view. (See Depth Controls .)



You probably have Snap to Grid selected. Unselect Snap to Grid under the Tumble menu, 
and try slicing again. Also, you may want to move the Origin to help with your 
measurements. (See Movable Origin .)



Is the "floor" endpoint of the Depth Control set correctly? Look at the "f" reading in the 
Position Indicator. It displays the position of the lower Depth Control endpoint. If the floor 
endpoint is not set correctly, cut the floating object(s), reset the "floor" endpoint, and 
paste the object(s) again. (See Depth Controls . See also Library .)



Do you have many translucent or transparent objects or surfaces in the model? Try 
hiding them with the See In and See Out options in the Preferences, Rendering dialog or 
select Faster or Fastest under the Walk menu.
Do you have many surfaces? Remember, speed and detail are inversely proportional. The
more surfaces you have, the slower your walk speed. Try changing the number of sides 
on multiple-sided objects and try changing the number of levels on objects that are 
inflated rounded.



Is the Observer positioned correctly? Did you select the correct placement and opacity 
for the surface feature?
If the surface feature is between two objects, did you connect the surfaces of the two 
objects with the Connect Surfaces Tool?



Colors are affected by light. Turn off the shading or adjust the lighting. (See Lighting 
Editor and Preferences, Rendering .)



This is usually due to an object overlap problem. Objects should not be drawn such that 
they overlap. Zoom in and closely check how object surfaces match up. If everything 
looks like it lines up, there is a sorting problem. Sometimes when several objects are in 
very close proximity, the program is not sure which object to draw first. If you can, try 
spacing the objects further apart. If you cannot space them without losing the desired 
construction, try building the section of the model differently.



The altitude of the Observer is probably above or below the model. Change views and 
reposition the Observer.



Does your CAD package support 3D DXF? Many do not. If yours does and the file wont 
read in correctly, try using different export options. (See Export .)





Flash Graphics
Flash Graphics is an option in the Preferences, Rendering dialog (under the Edit menu) 
that turns on Virtus Corporation drawing routines instead of the standard Microsoft 
Windows drawing routines and substantially speeds up the Virtus WalkThrough 
application. 
Usually, Flash Graphics is turned on by default; however, some video boards are not 
compatible with Flash Graphics. The Virtus WalkThrough application checks for 
compatibility with your system when you install, and if a conflict is detected, Flash 
Graphics is turned off.
In some cases a conflict may exist and be undetected by Virtus WalkThrough. In such a 
case the results of running Virtus WalkThrough will vary. Windows may be distorted, 
colors may be unusual, random noise may be displayed or other general funkiness might
occur. If you think there is a conflict with your system, you should turn Flash Graphics off 
using one of the following methods.
The first method requires Virtus WalkThrough to be running. If you can access the Virtus 
WalkThrough menus, select Preferences under the Edit menu to open the Preferences 
dialog. Click the arrow next to the word Editor to open the Preferences pop-up menu and 
select Rendering. The Flash Graphics checkbox will be displayed. Click the checkbox to 
turn Flash Graphics off.
The second method requires a text editor (Notepad, for example). If WalkThrough is not 
running or if you cannot select the menus if it is running, use a text editor to open the 
WIN.INI file in the \WINDOWS directory. Look for the following lines in the WIN.INI file:
[Virtus WalkThrough]
FLASH=1
Edit the text to read:
[Virtus WalkThrough]
FLASH=0
Close the file and save the changes.



What Is Virtus WalkThrough
Virtus WalkThrough is a 3D drawing and design package that helps you conceptualize 
and communicate your design ideas.
Virtus WalkThrough helps you conceptualize by allowing you to create environments on 
your desktop computer and then walk through and explore those environments 
interactively. The software provides immediate feedback so you can experiment with 
"what if" scenarios.
Virtus WalkThrough helps you communicate with its real-time drawing capability and by 
offering presentation formats like Autodesk Animator, thus providing the means for 
producing pre-recorded movies.

Virtus WalkThrough Is Not...
Virtus WalkThrough is not a CAD package. Every object in Virtus WalkThrough has depth; 
therefore, it is impossible to draw with traditional line and vector CAD constructs. When 
drawing in Virtus WalkThrough, basic polygons are drawn two dimensionally and then 
inflated into 3D objects. (A polygon is a three or more sided, closed figure bounded by 
straight lines.) 
Virtus WalkThrough is not intended to replace CAD, but to enhance it, as well as other 
types of applications. Virtus WalkThroughs import and export facilities make the package
versatile when working in conjunction with other design and graphics applications. Two-
dimensional as well as three-dimensional views can be integrated into drawing, word 
processing and page layout programs, as well as most CAD packages.
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Document Windows
The Virtus WalkThrough application window contains three kinds of document windows: 
the Tools Window, the Design View(s) and the Walk View.
The Tools Window contains sets of tools for drawing, editing, navigation and display 
aides. Each of the two kinds of views and each editor has its own set of tools which 
appear in the Tools Window depending on which view or editor is active at that time.
The Design View is a two-dimensional area where you draw objects. There are six 
possible Design Views: Front, Back, Top, Bottom, Left and Right. You can draw or edit your
drawings in any of the Design Views. 
The Walk View displays a three-dimensional rendering of objects you draw in a Design 
View. You can walk through and around the objects in the Walk View.
Three Editors which perform specific operations on the objects you draw are accessed in 
the Design Views. The three editors are the Surface Editor, the Tumble Editor and the 
Lighting Editor.
Each view or editor is displayed in a document window which can be resized or 
repositioned. (See your Windows documentation for more on window manipulation and 
standard Windows interface operations.)



Active Window
Only one view or editor window can be the active window (the window you are working 
in) at any time. If you click within the boundaries of any window, it becomes the active 
window. You may also select a view name from the View menu (see View menu ) or select
a window name from the Window menu (see Window menu ) to make different windows 
active.



Title Bar
The Title Bar of a view window displays the name of the view or editor the window is 
associated with.
If a window is active, its Title Bar is highlighted with a darker color. If a window is not 
active, its Title Bar is white or gray.



Navigation Methods
Navigation in your model in the Walk View is determined by your movement of the 
mouse pointer relative to the cross hair in the center of the Walk View window. 

 To increase the speed of your movement, point farther from the cross hair. 
To begin moving, press the mouse button. To stop moving, release the mouse button. 
Direction is determined by the position of the pointer relative to the cross hair. 

 Using a combination of the Control (Ctrl) key or Shift key with the mouse, movements 
resembling tilting your head, sliding from side to side or increasing (rising up) and 
decreasing (sinking down) your altitude are also possible.



Volumetricity: Space Modeling and Containment
When you draw a 2D object in the Design View, it becomes a 3D object in the Walk View. 
Though the object may appear solid in the Walk View, it is actually hollow. Every object 
has an interior space--it is volumetric.
Volumetricity has three considerations you should be aware of. The first consideration of 
volumetricity is space modeling, that is, you are able to use Virtus WalkThrough to model
space itself. Think in terms of space (with infinitely thin walls) defining the environment 
rather than the environment defining the space.
A second consequence of volumetricity is containment. Every object in Virtus 
WalkThrough knows what objects it contains and what object contains it. Containment 
provides you with some important benefits. For example, if you move a container, all 
objects contained within it also move.
In Virtus WalkThrough, containment is an all-or-none state; an object is either fully 
contained within another object or it is distinct from other objects. Objects cannot 
overlap (but they can be joined at a common surface). Unfortunately, it is possible to 
draw overlapping objects, and the program does not warn you if you make this mistake; 
however, the result of overlapping objects is always the same: the three-dimensional 
rendered objects appear twisted and grotesque and sometimes just plain funky.
If you drag a small object into a larger object, a state of containment will exist when the 
mouse pointer reaches the interior of the large object. The program indicates 
containment by displaying small blocks called containment markers at the vertices of the
large object. These markers will disappear when you release the mouse button. The 
figure at the left shows containment markers displayed as a small object is being 
dragged into a large object.
The third consequence of volumetricity is that each object surface has an inside and an 
outside. In Virtus WalkThrough, you can edit the inside or outside of any surface of an 
object to create surface features. Surface features are two-dimensional shapes that can 
be a different color or a different opacity than the object surface. Surface features are 
used to represent doorways, windows, holes and other items. 



Convex Objects
All objects created in Virtus WalkThrough must be convex. Convex is defined as "having a
surface or boundary that curves or bulges outward, as the exterior of a sphere." Virtus 
defines a convex object as an object whose polygonal outline can have a line drawn from
any point on it to any other point on it without the line passing outside the outline 
boundary. 
Even though non-convex objects are not permitted, the effect of a non-convex object can
be achieved by creating more than one convex object, connecting them and then 
creating an opening in the common wall between them. It is important when building a 
model to think in terms of convex space. In other words, divide large complex models 
and objects into smaller simple objects.



Virtus Rules of Drawing
The following five rules are important to creating models and visualization studies 
successfully with Virtus WalkThrough.
1. Do not overlap objects. Overlapped objects are not good. In fact, they are bad. Very 

bad. Do not draw them.
2. Non-convex objects are not allowed. Objects which are non-convex should be created 

by attaching two or more convex objects together. 
3. Speed and detail are inversely proportional; you have to give up one for the other. The

more complex your model (the more polygons it has), the harder your computer has to 
work. The larger your processor, the faster your computer will work.

4. Transparent and translucent (like glass) objects and surfaces drain processing power; 
use them sparingly.

5. Everything is an object in Virtus WalkThrough. You cannot draw a line. All objects 
drawn have depth, even if they appear infinitely thin.



The Virtus World
The Virtus World is a large cube (six sides). Each of the six Design Views corresponds to a
side of the cube (Top, Bottom, Front, Back, Left and Right). 



The Virtus Reference Cube
Included in your software package is the Virtus Reference Cube. It looks like a flat, funky-
shaped piece of paper until you assemble it. Once assembled, the Virtus Reference Cube 
is designed to act as a quick reference for navigation and to help you understand the 
relationship between your 2D, flat screen and the 3D, Virtus World. It's also useful to 
throw at people who annoy you.



Dimensions
When speaking of three-dimensional space, the coordinate system is usually displayed or
discribed in X,Y and Z axes (or planes). Such is the Virtus WalkThrough world. Because 
the Top View is the default view when the program is started, the three dimensions are 
based on the Top View rather than the Front View, as in some other 3D programs.
To demonstrate this, assemble your Virtus Reference Cube (if you haven't already) which 
is included with the Virtus WalkThrough package. Hold it up in front of your face so the T 
(Top View) is facing you. Notice the rulers on the top edge and left edge of the Top View. 
At the bottom of the left ruler is the letter Y. This indicates the left ruler is associated with
the Y dimension. At the right of the top ruler is the letter X. This indicates the top ruler is 
associated with the X dimension. So, when viewing or drawing objects in the Top View 
you are viewing or drawing the XY dimensions of objects.
Now, rotate the Virtus Reference Cube so the F (Front View) is facing you. Like the Top 
View, you will see a ruler on the top edge and left edge of the view. But notice at the 
bottom of the left edge ruler is the letter Z indicating the ruler is associated with the Z 
dimension. The top ruler has not changed and is still associated with the X dimension. 
So, when viewing or drawing objects in the Front View you are viewing or drawing the X-Z
dimensions of objects.
Now, rotate the Virtus Reference Cube so the R (Right View) is facing you. Notice the top 
ruler has changed to Y. So, when viewing or drawing objects in the Right View you are 
viewing or drawing the Y-Z dimensions of objects.
To put it another way:
X is the left/right dimension,
Y is the front/back dimension, 
Z is the top/bottom dimension. 



Object Definition
There are three factors which define the object. The first is the 2D polygonal outline you 
draw in the Design View. The second is the objects location in the 3D world. The third is 
the objects inflation distance (the object depth). The inflation distance is the missing 
third dimension. Given these three elements, the resulting 3D virtual object appears 
immediately in the Walk View.
An object polygonal outline is drawn by you, and where you draw the object outline 
partially determines the object location. The inflation distance, and to some extent the 
object location, is determined in Virtus WalkThrough by a Depth Control which you adjust
before you draw. 



Depth Controls
A Depth Control consists of a gray bar with two black half-arrowheads (called endpoints) 
on each end. The length of the gray bar between the endpoints is the inflation distance 
(the depth). The object location is determined by where you draw the polygonal outline 
and by the location of the Depth Control endpoints in space. 
A Depth Control appears on each ruler in the Design View(s). Take a look at the Top View 
of the Virtus Reference Cube. Look on each ruler and find the Depth Control. Because 
there are three dimensions in Virtus WalkThrough, there are three Depth Controls which 
determine inflation distance and position in the X, Y and Z dimensions. So, if you change 
the X ruler Depth Control in the Top View you are also changing the X ruler Depth Control
in the Front View.
To adjust or change a Depth Control, each endpoint can be dragged to a new location, 
thus stretching or compressing the gray bar. Or, the entire Depth Control can be moved 
by dragging the gray bar.
The direction of the inflation depends on the view in which an object is drawn. For 
example, the inflation of an object drawn in the Front View is not the same as an object 
drawn in the Top View. An object drawn in the Front View is inflated front to back (along 
the Y axis).    An object drawn in the Top View is inflated bottom to top (along the Z axis). 
To demonstrate this, hold the Virtus Reference Cube in front of your face so the F (Front 
View) is facing you. The inflation direction is always the dimension you cannot see in the 
view you are drawing. For example, when you look at the Front View you see the X and Z 
dimensions, but not the Y dimension. So, the Y dimension is the direction of inflation for 
the XZ plane.
Now, rotate the Virtus Reference Cube so the T (Top View) is facing you. Looking at the 
Top View, which dimension is not visible? In the Top View you see the XY dimension, so 
the Z dimension is the direction of inflation.
This is important because the inflation distance must be adjusted before you draw an 
object, and you have to know which ruler contains the Depth Control you need to adjust. 
If you draw an object in the Top View the Depth Controls on the X and Y rulers will have 
no effect on the object inflation. To adjust the inflation for an object drawn in the Top 
View you must adjust the Depth Control on the Z ruler. That means you have to change 
to a perpendicular view, like the Front View, so you are able to make the adjustment.



Base Units
The Virtus 3D world is a cube 65,536 base units across. Virtus WalkThrough allows you to
change the base unit size (See Preferences, Units ) and, therefore, change the relative 
size of the Virtus World.
For example, the default base unit is 1 inch. With a 1 inch base unit, the Virtus World is 
65,536 inches across. If you change the base unit to 1 centimeter, the world becomes 
65,536 centimeters across; since centimeters are smaller than inches, the relative size of
the world is smaller.
You dont necessarily have to change measurement systems when you change the base 
unit. You could just as easily have a .25 inch base unit and make the Virtus World appear 
one fourth the size of the default.    (0.25 inches x 65,536 inches = 16,384 inches.)
Changing the base unit to a smaller size is good because smaller base units cause the 
Walk View to display 3D objects in greater detail than larger base units. Also, because 
Virtus WalkThrough draws objects in the Walk View to the nearest base unit, any surfaces
smaller than the base unit tend to collapse in on themselves, and if you are planning to 
draw very small, detailed objects, you may wish to change the base unit to a smaller 
size. 
However, changing the base unit to a smaller size is not advised if you are drawing very 
large models. For example, if your are drawing several city blocks and you have reduced 
the base unit such that the entire Virtus World is less than one city block, your model will
exceed the boundaries of the Virtus World. 





Walk View Tools
When the Walk View is active, the Walk View Tools are displayed in the Tools window.
The Walk View Tools allow you to change the Walk View background color, adjust the lens
of the Observer and record and play back a walk path. The Tools window can be hidden 
with Tools Window under the Window menu.
Background Color Selector 
Lens Focal Length Tool 
Orientation Cube 
Record, Playback Path 



Background Color Selector
The Color Bar on the top of the Tools window is the Background Color Selector used to 
change the color of the background within the Walk View. 
To change the background color...
... mouse down on the Background Color Selector (Color Bar) to reveal the color selector. 
Drag the mouse to the desired color and release.
If the colors in the color selector do not contain the desired color, drag the mouse to the 
icon in the upper left corner of the color selector and release. This action displays the 
standard Windows Color Palette and Custom Color Selector in one window. (The Color 
Palette and Custom Color Selector are normally displayed in separate windows.)
To select a new color from the Windows Basic Color Palette...
... point to the desired color and click.
To define a custom color...
... point to a shade of color in the color refiner box and click. To the left of the color 
refiner box is the Windows Vertical Luminosity Bar (brightness control). You may slide the
Vertical Luminosity Bar up or down to change the shade of a color, thus creating a 
custom color.
If the color you selected does not look the same shade in the Walk View, it is probably 
due to the effects of lighting. You may wish to adjust the lighting (see Lighting Editor ) or 
turn off the effects of light and shade (see Preferences, Rendering ).



Lens Focal Length Tool
The lens size indicator and the sliding control beneath it are both parts of the Lens Focal 
Length Tool. If the sliding control is moved, the reading in the lens size indicator will 
change to display the new lens focal length. You can also adjust the lens focal length by 
highlighting the numbers in the lens size indicator, typing a new number and pressing 
the Enter/Return key. You must press the Enter/Return key for the change to take effect.
The lens focal length determines the zoom factor of the virtual camera.
A smaller lens size indicates a wider angle lens while a larger lens size indicates a 
telephoto lens.
Focal length is also affected by film size. A larger film size requires a longer focal length 
to maintain the same camera angle. If the focal length does not change and the film size 
increases, the effect is a wide angle lens. If the film size decreases but the focal length 
does not, the effect is a telephoto lens.
Film size is set in the Preferences, Rendering dialog. The default value for film size is a 
35mm still camera.



Orientation
The Orientation Cube shows the orientation of the Observer inside the Virtus world. If any
objects can be seen, the Orientation Cube indicates the side(s) of the objects the 
Observer is facing: F=Front, B=Back, L=Left, R=Right, T=Top, b=bottom.
The Orientation Cube also appears in the Tumble Editor, but has added functionality 
there. (See Tumble Editor .)



Record, Playback Path
As you navigate through a model in the Walk View, you can record and later play back 
the walk path with the Record Tool and Playback Tool. 
The length of a recording is limited only by memory; however, it is unlikely you will run 
out of memory because the requirement is small.
When you save a file, the recorded walk path is saved with it. When you open the file 
again, you can click the play button and view the recording. Only one recorded path can 
be saved with each model. If you record another, the previous path will be erased.
Recording does not take a picture of the screen each time the Observer takes a step; it 
records movement through the Virtus world. This means if you record a walk path and 
then change your model, the playback will follow the same recorded path and you will 
see the changes you made to the model.
To record the walk path...
...click inside the Walk View to make it active then click on the Record Tool . Navigate the 
Observer through the Walk View. (See Navigation Methods .) 
You may also record a path by selecting Record under the Walk menu. This menu option 
is helpful when running in full screen mode or when the Tools window is hidden.
To stop recording...
... click the Stop Tool. The Stop Tool will also stop a playback in progress. 
You may also stop recording by selecting Stop under the Walk menu. This menu option is 
helpful when running in full screen mode or when the Tools window is hidden.
To play back a recording...
... click the Playback Tool. If the playback reaches the end of the recording, it will loop 
automatically and start from the beginning until you click the mouse button anywhere on
the computer screen or click the 
Stop Tool.
You may also play back a recorded path by selecting Play under the Walk menu. This 
menu option is helpful when running in full screen mode or when the Tools window is 
hidden.





Design View Tools
The Design View Tools allow you to create, edit and orient objects and surfaces. Some 
tools have other tools nested beneath them. Nested tools are indicated by a small 
arrowhead to the lower right of a tool.
To select a tool...
... point to the desired tool and click. 
To make a nested tool available...
... mouse down on the tool to reveal the nested tools, drag to the desired tool and 
release the mouse button. 
You can also cycle through the nested tools by selecting a tool, holding down the Ctrl key
and pressing the space bar.
Creating Tools
Creating tools allow you to draw 2D polygonal outlines of basic shapes. When the basic 
shapes are combined together and inflated (see Depth Controls ), complex 3D models 
can be created and rendered in the Walk View. Drawing tools are also used in the Surface
Editor to draw surface features.

 Create 6-Sided Object Tool 

 Create 8-Sided Object Tool 

 Create N-Sided Object Tool 

 Create Irregular Object Tool 

 Create Rectangular Object Tool 

 Create Triangular Object Tool

 Create Square Object Tool 

Editing Tools
Editing tools allow you to manipulate objects you have already drawn and manipulate 
the drawing area of the Design View.

 Add Remove Handle Tool 

 Color Bar



 Color Lifter Tool 

 Connect Surfaces Tool    

 Constrained Zoom Tool    

 Hide Object Tool    

 Lighting Editor Tool    

 Lock Object Tool    

 Rotate Object Tool 

 Scale Object Tool 

 Select Object Tool 

 Skew Object Tool 

 Surface Editor Tool 

 Tape Measure Tool 

 Tumble Editor Tool 

 Zoom In Tool 

 Zoom Out Tool 
Layer List    
Position Indicator

Opacity Modifiers
Opacity modifiers function in the Design Views, the Surface Editor and the Tumble Editor 



and edit the opacity of entire objects, selected object surfaces or surface features. Object
surfaces can be modified in the Tumble Editor or the Surface Editor, and surface features 
can be edited only in the Surface Editor.

 Make Opaque Modifier    

 Make Translucent Modifier 

 Make Transparent Modifier

Inflation Modifiers
The Inflation modifiers determine the inflation type, or shape, of an object. Inflation is the
process of creating a 3D object from a 2D polygonal outline. The distance and the 
direction of object inflation are determined by the Depth Controls. (See Depth Control. 
See also Inflation.)

 Inflate Straight Modifier 

 Inflate Pointed Modifier 

 Inflate Pointed Flip Modifier 

 Inflate Double-Pointed Modifier 

 Inflate Rounded Modifier 

 Inflate Rounded Flip Modifier 

 Inflate Double-Rounded Modifier 



Color Lifter Tool    
The Color Lifter Tool    copies the color of an existing object to the Color Bar . The copied 
color can then be used for the next object drawn or can be transferred to an already 
existing object. (See Color Bar.) This tool allows for consistency with colors in your model.
To copy a color to the Color Bar...
... select the Color Lifter Tool    and click on an object in the Design View. You cannot use 
the Color Lifter on objects in the Walk View.
If a surface of an object has been edited to a different color, the Color Lifter will not copy 
the surface color; it will copy only the color of the whole object.



Tape Measure Tool 
The Tape Measure Tool finds the distance between two points. The distance is displayed 
in the Position Indicator. (See Position Indicator.)
To measure the distance between two points...
... select the tool and point to the location in the active view where you want to measure 
from. Press the mouse button and drag to the location you want to measure to. As you 
drag, a dotted line appears between the starting point and the cursor, and the distance 
and other information is displayed in the Position Indicator. 
The information displayed in the Position Indicator depends on the Tracking option in the 
Preferences, Editor dialog. The two options in the dialog are World and View. If the View 
option is selected, the following information is displayed in the Position Indicator:
h: the horizontal coordinate of the cursor
v: the vertical coordinate of the cursor
h°: the difference between the horizontal coordinate of the cursor and the starting point
v°: the difference between the vertical coordinate of the cursor and the starting point
l: the linear distance or length of the line between the starting point and the cursor
a: the angle of the line between the starting point and the cursor

Right horizontal is 0 degrees.
If the World option is selected, the following information, depending on which Design 
View is active, is displayed in the Position Indicator:
x: the linear distance from 0 on the X axis
y: the linear distance from 0 on the Y axis
z: the linear distance from 0 on the Z axis
x°: the linear distance from the x coordinate of the point where you began dragging
y°: the linear distance from the y coordinate of the point where you began dragging
z°: the linear distance from the z coordinate of the point where you began dragging
l: the linear distance or length of the line between the starting point and the cursor
a: the angle of the line between the starting point and the cursor

Right horizontal is 0 degrees.



Select Object Tool 
The Select Object Tool is used to select and edit objects. The Select Object Tool is used in 
the Design Views, Surface Editor and Tumble Editor. In the editors, the Select Object Tool 
functions differently than in the Design Views.
If you are working with another tool and wish to use the 
Select Object Tool , press the space bar and the Select Object Tool will automatically be 
selected. Press the space bar again to go back to the previously selected tool.
In the Design Views and Surface Editor, the Select Object Tool is used to select, move 
and change the size or shape of objects and surface features.
To select an object or surface feature...
... click the Select Object Tool , point to the object or surface feature and click. Handles 
(blocks at the object vertices) are displayed when an object or surface feature is 
selected.
To select more than one object or surface feature...
... there are two methods. The first is to hold down the Shift key and click each object or 
surface feature you want to select with the Select Object Tool. The second is to point to a
location outside the objects you want to select, drag the Select Object Tool pointer to 
create a box around the objects or surface features (as you drag, a dotted rubber-
banding box will appear) and release the mouse button. 
This selection rectangle method is a standard Windows procedure.
To select all objects or surface features...
...choose Select All under the Edit menu or double-click the Select Object Tool. 
To unselect some objects...
...hold down the Shift key and click the objects you want to unselect.
To unselect all objects...
... choose Unselect All under the Edit menu,
... or point to an empty space in the Design View and click.
To move an object or surface feature...
... select the object or surface feature to make it active, point with the Select Object Tool 
inside the polygonal outline of the object or surface feature, and drag to a new location. 
When moving an object which contains other objects, the contained objects will move 
with it unless you press and hold down the Ctrl key before you press the mouse button to
drag. The Ctrl key leaves contained objects behind.
To change the size or shape of an object or surface feature...
... select the object or surface feature to make it active, point with the Select Object Tool 
to a side of the outline of the object or surface feature or to a handle, and drag to a new 
location. You will not be able to drag the object into a non-convex shape.
Dragging a handle with the Ctrl key held down changes the objects type. For example, 
moving a handle of a rectangle with the Ctrl key will create a shape that is no longer a 
rectangle because only the handle will move. If you drag the handle without the Ctrl key, 
the object will resize--it becomes a larger or smaller rectangle.
In the Tumble Editor the Select Object Tool is used to select surfaces and edit slices.
To select a surface in the Tumble Editor...



... click the Select Object Tool , point to the surface and click. (You can also select 
surfaces in the Tumble Editor with the Move Tool. See Move Tool.)
To change the position of a slice in the Tumble Editor...
... click the Select Object Tool , point to the slice and drag it to a new location. You can 
also change the angle of a slice by using the Select Object Tool to select and drag one of 
the slices handles.



Lock Object Tool 
The Lock Object Tool functions in the Design Views and in the Surface Editor and allows 
you to lock objects or surface features so they cannot be edited. A locked object or 
surface feature appears with a dotted polygonal outline rather than a solid outline.
To lock an object or surface feature...
... select the Lock Object Tool , point to the object or surface feature and click. 
To unlock a locked object or surface feature...
... hold down the Ctrl key and click the object or surface feature with the Lock Object 
Tool. 
To unlock all locked objects and surface features...
... double-click the Lock Object Tool ,
... or select UnLock All under the Edit menu.
Objects can also be locked through the Layer menu; however, locked layers are not 
affected by the Lock Object Tool or the UnLock All command.



Hide Object Tool 
The Hide Object Tool functions in the Design Views and in the Surface Editor and allows 
you to hide objects or surface features in the Design Views, the Walk View or both views. 
The Hide Object Tool hides objects and surface features from the view, but does not 
actually remove them from the model.
To hide an object or surface feature in a Design Views...
... select the Hide Object Tool and click on the object or surface feature.
Hidden objects and surfaces features in the Design Views can be made visible by double-
clicking the Hide Object Tool or by selecting Show All under the Edit menu. 
To hide an object or surface feature in the Walk View...
... select the Hide Object Tool , hold down the Ctrl key and click on the object or surface 
feature.
Hidden objects and surfaces features in the Walk View can be made visible by holding 
down the Ctrl key and double-clicking the Hide Object Tool , or by holding down the Ctrl 
key and selecting Show All under the Edit menu. 
Objects can also be hidden through the Layer menu; however, objects in hidden layers 
cannot be made visible by double-clicking the Hide Object Tool or by using the Show All 
command.
When you save your model, all hidden objects and surface features are made visible 
before being saved.



Create 8-Sided Object Tool 
The Create 8-Sided Object Tool draws an 8-sided polygonal object outline or surface 
feature. 
To create an 8-sided object or surface feature...
... select the Create 8-Sided Object Tool , point to the location where you want the center 
of the outline or surface feature and drag in any direction. As you drag outward from the 
center a dotted outline is displayed. When you release the mouse button the dotted 
outline becomes solid and an object or surface feature is created.



Create 6-Sided Object Tool 
The Create 6-Sided Object Tool draws a 6-sided polygonal object outline or surface 
feature. 
To create a 6-sided object or surface feature...
... select the Create 6-Sided Object Tool , point to the location 
where you want the center of the outline or surface feature and drag in 
any direction. As you drag outward from the center, a dotted outline is displayed. When 
you release the mouse button, the dotted outline 
becomes solid and an object or surface feature is created.



Create Square Object Tool 
The Create Square Object Tool draws a square polygonal object outline or surface 
feature. 
To create a square object or surface feature...
... select the Create Square Object Tool , point to the location where you want the center 
of the outline and drag in any direction. As you drag outward from the center, a dotted 
object outline is displayed. When you release the mouse button, the dotted outline 
becomes solid and an object or surface feature is created.



Create Triangular Object Tool 
The Create Triangular Object Tool draws an equilateral triangular object outline or surface
feature. 
To create a triangular object or surface feature...
... select the Create Triangular Object Tool , point to the location where you want the 
center of the outline and drag in any direction. As you drag outward from the center, a 
dotted outline is displayed. When you release the mouse button, the dotted outline 
becomes solid and your object or surface feature is created.



Create N-Sided Object Tool 
The Create N-Sided Object Tool draws a polygonal outline with a user-specified number of
sides up to 32. The number of sides can be specified by double-clicking the Create N-
Sided Object Tool. This action takes you to the Preferences, Defaults dialog where you 
can specify the number of sides. Once an object is drawn with this tool, the sides can be 
changed with the Sides... command in the Modify Selected submenu under the Edit 
menu. 
To create an n-sided object or surface feature...
... select the Create N-Sided Object Tool, point to the location where you want the center 
of the outline and drag in any direction. As you drag outward from the center a dotted 
outline will be displayed. When you release the mouse button the dotted outline 
becomes solid and your object or surface feature is created.



Create Irregular Object Tool 
The Create Irregular Object Tool draws an irregular-shaped polygonal outline one 
segment at a time. This tool does not draw non-convex objects or surface features. (See 
Convex Objects.)
To create an irregular object or surface feature...
... select the Create Irregular Object Tool and point to the location where you would like 
one of the vertices (meeting of two sides represented by a handle) of the outline. Click to
establish the vertex and move the mouse to another location. Click again. Do this for all 
the vertices. There is no limit to the number of vertices allowed; however, there is a 
convex space limitation. If you double-click, a line is drawn from where you double-
clicked to the starting point, thus closing or finishing the object outline.
When creating an irregular object with this tool, you are limited to the immediate 
drawing area in the window. If you want your object outline to go beyond the confines of 
the window, drag the cursor. In other words, instead of simply clicking to establish a 
vertex, press and hold down the mouse button as you move to establish the next vertex. 
If the mouse button is down, the window will scroll automatically any time the cursor 
touches the window border.
Another method of creating an irregular shaped object or surface feature is to create a 
regular shaped object or surface feature, and then use the Add/Remove Handle Tool    to 
change the object shape.



Create Rectangular Object Tool 
The Create Rectangular Object Tool    draws a rectangular polygonal outline. 
To create a rectangular object...
... select the Create Rectangular Object Tool , point to the location of one of the corners 
of the rectangle and drag to the opposite diagonal corner. As you drag, a rubber-banding 
dotted line is displayed indicating where the object or surface feature is being positioned.
When you release the mouse button, the dotted line becomes solid and your object or 
surface feature is created.



Connect Surfaces Tool 
The Connect Surfaces Tool functions in the Design View and is used to connect two 
objects together at a common surface. A connection between surfaces is necessary to 
see any common surface features such as the colored, transparent or translucent surface
features representing doorways or windows. Without the connection, surface features 
between objects will not be shared and holes will not penetrate both surfaces. 
A common misconception is that a connection will increase speed. This is not true. A 
connection should only be made where necessary, that is, where surface features are 
shared between two objects.
To connect object surfaces...
... click inside one of the objects you want to connect to make it active. Click on the 
Connect Surfaces Tool. If the object surfaces you want to connect are already touching, 
click on the line that represents the touching surfaces. A "snap" sound indicates a 
connection has been made. If the object surfaces you wish to connect are not touching, 
drag the surface of the selected object toward the surface of the second object until you 
hear a "snap" sound.
A connection can be broken by dragging one object away from the other with the Select 
Object Tool.
The See Through option in the Preferences, Rendering dialog allows connections to be 
seen. If not selected, all connections within the model cannot be seen (you cannot see 
through any transparent or translucent surfaces between objects).
A fundamental limitation of connections is apparent when a single object surface with 
multiple surface features is connected to more than one adjacent object. Whole surfaces 
connect together, so often only one of the surface features will be visible after the 
connection. For example, if you have a large object with surface features and you 
connect it to a smaller object, you can only see through one of the surface features 
because the program interprets the entire side of the larger object as being connected to
the smaller side.
To solve the problem you need to add a handle to the larger object. Then you must break
the connection between the two objects (move one away from the other) and re-connect 
them.



Add/Remove Handle Tool 
The Add/Remove Handle Tool    functions in the Design View and the Surface Editor and is
used to add a new handle to an object or surface feature or remove an existing handle. A
handle represents a vertex--the meeting of two object surfaces. 
To add a handle...
... select the object or surface feature you want to modify and click the Add/Remove 
Handle Tool. Point to the location on a segment of the outline where you want to add the 
new handle and click. Depending on the complexity of the object or surface feature and 
the speed of your machine, there may be a brief pause before the handle appears. If a 
handle does not appear, select the Add/Remove Handle Tool , point to the location on the
outline where you want the new handle and drag the surface slightly outward.
To remove an existing handle...
... select the Add/Remove Handle Tool , point accurately to the handle and click. Again, 
depending on the complexity of the object or surface feature and the speed of your 
machine, there may be a brief pause before the handle disappears.
You may reposition a new handle at the same time you add it by dragging instead of 
clicking.
Adding a new handle to a regular polyhedron or polygon breaks its type (for example, an 
octagon will no longer be an octagon), but breaking the objects type can be avoided by 
holding down the Ctrl key.
If your goal is to create an irregular object or surface feature, you might want to try the 
Create Irregular Object Tool instead of the Add/Remove Handle Tool. Both tools can 
accomplish the same result, but you may prefer one method over the other.



Rotate Object Tool 
The Rotate Object Tool functions in the Design Views and the Surface Editor and is used 
to rotate an object or surface feature. When rotating an object, this tool works in any 
view, thus allowing rotation on more than one axis.
To rotate an object or surface feature...
... select the object or surface feature you want to rotate, click on the Rotate Object Tool 
and point to any location to establish the center of rotation. Drag the pointer away from 
the center of rotation. A dotted line will appear between the pointer and the center of 
rotation. As you drag the pointer farther from the center of rotation, you gain finer 
control over the angle of rotation. Drag the pointer in an arc around the center point to 
rotate the object.
The "a" text field in the Position Indicator (see Position Indicator ) shows the angle of 
rotation relative to the 0° start angle. The default position for the 0° start angle is right 
horizontal.
If Snap to Grid is selected (see Snap to Grid ) when you rotate the object or surface 
feature, the rotation snaps to 5° increments.
If you hold down the Shift key when you rotate the object or surface feature, the rotation 
is constrained to 15° increments.
Contained objects are rotated with the container unless you hold down the Ctrl key when 
you rotate an object. Holding the Ctrl key rotates the container, but not the contained 
objects.
If objects are grouped (see Group ), they will maintain their orientation relative to each 
other when the group is rotated. 



Scale Object Tool 
The Scale Object Tool functions in the Design Views or Surface Editor and scales an 
object or surface feature about its center or about a specified anchor point. 
Objects may be scaled independently along any of the three coordinate axes. 
Objects may also be scaled uniformly in all dimensions (X, Y and Z) by holding down the 
Shift key before dragging.
When an object is scaled, its contents and any surface features are scaled with it unless 
you hold down the Ctrl key while you are dragging.
To scale an object about its center...
... select the object to be scaled, select the Scale Object Tool , point to a reference point 
(like a corner) and drag to the new position.
To scale an object about a specified anchor point...
... select the object, select the Scale Object Tool and point to the desired location of the 
anchor point. Hold down the Ctrl key and click to establish the new anchor point. Point to 
a reference point and drag to a new location. 



Skew Object Tool 
The Skew Object Tool distorts an object from its true symmetrical form making the object
out of plumb. An object can be skewed on more than one axis, but only from the view (or
opposite view) it was created in.
To skew an object...
... select the object you wish to skew and select the Skew Object Tool. Point inside the 
object outline and drag in the direction(s) you wish to skew.
Contained objects are not skewed with the container.



Lighting Editor Tool
The Lighting Editor Tool functions in the Design Views and in the Tumble Editor and opens
the Lighting Editor. The Lighting Editor lets you set the intensity and color of light sources
inside a selected object or inside the Virtus world.    (See Lighting Editor .)



Surface Editor Tool
The Surface Editor Tool functions in the Design Views and Tumble Editor and accesses the
Surface Editor. (See Surface Editor .)



Tumble Editor Tool
The Tumble Editor Tool functions in the Design Views and accesses the Tumble Editor. The
Tumble Editor allows you to add a surface to a selected object by slicing off a piece of the
object. The Tumble Editor also allows you to edit the color and opacity of a selected 
object or object surface. (See Tumble Editor .)



Color Bar
The Color Bar functions in the Design Views, the Surface Editor and the Tumble Editor 
and displays the default color for new objects. It also allows new colors to be selected, 
created and assigned to objects or surface features. Colors can be applied to translucent 
as well as opaque objects and surfaces.
The current color displayed in the Color Bar is the default color for all newly created 
objects or surface features. The default color and the color of existing objects or surface 
features can be changed.
To change the default color...
... point to the Color Bar    and mouse down. The color selector will appear. Drag the 
pointer to the desired color on the color selector and release the mouse button. The color
you selected appears as the default color in the Color Bar.
If an object is selected when you change the default color, the object assumes the 
default color.
To change the color of an existing object...
... select the object and double-click the Color Bar    to give the object the default color,
... or select the object and select a new color from the color selector.
Color Palette 
Custom Colors 



Each time you select a new color, that color appears as a small square across the top of 
the color selector. This section of the color selector is the color palette. If you have 
selected several colors since you started the program each of those colors will be 
displayed as a small square in the color palette. This helps you keep your color selections
consistent. By recording the last 30 colors you selected, the color palette allows you to 
select the same shade of color for the same types of objects. For example, you might 
select a light shade of blue from the color selector and apply that color to a glass 
window. Every time you create another glass window you will be able to give it exactly 
the same shade of blue by selecting from the color palette rather than from the color 
selector.



Custom colors
If the colors in the color selector do not contain the desired color, drag the mouse to the 
icon in the upper left corner of the color selector and release. This action displays the 
standard Windows Basic Color Palette and Custom Color Selector in one window. (The 
Color Palette and Custom Color Selector are normally displayed in separate windows.)
To select a new color from the Windows Basic Color Palette...
... point to the desired color and click.
To define a custom color...
... point to a shade of color in the color refiner box (within the Custom Color Selector) and
click. To the left of the color refiner box is the Windows Vertical Luminosity Bar 
(brightness control). You may slide the Vertical Luminosity Bar up or down to change the 
shade of a color in the color refiner box, thus creating a custom color. If you wish to add 
a selected custom color to the Windows Basic Color Palette, click the Add button. (See 
your Windows documentation for more on standard Windows color functionality.)
If the color you selected does not look the same shade in the Walk View, it is probably 
due to the effects of lighting. You may wish to adjust the lighting (see Lighting Editor ) or 
turn off the effects of light and shade (see Preferences, Rendering ).



Make Opaque Modifier 
The Make Opaque Modifier functions in the Design Views, the Surface Editor and the 
Tumble Editor and makes selected objects, object surfaces or surface features opaque 
(solid).
To make an object, object surface or surface feature opaque...
... select the object, object surface or surface feature and choose Opaque in the Modify 
Selected submenu under the Edit menu,
... or select the object, object surface or surface feature and double-click the Make 
Opaque Modifier    in the Tools window.
If modifying a whole object, any surfaces or surface features with a different opacity will 
not be affected by this procedure unless they are edited individually either in the Surface
Editor or the Tumble Editor.



Make Translucent Modifier 
The Make Translucent Modifier functions in the Design Views, the Surface Editor and the 
Tumble Editor and makes selected objects, object surfaces or surface features 
translucent (like glass).
To make an object, object surface or surface feature translucent...
... select the object, object surface or surface feature and choose Translucent in the 
Modify Selected submenu under the Edit menu,
... or select the object, object surface or surface feature and double-click the Make 
Translucent Modifier    in the Tools window.
If modifying a whole object, any surfaces or surface features with a different opacity will 
not be affected by this procedure unless they are edited individually either in the Surface
Editor or the Tumble Editor.



Make Transparent Modifier 
The Make Transparent Modifier functions in the Design Views, the Surface Editor and the 
Tumble Editor and makes selected objects, object surfaces or surface features 
transparent (invisible).
To make an object, object surface or surface feature transparent...
... select the object, object surface or surface feature and choose Transparent in the 
Modify Selected submenu under the Edit menu
... or select the object, object surface or surface feature and double-click the Make 
Transparent Modifier in the Tools window.
If modifying a whole object, any surfaces or surface features with a different opacity will 
not be affected by this procedure unless they are edited individually either in the Surface
Editor or the Tumble Editor.



Inflate Straight Modifier 
The Inflate Straight Modifier inflates an object with straight sides perpendicular to the 
object base, like a box.
To create an object inflated straight...
... select the Inflate Straight Modifier and draw the object.
To make an existing object inflate straight...
... select the object and choose Straight in the Modify Selected submenu under the Edit 
menu,
... or select the object and double-click the Inflate Straight Modifier in the Tools window.



Inflate Double-Pointed Modifier 
The Inflate Double-Pointed Modifier inflates an object with sides that converge to two 
points, like a diamond.
To create an object inflated double-pointed...
... select the Inflate Double-Pointed Modifier and draw the object.
To make an existing object inflate double-pointed...
... select the object and choose Pointed, then Double in the Modify Selected submenu 
under the Edit menu
...or select the object and double-click the Inflate Double-Pointed 
Modifier in the Tools window.



Inflate Double-Rounded Modifier 
The Inflate Double-Rounded Modifier inflates an object with sides that round to two 
points, like a sphere.
To create an object inflated double-rounded...
... select the Inflate Double-Rounded Modifier and draw the object.
To make an existing object inflate double-rounded...
... select the object and choose Rounded, then Double in the Modify Selected submenu 
under the Edit menu,
... or select the object and double-click the Inflate Double-Rounded Modifier in the Tools 
window.



Inflate Pointed Modifier 
The Inflate Pointed Modifier inflates an object with sides that converge to a point, like a 
pyramid. The object can be inflated to a point in the opposite direction with the Inflate 
Pointed Flip Modifier.
To create an object inflated pointed...
... select the Inflate Pointed Modifier    and draw the object.
To make an existing object inflate pointed...
... select the object and choose Pointed in the Modify Selected submenu under the Edit 
menu 
... or select the object and double-click the Inflate Pointed Modifier in the Tools window.
To reverse the direction of the point...
... select the object and choose Flip in the Modify Selected submenu under the Edit 
menu.



Inflate Rounded Modifier 
The Inflate Rounded Modifier inflates an object with sides rounded to a point, like a 
dome. The object can be inflated rounded to a point in the opposite direction with the 
Inflate Rounded Flip Modifier.
To create an object inflated rounded...
... select the Inflate Rounded Modifier and draw the object.
To make an existing object inflate rounded...
... select the object and choose Rounded in the Modify Selected submenu under the Edit 
menu 
... or select the object and double-click the Inflate Rounded Modifier in the Tools window.
To reverse the direction of the rounded inflation...
... select the object and choose Flip in the Modify Selected submenu under the Edit 
menu.



Inflate Pointed Flip Modifier 
The Inflate Pointed Flip Modifier inflates an object to a point in the opposite direction of 
the Inflate Pointed Modifier.
To create an object inflated pointed and flipped...
... select the Inflate Pointed Flip Modifier and draw the object.
To make an existing object inflate pointed and flipped...
... select the object and choose Pointed, then Flip in the Modify Selected submenu under 
the Edit menu,
... or select the object and double-click the Inflate Pointed Flip Modifier in the Tools 
window.
To reverse the direction of the point...
... select the object and choose Flip in the Modify Selected submenu under the Edit 
menu.



Inflate Rounded Flip Modifier 
The Inflate Rounded Flip Modifier inflates an object with sides rounded to a point in the 
opposite direction of the Inflate Rounded Modifier.
To create an object inflated rounded and flipped...
... select the Inflate Rounded Flip Modifier and draw the object.
To make an existing object inflate rounded and flipped...
... select the object and choose Rounded, then Flip in the Modify Selected submenu 
under the Edit menu,
... or select the object and double-click the Inflate Rounded Flip 
Modifier in the Tools window.
To reverse the direction of the rounded inflation...
... select the object and choose Flip in the Modify Selected submenu under the Edit 
menu.



Layer List
The Layer List displays the names of the different layers you create. When working on 
complex models, layers can be helpful because individual layers may be locked, hidden 
or assigned a special color in the Design Views, or a layer can be hidden from the 
rendering in the Walk View. For example, if you were creating a building with many floors,
you could put each floor in its own layer. You also might wish to put furniture in its own 
layer.
When you draw new objects, they are put in the layer whose name is highlighted in the 
layer list. Though it is possible to move objects to different layers, it is a good idea when 
drawing new objects to first highlight the layer you want the new objects in. This will 
save you the time of having to move them later. Initially, there is only one layer, 
Unnamed, and all objects are put in this layer unless you create another.
To create a layer...
... select New Layer under the Design menu. A dialog appears with a text box for you to 
enter a new layer name. After you enter the name and click OK, the new layer is 
displayed in the Layer List and its name is highlighted.
To remove a layer from the layer list...
... highlight the name of the layer you want to remove and select Delete Layer from the 
Design menu. A pop-up dialog appears asking you to verify the deletion of the layer and 
any objects in it. Any objects in the layer will be deleted unless you move them to 
another layer first.
To move an object to another layer...
... select the object you want to move and double-click on the name of the layer in the 
layer list you want to move it to. A pop-up dialog appears asking you to verify the move.
To rearrange the order of layers in the layer list...
... select a layer name in the Layer List and drag it up or down to a new position in the 
list.



Position Indicator

 The Position Indicator identifies the position of the mouse cursor in the active drawing 
area. The information in the Position Indicator helps you measure and draw accurately. 
The Position Indicator does not function in the Walk View. 
The information displayed in the Position Indicator is in screen coordinates or in world 
(3D) coordinates. The type of display is determined by the Tracking option in the 
Preferences, Editor dialog under the Edit menu. The two choices for Tracking are World 
and View.
If View is selected as the Tracking option, the information in the Position Indicator is in 
the following format:
h: the horizontal distance from 0,0
v: the vertical distance from 0,0
f: the current floor setting, the lower endpoint of the depth control
d: the current inflation distance, the length between the two endpoints of the depth 
controls
When you press the mouse button, the Position Indicator changes to display local 
coordinates. This gives you the size of the object you are drawing so you dont have to 
add and subtract ruler measurements. When the mouse button is down the following 
information is displayed:
h: the horizontal distance from 0,0
v: the vertical distance from 0,0
h°: the horizontal distance from where you began dragging
v°: the vertical distance from where you began dragging
l: the diagonal distance from where you began dragging
a: the angle in degrees of the diagonal from where you began dragging

Zero degrees is right horizontal.

If World is selected as the Tracking option, the information in the Position Indicator, 
depending on which Design view is active, is in the following format:
x: the linear distance from x to 0 in the world
y: the linear distance from y to 0 in the world
z: the linear distance from z to 0 in the world
d: the current inflation distance, as set by the depth controls
When the mouse button is down, the Position Indicator changes to display the following 
information:
x°: the linear distance from the x coordinate of the point where you began dragging
y°: the linear distance from the y coordinate of the point where you began dragging
z°: the linear distance from the z coordinate of the point where you began dragging



l: the diagonal distance from where you began dragging
a: the angle in degrees of the diagonal from where you began dragging

Zero degrees is right horizontal.



Zoom In Tool    
Each click of the Zoom In Tool    increases the apparent size of the drawing by a factor of 
two. There is a limit to how close you can zoom in. When you reach the limit, clicking the 
Zoom In Tool    will have no effect.
You can also zoom in by selecting Zoom In command under the Design menu. (See also 
Constrained Zoom Tool .)



Zoom Out Tool 
Each click of the Zoom Out Tool    decreases the apparent size of the drawing by a factor 
of 2. There is a limit to how far you can zoom out. When you reach the limit, clicking the 
Zoom Out Tool    will have no effect.
You can also zoom out by selecting Zoom Out under the Design menu.



Constrained Zoom Tool 
The Constrained Zoom Tool    allows you to define the area to zoom to. 
To define an area to zoom to...
... click the Constrained Zoom Tool . The area to zoom to is defined by dragging a box 
around the area. As you drag, a rubber-banding box will appear. Drag the rubber-banding
box around the area you wish to zoom to and release the mouse button.
The apparent size of the drawing within the defined zoom area increases to the largest 
possible size within the constraints of the window. To reverse the effects of the 
Constrained Zoom Tool , you must use the Zoom Out Tool.





Lighting Editor Tools
Subject Button 
Color Bar 
Lights List 
Rotation Constraint Tools 



Subject Button
At the top of the Lights List is the word Subject. Subject refers to the Subject Cube within 
the Lighting Editor window. The Subject Cube represents objects contained within the 
object you are editing and shows how light affects those objects. The Subject Cube can 
be rotated so you may view different sides and see the effects of light sources on the 
cube. The Subject Button allows you to rotate the Subject Cube rather than rotate a light 
source. Both the Subject Cube and individual light sources can be rotated by pointing in 
the Lighting Editor window and dragging. The Lighting Editor assumes you wish to rotate 
a light source unless you first click the Subject button.



Color Bar
The Color Bar    allows you to change the color of the Subject Cube. This is used to see 
how different object colors are affected by different colored light sources. By changing 
the color of the Subject Cube you can simulate the color of the contained objects or walls
of the object whose lighting you are editing. 
The Color Bar    functions the same as the Color Bar in the Design Views. Mouse down on 
the Color Bar and drag to choose a color. (See Color Bar.)



Lights List
Beneath the Color Bar is the Lights List, a list of existing light sources. Light sources can 
be added or deleted with the New Light and Delete Light commands in the Lights menu. 
It is possible, but not practical, to have thousands of light sources. A practical range is 
three to ten.
Each light source in the Lights List consists of two check boxes and a Color Bar . The first 
check box, on the left, indicates whether the light source is turned on. 
The second check box indicates what type the light is. A light source can be either 
ambient or directional. Only one ambient light is necessary. (More than one ambient light
is possible, but the colors and intensity will either wash each other out, creating white 
light, or they will have an almost undetectable effect on each other.) A single arrow in 
this box indicates a directional light source. An X in the box indicates an ambient light 
source. To change between directional and ambient click the check box.
Each light source has its own Color Bar . The Color Bar for each light source functions the
same as the Color Bar in the Design Views. Mouse down on the Color Bar    and drag to 
choose a color for the light source. (See Color Bar.)
To modify a light source...
... select a light source by clicking it in the Lights List. (Make sure the light source is 
turned on, indicated by a check mark in the left box of the individual light source in the 
light list.)
When you click a light source on the Lights List, the light appears in the Lighting Editor 
window. If the selected light source is ambient, the background of the Lighting Editor 
window will display the color of the ambient light. 
If a selected light source is directional, a cylindrical light will appear near the Subject 
Cube. Directional light sources can be positioned to shine on different surfaces of the 
Subject Cube. 
To position a directional light source...
... select a light source in the Lights List. Point to the cylindrical light near the Subject 
Cube. Drag to rotate the light source to the desired position. The directional light sources
rotation is affected by the Rotation Constraint Tools. (See Rotation Constraint.)
If a directional light source is selected in the Lights List and you wish to rotate the 
Subject Cube, you must click Subject in the Tools window to toggle off the directional 
light source first. 
To add a new light source...
... choose New Light under the Lights menu.
To remove a light source...
... select the light source you wish to delete in the Light List. Choose Delete Light under 
the Lights menu.
Because the Lighting Editor affects the interior of the object you edit, the Subject Cube 
can be misleading. For example, if a yellow directional light is positioned so that it shines
on the front (F) of the Subject Cube, the back (B) interior surface of the object will appear
yellow, not the front; however, the front of any contained objects will appear yellow. The 
yellow light is coming from the front of the object, passing through the interior and 
hitting the back of the interior. Remember, the Subject Cube represents contained 
objects.
After modifying the lighting, you must apply the changes to the selected object or world. 



To apply the changes choose Apply under the Lights menu. If you forget to apply the 
changes, you will be prompted to do so when you close the Lighting Editor.



Rotation Constraint Tools
The Rotation Constraint Tools affect how the Subject Cube and the directional light 
sources in the Lighting Editor window or how objects in the Tumble Editor window can be 
rotated. There are three Rotation Constraint Tools. The default is all three selected. The 
Rotation Constraint Tools may be turned off and on by clicking; however, at least one tool
must be selected at any time.
If a Rotation Constraint Tool is turned off, rotation is not allowed in the direction 
associated with that tool. To unselect a Rotation Constraint Tool, click on its icon.
Allow XY Motion Tool 
If selected, this tool allows rotation in the apparent XY plane.
Allow XZ Motion Tool 
If selected, this tool allows rotation in the apparent XZ plane.
Allow YZ Motion Tool 
If selected, this tool allows rotation in the apparent YZ plane.



Surface Editor Tools
Most of the Surface Editor Tools are identical to tools in the Design View Tools window. 
Additional tools specific to the Surface Editor are as follows:
Placement Modifiers
When changing the color of a surface or when adding a surface feature, it is important to
consider the two sides of the surface. For example, you may want the color of the interior
side of an object surface to be different from the color of the exterior side; or you may 
want a surface feature to appear on one side but not the other; or you may want a 
surface feature on both sides. The placement of surface features is determined by the 
Placement Modifiers. By selecting the correct Placement Modifier, you can edit the 
outside, the inside or both sides of a surface.
Place on Front 
Place Through 
Place on Back 



Place on Front
Place on Front makes surface edits on the side of the object surface facing you in the 
surface window. If this modifier is active when you select a color, only the side of the 
surface facing you in the surface window will reflect the color change.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on the side facing you in the Surface Editor window.
To change the placement of any surface feature...
... select the feature and double-click the desired Placement Modifier.
You can toggle between the inside and outside surface by choosing Opposite in the 
Change View submenu under the View menu.



Place Through
Place Through makes surface edits on both sides of an object surface. If this modifier is 
active when you select a color, both sides of the surface will reflect the color change.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on both sides of the surface. This is the placement required for making holes like a 
doorway or a window.
To change the placement of any surface feature...
... select the feature and double-click the desired placement modifier.



Place on Back
Place on Back makes surface edits on the opposite side of a surface in the surface 
window. If this modifier is active when you select a color, only the opposite side of the 
surface will reflect the color change. You will not be able to see any changes unless you 
choose Opposite in the Change View submenu under the View menu.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on the opposite side of the surface in the Surface Editor.
To change the placement of any surface feature...
... select the feature and double-click the desired Placement Modifier. To select a surface 
feature that is placed on back, you must first flip the surface by choosing Opposite in the
Change View submenu under the View menu.



Tumble Editor Tools
Most of the Tumble Editor Tools are identical to tools used in the Design View Tools 
window. Additional tools specific to the Tumble Editor are as follows:
Move Tool 
Orientation Cube 
Rotation Constraint Tools 
Slice List 
Slice Tool 



Move Tool 
The Move Tool is used to tumble (orient in 3D) the object in the Tumble Editor window or 
to tumble the Orientation Cube. In the Tumble Editor tools window, the Move Tool is also 
used to select specific surfaces on the object or on the Orientation Cube.
To tumble an object...
... select the Move Tool and drag the object in any direction,
... or drag the Orientation Cube (in the tools window) in any direction. The Orientation 
Cube and the object are linked, and when one is tumbled the other tumbles with it. If you
hold down the Ctrl key while you tumble, the link between the Orientation Cube and the 
object is temporarily suspended and tumble speed increases.



Orientation Cube 
The Orientation Cube represents the selected object within the Virtus world. Each side of 
the cube is marked with a letter: T=Top, b=Bottom, F=Front, B=Back, L=Left and 
R=Right. The Orientation Cube can be tumbled to view other surfaces. As the Orientation
Cube is tumbled, the object in the Tumble Editor window imitates its movement. To rotate
the Orientation Cube, select the Move Tool and drag the Orientation Cube in any 
direction.
By holding down the Ctrl key when tumbling, you can temporarily suspend the link 
between the object being tumbled and the Orientation Cube so that they rotate 
independently of each other. This increases the tumble speed.
The Orientation Cubes rotation is affected by the Rotation Constraint Tools. 



Slice Tool 
The Slice Tool adds a surface to an object by slicing off a piece of that object.
To slice off a piece of an object...
... select the Slice Tool and drag a line through the object. The direction of the drag 
determines how the slice is made. If you drag from left to right or from top to bottom, the
portion above or to the right of the line will be sliced off. If you drag from right to left or 
from bottom to top, the portion below or to the left of the line will be sliced off.
To reverse the direction of a slice...
... hold down the Ctrl key while slicing,
... or after slicing, choose Reverse Slice from the Tumble menu.
After a slice is made it can be edited. 
To edit a slice...
... click the Select Object Tool , then click the slice you wish to edit in the Slice List. (See 
Slice List.) The slice will appear on the object in the Tumble window. If you dont know 
which slice in the list corresponds to the slice you wish to edit on the object, click each 
one until you see the appropriate slice appear in the Tumble window. The slice can be 
edited by dragging to a new location or you can change the angle of the slice by 
dragging one of the slices handles.
To delete a slice (and thereby replace the portion of the object that was 
removed)...
... select the slice from the Slice List and choose Cut or Clear from the Edit menu, or 
press the Delete key or the Backspace key.
A slice can be copied from one object to another. Each slice knows its position relative to 
the origin of the object. If you select a slice and then select Cut or Copy under the Edit 
menu, the slice is saved to a clipboard. If you edit another object in the Tumble Editor, 
you can paste the slice with the Paste command under the Edit menu and maintain the 
same slice angle and object rotation angle; however, since a slice knows its position 
relative to the object origin, you may have to drag the slice to position it correctly.



Slice List
The Slice List displays the word slice and a number for each slice you make in an object. 
If you wish to edit a slice, click the slice in the list and it will appear in the Tumble Editor 
window. If you arent sure which numbers correspond to which slices, click on each name 
in the list until the desired slice appears.





File Menu
Many of the Virtus WalkThrough File menu options and commands are standard for the 
Windows operating system. These include New, Open, Close, Save, Save As, Print Setup, 
Print and Quit. If you do not understand these options and commands, please review 
your Windows documentation.
New 
Open 
Close 
Save 
Save As 
Revert to Saved 
Print Setup 
Print 
Import 
Export 
Place 
Snapshot 
QuickSnap 
Library 
Exit 



New (Ctrl+N)
New creates and opens a new Virtus WalkThrough file.



Open (Ctrl+O)
Open displays the standard Windows Open dialog from which you can select an existing 
file to open. 



Close (Ctrl+W)
Close closes the current file. If you made any changes to the file since the last time you 
saved it, you will be prompted to save the changes before the file is closed.



Save (Ctrl+S)
Save saves the current file under the currently used name.



Save As
Save As opens the standard Windows Save As dialog which allows you to save the 
current file under a new name.



Revert to Saved
Revert To Saved opens the last saved version of the current file. If you select this option, 
any changes made to the model since the last time you saved it will be lost unless you 
first use Save As and save the changes to the file under another name.



Print Setup
Print Setup opens the standard Windows Print Setup dialog with which you choose 
printout size, paper orientation and other printing features.



Print (Ctrl+P)
Print prints the active window centered on the page and enlarged within the constraints 
of the page. However, what you see is what you print. 
To print an entire Design View...
... select the Design View to make it active, zoom out until you can see all the objects 
then choose Print. 
To print the Walk View...
... navigate in the Walk View to the desired viewing angle then choose Print.
When printing the Walk View, if your printer does not print gray scales, you may wish to 
print black object frames with white shading. This gives you a clean, black line drawing.
To print objects with black frames and white shading...
...in the Preferences, Rendering dialog, click Print Fill (so the checkbox is not selected) 
and choose Black Frames.



Import
Import opens the Import dialog with which you can select a file in DXF 3D format to 
import into Virtus WalkThrough.
The first rule of importing is: 
There is no universal translator; therefore, all data will not be transferred between 
formats.
Dragging open Import displays a pop-up menu with the DXF 3D file format option. 
Highlighting DXF 3D displays a dialog of Import options.
The default settings for the import options are such that all objects that can be imported 
and drawn correctly will. That does not mean that all objects can or will be imported. The
price for correct drawing is lost data. If there is a problem with an object or object 
surface, it will be discarded unless the option that causes it to be discarded is 
unselected.
The Import options are as follows:
Patch Non-Planar Holes 
Discard Non-Convex Objects 
Discard Degenerate Objects 
Discard Orphan Surfaces 
After selecting the desired import options and clicking Done the standard Get File dialog 
is displayed from which you can select a DXF 3D file to import.



Patch Non-Planar Holes
When you import, surfaces are matched together to form objects. After matching all 
available surfaces, Virtus WalkThrough patches any remaining holes with transparent 
surfaces.
Problems arise if the edges of a hole are not all in the same plane. The problem in the 
case of non-planar holes is that the import process will most likely create a non-convex 
object, and non-convex objects are not allowed in Virtus WalkThrough. The result is that 
the object is difficult to select and sometimes the surfaces are drawn in the wrong order.
If this option is not selected and an imported object (which is otherwise convex) with a 
non-planar hole is imported, you may be able to select the object with the selection 
rectangle method and walk inside it, but nothing will be drawn in place of the hole. This 
means that when looking at the outside of the object, it may appear that you can see 
straight through the entire object. When looking at the hole from inside the object, 
garbage (for lack of a better word) will be drawn where the surface should be. 



Discard Non-Convex Objects
Non-convex objects are not allowed in Virtus WalkThrough. If a non-convex object is 
imported it is difficult to select, you may not be able to walk inside it and surfaces may 
be drawn in the wrong order. Also, you may not be able to place an object inside a non-
convex object because it will not recognize the containment.
If an object to be imported is non-convex and this option is selected, the object will be 
discarded. This also applies if hole patching made the object non-convex. (See Patch 
Non-Planar Holes .)
If a non-convex object is allowed to be imported and you wish to select it, you must use 
the selection rectangle method. The Select Object Tool may not work. 



Discard Degenerate Objects
Sometimes surfaces may get matched together, but the resulting object may not be a 
volumetric object because it cannot be closed. For example, a paddle wheel formed by 
joining several surfaces together at a common edge is not a volumetric object. Since 
Virtus WalkThrough cannot deal with this type of object, it would prefer to discard it. If 
you want to try your luck anyway, unselect this option. The import wont fail, but 
degenerate objects probably wont be drawn correctly.



Discard Orphan Surfaces
If a surface is not part of a volumetric object, Virtus WalkThrough would like to discard it. 
Virtus WalkThrough is not a surface renderer and extraneous surfaces can slow the walk 
speed. If you unselect this option, Virtus WalkThrough will make all orphan surfaces into 
infinitely thin volumetric objects, but your walk speed will most likely slow down.



Export
Export allows you to save the currently open Virtus WalkThrough file to another file 
format.
The first rule of exporting is:
There is no universal translator; therefore, all data will not be transferred between 
formats.
Export displays a pop-up menu containing the possible file formats to export to. Available
file formats for exporting are DXF 2D and DXF 3D.
Highlighting a file format displays a dialog containing options specific to the file format. 
The Export options are as follows:
DXF 2D 
DXF 3D 



DXF 2D
View is a pop-up listing the possible design views to export. Since DXF 2D is a 2D format,
only one Design View can be exported per file.
Color By:
Object exports all polygonal object outlines in their assigned colors.
Layer exports all polygonal object outlines in the color assigned to the Virtus 
WalkThrough layer they are in.
Line Termination allows you to pick a platform to export to. DXF is a text format, and 
different platforms handle text files differently so it is necessary to select a specific 
platform for the file.



DXF 3D
Surface Type:
POLYLINE exports each surface of an object as a 3D polygon, a line connecting points. 
Some programs interpret a POLYLINE as an opaque face; others do not. If the program 
you are exporting to does not interpret a POLYLINE as a face, try using the 3DFACE 
option.
Surface Type:
3DFACE exports object surfaces as faces. By DXF definition, a face can have only 3 or 4 
sides; therefore, any object with greater than 4 sides is broken into multiple objects. In 
general (not always), 3DFACE objects are interpreted as opaque.
Color By:
Object exports all 3D objects in their assigned colors.
Layer exports all 3D objects in the color assigned to the Virtus WalkThrough layer they 
are in.
Line Termination allows you to pick a platform to export to. DXF is a text format, and 
different platforms handle text files differently so it is necessary to select a specific 
platform for the file.
Use Extrusions writes objects out as extruded bases whenever possible. Use Extrusions 
draws an objects outline and extrudes (inflates) the sides upward. The object is then 
capped with a POLYLINE or 3DFACE, whichever is selected.
Use Extrusions makes use of the DXF User Coordinate System, keeping object 
information together and reducing file size. Unless there is a conflict, Use Extrusions 
should always be selected.
Use Extrusions will apply to an object only if the following three conditions are met: (1) 
The object is inflated straight. (2) All surfaces of the object are the same color. (3) The 
object is not sliced. For objects that do not meet these three conditions, each surface is 
written out separately as a 3DFACE or POLYLINE, whichever is selected.
Use Extrusions does not apply to surface features; therefore, all surface features are 
written out as a POLYLINE or 3DFACE.
In applications that do not interpret the DXF User Coordinate System, Use Extrusions 
may cause objects to be oriented incorrectly. In such cases, unselect Use Extrusions and 
try exporting the file again.



Place
Place allows you to select a 2D file in BMP, DXF or TIFF format and place that file in a 
Virtus WalkThrough model as a drawing template. Place allows you to import a line 
drawing, such as a floorplan, and draw objects over the line drawing, using it as a guide.
You cannot assign a depth to the template. Edits to placed templates are limited to 
rotation, scaling and moving.
A template can be seen only in the view it was placed. This means if you place a 
floorplan template in the Top View, you will not see it in the Front View. However, a 
separate template can be placed in each of the six views if desired. This means in 
addition to a floorplan template in the Top View, you may also have an elevation view 
template in the Front View.
Selecting Place displays a pop-up menu containing the possible 2D file formats to place. 
Select one of the formats and the standard Windows open file dialog is displayed for you 
to pick a file to Place.
The template file you choose will be displayed in the active Design View. You may move 
the template with the Select Object Tool, scale it with the Scale Object Tool, or rotate it 
with the Rotate Object Tool. 
When templates are placed there is usually a need to scale them to match the scale of 
the Design View. To do this, you must have a known dimension of the template. For 
example, if you know a certain line in the template is 10 ft., you can scale the entire 
template with the Scale Object Tool until the line is 10 ft. according to the Design View 
rulers.
Before selecting a file format, make sure the Design View where you want the template 
placed is active.



Snapshot
Snapshot allows you to save a view of a Virtus WalkThrough model in another file format.
The saved view can be a particular perspective in the Walk View, the drawing in a Design
View, the Surface Editor window the Tumble Editor window, the Lighting Editor window, 
or a recorded walk path.
Snapshot displays a pop-up menu listing possible file formats to save the snapshot to. 
Possible formats are BMP, EPS, Illustrator, TIFF and Animator Pro.
To take a snapshot...
... click the window you wish to take the snapshot of (to make it the active window), and 
then select Snapshot and a file format for the snapshot. Select the desired options for 
the snapshot and click OK. The options for each snapshot are described below.
If Aspect Ratio is selected in the Preferences, Navigation dialog, the selected aspect ratio
will be applied to the snapshot, overriding the Size selection in the Snapshot dialog.
After a file format is selected, a dialog with options specific to the format type is 
displayed.    The formats and their options are as follows:
BMP Options 
EPS Options 
TIFF Options 
Illustrator Options 
Animator Pro Options 
After all options are selected for Snapshot, the standard Save As dialog will appear, from 
which you can select or type a file name for your snapshot.



BMP Options
Size:
Size is a pop-up menu with a list of common screen sizes, measured in pixels, from which
you can choose a size for the snapshot. Also on the pop-up is the Custom option which 
allows you to enter a custom pixel width and height in the text boxes next to the pop-up 
menu.
Colors:
Colors displays a pop-up of 2, 16, 256 or Millions from which you can select a color mode.
Also displayed is the Grayscale checkbox which will save the snapshot in shades of gray 
if your monitor supports this mode. The number of shades of gray depends on the which 
option is selected under the pop-up.
Compression:
Compression options are On or Off. The default is On. Most software capable of reading 
BMP format can deal with compressed format; however, some software cannot. If you 
have trouble reading a BMP snapshot into another program, try turning off compression.



EPS Options
Size: 
Size is a pop-up menu with a list of common screen sizes, measured in pixels, from which
you can choose a size for the snapshot. Also on the pop-up is the Custom option which 
allows you to enter a custom pixel width and height in the text boxes next to the pop-up 
menu. 
EPS does not understand pixel size, only a width-to-height ratio. The resolution of an EPS 
snapshot is the same no matter what size the window; however, selecting a size gives 
the snapshot a reference to start from. 
Size also determines the size of the TIFF preview saved with the EPS file. 
Colors:
Colors offers two options for the EPS file. Color writes a Level 2 PostScript file (color). 
Grayscale writes a Level 1 Postscript file (gray scale).
Include Preview
If selected, Include Preview writes a preview of the EPS snapshot in TIFF format.



TIFF Options
Size:
Size is a pop-up menu with a list of common screen sizes, measured in pixels, from which
you can choose a size for the snapshot. Also on the pop-up is the Custom option which 
allows you to enter a custom pixel width and height in the text boxes next to the pop-up 
menu.
Colors:
Colors displays three options from which you can select to save the snapshot in Color, 
Grayscale or B&W (black and white). Colors allows 24-bit color if your monitor supports 
this color mode. Grayscale is 8-bit (256 levels of gray) if your monitor supports this 
mode. B&W is 1-bit (black and white).
Compression:
Compression options are On or Off. The default is On. Most software capable of reading 
TIFF format can deal with compressed format; however, some software cannot. If you 
have trouble reading a TIFF snapshot into another program, try turning off compression.



Illustrator Options
Size: 
Size is a pop-up menu with a list of common screen sizes, measured in pixels, from which
you can choose a size for the snapshot. Also on the pop-up is the Custom option which 
allows you to enter a custom pixel width and height in the text boxes next to the pop-up 
menu. 
Illustrator format, like EPS, does not understand pixel size, only a width-to-height ratio. 
The resolution of an Illustrator snapshot is the same no matter what size the window; 
however, selecting a size gives the snapshot a reference to start from. 
Size also determines the size of the TIFF preview saved with the Illustrator file. 
Colors:
Colors offers two options for the Illustrator file, Color or Grayscale.
Include Preview
If selected, Include Preview writes a preview of the Illustrator snapshot in TIFF format.



Animator Pro Options
To take a snapshot in Animator Pro...
... you must first record a walk path using the Record Tool. If you have not recorded a 
walk path, the Animator Pro format option will be grayed and unselectable.
Size:
Size is a pop-up menu with a list of common screen sizes, measured in pixels, from which
you can choose a size for the snapshot. Also on the pop-up is the Custom option which 
allows you to enter a custom pixel width and height in the text boxes next to the pop-up 
menu. 
True Animator format size is 320x200. Any other size is considered Animator Pro format. 
This is important to users who wish to playback the snapshot with an older Animator 
player. Some older players will read ONLY Animator format (320x200).
Colors:
Colors offers two options for the Animator Pro file, Color or Grayscale.
Frames:
Frames allows you to select a range of frames from the recorded walk path to be saved 
in Animator Pro format. The default is for all frames to be saved, but you may type a new
range in the text boxes.
Smooth Path
If selected, Smooth Path compares frames in the recorded path and inserts more frames 
where necessary to make the path less jerky when played back.
Rate:
Rate allows you to enter a rate of frames per second for Animator Pro to play back the 
file. Your machine is limited to how fast it can play back frames. For example, you may 
set the Rate option at 32 frames/second but your machine may only be fast enough to 
play back 6 frames/second. 



QuickSnap (Ctrl+Shift+P)
QuickSnap is not a file format option, but is used to take a snapshot using the file format 
and options you last selected for Snapshot. This allows you to quickly take several 
snapshots without having to reset the snapshot options each time.



Library
Library allows you to create a new object library or open an existing object library. 
Choosing Library displays the standard Open dialog from which you can select an 
existing library to open. In addition to the standard dialog buttons, the New button is 
displayed, which allows you to create a new library. Once a library is open, Library items 
can be added to or copied from the library.
An open library displays a window containing a list of Library item names and a Walk 
View where the library items themselves are displayed one at a time. Clicking a name in 
the library list causes the associated library item to appear in the Walk View. In the 
Library Walk View you can navigate around and through the library items. (See 
Navigation Methods.)
To select an object from an existing library and copy it into your model...
... open the desired library and click on the desired library item name in the list. Copy the
object by choosing Copy under the Edit menu. Make a Design View of your model active 
by clicking it or by selecting the appropriate Design View name from under the Window 
menu. (You do not have to close the open library, but you may. If you are planning to 
copy another object from the same library, it will be more efficient to leave the library 
open.) Point in the Design View where you want the library item to be placed and click. 
Check the appropriate Depth Control endpoint. (See Depth Control .) You can quickly 
check the floor marker by looking at the "f" reading in the Position Indicator of the Tools 
window. Paste the object by selecting Paste under the Edit menu.
Creating Library Items
Library items are actually Virtus WalkThrough models. They are usually, but not 
necessarily, built on a small scale. The more surfaces and the more translucencies and 
transparencies you have in a library item, the slower your rendering speed. Try to keep 
your library items as plain as possible.
You can create library items while in an existing model or as a separate model. It is 
usually easier to create a library item if there are no objects nearby because working on 
a small scale requires you to be zoomed in very close, and it is sometimes difficult to 
select a small object if larger objects are in the vicinity.
Library items are usually several objects put together. Before adding a library item to a 
library, it is important to remember to group the objects by selecting all of them and 
choosing Group under the Design menu. Grouped objects are treated as one single 
entity. (See Group .)
To add a library item to a library...
... create the library item and group it using the Group command under the Design 
menu. Select the grouped library item and copy it by choosing Copy under the Edit 
menu. Select Library... under the File menu, and open an existing library or select New to
create a new library. Paste the library item by choosing Paste under the Edit menu. 
If you are adding the library item to an existing library, select the name of the existing 
library item occupying the position where you want your new library item. When you 
paste the new library item the existing library item name and any library item names 
below it will move down in the library list and your new library item will assume the 
space.
When you add a library item to a library, the name of the new library item in the library 
list will default to Object #. 
To change the name of a library item...
... highlight Object # in the list by clicking it. Point to the highlighted name and press and



hold down the mouse button. The existing name will appear to the right of the list. Drag 
the pointer to the right to highlight the name and release the mouse button. A pop-up 
will appear where you can type the new name of the library item.



Exit (Ctrl+Q)
Exit exits Virtus WalkThrough. If a model is open and changes were made since the last 
time it was saved, you will be prompted to save any changes before exiting.



Edit Menu
Undo (Ctrl+Z) 
Cut (Ctrl+X) 
Copy (Ctrl+C) 
Duplicate (Ctrl+D) 
Paste (Ctrl+V) 
Delete 
Modify Selected 
Select All (Ctrl+A) 
UnSelect All (Ctrl+Shift+A) 
Hide Selected (Ctrl+H) 
Show All (Ctrl+Shift+H) 
Lock Selected 
UnLock All 
Preferences (Ctrl+;) 



Undo (Ctrl+Z)
Undo undoes the last operation. This command is available in the Design Views as well 
as all Editors.



Cut (Ctrl+X)
Cut removes any selected objects, surface features or slices and places them in the 
clipboard. Cut objects, surface features and slices can then be pasted with the Paste 
command. (See Paste .)



Copy (Ctrl+C)
Copy copies any selected objects, surface features or slices to the clipboard. The 
difference between Copy and Cut is that Copy leaves the original in place, and Cut 
removes the original. Copied objects, surface features and slices can then be pasted with
the Paste command. (See Paste .)



Duplicate (Ctrl+D)
Duplicate duplicates any selected object or surface feature and places it on or near the 
original. Duplicate does not copy to the clipboard as does the Copy command. (See Copy
.)
Duplicate will duplicate objects as well as object placement, scaling and rotation. For 
example, if you create an object, duplicate that object, and position the duplication on 
the right side of the original so that the objects appear to be touching, you can then 
select Duplicate again and the result will be an identical object joined on the right side of
first duplication--a line of three identical objects spaced the same distance apart. The 
duplications position relative to the object it duplicated is maintained as long as it 
remains selected. If you continue choosing Duplicate, the objects will continue 
duplicating to the right until you have a line of identical objects. This functionality can be
extremely helpful in modeling objects such as staircases--even spiral staircases. 
When you create the first duplication, it holds the object's position, scaling and rotation 
information. It must remain selected until the next duplication or the 
information will be lost. When the next duplication is made, the position, scaling and 
rotation are passed to it, and it must remain selected until the next duplication or the 
information will be lost.
Changes to object type are not duplicated. For example, if you create an object ten feet 
tall and then duplicate it and increase the height of the duplication to fifteen feet, 
successive duplications will have a height of fifteen feet--they will not grow in height by 
increments of five feet. If you wish to accomplish the effect of an incremental increase in 
size or shape, you must use the Scale Object Tool to adjust the size or shape of the first 
duplication and then duplicate it.
The Duplicate command only duplicates manipulations to the entire object. It does not 
duplicate edits to part of an object. 



Paste (Ctrl+V)
Paste pastes the contents of the Clipboard into the model. Clipboard contents can 
include objects, surface features or slices. Different rules apply for where these types of 
Clipboard content can be pasted. For example, you cannot paste a slice in the Design 
View because a slice has no meaning there. A slice can only be pasted in the Tumble 
Editor. Similarly, surface features only have meaning in the Surface Editor, and object 
polygonal outlines only have meaning in the Design View.
When pasting an object in the Design View or a surface feature in the Surface Editor, first
click where you want the center of the object or feature to be pasted and then choose 
Paste.
When pasting a slice in the Tumble Editor the angle of the slice is pasted as well as the 
position of the slice relative to the apparent origin and rotation of the object. A slice has 
a position and angle in the Tumble Editor, and if copied and pasted it will assume the 
same position. 
Paste also allows objects and grouped objects to be pasted to or from a library or another
model.



Delete 
Delete removes or deletes selected objects, surface features or slices without placing 
them in the Clipboard. Selected objects, surface features and slices can also be deleted 
by pressing the Del key or the Backspace key. The difference between Cut and Delete is 
that Delete removes objects completely, whereas Cut removes objects to the clipboard 
so that they may be pasted again. 
If you cut or delete something accidently, the Undo command under the Edit menu will 
save you as long as you choose Undo immediately after cutting or deleting.



Modify Selected
Modify Selected is a pullout submenu of modifiers that may be applied to selected 
objects in the Design View and to selected surface features in the Surface Editor. If a 
particular option is not available, it will be grayed. If the Walk View is active, all options 
are gray.
All of the options in the Modify Selected submenu mirror tools in the Design View Tools 
window or in the Surface Editor Tools window.
The Modify Selected options are as follows:
UnRotate 
UnScale 
UnSkew 
Opaque 
Translucent 
Transparent 
Single 
Double 
Flip 
Straight 
Pointed 
Rounded 
Sides 
Levels 



UnRotate
UnRotate removes any rotation of an object or surface feature applied with the Rotate 
Object Tool. You can also remove any rotation by selecting the object or surface feature 
and double-clicking the Rotate Object Tool in the Tools window.



UnScale
UnScale undoes any scaling modifications of an object or surface feature that were 
applied with the Scale Object Tool. Scaling can also be undone by double-clicking the 
Scale Object Tool    in the Tools window.



UnSkew 
UnSkew removes any skew modifications of an object that were applied with the Skew 
Object Tool. Skewing can also be removed by double-clicking the Skew Object Tool in the 
Tools window.



Color
Color opens the standard Windows Basic Color Palette and Custom Color Selector in one 
window. (The Color Palette and Custom Color Selector are normally displayed in separate 
windows.) With this option you may choose a new display color for all selected objects.
To select a new display color for the selected objects...
... point to the desired color in the Windows Basic Color Palette and click.
To define a custom color for the selected objects...
... point to a shade of color in the color refiner box (within the Custom Color Selector) and
click. To the left of the color refiner box is the Windows Vertical Luminosity Bar 
(brightness control). You may slide the Vertical Luminosity Bar up or down to change the 
shade of a color in the color refiner box, thus creating a custom color. If you wish to add 
a selected custom color to the Windows Basic Color Palette, click Add. (See your 
Windows documentation for more on standard Windows color functionality.)
The color of a selected object or surface feature can also be changed by dragging open 
the Color Bar    in the Tools window.



Opaque 
Opaque makes a selected object or surface feature opaque (solid). If individual object 
surface opacities have been modified with the Surface or Tumble Editors, they will not be
affected by this command. The object as a whole is turned opaque, but individual surface
edits override this modify command.
A selected object or surface feature can also be made opaque by double-clicking the 
Make Opaque Modifier    in the Tools window.



Translucent
Translucent makes a selected object or surface feature translucent (like glass). If 
individual object surface opacities have been modified with the Surface or Tumble 
Editors, they will not be affected by this command. The object as a whole is turned 
translucent, but individual surface edits override this modify command.
A selected object or surface feature can also be made translucent by double-clicking the 
Make Translucent Modifier in the Tools window.



Transparent
Transparent makes a selected object or surface feature transparent (invisible) except for 
a wire frame. (See Preferences, Rendering for more on wire frames.) If individual surface 
opacities have been modified with the Surface or Tumble Editors, they will not be 
affected by this command. The object as a whole is turned transparent, but individual 
surface edits override this modify command.
A selected object or surface feature can also be made transparent by double-clicking the 
Make Transparent Modifier in the Tools window.



Single 
Single inflates a selected object in one direction if it is already inflated in two directions. 
For example, if an object is inflated double-rounded, like a sphere, the Single modifier will
make the object inflate rounded, like a dome.
A selected object can also be inflated in one direction by double-clicking the desired 
Inflation Modifier in the Tools window.



Double
Double inflates a selected object in two directions if it is already inflated in one direction. 
For example, if an object is inflated pointed, like a pyramid, the Double modifier will 
make the object inflate double-pointed, like a diamond.
A selected object can also be inflated in two directions by double-clicking the desired 
Inflation Modifier in the Tools window.



Flip
Flip reverses the direction of inflation for a selected object if the object is already inflated
in one direction. A selected object can also be inflated in a reverse direction by double-
clicking the desired Inflation Modifier in the Tools window.



Straight
Straight inflates an object with straight sides perpendicular to the object base, like a box.
An object can also be inflated straight by double-clicking the Inflate Straight Modifier in 
the Tools window.



Pointed
Pointed inflates an object with sides that converge to a point, like a pyramid. An object 
can also be inflated pointed by double-clicking the Inflate Pointed Modifier in the Tools 
window.



Rounded 
Rounded inflates an object with sides rounded to a point, like a dome. An object can also 
be inflated rounded by double-clicking the Inflate Rounded Modifier in the Tools window.



Sides
Sides allows you to change the number of sides for an object created with the N-Sided 
Object Tool. The maximum number of sides allowed is 32; however, the more sides in 
your objects, the slower your walk speed. With this command you can alter the existing 
sides of objects. (See Preferences, Defaults .)



Levels
Levels allows you to change the number of levels for an object whose inflation type is 
rounded or double-rounded. The maximum number of levels allowed is 16; however, the 
more levels in your objects, the slower your walk speed. With this command you can 
alter the existing levels of objects. 
Levels of a rounded object are doubled if the object is inflated double-rounded. When an 
object is double-rounded the maximum number of levels is 32 -- 16 levels in one 
direction and 16 in the opposite direction. (See also, Preferences, Defaults .)



Select All (Ctrl+A)
Select All selects all objects (displays all handles). If your entire model is being created 
as a library item, use the Select All command to select all the objects and then group 
them together with Group under the Design menu.
All objects can also be selected by double-clicking the Select Object 
Tool.



 UnSelect All (Ctrl+Shift+A)
UnSelect All unselects objects or surface features (removes handles). Another method of 
unselecting is clicking on the background in the Design View or Surface Editor.



Hide Selected (Ctrl+H)
Hide Selected hides selected objects and surface features. Hiding objects or surface 
features allows you to work with overlapping objects or surface features without having 
to shuffle them. (See Surface Editor for more on shuffling surface features.) 
By default, hidden objects are hidden in the Design View and surface features are hidden
in the Surface Editor, but they remain visible in the Walk View. By using the Ctrl key in 
conjunction with Hide Selected, you can hide objects and surface features in the Walk 
View.
To hide objects in the Walk View...
... select the object(s) or surface feature(s), hold down the Ctrl key and choose Hide 
Selected under the Edit menu.
Use of the Ctrl key with this menu command nullifies the use of the Ctrl-H key equivalent.
You must always select from the menu if you use the Ctrl key.
Once objects or surface features are hidden in the Walk View, you can hide them in the 
Design Views and Surface Editor as well.
Selecting Show All or double-clicking the Hide Object Tool shows your hidden objects and 
surface features. The Show All command and the Hide Object Tool also function with the 
Ctrl key. (See Show All .)
Hidden objects and surface features are made visible before the model is saved so that 
all objects and surface features are displayed when the model is reopened.



Show All (Ctrl+Shift+H)
Show All displays all objects or surface features that have been hidden with either the 
Hide Object Tool or the Hide Selected command.
If objects or surface features are hidden in the Walk View, the Ctrl key must be held down
in conjunction with Show All to display them. If using the Ctrl key with this command, you
must select the command from the menu; you cannot use the command key equivalent.



Lock Selected
Lock Selected locks selected objects in the Design View and selected surface features in 
the Surface Editor. Locking objects or surface features prevents them from being edited. 
When an object or surface feature is locked, its polygonal outline is dotted rather than 
solid.
Selecting UnLock All or double-clicking the Lock Object Tool will unlock all locked objects 
and surface features. The Lock Object Tool can also be used to lock objects and surface 
features.
Objects can also be locked if the layer they are in is locked. (See Layer Menu .)
Locked objects and surface features are saved as locked so if the model is saved, any 
locked objects or surface features remain locked when the model is reopened.



UnLock All
Unlock All unlocks all objects or surface features locked with the Lock Object Tool or with 
the Lock Selected command to allow editing.
All locked objects or surface features can also be unlocked by double-clicking the Lock 
Object Tool.
To unlock individual objects...
... hold down the Ctrl key and click the objects with the Lock Object Tool. (See Lock 
Object Tool .)



Preferences (Ctrl+;)
Preferences opens the Preferences dialog. The Preferences dialog allows you to set 
preferences for the appearance of the Design and Walk Views, navigation, measurement 
units and other application and model attributes. With the Preferences dialog you can 
customize your application.
The preferences are separated into different groups. To view the different groups of 
preferences, mouse down on the pop-up menu to the right of the word Preferences: and 
drag to select a group of preferences.
Each time you save a Virtus WalkThrough model, any changes you made to the 
preference settings are saved with it. When you open the model again, its preferences 
are restored and override the application preferences.
The buttons at the bottom of the dialog determine if the preference settings are to be 
used for new models, and they allow you to reset the preferences to the factory-set 
defaults. 
Default Button 
Revert Button 
OK Button 
Cancel Button 
The pop-up menu next to the word Preferences at the top of the dialog has five 
selections. Each of the five selections displays specific options within the Preferences 
dialog. The five selections and their options are as follows:
Editor 
Rendering 
Navigation 
Defaults 
Units 



Default Button
Default saves the current preferences as the application default preferences. Application 
default preferences apply to all new models you create. If you open an existing file, that 
files preferences will override the application defaults.



Revert Button
Revert resets the preferences to the last selection of Default. If you wish to reset the 
preferences to the factory-set defaults, you must remove the VWALK.INI file from your 
Virtus directory.



OK Button
OK applies any Preferences dialog changes to the current model.



Cancel Button
Cancel voids any changes you made to the preferences.



Preferences, Editor
The Editor options allow you to change preferences common to the Design Views, 
Surface Editor and Tumble Editor. The Preferences, Editor options are as follows:
AIDS
Show Ruler
Displays rulers (see Rulers )
Show Grid
Displays the background grid based on the ruler major tick marks (see Grid Lines )
Show Depth
Displays the Depth Controls on the rulers (see Depth Controls )
Show Guides
Displays Non-Reproducing Guidelines (see Non-Reproducing Guidelines )
Show Origin
Displays Movable Origin (see Movable Origin )
Snap to Grid 

COLOR
Ruler
Lets you specify ruler color (see Rulers , see also Color Bar )
Grid
Lets you specify Grid color (see Grid Lines, see also Color Bar )
Depth
Lets you specify Depth Control color (see    Depth Controls, see also Color Bar )
Guide 
Lets you specify Non-Reproducing Guideline color (see    Non-Reproducing Guidelines, see
also Color Bar )
Origin 
Lets you specify movable Origin color (see    Movable Origin, see also Color Bar )
Background
Lets you specify background color 
The background color is the color of the drawing area in the Design Views, Surface Editor
and Tumble Editor. (See Color Bar .)

TRACKING
World
Displays information in the Position Indicator in X, Y and Z coordinates (see Position 
Indicator )
View
Displays information in the Position Indicator in horizontal and vertical screen coordinates
(see Position Indicator )



Snap to Grid
Snaps objects, surface features and slices to an invisible grid when they are created, 
moved or edited
The grid is based on the ruler tick marks in the Design View, Surface Editor and Tumble 
Editor. Handles of objects, surface features and slices will "snap to" the grid when Snap 
to Grid is selected.
If you zoom in or out, the ruler tick marks change, therefore, the invisible grid changes. 
For example, if each tick mark represents one inch, handles snap to the nearest inch. If 
each tick mark represents one foot, handles snap to the nearest foot.
If Snap to Grid is not selected, the ability to create, edit and move objects, surface 
features and slices is constrained only by screen pixels.
If an object, surface feature or slice is created with Snap to Grid unselected and then 
edited or moved with Snap to Grid selected, the result is the object or surface feature will
move in increments of the invisible grid but wont actually snap to the grid. This makes it 
possible for handles to fall between the ruler tick marks and it can become frustrating 
trying to align objects or surface features. However, if you move a handle rather than the
whole object or surface feature, it will snap to the grid.
Snap to Grid can also be selected and unselected under the Design menu, the Surface 
menu or the Tumble menu.



Preferences, Rendering
The Rendering options allow you to change preferences related to rendering in the Walk 
View. The Preferences, Rendering options are as follows:
SHADING
Shaded
Displays objects with the effects of lighting (see Lighting Editor )
Unshaded 
Displays object colors with no lighting effects
White
Displays objects with no color (white color fill) and no lighting effects

DRAWING
Fill & Frame
Displays both the color fill and wire frame of objects
Fill
Displays only the color fill of objects with no wire frame
Frame
Displays only the wire frame of objects
Frame color is a shade darker than the fill color unless Black Frames is selected.
Black Frames
Displays all object wire frames in black
If unselected, wire frames are displayed two shades darker than the color of the object or
surface feature. Black Frames makes the distinction between two adjacent surfaces more
apparent, and is therefore sometimes helpful when printing.
Print Fill
Prints objects with black lines and white surfaces (hidden line removal)
The printed result is a clean line drawing. 

OPENINGS
See In
Allows you to see in from outside an object through translucent and transparent surfaces
and surface features
See Out
Allows you to see out from inside an object through translucent and transparent surfaces
and surface features
See Through
Allows you to see connections between objects made with the Connect Surfaces Tool 

Flash Graphics
Flash Graphics turns on Virtus Corporation drawing routines and uses those routines 
instead of the standard Microsoft Windows drawing routines. Flash Graphics substantially
speeds up the Virtus WalkThrough application. Usually, Flash Graphics is turned on by 



default; however, some video boards are not compatible with Flash Graphics. The Virtus 
WalkThrough application checks for compatibility with your system when you install, and 
if a conflict is detected, Flash Graphics is turned off. (More on Flash Graphics .)

Dithering
Dithering is a technique which allows more colors, thus more color accurate renderings. 
Dithering is turned on by default. The downside of Dithering is the screen appears more 
grainy.

Blended Translucency 
Blended Translucency offers a smoother look to translucent surfaces and, in most cases, 
a faster walk speed than in previous versions of Virtus WalkThrough. Blended 
Translucency applies the color of translucent surfaces to objects you can see beyond the 
translucent surfaces. If Blended Translucency is turned off (not selected), a colored dot 
pattern represents translucent surfaces in the rendering.



Preferences, Navigation
The Navigation options allow you to change preferences related to navigating the 
Observer through the Walk View and related to Walk View features. The Navigation 
options are as follows:
AIDS
Button Down
If this option is selected, the Observer moves when the mouse button is pressed and 
stops when the mouse button is released. If this option is not selected, the Observer 
moves when the mouse button is released and stops when the mouse button is pressed.
Cross Hair
Displays a cross hair in the Walk View used as a reference point for direction and speed 
of the walk through (see Navigation Methods )
Velocity Grid
Displays horizontal and vertical marks at increments relative to the cross hair where walk
speed changes

CAMERA
Film
Allows you to specify the size in millimeters of the image on film
Lens
Allows you to specify a lens focal length for the view
Film and Lens work together to determine the angle of view as illustrated.
Aspect Ratio
The aspect ratio is the ratio of horizontal to vertical screen dimensions. Aspect Ratio 
options are: 35 mm Horz 36:24, 35 mm Vert 24:36, 2.25 Square 1.1, 4x5 Horz 5:4, 4x5 
Vert 4:5, Television 133:1:00, Academy Aperture 133:100, Euro Wide Screen 166:100, US 
Wide Screen 185:100, Anamorphic Aperture 235:100.
To change the aspect ratio, point to the aspect ratio pop-up and mouse down. Drag to 
select the desired aspect ratio. After selecting the desired aspect ratio, you must select 
the Aspect Ratio checkbox to apply the new aspect ratio to the Walk View.
If the Aspect Ratio checkbox is selected, the aspect ratio displayed in the pop-up menu 
box will override any size options set in the Snapshot dialog. (See Snapshot .)



Preferences, Defaults
The Defaults options allow you to change preferences related to object depth in the 
Design Views. The Preferences, Defaults options are as follows:
FROM TO
X
Sets the default Depth Control value (inflation distance and position) for objects inflated 
along the X axis
Values must be entered in base units.
Y
Sets the default Depth Control value (inflation distance and position) for objects inflated 
along the Y axis
Values must be entered in base units.
Z
Sets the default Depth Control value (inflation distance and position) for objects inflated 
along the Z axis
Values must be entered in base units.

HOME
X, Y, Z
Sets the default home position in X, Y and Z coordinates
The home position can also be changed with commands under the View menu. If you 
enter coordinates in the text boxes you must enter the coordinates in base units. (See 
Model Unit .)

Sides
Allows you to specify the number of sides for an object or surface feature drawn with the 
N-Sided Object Tool 
The maximum number of sides allowed is 32; however, the more sides in your model, the
slower your walk speed. It is wise to keep the number of sides at the minimum required 
to represent the desired shape.
Levels
Allows you to specify the number of levels for an object whose inflation type is rounded 
or double-rounded
The maximum number of levels allowed is 16; however, the more levels in your objects, 
the slower your walk speed. It is wise to keep the number of levels at the minimum 
required to represent the desired shape. 
Levels of a rounded object are doubled if the object is inflated double-rounded. When an 
object is double-rounded, the maximum number of levels is 32 -- 16 levels in one 
direction and 16 in the opposite direction.



Preferences, Units
The Units options allow you to change preferences related to measurement units and 
world size.
The Virtus world is a cube of 65,536 base units across; however, you may select a 
measurement base unit. This allows the world to be virtually any size, measured in units 
ranging from angstroms to light-years. The relative resolution within the world does not 
change, however. This means that as the measurement unit size increases, the world 
becomes more granular. Conversely, as the size decreases, the world becomes more 
precise.
The Preferences, Units options are as follows:
RULER UNIT
Allows you to select a unit for display on the rulers in the Design Views, Surface Editor 
and Tumble Editor
Selecting Custom for Ruler Unit is a special case. Custom allows you to select a custom 
ruler unit. Selecting this option displays the following:

Custom Name - A text box for you to enter the name of your custom unit
Sym - A text box for you to enter the symbol that will appear on the rulers and
will represent your custom unit
Size - A text box for you to enter the size of your custom unit relative to one 
meter

Promotable - Determines if units are displayed on the rulers in sub-units and super-
units as zoom scale changes
For example, if you select Meter as the unit and promotable is selected, when you zoom 
in after a point the rulers will display Centimeters, and when you zoom out after a point 
the rulers will display Kilometers.

Model Unit 



Model Unit
The two possible options for Model Unit are Size and World. Size allows you to specify a 
multiple or fraction of the unit you selected and assign the result as the base unit. This is
helpful if you want your rendering to be more detailed.
Since Virtus WalkThrough renders to the nearest base unit, a base unit size of.25 inches 
gives a more precise rendering than a base unit size of 1ft. Also, any surfaces smaller 
than the base unit tend to collapse in on themselves when rendered in the Walk View. 
The downside of a smaller base unit is the overall size of the world shrinks. If you are 
modeling several city blocks, a base unit of.25 is impractical because the world will be 
too small to fit the city blocks.
Likewise, you can enter a number in the World text box and change the overall size of 
the world. For example, the world is approximately 65K base units across. If you have 
meters selected as the unit, you can enter 2 in the Size text box. The result is a world of 
65K two-meter base units or 130K meters across. Or if you decrease the size of the World
text box to 32.5K and have meters selected as the unit, the base unit Size would be.5 
meters. Size and World are directly proportional; as the size increases, the world also 
increases.
Multiples of 2 or divisions of 2 are the best choices for the model unit options to avoid 
rounding errors.



View Menu
The View menu allows you to open new Design Views, change a Design View that is 
already open to another view, make the Walk View active, access the Lighting Editor for 
the Virtus world and manipulate the position of the Observer and the center of the active
view.
Change View 
New View 
Home Commands
The concept of "home" is important because the following four View menu commands 
relate to the home position. Home is a 3D location in the world that can be used as a 
base or reference for the Observer or for a Design View. The default home position is 
0,0,5'6". 
The following four View menu commands allow you to specify the home position, move 
the Observer to the home position or move the center of the active view to the home 
position. 
You may also set the Home position in the Preferences, Defaults dialog.

Set Home to Editor 
Set Home to Observer 
Home Editor 
Home Observer 

Center Observer 
Reset Origin 
Level Observer 



Change View
Change View is a pullout submenu listing possible Design Views which the current Design
View window can be changed to. (See also New View .) Change View is only available 
when a Design View or the Surface Editor is active. If an option in the Change View 
submenu is not available, it will be grayed.
The Change View options are Top, Bottom, Front, Back, Left, Right and Opposite.
Selecting one of the views on the Change View submenu will change the active Design 
View to the selected view. This allows you to move quickly between Design Views without
having to open a window for each view. (See also New View .)
Opposite
Opposite is used in the Surface Editor to flip the selected surface so you are able to see 
and edit the opposite side. It also changes the action of the Placement Modifiers. (See 
Surface Editor .)
Opposite is used in the Design Views to change the current view to its opposite parallel 
view. For example, if youre in the Top View, Opposite will change the view to the Bottom 
View. Left and Right are opposite, as are Front and Back.



New View
New View is a submenu listing possible views which can be opened in a new window (see
also Change View ). The new views you can open include the Design Views, the Walk 
View and the world lighting.
Selecting a view name from the list opens a new view window. The new window is 
positioned slightly off center of the active window. It is possible to "stack" several 
windows on top of each other, but this is not recommended since open windows in Virtus 
WalkThrough require memory to show the representations of objects, and memory is 
precious.
All open views are listed under the Window menu.
It is better to use Change View to switch between windows in the Design Views because 
Change View does not open a new window, rather, it changes an already open window.
Walk View
Walk View creates a Walk View if one is not currently displayed. If a Walk View is 
currently displayed this command will make the Walk View the active view. Unlike Design
Views, only one Walk View can be open at any time.
World Lighting
World Lighting opens the Lighting Editor for the Virtus World. (See Lighting Editor .) You 
can also open the World Lighting Editor by double-clicking the Lighting Editor icon in the 
Tools window.



Set Home to Editor
Set Home to Editor specifies home as the center of the current Design View window. By 
using the home position as a reference point you can quickly move the Observer or the 
center of the active Design View to the home position from anywhere in the Design View 
window. To move the Observer home, use the Home Observer command. To move the 
center of the Design View home, use the Home Editor command.
Because each Design View is 2D, this command only changes the home position on the 
axes associated with the particular Design View. (See Dimensions XYZ.) You can, 
however, set 3D coordinates by setting the home position in two perpendicular Design 
Views. For example, setting the home position in the Top View specifies the X and Y 
coordinates. If you change to a view perpendicular to the Top View (the Front, Back, Right
or Left), you can use the scroll bars or the Move View Tool to adjust the view along the Z 
access. After adjusting the view so the center is at the desired Z coordinate, select Set 
Home to Editor again, and this will set the home Z coordinate.
If you change the Origin of the view (see Movable Origin ) after setting the home 
coordinates, home is still defined by the true coordinates.



Set Home to Observer
Set Home to Observer specifies home as the position of the Observer. By using the home
position as a reference point, you can quickly move the Observer or the center of the 
active Design View to the home position from anywhere in the active Design View 
window. To move the Observer home, use the Home Observer command. To move the 
center of the Design View home, use the Home Editor command.
Because each Design View is 2D, this command only changes the home position on the 
axes associated with the particular Design View. (See Dimensions .) You can, however, 
set 3D coordinates by setting the home position in two perpendicular Design Views. For 
example, setting the home position in the Top View specifies the X and Y coordinates. If 
you change to a view perpendicular to the Top View (the Front, Back, Right or Left), you 
can drag the Observer to a new position along the Z axis. After adjusting the Observer to
the desired Z coordinate, select Set Home to Observer again, and this will set the home 
Z coordinate.
If you change the Origin of the view (see Movable Origin ) after setting the home 
coordinates, home is still defined by the true coordinates.



Home Editor
Home Editor returns the center of the active Design View to the home position. Home is 
specified with the Set Editor to Home command, the Set Observer to Home command or 
in the Preferences, Defaults dialog.
If you change the Origin of the view (see Movable Origin ) after setting the home 
coordinates, home is still defined by the true coordinates.



Home Observer
Home Observer returns the Observer to the home position. Home is specified with the 
Set Editor to Home command, the Set Observer to Home command or in the Preferences,
Defaults dialog.
If you change the Origin of the view (see Movable Origin ) after setting the home 
coordinates, home is still defined by the true coordinates.



Center Observer
Center Observer moves the Observer to the center of the active Design View.



Reset Origin
Reset Origin resets the Origin to true 0,0 coordinates if it has been changed. (See 
Movable Origin .) 



Level Observer (Ctrl+Y)
Level Observer orients the line of sight in the Walk View, making it level if it has been 
altered with the Shift key when navigating. (See Navigation Methods .)



Design Menu 
The Design menu is available only when a Design View is active. If the Surface Editor, 
Tumble Editor, Lighting Editor or Walk View is active, the Design menu is replaced with 
the active windows associated menu.
Snap to Grid 
Zoom In (Ctrl + =) 
Zoom Out (Ctrl + -) 
New Layer 
Delete Layer 
Group (Ctrl+G) 
UnGroup (Ctrl+Shift+G) 



Zoom In (Ctrl + =)
Zoom In increases the apparent scale and the apparent size of objects in the view by a 
factor of 2. With each Zoom In, the minor tick marks on the rulers represent a smaller 
unit of measurement. There is a limit to the range of the Zoom In command. When you 
reach the limit, selecting Zoom In will have no affect.
Zooming in can also be accomplished by clicking the Zoom In Tool. Zoom Out reverses 
the effect of Zoom In.



Zoom Out (Ctrl + -)
Zoom Out reduces the apparent scale and the apparent size of objects in the view by 
half. With each Zoom Out, the minor tick marks on the rulers represent a larger unit of 
measurement. There is a limit to the range of the Zoom Out command. When you reach 
the limit, selecting Zoom Out will have no effect.
Zooming out can also be accomplished by clicking the Zoom Out Tool. Zoom In reverses 
the effect of Zoom Out.



New Layer
New Layer lets you add a new layer to the Layer List. If you select New Layer, a dialog 
appears with a text box in which you can type the new layer name. (See also Layer List 
and Layer Menu .)



Delete Layer
Delete Layer deletes the selected layer in the Layer List. If you select Delete Layer you 
will be prompted to verify the deletion. (See also Layer List and Layer Menu .)



Group (Ctrl+G)
Group groups all selected objects treating them a single object. A grouped object can be 
moved, copied, rotated and scaled. It is important to group library items with the Group 
command before copying them to a library. 



UnGroup (Ctrl+Shift+G)
UnGroup ungroups selected objects that were grouped with the Group command. Once 
you ungroup an object, all the objects that make up the group remain selected until you 
click somewhere else inside the view. This means if you want to change the color of a 
grouped object, you can ungroup it, select a new color and group the objects again. This 
only works if you want all objects within the group to be the same color.
It is possible to have groups within other groups. If you ungroup an object but cannot edit
it, try ungrouping again.



Light Menu
The Light menu is available only when the Lighting Editor is the active window. If the 
Design View, Surface Editor, Tumble Editor or Walk View is active, the Lights menu is 
replaced with the active windows associated menu. (See also Lighting Editor .)
Apply Changes 
Revert 
New Light 
Delete Light 



Apply Changes
Apply Changes causes the changes made within the Lighting Editor to be applied to the 
interior of the selected object or to the world in your Virtus WalkThrough model. If you 
make changes in the Lighting Editor and you do not select Apply Changes, you will be 
prompted to apply the changes or cancel them when you close the Lighting Editor.



Revert
Revert changes the Lighting Editor back to the way it was when you last selected Apply 
Changes. If you made changes to the Lighting Editor, but you dont like the changes, you 
can basically "erase" them with Revert as long as you have not applied the changes first.



New Light
New Light adds a new light to the Lights List. The new light can be directional or ambient
and can have color. (See Lighting Editor .)



Delete Light
Delete Light removes the selected light from the Lights List.



Surface Menu
The Surface menu is available only when the Surface Editor is the active window. If the 
Design View, Tumble Editor, Lighting Editor or Walk View is active, the Surface menu is 
replaced with the active windows associated menu. (See also Surface Editor .)
Snap to Grid 
Zoom In (Ctrl + =) 
Zoom Out (Ctrl + -) 
Move Forward 
Move to Front 
Move Back 
Move to Back 



Move Forward
Used with multiple surface features which overlap, Move Forward shuffles the order of 
the overlapping features by moving a selected surface feature forward one position. For 
example, if the selected surface feature has three surface features in front of it, Move 
Forward will cause only two surface features to be in front of the selected feature. The 
third surface feature will move behind the selected feature.



Move to Front
Used with multiple surface features which overlap, Move to Front shuffles the order of 
the overlapping features by moving a selected surface feature to the front of all the 
overlapping features.



Move Back
Used with multiple surface features which overlap, Move Back shuffles the order of the 
overlapping features by moving a selected surface feature back one position. For 
example, if the selected surface feature has two surface features in front of it and two 
behind it, Move Back will cause three surface features to be in front of the selected 
feature and only one behind it.



Move to Back
Used with multiple surface features which overlap, Move to Back shuffles the order of the
overlapping features by moving a selected surface feature to the back of all the 
overlapping features.



Tumble Menu
The Tumble menu is available only when the Tumble Editor is active. If the Design View, 
Surface Editor, Lighting Editor or Walk View is active, the Tumble menu is replaced with 
the active windows associated menu. (See also Tumble Editor .)
Snap to Grid 
Zoom In (Ctrl + =) 
Zoom Out (Ctrl + -) 
Reverse Slice (Ctrl + ,) 
Momentum 



Reverse Slice (Ctrl + ,)
Reverse Slice changes which side of a slice is removed. The direction the slice line is 
drawn through an object determines which side of the object is removed. If you drag 
from left to right or from top to bottom, the portion above or to the right of the line will 
be sliced off. If you drag from right to left or from bottom to top, the portion below or to 
the left of the line will be sliced off. Reverse Slice reverses the slice direction. 
The Reverse Slice effect can also be achieved by holding down the Ctrl key when the 
slice line is drawn.



Momentum
Momentum causes an object in the Tumble Editor window to continue tumbling after it is 
set in motion. (See Move Tool .)



Walk Menu
The Walk menu is available only when the Walk View is active. If the Design View, 
Lighting Editor, Surface Editor or Tumble Editor is active, the Walk menu is replaced with 
the active windows associated menu.
Button Down 
Cross Hair 
Velocity Grid 
Normal 
Faster 
Fastest 
Record 
Play 
Stop 
Aspect Ratio 
Full Screen 



Button Down
Button Down controls how movement in the Walk View starts and stops. If Button Down 
is selected (denoted by a check), movement begins when you press and hold down the 
mouse button. When you release the mouse button, movement stops.
If Button Down is not selected, movement stops when you press and hold down the 
mouse button and begins when you release the mouse button. (See Navigation 
Methods .) Button Down can also be selected in the Preferences, Navigation dialog under 
the Edit menu.



Cross Hair
Cross Hair turns on and off the display of the cross hair in the center of the Walk View. 
The cross hair orients the mouse pointer when navigating through the model. (See 
Navigation Methods .) The cross hair can also be turned on and off in the Preferences, 
Navigation dialog under the Edit menu.



Velocity Grid
Velocity grid marks are the horizontal and vertical marks in the Walk View which display 
the points at which walk speed changes. Novice Virtus WalkThrough users may find the 
velocity grid helpful while learning to navigate. The default for the velocity grid marks is 
off (not visible), but they can be turned on and off with the Velocity Grid command under 
the Walk Menu or by selecting Velocity Grid in the Preferences, Navigation dialog under 
the Edit menu. 



Normal
Normal displays all translucent and transparent object surfaces and surface features and 
displays object color fill and wire frames. These object rendering attributes can also be 
selected in the Preferences, Rendering dialog under the Edit menu.



Faster
Faster speeds up your walk through by not allowing you to see through transparent or 
translucent object surfaces or surface features. Object rendering attributes can also be 
selected in the Preferences, Rendering dialog under the Edit menu.



Fastest
Fastest speeds up your walk through by displaying only wire frames of objects, no object 
color fill is displayed. Object rendering attributes can also be selected in the Preferences,
Rendering dialog under the Edit menu.



Record
Record allows you to record a walk path. You may also record a walk path by selecting 
the Record Tool in the Tools window. Record allows access to the recording function when 
in Full Screen mode.



Play
Play allows you to play back a recorded walk path. You may also play back a walk path by
selecting the Playback Tool in the Tools window. Play allows access to the playback 
function when in Full Screen mode.



Stop
Stop stops a recorded walk path if one is playing. You may also stop a recorded walk path
by selecting the Stop Tool in the Tools window.



Aspect Ratio
Aspect Ratio reads the aspect ratio setting in the Preferences, Navigation dialog and 
applies it to the Walk View. Aspect Ratio can also be selected in the Preferences, 
Navigation dialog under the Edit menu.



Full Screen
Full Screen opens the Walk View window to cover your full computer screen, including 
the Menu Bar. The Menu Bar is still there, but it is hidden. If you point to the normal 
position of the Menu Bar you can still pull down the menus.
To change back to a normal screen mode, find the Walk menu by pointing to its normal 
position and select Full Screen again.



Window Menu
The Window menu displays the names of all open windows, views and models and 
contains commands for displaying the Tools window and the Depth window. The Window 
menu helps you quickly navigate through open views and open models.
The lower section of the Window menu lists all open models. You can select a model 
name from the list and that model will become the active model and move to the front of
your computer screen.
The middle section of the Window menu lists all open views for the active model. You can
select a view name from the list and that view will become the active view and will move
to the front of your computer screen. 
Tools Window (Ctrl + ]) 
Depth Window (Ctrl + [) 



Tools Window (Ctrl + ])
Tools Window displays or hides the Tools window. There is only one Tools window, though 
there are several sets of tools. If the Tools window is hidden in one view or editor, it is 
hidden for all views and editors.



Depth Window (Ctrl + [)
Depth Window displays or hides the Depth window. The Depth window is a ruler, like the 
Design View rulers, that contains a Depth Control. (See Depth Controls .) The Depth 
window displays the position and inflation distance for the active design view. If you 
change to another design view, the Depth window will change to display the position and
inflation distance for the new view.
The measurement scale of the Depth window ruler is the same as the scale of the rulers 
in the Design View. As you zoom in or out in the view windows, the Depth window ruler 
scale changes.



Help Menu
The Help menu allows you to search an online text file for help on Virtus WalkThrough 
functionality. The Help menu is a standard Windows menu. See your Windows 
documentation for more on the Help menu.
Contents
Contents displays an alphabetical listing of all topics available in the online help file. 
Search for Help On
Search for Help On allows you to enter a text string to search for specific information 
within the online help file.
How to Use Help
How to Use Help displays information about the Windows Help menu system and 
instructions for its use.
About Virtus WalkThrough
About Virtus WalkThrough displays the version number and copyright notice of your 
Virtus WalkThrough application.



Layer Menu
Layer menu options and commands allow you to put objects in layers and manipulate 
those layers. The Layer menu cannot be accessed from the Menu Bar. The Layer menu is 
accessed by pointing to a layer name in the Layer List (see Layer List ) and pressing and 
holding down the mouse button. When the Layer menu is displayed, drag the mouse to 
make a menu selection.
Adding and removing layers is done with commands under the Design menu. (See New 
Layer , Delete Layer .)
Change Name 
Change Color 
Color by Object 
Lock 
Hide 
Features 
Render 



Change Name (Layer)
Change Name opens a pop-up dialog containing a text box where you can enter a new 
name for the layer. When you have entered the name press Enter or click OK.



Change Color (Layer)
Change Color opens the standard Windows Basic Color Palette and Custom Color Selector
in one window. (The Color Palette and Custom Color Selector are normally displayed in 
separate windows.) With this option you can choose a new Design View display color for 
all objects within the layer.
To select a new Design View display color for the layer...
... point to the desired color in the Windows Basic Color Palette and click.
To define a custom color for the layer...
... point to a shade of color in the color refiner box (within the Custom Color Selector) and
click. To the left of the color refiner box is the Windows Vertical Luminosity Bar 
(brightness control). You can slide the Vertical Luminosity Bar up or down to change the 
shade of a color in the color refiner box, thus creating a custom color. If you wish to add 
a selected custom color to the Windows Basic Color Palette, click the Add button. (See 
your Windows documentation for more on standard Windows color functionality.)
The layer color is displayed as a rectangular box in the Layer List next to the layer name.



Color by Object (Layer)
If Color by Object is selected, the polygonal outlines of objects within the layer are 
displayed in the color each was last assigned, thus overriding the layer color.



Lock (Layer)
Lock locks the layer and all objects in it so they cannot be edited. Locked objects appear 
as dotted polygonal outlines. 
The Lock option under the Layer menu is not associated with the Lock Object Tool or the 
Lock Selected and Unlock All commands in the Edit menu and is not affected by their 
use. If a layer is locked using the Lock option in the Layer menu, it can be unlocked only 
by selecting the Lock option the Layer menu again.
If a layer is locked, the layer color will appear in the Layer List next to the layer name as 
a shaded (screened) rectangle.



Hide (Layer)
Hide hides the layer and all objects in it so they cannot be seen or edited. 
The Hide option under the Layer menu is not associated with the Hide Object Tool or the 
Hide Selected and Show All commands under the Edit menu and is not affected by their 
use. If a layer is hidden with the Hide option in the Layer menu, it can be re-displayed 
only by selecting the Hide option in the Layer menu again.
If a layer is hidden, the layer color will not appear in the Layer List next to the layer 
name.



Features (Layer)
If an object in the layer has surface features, the Features option displays the surface 
features in the Design Views. 



Render (Layer)
Render displays the layer objects in the Walk View. If not selected, the objects in the 
layer are not displayed in the Walk View.





Lighting Editor
Overview
There are two kinds of Lighting Editor: the Object Lighting Editor and the World Lighting 
Editor. Both look and function the same.
A contained object assumes the same lighting as its container until the individual lighting
of the contained object is changed. This is true for the world lighting as well since all 
objects are contained within the Virtus world. The world lighting affects all objects until 
each objects individual lighting is changed. Once an objects lighting is changed, its 
interior is not affected by lighting changes made to its containing object or to the Virtus 
world; however, the exterior lighting is affected.
To open the Object Lighting Editor...
... select the object whose lighting you wish to edit. Click the Lighting Editor Tool, then 
click the selected object,
... or click the Lighting Editor Tool and double-click the object whose lighting you wish to 
edit.
To open the World Lighting Editor...
... choose World Lighting in the New View submenu under the View menu,
... or double-click the Lighting Editor Tool. 
When the Lighting Editor is opened, a window containing a Subject Cube appears along 
with a Lights List in the Tools window. Also, a new menu, the Light menu , appears on the
menu bar.

Subject Cube
At the top of the Lights List is the word Subject. Subject refers to the Subject Cube within 
the Lighting Editor window. The Subject Cube represents objects contained within the 
object you are editing and shows how light affects those objects. The Subject Cube can 
be rotated so you may view different sides and see the effects of light sources on the 
cube.
The Color Bar    allows you to change the color of the Subject Cube. This is used to see 
how different object colors are affected by different colored light sources. By changing 
the color of the Subject Cube you can simulate the color of the contained objects or walls
of the object whose lighting you are editing. 
The Color Bar    functions the same as the Color Bar in the Design Views. Mouse down on 
the Color Bar and drag to choose a color. (See Color Bar.)

Light Sources
Beneath the Color Bar is the Lights List, a list of existing light sources. Light sources can 
be added or deleted with the New Light and Delete Light commands in the Lights menu. 
It is possible, but not practical, to have thousands of light sources. A practical range is 
three to ten.
Each light source in the Lights List consists of two check boxes and a Color Bar. The first 
check box, on the left, indicates whether the light source is turned on. 
The second check box indicates what type the light is. A light source can be either 
ambient or directional. Only one ambient light is necessary. (More than one ambient light



is possible, but the colors and intensity will either wash each other out, creating white 
light, or they will have an almost undetectable effect on each other.) A single arrow in 
this box indicates a directional light source. An X in the box indicates an ambient light 
source. To change between directional and ambient click the check box.
Each light source has its own Color Bar . The Color Bar for each light source functions the
same as the Color Bar in the Design Views. Mouse down on the Color Bar    and drag to 
choose a color for the light source. (See Color Bar.)
To modify a light source...
... select a light source by clicking it in the Lights List. (Make sure the light source is 
turned on, indicated by a check mark in the left box of the individual light source in the 
light list.)
When you click a light source on the Lights List, the light appears in the Lighting Editor 
window. If the selected light source is ambient, the background of the Lighting Editor 
window will display the color of the ambient light. 
If a selected light source is directional, a cylindrical light will appear near the Subject 
Cube. Directional light sources can be positioned to shine on different surfaces of the 
Subject Cube. 
To position a directional light source...
... select a light source in the Lights List. Point to the cylindrical light near the Subject 
Cube. Drag to rotate the light source to the desired position. The directional light sources
rotation is affected by the Rotation Constraint Tools. (See Rotation Constraint below.)
If a directional light source is selected in the Lights List and you wish to rotate the 
Subject Cube, you must click Subject in the Tools window to toggle off the directional 
light source first. 
To add a new light source...
... choose New Light under the Lights menu.
To remove a light source...
... select the light source you wish to delete in the Light List. Choose Delete Light under 
the Lights menu.

How Lights Affect Objects
Because the Lighting Editor affects the interior of the object you edit, the Subject Cube 
can be misleading. For example, if a yellow directional light is positioned so that it shines
on the front (F) of the Subject Cube, the back (B) interior surface of the object will appear
yellow, not the front; however, the front of any contained objects will appear yellow. The 
yellow light is coming from the front of the object, passing through the interior and 
hitting the back of the interior. Remember, the Subject Cube represents contained 
objects.
After modifying the lighting, you must apply the changes to the selected object or world. 
To apply the changes choose Apply under the Lights menu. If you forget to apply the 
changes, you will be prompted to do so when you close the Lighting Editor.

Rotation Constraint
The Rotation Constraint Tools affect how the Subject Cube and the directional light 
sources in the Lighting Editor window can be rotated. There are three Rotation Constraint



Tools. The default is all three selected. The Rotation Constraint Tools may be turned off 
and on by clicking; however, at least one tool must be selected at any time.
If a Rotation Constraint Tool is turned off, rotation is not allowed in the direction 
associated with that tool. To unselect a Rotation Constraint Tool, click on its icon.
Allow XY Motion Tool 
If selected, this tool allows rotation in the apparent XY plane.
Allow XZ Motion Tool 
If selected, this tool allows rotation in the apparent XZ plane.
Allow YZ Motion Tool 
If selected, this tool allows rotation in the apparent YZ plane.



Surface Editor
Overview
Like the Tumble Editor, the Surface Editor allows you to edit object surfaces selected in 
the Design View or the Tumble Editor. Edits to selected object surfaces include changing 
the color or opacity of the entire surface. (See Surface menu.)
Surface Features
The Surface Editor is also used to create surface features. A surface feature is a 
polygonal 2D object which can represent things such as a door, a window, a floor or a 
wall feature with a specified opacity and color. Surface features are created like objects 
with any of the drawing tools but do not have a depth and, therefore, are not affected by 
the Depth Controls. Surface features can be edited in the Surface Editor just as objects 
can be edited in the Design Views: They can be scaled, rotated, stretched, and their color
and opacity can be changed.

Placement
It is important to remember that every selected object surface has two sides, interior and
exterior, relative to the object the surface belongs to. You can toggle between the sides 
of a surface by choosing Opposite in the Change View submenu under the View menu.

Placement Modifiers
When changing the color of a surface or when adding a surface feature, it is important to
consider the two sides of the surface. For example, you may want the color of the interior
side of an object surface to be different from the color of the exterior side; or you may 
want a surface feature to appear on one side but not the other; or you may want a 
surface feature on both sides. The placement of surface features is determined by the 
Placement Modifiers. By selecting the correct Placement Modifier, you can edit the 
outside, the inside or both sides of a surface.
To change the placement of any surface feature...
... select the feature and double-click the desired Placement Modifier.
Place on Front 
Place on Front makes surface edits on the side of the object surface facing you in the 
surface window. If this modifier is active when you select a color, only the side of the 
surface facing you in the surface window will reflect the color change.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on the side facing you in the Surface Editor window.
You can toggle between the inside and outside surface by choosing Opposite in the 
Change View submenu under the View menu.
Place Through 
The Place Through Modifier makes surface edits on both sides of an object surface. If this
modifier is active when you select a color, both sides of the surface will reflect the color 
change.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on both sides of the surface. This is the placement required for making holes like a 
doorway or a window.



Place on Back 
Place on Back makes surface edits on the opposite side of a surface in the surface 
window. If this modifier is active when you select a color, only the opposite side of the 
surface will reflect the color change. You will not be able to see any changes unless you 
choose Opposite in the Change View submenu under the View menu.
If this modifier is active when you draw a surface feature, the surface feature will appear 
on the opposite side of the surface in the Surface Editor.
To select a surface feature that is placed on back, you must first flip the surface by 
choosing Opposite in the Change View submenu under the View menu.

Selecting a Surface to Edit
To select an object surface and open the Surface Editor from a Design View...
... select an object and click on the Surface Editor Tool. Click the surface you wish to edit,
... or click the Surface Editor Tool and double-click on the object surface you wish to edit.
You can click on a visible surface or on a line representing a surface perpendicular to the 
active view.
If you wish to edit a surface not visible in the active view and not perpendicular to the 
active view, change views so the surface is visible, or rotate the object within the Tumble
Editor. (See Tumble Editor.)

Editing a Selected Surface
When the Surface Editor is opened, the Surface Editor Tools    appear in the Tools window 
and the selected surface appears in the surface window. Also, a Surface menu is added 
to the menu bar. The surface window has the same features of the Design Views window 
except there are no Depth Controls because individual surfaces have no depth. The 
Surface Editor does show rulers, Non-Reproducing Guidelines and a Movable Origin.
Once you have an object surface in the surface window you can edit it or add surface 
features to it using the tools in the Surface Editor Tools window. Most of the tools in the 
Surface Editor Tools window are identical to tools found in the Design Views Tools window
except that the Surface Editor Tools deal with surface features and selected object 
surfaces rather than whole objects.
To change the color of a whole surface...
... click on the surface to select it and double-click the default 
Color Bar    to assign the default color to the surface
... or drag open the Color Bar    to reveal the color selector, point to the desired color and 
release the mouse button. (See Color Bar.)
To change the opacity of a whole surface...
... click the surface to select it and choose an opacity from the Modify Selected submenu 
under the Edit menu,
... or click the surface to select it and double-click the desired opacity modifier. If 
translucent opacity is selected, the translucency will assume the default color displayed 
in the Color Bar . The color of the translucency can be changed by dragging open the 
Color Bar    and selecting the desired color.



Editing a Surface Feature
A surface feature is a two-dimensional object drawn through, on the outside or on the 
inside of an object surface. Like an object surface, a surface feature can have color and 
opacity.
Whether a surface feature is through, outside or inside the object surface is determined 
by the Placement Modifiers. (See Placement Modifiers.)
To add a surface feature to a selected surface in the Surface 
Editor...
... select any drawing tool, and drag to create the desired shape of the surface feature. 
Notice that a surface feature has handles (see Select Object Tool ) which indicate 
whether or not a surface feature is selected. 
You can select a color or an opacity for a selected surface feature just as you change the 
color and opacity of an object. Surface features, like objects, can be rotated and scaled, 
and their shape can be changed by manipulating handles.
More than one surface feature can be drawn on a selected surface. Surface features can 
overlap each other and the order of the overlap can be rearranged with commands under
the Surface menu. (See Surface Menu .)
If surface features are to be shared between objects, it is necessary to connect the 
objects. (See Connect Surfaces Tool .)



Tumble Editor
Overview
The Tumble Editor can be accessed in the Design Views and in the Surface Editor and is 
used to view a three-dimensional object from different orientations, allowing access to all
sides of the object. (See also Tumble Menu .) The Tumble Editor allows you to slice off a 
piece or several pieces of an object, creating a new surface for each slice. The Tumble 
Editor also allows you to edit the color and opacity of whole object surfaces or entire 
objects. The color and opacity of object surfaces can also be edited in the Surface Editor. 
Unlike the Surface Editor, the Tumble Editor cannot be used to create surface features. 
(See Surface Editor .)
The Tumble Editor window has the same features as the Design Views window except 
that it has no Depth Controls. It does show rulers, Non-Reproducing Guidelines and a 
Movable Origin.
To open the Tumble Editor...
... select an object, click the Tumble Editor Tool and click the selected object,
... or click the Tumble Editor Tool and double-click the object you wish to edit.
When the Tumble Editor is open, the Tumble Editor tools appear in the Tools window and 
the selected object appears in the Tumble Editor window. Also, a new menu, the Tumble 
menu, is added to the menu bar.
You can edit the color and opacity of the whole object or edit the color and opacity of a 
selected surface using the Tumble Editor Tools.

Tumbling a Selected Object
The Move Tool is used to tumble (orient in 3D) the object in the Tumble Editor window or 
to tumble the Orientation Cube. In the Tumble Editor tools window, the Move Tool is also 
used to select specific surfaces on the object or on the Orientation Cube.
To tumble an object...
... select the Move Tool and drag the object in any direction,
... or drag the Orientation Cube (in the tools window) in any direction. The Orientation 
Cube and the object are linked, and when one is tumbled the other tumbles with it. If you
hold down the Ctrl key while you tumble, the link between the Orientation Cube and the 
object is temporarily suspended and tumble speed increases.

Rotation Constraint Tools
Rotation Constraint Tools affect how the Orientation Cube and the object in the Tumble 
Editor window can be rotated. There are three Rotation Constraint Tools. At least one 
Rotation Constraint Tool must be selected at any time.
If a Rotation Constraint Tool is turned off, rotation is not allowed in the direction 
associated with that tool. The Rotation Constraint Tools can be turned on and off by 
clicking.
Allow XY Motion Tool 
If selected, this tool allows rotation in the apparent XY plane.
Allow XZ Motion Tool 



If selected, this tool allows rotation in the apparent XZ plane.
Allow YZ Motion Tool 
If selected, this tool allows rotation in the apparent YZ plane.

Orientation Cube
The Orientation Cube represents the selected object within the Virtus world. Each side of 
the cube is marked with a letter: T=Top, b=Bottom, F=Front, B=Back, L=Left and 
R=Right. The Orientation Cube can be tumbled to view other surfaces. As the Orientation
Cube is tumbled, the object in the Tumble Editor window imitates its movement. To rotate
the Orientation Cube, select the Move Tool and drag the Orientation Cube in any 
direction.
By holding down the Ctrl key when tumbling, you can temporarily suspend the link 
between the object being tumbled and the Orientation Cube so that they rotate 
independently of each other. This increases the tumble speed.
The Orientation Cubes rotation is affected by the Rotation Constraint Tools. 

Slicing a Selected Object 
The Slice Tool adds a surface to an object by slicing off a piece of that object.
To slice off a piece of an object...
... select the Slice Tool and drag a line through the object. The direction of the drag 
determines how the slice is made. If you drag from left to right or from top to bottom, the
portion above or to the right of the line will be sliced off. If you drag from right to left or 
from bottom to top, the portion below or to the left of the line will be sliced off.
To reverse the direction of a slice...
... hold down the Ctrl key while slicing,
... or after slicing, choose Reverse Slice from the Tumble menu.

Editing a Slice
After a slice is made it can be edited. 
To edit a slice...
... click the Select Object Tool , then click the slice you wish to edit in the Slice List. (See 
Slice List .) The slice will appear on the object in the Tumble window. If you dont know 
which slice in the list corresponds to the slice you wish to edit on the object, click each 
one until you see the appropriate slice appear in the Tumble window. The slice can be 
edited by dragging to a new location or you can change the angle of the slice by 
dragging one of the slices handles.
To delete a slice (and thereby replace the portion of the object that was 
removed)...
... select the slice from the Slice List and choose Cut or Clear from the Edit menu, or 
press the Delete key or the Backspace key.
A slice can be copied from one object to another. Each slice knows its position relative to 
the origin of the object. If you select a slice and then select Cut or Copy under the Edit 
menu, the slice is saved to a clipboard. If you edit another object in the Tumble Editor, 



you can paste the slice with the Paste command under the Edit menu and maintain the 
same slice angle and object rotation angle; however, since a slice knows its position 
relative to the object origin, you may have to drag the slice to position it correctly.

Slice List
The Slice List displays the word slice and a number for each slice you make in an object. 
If you wish to edit a slice, click the slice in the list and it will appear in the Tumble Editor 
window. If you arent sure which numbers correspond to which slices, click on each name 
in the list until the desired slice appears.

Editing a Whole Object in the Tumble Editor
To change the color or opacity of an object, you need not tumble it at all; however, when 
editing the color of an object, you must consider placement. (See Place on ... .) 
To change the color of the whole object...
... make sure no surfaces are selected (this is done by clicking in the Tumble Editor 
window away from the selected object), then double-click the Color Bar    to change the 
object to the default color,
... or drag open the Color Bar    to reveal the color selector, point to the desired color and 
release the mouse button. (See Color Bar .)
To change the opacity of the whole object...
... make sure no surfaces are selected (this is done by clicking in the Tumble Editor 
window away from the selected object), then double-click on the desired opacity 
modifier. If translucent opacity is selected, the translucency will assume the default color.
The color of the translucency can be changed using the Color Bar. (See Color Bar .)

Selecting and Editing a Single Surface
To select a single surface for editing...
... tumble the object until the desired surface can be seen. Select the surface by double-
clicking it with the Move Tool or with the Select 
Object Tool ,
...or tumble the Orientation Cube and double-click the side of the Orientation Cube that 
corresponds to the surface of the object you wish to select. Double-clicking the 
Orientation Cube will re-orient the object but will not select the surface. You must double-
click the object surface in the Tumble Editor window to select it.
After you double-click a surface, the object will re-orient itself so that the surface you 
selected is planar (perpendicular to your line of sight) and shaded with dots. 
To change the color of a selected surface...
... check the Placement Modifiers to verify the desired placement. Double-click the Color 
Bar    to change the surface to the default color,
... or drag open the Color Bar    to reveal the color selector, point to the desired color and 
release the mouse button. (See Color Bar .)
To change the opacity of a selected surface...
... select the desired surface and double-click the desired Opacity Modifier. (See 
Make .... )



Placement Modifiers
When editing a whole objects color or the color of a selected object surface in the Tumble
Editor, you must consider which side of the object or surface you are editing. Every 
object has an inside and an outside, and every surface has an inside and an outside 
relative to the object it is part of. You can edit the inside, the outside or both sides in the 
Tumble Editor. The side of the object or surface to be edited is determined by the 
Placement Modifiers. There are three Placement Modifiers: Place on Front , Place Through
, and Place on Back.
Place on Front Modifier 
If this modifier is active when you select a color, only the outside of the object or 
selected surface will reflect the color change.
Place Through Modifier 
If this modifier is active when you select a color, both sides of the object or selected 
surface will reflect the color change.
Place on Back Modifier 
If this modifier is active when you select a color, only the inside of the object or selected 
surface will reflect the color change. You will not be able to see the change in the Tumble 
Editor; you will have to go to the Walk View and walk inside the object to see the change.





Views
There are two kinds of views in Virtus WalkThrough: the Walk View and the Design Views.
The Walk View displays a three-dimensional rendering of the objects you draw in a 
Design View and allows you to walk through and around the objects.
A Design View is a two-dimensional area where you draw objects. There are six possible 
Design Views: Top, bottom, Front, Back, Left and Right. You can draw, view or edit your 
drawings in any of the Design Views. 
Within the Design Views there are three editors which perform specific operations on the 
objects you draw: the Surface Editor, the Tumble Editor and the Lighting Editor.



Windows
Each view or editor is displayed in a window which can be resized or repositioned. (See 
your Windows documentation for more on windows manipulation and standard Windows 
interface operations.)
Tools Window 
Each of the two kinds of views and each editor has its own set of tools which appear in 
the Tools window. The view or editor you are working in determines which tools are 
displayed.
Active Window
Only one window may be active at any time. To make a window active, click anywhere 
inside its boundaries, or select a view name from the View menu (see View Menu ) or 
select a window name from the Window menu (see Window menu ). You can tell if a 
window is active by looking at its Title Bar.
Title Bar
The Title Bar of a view window displays the name of the view or editor the window is 
associated with.
If a window is active, its Title Bar is dark and text is light. If a window is not active, its 
Title Bar is light and text is dark.



Walk View
The Walk View displays a three-dimensional rendering of the objects you draw in a 
Design View. In the Walk View you can walk around and through objects by moving the 
mouse. The Walk View has a set of tools specific to the Walk View. (See Walk View Tools .)
These tools are displayed when the Walk View is active.
In addition to the regular menus, the Walk menu is visible when the Walk View window is 
active. The Walk menu contains commands and options that affect the appearance of the
Walk View and the objects within it. (See Walk Menu .)
Cross Hair
The cross hair in the middle of the Walk View is used as a reference point for navigation. 
(See Navigation Methods .) The cross hair can be hidden with the Cross Hair option under
the Walk menu.
Velocity Grid
Velocity Grid marks are the horizontal and vertical marks in the Walk View which display 
the points at which walk speed changes. The default for the Velocity Grid marks is off 
(not visible), but they can be turned on and off by selecting Velocity Grid under the Walk 
Menu or by selecting Velocity Grid in the Preferences, Navigation dialog under the Edit 
menu. Novice Virtus WalkThrough users may find the Velocity Grid helpful while learning 
to navigate. 



Design Views
There are three sets of skills to learn in Virtus WalkThrough: creating objects, 
editing/modifying objects and navigating in and around objects. The Design Views are 
used for creating and editing/modifying objects.
A Design View is a drawing area where you draw or view object outlines in two 
dimensions. There are six different Design Views: Top, bottom, Front, Back, Left, Right. 
You may draw in any Design View. More than one Design View can be open at any time 
(see Multiple Design Views ); however, only one view can be active at any time.
The Design Views have a specific set of tools. When a Design View is active, the Design 
View tools are displayed in the Tools window. (See Design View Tools .)
Moving Between Design Views 
Multiple Design Views 
Dimensions: X, Y and Z 

Working with Objects
Object Creation 
Object Modifying 

Modifying Handles 
Moving an Object 
Modifying Inflation Type 
Modifying Opacity 
Modifying Color 

Design View Features
Depth Controls 
Grid Lines 
Movable Origin 
Non-Reproducing Guidelines 
Observer 
Rulers 



Object Creation
In the Design Views an object is represented by a 2D polygonal outline. To draw the 
polygonal outline of an object, select a drawing tool, point to a location in the active 
design view and drag.
The resulting polygonal outline is a 2D cross-section from which a 3D object is derived. 
The polygonal outline may look flat, but it has depth and a position in space. Virtus 
WalkThrough applies an inflation distance, or depth, to the outline and inflates the object
in the same direction you are viewing so you cannot see the inflation unless you change 
views. (See Depth Controls .) To change views, select a view from the Change View 
submenu under the View menu.
The 3D object assumes the default color displayed in the 
Color Bar    (see Color Bar ), as well as the selected opacity    and the selected inflation 
type. You can change these factors before you draw the object or change them after the 
object is drawn.



Moving Between Design Views
Usually only one Design View is open at any time, but more are possible. (See Multiple 
Design Views .) 
When Virtus WalkThrough is started, the Top View is displayed by default. To change the 
Top View to another Design View, make sure the Design View is active. (See Active 
Window .) If not, click anywhere inside its boundaries. Select Change View under the 
View menu. A pullout menu will display the names of the six possible Design Views. 
Select the desired view. The active Design View will change to the view you selected.
An active Design View can be changed to another Design View with the Change View 
command under the View menu. Or a new window with a new Design View can be 
opened with the New View command under the View menu. It is important to understand
the difference between Change View and New View. (See Change View and New View .)



Multiple Design Views
There are six Design Views and, if desired, all six can be open at the same time. In most 
cases, however, the size of your monitor will limit the usefulness of multiple Design 
Views. If you have a large monitor, you may wish to experiment with multiple Design 
Views; this can increase your efficiency.
To open multiple Design Views select New View under the View menu. A pullout menu 
will display the names of the six possible Design Views; select the desired view. The new 
view you select appears over the active view. It can be resized and positioned. Though 
only one view can be active at a time, you are able to see objects and edits in all views.



Object Modifying
After objects are created they can be modified. Any modifications or edits to an object 
must be preceded by selecting the object. An object is selected if it displays handles. A 
handle is a small square block that represents the meeting of two planes, or in the case 
of an object, the meeting of two sides. If an object is selected, its handles are visible. 
Immediately after you draw an object, its handles are displayed and the object is 
selected, allowing for any adjustments in size or shape you may wish to make.
To select an object...
... click the Select Object Tool , point to the desired object and click inside the polygonal 
outline. (See Select Object Tool .)
Modifications to selected objects are accomplished with different tools and editors. For 
example, the size and shape of an object can be changed by dragging a handle or a 
surface with the Select Object Tool. The type of object can be changed by adding or 
deleting a handle with the Add/Remove Handle Tool. The inflation type (the 3D shape of 
the object) can be changed with Inflation Modifiers. An object can be rotated or scaled 
with the Rotate Object Tool    and Scale Object Tool . The opacity of an object can be 
changed with the Opacity Modifiers. The color of an object can be changed with the Color
Bar . The interior lighting of an object can be changed with the Lighting Editor. Individual 
object surfaces can have surface features added to them with the Surface Editor. 
(Surface features, like objects, can have color and opacity, and they can be rotated or 
scaled.) Also, the opacity or color of an entire object surface can be changed with the 
Tumble Editor, and a new surface can be created in the Tumble Editor by slicing off part 
of the object.



Modifying Handles
An object can be reshaped by dragging a handle or a surface between two handles. 
To reshape an object...
... select the object, point to a side or to a handle and drag to a new location. If you hold 
down the Ctrl key while dragging, you can move an individual handle rather than an 
object surface.
The way an objects handles appear indicates the extent to which an object can be 
reshaped in the active view. If the handles appear solid, all sides and handles can be 
dragged to reshape the object. If handles appear hollow, only some sides and handles 
can be dragged to reshape the object (depending on the direction of the objects 
inflation). If handles appear gray, the object sides and handles cannot be manipulated at 
all; however, the object can be scaled since object scaling has no restrictions.
The limitations to how an object can be reshaped occur if you are attempting to reshape 
it in a view other than the view in which it was created. Furthermore, if you rotate an 
object out of the plane in which it was created, it cannot be reshaped; you must unrotate
the object first.



Moving an Object
You may move an entire object to a new location by pointing inside the polygonal outline 
and dragging. Any contained objects will move with the object unless you hold down the 
Ctrl key while moving.



Modifying Inflation Type
Inflation Modifiers determine the 3D shape of an object. You can select an inflation type 
before you draw an object, or change the type after the object has been drawn. 
To create an object with a selected inflation...
... click on the desired Inflation Modifier, select a drawing tool and draw the object.
To modify the inflation of an existing object...
... select the object and choose an inflation type in the Modify Selected submenu under 
the Edit menu. You can also modify an objects inflation by double-clicking the desired 
Inflation Modifier in the Tools window.



Modifying Opacity
The opacity of an object can be changed with the Opacity Modifiers: Make Opaque , Make
Translucent and Make Transparent.
Opacity Modifiers determine whether the entire object has opaque, translucent or 
transparent surfaces. You can select the opacity before you draw an object or change the
opacity after the object has been drawn.
To create an object with a selected opacity...
... click on the desired Opacity Modifier, select a drawing tool and draw the object.
To modify the opacity of an existing object...
... select the object and choose an opacity type in the Modify Selected submenu under 
the Edit menu. You can also modify an objects opacity by double-clicking the desired 
Opacity Modifier in the Tools window.



Modifying Color
The color of an entire object can be changed with the Color Bar. You can select a color 
before you draw an object or change the color after the object has been drawn. (See 
Color Bar .)



Observer
The Observer represents your eyes in the Virtus WalkThrough environment. In a Design 
View the Observer is shown as a circle with a line that indicates the viewing direction. In 
different Design Views, the appearance of the Observer is different.
As you navigate in the Walk View, the Observer position changes in the Design View.
You can drag the Observer to a desired location with the Select 
Object Tool. 
You can also rotate the Observer, thus changing the viewing direction, by holding down 
the Ctrl key and dragging from the center of the Observer outward to the direction of the
desired view. As you drag outward a dotted line appears, representing the apparent 
viewing direction of the Observer. The farther you drag, the more control you have over 
the angle of view.



Rulers
Rulers appear in the Design Views, the Surface Editor and the Tumble Editor. They help 
you measure objects, determine the grid system to snap to and display Depth Controls 
(see Depth Controls ) and Non-Reproducing Guidelines (see Non-Reproducing 
Guidelines ).
In each design view a ruler appears across the top of the window and along the left side 
of the window. The gray box at the right of the top ruler and at the bottom of the left 
ruler is called a Dock. Each Dock will have a letter in it which determines the dimension 
(X, Y or Z) that the ruler and its Depth Control are associated with. (See Depth Controls .)
The rulers show major tick marks and minor tick marks. Depending on which 
measurement system you are working in and which base unit you have selected (see 
Preferences, Units ), the tick marks represent different units of measurement. If you 
change the relative scale of the current view by zooming in or out with the zoom tools, 
the tick marks will represent a larger or smaller unit of measurement.
Rulers can be hidden with the Show Rulers option in the Preferences, Editor dialog under 
the Edit menu. The ruler color can also be changed in the Preferences, Editor dialog.



Movable Origin
At the 0 coordinate of each ruler there appears an arrowhead attached to a line 
perpendicular to the ruler. This arrowhead and line represent the ruler Origin, the 0 
coordinate. The Origin can be moved by dragging the arrowhead to a new position on the
ruler. After you release the mouse button, the ruler and tick marks will follow you, in 
effect resetting the 0 coordinate. This will help with measurement of objects and 
distances. 
Once moved, the Origin can be reset to its original position by selecting Reset Origin 
under the View menu. It is a good habit to always reset the origin after you have moved 
it. 
The Origin can be hidden by unselecting Show Origin in the Preferences, Editor dialog 
under the Edit menu. The Origin color can also be changed in the Preferences, Editor 
dialog.
If you are positioned in the view such that you cannot see the Origin, you can hold down 
the Ctrl key and drag the Origin out of a Dock. (See Non-Reproducing Guidelines .)



Non-Reproducing Guidelines
Non-Reproducing Guidelines are available in the Design Views, the Surface Editor and the
Tumble Editor to help align objects. At the end of each ruler is a Dock. A Dock is a gray 
box with the letter X, Y or Z in the center. (X, Y or Z tells you which axis the ruler is on.) 
By pointing to the Dock and dragging outward along the ruler you can display a Non-
Reproducing Guideline and position it where you like. There is no limit to the number of 
guidelines. If you want to get rid of some of them, just drag them back into the Dock. The
color of the guidelines can be set in the Preferences, Editor dialog.
If you hold down the Ctrl key when you drag out from a Dock, you can display the 
Movable Origin instead of a Non-Reproducing Guideline. (See Movable Origin .)



Grid Lines
Grid Lines appear on the drawing area of the Design Views, the Surface Editor and the 
Tumble Editor and are extensions of the major tick marks on the rulers. As the relative 
scale of the Design View changes, through zoom commands, the major tick marks will 
change to represent different units of measure. Because Grid Lines are based on the 
major tick marks, the actual distance between Grid Lines changes. 
Grid Lines can be hidden with Show Grid in the Preferences, Editor dialog under the Edit 
menu. The Grid color can also be changed in the Preferences, Editor dialog. Grid Lines 
cannot be printed.




