Main Window

This is Audio Converter's main window. You can click on toolbar buttons or menu items in the screen shot to find out what they do.

File Menu

  • Add Files - Allows you to select one or more audio file(s) that you would like to convert. The standard File Open dialog is used to select the files. There is a Convert to combo box, allowing you to select the audio format the source files are converted to.

  • Add Folder - See Add Folder Dialog.

  • Audio CD - See Audio CD Dialog.

  • Playlist - Allows you to select a play list file (M3U or PLS). The standard File Open dialog is used to select the files. All files within the play list will be added to the list.

  • Convert - Converts all files or CD audio tracks that have been added to the list.

  • Normalize - Activates or deactivates audio volume normalization during the audio file conversion.

  • Delete Source Files - Deletes source files after they have successfully been converted.

  • Burn Audio CD - Opens Easy CD-DA Recorder.

  • Settings - See Application Settings.

  • New Windows - Opens a new Audio Converter window.

Edit Menu

  • Remove - Removes selected items from the list.

  • Remove All - Removes all items from the list.

  • Metadata - See Metadata Editor Dialog.

Output Menu

  • Change Directory - Changes the output directory of selected items.

  • Encode Portions - See Encode Portions Dialog.

  • Naming Scheme - See Naming Scheme Dialog.

  • Settings - Allows you to change settings like bitrate or sample rate of the output file. For more information, please see Audio Settings.

View Menu

  • Estimated Size - Shows or hides the Estimated Size column in the list.

  • Sort By - Sorts the list by the selected column.

Related Topics

  • Add Folder Dialog

  • Audio CD Dialog

  • Application Settings

  • Audio Settings


Add Folder Dialog

This dialog allows you to select audio files within a folder and add them to the list in the Main Window.

Search For
The type of audio files to look for within the selected folder.

Search Folder
You can use the explorer tree to select this folder.

Include Sub Folders
Check this checkbox if you would like to search for audio files in folders underneath the selected folder.

Output Format
The format the audio files are to be converted to.

Add
All audio files that have been found will be added to the list. You may select Convert from Audio Converter's File menu to convert them.


Audio CD Dialog

This dialog allows you to select tracks from an audio CD.

Drive
This combo box lists all CD-ROM devices that support digital audio extraction (DAE). If this combo box is empty, you may need to install an ASPI driver.

Installing an ASPI Driver

Refresh
Reads the TOC of the audio CD again and displays the tracks in the track list.

Track List
If an audio CD is inserted into the selected Drive, all CD audio tracks are displayed. The Time column displays the length of the track in MSF format. To edit the titles of album tracks, right-click the track that you want to edit, and then click Edit Title.

Album Details
Opens an Internet page with detailed information on your album. This feature works independently from the CDDB feature.

Edit Album
Allows you to edit or modify album information of the CD currently inserted.

CDDB Submit
Submits new or modified entries to the CDDB. If you want to submit modified entries, please make sure that you did not change the CDDB category (using Edit Album). All submission require that you have entered a valid e-mail address in the CD Audio Settings dialog.

File Naming Scheme
The naming scheme of destination files. For more information on naming schemes, please see Naming Scheme Dialog. The default value is:

C:\My Music\<artist>\<album>\<title>

Audio File Format
The audio file format which will be used to store the tracks on hard disk. The Windows Media Audio format offers best quality at the smallest file size.

Copy Tracks to Single File
Copies the selected tracks to a single output file instead of copying each track to a separate file.

Tip

  • You can use the context menu of the track list to check or uncheck all tracks.


Metadata Editor Window

The Metadata Editor lets you easily view or change information about artists, album titles, and song names.

This icons are used in the list:

Icon | Read-only | Multiple Files
 | No | Yes
 | Yes | Yes
 | No | No
 | Yes | No

Save
Saves the tag information.

Close
Closes the windows without saving the information.

Remove All
Removes all information.

Edit Tag
Edits the selected tag.

Remove Tag
Removes the selected tag.

Tip

  • If you are editing multiple files, you can right-click on a tag and all different tag values of the files will be listed in the context menu. You can select one to set this tag value for all files.


Transcode WMA Dialog

Transcode Windows Media Dialog

This dialog allows you to alter the current encoding or form of a Windows Media Audio file.

Source File
The WMA file to transcode. Click the Browse button to select this file using a standard File Open dialog.

Codec
The codec (short for compressor/decompressor) used to compress the source file.

Format
The bit rate in kilobits per second (kbps), the sample rate and the number of channels of the source file.

Destination File
The file name of the destination file. Click the Browse button to select this file using a standard Save As dialog.

New Codec
The codec (short for compressor/decompressor) used to encode the destination file.

New Format
The bit rate in kilobits per second (kbps), the sample rate and the number of channels of the destination file.

Change
Displays the Windows Media Audio Settings dialog, which allows you to change the format of the destination file.

Transcode
Begins to transcode the selected file.


Encode Portions Dialog

This dialog allows you to select a start and end time, which will be used by the encoder. This dialog can also be used to select a start and end time for more than one file at once.

Start
Check this box to specify a start time. Otherwise the file will be encoded from the beginning. The text box and the slider allow you to select the start time in ms.

End
Check this box to specify a end time. Otherwise the file will be encoded to the end. The text box and the slider allow you to select the end time in ms.

OK
Click here when you have done.


Naming Scheme Dialog

This dialog is used to change the file naming scheme.

File Naming Scheme
The file name of the destination file(s). It may contain naming scheme elements, which start with < and end with > (these characters cannot be used in normal file names) and are replaced in the final file name.

The following table shows which elements may be used, and what they do.

Element

Replaced by

<artist>

The artist of the audio file or track being converted.

<album>

The album title of the audio file or track being converted.

<title>

The song name of the audio file or track being converted.

<tracknum>

The order number of the audio file or track on its original recording.

<year>

The year of recording.

<sourcepath[:num]>

The directory of the source file, but a specified number of path components are removed in front of the directory. Here are a few examples of how this element is replaced if the source file is C:\Music\MP3s\Song.mp3.

<sourcepath:0> (equal to <sourcedir>) turns into C:\Music\MP3s
<sourcepath> (equal to <sourcepath:1>) turns into Music\MP3s
<sourcepath:2> turns into MP3s

<sourcename>

The file name (without directory and file extension) of the source file. This cannot be used if you are converting a CD audio track.

<sourcedir>

The directory the source file. This element should not be used if you are converting a CD audio track, because that would be the root directory of your CD-ROM drive, which is usually read-only.

Preview
Displays the final destination file name generated with the entered naming scheme. If the naming scheme has a syntax error, the details of the error are displayed here.


Copy to Hard Disk Dialog

This dialog is used by the shell extensions when you click Copy to Hard Disk in the context menu of .cda files.

Audio File Format
The audio file format of the files that are saved to hard disk. The Windows Media Audio format offers best quality at the smallest file size.

Audio Settings
The audio settings used to encode the audio file. For more information, see Audio Settings.

File Naming Scheme
The naming scheme of destination files. For more information on naming schemes, please see Naming Scheme Dialog. The default value is:

C:\My Music\<artist>\<album>\<title>

You can use the directory tree to select a directory.

Activate Volume Normalization
Activates or deactivates audio volume normalization.

See Also

  • Shell Extensions Settings

  • Audio Settings


Audio Settings

Audio Converter converts audio files to Windows Media, MP3, AIFF or Wave format. Each output format has different settings.

  • Windows Media Audio Settings

  • MPEG Layer-3 Settings

  • Wave Audio Settings

To change audio settings, select Settings from Audio Converter's Output menu.

Note

  • The audio settings are changed for all items that are selected. You may select Select All from Audio Converter's Edit menu to select all items.


Windows Media Audio Settings

This dialog is used to change Windows Media Audio settings.

Bitrate
The bit rate in kilobits per second (kbps). You can use the slider to change the bit rate.

Quality | Bit rate | Disk space*
Smallest size | 48 Kbps | 25 MB
Medium | 64 Kbps | 28 MB
High | 96 Kbps | 42 MB
Best quality | 128 Kbps | 56 MB

*Refers to the amount of disk space required if you copy an entire CD (74 minutes) according to quality level.

The better the quality, the more disk space required. As you compress the audio you lose quality.

File Size
Displays the estimated file size of the encoded file with the selected bit rate.

Sample Rate
The sample rate in kilo hertz (kHz). Possible values depend on the bit rate.

Channels
The channels (either mono or stereo).

Changing Windows Media Audio Settings

  1. In the Main Window select one or more source files or tracks in the list that are to be converted to Windows Media format (see Convert to column).

  2. Select Settings from Audio Converter's Output menu or right-click on the selected item(s) and select Audio Settings.


MPEG Layer-3 Audio Settings

Encoder
The encoder that will be used to compress the audio. The best encoder is Radium MP3. For information on how to install, please see:

http://www.audioconverter.info/Q1006.php
http://www.audioconverter.info/Q1001.php

Bitrate
The default bit rate is 128 kbps. You can choose between bit rates from 32kbps and 320kbps. The higher the bit rate, the more disk space required and the better the quality.

Sample Rate
The sample rate (in Hz).

Generate CRC
For error protection using CRC.

Changing MPEG Layer-3 Audio Settings

  1. In the Main Window select one or more source files or tracks in the list that are to be converted to MP3 format (see Convert to column).

  2. Select Settings from Audio Converter's Output menu or right-click on the selected item(s) and select Audio Settings.


Wave Audio Settings

Compressor (or Codec)
The default compressor is PCM, which does not compress the audio data. Compressors are provided by ACM drivers installed on the system.

Format
The bit rate, sample rate and channels used to compress the audio file. By default the ACM driver automatically suggests the format.

Changing Wave Audio Settings

  1. In the Main Window select one or more source files or tracks in the list that are to be converted to Wave format (see Convert to column).

  2. Select Settings from Audio Converter's Output menu or right-click on the selected item(s) and select Audio Settings.


Application Settings

This select the application settings category that you need information on.

  • General Settings -- Change temporary folder, naming scheme, overwrite mode and more.

  • Shell Extensions Settings -- Configure the context menu and property sheet extensions.

  • CD Audio Settings -- Change CDDB settings, proxy servers, read error mode, error correction and more.


General Settings

Temporary Folder
The directory where Audio Converter stores temporary files.

Default File Naming Scheme
The default file naming scheme. For more information on naming schemes, please see Naming Scheme Dialog. The application default value is:

<sourcedir>\<sourcename>

Default Output Format
The default output format.

Default Audio Settings
Select an output format in the combo box and click Change to change its default audio settings. Below the combo box the current default audio settings are displayed.

Add Converted Media to Media Library
You will need to enable write access for the application. In the Windows Media Player go to the Tools : Options dialog and choose the Media Library tab then by selecting Full Access in the Internet site rights group Audio Converter will be able to add media directly to your library.

Overwrite Mode

  • Always - Destination files will always be overwritten without confirmation if they already exist.

  • Never - Destination files with never be overwritten. If they already exist you will get an error.

  • Rename - Destination files with be renamed if they already exist (#2, #3, ...).

  • Ask - Audio Converter will ask you what to do if a destination file already exists.

Changing General Settings

  1. Launch Audio Converter

  2. Select General from the submenu Settings from Audio Converter's File menu.


Shell Extensions Settings

Add to Context Menu of Audio Files:

  • Convert to Windows Media - Allows you to convert the selected audio file(s) to Windows Media format directly from Windows Explorer.

  • Convert to Wave - Allows you to convert the selected audio file(s) to Wave format directly from Windows Explorer.

  • Convert to MP3 - Allows you to convert the selected audio file(s) to MP3 format directly from Windows Explorer.

  • Convert to AIFF - Allows you to convert the selected audio file(s) to AIFF format directly from Windows Explorer.

  • Burn Audio CD - Opens Easy CD-DA Recorder directly from Windows Explorer, initialized with the selected audio file(s).

Transcode Windows Media

Allows you to alter the current encoding or form of a Windows Media Audio file directly from Windows Explorer.

Copy to Hard Disk

Allows you to easily copy a CD audio track to hard disk by selecting Copy to Hard Disk from the context menu of a .cda file (for example, in Windows Explorer). For more information, please see Copy to Hard Disk Dialog.

Metadata

Lets you easily view or change information about artists, album titles, and song names directly in the property sheet page Metadata of one or more audio file(s).

Changing Shell Extensions Settings

  1. Launch Audio Converter

  2. Select Shell Extensions from the submenu Settings from Audio Converter's File menu.


CD Audio Settings

Enable CDDB
Enable CDDB to download track listings in the Audio CD Dialog (select Audio CD from Audio Converter's File menu).

CDDB Server / CGI Path
Use the drop down list to select a CDDB server. For an up-to-date list of CDDB servers, please see:
http://www.audioconverter.info/cddb.php

Your E-Mail Address
Especially required for submission to CDDB.

Use Proxy Server
Enables the use of a proxy server. You will have to enter the proxy address and proxy port. Ask your proxy server administrator for that information.

Error Correction
Enables or disables the Jitter correction algorithm.

Read Error Mode

  • Abort - The copy operation will be aborted if any unreadable sector is found.

  • Ignore - Replace any unreadable sector with another unreadable sector and continue reading the disc.

  • Replace - Replace any unreadable sector with a readable one (the sector will contain all zeros) and continue reading the disc.

Audio Reading Speed
The speed at which the audio is read from the audio CD. Sometimes it will not be much faster with MAX speed, because it takes most time to encode and compress the audio.

Drive Letter
Audio Converter sometimes fails to find out the proper drive letter of a device. So if auto-detection does not work, you can manually correct the drive letters.

Changing CD Audio Settings

  1. Launch Audio Converter

  2. Select CD Audio from the submenu Settings from Audio Converter's File menu.


Visual Basic Object Model

The Visual Basic objects are only available in Audio Converter PE.

To make the Audio Converter objects available in Visual Basic, go to Project -> Links, check Audio Converter PE Type Library in the list and click OK. Then you should be able to use the objects.

If you can't find the type library in the list of available links, please try executing this command:

regsvr32.exe "C:\Program Files\Audio Converter\audcom.dll"

The directory may be different.


ConvertFile

The ConvertFile method converts an audio file.

Syntax

Converter.ConvertFile audiofile

Parameters

audiofile
The audio file to convert.

Example

The following example converts the MP3 file to a 64kbps, 44kHz, stereo Windows Media audio file.

Set conv = CreateObject("AudioConverter.Converter")

' Set output format to Windows Media
conv.OutputFormat = acWindowsMedia

' Set output settings
conv.AudioSettings.Bitrate = ac64kbps
conv.AudioSettings.SampleRate = ac44kHz
conv.AudioSettings.Channels = acStereo

' Convert the file
conv.ConvertFile "C:\test.mp3"

Related Topics

  • AudioSettings Property

  • OutputFormat Property


ConvertTrack

The ConvertTrack method converts an audio CD track.

Syntax

Converter.ConvertTrack track

Parameters

track
An AudioCDTrack object.

Example

The following example converts first track of the audio CD to a 64kbps, 44kHz, stereo Windows Media audio file.

Set cds = CreateObject("AudioConverter.AudioCDDrives")
Set conv = CreateObject("AudioConverter.Converter")
'Set output format to Windows Media
conv.OutputFormat = acWindowsMedia

'Set audio settings
conv.AudioSettings.Bitrate = ac48kbps
conv.AudioSettings.SampleRate = ac44kHz
conv.AudioSettings.Channels = acStereo

'Overwrite output file
conv.Overwrite = True

'Naming scheme of the output file
conv.NamingScheme = "C:\My Music\<title>"

'Get the AudioCD object of the D:\ drive
Set cd = cds.ItemByPath("D:\")

'Contact CDDB
cd.CDDB

'Convert the first track from the audio CD
conv.ConvertTrack cd.Track(1)

Related Topics

  • AudioSettings Property

  • OutputFormat Property


OutputFormat

The format of the audio file to be created. The default is acWindowsMedia.

Syntax

Converter.OutputFormat [= format]

Parameters

format
Either acWindowsMedia, acAIFF, acMP3 or acWave.

Related Topics

  • ConvertFile Method


AudioSettings

The encoder settings. This property is read-only.

Syntax

settings = Converter.AudioSettings

Parameters

settings
Specifies a variable to receive an object which is used to change audio settings.

If the OutputFormat property is acWindowsMedia an WMASettings object is returned.

If the OutputFormat property is acMP3 an MP3Settings object is returned.

Related Topics

  • ConvertFile Method


NamingScheme

The naming scheme of the audio file to be created.

Syntax

Converter.NamingScheme [= scheme]

Parameters

scheme
The naming scheme for output files.

Related Topics

  • ConvertFile Method


Normalize

Normalize the audio volume of the audio file during the conversion. The default value is False.

Syntax

Converter.Normalize [= normalize]

Parameters

normalize
If true, the audio volume is normalized.

Related Topics

  • ConvertFile Method


Overwrite

Overwrite the output file if it already exists. The default value is False.

Syntax

Converter.Overwrite [= overwrite]

Parameters

overwrite
If true, the output file is overwritten.

Related Topics

  • ConvertFile Method


Item

An array of AudioCD objects.

Syntax

audiocd =AudioCDDrives.Item( index )

Parameters

audiocd
An AudioCD object.

index
The index of the AudioCD object to be returned. Values from 1 to Count are allowed.

Related Topics

  • ConvertTrack Method


ItemByPath

Returns an AudioCD object for the specified root directory.

Syntax

audiocd =AudioCDDrives.ItemByPath( root )

Parameters

audiocd
An AudioCD object.

root
The root directory. For example, D:\.

Related Topics

  • ConvertTrack Method


Count

Returns the number of CD drives on your system.

Syntax

count =AudioCDDrives.Count

Parameters

count
The number of CD drives on your system.

Related Topics

  • ConvertTrack Method


Track

Item

An array of AudioCDTrack objects.

Syntax

track =AudioCD.Track( index )

Parameters

track
An AudioCDTrack object.

index
The index of the AudioCDTrack object to be returned.

Related Topics

  • ConvertTrack Method


TrackCount

Returns the number of tracks on the audio CD.

Syntax

count =AudioCD.TrackCount

Parameters

count
The number of tracks on the audio CD.

Related Topics

  • ConvertTrack Method


Artist

Returns the artist of the recording on the audio CD.

Syntax

artist =AudioCD.Artist

Parameters

artist
The name of the artist.

Related Topics

  • CDDB Method


AlbumTitle

Returns the album title of the audio CD.

Syntax

title =AudioCD.AlbumTitle

Parameters

title
The album title.

Related Topics

  • CDDB Method


CDDB

The CDDB method contacts the CDDB server to obtain track-listings.

Syntax

AudioCD.CDDB

Parameters

This method has no parameters.

Related Topics

  • ConvertTrack Method


Refresh

The Refresh method reads the table-of-content of the audio CD and updates the Track and TrackCount properties.

Syntax

AudioCD.Refresh

Parameters

This method has no parameters.

Related Topics

  • ConvertTrack Method


Len

The length of the audio CD track in frames.

Syntax

length = AudioCDTrack.Len

Parameters

length
Receives the length.

Related Topics

  • ConvertTrack Method


Title

Returns the title of the audio CD track.

Syntax

title =AudioCDTrack.Title

Parameters

title
The album title.

Related Topics

  • CDDB Method


Bitrate

The bit rate (in kbps) of the Windows Media audio file to be created. The default value is ac64kbps.

Syntax

WMASettings.Bitrate [= bitrate]

Parameters

bitrate
Set this to one of the following values:

typedef enum AcWindowsMediaBitrate
{
  ac5kbps = 5,
  ac6kbps = 6,
  ac8kbps = 8,
  ac10kbps = 10,
  ac12kbps = 12,
  ac16kbps = 16,
  ac20kbps = 20,
  ac22kbps = 22,
  ac32kbps = 32,
  ac40kbps = 40,
  ac48kbps = 48,
  ac64kbps = 64,
  ac80kbps = 80,
  ac96kbps = 96,
  ac128kbps = 128,
  ac160kbps = 160,
  ac192kbps = 192
} AcWindowsMediaBitrate;

Related Topics

  • AudioSettings Property


SampleRate

The sample rate (in kHz) of the Windows Media audio file to be created. The default value is ac44kHz.

Syntax

WMASettings.SampleRate [= samplerate]

Parameters

samplerate
Set this to one of the following values:

typedef enum AcWindowsMediaSampleRate
{
  ac8kHz = 8000,
  ac11kHz = 11025,
  ac16kHz = 16000,
  ac22kHz = 22050,
  ac32kHz = 32000,
  ac44kHz = 44100,
  ac48kHz = 48000
} AcWindowsMediaSampleRate;

Related Topics

  • AudioSettings Property


Channels

The channels of the Windows Media audio file to be created. The default value is acStereo.

Syntax

WMASettings.Channels [= channels]

Parameters

channels
Set this to one of the following values:

typedef enum AcChannels
{
  acMono = 1,
  acStereo = 2
} AcChannels;

Related Topics

  • AudioSettings Property


Bitrate

The bit rate (in kbps) of the MP3 audio file to be created. The default value is acm128kbps.

Syntax

MP3Settings.Bitrate [= bitrate]

Parameters

bitrate
Set this to one of the following values:

typedef enum AcMP3Bitrate
{
  acm32kbps = 32,
  acm40kbps = 40,
  acm48kbps = 48,
  acm56kbps = 56,
  acm64kbps = 64,
  acm80kbps = 80,
  acm96kbps = 96,
  acm112kbps = 112,
  acm128kbps = 128,
  acm160kbps = 160,
  acm192kbps = 192,
  acm224kbps = 224,
  acm256kbps = 256,
  acm320kbps = 320
} AcMP3Bitrate;

Related Topics

  • AudioSettings Property


SampleRate

The sample rate (in kHz) of the MP3 audio file to be created. The default value is acmAutoSampleRate.

Syntax

MP3Settings.SampleRate [= samplerate]

Parameters

samplerate
Set this to one of the following values:

typedef enum AcMP3SampleRate
{
  acmAutoSampleRate = 0,
  acm48kHz = 48000,
  acm44kHz = 44100,
  acm32kHz = 32000
} AcMP3SampleRate;

Related Topics

  • OutputSettings Property


GenerateCRC

Generate CRC for each frame in the MP3 audio file. The default value is False.

Syntax

MP3Settings.GenerateCRC [= crc]

Parameters

crc
If true, the CRC will be generated for each frame.

Related Topics

  • AudioSettings Property


PrivateFlag

Set private flag in the MP3 audio file. The default value is False.

Syntax

MP3Settings.PrivateFlag [= private]

Parameters

private
If true, the private flag will be set.

Related Topics

  • AudioSettings Property


OriginalFlag

Set original flag in the MP3 audio file. The default value is False.

Syntax

MP3Settings.OriginalFlag [= original]

Parameters

original
If true, the original flag will be set.

Related Topics

  • AudioSettings Property


CopyrightFlag

Set copyright flag in the MP3 audio file. The default value is False.

Syntax

MP3Settings.CopyrightFlag [= copyright]

Parameters

copyright
If true, the copyright flag will be set.

Related Topics

  • AudioSettings Property


What's new in this release?

  • Editing of album information and submissions to CDDB are now supported.

  • New customizable toolbar. The new toolbar icons were drawn by Jon Wojan.

  • This program now supports the encoding of MP3 files using the MP3 codec installed on the system or L.A.M.E (Lame ain't an MP3 encoder). Previously only the BladeEnc MP3 encoder had been supported.

  • You can now create your own custom audio CDs that can be played in any standard home or car stereo.

  • WinAmp M3U and PLS playlists are also supported -- just load a playlist and burn its contents directly to an audio CD.

  • An ID3v2 tag editor is included, allowing you to edit information like Author, Title, Comments or Album Title of audio files.

  • Normalization of the audio volume is now supported.

  • The AIFF format is now completely supported.

There is a ChangeLog.txt file in the directory where Audio Converter has been installed to. It contains a detailed list of changes.


Launch Audio Converter

  1. Click Start.

  2. Point to Programs.

  3. Point to Audio Converter.

  4. Click Audio Converter.


Command Line Reference

To access Audio Converter's functionality by command-line you can use the tool audcmd.exe which is part of Audio Converter PE.

In the DOS box, type audcmd /? for information on the command-line syntax.


Installing an ASPI Driver

An ASPI driver is required for digital audio extraction (DAE) or CD ripping. If Audio Converter is unable to find the ASPI driver ("Unable to initialize ASPI manager") please try this:

1) Download this ZIP file: http://www.audioconverter.info/downloads/nexitech.zip
2) Extract all files to a directory, for example: C:\Nexitech\
3) Execute: C:\Nexitech\aspikit.exe

You can use WinZip to work with ZIP files.


Support CD-R Devices

IDE/ATAPI Recorders

Many IDE/ATAPI recorders are supported.

CDROM Recorders

  • Acer 6206A / 4232A / 4432A / 6232A / 6432A / 8432A

  • Actima 4420

  • AOpen 9420 / 9624

  • Creative Labs 2224 / 4224 / 4800 / 6424 / 8432 / 8433

  • Creative Labs 8435E / 8438E / 121032E

  • Cyberdrive CDRW602

  • Grundig CDR100IPW

  • Hewlett Packard 4020 / 6020 / 7100 / 7200 / 7500 / 8100 / 8200 / 8250 / 8290 / 9100 / 9200 / 9300 / 9500 / 9600 / M820E

  • Hewlett Packard 9700 / 9900

  • Hi-Val 2242

  • Iomega ZipCD (all models)

  • Imation 4x4x20 / 8x2x20

  • JVC XR-W2010 / XR-W2020 / XR-W2040 / XR-W2080 / XR-W4080

  • Kodak PCD225 / PCD600

  • LG/Goldstar 8041B / 8042B / 8080B / 8083B

  • Memorex 620 / 1622 / 2642 / 2216 / 4224 / 6424 / 8432 / 8220S

  • Micro Solutions BACKPACK (all models)

  • Mitsumi 2401TS / 4801TE / 4802TE / 4804TE

  • Mitsubishi CDRW226

  • Olympus CDS615E / CDS620E

  • Panasonic (Matsushita) 7501 / 7502 / 7582 / 7503 / 7585 / 7586 (see notes below)

  • Philips CDD522 / 2000 / 2600 / 3600 / 3610 / 3801 / 4201 / 4401 / 4801 / OmniWriter

  • Pinnacle RCD5040 / RCD4X4

  • Plasmon RF4100 / CDR4220 / CDR4240 / CDR480

  • Plextor All Models

  • Ricoh 1420C / 6200 / 6201 / 7040 / 7060 / 7063 / 7080 / 7083 / 7120 / 8040 / 9060 / 9120

  • Samsung SW-204 / SW-206 / SW-207 / SW-208 / SM-304

  • Samsung SM-308 / SW-408 / SW-212

  • Sanyo 8x / 12x

  • Smart & Friendly All Models (except portable 4x)

  • Sony 920S / 924S / 948S / CRX100 / CRX110 / CRX120 / CRX140 / CRX145 / CRX160

  • TDK VeloCD 8x / VeloCD 12x

  • Teac CD-R50S / CD-R55S / CD-R56S / CD-R58S / CD-W54E / CD-W-512E

  • Toshiba SD-R1002

  • Traxdata CDRW2260 / CDRW4260 / CDR4120 / CDRW2224 Plus

  • Waitec WT2036 / WT2422 / WT2444 / WT3244 / WT412 / WT624 / WT824 / WT4046 / WT2082 / WT3284

  • Wearnes CDR-432 / CDR-632 / CDRW-622

  • Yamaha All Models

  • Yamaha CRW2100E / CRW2100S

Notes

  • The copying of discs directly from a CDROM drive to the recorder (i.e. "on the fly") is not supported for the Panasonic 7501 for technical reasons (this model is not compatible with how the software was written for all other recorders).

  • The Philips CDD521, Sony 926S, Sony 928E, S&F 2006 (not the same as 2006Plus), Olympus CDS630E, Mitsumi 2600TE, and Mitsumi 2801TE do not support disc-at-once recording, so they are not supported by our software (and never will be).

  • The Creative 4210, Sony 900E, JVC XR-W2001, Pinnacle RCD1000, and Pinnacle RCD5020 are no longer supported by our software.


Jitter Correction

When digital audio is read from a CDROM drive, most drives are not capable of positioning the laser at the precise beginning of the data that you are trying to read. This is because there is no extra information in an audio sector to indicate where the sector starts (as there is in a data sector). Because of this positioning error, the drive will either miss a certain number of bytes at the beginning of a sector or read duplicate bytes from the end of the previous sector. The jitter correction algorithm in this software compensates for these positioning errors through the use of overlapped I/Os and a sector comparison scheme.

The only drives that absolutely require jitter correction (to insure a perfect copy) are those made by Toshiba. All other drives supported by this software only require that the audio data be read fast enough to keep the drive's internal buffer from overflowing as it streams data off of the disc. If you are using a very fast drive such as the Plextor 6Plex, then your system might not be able to keep up with the fast transfer rate and a buffer overflow will occur. In these rare cases, you will need to enable jitter correction to compensate for this heavy load. Some drives, such as the Plextor 8Plex and 12Plex have automatic jittter correction built into the firmware.

Note: It is not harmful to explicitly enable jitter correction for any CDROM drive. The worst that will happen is that the audio will be read slower due to the overlapped I/Os.


Codec

The codec of the Windows Media audio file to be created. The default value is acCodecWindowsMediaAudioV7.

Syntax

WMASettings.Codec [= codec]

Parameters

codec
Set this to one of the following values:

typedef enum AcWindowsMediaCodec
{
  acCodecWindowsMediaAudioV7 = 0,
  acCodecACELP = 1
} AcWindowsMediaCodec;

Related Topics

  • OutputSettings Property


OutputDirectory

The directory of the audio file to be created. It may be unspecified.

Syntax

Converter.OutputDirectory [= directory]

Parameters

directory
The directory for output files.

Related Topics

  • ConvertFile Method


OutputSettings

The settings of the audio file to be created. This property is read-only.

Syntax

settings = Converter.OutputSettings

Parameters

settings
Specifies a variable to receive an object which is used to change output settings.

If the OutputFormat property is acWindowsMedia an WMASettings object is returned.

If the OutputFormat property is acMP3 an MP3Settings object is returned.

Related Topics

  • ConvertFile Method