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Overview of WRackO
WRackO is a game that is easy to learn, and simple to master.    Becoming good at this 
game is based on your ability to quickly see patterns and adapt your strategy to changing 
situations.    Winning at WRackO is dependant on your skill and, (of course) your luck.    You 
can play against the computer or another person.

About the game

The idea here is to get a rack of numbers that fall in ascending order.    The numbers do not 
have to be consecutive.

The game starts with a deck of cards that are shuffled.    Each player is dealt 10 cards.    The
remainder of the cards are placed in a draw pile.    You will start out with a chaotic order of 
numbers.    However, some of these numbers can be kept, since they will be in slots that 
will allow for an eventual winning rack.    Your ability to spot numbers that you will keep is 
essential to winning, since it minimizes the number of slots you need to replace.    Don't 
take too many risks here because you can get locked into needing to fill in a gap that is too 
narrow.

If some of this does not make sense right now, don't worry.    It will once you play a bit.    In 
fact, you may develop strategies that have not been tried by anyone yet.    In time, you will 
find that the computer opponents can be regularly beaten.    When this happens, change 
the options to decrease the deck size, or hide the computer's rack from view.    If you have 
all of the options set to their toughest level, it may be time for the ultimate challenge: 
playing against another human.

Your first game

When you first play WRackO, you will be playing against the computer.    Your rack will be at
the bottom of the screen.    To begin playing, press the Start button.    For each new rack the
first turn is chosen at random, so be ready!    If it is your turn first, the arrow indicator in the
center of the screen will be pointing down, and the red timer bar will begin counting down.   
Decide where you want to place the draw card and click on that slot.    If you do not want 
the draw card, click on the draw slot to get another one.    If you click it a second time, you 
give up your turn.

Once you make a play, the computer opponent will take its turn.    It will do this very quickly
, so be ready to take your turn again.    This will go on untill someone gets a WRackO, or the
deck runs out.

Hang in there, and have fun!    The game isn't hard to pick up and you will soon be beating 
the computer often.



Definitions
Game - a game consists of several racks.    The winner of the game is the first player to get 
more than 500 points.

Rack - a rack is one play of the deck that begins with a new deal.    Each player takes turns 
making plays on their rack until one player gets a WRackO and the appropriate scoring is 
tallied (see scoring).    In addition, the rack is what we call the array of slots that contain the
numbers you will be playing with.

Slot - a slot is one of the positions in the rack where the numbers that you play are located.

Card/Value - this is the number or value that is contained in each slot.

Deck - the deck refers to a virtual pile of cards that are distributed to the players when a 
rack is started, and available in the draw pile for selection during play.

WRackO - In addition to being the name of the program, this term is used to describe the 
winning play of a rack.    This happens when you have made a move to get all of your 
numbers in ascending order.    The game stops, and scores are added up (see Scoring ).



Scoring
When a player achieves a WRackO or if the deck runs out, scoring is applied.    If a player 
gets a WRackO, that player receives 75 points.    The losing player gets 5 points for each 
slot that is greater than the slot before it.    Therefore the minimum a player can receive is 5
points.    In addition, bonus points are awarded for 3 or more slots that have consecutive 
values (for example, a rack that contains 3, 7, 8, 9, 25, 29, 33, 35, 44, 54 has the numbers 
7, 8, and 9 as consecutive values). 

The bonus method works as follows:

3 consecutive slots: add 75 points.
4 consecutive slots: add 125 points.
5 consecutive slots: add 175 points.
6 consecutive slots: add 225 points.
and so on...

For each additional consecutive slot, add 50 points.



Features
The options available in WRackO allow you to configure many different ways of playing.    
This gives you the ability to vary the level of difficulty.    The Game Setup dialog contains 
the following controls:

Hiding the Rack: Use this option to determine whether to show the computer's rack values. 
Not knowing what the computer has in its hand makes deciding which card to discard more 
difficult.    This does not give the computer opponent any additional advantage since it 
never looks at your rack (honest!).

Showing Progress: During a game against a computer opponent, the computer's held cards 
are shown in green.    As more and more slots turn green, you know that the computer 
opponent is nearing a WRackO.    This knowledge can affect your strategy.    Turn this feature
off to increase difficulty.

Timer Speed: When its your turn, a red bar will count down to signify the time remaining in 
your turn.    You can shorten this time to increase the difficulty of making placement 
decisions.

Deck Size:    A basic WRackO deck has 60 cards, numbered 1-60.    This range of values 
gives you much flexibility, and more opportunity to take chances.    Decreasing the deck 
size will increase the overall difficulty of the game (for you and your opponent).

Other features in WRackO are:

Player controls (keyboard/mouse): You can choose between using a mouse to make 
selections or two different rows of keys on the keyboard.    In a game between two humans, 
it is best to have one player use the mouse, and the other use one of the keyboard 
selections.    This selection can be made in the Player Setup dialog.

High Score list: Any time a player gets a WRackO that has more than 75 points (see Scoring
), that player's score for the rack is compared against other high scores for inclusion in the 
high score list.    You can see this list by selecting the Show High Scores item in the File 
menu.

Sound: If your computer is equipped with a sound card, you may enable the sound effects 
option.    This option is found in the Game Setup dialog.

Animation: When a card is chosen from the draw slot, its movement to the player's rack is 
animated by sliding the card over and down.    This feature may not look smooth on some 
computers.    You can disable the animation by making the appropriate selection in the 
Game Setup dialog.



The File Menu

The File Menu contains the following menu commands from which you may choose:

New Game - Starts a new game.    The scores are set to zero.

Show High Scores - The ten highest rack values achieved are listed here.

Exit - Select this command to quit WRackO.



The Options Menu

The Options menu contains the following commands from which you can choose:

Game Setup - This menu item will bring up a dialog that will allow you to select the game 
level and speed, whether to show the computer's rack values and progress, and control the 
use of sound and animation.

Player Setup - This menu item will bring up a dialog that will allow you to identify Player 1 
or 2 as human or computer, and whether to use the mouse or keyboard.

Set Player Names - This menu item will bring up a dialog that will allow you to change the
names of the computer and human players.

Clear Running Score - The running score is the total number of games that each player 
has won and is shown in the title bar of the window.    It will be kept between sessions.    The
only way to reset it is by selecting this menu item.



Starting WRackO
Overview of the game.

This is what the main screen of WRackO looks like.    To begin playing a game, select New 
Game from the File Menu.    Before you start, you can configure the game by making 
selections in the Options Menu.    

To find out what each of the items in the window do, just click on them.



Game Setup
When you select Game Setup from the Options Menu, the following dialog appears.      You 
can use this dialog to configure many of the game's features.    Some of the items will 
control the level of difficulty of the game.    To find out what each of the items in the window
do, just click on them.



Player Setup
When you select Player Setup from the Options Menu, the following dialog appears. You can
use this dialog to configure what type of players will play, and what they will use.    To find 
out what each of the items in the window do, just click on them.



Why Register?
Why should you register this product?    What's in it for you?    The topics listed below have 
more information on this questions

The reasoning
What you receive
Registering WRackO



Credit Card Payment
The basic registration cost of this product is $15.

We now have a new credit card payment option available.    This is accessable through a 
toll-free phone line.    In addition, you can access this service by mail, CompuServe or Fax.    
Payments made through this channel are subject to a $5.00 handling fee.    As always, you 
can register by check or money order through our PO Box.    This new service has been 
added to accomodate the needs of some of our customers.    We hope you find this helpful 
and convenient.

You can order with MC, Visa, Amex, or Discover from Public (software) Library by calling:
1-800-2424-PsL 
713-524-6394 
between the hours of    7AM to 6PM CST (Monday-Thursday) and 7AM to 12:30PM CST 
(Friday)

Be sure to mention that you are registering Product Number 11909

By FAX to 713-524-6398

By CIS Email to 71355,470. 

You can mail credit card orders to:
PsL
at P.O.Box 35705, Houston, TX 77235-5705.

THE ABOVE NUMBERS ARE FOR CREDIT CARD ORDERS ONLY.
THE AUTHOR OF THIS PROGRAM CANNOT BE REACHED AT THESE NUMBERS.



Registering WRackO
If you have already registered and would like to validate your copy of WRackO, open the 
Register menu and select the Enter Registration Number item.    Enter the number that 
was provided in your registration letter.    The OK button will become enabled, and you can 
press it.    When the dialog closes, the program becomes a registered version.    You will no 
longer see registration reminders.    Thank You for your support!

Otherwise...

WRackO is distributed as Shareware.    This means that if you regularly use the product and 
benefit from it, you should register with the author (see name and address below).    The 
software you now have is not crippled in any way.    This indicates a basic trust of the 
Shareware concept by myself and other Shareware authors who provide useful products 
with the hope of some type of return for their efforts.

The basic registration cost of this product is $15.

Please print the registration form and fill in the requested information.    In addition you may
register by credit card.

You may contact me electronically in the following ways:

GEnie: DOLAN
Compuserve: 71075,3256
Internet: 71075,3256@compuserve.com

Distribution

If you distribute WRackO to friends, associates, or to a computer bulletin board system 
(BBS),    you may only distribute the compressed file including the copyright and disclaimer.

Disclaimer

WRackO is copyright 1995 by Bob Dolan

The Copyright Owner hereby disclaims all warranties relating to this software, whether 
express or implied, including without limitation any implied warranties of merchantability or
fitness for a particular purpose. The Copyright Owner will not be liable for any special, 
incidental, consequential, indirect or similar damages due to loss of data or any other 
reason, even if The Copyright owner or an agent of The Copyright Owner has been advised 
of the possibility of such damages.    In no event shall The Copyright Owner's liability for 
any damages ever exceed the price paid for the license to use the software, regardless of 
the form of the claim.    The person using the software bears all risk as to the quality and 
performance of the software.



Registration Form
To print this registration form, open the File menu and select Print Topic.

Mail to:
Bob Dolan
P.O. Box 16514
Rochester, New York 14616-0514

Please register me as a satisfied user of WRackO    (ver 1.10)

Please enclose $15 in US funds.    Make checks or money orders out to Bob Dolan.    

Your registration includes a disk containing the latest version of WRackO.    In addition, this 
disk will include evaluation copies of many of my other products.    These will be the current
versions of each, including programs that were not available when this was written.    The 
disk will be a 1.4M 3.5 floppy unless you request otherwise.    All files will be in ZIP 2.0 
format unless you request otherwise.

For orders from outside of the U.S., please add $3 to cover additional postage.

Name:_____________________________________________________

Address:___________________________________________________

City:______________________State:_______Zip:__________________

Phone(optional):_____________________________________________

GEnie/CompuServe/Internet/AOL mail address:

_________________________________________________________

Where did you get this program?    This is important in that it helps us to 
distribute the product to places where you are more likely to see it.

__________________________________________________________

___________________________________________________________

Comments:_________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________

___________________________________________________________



Other Products from Bob Dolan Software

Windows Shareware

WRackO -- A number strategy game that is easy and fun

WRackO is a challenging, card type strategy game that you can play against the computer 
or another person.    It is easy to learn, simple to master.    Quick thinking and risk taking are
essential to being a winner in WRackO.

The Spelling Voice -- A learning program that makes spelling fun!

An educational program that is both fun and effective.    Students create and use spelling 
lists that are spoken to them in their own voice.    An easy to use interface guides spellers 
from the age of 5 to 50 in improving their spelling skills.    This program requires a sound 
card for proper usage.    A microphone is also suggested.

DeskMenu! --    A low profile, text based Program Manager for Windows

There is probably no other program you can add to your system that will make better use 
of its screen and disk space than DeskMenu!    This easily configured program manager and 
resource monitor speeds access to all your applications.    DeskMenu! places a menubar on 
your desktop and allows you to setup the menu headings to reflect how you categorize 
your applications. An optional InfoBar shows time, date and up to six different system 
resources. DeskMenu! can be used in addition to the Program Manager or it can replace it 
as the Windows shell.    All of this functionality in a good looking, easy to use package!

Yacht-Z    --    A dice strategy game for Windows

Yacht-Z is a version of the classic dice game.    You can play single or triple scoring varieties 
of the game.    Up to four players can play at once. This is the original and most often 
reviewed of all Yacht-Z type dice games.    Several years of constant use and valuable input 
from users has honed this into one of the most enjoyable and challenging games available (
unless you prefer blowing up things! ).

WinGo! --    The classic Bingo for Windows

Finally, Bingo has arrived for Windows!    You match wits with Rosie, an alert and cunning 
adversary.    You can play with as many cards as you can handle at the speed you like.    
Fully configurable to adapt to your playing style.    The registered version includes digitized 
voice calling for the most realistic Bingo play possible.

The Joker -- Jokes On Demand

The Joker gives you a laugh whenever you need it. Just as your day is getting completely 
boring, a window will appear with a joke to break the ice.    If one joke doesn't do it for you, 
then press the ANOTHER button for more.    The program is easy to use, and once setup to 
your liking, it will require no maintenance.    You can load different joke files, order more 



from the author, and even create your own.

BattleGrid -- War in a window -- Battleship for Windows 3.x

BattleGrid is a version of the classic board game.    Play against the computer or another 
person.    Watch the computer play against itself using different strategies.    Several levels 
of a computer opponent are available, from idiot to genius.    

SCAT -- A strategic and daring card game

Don't get stuck with the lowest hand!    SCAT is a card game involving four players that can 
be as simple or challenging as you want.    Features include defining strategy levels, setting 
the game speed, and leaving the cards face up or face down as you play.    This game even 
includes conversational chit chat between the players!    Very addicting and fun!

WinDial -- A    Windows Phone Book that dials

An easy to use phone book that will automatically dial any selected number as long as you 
have a modem.    When a busy signal is detected, you can tell WinDial to retry until 
someone answers.    Other busy attempts can be placed into a queue, and all will be retried 
in order.

Mister Clean -- Clean up your hard drive

One of the most efficient ways to clean up those hidden but unwanted or unused files that 
take up needed space.    A slick Windows 3.x user interface makes this utility a must have 
for your toolbox.    Mister Clean finds files the you specify and sorts them by size.    You click 
on the ones you want deleted and then off they go, one-by-one (to be safe) or all at once.    
Not sure what the file is?    Then run it right from Mister Clean and check it out before 
dumping it!    Truly a unique way of managing precious disk space.

InstallWare -- An application installer
InstallWare is a small, easy to use application installation program for Windows 
applications.    It costs nothing to use if you are distributing Freeware.    Registration 
provides an extended version that enables automated construction of installation disks.

Windows Freeware

16 Tons -- Drop your sound files here!
Simply plays WAV and MIDI files.    Accepts drag & drop operations from the file manager.    
Most handy when used it as an icon.

Random Saver -- Variety in savers
Make full use of that collection of screen savers you've got.    Now you can get them out of 
your WINDOWS directory.    This utility will run them at random from any location when you 
install it as the default screen saver in the Windows Control Panel.





Select the OK button to apply and save your selections.



Closes the dialog without making any changes.



Opens the on-line help and shows a topic related to current task.



This selection will determine the number of cards in the deck.    When a value of 60 is used, 
the chances of building a winning rack are greater.    Selecting 40 will allow little room for 
error.    



This setting controls the speed of your turn.    Set it to Fast if you need a greater challenge.   
You will have less time to make your move.



If checked, the rack values of the computer player will be displayed.    Otherwise they are 
hidden until the end of the game.



If you check this, the rack slots that the computer player has locked will be indicated by a 
green highlight.    Otherwise, you have no idea which slots are being held, which increases 
the game difficulty.



If you enable this item, a drawn card will slide into place in the selected rack slot.    If not 
selected, the value just appears in the slot.



If you have a working sound card in your machine, checking this item will enable the sound 
effects.    If you do not have a card (or just don't like the sounds), then you should clear this 
checkbox.



This is a player's rack of cards (or values).    It contains ten slots which must be manipulated
to get a winning rack.



Your current score for this rack is indicated by a green bar graph.    When your opponent 
gets a winning rack, your score for the rack is determined by the length of this indicator.    
You receive five points for each slot that is in order from smallest to largest.



Before a game begins, this button will read Start.  When you press it, the game begins, and
its text changes to Next.  After each rack is completed, this button will become enabled, 
allowing you to start the next rack of the game. 



Press this to temporarily stop the current rack.    It isn't fair to do this just to have time to 
analyze the computer's rack.    Remember that the logic that the computer player uses, 
does not involve looking at your rack (at least in this version).



Cancel the play for this rack (and maybe try again).



This bar graph shows the size of the remaining deck of cards.    If it reaches zero, the rack 
ends, and the players score's are credited with the size of their current rack.



This indicator graphically shows who the current player is.



This is the draw slot.    Clicking on it retrieves the next card in the deck.    Clicking on it a 
second time, gives up your turn.    If you click a slot in your rack, the draw card will be 
placed in this slot, and the previous value of the slot will be moved to the draw.    This will 
allow your opponent to use that card.



Shows the names of the players and their scores for the current game.



A red bar graph shows the time remaining in your turn.    This is not used for the computer 
players, since they make their choices instantly.    At the end of a rack, the rack value is 
shown here and is added to your total score.



Game status, or any other messages are shown here.



Indicates what type of player will be used.    If a human player is chosen, the Keyboard 
control section becomes enabled.



When a human player is chosen, any of these three types of control can be used.    F1-F10 
are the function keys.    0-9 are the number keys across the top of the keyboard.    These 
keys are assigned to the rack slots in order.    They are helpful in a game involving 2 
humans.    When the keyboard is used, the space bar is assigned to the draw slot.



Reasoning
Why should you register a Shareware product?    Since you already have the product, why 
should you pay for it?    The fact that many people using Shareware feel this way has a lot 
to do with the trend towards crippling and nagging.    Shareware authors are trying to 
create incentive for those who use their products to actually pay for them.    In a perfect 
world, those who try Shareware realize that they only have a license to evaluate the 
product, and after a reasonable amount of time, will either pay for the right to continue 
using it, or remove it from their computer.

It isn't always a question of affordability.    I know folks with more money than you could 
imagine that would never pay for a Shareware package ("it's free software, isn't it?").    On 
the other hand, I know of people that barely make their bills each month that wouldn't think
of using a Shareware product that they hadn't registered.

The only difference between this software and the software you buy at the store, is that 
shareware gives you the benefit of making sure that the product is of value to you.    If you 
are still using it after two weeks, then you should should consider registering.    Not doing so
is no different than stealing a software package from your local computer store.

So much for the ethics of registering Shareware.    Understandably, some folks just aren't 
interested in this.    Even though it all makes sense, what they really want to know is: What 
do I get when I register? 



From the author's perspective, there are three types of prospective customer:

The conscientious Shareware buyer:    This person looks at Shareware for what it 
is: a low cost alternative to commercial software.    If a product serves their needs and meets
their quality expectations, they register it right away.    If more people had this attitude, 
crippling and nagging would disappear.

The well-intended Shareware procrastinator:    This person knows that they 
should register the Shareware that they are constantly using, but they just don't "get around
to it".    Nagging gives this person incentive to register.

The hard-core (L)user:    This person has no intention of paying for anything that 
they can steal.    When a program they use nags them too much, they either find something 
else to occupy their time with or try to crack the program's nag mechanism.    Since this 
person will never buy, they are ignored by most Shareware authors.

So, who are you?



What You Get
This is what you get when you register one of my products:

The ethics angle is covered.    You have done the Right Thing.
Any nagging that is going on will stop.
If there are features missing, they will be enabled.
I will send you a disk with many of my other products for you to evaluate.
You will get the latest version of the program that you are registering.
If you find a newer version later on, the registration number I send you will register 

that also.
If you need to call me for help, you will have my undivided attention.
I will send you a letter of heartfelt thanks, since you have acknowledged my hard 

work.

Granted, it's not a lot of material stuff.    But, most of my customers just want to tell me 
thanks, and I think that is what Shareware buyers are all about.



When this is checked, the sound of the clock ticking will be heard during your turn.    Clear 
the checkmark to silence the ticking.



Brings up a dialog showing the program name and version, as well as a button to get 
information on registering the program.



New Features In This Release
Version 1.10

Fixed a bug that caused to play timer to reset to the fastest speed after the first 
game.

Fixed a bug in the Pause control handling.

Version 1.01
Did not include the price of registration in the help file....




