
Examples for Personal AVI Editor

All references to the Motorsports Action! CD-ROM in this document, is a reference to the 
CD-ROM that is a part of the registred version of Personal AVI Editor/Motorsports Action!

This document describes the example files included with Personal AVI Editor. The purpose of the 
examples is to teach you the basics of Personal AVI Editor. Try to create the projects from the 
describtion and watch the results.

If you just want to see the projects, you can load a finished version of every project from the 
directory where you installed Personal AVI Editor (the files are named example1.pae, 
example2.pae, example3.pae, and example4.pae). The resulting AVI files from the projects are 
stored in the directory examples on the Motorsports Action! CD-ROM (example1.avi, 
example2.avi, example3.avi, and example4.avi).

Example 1 - Creating a simple project.

This example demonstrates how to create a new project, and how to add files to the project. 

For the first example we use just two files - a BMP file (still image) and a WAV file (sound). The 
resulting AVI file simply shows the picture while playing the sound. Here is how it was done:

* Start Personal AVI Editor.
* Choose "Construction window" from the "Options" menu.

Select "Drop file at end" 
Check the "Always prompt for still image duration" box. (note 1)

* Create a new project: 
Choose "New" from the "File" menu.

* Import the files needed for this project: 
Choose "Import file" from the "File" menu and select the file "ex1bmp.bmp".
Choose "Import file" from the "File" menu and select the file "ex1sound.wav".

* Drag the sound file "ex1sound.wav" from the project window to the audio track (the bottom 
track) in the construction window.
* Drag the picture file "ex1bmp.bmp" from the project window to the video track (the top track) in 
the construction window.
* Enter "10.61" (the length of the sound file) in the "Still duration" box. (note 2)
* Choose "Project" from the "Options" menu.

Set the size to 120x120 
Set the frame rate to 5 fps. (note 3)

* Choose "Save as" from the "File" menu, and name the project "ex1.pae".
* Choose "Make movie" from the "Project" menu and click on the "OK" button to make the movie. 
Be patient - this takes some time.
* When the movie is complete choose "Yes" to see the movie.

Note 1: The "Drop file at end" setting is the common setting when creating a new project or when 
you are working with simple projects. Use this setting whenever you can.
Note 2: By entering the length of the sound we ensure that picture and sound both has the same 
length in the final AVI file. The length of the sound is displayed in the project window next to the 
picture.
Note 3: The purpose of lowering the frame rate is to obtain as low a data rate as posible. The 
reason that we don't set the frame rate to "1 fps" is that the sound then will be resized to 10 
seconds and we will lose the end of the file. By using "5 fps" we only lose 0.01 second (10.61 
seconds is resized to 10.6 seconds). You should always pay attention to the individual sound files
before altering the frame rate, as some resizing of the sound files almost always is necessary to 
match the frame rate.



This example is nothing more than a sound file with a picture. Now on to moving pictures...

Example 2 - Animation and effects.

This example demonstrates how to use Personal AVI Editor to create simple animations, and how
to use an effect. Further it demonstrates how to alter the length of a file in the construction 
window.

In this example we use the files "ex2bmp1.bmp", "ex2bmp2.bmp", "ex2bmp3.bmp", and 
"ex2sound.wav". The final AVI file shows a little animation and plays a little Cicada song.

* Start Personal AVI Editor.
* Create a new project.
* Import the files needed for this example:

ex2bmp1.bmp
ex2bmp2.bmp
ex2bmp3.bmp
ex2sound.wav

* Choose "Project" from the "Options" menu.
Set the size to 160x120
Set the frame rate to 15 fps. (note 1)
Set the compression method to "Cinepak Codec...".

* Drag the sound file "ex2sound.wav" from the project window to the audio track in the 
construction window.
* Choose "Construction window" from the "Options" menu.

Select "Drop file at end".
Un-check the "Always prompt for still image duration" box. 
Enter "0:4" in the "Default duration for stills" field. (note 2)

* Build the animation in the video track by dragging the picture files to the construction window.
First drag ex2bmp1.bmp to the construction window, 
then ex2bmp2.bmp, 
then ex2bmp3.bmp
and repeat this 4 more times.

* If you have followed the above steps, the last file in the video track should now end at the 4 
seconds mark, and the audio track ends just past the 4 seconds mark.
To make the video track and audio track the same length, we have to alter the length of the last 
file in the video track.
* Select the file in the audio track by clicking on the file. The information window now displays the 
information for the selected file.

We note that the "Stop (lead out)" time is "00:00:04:01". (note 3)
* Select the last file in the video track by clicking on the file. In the information window we can 
see, that this file ends at "00:00:03:14". (note 3)
* Alter the length of the file by selecting the the "Stop (lead out)" field in the information window 
and
change the value in the field to "00:00:04:01". (note 4)
* Finally we want to fade the sound away at the end of the AVI file. Drag the "Fade" effect from 
the "Plug-in modules" window and drop it at the 3 second mark in the audio track.
* The plug-in effect displays and configuration box and suggests a "fade out" effect. Click the 
"OK" button to accept. (note 5)
* Choose "Save as" from the "File" menu, and name the project "ex2.pae".
* Choose "Make movie" from the "Project" menu and click on the "OK" button to make the movie. 
Be patient - this takes some time.
* When the movie is complete choose "Yes" to see the movie.



Note 1: Normally you would choose a frame rate for an animation that matches the length of the 
pictures (eg. using "5 fps" and a picture duration of 1 frame instead of "15 fps" and a picture 
duration of 3 frames). In this example we use the setting of "15 fps" to demonstrate how to set the
length of a file to match the length of the two tracks. REMARK: The size of the resulting AVI file is 
almost the same no matter what frame rate you use, as Personal AVI editor optimizes the size 
used by still images. The use of a lower frame rate does lower the request for system 
performance, however.
Note 2: The "Default duration for stills" field asks you to enter the duration in seconds. You can 
however enter the duration in frames as well - this is done using the colon (as in "0:4" which is 0 
seconds and 4 frames). REMARK: When entering time in second:frames the frames are always 
based on the current project frame rate. If you enter "0:10" when the frame rate is "15 fps" you 
get 2/3 of a second. If you enter "0:10" when the frame rate is "5 fps" you get 2 seconds (10 
frames = 2 seconds at 10 Frames Per Second").
Note 3: The time in the information window is shown in "h:m:s:f" format (that is 
hours:minutes:seconds:frames).
Note 4: You can use the mouse to set the length (the start and position as well) of a file. See the 
help file for a complete describtion (search for the term "mouse editing").
Note 5: When you use "fade out" the effect is placed at the end of the file on which you dropped 
the effect. When you use "fade in" the effect is placed at the start of the file. You can try to 
experiment with this yourself (if you lose track of a file or an effect because it becomes to small 
then you can use the "Select file" from the "Edit" menu to select it and the delete it).

In this example we used 3 pictures for the animation but you can use as many pictures as you 
want to build a cartoon or a more exciting animation.

Something you should note (and a nice feature of Personal AVI Editor) is the automatic 
convertion and scaling it does for you. If you check the "project window" you can see that the 
pictures have a size of 80x80 and the sound is sampled at 22050 Hz. In the final AVI file the 
pictures have been scaled to a size of 160x120 and the sound has been converted to a sample 
rate of 11025 Hz.

Now on to working with AVI files...

Example 3 - Using AVI files

This example demonstrates how to use just a part of an AVI file to create a new AVI file.

In this example we use the file "ex3avi.avi".

.* Start Personal AVI Editor.
* Choose "Project" from the "Options" menu.

Set the size to 160x120.
Set the frame rate to 15 fps.

* Create a new project.
* Import the file needed for this example:

ex3avi.avi
* Double-click the file in the project window to view the AVI-file. You'll see a short introducation 
(Get ready) followed by some ostrichs.
In the previous example we altered the length of a file (by altering the value in the "Stop (lead-
out)" field). In this example we want to get rid of the introduction.
* Drag the "ex3avi.avi" file to the construction window. Both the pictures and the sound will be 
added to the construction window.
* Select the file in the video track.
* Move the cursor to the start of the selected file (until the cursor changes shape) and set the 
starting frame of the file by dragging the start of the file. Watch the information window and drag 



until the field "Start (lead in)" is "00:00:01:00". When you release the mouse button the 
information window should read "00:00:01:00" in the start field and "00:00:03:07" in the stop field 
(if this is not the case the use "Undo" from the edit menu, and try again - the cursor must be very 
near the start of the selected file).
* Repeat the above action for the audio track.
Both tracks now starts with a 1 second pause, followed by the "ex3avi.avi" file.
* Select the pause in front of the file in the video track. Remove it by using "Delete" from the edit 
menu. Repeat this action for the audio track.
Check both tracks: The times in the information window should be "00:00:00:00: in the start field 
and
"00:00:02:07" in the stop field.
* Add a "fade in" effect to the video track by dragging the "fade" effect to the construction window, 
releasing it at the 1 second mark and selecting "Fade in". The effect will be added to the start of 
the window. Select the effect and set the stop (lead-out) time to "00:00:00:10" (use the 
information window).
* Add a "fade out" effect to the video track - release it just before the 2 seconds mark.
* Add similar effects to the audio track.
* Choose "Save as" from the "File" menu, and name the project "ex3.pae".
* Choose "Make movie" from the "Project" menu and click on the "OK" button to make the movie. 
Be patient - this takes some time.
* When the movie is complete choose "Yes" to see the movie.

Example 4 - Effects that uses two files

In this final example we look at plug-in effects that use two files.

In this example we use the files "ex4bmp1.bmp", "ex4avi1.avi", and "ex1sound.wav".

.* Start Personal AVI Editor.
* Choose "Project" from the "Options" menu.
* Set the size to 160x120 and the frame rate to 15 fps.
* Choose "Construction window" from the "Options" menu.

Select "Drop file at end" 
Check the "Always prompt for still image duration" box.

* Create a new project.
* Import the following files:

ex4bmp1.bmp
ex1sound.wav

* Drag the "ex4bmp1.bmp" file to the video track in the construction window, and give it a duration
of 2 seconds.
* Drag the "Wipe" effect from the plug-in window, and drop it on the video track at the 1 second 
mark.

Select "0°" and "OK".
* Personal AVI Editor prompts you for the name of the second file to be used for this effect. Select
the "ex4avi1.avi" file.
* Drag the "Fade" effect from the plug-in window, and drop it on the video track at 2.5 seconds.

Select "Cross fade" and "OK".
* Personal AVI Editor prompts you for the name of the second file to be used for this effect. 

Select the "ex4avi2.avi" file.
* Drag the "ex1sound.wav" file to the audio track, and adjust the length to match the total length 
of the video track.
* Add a "Fade out" effect to the audio track at 4 seconds.
* Choose "Save as" from the "File" menu, and name the project "ex4.pae".
* Choose "Make movie" from the "Project" menu and click on the "OK" button to make the movie. 
Be patient - this takes some time.



* When the movie is complete choose "Yes" to see the movie.

Tips and tricks for Personal AVI editor

* In the examples we used a lot of BMP files (to avoid using a lot of harddisk space), but Personal
AVI Editor works just as easy with AVI files.
* The "Mix" effect (not demonstrated in the examples) can be used to mix two audio files together.
* You can use the preview function (Project menu, Preview) to see how the movie is progressing 
(very small effects will not always be played!).
* As demonstrated in example 4, you can use a bitmap file (BMP file) to make simple title 
screens.
* Scrolling title pages can be created using the animation technique from example 2 (or you can 
order our plug-in pack which includes a "Text" plug-in).
* It is possible to stack effects (use 2 or more effects on the same time) to make interesting 
combination effects.
* You can use Personal AVI editor to record sound (requires a sound card) and video (requires a 
video grabber).

Other video products from FlickerFree Multimedia Products

The MEGAPLUG plug-in pack
The MEGAPLUG plug-in package has more than 50 additional plug-ins for use with Personal AVI 
editor, including...
- "Text" video plug-in for title screens, credit screens, and sub titles. The text can be scrolled in 
different directions and all Windows fonts available can be used.
- Improved "Fade" video and audio effect with configurable fade-style (the fade included with 
Personal AVI Editor is a linear fade only).
- Improved "Wipe" video effect - wipes in all directions.
- Additional Wipes (video) - wipes in bands, circles, like opening or closing doors, etc...
- "Zoom" video effects to zoom in on details in a picture - rectangle zoom, circle zoom, user 
defined shape zoom .
- "Croma key" video plug-in to overlay one picture with another.
- "Warp" video effects to stretch pictures in interresting ways.
- "Slow motion" video and audio effect with an option to interpolate in-between pictures.
- "Fast motion"  video and audio effect.
- "Echo" video and audio effect.
- Improved "Mix" audio plug-in.
- "Flanger" audio effect.
- and even more...
 The MEGAPLUG pack also includes the FlickerFree plug-in SDK, which includes the information 
you need to create your own plug-ins (compilers NOT included). The SDK has the following 
features:
- Header files for C and C++.
- Unit files for Turbo/Borland Pascal for Windows.
- Complete documentation for our plug-in technology.
- Documentation for how to create plug-ins.
- Documentation for how to use the plug-ins in your own programs.
- Documentation in both WRITE format and HELP format.
- Working samples in C and Pascal with source code.
- The DIBLIB.DLL and DIBLIB32.DLL library for handling bitmaps (creates, loads and saves BMP-
files, bitmaps from video pictures, convert to 24 bit color, scaling, dithered drawing, and fast pixel 
manipulation...) which handles bitmaps in the format expected by Personal AVI editor.
- The WAVETOOL.DLL and WTOOL32.DLL for manipulation of sample rates.
- The PSWRAP.DLL to make Photoshop compatible plug-ins. When you've written a plug-in you 



simply makes a copy of PSWRAP, and changes a string-resource, and then the plug-in will be 
accessible by Photoshop through the wrapper. 
- You can use C, C++, and Pascal to create the plug-ins.

IN FOCUS - The Professional AVI Editor
IN FOCUS is our full-fledged, multi-track video editing software. It has all the features of Personal
AVI editor, plus a lot more...
- Multiple, sizeable, zoomable, and scrollable video and audio tracks (32000+).
- Works with all multimedia file types registred in Windows.
- Enables the use of all compression codecs (Personal AVI Editor only works with 24 bit codecs).
- Fully configurable video recording, with improved AUTO technology.
- Fully configurable audio recording.
- Improved editing, including file splitting, clip editor, and trimming.
- Sample-precise sound editing (Personal AVI Editor edits sound in frame rate steps).
- Glue files and Break glued files (glued files is edited as one file). AVI files are automatically 
glued when inserted in the construction window.
- Anti-alias and interpolation options for automatic scaling of picture size.
- Interpolation option for missing frames during automatic frame rate convertion.
- Anti-alias and interpolation options for missing samples during automatic sample rate 
convertion.
- Improved configurable preview, including our fast "TEMPAVI" codec, which improves the 
playback rate and uses less harddisk space than the "Full frames" concept used in Personal AVI 
Editor.
- Improved "Make movie" with "on the fly" compression (does not use separate harddisk space for
effects and rate convertions).
- Project window with note capability, and a quick-locate function.
- Import all files from a directory.
- Configurable information window.
- Configurable plug-in window.
- New preview window.
- New clip window.
- Handles projects with missing project files (eg. files from different CD-ROMs).
- "Locate files" option.
- Reads project files created by Personal AVI Editor.
- Project files can be read by Personal AVI Editor (Personal AVI Editor ignores the information 
specific to IN FOCUS).
- Includes all plug-ins from the MEGAPLUG pack in 32 bit versions.
- Includes the "FlickerFree plug-in SDK".
- Full 32 bit program that runs under Windows 95, Windows NT 3.51 and Windows 3.1 with 
Win32s (included).
- Uses threads for time consuming tasks under Windows 95 and Windows NT.
- Final version will be available in early 1996. If you order now you'll receive the latest version of 
Personal AVI Editor, the MEGAPLUG pack for use with Personal AVI Editor, and will be included 
in our beta-test program and receive the beta-version of IN FOCUS. Active beta testers will 
receive fixes and newer beta versions as appropriate. The final version will be sent, as soon as it 
is released.


