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 About WorkBlox

WorkBlox the graphical organizer for objects and files
WorkBlox is a graphical workspace for storing, organizing, and tracking objects and files to which you 
want quick, easy, and organized access. WorkBlox stores your objects on tabbed pages which you can 
set up to reflect the way you categorize your own work tasks; subtabs provide a second level of 
organization within each category.
WorkBlox has full OLE functionality, allowing you to store objects directly within its tabbed pages and also
to create shortcuts or links to files stored elsewhere. You no longer need to remember complex paths, 
directories and filenames to find what you want instead, use WorkBlox to access them directly.
Using drag-and-drop, you can add objects and files to WorkBlox quickly and easily, and you can copy 
objects from WorkBlox directly into other documents whenever they are needed. If you are a network 
user, you can share WorkBlox with other users and include links to files stored on other network drives. 
WorkBlox supports objects and files from all AlphaBlox applications for example, NoteBlox, CalcBlox, 
and ListBlox

and from any other OLE-compliant applications.
        WorkBlox Features



 WorkBlox Features

WorkBlox is a simple yet powerful tool for organizing and accessing objects and files:
Customizable Design: Design your WorkBlox to reflect the way you organize your own work. 

Create tabs for the various categories of information you work with. Use subtabs to create a second level 
of organization within each category. 

Add your own labels to the tabs to identify their contents. Customize the fonts and colors used for
each tabbed page to suit your own preferences and to help distinguish the various categories. 

Predefined Subtabs: WorkBlox has predefined sets of subtabs for commonly-used categories 
such as days, months, years, and letters of the alphabet. You can use these for subdividing your top level 
tabs, or you can create your own subtabs.

Linking and Embedding: WorkBlox has full OLE functionality. It can contain both embedded and
linked objects created by any OLE-compliant application. Simply drag-and-drop the object onto the 
appropriate page (from ToolBlox, for example), or use the standard Edit | Insert Object command. You can
also drag-and-drop objects from WorkBlox into other applications.

You can display objects with their content visible or as icons, and you can choose to edit 
embedded objects either in place or in separate windows. To activate and edit an object, simply double-
click on it. 

Arranging Objects: WorkBlox allows you to arrange objects either manually or automatically. If 
you wish, WorkBlox will arrange objects in ordered rows either on request or automatically as objects are 
added or moved. 

You can also display objects as miniatures (choose Display as Miniature from the pop-up menu 
displayed when you right-click on an object)—objects are automatically resized as miniatures when you 
drag them from Explorer into WorkBlox. 

Reorganizing Tabs and Objects: WorkBlox supports dragging-and-dropping of objects within 
and between tabbed pages. You can also reorder tabs and subtabs by dragging them from one position to
another.

Multiple WorkBlox: You can create and use more than one WorkBlox simultaneously
a different WorkBlox for each project you are working on, for example. You can even drag-and-drop 

between different WorkBlox.
Tracking: Keep track of objects and documents by creating shortcuts to them in WorkBlox. For 

example, if you have a number of files relating to a particular task stored in different directories on your 
computer or elsewhere on a network, you can create links to all the files on a single tab in WorkBlox. 
Double-clicking on the object in WorkBlox immediately opens the source application and file ready for 
editing.



 WorkBlox: the Basics

For a description of any component, click on that component in the picture below (a tool button or menu, 
for example).



New WorkBlox
Creates a new WorkBlox in the WorkBlox window.



Open WorkBlox
Opens an existing WorkBlox file. In the Open dialog, you specify the name of the file and its location. 
Then click Open to open it.



Save All
Saves the content of the currrent tab. Tab contents are automatically saved when you bring a different tab
to the front and when you close the WorkBlox. If you want to save the current tab without performing 
either of these actions, use the Select All command.



New Tab
Creates a new tab in the current WorkBlox. The new tab is automatically added as the rightmost tab, but 
you can move it to another position using drag-and-drop.



New Subtab 
Creates a new subtab for the currently selected tab. WorkBlox provides a number of predefined subtabs 
(months, years, letters of the alphabet, etc.), but you can also create your own.



Edit Tab
Allows you to change the attributes of the currently selected tab (colors, font, label, etc.)



Edit Subtab
Allows you to edit the attributes of the currently selected subtab (font, colors, label, etc.).



Always on Top
Click this button if you want WorkBlox always to appear on top of other windows on your desktop.



Fit to Window
Resizes objects on the current page so that they all fit within the current window size and can be viewed 
without scrolling.



Arrange
Arranges objects on the current page in ordered rows. The grid to which WorkBlox aligns the objects is 
set up using the Blox | Options | Layout option.



Auto Arrange
WorkBlox automatically arranges objects in ordered rows on the page whenever you insert them or move 
them. The grid to which WorkBlox aligns the objects is set up using the Blox | Options | Layout option.



Status Bar
The status bar is displayed at the bottom of the WorkBlox window. The left part of the status bar displays 
a description of the function of menu items and toolbar buttons as you move the mouse pointer over 
them. The right part of the status bar indicates whether the following keys are currently on or off: CAP 
(Caps Lock key is on), NUM (Num Lock key is on), SCRL (Scroll Lock key is on).



Caption Bar
This displays the name of the current WorkBlox file. Minimize, Maximize, and Close buttons are included 
at its right-hand side, the control menu button at its left-hand side. 
To move the WorkBlox window, drag the title bar. 



Scroll Bar
If the WorkBlox window is not large enough to display all the objects on a page, use the scroll bars to 
scroll to the parts of the page not currently displayed. You can scroll by dragging the scroll box, by clicking
the scroll arrows, or by pressing the PgUp, PgDn, or Arrow keys on your keyboard.



Tabs
Tabs are used to create categories within a WorkBlox so that objects relating to particular categories can 
be stored together for quick, easy, and organized access. You create tabs using the New Tab button or 
the File | New Tab command. 
To edit an existing tab, double-click on it to display the Edit Tab dialog box. 
Right-click on a tab to display its pop-up menu. The Edit Summary Info option on this menu allows you to 
enter and view summary information about the tab. The Edit Tab option displays the Edit Tab dialog box.



Subtabs
Subtabs provide a second level of organization within each tab category. WorkBlox has predefined sets of
subtabs for commonly-used categories such as days, months, years, and letters of the alphabet. You can 
use these for subdividing your top-level tabs, or you can create your own subtabs. 
Use the New Subtab button or the File | New Subtab command to create a new subtab. 
To edit an existing subtab, double-click on it.
Right-click on a subtab to display its pop-up menu. The Edit Summary Info option on this menu allows you
to enter and view summary information about the subtab. The Edit Tab option displays the Edit Tab dialog 
box.



Embedded Object
WorkBlox has full OLE functionality. It can contain both embedded and linked objects created by other 
OLE-compliant applications. Simply drag-and-drop the object onto the appropriate page.
You can display objects with their content visible or as icons, and you can choose to edit embedded 
objects either in place or in separate windows. 
To activate and edit an object, simply double-click on it.



Linked Object
WorkBlox has full OLE functionality. It can contain both embedded and linked objects created by other 
OLE-compliant applications. Linked objects retain a link to the original source file and are updated 
whenever that file is updated. Linked objects are identified by their broken outline.



WorkBlox Page
A WorkBlox page is a large virtual page onto which you can embed and link objects from any OLE-
compliant application. At any one time, the WorkBlox window provides a view onto some portion of this 
virtual page, and you can use the scroll bar to move to the parts not currently displayed.
The Fit to Window command on the Blox menu resizes all objects so that they can be viewed at one time 
within the current WorkBlox window size.



Tab Scrolling Arrows
If the current window size is too narrow to display all the tabs included in a WorkBlox, tab scrolling arrows 
are added at the right of the tabs. You use these arrows to scroll the tabs left and right.



Insert Object Button
Use to insert a new or existing object into WorkBlox. The object can be inserted as an icon or with its 
content displayed, and can be either linked or embedded. To activate and edit the object, simply double-
click on it. 



 About OLE

OLE (Object Linking and Embedding) is a mechanism that allows applications to integrate seamlessly. 
Documents can contain objects of many different types, created by different applications, and the objects 
have associated with them not only the data necessary to display them but also the information needed to
edit them. The host document is the container; the application that created the object is the server.
Linking and Embedding 
Using OLE you can choose to embed or link an object into a container such as WorkBlox. 
Embedded objects are stored in the container, and can be edited using the tools and controls of their 
applications. You simply double-click on an object to activate and edit it. When you send an embedded 
object to other people, they too can view and edit it (provided that they have the application that created 
it).
With linked objects, only the display data is included in the container, together with a pointer to the original
data. When the original object is updated, so is the linked object. And when you double-click on the linked
object, the original document is immediately launched ready for editing.
In-place (or Visual) Editing 
You can edit an embedded object either in place or in a separate window. Simply double-click on the 
object to activate it. With in-place editing, you edit the object without leaving the container document. The 
necessary menus and tools temporarily replace or supplement those of the container application. Click 
back on the container, or press ESC, and its menus and tools reappear. 
Drag-and-Drop 
Drag-and-drop is a fast and intuitive method of moving objects within and across applications. Point to the
object, press and hold down the left mouse button while dragging the object into place, then release the 
button. To move data, first select it and then follow the same steps. 

Move an object or selected data Drag-and-drop 
Create a copy of the object or data CTRL+Drag-and-drop 
Create a linked copy of the object or data CTRL+SHIFT+Drag-and-drop
When dragging-and-dropping into WorkBlox from Explorer or from the Desktop, objects are linked to the 
original source file by default. Press CTRL while dragging-and-dropping to embed an object instead.
Icon or Content Display 
You can display OLE objects either with their content visible or as icons. To switch modes, right-click on 
the inactive object; then choose Display Content or Display as Icon from the pop-up menu. When creating
an object directly from ToolBlox, you can create it in either mode. Objects displayed as icons are 
automatically edited in separate windows; objects with content displayed are automatically edited in 
place.
Note: Only OLE2-compliant applications can exchange information with AlphaBlox OfficeBlox objects 
using linking and embedding and drag-and-drop techniques.



 About ToolBlox

ToolBlox is your point of access to WorkBlox. It is a powerful, customizable toolbar that provides fast 
access to AlphaBlox objects and to other frequently-used applications such as Microsoft Word or Excel. A 
distinguishing feature is that not only can you use it to launch applications but you can also create objects
directly from it with a single action. 

To launch WorkBlox or any other application included on ToolBlox, simply click on its icon.
To create an object directly in a container document or on the desktop, drag the object's icon from

ToolBlox to the desired position. You can then activate and work with the object by double-clicking on it. 
You can drag the object as an icon or as an in-place object. The default is set in the ToolBlox preferences,
but there are also keyboard shortcuts. To create an in-place object, press CTRL while dragging the object 
into position; to create an iconized object, press SHIFT instead. 

To add an application to ToolBlox, use Explorer to locate the executable file (WINWORD.EXE for 
example), and drag it into position on ToolBlox. AlphaBlox objects are automatically added to ToolBlox 
when you install them. 

To change ToolBlox preferences, click on the ToolBlox Configure icon. Then use the Preferences 
options to change attributes such as the size and layout of icons and whether objects are embedded by 
default as icons or as in-place objects. 

When ToolBlox is the active task, you can switch between its normal size and a captionized version by 
pressing ESC.



 About AlphaBlox

WorkBlox is one of a suite of components from AlphaBlox Corporation which gives you quick and easy 
access to frequently-used items such as notes, calculations, and lists. Many other components are 
already available, under development, or planned.
Making full use of OLE functionality, all components integrate seamlessly with each other, with the 
desktop, and with other OLE-compliant applications they can be combined in whatever way suits your 
needs, and are available wherever and whenever required. 
All AlphaBlox tools are designed to be simple, quick, easy, adaptable, compact and affordable. A 
consistent interface style across the components, and the use of common tools for common tasks, 
contributes to more intuitive interaction with the tools.



 Creating a New WorkBlox

1 Choose the File | New WorkBlox command to create a new WorkBlox.
2 Use the New Tab button or the File | New Tab command to create a tab for each of the main 

categories you want to include in the WorkBlox.
3 Use the New Subtab button or the File | New Subtab command to create each of the subdivisions 

you want to include under a particular tab. Click on the relevant tab before choosing the button or 
menu command.

4 New tabs and subtabs are always inserted to the right of existing tabs. To reposition a tab or 
subtab, click on it and drag it to its new position.

5 To edit the attributes of a particular tab or subtab, first click on the tab or subtab you want to edit, 
then click on the Edit Tab or Edit Subtab button, as appropriate, or choose the Edit | Edit Tab or Edit
| Edit Subtab command.

6 Insert the objects and files you want to store in the WorkBlox.
7 Save the WorkBlox to a file using the File | Save WorkBlox As command. You can subsequently 

use the File | Open WorkBlox command to open the WorkBlox whenever you want to use it.
Each time you start the WorkBlox application, the WorkBlox you were last working with is opened 
automatically, ready for use. It is displayed at its previous size and position if the Retain Position on Exit 
option is currently selected (use the Blox | Options command to access this option).



 Creating a New Tab

Use the File | New Tab command or the New Tab button to create a new tab. Choosing the command 
displays the Add Tab dialog box where you specify the settings for the tab.



 Creating a New Subtab

1 Choose the File | New Subtab or the New Subtab button.
2 In the Subtab Category Styles dialog box, select Custom if you are designing your own subtabs; 

otherwise, select one of the predefined options.
3 Select Use Parent Attributes if you want the subtabs to use the same colors and fonts as the parent

tab.
4 Click OK.

If you select the Custom option, the Add Tab dialog box is now displayed so that you can specify the 
subtab settings.



 Editing a Tab

Use the Edit Tab button or the Edit | Edit Tab command to change the attributes of the currently selected 
tab. Choosing the command displays the Edit Tab dialog box where you specify the new settings.



 Editing a Subtab

Use the Edit Subtab button or the Edit | Edit Subtab command to change the attributes of the currently 
selected subtab. Choosing the command displays the Edit Tab dialog box where you specify the new 
settings.



 Deleting a Tab

Use the File | Delete Tab command to delete the currently selected tab or subtab and all its contents. The 
tab is removed from all WorkBlox in which it is included and cannot be accessed again. Note that you 
cannot delete a tab until all its subtabs have been deleted.
You are prompted for confirmation only if the Prompt for Tab Delete option is currently selected (use the 
Blox | Options command to access this option).
To remove a tab from the current WorkBlox instead, use the Remove Tab command on the File menu. 
The tab is removed from the current WorkBlox but remains available to other WorkBlox, and can be 
reloaded into the current WorkBlox using the New Tab command.



 Removing a Tab

Use the File | Remove Tab command to remove a tab from the current WorkBlox. The tab is removed 
from the WorkBlox but remains available to other WorkBlox. It can be reloaded into the current WorkBlox 
using the New Tab command.
Use the File | Delete Tab command instead to delete a tab or subtab and all its contents. The tab is 
removed from all WorkBlox in which it is included and cannot be accessed again. Note that you cannot 
delete a tab until all its subtabs have been deleted.



 Inserting New Objects on a Page

You can insert a new object in WorkBlox by dragging it from ToolBlox, by using the Edit | Insert New 
Object command, or by using the Insert Object button on the toolbar. 
For example, to embed an Excel worksheet in a WorkBlox:

1 Display the WorkBlox page where you want to insert the object by clicking on its tab and subtab.
2 From ToolBlox, drag Excel into WorkBlox and drop onto the page. Or use the Insert New Object 

command on the WorkBlox Edit menu.
3 Double-click on the worksheet to activate it.

If the worksheet is embedded as an icon, Excel is launched in a separate window. Otherwise it is 
edited in place.

4 Enter your data.
5 If editing in an Excel window, click the Close button when finished. If editing in place, click outside 

the object when finished or press ESC.
6 To switch between displaying the Excel worksheet as an icon or as content, right-click on the object

and choose Display as Icon or Display Content from the pop-up menu. Alternatively, use the Object
| Convert command on the WorkBlox Edit menu and select or deselect the Display as Icon option.



 Inserting Existing Objects on a Page

You can drag-and-drop any existing AlphaBlox object directly onto a WorkBlox page. For example, open 

an existing NoteBlox file, then click on the Drag Note button in its toolbar and drag into place this 
creates a separate copy of the NoteBlox in WorkBlox. 
If you drag the Drag Link button instead, the new NoteBlox is linked to the original NoteBlox and is 
updated whenever that file is updated. In WorkBlox, linked objects are identified by a broken outline.
If the page into which you want insert the object is not visible, move the mouse pointer to the relevant tab 
while dragging the object. That tab will then move to the front and you can then select the subtab you 
want in the same way. Then simply drop the object on the page.
You can also insert an existing file using the Edit | Insert New Object command.
You can also insert an existing file directly from Explorer or from the Windows 95 desktop. First locate the 
file you want to insert and then simply drag-and-drop it into position on the WorkBlox page. By default, 
objects dragged from Explorer or from the desktop are linked to the original source object. To embed an 
object instead, press CTRL while dragging the object into place.



 Arranging Objects

You can place objects anywhere on a tabbed page; use the scroll bars to move to areas of the page not 
currently displayed.
If you wish, WorkBlox will arrange the objects in ordered rows either on request (click the Arrange button) 
or automatically whenever you move or insert them (when the Auto Arrange option is currently selected).
The grid to which WorkBlox aligns the objects is set up using the Blox | Options | Layout options. 
WorkBlox automatically resizes the objects to fit the grid if the Snap Object Sizes to Grid option is 
selected (use the Blox | Options | Settings command to access this option).



 Activating Objects

To activate a WorkBlox object, double-click on it.
By default, objects with their content displayed are activated in place. WorkBlox menus and tools are 

replaced or supplemented with those you need to edit the object these disappear when you click 
outside the object again.
By default, objects displayed as icons, and all linked objects, are activated in separate windows. Click the 
Close button when finished to return to WorkBlox.
If you wish you can override these defaults using options on the object's pop-up menu.
Right-click on the object to display the menu, choose the last option on the menu (ListBlox Object, for 
example), and then choose Edit to edit the object in place or choose Open to edit the object in a separate 
window.



 Display Options

Icon and Content Display
You can display a WorkBlox object with its content visible or as an icon. To switch between the two 
modes, right-click on the object and choose Display Content or Display as Icon from the pop-up menu.
Choose Display as Miniature instead to display a miniature version of the object. Use the Set Miniature 

Scale option to specify the size of the miniature the default size is set using the Blox | Options | 
Settings command. Objects dragged from Explorer or from the desktop are displayed as miniatures by 
default.
You can also use the Object | Convert command on the WorkBlox Edit menu to switch between icon and 
content display.
Objects displayed as icons are automatically edited in separate windows; objects with content displayed 
are automatically edited in place.

Fit to Window View
The Blox | Fit to Window command allows you to view all the objects on a page in a single window. 
WorkBlox resizes the objects to fit the current window size.



 Moving and Copying Objects

You can move an object from one page to another using drag-and-drop. Drag the object until the mouse 
pointer is over the tab of the page into which you wish to insert the object. That tab moves to the front and
you can then select the subtab you want in the same way. Then simply drop the object on the page. 
To copy an object from one page to another, hold down the CTRL key while dragging-and-dropping the 
object.
To move an object from WorkBlox to another document, simply open the document and drag the object 
into it. To copy the object instead, press the CTRL key while dragging-and-dropping it.
You can also use standard Cut, Copy and Paste commands to move and copy objects. First select the 
object by clicking on it and then choose the command.



 Tracking Objects Using WorkBlox

You can use WorkBlox to track objects by creating links to the objects in WorkBlox:
1 In the source application, right-click on the object you want to create the link to and choose Copy 

from the pop-up menu. Or select the object and choose Copy from the Edit menu.
2 Right-click on the WorkBlox page where you wish to insert the shortcut and choose Paste Link from

the pop-up menu. A linked copy of the object is created on the WorkBlox page.
3 Close the source application.
4 Whenever you now double-click on the object's icon in WorkBlox, the source application and object 

are immediately opened ready for editing.



 File Menu

New WorkBlox Creates a new WorkBlox in the WorkBlox window. If 
the current WorkBlox has not been saved to a file, 
you are prompted to save it; otherwise the current file
is automatically closed and saved before the new 
WorkBlox is opened.

Open WorkBlox Opens an existing WorkBlox file. In the Open dialog, 
you specify the name of the file and its location. Then
click Open to open it.

Save WorkBlox 
As

Use to save a new WorkBlox to a specified filename 
and location. The WorkBlox is subsequently saved to 
that file whenever you close it. You can also use this 
command to change the name of a WorkBlox file or 
to make a copy of it to a different filename and 
location.

Save All Saves the content of the current tab. Tab contents 
are automatically saved when you bring a different 
tab to the front and when you close the WorkBlox. If 
you want to save the current tab without performing 
either of these actions, use the Select All command.

New Tab Creates a new tab in the current WorkBlox. The new 
tab is automatically added as the rightmost tab, but 
you can move it to another position using drag-and-
drop.

New Subtab Creates a new subtab for the currently selected tab. 
WorkBlox provides a number of predefined subtabs 
(months, years, letters of the alphabet, etc.), but you 
can also create your own.

Remove Tab Removes the current tab from the WorkBlox. The tab 
remains available to other WorkBlox, and can be 
reloaded into the current WorkBlox using the New 
Tab command.

Delete Tab and 
Contents

Deletes the current tab or subtab and all its contents. 
The tab is removed from all WorkBlox in which it is 
included and cannot be accessed again. Note that 
you cannot delete a tab until all of its subtabs have 
been deleted.

Exit Exits WorkBlox. 



 Edit Menu

Undo Reverses the previous action, where possible.
Cut Deletes a selected object, placing it on the clipboard.
Copy Copies a selected object to the clipboard.
Paste Inserts the clipboard contents onto the current page as an 

object.
Paste Link Inserts the clipboard contents onto the current page as an 

object, and creates a link between the object in the 
WorkBlox and the source object.

Edit Tab Displays attributes of the currently selected tab and 
enables you to edit them.

Edit Subtab Displays attributes of the currently selected subtab and 
enables you to edit them.

Insert New 
Object

Inserts a new or existing object into WorkBlox. You can 
insert the object with its content visible or as an icon. You 
can also choose either to embed the object or to create a 
link to an existing file.

Links Lists any OLE links included in the current WorkBlox and 
enables you to edit them.

Object This command becomes available when you click on a 
WorkBlox object. Its differs depending on the type of 

object selected for example, Microsoft Excel 
Worksheet Object, CalcBlox Object, ListBlox Object.
Choosing the command displays the Object submenu.

Object | Open Opens the selected object in a separate window, ready for
editing.

Object | Edit Activates a selected object ready for in-place editing. The 
menus and tools required are added to the WorkBlox 
menu bar and toolbar.

Object | 
Convert

Enables you to convert a selected object to a different 
object type (where relevant), and also to switch between 
displaying the object as an icon or as content.



 Blox Menu

View Displays a submenu that allows you to choose whether 
the toolbar and status bar are displayed, and to choose 
whether Fit to Window view is currently on or off. 
In Fit to Window view, objects are resized so that they all
fit in the current window and can be viewed without 
scrolling.

Arrange Arranges objects on the current page in ordered rows. 
The grid to which WorkBlox aligns the objects is set up 
using the Blox | Options | Layout option. 
If the Snap Object Sizes to Grid option is currently 
selected (in the Blox | Options | Settings dialog box), 
WorkBlox automatically resizes the objects to the grid.

Auto Arrange You can toggle this command on and off. When it is on 
(a checkmark appears beside it), WorkBlox 
automatically arranges objects in ordered rows on the 
page whenever you insert them or move them. The grid 
to which WorkBlox aligns the objects is set up using the 
Blox | Options | Layout option. 
If the Snap Object Sizes to Grid option is currently 
selected (in the Blox | Options | Settings dialog box), 
WorkBlox automatically resizes objects to the grid.

Always on Top You can toggle this command on and off. When it is on 
(a checkmark appears beside it), WorkBlox always 
appears on top of other windows on your desktop.

Options Use to change WorkBlox options.



 Help Menu

WorkBlox 
Help Topics

Opens the WorkBlox online help window. 

About 
WorkBlox

Displays WorkBlox version and copyright details.



 WorkBlox Options

Use the Blox | Options command to change WorkBlox attributes. The following tabs are displayed:
Settings
Layout
Window



 WorkBlox Settings Options

Use the Blox | Options | Settings command to access these options:

Retain Position on Exit
WorkBlox always opens displaying the same tabbed page that was displayed when you last exited it.

Default Auto Arrange
WorkBlox uses Auto Arrange by default. In Auto Arrange mode, WorkBlox automatically arranges objects 
in ordered rows on the page whenever you insert them or move them. The grid to which WorkBlox aligns 
the objects is set up using the Blox | Options | Layout option. 
If the Snap Object Sizes to Grid option is currently selected (see below), WorkBlox automatically resizes 
objects to the grid.

Prompt for Tab Delete
WorkBlox prompts for confirmation before deleting a tab.

Prompt for Object Delete
WorkBlox prompts for confirmation before deleting an object.

Snap Object Sizes to Grid
WorkBlox automatically resizes objects to fit the grid defined by the Blox | Options | Layout options.

Save Settings
The current WorkBlox settings are saved as the default settings for future WorkBlox sessions.

Tab Select Delay (seconds)
When using drag-and-drop to move or copy an object to a different page, you drag it up to the tab of the 
page where you wish to insert it; that page moves to the front and you then drop the object onto it. Use 
this option to introduce a time delay (in seconds) so that the tabs do not move to the front immediately as 
you move the mouse pointer over them.

Default Miniature Size
The Display as Miniature option on an object's pop-up menu displays a miniature version of the object

the Set Miniature Scale option on the menu allows you to set the size of the miniature. The default 
miniature size (expressed as a percentage) is set using this option. 



WorkBlox Layout Options

Use the Blox | Options | Layout    command to access WorkBlox layout options.
These options allow you to set up the invisible network of grid lines to which WorkBlox aligns objects 
when arranging or auto arranging them, and to which it sizes objects when the Snap Object Sizes to Grid 
option is selected (see the Blox | Options | Settings option). All grid measurements are in pixels.

Grid Settings
Grid X and Grid Y control the horizontal and vertical spacing respectively between grid lines.

Spacing 
Offset X specifies the distance from the horizontal grid lines to the edge of an object. Offset Y specifies 
the distance from the vertical grid lines to an object.



WorkBlox Window Options

Use the Blox | Options | Window    command to access these options:

WorkBlox Color
Specifies the color of the window area surrounding the tabbed pages.

WorkBlox Border
Specifies the distance between the edge of the WorkBlox window and the edge of the tabbed pages.

Tab Border
Specifies the width of the border around tabbed pages.



 Control Menu

Restore Returns the WorkBlox window to its size and position 
before you chose the Maximize or Minimize command.

Move Enables you to move the WorkBlox window using the 
arrow keys. Choosing the command displays a four-
headed arrow, and you simply press the arrow keys on 
your keyboard to move the window around the screen. 
Press ENTER when finished.

Size Enables you to size the WorkBlox window using the 
arrow keys. Choosing the command displays a four-
headed arrow. First press the arrow key (up, down, left, 
or right) that corresponds to the border you want to 
move; then press the appropriate arrow keys to move 
that border in the desired direction. Press ENTER when 
finished.

Maximize Enlarges the WorkBlox window to fill the entire screen.
Minimize Reduces the WorkBlox window to an icon on the 

taskbar.
Close Exits WorkBlox.



 Open WorkBlox Dialog

Use the File | Open WorkBlox command to open an existing WorkBlox. The Open dialog box presents the
following options:

Look In
Identifies the current folder. The contents of that folder are listed in the box below. 
To view how the current folder fits in the hierarchy of folders on your computer, click the down arrow. To 

open one of those folders, simply click on it its contents are then shown in the list below.
To open one of the files or folders listed, double-click on it. 
File Name

Use to specify the name of the file you want to open this can include the full path for the file. You 
can include * as a wildcard to filter the files displayed in the list above. If you select a file in this list, its 
name is automatically entered here.

File of Type

Specifies the type of file to be listed in the dialog box that is, WorkBlox Configuration File. WorkBlox
files have the file extension .wtx.

Toolbar
The following tool buttons appear at the top of the dialog box:
Up One Level: Opens the folder one level higher than the current one.
Create New Folder: Creates a new folder in the current one.
List: Lists files and folders with their icons and names only.
Details: Lists files and folders with their icon, name, file size, file type, and date last modified.

Open button
Click to open the WorkBlox specified in the File Name box. 

Cancel button
Click to close the dialog box without opening a WorkBlox.



 Save WorkBlox As Dialog

Use the File | Save WorkBlox As command to save a new WorkBlox to a specified filename and location. 
The WorkBlox is subsequently saved to that file whenever you close it. You can also use the command to 
change the name of a WorkBlox file or to make a copy of it to a different filename and location.
The Save As dialog box presents the following options:

Save In
Identifies the current folder. The contents of that folder are listed in the box below. 
To view how the current folder fits in the hierarchy of folders on your computer, click the down arrow. To 

open one of those folders, simply click on it its contents are then shown in the list below.
Double-clicking on an existing file name in the list saves your WorkBlox to that file, overwriting the current 
contents of the file.
File Name
Use to specify a name for the file you want to save. You can specify a full path for the file if you wish. If 
you have selected a file in the list above, its name is automatically entered here.

Save as Type

Specifies the type of file you are saving that is, WorkBlox Configuration File. WorkBlox files have 
the file extension .wtx.

Toolbar
The following tool buttons appear at the top of the dialog box:
Up One Level: Opens the folder one level higher than the current one.
Create New Folder: Creates a new folder in the current one.
List: Lists files and folders with their icons and names only.
Details: Lists files and folders with their icon, name, file size, file type, and date last modified.

Save button
Click to save your WorkBlox to the specified filename and location. If you specify the name of an existing 
file, the current contents of that file will be overwritten. 

Cancel button
Click to close the dialog box without saving the WorkBlox.



 Insert Object Dialog Box

Use the Edit | Insert New Object command to insert a new or existing object into WorkBlox. The object 
can be inserted as an icon or with its content displayed, and can be either linked or embedded. To 
activate and edit the object, simply double-click on it. 
The Insert Object dialog box presents the following options:

Create New
Embeds a new object of the specified type into the current WorkBlox. You specify the object type by 
selecting the appropriate option in the Object Type list.

Create from File
Embeds or links an existing file into the current WorkBlox. You specify the file you want by typing its name
in the File box. Alternatively, you can use the Browse button to browse through the files and folders on 

your computer until you find the file you want then double-click on it to enter its name in the File 
box.
Select the Link option to specify that you want to link the file instead of embedding it. If you link the file, 
the copy of the file in WorkBlox is linked to the original source file and is updated whenever the source file
is updated. If you embed the file, a separate copy is inserted in WorkBlox with no links to the source file. 
Display as Icon / Change Icon
Select Display as Icon to display the object in WorkBlox as an icon instead of with its content displayed. 
When you select this option, the default icon is displayed and also a Change Icon button which allows you
to choose a different icon.

Result
Describes the result of using the current settings when you insert an object. 

OK button
Click OK to insert the specified object or file into WorkBlox using the currently selected settings. 

Cancel button
Click Cancel to close the dialog box without inserting an object.



 Convert Dialog Box

Use the Edit | Object | Convert command to convert a selected object to a different file type, to activate it 
using an application other than its original application, or to switch between displaying the object with its 
content visible or as an icon. The Convert dialog box presents the following options: 

Current Type
Indicates the current file type.

Object Type
Lists the file types to which the object can be converted, or which it can be activated as.

Convert to
Click this to convert the object to the file type selected in the Object Type list.

Activate as
Click this if you want to edit the object using an application other than its original application. Select the 

required application in the Object Type list the selected application must support the particular 
object type. 

Result
Describes the result of implementing the current settings.

Display as Icon / Change Icon 
Select Display as Icon to display the object in your WorkBlox as an icon instead of with its content 
displayed. When you select this option, the default icon is displayed and also a Change Icon button which
allows you to choose a different icon.

OK button
Click OK to implement your selections. 

Cancel button
Click Cancel instead to close the dialog box without implementing your selections.



 Links Dialog Box

Use the Edit | Links command to list and edit any OLE links included in your WorkBlox. The Links dialog 
box presents the following options:

Links
Lists the links included in your WorkBlox, together with their type and update status.

Source / Type
Indicates the source and file type of the currently selected link.

Update
Use to specify whether you want links to be updated automatically or only on request.

Update Now
Click this to update the currently selected link.

Open Source
Click this to open the source file for the currently selected link.

Change Source
Click this to specify a different source file for the currently selected link. 

Break Link
Click here to disconnect the currently selected link. This is useful if you no longer want changes in the 
source file to be reflected in the WorkBlox object.



 Font Dialog Box

The Tab Font option in the Add Tab and Edit Tab dialog boxes allows you to change the font attributes of 
tab and subtab labels.

Font
Lists all available fonts and indicates the currently selected one. To change to a different font, select the 
new font from the list.

Font Style and Size
Lists the available font styles and sizes for the currently selected font, and indicates the currently selected
options. To change to a different style or size, select the desired options from the relevant list.

Effects
Use to specify whether the text should be struck out and/or underlined, and the color in which it should be
displayed.

Sample
Displays sample text using the settings currently selected in the Font dialog box.

Script
Lists the available language scripts for the currently selected font, and enables you to select the one you 
want to use.

OK button
Click OK to implement any changes you have made. 

Cancel button
Click Cancel instead to close the dialog box without implementing the changes.



 Color Dialog Box

Use this dialog box to change tab, subtab, page, and window colors.

Basic Colors
Presents the basic colors available. To select a particular color, simply click on it.

Custom Colors
Displays any custom colors you have previously defined. To edit a custom color, click on it, click on the 
Define Custom Colors button, make your changes, and then click the Add to Custom Colors button.

Define Custom Colors
Click here to define or edit custom colors. To define a custom color, click on the required color in the color 
matrix and then use the slider at the right side of the matrix to adjust the color's attributes. Alternatively, 
specify precise settings for the color using the Hue/Saturation/Luminosity or Red/Green/Blue options.

Add to Custom Colors
When you have defined a custom color, click here to display it in the Custom Color palette on the left of 
the dialog box.

OK button
Click OK to apply the selected color to the current item (tab, subtab, page, window). 

Cancel button
Click Cancel instead to abandon your selection.



 Add Tab and Edit Tab Dialogs

You use these dialog boxes to specify the settings for a tab or subtab you are creating or editing. 

Tab Name
Use to specify the tab or subtab label.

Tab Color
Displays the Color dialog box which you use to specify a color for the tab and tab border, or the subtab 
and subtab border. 

Tab Font
Displays the Font dialog box which you use to specify font attributes for the tab or subtab label.

Page Color
Displays the Color dialog box which you use to specify a color for the page.

Advanced 
Click here to display the Advanced dialog box where you can specify the directory where the tab data is to
be stored. If you do not specify a directory, WorkBlox uses a default option.

OK
Click OK to implement the tab settings. 

Cancel
Click Cancel instead to close the dialog box without implementing the settings.



 Advanced Dialog Box

This dialog box is displayed when you choose the Advanced button in the Add Tab or Edit Tab dialog box. 

Tab Directory
Use to specify the directory where the new tab and its contents are to be stored.

Browse
Use to browse through the directory structure on your computer to find a particular directory. Select a 
directory and click OK to enter the directory name in the Tab Directory field.

OK
Click OK to confirm the directory name and return to the Add Tab or Edit Tab dialog box.

Cancel
Click Cancel instead to abandon your entry and return to the Add Tab or Edit Tab dialog box.



 Subtab Category Styles Dialog

You use this dialog box to add new subtabs to the currently selected tab.

Styles
Custom: Select this option if you are designing your own subtabs. When you click OK, the Add Tab dialog 
box is displayed so that you can specify the subtab settings (name, color, and font).
Weekdays, Months, etc: Select one of these options to use the corresponding predefined subtabs.
Use Parent Attributes: Select this option if you want the subtabs to use the same colors and fonts as the 
parent tab. Otherwise, when you click OK, the Add Tab dialog box is displayed so that you can choose the
required colors and font.

OK
Click OK to create the new subtab(s). If you selected Custom, or if you chose not to use the parent 
attributes, the Add Tab dialog box is displayed so that you can specify the subtab settings.

Cancel
Click Cancel to close the dialog box without creating any subtab(s). 



Microsoft Office Compatible

Microsoft Office Compatible
WorkBlox is a Microsoft Office compatible product, which means that its toolbars, menus, and accelerator 
keys are similar to those used by Microsoft Office. If you are already using Microsoft Office, which 
includes Microsoft Excel, Word, Microsoft Access and Powerpoint, then many of the tasks you have 
learned to complete in Office can be completed in a similar manner in WorkBlox. AlphaBlox and Microsoft 
hope these similarities will make it easier for you to use our products together and with other Microsoft 
Office Compatible products.
Look for the Microsoft Office Compatible logo when purchasing software. For more information about the 
Microsoft Office Compatible program, and for a complete listing of Microsoft Office Compatible products, 
in the United States, call Microsoft Customer Service at 1-800-426-9400. Customers outside the United 
States should contact their local Microsoft office. 

WorkBlox and the Office Compatible Features
The skills that you have acquired while using Microsoft Office are applicable to WorkBlox. You will find in 
WorkBlox a menu and toolbar arrangement that is very similar to those of Office and the techniques you 
use for navigating around the application are the same. 
For example, to open a WorkBlox, click on the Open button on the toolbar, and to create a new WorkBlox,
click on the New button. Of course, you can also use the Open WorkBlox and New WorkBlox options on 
the File menu to achieve the same results. To discover the function of each button on the WorkBlox 
toolbar, just position the mouse pointer over the button and the tooltip for that button is displayed.

Toolbar Button Differences
Not all of the Office functions are placed on the toolbar.    The reason for this difference is that all 
AlphaBlox products are compact products designed to fit into and complement your Office and other 
applications and so the toolbar has been kept to a minimum size, in order to keep the window width and 
height to the smallest and most useful dimensions.    The functions are, of course, all available from 
menus and shortcut keys.
In particular, you can access Cut, Copy and Paste via the Edit menu or by using the standard accelerator 
keys, these being Control X for Cut, Control C for Copy and Control V for Paste.

Using WorkBlox with Microsoft Office
WorkBlox incorporates full OLE functionality, and you can integrate it directly with Microsoft Office. You 

can use it to store and organize objects and files created by any Microsoft Office application for 
example, Word documents, Excel spreadsheets, and Powerpoint presentations.
The are a number of ways in which you can integrate Office applications with WorkBlox (and indeed other
OfficeBlox applications). Some of the tasks that you can perform are described below.
Inserting Microsoft Office Documents in WorkBlox
To insert a new or existing Microsoft Office object into WorkBlox, use the Insert New Object command on 
the Edit menu, or click the Insert Object button on the toolbar. You can choose to embed the object or to 
link it, whichever you prefer.
You can insert Microsoft Office objects directly from Explorer, if you wish. Simply, locate the file using 
Explorer, and then drag it into position in WorkBlox. Note that objects dragged from Explorer are linked to 
their source files by default. To embed them instead, press CTRL while dragging them.

Inserting WorkBlox Objects into Microsoft Office Documents
To embed an object that is stored in WorkBlox into a Word document, for example, simply drag the object 
from WorkBlox into Word. 



To link the object instead, press CTRL+SHIFT while dragging the object.




