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 System Reporter 

What is the System Reporter? The AT&T WorldNet System Reporter is designed to help you 
get the most out of your AT&T WorldNet software and service.    If you are an experienced PC 
user,    System Reporter may help you diagnose and correct problems.      If you need to call 
AT&T WorldNet Customer Care for help, System Reporter will help you give your service 
representative the information he or she needs to solve your problem and get you back online.

What do the four System Reporter screens do? System Reporter has four different screens, 
each displaying a different kind of information.    Click on the underlined text below for more 
information about the features that interest you.

System Profile shows you basic information about your PC    -- how much memory you have, 
how much space on your hard disk, what sort of BIOS you have, and so forth.

File Versions helps you find important files on your PC, and helps you detect out-of-date or 
incompatible versions of system files.    It also helps you notice if you have conflicting network 
software packages installed, or if you have installed the same package more than once.

Modem/Comm helps you determine if your modem is working correctly.

Running Apps helps you notice other applications that you have running under Windows, which 
may be interfering with the proper operation of your AT&T WorldNet software.

To select one of these screens, simply click on the button next to its name, on the control bar that 
runs across the top of your System Reporter screen (under the menu bar) or choose the 
corresponding entry from the View menu.

Other features:    Using options under the File Menu, System Reporter also allows you to 
format and print reports on system information, and save reports to disk    Using options under 
the View Menu, you can select the screen you want to display, or refresh the currently visible 
display.



 System Profile
Total Installed RAM tells you how much physical memory is installed on your PC.    Note that 
in keeping with the conventions of DOS and Windows, it reports only 640K of the first 1 Meg.    
Accordingly, the amount reported may be less than you expect.

Windows Free Memory tells you how much memory Windows thinks it has.    This number may
be more or less than the total installed RAM, depending on how Windows is configured.

Free Global Heap measures how much memory Windows thinks it has left to parcel out to 
applications when they request it.    It is free because it refers to memory that is not yet being 
used by any application.    It is called heap because different sized chunks of it can be given to 
different programs whenever they request it.    The size of the Free Global Heap may be larger 
than the amount of    Windows Free Memory, depending on how Windows is configured.

Total indicates the total amount of global heap available.
Max Block indicates the largest single chunk available.

Free Resources gives you an idea of how close Windows is to exhausting system resources.    
The lower the percentage of free resources, the more likely you are to encounter problems 
loading or running applications.    A number less than 10% for any of the values indicates that 
you are nearly out of system resources, and should close some applications.

The System Profile display shows information about three different kinds of system resources: 
System, GDI, and User.    The System resources number is the same as shown in the Program 
Manager Help menu, and indicates the percentage of free space available for general use by the 
Windows system.    The GDI resources number shows Graphical Device Interface resource 
usage, including fonts, bitmaps, and other graphics-related resources.    The User resources 
number indicates how much system memory is available for user interface control resources such
as window and menu handles. 

Disk gives you information about the hard drives, floppy drives, CD-ROM drives, and network 
drives on your PC.    For each drive, it displays the drive letter, type, total and available capacity 
in kilobytes, percentage of disk space available, and any network or volume name associated 
with the drive.    To update disk information after you have inserted or removed a CD or floppy, 
use the Refresh option under the View menu.

System indicates if you are running Windows, Windows for Workgroups, or Windows 95.      It 
also tells what version of DOS is running on the PC.    Windows 95 will appear as Windows 3.95 
and DOS Version 7.0.

BIOS is short for Basic Input/Output System.    The BIOS is low-level software provided by the 
manufacturer of your PC to allow it to work with input-output devices like keyboards, video 
cards, disk drives, and communications ports.    Because not all BIOS software works the same 
way, knowing the type and version of your BIOS can sometimes help AT&T WorldNet customer 
care representatives pinpoint hardware problems and software incompatibilities.





File Versions
The File Versions screen allows you to search for specific files or groups of files.    It is intended 
to make it easy for you to get information about different versions of files you may have on your 
hard drives, and especially to help you notice when you have installed an application more than 
once, or when different applications try to work with different versions of a system library.

For example, users of Internet services sometimes run into problems when they try to run 
different Internet clients, and each of the clients requires a different version of the network 
library known as winsock.dll.    To use File Versions to help you track down this problem, select 
Network Libraries from the Search For list box, select your primary hard drive (usually drive C:)
from the Search Drive combo box, and then click on the Begin Search button.      System 
Reporter will scan your drive looking for all files with names matching one of the patterns in the 
Pattern text box, and will display the results in the list box at the bottom of the screen, including 
file name, size, date, time, version, and path.

The Search For list box lists the names of some predefined search patterns which have been 
useful in tracking down problems.    Clicking one of these will cause the corresponding set of 
patterns to be written into the Pattern edit box.

The Pattern edit box shows the patterns that determine which files will be displayed.      If a file 
name matches any of the patterns, it will show up in the list.    Note that the patterns are used to 
match file names only --you cannot directly use this feature to find files whose contents match 
the patterns.

You can use it to specify your own custom searches by adding to, deleting from, or modifying 
the patterns selected through the Search For list.    You can use standard DOS wildcard characters
as well, so that for instance *.dll will give you a list of all files ending with the letters dll, and 
netscape.*    will give you a list of all files beginning with the letters netscape.

Search Drive is used to select which disk drive you want System Reporter to search.    You may 
search hard disks, network drives, floppies, even CD ROMs, but you can only search one drive at
a time.

Check the Also find hidden files checkbox if you want to search every file on the drive, even 
those that are usually hidden.    Otherwise, leave it unchecked.    Generally you will not be 
interested in hidden files.

Click the Begin Search button when you are ready to search the drive for files matching the 
specified patterns.    If you start a search and then find that it is taking too long, or is returning 
more files than you want to see, you can cancel it by hitting the ESC key on your keyboard.

Once the search is complete, you will see a list of the files that System Reporter has found.    For 
each, it lists name, size, date and time of last modification, version (when available) and path.    
Your AT&T WorldNet customer care representative can frequently use this information to 
determine if you have obsolete or incompatible files on your PC.



Many files, especially configuration files ending in .ini, .inf, .txt, or .sr contain ASCII text and 
can be read with a simple editor like Windows Notepad.    When one of these files is selected in 
the search results list box, the View File button is enabled.    Clicking on the button (or double-
clicking on the file name) will launch Notepad on the corresponding file.    If you use this option, 
be careful not to inadvertently change the contents of the files you are looking at!    If you do 
accidentally make changes, be sure NOT to save them when you exit Notepad.



Modem/Comm
The Modem/Comm screen is designed to help AT&T WorldNet Customer Care representatives 
identify and resolve problems caused by your modem and communications port setup.

The list box in the upper left corner labeled Port:        Device: shows all the serial ports (COM1, 
COM2, etc.) that System Reporter can find on your PC.    For each, it will indicate if it finds a 
modem or serial mouse attached.    When you highlight any of the ports in the list, System 
Reporter will display the corresponding address, interrupt number, and buffer size in the box 
to the right of the list.    If the port you have chosen has a modem attached,    System Reporter 
will enable the Modem Test and Line Test buttons.

If you click on Modem Test, System Reporter will attempt to determine what kind of modem 
you have attached to the port, and also tell you the modem speed and port speed.

If you click on Line Test, System Reporter will try to use your modem to get a dial tone, and 
thus verify that the modem is properly connected to the telephone jack.    You wont want to do a 
line test while someone else is using the phone!

The System and BIOS displays are the same as on the System Profile screen.    They are 
duplicated here for convenience, because some communications problems only show up with 
specific System or BIOS versions.

System indicates if you are running Windows, Windows for Workgroups, or Windows 95.      It 
also tells what version of DOS is running on the PC.    Windows 95 will appear as Windows 3.95 
and DOS Version 7.0.

BIOS is short for Basic Input/Output System.    The BIOS is low-level software provided by the 
manufacturer of your PC to allow it to work with input-output devices like keyboards, video 
cards, disk drives, and communications ports.    Because not all BIOS software works the same 
way, knowing the type and version of your BIOS can sometimes help AT&T WorldNet customer 
care representatives pinpoint hardware problems and software incompatibilities.

On the modem/comm screen, the category Device Drivers refers to software modules that 
manage the serial port hardware.    Some older versions of this software can have problems with 
some brands of modems, so information about version, date, and size can be helpful to the AT&T
WorldNet Customer Care representative.



Running Apps
This screen shows you all the 16-bit modules currently loaded in memory.    It shows both 16-bit
applications with names ending in .exe and 16-bit dynamic link libraries with names ending in
.dll, and gives you detailed information about module versions and usage which can be very 
helpful in identifying conflicts between applications.

When you click on an entry in the list box on the left labeled 16 bit modules in memory,    
detailed information about the corresponding .exe or .dll will be displayed, including the path 
from which it was loaded, as well as size, date, time, version and type.    

If the selected entry is an application, you will see a list of the dynamic libraries it uses in the 
box labeled Uses, and the box labeled Used by will typically be empty.

If the selected entry is a dynamic library, it may make use of other dynamic libraries, which will 
be listed in the Uses box.    It will also be used by one or more applications, and possibly one or 
more dynamic libraries as well.    These will all be listed in the Used by box.

Clicking on an entry in the Uses or Used by box will change the focus of the display to the 
corresponding module.

The column labeled Ref Count in the three list boxes gives an indication of how many times the 
particular module is referenced, either by applications or other modules.

Sometimes Windows knows that a particular library is in use, but cannot identify all the modules 
that have loaded it.    When this occurs, the module information box includes a line labeled 
Explicit Loads, along with a number indicating how many times this module has been loaded in 
this manner.

Notice to users of Windows 95:
The information you see displayed on the Running Apps screen may not be complete.    In 
particular, you will only see 16-bit applications and dynamic link libraries (DLLs) written for 
Windows 3.1 or 3.11.    Any 32-bit applications or dynamic libraries in memory will not show up 
in the listings.



File Menu 

Report Format is used to select which information you want to have included in your reports. 
The selections you make will apply to all reports you make, whether printed or saved to disk.    If
you select the File Versions option, you can also select whether to include all entries in the list 
(which can get quite large!) or just the first 20.    If you select the Running Applications option, 
you can choose to include information about applications, dynamic libraries, or both, and also 
whether or not to include information about module usage. 

The format you select will be saved in a file called wnsysrpt.ini, and will be in effect until you 
change it again.

Save is used to save a report about the System Reporter information to disk.    Every time System
Reporter is started and then Save is selected, you will be asked to provide the file name and 
directory where you wish the report to be saved.    After that, each time you select Save again, it 
will copy the current system information to that file, erasing whatever had previously been saved
there.

Save As is used when you wish to save the report to a filename or directory different from what 
you had most recently used.

Print is used to direct the report to a printer attached to your system.

Print Preview is used to see what the printed output will look like without actually sending it to 
the printer.    This will allow you to make sure you have selected the appropriate report formating
options.

Print Setup is used to set up or reconfigure your printer.

Exit is used when you want to terminate the System Reporter application.



View Menu
Refresh will re-scan your computer and provide updated information displayed on your current 
screen.    Note that Running Apps information and memory and resource data is continuously 
updated,    whether or not Refresh is invoked.

The other four items on the View Menu duplicate the functionality of the four screen selection 
buttons at the top of the main screen.

Selecting System Profile from the View menu will bring you to the System Profile screen.

Selecting File Versions from the View menu will bring you to the File Versions screen.

Selecting Modem/Comm from the View menu will bring you to the Modem/Comm screen.

Selecting Running Apps from the View menu will bring you to the Running Apps screen.




