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Basic Game Play

HANGWIN is the traditional hangman word game in a Windows 3.1 package.    Guess the letters in a word 
puzzle before the man gets hung.    The computer will randomly extract a word puzzle from a dictionary 
and display the word by showing one asterisk (*) for each letter of the word.    Any non-alpha characters 
will be immediately revealed.    The user then makes guesses about individual letters in the word puzzle 
by selecting letters at the bottom of the window.    If the player guesses correctly, HANGWIN will reveal the 
position(s) of the correctly guessed letter.    If incorrect, a new body part will be added to the hanging man.
In the standard game, six (6) incorrect guesses consecutively add the man's head, body, arms (2) and 
finally the legs.    In the easy game, the man's hands and feet are also drawn, giving the player a total of 
ten (10) guesses.

After the word puzzle is guessed or the number of allowed misses is exhausted, a score is computed and 
displayed at the top of the screen and a new word puzzle is randomly selected from the dictionary.



Advanced Game Features

Initialization
HANGWIN can be launched in any of the ways windows applications can be started.    Once started, 
HANGWIN will search for the HANGWIN.INI initialization file.    If not found in the current directory, HANGWIN 
will search the path environment for HANGWIN.INI.    To keep everything together and easy to uninstall, 
HANGWIN.INI should be in the same directory as the HANGWIN program.    If HANGWIN cannot find the 
initialization file, the HANGWIN window will be displayed informing the user it could not be found.

Game Statistics
The score at the top of the window includes three items:    the average numbers of guesses per puzzle, 
the number of puzzles played in the current game, and finally the percentage of correctly guessed word 
puzzles.

Keyboard or Pointing Device?
In addition to being able to play HANGWIN with a pointing device or the tab, arrow and <enter> keys, the 
user can also guess letters using the keyboard.    In fact reasonably adept keyboard users will prefer this 
method as the interim message boxes between each word can be quickly dismissed with the <enter> key.

User Defined Dictionaries
As long as the specified format is strictly followed, HANGWIN can use any user-supplied dictionary.    This 
makes HANGWIN a useful tool for anyone, including students, for spelling practice or other memorization 
drills.    (See Dictionary)



Menu Command File>New Dictionary

This menu item will invoke a pop-up window which will prompt the player for a new dictionary.    It is 
expected (but not required) that the dictionary will end in an ".DIC" filename extension.    The file structure 
may be navigated through the usual methods until the desired dictionary is high-lighted.    Selecting the 
"OK" push button will cause HangWin to read the entire dictionary.    A minimal check is performed to 
ensure the dictionary has the proper format.    If satisfactory, a new game will be started, and HANGWIN.INI
will be updated with the newly selected dictionary.



Menu Command File>Statistics

A pop-up window is displayed showing dictionary statistics:    total number of characters, total number of 
word puzzles and the number of characters in the longest puzzle.



Menu Command Game>Sound

Upon start-up, HANGWIN looks for a sound device capable of playing ".WAV" files, if one is found this menu
item will be enabled.    Selection of this menu item will display a pop-up window to configure the sound 
capabilities of HANGWIN.

A box shows the two HangWin events which can be assigned to a sound along with a file selection box.    
To assign a new sound to either of the events, select the event and then navigate to the ".WAV" file and 
select it.    The sound can be tested with the test button or by double-clicking the event or ".WAV" file.

Selecting "OK" will redefine the event sound(s) which have been assigned.    If the initialization file, 
HANGWIN.INI, was found when starting up, the file will be updated with the latest sound settings.    
Selecting "Cancel" will return the sound configuration to the state before the pop-up was displayed.

Sound may be disabled or enabled with the check box, or alternatively, an event sound may be disabled 
by assigning it to the "<none>" item in the file box.



Menu Command Game>Prisoner

This menu command allows you to choose the prisoner from a list.    First, highlight the desired prisoner, 
then select OK.    You may also select the prisoner by double clicking on your choice.    The prisoner can 
be selected or changed at any time.    The prisoner choice will be saved in the HANGWIN.INI file (see also 
H  ANG  W  IN  .I  NI   file format).



Menu Command File>Exit

This terminates the HANGWIN program.



Menu Command Game>Restart

This menu command reinitializes the game statistics and selects a new word puzzle from the current 
dictionary.



Menu Command Game>Standard or Game>Easy

Standard
Allows six (6) guesses per word.

Easy
Allows ten (10) guesses per word.

In either case if the game toggles from the other form, the game will be restarted.



Menu Command Help>Contents

Displays this help file Table of Contents.



Menu Command Help>Search for help on ...

This shows    the HANGWIN help file with the keyword search dialog box enabled, allowing the user to 
search for a particular topic.



Menu Command Help>What is Shareware?

DEFINITION OF SHAREWARE

Shareware distribution gives users a chance to try software before buying it. If you try a Shareware 
program and continue using it, you are expected to register. Individual programs differ on details -- some 
request registration while others require it, some specify a maximum trial period. With registration, you get
anything from the simple right to continue using the software to an updated program with printed manual.

Copyright laws apply to both Shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is in the method of distribution. The author 
specifically grants the right to copy and distribute the software, either to all and sundry or to a specific 
group. For example, some authors require written permission before a commercial disk vendor may copy 
their Shareware.

Shareware is a distribution method, not a type of software. You should find software that suits your needs 
and pocketbook, whether it's commercial or Shareware. The Shareware system makes fitting your needs 
easier, because you can try before you buy. And because the overhead is low, prices are low also. 
Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't pay for it.

Temprano Software is a member of the Association of Shareware Professionals (ASP).    ASP wants to 
make sure that the shareware principle works for you. If you are unable to resolve a shareware-related 
problem with an ASP member by contacting the member directly, ASP may be able to help. The ASP 
Ombudsman can help you resolve a dispute or problem with an ASP member, but does not provide 
technical support for members' products.    Please write to the ASP Ombudsman at 545 Grover Road, 
Muskegon, MI 49442-9427 USA, FAX 616-788-2765 or send a CompuServe message via CompuServe 
Mail to ASP Ombudsman 70007,3536.



Menu Command Help>License Agreement

DISCLAIMER and AGREEMENT

Users of HANGWIN must accept this disclaimer of warranty:    "HANGWIN is supplied as is.    The author 
disclaims all warranties, expressed or implied, including, without limitation, the warranties of 
merchantability and of fitness for any purpose.    The author assumes no liability for damages, direct or 
consequential, which may result from the use of HANGWIN."

HANGWIN is a "shareware program" and is provided at no charge to the user for evaluation.    Feel free to 
share it with your friends, but please do not give it away altered or as part of another system.    The 
essence of "user-supported" software is to provide personal computer users with quality software without 
high prices, and yet to provide incentive for programmers to continue to develop new products.    If you 
find this program useful and find that you are using HANGWIN and continue to use HANGWIN after a 
reasonable trial period, you must make a registration payment of $11.95 (plus $3.00 for shipping and 
handling) to Temprano Software.    The $11.95 registration fee will license one copy for use on any one 
computer at any one time.    You must treat this software just like a book.    An example is that this 
software may be used by any number of people and may be freely moved from one computer location to 
another, so long as there is no possibility of it being used at one location while it's being used at another.   
Just as a book cannot be read by two different persons at the same time.

Commercial users of HANGWIN must register and pay for their copies of HANGWIN within 30 days of first 
use or their license is withdrawn.    Academic instutions will receive a campus-wide site license at no 
addtional cost by sending their order on instution letter-head.    Site-license arrangements for other users 
may be made by contacting Temprano Software.

Anyone distributing HANGWIN for any kind of remuneration must first contact Temprano Software at the 
address below for authorization. This authorization will be automatically granted to distributors recognized
by the (ASP) as adhering to its guidelines for shareware distributors, and such distributors may begin 
offering HANGWIN immediately (However Temprano Software must still be advised so that the distributor 
can be kept up-to-date with the latest version of HANGWIN.).

You are encouraged to pass a copy of HANGWIN along to your friends for evaluation.    Please encourage 
them to register their copy if they find that they can use it.    All registered users will receive a copy of the 
latest version of the HANGWIN system.    (See the registration form.)



Menu Command Help>How to Use Help

This menu command displays a help file explaining the use and functionality of the Windows help system.



Menu Command Help>About HANGWIN

Displays HANGWIN version and registration information.    This window contains personalized information if
this is a registered copy of HANGWIN.    If personalized information is present and incorrect, you may be in 
possession of an illegal copy of HANGWIN;    please contact Temprano Software for information on how to 
obtain a legal copy.



File Formats:HANGWIN.INI

HANGWIN has an initialization file, HANGWIN.INI.    This file is usually located in the working (start up) 
directory.    Only in rare circumstances does the HANGWIN.INI file ever need to be edited directly.    Usually, 
HangWin will update it when the player selects a new dictionary or new sound settings.

If the initialization file becomes lost, you may create a new one with a simple text editor like notepad.exe. 
Alternatively, you can reinstall HANGWIN from your source floppy.    The installation program will create a 
new initialization file.

There are only three sections in HANGWIN.INI.    First the [files] section contains the full path name of 
the most recently used dictionary, listed after the dictionary= keyword.
Second, in the [style] section the difficulty= keyword is defined as either easy, for the 10 
guesses per word game, or standard for 6 guesses per word. the prisoner= keyword holds the name 
of the current prisoner.
Finally the [sounds] section has three entries: sound_enable= is assigned an integer ( 0 for disable, 1
for enable ), and the two sound events, Guessed Word and Missed Word are assigned by the 
guessed_word= and missed_word= keywords.



File Format:Dictionary

HANGWIN can use any dictionary.    However, the dictionary must be in a format described below.

The dictionary format is simple.    Printable ASCII characters only, with <enter> characters delimiting word 
puzzles.    (Technically, DOS expands an <enter> as a <linefeed> <carriage return>.)    Each word puzzle 
in a dictionary must contain at least one alpha character (a through z, or, A through Z).    Under no 
circumstances should the dictionary contain any control characters.    The word puzzles need not be 
alphabetized as the they will be chosen randomly.

If a word processor, is used to generate the dictionary, be sure to save the file as an text (.txt) file; normal 
word processing files contain many special control characters HANGWIN will not like.

There is no upper limit for the length of a word puzzle.    The maximum length is variable as the font used 
to display the puzzle is variable-width.    However, individual word puzzles should be less than about 50-
60 characters.

NOTE:    Be aware that there may already be files on your system which have a "DIC" extension and they 
may have a format which is not compatible with HANGWIN.    You can simply try to read them with the New
Dictionary menu command.    If there is a problem with the dictionary, HANGWIN will let you know.



Deleting HANGWIN from you disk

Should you want to delete HANGWIN from your disk, first remove references to HANGWIN from your 
program manager by high-lighting the HANGWIN icon and selecting File>Delete from the program 
manager menu.    Finally, delete the entire contents of the HANGWIN directory.    Except for the entry in the 
program manager, HANGWIN modifies no files outside of its own directory.



Temprano Software's HANGWIN Registration Form

HANGWIN is shareware, please register.    By registering, you will receive the latest version which will not 
remind you to register.    You will also receive several dictionaries.    The normal dictionary contains over 
17,000 words.    A science dictionary includes all the normal dictionary's words, plus over 2000 high-tech 
words!    There is a dictionary of proper names (WARNING: the proper names dictionary is really tough!).   
Also included is a dictionary of TV show titles and another dictionary of over 20,000 movie titles.

You can print this help topic as an order form and send it to the address below.    Include a check for 
$11.95 for each registered copy you would like plus $3.00 for shipping and handling.    (If you are outside 
North America, shipping and handling charges are $5.00.)

Name__________________________________________________________

Address__________________________________________________________

City__________________________________________________________

State__________________________________________________________

Zip Code_____________________________

Number of copies of HANGWIN _________ x $11.95 =_________

Shipping and handling (see above)_________

Total_________

Disk size:    ______ 5.25 "    _____ 3.5 "

Where did you get your copy of HANGWIN? _______________________________

Send to:

Thomas A. Early
Temprano Software
32 Leonardo Drive
Clifton Park, NY 12065-2038

Don't send cash through the mail.    Sorry, no credit cards are accepted.    Please send a check drawn on 
a United States bank, or an International or Postal money order only.



Error: HANGWIN could not open the Dictionary specified in HANGWIN.INI.    The file has probably been 
erased or moved.    You may simply open a valid dictionary with the File>New Dictionary menu command. 
Once a valid dictionary has been opened, HANGWIN.INI will be updated.



Error: HANGWIN could not find its initialization file, HANGWIN.INI.    HANGWIN searches the startup directory,
then all the directories in the DOS "PATH" environment.    Check to make sure the Files>Properties 
program manager has specified the right working directory.    You may go ahead and play without 
initialization by specifying a dictionary with the File>New Dictionary and optional sound settings with the 
File>Sound menu commands.    However the selections will not be remembered for the next playing until 
an initialization file has been created.

To create a new initialization file in the HANGWIN working directory, see File Formats:H  ANG  W  IN  .I  NI  .




