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Creating Computer Opponents

You may use the Player Properties dialog box to mark any player as a computer opponent, 
and to select its artificial intelligence (A.I.) type.    There are four different A.I. types 
available.

The passive A.I. does not build any buildings or units.    Generally you will use this A.I. type if 
you are pre-placing a large force.    For example, passive A.I. is ideal for an "assault the 
castle" type of level.

There are three flavors of active A.I.'s: land attack, sea attack, and air attack.    These A.I.'s 
are all capable of building their own towns, training units, and launching attacks on the 
human player.    They differ in their attack strategy.

Since the active A.I.'s build their own towns, it is not necessary to start them out with a large
material advantage.    They will build up as quickly as a good player can, and provide an 
intense challenge.    If you do start the computer with more units than the player, remember 
that a small difference in starting conditions can make a big difference over time.

If you do start the computer with pre-placed units, make sure that you also place enough 
farms to support those units.    Otherwise, the computer will be slowed down while it 
produces enough farms to feed all of its people.

In order to ensure that the computer builds properly, you should make sure that it has 
access to as many resources (gold, lumber, and oil) as it will need.    This is especially true 
when using the air and sea A.I.'s, which build very expensive units (dragons and 
battleships).    If you don't provide the computer with access to enough resources, it will 
eventually run out and be unable to train new units.



Controlling Difficulty

If you find that the computer A.I.'s are too difficult, you can slow them down by pre-placing 
the computer's town hall in a spot that is relatively far away from its gold mine.    The 
computer has to pay for all of his buildings and units just like a human player, so the longer 
it takes him to get gold, the longer it will take him to produce attack units.

Conversely, if you are able to consistently beat the computer A.I., you can make it more 
challenging by giving the computer additional starting peasants, or by adding resources in 
the Starting Conditions dialog box.    For the ultimate challenge, try placing two different 
computer opponents, each using different A.I.'s, on the same map.



Map Layout

The computer A.I. must adapt itself to each new map that you build, developing attack 
routes, staging points, and so on.    Because of this, it is important that you design your 
terrain with the computer in mind.

The best way to aid the computer is to develop relatively straightforward paths that it can 
take when assaulting the human player's town.    Don't place obstacles that the computer 
will have to walk around.    Make sure that any passageway the computer will take, whether 
on land or sea, is nice and wide. Also, avoid using crescent-shaped forests, islands, and rock 
formations, as these can confuse the computer.

In addition to giving the computer a clear path to the human player, you should make sure 
to give it a clear path from its town hall to the resources it will harvest: nearby gold mines 
and forests.

If you place buildings for computer players, make them relatively spread out.    Avoid 
grouping buildings in tight clusters.    When the computer builds new structures, it will try to 
keep them spread out as well.    Make sure to leave plenty of empty space around the 
computers starting location for it to place new buildings.



Map Editor Tips

When building levels, you will often find yourself laying down large areas of forests and 
oceans.    To make this job easier, use the various brush sizes on the toolbar.    Use the largest
brush to quickly build a big forest, and then use one of the smaller brushes to touch up the 
edge.

Another useful tool is group selecting.    To group select a number of units, click on the 
ground and then drag a rectangle around the units you want to select.    Once you have 
group selected a number of units, you can right click to edit the properties of all units 
simultaneously, or you can type a number (1-8) to switch all units to that player number.



Creating a New Scenario File

To create a new scenario file

1. From the File menu, choose New.

The New Scenario dialog box appears.

2. Select a map size.

3. Select a terrain type.

4. Choose the OK button.



Working with the Minimap

The minimap is a small window that shows a scaled down view of the entire map and allows 
you to scroll around the map in the main window.    On the minimap are small colored dots, 
each represents a unit in its own color.    Black dots indicate oil patches and bright yellow 
dots indicate gold mines, critters, Circles of Power, Dark Portals, or Runestones.    Also, on 
the minimap is a white view rectangle that indicates the part of the map you are currently 
viewing on the main window.

To scroll around in the main window using the minimap

1. Move the cursor to the place in the minimap that you want to view in the main window.

2. Click on the minimap or drag to continually scroll around.

3. Release the mouse button.

To show or hide the minimap

1. From the View menu, choose Minimap.



Animating the Colors in the Map

The Warcraft II Editor supports color animation only in 256 color video mode.    This feature 
only helps to display what the current map will look like in the game.

To animate the colors in the map

1. From the View menu, choose Animate.

A check mark next to the command means it is in effect.



Working with the Map Brush Tools

The Map Brush Tools are used to edit the terrain of your map by replacing the tiles, that 
make up a map, with different tiles.    The tools helps you by adjusting the surrounding tiles 
so that all tiles blend with each other.    When using one of these tools, the cursor will be 
followed by a white rectangle which indicates the tile that you are about to change.

All the possible tiles that are available to you are divided into sets of different types such as 
water, dirt, grass, tree, rock, etc.    These sets make up the different Map Brush Tools.    

Some of these sets can be divided further into two sets of different brightness levels.    One 
set contains lighter colored tiles and the other darker colored tiles.

Some of these sets can be divided further into two sets of different kinds. One contains plain
tiles, and the other filler tiles which are used for decorating the map.

Every time you change a tile on the map, the Map Brush Tool picks a tile from one of the sets
of tiles.    Map Brush Tools have commands available to control which set of tiles that the tool
uses and how it picks tiles from that set of tiles, and which brush size to use.    These 
commands are provided for those that like to be more creative in their map designs.

The Light Command makes the Map Brush Tool pick from a set of lighter colored tiles.    The 
Dark Command makes the tool pick from a set of darker colored tiles.

The Plain, Filler, and Random Commands controls how the Map Brush Tool picks a tile, and 
from which set to pick. The Plain Command causes the Map Brush Tool to randomly pick from
the set of plain tiles.    The Filler Command causes the tool to pick from the set of filler tiles.    
When you change the same tile as the last, the tool will cycle through the set.    When you 
change a different tile on the map, the last tile picked is picked again.    The Random 
Command causes the Map Brush Tool to randomly pick from both the set of plain tiles and 
filler tiles.

The 1 x 1 Command, 3 x 3 Command, and 5 x 5 Command controls the brush size of the 
Map Brush Tool.

Note: Grayed out commands indicate they are not available for the selected Map Brush Tool.



Working with the Unit Tools

All of the Unit Tools are below the Map Brush menu in the Tools menu.    When you choose 
one of the Unit Tools, the cursor will move a rectangle that matches the size of the selected 
unit.    A white rectangle indicates that the current unit is allowed to be placed in the current 
location.    A red rectangle indicates that the current unit is not allowed to be placed in the 
current location.

To place a unit on the map

1. From the Tools menu, choose one of the available Unit Tools.

2. Place the rectangle in a valid location.    This is indicated when the rectangle is white.

3. Click on the map.



Working with the Human and Orc Unit Tools

All menu commands prefixed with Human select one of the Human Unit Tools and all menu 
commands prefixed with Orc select one of the Orc Unit Tools.    At any one time, either the 
Human Unit Tools or the Orc Unit Tools are enabled.    This depends on which player is 
selected in the Player menu and the race of the player.    The race of the player can be seen 
the Player Properties dialog box.    The tools are divided into submenus to make finding a unit
tool easier.    There is a submenu for the air units, land units, water units, and building units.

The following is a table of the different type of units and where they can be placed.

Unit Type Can be placed on...
Start Location Anywhere except over water, tree, rock, wall, tiles adjacent to 

water, and other air units.

Air Anywhere except over other air units.

Land Anywhere except over water, trees, rocks, walls, tiles adjacent to
water, and other land and building units.

Water Water except over other water units, oil platforms, and oil 
patches.

Buildings Grass, snow, dry mud except over other land and building units.

The following is a table of exceptions:

Unit Must be placed...
Town Hall, Keep, 
Castle, Great Hall, 
Stronghold, Fortress

At least 3 tiles away from a gold mine.

Shipyard, Refinery Partially on water and on land and must be at least 4 tiles away 
from an oil patch or oil platform.

Foundry Partially on water and on land.

Oil Platform Water, or over an oil patch, except over other water units.    At 
least 4 tiles away from Shipyard or Refinery.



Working with Miscellaneous Unit Tools

All the Miscellaneous Unit Tools are below the Human and Orc Unit Tools and above the NPC 
Unit Tools.

The following is a table of the different miscellaneous units and where they can be placed.

Unit Can be placed on...
Gold Mine Grass, snow, dry mud, except over other land and building units,

and must be at least 3 tiles away from a Town Hall, Keep, Castle, 
Great Hall, Stronghold, and Fortress.

Oil Patch Water except over other water units and must be at least 4 tiles 
away from a Shipyard or Refinery.

Critter Anywhere except over water, tree, rock, wall, tiles adjacent to 
water, and other land and building units.

Circle of Power, 
Dark Portal, 
Runestone

Grass, snow, dry mud except over other land and building units.

See also:

Working with Human and Orc Unit Tools



Working with NPC Unit Tools

The NPC (Non-Player Character) Unit Tools let you place units that are special legendary 
characters and creatures in the world of Warcraft.    These units have special statistics, 
abilities and powers that set them apart from normal units.

The following is a table of the different NPC units and where they can be placed.

Unit Can be placed on...
Skeleton, Zuljin, 
Chogall, Guldan, 
Uther Lightbringer, 
Lothar

Anywhere except over water, tree, rock, wall, tiles adjacent to 
water, and other land and building units.

Daemon Anywhere except over other air units.

Selecting Units on the Map

You can use the mouse to select a unit or group of units.    Before you can select units, they 
must be visible in the window.

To select a unit

Click the unit that you want to select. 

To select two or more units

Hold down the SHIFT key and click each unit that you want to select. 

To select a group of units next to each other

Press the left mouse button and drag a rectangle around the units that you want to 
select. 

To deselect a one or more units

Hold down the SHIFT key and click each unit that you want to deselect.

To cancel a selection

From the Tools menu, choose Select.



Changing the Amount of Gold in Gold Mines

You can use the mouse to change the amount of gold in a gold mine or group of gold mines.  
Changing the amount of gold in one gold mine that is within a selected group of gold mines 
changes the amount of gold in each gold mine in the entire group.

To change the amount of gold in a gold mine

1. Click on a gold mine with the right mouse button.
The Gold Mine Properties dialog box appears.

2. Use the scroll bar to increase or decrease the amount of gold.

3. Choose the OK button.

To change the amount of gold in a group of gold mines

1. Select a group of gold mines.

2. Click on a selected gold mine with the right mouse button.
The Gold Mine Properties dialog box appears.

3. Use the scroll bar to increase or decrease the amount of gold.

4. Choose the OK button.



Gold Mine Properties Dialog Box

The following options allow you to specify the amount of gold in the selection of a gold mine 
or a group of gold mines.

Gold Amount
This indicates the current amount of gold.

Scrollbar
Use the scrollbar to increase or decrease the amount of gold.



Changing the Amount of Oil in Oil Patches and Oil Platforms

You can use the mouse to change the amount of oil in an oil unit or group of oil units, which 
are oil patches and oil platforms.    Changing the amount of oil in one oil unit in a selection of
units, changes the amount of oil in all oil units in the selection.

To change the amount of oil in an oil unit

1. Click on a oil unit with the right mouse button.
The Oil Properties dialog box appears.

2. Use the scroll bar to increase or decrease the amount of oil.

3. Choose the OK button.

To change the amount of oil in a group of oil units

1. Select a group of oil units.

2. Click on a selected oil unit with the right mouse button.
The Oil Properties dialog box appears.

3. Use the scroll bar to increase or decrease the amount of oil.

4. Choose the OK button.



Oil Properties Dialog Box

The following options allow you to specify the amount of oil in the selected oil patches and 
oil platforms.

Oil Amount
This indicates the current amount of oil.

Scrollbar
Use the scrollbar to increase or decrease the amount of oil.



Changing the A.I. of Units

You can use the mouse to change the A.I. of a unit or group of units.    Changing the A.I. of 
one unit in a selection of units, changes the A.I. of all units in the selection.

To change the A.I. of a unit

1. Click on a unit with the right mouse button.
The Artificial Intelligence Properties dialog box appears.

2. Select either Active or Passive button.

3. Choose the OK button.

To change the A.I. of a group of units

1. Select a group of units.

2. Click on a selected unit with the right mouse button.
The Artificial Intelligence Properties dialog box appears.

3. Select either Active or Passive button.

4. Choose the OK button.



Artificial Intelligence Properties Dialog Box

The following option allows you to specify which artificial intelligence to use for the selected 
units.    Units set to active artificial intelligence will actively find something to do.    Units set 
to passive artificial intelligence will stay in place and respond to any events that affect them 
directly.

Artificial Intelligence
Select either the Active or Passive button.



Assigning a Unit to a Player

To assign a unit or group of units to a player

1. Select a unit or group of units.

2. From the Player menu, choose the player to which you want to assign.
Or, type the number that corresponds to the player number to which you want to assign.



Changing the Terrain Type

To change the terrain type of the map

1. From the Player menu, choose Map Properties.
The Map Properties dialog box appears.

2. Select either the Forest, Winter, or Wasteland button

3. Choose the OK button.



Changing the Map Description

To change the map description

1. From the Player menu, choose Map Properties.
The Map Properties dialog box appears.

2. Type in the map description in the text box.

3. Choose the OK button.



Changing the Race of a Player

To change the race of a player

1. From the Player menu, choose Player Properties.
The Player Properties dialog box appears.

2. Select either the Human or Orc buttons for each player that you want to change.

3. Choose the OK button.



Changing the Controller of a Player

To change the controller of a player

1. From the Player menu, choose Player Properties.
The Player Properties dialog box appears.

2. Select a controller for each player you want to change.

3. Choose the OK button.



Changing the A.I. of a Player

To change the A.I. of a player

1. From the Player menu, choose Player Properties.
The Player Properties dialog box appears.

2. Select an A.I. Player for each player you want to change.

3. Choose the OK button.



Editing the Starting Resources of all Players

To change the Starting Resources of all players

1. From the Player menu, choose Starting Resources.
The Starting Conditions dialog box appears.

2. Type in the amount of gold, lumber, and oil for each player.

3. Choose the OK button.

To copy the Starting Resources of player 1 to all the other players

In the Starting Resources dialog box, click the Duplicate button.



Editing the Properties of all Units Types

To edit the properties of all unit types

1. From the Player menu, choose Unit Properties.
The Unit Properties dialog box appears.

2. Use the scroll bar on the bottom to find the unit you want to change.

3. Edit the number in the text boxes for each unit that you want to change.

4. Choose the OK button.

To restore the properties of all unit types

In the Unit Properties dialog box, click the Default button.



Editing Upgrade Properties

To edit the upgrade properties

1. From the Player menu, choose Upgrade Properties.
The Upgrade Properties dialog box appears.

2. Use the scroll bar on the bottom to find the upgrade you want to change.

3. Edit the number in the text boxes for each upgrade that you want to change.

4. Choose the OK button.

To restore the upgrade properties

In the Upgrade Properties dialog box, click the Default button.



Working with the Sound Editor

The Sound Editor allows you to do several things with the sounds that are used in the game. 
You can listen to the sounds, extract and save the sounds into Windows sound files, replace 
the sounds with your own sounds, and restore the sounds to their original sounds.    

To bring up the Sound Effects Editor

From the File menu, choose Sound Editor.

To select a sound

1. Choose either the Human Sounds or Orc Sounds button.

2. Select a category from the Category menu.

3. Select a sound from the Sound List that you want to select.

To turn on or off a sound

1. Select the sound you want to turn on or off.

2. Click on the check box next to the sound that you want to turn on or off.

To extract a sound into a Windows sound file

1. Select the sound that you want to extract.

2. Choose the Extract button.
The Save As dialog box appears.

3. Save the sound file.

To replace a sound with your own sound

1. Select the sound that you want to replace.

2. Choose the Replace button.
The Replace With dialog box appears.

3. Select a Windows sound file.

4. Choose the OK button.

To restore a sound to its original sound

1. Select the sound that you want to restore

2. Choose the Restore button.
A confirmation dialog box appears.

3. If you are sure, choose the Yes button.

To restore all sounds to their original sounds



1. Choose the Restore All button.
A confirmation dialog box appears.

2. If you are sure, choose the Yes button.



File Menu Commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Sound 
Editor...

Opens the Sound Editor.

Recent Files Opens the specified document.
Exit Exits Warcraft II Editor.

Edit Menu Commands

The Edit menu offers the following commands:

Delet
e

Deletes units from the document.

View Menu Commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Animate Starts or stops color animation in map.
Minimap Shows or hides the minimap.

Tools Menu Commands

The Tools menu offers the following commands:

Select Selects the Select Tool.
Map Brush Shows the Map Brush menu.
Human Selects a Human Unit Tool.
Orc Selects a Orc Unit Tool.
Gold Mine Selects the Gold Mine Tool.
Oil Patch Selects the Oil Patch Tool.
Critter Selects the Critter Tool.
Circle of Power Selects the Circle of Power Tool.
Dark Portal Selects the Dark Portal Tool.
Runestone Selects the Runestone Tool.
NPCs Shows the NPCs menu.

Map Brush Menu Commands

The Map Brush menu offers the following commands:

Light Sets the brightness of the current Map Brush Tool to a lighter 
color.

Dark Sets the brightness of the current Map Brush Tool to a darker 
color.

Plain Sets the Map Brush Mode to use plain tiles.



Filler Sets the Map Brush Mode to use filler tiles.
Random Sets the Map Brush Mode to randomly use plain and filler 

tiles.
1 x 1 Sets the Map Brush Size to 1 x 1.
3 x 3 Sets the Map Brush Size to 3 x 3.
5 x 5 Sets the Map Brush Size to 5 x 5.
Water Selects the Water Tool.
Dirt/Ice/Mud Selects the Dirt/Ice/Mud Tool depending on the currently 

selected terrain type.
Grass/Snow/Dry 
Mud

Selects the Grass/Snow/Dry Mud Tool depending on the 
currently selected terrain type.

Tree Selects the Tree Tool.
Rock Selects the Rock Tool.
Human Wall Selects the Human Wall Tool.
Orc Wall Selects the Orc Wall Tool.

Player Menu Commands

The Player menu offers the following commands:

Player 1, 2, 3, ... Selects the player that is assigned to new units when they are
drawn, or assigns a player to selected units.

Map Properties... Shows the Map Properties dialog box.
Player Properties... Shows the Player Properties dialog box.
Starting 
Conditions...

Shows the Starting Conditions dialog box.

Unit Properties... Shows the Unit Properties dialog box.
Upgrade 
Properties...

Shows the Upgrade Properties dialog box.

Help Menu Commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using Help Provides general instructions on using help.
About Warcraft II 
Editor

Displays the version number of this application.

New Command (File menu)

Use this command to create a new document in Warcraft II Editor.    Select the map size and 
terrain type of the new file you want to create in the New Scenario dialog box.

You can open an existing document with the Open Command.

Shortcuts
Toolbar:

Keys: CTRL+N

New Scenario Dialog Box



The following options allow you to specify the new scenario.

Map Size
Indicate the size of the map that you want.

Terrain Type
Indicate the terrain type that you want.



Open Command (File menu)

Use this command to open an existing document.

You can create new documents with the New Command.

Shortcuts
Toolbar:

Keys: CTRL+O

File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
Scenario File (*.pud)
All Files (*.*)

Drives
Select the drive in which Warcraft II Editor stores the file that you want to open. 

Directories
Select the directory in which Warcraft II Editor stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save Command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, Warcraft II Editor displays the Save As dialog box so 
you can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As Command.

Shortcuts
Toolbar:

Keys: CTRL+S



Save As Command (File menu)

Use this command to save and name the active document.    Warcraft II Editor displays the 
Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save Command.

File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:

File Name
Type a new filename to save a document with a different name. Warcraft II Editor adds 
the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Sound Editor Command (File menu)

Use this command to bring up the Warcraft II Sound Editor where you can extract, replace, 
restore, or turn on or off the sounds that are used in the game.

Sound Effects Editor Dialog Box

The following options allow you to listen to, extract, replace, restore, or turn on or off sounds
that are used in the game.

Human Sounds
Choose this button to work with human sounds.

Orc Sounds
Choose this button to work with orc sounds.

Category
Select the unit or category that you want edit.

Sound List
Select the item you want to replace, restore, or turn on or off.    Click the check box to 
turn on or off the sound.    Double click the item to hear the current sound.

Play
Choose this button to play the selected item.

Extract
Choose this button to save the selected sound into a Windows sound (*.wav) file.

Replace
Choose this button to replace the selected sound with your own sound.    You must 
specify a Windows sound (*.wav) file.

Restore
Choose this button to restore the selected sound to its original sound.

Restore All
Choose this button to restore all sounds to their original sounds.



1, 2, 3, 4, ... Command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last ten 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit Command (File menu)

Use this command to end your Warcraft II Editor session.    You can also use the Close 
Command on the application Control menu.    Warcraft II Editor prompts you to save 
documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Delete Command (Edit menu)

Use this command to delete selected units.

Shortcuts
Keys: DEL



Toolbar Command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in Warcraft II Editor, such as File Open.    A check mark appears 
next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Status Bar Command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Animate Command (View menu)

Use this command to start or stop color animation in the map.    A check mark appears next 
to the menu item when color animation is on.



Minimap Command (View menu)

Use this command to display and hide the Minimap.    A check mark appears next to the 
menu item when the Minimap is displayed.



Status Bar

The status bar is displayed at the bottom of the Warcraft II Editor window.    To display or hide
the status bar, use the Status Bar Command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.    This area also shows the name of 
last selected unit and its properties. This area also show the players that units belong to 
when more than one unit is selected.

The right area of the status bar indicate the coordinates of your cursor in the map.



Select Command (Tools menu)

Use this command to use the Select Tool.    A check mark appears next to the menu item 
when the Select Tool is selected.

Shortcuts
Toolbar:



Light Command (Map Brush menu)

Use this command to change the brightness of the brush to a lighter color.    A check mark 
appears next to the menu item when the brush brightness is light.

Shortcuts
Toolbar:



Dark Command (Map Brush menu)

Use this command to change the brightness of the brush to a darker color.    A check mark 
appears next to the menu item when the brush brightness is dark.

Shortcuts
Toolbar:



Plain Command (Map Brush menu)

Use this command to change the brush mode to use plain tiles.    A check mark appears next 
to the menu item when this brush mode is selected.

Shortcuts
Toolbar:



Filler Command (Map Brush menu)

Use this command to change the brush mode to use filler tiles.    A check mark appears next 
to the menu item when this brush mode is selected.

Shortcuts
Toolbar:



Random Command (Map Brush menu)

Use this command to change the brush mode to randomly use plain & filler tiles.    A check 
mark appears next to the menu item when this brush mode is selected.

Shortcuts
Toolbar:



1 x 1 Command (Map Brush menu)

Use this command to change the brush size to normal.    A 1 x 1 brush size affects a 1 x 1 
area on the map.    A check mark appears next to the menu item when this brush size is 
selected.

Shortcuts
Toolbar:



3 x 3 Command (Map Brush menu)

Use this command to change the brush size to large.    A 3 x 3 brush size affects a 3 x 3 area 
on the map.    A check mark appears next to the menu item when this brush size is selected.

Shortcuts
Toolbar:



5 x 5 Command (Map Brush menu)

Use this command to change the brush size to extra large.    An 5 x 5 brush size affects a 5 x 
5 area on the map.    A check mark appears next to the menu item when this brush size is 
selected.

Shortcuts
Toolbar:



Water Command (Map Brush menu)

Use this command to select the Water Tool.    A check mark appears next to the menu item 
when this tool is selected.

Shortcuts
Toolbar:



Dirt/Ice/Mud Command (Map Brush menu)

Use this command to select the Dirt/Ice/Mud Tool.    The name of this tool will change to 
either dirt, ice, or mud depending on the terrain type of the map.    A check mark appears 
next to the menu item when this tool is selected.

Shortcuts
Toolbar:  
 



Grass/Snow/Dry Mud Command (Map Brush menu)

Use this command to select the Grass/Snow/Dry Mud Tool.    The name of this tool will change
to either grass, snow, or dry mud depending on the terrain type of the map.    A check mark 
appears next to the menu item when this tool is selected.

Shortcuts
Toolbar:  
 



Tree Command (Map Brush menu)

Use this command to select the Tree Tool.    A check mark appears next to the menu item 
when this tool is selected.

Shortcuts
Toolbar:  
 



Rock Command (Map Brush menu)

Use this command to select the Rock Tool.    A check mark appears next to the menu item 
when this tool is selected.

Shortcuts
Toolbar:  
 



Human Wall Command (Map Brush menu)

Use this command to select the Human Wall Tool.    A check mark appears next to the menu 
item when this tool is selected.

Shortcuts
Toolbar:  
 



Orc Wall Command (Map Brush menu)

Use this command to select the Orc Wall Tool.    A check mark appears next to the menu item
when this tool is selected.

Shortcuts
Toolbar:  
 



Human Unit Commands (Tools menu)

Use one of the Human Unit Commands to select one of the Human Unit Tools.    Human Unit 
Commands are disabled when a player in the Player menu is selected and that players race 
is not human.    A check mark appears next to the menu item when the tool is selected.

Note: There can only be one human starting location per human player.    Placing another 
one, deletes the previous one.



Orc Unit Commands (Tools menu)

Use one of the Orc Unit Commands to select one of the Orc Unit Tools. Orc Unit Commands 
are disabled when a player in the Player menu is selected and that players race is not orc.    
A check mark appears next to the menu item when the tool is selected.

Note: There can only be one orc starting location per orc player.    Placing another one, 
deletes the previous one.



Miscellaneous Unit Commands (Tools menu)

Use one of the Miscellaneous Unit Commands to select one of the Miscellaneous Unit Tools.    
A check mark appears next to the menu item when this tool is selected.



NPC Unit Commands (Tools menu)

Use one of the NPC Unit Commands to select one of the NPC Unit Tools.    Some NPC units 
belong to humans and others belong to orcs.    NPC Unit Commands are enabled when the 
unit belongs to the race of the selected player.    A check mark appears next to the menu 
item when the tool is selected.



Player 1, 2, 3, ... Command (Player menu)

Use this command to select a player to which new units will be assigned or to which selected
units are assigned.    A check mark appears next to the menu item when the player is 
selected or when the players units is in the current selection.



Map Properties Command (Player menu)

Use this command to bring up the Map Properties dialog box where you can change the 
terrain type of the map and the map description.

Map Properties Dialog Box

The following options allow you to specify terrain type of the map and the map description.

Terrain Type
Indicate whether you want a forest, winter, or wasteland terrain type.

Map Description
Type the map description that will display itself in the custom scenario dialog box.    The 
description is limited to 31 characters.



Player Properties Command (Player menu)

Use this command to bring up the Player Properties dialog box where you can change the 
race, controller and A.I. for all players.

Player Properties Dialog Box

The following options allow you to specify player properties.

Race
Indicate whether you want a player to be human or orc.

Controller
The following options allow you to specify the controller for each player.
Human

Select this option to allow a person to control the units assigned to the player.
Computer

Select this option to make the computer control the units assigned to the player.
Rescue(Passive)

Select this option to make the computer control, in passive mode, the units that are 
assigned to the player.    Units assigned to a player with this controller can be 
controlled by human players after the units have been rescued.

Rescue(Active)
Select this option to make the computer control, in active mode, the units assigned to
the player.    Units assigned to a player with this controller can be controlled by 
human players after the units have been rescued.

A.I. Players
The following options allow you to specify an A.I. for each player should the player be 
controlled by the computer.
Land Attack

Select this option to make the computer player attack with land units.
Passive

Select this option to make the computer player remain inactive until it is attacked 
upon.

Sea Attack
Select this option to make the computer player attack with sea units.

Air Attack
Select this option to make the computer player attack with air units.



Starting Conditions Command (Player menu)

Use this command to bring up the Starting Conditions dialog box where you can edit the 
amount of gold, lumber, and oil each player will have at the beginning of the game.

Starting Conditions Dialog Box

The following options allow you to specify the starting resources for each player.

Gold
Type how much gold each player will have at the beginning of the game.

Lumber
Type how much lumber each player will have at the beginning of the game.

Oil
Type how much oil each player will have at the beginning of the game.

Duplicate
Click this button to copy the gold, lumber, and oil values of player 1 to the other players.



Unit Properties Command (Player menu)

Use this command to bring up the Unit Properties dialog box where you can edit the 
properties for all unit types.

Unit Properties Dialog Box

The following options allow you to specify values of different properties for all unit types.

Use Default Data
Check this box to use the data thats built into the game.

Default
Click this button to restore all values from the built-in data and automatically check the 
Use Default Data button.

Scroll Bar
Use the scroll bar to find the unit type that you want to edit.

Visible Range
Type the maximum distance that a unit can see on a scale from 1 to 9.

Hit Points
Type the total amount of damage a unit or building can sustain before it is destroyed.

Magic Points
Type the maximum amount of mana available for casting spells.    

Build Time
Type the time it takes to build or train each unit.

Gold Cost
Type the cost in gold to build or train each unit.

Lumber Cost
Type the cost in lumber to build or train each unit.

Oil Cost
Type the cost in oil to build or train each unit.

Attack Range
Type the maximum distance at which each unit can attack another.

Armor
Type the amount of damage a unit can absorb before damage is deducted from its Hit 
Points.

Basic Damage
Type the maximum amount of damage that may be done to a unit.    If a unit that is 
attacked has armor, at least half of the damage that penetrates the armor will be dealt 
to the unit.    EXAMPLE: A unit with a Basic Damage rating of 10, attacks a unit that has 
an Armor rating of 2.    The attacker penetrates the defenders Armor rating by 8 points, 
and therefore would deal a random amount of damage with a minimum of 4 points up to 
a maximum of 8 points.

Piercing Damage
Type the maximum amount of damage will ALWAYS be done to a unit regardless of armor.
This damage is considered to be armor piercing, and therefore ignores any Armor ratings.
The amount of damage that is dealt will be random, with a minimum being one half of 
the Piercing Damage rating.    EXAMPLE: A Piercing Damage rating of 6 would ALWAYS do 
between 3 and 6 points of damage to any unit.





Upgrade Properties Command (Player menu)

Use this command to bring up the Upgrade Properties dialog box where you can edit the cost
of all the upgrades.

Upgrade Properties Dialog Box

The following options allow you to specify the cost of all the upgrades.

Use Default Data
Check this box to use the data thats built into the game.

Default
Click this button to restore all values from the built-in data and automatically check the 
Use Default Data button.

Scroll Bar
Use the scroll bar to find the upgrade that you want to edit.

Step Cost
Type the amount of game time that the upgrade takes.

Gold Cost
Type the amount of gold that the upgrade costs.

Lumber Cost
Type the amount of lumber that the upgrade costs.

Oil Cost
Type the amount of oil that the upgrade costs.



Index Command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using Warcraft II Editor and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help Command (Help menu)

Use this command for instructions about using Help.



About Command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
Warcraft II Editor.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in Warcraft II Editor,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To
Open a new document.
Open an existing document.    Warcraft II Editor displays the Open dialog box, in which

you can locate and open the desired file.
Save the active document with its current name.    If you have not named the 

document, Warcraft II Editor displays the Save As dialog box.
Use lighter colored tiles.
Use darker colored tiles.
Use plain tiles.
Use filler tiles.
Use plain and filler tiles.
Use the 1 x 1 Map Brush size.
Use the 3 x 3 Map Brush size.
Use the 5 x 5 Map Brush size.
Use the Select Tool.
Use the Water Tool.

 
 

Use the Dirt/Ice/Mud Tool depending on the currently selected terrain type.
 
 

Use the Grass/Snow/Dry Mud Tool depending on the currently selected terrain type.
 
 

Use the Tree Tool.
 
 

Use the Rock Tool.



 
 

Use the Human Wall Tool.
 
 

Use the Orc Wall Tool.
Get context help.



Context Help Command 

Use the Context Help Command to obtain help on some portion of Warcraft II Editor.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the Warcraft II Editor window, such as another
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.
To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.
A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

Shortcut
Mouse: Drag the white rectangle in the minimap.



Size Command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to 
the border you want to move.    
Press a DIRECTION key to move the border.
Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move Command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.
Shortcut

Keys: CTRL+F7



Minimize Command (application Control menu)

Use this command to reduce the Warcraft II Editor window to an icon.

Shortcut
Mouse: Click the minimize icon  on the title bar.

Keys: ALT+F9



Maximize Command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon  on the title bar; or double-click the title bar.

Keys: CTRL+F10 enlarges a document window.



Close Command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close Command.

Note:    If you have multiple windows open for a single document, the Close Command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close Command on the File menu.

Shortcuts
Keys: ALT+F4 closes the application window or dialog box



Restore Command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize Command.



Switch To Command (Application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To Command, you will be presented with a dialog box with 
the following options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Credits

Warcraft II Map Editor Help

Written by Tim Thein

Portions written by Bill Roper, and Mike Obrien.



<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>




