
The Telnet Application

The Telnet application allows you to login to other computers across the network and 
access services that those computers provide to their local terminals. When you are 
connected, it is as if your keyboard and monitor are connected directly to that 
computer (the host system). You can execute commands, run certain programs, and 
access many special services offered by the remote computer.

The Telnet application provides full emulation of the Digital Equipment Corp. VT220, 
VT102, and VT52 terminals, and communicates with a remote system (called a host 
system) using the Telnet protocol. With the Telnet application, you can run script files,
create and use login scripts, and redefine the keyboard to better match the terminal 
you are emulating.

Note: To use Telnet, you must be familiar with the commands and other user 
interface conventions of the computer to which you connect.

The following Help topics are available:
Getting Started with Telnet 
Telnet Reference 
Keyboard Mapping 
Index 
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Getting Started with Telnet

The Telnet application contains a wide range of features that help you to 
communicate with remote hosts. The information provided in this section 
demonstrates the basic Telnet features so that you can start using the Telnet 
application with the default settings. Once you are familiar with the basic features, 
you can continue to explore other Telnet features with the help of the Telnet 
Reference.

This section discusses the following topics:
Starting the Telnet Application 
Connecting to a Host System 
Disconnecting from a Host System 
Other Telnet Features 



Starting the Telnet Application

To start the Telnet application, double-click on the Telnet icon in the TCP Pro program 
group.



Connecting to a Host System

Before you attempt to establish a connection to a host system, you need to know the 
information listed below. This information can be obtained from your network 
administrator, or from the person whose system you want to access.

- The host name or IP address of the host system
- The login information you need to enter to connect to the host system. (Your 

user name and, if necessary, your password.) 

Once you have obtained the above information, you can establish a connection to the
host system by following the steps below:

1. Select Connect from the Connect menu to open the Telnet Connect dialog box.
2. In the Host Name field, enter the host name or IP address of the host system to 

which you want to connect, then click on the OK button to establish a 
connection.
The login prompt for the system you specified appears in the Telnet window.

3. Enter your login at the login prompt and if necessary, enter your password at 
the password prompt then press Return.

You are now logged-in to the host system.

You can change the default Telnet settings to better match the host system you are 
emulating by selecting Telnet Setup from the Options menu. You can also associate 
specific settings with a host system and save the information under a session name. 
This makes it possible to reestablish connections to specific host systems at a later 
time and maintain the same settings for each host system.



Disconnecting from a Host System

To disconnect from the host system to which you are currently connected, either 
logout of the remote system or select Disconnect from the Connect menu. You can also 
select Exit from the File menu to quit the Telnet application.



Other Telnet Features

Now that you are familiar with the basic features, you can continue to explore the 
many features that the Telnet application has to offer. With Telnet, you can:

- Save to a file or print the data in the terminal screen area by selecting the 
appropriate menu item from the File menu.

- Run script files during a connection by selecting Run Script.
- Copy and paste data between the Windows clipboard and the terminal screen 

by selecting the appropriate menu item from the Edit menu.
- Redefine the keys on your keyboard to better match the terminal you are 

emulating by selecting Keyboard Setup from the Options menu.
- Modify certain characteristics of a session to better match the host system 

environment by selecting Telnet Setup from the Options menu.
- Configure the Telnet application to use a login script to login to a host system 

automatically by selecting Telnet Setup from the Options menu.
- Save to a file a record all characters received during a connection and any error

messages generated while the application is in use by selecting Log to File from
the Options menu.



Telnet Reference

This section introduces you to the main window of the Telnet application and 
describes each pulldown menu, menu item, and dialog box in detail.

When you start the Telnet application, the Telnet window appears on your screen. The
Telnet window is the main window of the Telnet application. It contains the following: 

A Terminal Screen Area 
A Status Bar 
The File Menu 
The Edit Menu    
The Connect Menu 
The Options Menu 



Terminal Screen Area

The Terminal screen area of the Telnet window displays the login prompt during 
connection to a host system, and once connected, displays all interactions with the 
host system.



Status Bar

The status bar is located at the bottom of the Telnet window. It contains four areas 
described from left to right.

- A screen size area, which indicates the width of the terminal screen in 
characters followed by the height of the screen in lines.

- A cursor position area, which indicates the position of the cursor on the terminal
screen.

- A help message area, which displays error messages and information about the 
feature you are using.

- A status area, which indicates if a connection is established with a host system 
(Ready) and displays the host name or the IP address of the system to which 
you are connected.



File Menu

The File pulldown menu contains the following menu items:
Print Screen 
Printer Setup 
Run Script 
Save Screen 
Exit 



Print Screen

The Print Screen menu item sends an image of the terminal screen to a printer. 

Note: To specify a printer, select Printer Setup from the File menu.



Printer Setup

The Printer Setup menu item lets you select a printer from which to print a screen 
image. Selecting Printer setup presents the Print Setup dialog box. This dialog box 
lets you select a printer locally or on the network. You can also select the orientation 
and size of the paper.



Run Script

The Run Script menu item lets you run script files during a connection. When you 
select Run Script, the Run Script File dialog box opens. The Run Script File dialog box 
lets you select the file containing the script.



Save Screen

The Save Screen menu item saves an image of the terminal screen to a file. Selecting
Save Screen presents the Terminal Screen Image dialog box. This dialog box lets you 
specify a file name, drive, and directory where you want to save the screen image. A 
default name is supplied. You can use the default file name instead of specifying your 
own.

Note: The screen image is stored in a format that makes it easy to load the image 
into a word processor or text file. If the screen image contains DEC Special Graphics 
characters, they are translated to their nearest ASCII equivalents before the image is 
saved to the specified file.



Exit

The Exit menu item disconnects you from the host system to which you are currently 
connected and exits the Telnet application.



Edit Menu

The Edit menu lets you copy data to and from the Windows clipboard. It contains the 
following menu items:

Copy 
Paste 
Clear 



Copy

The Copy menu item copies selected data from the terminal screen to the Windows 
clipboard. If the selected data contains DEC Special Graphics characters, they are 
translated to their nearest ASCII equivalents before being copied to the clipboard.

Note: If no data is selected, the Copy menu item is grayed-out and cannot be 
selected.



Paste

The Paste menu item pastes data from the Windows clipboard to the cursor position 
in the terminal screen area.

Note: If no data is present in the Windows clipboard, the Paste menu item is grayed-
out and cannot be selected.



Clear

The Clear menu item clears data from the Windows clipboard.

Note: If no data is present in the Windows clipboard, the Clear menu item is grayed-
out and cannot be selected.



Connect Menu

The Connect menu lets you connect to and disconnect from host systems. It contains 
the menu items listed below. A list of session names appears in the Connect pulldown
menu if you have previously defined sessions. A session identifies specific Telnet 
settings that can be associated with a host system. To define a session, select Telnet 
Setup from the options menu to open the Telnet Session Setup (1) dialog box dialog 
box.

The Connect menu contains the following menu items:
Connect 
Disconnect 



Connect

The Connect menu item establishes a connection to a host system. When you select 
Connect, the Telnet Connect dialog box opens.



Telnet Connect Dialog Box

The Telnet Connect dialog box lets you establish a connection to a host system. It 
contains the following fields and buttons:

Session Name This field lets you select a Telnet session that has been defined. If you
have not yet defined any Telnet sessions, only the default settings 
will be available. To define a session, select Telnet Setup from the 
Options menu.

Host Name This field lets you enter the host name or IP address of the system to 
which you want to connect.
If you have selected a session from the Session Name field, described
above, the host name or IP address associated with the session is 
displayed in this field.

OK Clicking on this button exits the Telnet Connect dialog box and 
presents the login prompt from the host you specified.

Cancel Clicking on this button exits the Telnet Connect dialog box without 
establishing a connection to the host.



Disconnect
The Disconnect menu item terminates your current connection.



Options Menu

The Options menu contains the following menu items:
Keyboard Setup 
Log to file 
Log File Setup 
Telnet Setup 



Keyboard Setup

The Keyboard Setup menu item lets you redefine the keys on your keyboard to better 
match the terminal you are emulating. You can also redefine the function keys by 
assigning repetitive commands to reduce typing time. The main alphanumeric 
keypad and the twelve top-row function keys, as well as the keys on numeric keypad 
can be redefined. The redefined keys must be saved to a file and then associated 
with a specific session. 

Selecting this menu item presents the Keyboard Map dialog box. 

For information about redefining keys, refer to Redefining a Key.



Keyboard Map Dialog Box

The Keyboard Map dialog box contains a map of the main alphanumeric keyboard and
the twelve top-row function keys of the 101-key keyboard.    Clicking on the Numeric 
Pad button opens a map of the three small keypads on the right-hand side of the 101-
key keyboard. The Keyboard Map dialog box also contains the following buttons:

Open Clicking on this button opens the Open Key Redefinition File dialog 
box, which lets you enter the name of an existing file containing key 
definitions so they can be edited. Once you have redefined keys, you 
must click on the Save button to save the definitions to the file.

Save Clicking on this button opens the Save Key Redefinition File dialog 
box that prompts you for the name of the file where you want to save
the key definitions. 

Cancel Clicking on this button exits the Keyboard Map dialog box without 
saving any definitions.

Numeric Pad Map
Clicking on this button presents the Keypad Map dialog box which 
displays a map of the numeric keypads. This dialog box lets you 
redefine any of the keys represented.

For information about redefining a key on the keyboard, refer to Redefining a Key.



Redefining a Key

To redefine a key, click on the key in the Keypad Map dialog box. A small dialog opens
allowing you to enter any character sequence for that key (between one (1) and 
eighty (80) characters in length). Typing normally will enter the ASCII characters 
associated with the default keyboard mapping or the current sessions keyboard 
mapping (if the keyboard has been previously redefined).

You can enter ASCII control characters by typing the caret character (^) followed by 
the printable equivalent of the control character you want to enter. For example, ^C 
redefines a key to Control C. You can also enter any character (including non-printing 
characters) by specifying its octal coding equivalent in the format \nnn, where n is 
an octal digit. For example \033 specifies the Escape character.

Each key on the keyboard is capable of sending one of four different character 
sequences, each one associated with one of the keys four states: the base (or 
unmodified) state, the Shift state, the Control state, and the Control-Shift state. The 
redefinition character sequences for all four states can be concatenated into the 
single redefinition field, with the character strings associated with each state 
separated by the vertical bar character (|). For example, the character sequence abc|
def|ghi|jkl would cause a key to send abc when struck in its base state, def when
struck with the Shift key depressed, ghi when struck with the Control key depressed,
and jkl when struck with both the Shift and Control keys simultaneously pressed.

You can incorporate the special characters vertical bar (|), caret (^), and backslash (\)
into redefinition character sequences by encoding their octal equivalents; \
174,\136,\134 respectively.

IMPORTANT: The total length of a key-definition character sequence (including the 
special characters (\), (^), (|)) cannot exceed 80 characters. All four states of the 
redefinition string must fit into this space.

Once you have entered the keys new character sequence, click on the OK button in 
the small dialog box to save the definition in memory and return to the Keyboard Map
dialog box. Then click on the Save button in the Keyboard Map dialog box to 
permanently save the key definitions to a file.

To associate the key definitions with a session, you must specify the file name 
containing the definitions in the File Name field of the Telnet Session Setup (2) dialog 
box. To access the Telnet Session Setup (2) dialog box, select Telnet Setup from the 
Options menu. 



Log to file

The Log to File menu item saves to a file a record of all received characters during a 
connection. A check mark appears to the left of the Log to File menu item when it is 
selected. 

Note: If you have not specified a file name, the Log to File menu item is grayed-out 
and cannot be selected. To specify a file name, select Log File Setup from the Options 
menu.



Log File Setup

The Log File Setup menu item lets you specify a file name where you want to save all 
received characters during a connection.    When you select Log File Setup, the Log 
File Setup dialog box opens.



Log File Setup Dialog Box

The Log File Setup dialog box contains the following fields and buttons:
Session Name This field lets you select a session name from the drop-down list so 

that you can associate a log file with a specific session. A list of 
session names appears only if you have previously defined sessions. 
Logging will occur only for the selected session.

File Name This field lets you specify the name of the file where you want to save
all received characters.

Open Mode Append adds new information to the end of the log file each time a 
new connection is established.
Truncate deletes all old information from the log file each time a new 
connection is established.

OK Clicking on this button saves the file name and exits the Log File 
Setup dialog box. 

Cancel Clicking on this button exits the Log File Setup dialog box without 
saving the file name.

Files Clicking on this button opens a dialog box that lets you select a file 
on your PC or on the network where you want to save all received 
characters during a connection.



Telnet Setup

The Telnet Setup menu item lets you modify some of the characteristics of a 
connection to better match the host environment. You can select specific Telnet 
settings and save the settings under a session name. A session can be associated 
with a particular host system. 

Selecting Telnet Setup presents the Telnet Session Setup (1) dialog box.



Telnet Session Setup (1) Dialog Box

The Telnet Session Setup (1) dialog box lets you modify some of the characteristics of
a connection to better match the host environment. It contains the following fields 
and buttons:

Session Name This field lets you enter a descriptive name for the Telnet session you 
want to save.

Host Name This field lets you enter the host name or IP address of the host 
system with which you want to associate the session specified above.

Host Port If you do not use the standard Telnet port 23, enter the port in this 
field.

Exit on Disconnect
If you select this box, the Telnet application will quit automatically 
when you disconnect from the host system.

Login Script If you want to use a login script to login to the host system, enter the 
name of the login script in the File Name field.    For information about
creating a login script, refer to Creating a Login Script.

Colors Foreground lets you select the color of the text displayed in the Telnet
window for the session specified.
Background lets you select the background color of the Telnet window
for the session specified.
Bold lets you select the color of high-intensity text in the Telnet 
window for the session specified.

Custom Clicking on this button opens a dialog box that lets you define your 
own custom colors.

Font Name lets you select the font used for text in the Telnet window for 
the session specified.
Custom lets you to define which font type and size you want to use 
for text. When you select Custom Font, the Font dialog box opens. 
This dialog box allows you to select a font type (for example, courier),
style (for example, bold), and size from the lists provided.

OK Clicking on this button saves the information in the Telnet Session 
Setup (1) dialog box under the session name specified in the Session 
Name field. The Telnet Session Setup (1) dialog box then closes.

Cancel Clicking on this button cancels any modifications you made and 
closes the Telnet Session Setup (1) dialog box.

Remove Clicking on this button deletes the session name specified in the 
Session Name field from the configuration file. The session name no 
longer appears in the Session Name drop-down list.

More Setup (2) Clicking on this button presents the Telnet Session Setup (2) dialog 
box.



Creating a Login Script

To create a simple login script, you must create a file containing a script using the 
following statements:

wait secs "string"
Causes the incoming data stream to be scanned for an occurrence of the text 
string specified by string. 
secs 
Indicates the number of seconds that the application should wait for the 
specified string before giving up. If the string is not detected within the 
specified number of seconds, the script will abort. The quotation marks around
the string parameter are required.
type "string"
Causes the specified string to be transmitted to the host system as though it 
had been typed by the user at the keyboard. The quotation marks around the 
string parameter are required.
if_err_goto label
if_noerr_goto label
Are provided so that the login script can react to the result of the wait secs 
"string" statement. The target of the    goto statement is a label, which is 
included in the script file by using a syntax similar to that used by DOS batch 
files.

The following is a sample script file which automatically logs-in to a host system 
using the login name Bob and the password Begonia, and starts the mail application.
In the following sample, \015 signifies a hard return.

wait 15 "login:"
if_err_goto :end
type "Bob\015"
wait 10 "password:"
if_err_goto :end
type "Begonia\015"
if_err_goto :end
type "mail\015"
:end



Telnet Session Setup (2) 

The Telnet Session Setup (2) dialog box contains the following fields and buttons:
Emulation Lets you select between VT220, VT102, or VT52 emulation.
Screen Selecting the Wrap check box will wrap text to the next line when the 

end of the line is reached. If this check box is not selected, the last 
character will be repeatedly displayed at the end of the line, with 
each character overwriting the last.
Selecting the Echo check box echoes all keystrokes immediately back
to the screen as well as transmitting keystrokes to the host system. If
this check box is not selected, keystrokes are transmitted to the host  
system but not echoed back to the screen.
Selecting the Bell check box will sound an audible bell or will flash the
menu bar when a BEL character is received.

Backspace Key
Selecting DEL redefines the backspace key on your keyboard to be 
the delete key.
Selecting BS does not redefine the backspace key.

Numeric Keypad
Selecting Application places the numeric keypad on your keyboard in 
application mode. 
Selecting Numeric places the numeric keypad on your keyboard in 
numeric mode.

Cursor Keys Selecting Application places the cursor keypad on your keyboard in 
application mode.
Selecting Normal places the cursor keypad on your keyboard in 
normal mode.

Control Keys Selecting Interpret interprets received control sequences as 
commands.
Selecting Display displays received control sequences on the screen.

Key Redefinition File
The File Name field lets you specify the name of the file containing 
the key definitions you want to use for the session specified. To 
redefine the keys on your keyboard, select Keyboard Setup from the 
Options menu. 

OK Selecting this button closes the Telnet Session Setup (2) dialog box. 
You must click on the OK button in the Telnet Session Setup (1) dialog
box for your changes to take effect.

Cancel Clicking on this button cancels the modifications you made and 
returns you to the Telnet Session Setup (1) dialog box.

More Setup (3) Clicking on this button presents the Telnet Session Setup (3) dialog 
box. This button is available only when the default session is being 
used. The settings apply to all connections.



Telnet Session Setup (3) 

The Telnet Session Setup (3) dialog box is only available when the default session is 
being used. The settings apply to all connections. The Telnet Session Setup (3) dialog 
box contains the following fields and buttons:

Screen Scroll Buffer lets you specify the number of lines in the scroll buffer of
the Telnet window. In order for the changes you make to take effect, 
you must exit then restart the Telnet application.

Keyboard Type
This field lets you select the keyboard that is attached to your PC. You
can select the IBM Enhanced keyboard or the DEC LK250 keyboard. 

NumLock The field lets you select whether you want the NumLock on your 
keyboard set to ON or OFF.

Edit Keys This field lets you specify the mapping applied to the six dedicated 
editing keys on the keyboard connected to your PC. Selecting DEC 
indicates that direct physical mapping to the DEC LK250 keyboard is 
used. Selecting IBM indicates that each key should be mapped to its 
closest logical equivalent.

OK Clicking on this button closes the Telnet Session Setup (3) dialog box. 
You must click on the OK button in the Telnet Session Setup (1) dialog
box for your changes to take effect.

Cancel Clicking on this button closes the Telnet Session Setup (3) dialog box 
without saving any changes.



Keyboard Mapping

The Telnet application is a DEC VT220 emulator. Its use is tied to the layout of the 
DEC LK201 keyboard. The following table provides a guide to the default mapping 
used by the Telnet application to provide compatibility with the DEC keyboard.

DEC Key IBM Key

PF1 Numlock

PF2 / (on numeric pad)

PF3 * (on numeric pad)

PF4 - (on numeric pad)

, (comma) Plus (on numeric pad)

- (minus) CTRL Plus (on numeric pad)

Enter Enter (on numeric pad)

HoldScreen Pause

PrintScreen Alt F2

F6 thru F10 F6 thru F10

F11 thru F20 Shift F1 thru Shift F10

Help F11

Do F12

The mapping of the editing keys will vary depending on the settings of the Edit Keys 
setting in the Telnet Session Setup (3) dialog box. To access the Telnet Session Setup 
(3) dialog box, select Telnet Setup from the Options menu.

VT Key Edit Keys=DEC EditKeys=IB
M

Find Insert Home

InsertHere Home Insert

Remove PageUp Delete

Select Delete End

PrevScreen End PageUp

NextScreen PageDown PageDown



 




