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Introduction
Photo Factory for Windows version 2.1 offers a complete image editing and display solution to the 
KODAK Photo CD business or casual user. Photo Factory for Windows is a powerful, yet easy to use 
image editing and presentation program for Photo CD and other common image formats.



Features and Benefits
Photo Factory for Windows 2.1 is a single-program solution for loading, composing, manipulating, 
displaying and printing Photo CD images. It also supports importing and exporting seven other image file 
formats.    Enhanced by the Slideshow editor and presentation package, Photo Factory for Windows is an 
ideal platform for a computer based Photo CD presentation system.    
Photo Factory for Windows 2.1 has many powerful and useful features, which fall into three main 
categories:

Related Topics:
Display Features
Editing Features
File Management Features



Display Features
· Create multimedia Slideshows to run on your (or someone else's) system, complete with image, 

text, and sound.

· Create multimedia Screen Savers for Windows from your Slideshows.

· View available Photos in a Thumbnail Contact Sheet. 

· Display multiple Photos at your specified resolution.

· Print high resolution photos and images to selected printers.

· Print high-quality contact sheets of Photo CD disks.

· Create Slideshows with embedded sound and text.

· Create Slideshows from seven different Image File types and Photo CD photos.

· Play Slideshows with Wave and MIDI sound.

· Play Photo slides directly from the Photo CD.



Editing Features
· Select Photos by File, Thumbnail, or Contact Sheet.

· Cut, Copy, and Paste selected areas via the Clipboard.

· Crop, Rotate, Flip, and Mirror Photos and Images.

· Zoom in/out on user-specified portions of the photo.

· Resize both Photos and imported images.

· Apply image and color Filters to Photos and Images.

· Color correct images with the image editor.

· Edit Slideshows with a script editor and floating Tool Bar.

· Print Slideshow script information with thumbnail images.



File Management Features
· Save photos to various file formats and resolutions.

· Convert images to seven different file formats.

· Import and display images from many different formats.

· Consolidate a Slideshow to JPEG or seven other formats from many different image file types.

· Batch convert Photo CD images from the Contact Sheet.

· Export an entire Slideshow with images, sound and Runtime Player to multiple diskettes for 
playing on systems without Photo Factory for Windows.



Navigating Photo Factory
Photo Factory for Windows is a powerful imaging program with many useful features. The tools available 
for supporting each of these features are automatically presented when the feature is selected. For 
instance, if you select a displayed image with the mouse, the Photo Factory Menu Bar will provide the 
tools for editing, manipulating or saving the image.

The Multimedia Store has organized Photo Factory so that you can easily navigate to different areas of 
the program when you need them. This Help is organized to first take you through the major features in 
the Quick Start, Getting Started section, and then present detail on each feature as you might use them.

Related Topics:
Program Layout



Program Layout
Photo Factory is designed to work with Kodak's Photo CD. When you first run Photo Factory, an empty 
window appears. To use Photo Factory, you must open an image or images. When you do, other windows
appear within the Photo Factory window. One available window is the Contact Sheet Window.    This 
presents all the images on your Photo CD disk. Another,    the Slideshow Script Window,    is created when
you decide to create a Slideshow from those images. The menus and their commands will change 
according to which window is selected.

The top level in Photo Factory is the Photo Factory Window. In this window you can view contact 
sheets, Photo CD images, other images and create Slideshows.

You can activate the image editor by selecting a particular image to work on; this action opens an 
Image Window within the Photo Factory Window. The menus change when you select an image for 
editing, and thus you enter the image editor.

You can assemble a Slideshow by simply dragging images to the Slideshow Script Window from the 
contact sheet. You can also edit the images first, and then assemble them into a Slideshow. Photo 
Factory has a powerful image editor and color correction facility for editing the images themselves. With 
the Slideshow editor, you can add background music, voice over, background color, text, etc., to each of 
the images in the Slideshow. You can also set the time duration each image appears and select how to 
advance to the next slide.
You can enter the Slideshow editor by double-clicking on a slide from the Slideshow Script Window. 
Entering the Slideshow editor produces a more dramatic transition than the image editor. And, the 
Slideshow editor has its own floating tool bar with icon tools rather than text menus.

Printing and Saving are accomplished in the usual way from the File menu, using the appropriate 
commands.

You can Export Slideshows from within Photo Factory or by using the stand-alone Export program.    
This includes an Import program allowing easy importing of the Slideshow to another computer for 
editing, or viewing with the Runtime Player.



What You Will Need
Photo Factory is designed to work with Microsoft Windows 3.1 or later, and a Photo CD compatible CD 
ROM drive.

Related Topics:
Hardware Requirements
Software Requirements



Hardware Requirements
IBM PC/AT or fully compatible 386-based computer as a minimum.

CD-ROM mode 2, Form 1 drive. MPC 1 compatible (for Photo CD compatibility).

At least 4 MB of RAM; 8 MB recommended (for High Color Display Modes, 8 MB minimum is required).

At least 2 MB of available hard-disk storage to load the Photo Factory software (4 MB recommended with 
Demo Files).

An 8 bit (256 color) VGA color display minimum; 24-bit (16 million color)or 16 bit (64,000 color) color 
display recommended, with appropriate Windows drivers. 

Video Note:    A 4 bit (16 color) display is supported, but is not recommended.    Photo Factory will attempt
to display images with this video mode.

A Windows compatible sound board that can play Wave (.wav) and MIDI (.mid) files is necessary to play 
sound with slides.

Memory Note: Because image files can approach 16 MB, a large amount of system memory is required 
to prevent excessive disk swapping with the Windows virtual memory swap file. At least 20 MB of virtual 
memory (system RAM plus the swap file) will be required to open large images. This requirement varies 
with each system, but more RAM the better.

To run a Slideshow in 24 bit at 1024 X 768 and display large images with MIDI and Wave play, a 
486DX66 with 16 MB, a fast CD drive and Graphics Accelerator is required. But, a Slideshow in 24 bit at 
640 X 480 will run fine on most systems.



Software Requirements
MS-DOS, version 3.3 or later; version 5.0 or later recommended.

Microsoft Windows, Version 3.1 or later.

Mode 2 capable CD-ROM Windows driver (e.g., MSCDEX). 

Microsoft Windows should be configured to run in at least 256 Color mode for minimum acceptable 
performance.



About Help
Help shows you how to install and use Photo Factory for Windows Version 2.1, and is divided into five 
sections. The first two sections are for those who are in a hurry and will seek the details later. The third 
section provides more detail and describes each menu and command. The fourth section explains how to 
put a Slideshow on diskette for a friend or business associate. The last section contains reference 
material.

The first section, Installation (Installing Photo Factory for Windows)

· Setup instructions describing how to install and setup Photo Factory for Windows.

· Gives a List of the Files which will be installed by setup.

The second section, Quick Start (Getting Started)

· Open a Photo CD disk

· Create a Slideshow

· Run Slideshow

The third section, Menu Command Reference

· Lists all Photo Factory menu commands in each window and describes how to use them.

¨ Photo Factory Window Commands

¨ Contact Sheet Window Commands

¨ Image Window Commands

¨ Slideshow Script Window Commands

¨ Slideshow Editor Window Commands

The fourth section, Distributing What You've Produced
· Compressing and saving a Slideshow to diskette

· Saving a Slideshow as a screen saver

The fifth section, Reference Information

· Appendixes

· Glossary of Terms

· Index



Installing Photo Factory for Windows

Here's how to install Photo Factory for Windows:

· Run Microsoft Windows and open the Program Manager

· Insert the Photo Factory CD into the appropriate CD ROM Drive on your computer (probably the 
D: drive).    

· From the Program Manager, select    File Menu, then Run.

· Enter the appropriate CD drive letter followed by :\Pfactory\Setup.exe (e.g., d:\Pfactory\
Setup.exe). 

· Select the Set Location button to enter the desired destination drive, along with the desired 
location for storing the program files (the default is C:\PFACTORY).

· Choose those items you wish installed from the Installation Options list:

¨ Check the Photo Factory for Windows box to install the Photo Factory program and its 
main required support files. You may not install this on more than one machine at a time.

¨ Check the Runtime Player box to install the Slideshow player. This is useful to install only 
the Slideshow player on another diskette or system. You may freely distribute the Runtime 
Player.

¨ Check the Screen Savers box to install the capability to run a Slideshow created with Photo 
Factory as a Windows Screen Saver. You may freely distribute the Screen Saver file.

¨ Check the Midi Gallery and/or demo Slideshows boxs to install sample Slideshows, images,



Wave and MIDI files. You may not sell these as music or clip art files, but you may otherwise 
freely distribute them in presentations and documents you create.    

¨ Checking additional demonstration programs will also install their files with your Photo 
Factory programs.

The setup program will automatically sense the files installed on your system and will indicate the 
required space to install each selected option.

Setup installs these files: 
File Description
BWCC.dll Dialog support functions
LEADDLL.dll File processing support functions
PCDLIB.dll Photo CD support functions
PFACTORY.exe Photo Factory program
PFACTORY.hlp Photo Factory help
PFACTORY.ini Photo Factory defaults
PFRUN.exe Photo Factory runtime engine
PFSCR.dll Screen Saver support functions
PFSCRNSV.scr Screen Saver control script 

(Windows)
EXPORT.exe Slideshow Export utility
LEAD.dll File Processing support functions
LEADDIB.drv Device Independent Bitmap driver
IMPORT.exe Slideshow Import utility
CONTROL.ini Modified for Screen Saver 

(Windows)
PFVIC.dll Image processing support functions

At the completion of installation, the Setup program automatically creates a Program Group in Program 
Manager called Photo Factory with an Icon for Photo Factory for Windows and the Import/Export 
utilities.    If you installed the Runtime Player, Midi Gallery or demonstration Slideshows and programs, 
they may also have Icons.    Clicking an icon twice starts the program.    Refer to the README.1st file with
Notepad for any last minute instructions, documentation modifications or corrections.

Note: User's with network CD-ROM drives and multiple CD-ROM drives should refer to appendix notes 
for special installation instructions.



Installing Features Later
The Optional installation items of Photo Factory for Windows may be installed later if you didn't install 
them in the beginning. To install these items, re-run Setup as described in the initial Installation and select
only the items you missed. Your installed Photo Factory files will not be affected by this second installation
(Refer to Installing Photo Factory for Windows).



Introduction
This section provides a brief and basic introduction to Photo Factory for Windows. It will take you through 
a quick session using most of the parts of Photo Factory for Windows.

To realize the full power of Photo Factory, continue on to the following sections.



Getting Started
Load the Photo CD disk
Run Photo Factory for Windows
Open the Photo CD Contact Sheet
Open a Photo CD Image (.PCD)
Crop the Photo CD Image
Open a New Slideshow
Assemble Slideshow Script
Open the Slideshow Editor
Run Slideshow
Save Slideshow
Open Slideshow
Conclusion



Load the Photo CD disk
Insert the Photo CD disk in the CD ROM drive with the KODAK Photo CD logo face up. The KODAK 
Photo CD logo assures you of Photo CD file compatibility.

Hint: You may also use Photo Factory to read several other image file types.



Run Photo Factory for Windows

Double-click on the Photo Factory icon in the Windows Program Manager to start the program.



Open the Photo CD Contact Sheet
From the File menu in Photo Factory select Open and Photo CD Contact Sheet. Photo Factory will 
display a contact sheet for you containing all of the images on your Photo CD.



Open a Photo CD Image (.PCD)
Double-click on an image you like in the contact sheet. Photo Factory loads the Photo CD file and 
displays it in the Photo Factory window. The photo is much larger than the thumbnails in the contact 
sheet¾detail can be seen much more easily.

Hint: An advantage in opening the image first is that you may Crop, Zoom or modify it before you include 
it in a Slideshow.



Crop the Photo CD Image 
Notice that the Photo Factory menu bar is different.    This is the Image Editor.    Point at the top left corner 
of a portion of the displayed image you want to keep (you are going to draw a box with the mouse).    You 
are going to Crop out (throw away) the rest.    Hold down the left mouse button and drag diagonally 
across the image drawing a box around the portion you want.

Open the Image menu and select Crop.    Photo Factory will re-access the Photo CD to retrieve that 
portion of the Image you selected.    This image is now ready for a Slideshow.



Open a New Slideshow
From the File menu, select New and Slideshow. Photo Factory will make a new Slideshow Script window. 
Since it is new, it won't have any images in it yet. Next, we'll put some there.



Assemble Slideshow Script
First, include the open photo in the Slideshow.. Shift, Click, and Drag the photo to the Slideshow 
Script...Your first slide is in.

Place the arrow cursor over an image on the Photo CD Contact Sheet you wish to add to the Slideshow 
Script. Select the image with the mouse (left button) so the image number is highlighted.

Hint: Multiple images may be selected by using the Shift or Ctrl key while selecting images.

Hold down the Shift key while you click and hold the image on the contact sheet. A Hand appears and 
replaces the arrow cursor as you drag. Continue to hold the mouse button and Shift Key.    

Drag the image or images from the Photo CD Contact Sheet to the Slideshow Script window. Release the
mouse button when the hand is over the Slideshow script window.

Hint: Make sure you keep the mouse button and Shift key depressed until you are ready to place 
the image.

Repeat this process until you have several images in the Slideshow Script window.

Related Topics:
Selecting Multiple Images



Selecting Multiple Images    
You can also select multiple images from the contact sheet. If the images are contiguous, click on the 
first image, then hold down the shift key and click on the last image. The images you clicked on, and 
those in between, have been selected. If you wish to select or deselect multiple images that are not 
contiguous, hold down the Ctrl key and click on the images you want. Each will remain selected until 
you click without holding down the Ctrl key. Hold down the Shift key and mouse button as before, and 
drag multiple images into the Slideshow Script window.



Open the Slideshow Editor
Double-click on an image in the Slideshow Script window.    The Slideshow Editor will open with your 
selected image in the center of the screen and the floating tool bar to the left. Click once on the 
eyedropper tool and then click twice to pick up a color you like. This makes the color indicator box at the 
bottom right of the tool bar the color you picked up. Clicking once in the background color box (second 
from the top on the left, under the "A"), makes the background that color. 

Press the OK button when you are done.    Photo Factory will detect that the slide has been edited and 
ask you to save the changes.    Say Yes, and the changes will be in your new Slideshow.

(You can learn about all the other interesting effects in the Slideshow Editor section.)



Run Slideshow
Drag the arrow cursor over the Slideshow Script window and click once to be sure you have the window 
selected.

From the File menu, select Run Slideshow (or hit the F6 key).    Photo Factory will ask you which slides 
you wish to run and if you want to Enable Debugging.    Select the From Slide and To Slide for Photo 
Factory run the Slideshow you have just assembled.

The default time for each slide is 10 seconds. You can press the mouse button or any key to advance 
sooner. (If the next image is not loaded yet, the slide will not advance until the load is complete.) You can 
also select different slide duration times from the slide configuration window.    Enable Debugging will 
display time statistics to help you in slideshow display design....See Slideshow Script Window 
Commands. 

Press the Esc key to stop the slideshow and return to Photo Factory.

Hint: The Esc key is almost always a default throughout Windows as the Cancel or Abort key.    Photo 
Factory uses the Esc key to cancel almost all operations.



Save Slideshow
When you have your Slideshow arranged the way you want it, pull down the File menu and select Save. 
When the Save dialog box appears, give your Slideshow a name and be sure to keep the .sld extension. 
Use the other functions in the dialog box to put the file in the directory you choose.



Open Slideshow
You can open the Slideshow later by pulling down the File menu to Open, and then entering the name of 
the Slideshow you wish to see. Once the Slideshow is open, then you can run it or edit it.



Conclusion
Congratulations! You have just created a simple Slideshow and saved it for later replay. From here you 
can rapidly assemble Slideshows and save them, learning new Photo Factory features as you go. For 
more advanced techniques, go on to the next sections where you will learn how easy it is to add text and 
sound, edit and color-correct images, and save Slideshows on diskettes or as a Screen Saver file.



Introduction
The commands available from the Menu Bar change when    different Photo Factory windows are 
selected. Explore each of the following Chapters to determine what commands are available for each. 
This Chapter discusses the commands and menus available on initial start-up when only the Photo 
Factory Window is open.



The File Menu Commands
When Photo Factory first starts, there aren't any windows open. The File Menu has only four commands 
available when no other windows are selected. In the Quick Start section you have already seen this 
menu change.    This section will take the menu commands in the order they appear in the menu.

Related Topics:
The New Menu
The Open Menu
Set Photo CD Defaults
Exit



The New Menu
This menu has three selections for creating either a new Image window or a new Slideshow window.

Related Topics:
New Image Window
New Slideshow
Import Slideshow



New Image Window
The new image window will open an empty image window for pasting image from the clipboard.    You are 
asked for the size of the Dib window when the selection is made.    The empty window is opened untitled 
and will remain this way until you save it to a file.



New Slideshow
 Select the Slideshow command when you are ready to create a Slideshow. Photo Factory opens an 
empty Slideshow Script window when you select this command.

When Photo Factory first displays the Slideshow Script window, it is empty. You must click and drag 
images to the Slideshow Script window to assemble a Slideshow.



Import Slideshow 
Select the Import Slideshow command to import a slideshow which has been provided to you.    This 
command allows you to bring in Slideshows from any source (probably your floppy drive) that have been 
exported using the Export command or utility.

When a Slideshow is to be imported, use the Script button to brouse the available paths and Slideshow 
scripts (.LST files).    If the selected file is accompanied by the Runtime Player or Screen Saver, these 
options will be activated for selection in the Import window.    The choices you make determine the 
indicated Disk Space Required.    With the selections made, depress OK and choose the desired location 
to import your choices.



The Open Menu
This menu command has four selections. Point at the item you wish to open, then press and release the 
mouse button.

Hint: Menu items may be chosen by depressing and holding the mouse button as you drag down and 
across the menus. The desired choice is selected by releasing the mouse button when that choice is 
highlighted.

Related Topics:
Open--Photo CD Contact Sheet (Photo CD Files Only)
Open--Photo CD Image
Selecting an Image by Thumbnail
About Image File Sizes
Open--Images from File Manager
Open--Image File
To select an image



Open--Photo CD Contact Sheet (Photo CD Files Only)
This command opens the Photo CD disk as a Contact Sheet, similar to the Contact Sheet you would 
receive at a photographic processing lab. This Contact Sheet displays a small Thumbnail image of each 
of the images on the Photo CD disk, along with a number designator for each image. If there are many 
images on the disk, you may have to scroll the window to see all the images.

At the top of the Contact Sheet you will see the Photo CD Volume number. This is the volume ID number
of that particular Photo CD. When the contact sheet is open, click on the image you wish to edit. When 
you do this, Photo Factory opens the Photo CD image file from the CD and displays it on the screen. The 
image is now ready to edit.

A Photo CD must be inserted in the CD ROM Drive before selecting Contact Sheet or Photo CD Image, 
or an Error message will appear.



Open--Photo CD Image 
When you select the Photo CD Image command in the Open menu, an image selection window appears.
Two different types of window are available:    by Thumbnail or by Filename. The type of window 
displayed depends upon your choice selected in Set Photo CD Defaults ¾discussed later.

Hint: You can also open a Photo CD image by double-clicking on the image in the contact sheet; by Drag 
& Drop or Ctrl/Click in the Slideshow Script window.

The By Thumbnail selection window displays the Photo CD images Thumbnails for choice.    This 
window displays each of the image Thumbnails for selection in a scrolling window.    The By Filename 
selection window lets you see all of the files on the Photo CD by their file name.    A preview window is 
available to see the Thumbnail of the selected file.    Functionally both windows are the same.    The By 
Filename window may be a little faster in display if your computer has a slower video system.



Selecting an Image by Thumbnail
This window not only displays the contents of the Photo CD as Thumbnail images, it also displays the 
resolution, color depth, and size of the images. These parameters are set in the File/Set Photo CD 
Defaults menu, discussed below.    To select an image:

· Scroll up and down with the scroll bars to browse through the images on the Photo CD disk.

· Click once on the image you are interested in to view its parameters. (A thick border appears 
around the Thumbnail to indicate it is selected).

· Select the desired Size and Color depth for display.    (The defaults were set by Set Defaults.)

Hint: Try using Snapshot size for quickest loading and greatest flexibility. This provides a 256 X 384 
photo, which is desirable for displaying multiple photos on an 800 x 600 SVGA display.

· Click twice on the image you wish to load or hit the Enter key.    

· Use the Escape (Esc) key to cancel the load.

Note: If your computer does not have sufficient memory to display the photo image at the selected 
resolution, an insufficient memory error message will be presented.    A lower resolution must be selected 
for viewing, or more memory must be added to your system.



About Image File Sizes
The Thumbnail list box provides an estimate of the memory requirements for the exact image display size
selected.    This table provides a cross reference for all Photo Factory images.

Descriptio
n

Photo CD 
Resolutio
n

Image 
Size 
(Pixels)

24 Bit File 
Size (KB)

8 Bit File 
Size (KB)

Wallet Base/16 192 X 128 73.7 24.6
Snapshot Base/4 256 X 384 294.9 98.3
Standard Base 768 X 512 1,179.7 339.2
Large 4Base 1536 X 

1024
4,718.6 1,572.8

Poster 16Base 3072 X 
2048`

18,874.4 6,291.5

Poster cannot be selected directly from the Open Image File or Select Photo list box.    A 24bit Poster 
image requires at least 19MB of memory. Because of Windows 3.1 memory limitations, Photo Factory 
does not load images larger than 16 MB. Since the Photo CD 24 bit poster image is 19 MB, it cannot be 
loaded full frame. You can load a poster image cropped to less than 85% of its original size. 

Use this procedure to load Poster size:

· Open a Photo CD image at a lower Resolution.

· Crop the image to less than 85% of full size.

· From the Image menu choose Zoom with the highest available Factor.



Open--Images from File Manager
There are two ways to open image formats supported by Photo Factory from the Windows File Manager.

· Double-click on a file¾the installation of Photo Factory associates supported image file 
extensions with Photo Factory. This will run Photo Factory (if it's not already open) and open the 
selected file.

· Drag the file or group of files onto the minimized Photo Factory icon, or into the Photo Factory 
window. 

One example of how to do this is to:

¨ First, start Photo Factory and minimize it to an icon on the desktop. Then, start File Manager 
and position its windows so the files you want to open are visible and the Photo Factory icon 
is visible.

¨ Next, select the file or group of files and drag them to the minimized Photo Factory icon.

¨ Maximize the Photo Factory icon to see the files. If you selected more than one, they will be 
cascaded.



Open--Image File
Use this command to open any of the image types supported by Photo Factory, including Photo CD 
(.PCD) images.

Hint: Opening images by filename is faster in terms of machine performance. Opening By Thumbnail is 
often easier for the user.    This menu selection should not be confused with the Photo CD By Filename 
which is selected by Open Photo CD Image.

When you select Open/Image File, the Open Image File window appears.

Photo CD images as well as other image file formats are listed by file name in the File Name box. Any 
supported image file can be selected and opened in this fashion. The List Files of Type: box lets you 
select only certain file types or all file types. The Drive box lets you specify which drive to search. The 
Directories box shows you the path to the sub directory you presently have active. You can use this box to
change the path to a different sub directory.



To select an image
· Scroll the image list box and highlight the desired image file name by clicking on it.

· Use the Type and Drive boxes to help find the file you want.

· Click OK to load the image for editing or display.

Note:    It is possible to load Image Files that do not have one of the specified extensions.    Photo Factory 
will detect the image format when loading the file.    If you think the file may be a supported format, type 
the file name into the File Name: edit box to attempt the load.    If Photo Factory cannot interpret the 
format, it will inform you of the problem.



Set Photo CD Defaults
This command sets the default values for images you will open on a regular basis with Photo Factory.

When you select the Set Photo CD Defaults command from the File Menu, the Photo CD Defaults window
appears.

When Photo Factory is installed, the installation program will determine the best default settings and store
them for you.    These values will be based on the configuration of your system (video, CD ROM Drive, 
etc.) at the time installation is performed. You may want to check the default preferences if this is your first
session with Photo Factory for Windows. You can change the Photo Factory for Windows defaults at any 
time. 

The Reset button automatically sets all defaults to the values Photo Factory has determined will work best
for your computer. Photo Factory will reexamine your computer when you select Reset, and enter the new
defaults.

The Defaults are stored in a file called PFACTORY.ini.
· First of all, set the default resolution. Click on the list box so you can see the available selections, 

then click on the one you want.    Keep in mind the larger the image selected, the more memory 
the image will need.    In addition, a larger image will require a higher screen resolution to be fully 
displayed.    It is better to start small and use Zoom (discussed later) to increase the size.

Hint: Snapshot is a good place to start.

· Next, click on the Color Mode list box to view the color depth selections available. Choose the 
color depth you want.

¨ Gray Scale sets Photo Factory to display an 8 bit monochromatic (gray scale) tonal range. 
This is useful for images you wish to print on black & white printers.

¨ 256 Color sets Photo Factory to display 8 bit color images by default. 8 bit color is supported 
on most SVGA display adapters at their highest resolution.

¨ 24 bit Color sets Photo Factory to display images in high color (24 bit, 16 bit or 15 bit).    In 
full 24 bit mode (True Color), Photo Factory is capable of displaying over 16 million colors. 
Your display adapter and Windows display driver will determine your actual display mode.

· Click on either by Thumbnail or by Filename. This selects the type of window displayed by 
Open/Photo CD Image.

· Select the Default CD ROM Drive letter to be used for loading Photo CD images. The default 
used by Photo Factory is the first CD ROM Drive found when your computer is examined. If a 
different drive is desired, or a drive was not detected by Photo Factory, you will need to enter the 
letter.

Note: If no CD ROM Drive was detected on installation of Photo Factory, you were asked to supply one. 
To use a different drive, enter the letter here. If the drive is a Network Drive, you must provide the letter in 
setup or here. In all cases, the CD ROM Drive    entered must be Photo CD Compatible.

· Select disable sound by clearing the Enable Sound check box if your system is not equipped with 
a Sound board.    This will prevent getting error messages when you play Slideshows that include 
sound.    You may also use this selection to turn sound off when playing Slideshows.

When you have selected your default parameters, click on the OK button.
Note: If your computer is capable of displaying high color or True Color images, you must select an 
appropriate display driver with the Windows Setup utility before you can satisfactorily display 24 bit 
images. Some Windows display drivers have 15 or 16 bit settings (32 or 64 thousand colors). These will 
work equally as well as the full 24 bit color settings.



Exit
The File/Exit command closes Photo Factory. If you have performed editing tasks or made other file 
changes, Photo Factory will prompt you to save the changes before it quits.



Edit/Window Menu Commands
If there are no windows open within Photo Factory, these menus will have no functional selections. The 
only edit selection possible at this level is Paste New images from the Windows Clipboard.    This option 
will be active if the Clipboard contains an image in DIB format. This is the only format which Photo 
Factory will import from the Clipboard. (See the Edit menu description in the    section.)

Note: The Paste New    option will be dimmed-out (grayed) if you have no DIB images in the clipboard.



Photo Factory Key Strokes 
Photo Factory provides special keys and key combinations to aid you in working more effeciently. Some 
of these are dedicated to the type of window you have selected. All except Key/Mouse Button 
combinations are presented in the Menus with their appropriate function.    Below is a table of the 
combinations:

Keys Active Window Function
Shift+Del or 
Ctrl+X

Slideshow Only Cut to Clipboard - Deletes a slide and copies it to the 
Clipboard

Ctrl+Ins or 
Ctrl+C

Image or 
Slideshow

Copy to Clipboard - Copies a slide or selected image

Shift+Ins or 
Ctrl+V

Image or 
Slideshow

Paste New - Adds a new image to a Slideshow or Image
Window

Ins Image Only Transparent Paste or Paste into
Del Slideshow Only Delete - Removes a slide without copying it to the 

Clipboard 
F2 Any Select an Image File to load into a New Image Window
F4 Image Only View the selected Image Full Screen 
F5 Slideshow Only Configure Slide 
F6 Slideshow Only Run Slideshow (Last Slideshow selected)
Ctrl+Left Mouse Contact Sheet Randomly adds image selections (For multiple slide 

selections)
Ctrl+Left Mouse Slideshow Opens an Image Window for a selected slide in a 

Slideshow
Ctrl+Left Mouse Image Drag and Drop an image to replace an existing slide in a

Slideshow
Shift+Left 
Mouse

Image or Contact
Sheet

Drag and Drop a new image or images into a Slideshow.
Allows range selection of images in a Contact Sheet 
(See Contact Sheet). 

Mouse Double-
Click

Contact Sheet Loads the selected image into a new Image Window

Mouse Double-
Click

Slideshow Loads the selected slide into the Slideshow Editor

File Menu
When a Contact Sheet window is selected, nine commands are available under the File Menu.

Of these commands, four will perform the same tasks as described in the Photo Factory Window 
Commands section.    Refer to the table below for the reference section containing detail on these menu 
items (see the Index).

Command Section Name Heading Sub-Heading
New Photo Factory Window 

Commands
File Menu 
Commands

New Menu

Open Photo Factory Window 
Commands

File Menu 
Commands

Open Menu



Set Photo CD 
Defaults

Photo Factory Window 
Commands

File Menu 
Commands

Set Photo CD 
Defaults

Exit Photo Factory Window 
Commands

File Menu 
Commands

Exit

Related Topics:
Preview Images
Convert Images
Print
Select Printer
Photo CD Volume Information



Preview Images
The Preview Images command provides a full screen display of each image on the Photo CD for the 
Contact Sheet selected. This is a "quick view" Slideshow of all images on the Photo CD.    The images will
display at the size defined by Set Photo CD Defaults, with a ten second delay between images. The 
Photo CD Image file name appears in the upper, left-hand corner of the screen.

Hint:    The Color Mode and Resolution (size) are as selected in Set Photo CD Defaults.    The image 
display rate will vary with photo load time (color, disk and computer).

Press the Space Bar to pause an image display, and the Space Bar again to continue with the preview.

Press the Esc key to interrupt preview and return to Photo Factory.

Note:    If the Space Bar has been used to pause the display, you must press the Space Bar a second 
time to end the pause before the Esc key will interrupt the preview.



Convert Images
The Convert Images command lets you block convert one or more images you have selected on the 
Contact Sheet. You can convert the Photo CD images to any of the other supported file formats. This 
command is very handy for quickly getting your Photo CD Images into a file format on your Hard Drive.

Hint: This feature is useful for transferring your Photo CD Images to another computer or for use in a 
distributed Slideshow. You may also use this to save images which your computer cannot display.

You may store images in sizes from Wallet to Large with a color depth from 256 colors (8 bit) to 16 
million colors (24 bit) per pixel.    You may also convert them to a Gray Scale color format.

· Select the images on the contact sheet you want to convert.

Hint: Use the Shift and Ctrl keys for multiple image selections.    Select the first image in a contiguous 
group,    hold down the Shift key and select the last image.    Randomly select Images with the Ctrl key 
depressed.

· Select Convert Images from the File menu.

· Select the drive you want your files stored on in the Drives list box.

· Select the PCD Resolution you want your image files converted from in the PCD Resolution list 
box.

· Select your desired Color Depth in the Bits Per Pixel list box.

· Select the file format you want your Photo CD files converted to in the Output Format list box.

· Select if you want your files stored in Color or Gray Scale with the select buttons at the bottom of 
the window.

· Click OK when you are ready to convert your image files.

After you click OK, Photo Factory displays a progress bar to let you know the conversion's progress. 

Related Topics:
About JPEG Compression



About JPEG Compression
If you selected JPEG compression, Photo Factory asks you to decide how much compression versus how
much quality you require. That is, the better the quality, the less the file compression factor. Since the 
JPEG compression standard does have some image losses, maximum file compression will yield patchy 
looking images.    But, you can achieve as much as a 100:1 file compression ratio.

As compression ratios go down, subjective image quality improves significantly.

 Hint: Enter relative compression value (1-254) or adjust the compression /quality to give the image 
display quality you require.    You may use Photo Factory to display different compressions of the same 
image to decide which is best. The affect will vary between images.



Print
The Print command prints the entire Contact Sheet with each image approximately the size of an original 
35mm film frame. The Photo CD volume number is printed at the top of the page and the image number 
is printed next to the lower, left hand corner of each image. Images are printed at the maximum density 
possible, depending on your printer and the paper size loaded in it. For example, on an HP Deskjet 500 
with letter paper, the images are printed four up; that is, four to a row, eight rows to a page. Portrait 
images are automatically rotated 90 degrees so that all the images will have the same orientation.

The Print Contact Sheet command is extremely useful for producing a compact hard copy of all the 
images on your Photo CD. The contact sheet quality is particularly good when output on color dye 
sublimation printers, rivaling that of actual photographic contact sheets. Gray Scale quality is also quite 
acceptable, even on an inexpensive ink jet printer.

Here's how to do it:

· Select the desired printer from the File/Select Printer dialog box.

· Select File/Print    with the desired Contact Sheet active.

· Select your resolution between 128 dpi (Dots per Inch) and 256 dpi.

Hint: The 128 dpi resolution provides good quality. The 256 dpi resolution provides better quality, but 
takes up to five times longer to print.    The print time depends on the computer, printer and the amount of 
work to be done.

· Select between Color or Gray Scale.

· Select if you want your images printed Portrait or Landscape.

· Select OK.

After you select OK, print processing begins and you will see the familiar Windows progress bar, letting 
you know the status of your print job.



Select Printer
The Select Printer command brings up the familiar Windows printer selection window. Click on the 
Windows printer you wish to direct your output to and press OK. You can also select the Setup button in 
this window to configure your printer.



Photo CD Volume Information
When you select this command from the File menu, Photo Factory displays information about your Photo 
CD disk.

This information applies to the disk for the Contact Sheet that is active. Because Photo Factory may have 
contact sheets open for more than one Photo CD at a time, make sure you have the right one active 
before you select this command.    The Serial Number for a Photo CD is etched on the inner clear ring of 
the CD. All images used in a Slideshow are tagged to this Serial Number.



Edit Menu
Two commands are available under the Edit Menu when a Contact Sheet is selected as the active 
window.    These two commands augment the selection capability of Photo CD images from the Contact 
Sheet for making Slideshows or    Converting image files.

Related Topics:
Select/Deselect All
Random Selection--Ctrl + Click
Range Selection--Shift + Click



Select/Deselect All
Use these commands when you wish to use all the contact sheet images, or wish to de-select a group of 
images you have already used. Photo Factory highlights an image's number designator when it is 
selected.    In addition to Select All and    the individual Image selection, there are two other selection 
capabilities.



Random Selection--Ctrl + Click
You can select random images on the contact sheet by holding down the Ctrl key and clicking on the 
image you want. The Ctrl key acts as a toggle, so you can randomly de-select an image by clicking on it 
again while holding down the Ctrl key.



Range Selection--Shift + Click
You can select a range of images on the contact sheet by clicking on the first in a range and then, while 
holding down the Shift key, click on the last image in the range. For example, click on image 2, hold down 
the Shift key and click on image 11. Images 2 through 11 are selected and highlighted.



Window Menu
The Window menu will remain the same for all Photo Factory window types selected.    Because most of 
the function of this menu is used when multiple Image Windows are open, complete descriptions of its 
Commands are covered in the The Window Menu section.    However, if you open a Photo CD Contact 
sheet and select the Window Menu, you will see that a number beside Contact Sheet for the Photo CD 
Volume: The ( Ö ) beside the window indicates it is active.    All windows open will be listed here.



Introduction
This section takes you through each of the Image Editor menus, as they occur. You have started the 
Image Editor when you open an Image File Window. Notice that many, but not all, of the menu commands
have changed in the Image Editor. However, most of those that have not changed will have new 
selections.



File Menu
The File Menu is only slightly different when the Image Window is active. The functions of the New, 
Open, Select Printer, Set Photo CD Defaults, and Exit will be the same as described in the previous 
sections.    The Print selection has the same name, but will perform different from the description in the 
Contact Sheet Window Commands.    The new item in this menu is Save View.

Related Topics:
Save View
Print



Save View
The Save View selection from the File Menu saves the currently active image in various file formats. You 
will get a different dialog box dependent upon what type of image you have selected.    If the image is an 
original Photo CD image, you will get the Save Bitmap File window.

Related Topics:
Photo CD images
Non-Photo CD images
File Formats



Photo CD images
From this window you may select the File Name, location (Directory and Drive) to be saved, File Format 
(File Type) to save the file as, Resolution (Image Size) and Color Depth (Image Format) to be used.    A 
unique advantage of this file save capability is that you may choose a different Resolution and Color 
Depth from that of the displayed image.    Photo Factory will load the new information directly from the 
Photo CD in performing the Save.    This is the same process used when you chose Convert Images for 
a Contact Sheet.
Hint:    If the Image selected for Save View was Cropped, Rotated, Mirrored, Flipped or Zoomed, the 
image is saved directly from the Photo CD. It is saved at the Resolution and Color Depth selected, with 
instructions for the edits performed.    An image loses its Photo CD attachment only if you alter its color, 
apply filters or use resize.

The Image Formats define the color depth of the image to be loaded by Photo Factory for saving.

The available formats are:

24 Bit    True Color

256 Color    8 Bit w/ palette

Gray Scale 8 Bit    w/ palette.

Note:    JPEG is always in 24 Bit.

The available Image Sizes are:

Wallet (192x128)

Snapshot (384x256)

Standard (768x512)

Large (1536x1024)



Non-Photo CD images
If the image you select is non-PCD (Open Image File), or was altered by applying Filters, Color 
Corrections (except Color Depth), or Resize it will no longer save from the original Photo CD image. The 
image will now save in the Color Depth and Resolution displayed. Because you may no longer select 
these items, the Save Bitmap File window is different.

You no longer have selections for Resolution (Image Size) and Color Depth (Image Format).



File Formats
Photo Factory features the ability to open image files in eight different formats and save image files in 
seven different formats. (You cannot save a file in Photo CD format.)

Here are the available formats:
File Colors Supported Format
Extension 24 

bit
8 bit 4 bit 1 bit Description

BMP Ö Ö Ö Ö Windows Bitmap Format
DIB Ö Ö Ö Ö Device Independent Bitmap
TIF Ö Ö X Ö Tag Image File Format
TGA Ö Ö X Ö Targa
JPG Ö Ö X X Joint Photographic File Interchange 

Format 
GIF Ö Ö X X Bulletin Board Systems    (256 color)
PCX            Ö Ö Ö Ö Paintbrush

The ( Ö ) indicates supported Color mode.



Print
You can use Print    to give you a Full page image print while maintaining the aspect ratio of the selected 
image.    For a high quality print, use the larger image sizes in your display.    The larger the displayed 
image size, the more information is available to the printer.    A side effect of this technique is that the print 
process will take longer.    You will need to experiment with your printer to find the optimum trade off.

Hint:    Only the best (400 dpi) Dye Sublimation color printers will benefit from the largest image format. 
(The maximum image size supported by Photo Factory is 16 MB).



The Edit Menu
There are seven commands available in the Edit Menu when there is an Image File open for editing. Each
of the commands in the Edit Menu relate to selecting or moving portions of the image. The portion may 
also be All.

Hint:    The items in this menu which require a selection to function are dimmed-out until a portion of the 
image is selected.

Related Topics:
Select All
Clear Selection
Copy to Clipboard
Paste Into
Paste to New
Rectangular Select
Irregular Select



Select All
Choosing this command selects the entire image for copying, pasting into, etc.    A box is drawn around 
the entire image when you have selected all of the image.



Clear Selection
Select this command to undo or de-select the selection you have made. 

Hint:    You can click the right mouse button to de-select, too.



Copy to Clipboard
This command copies the selected area to the Windows clipboard. Only one thing at a time can reside on 
the clipboard, and the information on the clipboard is temporary. It is used as a transfer media between 
Windows programs. Review your Windows documentation for more information about using the clipboard.

Photo Factory copies DIB and BMP formats to the clipboard.



Paste Into
This command puts the image on the clipboard into the image window you have open and selected. After 
performing the Paste, the cursor turns into a four-way cursor when you are over the pasted image.    Click 
and drag the image you have just pasted    where you want. Double-click or hit the Insert key when you 
are satisfied with the location of the pasted image.

 If you decide to not insret the image, you may abort the operation with the Delete or Esc keys. Once the 
Paste Into operation is complete (i.e., you have double-clicked or inserted), there is no Undo.    However,
the image is still in the Clipboard, so you can attempt the Paste Into again on another image window. 
This is a good place to use Clone for the image to receive the paste.

When using the Paste Into or Paste New commands, only DIB format is supported. Ensure that the 
program used to copy the original to the clipboard supports DIB format.

Hint: You can check the image content and file type in    the View menu of the Clipboard Viewer utility, 
after the object is copied.

Related Topics:
Transparent Background (24 bit only)



Transparent Background (24 bit only)
If the image you are pasting is on a white background (source image), the white background becomes 
transparent on the target image, seeming to disappear. This is very useful for seamless pasting of images
onto other images.

Some 16 bit display modes will not support transparent paste.    It has to do with the drivers definition of 
White. Most 24 Bit display modes work OK.



Paste to New
This command pastes the contents of the clipboard into a new image window.    This window will have the 
name *Clipboard until the image is saved.

Hint: An asterisk (*) before the name in the window title denotes a non- Photo CD image format that is not
yet saved.



Rectangular Select 
This command lets you click and drag the mouse to define a box from corner to corner. You can adjust the
size of the box after you have defined it by grabbing one of the handles on the box with the cursor and 
dragging it where you want.    When the selection box has been defined, you can move it around the 
image window by clicking the mouse and dragging the box.    A Hand will appear in the box.

Clicking the right mouse button de-selects whatever you have selected.

Hint: When drawing a selection box in a large image (larger than the image window), the image will auto 
scroll to allow selection of an area larger than the Image Window.    This is handy for capturing a large 
portion of an image at the highest    resolution.



Irregular Select
This lets you use the mouse as a free-form selection tool. The selected area is copied to the Clipboard in 
both BMP and DIB formats. The color depth copied is as set for the selected image.

· Click and hold the mouse button down and drag the cursor around the area on the image you 
wish to select.

or
· Click from point-to-point around the object you wish to select.
· Click twice to release the cursor.
· Copy the item to the clipboard.

This is an ideal place for you to use the transparent background described earlier.

Note: Be sure to turn Irregular Select off when you are through using it (i.e., click on Rectangular Select). 
Some other commands won't work while Irregular Select is on.



The Image Menu
The Image Menu lets you manipulate the image itself by cropping, zooming, mirroring, rotating, resizing, 
etc. There are ten available commands under the Image Menu and numerous pop-up menus associated 
with them.

Note: Certain commands and filters are unavailable unless you are working on a 24 bit image. 
Unavailable commands are dimmed-out.

Related Topics:
Crop
Zoom (Photo CD Images only)
Mirror
Flip
Rotate
Resize
Filter (24bit display only)
Clone Picture
View Full Screen (F4)
Image Info...



Crop 
This works just like traditional photo cropping. The Crop tool allows a portion of a photo to become the 
new image. 

Note: For the Crop tool to be available, a Rectangular image area must be defined for the selected 
window. An Irregular area may not be cropped.

Here's how to crop an image with Photo Factory:

· Move the mouse pointer to a corner of the cropping area.

· Hold down the left mouse button and move the pointer to the diagonal corner of the cropping 
area. Photo Factory "auto-scrolls" the image, if necessary.

· When the mouse button is released, the image inside the rectangle is the part to be kept. (The 
image outside is "cropped out.")

· The area selected may be altered by grabbing one of the box "handles" with the left mouse button
and dragging the handle.    The area may be moved by grabbing inside the area and moving the 
area.    The cursor changes to a hand.

· After the area has been selected, choose CROP from the Image Menu.

Hint: A cropped Photo CD image is still treated as an original Photo CD image by Photo Factory.    A 
copied or saved image that is cropped, is as good as the original.



Zoom (Photo CD Images only)
Zoom is a handy way to work with Photo CD images. You can start with a Snapshot or Standard. Then, 
crop it to the image area you wish, and finally zoom to the required finished size.

The Zoom tool makes a portion or all of the image into a new image at lower or higher resolution. The tool
automatically accesses the Photo CD disk to the selected resolution, and displays the portion of the 
image that you marked. Each time you use the Zoom tool, a new Photo CD resolution is loaded from your
Photo CD disk.    The current color depth may allow only certain Zoom Factors to be available.

Select the area to be zoomed as described in Cropping, above.

Then, select Zoom from the Image Menu; a second menu allows    you to choose either Zoom In or Out.    
A third menu allows you to choose the zoom factor. From here the full five resolution capacity of the Photo
CD format is available.

Caution: When Zooming to a higher resolution, it is possible to describe an area which will require more 
memory than is available. If this should occur, an Insufficient Memory Error will be presented. Selecting 
OK from the message box should return to the currently selected view. Then, select a smaller area to be 
Zoomed.



Mirror 
This tool lets you produce a reverse or "mirror"    image of the selected Photo. Selecting Mirror a second 
time displays the original image.



Flip 
Flip moves the image 180 degrees around the horizontal axis. This is the equivalent of a mirrored image 
rotated 180 degrees.



Rotate 
The Rotate option lets you turn the image around the center axis in either direction in 90 degree 
increments.

Note: As with a cropped    image, a mirrored, flipped or rotated Photo CD image is still treated as an 
original Photo CD image by Photo Factory.



Resize 
The Resize tool lets you change an image's size.    It is mainly used for resizing images that are no longer 
in Photo CD file format (images that have been edited, imported, etc.)or to off- size Photo CD images. 
Enter new width or height values to resize the image. Select Maintain Aspect Ratio and only enter one 
value, Photo Factory will calculate the other. 

Note: If an image is made larger with this function, apparent detail is lost. An original Photo CD format 
image that is resized is NO LONGER a PCD image. An * appears in the title bar until the New image is 
saved.    



Filter (24bit display only)
Filters let you add sophisticated special effects to your images quickly and easily. Photo Factory provides 
four ready to use filters and a user-definable custom filter. The standard filters are Enhance Detail, 
Soften, Edge Detect and Emboss.

Hint: Try using the Negate Image command in combination with the Edge Detect and Emboss filters

Each of these is useful for different effects. The Enhance and Soften filters allow you to alter the 
sharpness of the image's appearance. Embossing is a visual special effect used by more sophisticated 
presenters, including the broadcast television networks, on posters, etc. A discussion of the user-
definable filter feature is located in Appendix A.

Filters only work on 24 bit color images. Furthermore, once a filter is applied to an image loaded from a 
Photo CD, the image is no longer in the Photo CD file format.    This is a perfect application for Clone.    
(Of course, your original Photo CD image is still preserved on your Photo CD disk.)

Related Topics:
Enhance Detail Filter
Soften Filter
Edge Detect Filter
Emboss Filter
User Defined Filters



Enhance Detail Filter
This filter affects the contrast between the pixels. It will sharpen the image in five steps from Sharpen 
(min) to Heavy.



Soften Filter
This filter will reduce the contrast between pixels in the image.    The image detail is reduced in three 
steps, Averaging through Blur. Use it to calm heavy areas in an image.



Edge Detect Filter
This produces several types of solarized or line drawing effects.    Of the first three filters, the first one 
produces the greatest affect.      It finds edges, either sharp or subtle, and enhances them.    There are 
three general edge detect levels, LaPlace 1 through LaPlace 3.    The Gradient, Horizontal Edges and 
Vertical Edges filters will only affect specific types of edges.



Emboss Filter
This filter is ideal if you want to make posters.    It produces a raised 3D embossed effect by making 
shadows at image edges.    This filter works best on high contrast images.



User Defined Filters
This Photo Factory feature allows you to define your own custom filters.    You may use this capability to 
Load an existing filter into the Filter Matrix, modify the filter and Save it as your own custom filter.    All 
pre-defined filters are available in the filters to load list box.    This allows you even to create special 
effects filters for very specific jobs or images.

Although the concept of making filters may be a little difficult to grasp,    you might enjoy the effects they 
have.    For a detailed explanation on defining a Filter Matrix, refer to User Filters in Appendix A.



Clone Picture
The Clone tool lets you duplicate the selected photo quickly and easily. It will open a new Image Window 
with the duplicate image.

Hint: Clone the photo first! Try different filters and tools on a clone of the original photo to see if you 
like the result. Then, save the cloned image. It's faster and easier.

Note: Your Photo CD image is always safely archived on your Photo CD disk¾it cannot be altered or 
damaged by Photo Factory for Windows.



View Full Screen (F4)
This command displays the currently selected image window as large as possible on your screen. Select 
this command from the Image Menu or press function key F4. Press the Esc key to return to Photo 
Factory.

Hint: If the Image is too large to be displayed on the screen, it is automatically reduced.    However, 
smaller images are not resized.



Image Info...
Selecting the Image Info... command from the Image Menu causes Photo Factory to display a window 
with the current image's specifications.    Selecting the Photo CD Information button within this window 
provides complete specifications on the CD containing the image.



The Color Control Menu
About Color
Color Control
Gamma Correct
Negate Image
Color Balance
Increase Contrast (24bit)
Brighten Shadows (24bit)
Brighten Midranges (24bit)
Color Depth



About Color
Now, a few words about color. Every human sees color a little differently. And, every monitor's phosphors 
and electron guns are a little different. Add to this complexity the color variations with ambient room light, 
background, etc., and you can see that color is a relative thing. Therefore, it is nearly impossible to 
duplicate color exactly. However, with a computer and Photo Factory we can get much closer than was 
previously possible.



Color Control
The Color Control Menu is only available when an image window is open. You must open an Image File 
for Photo Factory to make the Color Control menu available on the tool bar.

Seven commands or sub-menus comprise the Color Control Menu. The Increase Contrast, Brighten 
Shadows, and Brighten Midranges commands are not available unless you have loaded a 24 bit color 
depth image file.

Hint:
· Run Windows in 24 bit, 16 bit or 15 bit color mode whenever possible. 

· Use 24 bit color when you want your images to look most life-like.

· Use 8 bit color when you want to conserve image memory.

· Use gray scale when you want to print black and white originals to make photo copies from.



Gamma Correct
The Gamma Correct command from the Color Menu boosts or reduces the gamma (brightness/contrast) 
of your image. A gamma value of less than one makes the image darker; a value greater than one makes 
it brighter.

Hint: A very small amount of gamma correction has a dramatic effect. Try reducing in the range of 0.8 to 
0.9 and increasing in the range of 1.1 to 1.3.

Use the Gamma Correct tool to brighten apparently dark images or darken images that are apparently too
light. Gamma changes the apparent "brightness" of an image without affecting very dark or light areas of 
an image. This makes for a pleasing "brightness" adjustment.

Note: When you apply any of the Color Control commands, the displayed image is altered, and is no 
longer in Photo CD format. The original Photo CD image on the disk remains unaltered.



Negate Image
The Negate Image command from the Color Control Menu lets you create a photographic negative effect 
on the image. Light, dark, and color values are reversed.



Color Balance 
The Color Balance command provides three sliding controls.

These controls vary the amount of primary color in the image: red, green, blue.

Photo Factory generates color on your computer screen by combining the primary colors red, green, and 
blue, in different percentages. Here are some suggestions for color adjustments.

Image... ...Change ...Or Change
too Red decrease Red increase Blue and 

Green
too Green decrease Green increase Red and 

Blue
too Blue decrease Blue increase Red and 

Green
too Cyan increase Red decrease Green and

Blue
too 
Magenta

increase Green decrease Red and 
Blue

too Yellow increase Blue decrease Red and 
Green

too Dark increase 
Gamma

increase RGB

too Light decrease 
Gamma

decrease RGB

Increase Contrast (24bit)
The Increase Contrast command on the Color Control Menu lets you increase image contrast without 
varying brightness.



Brighten Shadows (24bit)
The Brighten Shadows command on the Color Control Menu is very useful for "bringing up" the image in 
shadows, without boosting the overall brightness of the image.    A side affect of brightening shadows is to 
decrease image contrast.



Brighten Midranges (24bit)
The Brighten Midranges command on the Color Control Menu is like Brighten Shadows, but with 
Midrange values like faces.



Color Depth
The Color Depth selection on the Color Control Menu provides tools to make specific color depth 
changes. 

· The Gray Scale tool converts the colors in your image to monochromatic tonal values (different 
shades of black and white; i.e., gray). It results in a 256 color gray scale image.

· Halftone Methods tools provide you with Error Diffusion, Oderded Dither and Threshold 
selections for black and white conversions (1 bit or 2 color).    These choices allow you to select 
how the halftones in your black and white image will be dithered.

· RGB to 8 Bit converts a 24 bit RGB image to an 8 bit image.    You may select either Optimum 
Palette, which uses what Photo Factory computes as the best color substitutions in the color 
palette (256 color) with the dithering method selected, or Fixed Palette, which uses the standard 
Photo Factory palette.    This conversion is accomplished by dithering the 24 bit image down to an
8 bit image using the Floyd Steinberg algorithm.

· RGB to 4 Bit converts a 24 bit RGB image to a 4 bit image (16 color), with the same choices as 
RGB to 8 Bit.

· <N> Bit to RGB converts an 8 bit or 4 bit image to a 24 bit image.    This conversion will set the 
image colors based on palette colors and eliminate the palette.    The 1 bit image created in the 
Halftone conversion may be converted back to an 8 bit image.    From this point it may be 
converted to a non-palette image.

· Dithering Methods presents the user with 6 Dithering methods which can be used when 
reducing an image's color depth (i.e., 24 Bit to 8/4 Bit).The No Dither method is only available 
when using the Optimized    Palette options. When selected, the image will be reduced to the 
nearest set of x colors, and all pixels will be mapped to the nearest color.    Any of the other 
methods will apply a dithering method to the color matching step. This dithering tends to smooth 
the transitional boundary between adjacent colors and is applied best to an image containing 
large areas of continuos tones (e.g., skin or sky).    Each method will produce a slightly different 
appearance.

Hint: Use 8 Bit to RGB to convert a 256 color image for filtering, even though the results won't be as good
as starting with a 24 bit image.    Remember, filters may only be used on 24 bit images.

Photo Factory displays the image, according to the default settings set in the File Menu.    If not altered at 
installation, this will be based on the color mode of your display. You can change the default color values 
at any time by selecting one of the available Color Depth options with the File/Set Photo CD Defaults 
command discussed previously.

Note: If the display mode is set to 256 Color or Gray Scale then Windows color palette images should not 
be displayed at the same time. This causes the Windows palette selection to be altered, which will distort 
the images. If you are working in 24 bit color, then displaying both color and gray images is OK.

To allow gray scale and color display at the same time, the Windows display mode must be set to either 
24 bit or 16 bit.    This provides adequate color choices for all display modes to coexist within Windows.

Hint: Attempting to view a photo in 24 bit resolution on a 256 color system will not produce satisfactory 
results.



The Window Menu
Introduction
Tile
Cascade
Arrange Icons
Open Windows



Introduction
The Window Menu is designed to help you arrange multiple windows easily. It will also help you arrange 
icons of windows that have been minimized.



Tile
When you select the Tile command from the Window menu, Photo Factory arranges all of the open 
windows in a square tile pattern. Each window is given an equal size.



Cascade
With Cascade, Photo Factory arranges all displayed photo windows in an overlapping format. This 
selection makes all photo titles visible.    To bring a photo to the foreground, click the left mouse button 
while pointing at the desired window title.



Arrange Icons
When you select the Arrange Icons command from the Window menu, any minimized icons in the Photo 
Factory window move to the lower, left-hand corner of the window.



Open Windows
Multiple windows can be open at the same time. You can select and bring to the front a window on the 
desktop by clicking on its name in the Open Windows list.



Introduction
This Chapter deals with assembling a Slideshow, including images, sounds, background color, timing, etc.
The Slideshow Script Window is the place where you assemble images into Slideshows by dragging and 
dropping images in the order you wish them to appear. These images may be any of eight possible image
file types, an image you have edited from a Photo CD, or an image directly from your Photo CD disk.



File Menu
When the Slideshow Script Window is selected, ten commands are available under the File Menu. Of    
these commands, New, Open, Select Printer, Set Photo CD Defaults, and Exit are the same as 
described in the previous sections. This section will focus on the remaining selections.

Related Topics:
Run Slideshow
Save Slideshow
Save Slideshow As
Consolidate Script
Export Script
Print Script



Run Slideshow
· Select File/Run Slideshow to display each slide in the Slideshow Script Window. When you 

select Run Slideshow, a window will appear requesting the beginning and ending slide number.

· Enter the starting and ending slide you want to see in the Slideshow. 

· Select the Enable Debugging check box to enable the debugging display.

· Select the OK button. 

· The Slideshow will run until it has completed displaying all the slides in the Slideshow Script and 
returns to Photo Factory.

· Press the Esc key to stop the Slideshow and return to Photo Factory.

Background color, each slide's duration, background music, and voice-over for each slide can be selected
with the Slideshow editor, Configure Slideshow, and Configure Slide commands (explained later).

If Enable Debugging was selected the upper left corner of the display contains slide timing information.    
This information is:

Slide: #    Cue: <t> msec    Compose: <t> msec    Cycle: <t> msec
...where t is time in milliseconds.

Heading Description
Slide: # Slideshow Slide Number
Cue: <t> mSec Time required to load all of the resources for the 

slide
Compose: <t> 
mSec

Time required to build the slide bitmap

Cycle: <t> mSec Time required to change slides from the previous 
slide.

The Cycle time is the greater of either the slide time entered in the script, or the total of Cycle, Display 
and other overheads.    Other overheads can include Wave play and system processing.

Hint:    When working with compressed images such as .Jpg or .Pcd it is useful to know these times for 
setting up your slideshow.



Save Slideshow
When you have the images you want in your Slideshow assembled in the proper order in the Slideshow 
Script window, you can save that particular Slideshow to disk. If this is the first time the Slideshow has 
been saved the Save Slideshow As window will appear.



Save Slideshow As
This command lets you save a Slideshow Script which you have modified as another Slideshow Script 
with a different file name. The Save As window lets you choose file name, path, disk drive, and if you want
the Slideshow saved with or without Thumbnails.

Hint: Remove the Save Thumbnails Ö to reduce the size of your Slideshow file.    This is good for making 
distribution diskettes for viewing only.



Consolidate Script
The Consolidate Script command lets you convert all the different file types in your Slideshow Script into 
the same file type. All the MIDI and Wave files used in the Slideshow are copied to the specified 
consolidation directory. It also modifies the script to point to the new files in that specified directory.

Photo CD images will be converted directly from the Photo CD based on the PCD load Option selected. 
Other bitmap images will be converted based on their native color depth and/or palette.

Consolidate Script is a handy way to prepare your Slideshow for export to another computer.    You can 
consolidate your Slideshow Script images into any of the supported image file types.    If you select JPEG 
for the file format, when you press OK, the JPEG Compression/Quality window appears. Otherwise, 
Photo Factory displays a progress bar until the file consolidation is complete.

Hint: You can use Consolidate to "batch convert" the Photo CD images which you cropped, rotated and 
zoomed before they were put into the Slideshow.    The Slideshow in this example will run without the 
photo CD now.

Be sure that the Convert Image box is checked if you want to change image formats. Also make sure 
there is adequate space available on the destination disk to hold the consolidation with images, sound 
and script files.



Export Script
The Export utility compiles all of the files necessary to support a Slideshow and writes them to the 
specified drive.    This selection provides a window to assist in compiling the export.    The window displays
size statistics on the Slideshow including the quantity and space requirements in Image files, MIDI files 
and Wave files.    Because Photo CD Images are displayed directly from the Photo CD, they will not be 
included in the Image file space requirement.    To Export a Slideshow:

· Enter the Slideshow file name in the Script edit box.    Use the Script button to browse for the 
name and path for the desired Slideshow.

· Select the Strip CD Volume Info check box if the Slideshow contains Photo CD Images (this 
option is not dimmed), and you do not wish the Photo CD Volume ID to be include with the slide 
requirement.    

Note:    If this choice is selected, remember that any Photo CD which contains that Image File Number 
may be used for the slide load.    This may not be the actual slide you desired.    This option is most useful 
when duplicate Photo CDs are to be used.    These CDs will not have the same ID.

· Select Export Runtime Player or Screen Saver if the Slideshow is only to be run on the 
importing computer.    This will export all necessary files to allow the Slideshow to be run without 
Photo Factory.

· Select the Export button.    (Note that the total amount of required disk space is dynamically 
updated as you choose the desired options.)

· An additional window will appear for you to choose the destination of the Slideshow.    Use the 
Browse button or enter the path desired.

· Press the OK button and the Export will begin.    The Export button is replaced with an Abort 
button and a progress line will appear.

If multiple diskettes are required, the Export utility prompts you for additional diskettes.    At completion, 
press the Exit button to return to Photo Factory.    All of your choices are now stored on the selected disks.



Print Script
The File/Print Script command prints out the Slideshow script, with Thumbnail images and configuration 
data for each slide in the Slideshow. 

The choices of Thumbnail and Embedded text allow you to reduce the size of the printout by not including
the Thumbnail Image and any text added to each Slide.

The printout also includes:

· Slide title

· Slide number

· Zoom status

· Frame duration in seconds

· Continuation cue

· CD ROM drive where the slide resides

· Photo CD Volume ID

· The image number on the Photo CD disk

· Slide resolution

· Text in slide

· The DOS path to the slide's image

· The DOS path to the slide's Wave file

· The DOS path to the slide's MIDI file

This information is printed for each slide in the Slideshow. Most of this information you provided when you
configured your slides and Slideshow.    These are covered later in this section under the Edit Menu.



Edit Menu
Introduction
Cut
Copy
Paste
Delete
Configure Slideshow
Configure Slide



Introduction
This menu provides options for manipulating the slide configurations in your Slideshow.    The first group 
of commands allows you to alter the order of the slides in the Slideshow, while the second configures the 
slides and Slideshow themselves.



Cut 
Cut allows you to delete a slide from an existing location and place the slide into the Clipboard.    The 
slide is preserved in the Clipboard with all of its configuration data including any Voice and MIDI files 
configured.

Hint:    You can use Cut, Copy, and Paste to move slides within a Slideshow or from one Slideshow to 
another.



Copy
Copy will perform the same task as Cut except the slide is not removed from the Slideshow.



Paste 
Paste will insert a slide stored in the Clipboard in front of the selected slide in a Slideshow.



Delete 
Delete may be used to permanently delete a slide from a Slideshow.    The slide is not copied to the 
Clipboard, so a Delete operation is permanent (There is no Undo).    



Configure Slideshow
When you select the Configure Slideshow command, a window appears to allow you to:

· Give your Slideshow a title.

· Loop the Slideshow - Make the Slideshow play endlessly until the Esc key is pressed.

· Hide Mouse during Play - Hide the cursor while the Slideshow is running.

· Scale Objects to Fit Screen - Scale slides to fit the running computers screen resolution.

· Select the options you wish.

· Click OK

Example: If the Scale Objects to Fit Screen option is selected with a Slideshow created on a 
640x480 machine, and displayed on an 800x600 machine, it will appear the same size. 
However, this    resizing takes some additional time. It's best to try to run the Slideshow 
in the same resolution as created.



Configure Slide
This command calls the Configure Slide window. In this window you will define: 

· The Slide Description.

· Continuation options.

· Display time.

· MIDI play mode.

· Photo CD source and configuration if a Photo CD slide.

· Image File name and path if an Image file slide.

· Wave and/or MIDI file names and paths if desired.

The number of the slide in the Slideshow Script is in the Configure Slide window title area.

To configure a slide:

· Type in information about the slide in the Slide Description box. This text appears on the 
Slideshow Script print out.

· Choose one of the three options for what actions should cause the Slideshow to continue:

· Continue on Mouse Click - This will force the slide to continue when a Mouse Click occurs.

· Continue on Key Hit - This will force the slide to continue when a any key on the keyboard is 
hit.

· Continue on End of Sound - This will hold the slide display until the currently playing Wave 
and/or MIDI file has completed.

· Choose the maximum amount of time you wish the slide to play if none of the Continue on 
options have expired.    This has a maximum of 65 seconds. To make the slide display until the 
Continue on options are met, set the Frame Duration to a -1.

· Choose Loop MIDI if you would like the background music to continue play endlessly (MIDI file).

Hint: The Loop MIDI file will play until another MIDI file is defined or the slideshow is complete.

· Select the Edit Slide Path button to designate background music, voice-over files slide paths and 
Photo CD image configurations.

The upper portion of the window displays information about Photo CD Volume ID, image number, 
resolution, CD ROM drive designator, and display resolution.    This information is automatically provided if
the image is inserted from a Photo CD.

· Click on the MIDI File button to select a MIDI file to play in the background. If the MIDI file is 
looped, it will play continuously as background music for the entire Slideshow.

· Click on the Wave File button to select a Wave file. This file is foreground or "voice-over" sound 
that plays on top of the MIDI file while the slide is displayed.

· If the Image is a Photo CD Image, choose to use either the Default CD Drive or the definitions of 
the Image Path.

· If the Image is not a Photo CD select the Image Path and filename using the Image Path button.

The image file window displays the Photo CD image or image file used for the slide.    

Note: For a non-Photo CD image to be used, the image must be saved as an Image file first.    Images 
may be edited after insertion by depressing the Ctrl Key and clicking the image.    This will open the image
in an image window for editing.    If the image is edited to be a non Photo CD image, the image must be 
saved as an image file before it may be re-inserted.





The Window Menu
The Window Menu menu works the same as discussed in the Image Editor section.



Introduction
The Slideshow Editor is an entirely different edit window. You enter the Slideshow Editor by double-
clicking on an image in the Slideshow Script Window. The slide will be displayed in a full screen window 
with a floating Tool Bar for controlling edits.



Using the Slideshow Editor
About the Slideshow Editor
Using the Tool Bar
Parts of the Tool Bar



About the Slideshow Editor
The Slideshow Editor will display the image exactly as it will be viewed in a slideshow.    It uses a floating 
Tool Bar for all of the editing tasks. In this edit window, the slide not the image is being edited.    Using the 
Tool Bar, you can perform certain editing tasks relating to the Slideshow itself, such as:

· Position the image and text.

· Add text.

· Add a background color

· Add a frame and frame color.

· Enlarge or reduce the image on the screen.

· Set timing (duration on screen).

· Add both music (.mid) and voice(.wav) annotation.

· Print slides as they appear.

· Save the slide layout as an image file.



Using the Tool Bar
You will usually edit a slide with the Tool Bar while displaying your image full size. To open the Slideshow 
Editor, click twice on an image in the Slideshow script window. A full screen window appears with your 
image at its full display size, and a tool bar on the left. This is a "floating" tool bar which you can position 
anywhere on the screen.



Parts of the Tool Bar
The Tool Bar tools are selected by clicking once on the Tool Button desired. Each Tool Bar location or 
button is described below.

Related Topics:
Slide Counter
Text
Move
Background Color
Frame
Magnify
Configure Slide
Play
Eye Dropper
Print
Copy to Disk
Go to Previous
Go to Next
Abort
OK
Color Selector



Slide Counter
The Slide Counter tells you how many slides there are and the current 
slide number. The Tool Bar above shows slide 2 of 6.

Text
This tool lets you add text to the image. When you click on this button, 
point the arrow to a location and click again, an insert window 
appears. Type the desired text in the insert window. If you want to 
move the text, click on the move image tool. Then, move the hand 
cursor over the text. Click and hold the mouse button down on the text 
and drag it where you wish. You can also move text you have just 
typed by holding down the shift key and dragging the text window.

Selecting Text Attributes
You can change the color, style, and font by selecting the text and then clicking twice on the text itself. 
This brings up a dialog box with typeface, text color, style, etc. Choose the text attributes you want from 
this box.



Move 
This tool lets you move things around. Just click on the button 
converting the cursor to a hand. Then, click and drag the object you 
want to move. Use this tool for moving text as well as the image itself.

Background Color 
Click this button to make the background behind the image the color 
which is in the Color Selector box (lower right box on the Tool Bar).    
See Color Selector below for changing this color.

Frame 
Click this button and a window appears asking how many pixels wide 
you want the frame (2 to 10 is a good starting place). Type in the width
you want and click O.K. The frame appears around your image. Notice
that the frame is the same color as in the color selector box. If you 
would like a different color, select it with the eye dropper tool 
(described below) and repeat this step.

Magnify
Magnify controls the size of the slide on the display monitor. This 
button will toggle between displaying your slide full-screen, and 
displaying it at the normal size.    The full-screen display will always 
maintain its correct aspect ratio.

Configure Slide 
This button will select the Configure Slide dialog box described in the 
Edit Menu. The dialog box configures the Slide attributes of each slide.
The slide number being configured is indicated in the title bar. 

Select the appropriate check box for Slideshow continuation with the Continue on options. The Frame 
Duration box lets you set the duration your image will be on the screen in seconds. You can also add 
MIDI and Wave sound to your Slideshow and slides (MIDI for background music; Wave for voice-over on 
each slide). 

The Frame Duration may be set for up to 65 seconds.    If you want the slide to continue until one of the 
Continue on options is performed, enter a -1 for the Frame Duration.

Click on the Loop MIDI check box to make the MIDI file play continuously during the Slideshow. Add a 
Wave file to each slide to provide voice-over. Click on the Edit Slide Paths button to define wave and MIDI
files and their paths. Click the OK button when you're done.



Play
Click this button and Photo Factory will play the music files associated 
with this slide. Press the Esc key to stop the play.

Eye Dropper 
Use the eye dropper tool to "pick up" color. Click once on the eye 
dropper to replace the cursor with the tool. Then, point at a desired 
color and click once to pick up the color. Hit the Esc key to close the 
tool. The selected color is indicated in the Color Selector box.

You can also double-click to pick up the color and close the tool in 
one operation.

Print 
You can print your slides, along with background color, text, and frame 
with this tool. Photo Factory supports printing in both color and black 
and white on most high-quality printers, including bubble jet and dye 
sublimation color printers. The printed resolution will be the same as 
the displayed resolution.

Copy to Disk 
Clicking on this button copies your slide to your hard disk. This is the 
image plus all additions you have made in designing your slide.    The 
slide may be saved in any of the seven supported file formats to any 
disk and path you select.

Go to Previous
This button steps you to the previous slide in the order you placed 
them into the Slideshow window.

Go to Next 
This button steps you to the next slide in the order you placed them 
into the Slideshow window.

Abort    
This button cancels all edits performed on the current slide and returns
you to the Photo Factory window.

OK
....saves your work and returns you to the Photo Factory Window.



Color Selector 
This button shows the currently selected background color. You can select the background color and 
border color with the eyedropper (above) or by clicking the Color Indicator. This brings up the color palette
where you can select any color.



Creating Distribution Disks
About Distribution Diskettes
Distribution Slideshow Considerations
Building Distribution Disks



About Distribution Diskettes
You may find it useful to assemble a Slideshow and copy it to    diskettes for viewing by someone else. 
With Photo Factory, all you have to do is create a distribution diskette and send it to its recipient. Of 
course, your recipient must also have a computer running Windows 3.1 or later and a VGA color monitor. 
Your recipient must also have sound capability to hear the sound portion of your Slideshow.    In Photo 
Factory this is called Export and Import.    The Export operation will copy all of the necessary files to 
support your slideshow to diskettes.    The Import will install these files on the recipient's computer.



Distribution Slideshow Considerations
You can get much more information on a diskette if you consolidate your Slideshow images using a 
compressed image format before exporting it to diskettes.    This operation is performed by the Colsolidate
tool of the Slideshow File Menu.    You should also consider the recipient's computer system in 
consolidating the Slideshow before export.

Related Topics:
Distribution with Photo CD's
Distribution for non-CD Drive Systems
Screen Size Considerations



Distribution with Photo CD's 
If the Slideshow is to be distributed with a Photo CD, leave all images in the Photo CD format.    This will 
take less diskette space in the Export operation.    The Photo CD ID and Drive Letter may be removed 
before the process allowing the Import utility to install the default CD drive for the recipient's computer.



Distribution for non-CD Drive Systems 
If the recipient's computer does not have a CD Drive all Photo CD images should be converted to a file 
format.    The best format to use is JPEG.    This format will compress the images in High Color to 
manageable file sizes for the distribution diskette.    

If the recipient's computer is slow or will not display in high color modes (i.e., 15, 16 or 24 bit color) the 
JPEG images will take longer to display.    An alternative to JPEG is to change your images to 256 color 
images using the standard (Fixed) palette before converting them to a file format.    The recommended file
format for storing these images is GIF.

For a fast Slideshow with Graphic Images (not true color pictures), consider using 4 bit (16 color) bitmap 
images.

In all cases the Consolidate tool is the best tool for performing the mass conversion of    your Slideshow 
images.



Screen Size Considerations
In the Configure Slideshow options, you may choose "Hide Mouse during Play" and "Scale Objects to 
Fit Screen" before saving or consolidating your Slideshow.    These choices must be made before the 
Slideshow is exported to affect the recipient's version.    The Hide Mouse option is self explanatory, but the
Scale Objects option needs your consideration.    Although this is handy in assuring the recipient's slides 
will scale properly to display as you created them, regardless of his screen resolution, this process will 
take time in running the Slideshow.    To eliminate this unnecessary time, you should save the Slideshow 
in the resolution of the recipient's display.    This allows the recipient's Slideshow playback to look exactly 
like yours, and to run as efficiently as possible.



Building Distribution Disks
With the Slideshow properly configured for distribution, given all of the considerations above, choose 
Export Script from the Slideshow File Menu.    You may also use the Export utility by selecting it directly 
from the Icon.

To Export a Slideshow:

· Enter the Slideshow file name in the Script edit box.    Use the Script button to browse for the 
name and path for the desired Slideshow.

· Select the Strip CD Volume Info check box if the Slideshow contains Photo CD Images (this 
option is not dimmed), and you do not wish the Photo CD Volume ID to be included with the slide 
requirement.    

Note:    If this choice is selected, remember that any Photo CD which contains that Image File Number 
may be used for the slide load.    This may not be the actual slide you desired.    This option is most useful 
when duplicate Photo CDs are to be used.    These CDs will not have the same ID.

· Select Export Runtime Player or Screen Saver if the Slideshow is only to be run on the 
importing computer.    This will export all necessary files to allow the Slideshow to be run without 
Photo Factory.    If the Slideshow is to be a Screen Saver, the recipient will need to select Photo 
Factory in the Control Panel to activate the Slideshow as a Screen Saver.

· Select the Export button.    (Note that the total amount of required disk space is dynamically 
updated as you choose the desired options.)

· An additional window will appear for you to choose the destination of the Slideshow.    Use the 
Browse button or enter the path desired.

· Press the OK button and the Export will begin.    The Export button is replaced with an Abort 
button and a progress line will appear.



Installing Distribution Disks
To install the distributed Slideshow, it is Imported to the recipient's computer.    If the recipient has Photo 
Factory, the Slideshow may be imported by selecting the Import Icon or by selecting New from the File 
Menu and choosing Import Slideshow.    

Related Topics:
Importing a Slideshow with Photo Factory
Importing a Slideshow to Run



Importing a Slideshow with Photo Factory
To Import a Slideshow:

· Enter the Slideshow file name in the Script edit box.    Use the Script button to browse for the 
name and path for the desired Slideshow.

· Select either Import Runtime Player or Screen Saver, if they are highlighted, and the Import is 
not into Photo Factory.    These options will be available if the selected distribution disk contains 
these files.

· Select the Import button and enter the destination for the Slideshow.    Use the Browse button or 
enter the destination directly.

· Select OK to begin the import.

A progress bar is presented to indicate the progress of the installation, and it will disappear when the 
installation is    complete.    If you where importing the Slideshow with the Runtime Player, the Runtime 
Icon is installed in a Photo Factory Group of Program Manager with the name of the Slideshow.    The 
recipient may run the Slideshow by selecting the player icon.



Importing a Slideshow to Run
To import a Slideshow from diskettes on a computer that does not have Photo Factory installed, the 
process is similar to installing any windows program.

· From the Program Manager, select    File Menu, then Run.

· Enter the appropriate    disk drive letter followed by :\Setup.exe (e.g., a:\Setup.exe). 

· The Import window will then be displayed as described in Import from Photo Factory above.

At the completion of the Import procedure the Photo Factory Group will be created with an Icon for the 
Slideshow.



Introduction
In the installation of Photo Factory, you were given the option of allowing a Photo Factory Slideshow to be
used as Windows Screen Savers. When this option was selected the Photo Factory installation program 
did most of the work for you. It modified the Windows' .ini files to add Photo Factory for Windows to the 
Screen Saver list in the Windows Desktop Control Panel. This allows you to make your own Screen Saver
using the Photo Factory Slideshow Script Window and select it for automatic play with the Windows 
Desktop Control Panel. If you didn't make this selection when you installed Photo Factory don't worry, we 
will tell you how to add it now.



Adding Screen Saver Capability
Initial Installation
Installing Later



Initial Installation
When Photo Factory initially installs, you are given installation options to choose from. One of the options 
is Screen Saver.    With this selection, the installation program modifies the Windows .ini files and adds 
Photo Factory Slideshow capability to the Screen Saver.



Installing Later
If you didn't select the Screen Saver in the initial installation, you may do this now.    Simply perform the 
same steps as the first time, except only choose Screen Saver. (Refer to Installing Photo Factory for 
Windows in the Installation section for more detail.)

Hint: Don't worry about the message warning you of overwriting the existing files, Photo Factory Setup will
not hurt any of your existing files.



Enabling the Screen Saver
Creating a Screen Saver
Turning On a Screen Saver



Creating a Screen Saver
You create a Screen Saver Slideshow the same way you would create any other Slideshow. You can add 
any images you wish and play MIDI or Wave sound files.

Hint: When the screen saver is enabled in Windows, you will be given the choice of playing the sound, so 
you won't have to use it all of the time.

There are a couple of tips that could be helpful:

· Add images that are files instead of Photo CD images, so you won't require a Photo CD to play.    
You could use the Consolidate Convert to store PCD images as files.

· Since the Slideshow will continually Loop as a Screen Saver, you should use multiple slides 
placed in different positions on the screen to really save your screen.

Hint: To protect your screen even better, use different background colors as well.

· Use the End of Sound continue option on the last slide to prevent assure all sound files have 
completed play before the Slideshow repeats.



Turning On a Screen Saver
Select the Windows Control Panel from Program Manager and open the Desktop Control. Open the 
Screen Saver selection box and choose Photo Factory.

Now, select the Setup button and enter the Slideshow name. 

Use the Browse to make finding the Slideshow and correct path easier.

You may also enable Password protection to the Screen Saver. This will prevent anyone else from gaining
access to your computer while it is unattended.

Select Play Sound Files if you wish and Select OK. In the control, choose a time for the show to start and 
Select OK again.

You now have a Slideshow as a Screen Saver....



User Filters
The purpose of the User Defined Filter option is to give the Photo Factory user the ability to implement 
filter functions which may not be already supported. The filter is described as an array of values which, 
when combined with the image pixels, transforms the image. 

The array of filter values is referred to as the Filter Kernel. The Kernel Size is defined by the X and Y 
dimensions in the Dialog Box and is always an Odd size (e.g. 3x3, 3x5). These values default to 3x3, but 
may vary between 1 and 7. Once the dimensions are defined, the appropriate Kernel matrix fields will be 
enabled for you to enter values. As in most Windows dialog boxes, use the Tab key to move between edit
fields.

Once the Kernel matrix is filled in, you must calculate and enter the proper SCALE value. This value is the
Sum of Kernel Values and is typically either 0 or 1. However, some filters may have a larger Scale factor 
(e.g. Blurring Filters). As a rule of thumb,    Kernels with a SCALE of 1 or larger will retain the original 
image, but Kernels with a Scale of 0 result in a threshold image.

The Bias field allows the user to specify a value which will be added to the pixel of interest after the Filter 
function has been calculated. This value can be used to scale the Brightness of the resultant pixel up or 
down. The affect of this value can be seen in the Emboss Filter where it is set to 128 and produces the 
Grayish color.

The Filter function calculates a Weighed Sum for the pixel of interest. The Filter Kernel is combined with a
matrix of image pixels in the following manner:

pixel value = ((p0k0 + ... + piki)/scale)) + bias

The pixel of interest always lies in the center of the matrix, hence the requirement for odd sizes. Note that 
if the Kernel element is 0, the corresponding image pixel will have no effect in the calculation.

As an example, look at a typical sharpening filter. Sharpening Kernels accentuate the edges of an image. 
This sharpens the image by brightening the pixels whose value varies greatly from neighboring pixels, 
leaving the other pixels largely untouched.

Related Topics:
A typical Sharpening Kernel:
Photo Factory Kernels



A typical Sharpening Kernel:
0 -1  0

-1  5 -1

0 -1  0

The above kernel has a Scale value of 1 and typically has no Bias. This filter has the affect of highlighting 
pixels which differ both horizontally and vertically from its neighbors. The diagonal variations have no 
affect. 

-1 0 -1

0 5  0

-1 0 -1

Conversely, the above Kernel would accentuate the diagonal differences.

As the center number becomes larger, the affect of the neighboring pixels can be reduced. This is used to
reduce the harshness of a filter. The harshness of the Kernel can be reduced by changing the 5 to an 8 
and adjusting the Scale value appropriately (i.e., 4). 

The affect of any Image Filter is dependent on the image content, and a Filter that produces a desirable 
effect on one image may totally destroy another. 



Photo Factory Kernels
Enhance Detail
Soften
Edge Detect
Emboss



Enhance Detail 
Heavy -1 -1 -1 Scale = 1

-1  9 -1 Bias      = 0

-1 -1 -1

Medium 0 -1  0 Scale = 1

-1  5 -1 Bias      = 0

 0 -1  0

Light 1 -2 1 Scale = 1

-2  5 -2 Bias      = 0

1 -2 1

Sharpen  0 0  0 Scale = 1

-1 3 -1 Bias = 0

 0 0  0

Sharpen (min)  0 -1  0 Scale = 8

-1 12 -1 Bias =0

 0 -1  0

Soften
Blur 1 1 1 1 1 Scale = 25

1 1 1 1 1 Bias    = 0

1 1 1 1 1

1 1 1 1 1

1 1 1 1 1

Low Pass 0 1 0 Scale = 6

1 2 1 Bias    = 0

0 1 0

Averaging 1 1 1 Scale = 9

1 1 1 Bias    = 0

1 1 1

Edge Detect
LaPlace 1 0  1 0 Scale = 1

1 -4 1 Bias    = 0

0  1 0



LaPlace 2 -1 -1 -1 Scale = 1

-1  8 -1 Bias = 0

-1 -1 -1

LaPlace 4  1 -2  1 Scale = 1

-2  4 -2 Bias    = 0

 1 -2  1

Gradient -1 0 0 Scale = 0

0 1 0 Bias    = 0

0 0 0

Horz Edges 0 -1 0 Scale = 0

0  1 0 Bias    = 0

0  0 0

Vert Edges  0 0 0 Scale = 0

-1 1 0 Bias = 0

 0 0 0

Emboss
1 0  0 Scale = 0

0 0  0 Bias = 128

0 0 -1

A special filter function exists which is called the Identity Filter. This is defined as the kernel which is the 
image itself.

0 0 0 Scale = 1

0 1 0 Bias    = 0

0 0 0

This kernel can be added to any other kernel and has the effect of adding the Filtered image back onto 
the original. This is used with kernels with a Scale of 0.



Glossary of Terms
1 bit
15 bit
16 bit
16 color
16 million Color
2 color
24 bit
256 Color
4 bit
8 bit
8 bit Gray Scale
Byte
CD-ROM
Clipboard
Clone
Crop
Desktop
DIB
Diskette
File Manager
Flip
Floyd Steinberg
Gray Scale
Gray Scale
Halftone
high color
Icon
JPEG
Kernel
KODAK Photo CD
List Box
Megabyte
Microsoft Windows
Mouse
Palette
Pixel
Program Manager
SVGA
Thumbnail
True Color
VGA
Zoom



1 bit
(2 color) Refer to Halftone.



15 bit
( 32 thousand Color )A graphics display format which provides a 15 bit word to describe the color of a 
single pixel of display.    In 15 bit mode, each pixel may contain 32,768 possible colors.    When a 24    bit 
image is loaded into a computer configured for displaying in 15 bit color, the colors are interpreted to the 
closest fit within the 32,768 available colors.    This mode will provide a high quality color image, but 
requires less computer resources to display.



16 bit
(64 thousand Color) A graphics display format which provides a 16 bit word to describe the color of a 
single pixel of display.    In 16 bit mode, each pixel may contain 65,536 possible colors.    When a 24    bit 
image is loaded into a computer configured for displaying in 16 bit color, the colors are interpreted to the 
closest fit within the 65,536 available colors.    This mode will provide almost a true color image, but 
requires less computer resources than the 24 bit mode to display.



16 color
Refer to 4 bit.



16 million Color
Refer to 24 bit.



2 color
(1 bit) Refer to Halftone.



24 bit
(16 million Color or True Color) A graphics storage format which provides a 24 bit word to describe the 
color of a single pixel of display.    In 24 bit mode, each pixel may contain 16,777,216 possible 
colors¾more that the human eye can see. 24bit color images show smooth curves and diagonals and 
shadows (no jags or patching).    This is considered all possible colors and gradation of colors available. In
this mode any color may be created without the use of a palette. 



256 Color
Refer to 8 bit.



4 bit
(16 color) A term used to describe the number of possible colors available for display at one time. This 
graphics format is stored in 4 bits. In this mode the specific colors may be selected by defining a palette 
containing each of the 16 possible colors. 4 bit color is available in the Standard VGA default available in 
the Windows VGA driver. 



8 bit
(256 Color) A term used to describe the number of possible colors available for display at one time. This 
graphics format is stored in 8 bits. In this mode the specific colors may be selected by defining a palette 
containing each of the 256 possible colors. 8 bit color looks pretty good with only minor jags and patching.
Most computers use 8 bit color. 8 bit color uses less memory to display images.



8 bit Gray Scale
This term is used to describe the monochromatic tonal range (gradations of black and white) used to 
display a color picture.    Like 256 Color, a palette of shades is created to display the image as a gray-
scale representation. 8 bit Gray Scale is the least demanding of all on your computer and is useful for 
printing images that will be copied on office copying machines, etc.



Byte
(Pronounced "bite") a sequence of adjacent bits operated upon as if they were a single unit.    A grouping 
of eight bits is called a byte in most computer systems.    A bit is a binary digit.    It is the smallest unit of 
data in a computer system. 



CD-ROM
Acronym for Compact Disc Read Only Memory¾a compact disc that stores large quantities of information
in read-only format.



Clipboard
A Microsoft Windows application which may be used to transfer information and images between various 
Windows programs.



Clone
The creation of a duplicate image window within Photo Factory for Windows.    This clone will maintain all 
of the characteristics of the original image loaded.



Crop
A method of discarding portions of an image which are not desirable.    Cropping is accomplished by 
selecting the portion of the image desired, discarding the remaining periphery of the image.



Desktop
A term used in Microsoft Windows to describe the background area of a window.    This is the area 
confined within the Windows program window if this program uses the MDI interface standard.



DIB
Device Independent Bitmap - This is a universal image bitmap format used by OS/2 and Microsoft 
Windows.    Photo Factory will only accept Windows RGB encoded (no compression) DIB formats when 
pasting images from the Clipboard. 



Diskette
A portable magnetic storage media used in computer systems.    Standard sizes used are 5.25" and 3.5" 
with storage capabilities from 360 kilobytes (360,000 bytes) to 1.44 megabytes.



File Manager
A Microsoft Windows application program for conveniently moving program and data files within computer
disk drives.



Flip
The rotation of an image around the horizontal axis.    This is the equivalent to rotating the image twice in 
the same direction.



Floyd Steinberg
This is one of the most common methods for selecting colors for the palette. It will    diffuse the error to the
neighboring pixels. 



Gray Scale
Refer to 8 bit Gray Scale.



Gray Scale
A term in computer display which provides monochromatic tonal values for color images (see 8 bit Gray 
Scale).



Halftone
(2 color) This is a black and white image with no shades of gray.    It is also called 1 bit.



high color
Refer to 15 bit or 16 bit color.



Icon
A term used in computer programs to describe an image which represents either a program or program 
item.    In Photo Factory for Windows, the photo Thumbnails are used as the Icons for the window 
containing that Photo.



JPEG
"Joint Photographic Expert Group" file format.    As applied in Photo Factory for Windows, this is the JPEG
File Interchange Format JFIF.    This format supports 24 bits per pixel and 8 bits per pixel gray scaled 
images.



Kernel
This term is applied to the Filter Kernal in Photo Factory for Windows. A Filter Kernal is the matrix of 
pixels which are used to calculate the value of each pixel. In filters, each pixel is adjusted in color and 
intensity by applying algorithms, or formulations based on the values of the surrounding pixels. The 
number of pixels used is the Kernel.



KODAK Photo CD
A (C) Compact (D) Disc containing a special Image compression format created by Eastman Kodak 
company for photo storage.



List Box
A selection window within a Microsoft Windows program which allows convenient access of choices with 
a mouse and on screen pointer (or arrow).



Megabyte
From the term Mega meaning million, a megabyte is one million bytes.    (See also byte)



Microsoft Windows
An IBM PC DOS compatible program created by Microsoft Corporation which produces a complete 
operating environment for Windows' Application programs like Photo Factory for Windows ™.



Mouse
A style of computer control device which allows the operator to move an arrow on the display by moving 
the device, and select program actions by pointing the arrow and depressing buttons on the device.



Palette
A group of colors which provides the choices necessary in image presentations.    The number of colors 
are defined by the color mode selected (e.g. 16 color-4 bit, 256 color-8 bit, etc.).



Pixel
A pixel is the smallest resolution element in a video display. It may be considered the same as a dot of 
display. For example, a video system set to 800 x 600 pixels will have 800 colored pixels in the horizontal 
direction and 600 in the vertical.



Program Manager
A Microsoft Windows application which allows easy access to programs by storing their program calls as 
Icons within groups (or display windows).



SVGA
An acronym for Super VGA.    This is a computer display resolution beyond the standard VGA capability.    
This term may apply to any number of VGA resolution capabilities beyond that of the standard.



Thumbnail
A term referring to a single, miniaturized image that appears on an index print of the Photo CD.    This 
same image is used in selecting the photo for view.



True Color
Refer to 24 bit.



VGA
An Acronym for Video Graphics Array.    This is a standard of computer display resolution which defines 
the screen as divided into 480 lines containing 640 dots (pixels) per line.



Zoom
A method of selecting a portion of an image and magnifying the selected portion.    Like cropping, the 
periphery portion is discarded, and the selected portion is magnified by the selected factor (times 2, times 
4, etc.).



Hint: Double-click is clicking the Left Mouse Button twice in quick succession.



Hint: The Photo Factory installation will not make all file associations for File Manager.    You may add the
associations if desired.



Hint: Click on the RESET button if you are not sure what defaults to set.



Note: The Zoom factors allowed are based upon the resolution of the display image.




