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Series II Commands
The following list maps Tango PCB Series II commands/operations with their equivalent PCB 
commands, where equivalents exist.    

The bolded terms on the left are the Series II commands, followed by their respective equivalent PCB 
commands/operations, which are non-bolded and indented.

For example:

Series II or PLUS command
Equivalent ACCEL PCB V2.00 Command/Operation

For more information on specific PCB commands, refer to their respective sections by way of the 
Contents or Search buttons in this on-line system.    The Series II to PCB command/feature mapping is
as follows:

Current Layer; or <L>
Options Layers; or <L>; or click on combo box on Status Line; or click scroll bar on Status Line

Current Line
Options Current Line

Current Pad
Options Pad Style

Current Text
Options Text Style

Current Via
Options Via Style

Delete Arc
Select arc, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Block
Select block, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Component
Select component, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Highlight
Select net using Edit Nets or select a segment of net <Right Mouse> Select Net, Edit Delete; or 
<Del>, or <RightMouse> Delete

Delete Line
Select line, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Pad



Select pad, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Polygon
Select polygon, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Text
Select text, Edit Delete; or <Del>, or <RightMouse> Delete

Delete Via
Select via, Edit Delete; or <Del>, or <RightMouse> Delete

Edit Arc
Select arc, Edit Properties; or <RightMouse> Properties

Edit Component
Select component, Edit Properties; or <RightMouse> Mroperties

Edit Line
Select line, Edit Properties; or <RightMouse> Properties

Edit Pad
Select pad, Edit Properties; or <RightMouse> Properties

Edit Polygon
Select polygon, Edit Properties; or <RightMouse> Properties

Edit Text
Select text, Edit Properties; or <RightMouse> Properties

Edit Via
Select via, Edit Properties; or <RightMouse> Properties

File Clear
File New

File DOS
Select DOS prompt from Program Manager

File Load
File Open; see also File Gerber In; See also File DXF In

File Quit
File Exit

File Save
File Save; File Save As

File Save (ASCII)



File Save (ASCII); File Save As (ASCII)

Info Measure
Edit Measure; or click Toolbar Measure icon

Info Pad/Via
Select Component <RightMouse> Properties or Edit Properties Pattern Pads.    For vias, select via 
<RightMouse> Properties or Edit Properties.

Info Status
File Design Info, click "Statistics"

Jump Component
Edit Components, Select Ref Des, Jump

Jump Location
View Jump Location

Jump Net
Edit Net, Select Net, Select Net Node, Jump to Node

Jump Pad_Center
Not applicable in ACCEL PCB

Jump Text
View Jump Text

Keys, <K> to Record/Stop, <E> to execute
Macro Record/Stop; Macro Delete; Macro Rename; Macro Run; Macro Assign To Key, <M> to 
Record/Stop; or click "M" on Status Line, <E> to execute

Library Add
Select pattern entities, Library Pattern Save As

Library Browse
Accessed in Place Component dialog box

Library Delete
Library Delete

Library Merge
Library Copy

Library Rename
Library Rename

Move Arc
Select arc, Drag; Move to Layer to move between layers



Move Block
Select block, Drag

Move Component
Select component, Drag

Move Endpoint
Select segment, Drag handle to re-size

Move Line
Select line, Drag; Move to Layer to move between layers

Move Pad
Select pad, Drag

Move Polygon
Select polygon, Drag; Move to Layer to move between layers

Move Reroute
Route Manual

Move Text
Select text, Drag; Move to Layer to move between layers

Move Via
Select via, Drag

Nets Clear
Not applicable in ACCEL PCB

Nets Display
Edit Nets, Show Conns, Hide Conns

Nets Generate
Utils Generate Netlist 

Nets Highlight
Select net item, <RightMouse>, Select Net; or Edit Nets Select Net, click "Select"

Nets Identify
Select net, <RightMouse>, Net Info; or look on status line; or View Zoom In to see; or Edit Nets, 
Select Net click "Info"

Nets Load
Utils Load Netlist 

Nets Optimize
Utils Optimize Nets, Utils Load Netlist, Choose Optimize Nets checkbox 



Nets Reconnect
Utils Renumber, Utils Load Netlist, Choose Reconnect Copper checkbox

Nets Route
Route Manual

Nets Verify
Utils DRC, Netlist Compare option

Output Apertures
File Gerber Out, click "Apertures"

Output CAM
File N/C Drill; and File Gerber Out

Output Plot/Print
File Print; and File Printer Setup; For DXF Output, use File DXF Out

Output Reports
File Reports

Place Arc
Place Arc; or click Toolbar Arc icon

Place Block Copy
Select region or item, Edit Copy, Edit Paste; Edit Copy Matrix; or <RightMouse> Copy Matrix; or 
<Ctrl-LeftMouse>, drag and drop copy; see also Options Block Selection

Place Component
Place Component; or click Toolbar Component icon

Place Designator
Utils Renumber

Place Line
Place Line; or click Toolbar Line icon

Place Pad
Place Pad; or click Toolbar Pad icon

Place Polygon
Place Polygon; or Place Copper Pour; or Place Keepout; or Place Cutout; or click Toolbar icons

Place Text
Place Text; or click Toolbar Text icon

Place Via
Place Via; or click Toolbar Via icon



Setup Communications
Windows Program Manager, Main, Control Panel, Ports

Setup Display
Options Display

Setup DRC
Utils DRC

Setup Grids
Options Grids

Setup Libraries
Library Setup

Setup Options
Options Configure

Setup Palette
Not applicable in ACCEL PCB

Undo, or <U> to Undo
Edit Undo; or <U> to Undo; or click Toolbar Undo icon

Zoom All
View All

Zoom Board
View Extent

Zoom Center; or <C>
View Center; or <C>

Zoom In
View Zoom In; or <+>

Zoom Last
View Last

Zoom Out
View Zoom Out; or <->

Zoom Redraw
View Redraw

Zoom Window; or <Z>
View Zoom Window; or <Z>; or click Toolbar Zoom icon



Other Keyboard Shortcuts:
<E> to play default macro

<E> to play default macro

<F> to flip items
<F> to flip items

<R> to rotate items
<R> and <Shift-R> to rotate items

<O> toggle ortho modes
<O> to toggle ortho modes, <F> to flip 

<U> unwinds placed routes
<Backspace> unwinds placed routes

<Arrow> to move cursor
<Arrow> to move cursor

<Shift-Arrow> moves 10X
<Shift-Arrow> moves cursor 10X

<Esc> exits commands
<Esc> exits commands

<RightMouse> cancels dragging
<RightMouse> cancels dragging

<?> on status line for help
<F1> for help, Help

<K> to start/stop Macro Recorder
<M> or Macro Record/Stop

<M>, or <SpaceBar>, or <DoubleMouse> to access menu
<Alt> or <F10> to access menu

For more information on specific commands, refer to their respective sections in this help system.    Use 
the Contents or Search help buttons for easy access.



Shortcut and Special Use Keys 
Alt+F4 (File Exit)

Shortcut for File Exit, which exits the ACCEL program.    If the current design has been modified 
since the last save, you will be prompted (YES or NO) as to whether you want to save the changes 
to the file.    The program will write information to the PCB.INI file when you exit.

Alt + mouse click
For any click-and-drag or drag-and-drop operations, you can hold down the Alt key, click the left 
mouse button, then move or drag the object wherever you want without having to keep the mouse 
button depressed.    Without the Alt key, you would normally have to click and drag with the button 
depressed while you are dragging.

arrow keys
A directional arrow key moves the cursor to the next grid point.    If Ctrl+arrow, then the cursor is 
moved 10 grid points, which can be used to pan the screen.

Ctrl+C (Edit Copy)
A shortcut for Edit Copy.    Copies objects from your design to the clipboard.

Ctrl + Mouse Click    (drag and drop copy)
You can copy-and-drag an object by first selecting the object, holding down Ctrl and clicking the left 
mouse button in the selected object region, and dragging a copy of the object to a location and 
releasing to paste it.

Ctrl+N (File New)
A shortcut for File New.    This command opens a window containing a new, untitled window

Ctrl+O (File Open)
Displays the File Open dialog, from where you can choose a file.

Ctrl+P (File Print)
Displays the File Print dialog, where you can set options for your output.

Ctrl+S (File Save)
Saves changes to the current design without closing it.    To save the design to a different file, use 
File Save As.    To clear the workspace, use File New.

Ctrl+V (Edit Paste)
A shortcut for Edit Paste.    You can paste objects from the clipboard to the your design.

Ctrl+X (Edit Cut)
A shortcut for Edit Cut.    Cuts objects from the design to the clipboard.

Ctrl+Z    (Edit Undo)
A shortcut for Edit Undo, which reverses a completed action.    If you have not completed your 
action (e.g., you are in Place Line mode and have not finished a series of segments), Undo will not 
reverse the action.    Use the backspace key to unwind the unfinished actions when you are in a 
placement mode.



Ctrl+F4

Closes the active window.

Ctrl+F6    and Ctrl+Tab

Switches focus to the next window.    Use Ctrl+Shift+F6 or (Ctrl+Shift+Tab)to switch focus to the 
previous window.

Shift+T    (Move to Layer)

Move to Layer shortcut.

Shift+F4    (Window Tile)
Shortcut for the Windows Tile command.    Windows are resized and arranged side-by-side so that 
all windows are visible and none overlap.

Shift+F5    (Window Cascade)
Shortcut for the Windows Cascade command.    All windows overlap, starting in the upper-left corner
of your Workspace.    You can see each window's title, making it easy to switch between windows.

Del    (Delete)
Deletes all selected objects.

F1 (Help)
Displays the Help Contents window, from which you can access help information on ACCEL 
commands and tutorials.

Page Down
Scrolls one page down in the workspace. Ctrl+Page Down scrolls one page right. 

Page Up
Scrolls one page up in the workspace. Ctrl+Page Up scrolls one page left. 

Spacebar
The spacebar can be used in place of the left mouse button; but the action is different.    To simulate
a typical click and release of the mouse button, you need to press and release the spacebar twice.   
Therefore, to simulate the click and hold mouse action, you press and release the spacebar once.

As the left mouse button is used in such a variety of ways throughout the ACCEL program, this 
spacebar keystroke can become a regular part of your work.

Backspace    (Unwind)
Used as unwind command while placing objects with multiple segments (e.g., lines, polygons, route
manual).    Each backspace    stroke unwinds the previously placed item.

Esc    (Escape)
Terminates placement of objects with multiple segments; it also cancels a redraw in progress.    It is 
often equivalent to the right mouse button.    Esc also exits from dialogs (equaling the Close or 
Cancel button), which is a common Windows feature.

+ Plus Key    (Zoom In)



Shortcut for View Zoom In command.    The keypad plus key also works.    The plus key causes a 
zoom in to occur at the cursor location.    Refer to the View Zoom In command documentation for 
more information.    The plus key does not change the cursor to a zoom cursor (as do the zoom 
commands from the View menu).

- Minus Key    (Zoom Out)

Shortcut for View Zoom Out command.    The keypad minus key also works.    The minus key 
causes a zoom out to occur at the cursor location.    The minus key does not change the cursor to a 
zoom cursor (as do the zoom commands from the View menu).

A key    (Grid Toggle)
Toggles between absolute and relative grid settings.

C Key    (View Center)
Shortcut for View Center command.    This command allows you to center your cursor location.    
Place the cursor in the area of your design that you want centered and press C.    Repeated uses of 
the C key can be used to pan across the workspace.

D Key    (Increment RefDes)
Increments the RefDes if while the Place Component tool is enabled.    use Shift+D to decrement 
the RefDes.

E Key    (Play Macro)
Plays back (executes) the temporary macro (named DEFAULT).    Temporary macros are recorded 
by activating the macro toggle button (or the M key) to begin recording, and deactivating the button 
to end recording.    Each successive temporary macro overwrites the previous one.    Refer to the 
Macro Record/Stop command documentation (in this Reference manual) for information about the 
temporary macro and the macro toggle button.

F Key    (Flip Object)
Flips an object during place and move operations.    Not all objects can be flipped.    Refer to the Edit
Select command (in this Reference manual) for more information about flipping objects.

The F key also toggles between orthogonal mode pairs; see the Options Configure command for 
details on orthogonal modes.

G Key    (Grid Select)
This key scrolls forward through the list of grid settings.    Use Shift+G to scroll back through the list.

J Key    (Enter Coordinate)
Gives focus to the X coordinate box in the status line.    From there, you can enter new X and Y 
coordinates.

L and Shift+L Keys (Change Layer)
L cycles downward through the board layer list, duplicating the function of the down arrow on the 
layer list/combo box on the Status line.    Shift+L cycles upward through the layer list.

M Key    (Record Macro)
Duplicates macro toggle button (M button on the Status line) for starting/stopping recording of the 
temporary macro (see E key description).    Refer to the Macro Record/Stop command (in this 



Reference manual) for information about the temporary macro and the Macro toggle button.

O and Shift+O    Keys (Orthogonal Mode)
O sequences forward through the orthogonal modes during placement of line objects or manual 
routing; Shift+O sequences backward throughout the modes.    The F key toggles between 
orthogonal mode pairs.    Orthogonal modes are set in the Options Configure dialog box.    Refer to 
Options Configure for more information.

Q Key (Draft Mode)
Turns draft mode on and off. 

R and Shift+R keys (Rotate) 
R Rotates objects 90 degrees during Place and Select operations.    Shift+R rotates objects by the 
rotation angle specified in the Options Configure dialog box.    For more information about rotating 
objects with Place and Select operations refer to the Edit Select command.

ACCEL Tango PCB allows rotation increments of 90 degress only.    Thus both R and Shift+R rotate 
an object 90 degrees. 

S Key (Select)
Shortcut for the Edit Select command (also the toolbar Select button).    When enabled, you are able
to click on objects to highlight them, then move, rotate, delete, duplicate, and otherwise modify 
them.

U Key    (Undo) 
Shortcut for the Edit Undo command, which reverse a completed action.    Refer to the Edit Undo 
command for more information. For the unwind feature, refer to the backspace key description in 
this section.

Y Key    (Options Layers) 
Shortcut for the options Layers command.    This key opens the Options Layers dialog.

W Key    (Line Width Scrol) 
Scrolls forward through the list of line widths established in the design.    Use Shift+W to scroll back 
throught the list.

X Key    (Cursor Style) 
Toggles between the three cursor styles: Arrow, Small Cross, and Large Cross.

Y Key    (Options Layers) 
Shortcut for the Options Layers command.    This key opens the Options Layers dialog.

Z Key    (Zoom Window) 
Shortcut for the View Zoom Window command.    Just press Z and then draw the zoom window; a 
zoom cursor (magnifying glass) will display until you draw the zoom window.    Whatever you 
surround with the zoom window will fill the screen.    

Slash Keys (/ or \)



Stops a route in mid-connection without adding a final copper segment.    A backward slash 
functions identically to a forward slash.





File Menu (PCB)



File New
Opens a window containing a new, untitled window.    

The File New command clears the styles,    sheet definitions, and sheet sizes for the new design.    All 
design parameters are returned to their default settings.



File Open
Opens an existing file using the Windows standard File Open dialog.    If the design isn't currently 
loaded, this command creates a new window and loads the design.    If the design is already loaded, 
this command creates a new window on the design; it doesn't reload the file from the disk.    This is the 
same as the Window New Window command.

When you choose Open, PCB displays a dialog from where you can choose the directory and filename 
of the file you want to open.    The Directories area displays the current path and a list of your immediate
directories from which to change the path.    The File Name area lists all the files of the current directory,
with the extension specified in the List Files of Type area.    Notice that your default file extension 
is .PCB.

You can use the drag and drop method for opening PCB design files (.pcb) from the File Manager or 
other Windows file maintenance Utils.    Just click on the filename in the utility and drag it to the PCB 
window or reduced icon and release.    The specified PCB design file will open.    

PCB can read ASCII files as well.

To Open a File
1. Run the File Open command to open the File Open dialog.    

2. Type, or select from the list, the name of the file you want to open in the File Name box.    

3. If the file you want is not in the current directory, then either type the directory name in front of the
document name, or select the directory from the Directories box.    You can move through the 
directory tree by selecting the appropriate directories from the list.

note:
Global and local attributes in PCB design files are merged when the files are loaded from 
versions 3.05 and earlier.

4. Click OK.

To Open a Recently Used File
You can quickly open any of the last four files you worked on; their names appear at the bottom of the 
File menu.    Just open the File menu and click the name of the file you want to open.    The most 
recently opened file will be the one at the top of the list.

ACCEL Tango PCB

If any of the design limits are exceeded, your design cannot be opened using ACCEL Tango PCB.
See also:

Opening an ASCII File
Opening a P-CAD Binary File



File Close
Closes all windows for the active design. 

If the design has been changed but not yet saved, you are asked whether or not you want to save your 
changes before closing.      If you close the last design, it is automatically replaced with a new, untitled 
design.



File Save
Saves the changes to the design in the active window and creates a backup file (.BAK).    

When you select File Save, the file remains open so you can continue working on it, and the backup file
is copied.    The current file name and location are unchanged by this command.    To save a new 
(untitled) file or the current file to a different name or location, use the File Save As command.

Pending Engineering Change Orders (ECOs) must be appended to an ECO file or discarded when a 
design file is saved.    If there are pending ECOs, the Save ECOs dialog appears.

1. The ECO filename appears at the top of the dialog.    It is the last used ECO file.    To change it, 
click the ECO Filename button and the ECO Filename dialog appears.

2. The ECO Filename dialog is a standard File Save dialog.    Type, or select from the list, the name 
of the ECO file you want to use in the File Name box.    Click OK to return to the Save ECOs 
dialog.

3. In the Comments box, type any comments that can help document the ECOs.

4. To append ECOs to the ECO file, click the Append ECOs to File button.

5. To discard ECOs, click the Discard ECOs button.    Once discarded they cannot be recovered.

Net Classes
Net classes are saved to binary and ACCEL ASCII design files.    Pre-Sequoia binary files will be post-
processed after loading so that net classes can be automatically created from nets with CLASS 
attributes.    This will only be necessary for designs that used the CCT router.

ACCEL Tango PCB

If any of the design limits are exceeded, your design cannot be opened using ACCEL Tango PCB.
See also:
Saving an ASCII File



File Save As
Saves the current design to a specified file name and location and creates a backup file (.BAK).    You 
can either name a new file or save an existing file to a new name (if there is an original file, it remains 
the same). 

This command displays the Windows common File Save As dialog, from where you can choose the 
directory and enter the filename you want to save the changes to.    The Directories area displays the 
current path and a list of your immediate directories.    The File Name area lists all the files of the 
current directory with the extension specified in the Save File as Type area.    Notice that your default 
file extension is .PCB.

To save a file to a name and location:

1. Select File Save As and the dialog is displayed.    

2. Type the filename you want to use in the File Name box.    

3. If the current directory is not appropriate, then either type the directory name in front of the 
document name, or select the directory from the Directories box.    You can move through the 
directory tree by selecting the appropriate directories from the list.    

4. Make sure the extension is correct by checking the Save File as Type box.

5. Click OK to save the file as you have specified.

If there are pending ECOs, you are prompted to save them.    Refer to the File Save command 
section for detailed instructions.

ACCEL Tango PCB

If any of the design limits are exceeded, your design cannot be opened using ACCEL Tango PCB.
See also:
Saving an ASCII File



File Clear
Clears the workspace and resets the title bar.    

When you choose Clear, you will be prompted to save changes to the current file before it is cleared 
from the workspace.    The File Clear command does not clear the style or layer definitions setup by 
Options Pad Styles, Options Layers, etc. for the previously opened file.    This allows you to use 
template information from an existing file.    The command also does not clear the aperture list defined 
by the File Gerber Out command, allowing you to load a photoplot file without redefining all of the 
apertures.



File Print
Prints a copy of the currently displayed PCB file, according to the printing specifications you have set.    
When you run the File Print command, the File Print dialog appears.

This dialog is used to generate individual or batch print jobs according to a variety of specifications.    If 
you already have print jobs set up, you can generate them from this dialog.    Additional dialogs for 
further specifications are accessible from this main dialog.

ACCEL Tango PCB

If any of the design limits are exceeded, your design cannot be printed using ACCEL Tango PCB.
To learn more, click a button from the following diagram:



Generating Print Jobs
After you have set up the print jobs, drill symbols, and colors, return to the File Print dialog to generate 
the print jobs.    You can do a batch print by highlighting multiple print jobs in the listbox.    You can 
individually highlight or de-highlight print jobs by clicking them in the listbox.

When you click Generate Printouts, the highlighted print job(s) are processed and printed.

Close exits the dialog and saves the settings for the File Print dialog and related dialogs.



Setup Print Jobs
The Setup Print Jobs button displays the Setup Print Jobs dialog.

In this dialog you can set up multiple print jobs, with each job including specific layers, design items, 
and other print options.    You can also modify existing print jobs to include (or exclude) layers, items, 
etc. 

The Setup Print Jobs dialog contains the following areas:
Print Jobs
Print Job Selections



Print Jobs
Any print jobs that you have defined in the Print Name textbox appear in this listbox.    Each print job 
listed can have its own particular layers, and other options specified.    After you have set up a number 
of print jobs and listed them, you can highlight each print job name and the layers and parameters you 
specified for that particular job will be reflected in the dialog.

Whatever is in the listbox appears in the Print Jobs listbox in the File Print dialog after you exit (Close) 
this dialog.

The Add, Modify, and Delete buttons beneath the listbox work in conjunction with what you enter in the
Print Name textbox.    The print name that you enter appears in the list if you click Add; whatever print 
job(s) are highlighted in the listbox or listed in the textbox are deleted when you click Delete.

The collection of print jobs defined in the dialog are saved to the design file, possibly to be printed at 
some other time.



Print Job Selections
The following options appear in the Print Job Selections area:

Print Name
Layers
Layer Sets
Scale
X and Y Offset
Drill Sym Size
Rotate
Mirror
Draft
Keepouts Checkbox
Cutouts Checkbox

Pads Checkbox
Vias Checkbox
Drill Sym Checkbox
RefDes Checkbox
Pad/Via Holes Checkbox
Connections Checkbox
Value Checkbox
Type Checkbox
Glue Dots Checkbox
Pick and Place Checkbox

After you have setup all the options and specifications for the print jobs, click Close to return to the File 
Print dialog.



Print Name
Print Name is the name you give a print job.    When you click the Add button, the name you enter here 
is added to the Print Jobs listbox.



Layers
All items on the selected layers are printed in the current print job.    Pads and vias must be enabled 
separately.    For example, to include all items on the top layer in the print output, select Top in the 
Layers listbox.    The Set All and Clear All buttons beneath it affect the Layer listbox.    To print a 
composite of all layers, click Set All to highlight all of the layers, which you can then name as a print 
job.

When creating output for a specific hole range, you need to select all the layers on which a pad and 
vias hole has been defined.



Layer Sets
The Layer Sets box is used to designate specific, predefined layer sets to print.    To select a layer set:

1. Select a layer set from the drop down list box.

2. Click the Apply Layer Set button.

The layers belonging to that set are highlighted in the Layers box.



Scale
Scale allows you to increase or decrease the size of the print job by a specific factor.    The value you 
enter affects the X axis and Y axis equally.      For example, 0.100 reduces the output by a factor of 10, 
while 10.00 enlarges the output by a factor of 10.



X and Y Offset
The X and Y Offset adjustment allows you to offset your printout horizontally or vertically by whatever 
value you specify.    Minus values go left and/or down; plus values go right and/or up.    Default units are 
the values settings in Options Configure.    You can override the default units by entering the units with 
the value (e.g., mil, mm, in).



Drill Sym Size
Drill Sym Size allows you to adjust the size of the drill symbol (usually for size reduction), which 
represents the drill hole location.    For example, you would reduce the drill symbol size so that the drill 
symbols will not overlap in the printout if they are located close to one another.



Rotate
Rotate, when enabled, causes a 90 degree clockwise rotation of the image on the printout.    If Mirror is 
also enabled, the image mirrors before it rotates.



Mirror
Mirror, when enabled, causes the printout to be a mirror image (reverse) of the normal view.    Normally, 
each layer is displayed as seen from the Top layer.    A mirror image printout would be as the board 
appears from the Bottom layer (as if you flipped the board over horizontally and looked at it with the 
Bottom layer facing up).



Draft
Draft, when enabled, allows an outline rough draft to be printed (normally speeding up the print job).    
This would be a printout of only the outlines for pads, vias, polygons, copper pours, etc.



Object Checkbox
When this checkbox is enabled, the corresponding object is included in the printout.



Drill Symbols
To define drill symbols in your printer output, click the Drill Symbols button to display the Drill Symbol 
Assignments dialog.

To generate a drill symbol drawing, you must enable all signal and power/ground layers on which the 
pad is defined.    Enabling Drill Symbols excludes all copper from this print job and sends just the 
assigned symbol in its place.

To attach a drill symbol to a hole diameter, highlight both of them and then click Assign.    You can clear
the assignment in the same way by clicking Unassign.

If you click Automatic Assign, the drill symbol and hole diameter lists will automatically match up from 
top to bottom, the first hole diameter assigned to the first drill symbol, the second symbol to the second 
diameter, etc.    Unassign All clears all of the drill symbol assignments.

Click Close to save all of the assignments and return to the File Print dialog.



Colors
You can define your printer output to use colors, grayscale, or monochrome (depending on your printer).
Click the Colors button to display the Printer Colors dialog.    

The Printer Colors dialog has the following functions:
Layer/Item Colors
Display Colors
Defaults Button



Layer/Item Colors
This is a color matrix with objects across the top (columns) and layers along the side (rows).    You can 
specify everything on one layer to be of one color by clicking on a layer button (e.g., Bottom) to display 
the color.    By the same process, you can make an item the same color on all layers by clicking an item 
button (e.g., Line).    Or you can make an item a specific color on a specific layer by clicking on the 
square where the item and the layer meet.    You can then choose the color for the layer, item, or 
combination.

Any of these choices displays the Windows standard Color dialog.    From there you can perform the 
color selections; PCB is limited to 16 solid colors.    If you select a non-solid color, it automatically maps 
to the nearest solid "equivalent".



Display Colors
When you select one of the item buttons in the Display Colors area, it displays the same Windows 
standard Color dialog(s) as in the Layer/Item Colors selection.    

When you select a display color for an item, that color applies throughout the design on the printed 
output.



Defaults Button
The Defaults button turns all of the colors to monochrome, a white background with black items.    If you
don't have a color printer, then this is the recommended setting.    If you have color settings, but a 
monochrome printer, you may get undesirable output when the colors are converted to grayscales.



File Printer Setup
Displays a list of installed printers and allows you to set the current printer.    You can also change 
device-specific parameters.    When you run the command, you see the Print Setup dialog.

Select a printer and press the Setup button to configure print parameters.    Because the parameters 
are device-specific, the dialog which appears is different depending upon the printer you selected.

To select a printer, highlight it in the Printers listbox, and click Close.



File Reports
Allows you to output reports with specific output options.    These options are saved to the PCB.INI file 
when you exit the program.    

The following paragraphs describe the areas and function of the File Reports dialog.

Filename
Generally, you specify individual reports (report types listed in the Report Options area), which you can 
choose to output all at once, or one at a time.    Each report type has its own extension, the filename 
determined by the current open design.    

Report File Extensions
These extensions cannot be changed.    The extensions are used are as follows: 

APR for Aperture Information
BOM for Bill of Materials
CPL for Component Locations
GLU for Glue Dot Locations
LCT for Library Contents
PNP for Pick and Place locations
STA for Statistics. 
ATR for Attributes
DEI for DRC Error Indicators. 

Report Options
Aperture Information lists aperture information such as units used, definitions (D code, type, etc.), and
aperture assignments.

Bill of Materials lists the component type, component value (if any), number of components of each 
type, and reference designator assigned to each component.      If you have special components that 
have hidden reference designators (RefDes) and you want to exclude them from the Bill of Materials, 
you can explode the component (Edit Explode Component) and delete the RefDes, or just delete the 
component from the report.

Component Locations lists, for each component, the reference designator and location (the X, Y 
coordinates).      If you have special components that have hidden reference designators (RefDes) and 
you want to exclude them from the Component Locations, you can explode the component (Edit 
Explode Component) and delete the RefDes, or just delete the component from the report.

Glue Dot Locations lists the layer and position of all glue dots in the current design.

Library Contents lists all of the components that are listed in all of the open libraries (see Library Setup
for opening libraries).    

Pick and Place Locations lists the layer and position of all pick and place points in the current design.

Statistics contains a variety of information about the current design, such as primitives count, board 
dimension, line widths used, layer types used, etc.



Attributes contains component and net attributes.

DRC Error Indicators generates a list of all the DRC error indicators on the board.    The report shows 
the locations and text of all the DRC error indicators on the board.    This allows you to generate a 
hardcopy for all the DRC error indicators generated by Online DRC.

Page Format
These options, when enabled, will be output with whatever report type you have chosen to use.    

Use Header and Use Footer will include whatever you have specified as header and footer in the 
header and footer dialog fields.  

Design Info will include whatever you entered in the File Design Info command/dialog.    

Date/Page will include the current date and page number.    

Pagination allows you to create your own pagination (lines per page); don't print from Notepad if you 
enable this option; use the DOS Print command.

Style Format
Comma Separated puts all information in comma separated format, which is a spreadsheet-readable 
format.    

PCB is a human-readable format, with columns and spaces, etc.

Lines per Page allows you to specify the number of lines per page in your output.

Report Destination
Screen sends the output to a file and invokes Notepad, where you can view the report.

File sends the output to a file.

Printer sends output directly to the printer without creating files.



File Design Info
You can enter design information into the dialog that is displayed with this command.

Certain fields that you place in your design will use this information to display data in the respective 
fields.    Title, Author, Date, Time, and Revision number can all be changed. 

For example, if you placed a Title attribute (Place Attribute command) in your design as design01, and 
you changed it in this dialog to design02, then the Title attribute in your design would change to 
design02.    If you had numerous Title attributes placed in your design, they would all be changed by 
what you enter here.

The information that you specify with this command is saved and restored from design files.

Statistics
The Statistics button displays a view-only dialog that gives you statistics for the specific file that you 
currently have open.

Attributes
Allows you to display and modify design-level attributes.    These are attributes that are attached to a 
particular sheet, rather than a part or net.    When you click the Attributes button, the Attribute 
Collection Property Page dialog appears.

You can view, add, modify, or delete a collection of design attributes.    The dialog contains a two-
column table showing the collection of design attributes.    Within a collection, each attributes name and 
value appear in the column.

Changing an Attributes Value:    To change a value, select it and type the new value over the 
existing value.    The name column cannot be changed

Adding an Attribute:    To add an attribute, click the Add button to open the Attribute dialog.    
Enter the name and value for the attribute and set attribute properties.    Click OK, and the attribute is 
added to the table.    

Viewing or Changing Attribute    Properties:    To view or change an attributes properties, select
an attribute from the table and click the Properties button (or double-click the attribute) to open the 
Attribute dialog. 

To Delete an Attribute:    Select an attribute in the table and click Delete, or press the Del key.

Attribute Dialog
The following information appears in the dialog:

Category Listbox:    Displays a list of all attribute categories, All, Component, Net, Clearance, 
Router and SPECCTRA.    Selecting a category brings up a list of pre-defined attributes for that category.

Name Listbox:    Displays all pre-defined attributes for the specified category.    The first entry in 
the list is User-defined.

The currently-selected attribute also appears in the Name edit box, unless User-defined is 
selected.    In that case, the Name edit box is blank so that you can enter a user-defined attribute name.

Name Edit Box:    For user-defined attributes, enter a name for the attribute. 

note:
If the dialog is accessed for an attribute that already has a name, then the Category listbox, 
Name listbox, and Name edit box are filled in, but grayed.    If the attribute doesnt have a name, 



these controls are enabled.

Value:     Use this edit box to enter a value for the attribute.
Visible:    This checkbox indicates whether or not the attribute is visible.
Location:    This area shows the X and Y coordinates of the components reference point.
Text Style:    This area lets you select the attribute text style.    Text styles appear in the Text 

Style drop down listbox.    To change the selected Text Style, click on the text style you want from the 
listbox.    To modify the text style, click the Text Style button.

Rotation:    Shows the rotation amount if the pattern has been rotated.
Flipped Box: This box indicates whether or not the pattern has been flipped. 
Justification:      Under Justification are nine buttons, which allow you to change text justification

by setting the reference point of the text string.    For example, if you enable the middle button, the text 
reference point (the lower-left corner) moves to the center of the bounding rectangle.

See also:

Place Field



File DXF In
DXF files can now be loaded into PCB.    This allows you to create dimensions, board outlines, 
manufacturing instructions, artwork, logos, etc., and then import the resulting DXF file into PCB.    DXF 
files generated using AutoCAD® Version 9.0 through 12 or other conforming CAD program may be 
input into PCB.

Loading a DXF File
To load a DXF file into PCB, run the File DXF In command.    The File DXF In dialog appears requesting
a file name and layer name.    

To load a DXF file into PCB, run the File DXF In command.    The File DXF In dialog appears requesting
a file name,layer name, and layer.    

1. Click the File Name button and the following standard File Open dialog appears for you to select 
a file.    

2. Type, or select from the list, the name of the file you want to open in the File Name box.

3. If the file you want isn't in the current directory, then either type the directory name in front of the 
document name, or select the directory from the Directories box.    You can move through the 
directory tree by selecting the appropriate directories from the list.    Click OK to exit this dialog.

4. From the File DXF In dialog, type a layer name and select an unassigned layer number.    The 
layer name entered is used to create a non-signal layer where all the DXF items are placed.    
After the DXF items have been translated and placed onto the new non-signal layer, these items 
are equivalent to other PCB primitives.    The new lines, arcs, text, and polygons can be modified 
as usual.

5. Click OK.

The progress of DXF translation is shown by a percentage counter.    Some items supported in 
the DXF language cannot be translated for use by PCB.    Other items may fall outside the PCB 
Workspace.    Errors and warning messages are placed in a report file, which you may view at the 
end of the translation.

Items and Features Supported for Translation
The following items and features are supported for translation:

Header Variables
The AutoCAD® state variables are grouped together at the top of the file in the HEADER section.    
Supported variables are listed and described below, with default values in parentheses:

$ACADVER The AutoCAD® drawing database version number (must be 9.0 or higher).

$ANGBASE The angle zero direction.    The DXF coordinate system is rotated by this angle.    
(0)

$ANGDIR The angular orientation: 1 = clockwise; 0 = counterclockwise.    (0)

$MIRRTEXT Mirrored text if non zero.    (0)



$TEXTSIZE Default text height.

Tables
The DXF In command does not support the LTYPE, LAYER, or STYLE tables.

The only entries in the BLOCKS section that are supported are the dimension blocks.    All dimensions 
that are translated come from this section.

Entities
The majority of a DXF file is made up of entities.    These include lines, arcs, text, block insertions and 
others.    Only two-dimensional entities are supported; z-axis values are ignored.    All block insertion 
entities are ignored.    Information embedded in the entities for color and layer are also be ignored.

LINE DXF LINE entities have infinitesimal width.    They are translated into PCB lines 
one mil wide.    All line styles are translated to solid.

ARC DXF ARCs are translated into PCB arcs of one mil.

CIRCLE DXF CIRCLEs are translated into PCB arcs with a sweep angle of 360 degrees 
and one mil.

POLYLINE DXF POLYLINEs are sequences of possibly tapered, straight and curved lines 
that are connected end-to-end.    These may be open or closed.    PCB does not 
support tapering and only supports normal 2-D (unflagged) DXF vertices.    
POLYLINEs are translated into PCB arcs and lines with a thickness equal to the 
initial POLYLINE thickness.

VERTEX Vertices define DXF POLYLINEs.    When translated, they become the defining 
vertices of the translated PCB item.    Only normal 

2-D DXF vertices are supported (no spline-fit, curve-fit, 3-D mesh, or other 
special flags).

SOLID DXF solids are filled three- or four-sided polygons.    They are translated into PCB
polygons.    Four sided solids that form a PCB "complex" polygon will be ignored.

TRACE DXF traces are lines with thickness that can be filled or unfilled.    They are 
treated the same as DXF solids and are translated into PCB polygons.

TEXT DXF text is translated into PCB text.    Obliquing angle ("slant") and font name are
not supported.    The font used for translation is the PCB default font.    Due to the
difference in fonts, translated text strings may be of different total width 
than the DXF version. The bar over barred text may not align exactly with the 
text. 

The following is a specific (but not comprehensive) list of items that are not supported:

All BLOCKS, except the dimension blocks.
DIMENSION entities.    All dimensions are translated from the BLOCKS section.
SHAPE, ATTDEF, and ATTRIB entities.
3DLINE and 3DFACE entities.
Curve- or spline-fit vertices or meshes for POLYLINE and VERTEX entities.    Tapering 



POLYLINEs are also not supported.
Obliquing angle and font for TEXT entities.    The PCB Quality font will always be used.
Three-dimensional entities and coordinates; thickness for all entities will be ignored, and only the 

first two values of a coordinate-triplet will be used.
Color values for individual entities.    Color values for entities will depend on the PCB primitive and

layer to which the entity is translated.

DXF In Notes
The following is a list of notes that are important or useful when using the DXF In command:

The EXPLODE command in AutoCAD® can be used to transform blocks into individual entities.
An important item to be translated from a DXF file is the dimension.      AutoCAD® creates a new 

dimension block every time a dimension is    moved, edited, or altered in any way.    The user should use 
the PURGE command to eliminate any unreferenced copies of the dimension blocks created by 
AutoCAD®.    The user should then output the design to DXF format immediately after the PURGE 
command, before editing or modifying dimensions.



File DXF Out
The File DXF Out command is used to create DXF (Drawing Interchange Format) files of your PCB 
designs.    These files can then be transferred to AutoCAD and other mechanical CAD packages.    The 
output is compatible with AutoCAD® Version 9.0,    and above. 

When you run the File DXF Out command, the File DXF Out dialog appears.

To use this dialog:

1. Click the DXF Filename button and following the standard File Save dialog appears for you to 
select a file.

2. Type the name of the DXF file to you want to save in the File Name box.

3. Click OK.

4. Select the PCB layers you wish to output using the Layers listbox.    Each PCB layer is output to 
a separate DXF layer.    The Select All and Clear All buttons let you select and clear all the board 
layers at once.

You can use Layer Sets box to designate specific, predefined layer sets to output.    To select a 
layer set, select a layer set from the drop down list box and click the Apply Layer Set button.

5. If you select Output Drill Symbols, you need to specify a size for the resulting drill symbols.    The 
default value is 80 mils (or the equivalent if you're in metric mode).    To use a different value, type 
it in the Size box.    If you specify zero, the Drill Drawing layer is output without drill symbols.

To make or examine drill symbol assignment, click the Setup button.    The Drill Symbol 
Assignments dialog appears.    This dialogis explained in the File Gerber Out command section of 
PCB Reference.

6. DXF polylines are normally used for all lines, arcs, and pad and via shapes, and solids are 
normally used for polygons.    Polylines are filled lines with thickness.    Select the Draft checkbox 
to output DXF arcs, lines, and circles instead of polylines, and polygon outlines instead of DXF 
solids.    Draft mode produces smaller files that process faster, but the drawings are not 
technically accurate since the lines have no width and areas are not filled. 

7. Click the OK button to generate the DXF output file.    While the file is generating, the Status line 
indicates progress by displaying the current layer being output.    While the file is being generated,
you can press Esc or click the right mouse button to cancel the operation. 

Component Height Checkbox
When you enable the Component Height checkbox, PCB automatically detects valid 
ComponentHeight attributes assigned to components, and writes corresponding component height 
geometry to the DXF.

PCB uses the geometric primitives in a components pattern to produce component geometry in a DXF 
(circles, lines, arcs, and polygons).    Pads, vias, text, and signal layer items are ignored.    Component 
height geometry is created in the DXF on layers that are consistent with the source geometry.

In the DXF, the height of an individual component extends upwardly or downwardly from the PCB, 
depending on whether the component resides on the top or bottom layer. 

When the DXF is read into a    3-D CAD system (such as AutoCAD), the specified heights are 
represented as geometric elements of the proper PCB components when viewed in 3-D mode.



DXF Output Considerations
Layers.    Items are output to individual layers, which keep their PCB names.

Blocks.    DXF blocks are used to combine individual entities into a common unit, to be treated as a 
whole by the CAD package, analogous to a part or component.    Blocks are used, where possible, to 
make CAD processing easier, and to reduce the size of the DXF file.    For example, a component block 
has the name of the reference designator; exploding a component block produces text (for attributes) 
and a pattern block.    This in turn can be exploded to produce some single items and padstyle blocks.    
These can be exploded to produce padshape blocks; which can be exploded to produce solids and 
polylines.

Polygons.    PCB polygons are also represented as blocks containing a collection of three- or four-sided
solids.    In this way they can be processed as a unit.

Copper Pours.  PCB copper pours are represented as blocks containing a collection of lines that 
outline and fill the copper pour.    In this way they can be treated as a unit.

Lines.    When not in Draft mode, lines consist of a straight polyline and two round endcaps.    Note that 
due to limitations in how blocks are scaled in DXF, lines are not blocks; the endcaps and polylines are 
separate from one another.    In Draft mode, lines become DXF LINEs with no endcaps.

Arcs.    When not in Draft mode, lines consist of a curved polyline and two round endcaps.    Note that 
due to limitations in how blocks are scaled in DXF, arcs are not blocks; the endcaps and polylines are 
separate from one another.    In Draft mode, arcs become DXF ARCs with no endcaps.

Text.    Text strings are converted into DXF text strings of the same height, rotation, mirroring, and 
justification; the AutoCAD® STANDARD font is used.    Note that due to the difference in fonts, 
translated text strings may be of different total width than in PCB.

Pads and Vias.    These are blocks of pad shapes, which are in turn blocks of SOLIDs and POLYLINEs.
For example, a rounded rectangle is a block consisting of two SOLIDs forming a thick "plus" and four 
circular POLYLINEs in the corners.    A pad is a block containing a stack of what could be different 
shapes on different layers.    When not in Draft mode, these shapes are filled; in Draft mode, only the 
outlines are represented with lines, arcs, and circles.    Pads and vias are not output with holes whether 
or not you are in Draft mode.



File Gerber In
File Gerber In allows you to load a series of Gerber files.    You can load a Gerber file into the editor to 
check its accuracy.    Each file is loaded onto a separate layer.

You can load a Gerber file either into an empty workspace (use File Clear to clear the workspace) or 
superimpose it onto an existing design.    Loading a file alone is usually for checking pad size, line width,
or other possible errors.    Superimposing a file onto a design is a good way to verify the Gerber file 
against the design.

You can examine the Gerber file through the workspace display in addition to analyzing the error file 
displayed in Notepad.

From the Gerber File In dialog, click the Gerber Filename... button to access the Windows common 
File Open dialog (File Gerber In), where you can access the Gerber file.    

Access your Gerber file (e.g., chap9.top) and click OK to return to the first dialog.    

From the first dialog, specify the Layer Name and Layer Number and enable or disable View log file 
upon completion.    The layer name Gerber is provided as a default, but may be changed.    

You can load multiple Gerber files onto your design file, each inhabiting its own layer.    Therefore, the 
layer names must be unique.    So, the first file loaded would be on the layer Gerber,    the next file 
loaded would receive the default name Gerber1, then Gerber2, etc.

When you load a Gerber file, it automatically creates a non-signal layer named "Gerber", using the next 
free layer in sequence.    (If you have eleven layers, the twelfth is used.) 

Normally you would load multiple files to verify that the layers are aligned and registered properly.

warning:
The D Code apertures that are called out by the loaded Gerber file must be present and be 
defined as they were in the original Gerber file.    If a D Code is no longer present, then the 
program will flag the error.    If the D Code is present but its definition has changed, no error will 
be flagged, and you may get unexpected results.    For example, this could occur if you loaded an 
old Tango Series II Gerber file without first recreating the aperture definitions properly.    Our 
advice is that you should not redefine D Codes at all between the creation of the Gerber file and 
reloading it for design file/Gerber file compairson.

Aperture definitions are saved and loaded in the design file.    Loading a new design file can completely 
change the current aperture settings.    The File Clear command does not clear current aperture 
definitions, so use File Clear to clear the workspace before loading a newly created Gerber file.

Click OK and the photoplot file will load.

ACCEL Tango PCB

If the layer limit is exceeded, your design cannot be loaded using ACCEL Tango PCB.    ACCEL Tango 
PCB supports 4 user-defined layers and up to 15 total layers.



File Gerber Out
The File Gerber Out command allows you to output Gerber files with a variety of options and 
specifications.    You can cancel this command before the dialog appears (while the program is 
searching the database for items) by clicking the Cancel button or pressing Esc.

When you run this command, the File Gerber Out the dialog appears.

There are multiple dialogs you can access from the File Gerber Out dialog buttons.    

To learn more, click a button from the following diagram:



Setup Output Files
The Output File listbox contains the filenames of the output files you set up.    Each set of options you 
specify (described in the following paragraphs) comprises a separate output file, differentiated by its 
extension.    After you have set options and the extension for a particular file, you can click Add to add it 
to the list.    After you have a file list, you can choose to change a file (click Modify), or delete it from the 
list (click Delete).

Your output files will have the same base name as the design file, but each with a unique extension.    
Typical extensions used to differentiate files would be layer-specific, such as TOP, BOT, and TSK (TOP, 
BOTTOM, and TOP SILK).

The Output File Selections area allows you to set options for each output job such as: layer, file 
extension, X and Y offset, drill symbol size, and items included (Pads, Type, etc.), and the output path 
of the particular file.

File Extension should be a meaningful name for the output (e.g., .top).    Avoid such potentially 
conflicting extensions as .exe and .pcb.    When you click Add, the base filename with the extension you 
specify will be added to the file list.

X Offset and Y Offset allow you to set the origin of the plot in a different position than the home 
position of the plotter.    For X offset, enter a negative number to offset the plot towards the left, positive to 
the right.    For Y offset, enter a negative number to offset downward, positive to offset upward.

Drill Symbol Size value determines the sizes of the drill symbols output in the particular file.
The Enable/Disable checkboxes allow you to include or exclude items and attributes from the 

output.    
Ref Des, Type, and Value checkboxes are typically used for silkscreen generation, with the 

silkscreen layers.
Mirror is typically used to produce a mirror-image output for bottom layers (bottom, bottom silk, 

paste mask, solder mask, assembly, etc.)    Some fabrication shops prefer to mirror the output 
themselves, so check with them before using Mirror.

Pads, Vias, Pad/Via Holes, and Drill Symbols should be enabled if you want them included in 
the Gerber output.

When producing an output file for a specific hole range, you need to select all the layers on which
a pad and vias hole has been defined.      

Output Path allows you to output the files to a particular location.
View error file upon completion gives you the option of viewing the log file in Notepad.
The Layers box lists all current layers of the design.    You can highlight any number of them for 

output to a particular file.
The Layer Sets box is used to designate specific, predefined layer sets to output.    Select a layer

set from the drop down list box and click the Apply Layer Set button.

To generate a drill symbol drawing, you must enable all layers that match the pad stack (plane and 
signal).    Also, you must enable pads, vias, and drill symbols.

After you have set up your output files list in the dialog, click Close and return to the Gerber File Out 
dialog, which will list the files that you set up for output.



Apertures
To assign/describe apertures automatically or manually, click the Apertures button (from the File 
Gerber Out dialog) to display the Aperture Assignments dialog.

The listbox of this dialog displays the items of the loaded design file and any aperture assignments that 
may exist for those items.    You can click an item line and the item's characteristics will be listed to the 
right of the listbox.    If an aperture is assigned to the item, the aperture characteristics are listed there 
as well.

To manually describe and assign an aperture (or change an existing assignment), double-click an item 
line, or highlight an item line and click Assign, which displays the Describe/Assign Apertures dialog.

Unassign deletes the assignment for the item that is selected in the assignment list.

Unassign All clears all assignments, usually so that you can perform automatic describe and assign 
functions to all items/apertures.

Additional Information
Auto (Automatic Describe/Assign)
Assign (Manual)
Available Procedures



Auto (Automatic Describe/Assign)
To automatically assign apertures, click the Auto button.    PCB automatically assigns all apertures that 
have not been assigned manually. 

You can enable the Pad/Via holes option to have PCB create apertures with holes, but this is generally 
not recommended for two reasons:

Drilling holes through the board could break drill bits if the flashed pad/via holes don't line up 
through the board exactly.

Non-hole apertures are usually less numerous; a 50 x 50 round with no hole can be used for a 50
x 50 on the Top layer and also for a 40 x 40 via with a 5 mil swell solder mask.

The Clear current apertures option is enabled by default.    If disabled, the current apertures remain.    
You generally would want to clear apertures when you auto-assign.

Draw Rotated or Offset Pads/Vias, when enabled, draws pads and vias with non-orthogonal rotations,
or offset holes (non-orthogonal being rotations other than 0 or multiples of 90 degrees).

Draw Aperture Size specifies the default draw aperture size for any unassigned apertures, such as 
drawn drill symbols and polygons.

After you have taken these steps, click Auto to automatically describe and assign all unassigned 
apertures to the appropriate items.



Assign (Manual)
To manually describe/assign apertures, click Assign to display the Describe/Assign Apertures dialog.    
You can also double-click an item line in the previous dialog to display this dialog. 

The item name you highlighted on the previous dialog appears in the Assign Aperture to field at the 
top of this dialog.    If the item was already assigned an aperture, that aperture name appears 
highlighted in the Apertures listbox.    The item characteristics are listed to the right of the listbox, and 
the aperture characteristics are listed there as well (if an aperture is assigned).    

In the D Code entry box, you can enter a value in the range of 10 through 999 for the draft code used to
select the aperture.    The program automatically prefixes the value with the letter D.

The Shape combo box displays the aperture shape.    The following shapes are supported:

Ellipse is a rounded shape with separately specifiable X and Y dimensions; an ellipse with equal 
X and Y dimensions is a circle (frequently called a round).

Oval is a short line segment with round end caps (half-circles), the radius of which is 1/2 the 
length of the shortest side; if the X and Y dimensions are equal, this too is circular or round.

Rounded Rectangle contains 1/4 circles on the corners of a rectangle.    The 1/4 circle radius is 
1/4 the length of the shortest side.

Rectangle shapes are X=width and Y=height.

note:
If you want a circle pad, you use the ellipse shape with identical height and width (the example 
shown is an oblong ellipse).    If you want a square pad, use a rectangle with identical height and 
width.

Thermal apertures are typically used for connection to planes, where heat is a factor.    These 
apertures are constructed from two or four arc segments separated from each other by spokes.    The 
other dimension is the diameter of the outer edge of the arc-segments, the inner dimension measures the 
inside edge, and the gap measures the spoke width, or amount of copper connection on a reverse-
screened plane layer.    Thermals are always circular, and the size is a function of the pad/via hole size.

thermal spoke apertures

thermal diameters and spoke width



A Target is used for layer registration.

Mounting Hole is a circle shape with a cross in it used to represent a mounting hole.

Drill Symbol could be any of the drill symbol shapes assigned in the Drill Symbols dialog.    

X Dim and Y Dim are the X (horizontal) and Y (vertical) dimensions for the aperture.    These values 
may be entered with your choice of units.

The H Dia is the hole diameter for the aperture.    This value may be entered with your choice of units.    
The hole diameter cannot exceed the minimum aperture dimension.

Angle is the amount in degrees that an aperture is rotated.

X Off and Y Off are horizontal and vertical offset amounts of the hole in an aperture. 

The Type combo box lists the aperture types (type indicates whether the aperture can be flashed, drawn 
or both).    The type is specified using either Flash, Draw, or Flash/Draw.    Flash and Draw are typically 
specified for use with mechanical or vector photoplotters, because different holders must be used for the 
two types of apertures.    Flash/Draw is used with laser photoplotters, which do not have this limitation.

The Comment box allows you to enter a comment of up to 32 characters.    This is especially helpful for
further describing thermal reliefs and drill symbols.



Available Procedures
There are basically four procedures available in this dialog:

Create a new aperture by describing the aperture (filling in the D Code, Shape, etc.) and clicking 
Add to assign it to the item.    The Shape and Type combo boxes allow you to select the shape and type of
the aperture.

Modify an existing aperture by changing various descriptions, but keeping the same name (D 
Code), and clicking Modify.    The assignment remains the same (item to aperture), but the characteristics 
of the aperture have been changed.

Use an existing aperture to create a new one by changing the name (D Code) of the aperture, 
and then changing the descriptions of the aperture or using the same descriptions.    You would then click 
Add, in effect creating a new aperture.

Delete an aperture assignment/description by simply clicking Delete.

Click Close to save all of your changes.    You then return to the Aperture Assignments dialog, where the
assignments you've made are listed.    The currently selected aperture is used as the assignment for the
item shown in the dialog.



Gerber Format
To access Gerber options, click the Gerber Format button (in the File Gerber Out dialog) to display the 
Gerber Format dialog.

Select the Output Units as inches or millimeters for your output file.

Select Numeric Format on the basis of the required resolution.    The format 4.4 means that there are 
four digits to the left of the decimal point and four digits to the right.    The format 5.3 means that there 
are five digits to the left of the decimal point and three digits to the right.    

The G54 With Apertures option is initially disabled.    It determines whether or not to send a G54 tool-
select code with each command to change apertures.

The Include aperture definitions option determines whether definitions and assignments macros are 
to be included in the output.

Click Close to exit the dialog, and the format you specified will be applied when the output is generated.



Generate Gerber Output
After you have set up the output files, aperture assignments, drill symbols, and Gerber format, you can 
generate the output files by highlighting them from the Output Files list box and clicking the Generate 
Output Files button in the File Gerber Out dialog.

A progress dialog displays the name of the file being converted.    When finished, the log file is displayed
if the View error file upon completion box was enabled in the Setup Output Files dialog.



File N/C Drill
Allows you to output an N/C Drill file for your design in Excellon format.    You can cancel this command 
before the dialog is displayed (while the program is searching the database).    Choose File N/C Drill to 
display the dialog.

This main N/C Drill dialog allows you to output individual or multiple files.    Before you generate output, 
you may need to establish N/C Drill settings in some of the multiple dialogs available from the File N/C 
Drill dialog.

To learn more, click a button from the following diagram:



Generate N/C Drill Output Files
When you have established all of the options for output files, tool assignments, and other drill settings, 
the resulting output files will be listed in the Output Files listbox.    You can click on the filenames 
individually to enable or disable for output.    Set All enables all of the files for output (you can then 
deselect individually).    Clear All deselects all the files (you can then select files individually).    Then 
click Generate Output Files to generate drill files according to what you have specified. 



Setup Output Files
When you click Setup Output Files, the Setup Output Files dialog appears.

The filenames for the output files you set up here are determined by the individual extensions you give 
them (e.g., filename.NC1, filename.NC2).    Most of the time only one file is used for N/C Drill, so that 
you have the design filename as the root name, and the extension as .NCD.    This is to differentiate it 
from the regular design file and Gerber files in the same directory (.PCB, .TOP, .BOT, etc.)

The Layers listbox fills with defined signal layers; no non-signal layers appear.

When producing an output file for a specific hole range, you need to select all the layers on which a pad
and vias hole has been defined.      In this way it is possible to generate files for blind and buried vias.    If
your board contains only through-hole pads/vias (not blind or buried vias), then only one file is 
necessary, and it should contain all of the signal and plane layers.

You can perform four basic procedures for output files from within this dialog:

Create an output file.    Specify an extension (e.g., NC1) and the X, Y offset settings.    Select 
layers to be included by clicking on the layer names individually to highlight them, or use the Set All or 
Clear All button to highlight all or deselect all, respectively.    For example, if you set all layers, you can 
then deselect one or two layers that you want to exclude.    Click Add.

Modify an existing output file.    Select (highlight) a filename from the list.    Keep the same 
extension, but change the settings accordingly, including X, Y offset, and layers to be included.    Click 
Modify.

Create a new output file from an existing one.    Select (highlight) a filename from the list.    
Change the extension of the file, and either change settings and included layers, or leave them alone, as 
appropriate.    Click Add.

Delete an output file from the list.    Select (highlight) a filename from the list.    Click Delete.

Specify the destination of your output files by specifying the path in the Output Path textbox.

You can also enable or disable the option to View error file upon completion.

Click Close to save your output files settings and return to the main File N/C Drill dialog.



Tools (Assignments)
To assign N/C Drill tools, click the Tools button in the File N/C Drill dialog to display the Tool 
Assignments dialog.    In this dialog you can unassign tools, and then either automatically or manually 
describe/assign what remains.

To manually describe/assign tools, click on (highlight) a line, then click Assign to display the 
Describe/Assign Tools dialog.    (Or you can double-click on a hole/tool line to display the dialog.)

To individually unassign a tool, select a tool assignment in the list to highlight it, then click Unassign.

To unassign all tools (usually before you automatically assign), click Unassign All.

To automatically describe/assign all remaining unassigned tools, click Auto.    When you enable the 
Clear current tools option, the tools will automatically clear when you use Auto.

Click Close when your descriptions and assignments are set.

Additional Information:
Assign (Manual)



Assign Manual (N/C Drill)
Click Assign to display the Describe/Assign Tools dialog, where you can manually describe/assign tools.

The hole name of the hole or tool you highlighted on the previous dialog appears at the top of this 
dialog in the Assign Tool to field.

All tools are listed in the listbox; if the hole already has a tool assigned to it, then that tool is highlighted, 
and the tool's Tool code and Diameter values appear in the edit boxes.    If the hole has no tool 
assigned (no tool is highlighted) then the contents of the edit boxes contain the next available tool code 
and hole diameter.

In the Tool Code text box, you can enter a value in the range of 1 through 80 for the tool code used to 
select the drill bit.    The program automatically prefixes the value with the letter T and fills in the leading 
zero for codes T01 through T09.

In the Diameter textbox, you can enter a value to determine the diameter of the drill bit.

There are four procedures available in this dialog:

Create a new tool assignment by describing/assigning the tool (filling in the T Code and Diameter)
and clicking Add to assign it to the hole.    

Modify an existing tool assignment by changing the Diameter, but keeping the same T Code, then
clicking Modify.    The assignment remains the same (tool to hole), but the diameter of the tool has been 
changed.

Use an existing tool to create a new one by changing the name (T Code) of the tool, and then 
using the same diameter and hole assignment.    You would then click Add, in effect creating a new tool 
assignment.

Delete a tool assignment/description by simply clicking Delete.    The tool assignment must be 
highlighted to delete it.

Click Close to save changes.    You are then returned to the Tool Assignments dialog, where the 
assignments you've made will be listed.



N/C Drill Format
To establish N/C Drill format settings, click N/C Drill Format (from the File N/C Drill dialog) to display 
the N/C Drill Format dialog.

For Units, if you select Inches, the units are in inches and the format is automatically set to 2.4 (two 
digits to the left of the decimal point and four digits to the right).    If you select Millimeters, the format is 
automatically set to 4.2 (four digits to the left of the decimal point and three digits to the right).

Select the appropriate Output Code Type and Zero Suppression options.    Check with the fabrication 
house for the appropriate settings.    These options are saved in your PCB.INI file.

After you have established settings in N/C Drill Format, click Close to save settings and return to the 
File N/C Drill dialog.



File PDIF In
Allows you to load PCAD.PDF format design files.    When you run this command, the PDIF File Name 
dialog appears.

1. Select File PDIF In to open the dialog.    

2. Type, or select from the list, the name of the file you want to open in the File Name box.

3. If the file you want is not in the current directory, then either type the directory name in front of the
document name, or select the directory from the Directories box.    

4. Click OK.

Refer to the chapter Using P-CAD files for more information.

ACCEL Tango PCB

If any of the design limits are exceeded, your design cannot be loaded using ACCEL Tango PCB.
For additional information, refer to the PCB Users Guide.



File PDIF Out
The File PDIF Out command is used to create PDIF files of your PCB designs.    When you run the File 
PDIF Out command, the PDIF File Name dialog appears.

PDIF File Export
2. Type the filename you want to use in the File Name box.    

3. If the current directory is not appropriate, then either type the directory name in front of the 
document name, or select the directory from the Directories box.    You can move through the 
directory tree by selecting the appropriate directories from the list.    

4. Make sure the extension is correct by checking the Save File as Type box.

5. Click OK to save the file as you have specified.

For additional information, refer to the Using PDIF document.



File Exit
Exits the PCB program.    

If any open designs have been modified since the last save, you are prompted whether you want to 
save the changes to each design.

The program writes information to the PCB.INI file when you run Exit.    This information, which will 
apply to subsequent PCB sessions, consists of parameters and settings such as workspace size, units 
and values set in Options Configure, report file settings from File Reports and Utils DRC, etc.



Edit Menu (PCB)





Edit Undo
Undo reverses your last completed action to the design file.

You can undo Place commands, Delete, Copy Matrix, and Alter Component, and modifications such as 
move, rotate, and flip (actions performed using the Select tool).    Many File commands, such as File 
New, Save, Print, etc. cannot be undone.    If an action cannot be undone, Undo appears grayed on the 
Edit menu.    

You can only undo a finished Place command.    For example, if you are placing an object that requires 
more than just one click in the workspace (such as drawing lines, polygons, arcs), you must finish the 
segment or arc before you can undo it.    

To unwind line segments (delete the previous segment) before you finish the series of segments, use 
the backspace key.

This function can be enabled with the Undo button from the toolbar.

See also:

Delete



Edit Cut (Ctrl+X)
Cut removes objects/items from your design and saves them to the Windows clipboard, from where you
can paste them into another design or to another location within the current design.

You must enable the Select tool (Edit Select) and have at least one item selected to run this command; 
otherwise the menu item is grayed and the Ctrl+X shortcut key is inoperative.

Once items are in the clipboard, you can either immediately paste them to another design location, or 
save them to a clipboard file (.CLP).    Use File Save in the Windows Clipboard application to create a 
clipboard file.    You can paste a clipboard file into your design file.    The clipboard format in this case is 
specific to PCB and cannot be used by non-PCB applications.

You can cut multiple objects by using multiple select and block select operations.    Refer to Edit Select 
for information.

Cutting Objects from Nets
When you Edit Cut to remove objects from nets, you can get a variety of results, depending on what 
you cut and the makeup of the net you remove it from.    The function of smart nets is to maintain certain
connections when objects such as copper connections, unrouted connections, and net nodes are 
removed.    In general, the following can occur.

If you remove free copper (no connections), then the copper disappears and no connection 
compensation occurs.

If you remove a node, then the remaining nodes are still part of the net, and there will be 
compensation to maintain connections between the remaining nodes.

If you remove a component, you are removing nodes from all nets to which the component's pads
were connected.    The connectivity feature of PCB reconnects the remaining nodes in each net in the 
most efficient way.

If two nets become merged, and one net is a plane net, then the plane layer net takes 
precedence and the merged net is a plane net.

If you remove a connection from the middle of a net, the net is split.    One portion retains the net 
name and the other is given a new net name.

If you remove a connection that isolates a pad from the rest of the net, you end up with a 
disconnected node. 

If you remove a copper segment that is part of a net, that segment is not removed, but instead 
becomes a connection (in effect unrouting the net).    In this case, the net remains intact, although 
changed.



Edit Copy
Allows you to copy objects/items to the clipboard, from where you can paste them to another design, or 
to another location within the same design.

You must enable the Select tool (Edit Select) and at least one item selected to run this command; 
otherwise the menu item is grayed and the Ctrl+C shortcut key is inoperative.

You can use Ctrl + left mouse button (a drag-and-drop operation) to copy within the same design.

Once items are in the clipboard, you can either immediately paste them to another design location, or 
save them to a clipboard file (.CLP).    Use File Save in the Windows Clipboard application to create a 
clipboard file.    You can paste a clipboard file into your design file.    The clipboard format in this case is 
specific to PCB and cannot be used by non-PCB applications.

Refer to the Edit Paste command for rules and parameters for pasting objects.



Edit Copy to File
Allows you to copy selected objects to a block file, from which you can paste them at a later time using 
the Paste From File command.

You must enable the Select tool (Edit Select) with at least one item selected to run this command; 
otherwise the menu item is grayed. 

When you run the Copy to File command is selected, the Edit Copy to File dialog box appears.

The Directories area displays the current path and a list of directories for changing the path.    The File 
Name area lists all the files of the current directory, with the extension specified in the Save Files as 
Type area.    Notice that the default file extension is .BLK. 

Specify a location and name of the block file to which you wish to copy the selection.    You can copy 
multiple objects by using multiple select and block select operations.    Refer to the Edit Select 
command section for more information.



Edit Paste (Ctrl+V)
Allows you to paste objects/items from the clipboard into your design file.    

When you choose Edit Paste, your cursor becomes an action pending cursor (a crosshair-style shape), 
until you click in the Workspace to paste the item(s).    Items are pasted at the cursor position.

The Paste command handles only clipboard items that are in PCB format.

If any of the design limits are exceeded, the object/item cannot be pasted in your design using ACCEL 
Tango PCB.    See ACCEL TangoPCB features.

Paste Item(s)
1. Choose Edit Paste, and click in the workspace in the appropriate location.

2. A ghosted shape of the item appears in the workspace until you release the mouse button.    But 
before you release the mouse button, you can drag the item to a more precise location and then 
release.

3. The area you are pasting in must contain available space for the item you are pasting.    The 
computer will beep if the object is too large for the space or if you are attempting to paste too 
close to the edge of the workspace.

Pasting On Layers
If an item is layer-specific, then it will be pasted onto the same layer that it was cut/copied from, 
regardless of the current layer setting.    If the target layer doesn't exist, then the item(s) will not be 
pasted.    To paste to a different layer, use Paste to Layer.

When pasting a component from one design to another (or placing a component from a library), if 
components of the same name but from a different library already exist in the destination design, the 
component cannot be pasted/placed due to the probable conflict in pin assignments.    This conflict 
could also occur when components from a Series II board are mixed with components of the same 
name in a PCB library.    In effect, the first instance of the component name establishes the standard.

When you paste vias, pads, and text (usually in a component) from a different design that contain styles
that have the same names but different data than those in the current design, the incoming style names
will be bracketed to indicate the style conflict.    The new (bracketed) style names will be added to the 
list of available styles in the current design.    Refer to the Edit Modify, Options Pad Style, and Options 
Text Style commands for object style information.    If you paste a component that has the same RefDes
as a component already in the design, an A is appended to its RefDes (e.g., U10A).



Edit Paste to Layer
Allows you to paste items to a different layer from what they were cut or copied from, within the same 
design or to a different design.    This feature includes single, multiple, or block selection cuts and 
copies.

The Edit Paste To Layer command accepts only clipboard data that are in PCB format.    Clipboard data 
from other applications cannot be pasted into the PCB Workspace.

If you block select items that reside on different layers, e.g., one line on the Top layer and one on 
the Bottom, they will both be pasted onto the current layer.

Multi-layer items, such as pads, will remain as multi-layer.
When items are ghosted for pasting, you can press the L key to toggle between layers before you

do the final paste.
You can paste to layer from a clipboard file (.CLP) as well as directly from the clipboard.    This 

clipboard data cannot be loaded or pasted to or from any other Windows utility; it is PCB-specific.    
When pasting a component from one design to another (or placing a component from a library), if 

components of the same name but from a different library already exist in the destination design, the 
component cannot be pasted/placed due to the probable conflict in pin assignments.    This conflict could 
also occur when components from a Series II board are mixed with components of the same name in a 
PCB library.

When you paste vias, pads, or text from a different design that    have the same style names but 
different data than those in the current design, the incoming style names will be bracketed to indicate the 
style conflict.    This would normally occur with components, which contain vias, pads, and text.    The new 
(bracketed) style names will be added to the list of available styles in the current design.    Refer to the 
Edit Modify, Options Pad Style, and Options Text Style commands for object style information.



Edit Paste from File
Allows you to paste items from a block file into the current file.    The block file must have been 
previously created using the Edit Copy to File command.    When selected, the Edit Paste from File 
dialog appears.

The Directories area displays the current path and a list of directories for changing the path.    The File 
Name area lists all the files of the current directory, with the extension specified in the List Files of 
Type area.

Select the block file containing the item(s) you wish to paste.    Once the file is selected, this command 
works like the Edit Paste command.

If any of the design limits are exceeded, the object/item cannot be pasted from the Clipboard using 
ACCEL Tango PCB.    See ACCEL TangoPCB features.



Edit Move to Layer
This command allows you to select a number of objects, and then move the objects to another layer.    
This facility will enhance the your ability to clear out congested areas for routing.    Additionally, if you 
have accidentally placed objects on the wrong layer, you can move them to the correct to the correct 
layer.

To Move an Object
To move one or more objects to a different layer:

1. Select the object or objects.

2. Change to the layer where you want the objects moved.

3. Run the Edit Move to Layer command or use Shift-T. 

All the single-layer objects are moved to the current layer.    You will be returned to the Select tool 
and all the moved objects will be selected.

Restrictions
If an object has net information it can move between signal layers only.    Otherwise it can move to

any layer.
Multi-layer objects will not be moved (components, glue dot points, keepouts, pads, pick and 

place points, reference points, or vias).    Objects that can be moved are single layer objects (arcs, copper
pours, cutouts, keepouts, lines, polygons, attributes, fields, and text).

If multi-layer and single-layer objects are selected simultaneously the tool will ignore the multi-
layer objects and only move the single-layer objects.

Single-layer objects on different layers will all be moved to the current layer.
If the single-layer objects are of mixed net and non-net types and you are moving them to a non-

signal layer, a warning message will appear telling you that only the non-net objects will be moved.    You 
can cancel this command at this time. 

The Move To Layer performs auto-insertion of vias with a slight difference compared with the 
Route Manual command.    A via will not be inserted if a line segment is already connected to a pad or via. 
If the existing pad or via is incorrect for maintaining physical connectivity, the line segment will not be 
moved.

When moving copper traces between layers, vias are not added for free copper, only for net 
copper.    The net attribute VIASTYLE will be honored as it is in Route Manual.    

When multiple objects are moved and the physical connectivity cannot be maintained for some of 
the objects (e.g.,if a via cannot be added), a warning message appears prompting you to continue or 
cancel the command.    If you press Cancel, the objects moved before the cancel will not be moved back. 
If you press Continue, the object with the error will not be moved and the tool will skip to the next object.

If a copper pour is currently poured, it will be unpoured before the move and automatically 
repoured after a move.    If the pour is not correct, use Modify Copper Pour to repour the pour.    If the pour
is not poured, it will remain unpoured after the move.    A pour's net connectivity will be maintained.



Edit Properties
Displays the Properties dialog for the selected object(s).    This dialog lets you query and modify the 
selected objects properties.    Except when selecting components and nets, you must use the Select 
tool to select the object(s) before you can run Edit Properties.

The Properties dialog that appears is specific to the object you select.    If multiple objects are selected, 
they must all be of the same type (e.g., arcs), otherwise the command is grayed and no dialog will 
appear.    If the objects are of the same type, the changes you make apply to all selected objects.

Right Mouse Button to Query/Modify
You can also run the Properties command from a popup menu.    Select an object and click the right 
mouse button to bring up a pop-up menu.    The items available from this pop-up menu vary depending 
on the object you select.

Double Click to Query/Modify
You can also run the Properties command by double clicking on an object to open that objects Property 
dialog, if the option is enabled in the Options Preferences dialog.

To learn how to query or modify an objects properties, click an object from the list:
Component Properties
Line Properties
Arc Properties
Pad Properties
Via Properties
Polygon Properties
Copper Pour Properties

Cutout Properties
Plane Properties
Text Properties
Attribute
Field Properties
Connection Properties
DRC Error Indicator Properties



Plane Properties
When you select a cutout and run the Edit Properties command, the Cutout Properties dialog appears 
with the Plane tab selected.    

The Net tab on the Connections Properties dialog provides access to Net information.

The Plane Properties dialog presents the following information: 

Net:    Use the drop down list box to assign the plane to an existing net.
Boundry Width:    This box define the line width for the Polygonal outline.    The default is the 

current defaut line width.    Change the width by typing over the default value.

Net Plane Color Button
Select a net plane color, by clicking the Net Plane Color button and selecting a color from the Color 
dialog.



Connection Properties
When you select a connection and run the Edit Properties command, the Properties dialog appears with
the Connection tab selected.    

For the connection Start and End points, you see these query fields:

Net Name:    The net name of the connection.
X and Y coordinates:    The X and Y location of the start and end point.
Node:    The node name to which this connection is connected.
Type:    The type of start or end point shows what the connection is connected to (e.g., pad).

The Net tab on the Connections Properties dialog provides access to Net information.



Copper Pour Properties
When you select a copper pour and run the Edit Properties command, the Properties dialog appears 
with the Style tab selected.

This dialog allows you to establish or change the characteristics of a copper pour object.    A typical 
scenario would be to draw multiple copper pour outlines (Place Copper Pour), then select them all in a 
multiple select action, and modify them all at once.

When you click OK, the copper pour shape fills in (if Poured was enabled).    The copper pour polygon 
will remain selected (in the select highlight color) until you click outside of the shape.

warning:
You can mistakenly split the copper pour in half (or more than two pieces) by modifying lines or 
polygons that were inside the pour region to where they are longer than the copper pour polygon. 
In that case, the electrical connection would be severed.

On the Style tab, you'll have following options available to you:

Line Options
Line Width determines the width of the lines used in filling and hatching.    

Line Spacing determines the separation between fill or hatch lines.    If you selected Solid for the Fill 
Pattern, then the Spacing value is grayed.

Backoff Option
The Backoff option allows you to set the distance between the copper pour and any objects that may 
be inside of the copper pour polygon.    This option also backs off from any objects that are outside the 
copper pour polygon if they are too close to it.    The copper pour backoffs from any copper item that is 
not in the net associated with the pour.    The backoff options takes the objects thickness into account.

If you choose the Fixed radio button, you can specify a value for this distance.    

If you choose Use Design Rules, the backoff distance for a specifc net can be set using design rules    
(see the Options Design Rules command).      Backoff clearances are fixed at the greatest of the Line to 
Line or Line to Pad clearance amount set for the current layer in Options Design Rules dialog.

State Options
Poured Unpoured and Repour are the fill states of the Copper Pour.    Repour can be selected to force
an already filled pour to recalculate its islands.

This tab also allows you to select Fill Patterns, and to set the Backoff     Smoothness  .

The following tabs on the Properties (Copper Pour) dialog provide access to additional 
information:

Connectivity
Island Removal



Net



Fill Patterns
Select one of the following Fill Patterns: 

Solid copper fill will actually be banded (striped) with lines.
Horizontal fills the pour with horizontal lines (no hatching).
Vertical fills the pour with vertical lines (no hatching).
45-degree Cross is cross-hatched diagonally, at a 45-degree angle (like X).
90-degree Cross is cross-hatched horizontally and vertically, at a 90-degree angle (like +).



Thermals
The Thermals options determine whether to use thermals, and if you do, what type.    

None specifies that the copper will pour right over pads and vias (no thermals) that belong to the 
same net as the copper pour (i.e., direct connect).    

45 and 90 specify 45- or 90-degree thermals.



Backoff Smoothness
These options allow you to set the smoothness of backoff polygons.    There are three objects:

Low specifies eight- to 10-sided polygons.    
Medium specifies 12- to 14-sided polygons.    
High specifies 16- to 18-sided polygons.    



Connectivity
When you select the Connectivity tab, the Properties dialog appears with the following options: 

Thermals
The Thermals options determine whether to use thermals, and if you do, what type.    

None specifies that the copper will pour right over pads and vias (no thermals) that belong to the 
same net as the copper pour (i.e., direct connect).    

45 and 90 specify 45- or 90-degree thermals.

Spoke Width
The Spoke Width option allows you to specify a value for the width of the thermal spokes.

Net Combo Box
The Net combo box allows you to list the net that you want the copper pour to connect to.    The copper 
pour will backoff from all copper items not in this net.    If no net is specified, the copper pour backs off 
from all copper objects inside the pour region except other "no-net" copper pours.

The following tabs on the Copper Pours Properties dialog provide access to additional 
information:

Style
Island Removal
Net



Island Removal
When you select the Island Removal tab, the Properties dialog appears with these three Automatic 
Island Removal objects, which allow you to set the smoothness of backoff polygons:

Minimum Area specifies a minimum area an island can have before being removed.    Enter a 
minimum value (in square units) in the text box.

Interior specifies that all islands in a pour that dont have an edge in common with the perimeter 
of the copper pour are removed.

Do not repour performs the island removal without repouring the pour.    This is a very fast way to
remove unwanted islands since you do not have to wait for the pour to regenerate.



Cutout Properties
When you select a cutout and run the Edit Properties command, the Properties dialog for cutouts 
appears.    

The Properties dialog for cutouts shows you the following information: 

Layer:    The layer on which the cutout appears.
Points:    The X and Y location of each point in the cutout polygon.



Field Properties
When you select a field and run the Edit Properties command, the Fields Properties dialog appears.    

Query Fields
The Properties dialog for fields lets you view the following:

Value:    The field value entered in the File Design Infor dialog. 
Rotation:    The Rotation field shows the rotation amount if the field has been rotated.

Name
The field name appears in the Name drop down listbox.    You can change the name by selecting a new 
field from the list of field name.

If you change the field name, its value changes accordingly.

Location
The X and Y coordinates of the selected field appear in the Location box.    You can move the field, by 
typing new coordinates.

Justification
Nine buttons allow you to change justification by setting the reference point of the field.    For example, if
you enable the middle button, the field reference point (the lower-left corner) moves to the center of the 
bounding rectangle.

Text Style
Text styles appear in the drop down listbox.    To change the Text Style, click on the text style you want 
from the Text Style listbox.

Clicking the Text Style button displays the Options Text Style dialog.

From this dialog you can add, delete, rename, or edit text styles.    



Layer
The layer on which the field is placed appears in the Layer drop down listbox.    You can change the 
layer by selecting a new field from the list of field name.    @@IS THIS GONE??



Arc Properties
When you select a free arc and run the Edit Properties command, the Arc Properties dialog appears.    

Query Fields
For the free arc Center, Start, and End points, you see:

X and Y coordinates:    The X and Y location of the Start and End point.
Tangent Slope Angle:    The tangent slope angle of the arc.

Change Arc Properties
You can only change these properties if the arc is not part of a net and is not connected to other 
objects.

To change the arcs Start Angle:    use the scroll buttons (up and down arrows) to scroll through arc 
start angles or type in the new value. 

To change X and Y coordinates of the Center Point:    type over the existing X and Y values in the 
Center Point box.

To change the arcs Sweep Angle:    use the scroll buttons (up and down arrows) to scroll through arc 
sweep angles. 

To change the arcs Radius:    type a new radius over the existing value. 

To change the arcs line Width:    type a new width over the existing value.



Line Properties
When you select a free line and run the Edit Properties command, the Line Properties dialog appears. 

This dialog shows you the Length of the selected line.

Change Line Properties
You can change line properties as follows:

To change the lines Width:    type a new width over the existing value.

To change the lines End Points:    type new X and Y coordinates over the existing values.    You can 
only change end points if a line is not part of a net and is not connected to other objects.



Pad Properties
When you select a free pad and run the Edit Properties command, the Pad Properties dialog appears 
with the Pad tab selected.

The Net tab on the Pad Properties dialog provides access to Net information.

Query Fields
The Properties dialog for free pads shows you the following:

Net Name:    The name of the net associated with the selected pad.
Tool Code:    The tool code used to select the drill bit for the corresponding hole diameter.    See 

the File N/C Drill command for additional information.
Flip:    The Flip box indicates whether or not the pad has been flipped.
Rotation:    The Rotation field shows the rotation 

Change Pad Properties
You can change pad properties as follows:

Pad Number:    Changing the pad number is useful when you only want to change one or two pads.    If 
you want to renumber a series of pads, use the Utils Renumber command for smoother and faster 
action.

Location:    Enter new X and Y coordinates for the pad.

Pad Style:    You can change the style of the selected pad by selecting one of the existing pad styles in 
the Pad Style listbox. 

Clicking the Pad Styles button displays the Options Pad Style dialog.    From this dialog you can modify 
a pad style.



Free Polygon Properties
When you select a free polygon and run the Edit Properties command, the Properties dialog appears. 

The Properties dialog for free polygons shows you these two fields:

Area:    The area of the polygon.
Points:    The X and Y location of each point in the free polygon.    You can type over the existing 

values.



Text Properties
When you select a text and run the Edit Properties command, the Text Properties dialog appears.    

From this dialog, you can change the text content, justification, and style.    You can also modify any 
non-default text styles. 

Query Fields
The following fields are available for viewing only:

Flip:    The Flip box indicates whether or not the text has been flipped.
Rotation:    The Rotation field shows the rotation of the text.

Changing Text Properties
To change the Text:    Type over the text displayed in the Text box and click OK.    For multi-line text, 
Enter creates a line break.    You can enter a maximum of 2,000 characters.

While the Text edit box has focus, you can use Ctrl+V to paste text from the Windows clipboard.    

To change the text Location:    The X and Y coordinates of the selected text appear in the Location 
box.    You can move the field, by typing new coordinates.

To change the text Justification:      Under Justification are nine buttons, which allow you to change 
text justification by setting the reference point of the text string.    For example, if you enable the middle 
button, the text reference point (the lower-left corner) moves to the center of the bounding rectangle.

To change the Text Style:    Click on the text style you want from the Text Style listbox.

Text Style
Text styles appear in the drop down listbox.    To change the Text Style, click on the text style you want 
from the Text Style listbox.

Clicking the Text Style button displays the Options Text Style dialog.



Attribute
When you select and attribute and run the Edit Properties command, the Attribute Properties dialog 
appears.

The following information appears in the dialog:

Category Listbox:    Displays a list of all attribute categories, All, Component, Net, Clearance, 
Router and SPECCTRA.    Selecting a category brings up a list of pre-defined attributes for that category.

Name Listbox:    Displays all pre-defined attributes for the specified category.    The first entry in 
the list is User-defined.

The currently-selected attribute also appears in the Name edit box, unless User-defined is 
selected.    In that case, the Name edit box is blank so that you can enter a user-defined attribute name.

Name Edit Box:    For user-defined attributes, enter a name for the attribute. 

note:
If the dialog is accessed for an attribute that already has a name, then the Category listbox, 
Name listbox, and Name edit box are filled in, but grayed.    If the attribute doesnt have a name, 
these controls are enabled.

Value:     Use this edit box to enter a value for the attribute.
Visible:    This checkbox indicates whether or not the attribute is visible.
Location:    This area shows the X and Y coordinates of the components reference point.
Text Style:    This area lets you select the Ref Des, Value, and Type text style.    Text styles 

appear in the Text Style drop down listbox.    To change the Text Style, click on the text style you want 
from the listbox.

Layer:    This combobox shows the name of the layer on which the attribute is located.    To 
change the layer, select a new one from the drop down list.

Rotation:    Shows the rotation amount if the pattern has been rotated.
Flipped Box: This box indicates whether or not the pattern has been flipped. 
Justification:      Under Justification are nine buttons, which allow you to change text justification

by setting the reference point of the text string.    For example, if you enable the middle button, the text 
reference point (the lower-left corner) moves to the center of the bounding rectangle.



Component Properties
When you select one or more patterns and run the Edit Properties command, the Component 
Properties dialog appears with the Pattern tab selected.    

The Component Properties dialog allows you to observe properites for the selected component and to 
modify certain component properties.    The selected component appears in a view area of the dialog.

Pattern Tab
The following information appears in the dialog:

The Ref Des box shows the reference designator name.    To change the reference designator, 
type a new value in the Ref Des field.    If you selected more than one component, this value cannot be 
changed.

The Value box shows the components value.      To change the value, type a new value in the 
Value field.

The Type drop down list box shows the component type.      
The Libraries box lets you select a library when you want to change the type of component.
The Visibility area contains checkboxes indicating whether the selected component(s) have 

visible, invisible, or undetermined Ref Des, Value, and Type attributes.    
If a box is checked, the attribute is visible.    If the box isn't checked, the attribute is invisible.    If 

the box is grayed, then the attribute either does not exist (e.g., there is no Value attribute for the selected 
component), or there is a conflict between multiple components selected (e.g., the attribute on one 
component is visible, but is invisible on another).    

The Text Style area lets you select the Ref Des, Value, and Type text style.    Text styles appear 
in the Text Style drop down listbox.    To change the Text Style, click on the text style you want from the 
listbox.

The Pattern field displays the pattern name.    To change the pattern, type a new pattern name in 
the box.    Changing the pattern in this dialog doesn't change the pattern attached to the component in the
library.

The Location area shows the X and Y coordinates of the components reference point.
The Flip box indicates whether or not the pattern has been flipped. 
The Rotation field shows the rotation amount if the pattern has been rotated.
The Glue Dot Locations listbox shows a list of all glue dot locations.    Glue Dots are used to 

hold components in place until they are soldered during manufacturing.
The Pick and Place Locations listbox shows a listing of all pick and place locations.    Pick and 

Place points provide reference points in directing the pick and place mechanism (or auto insert) in 
manufacturing (picking up the component and placing it on the board).

To replace a component, click the following topic:
Replacing a Component

Clicking the Text Style button displays the Options Text Style dialog.

In addition to the Pattern tab, the following tabs on the Component Properties dialog provide 
access to additional information:

Pattern Pads Tab
Component Tab
Component Pin Tab
Attributes Tab



Replacing a Component
To replace the component(s) associated with this pattern with another component from any open library:

1. To select a component from another open library, select a new library from the Libraries listbox.

2. Select a new component from the drop down listbox.

3. Click OK to replace the component or components with the new component.

The new component is placed at the same Reference Point and same Rotation as the old.

The net connectivity is maintained after the swap.

If connectivity can't be maintained, a warning message appears and the component is swapped.

note:
Using the Properties function to swap a component can result in changes to the netlist if the pin 
designators on the replacement component are not the same as those on the original component.

If a warning message indicates that netlist changes have occurred, not only may some netlist 
nodes and their corresponding from-to connections be missing, but the net names may be 
removed if they result in a single node net.    Additionally, any intelligent copper connected to the 
pads that are no longer netlist nodes are stripped of their netlist information.    Use Edit Undo if 
you want to undo the component swap.



Component Tab
When you select the Component tab, the Component Properties dialog appears showing component 
information. 

This dialog shows information for the component or components you selected.    It shows information on
a gatebygate basis.    This information is display-only; it cant be modified from this dialog.    

To show information for a different gate, select the gate from the Gate Number drop down list box.



Component Pins Tab
When you select the Component Pins tab, the Component Properties dialog appears.    Use this dialog 
to look at pin information for the component pins within the symbol or component.    

The following information appears:

Pad #:    The number of the corresponding pad on the attached pattern. 
Pin Des:    The pin designator of each pin in the component.
Gate #:    The part number defines the part that the pin is associated with.    In multi-part 

components, the parts are uniquely numbered from 1 through n.
Pin #:    The number of the corresponding pin on the attached symbol.    
Pin Name:    The pin name associated with that pin designator.
GateEq:    The gate equivalence column defines which gates are equivalent.    All gates with the 

same GateEq number are defined to be equivalent.    This information is used by PCB Schematic when 
automatically incrementing reference designators (e.g., Place Part and Utils Renumber commands) and 
by PCB to determine which gates can be swapped during manual or automatic gate swapping.

PinEq:    Indicates which pins within a gate are logically equivalent and may be swapped using 
the Utils Optimize Nets pin swap commands.    The pin equivalence values must be non-zero and identical
for a swap to occur between two pins.    Non-swappable pins are indicated with a zero value.

Elec Type:    The electrical type of the pin.    



Attributes Tab
Allows you to display and modify component attributes for the selected component.    When you click 
the Attributes tab, the dialog appears.

You can view, add, modify, or delete a collection of component attributes.    The dialog contains a two-
column table showing the collection of component attributes.    Within the collection, each attributes 
name and value appear in the column.

Changing an Attributes Value:    To change a value, select it and type the new value over the 
existing value.    The name column cannot be changed

Adding an Attribute:    To add an attribute, click the Add button to open the Attribute dialog.    
Enter the name and value for the attribute and set attribute properties.    Click OK, and the attribute is 
added to the table.    

Viewing or Changing Attribute    Properties:    To view or change an attributes properties, select
an attribute from the table and click the Properties button (or double-click the attribute) to open the 
Attribute dialog. 

To Delete an Attribute:    Select an attribute in the table and click Delete, or press the Del key.

Attribute Dialog
The following information appears in the Attribute dialog:

Category Listbox:    Displays a list of all attribute categories, All, Component, Net, Clearance, 
Router and SPECCTRA.    Selecting a category brings up a list of pre-defined attributes for that category.

Name Listbox:    Displays all pre-defined attributes for the specified category.    The first entry in 
the list is User-defined.

The currently-selected attribute also appears in the Name edit box, unless User-defined is 
selected.    In that case, the Name edit box is blank so that you can enter a user-defined attribute name.

Name Edit Box:    For user-defined attributes, enter a name for the attribute. 

note:
If the dialog is accessed for an attribute that already has a name, then the Category listbox, 
Name listbox, and Name edit box are filled in, but grayed.    If the attribute doesnt have a name, 
these controls are enabled.

Value:     Use this edit box to enter a value for the attribute.
Visible:    This checkbox indicates whether or not the attribute is visible.
Location:    This area shows the X and Y coordinates of the components reference point.
Text Style:    This area lets you select the attribute text style.    Text styles appear in the Text 

Style drop down listbox.    To change the selected Text Style, click on the text style you want from the 
listbox.    To modify the text style, click the Text Style button.

Rotation:    Shows the rotation amount if the pattern has been rotated.
Flipped Box: This box indicates whether or not the pattern has been flipped. 
Justification:      Under Justification are nine buttons, which allow you to change text justification

by setting the reference point of the text string.    For example, if you enable the middle button, the text 
reference point (the lower-left corner) moves to the center of the bounding rectangle.



Pattern Pads Tab
When you select the Pattern Pad tab, the Component Properties dialog appears.    This dialog allows 
you to change the pad style of specific pins within the component and edit the pad style itself.

Query Fields
The following information appears (for display purposes only):

Location:    The X and Y coordinates of the selected pad.
Flip:    The Flip box indicates whether or not the pad has been flipped.
Rotation:    The Rotation field shows the rotation amount if the pad has been rotated.
Net Name:    The net name for the net to which the pad is attached.
Tool Code:    The tool code used to select the drill bit for the corresponding hole diameter.    See 

the File N/C Drill command for additional information.

This dialog has two listboxes.    To learn about them, click on one of the following topics:
Pads Listbox
Pad Styles Combo Box



Pads Listbox
The Pads listbox lists the pin numbers of the pads in the selected component.    The information fields 
to the right display information about the highlighted pad.    

The Set All and Clear All buttons can be used to highlight and unhighlight all pads in the listbox.



Pad Styles Combo Box
The Pad Style list box allows you to perform single or multiple pad editing.    The pad numbers are 
highlighted in the Pads listbox and you can either change to another pad style for those pads, or you 
can click Pad Styles to display the Options Pad Style dialog, allowing you to modify an existing pad 
style, rename it, or create a new one based on an existing style. 

Click Apply to apply any modifications to the selected pad or pads.



Via Properties
When you select a via and run the Edit Properties command, the Properties dialog for vias appears.

Use this dialog to view or change the style of the selected via and to change its location.

The Net tab on the Via Properties dialog provides access to Net information.

To learn about this dialogs query fields, click the following topic:
Via Properties Query Fields

To learn about changing pad properties, click the following topic:
Changing Via Properties

To learn about the Text Style button, click the following topic:
Via Styles Button



Via Properties Query Fields
The following fields are available for viewing only:

Net Name:    The name of the net associated with the selected via.
Tool Code:    The tool code used to select the drill bit for the corresponding hole diameter.    See 

the File N/C Drill command for additional information.
Flip:    The Flip box indicates whether or not the via has been flipped.
Rotation:    The Rotation field shows the rotation of the via.



Changing Via Properties
You can only change these properties if the via is not part of a net and is not connected to other objects.

To change the via location:    The X and Y coordinates of the selected via appear in the Location box. 
You can move the field by typing new coordinates.

To change the via style:    Click on the via style you want from the Via Style listbox.



Via Styles Button
Click Via Styles to display the Options Via Style dialog for via styles.    From this dialog you can add a 
new style based on an existing style, modify a non-default via style, or delete a non-default via style.    



Modify (View) DRC Errors
Using the Edit Modify command or Modify from the Select popup menu allows you display a dialog from
which to view DRC error/violations through indicators visible in your design.    Each indicator represents 
an error or violation detected in the design rule checking pass (Utils DRC).    You can block select error 
indicators and cycle through them by error number.

To generate DRC error indicators, use the Utils DRC command.

To block select DRC error indicators, use the Options Block Selection command to include the 
indicators in a block select, then use Edit Select to perform the block select.

To display DRC error indicators, use the Options Display command, click Misc... and click Show DRC 
Errors.

View DRC Errors
1. Select DRC error(s) either individually or through a block select.

2. Click the right mouse button and select Modify from the popup menu, or choose Edit Modify to 
display the View DRC Errors dialog.

3. The dialog is view-only, therefore you are limited to reading error information, or scrolling through 
the errors if you have selected multiple errors in the design.

Use the Next and Previous buttons to scroll forward and backward through the errors.



Edit Delete
Deletes all selected objects.    Use the Del key as a shortcut.

This command does not cut the data to the clipboard (as does Edit Cut).    As there is nothing to paste, 
the only way to reverse Delete is to use the Edit Undo command.

You can also access Delete from the popup menu (select an object, then click the right mouse button to 
display).

To Delete Objects
1. Choose Select from the Edit menu (or use the Select button on the Toolbar).    Click on the object 

you want to delete.    

2. Choose Delete from the Edit menu, press the Del key, or click the right mouse button and select 
Delete from the popup menu.    If you mistakenly delete an object, choose Undo from the Edit 
menu to reverse the delete action.

This operation can also be performed with multiple objects by using multiple select and block 
select operations.    Refer to Edit Select.

Deleting Objects from Nets
When you delete objects from nets, you can get a variety of results, depending on what you delete and 
the makeup of the net you delete from.    The function of smart nets is to maintain certain connections 
when objects such as copper connections, unrouted connections, and net nodes are deleted.    In 
general, the following can occur.

If you delete free copper (no connections), then the copper disappears and no connection 
compensation occurs.

If you delete net copper, then it will be replaced with connections to maintain the net.
If you delete a node, then the remaining nodes are still part of the net, and there will be 

compensation to maintain connections between the remaining nodes.
If you delete a component, you are removing nodes from all nets to which the component's pads 

were connected.    The connectivity feature of PCB reconnects the remaining nodes in each net in the 
most efficient way.

If you delete a connection from the middle of a net, the net is split. One portion retains the original
net name and the others are given new system-generated names.

If you delete a connection that isolates a pad from the rest of the net, you end up with a 
disconnected node that is no longer part of any net.

If you delete a copper segment that is part of a net, that segment is not deleted, but instead 
becomes a connection (in effect unrouting the net).    In this case, the net remains intact, although 
changed.

Related Topics
Select
Undo



Edit Copy Matrix
Duplicates all the selected objects according to the parameters you specify.    The objects must be 
selected first before Copy Matrix can function.    

In the Edit Copy Matrix dialog, the Number of Columns and Number of Rows determine the number 
of X (horizontal) and Y (vertical) duplications, respectively, of a selected object.    

Column Distance and Row Distance allow you to enter a value, in current units, to determine the 
spacing between the duplicated objects.    With Column, a positive value will duplicate to the right, a 
negative value to the left.    With Row, a positive value will duplicate up, a negative value down.    For 
example, if you specify 200 mil for Column Distance and 200 mil for Row Distance (and specify 3 rows 
and 3 columns), the result is a matrix with 9 objects 200 mils apart. 

The values represented in Distance will default to mm (millimeters) or mil, depending on what you have
set in Options Configure (your current units).    You can specify a measurement value (overriding 
Options Configure) by typing in mil, mm, cm, or in after the numerical value.

To Duplicate an Object(s)
1. Choose Select from the Edit menu.    Select the object(s) you want to duplicate by clicking and 

releasing over the objects to highlight them.    

2. Choose Copy Matrix from the Edit menu, and the dialog appears.    

3. In the Number of Columns box, specify how many duplications you want to perform horizontally. 
In the Column Distance box, enter a value to determine the spacing between duplications and in
which direction (positive=right, negative=left) to duplicate. 

4. In the Number of Rows box, specify how many duplications you want to perform vertically.    In 
the Row Distance box, enter a value to determine the spacing between duplications and in which
direction (positive=up, negative=down) to duplicate.

You will receive an error message if what you specify for your duplication is too large to appear 
the workspace

5. Click OK.    If your duplication is unsatisfactory, select Undo to reverse the action and try again.

See also:
Select
Undo



Edit Explode Component
This command allows you to convert a component back to its basic primitives, creating a collection of 
editable graphic objects.    When you explode a component, the collection of objects is no longer a 
component or a pattern.

This feature is useful for modifying an existing component or creating a new component from an 
existing one.    After you explode the component, you can then perform changes to the objects such as 
adding more pads, changing line size or thickness, renumbering pads, etc.    

warning:
Make sure that the component you are about to explode has not been flipped.

To Explode a Component
1. Select the component you want to explode by using the Select button from the Toolbar or with the

Edit Select command.

2. While the component is selected (in the Select color), choose Explode Component from the Edit 
menu.

3. The component then becomes a collection of modifiable objects.    To create a component again, 
you must save the objects as a pattern (Library Pattern Save As command), and then define the 
pattern as a component in the Library Manager.

To alter an existing component in place without having to save its pattern to a library, use the Sub 
Select feature.

Refer to the Library Pattern Save As command for more information.



Edit Alter Component
Allows you to select certain component items and subsequently move, rotate, flip, and (in some cases) 
delete them.

With this editing process you can alter certain component characteristics either for aesthetic reasons or 
manufacturing improvement, such as avoiding any co-location problems during manufacturing (e.g., 
through-holes and silkscreen paint).    The rules/restrictions are as follows:

Pads cannot be selected, and therefore cannot be edited in any way.
RefDes, Type, Value and Ref Point (reference designators and reference points) cannot be 

deleted.    
If you want to hide the RefDes, Value, or Type, modify the component (select and Edit Modify), 

and disable the Visibility options.    To hide Glue Dot and Pick and Place points, disable their respective 
display options in Options Display (Misc).

You cannot undo any alter actions until the operation is complete.

Alter a Component
1. Run the Edit Select command to select the component you want to edit.    Then run the Edit Alter 

Component command.    You are now in a temporary editing mode, signified by the crosshair 
cursor shape.

2. Zoom in sufficiently.    Change layers if necessary.    You can select items individually only if you 
are on the correct layer, otherwise you need to use a block select.    The settings in Options Block 
Selection can affect your results here.

Editable items typically reside on the Top Silk layer, except for Ref Points, which aren't layer 
items, but this depends on how the pattern was originally created.

3. After you have selected individual item(s), you can then move, delete, or otherwise alter them 
(according to the restrictions mentioned previously).    Press Esc or click the right mouse button to
end the editing mode.



Edit Select All
Selects all items on the current sheet.



Edit Deselect All
Deselects all items previously selected.



Edit Highlight
Highlights the selected item or items in one of the highlight colors chosen through the Options Display 
command.    Successive invocations of this command cycle through the defined highlight colors.    If you 
do not want to use two highlight colors, set both colors to be the same in the Options Display dialog 
box.

If PCB and PCB Schematic are both running, and if the DDE Hotlinks checkbox in the Options 
Configure dialog box is checked in both applications, then component and net highlight information is 
communicated between the two applications.    Highlighting a net in one application highlights the 
corresponding net in the other application; highlighting a pattern in PCB highlights the corresponding 
symbol in PCB Schematic and vice versa.

When you run this command, the selected items are drawn in the highlight color until they are 
unhighlighted.    The selected color overrides the highlight color, so you won't see the highlights until the 
items are deselected.

You can also access this command by selecting an item or items, clicking the right mouse button to 
bring up the popup menu, and choosing Highlight.



Edit Unhighlight
Removes the highlighting from the selected item or items and restores the normal object colors.

If PCB and PCB Schematic are both running, and if the DDE Hotlinks checkbox in the Options 
Configure dialog box is checked in both applications, the highlights are removed from the selected item 
or items in both applications.

You can also access this command by selecting an item or items, clicking the right mouse button to 
bring up the popup menu, and choosing Unhighlight.



Edit Unhighlight All
Select the Unhighlight All command to remove the highlight from all items on all layers in the design and
to restore the normal object colors.    This command applies to all highlighted objects, regardless of 
whether they are selected or not.

If PCB and PCB Schematic are both running, and if the DDE Hotlinks checkbox in the Options 
Configure dialog box is checked in both applications, the highlights are removed in both applications.



Edit Nets
Allows you to display, hide, and rename nets, display net information, select net items, and edit net 
attributes.    These functions are not undo-able.

When you run the Edit Nets command, the Edit Nets dialog appears. 

Nets Listbox
The Net Names listbox contains the names of all nets in the active design.    You can select individual or
multiple nets in the listbox.    Once selected, you can highlight and unhighlight nets and jump to a node 
in the net.

Nodes Listbox
The Nodes listbox contains the names of all nodes in the net that is outlined by the focus cursor in the 
Net Names listbox.    If you select more than one node, this listbox is blank.

Set All Nets/Clear All Nets
These buttons allow you to select or deselect all of the nets displayed in the Nets list box. 

Set Nets by Attr
When you click the Set Nets by Attr button, the Set By Attribute dialog appears.    This dialog lets you 
find those nets for which attributes have been defined.

If you select an attribute from the list box and click OK, you are returned to the Edit Nets dialog.    All 
nets that have that attribute defined are highlighted.

If you select an attribute and click Change Value, you can set a specific attribute value for that attribute 
name.    When you return to the Edit Nets dialog, all nets with the selected value for the attribute are 
highlighted.

You can select multiple attribute names and values.    When you return to the Edit Nets dialog, only 
those nets with all of the selected attribute names and values are highlighted.

To select all attribute names and current values, click Set All.    Clear All deselects all attributes.    The 
Clear current items checkbox allows you to control whether or not nets matching the selected 
attributes are added to, or replace, the highlighted nets in the Edit Nets dialog.    If this checkbox is 
enabled, only nets having the selected attributes are highlighted (i.e., the Nets List is cleared first).    
Otherwise, those nets are added to the list of highlighted nets.    

Show or Hide Connections
When you choose Show Conns or Hide Conns, the connections for the net highlighted in the list box 
are either displayed or hidden on the screen.    An asterisk next to a net name means the connections 
are visible.    The display of nets does not affect the routing of the net.



Edit Attrs Button
To learn about net attributes, click the following topic:

Net Attributes Tab

View Attrs
When you select one or more nets from the Nets listbox, the View Attrs button becomes active.    Click 
View to open the Windows Notepad utility and display a list of attribute names and values for each 
selected net.

In conjunction with the Set Nets By Attributes button, the View option makes it easy to find nets with 
the same attribute value, and then view all attribute values for those nets.

Rename
When you highlight a single net name in the Nets listbox, the Rename button becomes active.    Click 
Rename and the Net Name dialog will display.

Type in the new name and click OK to rename the net and return to the Edit Nets dialog.

Info
When you highlight a single net name in the Nets listbox, the Info button becomes active. You can 
display the Net Info dialog with the Info button. 

Net Info displays detailed information about length and characteristics of the selected net.    It only 
measures the X and Y distances, not depth (such as via length to another layer).    Arc length is included
(accurately) in the calculation of connection and copper lengths.    The Manhattan length is an 
approximation of the final routed length of a diagonal connection.

Select
You can select a net or multiple nets in the design by highlighting the net names in the listbox in the Edit
Nets dialog, then clicking the Select button (the button is enabled only if a net is chosen).    The nets in 
the design will highlight.    

Net Selection Mask
The performance of Select Net is directly affected by the settings in Options Block Selection.    For 
example, you could configure Options Block Selection to allow you to select line segments in a net 
while ignoring the vias (it ignores the inside/outside block specifications), allowing you to modify line 
widths for all segments in a net.

This feature is useful for unrouting a design (net by net) by highlighting routed copper items and 
deleting them.    Be careful to disable selection of connections when unrouting nets.    If a connection is 
deleted, the corresponding net is changed or destroyed.

You can also select nets through the Select popup menu.    Select an item that is part of a net (Edit 
Select), click the right button, and choose Select Net from the popup menu.    The complete net 
attached to the selected item will be selected and highlighted.



In the Edit Nets dialog, click Close to exit the dialog.

Set Nets By Node Count
This feature lets you select all nets with a node count between the range you specify in the 
corresponding Min and Max edit box.



Net Attributes
Allows you to display and modify component attributes for the selected component.    

When you click the Attributes tab, the dialog appear.

You can view, add, modify, or delete a collection of net attributes.    The dialog contains a two-column 
table showing the collection of net attributes.    Within the collection, each attributes name and value 
appear in the column.

Adding an Attribute:    To add an attribute, click the Add button to open the Attribute dialog.    
Enter the name and value for the attribute and set attribute properties.    Click OK, and the attribute is 
added to the table.    

Viewing or Changing Attribute    Properties:    To view or change an attributes properties, select
an attribute from the table and click the Properties button (or double-click the attribute) to open the 
Attribute dialog. 

To Delete an Attribute: Select an attribute in the table and click Delete, or press the Del key.

Attribute Dialog
The following information appears in the Attribute dialog.

Category Listbox:    Displays a list of all attribute categories, All, Component, Net, Clearance, 
Router and SPECCTRA.    Selecting a category brings up a list of pre-defined attributes for that category.

Name Listbox:    Displays all pre-defined attributes for the specified category.    The first entry in 
the list is User-defined.

The currently-selected attribute also appears in the Name edit box, unless User-defined is 
selected.    In that case, the Name edit box is blank so that you can enter a user-defined attribute name.

Name Edit Box:    For user-defined attributes, enter a name for the attribute. 

note:
If the dialog is accessed for an attribute that already has a name, then the Category listbox, 
Name listbox, and Name edit box are filled in, but grayed.    If the attribute doesnt have a name, 
these controls are enabled.

Value:     Use this edit box to enter a value for the attribute.

The following items appear grayed in the dialog:

Visible:    This checkbox indicates whether or not the attribute is visible.
Location:    This area shows the X and Y coordinates of the components reference point.
Text Style:    This area lets you select the attribute text style.    Text styles appear in the Text 

Style drop down listbox.    To change the selected Text Style, click on the text style you want from the 
listbox.    To modify the text style, click the Text Style button.

Rotation:    Shows the rotation amount if the pattern has been rotated.
Flipped Box: This box indicates whether or not the pattern has been flipped. 
Justification:      Under Justification are nine buttons, which allow you to change text justification

by setting the reference point of the text string.    For example, if you enable the middle button, the text 
reference point (the lower-left corner) moves to the center of the bounding rectangle.

To learn more about attributes, click on the following topics:
Attribute Description for Autorouting
Clearance Attributes

See also:
Edit Nets dialog



 Attribute Description for Autorouting
The following attributes are recognized by the autorouter.    All other predefined net attributes are 
ignored for routing.

Attribute Description

WIDTH Overrides global line width settings for the selected nets.    A valid line width 
should be entered as the value.

VIASTYLE Overrides global via style settings for the selected nets.    An existing via style 
name should be provided.

MAXVIAS Defines the maximum number of vias that can be placed for this net.    Valid 
values are 0 (no vias) - n (any specific number).

RIPUP Overrides the global ripup setting for the selected nets.    Valid values are No, 0
and False.    All indicate that the net should not be ripped up.

NOAUTOROUTE Indicates that the selected nets will not be routed.    You can use Yes, 1, and 
True to override a default ripup of No

AUTOROUTEWIDE Indicates that the selected nets are scheduled as WIDE passes when you 
select passes manually.    You can use Yes, 1, and True to override a default 
ripup of No.



 Clearance Attributes
Along with other pre-defined net attributes, which are available from the Names list box, the following 
clearance attributes are available:

PADTOPAD
PADTOLINE
LINETOLINE
PADTOVIA
LINETOVIA
VIATOVIA
CLEARANCE

By adding one of these attributes to a net and assigning it a value, thematching global default clearance
is overridden for DRC and auto-routing.The value may have a suffix to define the units.    If the units are 
left off, then the current global units are used.    If the clearance value can't be converted to a valid 
number for DRC or auto-routing, then the attribute is considered undefined and the corresponding 
global clearance is used.      The last pre-defined attribute, CLEARANCE, defines a clearance value for 
all object pairs in this net.

For example, if the clearance between every object pair in a net is the same value, then the 
CLEARANCE attribute can be used to store that value, rather than creating six clearance attributes with
the same value.

ACCEL PRO Route honors the clearances for all object pairs, but doesnt use the clearance attributes 
defined in specific nets.    The log produced by PCB Route includes the clearance values used for all 
object pairs.    QuickRoute clearances are set to approximately 1/2 of the routing grid.    The SPECCTRA
autorouter uses net specific clearance attributes, net class clearance attributes, and class to class 
clearance attributes.



Edit Measure
Measures the X distance, Y distance, and total distance between two points.    Use the ruler button on 
the Toolbar as a shortcut for the Edit Measure command.

You can measure vertical, horizontal, and diagonal distances and the results will be displayed on the 
status line.    The measurements are displayed either in mils or millimeters, depending on current 
settings in Options Configure.    

Measure is a mode, meaning that if you were placing or selecting objects, when you use Measure you 
will exit the mode to go into measure mode.    After you have measured, you will need to restart 
whatever mode you were in to resume editing.

To Measure
1. Select Measure from the Edit menu (or use the Toolbar button).

2. Move the cursor to the first point of your measurement in the workspace.    Click and drag to the 
end point of the measurement.

3. Before you release, look at the results on the status line for X distance, Y distance, and T (for 
total) distance (in mm or mils).    When you release the button the results disappear.

note:
Measuring with the mouse does not snap to grid.    If you want to get a measurement strictly 
between grid points, you must use the arrow keys and space bar.



Edit Select
Edit Select is a tool which allows you to perform many functions and commands with previously placed 
objects and items.    The Select tool can also be enabled from the Toolbar button (arrow). 

Select Actions
single-, multiple-, or block-select

move, resize, rotate, flip, copy, modify, highlight, unhighlight, and delete

Select Commands
Edit Cut, Copy, Copy to File, Paste, Paste from File, Paste to Layer, Select All, Deselect All, Delete, 
Highlight, Unhighlight, Copy Matrix, Modify, Explode Component and Alter Component are operational 
when the Select tool is enabled.    Net Info and Select Net are available from the Select popup menu 
(select the item, then right mouse click to access) or through the Edit Nets command.

Select actions are possible only if an object is selected.    For example, you cannot move an arc unless 
it selected; you cannot modify a line unless it is selected.

Information included in this section only covers the mouse/cursor actions for Select:    

For keyboard equivalents to standard mouse functions in PCB, refer to Keyboard. 

For the Edit menu command descriptions, refer to their respective command sections.    

Selecting Objects
To single select, click a single object; all other selected objects are deselected.    You must be on the 
appropriate layer.

To multiple select, first select a single object, then hold down the Ctrl key and click on additional 
objects/items.    The selected objects are surrounded by a selection box, which increases as you add 
items to the multiple selection.    Click again on selected items (still using the Ctrl key) to deselect them 
individually.    If you release the Ctrl key and click anywhere other than one of the selected objects, all 
are deselected.    

To deselect, click an empty area of the workspace to deselect all items outside the selection region or 
run the Edit Deselect All command.

To block select, you click, hold and drag the cursor to create a selection box surrounding a block of 
objects, then release the button.    You can add objects to the block selection individually by doing a 
multiple select (see above paragraph).    

If you have Outside Block enabled (in the Options Block Selection command), then the selection will 
occur outside of the selection block.    If you have the Touching Block option enabled, a block selection
will include everything inside and touching the selection block.

A block selection mask can be used.    Objects can be filtered or masked in a variety of ways, depending
on how you set up the selection options.    Use the Options Block Selection command for altering or 
setting the selection options. 

To sub select, hold down the Shift key and click with the mouse.    This allows you to select a single 



object which is part of another object (e.g., a single pad in a component or an island in a copper pour).

When Objects Overlap
When objects overlap, it may seem difficult to select an underlying object.    Continue clicking without 
moving the cursor and Select cycles through all objects underneath the cursor.    The spacebar is easier
to use than the mouse in this situation (pressing the spacebar twice equals click and release for the left 
mouse button).    For multiple select, press the Shift key, then click the left mouse button without moving
the mouse.

Moving and Copying Objects
To move an object, you first need to select it, then click on the object and drag the cursor (with the 
object attached) to the new location.    Release to place the object.

If you are moving multiple objects within a selection box, click anywhere in the selection box and drag; 
all the selected objects in the box will follow.    Release the button to place the objects.

You can copy objects in the same manner; after you select the object(s), hold the Ctrl key down and 
drag a copy of the object(s) to where you want to place it.    When copying a component, the RefDes 
(reference designator) will change in the copy, and connections will not copy.    Any copper that is copied
will become free copper that is not associated with any net.    To cancel a move or copy in progress, 
click the right mouse button while the left mouse button is still depressed.

Resizing Objects
You can resize a selected object by clicking one of its handles, and dragging to stretch the object.    The 
resize function varies for the different objects.    

For example, to resize an arc you click one of the endpoint resize handles and drag the endpoint to 
increase the sweep angle.    To resize a polygon, you can grab one of its vertex handles and move it to 
change the polygon.    

When you move a handle that is on an edge between two vertices, a new vertex is created (allowing 
you even more reshaping).    You can delete a vertex by moving it to an adjacent vertex and releasing.

Lines, Arcs, Polygons, Copper Pours, Keepouts, and Cutouts can be resized with the Select mode 
resize function.

Rotating and Flipping
Select an object.    Press R to rotate 90 degrees counterclockwise.    To flip the object in the X direction 
(about the Y axis), press F while the object is selected 

Shift+R will rotate the object by the value specified in the Rotation Increment field of the Options 
Configure dialog (default is 45 degrees).

This function works on multiple- or block-selected objects as well.



ACCEL Tango PCB allows rotation in 90 degree increments only.

warning:
When you flip a pad or component, pad characteristics on Top, Top Silk, Top Paste, and Top Mask
layers are swapped by corresponding characteristics on the Bottom, Bottom Silk, etc. layers.    All 
other layers are left alone.    Perform the operation cautiously.

Edit Properties 
While the Select tool is enabled, run Edit Properties after an object is selected.    Or, use the Select 
popup menu by clicking on the object to select it, then clicking the right mouse button to display the 
popup menu, then choosing Properties from the menu.    Either way will display a dialog for the selected
object.    

Modifiable objects include Components, Lines, Arcs, Pads, Vias, DRC error indicators, Copper Pours, 
and Text.    Each entity is enabled in the same manner, but has its own particular Modify dialog and 
subsequent results.    Refer to the Edit Modify command documentation for information on all modifiable
objects.

Net Info
Net Info is available from the Select popup menu, accessed by selecting an item that is associated with 
a single net, then clicking the right button.    Net Info will either display a dialog or a message stating that
items from multiple nets were selected.

Net Info displays detailed information about length and characteristics of the selected net item.    It only 
measures the X and Y distances, not depth (such as via length to another layer).    Arc length is included
(accurately) in the calculation of connection and copper lengths.    The Manhattan length is an 
approximation of the final routed length of a diagonal connection.

To access Net Information by net name, use the Edit Nets command.

Select Net
After you have selected one or more objects that are associated with nets, this command will select all 
of the items in each of the nets.    It will select everything in a net except component pads.    If you select
a component, then choose Select Net, it will select all net items that emanate from the pads on the 
component.

This feature is useful for unrouting a design (net by net) by highlighting routed copper items and 
deleting them.    Be careful to disable selection of connections when unrouting nets.    If a connection is 
deleted, the corresponding net is changed or destroyed.

The Options Block Selection command will operate in conjunction with Select Net, except that it ignores
the inside/outside/touching block specifications.



View Commands (PCB)



View Commands (Route)



View Redraw
Clears everything in the workspace to the background color and then repaints the screen.    View 
Redraw is good to use when you have leftover traces and shapes from moving or deleting objects; 
Redraw erases leftover graphics.

When you redraw, the items that reside on the current layer are drawn last.    Refer to Options Layers 
for more information about layers.

This command also causes co-located top and bottom layer items to be drawn in the correct order.    For
example, if the current layer is Top, all Top layer SMT pads of an edge connector will be drawn on top 
all Bottom layer SMT pads in the edge connector.    Other View/Zoom commands do not necessarily 
draw co-located pads in the correct order.

To interrupt a redraw in progress, click the right mouse button or press Esc.



View Extent
Displays the extent of all objects placed in the workspace.

PCB computes and draws the workspace such that all placed objects on enabled layers are visible.    
Disabled layers are ignored.



View Last
Redraws the previous view.    

There is no previous view until you run at least one View command that changes the view area.    If you 
run View Last multiple times, you will toggle between the last two views.

Scrolling, centering, and redrawing do not affect the previous view.



View All
Redraws the screen with the entire workspace shown.    

The workspace size displayed is determined by the Workspace Size option set in Options Configure.    
If you want to make the workspace smaller to fit the board you are working on, then size it accordingly 
using Options Configure.    Options Configure is available from the PCB menu bar when the router is not
running.    The scroll bars are not displayed at this zoom level.

View All is the default view when you start up PCB with an empty workspace.



View Center
Redraws the screen using the cursor as the relative center point.    

The cursor becomes a magnifying glass shape, signifying the zoom mode and prompting you to click in 
the workspace; the point where you put the cursor and click in the workspace will become the center of 
the screen.

View Center doesn't interfere with the mode in which you are operating, it is a temporary mode.    For 
example, if you are in Place Pad mode and then run View Center, wherever you put your cursor and 
click will become the center of the screen.    Then if you click again, you will place a pad, resuming the 
previous mode.

The selected point may not be in the center of the screen if you are near a workspace boundary.

C key

The shortcut key for View Center is C.    Using C is useful for panning across the workspace.    You don't
need to click the mouse button, just move the cursor to the point you want centered and press C.



View Zoom In
Zooms in by the magnification factor value set in Options Configure.    

When you select View Zoom In, the cursor becomes a zoom cursor, taking on the shape of a 
magnifying glass, prompting you to click for the center point of the zoomed area.    The cursor location 
becomes the center of the zoomed-in area.    You must re-invoke the command for every zoom action.    
To cancel the zoom after the zoom cursor appears, click the right mouse button or press Esc.

plus (+) key

An easier way to zoom in is to use the plus (+) key as a shortcut.    Your cursor location will become the 
center of the zoom action; you don't have to click in the workspace.    The keypad plus key also works.    



View Zoom Out
Zooms outs by the factor value set in Options Configure.

When you select View Zoom Out, you are prompted to click for the center point of the zoomed area.    
The cursor position becomes the center of the zoomed-out area.    You must re-invoke the command for 
every zoom action.    To cancel the zoom after the zoom cursor appears, click the right mouse button or 
press Esc.

minus (-) key

An easier way to zoom out is to use the minus (-) key as a shortcut.    Your cursor location will become 
the center of the zoom action.    The keypad minus key also works.



 View Zoom Window 
Zooms to an area of the workspace that is specified by a zoom window.    A zoom window is a rectangle 
you click and drag to create in the workspace; the window you create will fill the screen. 

To Zoom through a Window
There are three ways to invoke the zoom window:    the Z key, the Toolbar zoom button, or the View 
Zoom Window command from the menu bar.    In any case, after it is invoked, you must draw the zoom 
window in the workspace.    

1. After you enable the zoom window function, the cursor becomes a magnifying glass shape until 
you click and drag to create a rectangular shape around a specified view area.    

2. Release when you have completed your "window".    Whatever you surround with the zoom 
window will be enlarged on the screen (the window will fill the screen).    

3. The last active tool is still active after you do the zoom window action.    To cancel the zoom action
once the zoom cursor appears, click the right mouse button or press Esc.

note:
You must drag the cursor to create a zoom window.    If you click and release in the workspace 
without dragging the cursor, the program responds with a beep, and does not zoom in.    



 Edit Components
Allows you to edit components within your design and to jump to a particular component.    Also allows 
you to highlight components and to highlight nets attached to a particular component.

Select Edit Component to display the dialog.    

Components Listbox
The Components Names listbox contains the names of all components in the active design.      You can
select individual or multiple components in the listbox.    Once selected, you can highlight and 
unhighlight components and attached nets and jump to a component

Set    All /Clear All 
If you want to select all components in the Components listbox, click the Set All button.    If you don't 
want any components selected, click the Clear All button.

Properties
The Properties button accesses the Component Properties dialog for the selected component or 
components.    See Component Properties for details.

Highlight/Unhighlight
The Highlight button highlights one or more components selected from the Components listbox in one
of the highlight colors chosen through the Options Display command.    Successive invocations of this 
command cycle through the two defined highlight colors.    If you do not want to use two highlight colors,
set both colors to be the same in the Options Display dialog box.

When you run this command, the chosen components are drawn in the highlight color until they are 
unhighlighted.    The selection color overrides the highlight color, so you won't see the highlights until the
components are deselected.

If PCB and PCB Schematic are both running, and if the DDE Hotlinks checkbox in the Options 
Configure dialog box is checked in both applications, then component highlight information is 
communicated between the two applications.    Highlighting a component in PCB highlights the 
corresponding part in the PCB Schematic.

The Unhighlight button removes the highlighting from the selected components. 

Highlight an Attached Net
You can highlight nets which are attached to the components selected in the Components list box. 

1. To highlight attached nets, select one or more components from the Component listbox.    (You 
can use the Set All button if you want to select all components in the list.)

2. Click the Highlight Attached Nets button.    The attached nets are highlighted with the highlight 
color set using the Options Display command.

3. To remove a highlight, select one or more components from the Component listbox.



4. Click the Unhighlight Attached Nets button.

Jump to a Component
1. Select one component from the list.

2. Click Jump to jump to the specified component.    The specified component appears in the center 
of your Workspace.



View Jump Location
Positions the cursor to a specified location (X, Y coordinates).    You can also use the J key to enter 
coordinates on the status line.

If you are zoomed in, this command pans the workspace to the specified location, attempting to center 
the location.    Your current zoom setting is not changed by the jump location panning (except View Last 
will be updated).    If the specified location is already visible on the screen, no panning is necessary.

The units used for the location value (mil or mm) are determined by the setting in Options Configure.    
Select Options Configure to override the default settings.

The location is also based on the Options Grids setting, either Absolute or Relative; e.g., if your grid 
setting is in Relative mode, then the location is a Relative coordinate.    Also, you can use negative 
coordinate values when in Relative mode.    Refer to the Options Grids command documentation for 
more information.

To Jump to a Location
1. Select Jump Location from the View menu.    

2. When the dialog is displayed, specify the X and Y coordinates (in the text boxes) of where you 
want your cursor to be in the workspace. 

3. Click OK.



View Jump Text
Allows you to sequence through all text strings to locate a specific combination of letters (i.e., words).    
The character string that you specify could be part of a word or a complete word.    

Case Sensitive Search, if enabled, searches for text matches based on case.    If you disable this 
option, text case is ignored in the search.

Search Entire Design searches all layers for the specified text string, and search only the current layer
when you disable the option.

To Jump to Text
1. Select Jump Text from the View menu to display the dialog.    

2. Type the text you want to search for in the text box.    Notice that the OK button is grayed out.    
Click Search. 

3. If the matching text is not already on the screen, the program pans the screen at the current 
zoom level to locate the text and center its reference point.    (You can set the text reference point 
by setting the justification with the Options Text Style command.)    

4. After PCB finds the first instance of the specified text string (highlighting it in the highlight color), 
the Search button changes to Next, and if you click it the program will find subsequent instances 
of the same text string.    You can continue to cycle through all occurrences of the search pattern 
until you click Cancel or OK.

The OK button is no longer grayed; if you click it, the program moves the cursor to the highlighted
text and the highlighting disappears.

Highlighted text may be obscured by the dialog; move the dialog to view the text if necessary.



Placement Toolbar
With this command you show or hide the Placement Toolbar.    The toolbar gives you quick access to 
the most frequently used Place commands.    

Disabling the command increases the space within the applicable window.

The setting of the Placement toolbar visibility is saved to your PCB.INI file when you exit the program, 
and restored when you restart it.



View Toolbar
With this command you show or hide the System Toolbar.    The toolbar gives you quick access to the 
most frequently editing commands (such as the Select tool).

Disabling the command increases the space within the applicable window.

The setting of the toolbar visibility is saved to your PCB.INI file when you exit the program, and restored
when you restart it.



View Prompt Line
Allows you to either show or hide the Prompt line.

The Prompt line is useful in that it gives instructions on what to do in certain modes.    For example, 
while you are in one of the Place object modes, it tells you what to do next, depending on what action 
you have already taken.

The current settings for the visibility of the Prompt line will be saved to your PCB .INI file when you exit 
the program, to be applied to subsequent sessions.



View Status Line
Allows you to either show or hide the PCB Status line.      The Status line provides status information 
and allows you to change layers and execute temporary macros.

A check mark alongside the command indicates that the Status line is visible.    Disabling the command 
increases the space within the applicable window.

The setting of the Status line visibility is saved to your PCB.INI file when you exit the program, and 
restored when you restart it.



View Snap to Grid
Creates a snappy cursor, meaning that the cursor can only move from grid point to grid point, as 
opposed to a free floating cursor.    The benefits of a snappy cursor are mainly a question of personal 
preference-- the user may be accustomed to a snappy cursor from other program applications.    Also, a 
snappy cursor can create a predictable point of reference and placement when moving and rotating 
objects.    

At times the you may want to disable this command (and cause the cursor to float freely) due to the pick
and select limitations.    For example, a line you want to select does not run true along grid points; a 
snappy cursor only allows you to pick on the line where the line intersects a grid point.    Or, you may 
need to get to an off-grid pad.



View Toolbar (Route)
Use this command to show or hide the ACCEL PRO Route toolbar.

When you begin the routing process by running, the Toolbar changes.    The autorouting Toolbar consists 
of graphical display buttons (icons) that correspond to commonly used commands in ACCEL PRO Route. 
These icons appear just below the menu bar on the ACCEL PRO Route screen.    Their display is 
controlled by selecting the View Toolbar command.    
These buttons include some commonly used commands, in the following order (from left to right in the 
Toolbar): 

Route Info
Route View Log
Route Cancel
View Zoom Window



View Status Line (Route)
When you begin the routing process, the Status line changes.    The Status line area provides routing 
status information and summary pass performance data.    During each pass, the Status line is updated 
as each connection is attempted.    Information is presented as follows:

Pass Name:    (AA/BB:CC)    DD%    (EEEE/FFFF)

Pass Name The name of the current routing pass.

AA    Number of connections, nets, or fanouts completed for this pass.

BB    Number of connections, nets, or fanouts scheduled this pass.

CC Number of connections, nets, or fanouts deferred for later passes.

DD% Percent of all connections completed.

EEEE Number of all connections completed.

FFFF Total number of connections on the board.



 Place Commands (PCB)



Place Component
Places a named component at a specified location.

Placing a component requires that the component and its corresponding pattern have already been 
created and assigned to a library.    Also, the library must be open before the component can be 
accessed and placed (refer to the Library Setup command for information about accessing libraries).

With this command you can browse the component display.

Place a Component
1. Select Place Component from the menu, or use the component pushbutton on the Toolbar.

2. Click in the workspace to display the dialog.    You are now in the component selection mode of 
Place Component.

The Component Name listbox shows a list of component names of whatever library you have 
accessed.    You can display the component in the dialog with the Browse button.    You can also 
specify the RefDes and Value for the component you are placing.    The Library combo box 
shows the current library and allows you to switch to a different library.

3. In the Component Name listbox, find the component you want to place and highlight it.    If you 
want to view it, click Browse and the dialog will stretch to the right with the component view.    

If the component you want to place is not listed in any open libraries (the Library combo box lists 
them), you will need to run the Library Setup command. 

4. Specify a reference designator in the RefDes box.    

If you leave this blank, the program uses the default RefDes prefix assigned to the Component at 
component creation time.    If you do not assign a number, the program automatically assigns the 
next available number.

Specify a value in the Value box (e.g., electrical values for resistors and capacitors; typically 
blank for logic components).

Click OK when you have filled in the desired information.

5. You are now in the place mode of Place Component.    Move the cursor to the workspace location 
where you want to place the component.    Click to place it.    Or you can click down to make a 
ghost, then drag and drop (release) to place it more accurately.    (An alternate method for drag-
and-drop is Alt + left mouse click, then release the Alt key.    You can then move the component 
freely with the mouse without having to keep the button depressed.)    To cancel ghosting of a 
component, click the right mouse button.

You can rotate a component while placing it by pressing R while the mouse button is depressed.   
See the rotate/flip section (following) for more information.

You can continue to place the same component by clicking in selected locations, and each 
component will be given a unique reference designator.    Also, each component will have 
displayed its type, name, and any other attributes previously specified (from the Place Attribute 
function).

6. If you want to place a different component, you can press the right mouse button or Esc to exit 
the current place mode.    As you are still in Place Component mode, you can click in the 
workspace to display the dialog and select another component to place (as in step 3).

Rotate/Flip



To rotate or flip a component after it has been placed, select it, and press R to rotate or F to flip while 
the component is selected.

For rotation, the default increment rotation is 90 degrees, which is activated by the R key.    You can use
Shift+R for a rotation of 45 degrees (default) or for a different (custom) rotation.    Use the Options 
Configure command to set the rotation increment for Shift+R.    

You can also flip or rotate a component as you are placing it, by keeping the button down while pressing
F or R (or Shift+R).    For rotation, the result of the placement rotation will apply to the next component 
you place.    R and Shift+R still apply, as described above.    For example, you are placing a component 
and you rotate it 25 degrees before you finish it (Shift+R, with 25 degrees set in Options Configure).    
Then you place another component of the same type; it will be automatically placed at the same 25 
degree angle without any rotation action.    Therefore, you can place multiple components at the same 
angle by rotating only the first component you place.    

If you click the right button to end the temporary mode and then click the left button to place another 
component, the rotation memory will not apply; the rotation memory applies only to the temporary 
placement mode.    

note:
Components of the same type can be placed only if they have the same pin mapping (i.e., pin 
designator to pin name to pad number).    In other words, if you place the "same" component from 
different libraries, the first instance of the component type will establish the standard pin mapping 
for that type of component.    Any components of that type placed subsequently have to conform 
to the pin logic of the first or they will be unplaceable.

When you place components that include vias, pads, and text that are of styles that have the same 
names but different data than those in the current design, the incoming style names will be bracketed to
indicate the style conflict.    The new (bracketed) style names will be added to the list of available styles 
in the current design.    Refer to the Edit Modify, Options Pad Style, and Options Text Style commands 
for object style information.



Place Line
Places a line (or series of line segments) of the current line width on the current layer.    To change the 
current line width, use the Options Current Line command.

Place a Line
1. Select Line from the Place menu (or click the line button on the Toolbar).

While you draw a line or segments, the cursor is displayed as a crosshair shape.    When you 
finish the line segments, the cursor returns to its normal shape.

2. With the cursor in the workspace, click and hold the button at the starting point, then drag the line 
to its second point and release to place the line.    You can continue with connected segments in 
the same manner.

You can use Alt + left mouse button instead so you don't have to hold the button down while 
dragging line segments.

While you drawing a line or segments, the cursor is displayed as a crosshair shape.    When you 
finish the line or segments, the cursor returns to its normal shape.

3. To finish the line or line segments, click the right mouse button or press Esc.    Then you can 
begin another line beginning at a new location. 

You will remain in Place Line mode until you enable another mode.

If you use the Undo command (Edit Undo), it will undo only the last finished line or line segments (finish 
by pressing Esc or right button).

Status line measurement:  The Status line information display area shows line measurements for 
delta X and delta Y while you are dragging a line segment.    When the line segment is finished, the total
length measurement of the segment(s) is displayed, each subsequent segment being included in the 
total measurement, and each segment with a delta X and delta Y length while is being dragged.    

Orthogonal Modes (for Line Segments)
Orthogonal modes use lines that are horizontal, vertical, and at 45-degree angles.    The available 
orthogonal modes are provided as mode pairs.    The O key cycles through the mode pairs and the F 
key toggles between the pair that is current.    You can enable or disable the orthogonal modes in 
Options Configure.

For placing lines, only the linear orthogonal modes are available (no arcs).



Place Arc
Places an arc or circle of the current line width on the current layer.    With this command you can create
arcs of varying length and radius and circles of varying radius.

To change the current arc width (line width of the arc), use the Options Current Line command.

Arcs are partial circles.    Arcs and circles are constructed counter-clockwise; the click (down) and 
release (up) define the start and end point of the arc, therefore a stationary click/release comes full 
circle and defines a circle.    In this case, the second click and drag moves the center point away from 
the defined point on the circumference.

To Place an Arc
1. Select Place Arc or the arc button on the Toolbar.    Move the cursor into the workspace to where 

you want the starting point of the arc.    

While you draw an arc, the cursor is displayed as a crosshair shape.    When you finish the arc, 
the cursor returns to its normal shape.

2. Click and drag to where you want the end point of the arc to be.    Release and the start and end 
points are established as a 180-degree arc.    

The arc will sweep counterclockwise as you place it.    (e.g., left-to-right the arc sweeps up; right-
to-left the arc sweeps down, etc.)    If the start and end points are the same (i.e., you click and 
release without dragging) a circle will be created.

3. After the start and end points are established, click and drag the cursor to define/alter the center 
point, thereby increasing or decreasing the sweep angle (radius) of the arc.    

You can flip the arc (swapping the end points) by pressing F while the arc is still unfinished.    
When you release the mouse button, the arc is permanently placed.

To cancel ghosting of an arc, click the right mouse button.

Misc. Arcs
To move, resize, rotate, flip or perform other types of changes to the arc (after it is permanently 
placed), use the Edit Select tool.    

To rotate or flip an arc, select it, click and hold in the center of it as if to move it (not on the 
handles), and press R to rotate or F to flip while the button is depressed.

For rotation, the default increment rotation is 90 degrees, which is activated by the R key.    You 
can set a different rotation increment with Options Configure.    To activate what you have set in 
Options Configure, use Shift+R.

To move the arc, click within the selection box (not on the handles) and drag the arc.

To resize, click and move the center handle to change the center point or move the start or end 
point to change the sweep angle.



Place Pad    
Places a pad of the current style.    Pads do not belong to a particular layer.    To place a surface pad, for
example, the current style must be set up to have a shape defined only on a surface layer.

Use the Options Pad Style command to define new pad styles and to set the current Pad Style.    Use 
the Free Pad Properties (Edit Properties) command to change pad styles or pad numbers of already 
placed pads.

To learn how to rotate and flip a pad, click the following topic:
Rotate or Flip a Pad

To learn how to renumber pads, click the following topic:
Renumbering Pads

See also:
Options Pad Style
Free Pad Properties



Place a Pad
1. Select Pad from the Place menu (or use the toolbar pad button) and move the cursor to where 

you want to place the pad.    

2. Click the mouse to place the pad.    You can click, drag, and release for more accurate placement 
with a ghosted outline.    You can rotate or flip a pad while placing it.

To cancel ghosting of a pad, click the right mouse button.



Rotate or Flip a Pad
To rotate or flip a pad after it has been placed, select it and press R to rotate or F to flip.

The R key rotates the pad 90 degrees, Shift+R rotates by the rotation increment set in Options 
Configure.    

You can rotate a pad as you are placing it, and whatever angle is the result of the rotation will apply to 
the next pad you place.    You must keep the button down while you are rotating it (before the pad is 
permanently placed).    For example, you are placing a pad and you rotate it 25 degrees before you 
finish it (Shift+R, with 25 degrees set in Options Configure).    Then you place another pad; it will be 
placed at the same 25 degree angle without any rotation action.    If you decide to rotate the second 
pad, it will increment 25 degrees more, resulting in a 50 degree angle.    Therefore, you can place 
multiple pads at the same angle but only have to perform the rotation action on the first pad.

To flip a pad as you are placing it, press F while the pad is ghosted before final placement.    When you 
flip a pad, the hole range does not flip with it.

Pads and vias share the same rotation memory.    In other words, if you place and rotate a pad at 90 
degrees, then immediately place a via, that via will be placed at a 90-degree angle.    This rotation 
memory derives only from rotation action during placement, not from select-and-rotate actions that take 
place after object placement.



Renumbering Pads
If you want to number the pads you placed, you must enable the Select tool and then run the Utils 
Renumber command.    A dialog appears where you can choose Pad Num as the type, then specify the 
start value and increment value.    Then you can click on each pad manually and they will be numbered 
in sequence.    You can also use the Modify Pad function to assign a pad number (Select pad, Modify 
pad).    Refer to the Utils Renumber and Modify Pad commands for more details in this manual.



Place Dimension
Places a dimension at a specified location.

Dimensions are thin lines used to show the extent and direction of dimensions.    A break in the 
dimension allows you to display numeric values. 

Not available for ACCEL TangoPCB.

Placing a Dimension
1. Select Place Dimension from the menu, or use the dimension icon on the toolbar.

2. Click in the workspace to display the Place Dimension dialog.    

3. Choose a dimension style from the Styles drop down list box:
Point to Point:    Measures the distance between two points.
Baseline:    Measures the distance between a single reference point and subsequent points.
Leader:    A dimensioning line extending from a piece of text or symbol to the dimensioned object. 

It can be used for dimensioning or notation.
Center mark:    Is a cross-hair marking of the center of an arc or circle.
Radius:    Measures the radius of an arc or circle.
Diameter:    Measures the diameter of a circle.
Angular:    Measures the angle between two objects with a common center reference point.

4. Use the Orientation area to set the dimensions orientation to be either Horizontal or Vertical. 
5. Use the Text Orientation area to set the orientation of the text in between the dimension lines to 

be either Horizontal or Vertical.    
6. Use the Units area to choose the measuring unit for the dimension.    

7. Use the Symbol area to choose the type of notation for a Leader style dimension. 

8. Set a symbol size using the Symbol Size box.

9. Set a center size for the center of the symbol using the Center Size box.

10. In the Line Width box, set a line width for the dimension lines. 

(After you disable the Place Dimension tool, the cursor returns to its normal shape.)

11. Indicate whether to display the dimensions units and diameter symbols by enabling the 
appropriate checkboxes.

12. Click OK to return to the workspace.

13. Point in the workspace to place the dimension.    

To place a Point to Point dimension click an existing object, then click a second object.

14. Select the location for the dimension text and lines.

If the dimension lines and text cannot fit between the extension lines, you are asked if you want 
the dimension text outside the extension lines.    If you say No, the text remains in between the 
lines.

15. Continue placing dimensions as necessary.    To stop, press Esc or click the right mouse button.

Rotate
To rotate a dimension after it has been placed, select it, and press R .



For rotation, the default increment rotation is 90 degrees, which is activated by the R key.    You can use
Shift+R for a different (custom) rotation.    Use the Options Configure command to set the rotation 
increment for Shift+R.



Place Via
Places a via of the current style.    Vias do not belong to a particular layer.    To place a buried via, for 
example, the current style must be set up to have a shape defined only on a buried layer.

Use the Options Via Style command to define new via styles.    Use Via Properties (Edit Modify) to 
change styles of already placed vias..

Vias are almost identical to pads in the way that they are placed, rotated, flipped, and edited.    Refer to 
the Place Pad command instructions for detailed information.



Place Point
Place Point allows you to specify a Ref Point, Glue Dot, or Pick and Place point on a pattern object 
before it is saved to a library.    

Reference Point:    You need to specify a reference point on a pattern object before it is saved to a 
pattern library (Library Pattern Save As).    The Ref Point will appear in the same color as what is specified
for the 1x grid color in Options Display.
When you place a reference point on an object, the component (or pattern) will move with the cursor at 
the reference point.    Components are flipped and rotated about the reference point.    For most 
components, select a reference point in the center of pad #1.

Glue Dots are used to hold components in place until they are soldered during manufacturing.    A glue 
dot can be placed as part of a pattern before saving the pattern to a library.    Use the File Reports 
command to get a listing of all Glue Dot locations.

Pick and Place points provide reference points in directing the pick and place mechanism (or auto 
insert) in manufacturing (picking up the component and placing it on the board).    Use the File Reports 
command to get a listing of all Pick and Place locations.

note:
Glue Dots and Pick and Place points appear as free points, not associated with a pattern, unless 
you save them as part of a pattern in a library.

To Place a Point
1. Select Place Point or click the reference point button on the Toolbar.

2. Move the cursor to the location on an object or with a collection of objects.    Click to place the 
Point. (Or, click, drag and release to place the reference point more accurately.)

3. You can move a Point by selecting it and dragging it to a new location.

To cancel ghosting of a point, click the right mouse button.

note:
Pick and Place points and Glue Dots can be flipped to the Bottom layer.    They use the line color 
from the layer that they are on.

Displaying/Hiding Points
You can choose to display or hide the placed Glue Dot and Pick and Place reference points.    Select the
Options Display command, click the Misc... button, and then either show or hide them with the 
appropriate radio button selections.    You can also choose to include or exclude these items from your 
printer output (File Print) by specifying the items in the Setup Print Jobs dialog.



Place Polygon
Places a polygon fill on the current layer.

To Place a Polygon
1. Select Place Polygon or click the polygon button on the Toolbar.    

While you draw a polygon, the cursor is displayed as a crosshair shape.    When you finish the 
polygon, the cursor returns to its normal shape.

2. Put the cursor at the starting point of where you want your polygon.    Click and drag to the 
second point and release. 

3. Click and drag to a third point and you have a triangle.    Any subsequent polygon points will be 
connected by a line to the first point you selected, e.g., the fourth point of a polygon is connected 
to the first point automatically.    

note:
Complex polygons are not allowed.    A complex polygon is a self-intersecting or self-crossing 
polygon.    Polygon sides can touch each other but not cross each other.

4. When you have established all your points in creating the polygon, click the right mouse button 
(or press Esc) to finish and fill the polygon.

Draft/Outline Display Mode
Polygons can be drawn and printed as outlines.    They are drawn in outline form when the Draft Mode 
(Options Display Misc command) option is enabled.    They are printed as outlines when the Draft option
is enabled in File Print, Setup Print Jobs.

Rotate/Flip
You can rotate or flip a polygon after you have placed it.    Select the polygon and press R to rotate or F 
to flip while the polygon is selected.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever rotation increment is set 
in Options Configure (a customizable rotation).    

Alter the Shape
You can alter the shape (move, add, or delete vertices) by selecting the polygon, then clicking and 
dragging one of the handles.    When you move one of the handles that lies between two vertices, a new
vertex is created.    To delete a vertex, grab its handle and move it to an adjacent vertex and release.



Place Copper Pour
Creates a copper pour outline on the current layer.

A copper pour is a polygonal area that the user specifies, which will be filled by copper in the board 
manufacturing.    A copper pour will automatically back off from items in different nets.

To Place a Copper Pour
1. Select Copper Pour from the Place menu or click the copper pour button on the Toolbar.

2. Move the cursor into the workspace to where you want the first point of the copper pour to be.    
Click for the first point and drag to the second point and click to establish it.    Place the third point 
in the same manner and you can see the outline of the copper pour so far.    Click and drag to 
establish subsequent points.    "Complex" copper pour polygons (self-intersecting or self-crossing)
are not allowed.

3. Click the right mouse button to terminate the placing of the outline and establish the outline of the 
copper pour shape.

4. Now you will need to access the Modify Copper Pour dialog to establish the characteristics of 
your copper pour.    Whatever you specify here will only apply to the selected copper pour.

Select the copper pour outline (with the Edit Select tool), then choose Edit Modify.    The Modify 
Copper Pour dialog is displayed.

5. For Pour Pattern, you can choose between a number of options.    Solid is, of course, a solid 
pour (there is banding, but it overlaps to create a solid).    Horizontal and Vertical are banded or 
striped, according to what you specify for Line Width and Line Spacing.    45 Cross and 90 Cross
are both cross-hatched, but at different angles, also according to line width and spacing. 

For the line properties Line Width determines the size of the banding (solid), hatched, or cross-
hatched lines.    Line Spacing determines the space between lines, measured from the edge of 
one line to the edge of the next.    If you selected Solid for the Fill Pattern, then the Spacing 
value should be designated as a small negative number (e.g., -1), so there will be no spaces 
interfering with the solid fill that you specified.

The Pour Backoff option allows you to specify a value for the distance you want between the 
copper pour and any objects that may be inside of the copper pour polygon.    The copper pour 
will backoff anything that is not specified in the Net combo box (see the explanation for Net).

The Spoke Width allows you to specify the width of the track segments between pads and 
copper pour.

The Poured and Unpoured radio buttons allows you the option of turning off or on the graphic fill 
display (if you are working quickly, the graphic fill can be time-consuming to display, so you can 
disable it).

The Thermal options allow you to control the electrical connections to pads of the same net.

The Net combo box allows you to select the net that you want the copper pour to connect to.    
The copper pour will backoff from any copper items that are not in the same net as the pour.    If 
no net is associated with the pour, it backs off from all copper items except "no-net" pours.

warning:
You could mistakenly split the copper pour in half (or more than two pieces) if the copper pour 
surrounds items that are longer than the copper pour polygon.    In that case, the electrical 
connection would be severed.

6. Click OK and the copper pour shape will fill in, if the Poured option is enabled.    



Rotate/Flip
You can rotate or flip a copper pour after you have placed it.    Select the pour and press R to rotate or F
to flip while it is selected.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever rotation increment is set 
in Options Configure (a customizable rotation).    

AutoPlowing Pours on Disabled Layers
If you modify a component inside a pour on a disabled layer, the pour is autoplowed.    



Place Cutout
To Place a Cutout
To place a cutout    in your design:

1. Select Cutout from the Place menu or click the cutout pushbutton on the Toolbar.

2. Move the cursor into the workspace to where you want the first point of the cutout to be.    Click for
the first point and drag to the second point to establish the first edge of the polygon cutout.    Click
and move to place the third point in the same manner, and the outline of the cutout should be 
visible.    Click and drag to establish subsequent points.    "Complex" (self-intersecting or self-
crossing) polygons are not allowed.

3. Click the right mouse button (or press Esc) to establish the cutout polygon; it will appear as an 
outline.    When the copper is re-poured, the area defined by the cutout will not be filled.

Rotate/Flip
You can rotate or flip a cutout after you have placed it.    Select the cutout and press R to rotate or F to 
flip while the cutout is selected.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever rotation increment is set 
in Options Configure (a customizable rotation).    



Place Keepout
Allows you to create a barrier to either keep in or keep out certain processes on a specific area of the 
board.    You can place either a line keepout or a polygon keepout.

Keepouts are non-electrical items that only affect the autorouter; they are ignored by Design Rule 
Checking, nets, and copper pours.

First use Current Keepout to set up what type of keepout you want to place (line or polygon) and on 
what layers (all or current).    Place Keepout will reflect whatever you have specified in Current Keepout.

Line keepouts work like Place Line.    Polygon keepouts work like Place Polygon.    



Place Plane    
Creates a split plane outline on a plane layer.

Not available for ACCEL TangoPCB.

A split plane is a created by placing a polygon outline on a plane layer.    The area within the polygonal 
outline is the split planes copper.    A split plane is associated with a single net.    When you select the 
net, all split planes in that net are selected.

Split planes appear and are printed in negative video.    

To learn about connectivity issues with split planes, click the following topic:
Split Plane Connectivity

To learn how to rotate and file split planes, click the following topic:
Rotating and Flipping Split Planes



 Placing a Plane
1. Select Plane from the Place menu or click the plane icon on the toolbar.

2. Move the cursor to the first point of the plane.    Click for the first point and drag to the second 
point and release to establish it.    

Place the third point in the same manner.    (You can see the outline of the plane so far.)    

Click and drag to establish subsequent points.    

3. Click the right mouse button to terminate the placing of the outline and establish the outline of the 
plane shape.

The plane is drawn using the polygon color defined for that plane layer.

It is illegal to have two planes that intersect, because connectivity to the planes will not be correct.
Design Rule Checking (DRC) will report this error if you enable Plane Violations in the Utils DRC 
dialog.

4. Now you need to access the Modify Plane dialog to establish the characteristics of your plane.    

Select the plane outline (with the Select tool), then choose Edit Modify. 

5. Use the drop down list box or type a new value to assign the plane to an existing net.

6. Define the line width for the Polygonal outline.    The default is the current defaut line width.    
Change the width by typing over the default value.

7. Select a net plane color, by clicking the Net Plane Color button and selecting a color from the 
Color dialog.

8. Click OK and the plane shape fills in.



Split Plane Connectivity
For a pad to electrically connect to a split plane, the pad and the split plane must be in the same net 
and the pads hole must intersect the split plane.    If the pads hole partially intersects the split plane, the 
pad is still considered electrically connected to the split plane, but DRC reports this partial connection 
as a warning.

Net connectivity is maintained with split planes, just as net connectivity is maintained with plane layers.  
For example, if two pads are electrically connected because they both connect to the same split plane, 
then a connection line is not necessary between the two pads.    If two pads are electrically connected to
the same split plane, ACCEL PCB assumes that copper in the split plane is continuous between these 
two pads.



Rotating and Flipping Split Planes
You can rotate or flip a plane after you have placed it.    Select the pour and press R to rotate or F to flip 
while it is selected.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever rotation increment is set 
in Options Configure (a customizable rotation).      

See also:
Options Configure command



Place Text
Allows you to enter/place text on your design.    To define the style of text you want to place, use the 
Options Text Style command first.

To Place Text
1. After you are in Place Text mode, click on the workspace to display the Place Text dialog.    

2. In the Text box, enter the text that you want to place in the design.    If you want to enter multiple 
lines (e.g., a list), you can start new lines in the Text box by using a carriage return (the Enter 
key). 

While the Text edit box has focus, you can press Ctrl+V to paste text from the Windows clipboard.

In the Justification box, you can specify a change in the text reference point.    The default 
reference point for text is the lower-left corner.    You can modify the reference point before you 
place the text, or for already placed text (e.g., center rather than lower-left).    The reference point 
defines the cursor location on text placement, and also the axis on which text will rotate (see 
rotate/flip section below).    There are nine different reference point options.    

You can change the current text style by highlighting one in the Style box.

You can modify a non-default text style (or view the default text style) by clicking Edit Styles.    
The Options Text Style dialog is displayed.    Refer to Options Text Style for detailed information 
on adding, modifying, viewing, renaming, and deleting text styles.

3. After you click OK (or press Enter) and exit the dialog(s), click and hold the mouse button, and 
move the cursor to drag the box (containing the text) to where you want to place it.    When you 
release the button the text will be placed, with the cursor as the reference point.    The text will 
reflect the content, style, and justification you specified in the Place Text dialog.

If you want to rotate or flip a text string before you place it, press R (to rotate) or F (to flip) before 
you release the button.    See the following section for more information.

Rotate/Flip
To rotate or flip text after it has been placed, select it and press R to rotate or F to flip while the button is
depressed.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever angle you set in Options 
Configure (a customizable rotation).    

You can flip or rotate text as you are placing it.    For rotation, whatever angle is the result of the rotation 
will apply to the next text you place.    For example, you are placing text and you rotate it 25 degrees 
before you finish it (Shift+R, with 25 degrees set in Options Configure).    Then you place more text; it 
will be placed at the same 25 degree angle without any rotation action.    (If you decide to rotate the 
second text string, it will increment 25 degrees more, resulting in a 50 degree angle.)    Therefore, you 
can place multiple fields at the same angle but only have to perform the rotation action on the first text 
string.

Attributes, text, and fields share the same rotation memory.    In other words, if you place and rotate text 
at 90 degrees, then immediately place a field, that field will be placed at a 90-degree angle.    This 
rotation memory derives only from rotation action during placement, not from select-and-rotate actions 
that take place after object placement.



Text Summary
The text you enter is case-sensitive; what you enter is what you will get.

If you want to enter multiple lines (e.g., a list), you can start new lines in the text box by using the 
Enter key.

You can change the text justification by specifying one of nine justification points in the Place Text
dialog or Modify Text dialog.

With Modify Text (select the text, click right button, and click on Modify in the popup menu), you 
can change the content of already placed text.    In either of these dialogs, you can change the 
text style, add/delete a text style, or modify the text justification.    To change or add/delete a text 
style, click Edit Styles, which activates the Options Text Style dialog, where you can add, modify, 
view, rename, or delete text styles. 

note:
You cannot delete a text style currently in use.

Related Topics
Options Text Style



Place Attribute
Places an attribute according to the Name and Value options you select in the dialog.    This command 
allows you to place an attribute within a collection of objects comprising a pattern or component.

The predefined Names are:    Description, NoSwap, Part Number, RefDes, SwapEquivalence, Type,
and Value.

The Value box specifies the attribute definition, e.g., the actual filename rather than just the place holder
Filename. 

To edit an attribute after it's been placed, run the File Design Info command and click the Attributes 
button.

 Placing an Attribute
1. Choose Place Attribute, or click the attribute toolbar button.

2. Click in the workspace to display the Place Attribute dialog.

3. Choose an attribute category from the Category list.    All pre-defined attributes for the category 
appear in the Name list.    

4. Select an attribute from the Name list.    This name, unless you selected user-defined, appears in 
the Name edit box. 

5. For user-defined attributes, type an attribure name in the Name edit box.

6. Type a value for the attribute in the Value edit box.

7. Set attribute properties.    

8. Click OK.

9. Move the cursor into the workspace and click, drag and place the attribute.    Before you release 
the button to place it, you can move, rotate, or flip the placement box (see following section).

Rotate or Flip After Placement
To rotate or flip an attribute after it has been placed, select it and press R to rotate or F to flip while it is 
highlighted in the select mode.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever increment you set in 
Options Configure (a customizable rotation).      

You can rotate or flip an attribute as you are placing it.    For rotation, whatever angle is the result of the 
rotation will apply to the next attribute you place.    For example, you are placing an attribute and you 
rotate it 25 degrees before you finish it (Shift+R, with 25 degrees set in Options Configure).    Then you 
place another attribute; it will be placed at the same 25 degree angle without any rotation action.    You 
can place multiple attributes at the same angle by rotating the first attribute as you place it.    

Attributes, text, and fields share the same rotation memory.    In other words, if you place and rotate text
at 90 degrees, then immediately place an attribute, that attribute will be placed at a 90-degree angle.    
This rotation memory derives only from rotation action during placement, not from select and rotate 
actions that take place after object placement.

If you don't specify a value for an attribute, the attribute key name appears in brackets, e.g., {Type}.





Place Field
Places a field containing design information such as date, time, author, etc.

The information that is displayed when you place fields is determined by what you have specified in the 
File Design Info dialog (accessed through the File Design Info command).    You can place a field from a
selection of field types including:    date, current date, time, current time, author, revision, filename, title, 
and drill symbol.    Current date and current time are taken from the computer's clock.    If you just select 
date then you must specify the date in the File Design Info dialog.    The same is true for time (as 
opposed to current time).

All information except current time and current date must be specified in the Design Information sheet, 
otherwise you will place a generic field, e.g., {author} rather than {W. Shakespeare}.

To Place a Field
1. Select Place Field and click in the workspace.    A dialog is displayed with a combo box containing

a list of field types.

2. From the list in the combo box, select what kind of field you want to place.    Click OK.

3. Move the cursor in the workspace to where you want to place the field; click to place it.    If you 
click again, the Place Field dialog will be displayed so that you can choose another type of field 
for placement.

4. You can rotate a field as you are placing it by keeping the mouse button depressed and pressing 
R for 90 degrees (default) or Shift+R for a rotation value that you specify in Options Configure.

Rotate/Flip
To rotate or flip a field after it has been placed, select it and press R to rotate or F to flip the field while it 
is highlighted.

The R key rotation is 90 degrees.    You can use Shift+R to rotate to whatever increment you set in 
Options Configure (a customizable rotation). 

You can rotate or flip a field as you are placing it.    For rotation, whatever angle is the result of the 
rotation will apply to the next field you place.    For example, you are placing a field and you rotate it 25 
degrees before you finish it (Shift+R, with 25 degrees set in Options Configure).    When you place 
another field; it will be placed at the same 25 degree angle without any rotation action.    If you decide to
rotate the second field, it will increment 25 degrees more, resulting in a 50 degree angle.    Therefore, 
you can place multiple fields at the same angle but only have to perform the rotation action on the first 
field.

Attributes, text, and fields share the same rotation memory.    In other words, if you place and rotate text 
at 90 degrees, then immediately place a field, that attribute will be placed at a 90-degree angle.    This 
rotation memory derives only from rotation action during placement, not from select and rotate actions 
that take place after object placement.



Place Connection
Places a connection between pads.    Vias are not supported.    Connections do not belong to a 
particular layer and do not have a user-definable width.    

To perform a connection, you must have already placed free pads and/or component pads.    The 
connected pads become nodes of a net.

You need to change layers to place connections between surface pads that are on different layers.    For
example, switch the current layer to Top, begin the connection on one of the Top layer pad, change 
layers to the Bottom and complete the connection to a bottom layer pad.

To Place a Connection
1. Choose Place Connection or use the connection button on the Toolbar as a shortcut.

2. Click on a pad and draw a line by dragging to another pad and releasing.    You will be prompted 
for a net name (a default is provided).    Enter the net name (or accept the default net name as 
shown below) and click OK.

3. You can continue placing connections in the same manner, from pad to pad (node to node).    If 
the connection shares the same node as a previous connection, then they become part of the 
same net and you will not be prompted for a new net name.    

If you place a connection between nodes that don't share a node with an existing net, you will be 
prompted for a new net name (or you can use the automatically incremented default net name, 
e.g., NET00001).

Free Pads
You can place connections to free pads, but the free pads will not appear in the netlist when you 
generate a netlist (Utils Generate Netlist).

Unused Component Pads
Components can have unused pads that a electrically inactive (that is they have no designator).    
You cannot place a connection to an unused component pad.

Merging Nets
If you attempt to place a connection between two nets, in effect merging nets, you will see the Merge 
Nets dialog.    From there you can choose to name the merged net one of the two net names that are 
being merged, or give it a new name.

For routing of the connections you make, use the Route Manual or Route Interactive commands.

To optimize the connections for minimum length, use the Utils Optimize Nets command.



Route Commands (PCB)
PCB supports multiple autorouters.    Prior to version 2.50, ACCEL PRO Route was the only autorouter 
available for PCB designs. But with release 2.50, PCB now supports the following autorouters:

QuickRoute
PRO Route 2/4
ACCEL PRO Route
CCT SPECCTRA (valid for SP10, SP4P, and SP2 products)

The look and feel of the user interface is consistent for all autorouters.    The menu structure is similar 
for all routers.    The supporting dialog boxes are router-sensitive, so that router-specific data such as 
pass selection are different for each autorouter.    The Route Autorouters dialog is the dialog that lets 
you select and configure a router as well as start the routing process.

Route Menu
Autorouters
View Log
Miter
Manual
Interactive



Route Autorouters
When you run the Route Autorouters command, the Route Autorouters dialog appears.    The Route 
Autorouters dialog lets you choose the autorouter you want to use to route your designs and to set 
autorouter options for the selected autorouter.    You can also start and restart the autorouting process 
from this dialog.

The Autorouter combo box defaults to Quick Route, the embedded router.    To select a different router,
click the down arrow and choose a router from the list. Notice that dialog changes depending on the 
router you select.    To get information about a specific router, click on a router from the list below.

Supported Routers
ACCEL Quick Route
ACCEL PRO Route
CCT SPECCTRA
ACCEL Route 2/4



 ACCEL QuickRoute
When you select Route from the Autorouter combo box, the Route Autorouters dialog appears as 
follows.    Although there are differences in functionality, QuickRoute dialogs will look familiar to ACCEL 
PRO Route users.

Using Quick Route, you can perform the following functions from the Route Autorouters dialog:

Start
Restart

Strategy Box
Strategy File
Output PCB File
Output Log File
Load
Save
Set Base

Layers
Net Attrs
Passes
Via Style
Routing Grid
Line Width

Error Messages Box
Error Messages

See also:
Constraints

During routing, commands are available from the following Route menus:

View Menu
Route Menu
Options Menu



 ACCEL PRO Route
When you select PRORoute from the Autorouters combo box, you access ACCEL PRO Route.    
Several buttons, which now appear in the Route Autorouters dialog, are simply shortcuts to PCB 
commands and functions: Clearances, Layers, Net Attrs, Line Width, Via Style and Route Grid.    By 
pressing any of these buttons, you are taken to PCB dialogs which should already be familiar to you.

The remaining strategy options instruct the router in its operation.    All of these settings are saved to, 
and can later be loaded from, a strategy file using the Save and Load buttons.    This gives you an easy
way to test (and preserve) several strategies for optimum results.    Although default file names and 
strategy values are provided, you can override these names and values.

Using ACCEL PRO Route, you can perform the following functions from the Route Autorouters dialog:

Start
Restart

Strategy Box
Strategy File
Output PCB File
Output Log File
Load
Save
Set Base

Design Rules
Layers
Net Attrs
Passes
Line Width
Via Style
Routing Grid
Via Grid Multiple

Options Box
Options Box
Simaltaneous Class Routing

Copper Share Box
Copper Share

Error Messages Box
Error Messages



 CCT SPECCTRA Router
The SPECCTRA autorouters (SP10, SP4P, and SP2) work differently than other PCB autorouters.    
There is no real-time, record-oriented data exchange mechanism (like PRO Route); instead, the 
SPECCTRA autorouter runs in batch mode, driven by a command file called a DO file.    You set up a 
DO file using the Route Autorouters dialog.    When you start running SPECCTRA, PCB runs the 
autorouter in a Windows DOS shell.

You must save your design in ACCEL ASCII format.    PCB then translates this format into the native 
SPECCTRA format.    Upon termination of the autorouter, PCB merges the original ACCEL ASCII file 
with the routes produced by the autorouter.    The resultant file is your routed design.

If you start running SPECCTRA and the design is not currently in ACCEL ASCII format,you are 
prompted to save the design in ASCII format or abort the routing operation.

Route Autorouters Dialog
When you select the SPECCTRA autorouter, the Route Autorouters dialog dynamically changes to 
simplify DO file creation, building net classes and specifying and line options.    The    Strategy File 
button changes to a DO File button to reflect the fact that SPECCTRA uses a different command file 
format.    

DO File Button
The DO File is an ASCII file that contains SPECCTRA commands that execute in sequence to control 
autorouting.    It includes all data needed by the autorouter to route the board.    The DO filename initially
appears as the same name as the current design file, but with an .DO extension.    This is the default 
filename.    

Output PCB File Button
The Output PCB File button displays a dialog in which you can specify the name and location of your 
output design file after it has been routed.    Here too, a default name has been provided.    The letter R 
(for routed) precedes the current design filename.    The last character is dropped if the new name 
exceeds eight characters.    The default file extension is .PCB.

The default name can be overridden by clicking the Output PCB File button.    The dialog which 
appears allows you to specify the name and location of your routed PCB board.    Again, this is a 
Windows common dialog, with a familiar look and feel of other Windows dialogs used for opening, 
retrieving or creating files.

Output Log File Button
In addition to the output file, the SPECCTRA autorouter generates a report file at the end of the routing 
session, detailing the results of the session.    The Output Log File button displays the Select Output 
Log File dialog, in which you can specify the name and location of your report file.      This dialog is a 
Windows common dialog, with a familiar look and feel of other Windows dialogs used for opening, 
retrieving or creating files.

Load Button



Select the Load button to restore saved DO files.    Choose the DO filename, then click Load.    The DO 
file is then read into memory and may be edited as text or through the DO Wizard.

Save Button
Anytime after you have selected a DO filename, you can save the file by clicking Save.    The DO file is 
also saved automatically when you start the route. 

Set Base Button
The Set Base button returns the DO and output files to their default filenames.    This is a simple way to 
go back and start over again when assigning filenames.    The default names are derived from the 
design filename, including the full path.

DO Wizard
The easiest way to create or manipulate a DO file is by clicking the DO Wizard button.    The 
SPECCTRA DO File Wizard dialog    appears.    The SPECCTRA DO File Wizard dialog is an intelligent 
DO file editor that makes creating DO files more efficient.

From this dynamic dialog you can select DO commands, enter information, and add information to the 
DO file without having to edit DO file text directly.    The DO Wizard has an Auto Create DO File button 
that allows you to quickly create a DO file complete with current grid, line width and layer settings.    The
DO commands chosen closely match those of other PCB autorouters.    The DO Wizard creates 
commands with the correct syntax.    Refer to your SPECCTRA User's Guide and Reference Manual for 
a complete discussion on DO file options and use.

Edit as Text
You can click the Edit as Text button to bring up the file in a text editor.    The DO file created or 
modified in this manner is used verbatim as input to the SPECCTRA autorouter.

Net Classes Button
The option lets you define a group of nets that share common rules. Collections of nets sharing the 
same rules are referred to as a net class.      

When you click the Net Classes button, the Net Classes dialog appears. 

This class editor allows you to create named net classes using pre-defined SPECCTRA autorouter 
clearance rules and then assign nets to that class.    You can also add user-defined attributes to the net 
classes for your own use.

For net classes, you can specify general clearance rules.    These rules can be further refined by 
specifying clearance rules for pairs of objects, like pad to pad clearances or line to via clearances.        
To set net class to net class rules, use the Options Design Rules dialog in ACCEL PCB.

The precedence order used is (from lowest precedence to highest precedence) :

Default design (includes layer specific clearances).
Net class rules.
Net class to net class rules.



Net rules.

Within the net class rules and net rules, object-pair clearance rules have precedence over pad, line, and
via clearance rules.

To create named net classes:

1. Enter a class name in the Classes box.

2. Click Add.

3. Select unassigned nets and click the Add button (bottom of dialog) to add the nets to the class.

4. Use the Edit Attributes button to assign one or more attributes to this new net class.    (Refer to 
the Edit Nets command section for details.)

Command Line Button
When you click the Command Line button, the SPECCTRA Command Line dialog appears.    

The SPECCTRA program is run in a Windows DOS shell and must be launched with the correct 
command line arguments.    The SPECCTRA Command Line dialog gives you control over the exact 
manner in which the autorouter is run.    

The settings shown here are the recommended defaults.    Note that DOS command lines are limited to 
a maximum of 128 characters.    If that limit is exceeded, an error message is displayed in the DOS box 
or by Windows and the router is not started.    The edited command line is saved for the next run.    
These checkbox options are described in the CCT manual.

The Autorouting Process
The SPECCTRA autorouter can run in graphics mode or text-only mode, but in either mode it runs in a 
Windows DOS shell.    In graphics mode, the DOS shell does not run in the background under Windows 
3.x.    In text-only , the DOS shell runs in the background.    The graphics mode autorouter runs only in 
the foreground when the Windows DOS shell is full screen.    Therefore, once you start the CCT 
autorouter in graphics mode, focus switches to the autorouters DOS shell where it must remain until the
router is finished.    While the autorouter is running, this message appears if you switch back to PCB 
during the route:

SPECCTRA Autorouter is running.    PCB has been suspended until Routing Completes.

An autorouting menu and Toolbar do not be appear; they are not needed.    PCB simply waits for the 
SPECCTRA task to complete.    PCB knows when the autorouter is done and proceeds with the second 
part of the translation process.    

Log File
The log file is a combination of output from the PCB-to-SPECCTRA translator, the SPECCTRA 
autorouter output, and the SPECCTRA-to-PCB translator.    Post-route processing embeds the status 
file produced by the autorouter (and specified in the DO file) into the log file only if the System LogFile 
name is provided in the command line.    Thus, the Route View Log command in PCB provides you with 
post-route information.

Manual File Translation and Autorouting



The PCB interface to the SPECCTRA autorouter is fully automatic.    You can also "manually" invoke the
SPECCTRA autorouter outside of PCB, for example to run it on an alternate machine.    

The steps involved in manually autorouting a PCB design with SPECCTRA are as follows:

1. Create a DO file and set up net classes as described above.

2. Save the unrouted PCB design in ASCII format (a .PCB extension is assumed). 

3. Open a Windows DOS box and from the DOS prompt change to the PCB installation directory:

cd\PCB

4. Run the Tango-to-SPECCTRA translator using the following command line arguments: 

ACCL2SP <design.pcb> -o <design.dsn>

5. The output of step 4, <design.dsn>, is a SPECCTRA design file.    Autoroute it as described in 
your SPECCTRA documentation, using the DO file created in step 1.

6. The "routes" output from SPECCTRA must now be merged into the original PCB design.    
Assuming the routes to be in a file named <design.RTE>, run the SPECCTRA-to-Tango translator
using the following command line arguments:

SP2ACCL <design.rte> -orig <design.pcb> -o R<design>.PCB

7. If no command line arguments are given, the translators prompt for input.

8. The file R<design>.PCB is the routed design and may be loaded into PCB for review.

note:
The tranlators, ACCL2SP and SP2ACCL, use conventional DOS memory and have limits on the 
size of the input file.    The entire ACCEL ASCII file is read into memory before translation.    
Therefore, your computer may run out of memory with large designs.

Two additional translators are also supplied: ACCL2SPW and SP2ACCLW.    These are the exact same 
translators built to run as native Windows applications.    Since Windows applications allocate from a 
virtualized extended memory space, these versions of the translators work with very large designs.      



 ACCEL Route 2/4 Router
ACCEL Route 2/4 is a reduced functionality version of the PCB autorouter.    This version limits the 
complexity of the design file that may be submitted to the PCB autorouter.    This product enables the 
user to route boards with one or two signal layers with no pin count limitation, or route boards with up to
four signal layers with a limit of 4000 pins (net nodes) in the design.    Designs exceeding both limits will 
not be routed by the autorouter.    The availability of this interface, as with the full feature interface, is 
controlled by the PCB security key.

Documentation for the ACCEL Route 2/4 autorouter, subject to the limits described above, can be found
in the PCB Using Route manual.

See also:

ACCEL PRO Route



 Strategy File
The Strategy File is a collection of settings that you set up in Route Autorouters.    It includes the name 
of the router you are using and all data needed by the autorouter to route the board.    The strategy file 
name initially appears as the same name as the current design file, but with an .STR extension.    This is
the default file name.    You can, however, save route strategies to a file having any name you wish to 
assign.

Strategy File Button
To choose an alternative strategy file, use the Strategy File button.    The Strategy File button displays 
the Select Strategy File dialog in which you can select the name and location of a strategy file you want 
to save or load.    This is a Windows common dialog, with the familiar look and feel of other Windows 
dialogs used for opening, retrieving or creating files.



 Output PCB File Button
The Output PCB File button displays a dialog in which you can specify the name and location of your 
output design file after it has been routed.    Here too, a default name has been provided.    The letter R 
(for routed) precedes the current design file name.    The last character is dropped if the new name 
exceeds eight characters.    The default file extension is .PCB. 

The default name can be overridden by clicking the Output PCB button.    The dialog which appears 
allows you to specify the name and location of your routed PCB board.    Again, this is a Windows 
common dialog, with a familiar look and feel of other Windows dialogs used for opening, retrieving or 
creating files.



 Output Log File
In addition to the output file, ACCEL PRO Route and Quick Route generate a report file at the end of the
routing session, detailing the results of the session.

The Output Log File button displays the Select Output Log File dialog, in which you can specify the 
name and location of your report file.      This dialog is a Windows common dialog, with a familiar look 
and feel of other Windows dialogs used for opening, retrieving or creating files.

Valuable information about your PCB design, routing strategy and route preference data is provided.

Before routing starts, the input PCB is analyzed.    General information as well as your routing strategy 
and router-selected options are written to the log file.    After each pass, per-pass and total routing 
statistics are written to the file.    When routing is completed, summary information is written to the file.

Refer to View Log for additional information.



 Load Button
Select the Load button to restore saved strategies.    Choose the strategy file name, then 
click Load.    The design and routing data is updated to the saved values.    You will see these changes 
in the Route Autorouters dialog.



 Save Button
Anytime after you have selected a strategy file name, you can capture the current strategy by clicking 
Save.    The strategy file is also saved automatically when you start the route. 



 Set Base Button
The Set Base button returns the strategy and output files to their default file names.    This is a simple 
way to go back and start over again when assigning file names.    The default names are derived from 
the design file name, including the full path.



 Layers
The Layers button on the Route Autorouters dialog provides a shortcut for activating the Options 
Layers command and dialog.        

You can add, delete, enable, disable and modify the routing bias of a layer.    Changes made for 
autorouting apply to PCB.

ACCEL PRO Route supports true multi-layer autorouting on up to 30 signal layers including Top, Bottom
and user-defined layers.    The router seeks to make connections on any of the enabled signal layers; it 
is not restricted to routing on layer pairs.

ACCEL PRO Route supports any number of plane layers, up to a total of 99.    The nets to be connected
to planes are defined in PCB when the netlist is first loaded.    These can also be defined manually 
when a plane layer is created.    

ACCEL PCB provides Top, Bottom, Board and several non-signal layers automatically.    Additional 
signal layers (e.g., MID1-MID8) and power and ground plane layers are automatically defined when a 
Tango PCB or PCB PLUS (Series II) board is loaded.    

For additional information, refer to Options Layers.



 Net Attrs
Clicking the Net Attrs button from the Route Autorouters dialog displays the Edit Nets dialog.    This 
dialog allows you to display or hide nets, edit or view net attributes, change net names, get net 
information or select information by net.    Setting net attributes is important for routing, because it lets 
you override the global values on a net-by-net basis (for example: the line width and via style).    

See the Edit Nets command for details.

Quick Route 
QuickRoute supports the following net attributes.    These attributes override the default settings for 
each net to which they are attached.

AUTOROUTEWIDE = <TRUE/FALSE>

VIASTYLE = <via style name> for wide nets

WIDTH = <routing track width in current units>

NOAUTOROUTE = <TRUE/FALSE>

MAXVIAS = <number of vias> for maze route only

Limitations
Only a single via style is allowed across all non-wide net classes.    The current routing via as 

specified in the Route Autorouters dialog must be geometrically identical to any VIASTYLE attribute that 
exists for a net that is not routed with the wide pass.

For nets routed with the wide pass, each of the net attributes VIASTYLE, WIDTH, and 
AUTOROUTEWIDE must be specified.    There can be a different via style or line width for each wide net.

Global ripup and the RIPUP attribute are not supported.
The MAXVIAS attribute is supported for maze routing only.

Refer to the Edit Nets command for details.



 Passes
The Passes button allows you to enable different types of routing passes.    When you click the Passes 
button, you see the Passes Selection dialog.    All passes except Route Cleanup and Via Minimization 
default to ON.    From this dialog you have the following options:

Wide Line Routing
Horizontal
Vertical
L Routes (1 via)
Z Routes (2 vias)
C Routes (2 vias)
Any Node (2 vias)
Maze
Any Node (Maze)
Route Cleanup
Via Minimization



 Via Style
A via style defines a stack of shapes for each layer or layer type that make up the via.    This option 
indicates the via style to be used for vias added by the autorouter.    The shape and size of the item on 
each layer may vary.    By default, shape definitions are explicitly provided for top and bottom layers, 
signal layers (not specifically defined), plane layers (not specifically defined) and non-signal layers (not 
specifically defined).    However, you can add shapes for any layer.    Additionally, with the exception of 
the default style, which is read-only, pad definitions for any layer can be modified.

You can add, delete, or edit via styles by using the series of available dialog boxes.    This command 
also sets current via style for the Place Via command for PCB and can be accessed from the Options 
Via Style command.    

note:
With this command you are defining the global defaults for nets as they relate to a via style.    For 
wide routes only, you can override these defaults on a net-by-net basis by adding the VIASTYLE 
attribute with the Edit Nets command.

You set the default routing via by setting the desired via to be current, marked with an asterisk (*).    

note:
Do not confuse the default routing via with the default via style.    The default via style, which is 
seen as (Default) in the Options Via Style dialog, is a single style provided as part of PCB.    It 
may not be changed or deleted.    The default routing via is the via style that the autorouter uses 
to route all nets, except ones with the VIASTYLE attribute set to override this default.    The 
default routing via may be the default via style, or it may be any other style you choose.

You may create a new via style or modify an existing one directly from this dialog.    Additionally you can 
view the default via style and delete an existing via style.    See Via Properties for more details.

Quick Route Limitations
Only simple via and pad styles are supported.
Only a single via style is allowed across all non-wide net classes.    The current routing via as 

specified in the Route Autorouters dialog must be geometrically identical to any VIASTYLE attribute that 
exists for a net that is not routed with the wide pass.

The routing via can be no larger in diameter than twice the current routing grid.    In the case of 
non-uniform routing grids, the smallest of the individual grid values is the limit.

There is no via grid multiple.    Vias are placed on the routing grid.



 Error Messages
Use the Error Messages box to set where you would like error messages to appear.

You can direct the messages to appear on the screen only, only in the Output Log File, or both (the 
default setting).    If you choose Output to Log File, routing continues uninterrupted, because you do 
not have to respond to error messages.



Start Button
Clicking this button starts the routing process.    Several changes occur to the screen:

The Menu bar changes to offer route-specific commands.
The Toolbar icons are replaced with icons for route commands.
The Status line displays each step of the routing process.

The autorouter is then initialized, the board is prepared for routing, data is transferred to the router and 
the router analyzes your design.    During this time, the Status line keeps you informed of all activities.    
Routing begins, pass-by-pass, and the Status line displays each completed line as it is routed.

Remember, you are in Windows.    While routing you have access to other Windows applications.    Note
however, that the autorouter is resource-intensive; performance of the router and of other programs is 
affected as the demand for resources goes up.    The Pause command can be used to temporarily stop 
the autorouter and relinquish resources for other tasks, if this is necessary.

The router routes the board using the current design and route strategy information.    Your board must 
be saved prior to routing to ensure a known base.

If you run the command after having edited a strategy file that contains an existing output filename, the 
program prompts you to overwrite the output file or cancel.    In this way, you can avoid overwriting files
you may wish to keep.

Commands available during the routing process are:

Display (colors, layers, items, cursor shape, display mode, etc.). Options Display
- Info (current routing status display) Route Info

Zoom (various zoom levels and types). View Commands
Cancel to stop or suspend a route. Route Cancel
Pause/Resume. Route Pause and Route Resume
View Log to obtain a snapshot of the output log file during routing. Route View Log
Help.
Prompt, status and Toolbar line display control. View Commands

After interrupting routing to run one of the above commands, the routing process continues.    

note:
ACCEL PRO Route doesnt performs a DRC on pre-routes.    You should execute the PCB Utils 
DRC command to check pre-routes before the board is routed by ACCEL PRO Route. 



 Quick Route Constraints
Only simple pad and via styles are allowed.
Only a single via style is allowed across all non-wide net classes.    The current routing via as 

specified in the Route Autorouters dialog must be geometrically identical to any VIASTYLE attribute that 
exists for a net that is not routed with the wide pass.

For nets routed with the wide pass, each of the net attributes VIASTYLE, WIDTH, and 
AUTOROUTEWIDE must be specified.    There can be a different via style or line width for each wide net.

The routing via can be no larger in diameter than twice the current routing grid.    In the case of 
non-uniform routing grids, the smallest of the individual grid values is the limit.

The allowed routing grids are 10mil, 12.5mil, 16.7-16.6-16.7mil, 20mil, and 25mil.    Metric grids 
are not supported, even in mm mode.

The routing line width cannot exceed the grid value.    In the case of non-uniform grids, the 
smallest of the individula grid values is the limit.

The NOAUTOROUTE net attribute is supported.
Disabled layers are not sent to the router and a warning message is generated if disabled signal 

layers have copper on them.    The routes are discarded.
Checkpointing is not supported.
Global ripup and the RIPUP attribute are not supported.
The MAXVIAS attribute is supported for maze routing only.
Copper sharing is not an option, the router shares copper with vias.
The router always uses orthogonal routing.
There is no auto pass nor auto grid selection.
There is no via grid multiple.    Vias are placed on the routing grid.
The log file does not contain entries for options that are not supported removed.    However, the 

format of the log file is the same.
There can be no more than four plane layers.



 Options
The Options area of the Route Autorouters dialog lists the following options.

Auto Grid
Allows ACCEL PRO Route to select the best grid, based on the board to be routed and the design 
rules you specified.    When the Auto Grid option is enabled, the autorouter ignores the manual grid
setting.

Ripup
When enabled, this option allows ACCEL PRO Route's reconstruct algorithm to remove and re-
place pre-routed lines during the Iterative and Manufacturing passes.

This option should be disabled only when you have pre-routed lines that must remain intact as you 
routed them in PCB.    ACCEL PRO Route will leave those pre-routes alone.    However, if you have 
no sacrosanct pre-routes, always enable this option, giving ACCEL PRO Route the maximum 
flexibility to converge on the best design in the shortest time.    You can also control ripup per net 
using the Net Attrs button.

ACCEL PRO Route never rips up a line without re-placing it, with the original or a new topology.    
So you will never lose previously routed lines.

Diagonals
The Diagonals option allows you to enable diagonal routing, which performs 45-degree entry and 
exit from a pad as well as 45-degree diagonal lines elsewhere on the board.    If this option is 
disabled, no diagonal routes are added to the PC-board.

ACCEL PRO Route provides a great deal of flexibility with regard to the routing of 45-degree lines.   
If the diagonal routing option is enabled, ACCEL PRO Route will make 45-degree routes, taking into
account the type of grid in use.    The 45-degree routes are placed during the routing passes.

For SMT or particularly dense designs, disabling diagonals until the board is fully routed may help 
improve performance.    If the router is having trouble completing the board, disable Diagonals and 
run the design through the Iterative passes.    After the board routes to 100%, run the output PC-
board through the Manufacturing passes of ACCEL PRO Route with diagonals enabled to allow the 
router to shorten traces and to clean up the board.

The benefits of diagonal routing are that it reduces the number of vias and connection inches, 
produces more manufacturable results and creates a more aesthetically pleasing design.

Checkpoint Interval Minutes
ACCEL PRO Route saves a checkpoint file at the end of every routing pass and on request by 
means of the Route Cancel command during routing.    You can also direct the program to save a 
checkpoint file at a specified time interval according to the value set in the Cpt interval textbox.      
The default setting calls for a checkpoint every 120 minutes.

The checkpoint file can spare you the disappointment of lost routes and costly re-routing time in the 



event of power failure or other system disruption.    The checkpoint file is saved with the .CPT 
extension and may be used to resume the routing session with the Route Restart button.    



 Copper Share
The Copper Share option allows you to specify how the autorouter will do copper sharing; using lines 
and vias, or vias only.    You can also disable the option.    When line and via sharing is enabled, ACCEL 
PRO Route routes connections to the closest line or via in the same net, rather than being restricted to 
pin-to-pin routing.    Via-only copper sharing allows connections to be made through a via, but not 
directly to a line.

Copper    sharing, or "T-Routing," helps to achieve higher completion rates and reduces the amount of 
copper length on the finished board design.    This in turn improves the reliability and operational 
characteristics of the finished product.



 Passes
Allows you to enable different types of routing passes or set the program to automatically select the 
optimum passes to be run.    You also set the number of iterative (rip-up) and manufacturing passes to 
be run, and indicate if manufacturing passes should be forced if the board isn't 100 percent routed.

You may run up to 20 Iterative passes and ten Manufacturing passes.    Sets of (Wide Initial, Wide 
Comprehensive) or (Memory, Initial, Comprehensive, Exhaustive) passes are run for each net class.

The passes may be broken down into three phases:    

Constructive, which includes all of the options from Wide Via Fanout through Exhaustive in the 
Pass Selection dialog.    These passes function only to add lines and vias to the board.

Iterative, which includes local and global ripup passes.    These passes rip up and re-route 
existing connections to make room for routing other ones.

Manufacturing Improvement, which includes Manufacturing and Final Manufacturing passes.    
These passes clean up the board for manufacturing.    If the board is not 100% routed, these passes arent
run unless you enable the Force Manufacturing pass option.

The autorouter schedules passes for each net class.    A net class is a collection of nets with the same 
characteristics (e.g., width and via style).    If multiple net classes are defined, one "set" of passes is 
scheduled for each class.    

For example, you would have 2 net classes if the default is 12 mil lines and 40 mil vias, and your power 
and ground nets are given override attribute values indicating 20 mil lines and 50 mil vias.    The router 
may schedule wide initial and wide comprehensive passes as the constructive passes to complete the 
power and ground nets.    Memory, initial, comprehensive and exhaustive passes might be scheduled for
all other nets.

The autorouter automatically schedules iterative passes only for the default net class.    This is usually 
advantageous since the non-default net classes are typically routed first (when the board is empty) and 
do not need to be repeatedly ripped up.    It is a time-saving decision.    Alternatively, all net classes are 
scheduled for iterative pass routing when you manually select that pass.    This gives you more control to
finish your board.

All net classes are scheduled for the number of manufacturing passes chosen in the Pass Count box.    
The total number of scheduled passes cannot exceed 100.

If you decide to control the autorouter by manually selecting passes, the following description of 
individual passes may be helpful.

Wide Via Fanout (SMD)
During the Wide Via Fanout pass, wide lines are routed from SMD (e.g., power and ground) pads to
vias.    Fanouts ensure that all routing layers have access to the surface pads.    They are typically 
made on boards with more than two signal layers.    To schedule this pass manually, you must set 
the AUTOROUTEWIDE attribute for the nets to be fanned out as wide nets.    Click the Net Attrs 
button in the Route Autorouters dialog to access this option

Via Fanout (SMD)
During the Via Fanout pass, lines are routed from SMD signal pads to vias.    Fanouts ensure that 
all routing layers have access to the surface pads.    They are typically made on boards with more 
than two signal layers.



Wide Initial
During the Wide Initial pass, bus-width power and ground lines and other wide lines that require not 
more than three vias are routed in a particular arrangement.    This simplifies later signal line 
routing.    During this pass, layer directionality is strongly enforced.    To schedule this pass manually,
you must set the AUTOROUTEWIDE attribute for your wide nets.    Click the Net Attrs button in the 
Route Autorouters dialog to access this option.    See the Net Attrs section for additional information.

Wide Comprehensive
The Wide Comprehensive pass is similar to the Wide Initial pass except that layer directionality is 
loosely enforced and connections to any number of vias are made.    This pass is designed to 
complete power and ground routing. To schedule this pass manually, you must set the 
AUTOROUTEWIDE attribute for your wide nets.    Click the Net Attrs button in the Route 
Autorouters dialog to access this option.

Memory
During the Memory pass, easily made connections on a single layer are completed.    These are 
generally data bus connections to memory arrays.    The end points must be located so that they 
can be joined by lines that are very nearly horizontal or vertical within 100 mils or within the defined 
grid cell.    This pass only permits vias between surface pads.

Initial
During the Initial pass, easily made connections requiring no more than three vias are completed.    
Layer directionality is strongly enforced and no diagonals are permitted.

Comprehensive
During the Comprehensive pass, more difficult connections requiring no more than six vias are 
made.    Segments directed away from the targets are permitted and layer directionality is loosely 
enforced.

Exhaustive
During the Exhaustive pass, the most difficult connections are attempted, using whatever means 
are necessary within the constraints of the design rules.    An unlimited number of vias and 
segments directed away from the target are permitted.    Layer directionality is very loosely 
enforced.

Iterative (rip-up)
The iterative passes are the heart of this reconstruct router.    They perform the complex tasks of 
locating blocking traces and reconstructing alternative paths for them.    This allows previously un-
routed connections to be made.    During this process, the entire board is analyzed to get the 
highest completion rate possible.

ACCEL PRO Route supports up to ten Iterative passes per net class.    Two types of Iterative 
passes exist for different conditions:    local and global rip-up.    The autorouter selects local rip-up of



the board if it is 98% complete or if three global rip-up passes have been run consecutively.    
Otherwise, global rip-up is selected.    

A local rip-up pass is similar to an Exhaustive pass in that unlimited numbers of vias and segments 
directed away from the target are permitted, and layer directionality is very loosely enforced.

Global rip-up is more complex.    Like local rip-up, the autorouter permits an unlimited number of 
vias and, again, layer directionality is very loosely enforced.    However, if you watch the Status line 
during a global iterative pass routing, you will notice that statistics are provided twice for a single 
pass:    once to re-route nets and once to retry remaining open connection.    The first time, the 
router works through all nets and the second time, through all connections.

note:
You specify the number of iterative passes in the Pass Counts box.    Iterative passes should not 
be manually selected to route a board that has not been, or will not be, sent through the 
constructive passes.    Performance will degrade because of the considerable complexity of the 
Iterative pass algorithm.    Constructive passes work effectively to do the initial routing and should 
not be bypassed.

Manufacturing
The manufacturing passes are your cleanup passes; they optimize routing for manufacturing.    
Because the function of the iterative passes is to complete open connections, these passes place 
tracks and vias in a way that leaves space for subsequent tracks and vias.    Whereas these passes 
do a great job at completing the open connections, they leave your board far from being 
manufacturable.    That task is left for the manufacturing passes.    You specify the number of 
manufacturing passes to run for each net class in the Pass Counts box, up to a maximum of 10.

Other functions performed by the manufacturing passes include the spreading of lines, removal of 
acute angles and improved pad entry (through the corners of square pads and the ends of 
rectangular or oval pads).    True memory patterns of a single layer are generated.    These same 
routing characteristics provide improved electrical performance and result in aesthetically pleasing 
designs.

Line segments are moved to other layers to help separate the signals, and diagonals are added to 
shorten line length.    The pass also utilizes a concept known as copper sharing to combine lines in 
the same net.

The manufacturing passes are not intended to improve the autorouter's completion percentage and 
are generally not enabled until the board is finished.    

Final Manufacturing
During the Final Manufacturing pass, routing is refined for manufacturing.    The same changes 
seen during manufacturing passes are seen here, but the changes tend to be more subtle.    For 
instance, if diagonal routing is permitted by the design rules, additional 45-degree corners may be 
incorporated during this pass. 

Force Manufacturing Pass
The Force Manufacturing Pass check box allows you to force the router through the 
manufacturing passes even if the board is not 100% routed.    Disable this option if you want routing 
to stop before the Manufacturing passes if your board isn't completely routed, so that you can try a 



new grid or make some other design change that might help achieve 100% completion.

Auto Pass Selection
Allows ACCEL PRO Route to select which passes to use during routing.    If you want to select 
passes manually, disable this option and enable the specific pass selections in the Manual Pass 
Selection area of the dialog.    When you enable this option, The autorouter automatically selects 
constructive, iterative and manufacturing passes that are appropriate for your board.    The number 
of iterative and manufacturing passes scheduled come from the Pass Counts boxes (discussed 
below).

Once the router achieves 100% completion, it skips any remaining constructive or iterative passes.  
For this reason, you may want to set the Iterative pass count to 10, allowing the router the 
maximum opportunity to complete the board.

Pass Counts
Maximum Iterative Passes and Manufacturing Passes:    The maximum iterative and 
manufacturing pass counts instruct the autorouter on the number of passes to schedule.    These 
numbers are used whether you select passes automatically or manually.    However, there is an 
important distinction for the way iterative counts are used.    For Auto pass selection, the autorouter 
schedules only the default net class for the selected number of iterative passes.    For manual 
passes (assuming the Iterative Pass check box is enabled), the autorouter schedules all net 
classes for the number of iterative passes requested in the Pass Count box.    

The default numbers are 5 Iterative passes and 2 Manufacturing passes.    Acceptable ranges for 
both are from 0 to 10.



 Line Width
You can set the line width for the routed lines by clicking the Line Width button on the Route 
Autorouters dialog.    This presents the same menu as if you had chosen the Options Current Line 
command from the PCB menu.    Click the Line Width button to display the dialog.    Enter the value in 
the Line Width text box (or choose from the options in the combo box) and click OK.

Refer    to the Options Current Line command for details.



 Route Grid
Defines a routing grid if the Auto Grid option has not been selected.    The current, absolute or relative 
grid is used for routing.    In both cases, the autorouter automatically locates to optimal grid origin for 
routing.    When the route is complete, the Relative Grid Origin box is updated with the routing grid 
origin, and the routing grid used is added as the current Relative Grid Spacing.    The units used are 
determined by the setting in Options Configure.

Mode
To specify a routing grid when the Auto Grid option is disabled in the Route Autorouters dialog, you
may set either mode (Absolute or Relative).

Grid Spacing: Uniform/Non-Uniform
You specify routing grid spacing in the Grid Spacing text box.    The desired value may be selected 
from the Grids list, but you are not limited to using the grids listed there.    You specify your own 
custom grid by typing it in the Grid Spacing text box, and clicking Add.

The grid spacing defines the spacing pattern of the grid points. The grid pattern may be uniform 
(equal spaces between all lines) or it may be non-uniform to allow one or more lines to pass 
between component pads, while keeping the number of grid points to a minimum.

Uniform grids are generally used for relatively simple, low-density PC-boards.    The illustration 
below shows 60 mil pads spaced 100 mils apart, 50 mil grid spacing (using the hatched grid option),
with one routing connection running between the pads.

Non-uniform grids are typically required on complex, high-density PC-boards. The main benefit of 
the non-uniform grid over the uniform grid is performance:    it produces far fewer grid positions 
without the loss of route paths.    Thus, completion time is shortened and less memory is required, 
without losing any freedom in placement.    

For example, if you have 100 mils between grid points, you can set non-uniform grid spacing to 40-
20-40, which would allow two grid points between pads spaced 100 mils apart.    With 8 mil line 
widths and clearances and 56 mil pads, the autorouter could place two lines between the pads.

note:
Remember to set up your grids correctly before you place your components.    Place the 
components on a relatively coarse grid (e.g., standard DIP components on an absolute 100 mil 
grid).    You can subsequently choose a finer grid spacing for routing purposes (such as non-
uniform as described above).    The router is able to route to off grid components, but there is a 
performance penalty in speed and perhaps completion.

Additional Information
Routing and Via Grids



 Via Grid Multiple
This option limits via placement during routing to keep routing channels open.    It is most useful 
when fanning out vias for surface mount devices.    If you allow vias to be placed at every point, they
can block routing channels, reducing completion.    The value you specify here is a multiple of the 
manually selected routing grid.    

For non-uniform routing grids, the via multiple is applied to the sum of the non-uniform spacing 
values.    For example, if you have a 40-20-40 mil, non-uniform, routing grid, and type a 2 as the Via
Grid Multiple, then the autorouter allows via placement every 200 mils (2 times the sum of 40 + 20 
+40).    This option is valid only when you disable the Auto Grid option in the Route Autorouters 
dialog.

note:
The Visible Grid Style, Relative Grid Origin and Delete Grid options are also available from the
Options Grid dialog.    Because they aren't required for routing, they are not discussed here. 

Design Rules and Routing Grids
There is a direct correlation between your design rules (e.g., line width, clearances, via styles) and 
the routing grid.    Together, these values have an enormous effect on completion and performance 
of ACCEL PRO Route.

You are always responsible for setting the design rules because they are determined by your own 
particular fabrication requirements.    ACCEL PRO Route, on the other hand, will assist by 
automatically selecting the best routing grid to go with your design rules.    The default values 
supplied (12 mil for all instances) are satisfactory for general purpose commercial, high volume, low
priced production.

If you choose your own routing grid, be certain you consider the design rules before selecting a 
routing grid, and vice versa.

See also:

Routing and Via Grids



 Restart Button
Restarts ACCEL PRO Route from a checkpoint file.    When you cancel a route and choose the suspend 
option, the router saves your route in a checkpoint file, so that you can continue it at a later time.    
ACCEL PRO Route also saves a checkpoint file at the end of each pass and after the amount of time 
specified with the Cpt Interval option on the Route Autorouters dialog. 

Checkpoint files have the same path and base name as your design file, but have a .CPT extension.    
They are automatically deleted if the route completes the scheduled passes or is prematurely terminated
when you select any of the Stop options from the Route Cancel command.

To restart the route from this checkpoint file, you must first load the original, unrouted input board in 
PCB.    Then, select the Restart button from the Route Autorouters dialog.    All of the lines and vias 
placed before the checkpoint was made, exist as part of the checkpoint file, along with your original 
routing and design strategy.    This data is used to restore the autorouter to its state at the time the 
checkpoint file was created.

note:
The checkpoint file used for restarting is deleted when the route completes, when you cancel 
after restarting or when a new checkpoint file is created.    For this reason, you should save the 
checkpoint file before restarting if you intend to use it again.

Routing resumes automatically.    You don't have the chance to change your design and routing strategy,
once you have clicked the Restart button in the Route Autorouters dialog.    If you want to make strategy 
changes,    use the Route Cancel command to stop and save your board as an output PCB file.    After 
you make strategy changes, run this command to begin routing the updated design.



 Route View Log
Allows you to view the log file derived from your routing session.    ACCEL PRO Route generates a 
comprehensive report file at the end of the routing session, detailing the results of the session.    The 
report is presented in file viewer selected in the Options Configure dialog.    Viewing the log file does not
interrupt routing.

Valuable information about your PCB design, routing strategy and route preference data is provided.

Before routing starts, the input PCB is analyzed.    General information as well as your routing strategy 
and router-selected options are written to the log file.    After each pass, per-pass and total routing 
statistics are written to the file.    When routing is completed, summary information is written to the file.

The repor file contains the following information:

Headers and Footers
The name and version number of the router being used is found in the header.    The footer displays the 
date and time the report was created.    You can define your own header and footer using the File 
Reports command in PCB.    This information is stored in the PCB.INI file.

General
The report provides a list of the input PCB, output PCB and strategy file names, your selected units, the
available memory and the route start time.    The report also lists the routing grid and via grid settings, 
the checkpoint interval, rip-up pre-routes, diagonal routing and copper sharing options, the iterative and 
manufacturing pass counts and whether manufacturing passes should be run if the board is not 
completely routed.

Layer Settings
Provides a listing of the selected layers, indicating their directional bias (horizontal, vertical).    Net 
names are provided for plane layers. 

Net Classes
PRO Route determines net classes for nets with the same WIDTH, VIA STYLE, etc.    This area of the 
log provides a listing of each net class and their defined width, via padstack and the maximum number 
of vias.    The autorouter routes all nets belonging to the same net class together in a pass.

Pass Settings
Lists the scheduled passes and identifies the net classes to be routed during each.    Some scheduled 
passes may not be run, as explained in the next section.

Pass Performance
For each routing pass completed, the report file lists a count and percentage of the lines scheduled, 
completed and deferred during the pass, and for the entire run so far.    Also reported are vias and 



copper length that were added or deleted during the pass as well as for the entire routing session.

Final Board Statistics
Final board statistics lists the total number of pads on the board, the number of equivalent 16-pin ICs 
(EICs), the dimensions and area of the design, the density (in square units per EIC; the lower this 
number is, the denser the board), the vias added during the routing process, the total number and 
length of routed lines (and percentage of routed lines to total lines), the total number of un-routed lines 
(and percentage of un-routed lines to total lines) and the total execution time for the routing process.

note:
If you abort the routing process, the report file reflects the final board statistics only up to the point
of termination.    A warning message appears in the report file, indicating the type of termination 
request made (stop and save or stop and don't save).



Route Miter
Not available for ACCEL TangoPCB.

Converts 90-degree corners on routed connections into 45-degree mitered corners or 90-degree arcs, 
depending on which option you select.    The 90-degree corner must be true horizontal and vertical 
segments and have the same line width.    This command only works on 90-degree tracks; it does not 
work on 45-degree tracks or arcs.

1. Select Route Miter or the Toolbar button, and the Route Miter dialog appears.

Once you have selected the corner style option from the Route Miter dialog you can miter any 
number of corners with that style.    After you finish mitering, click the right mouse button or Esc to
cancel the mode.

2. Click and hold on the 90-degree corner that you want to miter.    Drag to create the mitered corner.
Don't release the mouse button until you have the proper length of mitering.



Route Manual
Allows you to manually route and/or reroute existing connections or net copper items on multiple layers.

Before you route you must have already placed components and placed connections between the 
component pads (net nodes).    For information about components and connections, refer to Place 
Component and Place Connection.    You can also get connections by loading a netlist (see Utils Load 
Netlist).

Also before you route, you should have all the layers enabled that you will be using during your routing 
procedure.    To see the list of enabled layers, use the layer combo box on the Status line.    You can 
change between these enabled layers (making each layer the current layer, in turn).    Use the Options 
Layers command to alter the list of enabled layers (enable, disable, add to, delete, modify), or as an 
alternate way to change the current layer.    

note:
The program does not allow routing on a non-signal layer.    If you try to change to a non-signal 
layer while you are in Route Manual mode, an error message will be displayed.

Manually Route a Connection
1. Zoom in so that the connections you want to route are large enough to select.    Select Route 

Manual.

2. Click directly over the connection and drag to where you want to route the connection.    The new 
segment will be drawn in the current layer color.    The new copper segment will start from 
whatever end of the connection it is closest to.

note:
An alternate method for click-and-drag is to press the Alt key, then click the left mouse button (Alt 
+ left mouse). You can then drag the routed line anywhere without having to keep the mouse 
button depressed.

3. You can continue routing by clicking at points where you want the route to go.    Click to select a 
route point on the connection line, drag the line to the new location.    Select the next point and do
the same thing.    Continue this process until the connection route is satisfactory.    

To complete the routing of a segment, click the right button.    

Slash Keys
To leave a partial route, which is represented by a connection line, press the forward slash key "/".

When the Optimize Partial Route option in the Options Configure dialog is enabled, pressing the slash
key during manual routing terminates the route and causes the guide connection line to connect to the 
nearest net endpoint.

Status Line Information
The right side of the Status line displays measurement information while you are manually routing.    For
example, it displays the delta X and delta Y measurements of a ghosted segment while you are 
dragging, and the total length of the segment being routed (as shown below) when you release.    The 
measurement does not include already routed or yet-to-route portions of a net.



Routing Between Layers
You must switch layers if you attempt to route from, or to, a pad on another layer from the current layer.  
Use the L key as a shortcut to toggle between enabled layers.    A via of the current style will 
automatically be inserted when you change layers.

Crossing a Blockage
To route any segments where you need to cross a blockage, change to the bottom layer (use the L key 
or the layer combo box).    A via is automatically placed to connect the layers and the line from that point
reflects the new color (of the layer).    Again, whenever you click, it becomes a point where you can 
create a routing angle or change direction.

Unwind 
If you make a mistake, you can press the backspace    key, and the previous segment disappears 
(unwinds).    With each press of the backspace key, a previous segment or via is unwound.

Right Mouse Button
To route the remainder of a connection (all the way to the next node), click the right mouse button.    You
can then click (left button) over another connection segment to begin routing it.

If the current endpoint of the trace being routed is point-to-point with an object belonging to the same 
net (pad, via, line, or arc) pressing the right mouse causes the route to be recognized as completed, 
ending the route.    The routing guide connection (the remaining connection displayed during manual 
routing) is not replaced with a line trace to the original guide connection destination point when the right 
mouse button is pressed.    The guide connection will be updated as appropriate.    

The exception to this behavior occurs when routing to a pad that is the endpoint of the current guide 
connection.    Pressing the right-mouse button completes the route to the pad center.

Orthogonal Modes (O key)
You can press the O key to toggle the orthogonal modes while placing lines during manual routing.    
You can enable/disable certain orthogonal modes in the Options Configure dialog.    The available 
orthogonal modes are provided as three mode pairs, with a total of six modes (three types, with two 
variations on each type).    The O key cycles through the three mode pairs and the F key toggles 
between the pair that is current. Refer to the Options Configure command for information.

90/90 Line-Line
Both lines are either horizontal or vertical (displayed perpendicular to each other).    For long, the first 
segment is always longer than the second.    For short, the first segment is shorter.    You can toggle 
between the two with the F key.

45/90 Line-Line
You can toggle between the two modes with the F key.    The first mode makes the first segment display 
at a 45-degree angle and the second segment is either horizontal or vertical.    The second mode makes
the first segment either horizontal or vertical and the second segment is displayed at a 45-degree angle.



90/90 Arc-Line 
You can toggle between two modes with the F key.    The first mode makes the first segment display as 
an arc and the second segment is either horizontal or vertical.    The second mode makes the first 
segment either horizontal or vertical and the second segment is displayed as an arc.

On-line DRC
Online DRC checking is performed after each mouse or keyboard click fixes the end of a segment 
during manual routing.    Each routing click can cause up to two trace segments (either lines or arcs) 
and a via to be placed in the design; all newly created items are checked for DRC violations.    When a 
violation is detected, a beep is generated and a DRC error indicator is placed at the approximate 
location of the violation; no error message appears. Multiple violations result in two beeps and multiple 
error indicators. 

When a connection is completed, the number of DRC error indicators generated for the connection 
appears in the Status Info box on the status line, and a report of the violations is presented 
automatically if you checked the View Report checkbox in the Options Configure dialog and there is at 
least one violation.    This report includes a summary count of the violations created during the routine of
the connection, plus the information from the individual DRC error indicators.

The clearance values used for clearance testing of pads, vias, and lines on a particular signal layer are 
taken from the Options Design Rules dialog. This dialog is discussed in the Clearances section above.

Associated DRC error indicators are automatically deleted when unwinding an offending trace or via, 
and when undoing a completed connection with violations.    Otherwise, DRC error indicators are not 
automatically removed when the violation is corrected.

Use the Options Configure dialog to enable online DRC checking.

Overlapping Connections 
For routing overlapping connections, you may need to temporarily route one connection out of the way 
to access the desired connection.    If you can't unwind or undo the temporary route, you can select and 
delete it and it will return to its prior existence as a connection.

When you complete a route on a pad and a diamond shape appears, then you have reached the 
connection destination.    The diamond symbol represents a zero length connection.    This is helpful if 
you can't distinguish between overlapping connections.    

Polygons
Polygons maintain full net information and correctly remove connections after the polygon is added to a 
net.    You can add the polygon by running the Utils Reconnect Nets command or the Utils Load Netlist 
command with the Reconnect Copper options enabled.

T-Routing
Manual routing of a trace to non-endpoints of an existing trace in the same net completes a net 
connection.    The new trace completes a net connection if it has been point-to-point routed, or crosses 
the center line of an existing line trace belonging to the same net. Moving an existing trace so that it is 
point-to-point routed, ends on, or crosses the center line of another trace in the net also completes the 



net connection.

If the routed trace endpoint lies on the center line of the existing trace, the existing trace is split into two 
traces, each having an endpoint at the intersection.    If the trace being moved or routed crosses an 
existing trace, the trace being moved or routed is also split into two traces having endpoints at the point 
of intersection.    

Any redundant connections in the net are removed. 

Line to arc, or arc to line routing where the endpoint of the trace being routed is point-to-point routed 
behaves as described above except that there is no automatic trace splitting performed to either trace.

Manual routes that intersect with traces belonging to other nets create on-line DRC and Utils DRC 
errors.

Routing to Free Copper
Manual routing to the center of a pad, via, or the endpoint of a line that is not part of any net adds that 
item to the net being routed.    This occurs as each route operation is completed, without running the 
Utils Reconnect command or the Reconnect Nets option in the Utils Load Netlist command.    

To add other objects (arcs and polygons) to the net, run Utils Load Netlist with the Reconnect Copper 
option enabled, or use the Utils Reconnect Nets command after the routes intersecting free copper 
have been completed.

Stop Routing
You can temporarily stop routing a connection by pressing the forward or back slash keys, leaving an 
unrouted connection attached to the last routed segment.



Options Commands (PCB)



Options Block Selection
Defines selection filter for block selects (see Edit Select).    You can configure the block select feature to 
select all objects, objects by type, or even objects with specific parameters.    And you can specify these
selection criteria layer by layer, e.g., certain types of objects for one layer, another type for another 
layer, etc.    The selection possibilities can be as specific, limited, or as general as you choose.

For example, if you wanted to change 10 mil lines to 15 mil lines on 3 layers, you could do it very easily 
with this command in conjunction with Edit Select and Modify Line, without affecting any other line 
widths on these or any other layers; this is not to mention ignoring all other objects within the block 
selection.

Enable Options Block Selection to display the Options Block Selection dialog.    From this dialog you 
can set criteria for selection of specific objects and layers.

Select Mode Box
Inside Block is the default setting, which means that all items inside the selection block will be 
included, according to the selection criteria you establish in this dialog.

Outside Block allows you to select outside of the block select (outside of the selecting rectangle).    All 
of the selection criteria that you specify in the Options Block Selection dialog will function outside the 
block rather than inside, which is the default.

Touching Block allows you to select anything that is touching or inside the selection block that you 
draw.    This feature is more inclusive (it selects more items) than either Inside or Outside Block.

Items Area
All of the objects listed in the dialog can be specified individually whether they will be included in a block
select or not.    If you want to include only one or two items in your selection, then first click Clear All to 
disable all items, then individually enable the specific items (with the check boxes).    If you want to 
exclude only one or two items in your selection, then first click Set All to enable all items (if they are not 
already enabled), then individually disable the specific items you want to exclude (with the check 
boxes).      

The enable/check boxes have three states: checked (included), blank (excluded), or grayed (masked).

Items Buttons (Selection Mask Dialogs)
Those items with corresponding Property buttons (e.g., Port) have three states:

included (checked).
excluded (blank).
masked (grayed).

This feature allows you to narrow your selection further by setting specific properties as selection 
criteria for any item with a corresponding Property button.    To access these property masks, set the 
item to its third state, the masked (grayed) state, in the items area.    This allows access to the items 
button.    For example, to create a selection mask for lines, you click the Line button and a smaller 
dialog appears (Line Selection Mask) where you can set the search criteria.    

If you designate 50 mil for the Line Width, then when you do a block select, only 50 mil lines will be 



selected within the block.    

Selection Mask Parameters
This is a basic summary of the parameters you can work with in the Selection Mask dialogs.

For Arc and Line, you can specify line width of arcs and line segments for a block select (refer to Free 
Arc Properties or Free Line Properties).    

For Component, you can specify component type, reference designator, and value.    For example, you 
can include a specific component of a certain value, and the block select will include only those of that 
value (refer to Pattern Porperties).    Type, reference designator, and value support wild card characters:
? to match any single character, and * to match a sequence of zero or more characters.    For example, 
a RefDes value of U? matches all components with a two character RefDes string beginning with U.

Notice that Component, Global Attr, Pins,    the Visibility options appear in the dialog, but are 
disabled because they are not valid options for block selection.

For Copper Pour, you can specify Pour Pattern, line properties, and even the specific net to include in 
the selection criteria (refer to Copper Pour Properties).

For Pad, you can include Pad Number and Pad Style in the selection criteria (refer to Free Pad 
Properties).

For Plane, you can specify a net and and boundary width (refer to Plane Properties).

For Text, you can use the mask feature to search for a specific text string in your block select (refer to    
Free Text Properties).

For Via, you specify the via style to include in the block select    (refer to Via Properties).

Layers
The Layers area of the dialog allows you to select any combination of layers for the selection mask.    
When you choose a layer, it becomes "highlighted" or colored.    You can individually select or deselect 
layers by clicking on a succession of layer names and they will become part of (or be excluded from) 
the selection list.    

If you want to exclude only a small number of layers, click Set All (the default setting) and individually 
choose the layers to exclude.    To include only a limited number of layers, click Clear All, then 
individually choose the layers to include in your block selection.

This is a scenario for selecting and modifying all lines of a width of 12 mil and changing them to 15 mil.

1. Choose Options Block Selection to display the dialog.

3. Click Clear All to disable all of the items in the Items area (the X disappears from each box).    

4. Click the Line enable box until the check box becomes grayed.    The Line button then becomes 
ungrayed.

5. Click the Line button to display the Line Selection Mask dialog.    Enter 12 mil in the textbox.    
Click OK.

6. In the Layers area, click Set All to allow selection on all layers.

7. Do a block select of the complete design.    Only the 12 mil lines will be highlighted.



8. Choose Edit Modify.    Enter 15 mil in the textbox.    Click OK.

All 12 mil lines in the design will be converted to 15 mil.

Related Topics
For information about determining Styles, refer to the Options Pad Style, Options Text Style, and 
Options Via Style commands.

For more detailed instructions on the use of the Mask Selection dialog, refer to the respective Modify 
Object commands.    The Modify dialogs are identical in both format and function.

For information about block selection, refer to the Edit Select command.



Options Configure
When you select this command, the Options Configure dialog is displayed, where you can set the PCB 
editor parameters.

Units
You can alter your display units between mils and millimeters with this option.    Dimensions are not 
altered, only the unit of measurement of dimension.    A mil equals 0.001 inch or .0254 mm.    A mm 
equals 0.001 meter.

This setting will affect all dialogs, reports, Status line displays, etc. containing measurements.    For 
example, setting Units to mm causes all dialogs to display measurements in millimeters.    These units 
can be overridden in many command settings.

Workspace Size
You can set your workspace size to the specified dimension.    If you change units, then the values in 
this box will change to reflect the units (although the size will remain constant).    

Orthogonal Modes
Orthogonal modes are for use while routing (Route Manual) or placing lines (Place Line) using lines that
are horizontal, vertical, at 45-degree angles, or with arcs.    The available orthogonal modes are 
described below. 

90/90 Line-Line creates true 90 degree angles, long and short.
45/90 Line-Line creates 45/90 and 90/45 angles.
90/90 Arc-Line creates a combination straight line and arc, in long and short.

For placing lines, only the linear orthogonal modes are available (no arcs).

Refer to Route Manual for more details about the orthogonal modes.

ECOs
Engineering Change Orders are generated when you enable the recorder using the Utils Record ECOs 
command.    From the Options Configure dialog, you can select a format for these ECO files.    This 
format applies to the active design.    For more information, refer to the Utils commands section.

The ECO file is generated in a ECO format or a Was/Is format.    Click either the ECO Format or the 
Was/Is Format radio button to select a format.    

ECO format records full ECOs.    The Was/Is format records only    RefDes changes.

ACCEL Tango PCB supports only Was-Is ECO format.

Online DRC



An Enable Online DRC checkbox is included in a new Online DRC group box in the Options Configure 
dialog; checking this box enables Online DRC.    A View Report checkbox has also be added to the 
group box; if it is checked, then a report of violations created during routing is automatically presented 
after each connection is complete.    For new designs, both checkboxes default to disabled.

The Online DRC function checks for clearance violations or shorts of traces (both lines and arcs) and 
vias that are added to a design during manual routing.    Online DRC performs a check of the traces and
vias against all items, including copper pours, on signal layers to determine if a DRC violation occurred. 
A violation occurring on a non-signal layer (such as a via intersecting a silk layer item) is not detected 
with Online DRC.

When Online DRC is enabled, the following DRC checks are included: Netlist Violations, Clearance 
Violations, and Text Violations.    The following DRC options are not available with Online DRC: Netlist 
Compare, Unrouted Nets, Silk Screen Violations, Unconnected Pins, and Copper Pour Violations.    The 
following actions explicitly do not invoke online DRC checking: placement (other than during manual 
routing), moving, copying, and editing of signal or non-signal items.

Although you can enable or disable the Online DRC feature at any time, the feature defaults to disabled
when you create a new design.    The current Online DRC setting is saved to a design file and restored 
when a design is loaded.

A button for Online DRC is included on the toolbar.    When the button is depressed, Online DRC is 
enabled; otherwise, it is disabled. You can also enable and disable Online DRC from within macros.

Refer to Route Manual for more details about online DRCs.

Connection Options
The Optimize Partial Route checkbox is used to indicate whether the guide connection is to be 
optimized for Manhattan length after manual routing.    When enabled, pressing the slash key during 
manual routing terminates the route and causes the guide connection line to connect to the nearest net 
endpoint.    This optimization doesnt occur if the checkbox is not checked, or if the net being routed has 
an Optimize=no attribute.

The Optimize After Delete checkbox is used to indicate whether any connections added after a trace is
deleted should be added in an optimized manner.      If it is not necessary to add a connection to 
maintain connectivity, none will be added.    If a connection is necessary, and either the checkbox is not 
checked or the net has an Optimize = no attribute, the connection is added at the same location as the 
deleted trace.

Autopan
Allows you to adjust the amount of autopanning that will occur when you move the cursor to the edge of
the screen with the arrow keys.    An autopan of 25 will move anything at the edge of the screen 25% 
nearer to the center of the screen; 50 will move fringe objects to the center, etc.

AutoSave
Allows you to enable the AutoSave feature, which regularly saves your files at a user-defined interval.    
The design is only saved when you select a menu item or a toolbar item.    AutoSave wont be performed
during autorouting or if a tool is busy.

The following options are available:



Enable AutoSave:    Click this checkbox to turn on the AutoSave feature.
AutoSave Time Interval:    Enter the time between saves.    AutoSave uses a rolling backup to 

save files, incrementing each subsequent autosave file.
Purge Previous Backups:  When enabled, the option causes all backups saved from the 

previous design session to be deleted when you begin a new design session.
Number of Backup Files:    Allow you to specify the number of design files to be archived before 

file names are reused.    This must be a number between 1 and 99.    

Rotation Increment
The rotation value you set here will be activated when you select an object and use Shift+R to rotate it.   
Values must be between 0 and 360 degrees, with tenth degree resolution.

You can also use the R key to rotate a selected object by 90 degrees; R is not affected by what you 
specify in this dialog. 

Zoom Factor
Allows you to adjust the amount of zoom that will occur when View Zoom In or View Zoom Out is 
enabled.    A factor of 2.00 will double (or halve) the size of objects in the workspace, etc.    Zoom factors
must be greater than 1.00.

File Viewer
Allows you to define the viewer to be used for viewing reports, log files, error reports, etc.    Enter the 
application name (e.g. Notepad).    If the application is in a directory that is not included in your 
AUTOEXEC.BAT path statement, include the complete pathname here.

DDE Hotlinks
If checked, this option enables exchange of hotlink data with PCB Schematic.    Hotlink data consists of 
highlighting and unhighlighting commands for components and nets.    The state of the DDE Hotlinks 
option is saved in the PCB.INI file.

Solder Mask Swell
Allows you to set the solder mask swell value globally for all pads on the Top and Bottom solder mask 
layers.    You can override the global swell value by specifying a pad style for the Top Mask and Bottom 
Mask layers (Options Pad Style).

A Solder Mask Swell resists the solder mask on the mask layers, in effect allowing solder to be placed 
both on the pad and the swell around it.    The swell that is created will conform to the shape of the pad 
increasing the pad shape by the swell value.    The swell value is added to the pad as a radius, 
enlarging the pad shape in all directions; therefore, if you have a 60 mil diameter pad and add a swell of
10 mil, the total diameter of the swell would be 80 mils.    When you define a pad size for the Mask layer
(creating a local swell value), the global swell value is ignored.

You can view the increased size by making the Mask layer current, and then redrawing (View Redraw) 
to see the results.

Paste Mask Shrink



Allows you to set the paste mask shrink value globally for the Top and Bottom Paste layers.    You can 
override the global value with a local value by specifying a reduced pad size for the Top and Bottom 
Paste layers (Options Pad Style).

A Paste Mask Shrink reduces the size of the area that paste will be applied to when components are 
attached to the board in manufacturing (to prevent paste from squeezing out when it shouldn't).    The 
shrink is a radius value and should be figured as such when subtracting it from the diameter value of a 
pad.    For example, a 60 mil pad with a 10 mil shrink value will create a 40 mil diameter entity.    When 
you define a pad size on the Paste layer (creating a local shrink value), the global shrink value is 
ignored. 

You can view the reduced size by making the Top Paste layer current, and then redrawing (View 
Redraw) to see the results.

Plane Swell
Allows you to set the plane swell value.    This becomes the global plane swell setting.    You can 
override the global value by enabling and setting the Local Swell option in Options Pad Style.

A Plane Swell is the gap between the copper on the plane layer and the hole on a pad or via which is 
not connected to the plane.    A plane swell would not be applicable to pads or vias that are thermally or 
directly connected to the plane.

Auto Plow Copper Pours
When you enable the Auto Plow Copper Pours option, copper pours affected by new copper 
generated by the Manual Route or Interactive Route tool will autoplow when the route Completes or 
Suspends..    Plowing can create more islands if you splinter existing islands, yet Automatic Islands 
Removal is still performed using the settings you established for that copper pour.



Options Grids
Defines current editing grid.    The dialog contains numerous grid options you can choose from, and 
allows you to set up custom grid settings.    Grid settings are saved in your design file.

The units used are determined by the Units setting in Options Configuration.

Mode
You can specify Absolute when you want the grid origin point to be the lower-left corner of the 
workspace.    You can specify Relative to allow any point as an origin point.

A typical setting is to set your Absolute mode to 100 mil grid spacing, Relative to 25 mil grid spacing.    
In this way you can toggle the Grid button on the PCB Status line between 100 mil and 25 mil.    (The 
relative grid origin should be set to Absolute 0,0 for this to work)

Visible Grid Style
The Visible enable box allows you to either display or not display grids.    When you enable this option, 
the grid style options are available.    Dotted pinpoints grid points, while Hatched draws lines along the 
grids to show grid intersections (like graph paper).

Relative Grid Origin
You can specify your X and Y relative grid origins by entering the coordinates.    You must have the 
Prompt for Origin option disabled for it to work.    

If you switch to Relative grid in the dialog and the Prompt for Origin dialog is enabled, you will be 
prompted for the new origin point after you click OK.    You will be prompted every time you change from
Absolute to Relative Grids using the grid toggle button or the A key.

Grid Spacing: Uniform/Non-uniform
You can select appropriate values for grid spacing for specific modes in the Grids listbox.    You are not 
limited to using the grids in the listbox; you can specify your own custom grid spacing in the Grid 
Spacing textbox, then click Add to add it to available choices in the listbox.    To delete a grid-spacing 
value, highlight it in the Grids listbox and click Delete.

The routing grid defines the spacing pattern of the grid points. The grid pattern may be uniform (equal 
spaces between all lines) or it may be non-uniform to allow one or more lines to pass between 
component pads, while keeping the number of grid points to a minimum.

Uniform grids are generally used for relatively simple, low-density PC-boards.    Non-uniform grids are 
typically required on complex, high-density PC-boards to achieve completion of the connections in the 
minimum amount of time.

Uniform Grid Spacing



The main benefit of the non-uniform grid over the uniform grid is performance:    it produces far fewer grid 
positions without the loss of route paths.    Thus, completion time is shortened and more freedom in 
placement is allowed.    

For example, if you have 100 mils between grid points, you can set non-uniform grid spacing to 40-20-
40, which would allow two grid points between pads spaced 100 mils apart.

Non-uniform Grid Spacing



note:
Remember to set up your grids correctly before you place your components.    It is important that 
you place the components on the appropriate grids (e.g., standard DIP components on 100 mil 
absolute).    You can subsequently alter your grid spacing for routing purposes (such as non-
uniform as described above).

Grid Toggle:    Abs (or Rel) Button
You can easily toggle between absolute and relative grid settings with the grid toggle button or G key.    
The button appears as Abs for absolute grid spacing and Rel for relative grid spacing.    Your absolute 
and relative grids are determined by what you have set in the Options Grids dialog.    For example, if 
you have Relative set to 25 mils and Absolute set to 100 mils, the Status line will read 25 mil when you 
are in Relative grid and 100 mil when you are in Absolute grid.    

If you use the grid toggle button or the G key to switch to Relative, you will be prompted for the origin 
point if you have the Prompt for Origin option enabled in Options Grids.    The crosshair cursor (the 
cursor displayed when the system is awaiting input) is displayed; when you click in the workspace, that 
becomes the relative origin point (X=O, Y=O) and the cursor returns to normal.



Options Display
Defines color preferences, cursor style, and other display-items.    When you select Options Display, the
dialog is displayed, where you can set your colors.

Whatever colors you establish here will be saved in your .INI file.

Layer/Item Colors
This is a color matrix with objects across the top (columns) and layers along the side (rows).    You can 
specify everything on a layer to be of one color by clicking on a layer button (e.g., Bottom) to display the
color.    By the same process, you can make an object the same color on all layers by clicking an item 
button (e.g., Line).    Or you can make an object a specific color on a specific layer by clicking on the 
square where the object and the layer meet.    Any of these choices will display the Windows common 
Color dialog.    The scroll bars allow you to access up to 99 layers along the side.

Color Dialog (Windows Common)
Click on a layer/item button and the Windows common Color dialog is displayed, where you can choose
the color for the layer, object, or combination.    Simply click on one of the colored squares, click OK, 
and the color will be applied.    

note:
In the Color dialog, there is a Define Custom Colors button which displays another Color dialog 
for dithered colors.    These dithered colors are not currently supported in PCB; only the Basic 
Colors displayed in the squares are supported.    If you choose a dithered (non-solid) custom 
color, it is automatically mapped to the nearest basic solid color.

Display Colors
These buttons determine general PCB display colors, regardless of layer or item colors.    You must be 
careful that your display colors do not conflict with layer or item colors that you specify; for example, if 
you set background color to be the same as line color, your lines will not display.

Notice that there are two highlight colors.    Successive invocations of certain commands (e.g., View 
Nets) cycle through the two colors selected here.    If you do not want to use two highlight colors, set 
both colors to be the same.

These commands also display the Color dialog, where you can select your display color.

Misc... Button 
The Misc button brings up a dialog with numerous display options for you to enable or disable, as 
follows:

Glue Dots
The Show radio button globally enables the display of Glue Dot points, which are used to hold surface-
mount components in place until they are soldered during manufacturing.    The Hide radio button 
globally disables their display.    A glue dot can be part of a pattern in pattern creation.    Glue dots 



appear as free points in the reports unless they are saved as part of the pattern.

You must click OK in the main Options Display dialog for the enable/disable to take place.

 Pick and Place
The Show radio button globally enables the display of Pick and Place points.    Pick and place points 
provide reference points in directing the pick and place mechanism (or auto insert) in manufacturing 
(picking up the component and placing it on the board).    A pick and place point can be part of a pattern 
when you create it.    The Hide radio button globally disables the display of pick and place points.    Pick 
and place points appear as free points in the reports unless they are saved as part of the pattern.    

You must click OK in the main Options Display dialog for the enable/disable to take place.

DRC Errors
The Show radio button enables the display of DRC Errors in your design.    Design Rule Check error flags
contain information concerning design errors and the layer of the error (Utils DRC).    The Hide radio 
button disables the display of DRC errors Refer to Edit Modify, View DRC Errors command for information
on accessing DRC error information by way of an error flag.

Cursor Style
Allows you to change the shape of your cursor to arrow, small cross, or large cross.    The large cross
stretches horizontally and vertically to the edges of the PCB screen.

Miscellaneous Checkboxes
In this section of the dialog, you have the following options:

Drag by Outline

Allows you to drag objects around the screen more quickly by only displaying the bounding box of the 
objects that are being moved.    This only affects the move and copy operations of the Edit Select 
command.

Draft Mode

Displays a thin (single-pixel) outline of pads, vias, and text.

Displays segmented, outlined representations of arcs, lines, and any line segment objects (i.e., 
polygons, cutouts, etc.)    Draft Mode can help in faster redraws and also allows you to view any 
segment overlaps.    

Scroll Bars

Enables or disables the display of Windows scroll bars in the active window.



Display Pad Holes

Enables or disables the display of any pad holes in the active window..

Display Pin Designators

Enables or disables the display of the pin designator.    The pin designator appears just above the pad 
center (the top half of the pad).    You must be zoomed in sufficiently for the designators to be displayed.

Display Pad Net Names 

Enables or disables the display of the pad net names just below the pad centers (bottom half of the 
pad).    You must be zoomed in sufficiently for the net names to be visible.    

Display Plane Indicator

Enables or disables whether to indicate which plane the pad or via is attached to, by putting a cross 
over the pad or via    in the line color of the plane layer it is attached to.    If there are multiple planes 
associated with a pad or via, the indicator color will match the line color of a randomly selected attached
plane layer.

Translucent Drawing

This checkbox is used for selecting whether or not items are drawn in translucent mode.

Silkscreen in Background

This    checkbox is used for selecting whether the silk layers are drawn in the foreground or background.



Options Preferences
Defines keyboard, mouse, and toolbar preferences used to set up the application.

The Options Preferences dialog, which appears when you run the command, has three tab:

Keyboard Tab
Mouse Tab
Toolbar Tab



Keyboard Tab
The Keyboard tab, which appears when you access the dialog, lets you customize shortcut key 
assignments for menu commands, shortcut key commands, and macros.

Command Type:    Choose the type of command for which you want to change shortcut key 
assignments.

Menu Commands/Shortcut Commands/Macros:    Select the command or marcro you want to 
add a shortcut key assignment to or from which you want to remove a shortcut key assignment.

Current Keys:  Displays the existing key assignments for the command or macro you select in 
the Menu Commands/Shortcut Commands/Macros box.

Press a Shortcut Key: Press the keys you want to assign to the selected command or macro. 
You can press the CTRL or SHIFT key plus any other combination of numeric or alphabetic keys and 
function keys.

If the shortcut is currently assigned, the current assignment appears in the Current Binding field 
just below this box.

Assign:    Assigns the key appearing in the Press a Shortcut Key box to the selected command 
or macro.    If the shortcut is currently assigned, the current assignment disappears

Remove:    Removes the key you select in the Current Keys box.
Key File:    Allows you to select or create a key binding file to use with this application.    When the

Select Key File dialog appears, select the file you want to use.    The current key file appears at the top of 
the dialog, and is written to the application .INI file.

Default:    Restores original default shortcut key assignments to all commands or macros.



Mouse Tab
The Mouse tab lets you customize certain mouse behaviors.

Ctrl/Shift Behavior:    Allows you to choose which keys to use (Ctrl or Shift) for multiple 
(extended) selections and which to use for Sub Selections.

Cycle-Picking Threshold:    The number of pixels you can move the mouse during cycle-picking.
Double-Click Displays Properties:    When enabled, this option allows you to double-click an 

object to bring up the Properties dialog for that object.



Toolbar Tab
The Toolbar tab lets you choose the location of the Placement toolbar.

Horizontal:    The toolbar appears just below the Command toolbar.
Vertical Left Side:    The toolbar appears vertically along the left of the workspace.
Vertical Right Side:    The toolbar appears vertically along the right of the workspace.



Options Layers    
Allows you to view layers and make modifications to layer properties.

When you run the Options Layers command, the Options Layers dialog appears with the Layers tab 
selected.    This dialog has a Sets tab which is discussed below.

To learn more about a function, click on the appropriate topic from the following list:
Layer Sets
Layers
Line Color
Routing Bias
Type
Buttons

To add a layer, delete a layer or make a layer current, click on the following topic:
Adding a Layer



Layer Sets
Layers sets let you group layers to control the selection, display, and printing of your design, Gerber 
output and N/C Drill output, DXF output.

Current Layer
The Current Layer drop down listbox displays the name of the current layer for the selected layer set.    
You can change the current layer by selecting a different layer from the drop down list.

Layers
The Layers box displays a list of all layers in the design.

Set Name
The Set Name box allows you to add a layer set name.

Layer Sets
The Layer Sets box displays a list of all layer sets in the design.

Set Contents
The Set Contents box displays a list of all layers in the currently selected layer set.

Adding or Modifying a Layer Set
Follow these instructions:

1. To add a new layer set, type a new name in the Set Name box and press New.    The newly-
added layer set is empty.

2. To add a layer to the set, select the layer set from the Layer Sets box.    Select the layer to be 
added from the Layers box and click Add.

3. To remove a layer from a layer set, select the layer set from the Layer Sets box.    Select a layer 
from the Set Contents box and click Remove.

4. Click Enable Layers to save the layer set.

5. To delete a layer set, select it and click Delete.



Layers
The following layers areas are found in the Options Layers dialog:

Layers
In the Layers box are listed all existing layers of your design.    The letter codes between the layer 
name and layer number represent the following:

Type:    S = Signal, P = Plane, N = Non-Signal

E = Enabled, D = Disabled

Routing Bias: A = Auto, H = Horizontal, V = Vertical (signal layers only)

Layers can be moved up and down the list using the Move Up and Move Down buttons.

Layer Name
Shows the name of the currently selected layer.

Layer Number
Shows the number of the currently selected layer.

L key and Status Line
You can use the L key or the layer box on the status line (combo box and scroll arrows) as a shortcut for
selecting the current layer.    The current layer is identified by name and color on the Status line.    Use 
Shift+L to scroll backwards through the enabled layers.



Line Color
Shows the line color for the current layer.



Routing Bias
The routing bias of a signal layer indicates the preferred routing direction.    Layer bias is strictly adhered
to in certain passes (e.g., Memory) and loosely adhered to in others (e.g., Iterative).    The router 
recognizes the bias only as a guideline when placing lines.

Automatic Bias Selection
The directional bias for the layer is determined by ACCEL PRO Route.    If you set the Auto selector for 
the layer, ACCEL PRO Route automatically selects the directional bias for that layer.    The bias is 
calculated following a number of guidelines:

Typically, half of the layers are biased horizontally and half vertically, in an alternating pattern, 
adjacent to one another.

Pre-routed copper.    The program tries to conform to any pre-routed copper lines.
Bias selection.    If no pre-routes exist, layers are biased arbitrarily according to the following 

rules:
1. If there are an even number of layers, odd-numbered layers are horizontal and even-numbered 
layers are vertical.

2. If there are an odd number of layers, ACCEL PRO Route tests whether the PC-board's x-
dimension is greater than or less than the y-dimension.    If x is greater than y, odd-numbered 
layers are horizontal and even-numbered layers are vertical.    If x is less than y, odd-numbered 
layers are vertical and even-numbered layers are horizontal.

The default layer directionality can be overridden as necessary by manually enabling either the 
Horizontal or Vertical option.    

ACCEL PRO Route's automation with respect to layers is limited to selecting directionality, not the 
number of layers used.    If you enable four signal layers, ACCEL PRO Route uses all four while routing.

There is no algorithm applied during the manufacturing passes to specifically move lines to reduce the 
number of layers back to something less than what you set.    It is best to start the routing process with 
as few layers as possible, adding more layers only if the completion percentage is unacceptably low or 
the via count is unacceptably high.

Manual Bias Selection
To manually select the layer bias, enable desired signal layer(s), and the routing direction on each of 
those layers (Vertical or Horizontal).

Any of the layers may be horizontal or vertical, but the number of layers in either direction is typically 
balanced in pairs, e.g., two horizontal, two vertical; or three horizontal, three vertical.    Long, narrow 
boards make up one exception.    For these boards, more layers should be biased in the longer direction
to enable more paths for routing, from one end of the board to the other.

Another example of when you should select layer direction manually is when you want to follow the 
direction of the wave solder flow.    There are also certain other designs which would benefit from an 
uneven number of layers being run in either direction due to the type and placement of their 
components, but they are generally few and far between.



Type
These options are applied to a new layer (Add).    You cannot modify the Type of an existing layer.



Buttons
The Move Up and Move Down buttons allow you to arrange layers.    You can arrange the layers in 
your design to reflect the actual layer order of your board.    However, signal and plane layers must be 
between the Top and Bottom layers.

The Add button adds to the list whatever Layer Name you have specified, with the Layer Number, 
Routing Bias, and Type specified.

The Modify button allows you to change the routing bias on a signal layer and to change the net name 
of a plane layer.    To modify the routing bias, select a signal layer, choose a routing bias option and click
Modify.    To modify a plane layer net name, select a plane layer, click Modify and enter the new name in
the Plane Layer Net Name dialog.

You can rename a layer although you can't change the Type or layer number.    You can also reassign a 
plane net name.

The Delete button deletes the highlighted layer.    You can delete any user-defined layer that is empty.    
You cannot delete a predefined layer.      

note:
When you delete a plane layer, the ratsnest does not automatically return.    You need to re-
optimize to get the ratsnest back.    Also, when you delete a layer, components are processed and
stripped of any items that existed on the deleted layer; this is done without warning.

When you delete a layer that a pad/via styles hole range is dependent on, an error message 
appears explaining the dependency and which style you should correct.    You are not allowed to 
delete a layer until there are no styles that are dependent on it.

The Current button makes current any highlighted layer (The current layer indicated by an asterisk).

note:
The current layer cannot be disabled.    Also, items on disabled layers dont appear and can't be 
edited.

The Enable and Disable buttons respectively enable or disable whatever layer that you have 
highlighted.

Enable All / Disable All enables or disables all existing layers regardless of what is highlighted.



 
 Adding a Layer
When you add (create) a layer, you must give it a unique name, specify a layer number (one that is not 
already occupied), a routing bias, and a layer type.    When you create a plane layer, you must give it a 
net name.

1. In the Options Layers dialog, type the new layer name in the Layer Name text box and specify 
the Layer Number to enter the Add mode.    The Add button is grayed until you specify layer 
name and number.

2. If you are adding a signal layer, click on the Routing Bias you want to use (used only by the 
autorouter).

3. Click the layer Type you want.

4. Click Add.    The new layer will be listed in the listbox, with the layer type (S, P, or N), E for 
enabled, and the layer number you specified.

Once a layer has been created/added, you cannot change its layer number or type.

Signal/plane layers are placed just above the Bottom layer.    Non-signal layers are placed at the 
bottom of the list.

5. Use the Move Up and Move Down buttons to arrange the layers in the appropriate order.

6. If this is a plane layer, you are prompted for a net name.

ACCEL Tango PCB designs are restricted to a maximum of four user-defined layers and 15 total layers.    
Therefore, when using ACCEL Tango PCB, do not exceed this number when pasting components into 
your design.

Deleting a Layer
To delete or enable/disabl a layer, click the layer name in the list box (to highlight it) and click on the 
appropriate button at the right (e.g., Current, Delete, etc.).    

You can delete any added layer (you cannot delete a predefined layer).    Also, you cannot delete a layer
that contains objects; you must first delete all items from the layer.    To modify a layer, click the layer 
name, make the desired changes and click Modify.    

Making a Layer Current
To make a layer current, select it from the Current Layer drop down list box.

The Enable All and Disable All buttons enable and disable all layers on the board.    The Current layer 
cannot be disabled.



Options Current Line
Sets the current line width for the Place Line, Place Arc, Route Manual, and Route Interactive 
commands and for routed lines.    Whatever line width was set in PCB will be in effect for ACCEL PRO 
Route unless you change the value here.    A change made here is reflected in PCB commands.    The 
Options Current Line setting doesn't affect placing of line segments for polygons, copper pours, 
keepouts, connections, etc.

When the dialog appears, the Line Width editbox with the current line width value.    The current line 
width is highlighted in the listbox.    

To choose a new line width value, select a new value from the listbox.    

To add a new line width value, type the new value in the Line Width editbox and click Add.    The new 
value is inserted in the listbox before the highlighted value.    To add a new value and make it the current
value in one step, type the new value in the Line Width edit box and click OK.

To delete a value, highlight it in the listbox and click Delete.

Overriding Default Units
The units displayed as default in Options Current Line are determined by what is set using the PCB 
Options Configure command.    To switch units between millimeters and mils, use Options Configure.    
You can also override the default units by typing in an explicit suffix (e.g., mm) in the Options Current 
Line dialog.    As noted previously, you can also override the line defaults on a net-by-net basis with the 
Net Attrs command. 

To change the line width (thickness) of existing lines and arcs (routed lines and arcs as well), use the 
Edit Modify command.    



Options Current Keepout
Keepout allows you to designate certain areas of you design as off limits to certain processes, e.g., 
routing.    What is specified here is used by the Place Keepout command. 

Options Current Keepout allows you to set up the type (line or polygon) and layers (current or all) of 
keepout barriers you want to use with the Place Keepout command.    Line or Polygon are the choices 
for Style, and you can select either Current or All for Layers.    When you specify All, then you can 
place one object that applies to all signal and plane layers.    Current restricts keepouts to only certain 
layers (the current layer).



Options Design Rules
When you access the Design Rules dialog, it appears with the Global tab selected.

The Default tab shows global default clearance rules.

The clearance values of the layer you select appear in the Pad to Pad, Pad to Line, Line to Line, Pad 
to Via, Line to Via, and Via to Via boxes. If you have a variety of settings and you click on two layers 
that contain conflicting values, the box is blank.    The value you enter in the box is applied to the 
selected layer(s) when you click the Update button.    

Clearance Rules
When a clearance rule for a specific object is requested (e.g., DRC), the design rules category are 
searched in the following order of priority

Class to class rules. (highest priority)

Net rules.

Net class rules.

Global rules. (lowest priority)

Within each category, the clearance rules are searched in the following order of priority:

1. Object pair clearance rules (e.g., Pad to Line clearance).

2. Clearance rules.

The order of evaluation matches the order of evaluation used by the CCT SPECCTRA Router.    ACCEL 
PRO Route uses only global clearance rules.    

ACCEL DRC ignores CCT SPECCTRA Router clearance rules that have been added as attributes.    

Net Class Tab
The Net Class tab allows you to specify clearance rules for pads, vias, lines, and object pairs (such as 
pad to pad or line to via).    The dialog lists all net classes and the rules associated with each.

To edit a rules Properties, double-click the rule in the Rules listbox.

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.    (Refer to the 
Edit Nets command section for details.)

Net Tab
The Net tab you to specify clearance rules for a specific net in the design.    The dialog lists all nets and 
shows the rules associated with the net you select from the Nets listbox.    

To edit a rules Properties, double-click the rule in the Rules listbox.

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.    (Refer to the 
Edit Nets command section for details.)



Class to Class Tab
The Class to Class tab allows you to specify class to class clearance rules.    The dialog lists all class to 
class definitions and the rules associated with each.

To create a Class to Class definition , select nets classes from the two Net Class Name listboxes, and 
click Add Definition.    Once you have created a definition, it can be deleted using the Delete 
Definition button and modified using the Modify Definition button.

To edit a rules Properties, double-click the rule in the Rules listbox.

To add, delete or edit rules, click the Edit Rules button to access the Attributes dialog.    (Refer to the 
Edit Nets command section for details.)

Clicking the Design Rules button in the Utils DRC dialog or the Route Autorouters dialog also brings up 
the Options Design Rules dialog.



Options Pad Style
Sets current pad style (a.k.a., pad stack) for the Place Pad command.    You can add, delete, purge 
unused pad styles, and edit pad styles and set hole ranges using the series of dialogs available.

A pad style (or pad stack) is a collection of pad information concerning pad shape relative to layer, hole 
size, offset, etc.    A pad style can be simple, or it can be complex.

Select Options Pad Style to display the Options Pad Style dialog.

You cannot modify or delete the Default pad style.    When the Default pad style is selected,    the 
Modify buttons become View (Simple) and View (Complex).

To learn how to view the default pad style, click the following topic:
Viewing the Default Pad Style

To learn how to add a new pad style, click the following topic:
Adding a Pad Style    

To learn how to modify a simple pad style, click the following topic:
Modifying a Simple Pad Style

To learn how to modify a complex pad style, click the following topic:
Modifying a Complex Pad Style

To learn how to delete a pad style, click the following topic:
Deleting a Pad Style

To learn how to purge unused pad styles, click the following topic:

Purging Unused Pad Styles

To learn how to rename a pad style, click the following topic:
Renaming a Pad Style

To learn how to set a pad style hole range, click the following topic:
Setting a Pad Style Hole Range



Purging Unused Pad Styles
1. Click Purge Unused Styles.    

All unused pad style definitions are deleted from the current PCB design.



Viewing the Default Pad Style
1. Select Default from the list of pad styles.

2. Click View Simple or View Complex.  (View appears instead of Modify when Default is 
highlighted).    

The read-only View Default Pad Style dialog appears.



Simple Pad Style
A simple pad style must meet the following criteria:

Shapes can be defined only on the built-in Top, Bottom, (Signal), (NonSignal), and (Plane) layers. 
No other custom layer definitions are allowed.

The shapes and dimensions on the Top, Bottom, and (Signal) layers must either be identical (a 
uniform thru-pad), be defined on the Top layer only (a top surface pad), or be defined on the bottom layer 
only (a bottom surface pad).

To qualify as a simple, uniform thru-pad, the signal layer shape must be an ellipse, an oval, a 
rectangle, a rounded rectangle, a target, or a mounting hole.    If a signal layer shape is an ellipse, oval, 
rectangle, or rounded rectangle, the (Plane) shape must be a Direct Connect or a 45-degree, 4-spoke 
Thermal.

To qualify as a simple, top surface pad, the shapes must have zero width and zero height on the 
Bottom, (Signal), (NonSignal), and (Plane) layers.    The Top shape must be an ellipse, an oval, a 
rectangle, or a rounded rectangle.

To qualify as a simple, bottom surface pad, the shapes must have zero width and zero height on 
the Top, (Signal), (NonSignal), and (Plane) layers.    The Bottom shape must be an ellipse, an 
oval, a rectangle, or a rounded rectangle.
If there is a hole defined for the pad, the X and Y hole offsets must both be zero.



Complex Pad Style
Any pad style that does not meet all of the criteria to be a simple pad sytle is considered a complex 
pad style.



Adding a Pad Style
To add a pad style, click the Copy button.    The Copy Pad Style dialog appears.

Type the new pad name (e.g., mypad) and select a pad style to copy it from (e.g., *(Default)).    Click 
OK to return to the Options Pad Style dialog.    



Modifying a Simple Pad Style
To modify a simple pad style, select a simple pad style and click the Modify (Simple) button.    The 
Modify Pad Style (Simple) dialog appears.    The Modify (Simple) button is grayed if you select a 
complex pad style.

Use this dialog to set the width, height, hole diameter and shape, select a pad type.    For thru type pad 
styles, you can select either a thermal or direct plane connection.    You can also set the plane swell 
value; either enable the Use Global Swell option (set in Options Configure), to use the global plane 
swell setting in Options Configure, or disable it and specify a Local Swell option, overriding the global 
Options Configure setting.



Modifying a Complex Pad Style
To modify a complex pad style, select a complex pad style and click the Modify (Complex) button.    
The Modify Pad Style (Complex) dialog appears.

The values represented will default to mm (millimeters) or mil, depending on what you have set in 
Options Configure (your current units).    You can specify a measurement value (overriding Options 
Configure) by typing in mil, mm, cm, or in after the numeric value.

The Pad Definition area allows you to add a new pad definition to the Layers list, or to modify an 
existing pad definition for a layer.

The Hole and Plane Swell areas refer to all layers and are not affected by the Add, Modify, or Delete 
functions.

The Add, Modify, and Delete buttons in the Pad Definition area of the dialog work as follows:

1. To add a pad definition to the Layers listbox from the Layer combo box in the Pad Definition 
area:    highlight a layer name in the Layer combo box, set the diameter, spoke width, shape, then 
click Add.    The new layer is added to the list.

2. To modify a pad definition for one of the layers in the Layers listbox:    highlight a layer name in 
the listbox; then you can change pad shape (Shape options), and (in the case of thermal pads) 
define the dimensions for Outer Dia and Inner Dia and Spoke Width; then click Modify.

You can view the pad definition of a layer by clicking on the layer name in the listbox.    The pad 
definitions are listed by shape, width, and height in the Pad Definition area.

3. To delete a pad definition, highlight a layer in the listbox and click Delete (a reverse action to 
number 1 above).    If the layer is predefined (e.g., Top), it cannot be deleted.

To learn about the some of the standard pad shapes and thermal spoke pads, click the following
topic:

Standard Pad Shapes and Thermal Spoke Pads

To learn how to set the Plane Swell option, click the following topic:
Plane Swell Option



Standard Pad Shapes and Thermal Spoke Pads
The following shapes are supported:

Ellipse is a rounded shape with separately specifiable X and Y dimensions; an ellipse with equal 
X and Y dimensions is a circle (frequently called a round).

Oval is a short line segment with round end caps (half-circles), the radius of which is 1/2 the 
length of the shortest side; if the X and Y dimensions are equal, this too is circular or round.

Rounded Rectangle contains 1/4 circles on the corners of a rectangle.    The 1/4 circle radius is 
1/4 the length of the shortest side.

Rectangle shapes are X=width and Y=height.
If you want a round pad, you use the ellipse shape with identical height and width (the example 

above is an oblong ellipse).    If you want a square pad, use a rectangle with identical height and width.
Spoke width, and the inner and outer diameters, are specifications for thermals.    There are four 

thermal pad styles, which appear as follows.

thermal spoke pads

thermal diameters and spoke width

The Hole and Plane Swell areas apply to all layers of the pad and are not part of the Add/Modify/Delete 
function for pad definitions.    Specify the Hole dimensions and the X and Y offset.    X Off and Y Off are 
horizontal and vertical offset amounts of the hole in an aperture. 
You cant add a hole range for a pad style with a 0 inch hole diameter.

offset aperture hole



Plane Swell Option
With the Plane Swell options you can set the plane swell value; either enable the Use Global Swell 
option, to use the global plane swell setting in Options Configure, or disable it and specify a Local 
Swell option, overriding the global Options Configure setting.

Click OK and all of the changes or settings will be saved and applied.    All pads that currently use this 
style will be immediately updated.



Deleting a Pad Style
To delete a pad style:

1. Select a non-Default pad style name in the listbox.    

2. Click Delete.    

The pad style name disappears from the list.    

note:
You cannot delete the default pad style, and you can only delete a style if it is not currently used 
by a pad.



Renaming a Pad Style
1. Click the Rename button.    

The Rename Pad Style dialog appears:

2. Type a new pad style name in the New style name listbox.

3. Click OK.



Setting a Pad Style Hole Range
To set a pad style hole range, click Modify Hole Range.    The Options Modify Pad Hole Range dialog 
appears.    

This dialog allows you to set up the hole ranges for pads.    Only those styles with a hole diameter is 
greater than zero appear.

The Hole Range Layers list box reflects the layer ordering of your board as you established in the 
Options Layers dialog.

To set a hole range:

1. Select a pad from the Styles list.

2. Select the begining and ending layers for the hole range.

3. Select another pad and repeat the process.

4. Upon completion, click OK. 



Options Via Style
Sets current via style for the Place Via command.    You can add, delete, rename or edit via styles by 
using the series of available dialog.

Select Options Via Style to display the dialog.    Note that Quick Route allows only simple pad styples.

note:
Via styles are almost identical to pad styles in the way that you add, edit, modify, view, delete, and
rename them in PCB.    Refer to Options Pad Style for all the details about via styles.

The only difference between pads and vias is that vias don't support Mounting Hole and Target shapes.

See also:
Options Pad Style



Options Text Style
Sets current text style for the Place Text command and allows you to add, delete, rename, or edit text 
styles by using the series of available dialogs.    The text styles you create or edit here are available 
when you enable the Place Text command, or when you want to modify already placed text with the Edit
Properties command.

The Default style can't be deleted, renamed, or modified.    The other three default styles can be 
modified, but not deleted or renamed.    

Choose Options Text Style to display the Options Text Style dialog.    

Adding Text Style
To add a text style, click Add and the Add Text Style dialog appears.    

1. Select the style of text you want to base the new style on.

2. Specify the text style name you are adding (e.g., busstyle).    

3. Click OK and the Text Style Properties dialog appears.

Text Style Properties
Remember, you cannot change the properties of Default text style; you can only query it.

To query and edit text style properties:

1. Highlight the text style.    

2. Click Properties and the Text Style Properties dialog appears (shown below).

3. From this dialog,    you can modify the Height, Thickness, and Font fields for non-default fonts    

Renaming Text Style
To rename a text style:

1. Highlight the non-default text style you want to rename. 

2. Click Rename.    The Rename Style dialog appears.

3. The new text style appears in the listbox.    

4. Specify the new name by typing over the existing name.

5. Click OK.

Deleting Text Style
To delete a text style:

1. Highlight the non-default text style you want to delete. 

2. Click Delete.

A message appears asking you to confirm your deletion.



3. Click Yes, and the highlighted text style disappears from the list.    

note:
You cannot delete default text styles or a text style that is currently in use.

Text Style Properties Dialog
The Text Style Properties dialog appears when you click the OK button in the Options Add Text Style 
dialog or the Properties button in the Options Text Style dialog.

This dialog lets you add and modify font properties of the selected (non-default) text style.

The values represented appear as mm (millimeters) or mil, depending on what you have set in Options 
Configure (your current units).    You can specify a measurement value (overriding Options Configure) 
by typing in mil, mm, cm or in after the numeric value.

You can set the following stroke font properties.    

Height:    The fonts height.
Thickness:  The text thickness..    
Font:    Choose between QUALITY, BASIC, or LCOM fonts.    QUALITY and BASIC fonts are 

interchangeable.    Basic is simpler and therefore draws faster.    LCOM is a serif font (a little fancier).

Font Examples

When you click OK, the new (or modified) text style is available for assignment.



Library Commands



Library New
Allows you to create a new library.    The new library is empty; it has no components, patterns, or 
symbols.

When you choose Library New, the Library New dialog is displayed, which is a Windows common dialog
(File New).    In the dialog, you can specify the filename of your new library.



Library Alias
An alias is an alternate name for an item (component or pattern).    You can create multiple equivalent 
names for the same item with this command.

When you create aliases for an item, it is not the same as creating copies or renaming.    For copying or 
renaming, see the respective Library commands.

Aliases allow you flexibility in using a variety of naming conventions for components or patterns, without
renaming them.    For example, what PCB calls an SN7400N, you may want to use a generic alias of 
7400.    Or, if you are using components from a vendor using a particular naming convention, and you 
want to continue using that system, you can use alias names and display them on your design as such.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename will remain 
current if you re-invoke any of the commands during the same PCB session.

Create an Alias
1. Choose Library Alias to display the Library Alias dialog.    

2. If the appropriate library is not current, then click the Library... button and the Library Select dialog
is displayed. 

The Library Select dialog is a Windows common dialog (File Open).

Set up the library you want, click OK, and the Alias dialog is redisplayed.

3. Specify the Alias Item (Component or Pattern radio button).    The Symbol radio button is 
grayed in PCB.

4. Click the item button (e.g., Pattern... or Component...) to display the Library Browse dialog.    
Highlight the item you want from the list and click OK. 

5. You have now returned to the first dialog.    Enter the new alias for the item in the New Alias edit 
box, and click Add to append it to the Aliases list.    Click Close when finished.

note:
If you click Close before Add, then the dialog will close without completing the add alias action.



Library Copy
Copies an item from one file to another (either in the same or in a different library).    If you want to copy 
a component with its associated Schematic symbols, use the Library Copy command in the Library 
Manager.    PCB cannot mange symbol data.

It's important to note that a library part consists of a component section (type, reference designator, 
etc.), a pattern section (the PCB graphics), and a symbol section (the Schematic graphics).    Generally, 
you will need to copy the component and its pattern when copying between different libraries (notice 
that the Copy Item section of the dialog has a choice between Pattern and Component).    When you 
copy a component, you will be prompted as to whether you want to include its associated pattern; you 
would normally respond Yes.    When you copy a pattern, no components will be included in the copy.

The dialog allows you to select source library and item name as well as destination library and item 
name.

The source library and destination library that are used with Rename will remain current if you re-invoke
the command during the same PCB session.

If you are copying a component or pattern but are not changing its name, you can leave the 
Destination Name box blank.

 Copy a Pattern or Component
1. Select the Library Copy command to open the dialog.

2. Select the Copy Item (Component or Pattern radio button) for your copy action.    The Symbol 
radio button is grayed in PCB.    If you are copying a component, make sure you also copy its 
pattern (if desirable) when copying from one library to another.

3. Click the Source Library button.    The Library Select dialog is displayed, from which you can 
select the source library of your copy action.    

The Library Select dialog is a Windows common File Open dialog.

After you choose the library from Library Select, the source library name is displayed in the 
Library Copy dialog.

4. Click the item button (Pattern or Component) and a list of items in the library are displayed in the
Library Browse dialog.    Select the item you want to copy, and the item name will be displayed in 
the Library Copy dialog.

5. Click the Destination Library button.    The Library Select dialog is displayed, from which you can
select the destination library of your copy action.    The library name is displayed in the Library 
Copy dialog.

6. Specify the Destination Name for the new item.    If you want to use the same name, you can 
leave the textbox blank.

7. Click the Copy button and all the boxes (except the Source library path and the Destination 
library path) become blank.    This way you can continue to copy items between the same source 
and destination libraries.

8. Press Close to exit the dialog.    

note:
If you click Close before Copy, then the box will close without completing the copy action. 



Library Delete
Deletes a library item.    

This command deletes the item in name only, if it has aliases.    The alternate names (aliases) still exist 
unless you delete them.    If the item has only one name and you delete it, then the item itself is deleted 
from the library.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename will remain 
current if you re-invoke any of the commands during the same PCB session.

warning:
If you delete a pattern, then all of the components in the library that reference that pattern will be 
without structure, and would therefore be unplaceable.    Normally you would want to delete a 
pattern alias only, which is not dangerous.

To Delete from a Library
1. Choose Library Delete to display the dialog.

2. Select the Delete Item type (Component or Pattern radio button) for your delete action.    The 
Symbol radio button is grayed in PCB.

3. Click the Library button.    The Library Select dialog is displayed, where you can select the library 
from which you want to delete an item.    

The Library Select dialog is the standard Windows File Open dialog in both form and function.

The library you selected in Library Select is displayed in the Library Delete dialog.    

4. Click the item button (Patterns... or Components...) and the items within the displayed library will
be listed in the Library Browse dialog.    Select one and it will then be listed in the Library Delete 
dialog.

5. Click the Delete button and the item box becomes blank.    This way you can continue to delete 
items from the same library.

6. Click Close to exit the dialog.    

note:
If you click Close before Delete, then the box will close without completing the delete action. 



Library Rename
Renames a pattern or a component.

The library that you use in the execution of Library Alias, Library Delete, or Library Rename will remain 
current if you re-invoke any of the commands during the same PCB session.

warning:
If you rename a pattern, then all of the components in the library that reference that pattern by the
original name will have no pattern reference, and will therefore be unplaceable.    If you want to 
use a different naming convention for a pattern, then create an alias for the pattern (Library Alias 
command) and use that alias name.    Likewise for components:    if you want to use a different 
naming convention, using aliases is much safer than renaming.

To Rename a Library Item
1. Select the Library Rename command to display the dialog.

2. First select the Rename Item type (Component or Pattern radio button).    The Symbol radio 
button is grayed in PCB.

3. Click the Library button to display the Library Select dialog, where you can choose the library to 
access. 

The Library Select dialog is Windows File Open common dialog.    The library you select in Library
Select is displayed in the Library Rename dialog.

4. Click the item button (Pattern... or Component...) and the items within the displayed library will 
be listed in the Library Browse dialog.    Select one and it will then be listed in the Library Rename
dialog.

5. In the New Name section type the new name of your item, then click Rename.    Both the old 
name and new name disappear if the rename action is successful.    Then you can continue 
renaming items in the same library.

6. Click Close to exit the dialog.    

note:
If you click Close before Rename, then the box will close without completing the rename action. 



Library Setup
Opens libraries from which you can access components.    The libraries that you open in Library Setup 
will then be available for the following functions:

The Place Component and Utils Load Netlist commands use the open library list to place components.   

The Library Pattern Save As command saves patterns to the open library list.

When you want to place a component, the library file where the component resides must be open. 

To Setup a Library
1. Run the Library Setup command to display the dialog.

The dialog will list any libraries that are already open in the Open Libraries listbox.

2. To add another library to the list, click Add to display the Library File Listing dialog, which is the 
Windows File Open common dialog.    From there you can access the library directory to select a 
library file.

When you select a file from the Library File Listing (and click OK), that filename appears in the 
Open Libraries listbox in the Library Setup dialog.    

3. To remove a library from the list, select the library name from the Open Libraries listbox and click
Delete.

4. Click OK and the libraries that you have specified are now open and accessible for component 
placement or saving patterns.

When you create a pattern or a component, you will need to have a library to save it to.    The list of 
open libraries is saved to the PCB.INI file and therefore saved for subsequent PCB sessions.



Library Pattern Save As
Saves a pattern to a library. 

This command allows you to group a selected collection of objects as a pattern, and save the pattern to 
a library.    From the library you can later attach the pattern to a component.    You must have a library 
already open to save a pattern to it (use the Library Setup command to list and open component 
libraries).

To Save a Pattern
1. Use the block select function (Edit Select, draw a selecting rectangle) to include all objects you 

want to be included in your pattern.

2. While the objects are highlighted, choose Library Pattern Save to display the dialog.

3. Choose a library (highlight it) that you want to save the pattern to, then specify a pattern name.    
If you want to just create a pattern (not a component), click OK.

4. To automatically create a component that corresponds to the pattern, enable the Create 
Component option before you click OK.

An auto-created component has pin designators which match the pin numbers, and the pin 
names are blank.    Give the component a new name when in the Save Component As dialog; 
otherwise the component will be named the same as the pattern name.    

note:
The Create Component option should be used only for components where pin numbers and pin 
designators can numerically match, as in DIP components.    A CAP component does not have 
numerically matching pin designators and pin numbers, and therefore cannot be created correctly
with this option.

If the box is left unchecked, the pattern is created without a component; to create a component 
from this pattern otherwise, you would use the Library Manager to build the component and 
attach this pattern to it.



Utils Commands



Utils Renumber
Renumber is a triple-function command for assigning pad numbers to free pads, and assigning 
reference designators to components manually or automatically.

For components, you can also specify designator templates (e.g., U) and increment values (e.g., 1) for 
reference designators (U1, U2, etc.).

Renumber Reference Designators
1. Select Renumber to display the Renumber dialog.

2. Enable RefDes and the rest of the choices in the dialog will be displayed accordingly (for Ref 
Des), such as the Starting RefDes (e.g., U1) and Increment Value (e.g., 1).    You also have the 
option of Manual or Auto, Top to Bottom or Left to Right.

3. If you enable the Manual option, you are in a temporary mode of assigning numbers, so every 
left-button click on a component for Manual renumbering will increment the value next to the 
designator.    Notice that the Top to Bottom and Left to Right options are unavailable.

You can enter the starting value in the Starting Ref Des box.    For example, if you entered the 
value U100 in the Starting Ref Des textbox, then specify the Increment Value as 10, the first 
component you click on would be designated U100, the next one U110, then U120, etc.    If you 
started at U000 and incremented by 1, the first would be U000, the second U001, etc.

Click the right-button or press Esc to end the temporary mode of Utils Renumber.

4. For the Auto option, you must have multiple components selected before you use this command 
(Auto is grayed if you don't).    After you click OK, the reference designators will automatically 
increment according to your specification.    Only the selected components will be renumbered.    
For example, you have selected three components positioned horizontally that are numbered U1 
through U3, you renumber them with the Increment Value of 2, automatically (Auto) and enabled
Top to Bottom.    When you click OK, they will renumber U1, U3, and U5, in row order.

Renumber Pads
1. Select Renumber to display the Renumber dialog.    

2. Enable Pad Num; the rest of the choices in the dialog will change accordingly.    Then specify 
Starting Number, and Increment Value, as appropriate.    Manual is the only choice for pad 
numbering; Auto is grayed out. 

3. You are in a temporary mode of assigning numbers, so every left-button click on a pad will 
number a pad. 

For example, the first pad you click on would be number 1 (if Start Value was specified as 1), the 
second pad number 2 (if the Increment Value was specified as 1).    As you click on a pad while 
in the Renumber mode, it highlights to show that a number has been assigned.

The Status line information area displays the pad number every time you (re)number a pad.

You can use the unwind feature to reverse the renumbering process.    The backspace key    will 
unwind the renumbering.

4. Click the right-button or press Esc to end the Renumber temporary mode.

note:
The renumber feature is sensitive to layers when renumbering pads.    You must be on the 
appropriate layer for the pad to renumber it.    For example, the current layer must be Top for a top



SMT pad.



Utils Force Update
This command replaces all components of a given type with the first component of that type in an open 
library.    When you run the Utils Force Update command, the Utils Force Update dialog appears.    

Use the Force Update command if you encounter a component cache error after using the Library 
Manager to change a component that is already placed in a PCB design.    You must update all 
occurrences of that component in the design.    This must be done before you can place any more 
instances of that component.

Select a component, or use the Set All button to select all components and press the Update button.    
The command looks in all open libraries in the order they are listed in the Library Setup list for the 
replacement components.

The Maintain Rotation option allows you to maintain of rotation of any rotated components.    It does 
not maintain rotations for components in designs loaded from Tango Series II.

Updating a component copies all the components attributes to all of the patterns representing that 
component.



Utils Record ECOs
The Utils Record ECOs dialog allows you to record Engineering Change Orders (ECO).    Select the 
ECO Recorder radio buttons to enable or disable the ECO recorder.    

If there are pending ECOs, you are prompted when a design is saved on whether to append the 
pending ECO to the current ECO file.    

This function can also be activated using the ECO icon on the Toolbar.    When this function is activated 
(either from the Toolbar or the Record ECOs dialog), the Toolbar icon is depressed.

Types of ECOs
The following types of ECOs can be recorded:

RefDes change (Was-Is).
Net name changes.
Additions, deletions, and modifications of components and parts.
Additions and deletions of nets.
Additions and deletions of net nodes.
Additions, deletions, and modifications of attributes.

The format of the ECO file is determined by the setting in the Options Configure dialog.    Full PCB ECO
files have an .ECO extension, and Was/Is ECO files have a .WAS extension.



Utils Import ECOs
Imports an ECO file and applies the ECO changes to the current design file.    The ECO file is created in
PCB Schematic to capture schematic changes that impact your design.    When you run this command 
the Utils Import dialog appears.

ECO Filename
1. Click the ECO Filename button to open the ECO Filename dialog.

2. The ECO Filename dialog is a standard File Open dialog.    Type, or select from the list, the name 
of the file you want to open in the File Name box.    Click OK.

.ECO files are assumed to be full PCB format; .WAS files are assumed to be Was/Is format.

Preview ECOs
When you select an ECO filename and then click the Preview ECOs button, you can view ECOs, if 
there are any, before importing them.    The ECOs are displayed in Windows Notepad.



Utils Export ECOs
Allows you to save ECOs to the ECO file at any time, without saving the design file.    If there are 
pending ECOs, the Utils Export ECOs dialog appears when you run this command.

View Pending ECOs
When you click the View Pending ECOs button, you can view pending (outgoing) ECOs which are still 
stored in memory.    The pending ECO data are written to a temporary ASCII file and displayed in 
Windows Notepad.    The format displayed is either full or Was/Is, depending on the setting in the 
Options Configure dialog.

Save ECOs Now
1. To save pending ECOs, click the Save ECOs Now button.    A warning message appears.

It is recommended that you save ECOs at the same time you save your design using the File 
Save command.    If you save ECOs without saving the design, your file and the ECOs may not 
match.    That is, the ECOs might not reflect the current state of the design.

2. To continue, click Yes.    

The Save ECOs dialog appears.

3. The ECO filename appears at the top of the dialog.    It is the last used ECO file.    To change it, 
click the ECO Filename button and the ECO Filename dialog appears.

4. The ECO Filename dialog is a standard File Open dialog.    Type, or select from the list, the name 
of the file you want to open in the File Name box.    Click OK to return to the Save ECOs dialog.    

Full ECO files must have a .ECO extension, and Was/Is files must have a .WAS extension.

5. In the Comments box, type any comments that can help document the ECOs.

6. To append ECOs to the ECO file, click the Append ECOs to File button.

7. To discard ECOs, click the Discard ECOs button.    Once discarded they cannot be recovered.



Utils DRC
Allows you to set up Design Rule Checking.    This process makes sure that all electrical connections in 
the design layout match the connections in the netlist; the program also checks to see if minimum 
clearances have been maintained throughout the design.

DRC uses the precedence rule order to determine the proper minimum clearance rule between two 
design objects.    (See Options Net Classes for details.)    The DRC report includes a list of the net class 
clearance rules.

Select the Utils DRC command to display the following dialog.

To learn how to select a report file for saving DRC information, click the following topic:
Saving DRC Information

To learn about the various DRC report options, click the following topic:
DRC Report Options

To learn about the View Report and Annotate Errors options, click the following topic:
View Report and Annotate Errors

To learn how to specify DRC clearance options, click the following topic:
DRC Clearance Options



Saving DRC Information
Click the Filename button to display the Design Rule Check Report dialog (a Windows common File 
Save As dialog).    From this dialog you choose a DRC report file to which you can save the report 
information.



DRC Report Options
When enabled, these options will be included on the DRC report.

Netlist Compare compares a Tango format netlist file with the current nets in the design.

Netlist Violations enables electrical checking against the netlist within the design.    Items are 
considered to be physically conntected if they overlap or have a clearance of 0 mil.    Items that can be 
physically conntected to one another are arcs, polygons, pads, lines and vias.    Copper Pour is not 
subject to Design Rule Checking because it has its own checking feature.    Note that although text can 
be checked for clearance violations, it is not considered to carry current.    If there are no nets in the 
design, this option is ignored.

Unrouted Nets enables reporting of any nets that are currently unrouted (unrouted connections still 
exist in the design).    The report includes a warning for those objects that are not point to point routed.    
The warning includes the location of the objects

Clearance Violations enables air-gap clearance checking.    If disabled, no clearance errors will be 
reported.

Text Violations enables air-gap clearance checking of text on the signal layers.    If you have placed 
text on the signal layers, you should enable this option to make sure that the text does not short to other
copper.    When checking for clearance violations, the bounding rectangle of the text is used.    

Silkscreen Violations enables checking on pad/via to silkscreen violations.    Silkscreen on pads on top
layer can interfere with soldering process; on vias it can cause paint dripping or collecting in unwanted 
areas.

Unconnected Pins enables the reporting of all pins that are not connected to other pins.    This includes
all of the single-node routes as well as pins that are not connected to anything at all.

Copper Pour Violations enables reporting of unflooded copper pour entities, copper pours that are not
part of a net, copper pour island clearance violations, unconnected islands, and thermal connections 
that have clearance violations.    

Only pour outlines are reported.    Thus if there is via that shorts in the middle of a pour, it is not 
reported.

Drilling Violations enables connectivity checking of pads/vias through their attached layers, utilizing 
the layer ordering and hole range for determining where the pad/vias begin and end. 

Also enables checking for layer separation, interference between holes, collocated holes, and vias 
existing solely on a signal layer.

Plane Violations enables reporting of overlapping planes, invalid pad and via copper connections, 
connected pad and vias that are not electrically connected to the plane, isolated areas of copper in a 
plane.    



View Report and Annotate Errors
View Report
The View Report checkbox enables the screen display of the DRC report file when the DRC is 
complete.

Annotate Errors
The Annotate Errors checkbox enables the creation of DRC error indicators, which will be displayed 
on your design.    These indicators can then be selected for viewing of error information.    The error 
information is determined by the other error/violation options that you enable in design rule checking.    

To view the error associated with an error indicator, select it and run Edit Modify.    Their display is 
controlled by the Options Display (Misc) command; the selection criteria for DRC error indicators (for 
block selecting) is determined by the Options Block Selection command.    Refer to the respective 
command sections for further information.

The DRC error indicators can be output to a report, which lists all of the locations and the errors that 
they are indicating.

When you are finished setting up the DRC options, click OK to begin the design rule checking process.  
Error indicators are cleared when you run Utils DRC.



DRC Clearance Options
You can specify the rules for the design check in the DRC Clearances dialog.    Click the Clearances 
button to display the Options Clearance dialog.

The dialog lists the enabled layers of the currently loaded design file.    The default clearances of 12 mil 
(.3 mm) are shown for each layer and between each item.

Set All will select (highlight) all layer names with items in the Layers listbox.    Clear All deselects them 
all.    You can select or deselect one or more layer names with items by clicking on them individually in 
the listbox.    

The clearance values of whatever you select appear in the Pad to Pad, Pad to Line, Line to Line, Pad
to Via, Line to Via, and Via to Via boxes. If you have a variety of settings and you click on two layers 
that contain conflicting values, the box will be blank.    Whatever value you enter in the box will be 
applied to the selected layer(s) when you click the Update button.    Nets with clearance attributes 
defined will override the global default clearance values for DRC.    The report produced by the DRC 
includes clearances specified for specific nets.

Click Set Defaults to return all layer/item settings to 12 mil clearances.

Hole to Hole Clearance is a design-wide clearance setting (rather than layer specific for the other 
clearances).    If you change it, the value will apply when you click OK .

Click OK when you have finished setting up the design rules (and return to the main DRC dialog).    
From the main dialog, click OK    to begin the design rule checking process.



Utils Load Netlist
Loads a netlist from a .NET file into your design.    If you have a board outline created, the components 
will be placed directly above the board outline.    If there is no board outline, the components will be 
placed into the lower-left corner of the workspace.

Load a Netlist
1. Choose Load Netlist, a dialog is displayed.

2. To choose a netlist file, click the Netlist Filename button.    This will display the Netlist File dialog, 
which is a Windows common File Open dialog.

3. Use the Netlist Format field and combo box to select the correct source file format for the netlist 
file so that the PCB file filter can read the format.

Your choices are Tango format and ACCEL ASCII format.    Tango format is the standard Tango 
format.    ACCEL ASCII format includes attributes attached to each net and component in the 
netlist.

4. If you select ACCEL ASCII, four options for attribute handling are available: attributes may be 
merged with current design attributes, favoring either the netlist or the design attribute if the 
attribute exists in both; attributes may be ignored; or all design attributes may be removed and 
replaced with those present in the netlist.

5. When you select a file from the Netlist File dialog, you will return to the Netlist File Load dialog, 
where the filename will appear.    Click OK and the netlist from the file will load onto your design.    

Loading a Netlist on an Existing Board
You can load a netlist onto an existing board (which already has items), with the following rules and 
results:

Components with matching RefDes must also have matching Types.    If there is any conflict with 
the component section of the netlist, the load is aborted.

Any existing components on the board that are not part of the netlist will be preserved.
Any components in the netlist being loaded that are new to the design will be added.
For components that include, pads and text that are of styles that have the same names but 

different data than those styles in the current design, the incoming style names will be bracketed to 
indicate the style conflict.    The new (bracketed) style names will be added to the list of available styles in 
the current design.    Refer to the Edit Modify, Options Pad Style, and Options Text Style commands for 
object style information.

The net information and connections of the existing design will be replaced by the new net 
information.

If you enable the Reconnect Copper checkbox, an analysis done by the program may find nets 
that are shorted.    Shorted nets are listed in the error log file.

When a new net is found to be open, a connection will be created.    When extra connections, or 
misconnections, are found, a warning message is displayed.

In the event that old copper and new nets match, no connection lines will appear because the 
nets are already routed.

Optimize Nets
The Optimize Nets checkbox can be used to inhibit the automatic optimization of the ratsnest 
connections.    If optimization is disabled, the connections are made in the order given in the netlist.    
Disabling this option also speeds up the netlist load process since the time-consuming optimization 



phase is skipped.    Once the netlist is loaded, you can run the Utils Optimize Nets command at any 
time.

Reconnect Copper
The Reconnect Copper checkbox can be used to inhibit the automatic "reconnect" of existing copper 
on the board.    If reconnect is disabled, the net connections match the netlist exactly, and all existing 
copper on the board is converted to "free" (non-intelligent) copper.    Free copper isn't associated with 
any net.    If there is existing copper on the board, and the reconnect option is enabled, the reconnect 
phase can take a long time.    Therefore, we recommend that you only disable the reconnect option if 
you want to quickly load a netlist into a board with existing copper, and you are willing to accept having 
free copper.

When the Reconnect Copper checkbox is enabled, Utils Load Netlist generates PCB connections 
between those objects that are physically connected but not point-to-point routed.

warning:
If you disable reconnect, it is possible that existing free copper on the board will short one or 
more nets together.    This can only be detected by running the Utils DRC command.    

After you have loaded the netlist, you can select the components and connections either as a group (a 
block select) or individually (single select) to move them into their appropriate positions in the design.    

Check for Copper Sharing
If the Check for Copper Sharing option is enabled, line to line trace intersections and line traces 
crossing the center of a pad or via are detected.    Intersecting line traces are split at the point of 
intersection and lines are split at pad or via centers, creating point-to-point routes.



Utils Generate Netlist
Creates a netlist from the combination of connections you have established (or loaded) in a design file.   

Free copper (non-net connections) will not generate a netlist.    Free pads which are a valid part of a net 
are not listed as net nodes in the netlist.

Generate a Netlist
1. With your design file open, choose the Generate Netlist command to open the dialog.

2. To choose a netlist file, click the Netlist Filename button.    This will display the Netlist File dialog, 
which is a standard Windows File Open dialog.

3. If you want to generate your netlist to a different format, use the Netlist Format textbox and 
combo box to specify the destination format.

Your choices are Tango format and ACCEL ASCII format.    Tango format is the standard Tango 
format.    ACCEL ASCII format includes attributes attached to each net and component in the 
netlist.

4. Enable the Include Library Information checkbox if you want an optional library section to be 
written to the netlist.

Library information is read by PCB but not processed; it is merely informational.    

5. Click OK in the Netlist Generate dialog and the netlist will be created with the filename and netlist 
format you have specified.



Utils Compare Netlist 
Allows you to compare the current nets of the design you have in memory with the netlist file that you 
specify.    This useful feature verifies the integrity of your design against the original netlist.    For 
example, if you mistakenly deleted a component or net, this command will show you the discrepancy.    
This command compares logical net information, i.e., it works even if there are open (unrouted) nets.    
Use the Utils DRC command to check existing copper.

Compare a Netlist
1. Choose Utils Compare Netlist to display the dialog.

2. Click the Netlist Filename button to display the Netlist File dialog (a File Open common dialog).    
From here you can access the netlist filename of the original netlist which you loaded into your 
design file.    

Also choose a Netlist Format which matches the format of the netlist file.

3. Click OK and any discrepancies will be displayed on the screen.



Utils Optimize Nets
Pin and gate swapping allows you to re-arrange connections logically in order to produce shortened or 
more direct routings, or dispersed routings to ease congestion in certain areas.    This function is 
performed using the Utils Optimize Nets command.

Generally, you apply a gate or pin swap on logical connections created as a result of placing 
components in PCB.    You can convey gate and pin swaps, which result in net list modifications, back to
PCB Schematic from PCB with the ECO utility.    (See the Utils ECO command sections in the PCB 
reference manual.)    

Rules for Pin Swapping
The rules for pin swapping are:

1. Pin swapping occurs within a gate between logically equivalent pins.    The equivalence values 
must be non-zero and identical for a swap to occur between two pins.    Swapping is allowed 
between non-equivalent pins, but only after you give confirmation (a forced swap).    Forced 
swaps can occur only during a manual pin swap; they do not occur during automatic pin 
swapping.

2. No swapping occurs if net copper is connected to either pad.

3. Swapping does not occur if a net connected to the pin has the OPTIMIZE attribute set with a 
value of "NO".

4. Swapping does not occur if the component has the NOSWAP attribute set to Yes.

Rules for Gate Swapping
The rules for gate swapping are:

1. The gates must be logically equivalent.

2. The gates must be of the same component type with equivalent value if swapping across 
components.    The component values must be the same so that gate swapping with discrete 
parts works correctly.    (For example, a gate swap between two RES components, one with a 
value of 50 ohm and the other 100 ohm, isn't allowed).

3. The swapping of gates between components can be further restricted by use of the swap 
eligibility attribute (SWAPEQUIVALENCE).    For example, one circuit might be used to monitor 
another circuit on the board.    It would defeat the purpose of the monitor circuit to have its gates 
swapped with the gates in the other circuit.    By setting the components in the monitor circuit to 
have a swap eligibility attribute different than the other circuit, swapping can be kept from 
occurring between the two circuits.

4. Swapping does not occur if the component has the NOSWAP attribute set to Yes.

5. Swapping does not occur if net copper is connected to either of the gates.

6. Swapping does not occur if any net connected to the gate has the OPTIMIZE attribute with a 
value of "NO".

Utils Optimize Nets Command
The Optimize Nets command allows you to select automatic or manual pin and gate swapping.    To 
run this command, you must enable the Select tool.



Run the Utils Optimize Nets command to display the Utils Optimize Nets dialog.

The dialog defaults to Auto, with the Gate Swap and Pin Swap options disabled.    To perform only a 
minimization of the nets connection, click OK.

When you click OK, connections are rearranged to shorten the total connection length.    If Gate Swap 
or Pin Swap are checked the gate and pin swaps occur in accordance with the rules found later in this 
section.

Automatic Pin and Gate Swapping
1. Be sure that that Auto radio button in the Method box is selected.

2. For gate swapping, click the Gate Swap box.

3. For pin swapping, click the Pin Swap box.

4. To perform gate and pin swapping in the entire design, click the Entire Design radio button.

5. To perform gate and pin swapping on selected objects, click the Selected Objects radio button.    
This button is grayed out unless you have selected objects before running the Utils Optimize Nets
command.

6. Click OK.

The Not-Undoable Operation Warning message appears.      If    you press No, you are returned to
the Optimize Net Dialog.    If you press Yes, the Optimize Nets Progress dialog appears. 

The Optimize Nets Progress dialog provides you with the current and cumulative status of the 
command.    You can stop the command at any time without losing the accumulated results.    

The Current Status box describes the current activity.    The current activity can show swapping 
gates or pins, or minimizing connection length.    Any swaps that occur follow the swapping rules.

Entire Design/Selected Objects
If you selected the Entire Design radio button on the Utils Optimize Nets dialog, the following actions 
occur:

If you selected Gate Swap or Pin Swap, pin or gate swapping occurs between any components 
in the design following the swapping rules outlined in the section entitled "When components and net 
connections are selected" below.    All nets are guaranteed to not have their connection lengths increase.

Minimum length optimization occurs for all nets.

If you selected the Selected Objects radio button, the following actions occur:

When only components are selected:
If you selected Gate Swap or Pin Swap, swapping is restricted to pins and gates among the 

selected components.    Swapping occurs only to improve (decrease the manhattan connection length of) 
those nets with connections to the selected components' pads.    Other nets' connections may increase in 
length.

Minimum length net optimization occurs on the connections between the selected components.

When only net connections are selected:
If you selected Gate Swap or Pin Swap, swapping occurs only to improve (decrease the 

manhattan connection length) the selected connections' nets.    This means that all gates and pins are 
eligible for swapping, as long as a selected net improves from the swap.    Un-selected connections may 
increase in length.

Minimum length net optimization occurs on the selected connections.



When components and net connections are selected:
If you selected Gate Swap or Pin Swap, swapping is restricted to pins and gates among the 

selected components.    Swapping occurs only to improve (decrease the manhattanconnection length) the 
selected connections' nets.    Those un-selected connections may increase in length.

Minimum length net optimization occurs on the selected connections.

Manual Gate Swap
You can use the Manual Gate Swap options to perform gate swapping manually on selected pads.    To 
perform manual    gate swapping,

1. Check Manual Gate Swap button on the Utils Optimize Nets dialog.

2. Click the OK button.    The Optimize Nets dialog disappears, and the cursor changes to the "more 
points" shape.    If you click the right mouse button or press the ESC key, the command is aborted
and you are returned to the Select Tool.    The cursor shape returns to the original shape.

3. Click on a pad and all pads of that gate, along with the connections that are attached to those 
pads, appear highlighted in highlight color one.    If you click the right mouse button or press the 
ESC key, the command restarts at the initial state, with all of the pads and their connections being
unhighlighted.

All the pads of the eligible equivalent gates (as defined by the gate swapping rules), and their 
connections, appear highlighted in highlight color two .

note:
The current layer must be a layer that the pad is defined on for the pad to be selected.    
Otherwise you hear a beep.    

4. Click a pad.    The pad and its connections appear in the first highlight color.    If the selected pad 
is not an equivalent pad, a warning message appears stating: "The selected pad is not 
recommended for swapping, proceed with caution."      This action constitutes a forced swap.    
The Swap Pins dialog now appears.

The dialog presents you with a list of the affected nets and their new connection lengths.    The 
manhattan connection length is calculated by determining the manhattan length after an 
optimization.    The percent changed is the percentage of the difference of the connection lengths 
before and after swapping.    Below the list box the total for all of the nets appears.

If net copper is attached to any pads of the two selected gates, then the Swap button is grayed 
and a warning appears in the dialog.    Nets that have copper attached are preceded by an 
asterisk.    The warning tells you that net copper is attached to a gate's pad, and it must be 
removed before swapping can occur.    Free copper is ignored.

5. To perform the gate swap, click Swap.

All of the nets attached to the first gate areswapped with all the nets attached to the second gate. 
The dialog disappears and the cursor returns to its original shape, ready for the next gate swap.    
All of the highlighted pads and connections are unhighlighted.

6. Click Cancel    to cancel the operation.    

The dialog disappears, no swap occurs, and the pads of the second gate, with their connections, 
revert to highlight color two. You can now select another gate for swapping.

Manual Pin Swap
You can use the Manual Pin Swap options to perform pin swapping manually on selected pads.    To 
perform manual    pin swapping,



1. Check Manual Pin Swap button on the Utils Optimize Nets dialog.

2. Click the OK button.    The Optimize Nets dialog disappears, and the cursor changes to the "more 
points" shape.    If you click the right mouse button or press the Esc key, the command is aborted 
and you arereturned to the Select Tool.    The cursor shape returns to the original shape.

3. Click a pad.    That pad, along with the connections that are attached to that pad, appear 
highlighted in highlight color one.    All of the eligible equivalent pads (as defined by the pin 
swapping rules), and their connections, appear highlighteded in highlight color two .    If you click 
the right mouse button or press the ESC key, the command restarts at the initial state, with all of 
the pads and their connections being unhighlighted.

note:
The current layer must be a layer that the pad is defined on for the pad to be selected.    
Otherwise you hear a beep.    

4. Click a pad.    The pad and its connections appear in highlight color one.    If the selected pad is 
not an equivalent pad, a warning message appears stating the specific discrepancy, and asks you
to confirm the selection.    This action constitutes a forced swap.    The Swap Pins dialog now 
appears.    

The dialog presents you with a list of the affected nets and their new connection lengths.    The 
manhattan connection length is calculated by determining the manhattan length after an 
optimization.    The percent changed is the percentage of the difference of the connection lengths 
before and after swapping.    Below the list box the total for all of the nets appears.

If net copper is attached to either of the two selected pads, then the Swap button is grayed and a 
warning appears in the dialog.    Nets that have copper attached are preceded by an asterisk.    
The warning tells you that net copper is attached to one of the pads, and it must be removed 
before swapping can occur.    Free copper is ignored.

5. To perform the pin swap, click Swap.

All of the net connections attached to the first pad swap with all the net connections attached to 
the second pad.    The dialog disappears, and the cursor returns to its original shape, ready for the
next pin swap.    All of the highlighted pads and connections are unhighlighted.

6. Click Cancel    to cancel the operation.    

The dialog disappears, no swap occurs, and the second pad with its connections, in highlight 
color one, reverts to highlight color two. You can now select another pad for swapping.

Impact on the PCB Library Mgr
Gate Equivalency maintenance:     Currently, the Library Manager allows you to set the gate 
equivalency of pins in the same gate to be different.    This causes gates to be non-equivalent by 
ambiguity.    To correct this problem, when you change a part number, or gate equivalence for some 
gate, the spreadsheet updates the gate equivalence field of the other pins of that gate to match.      
Existing components with this problem can be read in but cannot be saved.

Pin Equivalence:    Pin equivalence is allowed only between pins with the same electrical type.    The 
electrical types Unknown and Passive are considered the same for purposes of pin equivalence.    

See also:

For more details about modifying attributes, refer to the Place Attribute and Edit Modify commands.



Utils ACCEL Schematic
If ACCEL Schematic is installed on your computer, this command runs ACCEL Schematic.    If ACCEL 
Schematic is not running, it is launched.    If Schematic is already running, it becomes the active 
application.    Refer to your ACCEL documentation for additional information.



Utils ACCEL Lib Mgr 
If ACCEL Library Manager is installed on your computer, this command runs ACCEL Library Manager.    
If ACCEL Library Manager is not running, it is launched.    If it is already running, it becomes the active 
application.      Refer to your Library Manager documentation for additional information.



Macro Commands



Macro Record/Stop
Starts and/or stops a named macro recording.    After you record a macro, you can assign it to a key or 
to a menu.

To Record a Macro
1. Choose Macro Record/Stop to display the dialog. 

2. Enter the name of the macro you want to record and click OK.    The dialog will close and 
whatever actions you take will be recorded to the named macro (e.g., bionic).    

3. When you have finished the series of actions to be your macro, choose the Macro Record/Stop 
command again.    A dialog is displayed where you have the choice of ending the macro recording
altogether (click Stop), or stopping the macro in mid-recording to perform some other action (click
Pause) that you want to be recorded.    

To resume a paused macro recording, choose the Macro Record/Stop command again, and the 
same dialog is displayed, except with a Resume button instead of Pause.    You can then pick up 
where you left off and finish your macro.

Two shortcuts to end recording a macro are to either click the M button below the workspace (its 
other uses are explained in detail below), or press the M key.

Temporary Default Macro Record (M Toggle Button)
The Macro toggle button (M button located on the Status line) allows you to create temporary (default) 
macros on the fly.    Typically, you would use this default macro for a short time within a design process 
(e.g., repeatedly placing a combination of lines, duplicating the same lengths and angles). 

Only one default macro can be available at a time; each time you record a temporary macro, it 
overwrites the previous one.    

To Record a Default Macro:
1. Click the M button on the Status line to begin recording; it displays a red colored background 

when it is recording.    Press the M key as an alternate way to begin recording.

2. Perform whatever actions you wish to temporarily record.

3. The stop recording, click the M button (or press the M key) again; the colored background 
disappears when it stops the temporary recording.

4. Press the E (execute) key to playback the temporary macro.    The actions you recorded will 
repeat each time you press E.

A default macro can be paused and resumed just like a named macro, but you must use the 
Macro Record command to do it (see previous instructions).

note:
The name of the temporary macro is DEFAULT, so don't create any macros by that name.

If you want to create a more permanent macro, then you need to name it and record it with Macro 
Record/Stop.    You can rename DEFAULT with the Macro Rename command. 



Macro Delete
Deletes a named macro.    The Macro Delete dialog is displayed when you choose this command.

Select the macro you want to delete from the Macro Name combo box, or type the name of the macro.  
Click Delete and the macro will disappear from the list.



Macro Rename
Allows you to rename any created macros, including DEFAULT.    

When you rename DEFAULT, it is no longer a temporary macro, but a saved, named macro.

When you select this command, the Macro Rename dialog is displayed.

Renaming a Macro
Click on the Old Name combo box to select the name you want to rename.    Then enter the new name 
in the New Name textbox.    Click Rename, then click Close.    



Macro Run
Plays back a named macro.    The Macro Run dialog is displayed when you choose this command.

To run the macro, simply enter the macro name by typing it in or selecting it from the combo box, then 
click OK.

Run Temporary Macro
For running the temporary macro, use the E key.    To record a temporary macro, press the M key, do a 
series of actions, press the M key again to end recording.

This command is also handy for viewing your list of macros before you run one.    If you use a macro 
frequently, you can assign it to a key (Macro Assign To Key) as a shortcut.



Window Commands



Window New Window
Allows you to open additional windows for the active design.    You can move independently in each 
window, making it easy to compare different parts of the same design.    

A number identifying the window is added to the file name in the Title bar and at the bottom of the 
Window Menu.



Window Cascade
Arranges all open windows so that the window tiles are visible.

All windows overlap, starting in the upper-left corner of your Workspace.    You can see each window's 
title, making it easy to switch between windows.



Window Tile
Arranges all open windows so that all windows are visible.

Windows are resized and arranged side-by-side so that all windows are visible and none overlap.



Window Arrange Icons
Arranges design file icons (minimized windows) in the main application window.

Design files can be minimized into icons using the Control menu or by clicking the down arrow in the 
upper-left corner of the screen.    This command arranges these icons so that they are evenly spaced 
and don't overlap.    

You can open one of these design icons by double clicking it or choosing Restore from the icons Control
menu.



Libraries
This section provides important information about the structure and characteristics of PCB libraries, 
including:

- The relationship between components and patterns

- Using aliases instead of renaming

- Pad numbers vs. pin designators.

Components and Patterns
PCB libraries contain both components and patterns.    A pattern is the basic graphical structure that is 
used in the creation and display of a component; a component contains the logical and electrical data.    
A pattern by itself contains no information except the shape of its graphic display.    PCB cannot use 
either a component or pattern by itself, but needs a component/pattern combination.    When a 
component is placed it references a pattern, which is attached to it for graphical structure.    Numerous 
components can reference the same pattern.    The component and the pattern it references must both 
reside in the same library for the component to be placed.

It is very likely that a library will have multiple components using the same pattern.    This saves space 
and makes global edits of a pattern very efficient but also potentially dangerous, as it affects all 
components based on that pattern.    The graphical structure (shape, size, number and shape of pads) 
for the different components will be the same, but the electrical information for each one is unique.

Clearly, renaming or deleting a pattern could have a profound impact on a library.    If you change a 
DIP14 to a D14, for example, all components that reference the DIP14 pattern are now left hanging 
without a pattern.    The pattern is referenced by name only, and only when the component is placed or 
copied.

The graphical pattern DIP14 only needs to be stored as one entity.    When you place a component, the 
component in effect locates the named pattern structure and imports it into the design along with the 
component information.

You could have a PCB library containing 40 components and 25 patterns, and it would be complete as 
long as all the patterns that the components reference exist in the library.

Copying, Renaming, and Using Aliases
When you copy a component to another library, you generally need to copy its pattern too.    The pattern
copied with the component needs to be in the same library as the component, otherwise the pattern 
cannot be copied and the component cannot be placed.

As mentioned previously, you can rename components and patterns, but this is an action that must be 
undertaken with care.    If you prefer to use a different naming convention for your components and 
patterns, you can create aliases for them without having to alter the original name.    Aliases are 
preferable for a number of reasons:    it's a safe way to use a variety of naming conventions, there is no 
danger of making global mistakes (which is possible when you rename), and the flexibility of using 
aliases allows the component or pattern to be referenced by any of its aliases.

Pad Numbers vs. Pin Designators



An important fact to understand about components and patterns is that pad numbers do not equal pin 
designator values, except sometimes by a convenient coincidence.    Pad numbers are just identifiers 
for pads, used to cross-reference with the pin designators when assigning the pin designator values.    
Using an ordered, linear, pad numbering system just makes identifying pad numbers easier, but you 
could just as easily number your pads randomly and still assign pin designator values to them.

In the component/pattern combination, patterns contain only pad numbers, whereas components 
contain pin designators and the association between pin designators and pad numbers.    Each pin 
designator references one pad number.    The spreadsheet interface is where the you can map or 
associate the numbers with the designators.



 Route Commands (Route)

Info
Pause
Resume
View Log
Cancel (PCB Route)
Cancel (Quick Route)



Info
Displays the Information dialog box that shows up-to-the-minute statistics on your computer system, 
including available memory, disk size and disk space free.

The top line for each pass provides information for the pass: the pass name and number, the number of
connections, fanouts or nets scheduled, deferred and completed, the percentage completed, routing 
time and vias added or removed.    Note that the numbers of items scheduled, deferred and completed 
differ from pass to pass.    For via fanouts, the number of items fanned out is given.    During the 
constructive passes (Wide passes, Memory, Initial, Comprehensive and Exhaustive), connections are 
being referenced.    Local Iterative and Manufacturing rip-up passes also refer to connections.    
However, global rip-ups for Iterative and Manufacturing pass types go through two phases.    First nets 
are given, and later in the pass connections are referenced.

The second line contains overall routing statistics through completion of the pass.    This includes the 
total connections routed, a total percentage of connections completed, overall routing time and the total 
number of vias.

Routing stops while you are obtaining this information.    Remember to close the Information dialog after
you have finished reviewing it.



Pause
Temporarily stops the routing at the point where the command is invoked.    While paused, you may 
change your view, obtain routing information or on-line help, or cancel the route.

Computer resources are temporarily relinquished during pause allowing other memory-intensive 
applications to run.



Resume
Resumes a route that has been paused.    Routing starts at the point at which it was paused.



Cancel (ACCEL PRO Route)
The Route Cancel command provides options that let you terminate a route before it is completed and 
control certain aspects of the route.    

The Cancel Route dialog presents these options:

Stop routing and save.    Stops routing and saves an output PCB file with the name provided in the 
Route Autorouters dialog.    Associated checkpoint files are deleted.

Stop routing and do not save.    Stops routing and does not save an output PCB file.    The input 
design file is restored to its original state. Associated checkpoint files are deleted.

Stop routing at the end of this pass.    Stops routing at the end of the current pass and saves an 
output PCB file with the name provided in the Route Autorouters dialog.    

Skip this pass and continue.    Skips the current pass and continues routing at the next scheduled 
pass.    The autorouter does not save a checkpoint file or an output PCB file.

Checkpoint route and continue.    Creates a checkpoint file to save the current routing status and 
continues routing.

Suspend route.    Saves a "snapshot" of the current routing session in the checkpoint file and 
terminates the route. 

A checkpoint file can be restarted in the same pass you stopped the route, by selecting the Route Auto 
Restart command from the menu bar.    (If you are part way through a pass, you will restart at the 
beginning of that pass.) 



Cancel (Quick Route)
The Route Cancel command provides options that let you terminate a route before it is completed.    
The Cancel Route dialog presents these options:

Stop routing and save.    Stops routing and saves an output PCB file with the name provided in the 
Route Autorouters dialog.    Associated checkpoint files are deleted.

Stop routing and do not save.    Stops routing and does not save an output PCB file.    The input 
design file is restored to its original state. Associated checkpoint files are deleted.



 Options Commands (Route)



Routing Fine Points
Pre-routed Connections
Keepouts
Off-grid Items
Plane Connections
Surface Pads
Improving Performance
Grid Selection
Memory Management
Improved Completion Rates
Completing your Design
Backing Up Files



Pre-routed Connections
ACCEL PRO Route accepts any pre-routes whether they are added manually or created as a result of 
autorouting.    ACCEL PRO Route recognizes pre-routed nets so that they are not routed a second time. 
Pre-routes can be ripped up if the Ripup option is enabled in the Options area of the Route Autorouters 
dialog.    However, pre-routes on a disabled layer never are ripped up, even if ripup is allowed.    The 
router has knowledge of items on disabled layers so that it can avoid placing vias inadvertently through 
existing geometry.    It may choose to tap into connections on a disabled layer to complete a net in an 
optimal manner.

Additionally, you can have the autorouter fix individual nets (not ripped up), overriding the global ripup 
option by setting the RIPUP Net Attribute to No, 0 or False for those nets.    This is a very powerful 
feature and is suggested for preserving pre-routed lines.    It allows the autorouter to reconstruct any 
lines that were previously placed automatically, while leaving your manual placed routes alone.

If a free pad or via is pre-routed to a node in a net, the free pad or via is added to that net.    This is 
useful for connecting surface-mount components and edge connectors to the Power and Ground 
planes.

If a pre-routed connection consists of several line segments, always try to place the segments (and 
vias) on the anticipated routing grid.

Lines and arcs with a width that is different from the line width for the net are not ripped up.

If an area needs to be filled with copper, use polygon fills instead of placing a number of crisscrossing 
line segments.    Copper pours should be done after routing has been completed.

These practices reduce the amount of memory required to process the pre-routes and speed the 
processing of pre-routes.



Keepouts
A keepout defines an area of the board where ACCEL PRO Route and PCB Quick Route does not 
route.    The selected autorouter applies keepouts as lines or polygons on the current layer or on all 
layers depending on what you specified using the Options Current Keepout command.    A line segment,
as opposed to a polygon fill, is really a "don't cross", so lines can both restrict routing from a section and
confine routing within a border.

You can create a keepout on a layer by placing keepout lines or a keepout polygon fill on the current 
layer.    

note:
You must be sure not to touch these keepout items with lines or pads that belong to a net, 
otherwise the router treats them as a part of the net.

One example illustrating the use of keepouts on all layers is to place lines around a pre-routed analog 
section of a board.    This would prevent all digital lines placed by ACCEL PRO Route or Quick Route 
from entering the analog area.

You might want to use keepouts on signal layers to prevent the router from routing under the pads of an
edge connector.    To do this, create polygon keepouts beneath the edge connector on all mid-layers.    
Alternately, place line or polygon keepouts between the edge connector pads.    This has the benefits of 
affecting all layers at once and preventing the router from placing lines on the Top and Bottom layers 
between or around the pads.

You can save keepouts with a component.    For instance, to prevent the autorouter from using the 
space beneath a component, place a keepout polygon over the area to be restricted.    Select the 
keepout with the other objects being saved with the pattern.    Then use the PCB Library Patter Save As 
command to store the keepout with the pattern.

note:
Do not cover pad centers with keepouts, as this prevents the router from routing to or from the 
pad.



Off-grid Items
If a pad is not centered on the selected routing grid, the program routes to the nearest grid point and 
then adds a small line segment between the grid point and the center of the pad.    Off-grid pads and 
line segments tend to block subsequent routes more than on-grid items, and they may also lower the 
completion percentage.    Additionally, the router must maintain rows and columns of extra point 
locations.    This increases memory requirements and reduces router performance.    Although the router
is able to work with off-grid items it is best to place your components on the intended routing grid or 
some multiple thereof.    

The selected autorouter converts arcs to line segments.    To prevent clearance violations, these 
segments are short.    The side effect is that these segments are off-grid, and a problem similar to the 
one just described occurs.    If possible, place arcs after autorouting has been completed.



Plane Connections
ACCEL PRO Route and PCB Quick Route derives its plane information from the layer definition.    You 
can specify the nets to be connected to the planes when the layers are created.    You can also modify 
the net name using the Current Layers dialog accessed from the Route Autorouters dialog or by using 
the Options Layers command in PCB.

Power and Ground nets set in Tango PCB or PCB Plus (Series II) boards are automatically carried 
forward to PCB when they are loaded.    

If a pad belongs to the plane net but is not connected to it, ACCEL PRO Route or Quick Route may 
connect it by adding a line to a via or pad that is connected to the plane (i.e., perform via fanout on 
SMD).

As explained earlier in the section, a free pad or via that is pre-routed to a node in a net becomes a new
node in that net.    Pre-routes are taken into account during the processing of plane nets.    A free pad or 
via that is pre-routed to a node in one of the plane nets is considered a fanout to the node and 
processed like any other node in that net.

Connecting Surface Pads to a Plane
On a printed circuit board, you can usually find two types of pads:    Through-hole pads (which belong to
all PC-board layers) are used for component packages with leads that pass through all board layers.    
Surface pads (which belong to either the Top or Bottom layer) are used for surface-mount components 
and edge connectors.

You can connect through-hole pads directly to any plane.    Surface pads, however, require that you 
connect the pad to a plane by means of a free via or free pad.    Note that vias may be ripped up, but 
pads are never touched.

For boards with more than two layers (when the auto pass selection is enabled), ACCEL PRO Route or 
Quick Route automatically connects the surface pads, including pads for SMDs and edge connectors, 
to a via and then to the plane providing that:    

The surface pads are part of a    plane net. 
The surface pads are not already connected to a through hole pad.    

Additionally, pads are automatically connected to planes for two-layer boards under special conditions 
such as when a top and bottom surface pad, attached to the same net, are co-located.    This work is 
done in the Wide Via Fanout and Via Fanout passes.    You may also choose to schedule these passes 
manually.

Direct Connections
PCB, TangoRPO Route, and Quick Route display an X in the center of a pad to indicate that the pin is 
connected to a plane.

The X lets you tell at a glance whether a pad is connected to a plane.    But how can you tell to what 
plane the pad is connected?    By running the Options Display command, you can assign separate 
colors to each plane.    A good practice is to use red for a Power plane (red = hot = power) and green for
a Ground plane (green often signifies ground connections).    Alternately, select the via or free pad and 
the net name appears on the Status line.

note:



Plane vias added by the router are connected to the plane with a thermal relief or connected 
directly as defined by the via style assigned to that plane net.    You can see the type of 
connection by displaying the plane layer. 



Surface Pads
While ACCEL PRO Route and PCB Quick Route permit you to set the orientation of routes on any layer,
a typical double-sided board is routed with horizontal lines on the Top layer and vertical lines on the 
Bottom layer.    This convention makes it difficult to route a set of surface pads that are arranged 
horizontally on the Top layer or vertically on the Bottom layer.

For example, consider access to surface pads on the Top layer of an edge connector which is along the
lower edge of the board.    It is difficult to complete connections to the middle pads of the edge 
connector (all pads other than the first and last) since there is no easy access to these pads with 
horizontal lines.    Setting the layer bias (to vertical in this case) may help.

To ensure high rates of completion in these cases for boards with more than two layers, ACCEL PRO 
Route and Quick Route automatically connect the surface pads to a via, providing that:

The surface pads are part of a net.
The surface pads are not already connected to a through hole pad.    

The via or pad then becomes a potential target on any layer (with any bias) for routes to the surface 
pad.    If you have a board with several mid-layers, select layer biases to favor the direction of your 
surface mount pads or connectors.    Also, if you are manually selecting passes, run a fanout or wide 
fanout pass to create better access to your surface pads.



Improving Performance
Performance in an autorouter is defined as the minimum amount of time required to produce the 
desired result.    The desired result, in turn, is a printed circuit board design which is complete, 
manufacturable, electronically sound and aesthetically pleasing.

The total time to complete the desired board includes any time-consuming, manual clean-up required 
after the autorouter completes its end of the task.    Thus, completion percentages and the quality of the 
routes accomplished are a key component in performance.

ACCEL PRO Route is a very efficient and intelligent autorouter, and under most conditions it will 
produce better results with its default routing strategy than with a user-defined strategy.    However, 
under certain conditions the program may encounter problems, including failure to reach 100% 
completion and slower-than-expected performance.    This section contains information and tips about 
how to deal with these problems.

Routing Completion
Since there is no way to predict in advance what the results will be for a particular circuit design, the 
recommended procedure is to let ACCEL PRO Route start with the default routing strategy, in particular,
let the autorouter define the grid and pass selections.    

When to Abort the Default Strategy
Progress of the run should be monitored using the Route Info command and information provided on 
the Status line.    The critical point comes at the end of the Constructive passes, just before the start of 
the Iterative passes.    The decision to continue the run using the default strategy or to abort the run and
change the strategy should be guided by the completion rate at that point.    The general rules below 
provide guidelines to help make this decision.

Check the total board completion percentage just before the start of the Iterative passes.

Less than 90 percent.    The probability of achieving 100% completion is low.    Abort the run and 
try another alternative.

90 to 92 percent.  The probability of achieving 100% completion is about 50/50.    Either abort the
run and try another alternative, or continue to monitor the router's progress.    If little or no improvement is 
noted, abort the run and try the suggested alternatives.

Greater than 92 percent.  The probability of achieving 100% completion is very good but not 
assured.    Continue with the default strategy to the end of the run.

If it becomes necessary to abort the default strategy, one or more of the following actions or factors can 
be changed in an attempt to improve the results.

Change routing grid.
Change via grid.
Change line width or clearances.
Change via size.
Change pad sizes.
Increase number or change the direction of layers.
Adjust the component placement and make sure components are on grid.
Disable diagonal routing until the Manufacturing passes (for SMDs).
Add curved lines after autorouting has been completed.

View the Output Log File



To help you decide which changes to try, look at the output log file. ACCEL PRO Route generates a 
comprehensive report file at the end of the routing session, detailing the route strategy and results of 
the session.    This file is named in the Route Autorouters dialog, and it may be viewed by selecting the 
Route View Log command during or after a route session.

If ACCEL PRO Route fails to achieve 100% completion, this report file can be of real use to you in 
determining how best to alter the design rules or fine-tune the routing strategy to achieve 100% routing 
completion.

Choices made by the router are indicated with an asterisk (*) in the first section of the output log file .    
Examine these to make sure that the values are reasonable.    The second section provides per pass 
history.    Compare completion percentages against prior runs to determine the best strategy.

If you examine the file during routing or cancel the routing process, the report file reflects the final board
statistics only up to the point of termination.    When you cancel the route, a cancel warning message 
appears in the report file.

The manufacturing passes typically produce diminishing returns.    If you notice that results are 
satisfactory before all manufacturing passes are run, you may benefit by skipping the remaining passes 
and continuing to final manufacturing.

Once the board is routed to 100 percent, the router skips any remaining constructive or iterative passes.
However, it runs all manufacturing passes, so you will want to select the Manufacturing Pass Count 
carefully.    Three manufacturing passes are generally adequate.

Changing Design Parameters
On any board that gets poor completion rates, you should check the following items:

Design rules.
Line width.
Via size.
Pad size.
Number of layers.
Grid spacing.
Component arrangement.
Net attributes.
Layer bias.

Check the report file to verify that each of the above listed items has the value you expect.    In 
particular, if this is a fine line circuit, is there room to fit two (or more) lines between pins at the selected 
spacing?    Is the via pad size the size you expect?    

If all seems correct, consider reducing one of these items if your manufacturing techniques will permit.    
In particular, small reductions in the via size can often produce large gains if a line can be placed one 
grid point closer to a via.    The advantages of permitting more lines between pins and greater line 
packing are obvious.

The advanced design of ACCEL PRO Route permits it to effectively handle a wide range of autorouting 
requirements using its default strategy.    Under normal conditions, ACCEL PRO Route can compensate 
for occasional deviations from good design practices.    However, there is a limit where ACCEL PRO 
Route can no longer deal with components that are randomly placed.    

For the best results, components should be placed on the board in an orderly fashion.    Where possible,
components should be placed with their pad centers on a 100-mil grid, and if this is not possible, the 
pad centers should be placed on the intended routing grid.    The other standard placement 



considerations of locating components to minimize line length and reduce congested areas will also 
improve ACCEL PRO Route's results.

A good strategy for locating congested areas is to run ACCEL PRO Route through the Constructive 
passes and look at the remaining open connections (the rat's nest).    A display of the uncompleted 
connections at this point shows problem areas and may suggest improvements to component 
placement.



Grid Selection
The routing grid defines the spacing pattern of the grid points.    The grid pattern may be uniform (i.e., 
equal spaces between all lines) or it may be non-uniform to allow one or more lines to pass between 
component pads, while keeping the number of grid points to a minimum.    

Uniform grids are generally used for relatively simple, low-density PC-boards and often for SMD 
boards.    

Non-uniform grids are typically required on complex, high-density through-hole, and sometimes 
surface-mount, PC-boards to achieve 100% completion of the connections in the minimum amount of 
time.

ACCEL PRO Route's support of both uniform and non-uniform routing grids enables it to handle virtually
any board density and any combination of routing grids.    The main benefit of the non-uniform grid over 
the uniform grid is performance:    it contains far fewer grid positions without the loss of route paths.    
Thus, completion time is shortened and more freedom in placement is allowed.    ACCEL PRO Route 
easily handles both packages with different pitches on the same board and boards with mixed 
technologies (through-hole and SMD).

Selecting the Proper Grid
Grid selection is important for obtaining optimum router performance.    The autorouter can intelligently 
make this selection for you, and we suggest you use the auto grid option first.    However, since all of 
your special needs can't be anticipated, you have the option of setting grids manually.

With this flexibility comes the added responsibility of carefully planning the pad sizes, line widths and 
component placement grid so that you can get the most out of ACCEL PRO Route.

The first step is to determine your board manufacturer's capabilities and to verify the yields available 
with various line densities.    This helps you determine the best design rules to use when placing 
components and pre-routing, and on the autorouted lines in ACCEL PRO Route.

Planning in advance is absolutely necessary.    Determine your routing and placement grids early in the 
layout cycle; they should be known before placing components.    We cannot emphasize the importance
of proper component placement prior to autorouting.    Changing grids during placement can result in 
many off-grid components and pads, thus lowering completion rates.    

Always place components on a grid that is an integral multiple of the intended routing grid.    For 
example, place components on a 25-, 50- or 100-mil grid, if you intend to autoroute with a 25-mil grid.    
In general, it is best to try to place your components on a 100-mil grid, as all of the routing grids are 
evenly divided into 100-mil.    You should follow similar guidelines for metric boards.

If a pad is not centered on the routing grid, the program routes to the nearest grid point and then adds a
small line segment between the grid point and the center of the pad.    Off-grid pads and line segments 
block subsequent routes more than on-grid items and may lower the completion percentage.

If possible, place arcs on signal layers after autorouting.    The autorouter converts arcs to line 
segments, and the ends of these lines often fall off-grid.

Gridded vs. Gridless Routers
ACCEL PRO Route offers the best of both gridded and gridless autorouters.    ACCEL PRO Route is a 
gridded autorouter.    But unlike typical gridded routers, however, ACCEL PRO Route's support for both 
uniform (50, 25, 20, 16.7, etc.) and non-uniform (40-20-40, 42-16-42, etc.) routing grids, combined with 



its ability to route off-grid enable it to handle virtually any combination of design rules and pad sizes.

Non-uniform gridded routing allows multiple lines to be routed between pads for higher completion rate 
while still utilizing the speed advantage of the grid.    To achieve the same result with a uniform grid, a 
finer grid must be selected, thus making the process much slower and more memory intensive.

Once the grid is selected, it is set for the routing session.    However, ACCEL PRO Route solves 
localized blockage problems by routing off-grid, returning the line to the grid pattern when the 
component and line placement allows.

Thus, the non-uniform-grid and off-grid capabilities of ACCEL PRO Route provide the same benefits 
that gridless routers offer, but require much less time to route a PCB.    At the same time, the autorouter 
benefits from being grid-based (versus gridless) because gridded routers produce clean, attractive 
boards similar to those designed manually by experienced layout professionals.

Automated Grid Selection
When you enable the Auto Grid Selection option in the Route Autorouters dialog, the autorouter 
automatically selects the best routing grid based on the type and placement of components on the 
board, their pitch (spacing between pads), your selected line width(s) and design rule clearances.    The 
Grid button in the Route Autorouters dialog is disabled. 

ACCEL PRO Route begins by establishing a grid pattern over the routable area of the PC-board which 
is enforced during the entire routing session.    The grid establishes pathways for routing.    

The use of a grid is still the most efficient way to autoroute a circuit board.    However, with ACCEL PRO 
Route there is no requirement that items on the    your design must be on the grid.    The program routes
off the grid under two conditions:

To reach a pad.
To place a line between two pads.

ACCEL PRO Route automatically calculates the optimum routing grid using either of two sets of rules:    
through-hole pad rules or surface pad rules. 

Through-hole pad rules:    ACCEL PRO Route assumes that the through-hole pad-to-pad distance
(e.g., 100 mils) is the usual spacing between pads.    It then calculates how much space would be left 
between two pads with the most common through-hole pad size.    It calculates the maximum number of 
lines that can be packed into this space, given the line width and clearances.

If no lines fit between two pads, the routing grid is set to 50.    If only one line fits between two 
pads, the routing grid is set to 25.    If more than one line fits between two pads, ACCEL PRO Route 
defines a routing grid that accommodates the maximum of lines between them.

ACCEL PRO Route attempts to space the channels between the pads so that the distance 
between these channels divides evenly into 100.    If this is not possible, the channels between 
the pads are packed as tightly as the line widths and clearances will allow. 
Surface Pad Rules:    ACCEL PRO Route uses a proprietary algorithm.    If results are not as 

desired, manually select a grid that packs the maximum number of lines evenly into the normal spacing 
pads.

The decision to use one or the other of these rules is based on the ratio of surface pads to through-
holes.

If the surface pad through-hole ratio is equal to or greater than 2:1, surface pad rules are used.
If the ratio is less than 2:1, through-hole pad rules are used.

To determine the ratio, ACCEL PRO Route scans the input design file to count the number of through-
hole pads and surface pads.



When routing lines, ACCEL PRO Route follows your specifications for the allowable routing area, line 
widths, clearance tolerances and other design variables.

Because of the intelligence built into ACCEL PRO Route, we suggest that first-time or novice users stick
with ACCEL PRO Route's experience and not try to design their own routing strategy.    In fact, 
experienced users will find that in the large majority of cases, the default strategy of ACCEL PRO Route
produces better results than if user strategies are employed.

However, if at the end of the Exhaustive pass, completion is less than 92%, the router may have 
difficulty completing the design with the current settings so you may want to try your hand at selecting 
your own grid.

Manual Grid Selection
You can select the routing grid (and via grid) manually.    The grid you select is used throughout the 
entire routing session;    it is not changed on a pass-by-pass basis.

With SMD designs, the via size is a more critical element than with through-hole designs.    This is 
because there is generally a via placed by many SMT pads in the via fanout passes.    These vias may 
later be eliminated during the manufacturing passes, but in the meantime they present an obstacle to 
routing.    This is particularly true for SMD designs where the via is larger than the width of the average 
surface pad. 

The various grid options are primarily intended to improve the completion rate during the constructive 
and iterative routing passes.    However, you can take advantage of certain grid combinations to improve
the results of the manufacturing passes as well.

Here are three examples:    After routing the board with the 42-16-42 grid, use the 42-8-8-42 grid or the 
17-16-9-8-8-9-16-17 grid during the manufacturing passes.    After routing the board with the 40-20-40 
grid, use the 40-10-10-40 grid during the manufacturing passes.    This gives the reconstruct algorithm 
more grid positions to use while cleaning up lines, spreading tracks and reducing vias in the 
manufacturing passes.

Since the grid selected is for the entire routing session, you could try to re-initiate routing and select just
the manufacturing pass to enable these special grids as described above.

Via Grid
If you manually select the routing grid, you may also select the via grid to be a multiple of the routing 
grid.    If the routing grid spacing is non-uniform, the autorouter applies the via grid multiple to the sum of
the spacings (e.g., if the route grid is 38-12-12-38, and the via multiple is 2, vias can be placed every 
200 mils).    The via grid is selected for you if you have enabled the Auto Grid Selection option.    

The purpose of having a separate via grid from the routing grid is to allow for higher completion.    Again,
it is particularly important on SMD boards where the router does a fanout of vias from the SMD pads.    
By having a courser grid set for vias than for routes (a Via Grid Multiple greater than one), vias are 
placed further away from the SMD pads, and from each other.    This prevents a wall of vias from 
forming, which would block subsequent routes.    Coarser via grids may be required for 
manufacturability or testability reasons.    Many bed-of-nails testers require vias to be on a 100-mil grid.

ACCEL PRO Route uses the selected via grid as a recommendation, but is not bound by this selection.  
A "costed via grid" is used by ACCEL PRO Route when placing vias.    This means that placement of 
vias on the grid is encouraged, but is not mandatory.    Placement of vias off of the via grid only occurs 
as a last resort to achieving 100% completion.      





Memory Management
PCB is a powerful design tool that provides you with the ability to create large, complex designs.    The 
single non-design factor, which may limit autorouting of these complex boards is the amount of 
available Random Access Memory (RAM).    

Certain memory requirements are fixed.    A minimum of 7.6 Mb is required to begin routing.    This 
includes memory for DOS, Windows, PCB and the router itself.    Grid data requires additional memory. 
The amount of this additional memory varies depending on board size, the number of signal layers and 
the selected routing grid.

You can use the following formula to compute the approximate additional memory requirements for 
ACCEL PRO Route on your board:

Memory Requirement =(2+3L)(XG)(YG)

Where: L = number of signal layers

XG = number of grids in X

YG = number of grids in Y

For Example:
If L=4 Layers

Grid= 40-20-40; (3 grids/100 mils, or 30 grids/inch)

Board Size= 12.3 inches by 8.2 inches

Then:
Add'l Memory Req'd = (2+ 3*4)(30*12.3)(30*8.2)

= (14)(369)(246)

= 1,270,836 bytes

If the ACCEL PRO Route memory requirements exceed available physical memory, some solutions are 
to reduce the number of grid points (i.e., select a coarser or non-uniform grid), reduce the number of 
layers, or obtain more physical memory.    Also try removing any TSRs, including Smartdrive.    
Generally, you will want to run Windows using Smartdrive.    However, the effect of not using it during 
routing isn't significant.    Thus removing Smartdrive to obtain sufficient memory is a viable solution.

Remember that the non-uniform grids such as 40-20-40 use far less memory than the 20-mil grid, and 
yet still achieve the same number of lines between pads.    Use a non-uniform grid, where possible.    
Also, off-grid pre-routes and components and arcs on signal layers can significantly increase the 
amount of memory required.

ALLOC Option
The ALLOC option provides you with a way to limit the amount of memory available to ACCEL PRO 
Route.    This may be useful to run other Windows applications at the same time.    Use the Windows 
PIF Editor, and enter the following in the Optional Parameters field:

            /ALLOC:<Kbytes>



This option limits the router to allocate only the amount of memory specified.    Thus /ALLOC:8000 
would allow the router to allocate only 8 megabytes of memory.

The value, in kilobytes, should be less than or equal to the total amount available.    If the value exceeds
the memory available to the program, the maximum amount is allocated. 



Improved Completion Rates
Modifying the default grid strategy can be an effective way to improve the percent of completion on your
board.    Here are some suggestions for both SMD and through-hole designs.

SMD Boards
For SMD boards, there are two different approaches that may be tried to improve completion rates.    
These include using a finer grid and selecting a coarser via grid.    Both of these alternatives are 
discussed below.

Try a Finer Grid
The default strategy for SMD boards is to select a grid primarily based on considerations involving vias. 
Most surface pads (except in memory arrays) require at least one via in order to be connected.    On a 
fine grid, the vias may block more routing channels.    Occasionally, however, better results will be 
achieved by selecting a grid equal to the line width plus the line-to-line clearance, permitting maximum 
packing of lines.

Therefore, you may want to re-route your board to see if a finer grid improves the completion rate.    To 
experiment, set your grid and route through constructive passes.

When selecting a grid it is best to use a grid that fits exactly into the pitch of your through-hole 
components. 

Select a Via Grid
Typical design rules do not allow a line to go between two vias on the pitch of the SMDs even though 
the vias themselves may fit on the pitch.    For example, suppose the SMD pitch is 50 mils, the line width
is 10 mils, the via size is 40 mils and all clearances are 10 mils.    Under these conditions, two vias can 
be placed 50 mils apart, but no lines can go between these vias. 

When the router does a fanout from the SMD pins there will be a tendency for walls of vias to build up 
next to the SMDs.    If this seems to have occurred, use of a 100-mil via grid will force the vias on 
adjacent pins to opposite sides of the SMD.    In this case, selecting a via grid multiple of two 
accomplishes this goal.

On boards with only two signal layers, a coarser via grid should probably be used for all passes.    With 
designs having more than two signal layers, experiment with using a coarse via grid for just the fanout 
passes or for all passes except the Final Manufacturing passes.

Through-Hole Boards
Through-hole circuit designs require different remedies than SMDs to solve completion problems.

Through-Hole Fine Line
On fine line designs, ACCEL PRO Route typically selects a non-uniform grid that permits the maximum 
number of lines between two pins on 100-mil centers.    This choice is primarily made for performance 
reasons since ACCEL PRO Route can be as much as three times faster on a 40-20-40 grid as on a 
uniform 20-mil grid and use considerably less memory.    The negative side of this choice is that in open 
areas of the board, maximum line packing will not occur.    Using a finer grid that still permits the same 



number of lines between pins usually increases completions.

One special situation needs to be noted.    If the design rules are 8-mil lines and clearances with 60-mil 
pads, ACCEL PRO Route will choose a 42-16-42 grid for through hole designs.    If you decide to try a 
finer grid you might be tempted to use a 16.7 grid.    However, this grid only permits one line between IC
pins.    A better grid choice in this situation is the union of 42-16-42 and 16.7, i.e., 17-16-9-8-8-9-16-17.   
A choice that would not effect router performance would be to select a uniform 20-mil grid, with the pad-
to-line clearance reduced.    The technique of making a new grid that is a union of two others is equally 
feasible for metric boards.

It is recommended that the via grid multiple be set to 1 for passes other than the manufacturing passes 
if this strategy is attempted.

One Line Through-Hole
On one line through-hole designs it is difficult to improve on the results of the default passes and grids.   
Occasionally, if the design rules will permit, use of a finer grid to pack lines closer will gain connections. 
For example, if the line widths are 10-mil and the line-to-line clearance is 10-mil, you could try a 20-mil 
grid. 



Completing Your Design
After the routing passes conclude and the output files are generated, you may still find uncompleted 
connections.    Your options are to either:

Modify any or all of the routing parameters or modify the component placement and try 
autorouting again. 

Finish the remaining connection by hand.

Both procedures are explained below. 

Iterative Approach
The first step in finishing the board with the iterative approach is to examine the connections left 
unrouted by the autorouter.    Your choices at this point are:

To move components for better placement before re-routing.
Enable signal or planes layers (using Options Layers) that were not previously enabled, then re-

route.
To immediately return to ACCEL PRO Route and try new design rules, different passes, more 

layers or finer grids.

When viewing the unrouted connections in PCB, look for areas of obvious congestion that can be fixed 
by moving components around the board.    If you find such bottlenecks, move the components on the 
board, maintaining routed connections if possible without creating shorts, to relieve the congestion.    
Then, feed the board back into ACCEL PRO Route.

ACCEL PRO Route is fast enough that you can cycle through the following procedure several times 
before completing the board manually in PCB:

1. Autoroute the board only through the constructive passes (i.e., set Iterative and Manufacturing 
passes to zero if you are allowing the router to select passes or manually select just the 
constructive passes).

2. Move the components to minimize the density of unrouted connections and to move off-grid 
components onto the routing grid, or make other strategy changes discussed above.

3. If necessary, repeat steps 1 and 2.    Once the board routes to more than 92% before the Iterative 
passes, continue to the next step.

4. In ACCEL PRO Route, route the board that was output from step 2 through the maximum number
of Iterative passes (10) and choose any number of Manufacturing passes (up to 10).    Do not 
select the Force Manufacturing Passes option if you do not want the router to clean up the board 
before it is 100% completed.    

5. If necessary, continue to follow steps 2 and 4.

One final idea that you may want to try is to run your unfinished board through one or more 
Manufacturing passes, allowing the router to remove vias and line length before sending it through the 
Iterative passes again.    This could actually make routing more difficult, but the technique has been 
known to work.

When should you attempt this iterative approach and when is it time to manually complete the board?    
There are no hard and fast rules, but the following conditions favor the iterative approach:

The components can be moved.    If design constraints do not require fixed component 
locations, try moving the components before routing.

The input PCB contains few, if any, pre-routes.    This simplifies the process of moving 
components on the input PCB.



The routing grid may be changed.    If you have selected a grid for placement such as 50-mil, 
you may be able to switch routing grids from say 25-mil to 16.7-mil without adding a lot of off-grid 
components.    The finer routing grid may produce better results but must be within the fabrication 
capabilities of your board manufacturer.

More signal layers may be added.    This is a fast way to increase completion percentage, if you
can afford the expense of multi-layer board fabrication.

Add Plane layers.    Power and Ground layers, or other plane net layers, can be added.    This 
allows connections using thermals and eliminates lines on signal layers for these nets.

The routing process is relatively short, for the potential gain in completion.    If routing takes
over an hour and only leaves a few connections unfinished, it might be faster to complete them manually.  
On the other hand, if routing takes a few minutes and leaves 20 or more connections unrouted, it is 
probably worth a few iterations to reduce the number of    unrouted connections.

The completion improves with each iteration.    After a while, the iterative process yields 
diminishing rates of return.    If this happens, it is time to back up one step and make another iteration.

Iterative Passes
There are two types of iterative passes: global and local.    You can't select them directly, but you can 
guarantee a mixture of pass types.    Although global iterative passes are more comprehensive in 
handling the most complex connections, a mixture of global and local passes often provide the best 
results.

The autorouter defines scheduling for these passes.    At most, a maximum of three global passes are 
completed in a row.    Specifically the rules are:

If 98 percent or more complete, the autorouter runs a local pass.
If less than 98 percent complete, it runs a global pass, unless three global passes have just been 

run.

For designs that are very dense or complex, select at least four passes by setting the Iterative Pass 
Count.    This ensures a mix of global and local strategies.    Before concluding that the router is unable 
to proceed, allow it to complete these passes.

Manual Approach
Given the guidelines above, when you feel that ACCEL PRO Route has done the best job possible, it is 
time to manually complete the remaining connections in PCB, using the Route Manual command or 
Route Interactive command.



Backing Up Files
The autorouter generates checkpoint files after each pass, after the time interval you set in the Route 
Autorouters dialog, and when you suspend the route using the Route Cancel command.    These files 
have the same base name as your design, with a .CPT extension.    The file is deleted when the router 
normally terminates.    For safety, protect your checkpoint file (and your previous work) by making a 
copy of it before restarting.

If you want to save multiple strategies for one design, save each strategy under a unique file name.

We strongly recommended that you make backup copies of your finished designs and designs-in-
progress.    Hard disks occasionally crash and everyone at some time or another issues the command 
DEL *.* from the wrong directory!    You can take every precaution to avoid these problems but it never 
hurts to prepare for them.    Archiving all of your design files is inexpensive and takes very little time but 
it can be a lifesaver when a problem occurs.

And here's one final tip.    If you are iteratively running your board through ACCEL PRO Route, save 
subsequent output files using different, meaningful names.    If you move the components or make other
changes that result in a worse completion rate than the previous PCB file, you will always have the 
previous PCB file available in reserve.



Routing Grid
The Routing Grid combo box lists the fixed list of grids allowed by Quick Route.

Design Rules and Routing Grids
There is a direct correlation between your design rules (e.g., line width, clearances, via styles) and 
the routing grid.    Together, these values have an enormous effect on completion and performance 
of PCB Quick Route.

You are always responsible for setting the design rules because they are determined by your own 
particular fabrication requirements.    PCB Quick Route, on the other hand, will assist by 
automatically selecting the best routing grid to go with your design rules.    The default values 
supplied (12 mil for all instances) are satisfactory for general purpose commercial, high volume, low
priced production.

If you choose your own routing grid, be certain you consider the design rules before selecting a 
routing grid, and vice versa.



Line Width
The Line Width scroll box lets you select aa legal line width whose minimum value is 0.1 mil and 
maximum value is a function pf tje Routing Grid selection.    The routing line width can't exceed half the 
grid value.

For example, if you select a 25 mil grid, the Line Width option varies from 0.01 mil (.01 mm) to 12 mil 
(.30mm) in 0.1 mil (0.01mm) increments.    If you type too large a value, the scroll box automatically self-
adjusts to its maximum value when you move to another field.    Use the up and down arrows to scroll 
through valid values.



Selection Reference Point
PCB offers the ability to place a selection reference point.    The selection reference point is used with all
Select operations, such as moving, copying, rotating, flipping, or pasting.    However, a selection 
reference point is not required for these operations.

The selection reference point is saved to the clipboard or to a block file and automatically restored when
pasting from the clipboard or block file.    If the selection reference point is off-grid when a move 
operation begins, then it is automatically snapped to the nearest grid point and all the selected objects 
move the same relative distance.    The selection reference point is automatically erased when all the 
objects are deselected.

    To Place a Selection Reference Point
1. Select the object or objects.

2. Click the right mouse button which displays a pop-up menu.

3. Select the menu item Selection Point.

4. Click and drag the left mouse button to ghost the selection reference

            point.

5.      Clicking the right mouse button will cancel the placement of the selection reference point.

6. Dragging the selection reference point over pads (within a pattern or free), vias, or ref points 
(within a pattern or free) , causes the selection reference point to snap to that objects center 
point.    The shape of the selection reference point changes from a square to a diamond when it 
snaps to an objects center point.    If the selection reference point does not snap to an object, then
it moves to the nearest grid point.

7.      Release the left mouse button to stop ghosting the selection reference point.    The selection 
reference point is redrawn in the selection color.

8. To move a selection reference point, repeat the steps to place a selection reference point.

This function can be used for radial placement (e.g., of components).    To do so:

1. Select the object to be radially copied.

2. Move the selection point to the point about which the object is to be rotated (right mouse down, 
and release the selection point).

3. Holding the CTRL key down, select the object, moving the mouse slightly so that the cursor 
snaps to the selection point (this copies the object), then release the mouse button and CTRL 
key.

3. Type  R or Shift-R to rotate the copy.



Edit Align Components
Components can be aligned around a selection reference point either horizontally or vertically, and as 
an option, equally spacing the components.    Or, if a number of components are off-gird, these 
components can be aligned back on-grid.    

- The alignment of components is undoable.    

- The alignment of components has full macro support.

To Align Components Horizontally or Vertically
1. Select the components to align.    Only components can be selected for this command to be 

enabled.

2. Place a selection reference point.    This is the point about which the components will be aligned, 
either horizontally or vertically.

Without selecting a selection reference point, the alignment and component spacing options are 
grayed.

3. Select the command Edit Align Components.      The Edit Align Components dialog appears.

4. Select either horizontal or vertical alignment.

5.      To align the components with equal spacing, check the Space Equally checkbox and enter the 
Spacing value.    The spacing value is the distance between the reference points of the 
components.

6.      Press OK and the selected components will be aligned.

To Align Components To Grid
1. Select the components to align to grid.    Only components can be selected for this command to 

be enabled.

2. Select the command Edit Align Components.      The Edit Align Components dialog appears.

3.      Press OK and the selected components will be aligned to grid.    Each selected off-grid 
component will be moved to the nearest grid point.



Wide Line Routing
This pass routes all specified Wide Line nets before executing other passes.    Specify wide line nets by 
adding the AUTOROUTEWIDE attribute to them.    The Wide Lines Routing pass makes horizontal or 
vertical connections only and uses any enabled layer.    If you require a wide line that is not horizontal or
vertical, pre-route the line in PCB using the desired width.    Quick Route maintains this width.

All routing of wide lines is based on the same grid selected for routing single lines.    To guarantee the 
correct clearance, it is necessary for the wide lines to occupy more than one grid point.

When Quick Route performs a clearance check on pre-routed connections, it uses the actual width of 
the line in its calculations.    If Quick Route can't complete the net in the remaining routing passes.

To route the Wide Line nets:

1. Run the board through QuickRoute with only the Wide Lines routing pass enabled.    Disable all 
other passes.

2. If QuickRoute cannot complete the Wide Line nets, finish routing these nets manually using PCB.

3. Run the board though QuickRoute again; this time enable all routing passes.    Disable the Route 
Cleanup and Via Minimization post-routing passes until all nets on the board are completely 
routed.



Horizontal
This completes simple connections on any layer selected with a horizontal bias, with no vias and 
minimal deviations from a straight, horizontal line.



Vertical
This completes simple connections on any layer selected with a vertical bias, with no vias and minimal 
deviations from a straight, horizontal line.



L Routes (1 via)
This pass is formed by the intersection of two lines and one via, forming an L.    The lines have minimal 
deviations from their center lines and may be placed on any two enabled layers with opposite bias 
(horizontal and vertical) The L can have any orientation.    Lines are placed no more than 100 mils 
outside the rectangle defined by the two endpoints in the connection.    Although the pass is enabled by 
default, it is automatically disabled if at least two layers are not set to route in opposite directions (i.e., 
horizontal and vertical).



Z Routes (2 vias)
This pass is formed with three lines and two vias, forming an orthogonal Z shape.    The Z can have any 
orientation    Lines are placed no more than 100 mils outside the rectangle defined by the two endpoints 
in the connection.    Although the pass is enabled by default, it is automatically disabled if at least two 
layers are not set to route in opposite directions (i.e., horizontal and vertical).



C Routes (2 vias)
This pass is formed with three lines and two vias, forming a C.    The C can have any orientation    The C
route is more flexible than the L or Z routes; it allows lines to be placed more than 100 mils outside the 
rectangle defined by the two endpoints in the connection.    Any enabled layers may be used to 
complete the C route.    Although the pass is enabled by default, it is automatically disabled if at least 
two layers are not set to route in opposite directions (i.e., horizontal and vertical).



Any Node (2 vias)
The previous passes attempted to route only the optimized connections (the set of connections for a net
that would minimize the total line length).    To attain the highest possible number of completed 
connections, the Any Node pass analyzes each net and attempts to make a connection between any 
nodes in the net.



Maze Routes
This pass attempts optimum connections only (rather than any node in a net).    This pass is not 
restricted by line orientation.    It allows the line orientation to differ from the standard orientation of lines 
on the board layer, to make turns, and to double back.

The Maze pass inserts vias, as required to complete a connection.    Specify the maximum number of 
vias that are allowed for each connection.    The default is 10.

The lines generated by the Maze pass can block channels that you may need to hand-route remaining 
lines.    If so, you might consider an iterative approach; run the board through Quick Route with maze 
routing disabled, hand-route the desired lines in PCB, and then re-route with Maze routing enabled.



Any Node (maze)
This pass uses the same routing strategy as the Maze pass.    The Maze pass attempts to route only the
optimized connections.    The Any Nodes (Maze) pass attempts to obtain the highest possible number of
completed connections by analyzing each net and attempted to make a connection between any nodes
in the net.



Route Cleanup
This pass is included to improve a board's aesthetics and manufacturability.    The autorouter 
intentionally hugs lines during routing for efficiency and higher completion rates.    The Route Cleanup 
pass re-routes some of the lines to eliminate extra jogs where possible.    This pass uses the concept of 
copper sharing to combine lines in the same net.    The reduction in line segments has the added benefit
of reducing the size of your design file.    



Via Minimization
This pass attempts to reduce the number of free vias.    During this pass, Quick Route checks all the 
lines connected to each free via.    If the lines can be swapped to another enabled layer without violating
the design rules, they are swapped and the via is removed.

This pass doesn't affect pads.    If you want to ensure that all pre-routed vias remain intact, disable this 
pass or use a through-hole pad instead of a via for connecting pre-routed lines on opposite signal 
layers.



ACCEL ASCII Files
A file filter in the List Files of Type listbox in the File Open dialog and the Save File as Type listbox in 
the File Save dialog reads ASCII input.    The new file filter is ASCII Files (*.pcb), and it will read and 
write ACCEL ASCII files. 

If ACCEL ASCII Files is selected in the file type listbox of the File Save As dialog, a ACCEL ASCII file is 
generated instead of a PCB binary file.    The output file is a complete design file,and it contains all 
design data represented in a PCB binary file.    A description of the ACCEL ASCII format can be found in
the file ASCII.WRI.

Errors and warnings generated while loading an ASCII file are written to a file named <design-
name>.log, which is automatically displayed using the Microsoft Windows Notepad application.

ASCII File Save and File Save As use a temporary file for file generation.    The file is named <file>.pc$,
where file is the is the name you specify in the File Save As dialog or the current design name if you are
using the File Save dialog.    If the you cancel the save process or it is interrupted by an error condition, 
the temporary file will contain the ASCII contents written up to the point where the process was 
terminated.



Simaltaneous Class Routing
Simultaneous Net Class Routing indicates whether the ACCEL PRO Route autorouter will route all 
design net classes simultaneously, or route each class in sequence. Simultaneous routing is useful if 
signals routed during the first passes are prone to block channels necessary for routing subsequent net 
classes.

A net class is a collection of nets whose attributes cause the router to route that group of nets together.  
For example, several nets having identical WIDTH and VIASTYLE attributes attached would be viewed 
as a distinct net class by the PCB autorouter.    These nets would be routed in separate passes from 
other net classes if Simultaneous Class Routing is not enabled.    If the option is enabled, all net 
classes are routed in all passes.    The net classes chosen by the autorouter are listed in the router log 
file.

To enable simultaneous class routing, select the Simultaneous Class Routing checkbox in the Route 
Autorouters dialog.    The default for this option is "off" since not all boards benefit from simultaneous 
routing.    Simultaneous routing requires significantly more system memory, and is slower than 
sequential pass routing.    Memory usage and the time to complete a route increase directly as the 
number of net classes increase if this option is checked.

This option is recommended for designs where the Fanout or other route pass places a route for one 
net class that blocks the router from placing a route for a subsequent net class. Some designs will route
with higher completion rates and fewer vias when using the Simultaneous Class Routing option.



Routing and Via Grids
When the routing grid selection is set to Auto Grid, the via grid will be equal to the routing grid.

If you manually enter a non-uniform routing grid (Auto is not selected), the via grid used is a multiple of 
the sum of non-uniform grid values.      Normally, the multiple is one, but you can set this to be a multiple
value greater than one.      For example, a routing grid of 16.7 16.6 16.7 mils will cause the router to set 
the via grid to the sum of 16.7 16.6 and 16.7: a 50 mil grid.    In this example, a multiple of 2 sets the via 
grid to 100 mils.

The router may offset the routing grid in order to increase routing completion.    The design's relative 
grid origin will be updated by the router to reflect this offset.      Switch to relative grid mode to make 
further editing changes to the design.    



Utils Reconnect Nets
The Utils Reconnect Nets command uses the current design netlist to re-establish the net information 
for copper traces, arcs, pads, polygons, and vias having point-to-point routes to copper in an existing 
net.    When you run this command, the Reconnect Nets dialog appears.

This command is like the Reconnect Copper option within the Load Netlist command, except that it 
uses the current design netlist information instead of an external netlist file.    

Point-to-point routing is not required.    Routes that are physically connected but not point-to-point 
routed are indicated by a connection (blue-line).    

Shorted nets are indicated in the logfile with a warning.    These nets are not merged.    



Cutout
A cutout is a polygonal, void area for copper pours which will not be filled with copper when the pour is 
flooded.    Cutouts do not affect solid polygons or keepout polygons.    Cutouts are recognized only by 
copper pours.



Options Net Classes
The command lets you define a group of nets that share common rules. Collections of nets sharing the 
same rules are referred to as a net class.      

When you click the Net Classes button, the Net Classes dialog appears. 

This class editor allows you to create named net classes using pre-defined clearance rules or pre-
defined SPECCTRA autorouter clearance rules and then assign nets to that class.    You can also add 
user-defined attributes to the net classes for your own use.

For net classes, you can specify general clearance rules.    These rules can be further refined by 
specifying clearance rules for pairs of objects, like pad to pad clearances or line to via clearances.        

Net classes are transferred from the Schematic design to PCB via the ACCEL-format netlist.

The net class information is written to binary and ASCII design files.      P-CAD does not support Net 
Classes so this information is lost when exporting an ACCEL design to P-CAD format.

To create named net classes:

1. Enter a class name in the Classes box.

2. Click Add.

3. Select unassigned nets and click the Add button (bottom of dialog) to add the nets to the class.

4. Use the Edit Attributes button to assign one or more attributes to this new net class.    (Refer to 
the Edit Nets command section for details.)



Edit Move by RefDes
This command allows you to select and move a component by entering its reference designator, without
knowing where the component is located in the design.    

When you run this command the Edit Move By RefDes dialog appears:

To move a component:

1. Enable the Select tool.

2. Select a reference designator from, or type a value in, the RefDes drop down combo box.    The 
list contains all reference designators in the design.

3. Click OK.

The cursor appears as a crosshair shape.    

4. Move the cursor to the workspace location where you want to place the component.    

5. Click to move it to the new location.        

You can click down to make a ghost, then drag and drop (release) to place it more accurately.    To
cancel ghosting (and moving) of a component, click the right mouse button.



Net Tab
A number of objects have net information appearing on a Net tab with the objects Properties dialog.    
This section describes the information you will find on the Net tab.

Net Name
The Net Names box contains the name of the net associated with this pad.

Nodes Listbox
The Nodes listbox contains the names of all nodes in the net associated with this pad.

Layers Listbox
The Layers listbox contains the names of all layers associated with this net.

Connection Lengths
This area shows the Manhattan length, the Selected length, and the Total lenght of all connections in 
the net.    The Manhattan length is an approximation of the final routed length of a diagonal connection.

It only measures the X and Y distances, not depth (such as via length to another layer).    Arc length is 
included (accurately) in the calculation of connection lengths.    

Copper Lengths
This area shows the the Selected length and the Total lenght of all copper in the net.    

It only measures the X and Y distances, not depth (such as via length to another layer).    Arc length is 
included (accurately) in the calculation of    copper lengths.    

Counts
The Counts area counts the following objects in the selected net:

Arcs
Lines
Pads
Polygons
Copper Pours
Vias

Net Attrs Button



When you select the Net Attrs, the Attributes dialog appears.

This dialog show a collection of net attributes for the selected net.    You can add, change, edit and 
delete attributes for the net.

For details about this function and a complete listing of attribures, see the Edit Nets command below.



DRC Error Indicator Properties
Allows you to view DRC Error Indicator Properties.    Each indicator represents an error or violation 
detected in the design rule checking pass (Utils DRC). 

Generating DRC Error Indicators
To generate DRC error indicators:

1. Use the Options Display command to display DRC error indicators.    Click Misc... and click the 
Show radio button in the DRC Errors Area.

2. Run the Utils DRC command.

Selecting DRC Error Indicators
1. Use the Options Block Selection command to include only DRC error indicators in a block select

2. Run Edit Select to perform the block select.

Viewing Properties
1. Select DRC error(s) either individually or through a block select.

2. Choose Edit Properties to display the Error Properties dialog.

3. The dialog is view-only, therefore you are limited to reading error information, or scrolling through 
the errors if you have selected multiple errors in the design.

Use the Next and Previous buttons to scroll forward and backward through the errors.



Route Interactive
Allows you to run the interacting routing tool.    The interactive routing tool provides obstacle avoidance, 
copper hugging, and intelligent route completion.

Not available for ACCEL TangoPCB.

Routing Connections
To route connections, follow these steps:

1. Select the Route Interactive tool from the menu or from the tool bar.

2. Pick a connection to route.    The end closest to the cursor becomes the source point; the other 
end becomes the destination point.

3. The Interactive Route tool rubberbands uncommitted copper with the proper net width and 
clearance from the source point to the position of the cursor in the current ortho mode.    The 
rubberbanding copper tracks around obstacles, maintaining the proper clearance for that net, 
from the point of origin to the cursor position.    

While you are moving the cursor, a connection rubberbands from the cursor to the second node 
of the connection, indicating what remains to be routed.

4. When you click a coordinate that is not the destination node, the previously uncommitted lines are
placed on the board.    

5. Continue this process until you click on a node that is the other end of the rubberband (this could 
be a pad, via, line, arc, polygon or copper pour island).    

If the node clicked on is a termination point for the connection, the route completes automatically 
and you are now free to choose another connection to route or cancel the tool.

Changing Layers
Changing layers adds vias in the same manner as is done with the manual route tool except that once 
you switch to a new layer, the Interactive Route tool recalculates its internal data structures to reflect 
obstacles on the new layer.    

Blind and buried vias are handled as they are with the manual router.    Changing layers while on a 
through hole pad simply changes layers (if the hole range allows it).

Backtracking

Committing a straight line segment on top of another straight line segment, so called backtracking, acts 
as an erase operation and the intersection (in the mathematical sense) of the two lines is removed.    
Vias cannot be erased with backtracking.    The user has to perform an unwind operation.

Unwinding 

Any segments or vias that are committed can be uncommitted by pressing the Backspace "" key or 
running the Unwind command from the right mouse popup menu (see below).

Slash Key

Routing can be suspended by pressing the slash "\" or "/" key and the unrouted portion becomes a new 



connection from the suspension point to the end node.

Vias, Layers and Line Widths

You can select vias, layers and line widths during the routing operation through the Options menu or the
appropriate hot keys.

Net Attributes
The net attributes WIDTH, VIASTYLE, CLEARANCE, PADTOPADCLEARANCE, 
PADTOLINECLEARANCE, LINETOLINECLEARANCE, VIATOPADCLEARANCE, 
VIATOLINECLEARANCE, VIATOVIACLEARANCE will be honored given the appropriate net class 
hierarchy.

Copper Pours
Copper Pours affected by new copper generated by this tool will autoplow when the route Completes 
or Suspends.

Placing Arcs
Arcs can be placed, but obstacle avoidance and hugging are disabled.

Pop-up Menu
Click the right mouse button to display the following popup menu:

The following section summarizes the commands which appear on the pop-up menu:
Complete autoroutes the remaining portion of the route. 
Suspend, equivalent to the "slash" key, leaves the unrouted portion as a connection.
Cancel undoes all routing actions and puts the original connection back.    The Interactive Route 

tool remains active.    
Pressing Esc is the equivalent to selecting Cancel from the right mouse popup menu.    
Layers executes the Options Layers command. 
Via Style executes the Options Via Style command.    
Unwind removes the last line or via that was committed.

The following keys are recognized during the routing process:

Enter Same as left mouse, commits the current routed series of lines.

Esc Cancels the entire routing process and returns to connection selection mode.

/ or \ Stops routing the connection and leaves remaining, unrouted portion as a connection.

Backspace Undoes the last segment placed.



O Cycles the current ortho mode.

F Flips the current ortho mode.

 Rerouting Lines
The routing of existing lines is supported by the Interactive Route tool as described above except that 
once the operation is completed, the tool waits for another line to be selected.    

The popup menu behaves the same as when routing connections.

T-Route to Vias
You can use the Interactive Route tool to T-Route into vias that are part of the net that you are routing.    
To do so, route up to the via, then run the Suspend command.



Edit Alter Components
Allows you to select certain component items and subsequently move, rotate, flip, and (in some cases) 
delete them.

With this editing process, you can alter certain component characteristics either for aesthetic reasons or
manufacturing improvement, such as avoiding any co-location problems during manufacturing (e.g., 
through-holes and silkscreen paint).    The rules/restrictions are as follows:

Pads cannot be selected, and therefore cannot be edited in any way.
The RefDes, Type, Value and Ref Point (reference designators and reference points) cannot be 

deleted.    
If you want to hide the RefDes, Value, or Type, modify the component (Edit Properties command),

and disable the Visibility options.    To hide Glue Dot and Pick and Place points, disable their respective 
display options in Options Display (Misc).

You cannot undo any alter actions until the operation is complete.

Altering a Component
1. Run the Edit Select command to select the component.    Then run the Edit Alter Component 

command.    

You are now in a temporary editing mode, signified by the crosshair cursor shape.

2. Zoom in sufficiently.    Change layers if necessary.    You can select items individually only if you 
are on the correct layer, otherwise you need to use a block select.    The settings in Options Block 
Selection can affect your results here.

Editable items typically reside on the Top Silk layer, except for Ref Points, which aren't layer 
items, but this depends on how the pattern was originally created.

3. After you have selected individual item(s), you can then move, delete, or otherwise alter them 
(according to the restrictions mentioned previously).    Press Esc or click the right mouse button to
end the editing mode.

note:
You can also use the Sub Select command to select and modify a single part of a component.



ACCEL TangoPCB Features
ACCEL Tango PCB is a Windows-based printed circuit board design system without the full range of 
advanced design features available with ACCEL P-CAD PCB.

Differences between the two products have been noted throughout this manual with the symbol you see
in the left margin.    The following chart provides a summary those differences:

Maximum number of components 400

Maximum number of layers 4 user-defined
15 total

Copper pours only one with up 
to 32 vertices.    
90 thermals, 
backoff amount 
restricted to 1 per 
layer.

Unsupported objects cutouts
pick and place 
points
glue dots

Route Miter unsupported

Route Interactive unsupported

Rotation Increment 90 degree only

DBX modify functions unsupported

Pin and Gate Swapping unsupported

On-line DRC unsupported

Split Plane unsupported

Dimensioning unsupported

ECOs Was/Is only



Opening a P-CAD Binary File
To load a P-CAD binary file, follow these steps:

1. Choose File Open. The Open dialog appears.

2. At the List Files of Type field, select .pcb Files as the desired file type.

3. In the File Name box, enter the name of the desired .pcb file or select it from the file list.

4. Click OK.    PCB automatically detects that youre loading a P-CAD binary file and displays the P-
CAD to ACCEL PCB Layer Mapping dialog.

5. At the P-CAD to ACCEL PCB Layer Mapping dialog box, select the appropriate layer mapping 
assignments.    For details about mapping layers, see the section Mapping Layers from P-CAD 
Binary and PDIF Files to PCB.

6. Specify a tool table by clicking the Tool Table button.    The Tool Table dialog box appears,

At this dialog box, select the desired tool table (.tbl) file and click OK.    PCB returns you to the P-
CAD to ACCEL PCB Layer Mapping dialog box.

PCB requires the tool table file because it contains hole size information that the P-CAD file does 
not have.    You specify the tool table file to use at the tool table dialog box.    If you do not specify 
a tool table file, PCB assigns two default hole sizes for you. The sizes are 20 mils for pads and 10
mils for vias.

If you load the design without specifying a tool table file, you must edit the hole size of all pad and
via styles that have a hole size other than 20 mils and 10 mils.    To change these sizes, open the 
pcb.ini file, go to the [PDIF] section, and edit the entries DefaultPadHoleSize and 
DefaultViaHoleSize.
If a tool table file is specified but you do not want to load it, uncheck the Use Table checkbox.    
PCB uses the default hole sizes instead.

7. Specify the Cross Reference file to use using the PDIF Cross Reference button.    The Cross 
Reference file contains power and ground pin assignments and attempts to group heterogenous 
components.

8. Specify how you want PCB to convert polygons by selecting Copper Pour or Polygon.

You can convert polygons to copper pours or use them as polygons.

Select Copper Pour because these polygons can have cutouts (voids) and backoff from pads.      
Also, if you have padstacks with void definitions, you should select Copper Pour.
The only time you might want to select Polygon is if the P-CAD polygons have no cutouts (voids)
in them.    A P-CAD polygon with a void that is imported as a PCB polygon has the same net 
information.    However, voids are ignored, which may cause a shorted board.

9. Specify how you want to convert the pad definitions.    You can either convert them from the 
Embedded Aperture Table or from the designs Pad Graphics.

The polygon aperture shapes and the Aperture macros are not supported.

Select Embedded Aperture Table to take full advantage of the aperture shapes and sizes.    You 
should select Pad Graphics only if you dont have an aperture table embedded in your design.

10. Click OK.    PCB loads the selected .pcb file.

While loading, PCB displays several messages, indicating the systems progress.    After PCB 
loads the file, a message box appears indicating if there were any errors or warnings.    If there 
are none, you can click OK.

If there are errors or warnings while loading the file, PCB creates a log file design-name.log, 



where design-name is the name of the P-CAD binary file you loaded.    In this case, a dialog box 
appears, prompting you to view the log file.    PCB displays the log file using the viewer selected 
with the Options Configure command.    The default viewer is Notepad.

It is a good idea to examine the log and correct any errors that show up. For details about any 
problems that could occur, see Appendix B, P-CAD System Messages.



Master Designer Command Reference
The following lists maps Master Designer commands/operations with their equivalent PCB commands, 
where equivalents exist.    

The bolded terms on the left are the Master Designer commands, followed by their respective 
equivalent PCB commands/operations, which are non-bolded and indented.

For example:

Master Designer command
Equivalent ACCEL PCB V2.00 Command/Operation

For more information on specific PCB commands, refer to their respective sections by way of the 
Contents or Search buttons in this on-line system.    

Legend:    >    = Sub-command or sub-selection

To obtain the ACCEL command equivalent click one of the following topics:
Master Designer Editors
Master Designer Utilities
Schematic Tools
Interfaces
System Configuration
Schematic Editor Configuration



Master Designer Editors
Align > Components

Edit > Align Components (PCB)

Align > Objects
Edit > Shift Select, then Edit > Align Components

Align > Window
Edit > Select by window, then Edit > Align Components

Align > Undo
Edit > Undo (or the U key)    to undo last operation

Change Layer (Expand Def.)
Edit > Move to Layer

Chg. Layer > Component
Edit > Select component, change to the identified layer (Top, Bottom, etc.) and use the F key to flip 
the component to that layer

Chg. Layer > Object
Edit > Move to Layer

Chg. Layer > Objects
Edit > Shift Select, then Edit > Move to Layer

Chg. Layer > Window
Edit > Select a window, then Edit > Move to Layer

Copy      > Object
Edit > Copy or Ctrl + Left Mouse Button (Drag & Drop)

Copy > Object> Repeat
Edit > Copy Matrix

Copy > Objects
Edit > Shift Select, then Edit > Copy Matrix or Ctrl + Left Mouse Button (Drag & Drop)

Copy > Trace
Edit > Copy Matrix or Ctrl + Left Mouse Button (Drag & Drop)

Copy > Window
Edit > Select a window, then Edit > Copy Matrix or Ctrl + Left Mouse Button (Drag & Drop)

Critical. Path > Add Gate
not applicable 



Critical. Path > Break Link
not applicable 

Critical. Path > Change Name
not applicable 

Critical. Path > Remove Definition
not applicable 

Critical. Path > Remove Gate
not applicable 

Delete > Object
Edit > Select, then Edit > Delete (or the Delete key)

Delete > Objects
Edit > Shift Select, then Edit > Delete (or the Delete key)

Delete > Trace
Edit > Shift Select to select individual copper segments, then Edit > Delete (or Delete Key) to delete
the selected copper segments.    To delete the entire net, Edit > Select a net segment, click the right
mouse button to bring up the Pop-up Menu > Select Net, then Edit > Delete (or the Delete Key).

Delete > Undo
Edit > Undo (or the U key)    to undo last operation

Delete > Window
Edit > Select a window, then Edit > Delete (or the Delete Key) [Items can be masked before 
selection by using the Options > Block Selection]

Dimension
Place > Dimension

Display > Measure
Edit > Measure

Display > Control Ratsnest
Edit Nets > Select by Node Count

Display > Long Pan
not applicable 

Display > Path/Group Visibility
not applicable 

Display > Recall View
not applicable 



Display>Store View
not applicable 

Draw > 2 Point Arc
Place > Arc

Draw > 3 Point Arc
Place > Arc

Draw > Line
Place > Line

Draw > Polygon
Place > Polygon

Draw > Polygonal Void
Place > Cutout (Doesn't Clear a Placed Polygon, used for Copper Pour)

Draw > Text
Place > Text

Draw > Circle
Place > Arc

Draw > Circular Void
Place > Cutout (Doesn't Clear a Placed Polygon, used for Copper Pour)

Draw > Filled Circle
not applicable Draw > Filled Rectangle

Place > Polygon

Draw > Flash
Options > Pad Style, then Copy Default pad style and select Modify (Simple) or Modify (Complex) 
to create a new pad style (pad stack)

or

Options > Via Style, then Copy Default via style and select Modify (Simple) or Modify (Complex) to 
create a new via style (pad stack)

Draw > Rectangle
Place > Polygon

Edit    > Add Via
Place > Via

Edit > Add Vertex
Route > Manual



Edit > Attribute
Edit > Select a component, then Edit >Properties    > Comp Attrs or Part Attrs

Edit > Delete Segment
Edit > Select a copper segment, then Edit > Delete (or the Delete key)

Edit > Delete Trace
Edit > Shift Select to select individual copper segments, then Edit > Delete (or Delete Key) to delete
the selected copper segments.    To delete the entire net, Edit > Select a net segment, click the right
mouse button to bring up the Pop-up Menu > Select Net, then Edit > Delete (or the Delete Key).

Edit > Delete Vertex
Edit > Select vertex to be removed, then drag to closest remaining vertex.

Edit > Delete Via
Edit > Select a via, then Edit > Delete (or the Delete Key)

Edit > Keyword
File > Design Info > Attributes or Pop-up Menu > Properties.

Edit > Move All
Edit > Select and Drag copper vertices or vias

Edit > Move Segment
Edit > Select and Drag copper segment

Edit > Move Vertex
Edit > Select and Drag copper vertex

Edit > Move Via
Edit > Select and Drag via (will move attached copper segments)

Edit > Net Attr
Edit > Nets and select a net from the list. then click on the Edit Attrs button or

File > Design Info > Attributes

Edit > Packaging Data (Symbol Mode)
Utils > Library Manager > Pattern View

Edit > Pin Type (Symbol Mode)
not applicable (See Pad Style)

Edit > Segment Layer
Edit > Move to Layer

Edit > Trace Width
Edit > Select, then Edit > Properties



Edit > Undo Delete Segment 
Edit > Undo (or the U key)    to undo last operation (The backspace key can be used to unwind trace
& line segments)

Edit > Wire
Route > Manual

Enter > Component (PCB Editor)
Place > Component

Enter > Polygon
Place > Copper Pour

Enter > Wire
Route > Manual

Enter Attribute
Place > Attribute

Enter > Board Origin 
not applicable 

Enter > Component Type
Place > Attribute Type keyword

Enter > Jumper (Symbol Mode)
not applicable 

Enter > Non homogeneous Pkg (Symbol Mode)
Utils > Library Manger

Enter > Pin Sequence (Symbol Mode)
Utils > Renumber (Accomplished before Library > Library > Pattern Save As

Enter > Pin Type (Symbol Mode)
See Pad Style

Enter > Ratsnest
Place > Connection

Enter > Replace Component
Edit > Select a component or group of like components, then Edit > Properties > Type, to change 
the selected component to another type from the loaded library (PCB Only)

Enter > Uncommitted Pin
Edit > Select Connection to pin, then Edit > Delete (or the Delete key)

Environ.. > Polygon Wire Clearance



Edit > Select copper pour, then Edit > Modify    Copper Pour - Pour Backoff

Environ. > Merge Voids by Layer
Using Options > Block Selection to mask everything except Copper Pours, Edit > Select all Copper 
Pours on a layer (Edit > Shift Select or Edit > Select a window), then select the Pour Radio Button

Environ. > Merge Voids by Poly
Edit > Select Copper Pour, then Edit > Modify and select the Pour Radio Button

Environ. > Set Minimum Aperture
not applicable 

Environment > Display Statistics
File > Design Info > Statistics

Environment > Mask Items
Options Block Selection

Environment > Assign Layer Pairs
not applicable 

Environment > Attach Padstacks 
not applicable 

Environment > Change Units
Options > Configure > Units

Environment > Detail Mode
Not necessary

Environment > DOS Shell
Not necessary

Environment > Edit Aperture Table
File > Gerber Out, then select Apertures button

Environment > Min. Polygon Size 
Edit > Select > Copper Pour > Properties > Island Removal Dialog box

Environment > Set Snap Tolerance
Option > Preferences > Mouse > Cycle-Picking Threshold

File > Level Pop
not applicable PCB (See Part & Pattern Creation in the Editors)

File > Clear Database
File    > Clear (or File > New)



File > Create Plot File & Hardcopy > Print/Plot or Windows Plot Utility
File    > Print (Ctrl + P)

File > Level > Push
Edit > Explode Components & Utils > Library Manager

File > Load
File    > Open (Ctrl + O)

File > Load Block
Edit > Paste from File

File > Print 
File    > Reports

File > Save Block
Edit > Copy to File

File Quit
File    > Exit

File Save
File    > Save (Ctrl + S)

Fit View
View > Extent

Group > Add Gate
not applicable

Group > Change Name
not applicable 

Group > Remove Definition 
not applicable 

Group > Remove Gate
not applicable 

Chg. Layer > Component
Edit > Select Component , then use the F key to flip

Improve Plc    > Components
not applicable 

Improve Plc > Gates
Utils > Optimize Nets



Last View
View > Last

Move > Attribute
Edit > Alter Component(PCB)

Move > Component
Edit > Select, then Drag component

Move > Critical Path
not applicable 

Move > Group
not applicable 

Move > Object
Edit > Select, then Drag Object

Move > Objects
Edit >Ctrl Select, then Drag Objects

Move > Undo
Edit > Undo (or the U key)    to undo last operation

Move>Window
Edit > Select window, then Drag Objects

Name > Component
Automatically named

Name > Net
Edit > Nets > Rename

Name > Pin (Symbol Mode)
See Part & Pattern Creation in the Editors

Name > Reseq. Ref. Des. 
Utils > Renumber > Ref Des Radio Button

Name > Reseq. Window
Utils > Block Selection to mask everything but specific components, then Edit > Select Window & 
Utils > Renumber

Pan (Shift + Mouse Button 1)
View > Center (C key)

Pan > Enter Coordinates into status line
View > Jump Location



Placement > Automatic Placement
not applicable

 Placement > Define Barriers > Delete
not applicable

 Placement > Define Barriers > Delete
not applicable

 Placement > Define Barriers > Enter
not applicable

 Placement > Define Lattices > 
not applicable

 Placement > Define Lattices > 
not applicable

 Placement > Define Lattices    > Enter Spacing
not applicable

 Placement > Define Lattices    > Specify Clearance
not applicable

 Placement > Enter Cutlines
not applicable

 Placement > Fix > Component
not applicable

 Placement > Fix > Window
not applicable

 Placement > Histogram > Configure
not applicable

 Placement > Histogram > Define Grid
not applicable

 Placement > Histogram > Generate Statistics
not applicable

 Placement > Histogram > Reset Merit Factor
not applicable

 Placement > UnFix > Component
not applicable



 Placement > UnFix > Window
not applicable

 Query      > Component - By Name
Edit    > Components > Jump

Query Net > By Name
View    > Nets > Jump To Node

Query > Apertures
File > Gerber Out, then select Apertures button

Query > Component
Edit>Select, double-click on a Component or Edit Select Component and choose Properties from 
the Pop-up Menu (Right Mouse Button)

Query > Critical Path
not applicable

 Query > Group
not applicable

 Query > Net
Edit > Select, double-click on a Net or Edit Select Net and choose Properties from the Pop-up Menu
(Right Mouse Button)

Query > Net Pins
not applicable

 Query > Net Vias
not applicable

 Query > Object
Edit > Select double-click on an object or Edit Select an object and choose Properties from the Pop-
up Menu (Right Mouse Button)

Query > Padstack
Edit Select Component, then Edit > Modify    > Pins > Edit Style > Modify (Simple) or Modify 
(Complex)

Query > Pin
Edit > Select, Component, then Edit > Modify    > Pin

Query > Polygon
Not necessary

Query > Polygon Window
Not necessary



Query > Trace
Edit > Select copper segment, then Edit > Nets > Info (provides length of entire copper and length 
of remaining connections)

Query > Via
Edit > Select via, then Edit > Properties

Recall View
not applicable Redraw

View    > Redraw

Rotate > Component
Edit Select a component, then use the R key

Rotate > Object
Edit Select an object, then use the R key

Rotate > Objects
Edit Select a window, then use the R key

Rotate > Undo
Edit > Undo (or the U key)    to undo last operation

Rotate > Window
Edit Select a window, then use the R key

Swap > Component
not applicable

 Swap > Gate
Utils > Optimize Nets > Manual or Auto Gate Swap

Swap > Pin
Utils > Optimize Nets > Manual or Auto Pin Swap

Swap > Undo
not applicable PCB for Utils > Optimize Nets > Automatic, but can use Edit > Undo for Utils > 
Optimize Nets > Manual

View Layer
Options Display

View Window
View    > Zoom Window (Z Key)

>Merge Polygon Voids
Edit > Select a polygon pour, then Edit > Properties      > Poured Radio Button





Master Designer Utilities
Design Maintenance

not applicable in    

System Configuration
Options > Configure

Report Generator
File > Reports

Netlist Comparison
Utils > Compare Netlist 

Engineering Change Order ~ Back Annotate 
Export ECOs (Back Annotate)

Report Editor
Not Necessary.    Reports can be directly output to the screen or a user preferred file viewer can be 
selected in Windows to view previously generated reports.



PCB Tools
Editor Configuration

Options Menu

PCB Editor
ACCEL PCB

Autorouter
Route > Autorouters

Design Rules Check
Utils > DRC

SPECCTRA Router
Route > Autorouters > SPECCTRA

PDIF File Reader
File > PDIF In

PDIF File Writer
File > PDIF Out

Hardcopy or Windows Plot Utility
File > Print or File > Gerber Out

Report Generator
File Reports 

Drill
File N/C Drill 

Auto-Insertion
See Place > Point > Pick and Place or Glue Dot

Netlist Conversion
Utils > Load Netlist (.ALT Format)

EZPlot
File > Print or File > Gerber Out

Report Editor
Not Necessary.    Reports can be directly output to the screen or a user preferred file viewer can be 
selected in Windows to view previously generated reports.



Interfaces
Add Program

Not required under Windows, use ALT - TAB

SPICE Circuit Writer
Utils > Generate Netlist > PSpice

Viewlogic Interface
See Viewlogic Interface

EDIF Netlist Writer
Utils > Generate Netlist > EDIF 2.0

DXF File Reader
File > DXF In

DXF File Writer
File > DXF Out

Report Editor
Not Necessary.    Reports can be directly output to the screen or a user preferred file viewer can be 
selected in Windows to view previously generated reports



System Configuration
Text Editor

User Defined File Viewer

Printer Port
File>Print Setup



PCB Editor Configuration
Rotate Padstacks (check box)

not applicable

Rotate Text in Four Directions (check box)
not applicable

Allow Adding Uncommitted Pins (check box)
Not Required - a connection between pins must be defined before user can connect a wire to a 
component pin

Use Display List (check box)
not applicable

Display Trace Length (check box)
not applicable

Auto Clear Flash (check box)
Not Required - Automatic

Load Active PCB (check box)
not applicable

On-line DRC (check box)
Options > Configure > On-line DRC (check box)

Display Verbose Warnings (check box)
Not Required

Dynamic Ratsnest Display (check box)
Options > Configure > Connection Options (check box)

Edit Design Rules File
not applicable - Integrated into PCB Design File

Edit Check Pass File
not applicable - Integrated into PCB Design File

Function Key Filename:
Options > Preferences > Keyboard

Auto Save Configuration
Options > Configure > Autosave

Pin Size:
not applicable (see explanation of Pad definitions)



Via Size:
not applicable (see explanation of Pad definitions)

Flash Size:
not applicable (see explanation of Pad definitions)



Sub Select Command
The sub select feature lets you select a single part of an object.    Once selected, you can view and, in 
some cases, modify properties for the item selected.    Certain silk items can be moved, rotated, and 
flipped.

For example, you can select a component pad and bring up a Properties dialog for that pad.    Then you 
can change the pad style for the selected pad.    

note:
You can use the Options Preferences Mouse tab to set the Ctrl key as the key to use for a sub 
selection.

Example

To select pad 8 in a 7400 component:

2. Hold down the Shift key and left mouse button, and click the pad.

The pad, and not the entire component, will be selected.

 




