使用说明

快速使用指南

  • 紫光拼音输入法介绍
  • 版本更新说明
  • 安装与卸载
  • Windows系统中的输入法设置
  • 拼音字词输入介绍、全拼和双拼方式输入
  • 紫光拼音输入法的两种输入风格
  • 输入法界面
  • 定制输入法
  • 输入法使用键一览
  • 造词和删词、以词定字、模糊音和特殊输入
  • 紫光拼音输入法的高级智能特性
  • 词库的备份和恢复
  • 快速掌握(适用于高级用户)
  • 疑难解答
© 2001 北京清华紫光软件股份有限公司 版权所有


版本更新说明

紫光拼音输入法2.3版

▲新增和改动功能说明

  • 智能组成的词可以自动记忆到用户词库中(该选项可配置)；
  • 快捷键(Ctrl+下箭头)打开最近输入字词菜单选择输入；
  • 快捷键(Ctrl+上箭头)重复输入最近输入的字词；
  • 双拼输入时显示完整拼音串；
  • 状态条的改进：增加输入法系统菜单按钮，并记忆状态栏位置；
  • 可设置输入栏的中英文字体；
  • 输入中有多个候选字词时，可使用左右Shift或左右Ctrl键(可配置)输入第二、第三候选；
  • 从中文输入状态切换到英文输入状态时，原来已经键入的拼音串作废；
  • 改进的输入法联机帮助文档，便于用户快速掌握输入法以及在使用中获得帮助信息；
  • 对用户词库文件存放进行了调整。

▲修订错误说明

  • 2.2版使用一段时间后，容易发生输入法引擎出错的问题；
  • 对某些模糊音设置，使用无效；
  • 特殊字词和短语的定义，超出限制时出错；
  • 在IE等一些软件中，打开多个窗口并在窗口间切换时，导致输入法失效；
  • 在IE等一些软件中，打开输入法时关闭窗口导致屏幕频繁刷新。

紫光拼音输入法2.2版

▲新增和改动功能说明

  • 增加用户自定义的特殊字词和短语输入(参见自定义特殊字词和短语输入)；
  • 增加用户自定义词的批量导入功能(参见用户自定义词的批量导入)；
  • 改进的常用字词优先方式，增加字频调整的记忆功能和最近用字优先功能；
  • 改进的双拼编码定义，可使用分号“;”定义韵母；
  • 增强用户对功能键的定义功能；
  • 在“输入完拼音，按空格键后再显示汉字”输入模式下，可以直接输入URL和EMAIL地址等英文串；
  • 改进了对Windows 2000的支持(参见在Windows 2000下使用紫光拼音输入法)。

▲修订错误说明

  • 某些应用中打开输入法时，当前窗口焦点丢失问题；
  • Windows 2000下输入法状态栏上弹出右键菜单有时闪烁问题；
  • 某些应用中切换中英文输入并移动光标时，插入点不在光标位置上。

紫光拼音输入法2.01版

▲新增和改动功能说明

  • 英文符号键对应的中文符号可以自定义(参见自定义中文符号)；
  • 数字后面跟随英文符号(包括该选项的设置，参见输入法属性设置的高级设置)；
  • 全拼模式下可以用特殊形式输入中文数字和常用单位(参见特殊输入)；
  • 单字输入时，字频和词频一起调整，即使用中常用字优先(字频仅动态调整，不记录)；
  • 大小写结合状态下输入英文的同时可以输入英文＋数字串，并对大小写结合输入的英文串的长度作了扩充；
  • 增加对回车键功能的定义，回车键可用于直接输入英文串(参见输入设置)；
  • 在输入过程中切换窗口，当回到原窗口后，保留原来的输入状态。


关于紫光拼音输入法

紫光拼音输入法是一个完全面向用户的，基于汉语拼音的中文字、词及短语输入法。紫光拼音输入法是完全免费的(参见用户许可说明)。

紫光拼音输入法的特点：

▲考虑用户输入习惯

  • 既方便初用用户掌握，也充分考虑长期使用拼音输入的老用户的习惯。
  • 提供"输入拼音同时显示字词"和"输入拼音后显示字词"两种输入风格，具有跟随光标功能。
  • 提供全拼和双拼功能，并可以使用拼音的不完整输入（简拼）。双拼输入时可以实时提示双拼编码信息，无需记忆。
  • 支持翘/平舌音、前/后鼻音以及南方口音的模糊输入。
  • 单键切换中英文输入状态。
  • 用户可以任意定义字词和短语进行输入。
  • 大小写结合的英文串可直接输入。
  • 使用特殊输入方便地输入中文数字和常用单位。
  • 使用NumLock方便输入数字和小数点。
  • 为减少在多个重音字中查找，可以使用以词的方式输入字（以词定字）。
  • 用户可自己定义特殊的字词和短语(例如，定义“china=中华人民共和国”)，方便输入。

▲功能强大

  • 大容量精选词库，收录8万多条常用词、短语、地名、人名以及数字，优先显示常用字词，而字词的使用频度（词频〕则从一亿七千万字语料中统计而来。
  • 支持GBK大字符集。
  • 强大的用户自定制功能，用户可定制输入习惯、定制双拼编码、定制输入界面、定制模糊音设置、定制中文符号输入、以及定制输入法的智能特性。
  • 兼容Microsoft Windows95/98/NT中文版，兼容Windows 2000，兼容Microsoft Office、Internet Explorer中文版等系统和应用软件。
  • 支持Windows系统的多用户特性，不同用户可以有不同的输入法设置和各自的词库。
  • 可以备份并恢复用户词库。
  • 用户可以随时删除不再需要的词。
  • 用户可批量导入自定义的词和短语。

▲智能特性

  • 智能组词能力：对于词库中没有的词或短语，紫光拼音输入法可以搜寻相关的字和词，帮您组成所需的词或短语。组词算法同样以一亿七千万字语料的统计信息为基础，组词速度快，准确率高。
  • 词和短语输入中的自学习能力：包括自动造词、动态调整词频、自动隐藏低频词。
  • 智能调整字序，可根据用户前一次的输入情况，动态调整汉字的优先选择顺序。
  • 可以让数字后面跟随输入的符号是英文符号。

▲版本及其它

紫光拼音输入法的前身是李国华先生设计的考拉拼音输入法。紫光拼音输入法2.0版在考拉输入法1.1版的基础上，增加了智能组词、智能字序调整、词库管理、增强的用户定制等功能。
此后，紫光拼音输入法陆续推出2.01版本、2.2版本和2.3版本，进一步改进并增强功能。有关各版本的更新情况参见“版本更新说明”。

紫光拼音输入法有关版本更新和技术支持信息将主要通过Internet上发布，您可以访问紫光拼音输入法主页免费下载紫光拼音输入法软件和相关资料。

紫光拼音输入法主页：
http://www.thunisoft.com/unispim/

紫光拼音输入法E-Mail：
unispim@thunis.com

关于紫光拼音输入法的最新情况说明，以及软件其它相关说明信息，在软件所带的“软件有关说明(Readme)”文档中给出。


紫光拼音输入法用户许可说明

紫光拼音输入法 版本2.3
_______________________

紫光拼音输入法对最终用户是免费的。

北京清华紫光软件股份有限公司(以下简称本公司)拥有紫光拼音输入法的著作权。

以下是本输入法软件的用户许可协议说明：

1. 您可以任意使用和复制本输入法；

2. 您可以将本输入法复制提供给他人，但在未经许可的情况下，不得将本输入法用于商业用途；

3. 本软件受版权保护，您无权对软件的程序和文档进行修改；

4. 对由本公司直接发放的本输入法软件，本公司承诺软件中不含有病毒、逻辑炸弹等危害您的机器和文件的代码，承诺软件中不含有窃取您的私人信息的代码，但经由其它途径发放的软件，不属此列。

5. 本公司对使用本输入法的用户不提供直接的技术支持，但将尽力通过Internet提供帮助信息。

6. 本公司对本输入法的使用不提供任何担保，就衍生性损害不负赔偿责任。


安装与卸载

安装

紫光拼音输入法的安装介质有三种形式：

① zip文件unispim23.zip
你需要首先用WinZip（可到http://www.winzip.com或其他软件下载站点下载）来把该zip文件展开到某个临时文件夹中（约需要4MB空间），然后运行该文件夹下的SETUP.EXE进行安装。

② 三张3.5寸软盘
运行第一张软盘上的SETUP.EXE即可安装，在安装过程中，安装程序会提示你依次插入第二张和第三张软盘。

③ 一张光盘
安装程序会自动运行。如果安装程序由于某种原因没有自动运行，运行光盘上UNISPIM23文件夹下的SETUP.EXE即可安装。

紫光拼音输入法的安装过程中，安装向导将指示您阅读有关信息，并完成安装。安装过程中用户无需输入用户信息，也不需要指定安装在哪个文件夹中。

成功安装后，将在系统的“开始|程序”菜单中，创建子菜单“紫光拼音输入法2.3版”(参见输入法菜单项说明)。

紫光拼音输入法安装后，占据您的Windows系统所在硬盘分区约5M字节的空间。此后，如果您的微机有多个用户使用(且采用Windows系统的多用户特性)，紫光拼音输入法将为每个用户分配约1.5M的硬盘空间用于词库管理，并随着用户自造词的增多而增大(参见输入法的相关文件部分的有关说明)。

安装完毕后，您可以使用输入法切换键切换到紫光拼音输入法，或者从任务栏的输入法指示器图标选择使用紫光拼音输入法。
安装完毕后，您可以使用控制面板中的输入法设置，修改输入法的切换热键等设置。

安装之后的输入法文件参见“输入法相关文件”部分说明。

卸载

如果你想从系统中删除紫光拼音输入法的话，建议您如下操作：
1、在控制面板的“输入法”中删除紫光拼音输入法；
2、在控制面板的“添加删除程序”中删除紫光拼音输入法2.3的程序文件。


Windows系统中的输入法设置

在Microsoft Windows中文版系统中，不同的输入法作为Windows系统中的安装语言进行管理。
使用控制面板中的“输入法”一项功能可以对输入法进行设置；同时Microsoft又将有关输入法设置作为键盘属性中的语言部分，因此可以从控制面板中的“键盘”一项功能中设置一些输入法信息。

输入法设置包括了输入法切换热键的设置和各个输入法各自属性的设置。

切换热键包括语言切换热键、缺省输入法开关热键、全角/半角切换键和中英文标点符号切换键。
语言切换键用于在多个输入法之间循环切换，缺省设置是“Alt+Shift”组合键。

缺省输入法开关键用于打开缺省输入法，缺省设置是“Ctrl-空格”组合键。
全角/半角、中英文标点切换键用于切换不同编码的中英文及标点符号信息（参见标点符号和全角/半角）。

每个输入法的属性设置则由输入法软件各自实现。紫光拼音输入法提供了强大的设置功能。

此外，“启动任务栏上的指示器”选项开启时，可以在任务栏中看到输入法图标，缺省的英文输入状态下是一个语言的图标。

对于紫光拼音输入法的设置参见“定制输入法”。


拼音字词输入介绍

拼音输入

拼音输入是以汉语的标准发音为基础，通过键盘输入，按照发音检索汉字的一种中文输入方式，也是一种比较自然的输入方式。

拼音输入使用键盘中的英文字母替代汉语拼音进行输入，英文字母和汉语拼音基本对应，其中例外的有：

使用v替代拼音中的ü
使用ve或ue替代拼音中的üe

此外，拼音输入时，通常忽略发音中的四声，即输入拼音时不指定读音的声调。

由于汉语中有大量的同音字或同音词，拼音输入时，对同一个拼音串，往往有多个字或词与之对应(多候选字词)，这时需要用户进行选择。

字词输入

字词输入是指以汉字和汉语中的词为单位进行输入。输入过程相当于用户在输入一个字或词并进行确认之后，再输入下一个字或词。

紫光拼音输入法是一个拼音字词输入法，并对拼音字词输入方式进行了扩充（包括采用不完整的拼音串进行输入），同时采用针对字词的智能组合输入等手段，提高拼音输入的速度和方便性。

紫光拼音输入法在输入字词或短语时，一次通过连续的拼音串输入的词或短语不能多于9个汉字。


标点符号和全角/半角

中英文标点符号

中文的标点符号和英文标点符号不尽相同。中文输入法通常同时提供中英文标点符号的输入能力。

当输入法处于中文标点符号输入状态时，键入键盘上的标点符号键，将输入中文标点符号；反之，将输入英文标点符号。

紫光拼音输入法针对中文标点符号以及其它符号，提供了如下的输入方式：
处于中文标点符号输入状态时，通过键盘中的标点符号键输入常用中文标点（参见中文标点符号键表）；
通过软键盘可以输入多种符号（参见软键盘图示）；
此外，您还可以自定义键盘上的符号键所对应的中文标点符号，按照您的习惯进行输入。

注：缺省情况下，紫光拼音输入法使用“/”键输入顿号“、”，而使用“\”键输入除号“÷”，您可以按照您的习惯自定义符号输入。

参见：自定义中文符号。

全角/半角

全角和半角指不同格式的英文字母。
半角格式的英文字母相等于英语状态下输入的英文原始信息。全角格式英文字母和半角英文相比，在编码上不同，外观通常也不同。全角字母采用中文方式的编码，外观上更类似汉字。


安装后的菜单项

紫光拼音输入法成功安装后，将在开始|程序菜单中创建子菜单“紫光拼音输入法2.3版”，包括以下菜单项：

设置属性
设置紫光拼音输入法的可自定义属性。
参见：定制输入法。

帮助
查看紫光拼音输入法帮助信息。

软件说明信息
有关软件最新信息说明，建议使用前先阅读。

紫光拼音输入法主页
浏览紫光拼音输入法主页，查看软件更新信息。

在“自定义”子菜单中，包括：

双拼编码定义
自定义双拼的编码方案。

中文符号定义
自定义英文符号键对应的中文符号方案。

特殊字词和短语输入定义
自定义特殊方式的字词和短语输入。

在“工具”子菜单中，包括

词库备份和恢复
备份和恢复输入法当前用户的词库。

用户词库文本导入
从文本文件中批量导入词和短语。


输入法界面

输入法的界面包括状态条窗口、输入法系统菜单和输入栏窗口。

状态条窗口：

当输入法打开时，在屏幕的右下角显示状态条窗口。状态条窗口也用于输入法的控制操作。参见输入法状态条窗口说明。

输入法系统菜单：

在状态条窗口中，点击系统菜单按钮或按鼠标右键，将打开输入法系统菜单。菜单中的功能项包括软键盘选择、光标跟随状态更改、全拼和双拼选择、GB/GBK字符集选择、设置属性、输入法帮助（显示输入法帮助目录）和输入法版本信息。
参见输入法系统菜单说明。

输入栏窗口：

使用输入法进行输入时，所输入的拼音串以及输入法为您提示的候选汉字和词信息，在输入栏窗口中显示。
参见输入法输入栏窗口说明。

在紫光拼音输入法提供的两种输入风格中，输入栏窗口界面和输入操作有所不同。

参见：紫光拼音输入法的两种输入风格，定制输入法


输入法状态条

状态条窗口用于显示和设置输入法状态。用鼠标左键点按相应的按钮来修改输入法状态设置。用鼠标左键点按状态条的标题区可以拖动状态条窗口。

各图标说明如下：

标题区，用鼠标在该区域按下可以拖动状态条

中文输入状态

英文输入状态

中文标点符号状态

英文标点符号状态

半角输入状态

全角输入状态

软键盘关闭状态

软键盘开启状态

输入法系统菜单开关按钮

处于英文输入状态时，只能输入英文标点符号和英文字母，这时中/英文标点符号按钮和全角/半角按钮无效。


输入栏窗口

输入栏窗口用于输入拼音串并显示候选的字词。

紫光拼音输入法提供了两种输入风格，不同输入风格有不同的输入栏窗口的用户界面。

采用“输入拼音串后按空格显示候选字词”风格时，输入栏窗口包含拼音串输入栏和字词候选窗口两个部分。

采用“输入拼音串同时显示候选字词”风格时，输入拼音串和候选字词在一个输入栏窗口中。

参见：输入法的两种输入风格。


输入法系统菜单

在状态条窗口中，点击系统菜单按钮或按鼠标右键，将打开输入法系统菜单。

输入法系统菜单中的功能项包括软键盘选择、光标跟随状态更改、全拼和双拼选择、GB/GBK字符集选择、设置属性、输入法帮助（显示输入法帮助目录）和输入法版本信息 ，以及最小化/恢复状态条。

“软键盘”菜单项用于打开软键盘选择子菜单，参见使用软键盘。

“设置属性”菜单项用于启动输入法属性设置程序，对输入法进行配置。

“字符映射表...”菜单项用于打开Windows系统的“字符映射表”程序，利用该程序可以选择输入中英文符号和中文字。在Windows 2000中文版系统中，“字符映射表”还提供了按偏旁部首或按拼音检索中文字的功能。

注：“字符映射表”是Windows系统所带的系统工具，只有系统中安装了该工具的情况下才可以使用。

参见：输入法状态条，定制输入法，使用软键盘和软键盘图示


全拼方式输入和双拼方式输入

全拼方式输入

全拼方式输入指在输入拼音串时键入字词的全部拼音。

全拼输入时，如果是词输入，部分字词需要手工进行音节切分(参见输入中的修改和音节切分)。

紫光拼音输入法支持不完整的拼音(简拼)输入，即在输入中可以省略字词的韵母部分。例如，输入“中国”时，可以省略“中”字的韵母，输入拼音串“zhguo”。

双拼方式输入

双拼方式输入是两键输入一个汉字拼音的方式，对所有声母和韵母，可以用单个字母键对它们进行了编码。
例如：定义ch=A，ang=S，之后键入“as”将输入拼音“chang”。

紫光拼音输入法提供了可定义的双拼编码，和零记忆的实时双拼编码提示功能，便于用户输入。

在紫光拼音输入法中，模糊音定义对双拼输入也是有效的。

此外，使用双拼也可以使用简拼方式输入，但是当声母键同时定义为韵母时，需要手工键入音节切分符号“'”(单引号)来切分。
例如，定义“an=R”时，键入“fr”来输入读音为“fan”的“范”，输入“f'r”来输入读音为“fan'rong”的“繁荣”。

参见：自定义双拼编码和缺省的双拼编码表。


输入中的修改和音节切分

输入中修改

在输入拼音串过程中，可以修改所键入的拼音串。
修改拼音串时：使用退格键删除上一个拼音串中的字母；使用光标键←和→移动插入点；使用Home和End键将插入点移动到串的首部和尾部；使用Delete键删除插入点之后的字母；使用ESC键取消整个拼音串。

音节切分

全拼词输入时，两个或多个字的拼音串之间需要切分每个字的音节，每个字音节之间使用英文单引号格开。 紫光拼音输入法会自动切分各个字的音节，并在大部分情况下是正确的。 对于有多重含义而无法切分的音节，需要手工切分，这时需要键入英文单引号以切分音节。 例如，需要输入“西安”时，需要键入“xi'an”，其中单引号需要输入，否则输入法将理解为您可能要输入“现”。

参见：输入法使用键一览表


造词和删词

紫光拼音输入法提供了在输入过程中自动造词的功能，而且用户可以随时删除词库中的词，包括删除在系统词库中固有的词。

造词

在连续输入多个字的拼音串时，输入法将提示词和字信息。如果没有对应的词，您可以逐个选择字（或词），输入法将根据您的选择自动造词；在下一次输入时，输入法将能找到该词。

在采用输入风格一：“输入拼音串后，用空格显示候选字词”的方式时，在造词的过程中，使用退格键可以退回一个选择，并可一直退回到拼音串的修改。

在采用输入风格二：“输入拼音串同时显示汉字”的方式时，在造词的选择字词过程中，使用左移光标键可以退回一个选择；在选择字词过程中，如果已经选择了整个词中的一个或几个字，这时如果使用退格键或删除键修改拼音串，必须重新选择字词。

关于两种输入风格参见“紫光拼音输入法的两种输入风格”。

此外，紫光拼音输入法具有智能组词功能，如果您选用了此设置，输入法可以帮您组合一个词库中没有找到的词，如果不是您所需要的，您可以再逐个选择。

删词

紫光拼音输入法提供了词删除功能，具体操作是键入拼音串并出现候选词时，使用Ctrl+Shift+数字键（或字母键），删除数字键（或字母键）所对应的词，删除该词后，随后的词和字会自动上移一个位置。

删词操作对词库中所有词都有效，即使在词库中初始已有的词，您也可以将其删除。

注意： 以绿色显示的词是输入法智能组成的词，不能删除。

参见：输入法使用键一览表，关于智能组词参见输入法的高级智能特性，关于输入风格选择参见紫光拼音输入法的两种输入风格。


使用软键盘

在紫光拼音输入法中，软键盘用于输入各种符号。

按照符号的不同意义，共有13类软键盘符号。使用输入法系统菜单中的“软键盘...”一项选择需要的符号类别软键盘，使用输入法控制窗口中的软键盘按钮打开、关闭当前软键盘。

软键盘菜单：

在打开输入法并处于英文输入模式时，使用软键盘只能输入对应的英文字母。

参见：输入法界面，输入法系统菜单，软键盘图示。


以词定字

以词定字是一种在词中选择字来输入的方式，可以适当解决拼音输入中的重码问题。 例如，想输入“嫉”，用"ji"输入时找到“嫉”字很费劲，而输入"jidu"(“嫉妒”)后再取“嫉”就省事的多。

为此紫光拼音输入法引入了“活动候选”这一概念。活动候选是指候选中用紫红色显示的候选，它默认是第一个候选，您可以用Shift+数字或字母键把其他候选设置为活动候选。
在设置了活动候选之后，就可以使用以词定字键选择所需的字，左方括号“[”键取活动候选的第一个字，右方括号“]”键取活动候选的最后一个字(以词定字的选字键可以选择配置)。

以词定字可以和自动造词结合起来使用，即在造词过程中也可以使用以词定字功能。 例如，您想输入“愤世嫉俗”，可以用“愤怒世界嫉妒俗人”的形式输入，然后依次取“愤怒”的“愤”、“世界”的“世”，“嫉妒”的“嫉”和“俗人”的“俗”，最后得到“愤世嫉俗”。

紫光拼音输入法以“姓X”的形式收入了常见姓氏，为输入姓名提供了方便。 例如，假设您希望输入“韩智芳”，可以输入“xinghanzhihuifangxiang”, 然后取“姓韩”的“韩”(先使用Shift+数字或字母键把“姓韩”设置为活动候选，然后使用以词定字的选字键选择“韩”), “智慧”的“智”, “芳香”的“芳”。本次输入后输入法记录了此名字，您以后就可以用“hzhf”的简拼方式输入。

参见：定制输入法，功能键设置


特殊输入

中文状态下的英文输入

大小写结合的英文串可以直接输入，无需切换到英文状态。

此外，在使用全拼输入时，使用字母“v”可以直接输入英文串，用法是输入v打头的英文串，输入法将忽略第一个“v”字母，而直接输入随后的英语串。

在CapsLock开启的状态下，可以直接输入大写英文字母，并结合Shift输入小写英文字母。

中文数字和常用单位

在使用全拼输入时，使用字母“i”和“u”可以输入中文的数字和常用单位。 用法是以字母“i”或“u”开头，跟随数字和单位代号；其中“i”用于输入中文数字的小写形式(一、二、三等)，“u”用于输入中文数字的大写形式(壹、贰、叁等)。 可以输入的单位代号如下：

g 个 | s 十/拾 | b 百/佰 | q 千/仟 | w 万 | z 兆
n 年 | y 月 | r 日 | d 点 | f 分 | m 秒
v 元 | j 角 |  |  |  |

例如：键入“i2000nsy1r”输入“二○○○年十月一日”，键入“u8w7q6b3s1v”输入“捌万柒仟陆佰叁拾壹元”。

数字和小数点

在键盘的NumLock开启状态下，使用键盘的数字小键盘可以直接输入数字、小数点以及英文的加减乘除符号。


使用模糊音和词频调整功能

使用模糊音

紫光拼音输入法提供了声母和韵母共计11组拼音的模糊能力。

对某一组拼音的模糊是指输入法不区分该组拼音中互相模糊的两个拼音。例如，模糊“z=zh”后，拼音串“zong”和“zhong”都可以用来输入“中”。

使用模糊音可以提高输入的方便性，但会导致重码的增多。

此外，模糊音对某些不合法的拼音是无效的，例如拼音中不存在“duang”的读音，因此即使使用模糊音“uan=uang”，也不能使用“duang”来输入读音为“duan”的字。

参见输入法属性设置的模糊音设置。

紫光拼音输入法仅从输入的方便性上提供模糊音功能，紫光拼音输入法鼓励大家说好标准的普通话。

使用词频调整功能

紫光拼音输入法的词库中带有字词的使用频度（词频）信息，我们从报刊文字中统计得到字词的使用频度信息作为输入法词库的默认词频信息。用户在使用过程中，输入法将记录用户对字词的使用。对于常用字词，输入法会优先提供候选。

紫光拼音输入法的词库中收录了大量的词和短语，输入法可以自动隐藏低频词。

以上的词频相关功能均可设置，参见输入法属性设置的输入设置。

参见：定制输入法


定制输入法

紫光拼音输入法提供了强大的用户定制能力，您可以通过输入法的属性设置功能定制您所希望的输入风格、习惯和界面。

输入法属性设置
输入设置 | 包括两种输入风格的选择，是否需要光标跟随功能，全拼和双拼得选择，词库的词频调整功能等。
功能键设置 | 输入中的功能键定义。
外观设置 | 设置输入窗口界面。
模糊音设置 | 选择设置哪些拼音需要使用模糊音。
高级设置 | 包括是否使用GBK大字符集和高级智能特性设置。
自定义相关输入
自定义双拼编码 | 使用双拼编码定义程序，用户可以自定义双拼编码。
自定义中文符号 | 用户可自定义英文符号键对应的中文符号。
自定义特殊字词和短语输入 | 用户可自己定义特殊的字词和短语(例如，定义“china=中华人民共和国”)，方便输入。

参见：输入法安装后的菜单项，输入法界面，输入法系统菜单


输入设置

输入风格

您可以在两种输入风格中选择适合您使用的一种。
两种输入风格是：
①输入完拼音串之后，使用空格键显示对应的字词。使用这种风格时，可以使用字母键选择候选字词（否则，使用数字键选择）。
②输入拼音串的同时，输入法立即为您显示对应的字词（即敲即现）。

更详细的说明参见紫光拼音输入法的两种输入风格。

光标跟随

两种风格都可以设置是否让输入栏窗口跟随应用程序的光标移动（光标跟随）。清除该选项时，您可以用鼠标拖动输入栏窗口改变位置。
光标跟随选项还和应用软件有关，在一些不支持光标跟随的应用软件中，该选项设置是无效的。

全拼/双拼

您可以选择使用全拼方式输入还是使用双拼方式输入，使用双拼方式输入时，可以设置是否需要实时提示双拼编码信息。
参见全拼和双拼方式输入介绍。

字/词调整

设置了“动态调整词使用频率”选项后，输入法记录用户选择词及自造词情况，将常用词的候选位置前移。

设置了“总显示词库中所有的词”选项后，输入法的候选词中将显示词库中所有的词（包括用户自造的词）；否则，输入法将根据词的使用频率，自动隐藏很少使用到的词。

设置了“最近输入的字优先候选”选项后，最近输入过的字在单字候选中将处于前面的位置。

字词的输入以及候选还和高级设置中的智能特性选项有关，参见“高级设置”。


功能键设置

功能键定义

▲中/英文输入模式切换：
在打开输入法的状态下，可以使用单键切换中文和英文输入模式，您可以选择使用Shift键还是Ctrl键。

▲回车键(Enter)功能：
可定义回车键的功能，包括：

  • 用回车键输入缺省候选中文字词(相当于空格键)；
  • 用回车键输入英文串；
  • 多个候选的情况下，用回车键翻页到第一个候选字。

▲多个候选字词翻页键：
输入栏窗口一次只能显示有限数目的候选字词，候选字词数目多时，可使用翻页键翻页显示。 缺省的翻页键是逗号和句号键，分别为往回翻一页和往下翻一页。

▲以词定字时选字键：
采用以词定字功能键入字时，使用选字键选择词中的字。 缺省的选字键为左中括号键和右中括号键，分别为选择词中的第一个字和最后一个字。
参见：以词定字。

▲输入第2、第3个候选字词：
有多个候选字词的时候，可以选择左右Shift或左右Ctrl键进行输入，左键输入第2个候选字或词，右键输入第3个候选字或词。

▲软键盘开关键：
软键盘开关键是Ctrl键+Shift键和一个字母键的组合，您可以选择某个字母键。缺省的软键盘开关键是“Ctrl+Shift+K”。

参见：输入法使用键一览表


外观设置

外观

▲输入栏窗口中文和英文字体：
您可以选择输入栏上的中文和英文字体，分别作用于输入的候选字词和输入的拼音串。

▲输入栏窗口字体大小：
您可以设置输入栏字体大小，下拉选择框中的数字表示字体的高度为多少个像素。输入栏窗口将随字体大小改变而调整大小。
您可以从下拉选择框中选择一个大小，也可以手工输入字体大小的数字，输入数字必须在12～32之间。
在640x480分辨率下，推荐使用14个像素高的字体；在800x600及以上分辨率下，推荐使用16像素高或更大的字体。 如果使用很大的字，建议设置Windows系统显示属性中的“圆整屏幕字体边角”选项（针对Windows 98, Windows 2000，或Windows 95/NT + Plus）。

▲输入栏窗口显示风格：
您可以选择输入栏窗口三种显示风格中的一种。
浮动式是指输入栏以整个凸起浮动栏的方式显示； 传统信息栏式是指输入栏窗口以凹状的信息提示栏方式显示； 现代式为输入窗口使用阴影效果，并可以使用图像作为背景。
选择现代式时，可在使用图像文本框中输入要使用的背景图像文件名，也可以使用浏览按钮选择一个图像文件。
背景图像文件必须是Windows的位图文件（以“.bmp”结尾）。输入栏窗口以平铺方式显示背景图。 由于输入栏窗口中的文字是固定颜色的，在使用背景图时建议选用浅色图。


模糊音设置

选中某一组模糊音设置选项后，该组的两个拼音在输入时可以混用。

参见：使用模糊音。


高级设置

字符集

设置输入法是否检索GBK大字符集中的字。 清除该选项时，输入法仅在GB/2312字符集中检索字，但含有GBK字的词仍然可以显示。

有关Windows系统中的中文字符集，参见Windows的有关说明。

高级智能

▲智能组词：
设置了该选项时，对于输入的词拼音串，如果词库中没有对应的词，输入法将帮您组成一个词（即输入法帮您造词）。
输入法自动组成的词以绿色显示在候选词的第一个位置，不能删除。
如果设置了智能组词选项，您还可以选择“智能组词的词自动记忆到用户词库”选项，如果设置该选项，输入智能组成的词的同时，该词将被记忆到用户词库中，下次可以使用简拼输入该词；否则，该词并不加入到词库中。

▲按照前次输入字词动态调整字序：
设置了该选项时，输入法将根据您上一次输入的字，并结合字词的使用频度，动态调整候选字词的顺序。

▲数字后面跟随英文符号：
设置了该选项时，当输入一个数字后，随后紧跟着输入的符号将是英文的。例如输入数字“2”后，紧随着键入英文句号键，将输入“2.0”。

▲记忆并可选择输入最近输入过的字词：
设置了该选项时，输入法将记忆最近输入过的字、词以及标点符号(共16个)，您可以使用“Ctrl+↓”组合键打开最近输入字词的菜单进行选择输入，也可以使用“Ctrl+↑”组合键直接重复输入最近输入的字词。

参见：紫光拼音输入法的高级智能特性。


紫光拼音输入法的两种输入风格

紫光拼音输入法提供了两种输入风格，通过输入法的属性设置，您可以选择符合您的操作习惯的输入风格。

输入风格一：输入拼音串后，用空格显示候选字词

使用这种输入风格时，您需要先输入拼音串，此时只有拼音串输入栏窗口，可以编辑输入的拼音串；然后按空格键，将打开候选字词窗口，进行字词选择输入。

拼音串输入：

按空格键打开并选择候选字词：

在打开候选字词窗口后，如果您想输入的词在第一个候选位置，您可以直接键入下一个要输入字词的拼音(指使用数字而不是字母选择候选字词的情况下)，或直接输入随后要输入的标点符号(在中文标点符号状态下)，这时第一个候选词会自动输入到应用程序中。

有多个候选字词时，使用翻页键翻页，翻页键可以选择配置，缺省为逗号键“,”和句号键“.”。符号键定义为翻页键时，如果处于选择字词状态，符号键优先作为翻页键使用；没有候选时，仍可使用符号键输入符号。

这种输入风格可以使用字母键选择候选的字词，对于习惯键入字母（而不是数字）的用户来说，可以使用字母键选择方式加快输入速度。

在使用这种风格时，还可以直接输入URL和EMAIL地址等带有符号的英文串。

输入风格二：输入拼音串同时显示汉字

使用这种风格时，在输入拼音串的同时，在输入栏中将直接显示候选字词。

输入时按空格键，输入法将第一个候选字词输入到应用程序中。

有多个候选字词时，使用翻页键翻页，翻页键可以选择配置。

在输入拼音串并有候选字词的时候，如果键入符号键，将会直接输入默认的候选字词以及符号；但是符号键定义为功能键时，则优先作为功能键使用。

使用这种风格时，如果不设置光标跟随选项，输入栏窗口将总处于显示状态；如果设置了光标跟随选项，则仅当输入拼音串时，输入栏窗口才显示。

参见：定制输入法，输入法属性设置的输入设置和功能键设置，输入法使用键一览表。


高级智能特性

除在输入过程中的自动造词、自动调整字词输入频度、识别模糊音、自动切分拼音音节等智能特性以外，紫光拼音输入法还提供了“智能组词”这样的高级智能特性。

关于智能组词

智能组词是指词库中没有词和输入的词拼音串对应时，输入法将自动帮您组出一个词。 输入法所组出的词以绿色显示在第一个候选位置，由于它不属于词库中的词，不能以删词的方式删除。

输入法所组出的词并不一定是您所希望的，这时您可以通过选择来自己造词。 紫光拼音输入法自动造词所具有的记忆能力同样影响到智能组词。 例如，您输入了拼音串“chang'hui'jia”，这时输入法所组的词是“场汇价”，但是您选择了词“常回家”，说明您并不认可输入法所造的词，当您随后键入“chang'hui'jia'kan'kan”时，输入法将根据您所造的词重新组词，得到“常回家看看”。

智能组词的准确率也和输入的拼音串有关，输入的拼音串越完整，组词的准确率越高。

由于紫光拼音输入法是一个字词输入法，而不是整句输入法，因此智能组词特性也只针对词和短语，不具备组句功能。

如果您不喜欢智能组词功能，可以使用属性设置对话框屏蔽该功能。

在设置了“智能组词”选项的情况下，您还可以设置“智能组词的词自动记忆到用户词库”选项，如果设置该选项，输入智能组成的词的同时，该词将被记忆到用户词库中，下次可以使用简拼输入该词；否则，该词并不加入到词库中。

动态调整字序

紫光拼音输入法对字词输入具有最近输入记忆和联想的能力，使用动态调整字序选项时，输入法将根据前次输入情况调整候选字词的顺序。

调整的依据是将最可能出现的字优先提供选择。其中对前次输入情况的判断包括了对字的判断和标点符号的判断。 例如，如果您刚输入了句号，输入“fa”时，优先显示的字是“发”；如果您刚刚输入了“输入”，则输入“fa”时，将优先提示“法”。

您同样可以屏蔽动态调整字序功能。

数字后面跟随英文符号

紫光拼音输入法在输入过程中，键入的数字将直接输入到应用软件中，但输入法将记忆用户最近是否键入数字。输入一组带有符号的数字时，通常希望输入的符号是英文的，例如“2000/12/31”。

设置了该选项时，当输入一个数字后，随后紧跟着输入的符号将是英文的。例如输入数字“2”后，紧随着键入英文句号键，将输入“2.0”。该选项也仅对数字后面输入的第一个符号键有效。

参见输入法属性设置的“高级设置”部分。


词库的备份和恢复

词库的备份和恢复功能用于保存用户词库，此外还用于将当前用户的词库应用到其它环境中，例如将用户词库提供给另一用户使用，或者将用户词库移到另一微机上。

如果您需要重新安装系统或重新安装紫光拼音输入法，可以在安装前备份词库，安装后通过恢复字库，以保留原有词库中的词频、自造词等信息。

使用词库备份/恢复程序进行词库的备份和恢复操作。 在备份词库时，您需要指定词库备份文件名，词库将以压缩数据存放于备份中。

在恢复词库时，须指定词库的备份文件。

注意：恢复词库时，应关闭紫光拼音输入法并退出使用过输入法的应用程序；要恢复的词库将覆盖当前用户的词库。

参见：紫光拼音输入法相关文件


自定义双拼编码

关于双拼编码的定义

使用双拼编码定义程序，可以自定义双拼编码。
使用程序菜单中紫光拼音输入法菜单中双拼编码定义菜单项启动双拼编码定义程序。
运行双拼编码定义程序后，将打开双拼编码方案文件，通过修改该文件即可自定义双拼编码。
在“显示双拼提示信息”选项开启的状态下，双拼输入时将提示您所定义的双拼编码信息。

在多用户使用情况下，双拼编码定义对所有用户有同样的效果。

关于双拼编码定义文件

双拼编码以一个文本格式的定义文件存放，双拼编码定义程序即打开该文件进行编辑，并将修改效果应用到输入法中。
该编码定义文件是<WINSYSDIR>\IME\UNISPIM\UNISPIMSP.INI，其中<WINSYSDIR>是您的Windows系统的System目录。您可以复制备份或直接修改该文件。需要应用双拼编码时，再使用双拼编码定义程序使其生效。

如何定义双拼编码

双拼编码的定义包括三个部分，分别是“声母”、“韵母”和“零声母音节的韵母”。零声母音节的韵母是指一些直接以韵母发音的字，这些字的拼音中没有声母，例如“啊(a)”、“安(an)”、“欧(ou)”等字。
上述三个部分分别在双拼编码定义文件的三个小节中给出定义，三个小节分别以“[声母]”、“[韵母]”和“[零声母音节的韵母]”开头(注意：不要改动小节开头标志)。

双拼编码定义格式为：

拼音码=按键
拼音码即包括声母和韵母的拼音，按键为将用于输入该拼音码的键。例如：
ch=A
ang=S
上述定义表示键入“as”将输入拼音“chang”。

在定义声母时，按键定义只能使用英文字母；在定义韵母时，按键定义可以使用英文字母(A到Z)和分号符号键“;”。例如：“ing=;”。

在“声母”小节部分，您所需要定义的声母实际上只有“zh”、“ch”和“sh”，其它的单个拼音字母的声母本身可以和按键对应，不必再定义。
声母的定义使用单个按键字母。例如“sh=I”。

在“韵母”小节部分，同样使用单个按键字母来定义韵母。不同的韵母应该使用不同的按键来定义。但模糊音设置对双拼定义也是有效的。
例如：定义“an=R”和“ang=S”，当设置了模糊音“an=ang”时，两者是等效的。

在“零声母音节的韵母”部分，使用两个按键字母来定义零声母音节的韵母。这样可以和以声韵母组合输入方式区分开。例如：
an=OR
键入“or”两个键输入拼音“an”，来输入“安”、“按”等字。

在双拼编码定义中，以分号开头的是注释行，可用于解释说明；定义格式中，缺省情况下等号左侧的拼音码使用小写，而定义按键使用大写，这只是便于观看，在实际输入中，按键输入仍然需要使用小写。

参见：全拼方式输入和双拼方式输入，缺省的双拼编码表。


自定义中文符号

关于中文符号的定义

紫光拼音输入法2.01以后的版本支持用户自定义英文符号键对应的中文符号方案。
使用程序菜单中紫光拼音输入法菜单中的中文符号定义菜单项，启动记事本编辑中文符号方案定义文件。
中文符号方案定义文件是<WINSYSDIR>\IME\UNISPIM\CHNSYM.INI，其中<WINSYSDIR>是您的Windows系统的System目录。
自定义中文符号方案时，您可以参照方案定义文件中的说明，修改定义即可。完成定义后保存文件，输入法将在下次启动时使用您修改后的符号方案。

在多用户使用情况下，中文符号定义对所有用户有同样的效果。

如何定义中文符号

中文符号定义并不是必须的，对于没有定义的中文符号，输入法采用缺省的中文符号定义。但是，您可以使用此功能定义您常用的、习惯的中文符号输入方式。
在中文符号定义文件中，以分号“;”打头的行是注释，不处理。

中文符号的定义格式为：

英文符号键=中文符号
例如：“/=、”,表示使用斜杠符号输入中文标点顿号。

在定义格式中，等号右边的中文符号可以使用一个或两个中文符号，例如中文省略号"……"；等号右边的中文符号也可以使用英文符号。
例如：
(=(
)=)
^=……
两个小括号符号定义为对应的英文小括号，表示小括号输入时，直接输入英文小括号；而符号“^”则用于输入中文省略号。

注意：以下几个英文符号不允许自定义，它们是英文单引号、双引号、分号和等号。
英文单引号和双引号键对应中文的单引号和双引号，且有开闭状态(即第一次键入时是输入左引号，第二次键入时输入右引号)；英文分号键对应中文分号；英文等号键对应中文等号。

修改符号定义之后，需要关闭并重新打开输入法才有效；删除了某个符号的自定义，输入法将在下次重新启动后使用缺省的定义。


自定义特殊字词和短语输入

关于特殊字词和短语输入的自定义

紫光拼音输入法2.2以上版本支持用户自定义特殊的字词和短语输入。例如在定义了“china=中华人民共和国”后，您可以键入“china”来输入“中华人民共和国”。
使用程序菜单中紫光拼音输入法菜单中的特殊字词和短语输入定义菜单项，启动记事本编辑特殊字词和短语输入定义文件。
特殊字词和短语定义文件是<WINSYSDIR>\IME\UNISPIM\SPEWORDS.INI，其中<WINSYSDIR>是您的Windows系统的System目录。
自定义特殊字词和短语输入时，您可以参照定义文件中的说明，增加您自己的特殊定义即可。
完成定义后保存文件，在下次启动输入法，您就可以使用特殊字词和短语定义进行输入了。

在多用户使用情况下，特殊字词和短语输入的定义对所有用户有同样的效果。

如何自定义特殊字词和短语输入

在特殊字词和短语定义文件中，以分号“;”打头的行是注释，不处理。

特殊字词和短语输入的定义格式为：

英文输入串=中文字词和短语

其中，等号两侧不要出现空格；英文输入串必须是英文字母(并可以使用大小写结合的字符串)；中文字词和短语则可以是中文、英文以及其它符号。

定义格式中，中文字词和短语的总长度不能超过9个汉字长，否则将被截断。

注意：在“输入完拼音，按空格键后显示汉字”输入风格情况下，使用大小写结合的英文输入串定义无效；在此输入风格下，以“i”和“u”开头的定义与中文数字和单位输入有冲突时，将输入中文数字和单位。

自定义特殊字词和短语的限制

中文字词和短语不能超过9个汉字的长度。
大多数情况下，英文输入串长度不能超过9个英文字符，且只能使用英文字符。
自定义总数目不能超过2000个。
英文输入串相同的重复定义不能超过9个。


用户自定义词的批量导入

用户可以在文本文件中定义一批词或短语，通过导入程序将它们导入到紫光拼音输入法的当前用户词库中。

注意：自定义词库内容导入后，所导入的词不能批量删除。
建议用户在导入自定义词库前，先备份当前用户的词库。

使用程序菜单中紫光拼音输入法菜单中“用户词库文本导入”菜单项，启动用户自定义词库文本的导入程序。
使用本程序时，先浏览或键入用户自定义词文件名，然后按“开始导入”按钮进行导入操作。
选中“记录导入操作的错误信息到文件C:\Addwords.log中”选项时，导入操作中将对错误信息进行记录，导入完成后您可以打开文件C:\Addwords.log进行查看。
导入完成后，将弹出对话框显示从自定义词文件中读入的行数和处理的词数。导入过程中，仅对定义正确的词进行处理；词库中已有的词不会重复导入。

▲自定义词文件的格式说明

用户自定义词的文件必须是文本文件，每个词分行定义。
自定义词的文本文件必须是DOS/Windows文本编码格式，如果是Unicode或UNIX等其它文本格式，请使用文本转换工具进行转换。

词定义的格式为：

[中文词和短语] [拼音串] [词频数]

中文词和短语只能使用中文字、全角和中文符号，有效长度为2到9个汉字。
拼音串以英文单引号或空格隔开；拼音串中的汉字个数必须和中文词部分的汉字个数一致；拼音串可省略，省略时导入程序自动生成拼音串，多音字则按读音的拼音串顺序使用第一种读音。
词频数有效范围从1到100，数越大表示该词越常用；词频数可省略，省略时词频设置为1。

当词定义格式中省略拼音串时，导入程序自动查找汉字的读音，将会使导入过程延长。

以下结合示例说明定义格式。

示例：

#紫光拼音输入法，用户自定义词文件

#人名
阿土仔 a'tu'zai 10
令狐冲 100
我是谁

#其它
甲Ａ jia'a
沙尘暴 sha chen bao 80

#错误示例
甲B jia'bi
假Ａ
★ xing
中招 zhon'zhao
紫霞 zhi'zhun'bao 20

说明：

1. 以英文符号"#"开始的行是注释，词定义文件中也可以有空行。
2. "令狐冲"的词频为100，表示该词很常用，该词省略拼音串，由导入程序生成。
3. "我是谁"的定义可以省略拼音串和词频数，词频设置为1；其中谁是一个多音字，既读"shui"也读"shei"，导入程序生成拼音串时，将使用排在前面的"shei"，得到"wo'shi'shei"。
4. 中文词可以使用全角或中文符号，如"甲Ａ"中的"Ａ"是全角符号。
5. 拼音串可以用空格隔开，例如"沙尘暴"的拼音串定义。
6. 以上示例中，"#错误示例"部分为定义错误的词，导入过程中将忽略对这些词的处理。
7. "甲B"定义错误的原因是使用了英文符号"B"。
8. "假Ａ"定义错误的原因是没有给出拼音串，而导入程序无法找到全角符号"Ａ"的拼音读音。
9. 星号"★"定义错误是没有满足中文词2到9个汉字的有效长度要求。
10. "中招"定义错误是使用了非法的拼音"zhon"。
11. "紫霞"定义错误是拼音串说明该词有三个汉字，而中文词为两个汉字。

▲关于导入操作的错误信息记录

选中“记录导入操作的错误信息到文件C:\Addwords.log中”选项时，导入操作中将对错误信息进行记录。记录文件中将记录第几行和错误情况。

错误情况包括：

词定义格式不对 － 词定义不符合格式要求。
拼音串错误 － 拼音串不合法
插入自定义词到词库中时出错 － 插入词到词库时出错

▲从微软拼音输入法的用户自造词文本文件导入

用户自定义词库导入程序支持从微软拼音输入法的用户自造词文本文件中导入词。

注意：
用户自定义词库导入程序要求自定义词的文本文件必须是DOS/Windows(ANSI)的文本编码格式。从微软拼音输入法的用户自造词文本文件导入之前，请确认该文件为DOS/Windows文本编码格式。如果是Unicode文本格式，请使用文本转换工具将其转换为DOS/Windows文本编码格式。

在Windows 2000中，微软拼音输入法2.0使用Unicode格式保存用户自造词文本文件，您可以使用记事本打开该文件，使用“另存为...”功能并选择ANSI编码，即可将该文本文件转换为DOS/Windows文本编码格式。

▲自定义词导入的有关限制

用户自定义词库不宜过长，建议一个用户自定义词库不要超过10,000条词。否则导入程序可能因为为导入词库分配的空间不够而出错。

如果用户自定义词库中的词非常多，建议分为几个用户自定义词库文本文件，逐个进行导入。


在Windows 2000下使用紫光拼音输入法

英文版Windows 2000下的输入法安装：

在英文版的Windows 2000下安装紫光拼音输入法之前，需要将系统的默认编码设置为简体中文。

多用户使用：

在Windows 2000或NT下安装紫光拼音输入法，需要以系统管理员或拥有系统管理员权限的用户登录进入系统进行安装。
此后，其它用户需要使用紫光拼音输入法时，不需要重新安装，但需要进入控制面板中的“输入法”设置(或者“键盘”中的输入法相关设置)，使用“添加”功能添加紫光拼音输入法。

在MS-DOS窗口下使用输入法：

在Windows 2000的MS-DOS窗口中可以使用紫光拼音输入法，但必须在图形界面的窗口模式中使用，而不能在DOS窗口的全屏幕模式中使用。
在MS-DOS窗口中使用输入法时，光标跟随选项无效。


输入法相关文件

输入法相关文件说明

紫光拼音输入法的相关文件及其所在文件夹说明如下：

引擎和输入法文件：

在“<WinSysDir>”文件夹中(Windows的系统文件夹，在Windows95/98/Me系统中，是Windows安装目录下的“System”子文件夹，在Windows NT/2000系统中，是Windows目录下的“System32”子文件夹)。

紫光拼音输入法的核心文件包括引擎文件UPEngine.exe和输入法接口文件Unispim.ime。

系统词库和数据文件：

在“<WinSysDir>\ime\unispim”文件夹中。
包括词频统计信息文件BCOC.DAT(用于智能组词)、系统词库文件SYSWL.DAT(用于生成用户词库)。

用户词库文件：

紫光拼音输入法根据每个使用者，在第一次使用时生成对应的用户词库文件。
用户词库文件存放在“<用户应用数据文件夹>\unispim”文件夹中，用户词库文件名是USRWL.DAT。

<用户应用数据文件夹>是Windows 98(或Windows 95安装了IE4以上版本)和Windows NT/2000用于存放用户应用程序数据信息的文件夹，在Windows 2000中，<用户应用数据文件夹>是系统安装盘的“\Documents and Settings\<Username>\Application Data”文件夹，其中<Username>是当前使用用户名；在Windows 98中，如果使用单用户设置，<用户应用数据文件夹>是Windows文件中的“Application Data”子文件夹。

例如，Windows 2000下Administrator用户的词库文件为：
“\Documents and Settings\administrator\Application Data\Unispim\USRWL.DAT"

用户词库文件如果损坏，输入法将根据系统词库文件自动生成新的用户词库文件；如果生成新用户词库文件失败，在打开输入法时将提示“用户词库文件打开失败”的信息，这时需要手工恢复用户词库文件。
参见“疑难解答：词库文件打开失败”。

单字缓存文件：

单字缓存文件在输入法使用中生存，文件为“<WinSysDir>\ime\unispim\hzcache.dat”。
单字缓存文件用于记录最近输入的单字信息，删除该文件可以清除单字缓存信息。
单字缓存文件如果损坏，可能导致输入中在选择单字时，输入法引擎报告错误，这时可以通过删除单字缓存文件解决引擎错误问题。
参见“疑难解答：选择单字输入时出错”。

工具、配置和帮助文件：

在“<WinSysDir>\ime\unispim”文件夹中。
双拼编码定义文件、中文符号定义文件、特殊字词和短语输入的定义文件也在该文件夹中。

参见：自定义双拼编码、自定义中文符号、自定义特殊字词和短语输入


输入法使用键一览表

默认热键 | 说明
Ctrl+空格 | 打开/关闭缺省输入法(可配置)
Shift+空格 | 切换全角/半角状态(可配置)
Ctrl+.(句号) | 切换中/英文标点符号状态(可配置)
*注： | 以上为系统热键，通过控制面板的“输入法”可进行配置。
Shift或Ctrl | 切换中英输入状态(可选)
,和.(或-和=，或[和]) | 选择字词时向后/向前翻页，或作为以词定字键(可配置)
Enter | 可用于：输入英文串(缺省)；或输入中文字词；或选择字词时直接翻到有单字的第一页(如果已经是，则翻到下一页)。该键功能可以选择配置。
Ctrl+Shift+K | 软键盘打开/关闭的缺省组合键(可配置)。
*注： | 以上热键可以选择配置。
Ctrl+↓ | 打开最近输入字词的菜单进行选择输入(和选项设置相关，参见高级设置)
Ctrl+↑ | 直接重复输入最近输入的字词(和选项设置相关，参见高级设置)
Shift+数字 | 选择默认的候选字词－活动候选(输入中有多个候选字词的时候)
Ctrl+Shift+数字 | 删除某个候选词(输入中有多个候选词的时候)
退格 | 输入拼音串时往回删除，选择字词时回退选择
Delete | 编辑拼音串时删除插入点之后的一个字符
Home和↑ | 编辑拼音串时移动插入点到最前，选择字词时回到第一页
End | 编辑拼音串时移动插入点到最后
↓ | 选择字词时直接翻到有单字的第一页(如果已经是，则翻到下一页)。
PageUp/PageDown | 选择字词时向后/向前翻页
←和→(左右光标) | 编辑拼音串时移动插入点
NumLock | 打开状态时，可使用小键盘输入数字、小数点和英文的数学运算符
CapsLock | 打开状态时，可直接输入大写英文字母

参见：功能键设置，高级设置


缺省中文符号键表

字符 | 中文标点 | 字符 | 中文标点 | 字符 | 中文标点 | 字符 | 中文标点
` | · | & | ※ | \ | ÷ | ' | ‘或’
~ | ～ | * | × | | | § | " | “或”
! | ！ | ( | （ | [ | 【 | , | ，
@ | ◎ | ) | ） | ] | 】 | < | 《
# | ＃ | - | － | { | 『 | . | 。
$ | ￥ | _ | —— | } | 』 | > | 》
% | ％ | = | ＝ | ; | ； | / | 、
^ | …… | + | ＋ | : | ： | ? | ？

参见：自定义中文符号


缺省的双拼编码表

;双拼编码范围为A到Z。为醒目起见，双拼编码采用大写英文字母；
;在实际输入过程中，只能使用小写英文字母。

[声母]
;双拼编码就是它本身的声母不必列出
ch=A
sh=I
zh=U

[韵母]
;双拼编码就是它本身的韵母不必列出
ai=P
an=R
ang=S
ao=Q
ei=K
en=W
eng=T
er=J
ia=X
ian=F
iang=G
iao=B
ie=D
in=Y
ing=C
iong=H
iu=J
ong=H
ou=Z
ua=X
uai=Y
uan=L
uang=G
ue=N
ve=N
ui=N
un=M
uo=O

[零声母音节的韵母]
;在零声母音节情况下，韵母优先使用本节中的定义：
;本节中有定义时使用本节中的定义，本节中未定义时使用“韵母”节中的定义。
a=OA
ai=OP
an=OR
ang=OS
ao=OQ
e=OE
ei=OK
en=OW
eng=OT
er=OJ
o=OO
ou=OZ

参见：自定义双拼编码


软键盘图示

常用符号：

标点符号：

特殊符号：

表格线：

数字序号：

数学符号：

单位符号：

拼音符号：

注音符号：

日文平假名：

日文片假名：

希腊字母：

俄文字母：

参见：使用软键盘


疑难解答

  • 输入法打开时，报告“词库文件打开失败”错误
  • 打开输入法能看见状态条，无法输入中文，但可以切换到英文状态输入英文
  • 输入单个字，或者在用户自造词过程中选择单字时，输入法报告错误
  • 关闭输入法时，发现输入法引擎的进程仍在系统中运行
  • 在某些应用软件中，设置了光标跟随功能但不起作用
  • 在某些应用软件中，输入栏窗口被应用程序窗口覆盖而无法看见输入情况
  • 单字输入时，候选字的排序变化不定
  • 候选字词中以不同颜色显示各代表什么？
  • 输入法设置为中文符号输入，但为什么有时输入的是英文符号
  • 最近输入的一个词没有记入用户词库中，为什么？

  • 紫光拼音输入法是否支持整句输入？


疑难解答：词库文件打开失败

词库文件打开失败很可能是紫光拼音输入法的词库受到破坏。词库文件打开失败将导致无法输入中文。

以下说明如何恢复用户词库文件。

首先，您可以试着从其它机器复制用户词库文件(如果有且用户名相同的话)。

或者，直接删除用户词库文件，如果系统词库文件完好，输入法在下次打开时，将从系统词库文件重新生成用户词库文件。

如果系统和用户词库文件均已破坏，请删除上述文件后重新安装输入法。

如果您的词库有备份，安装后可以从词库备份文件中恢复。

词库文件受到破坏的原因通常是紫光拼音输入法引擎没有正常关闭导致的，因为输入法引擎打开了用户词库文件，而引擎仅在所有紫光拼音输入法的接口全部关闭后才退出。

关于词库文件的存放和文件名，参见“输入法相关文件”中的说明。


疑难解答：无法输入中文

如果可以打开输入法，并可以输入英文，但无法打开输入栏窗口输入中文，这种情况通常是由于用户词库文件受到破坏引起。

解决办法是恢复用户词库文件。参见“疑难解答：词库文件打开失败”。

此外，输入法引擎的申请内存失败等意外错误导致引擎不能正常运行时，也将导致此错误现象。


疑难解答：选择单字输入法时出错

疑难解答：选择单字输入时出错

选择单字输入时出错是指在输入单字中文字时，或者在用户造词中选择单字时，输入法引擎报告出错。

该错误通常由于输入法的单字缓存文件损坏导致，删除单字缓存文件即可解决该错误问题。

关于单字缓存文件的存放和文件名，参见“输入法相关文件”中的说明。


疑难解答：残留的输入法引擎进程

属正常情况，这个进程(UPEngine)是紫光拼音输入法的搜索组词引擎。

在Windows 95/98/NT/2000系统中，每个应用程序将独立开启一个用到的输入法进程。 为避免系统资源浪费，紫光拼音输入法采用输入法的核心(搜索组词引擎)和输入法接口部分分离的方式开发实现，核心引擎仅在系统中留有一份。

如果过一段时间没有打开输入法，输入法引擎会自动退出。

建议不要强行关闭输入法引擎进程，因为引擎进程打开了用户词库，强行关闭可能导致打开的用户词库受到破坏。
此外，也应尽量避免由于应用程序错误而导致输入法引擎没有正常关闭。


疑难解答：光标跟随无效

属正常情况，通常发生在使用英文应用软件时。
原因是英文应用软件没有考虑多语言输入法接口，输入法无法获取当前光标的位置信息。

这时，紫光拼音输入法将自动禁止光标跟随功能，并把输入栏窗口固定在屏幕中下部。您也可以使用输入法系统菜单中的“光标跟随”菜单项关闭光标跟随功能。


疑难解答：输入栏窗口被覆盖

这种情况通常发生在一些采用英文语言的应用软件中。输入法窗口被应用程序窗口覆盖而影响输入。

导致这种情况的原因是英文应用软件没有考虑多语言的输入法接口。
这种情况下，紫光拼音输入法将自动禁止光标跟随功能，而将输入栏窗口固定在屏幕中下部。您可以使用鼠标将输入栏窗口拖动到覆盖窗口之外。


疑难解答：候选字的排序顺序变化不定

在打开“最近输入的字优先候选”选项时，候选字的排序将随着最近所使用的字而变化。

如果候选字的排序顺序变化不定，是由于打开了“按照前次输入字词动态调整字序”选项导致的。该选项开启时，候选字将根据前次输入的字词，按照输入的可能性，重新进行字序排序。

参见输入法的高级智能特性说明中的“动态调整字序”。


疑难解答：候选字词的不同颜色代表什么

候选字词列表中，绿色词是输入法的智能组词功能帮您组成的动态词；紫色字词是缺省的候选字词；蓝色为其它字词。

绿色的智能组成词不能删除(参见高级智能特性说明中的“关于智能组词”)。

紫色的缺省候选字词是可选的，选择缺省候选通常用于以词定字(参见以词定字)。


疑难解答：中文符号状态下输入的是英文符号

在以下三种情况下，即使处于中文符号状态，键入英文符号键将直接输入英文符号。

1. 设置了“数字后面跟随英文符号选项”，当输入数字后键入符号键，将输入英文符号；
2. 使用中文符号定义功能，将符号键定义为英文符号；
3. 在键盘的大写输入状态(Caps Lock)下，将输入英文。


疑难解答：上次输入的词没有记入词库

输入法的自动造词功能会将用户组出的词记入用户词库中，但对于输入法智能组出的词，是否记入词库将根据选项配置而定。

输入时，键入拼音串后，以绿色显示的候选词即属于输入法智能组出的动态词。如果设置了“智能组词”选项，但没有选择“智能组词的词自动记忆到用户词库”选项时，智能组成的词不加入到词库中。

参见：输入法的高级智能特性说明中的“关于智能组词”，输入法属性设置中的高级设置。


疑难解答：是否支持整句输入

紫光拼音输入法是字词和短语输入法，不支持整句输入。

紫光拼音输入法将一次字词和短语输入的长度限制在9个汉字。

紫光拼音输入法的设计出发点是希望用户能够自然、快速地输入汉字，因此设计上考虑了在输入过程中尽可能降低重码选择和反复性的选择。

所以，使用紫光拼音输入法时，您不妨在想到字词和短语的时候，立刻键入拼音输入它们，而无须等到自己造完句子。


快速掌握

快速掌握(适用于高级用户)

本节是为已经熟悉拼音输入的高级用户准备，简要说明紫光拼音输入法的使用技巧和相关操作。

输入风格的选择

紫光拼音输入法提供两种可选的输入风格，一是输入拼音串后按空格再显示汉字，二是输入拼音串同时显示汉字，均可使用光标跟随。

全拼和双拼

可选择使用全拼或双拼。可使用不完整拼音输入。双拼时可实时提示编码信息，双拼编码可定义。

记忆造词和自动隐藏低频词

用户输入时自动造词，可设置是否需要自动隐藏低频词。

删词

候选窗口中显示该词后，使用Ctrl+Shift+相应的字母或数字键删除相应的词。

智能组词

词库中没有的词，输入法能自动组词，以绿色显示，不能删除，可自动加入到用户词库。该功能可屏蔽。

动态调整字序

根据前次输入调整候选字序。该功能可屏蔽。

数字后面跟随英文符号

输入数字之后紧随着输入的符号，将以英文符号输入。该选项可屏蔽。

模糊音

共11组，可选择。对双拼有效。

以词定字

用Shift+数字(或字母)键指定活动候选，以“[”和“]”键选择词中的第一个字和最后一个字。可以连续输入多个词的拼音串后逐词定字。以词定字键可配置。

输入英文和数字

大小写结合英文可直接上屏，字母“v”后所跟英文串直接上屏。NumLock开启时可直接输入小键盘上的小数点和英文运算符。
使用“i”和“u”可以输入中文数字和常用符号。

用户定制

定制功能强大，建议使用属性设置定制您自己的输入风格。

常用中文标点

英文键对应的中文符号可自定义。 缺省的常用标点定义是：大小于号(“<”和“>”)对应书名号(“《”和“》”)，正斜杠(“/”)对应顿号(“、”)，下划线号(“_”)对应破折号(“——”)，上尖角号(“^”)对应省略号(“……”)，引号有开闭状态。 中文标点输入是可自定义的。

常用热键

Shift或Ctrl切换中英文输入方式；多候选时，缺省使用大小于号翻页；左右Shift或左右Ctrl可用于输入第二、第三个候选字词。 Enter可用于输入英文或输入默认的候选字词。ESC取消输入。使用属性设置中的功能键设置定义一些功能键的使用。