
Understanding Performance Monitor

Performance Monitor is a graphical tool for measuring the performance of your own computer or other 
computers on a network. On each computer, you can view the behavior of objects, such as processors, memory, 
cache, threads, and processes. Each of these objects has an associated set of counters that provide information 
about device usage, queue lengths, delays, and information used to measure throughput and internal 
congestion.
It provides charting, alerting, and reporting capabilities that reflect both current activity and ongoing logging. You
can open, browse, and chart log files later as if they reflected current activity.

The following overview lists how you use Performance Monitor to view the performance of objects:
Simultaneously view data from any number of computers.
View and dynamically change charts reflecting current activity and showing counter values that are 

updated at a user-defined frequency.
Export data from charts, logs, alert logs, and reports to spreadsheet or database programs for further 

manipulation and printing.
Add system alerts that list events in the Alert Log and notify you either by reverting to Alert view, logging 

the event in Event Viewer's Application log, or issuing a network alert.
Run a predefined program either every time or only the first time a counter value goes over or under a 

user-defined value.
Create log files containing data about objects on different computers.
Append selected sections of existing log files to a single file, forming a long-term archive.
View current-activity reports or create reports from existing log files.
Save individual chart, alert, log, and report settings, or save the entire workspace setup to reuse when 

needed.



Understanding Objects, Counters, and Instances

When monitoring a system, you are really monitoring the behavior of its objects. In the Windows NT operating 
system, an object is a standard mechanism for identifying and using a system resource. Objects are created to 
represent individual processes, sections of shared memory, and physical devices. Performance Monitor groups 
the counters by object type. A unique set of counters exists for the processor, memory, cache, hard disk, 
processes, and other object types that produce statistical information. Certain object types and their respective 
counters are present on all systems. However, other counters, such as application-specific counters (such as 
Exchange), appear only if the computer is running the associated software.
Each object type can have several instances. For example, the Processor object type will have multiple instances
if a system has multiple processors. The PhysicalDisk object type has two instances if a system has two disks. 
Some object types, such as Memory and Server, do not have instances. If an object type has multiple instances, 
each instance may be used with the same set of counters. The data is then tracked for each instance.
Two object types, Process and Thread, have a particularly close relationship. A Windows NT process is created 
when a program runs. A process may be either an application (such as Microsoft Word or Corel Draw), a service 
(such as Event Log or Computer Browser), or a subsystem (such as the print spooler or POSIX). In addition to an 
executable program, every process consists of a set of virtual-memory addresses and at least one thread.
Threads are objects within processes that execute program instructions. They allow concurrent operations within 
a process and enable one process to simultaneously execute different parts of its program on different 
processors. Each thread running on a system shows up as an instance for the Thread object type and is identified
by association with its parent process. For example, if Print Manager has two active threads, Performance 
Monitor identifies them as Thread object instances Printman ==> 0 and Printman ==> 1.

Note
Instances of the Process object-type appear as numbers if they are internal system processes. Other types 

of processes are identified by the name of the executable file. Only 32-bit processes appear in the Instances box; 
16-bit applications running in a Virtual DOS Machine (VDM) do not appear unless they are started in a separate 
memory space.

{button ,AL("LM_act_dsk_cntrs")} Related Topics



New

Creates a new chart, alert settings display, log settings display, or report settings display, depending upon which
window you are in.

{button ,ALink("LM_wwcb_how_pm;LM_wwlb_how_pm;LM_wwab_how_pm;LM_wwrb_how_pm”)} Related Topics



Save Settings

Saves the current chart, alert, log, or report settings with a previously assigned filename, depending upon which 
window you are in. If no name has been assigned, the Save As dialog box appears.

{button ,AL("LM_ss_how_pm")} Related Topics



Add To

Adds selections to the chart, alert, log or report, depending upon which window you are in. 

{button ,AL("LM_acs_how_pm;LM_atal_how_pm;LM_aas_how_pm;LM_atar_how_pm")} Related Topics



Edit

Changes a selected chart line in the Chart window or an alert entry in the Alert window. 

{button ,AL("LM_ccs_how_pm;LM_cas_how_pm")} Related Topics



Clear Display

Clears the display.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Delete From

Deletes the selected item from the chart, alert log, log, or report.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Chart, Alert, Log, or Report

Customizes the available options in the various Performance Monitor windows. 

{button ,AL("LM_cco_how_pm;LM_clo_how_pm;LM_cao_how_pm;LM_cro_how_pm")} Related Topics



New Chart

Creates a new chart.

{button ,AL("LM_wwcb_how_pm")} Related Topics



Save Chart Settings

Saves the current chart settings with a previously assigned filename. If no name has been assigned, the Save 
As dialog box appears. 

{button ,AL("LM_acs_how_pm;LM_ss_how_pm")} Related Topics



New Alert Settings

Creates a new alert settings display.

{button ,AL("LM_wwab_how_pm")} Related Topics



Save Alert Settings

Saves the current alert settings with a previously assigned filename. If no name has been assigned, the Save As
dialog box appears.

{button ,AL("LM_aas_how_pm;LM_ss_how_pm")} Related Topics



New Log Settings

Creates a new log settings display.

{button ,AL("LM_wwlb_how_pm")} Related Topics



Save Log Settings

Saves the current log settings with a previously assigned filename. If no name has been assigned, the Save As 
dialog box appears. Performance Monitor also saves the log filename with the log settings file and will start 
logging data to that file upon reopening that settings file.

{button ,AL("LM_atal_how_pm;LM_ss_how_pm")} Related Topics



New Report Settings

Creates a new report settings display.

{button ,AL("LM_wwrb_how_pm")} Related Topics



Save Report Settings

Saves the current report settings with a previously assigned filename. If no name has been assigned, the Save 
As dialog box appears.

{button ,AL("LM_atar_how_pm;LM_ss_how_pm")} Related Topics



Exit

Quits Performance Monitor.

{button ,AL("LM_sqpm_how_pm")} Related Topics



Delete From Chart

Deletes the selected counter from the chart.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Delete Alert

Deletes the selected counter from the alert log.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Delete From Log

Deletes the selected object from the log.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Delete From Report

Deletes the selected item from the report.

{button ,AL("LM_cdvds_how_pm")} Related Topics



Chart

Displays the Chart window.

{button ,ALink("")} Related Topics



Alert

Displays the Alert window.

{button ,ALink("")} Related Topics



Log

Displays the Log window.

{button ,AL("LM_wwlb_how_pm")} Related Topics



Report

Displays the Report window.

{button ,AL("LM_wwrb_how_pm")} Related Topics



Menu and Title

Displays the menu bar and title bar at the top of the window. 

Tip
You can double-click anywhere in the display area that does not contain text information to show or hide 

the menu bar and title bar. To move the window while the title bar is hidden, click anywhere in the display area that 
does not contain text information and drag the mouse to move the window.

{button ,AL("LM_oys_how_pm")} Related Topics



Toolbar

Displays the toolbar beneath the menu bar at the top of the window.

{button ,AL("LM_oys_how_pm")} Related Topics



Status Bar

Displays the status bar at the bottom of the window. The status bar shows whether the data is from current 
activity or an existing log file.

{button ,AL("LM_oys_how_pm")} Related Topics



Always On Top

Keeps this program window stays visible over any other window on the display, even when another window is 
active.

{button ,AL("LM_oys_how_pm")} Related Topics



Update Now

Immediately updates the data in the display.

{button ,AL("LM_um_how_pm")} Related Topics



Contents

Starts Help and displays the topics in Help.



Search for Help on

Opens the Index tab for Help. You can look up Help information by using keywords on this tab. 



How to Use Help

Describes how to use Help.



About Performance Monitor

Displays version, mode, and copyright information about Performance Monitor. 



System menu

The System menu contains the following commands: 

Restore
Restores the window to its former size after it has been maximized or minimized. 

Move
Enables you to use the keyboard to move the window to another position. 

Size
Enables you to use the keyboard to change the size of the window. 

Minimize
Reduces the window to an icon. 

Maximize
Enlarges the window to its maximum size. 

Close
Quits Control Panel, or closes a window or dialog box. 

Switch To
Opens Task List, which you can use to switch between running applications or to rearrange their windows and 
icons on your desktop. 



File Open

Used to specify the path to a file you want to open.
Click the following buttons for information about the dialog box:
 File name
 Files of type
 Look in

{button ,ALink("M_wwcb_how_pm;LM_wwlb_how_pm;LM_wwab_how_pm;LM_wwrb_how_pm")} Related Topics



Save As

Used to save the settings for a file and assign a filename.
Click the following buttons for information about the dialog box:
 File name
 Save as type
 Save in

{button ,AL("LM_ss_how_pm")} Related Topics



Save Workspace As

Used to save the settings for all four windows to a single file.
Click the following buttons for information about the dialog box:
 File name
 Save as type
 Save in

{button ,AL("LM_ss_how_pm")} Related Topics



Export As

Used to export charts, alert logs, logs, and reports to spreadsheet or database programs for further manipulation
and printing.
Click the following buttons for information about the dialog box:
 File name
 Files of type
 Save in

{button ,ALink("")} Related Topics



Add to Chart

Used to select the computer to be monitored and add appropriate objects, counters, and instances. 
To make the graphs more readable, you can vary the scale of the displayed information and the color, width, and
style of the line for each counter as you add it to the chart. You can also modify these properties after you add a 
selection.
Click the following buttons for information about the dialog box:
 Computer
 Object
 Counter
 Instance
 Color
 Scale
 Width
 Style
 Explain Button
 Add Button

{button ,AL("LM_acs_how_pm")} Related Topics



Add to Alert

Used to create an alert log that enables you to monitor the current performance of selected counters and 
instances for objects. 
Click the following buttons for information about the dialog box:
 Computer
 Object
 Counter
 Instance
 Color
 Alert If
 Run Program on Alert
 Explain Button
 Add Button
 Done Button

Notes
With the alert log, you can monitor several counters at the same time. When a counter exceeds a given 

value, the date and time of the event are recorded in the Alert window. A total of one thousand events are recorded,
after which the oldest event is discarded when the next new one is added. The event can also generate a network 
alert. When an event occurs, you can run a specific program every time or just the first time it occurs. 

When an alert occurs while you are not in the Alert view, an alert icon appears in the status bar showing 
the number of alerts that have occurred since you were last in the Alert view.

{button ,AL("LM_aas_how_pm")} Related Topics



Add to Log

Used to create a log file that enables you to review at a later time the performance of counters and instances for 
objects. 
You can also collect data from multiple systems into a single log file. Log files contain detailed data for 
bottleneck detection or other detailed analysis. For capacity planning, you need to view trends over a longer 
period, which requires the ability to create a log file and to produce reports from that file.
Click the following buttons for information about the dialog box:
 Computer
 Objects
 Add Button
 Done Button

{button ,ALink("")} Related Topics



Add to Report

Used to create reports showing current information on counter and instance values for selected objects. 
The information is presented in columns for each individual instance. You can create a report on all the counters 
for a given object and then watch them change under various loads. You can also create reports to reflect the 
same information that you are charting or to monitor other specific situations. 
Click the following buttons for information about the dialog box:
 Computer
 Object
 Counter
 Instance
 Explain Button
 Add Button
 Done Button

{button ,AL("LM_atar_how_pm")} Related Topics



Edit Chart Line

Used to change how a selected counter is represented on the chart. 
You can change the scale at which you graph the counter information to display the activity more in the center of
the chart, but the actual reported values are not changed. You can also vary the color, style, and width used to 
make each counter's line stand out better.
Click the following buttons for information about the dialog box:
 Color
 Scale
 Width
 Style
 Explain Button

Note
You can change only those options that are not gray.

{button ,AL("LM_ccs_how_pm")} Related Topics



Edit Alert Entry

Used to change the criterion for receiving an alert, what program to run and how often to run it, and the color 
used to display certain alerts.
Click the following buttons for information about the dialog box:
 Color
 Alert If
 Run Program on Alert
 Explain Button

Note
You can change only those options that are not gray.

{button ,AL("LM_cas_how_pm")} Related Topics



Input Log File Timeframe

Used to specify how much information you want to display. 
You can select either Scroll Bars or Bookmarks, or both.
Click the following buttons for information about the dialog box:
 Scroll Bars
 Bookmarks

{button ,AL("LM_cttw_how_pm")} Related Topics



Chart Options

Used to customize the charts that you create.
Click the following buttons for information about the dialog box:
 Legend
 Value Bar
 Vertical Grid
 Horizontal Grid
 Vertical Labels
 Gallery
 Vertical Maximum
 Update Time

{button ,AL("LM_cco_how_pm")} Related Topics



Alert Options

Used to specify the alert interval and method of alert notification.
Click the following buttons for information about the dialog box:
 Switch To Alert View
 Log Event In Application Log
 Network Alert
 Update Time

{button ,AL("LM_cao_how_pm")} Related Topics



Log Options

Used to specify the complete path and name of the log file, the log interval, and the status (Collecting or Closed) 
of the log file.
Click the following buttons for information about the dialog box:
 Log File
 Update Time
 Relog File Button
 Start Log Button

{button ,AL("LM_clo_how_pm")} Related Topics



Report Options

Used to change the Report Interval time for updating the information displayed in the report.

To set Update Time
Click either Periodic Update or Manual Update.

If you click Periodic Update, enter a number in Interval to represent how often you want the report to be 
updated.

{button ,AL("LM_cro_how_pm")} Related Topics



Data From

Used to choose whether to view information from current activity or existing log files.

To set Data Values Displayed From
Click one of the following:
Click Current Activity to see information based on current activity.
Click Log File to see information from an existing log file, and enter the log filename under Data values 

displayed from.

{button ,AL("LM_self_how_pm")} Related Topics



Add Bookmark

Used to make log files more usable by adding bookmark comments. 
Bookmarks serve as reminders of the circumstances under which the file was created or by highlighting major 
points of interest. You can then refer to these bookmarks when you work with the log file later.
Bookmarks can be added in the Log view only when starting the log file.

Bookmark Comment
Type an appropriate comment in the box, and then click Add.

{button ,AL("LM_ab_how_pm")} Related Topics



Select Computer

Used to select a computer from the list of those contained in your log file.

Computer
Enter the computer name.

Select Computer
Lists the names of the computers contained in the log file. 

Select the name of the computer with whose data you want to work, and then click OK.

{button ,AL("LM_cilf_how_pm;LM_sailf_how_pm;LM_rilf_how_pm;LM_rbilf_how_pm")} Related Topics



Select Computer

Used to select a computer from the network.

Computer
Enter the computer name.

Select Computer

1 Double-click the name of the appropriate domain controller or workgroup to display a list of the servers and 
workstations connected to it. 

2 Select the name of the server or workstation that you want to monitor, and then click OK.

Note
The first time you use Select Computer, there may be some delay while the program searches the 

accessible domains and workgroups for member computers. 

{button ,AL("LM_sadc_how_pm")} Related Topics



Open Input Log File

Used to specify the path to a log file you would like to open.
Click the following buttons for information about the dialog box:
 File name
 Files of type
 Look in

{button ,AL("LM_self_how_pm")} Related Topics



File name

Used to specify the name of the file you want to open.



Files of type

Lists the available file formats, depending on whether you are opening a chart, alert, log, report, or workspace.



Look in

Lists the available folders and files. 
To see how the current folder fits in the hierarchy on your computer, click the down arrow. To see what’s inside a 
folder, click it. 
The box below Look in shows the folders and files in the selected location. You can double-click a folder or file in
that box to open it. To open the folder one level higher, click the up folder button on the toolbar.



Save in

Lists the available folders and files. 
To see how the current folder fits in the hierarchy on your computer, click the DOWN ARROW. To se what’s inside a 
folder, click it. 
The box below Save in shows the folders and files in the selected location. You can double-click a folder or file in
that box to open it. To open the folder one level higher, click the up folder button on the toolbar.



File name

Used to specify the name of the file you want to open.



Save as type

Lists the available file extensions, depending on whether you're saving a chart, alert, log, report, or workspace.



File name

Used to specify the name of the file you want to open.



Files of type

Lists the available file formats. The formats available depend on whether you're exporting with Tab delimiters or 
Comma delimiters.



Computer

Used to specify the workstation or server that you want to monitor. Your workstation or server appears as the 
default computer.

To monitor a different computer, enter the computer's name.

Tip
Click Select Computer to see the names of the domains or workgroups to which you have access. The 

first time you use this, there may be some delay while the program searches the accessible domains and 
workgroups for member computers.



Object

Used to select an object to monitor from those that are available on the chosen computer.



Counter

Used to select one or more counters. 

Tip
For a definition of the selected counter, click Explain.



Instance

Used to select one or more instances if appropriate.



Color

Used to assign colors to a group of counters or simply to reflect your personal preferences.



Scale

Used to change the scale at which the information is displayed. The numbers shown in the value bar, however, 
are not scaled.



Width

Used to make the line thicker or thinner. 

Tip
Thick lines cannot be styled.



Style

Used to assign a different style to a new line.

Note
Thick lines cannot be styled.



Explain Button

Displays a definition of the selected counter.



Add Button

Adds your selections.

Note
You can continue to select additional items to monitor.



Done Button

Closes the Add To dialog box and returns to the display window.



Alert If

Used to change the alert warning criterion.
Click either Over or Under and enter a value that is appropriate for that counter.



Run Program on Alert

Used to change how often the program is run or to change to a different program.
Click either First Time or Every Time, and type the complete path name for the program that you want 

to run whenever the specified alert occurs.



Objects

Used to select an available object or set of objects to monitor on a selected computer.



Done Button

Closes the Add To dialog box and returns to the display window.



Done Button

Closes the Add To dialog box and returns to the display window.



Legend

Displays the legend and legend-information area.



Value Bar

Displays the values for the counters in the legend.
The chosen graph-time interval is reflected in the value bar, which also displays the last, average, minimum, and
maximum values.



Vertical Grid

Displays vertical grid lines.



Horizontal Grid

Displays horizontal grid lines.



Vertical Labels

Displays labels on the vertical axis.



Gallery

Sets the information display for either Graph format or as a Histogram.

Tip
The Histogram view is useful for viewing the simultaneous behavior of many instances of the same object.



Vertical Maximum

Sets the maximum value to which the vertical axis should extend.



Update Time

Used to set either Periodic Update or Manual Update.

Notes
If you select Periodic Update, you must enter a number in Interval to set the time (in seconds) between 

updates of the charts.
The Graph Time value displayed in the value bar shows the time, in seconds, that it takes to create a 

complete chart across the window. 



Switch To Alert View

Displays the Alert window whenever an alert occurs.



Log Event In Application Log

Logs an event in Event Viewer Application log.



Network Alert

Sends a message to the specified network name when an alert occurs.



Update Time

Used to set either Periodic Update or Manual Update.

Note
If you select Periodic Update, you must enter a number in Interval to set the time (in seconds) between 

updates of the alert log.



Update Time

Used to set either Periodic Update or Manual Update.

Note
If you select Periodic Update, you must enter a number in Interval to set the time (in seconds) between 

updates of the charts.



Data Values Displayed From
Click Current Activity to see information based on current activity.
Click Log File to see information from an existing log file, and enter the log filename.



Bookmark Comment
Type an appropriate comment in the box, and then click Add.



Scroll Bars
To change the starting and stopping points to be used, drag the corresponding end of the slider.



Bookmarks
To use bookmarks as starting or stopping points, select the appropriate bookmark and then click either Set

As Start or Set As Stop.
The time interval slide bar changes to show your time window.



Log File
In Filename, type a name for the log file that you are creating. 

If this is the name of an existing file, the new data will be appended to the old data.

Note
You can use Folders and Drives to specify a different folder for the log file.



Update Time
Click either Periodic Update or Manual Update.

If you select Periodic Update, enter a number in Interval to represent how often you want the log to be 
updated.



Relog File Button

Relogs the selected log file.



Start Log Button

Starts logging.
A log symbol with the changing total file size appears on the right side of the status bar and remains there in 
all four views.



Computer

Used to enter a computer name.



Select Computer

Lists the names of the computers contained in the log file. 
Select the name of the computer you want to monitor, and then click OK.



Select Computer

The names of the domains or workgroups to which you have access appear in the box. The first time you use 
this, there may be some delay while the program searches the accessible domains and workgroups for member 
computers. 
1 Double-click the name of the appropriate domain controller or workgroup to display a list of the servers and 

workstations connected to it. 
Select the name of the server or workstation that you want to monitor. 

2 Click OK.



Specifies (when Periodic Update is selected) how often the selected objects are logged.



Specifies that the selected objects will logged only when you manually update the log (by clicking Update Now 
on the Options menu).



Specifies to automatically log data for the selected objects at the time interval specified in Interval.



Click this to start logging. Start Log is unavailable if you have not selected an object to log.



Click this to stop logging.



Click Help Topics for a list of Help topics. 



Starting and Quitting Performance Monitor

Performance Monitor consists of four main windows, which you display by clicking Chart, Alert, Log, or Report 
on the View menu. These windows contain different information and have only the menu bar, status bar, and 
toolbar in common. You can press the F1 key to see Help about any Performance Monitor command.
On the Options menu, Data From is available in any of the four windows. Use this command to switch from 
working with current values for current activity (real time data) to viewing and manipulating existing log files. 
The default is current activity. 
To quit Performance Monitor, click Exit on the File menu. Be sure to save your individual chart, alert, log, or 
report settings or the entire workspace to a file before quitting, unless you are sure you will not need that exact 
combination of settings again.

{button ,AL("LM_ss_how_pm;LM_oys_how_pm")} Related Topics



Saving Settings

To save settings for one Performance Monitor window

1 On the File menu, click the corresponding Save Settings command.
If you have not already assigned a filename, the Performance Monitor - Save As dialog box appears.

2 Enter a name in File name, and click Save. 
The assigned filename now appears in the status bar.

To simultaneously save settings from all four windows

1 On the File menu, click Save Workspace. 
2 In the Performance Monitor - Save Workspace As dialog box, enter a name in File name, and click Save.

{button ,AL("LM_wca_how_pm;LM_wh_how_pm")} Related Topics



Organizing Your Screen

To show or hide a display option
On the Options menu, click the display options you want: Menu and Title, Toolbar, Status Bar, and 

Always On Top. 
A check mark appears by selected commands. 

To hide the menu bar and title bar
Double-click anywhere in the display area that does not contain text. 

Double-click again to display the menu bar and title bar. 

To move the window while the title bar is hidden
Click anywhere in the display area that does not contain text and drag. 

To turn on chart highlighting 
Press CTRL+H. 

The selected counter in the legend changes to white. 
To stop highlighting selected counters, press CTRL+H again. 

Note
You can view any of four Performance Monitor windows: Chart, Alert, Log, or Report. The only consistent 

elements in the four windows are the display options: Menu and Title, Toolbar, Status Bar, and Always On Top.
By showing or hiding any of these options, you can vary the amount of screen space available for display. Always 
On Top ensures that Performance Monitor, even when no longer the active window, stays visible over any other 
window on the display.

{button ,AL("LM_wca_how_pm;LM_wh_how_pm")} Related Topics





Activating the Physical and Logical Disk Counters

To activate the physical and logical disk counters

1 Log on as a member of the Administrators group. 
2 At the command prompt, type diskperf to view Help on how to turn on and turn off diskperf, and how to 

specify a remote computer. 
It will also state whether or not the disk performance counters have been activated already on that computer.

3 Restart the computer to activate the disk-performance counters.

Notes
You do not need special privileges to open Performance Monitor, but must be logged on as a member of 

the Administrators group to use the diskperf command. 
Disk counters can increase disk access time by approximately 1.5% on 386 processors.



Working with Information on Current Activity

To work in any view with information on current activity

1 On the File menu, click New to open a new settings file.
Or, click Open for an existing settings file.

2 On the Edit menu, click Add To or Edit.
The Add to dialog box or Edit dialog box appears, 

3 Select, change, and then save settings for one or more computers and the appropriate objects, counters, and 
instances.

4 On the File menu, click Save Settings As to save selections in a new settings file. 
Or, click Save Settings to update the current settings file.

5 On the View menu, click Chart, Alert, Log, or Report to change settings for another window; then repeat 
steps 2 through 4 until you have the settings you want. 

Notes
If you have related information in all four windows, click Save Workspace on the File menu to save the 

current settings for all four windows.
You can open a separate chart (.pmc), alert (.pma), log (.pml), or report (.pmr) settings file, or a workspace

(.pmw) file that contains settings for all four windows.

{button ,AL("LM_ss_how_pm;LM_sadc_how_pm")} Related Topics



Selecting a Different Computer

To select a different computer 

1 On the Edit menu, click Add To.
2 In the Add to dialog box, enter the computer name in Computer. 

Or, click the button at the right end of the box to display the Select Computer dialog box, and select a 
computer name.

3 Double-click the name of the appropriate domain controller or workgroup to display a list of the servers and 
workstations connected to it.

4 Select the name of the server that you want to monitor, and click Add.

Notes
Add is not available in the Add to dialog box while Performance Monitor searches for a computer. If the 

computer is found, the Add is enabled again, and the boxes show the default settings of that computer. If the 
computer is not found, a message appears and you revert back to your own computer’s default settings.

If you want to add more counters or objects for a computer that has already been selected, you may also 
select that counter or object from the screen display before choosing the Add To command. The corresponding 
computer will then appear as the default computer.

{button ,AL("LM_wca_how_pm;LM_wh_how_pm")} Related Topics



Clearing the Display vs. Deleting Selections

To clear the values displayed on the screen
On the Edit menu, click Clear Display.

To delete a selection

1 Select the legend, log, or report item that you want to delete.
2 On the Edit menu, click Delete. 

Note
You can use the same approach in all four views to delete either a full screen of information or a single 

selection.

{button ,AL("LM_wca_how_pm;LM_wh_how_pm")} Related Topics



Updating the Display

To update the screen display in any view
On the Options menu, click Update Now.

To change the updating method for an individual view

1 If necessary, select the appropriate window on the View menu, and then click Chart, Alert, Log, or Report 
on the Options menu. 

2 In the Options dialog box, click either Periodic Update or Manual Update.
3 If you selected Periodic Update, type a number in Interval (seconds) to specify the time between updates.

Notes
You can set separate updating Options or switch to manual updates for the individual views.
Time-interval settings also affect the amount of memory and processor time used by Performance Monitor. 

Monitoring is generally not a large burden on processor time or memory unless you retrieve data very frequently 
from a large number of computers.
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Printing a Snapshot of the Window Display

To print a snapshot of the current window

1 Press ALT + PRINTSCREEN to copy a view of the active window. 
If Performance Monitor is maximized, press PRINTSCREEN to copy the whole desktop.

2 Click Start, point to Programs, point to Accessories, and click Paint.
3 On the Edit menu, click Paste.
4 Click Print.

Tip
If you want to save the bitmap to a file, click Save As on the File menu
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Exporting Data

To export data to a spreadsheet or database program

1 On the File menu, click Export.
The Performance Monitor - Export As dialog box appears.

2 In Save as, click either Export TSV Files (*.tsv) or Export CSV Files (*.csv). 
3 Enter a path name (including the appropriate extension for the column delimiter) for the file that you want to 

export, and click Save.
You can now open the exported file from within your spreadsheet or database program and work with the 
information. 

Note
The columns in TSV files are separated by tabs. The columns in CSV files are separated by commas.
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Working with Information from Log Files

To work in any view with information from log files

1 On the Options menu, click Data From, enter an existing log file in Log File, and click OK.
1.Or, click Open on the File menu to open an existing settings file or workspace.
2 On the Edit menu, click Time Window to change the starting and stopping times (if necessary).
3 On the Edit menu, either Add To or Edit and make or change any of the following settings or selections:

The computers you want to monitor.
The objects, counters, and instances you want to monitor.
The manner in which selections are represented.

4 On the File menu, click Save (to update the existing settings file) or Save As (to create a new file).
5 On Options menu, click Chart, Alert, Log, or Report to change any available options, if necessary.
6 Repeat the process in each view, as needed.

Tip
If you have related information in all four windows, click Save Workspace on the File menu to save the 

settings for all four windows in a single file.
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Working with Charts

To view the Chart window
On the View menu, click Chart.

To open an existing chart settings file

1 On the File menu, click Open.
2 In the Performance Monitor - File Open dialog box, enter the path name for the .pmc file containing the 

selections that you want to reuse, and click Open.

To create a new blank chart
On the File menu, click New Chart.

Notes and Tips
For help understanding a selected counter, click Explain in the Add To Chart dialog box.
You can create custom charts to monitor the current performance of selected counters and instances, such 

as the following:
Investigating why a computer or application is slow or inefficient.
Continuously monitoring systems to find intermittent performance bottlenecks.
Discovering why you need to increase capacity.
If you switch to Chart from another view and have not created or opened a chart in your current session, 

the Chart window is blank. 

{button ,AL("LM_acs_how_pm")} Related Topics



Adding Chart Selections

To add objects, counters, and instances to a chart

1 On the Edit menu, click Add To Chart.
The Add To Chart dialog box appears with the default settings and your workstation or server listed in the 
Computer box.

2 In the Object box, select an available object to monitor.
The Counter and Instance boxes change to display the available items for that object on the chosen 
computer.

3 In Counter, select one or more counters. 
For a definition of the selected counter, click Explain.

4 In Instance, select one or more instances, if appropriate.
5 If you do want different color, scale, and line width and style settings from the default, make selections now, 

and then click Add.
6 Repeat the steps 2 through 5 for any additional objects or computers that you want to monitor, and then click 

Done.
If you want to save your chart selections in a settings file, click Save Chart Settings As on the File menu.

Notes and Tips
The scale factor you select is applied to all the currently selected counters. The factor displayed is 

multiplied by the counter value, and the product is charted. Notice, however, that the value bar continues to show 
the actual value, not the scaled value.

A list of your selections appears in the legend at the bottom of the window, and Performance Monitor 
displays the changing values of your selections on the chart. Notice that each displayed value is usually an average 
over the last two data reads, which are separated by the length of the time interval.
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Changing Chart Selections

To change the way a selected counter appears on the chart

1 In the legend, select the counter that you want to change.
2 On the Edit menu click Edit Chart Line. 

The Edit Chart Line dialog box appears.
3 Change any of the available options, as needed:

In Color, select a different line color.
In Scale, select the scale of the vertical display of the line.
In Width, select the width of the line.
In Style, select a solid line or dashed-line pattern.

4 When you have finished making selections, click OK. 
If you want to update chart selections that have been saved in a settings file, click Save Chart Settings on 
the File menu.

Note
To turn the chart-highlighting mode on and change the color of the selected counter to white, press 

CTRL+H. To stop highlighting selected counters, press CTRL+H again.

{button ,AL("LM_cco_how_pm")} Related Topics



Changing the Chart Options

To change chart options

1 On the Options menu, click Chart. 
2 In the Chart Options dialog box, select the options that you want to display.
3 In Vertical Maximum, type the maximum value to which the vertical axis should extend.
4 In Update Time, select either Manual Update or Periodic Update, and then type a number in the Interval 

box to determine the time (in seconds) between chart updates.
5 In Gallery, click Graph or Histogram as the format.

Note
The Graph Time value displayed in the value bar shows the time (in seconds) that it takes to create a 

complete chart across the window.
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Working with Logs

To view the Log window
On the View menu, click Log.

If you are switching from another view, the Log window is blank unless you already created or opened a log file
during that session or from the command prompt. 

To open an existing log settings file

1 On the File menu, click Open.
2 In the Performance Monitor-File Open dialog box, enter the path name for the .pml file containing the 

selections that you want to reuse.
If there is a log filename associated with that log settings file, be aware that Performance Monitor will start 
logging data to that log upon opening that settings file.

3 Click Open.

To create a new blank log file
On the File menu, click New Log Settings.

Note
If you switch to Log from another view and have not created or opened a log in your current session, the 

Log window is blank. 
You can collect data from multiple systems into a single log file. For capacity planning, you need to view 

trends over a longer period, which requires the ability to create a log file and to produce reports from that file. 
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Adding to a Log

To add objects to a log

1 On the Edit menu, click Add To Log.
The Add To Log dialog box appears with the default settings and your workstation or server listed in the 
Computer box.

2 In Objects, select an available object or set of objects to monitor; then click Add.
3 Repeat the process for any additional computers that you want to monitor; then click Done.

To save log selections in a settings file

1 On the File menu, click Save Log Settings As.
2 In the Performance Monitor - Save As dialog box, enter a path name for the file that will contain the 

selections that you want to reuse; then click OK. 

Note
Performance Monitor saves the log filename with the log-settings file and will start logging data to that file 

upon reopening that settings file. 
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Changing the Log Options

To change the log options

1 On the Options menu, click Log. 
2 In Log File, type a name for the log file that you are creating.
3 In Update Time, click either Manual Update or Periodic Update, and then enter a number in the Interval 

box for the time (in seconds) between log updates.
4 If you do not want to start logging yet, click Save.

To start or stop logging

1 On the Options menu, click Log.
2 In the Log Options dialog box, click Start Log.

If Start Log is not enabled, you must first enter a log filename and add objects to log.
3 To stop logging, click Stop Log.

Notes
If you enter the name of an existing log file when you change log options, new data will be appended to 

the old data. To replace the old data, you must first delete the file and then create a new one with the old name. 
After you start logging, a log symbol with the changing total-file size appears on the right side of the status

bar and remains there in all four views.
When a remote computer from which you are logging data shuts down, a bookmark comment is added to 

the log file. Another bookmark comment is added when that computer reconnects and logging starts again.
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Adding Bookmarks

To add a bookmark

1 On the Options menu, click Bookmark. 
2 In Bookmark Comment, type a comment. 
3 Click Add.

{button ,AL("LM_clo_how_pm")} Related Topics



Working with Alerts

To view the Alert window
On the View menu, click Alert. 

To open an existing alert log settings file

1 On the File menu, click Open.
2 In the Performance Monitor - File Open dialog box, enter the path name for the .pma file containing the 

selections that you want to reuse.
3 Click Open.

To create a new blank alert log file
On the File menu, click New Alert Settings.

Notes
If you switch to Alert from another view and have not created or opened an alert log file in your current 

session, the Alert window is blank. 
You can simultaneously monitor several counters. When a counter exceeds a given value, the date and 

time of the event are recorded in the Alert window. An alert file can hold total of one thousand events, after which 
the oldest event is discarded when the next new one is added 

For help understanding what a selected counter shows, click Explain in the Add To Alert dialog box.
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Adding Alert Selections

To add objects, counters, and instances to an alert log

1 On the Edit menu, click Add To Alert. 
The Add To Alert dialog box appears with the default settings and your workstation or server listed in the 
Computer box. 

2 In Object, select an available object to monitor.
3 In Counter, select one or more counters.

For a definition of the selected counter, click Explain.
4 In Instance, select one or more instances, if appropriate.
5 In Alert If, click Over or Under, and add a value.
6 In Run Program On Alert, click First Time or Every Time, and enter the complete path name for the 

program or macro that you want to run whenever the specified alert occurs; then click Add.
7 Repeat the process for any additional objects or computers that you want to, and then click Done.

To save alert log selections in a settings file

1 On the File menu, click Save Alert Settings As. 
2 In the Performance Monitor - Save As dialog box, enter a path name for the new file, and click Save. 

Notes and Tips
Each alert value is usually an average over the last two data reads, which are separated by the length of 

the time interval.
When an alert occurs while you are not in the Alert view, an alert icon appears in the status bar showing 

the number of alerts that have occurred since you were last in the Alert view.
You can set the color assigned to a counter from within the Add to Alert dialog box if you do not want the 

default color selection. 
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Changing Alert Selections

To change how a selected counter is represented in the alert log

1 On the Edit menu, click Edit Alert. 
2 Set changes for any of the available options:

In Color, select a different line color, if necessary.
In Alert If, click Over or Under, and enter a number for the alert-warning criteria.
In Run Program on Alert, click First Time or Every Time, and enter the complete path name for the 

program that you want to run whenever the specified alert occurs.
4 When you have finished making selections, click OK. 

To update alert log selections that have been saved in a settings file
On the File menu, click Save Alert Settings. 

Note
If you want to update selections that have been saved in a settings file, click Save Alert Settings on the 

File menu.
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Changing the Alert Options

To change alert options

1 On the Options menu, click Alert. 
2 In the Alert Options dialog box, click to select any combination of Switch To Alert View, Log Event In 

Application Log, and Send Network Message.
3 In Network Alert, type the name of the alert-recipient’s computer in Net Name, but without typing 

backslashes (\\).
4 In Update Time, click Manual Update or Periodic Update; if you click Periodic Update, type a number in 

Interval to set the time (in seconds) between updates. 

Note
The Messenger service must already be started and the net name defined on the recipient's computer. To 

do so, at the command prompt, type net start messenger /? and net name /? to view Help information on how to 
use these commands



Working with Reports

To view the Report window
On the View menu, click Report. 

To open an existing report settings file

1 On the File menu, click Open.
2 In the Performance Monitor - File Open dialog box, enter the path name for the .pmr file containing the 

selections that you want to reuse.
3 Click Open.

To create a new blank report file
On the File menu, click New Report Settings.

Notes
If you switch to Report from another view and have not created or opened a report file in your current 

session, the Report window is blank. 
For help understanding a selected counter, click Explain in the Add To Report dialog box to display the 

Counter Definition box.
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Adding to a Report

To add objects, counters, and instances to a report

1 On the Edit menu, click Add To Report. 
The Add To Report dialog box appears with the default settings and your workstation or server listed in the 
Computer box. 

2 In Object, select an available object to monitor from the list.
3 In Counter, select one or more available counters. 

To see a definition of the selected counter, click Explain.
4 In Instance box, select one or more instances, if appropriate. 
5 Click Add.
6 Repeat the process for any additional objects or computers that you want to monitor, and then click Done.

To save report selections in a settings file

1 On the File menu, click Save Report Settings As. 
2 In the Performance Monitor - Save As dialog box, enter a path name for the file that will contain the 

selections that you want to reuse. 
3 Click Save.

Note
Each displayed value is usually an average over the last two data reads, which are separated by the length

of the time interval.
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Changing the Report Option

To change the report time interval option

1 On the Options menu, click Report. Or click Options on the toolbar.
2 In the Update Time box, select either Manual Update or Periodic Update and then type a number in 

Interval, or open the list and select a number, to determine the time, in seconds, between updates of the 
report. 

3 Click OK.

Note
The Report window shows a blank screen until you add information to it by selecting objects, counters, and

instances to be monitored with the Add To Report command on the Edit menu. The Options menu enables you to
update manually the information on the screen. You can use the Update Now command between automatic data 
updates to get a current snapshot of the situation. Choosing the Report command on the Options menu enables 
you to select either an automatic updating frequency or only manual updates.
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Selecting an Existing Log File

To select an existing log file

1 On the Options menu, click Data From.
2 In Data Values Displayed From, select Log File.
3 In Log File, enter the filename of the log you want to see.
4 Click OK.

Notes
This also activates Time Window in the Edit menu. 
You can move around in a log file (that is, change the start and stop times) by using the Time Window 

command on the view’s Edit menu. The times selected will apply to all four views. 
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Changing the Time Window

To change the time window for the logged information

1 On the Edit menu, click Time Window.
2 In the Input Log File Timeframe dialog box, use one or a combination of both of the following methods to 

specify how much information you want to display. 
To change the starting and stopping points to be used, drag the corresponding end of the time-interval 

slider. 
To use bookmarks as starting or stopping points, select the appropriate bookmark and click either Set As 

Start or Set As Stop.
3 Click OK.

The screen display changes to reflect the selected time frame.

Notes
Changing the times is easiest to do in the Chart window. Add your selections to the chart first. You can then

move the Input Log File Timeframe dialog box out of the way so you can see the gray vertical lines move on the 
chart as you move the ends of the slide bar. Set up a time window with this method that is appropriate for your 
needs and then set your alerts, create reports, or relog the data.

In charting, when you drag the ends of the slider, you also move two gray vertical lines on the chart. 
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Charting Input Log Files

To chart an input log file

1 On the Options menu in the Chart view window, click Data From.
2 Select a log filename from either your own computer or another one on the network.
3 On the Edit menu, click any of the following:

Add to Chart, to choose the counters and computers from which to chart.
Edit Chart Line, to change selection settings.
Delete From Chart, to remove any counters that are not of interest.
Time Window, to change the displayed starting and stopping points.

4 On the Options menu, click Chart to hide or display any items, change the vertical maximum, or change from
a graph format to a histogram.

5 On the File menu, click any of the following commands:
Save Chart Settings As, to update changes made to the current chart-settings file or to create a new file

for these setting selections.
Export Chart, to export the data from the displayed chart to a spreadsheet or database program.
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Setting Alerts on Input Log Files

To set alerts on an input log file

1 On the Options menu in the Alert view window, click Data From.
2 Select a log filename from either your own computer or another one on the network.
3 On the Edit menu, click any of the following commands:

Add To Alert, to choose the counters and computers from which to set alerts.
Edit Alert Entry, to change selection settings.
Delete Alert, to remove any counters that are not of interest.
Time Window, to change the displayed starting and stopping points.

4 On the Options menu, click Alert to select the update-time interval.
5 On the File menu, click any of the following commands:

Save Alert Settings As, to update changes made to the current alert settings file or to create a new file 
for these setting selections.

Export Alert, to export the data from the alert log to a spreadsheet or database program.
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Relogging Input Log Files

To relog an input log file

1 On the Options menu in the Log view window, click Data From.
2 Select a log filename from either your own computer or another one on the network.
3 On the Edit menu, click any of the following commands:

Add To Log, to choose the objects and computers from which to relog.
Delete From Log, to remove any objects that are not needed.
Time Window, to change the displayed starting and stopping points.

4 On the Options menu, click Log to change the log filename, the logging interval, and to start or stop 
relogging.

5 On the File menu, click any of the following:
Save Log Settings As, to update changes made to the current log settings file or to create a new file for 

these setting selections.
Export Log, to export the log setting to a spreadsheet or database program. 

Notes
If you select an existing log file for output, the data will be appended to the end of the file, thus creating a 

single, smaller archive file. To enable the Relog File, you must first provide a filename and select some objects to 
log.

By changing certain options when relogging, you can significantly condense large log files. You can relog 
with a longer time interval either all or only selected objects in an existing log file. You can also change the start 
and stop times and relog only the data within that time frame. 
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Reporting Based on Input Log Files

To create a report from an input log file

1 On the Options menu in the Report view window, click Data From.
2 Select a log filename from either your own computer or another one on the network.
3 On the Edit menu, click any of the following:

Add To Report, to choose which counters from which computers to display in the report.
Delete From Report, to remove any counters that are not interesting or needed.
Time Window, to change the displayed starting and stopping points.

4 On the File menu, click any of the following commands:
Save Report Settings As, to update changes made to the current report settings file or to create a new 

file for these settings selections.
Export Report, to export the data from the report to a spreadsheet or database program.

Note
You can create simple reports from existing log files the same as you would with current activity values. 

However, here the values shown represent the counter values over the selected time frame.
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Installing the Network Monitor Agent

To install the Network Monitor Agent on a Windows NT computer

1 In Control Panel, double-click the Network icon.
2 Click the Services tab, and then click Add.
3 In Network Service, click Network Monitor Agent, and then click OK.

Follow the instructions on screen for providing a path to the Windows NT distribution files and completing 
Setup.

Note
The Network Monitor Agent collects statistics from the computer's network adapter card by putting it in 

promiscuous mode You can view the statistics using Performance Monitor.

{button ,AL("LM_Add_NMA_Counters")} Related Topics



Adding Network Monitor Agent Performance Counters

To add performance counters provided by Network Monitor Agent

1 On the Edit menu, click Add To Chart.
2 Under Object in the Add To Chart dialog box, click Network Segment.
3 In Counter, select the counters that you want to chart.

If necessary, you can select other options now, before you click Done. 

Note
The Network Segment object and associated counters are available only if the Network Monitor Agent is 

installed.
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Enabling Windows NT Event Error Logging

To log Performance Monitor errors to the Event Viewer application log

1 Start Registry Editor (regedt32.exe).
2 On the HKEY_CURRENT_USER subtree, go to the following key:

\Software\Microsoft\PerfMon
3 Double-click ReportEventsToEventLog.
4 Press 1, and click OK.

Note
The change takes effect the next time you start Performance Monitor. You might want to update the 

Emergency Repair Disk to reflect these changes.




