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Nightmare on April 26 
My hard disk crashed when installing Star
Office 5.0 from the CHIP CD (April 1999).
The installation progress bar went as high
as �360%� and then my disk ran out of space.
I used Disk Cleanup to free some space and
uninstalled a few programs and deleted tem-
porary files. When I rebooted, the computer
hung and there was no activity for about 15
minutes. It then asked for the correct system
disk. I used a bootable diskette and the com-
puter booted perfectly. However, when I
removed the diskette and tried to boot again,
the computer gave the same errors. The hard
disk was set up correctly in the CMOS.

My engineer tried to repair the drive
using Norton Disk Doctor, but this worsened
the condition. Now the computer does not
even ask for a boot diskette. It verifies the
memory, recognises the CD-ROM drive and
stops all activity.

This happened on April 26 and my friend
says that a virus probably caused this. What
do I do now? 
Atreya Nitin
Noida

Your friend is right. Variants of the
Win.CIH virus activate on the 26th of
every month, and this April too, many
computers were affected. This virus first
infects the hard disk�removes all parti-
tions and erases the data. It then corrupts
and erases data from the BIOS.

Many programs that allow you to
recover data are available on the Inter-
net. You can try to recover your hard disk

data by downloading a software called
Tiramesu from w w w.zdnet.com. But it is
also possible that your engineer may 
have rendered the recovery of the data
impossible. 

Remember that in an event of a hard
disk crash, it is best to leave the computer
alone. Do not even boot until you have all
resources at hand. Get all the possible
recovery utilities and exercise extreme cau-
tion while deciding on any one. This may
be your last chance at recovering data.

If the boot-up does not ask you for a
boot device, it is possible that the BIOS,
too, is slowly getting corrupted. At such a
time, you can either �flash� your BIOS or
replace it. Even if you fail to recover data
from the hard disk, you can recreate your
partitions and continue using it. Just
remember to install a good anti virus
package as soon as you finish installing
the Operating System.

Forced Decimals in Excel
When I type any number, say 1234, in
Microsoft Excel, it automatically changes to
12.34. I tried selecting the cells and chang-
ing its properties from Format > Cells, but
that did not help. How can I remedy this?

How can I copy a .fot file to another 
computer? If I manually provide its reference
in the System.ini, then it is accepted as a
font, otherwise it is not installed.
Timothy Rhakho
Nagaland

To turn off the feature where a 

decimal place is automatically assigned 
to a number, start Excel and go to Tools >
Options > Edit and disable the Fixed 
Decimal box.

The .fot files are by nature not installed.
They are system fonts and should be on
every Windows OS. Most fonts for 
Windows today are designed as TrueType
Fonts. You will have to manually edit the
system.ini file to install the .fot fonts.

Online, but not On Line
I put up my Web site on Geocities, using 
correct metatags for content and keywords,
but it still does not appear in search results
on any of the search engines. Why?

When I insert an audio CD into my CD-
ROM drive, the CD Player starts to play,
even the indicator shows that it is playing,
but I cannot hear any music. However, I can
play songs on WinAmp and hear them too.
Rohan Desai
Bangalore

CD does not play, Web site does 
not figure on search engines, hard
disk has crashed� these and other
problems solved 

Modify the Edit Properties in Excel to avoid

automatic formatting
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For your Web page to appear on vari-
ous search engines, you have to register
your site with them. Look up details on
the search engine.

Regarding the problem with the audio
CD: the soundcard uses a separate chan-
nel for playing each device it supports
(Wave, MIDI, audio CDs, etc). Make sure
that the Volume Control for the CD is not
set to �Mute�. If it is not, you will have to
open the cabinet and check if the audio
cable from the drive to the soundcard is
connected properly. Remember to 
remove static charge from your body
before you open the cabinet. Refer to the
soundcard�s manual for the correct con-
nections of the cable. (Also look up �60
minutes to music� CHIP April 1998)

Music Mania
How can I play a music file every time 
Windows starts?
S Prabhakar
Erode

You can set a .W AV file to play when
Windows starts by putting it under Con-
trol Panel > Sounds in the Start W indows
option. For playing any other file, create a
l i n k
to it in the Startup folder under the 

Start menu.
A Broken Window

I have been using Windows 98 for the past ten
months. But of late, rebooting the computer
brings up the Windows start-up screen and
then displays this error message on a blue
background: �An internal overflow has caused
this session to halt. Change the STACKS set-
ting in Config.sys and try again.�

Previously there was no Stacks setting in
Config.sys so I tried the value �Stacks=9, 256�
but that did not help. The same error had

occurred earlier, but was corrected by 
Scandisk. This time even Scandisk does not
help. Reinstalling Windows did not help either.
Saurabh Sharma
Jabalpur

Try removing the Stacks setting from
Config.sys. If you are using Stacker, dis-
continue using it. If Config.sys does not
load Extended Memory Managers, add
the command lines either by typing them
or by using MemMaker or a similar tool.
This should solve the problem, even
though most Windows problems are
never rectified by reinstalling the Operat-
ing System. This is because Windows
does not overwrite most files, especially
system files. For this, you would have to
entirely remove and then reinstall 
Windows.

Need More Memory
Whenever I run a DOS application on my
Pentium 120 MHz system with 16 MB RAM,
I get error messages such as �Help Memory
Full� or �Not Enough Memory�. They do not
run under Windows either. The following
lines are present in Config.sys file:

Devicehigh=C:\Windows\Himem.sys
Devicehigh=C:\Windows\Emm386.e
xe noems

Start Windows with a bang!

Problem Chart 
I want to create the following output in
Microsoft Excel [Fig. 1] but when I enter the
following figures, [Fig. 2], I do not get the
right output.

How can I get the desired output using
Excel or any other software?
Sai Shankar
Hapur

You will not be able to get the output
you want using Microsoft Excel, as it
does not allow much flexibility while
customising charts. However, you will
require negative values for the field to be
displayed on the negative axes. For this,
you can either multiply all the values by
-1 or use the following macro.

Sub FillNegative()
ActiveCell.Offset(0,1).Range( A1 ).Sel

ect
ActiveCell.FormulaR1C1 = =RC[-

1]*-1
ActiveCell.Select
Selection.Copy

Do While ActiveCell.Offset(0, -
1).Value          <> 0

ActiveSheet.Paste
ActiveCell.Offset(1, 0).Select
Loop
End Sub

This macro, when run, will fill nega-
tive values in the column next to the
selected cell starting from that cell down-
wards till it finds a blank cell. You can
either cut and paste the column on to 
the original, or use the new column for
your chart.

Alternatively, you can copy the
desired columns into Microsoft Word,
where you can also create a chart. Once
you have created the chart, right-click
and ungroup it. Now move theFig 1: Desired Output

Fig 2: Graph in Excel
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DOS=UMB
DOS=High
Files=80
Device=C:\sbcd\drv\sbide.sys

/d:mscd001 /P:1e8,11 /v
The Autoexec.bat has these lines:
REM � By Windows Setup � C:\Win-

dows\Command\Mscdex.exe /D:Mscd001
/V /M:8

Reinstalling Windows does not help and
there are no TSRs (Terminate and Stay Res-
ident) running. Also, the Mscdex driver does
not install. Please help.
Ram Shyam
Mavelikara

Change the noems parameter of
emm386.exe to RAM and change the
Device= to Devicehigh= in the Config.sys.
Remove the limitation on Files=. This may
allow the programs to run. Also try loading
DOS without loading DriveSpace. If they
still refuse to run, you need to upgrade the
RAM. The Mscdex driver does not load
because the command line has been
remarked by Windows setup. Remove the
remark from the Autoexec.bat file.

Linux loader
I had partitioned my hard disk into two. I
installed Windows 95 on one and Linux on

the other. When I uninstalled Linux, I used
the command �Fdisk /mbr� to remove LILO.
LILO was removed, but Windows now refus-
es to boot into Normal Mode. I can run it in
safe mode, though.
Mayank Joshi
Mumbai

Where did you run Fdisk from? From
the hard disk or from a bootable diskette?
You should have created a Windows
Startup disk before installing Linux and
used this to remove LILO. You can try
using a Startup disk from another Win-
dows 95 machine. 

If that does not help, try this option.
Delete and recreate the Extended DOS
partition. After formatting it boot into
Windows Safe Mode. Open a DOS Win-
dow and at the root of the fresh drive (D:),
type xcopy c:\*.* /e /c /h /r. This will copy
your entire Windows installation on to
the extended partition. Next, boot from a
bootable disk that has Fdisk.exe and For-
mat.com on it. Run Fdisk and set the
Extended Partition as the Active Partition.
Your operating system will now boot from
here. You can stop here, but it is better to
complete the procedure. Format the Pri-
mary DOS partition (should now be D:;
You can run it before Fdisk for safety) and

boot into Windows. Copy the files back
to the Primary Partition and set this as the
Active Partition. Your system should be
back to normal now.

Memory block
On my Celeron 266 MHz system (64 MB
SDRAM and 2.1 GB hard disk on Windows
98), upon booting into DOS, the DriveSpace
driver gets loaded and takes up 107 K in the
memory. Due to this many programs and
games do not run. I have to boot via the �Step
by step confirmation� method to prevent it. I
do not use DriveSpace and my drives are not
compressed. How do I get rid of the driver?
Ashish Kumar
Noida

The simplest way is to delete the drv-
space.bin and dblspace.bin files from the
root of the hard disk. Since you do not have
any compressed drives and do not use the
utility, this will not harm your computer in
any way, it will only improve performance.

Or you could look under the C: > Pro-
gram Files> Plus! > System folder for a
file called Nocomp.exe. Running this file
will create a Windows Startup Disk that

will not load the compression drivers.

War of the slaves
I have a Pentium 100 MHz system with 16
MB RAM, and two hard disks of 2.1 GB and
630 MB capacities. The Primary Master
(2.1 GB) contains Windows and the Prima-
ry Slave (630 MB) is free. I want to install
Unix on this hard disk and I need to make
it the Primary Master. Will this corrupt the
Windows Registry or file system? Can I par-
tition the free hard disk for Unix and DOS
and have Windows installed on the 2.1 GB
disk but boot from this one?
Rahul Soni

Large MP3 files on floppies
How can I copy huge MP3 files on to my
floppy? Even after zipping the song files,
the size remains about 2.5 MB, which
again is too much. I have heard about a file
splitter that allows you to split a file and
copy it on to several floppies. I was unable
to find it on the Net. Please help.
Satish Pandya
Via e-mail

This program already exists on your
desktop. Most new zipping utilities
allow you to span multiple disks.
WinZip has this option (called span-
ning) in the Add dialog box. Click on
the Multiple Disk Spanning drop-down
list for options. 

This will be enabled only if a 
removable medium such as floppy is
entered as the target drive. Leave it as

Automatic. If you still want splitters,
you can use split.exe or asplit.exe (you
can also find this on the CHIP CD, June
1998).

A 2.5 MB file on floppy!

Prevent unnecessary programs from eating

up your memory
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Patna
You have two options. 
The first one requires you to swap

your drives. This will not corrupt Win-
dows in any way until you try to boot
into it. By default you will not boot into
Windows. You can install Unix on the
630 MB hard disk. 

To boot from Windows, remove the
Primary Master (630 MB) setting from the
CMOS and the 2.1 GB drive will then
become C: (even though it is set as slave).
Swap the CMOS settings each time you

want to swap the operating systems.
The second option is to partition the

free disk into a Unix partition and a DOS
partition. This, though more tedious 
initially, will be easier in the long run.
For Windows to boot from this hard
disk, you will need to reinstall Windows
and all other software since you will 
have to change all drive references from
C: to E:. 

Alternatively, you can use Power
Quest�s DriveMapper (included with 
Partition Magic) utility to change all the
drive references, thus saving you the
trouble. Reinstalling Windows will auto-
matically create the required boot files
for the Active Partition on the Primary
Hard Disk.

Memory blues
I use a utility called Freemem to know how
much free memory I have. My computer has
128 MB RAM. I start off with 80 MB free
and by the time I am through playing games,
surfing the Internet, listening to MP3s etc. I
have 30 MB free. Why does this happen?
Why doesn�t the memory free up automati-
cally when the program is done with? 

What should my Windows swap file 
size be (provided that I want it to be of a
fixed size)? 
Kapil Thombare

Via e-mail
Windows requires the better part of

this used memory for itself. The rest is
used by drivers, files and applications.
When you close an application, Windows
does not release the memory as this can
be used again in case the same applica-
tion is launched again. The memory is
released as and when required. This
speeds up applications, since the entire
application has to be loaded into memo-
ry before it can be executed. 

A pretty insignificant part of the appli-
cation has to be re-written to the memo-
ry the next time you open it during the
same session of Windows.

Depending on what you utilise the PC
for, an ideal swap file would be between
200 and 300 MB.

Start menu arrangement
All my folders in the �Programs� folder under
the Start Menu in Windows 98 are arranged
randomly. Earlier they used to be arranged
in the alphabetical order. Now, any new soft-
ware I install or any new folder I create in
the Start menu is automatically put at 
the end of the programs group. How can I
reorganise them alphabetically?
Amitabh Varma
Via e-mail

The flexibility to arrange items is a
feature that was included in Windows
with Internet Explorer 4. It is meant to
help you to organise your Start menu
more efficiently. However, if you do not
want this, you can install Internet
Explorer 5, which, upon right-clicking,
allows you to arrange the items in 
alphabetical order.

Making changes to the registry can
bring about a similar effect. Run Regedit

and navigate to
HKEY_CURRENT_USER> Soft-
ware>Microsoft>Windows>CurrentVer-
sion>Explorer>MenuOrder>Start
Menu>Programs. Delete all keys under
this key, but not the key itself. The next
time you start Windows, these keys will
be recreated, and the items will be listed
in alphabetical order. You will have to
repeat this every time you install a soft-
ware. Or manually drag the software to its
correct position.  

Cache Bank
I am not sure if my Celeron 300, 32 MB
RAM machine has any cache memory. How
can I check this? I recently upgraded from
Windows 95 to Windows 98. When Win-
dows 98 starts, the following error message
is displayed �Cannot run Unicode version of
ATL.DLL on Windows 95. Please install cor-
rect version�. What should I do? 

On the taskbar I can see the �Task Sched-
uler�, �The Microsoft Network�, Time and
Volume settings. The first two options were
not present in Windows 95. I cannot even 
disable them. Do these take up memory? 
Abhishek
Via e-mail

If you have an Award BIOS, the box
that appears after the memory check on
booting the PC shows not only the
amount of cache you have, but also
details about the hard disks and other
devices. Make sure the cache 
settings in the BIOS are enabled for 
this. Alternatively, you can use a CPU
benchmark.

Regarding the DLL, open Start > Pro-
grams > Accessories > System > Sys-
tem Information. From the Tools menu,
click on Version Conflict Manager. Your 
DLL should be listed here. Restore the
backup.

You can remove The Microsoft Net-
work by removing it from Windows Setup.
Double-click the Task Scheduler icon to
open the program. From the Advanced
menu, click on Stop Using Task Sched-
uler. This will remove it from the taskbar. 

Out of all the programs listed, only the

Do you need help?
Send in your queries and problems to
Do you need help?  CHIP, Third floor,
Taj Building, 210 D N Road, Mumbai

Directly sort the Start Menu items with IE

Easy control over all partitions
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Task Scheduler takes up any significant
memory. The memory usage for the rest is
negligible.
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