Strona tytułowa

Podręcznik
użytkownika

LF Networks sp. z o.o. (C)
1997/1999 Katowice, POLAND

about.jpg (75606 bytes)


Wstęp

ANASIL jest programowym analizatorem sieci lokalnych, których okablowanie spełnia standard Ethernet. Jego podstawowymi funkcjami są: monitorowanie stanu łącza, tworzenie spisu aktywnych stacji (komputerów), testy łącza i komunikacji pomiędzy stacjami, ostrzeganie o przekroczeniu zadanych parametrów stanu sieci oraz przechwytywanie i analiza krążących w sieci pakietów.

Jest to program adresowany głównie do:

  1. Administratorów sieci lokalnych - opcje badania rozkładu obciążenia pomogą im znaleźć stacje generujące największy ruch w sieci a testy point-to-point wykryć uszkodzone stacje. Profil sieci i wykrywanie nowych stacji pozwolą na łatwe zauważenie intruzów wpinających się w łącze. Dodatkowo profil sieci ułatwi przeprowadzenie remanentu.
  2. Programistów pracujących w środowisku sieciowym - przechwytywanie i analiza pakietów są nieocenionym narzędziem do testowania komunikacji pomiędzy programami działającymi na różnych komputerach. Programowalny dekoder protokołów pozwoli na łatwe stworzenie dekoderów własnych protokołów komunikacyjnych. ANASIL zapewnia też wgląd w status adapterów NetBIOS na zdalnych końcówkach.
  3. Instalatorów i serwisantów sieci i serwerów - dekoder protokołów i przechwytywanie ramek umożliwią im wykrycie i usunięcie problemów konfiguracyjnych a testy point-to-point pomogą sprawdzić jakość zainstalowanej sieci.

Pomimo faktu, że ANASIL działa w systemie Windows 95/98/NT, analizy przez niego wykonywane nie ograniczają się do systemów firmy Microsoft. ANASIL analizuje również sieciową aktywność systemów spod znaku UNIX'a, Novell'a czy Apple.


Instalacja i konfiguracja

Po uruchomieniu programu instalacyjnego SETUP.EXE program ANASIL jest instalowany na Twoim dysku twardym w wybranym przez Ciebie katalogu. Po zainstalowaniu, program jest gotów do pracy. Nie jest już konieczne instalowanie dodatkowego drivera sieciowego jak w ANASIL-u 1.4. Driver taki jest ładowany obecnie dynamicznie w czasie startu aplikacji.

Optymalna konfiguracja protokołów na stacji, na której ma działać ANASIL

ANASIL stara się wykorzystywać wszystkie dostępne w Windows 95/98/NT protokoły, żeby maksymalizować zakres swoich analiz. Z tego powodu wskazane jest zainstalowanie na komputerze, na którym ANASIL będzie uruchamiany wszystkich dostępnych w Windows 95/98/NT protokołów transportowych (IPX/SPX, TCP/IP oraz NetBEUI) nawet jeżeli Twoja sieć ich bezpośrednio nie używa. Dodatkowo należy włączyć dla protokołów TCP/IP oraz IPX/SPX emulację NetBIOS. NetBIOS dla NetBEUI jest włączony zawsze.

UWAGA: Jeżeli Twoja sieć nie używa protokołu TCP/IP a jest on zainstalowany na Twoim komputerze, powinieneś wpisać w panelu sterowania dane dotyczące adresu IP (np. 199.10.10.10) i maski (np. 255.255.255.0).

Włączanie NetBIOS dla IPX/SPX

W Panelu sterowania klikamy na ikonę Sieć. W oknie zainstalowanych składników sieci wskazujemy protokół Protokół zgodny z IPX/SPX i otwieramy okno jego właściwości:

ipxnb.bmp (87062 bytes)

Włączanie NetBIOS dla TCP/IP

W Panelu sterowania klikamy na ikonę Sieć. W oknie zainstalowanych składników sieci wskazujemy protokół TCP/IP i otwieramy okno jego właściwości:

tcpnb.bmp (99958 bytes)

UWAGA: Zakładka NetBIOS w konfiguracji protokołu TCP/IP pojawiła się dopiero w OEM Service Release 2 dla Windows 95. Orginalna wersja Windows 95 miała zawsze włączony NetBIOS dla TCP/IP.

Zalecane oprogramowanie klienckie dla serwerów Windows NT oraz Novell NetWare

ANASIL został przetestowany w konfiguracji z trzema klientami: Klient sieci Microsoft Network firmy Microsoft dla dostępu do usług serwerów NT, Klient sieci NetWare firmy Microsoft oraz Novell IntranetWare Client (Novell Client 32) firmy Novell dla dostępu do usług serwerów NetWare.


Sposób działania

Do kontaktu z siecią ANASIL używa specjalizowanego drivera. Driver ten umożliwia odbiór wszystkich ramek transmitowanych w sieci. Umożliwia też wysyłanie niestandardowych ramek. Z jego pomocą ANASIL jest w stanie odebrać i zanalizować ruch w całym segmencie sieci Ethernet (w tzw. domenie kolizji, czyli w jednym odcinku kabla lub w paru odcinkach połączonych przy pomocy repeaterów). Przez ruch rozumiemy tutaj ramki WSZYSTKICH typów oraz WSZYSTKICH protokołów sieciowych. Pole "widzenia" ANASILA kończy się jednakże na najbliższym routerze lub innym urządzeniu filtrującym pakiety (np. switching hub).

Odebrane ramki ANASIL analizuje i na podstwie tych analiz uaktualnia prowadzone przez siebie statystyki. Statystyki te dotyczą zarówno parametrów globalnych całego segmentu sieci (np. wykorzystanie czy sumaryczna liczba przetransmitowanych przez segment ramek) jak i poszczególnych stacji lub protokołów sieciowych.

Odebrane ramki (lub ich podzbiór określony przez filtr) mogą być również zapamiętywane w specjalnym buforze a następnie przeglądane w postaci zrozumiałej dla człowieka przy pomocy dekodera protokołów).

Statystyki mogą być wizualizowane na różne sposoby oraz eksportowane przy pomocy viewerów i form . Dzięki temu możliwe jest śledzenie tylko tych statystyk na których nam w danej chwili najbardziej zależy. Wybrany zbiór statystyk można eksportować z zadanym interwałem do pliku o specjalnym, skompresowanym formacie. Z plików takich można następnie przygotowywać różnego rodzaju raporty.


Podstawowe pojęcia

Dla lepszego zrozumienia możliwości ANASILA konieczne jest poznanie i przyswojenie pewnych pojęć, jakie będą się pojawiać w dalszych rozdziałach tego podręcznika. Są to:

Profil sieci

Dla każdej analizowanej sieci można (i powinno się) zbudować profil sieci. Profil przechowuje dodatkowe informacje o adresach kart sieciowych (MAC) spotykanych w sieci. Każdemu adresowi można w profilu przyporządkować mnemoniczną nazwę, adresy protokołów sieciowych oraz szereg innych przydatnych informacji np. rodzaj i wersję systemu operacyjnego działającego na opisywanej stacji. Profil sieci ma szereg zastosowań. Przede wszystkim pozwala ANASILowi stosować czytelne dla człowieka nazwy mnemoniczne zamiast adresów MAC. Może służyć jako narzędzie wspomagające sporządzanie remanentu. A dodatkowo wspomaga wykrywanie nielegalnie podłączonych do sieci komputerów, które są identyfikowane jako nie należące do profilu i odpowiednio zaznaczane.

Profil sieci można utworzyć ręcznie (wpisując poszczególne stacje) lub automatycznie za pomocą opcji zbierania informacji o sieci.

Baza statystyk oraz Viewery i formy

Wszystkie zbierane przez ANASILa informacje na temat ruchu w sieci są zapisywane w bazie statystyk . Baza ta jest tworzona i aktualizowana "w tle" działania programu. Informacje tam zapisane są wizualizowane przez viewery i formy. W ANASILu zastosowano zalecany przez podręczniki projektowania obiektowego rozdział pomiędzy danymi a ich zewnętrzną, widoczną dla użytkownika reprezentacją. W efekcie dane zbierane w bazie statystyk mogą być wizualizowane na szereg sposobów, zależnie od potrzeb użytkownika.

Szablony form

Wizualizacja szczegółowych danych dotyczących np. stacji sieciowych wymaga czasami skonstruowania identycznych lub bardzo podobnych form dla każdej z obserwowanych stacji. Aby uprościć to zadanie, ANASIL udostępnia możliwość zachowania formy na dysku jako szablonu. Szablon ten można później automatycznie otworzyć jako formę z zadaną np. stacją lub innym elementem tablicy (patrz Opcja "View row with template" ).

Filtry

Filtry służą do nakładania warunków na analizowane przez ANASILa ramki. Można w ten sposób ograniczyć liczbę ramek łapanych przez ANASILa do bufora, filtrować zawartość samego bufora lub badać liczbę ramek które spełniają kryteria filtra (patrz Opcja "Set-up global filter").

Testy point-to-point

W czasie testów point-to-point badana jest komunikacja pomiędzy komputerem, na którym działa ANASIL a grupą stacji. Komunikacja może odbywać się za pomocą jednego z czterech głównych protokołów sieciowych: IP, IPX, NetBEUI lub Appletalk. W czasie tych testów mierzone są czasy odpowiedzi stacji oraz procentowa "stratność pakietów". Na tej podstawie można określić stan łącza, karty sieciowej (czy np nie "śmieci") a także sprawdzić czy w/w protokoły są poprawnie skonfigurowane.

Bufor i dekoder protokołów

Dogłębna analiza problemów np. konfiguracyjnych, wymaga niekiedy bliższego przyjrzenia się zawartości transmitowanych ramek. ANASIL potrafi złapać część lub całość transmitowanych ramek do tzw. bufora. Złapane w ten sposób ramki mogą być następnie wizualizowane przy pomocy dekodera protokołów, tłumaczącego ramkę z postaci binarnej do zrozumiałej dla człowieka. Dekoder protokołów w ANASILu jest programowalny. Znaczy to, że każdy użytkownik może w języku opisu protokołów zbudować własny dekoder dla np. pisanego przez siebie protokołu.

ANASIL Desktop Agent

W wersji ANASIL 2.0 wprowadzono możliwość zainstalowania na stacjach w sieci specjalizowanego oprogramowania, wspomagającego pracę ANASILa. Oprogramowanie to nazywa się ANASIL Desktop Agent. Zainstalowane na komputerze użytkownika umożliwia administratorowi sieci zdalny restart/wyłączenie komputera, podgląd ekranu oraz pobranie statystyk dotyczących błędów transmisji, konfiguracji sieci, uruchomionych urządzeń i otwartych portów TCP/IP. ANASIL Desktop Agent działa w sposób niezauważalny przez użytkownika. Dostęp do jego funkcji administrator może zablokować przy pomocy hasła.

Eksporty i Raporty

W wersji 2.0 wprowadzono możliwość automatycznego lub ręcznego sporządzania raportów z wartości wybranych statystyk. Użytkownik może określić czas, w którym statystyki mają być zbierane (dzień tygodnia, godziny) oraz wybrać te statystyki, które go interesują. W zadanym czasie system zacznie notować wartości tych statystyk w pliku o specjalnym skompresowanym formacie. Po skończeniu eksportu możliwe jest wyprodukowanie raportu z wyeksportowanych statystyk (całościowego lub wybiórczego). W czasie generowania raportu możliwe jest liczenie średniej, maksimum i minimum z wybranych statystyk jak również uśrednianie z np. godzinnym interwałem. Statystyki mogą być generowane do pliku w formacie TXT lub HTML.


Profil sieci

Dla każdej analizowanej sieci można (i powinno się) zbudować profil sieci. Profil przechowuje dodatkowe informacje o adresach kart sieciowych (MAC) spotykanych w sieci. Każdemu adresowi (stacji) można w profilu przyporządkować następujące informacje dodatkowe:

  1. Numer stacji w profilu. Stacje są w bazie statystyk identyfikowane poprzez swój numer. Aby ta sama stacja była widoczna zawsze pod tym samym numerem, przechowuje się go w profilu. Numery stacji w obrębie jednego profilu powinny być unikatowe, w przedziale od 1-999.
  2. Nazwa mnemoniczna. Każdej stacji należy nadać nazwę która ułatwi jej identyfikację. Dzięki temu zamiast nic nie mówiącego adresu MAC (np. 00-1B-2C-34-5B-00) ANASIL będzie mógł wyswietlić nazwę czytelną dla człowieka (np. SERWER).
  3. Komentarz. Może zawierać dodatkowe informacje opisujące stację.
  4. Typ i wersja systemu operacyjnego.
  5. Adres IP. Adres IP jest wpisywany do profilu przy jego tworzeniu oraz przy każdym otwarciu profilu. Jeżeli używasz statycznego przypisania adresów IP do konkretnych stacji, możesz wyłączyć automatyczne odświeżanie adresów IP przy pomocy okna opcji programu.
  6. Domena i nazwa stacji w sieci MS-Network
  7. Domena i nazwa stacji w serwisie DNS
  8. Nazwa i typ stacji w NBP (Appletalk)
  9. Czy na danej stacji zainstalowany jest ANASIL Desktop Agent

Profil sieci ma szereg zastosowań. Przede wszystkim pozwala ANASILowi stosować czytelne dla człowieka nazwy mnemoniczne zamiast adresów MAC. Może służyć jako narzędzie wspomagające sporządzanie remanentu. A dodatkowo wspomaga wykrywanie nielegalnie podłączonych do sieci komputerów, które są identyfikowane jako nie należące do profilu i odpowiednio zaznaczane. Jeżeli na danej stacji jest zainstalowany ANASIL Desktop Agent, możliwe jest także zebranie w profilu bliższych informacji na temat konfiguracji danego komputera takich jak spis i status działających w nim urządzeń lub serwisów (dla Windows NT), dokładna konfiguracja sterowników sieciowych i inne.

new.BMP (358 bytes) Tworzenie profilu

Profil można utworzyć wybierając z menu "Profiles" opcję "Create new Profile"

open.BMP (358 bytes) Otwieranie profilu

Zachowany na dysku profil można otworzyć wybierając z menu "Profiles" opcję "Open profile"

edprof.BMP (358 bytes) Edycja profilu

Do edycji aktualnie otwartego lub utworzonego profilu przechodzimy wybierając z menu "Profiles" opcję "Edit current profile"

close.BMP (358 bytes) Zamykanie profilu

Jeżeli chcemy otworzyć lub utworzyć inny profil, musimy najpierw zamknąć profil aktualny. W tym celu wybieramy z menu "Profiles" opcję "Close profile"


Baza statystyk

Wszystkie zbierane przez ANASILa informacje na temat ruchu w sieci są zapisywane w hierarchicznej bazie danych, zwanej dalej bazą statystyk. Baza ta jest tworzona i aktualizowana "w tle" działania programu. Elementami tej bazy mogą być wartości skalarne, wektory wartości skalarnych oraz tablice wartości skalarnych:

stats1.gif (6190 bytes)

Wartości skalarne mogą być numeryczne (oznaczone ikoną num.gif (895 bytes)) lub nienumeryczne (oznaczone przez notnum.gif (871 bytes)). Na wartościach numerycznych viewery i formy mogą wykonywać pewne dodatkowe działania (np obliczanie maksimum, minimum czy średniej). Wartości nienumeryczne mogą być tylko wizualizowane w sposób bezpośredni.

Każda wartość jest pewnego typu . Typ wartości określa dostępne sposoby jej wyświetlania oraz sortowania.

Z bazy statystyk korzystają przede wszystkim viewery i formy , których zadaniem jest wizualizować je w postaci dogodnej dla użytkownika.


Typy wartości skalarnych

Każda wartość skalarna jest pewnego typu. Typ wartości określa dostępne sposoby jej wyświetlania oraz sortowania. Poniżej prezentujemy listę typów wartości wraz z dostępnymi dla nich sposobami wizualizacji:

  1. Liczba
    Liczba może być wizualizowana w sposób bezpośredni (jako liczba) lub może być użyta jako indeks w jednej z tablic dekodera protokołów. W tablicach tych zdefiniowane są np. nazwy mnemoniczne dla numerów portów lub usług protokołu SAP.
  2. Ilość danych
    Ilość danych (np. liczba bajtów przetransmitowanych przez sieć) może być wizualizowana jako:
    1. Liczba (Number)
    2. Dane (Data) - zamiast 1024 wyświetlane jest wtedy 1 K etc.
    3. Liczba ze spacją co trzy miejsca dziesiętne (Number separated) (np. 1 234 567)
    4. Dane ze spacją co trzy miejsca dziesiętne (Data separated) (np. 1 000 G)
  3. Tekst
    Tekst może być wizualizowany tylko w sposób bezpośredni (Generic).
  4. Procent
    Procenty są wizualizowane jako liczba z dwoma miejscami dziesiętnymi po kropce (np. 21.33)
  5. Adres MAC
    Adres MAC może być wyświetlany na szereg różnych sposobów:
    1. Adres (Address) - wyświetla adres MAC w postaci ciągu sześciu liczb heksadecymalnych
    2. Nazwa stacji (Station name) - korzystając z aktualnego profilu, wyświetla zamiast adresu binarnego - mnemoniczną nazwę stacji.
    3. Nazwa producenta karty sieciowej (Vendor name) - korzystając z pliku vendors.ini, zamiast adresu wyświetla nazwę producenta karty sieciowej.
    4. Adres IP (IP address) - korzystając z aktualnego profilu, zamiast adresu wyświetla adres IP.
    5. Nazwa w DNS (DNS name) - korzystając z aktualnego profilu, zamiast adresu wyświetla nazwę stacji w serwisie DNS.
    6. Nazwa domeny (DNS domain) - korzystając z aktualnego profilu, zamiast adresu wyświetla nazwę domeny DNS.
    7. Nazwa w NBP (NBP name) - korzystając z aktualnego profilu, zamiast adresu wyświetla nazwę stacji w serwisie NBP (serwis nazw protokołu Appletalk).
    8. Typ stacji w NBP (NBP type) - korzystając z aktualnego profilu, zamiast adresu wyświetla typ stacji w serwisie NBP (Appletalk).
    9. Nazwa w Microsoft Networking (MS-Net name) - korzystając z aktualnego profilu, zamiast adresu wyświetla nazwę stacji w Microsoft Network.
    10. Nazwa domeny Microsoft Networking (MS-Net domain) - korzystając z aktualnego profilu, zamiast adresu wyświetla domenę stacji w Microsoft Network.
    11. Nazwa systemu operacyjnego (OS name) - korzystając z aktualnego profilu, zamiast adresu wyświetla nazwę systemu operacyjnego danej stacji.
    12. Wersja systemu operacyjnego (OS version) - korzystając z aktualnego profilu, zamiast adresu wyświetla wersję systemu operacyjnego danej stacji.
  6. Adres IPX
    Adres jest wyświetlany jako NNNNNNNN : AAAAAAAAAAAA : SSSS, gdzie NNNNNNNN - heksadecymalny numer sieci IPX, AAAAAAAAAAAA - heksadecymalny numer stacji (odpowiadający adresowi MAC), SSSS - numer gniazda (IPX socket).
  7. Adres Appletalk
    Adres jest wyświetlany jako N.n.S, gdzie N - numer sieci Appletalk (dziesiętnie), n - numer stacji w sieci, S - numer gniazda
  8. Adres TCP/IP
    Adres jest wyświetlany w standardowej dla TCP/IP postaci czyli jako X.X.X.X, gdzie X jest liczbą 0-255. Może być również wizualizowany jako nazwa DNS (jeżeli DNS jest skonfigurowany i zawiera nazwę dla danego adresu)
  9. Identyfikator protokołu
    Identyfikator może być wyświetlony jako:
    1. Nazwa protokołu (Protocol name)
    2. Identyfikator 5-bajtowy (5 byte hex)
    3. Identyfikator 2-bajtowy (2 byte hex)


Okno wyboru statystyk

Okno wyboru statystyk pozwala nawigować w bazie statystyk i wybierać statystyki do wizualizacji. Górną część okna zajmuje drzewo statystyk. Dla każdej statystyki podawana jest jej nazwa i aktualna wartość. Powyżej drzewa statystyk jest napis określający jakie statystyki wolno nam w danej chwili wybrać ("You can select scalar value" - wolno wybrać tylko pojedynczą wartość skalarną).

statsel.gif (12532 bytes)

Po znalezieniu i zaznaczeniu szukanej statystyki naciśnięcie przycisku SELECT powoduje zamknięcie okna i przekazanie naszego wyboru do programu. Przycisk "Cancel" powoduje rezygnację z wyboru.


Viewery i formy

Viewery i formy są podstawowymi mechanizmami wizualizacji statystyk w ANASILu. Viewer jest oknem, które może zawierać jedną lub więcej form. Forma z kolei jest oknem zawierającym jeden lub więcej element. Element zaś wizualizuje już konkretne, wybrane przez użytkownika statystyki z bazy statystyk .

Cały ten (dość skomplikowany) układ ilustruje poniższy rysunek:

viewer.gif (25077 bytes)

Elementy formy mogą być różnych typów. Każdy typ wizualizuje statystyki w inny sposób. Dostępnymi typami elementów są:

  1. Tekst (Text element)
  2. Wielokrotny tekst (Multi-text element)
  3. Tabela (Table element)
  4. Histogram (Histogram element)
  5. Wykres kołowy (Pie chart)
  6. Zagnieżdżona tabela (Subtable)

Viewery, formy i elementy mogą być tworzone interaktywnie przez użytkownika oraz zapamiętywane na dysku do późniejszego użycia. Służy do tego menu "Constructor", zawierające opcje operacji na viewerach i formach. Do operacji na elementach służy menu kontekstowe, które można otworzyć klikając na element prawym przyciskiem myszy.


Progi

Progi (Tresholds)

Progi są mechanizmem ułatwiającym kontrolę krytycznych parametrów sieci. Dla każdego elementu typu Tekst lub Histogram, obrazującego statystykę numeryczną możemy zadeklarować próg. Deklarując próg, określamy dwie wartości danej statystyki: wartość ostrzegawczą oraz wartość alarmową.

Wartość statystyki może być wtedy mniejsza od wartości ostrzegawczej, znajdować się pomiędzy wartością ostrzegawczą a alarmową lub być większa od wartości alarmowej. Dla każdego z tych trzech przedziałów wartości możemy określić: zmianę koloru elementu (w przypadku elementów typu Tekst jest to zmiana koloru tła, w przypadku Histogramów jest to zmiana koloru pojedynczego słupka histogramu), komunikat zapisywany do dziennika wydarzeń przy wejściu w dany przedział oraz komunikat zapisywany do dziennika wydarzeń przy wyjściu z przedziału.

Progi ustawiane są za pomocą standardowego okna edycji progów.


Typy elementów

Elementy form mogą być różnych typów. Każdy typ wizualizuje statystyki w inny sposób. Dostępnymi typami elementów są:

  1. Tekst (Text element)
    Służy do wizualizowania pojedynczych statystyk.
  2. Wielokrotny tekst (Multi-text element)
    Wizualizuje zestawy pojedynczych statystyk lub ich wektory.
  3. Tabela (Table element)
    Służy do wizualizacji tablic statystyk.
  4. Histogram (Histogram element)
    Wizualizuje pojedynczą statystykę w formie wykresu słupkowego.
  5. Wykres kołowy (Pie chart)
    Wizualizuje tablicę statystyk jako wykres kołowy.
  6. Zagnieżdżona tabela (Subtable)
    Pozwala na wizualizację w postaci "spłaszczonej" tablic statystyk zawartych w elementach innej tablicy statystyk. Np. tablic dysków zawartych w każdym elemencie tablicy stacji.


Tabela

Tabela (Table)

Tabele są elementami służącymi do wizualizowania tablic statystyk.

Składają się z kolumn, z których każda odpowiada jednej ze statystyk wchodzących w skład pojedynczej pozycji tablicy statystyk. Tabela jest zawsze posortowana względem jednej ze swych kolumn. Wartości w tej kolumnie są wytłuszczone (patrz rys poniżej).

tabela.gif (5237 bytes)

Klikając na nagłówki kolumn, możemy sortować tabelę po wartościach z innych kolumn. Układ i wygląd tabeli, oraz wizualizowaną tablicę statystyk możemy zmieniać wybierając z menu kontekstowego opcję "Setup". Opcja ta otwiera okno edycji parametrów tabeli.

Okno edycji parametrów tabeli

tablsetup.gif (10020 bytes)

Na górze okna znajduje się pole edycyjne do wpisania nagłówka tabeli (rysowanego potem powyżej tabeli na żółtym tle).

Po lewej stronie okna znajduje się spis kolumn tabeli. Kliknięcie na jedną z nich powoduje pojawienie się odpowiadających jej właściwości po prawej stronie okna (w grupie "Column properties"). Kolumna tabeli ma następujące właściwości:

  1. Nazwa kolumny (Column name) - nazwa pojawiająca się jako nagłówek danej kolumny
  2. Sposób wizualizacji (Stat. format) - sposób wizualizacji (patrz "Typy wartości skalarnych") statystyk w kolumnie.
  3. Rozmiar kolumny w procentach szerokości okna (Size) - rozmiar ten można również ustawić rozsuwając kolumny na samej tabeli.
  4. Pismo nieproporcjonalne (Monospaced) - jeżeli kolumna ma załączoną tą opcję, jej zawartość będzie rysowana nieproporcjonalnym stylem pisma (wszystkie znaki będą miały tą samą szerokość). Bardzo przydatne zwłaszcza dla danych numerycznych.
  5. Wyrównanie (Alignment) - decyduje o tym czy kolumna będzie wyrównywana do lewego marginesu (Left), do prawego marginesu (Right) czy centrowana (Center). UWAGA: pierwsza kolumna tabeli jest zawsze wyrównywana do lewego marginesu.
  6. Porządek sortowania (Sort order) - decyduje o tym czy w czasie sortowania po tej kolumnie stosowany będzie porządek rosnący (Ascending) czy malejący (Descending).
  7. Rodzaj sortowania (Sort by) - decyduje o tym czy sortowanie będzie się odbywać po wartości statystyki (np po binarnej wartośći adresu MAC)(Stat. Value) czy po tekście powstałym w czasie wizualizacji (np po nazwie stacji o danym adresie MAC)(Stat. visible text).

Oprócz pól służących edycji właściwości kolumn, u dołu okna znajdują się trzy przyciski:

  1. Wybór obrazowanej statystyki (Choose viewed statistics) - powoduje otwarcie okna wyboru statystyk. W oknie tym uzytkownik może wybrać obrazowaną tablicę statystyk (patrz Baza statystyk). Uwaga: zmiana obrazowanej statystyki powoduje usunięcie wszystkich dotychczasowych ustawień dla kolumn i załadowanie nowego spisu kolumn, odpowiadającego wybranej tablicy.
  2. Usunięcie zaznaczonej kolumny (Delete column) - usuwa zaznaczoną kolumnę ze spisu i z tabeli.
  3. Zduplikowanie zaznaczonej kolumny (Duplicate column) - duplikuje zaznaczoną kolumnę. Opcję tą można wykorzystać do jednoczesnej wizualizacji tej samej statystyki za pomocą różnych sposobów wizualizacji. (Np. adres MAC moze byc w ten sposob wyświetlany jednocześnie jako adres MAC i jako nazwa odpowiadającej temu adresowi stacji).

Jeżeli chcemy zmienić kolejność kolumn wyświetlanych na tabeli, możemy to zrobić przesuwając je myszką w oknie, w którym znajduje się spis kolumn (drag&drop).


Histogram

Histogramy są elementami służącymi do wizualizowania pojedynczych statystyk. Ich głównym zastosowaniem jest prezentacja historii wartości danej statystyki w zadanym przedziale czasu. Na osi pionowej histogramu znajdują się wartości statystyki a na osi poziomej czas pomiaru. Czas pomiaru może być opisany jako liczba sekund jakie upłynęły od chwili obecnej (patrz poniżej) lub jako godzina/minuta/sekunda.

histogram.gif (3861 bytes)

Wygląd histogramu może podlegać daleko idącym modyfikacjom. Żeby zmienić wygląd histogramu bądź obrazowaną statystykę należy z kontekstowego menu elementu wybrać opcję "Setup". Opcja ta otwiera okno edycji parametrów histogramu.

Okno edycji parametrów histogramu

histset.gif (10020 bytes)

Okno to pozwala ustawić następujące właściwości histogramu:

  1. Nagłówek (Caption) - nagłówek rysowany na żółtym tle ponad histogramem
  2. Wizualizowaną statystykę (Stat OID) - naciśnięcie przycisku "Choose" powoduje otwarcie okna wyboru statystyk. W oknie tym można wybrać pojedynczą numeryczną statystykę. Wartość tej statystyki będzie śledzona przez histogram.
  3. Sposób wizualizacji statystyki (Stat. format) - Sposób wyprowadzania wartości wybranej statystyki (u dołu histogramu)
  4. Czy wizualizujemy wartość statystyki czy przyrost jej wartości (Per sample) - jeżeli ta flaga jest zaznaczona, histogram nie zbiera bezwzględnych wartości statystyki tylko różnicę pomiędzy wartością w poprzedniej próbce a wartością aktualną. Ma to zastosowanie w przypadku liczników, które mogą tylko rosnąć (np. liczba przetransmitowanych ramek) i pozwala wyznaczyć np. liczbę przetransmitowanych ramek w jednej próbce.
  5. Opis osi pionowej (Y-axis units) - tekst pisany jako opis osi pionowej
  6. Czy pokazywać wartość (Show value) - jeżeli flaga jest zaznaczona jest rysowana wartość statystyki, w przeciwnym wypadku rysowane są np. tylko średnia/minimum/maximum.
  7. Czy pokazywać średnią wartość (Show average ) - jeżeli flaga jest zaznaczona jest rysowana średnia wartość statystyki (jako linia ciągła)
  8. Czy pokazywać wartość maksymalną (Show maximum) - jeżeli flaga jest zaznaczona jest rysowana maksymalna wartość statystyki (jako linia ciągła)
  9. Czy pokazywać wartość minimalną (Show minimum) - jeżeli flaga jest zaznaczona jest rysowana minimalna wartość statystyki (jako linia ciągła)
  10. Czy stosować progi (Enable tresholds) - jeżeli flaga jest zaznaczona, histogram będzie używał mechanizmu progów. Aby ustawić progi należy wcisnąć przycisk "Treshold Setup". Otworzy to okno edycji progów. Zdefiniowane progi będą wpływały na kolor rysowanych słupków histogramu w zależności od wartości.
  11. Liczba przechowywanych próbek (History size) - liczba wartości danej statystyki (wstecz) obrazowanych na histogramie (liczba słupków histogramu).
  12. Rozmiar próbki w sekundach (Sample length) - liczba sekund odpowiadająca jednemu słupkowi histogramu. Wartości statystyki w obrębie jednego słupka są uśredniane (jeżeli > 1).
  13. Maksymalna wartość widoczna na histogramie (Max. value)
  14. Krok rysowania oznaczeń na osi pionowej (Y grid step)
  15. Czy u dołu histogramu wyprowadzać aktualną wartość (Show text values)
  16. Czy czas ma być wyprowadzany jako liczba sekund czy jako czas w postaci bezwzględnej (Absolute time)
  17. Czy rysować linie pionowe (Draw X grid )
  18. Czy rysować linie poziome (Draw Y grid )
  19. Kolor linii (Grid color)
  20. Kolor osi (Axis color)
  21. Kolor tła (Background color)
  22. Kolor wykresu (Graph color)
  23. Kolor średniej (Average color)
  24. Kolor wartości maksymalnej (Max color)
  25. Kolor wartości minimalnej (Min color)


Edycja progów

Parametry progów ustawiamy przy pomocy okna edycji progów.

treshset.gif (5778 bytes)

W oknie tym możemy ustawić następujące parametry:

  1. Wartość progu alarmowego (High treshold/Value)
  2. Kolor odpowiadający progowi alarmowemu (High treshold/Color)
  3. Tekst wpisywany do dziennika wydarzeń w momencie wejścia statystyki w zakres alarmowy (High treshold/Log on enter)
  4. Tekst wpisywany do dziennika wydarzeń w momencie wyjścia statystyki z zakresu alarmowego (High treshold/Log on leave)
  5. Wartość progu ostrzegawczego (Medium treshold/Value)
  6. Kolor odpowiadający progowi ostrzegawczemu (Medium treshold/Color)
  7. Tekst wpisywany do dziennika wydarzeń w momencie wejścia statystyki w zakres ostrzegawczy (Medium treshold/Log on enter)
  8. Tekst wpisywany do dziennika wydarzeń w momencie wyjścia statystyki z zakresu ostrzegawczego (Medium treshold/Log on leave)
  9. Kolor odpowiadający wartościom poniżej progu ostrzegawczego (Low condition/Color)
  10. Tekst wpisywany do dziennika wydarzeń w momencie zejścia wartości statystyki poniżej progu ostrzegawczego (Low treshold/Log on enter)
  11. Tekst wpisywany do dziennika wydarzeń w momencie wyjścia wartości statystyki powyżej progu ostrzegawczego (Low treshold/Log on leave)


Tekst

Elementy typu tekst są elementami służącymi do wizualizowania statystyk skalarnych.

Składają się z trzech części: opisu statystyki, wartości statystyki i jednostek w których statystyka jest wyrażona. Wygląd elementu oraz wizualizowaną statystykę możemy zmieniać wybierając z menu kontekstowego opcję "Setup". Opcja ta otwiera okno edycji parametrów.

Okno edycji parametrów

textset.gif (7758 bytes)

Można w nim ustawić następujące właściwości elementu typu tekst:

  1. Tekst poprzedzający wartość
  2. Wizualizowaną statystykę (Stat OID) - naciśnięcie przycisku "Choose" powoduje otwarcie okna wyboru statystyk. W oknie tym można wybrać pojedynczą statystykę. Wartość tej statystyki będzie śledzona przez element.
  3. Sposób wizualizacji statystyki (Stat. format) - Sposób wyprowadzania wartości wybranej statystyki
  4. Czy wizualizujemy wartość statystyki czy przyrost jej wartości (Per sample) - jeżeli ta flaga jest zaznaczona, histogram nie zbiera bezwzględnych wartości statystyki tylko różnicę pomiędzy wartością w poprzedniej próbce a wartością aktualną. Ma to zastosowanie w przypadku liczników, które mogą tylko rosnąć (np. liczba przetransmitowanych ramek) i pozwala wyznaczyć np. liczbę przetransmitowanych ramek w jednej próbce.
  5. Jednostki (Text after) - tekst pisany jako opis jednostek
  6. Czy pokazywać wartość (Show value) - jeżeli flaga jest zaznaczona jest rysowana wartość statystyki
  7. Czy pokazywać średnią wartość (Show average ) - jeżeli flaga jest zaznaczona jest rysowana średnia wartość statystyki
  8. Czy pokazywać wartość maksymalną (Show maximum) - jeżeli flaga jest zaznaczona jest rysowana maksymalna wartość statystyki
  9. Czy pokazywać wartość minimalną (Show minimum) - jeżeli flaga jest zaznaczona jest rysowana minimalna wartość statystyki
  10. Czy stosować progi (Enable tresholds) - jeżeli flaga jest zaznaczona, element będzie używał mechanizmu progów. Aby ustawić progi należy wcisnąć przycisk "Treshold Setup". Otworzy to okno edycji progów. Zdefiniowane progi będą wpływały na kolor tła elementu.
  11. Rodzaj czcionki (Font) - czcionka jaką będzie rysowana wartość statystyki (domyślnie Arial)
  12. Kolor tła (Background)
  13. Kolor czcionki (Foreground)
  14. Czy automatycznie skalować czcionkę uwzględniając rozmiar okna (Autosize)


Wielokrotny tekst

Elementy typu wielokrotny tekst są elementami służącymi do wizualizowania zestawów statystyk skalarnych lub wektorów statystyk skalarnych.

multtext.gif (4843 bytes)

Wygląd elementu oraz zestaw wizualizowanych statystyk możemy zmieniać wybierając z menu kontekstowego opcję "Setup". Opcja ta otwiera okno edycji parametrów.

Okno edycji parametrów

an249.jpg (99295 bytes)

Można w nim ustawić następujące właściwości elementu typu wielokrotny tekst:

  1. Nagłówek (Caption) - nagłówek rysowany na żółtym tle ponad elementem
  2. Zestaw wizualizowanych statystyk (Viewed OID) - naciśnięcie przycisku "Add OID" powoduje otwarcie okna wyboru statystyk. W oknie tym można wybrać zestaw pojedynczych statystyk lub wektor statystyk. Przycisk "Remove" usuwa z listy aktualnie zaznaczoną statystykę. Przycisk "Remove all" usuwa z listy wszystkie statystyki. Opcja "Add separator" pozwala dodać do listy odstęp polepszający widoczność. Opcje "Move up" i "Move down" przesuwają aktualnie zaznaczony element listy odpowiednio w gorę lub w dół.
  3. Opis statystyki (Text before)
  4. Sposób wizualizacji statystyki (Stat. format) - Sposób wyprowadzania wartości wybranej statystyki
  5. Czy wizualizujemy wartość statystyki czy przyrost jej wartości (Per sample) - jeżeli ta flaga jest zaznaczona, element nie zbiera bezwzględnych wartości statystyki tylko różnicę pomiędzy wartością w poprzedniej próbce a wartością aktualną. Ma to zastosowanie w przypadku liczników, które mogą tylko rosnąć (np. liczba przetransmitowanych ramek) i pozwala wyznaczyć np. liczbę przetransmitowanych ramek w jednej próbce.
  6. Jednostki (Text after) - tekst pisany jako opis jednostek
  7. Wytłuszczenie (Bold) - jeżeli flaga ta jest zaznaczona, dana statystyka jest wizualizowana pismem wytłuszczonym.
  8. Czy pokazywać wartość (Show value) - jeżeli flaga jest zaznaczona jest rysowana wartość statystyki
  9. Czy pokazywać średnią wartość (Show average ) - jeżeli flaga jest zaznaczona jest rysowana średnia wartość statystyki
  10. Czy pokazywać wartość maksymalną (Show maximum) - jeżeli flaga jest zaznaczona jest rysowana maksymalna wartość statystyki
  11. Czy pokazywać wartość minimalną (Show minimum) - jeżeli flaga jest zaznaczona jest rysowana minimalna wartość statystyki
  12. Rodzaj czcionki (Font) - czcionka jaką będzie rysowana wartość statystyki (domyślnie Arial)
  13. Kolor tła (Background)
  14. Kolor czcionki (Foreground)
  15. Czy automatycznie skalować czcionkę uwzględniając rozmiar okna (Autosize)


Wykres kołowy

Elementy typu wykres kołowy są elementami służącymi do wizualizowania tablic statystyk.

an23.jpg (27010 bytes)

Wygląd elementu oraz zestaw wizualizowanych statystyk możemy zmieniać wybierając z menu kontekstowego opcję "Setup". Opcja ta otwiera okno edycji parametrów.

Okno edycji parametrów

an251.jpg (66148 bytes)

Można w nim ustawić następujące właściwości elementu typu wykres kołowy:

  1. Nagłówek (Caption) - nagłówek rysowany na żółtym tle ponad elementem
  2. Zestaw wizualizowanych statystyk (Stat OID) - naciśnięcie przycisku "Choose" powoduje otwarcie okna wyboru statystyk. W oknie tym można wybrać tablicę statystyk, którą chcemy wizualizować w postaci wykresu kołowego.
  3. Elementy legendy (Name) - określa który z atrybutów elementu tablicy statystyk będzie stanowił opis w legendzie. Jeżeli wizualizujemy np. tabelę stacji, jako Name powinniśmy wybrać nazwę stacji.
  4. Sposób wizualizacji elementu legendy (Stat. format) - Sposób wyprowadzania wartości elementu legendy
  5. Wartość wizualizowana (Value) - określa który który z atrybutów elementu tablicy statystyk będzie stanowił wizualizowaną wartość. Jeżeli wizualizujemy np. tabelę stacji, jako wartość możemy wybrać np. liczbę danych przetransmitowanych.
  6. Sposób wizualizacji statystyki (Stat. format) - Sposób wyprowadzania wartości wybranej statystyki
  7. Jednostki (Units) - określa w jakich jednostkach wyrażona jest wartość
  8. Ignorowane wartości (Stat. shown as "Other") - pole to pozwala określić poniżej ilu procent wartości będą zaliczane do grupy "Other". Przy dużych tablicach zawierających mnóstwo elementów o bardzo małym udziale istnieje możliwość zgrupowania tych wszystkich nieistotnych z punktu widzenia statystyki elementów jako jednego elementu o nazwie "Other".
  9. Czy pokazywać wartość (Show value) - jeżeli flaga jest zaznaczona, na wykresie jest rysowana wartość statystyki
  10. Czy pokazywać nazwye (Show names) - jeżeli flaga jest zaznaczona, na wykresie są rysowane nazwy
  11. Czy pokazywać legendę (Show legend) - jeżeli flaga jest zaznaczona, po prawej stronie wykresu jest rysowana legenda
  12. Kolor tła (Background color)
  13. Kolor grupy "Other" (Other color)


Zagnieżdżona tabela

Zagnieżdżona tabela (Subtable)

Zagnieżdżone tabele są elementami służącymi do wizualizowania zbiorczo tablic statystyk będących elementami innej tablicy statystyk.

Składają się z kolumn, z których każda odpowiada jednej ze statystyk wchodzących w skład pojedynczej pozycji tablicy statystyk. Tabela jest zawsze posortowana względem jednej ze swych kolumn. Wartości w tej kolumnie są wytłuszczone (patrz rys poniżej).

tabela.gif (5237 bytes)

Klikając na nagłówki kolumn, możemy sortować tabelę po wartościach z innych kolumn. Układ i wygląd tabeli, oraz wizualizowaną tablicę statystyk możemy zmieniać wybierając z menu kontekstowego opcję "Setup". Opcja ta otwiera okno edycji parametrów tabeli.

Okno edycji parametrów tabeli

an253.jpg (111690 bytes)

Na górze okna znajduje się pole edycyjne do wpisania nagłówka tabeli (rysowanego potem powyżej tabeli na żółtym tle).

Po lewej stronie okna znajduje się spis kolumn tabeli. Kliknięcie na jedną z nich powoduje pojawienie się odpowiadających jej właściwości po prawej stronie okna (w grupie "Column properties"). Kolumna tabeli ma następujące właściwości:

  1. Nazwa kolumny (Column name) - nazwa pojawiająca się jako nagłówek danej kolumny
  2. Sposób wizualizacji (Stat. format) - sposób wizualizacji (patrz "Typy wartości skalarnych") statystyk w kolumnie.
  3. Rozmiar kolumny w procentach szerokości okna (Size) - rozmiar ten można również ustawić rozsuwając kolumny na samej tabeli.
  4. Pismo nieproporcjonalne (Monospaced) - jeżeli kolumna ma załączoną tą opcję, jej zawartość będzie rysowana nieproporcjonalnym stylem pisma (wszystkie znaki będą miały tą samą szerokość). Bardzo przydatne zwłaszcza dla danych numerycznych.
  5. Wyrównanie (Alignment) - decyduje o tym czy kolumna będzie wyrównywana do lewego marginesu (Left), do prawego marginesu (Right) czy centrowana (Center). UWAGA: pierwsza kolumna tabeli jest zawsze wyrównywana do lewego marginesu.
  6. Porządek sortowania (Sort order) - decyduje o tym czy w czasie sortowania po tej kolumnie stosowany będzie porządek rosnący (Ascending) czy malejący (Descending).
  7. Rodzaj sortowania (Sort by) - decyduje o tym czy sortowanie będzie się odbywać po wartości statystyki (np po binarnej wartośći adresu MAC)(Stat. Value) czy po tekście powstałym w czasie wizualizacji (np po nazwie stacji o danym adresie MAC)(Stat. visible text).

Oprócz pól służących edycji właściwości kolumn, u góry i u dołu okna znajdują się trzy przyciski:

  1. Wybór obrazowanej statystyki (Choose viewed statistics) - powoduje otwarcie okna wyboru statystyk. W oknie tym uzytkownik może wybrać obrazowaną tablicę statystyk, której elementy zawierają inne tablice statystyk (patrz Baza statystyk). Uwaga: zmiana obrazowanej statystyki powoduje usunięcie wszystkich dotychczasowych ustawień dla kolumn i załadowanie nowego spisu kolumn, odpowiadającego wybranej tablicy.
  2. Wybór tabeli w elemencie tabeli zewnętrznej (SubTable) - pozwala wybrać, którą z tablic wchodzących w skład elementu tablicy zewnętrznej chcemy wizualizować
  3. Dodanie kolumny z tablicy zewnętrznej (Add column from master table) - pozwala dodać kolumnę określającą element tablicy zewnętrznej.
  4. Usunięcie zaznaczonej kolumny (Delete column) - usuwa zaznaczoną kolumnę ze spisu i z tabeli.
  5. Zduplikowanie zaznaczonej kolumny (Duplicate column) - duplikuje zaznaczoną kolumnę. Opcję tą można wykorzystać do jednoczesnej wizualizacji tej samej statystyki za pomocą różnych sposobów wizualizacji. (Np. adres MAC moze byc w ten sposob wyświetlany jednocześnie jako adres MAC i jako nazwa odpowiadającej temu adresowi stacji).

Jeżeli chcemy zmienić kolejność kolumn wyświetlanych na tabeli, możemy to zrobić przesuwając je myszką w oknie, w którym znajduje się spis kolumn (drag&drop).


Standardowy viewer

Po uruchomieniu programu, system ładuje tzw. standardowy viewer. Jest to zdefiniowany przez producenta zestaw i układ okien pozwalający śledzić większość ze zbieranych przez ANASILA i jego agentów statystyk. Zazwyczaj jest to zestaw wystarczający dla początkującego użytkownika. Viewer ten składa się z 15 form:

  1. Utilization
  2. Network stations
  3. MAC traffic matrix
  4. Protocols
  5. Point-to-point tests
  6. Broadcasts and Packet sizes
  7. Net Errors
  8. IP subprotocols and ICMP
  9. TCP ports usage
  10. UDP ports usage
  11. TCP/UPD ports by station
  12. HTTP traffic
  13. IP traffic and RIP
  14. Opened ports
  15. Disks

an218.jpg (347158 bytes)


Utilization

Forma "Utilization" prezentuje użytkownikowi informacje na temat aktualnego wykorzystania łącza sieciowego. Składa się ona z pięciu elementów:

  • Current network utilization (short term) - pokazuje w formie histogramu procentowe obciążenie sieci w czasie ostatniej minuty.
  • Current network utilization (long term) - pokazuje w formie histogramu procentowe obciążenie sieci w czasie ostatniej godziny z czasem uśredniania równym jednej minucie.
  • Global statistics - pokazuje jako wielokrotny tekst podstawowe parametry obciążenia.
  • Current network utilization - pokazuje aktualne procentowe obciążenie sieci jako tekst.
  • Frame types - pokazuje jako wykres kołowy proporcje pomiędzy trzema podstawowymi rodzajami ramek Ethernet: Broadcast, Multicast i Directed.

an220.jpg (213070 bytes)


Network stations

Forma "Network stations" prezentuje użytkownikowi informacje na temat aktywności sieciowej poszczególnych stacji w sieci. Składa się ona z trech elementów:

  • Network stations - pokazuje w tabeli stacje nadające i odbierające dane oraz statystyki dotyczące nadawania i odbierania.
  • Top senders - pokazuje jako wykres kołowy stacje które wysyłają najwięcej danych
  • Top receivers - pokazuje jako wykres kołowy stacje które odbierają najwięcej danych

an221.jpg (173656 bytes)


MAC traffic matrix

Forma "MAC traffic matrix" prezentuje użytkownikowi informacje na temat transmisji sieciowych pomiędzy poszczególnymi stacjami. Składa się ona z jednego elementu:

  • Connections - pokazuje w formie tabeli, pomiędzy jakimi stacjami odbywa się największy transfer danych, jaki jest średni rozmiar ramki i ile stanowi to procent ogólnego ruchu w sieci.

an222.jpg (206304 bytes)


Protocols

Forma "Protocols" prezentuje użytkownikowi informacje na temat protokołów sieciowych obecnych w sieci. Składa się ona z trzech elementów:

  • Protocols - pokazuje w formie tabeli spis aktywnych protokołów wraz z informacją na temat wpływu danego protokołu na globalne obciążenie sieci.
  • Data transmitted by protocol - pokazuje jako wykres kołowy rozkład obciążenia sieci przez poszczególne protokoły biorąc pod uwagę liczbę przetransmitowanych danych
  • Frames transmitted by protocol - pokazuje jako wykres kołowy rozkład obciążenia sieci przez poszczególne protokoły biorąc pod uwagę liczbę przetransmitowanych pakietow

an223.jpg (154461 bytes)


Point-to-point tests

Forma "Point-to-point test" prezentuje użytkownikowi wyniki testów point-to-point. Składa się ona z czterech elementów:

  • IPX point-to-point tests - pokazuje w formie tabeli wyniki testów po protokole IPX.
  • IP (ICMP) point-to-point tests - pokazuje w formie tabeli wyniki testów po protokole IP
  • NetBEUI point-to-point tests - pokazuje w formie tabeli wyniki testów po protokole NetBEUI.
  • Appletalk point-to-point tests - pokazuje w formie tabeli wyniki testów po protokole Appletalk.

an224.jpg (163587 bytes)


Broadcasts and Packet sizes

Forma "Broadcasts and Packet sizes" prezentuje użytkownikowi informacje na temat udziału w obciążeniu sieci ramek o różnym typie i różnej wielkości. Składa się ona z czterech elementów:

  • Frame types - pokazuje jako wykres kołowy proporcje pomiędzy trzema podstawowymi rodzajami ramek Ethernet: Broadcast, Multicast i Directed.
  • Broadcasts - pokazuje jako wielokrotny tekst podstawowe parametry obciążenia łącza przez ramki typu Broadcast.
  • Frame sizes - pokazuje jako wykres kołowy proporcje pomiędzy ramkami o różnych wielkościach.
  • Multicasts - pokazuje jako wielokrotny tekst podstawowe parametry obciążenia łącza przez ramki typu Multicast.

an225.jpg (191412 bytes)


Net Errors

Forma "Net Errors" prezentuje użytkownikowi informacje na temat statystyk transmisji i błędów zbieranych na stacjach przy pomocy ANASIL Desktop Agent. Żeby w oknie tym pojawiły się statystyki, niezbędne jest wykonanie funkcji Refresh stats dla stacji, których statystyki chcemy sprawdzić. Forma składa się z dwóch elementów:

  • Network adapters statistics (general) - pokazuje w formie tabeli liczby pakietów odebranych i wysłanych ze stacji.
  • Adapters Errors - pokazuje w formie tabeli błędy transmisji dla konkretnych kart sieciowych na stacji. UWAGA: obecność lub nieobecność niektórych statystyk jest zależna od typu posiadanej karty sieciowej i wersji drivera. Jeżeli w jakiejś kolumnie pojawia się N/A, znaczy to, że driver danej karty nie udostępnia takiej statystyki.

an226.jpg (122273 bytes)


IP subprotocols and ICMP

Forma "IP subprotocols and ICMP" prezentuje użytkownikowi informacje na temat udziału w ruchu podprotokołów protokołu TCP/IP oraz na temat poruszających się w sieci ramek ICMP. Składa się ona z czterech elementów:

  • IP sub-protocols - pokazuje w formie tabeli udział podprotokołów TCP/IP.
  • IP sub-protocols by data transmitted - pokazuje jako wykres kołowy proporcje pomiędzy podprotokołami TCP/IP biorąc pod uwagę ilość wysyłanych danych
  • IP sub-protocols by frames transmitted - pokazuje jako wykres kołowy proporcje pomiędzy podprotokołami TCP/IP biorąc pod uwagę liczbę wysyłanych pakietów
  • ICMP packets - pokazuje w formie tabeli pakiety ICMP wysyłane przez konkretne stacje. Ponieważ protokół ICMP pełni w rodzinie protokołów TCP/IP funkcje sterujące, statystyka taka pozwala wykrywać nieprawidłowości w konfiguracji protokołów tej rodziny.

an227.jpg (180287 bytes)


TCP ports usage

Forma "TCP ports usage" prezentuje użytkownikowi informacje na temat podziału ruchu ramek TCP na konkretne porty. Składa się ona z czterech elementów:

  • TCP ports total - pokazuje w formie tabeli globalne wartości opisujące ruch na portach TCP.
  • TCP ports received/transmitted - pokazuje w formie tabeli wartości opisujące ile danych/pakietów zostało wysłanych/odebranych na konkretnym porcie.
  • TCP ports by data transmitted - pokazuje jako wykres kołowy proporcje pomiędzy portami TCP biorąc pod uwagę ilość wysyłanych danych
  • TCP ports by frames transmitted - pokazuje jako wykres kołowy proporcje pomiędzy portami TCP biorąc pod uwagę liczbę wysyłanych pakietów

an228.jpg (183750 bytes)


UDP ports usage

Forma "UDP ports usage" prezentuje użytkownikowi informacje na temat podziału ruchu ramek UDP na konkretne porty. Składa się ona z czterech elementów:

  • UDP ports total - pokazuje w formie tabeli globalne wartości opisujące ruch na portach UDP.
  • UDP ports received/transmitted - pokazuje w formie tabeli wartości opisujące ile danych/pakietów zostało wysłanych/odebranych na konkretnym porcie.
  • UDP ports by data transmitted - pokazuje jako wykres kołowy proporcje pomiędzy portami UDP biorąc pod uwagę ilość wysyłanych danych
  • UDP ports by frames transmitted - pokazuje jako wykres kołowy proporcje pomiędzy portami UDP biorąc pod uwagę liczbę wysyłanych pakietów

an229.jpg (209834 bytes)


TCP/UDP ports by station

Forma "TCP/UDP ports by station" prezentuje użytkownikowi informacje na temat wykorzystania portów TCP/UDP w konkretnych stacjach. Składa się ona z czterech elementów:

  • TCP ports usage by station (total) - pokazuje w formie tabeli wykorzystanie portów TCP na stacjach w sieci.
  • TCP ports usage by station (received/transmitted) - pokazuje w formie tabeli ilość danych/ramek wytransmitowanych i odebranych na konkretnych portach TCP w stacjach.
  • UDP ports usage by station (total) - pokazuje w formie tabeli wykorzystanie portów UDP na stacjach w sieci.
  • UDP ports usage by station (received/transmitted) - pokazuje w formie tabeli ilość danych/ramek wytransmitowanych i odebranych na konkretnych portach UDP w stacjach.

an230.jpg (287058 bytes)


HTTP traffic

Forma "HTTP traffic" prezentuje użytkownikowi informacje na temat odwołań stacji sieciowych do serwerów WWW po protokole HTTP. Oprócz tego, prezentowane są również wszystkie "Cookies" wysłane przy okazji tych odwołań. Pozwala to na kontrolę, czy za pomocą mechanizmu "Cookies" nie są transmitowane niepożądane informacje. Forma ta składa się z czterech elementów:

  • Global HTTP traffic - pokazuje w formie tabeli odwołania do serwerów HTTP i ich statystyki ilościowe.
  • Cookies sent - pokazuje w formie tabeli wszystkie wysłane przez stacje "Cookies"
  • HTTP traffic by GET count - pokazuje jako wykres kołowy proporcje pomiędzy ilością odwołań do różnych serwerów HTTP.
  • HTTP traffic by POST count - pokazuje jako wykres kołowy proporcje pomiędzy ilością odwołań do różnych serwerów HTTP (pod uwagę brane są formularze wysłane komendą HTTP POST).

an231.jpg (155949 bytes)


IP traffic and RIP

Forma "IP traffic and RIP" prezentuje użytkownikowi informacje na temat transmisji wykonywanych po protokole TCP/IP pomiędzy poszczególnymi adresami IP oraz tablic routingu rozgłaszanych protokołem RIP. Forma ta składa się z dwóch elementów:

  • IP traffic matrix - pokazuje w formie tabeli ilościowe statystyki dotyczące transmisji po protokole IP pomiędzy adresami IP.
  • Global IP RIP cache - pokazuje w formie tabeli rozgłaszane przez routery protokołem RIP tabele routingu.

an232.jpg (190977 bytes)


Opened ports

Forma "Opened ports" prezentuje użytkownikowi informacje na temat portów TCP/UDP otwartych na stacjach. Statystyka ta jest sporządzana na żądanie przy pomocy oprogramowania ANASIL Desktop Agent. Aby uaktualnić listę otwartych portów należy użyć opcji Get opened ports z kontekstowego menu stacji w drzewie struktury sieci. Opisywana forma składa się z jednego elementu:

  • Opened ports - pokazuje w formie tabeli listę otwartych portów na stacjach dla których wykonano komendę Get opened ports.

an233.jpg (219743 bytes)


Disks

Forma "Disks" prezentuje użytkownikowi informacje na stanu twardych dysków na stacjach. Statystyka ta jest sporządzana na żądanie przy pomocy oprogramowania ANASIL Desktop Agent. Aby uaktualnić listę dysków należy użyć opcji Refresh stats z kontekstowego menu stacji w drzewie struktury sieci. Opisywana forma składa się z jednego elementu:

  • Disks - pokazuje w formie tabeli listę dysków na stacjach dla których wykonano komendę Refresh stats

an234.jpg (104663 bytes)


Szablony form

Żeby ułatwić wizualizację wybranych elementów tablic statystyk w określony przez użytkownika sposób, w ANASILu wbudowano mechanizm szablonów form. Szablonem (template) może zostać każda forma, na której znajdują się statystyki dotyczące tylko jednego elementu jakiejś tablicy statystyk. Jeżeli na przykład zbudujemy formę za pomocą której oglądamy parametry jednej wybranej stacji w sieci (liczbę wytransmitowanych ramek, liczbę odebranych ramek etc.), możemy ją przy pomocy opcji "Save form as template" (w menu "Constructor") zachować jako szablon formy wizuaizującej elementy tablicy stacji.

Z zachowanego szablonu możemy skorzystać wybierając opcję "View row with template" z kontekstowego menu tabeli stacji.

UWAGA: Opcja "View row with template" pokazuje się tylko przy elementach typu tabela .


Filtry

Filtry służą do nakładania warunków na analizowane przez ANASILa ramki. Można w ten sposób ograniczyć liczbę ramek łapanych przez ANASILa do bufora, filtrować zawartość samego bufora lub badać liczbę ramek które spełniają kryteria filtra (patrz Opcja "Set-up global filter"). ANASIL pozwala na założenie jednego z trzech rodzajów filtrów:

  1. Filtra prostego (Simple filter)
    Jest to prosty filtr pozwalający nałożyć warunki na adres pochodzenia (Source Address) i przeznaczenia (Destination Address) ramki, rodzaj protokołu/podprotokołu oraz kombinację bajtów w ramce.
  2. Filtra zaawansowanego (Advanced filter)
    Filtr zaawansowany składa się z jednego do trzech filtrów prostych połączonych warunkami logicznymi.
  3. Filtra zachowanego (Persistant filter)
    Filtr zachowany jest filtrem prostym lub zaawansowanym, który został przez użytkownika zachowany na dysku (bo np. jest często używany).

Mechanizm działania filtra (niezależnie od rodzaju) jest zawsze ten sam - sprawdzenie zawartości ramki pod kątem zadanych kryteriów.


Testy point-to-point

Testy point-to-point sprawdzają łączność pomiędzy komputerem na którym uruchomiony jest ANASIL a innymi komputerami w analizowanej sieci. Test komunikacji odbywa się na poziomie warstwy sieciowej modelu ISO/OSI a konkretnie na poziomie protokołów: IPX, IP, DDP (Appletalk) oraz NetBEUI. Wysyłane są specjalne (różne dla różnych protokołów) ramki do testowanych stacji, które wymuszają ich odpowiedź. Czas odpowiedzi jak również liczba ramek, na które stacja nie odpowiedziała są zapisywane i mogą służyć jako podstawa do analiz jakości komunikacji tudzież do wykrywania stacji źle skonfigurowanych lub z uszkodzonymi kartami sieciowymi.

Dla poszczególnych protokołów, odpowiedź wymuszana jest w następujący sposób:

  1. IPX
    W testowaniu łączności za pomocą protokołu IPX wykorzystano tzw. protokół diagnostyczny (Diagnostic responder). Wszystkie stacje jakie będziemy badać przy pomocy testów point-to-point powinny mieć włączony ten moduł protokołu IPX. Podczas instalacji domyślnie jest on włączony ale czasami wyłącza się go, żeby zaoszczędzić np na pamięci operacyjnej.
  2. IP
    Łączność po protokole IP jest testowana za pomocą pakietów protokołu ICMP. Odpowiada to wywołaniu polecenia PING (standardowego w różnych implementacjach TCP/IP).
  3. DDP (Appletalk)
    Testowanie łączności po protokole DDP jest zrealizowane za pomocą Appletalk Echo Protocol (AEP). Pełni on w rodzinie protokołów Appletalk rolę podobną jak w TCP/IP protokół ICMP.
  4. NetBEUI
    Łaczność po protokole NetBEUI jest sprawdzana przy pomocy funkcji diagnostycznej interfejsu NetBIOS pozwalającej uzyskać status zdalnej stacji.


Dekoder protokołów i bufor dekodowania

ANASIL może przechwytywane ramki zachowywać do późniejszej analizy. W tym celu ramki są składowane w specjalnym buforze dekodowania. Bufor ten ma regulowaną pojemność a w zależności od ustawionych opcji może działać jako bufor cykliczny.

Do przetworzenia tak zgromadzonych ramek na postać czytelną dla człowieka, ANASIL używa dekodera protokołów. Dekoder protokołów w ANASILu jest programowalny. Znaczy to, że każdy dysponując tylko edytorem ASCII i znajomością języka opisu protokołów może dodać do ANASILa definicje własnych lub znanych przez siebie a przez ANASILa nie obsługiwanych protokołów.

Opcje związane z przechwytywaniem ramek oraz z dekoderem protokołów są zgrupowane w menu "Capture".


Drzewo struktury sieci

Po lewej stronie głównego okna ANASILa znajdować się może okno zawierające drzewo struktury sieci. Widoczność tego okna określa się przy pomocy opcji "Network structure tree".

tree.gif (3910 bytes)

Jest to struktura, pomagająca wizualizować aktywność stacji w sieci oraz uruchamiać opcje działające tylko dla wybranej stacji. Drzewo to ma dwie główne gałęzie: gałąź "Stations" oraz gałąź "Broadcasts / multicasts". W pierwszej z nich wyświetlane są stacje analizowanej sieci. Druga zawiera broadcasty / multicasty w tej sieci wykryte.

Stacje wyświetlane w gałęzi "Stations" mogą być oznaczone jedną z trzech ikon:

badstat.gif (924 bytes) oznacza stację, która wysyła ramki a której nie ma w aktualnie otwartym profilu sieci. Zamiast nazwy stacji, wyprowadzany jest jej adres sieciowy. Może to oznaczać np. nowy komputer w sieci (który należy dodać do profilu) lub intruza podłączonego do kabla sieciowego.

goodstat.gif (931 bytes) oznacza stację, która wysyła ramki i która jest ujęta w profilu.

an25.jpg (1133 bytes) oznacza stację z zainstalowanym oprogramowaniem ANASIL Desktop Agent.

deadstat.gif (934 bytes) oznacza stację egzystującą w profilu ale nie wysyłającą ramek (np. wyłączony komputer).

Kliknięcie na stację przy pomocy prawego klawisza myszy powoduje otwarcie kontekstowego menu stacji zawierającego następujące pozycje:

  1. Profile Info - pozwala uzyskać szybki dostęp do informacji o danej stacji zawartych w aktualnym profilu. Jeżeli stacji nie ma jeszcze w profilu, system pyta się czy ją do niego dodać.
  2. Send message - pozwala wysłać do stacji krótki komunikat (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  3. Set/change agent password - pozwala na ustawienie/zmianę hasła, którym zabezpieczony jest dostęp do funkcji ANASIL Desktop Agent na danej stacji.
  4. Refresh info - odświeża w profilu informacje na temat danej stacji (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  5. Refresh statistics - powoduje przesłanie przez agenta statystyk zbieranych na danej stacji (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  6. Get opened ports - powoduje przesłanie przez agenta listy otwartych na stacji portów TCP/UDP (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  7. Wake up - włącza zdalnie komputer korzystając z mechanizmu WakeUp On Lan. Mechanizm ten powinien być uaktywniony na danej stacji.
  8. Shutdown - wyłącza zdalnie komputer po uprzednim ostrzeżeniu użytkownika (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  9. Shutdown (no warning) - wyłącza zdalnie komputer bez ostrzeżenia (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  10. Restart - restartuje zdalnie komputer po uprzednim ostrzeżeniu użytkownika (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  11. Restart (no warning) - restartuje zdalnie komputer bez ostrzeżenia (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  12. NetWare status - pokazuje kto i do jakich serwerów NetWare jest obecnie na danej stacji zalogowany (Opcja działa tylko z Novell Client 32 lub z IntranetWare Client 32).
  13. NetBIOS status - pokazuje status wszystkich adapterów NetBIOS na danej stacji, wraz z zarejestrowanymi nazwami NetBIOS.
  14. Get application statistics - pobiera ze stacji statystyki aplikacji (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)
  15. Reset application statistics - resetuje statystyki aplikacji na danej stacji (Opcja działa tylko dla stacji z zainstalowanym ANASIL Desktop Agent)


Pobieranie statusu adapterów NetBIOS

ANASIL posiada unikatową właściwość rozpoznawania które adaptery NetBIOS posługują się jakimi protokołami transportowymi. W najbardziej rozwiniętej konfiguracji ANASIL rozpozna trzy adaptery: adapter podłączony do protokołu NetBEUI, adapter podłączony do IPX/SPX oraz adapter podłączony do TCP/IP.

ANASIL pozwala na sprawdzenie statusu wszystkich tych adapterów na zdalnej stacji. Aby to zrobić należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "NetBIOS status". Otworzy się wówczas następujące okno:

NBSTAT.gif (12175 bytes)

Okno to posiada pewną (zależną od liczby interfejsów NetBIOS zainstalowanych na komputerze na którym uruchamiamy ANASILa) liczbę zakładek - po jednej dla każdego protokołu. W górnej części okna znajdują się statystyki udostępniane standardowo przez NetBIOS (niestety ich interpretacja jest różna w zależności od konkretnej implementacji). W dolnej części okna znajduje się lista nazw NetBIOS zarejestrowanych dla danego interfejsu na danej stacji. Lista ta ma pięć kolumn:

  1. Nazwa (Name) - zarejestrowana nazwa poprzedzona ikoną. Kropka oznacza nazwę unikatową a folder oznacza nazwę grupową. Jeżeli w nazwie znajdują się znaki nie posiadające reprezentacji graficznej, są one zastępowane konstrukcją: \xHH gdzie HH to dwucyfrowa liczba heksadecymalna.
  2. Ostatni bajt (Last) - w niektórych zastosowaniach NetBIOS ostatni bajt nazwy NetBIOS ma szczególne znaczenie. Dlatego też jest on wyprowadzany osobno jako liczba heksadecymalna.
  3. Status (Status) - status rejestracji nazwy.
  4. Identyfikator (Id) - identyfikator nazwy w NetBIOS
  5. Interpretacja (Interpretation) - próba interpretacji znaczenia nazwy na podstawie jej ostatniego bajtu.

Naciśnięcie przycisku "Refresh" powoduje odświeżenie zawartości okna.


Pobieranie statusu połączenia z serwerami NetWare

Jedną z opcji ANASILa jest sprawdzanie statusu połączenia stacji w badanej sieci z serwerami Novell NetWare. Aby to zrobić należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "NetWare status". Otworzy się wówczas następujące okno:

NWSTAT.gif (6464 bytes)

W górnej części okna znajdować się będą wszystkie nazwy użytkowników, pod którymi zrealizowano połączenia z serwerami NetWare dla wybranej stacji. Kliknięcie na jedno z nich spowoduje ukazanie się szczegółowej informacji o tym połączeniu w dolnej części okna.


Wysyłanie wiadomości do użytkownika (Send message)

Wysyłanie informacji do użytkownika (Send message)

Jeżeli na zdalnej stacji jest zainstalowany ANASIL Desktop Agent, istnieje możliwość wysłania do użytkownika na tej stacji krótkiej informacji tekstowej. Aby to zrobić należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Send message". Otworzy się wówczas następujące okno:

an242.jpg (17298 bytes)

W polu edycyjnym należy wpisać wiadomość i wcisnąć przycisk "Send".


Ustawianie/zmiana hasła dostępu do ANASIL Desktop Agenta

Ponieważ ANASIL Desktop Agent pozwala administratorowi na dosyć daleko posuniętą kontrolę nad stacją, jego użycie przez osoby niepowowłane mogłoby spowodować zagrożenie dla bezpieczeństwa sieci lub prywatności użytkowników. Z tego powodu istnieje możliwość zabezpieczenia agenta hasłem. Aby to zrobić należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Set/change agent password". Otworzy się wówczas następujące okno:

an243.jpg (41375 bytes)

Zmiana hasła może nastąpić tylko po podaniu starego hasła w polu "Old password". W polach "New password" podajemy nowe hasło (dwa razy dla pewności) i naciskamy przycisk OK.


Odświeżanie informacji o stacji (Refresh info)

W profilu stacji przechowywanych jest dużo informacji na temat jej konfiguracji. Aby odświeżyć tę informację korzystając z usług zainstalowanego na niej ANASIL Desktop Agenta należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Refresh info". Otworzy się wówczas następujące okno:

an27.jpg (23708 bytes)

Jeżeli operacja przebiegnie bezbłędnie okno zamknie się automatycznie. W przeciwnym przypadku pozostanie razem z komunikatami o błędach póki nie naciśniemy klawisza "Close".


Odświeżanie statystyk stacji (Refresh stats)

W bazie statystyk dostępne są statystyki zbierane przez ANASIL Desktop Agenta na samej stacji. Aby je odświeżyć korzystając z usług zainstalowanego na niej ANASIL Desktop Agenta należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Refresh stats". Otworzy się wówczas następujące okno:

an27.jpg (23708 bytes)

Jeżeli operacja przebiegnie bezbłędnie okno zamknie się automatycznie. W przeciwnym przypadku pozostanie razem z komunikatami o błędach póki nie naciśniemy klawisza "Close".


Pobieranie listy otwartych portów TCP/UDP (Get opened ports)

Jedną ze statystyk stacji w bazie statystyk jest lista otwartych potrów TCP/UDP. Lista ta jest przygotowywana przez ANASIL Desktop Agenta na żądanie użytkownika. Aby dostać od niego tę informację należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Get opened ports". Otworzy się wówczas następujące okno:

an27.jpg (23708 bytes)

Jeżeli operacja przebiegnie bezbłędnie okno zamknie się automatycznie. W przeciwnym przypadku pozostanie razem z komunikatami o błędach póki nie naciśniemy klawisza "Close". Lista portów pojawi się w oknie viewera "Opened ports".


Zdalne włączenie stacji (Wake up)

Jeżeli komputer w sieci jest zgodny ze specyfikacją WakeUp On LAN i jest odpowiednio skonfigurowany istnieje możliwość zdalnego włączenia go przez sieć komputerową. Aby to zrobić należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Wake up". Do prawidłowego działania tej opcji niezbędne jest aby:

  • Stacja miała w profilu ustawiony prawidłowy adres IP
  • Zdalny komputer posiadał kartę sieciową i płytę główną zgodną ze specyfikacją WakeUp On LAN
  • Zdalny komputer był poprawnie skonfigurowany do pracy z WakeUp On LAN (płyta główna i karta muszą być połączone specjalnym kabelkiem, WakeUp On LAN musi być włączony w BIOSie etc.)


Odświeżanie informacji o wykonywanych aplikacjach (Get application...)

Jedną ze statystyk, zbieranie której umożliwia ANASIL Desktop Agent jest statystyka aplikacji wykonywanych na danej stacji. Może ona służyć zarówno do kontroli pracowników jak również do sprawdzenia czy w sieci nie są uruchamiane nieautoryzowane bądź pirackie aplikacje. Statystyka ta opisuje przez ile czasu (procentowo) każda z używanych aplikacji była na pierwszym planie (foreground).

Aby odświeżyć tę informację w bazie statystyk korzystając z usług zainstalowanego na niej ANASIL Desktop Agenta należy z kontekstowego menu stacji (w drzewie struktury sieci ) wybrać opcję "Get application statistics". Otworzy się wówczas następujące okno:

an27.jpg (23708 bytes)

Jeżeli operacja przebiegnie bezbłędnie okno zamknie się automatycznie. W przeciwnym przypadku pozostanie razem z komunikatami o błędach póki nie naciśniemy klawisza "Close". Statystyki po ściągnięciu są wpisywane do bazy statystyk. Jeżeli chcemy je zwizualizować należy zbudować dla nich odpowiedni viewer.


Dziennik wydarzeń i Okno komunikatów

Dziennik wydarzeń (Event log) jest oknem, w którym pojawiają się komunikaty o przekroczeniach zadanych parametrów. Wartości krytyczne, których przekroczenia mogą być odnotowywane w dzienniku są definiowane przy pomocy mechanizmu progów ustawianych dla konkretnych elementów wizualizujących statystyki. W definicji progu możemy podać które przekroczenia zostaną zapisane do dziennika oraz jaka będzie treść komunikatów. Wraz z treścią komunikatu, w dzienniku zapisywana jest również data i godzina.

Oprócz zapisu do okna (którego widoczność jest sterowana opcją "Event log" z menu "View") system zapisuje dziennik wydarzeń również na dysku, w podkatalogu WORK jako tekstowy plik EVENT.LOG. Plik ten ma stałą strukturę, ułatwiającą jego późniejszą analizę - każdy zapis do dziennika umieszczany jest w osobnej linii w formacie:

YY.MM.DD    HH:MM:SS     Komunikat

gdzie: YY - rok, MM - miesiąc, DD - dzień, HH - godzina, MM - minuta, SS - sekunda. Data, czas i komunikat są oddzielone od siebie znakami tabulacji.

Okno komunikatów (System log) jest przez system wykorzystywane do wyprowadzania różnych komunikatów systemowych (np. o błędach w czasie niektórych operacji). Jego zawartość jest tracona po każdym wyjściu z programu. Jego widoczność jest sterowana opcją "System log" z menu "View".


Eksporty

an219.jpg (60326 bytes) Jedną z nowości wprowadzonych w ANASIL'u 2.0 jest możliwość wykonywania automatycznych lub półautomatycznych eksportów zadanych zestawów statystyk w zadanym przedziale czasowym. Użytkownik musi tylko określić jakie statystyki mają być eksportowane, czy eksport ma startować automatycznie czy ręcznie, a jeżeli automatycznie to o jakich porach i w jakie dni tygodnia. W zadanym czasie system rozpocznie zapisywanie wybranych statystyk do pliku w specjanym skompresowanym formacie. Z plików tych można za pomocą mechanizmu raportów wyodrębnić i przetworzyć interesujące nas dane.

Użytkownik może modyfikować listę zdefiniowanych eksportów, tudzież obserwować ich status za pomocą okna eksportów (patrz rysunek po prawej). Poniżej okna znajduje się zestaw przycisków, służących do (od lewej):

  • Dodawania nowego eksportu do listy
  • Modyfikacji definicji aktualnie zaznaczonego eksportu
  • Usunięcia eksportu z listy
  • Ręcznego uruchomienia zaznaczonego eksportu
  • Ręcznego zatrzymania zaznaczonego eksportu

Opcje dodawania i modyfikacji eksportu powodują otwarcie się okna edycji definicji eksportu. Okno to pozwala dowolnie kształtować zestaw i parametry czasowe eksportowanych danych.


Okno edycji definicji eksportu

Parametry eksportu, zarówno zestaw eksportowanych statystyk jak parametry czasu eksportu można ustawić za pomocą poniższego okna:

an235.jpg (75437 bytes)

Okno to składa się z następujących elementów:

  • Job name - w polu tym wpisać należy mnemoniczną nazwę eksportu. Nazwa ta będzie wyświetlana w liście zdefiniowanych eksportów.
  • Statistics to be exported [Edit] - naciśnięcie tego klawisza spowoduje otwarcie okna wyboru statystyk i umożliwi wybór zestawu eksportowanych statystyk.
  • Export periodically - zaznaczenie tej opcji spowoduje, że eksport będzie się odbywał automatycznie w zadanych poniżej okresach czasu. Dane będą eksportowane do katalogu EXPORTS, do plików o nazwach w formacie: hh_mm (DD_MM_YY)V.AEX, gdzie hh- godzina rozpoczęcia, mm- minuta rozpoczęcia, DD- dzień rozpoczęcia, MM- miesiąc rozpoczęcia, YY- rok rozpoczęcia, V- kolejny numer pliku.
  • Every day - zaznaczenie tej opcji spowoduje, że eksport będzie się odbywał codziennie w godzinach zdefiniowanych poniżej.
  • On selected days - zaznaczenie tej opcji spowoduje, że eksport będzie się odbywał tylko w zaznaczone dni.
  • Starting at/Stopping at - wartości te definiują przedział czasu w jakim będzie się odbywał cykliczny eksport.
  • Export immediately - zaznaczenie tej opcji spowoduje, że eksport będzie można uruchomić ręcznie z listy eksportów
  • Number of samples - liczba sekund, przez które system będzie eksportował dane.
  • Output file - nazwa pliku do którego będą eksportowane dane.


Raporty

Z plików binarnych utworzonych w czasie eksportu statystyk możemy sporządzać różnorakie raporty. W definicji raportu możemy wybrać z pliku eksportowego tylko niektóre dane, dokonywać uśrednień wartości, liczyć maksima i minima. Jeden plik eksportowy może służyć jako źródło danych do wielu raportów. Raport definiujemy przy pomocy opcji "New report definition" i "Edit report definition" z menu Reports.

Raporty mogą być generowane w formacie tekstowym (TAB delimited) lub w formacie HTML. Generowanie plików TXT/HTML odbywa się za pomocą wybrania opcji "Create report from exported stats" z menu Reports.


ANASIL Desktop Agent

Aby umożliwić programowi dokonywanie bardziej dogłębnych analiz konfiguracji stacji, konieczne okazało się zaimplementowanie części funkcji analizujących na stacjach w sieci. ANASIL Desktop Agent jest niewielkim programem rezydentnym, uruchamianym automatycznie przy starcie systemu, który komunikując się z ANASILem jest w stanie dostarczyć mu szczegółowych informacji na temat konfiguracji stacji, wykonać niektóre funkcje (np. zdalny shutdown czy restart) jak również przesłać aktualną zawartość ekranu.

Instalacja ANASIL Desktop Agent na stacji jest bardzo prosta i sprowadza się właściwie do uruchomienia jednego programu. Jeżeli planujecie Państwo instalację agenta na większej ilości stacji, proponujemy następującą procedurę:

  1. Wszystkie pliki ANASIL Desktop Agent znajdują się po instalacji ANASIL'a 2.0 w podkatalogu ADAG (jeżeli zainstalowali Państwo ANASILa w katalogu C:\Program Files\ANASIL, to pliki potrzebne do instalacji ANASIL Desktop Agent'a będą się znajdowały w katalogu C:\Program Files\ANASIL\ADAG). Pliki te najlepiej przekopiować do katalogu dostępnego dla wszystkich użytkowników sieci (ogólnodostępny katalog na głównym serwerze).
  2. Na stacji, na której chcemy zainstalować agenta, uruchamiamy z tego wspólnego katalogu program ADAGINST.EXE. Program ten kopiuje potrzebne pliki na dysk lokalny stacji i instaluje agenta w rejestrze systemowym. Od tej pory agent będzie się uruchamiał automatycznie przy każdym starcie systemu przed zalogowaniem się do sieci. Ponieważ w z systemie Windows NT agent jest serwisem (service), do jego instalacji niezbędne jest posiadanie uprawnień administratora.
  3. W profilu sieci należy wskazać stacje, które mają zainstalowanego ANASIL Desktop Agent'a. W tym celu w oknie edycji właściwości stacji zaznaczamy flagę "Desktop agent installed". Żeby operacja ta się powiodła konieczne jest ustawienie w profilu adresu IP danej stacji.

Jakie operacje wspomaga ANASIL Desktop Agent?

Dzięki ANASIL Desktop Agent, będzie możliwy:

  • Zdalne wyłączanie i restartowanie stacji
  • Zbieranie statystyk na temat błędów transmisji popełnionych przez poszczególne adaptery sieciowe stacji.
  • Zbieranie informacji o aktualnie otwartych portach TCP/UDP
  • Zbieranie informacji o statusie urządzeń (Windows 95/98) lub serwisów (Windows NT)
  • Zbieranie informacji o konfiguracji stacji
  • Zbieranie informacji o liczbie dysków i o ilości wolnego miejsca na nich
  • Przesyłanie do użytkownika komunikatów
  • Pobieranie szczegółowych informacji o konfiguracji adapterów, protokołów i klientów sieci.
  • Podglądanie ekranu stacji (w trybie thumbnail i pełnoekranowym)
  • Zbieranie informacji na temat aplikacji używanych na danej stacji i ich wykorzystaniu.


Baza statystyk

Hierarchiczna baza statystyk składa się z kilku głównych części. Są to:

  1. Statystyki globalne - są to statystyki zbierane dla całej analizowanej podsieci.
  2. Statystyki stacji sieciowych - są to statystyki dotyczące każdej ze stacji sieciowych, zorganizowane w postaci tablicy statystyk.
    1. TCP Ports - statystyki ruchu na portach TCP konkretnej stacji
    2. UDP Ports - statystyki ruchu na portach UDP konkretnej stacji
    3. ICMP Received - statystyki rodzajów paketów ICMP kierowanych do konkretnej stacji
    4. Adapters Info - statystyki błędów transmisji dla adapterów sieciowych stacji (wymagany ANASIL Desktop Agent)
    5. Opened ports - lista portów TCP/UDP otwartych na stacji (wymagany ANASIL Desktop Agent)
    6. Disk info - stan dysków twardych na stacji (wymagany ANASIL Desktop Agent)
    7. Applications usage - statystyki użycia aplikacji na stacji (wymagany ANASIL Desktop Agent)
  3. Statystyki protokołów - są to statystyki dotyczące udziału protokołów sieciowych w wypełnieniu łącza, zorganizowane w postaci tablicy statystyk.
  4. Statystyki połączeń - są to statystyki dotyczące ruchu generowanego poprzez połączenia pomiędzy konkretnymi stacjami, zorganizowane w postaci tablicy statystyk.
  5. Statystyki testów point-to-point - są to statystyki przechowujące wyniki testów point-to-point.
  6. Statystyki typów ramek - są to statystyki opisujące proporcje pomiędzy Broadcatami, Multicastami i ramkami Directed.
  7. Statystyki rozmiarów ramek - są to statystyki opisujące dystrybucję rozmiarów ramek.
  8. Statystyki dotyczące konkretnych protokołów
    1. TCP/IP
      1. Global IP RIP Cache - pamięć podręczna pakietów protokołu routingu RIP
      2. IP sub-protocols - statystyka ruchu w podprotokołach rodziny TCP/IP
      3. TCP ports - globalna statystyka ruchu na portach TCP
      4. UDP ports - globalna statystyka ruchu na portach UDP
      5. Global HTTP Traffic - globalna statystyka odwołań do serwerów HTTP
      6. IP Connections - macierz połączeń po protokole TCP/IP
      7. Cookies sent - globalna statystyka wysłanych przez stacje "Cookies"
    2. ARP - pamięć podręczna protokołu ARP
    3. IPX SAP - pamięć podręczna protokołu IPX SAP
    4. Appletalk - pamięć podręczna protokołu NBP
    5. Appletalk ARP - pamięć podręczna protokołu AARP


Globalne statystyki

Są to statystyki dotyczące ruchu w całej analizowanej podsieci. W oknie wyboru statystyk są one umieszczone najbliżej "korzenia" drzewa statystyk. Zaliczamy do nich:

  1. Numer próbki (Sample number) - liczba próbek (sekund), które upłynęły od rozpoczęcia analiz przez ANASILa
  2. Liczba przetransmitowanych danych (Global transmitted data) - liczba bajtów przetransmitowanych przez sieć w tym czasie.
  3. Liczba przetransmitowanych ramek (Global transmitted frames count) - liczba ramek przetransmitowanych przez sieć w tym czasie.
  4. Aktualne wykorzystanie sieci (Current network utilization) - aktualne procentowe obciążenie łącza Ethernet. Jako podstawę obliczeń przyjmuje się, że łacze takie ma maksymalną przepustowość 10Mb/s. W obliczeniach brane są pod uwagę także elementy ramki nie wchodzące w skład ramki warstwy liniowej, tj. preambuła, suma kontrolna i inne.
  5. Średnie wykorzystanie sieci (Average network utilization) - średnie procentowe obciążenie łącza w czasie działania programu.
  6. Szczytowe wykorzystanie sieci (Peak network utilization) - szczytowe procentowe obciążenie łącza zaobserwowane w trakcie prowadzenia analiz.
  7. Liczba przepełnień sprzętowych (Hardware overflow count) - liczba ramek, których karta sieciowa nie zdążyła odebrać na skutek przepełnionych buforów.
  8. Liczba przepełnień programowych (Software overflow count) - liczba ramek odebranych przez kartę sieciową ale nie przetworzonych przez ANASILa na skutek np. zbyt małej wydajności komputera w stosunku do ruchu w sieci.
  9. Średnia dokładność pomiarów (Accuracy) - procentowa wartość określająca średnią dokładność pomiarów na podstawie liczby ramek odebranych i nie odebranych na skutek przepełnień.
  10. Czas rozpoczęcia pomiarów (Analysis started) - podaje czas rozpoczęcia pomiarów.
  11. Liczba ramek rozgłaszanych (Broadcast frames) - Liczba ramek nadanych w trybie rozgłaszania w czasie pracy programu.
  12. Liczba danych w ramkach rozgłaszanych (Broadcast data) - Liczba danych (w bajtach) zawartych w ramkach nadanych w trybie rozgłaszania w czasie pracy programu.
  13. Udział danych przesyłanych w trybie rozgłaszania w wykorzystaniu łącza (Broadcast share) - procentowa wielkość określająca jaki udział mają ramki rozgłaszane w wykorzystaniu łącza.
  14. Liczba ramek przesyłanych w trybie ograniczonego rozgłaszania (Multicast frames) - Liczba ramek nadanych w trybie ograniczonego rozgłaszania w czasie pracy programu.
  15. Liczba danych w ramkach przesyłanych w trybie ograniczonego rozgłaszania (Multicast data) - Liczba danych (w bajtach) zawartych w ramkach nadanych w trybie ograniczonego rozgłaszania w czasie pracy programu.
  16. Udział danych przesyłanych w trybie ograniczonego rozgłaszania w wykorzystaniu łącza (Multicast share) - procentowa wielkość określająca jaki udział mają ramki nadawane w trybie ograniczonego rozgłaszania w wykorzystaniu łącza.
  17. Liczba ramek skierowanych (Directed frames) - Liczba ramek nadanych w trybie skierowanym (ramki pomiędzy dwiema stacjami) w czasie pracy programu.
  18. Liczba danych w ramkach skierowanych (Directed data) - Liczba danych (w bajtach) zawartych w ramkach nadanych w trybie skierowanym w czasie pracy programu.
  19. Udział danych przesyłanych w ramkach skierowanych w wykorzystaniu łącza (Directed share) - procentowa wielkość określająca jaki udział mają ramki nadawane w trybie skierowanym w wykorzystaniu łącza.
  20. Liczba ramek poddanych filtrowaniu (Filtered frames) - liczba ramek poddanych działaniu globalnego filtra.
  21. Liczba ramek odrzuconych przez filtr (Rejected frames) - liczba ramek odrzuconych przez globalny filtr.
  22. Liczba ramek zaakceptowanych przez filtr (Accepted frames) - liczba ramek zaakceptowanych przez globalny filtr.
  23. Liczba ramek z błędnym CRC (CRC Errors) - globalne dla podsieci
  24. Liczba ramek z błędami wyrównania ramki (Alignment Errors) - globalne dla podsieci
  25. Liczba ramek, które napotkały pojedynczą kolizję podczas transmisji (Xmit Single Collisions) - tylko dla lokalnej karty sieciowej
  26. Liczba ramek, które napotkały wielokrotne kolizje podczas transmisji (Xmit Mulitple Collisions) - tylko dla lokalnej karty sieciowej
  27. Liczba ramek, które zostały wytransmitowane po jednokrotnym odrzuceniu przez kartę sieciową (Xmit deferred) - tylko dla lokalnej karty sieciowej
  28. Liczba ramek, które nie zostały wytransmitowane na skutek wielokrotnych kolizji (Xmit Max Collisions) - tylko dla lokalnej karty sieciowej
  29. Liczba ramek, które napotkały błąd "NIC Overrun" podczas odbioru (Receive overruns) - tylko dla lokalnej karty sieciowej
  30. Liczba ramek, które napotkały błąd "NIC Underrun" podczas transmisji (Xmit underruns) - tylko dla lokalnej karty sieciowej


Statystyki stacji sieciowych

W głównej gałęzi drzewa statystyk znajduje się tablica statystyk oznaczona jako Network stations. Zawiera ona informacje o aktywności wszystkich stacji w sieci. Dla każdej stacji gromadzone są następujące informacje:

  1. Adres sieciowy stacji (MAC Address) - adres MAC stacji, której dotyczą statystyki
  2. Liczba danych wytransmitowanych przez stację (Data transmitted) - sumaryczna liczba bajtów we wszystkich ramkach, które wysłała stacja (ramek, które w polu adresu pochodzenia miały adres danej stacji).
  3. Liczba danych odebranych przez stację (Data received) - sumaryczna liczba bajtów we wszystkich ramkach, które odebrała stacja (ramek, które w polu adresu przeznaczenia miały adres danej stacji).
  4. Liczba ramek wytransmitowanych przez stację (Frames transmitted) - sumaryczna liczba ramek, które wysłała stacja (ramek, które w polu adresu pochodzenia miały adres danej stacji).
  5. Liczba ramek odebranych przez stację (Frames received) - sumaryczna liczba ramek, które odebrała stacja (ramek, które w polu adresu przeznaczenia miały adres danej stacji).

Każda stacja w profilu sieci ma przypisany identyfikator, stanowiący o jego miejscu w tej tablicy statystyk. Stacje z profilu mają identyfikatory z zakresu od 1 do 1000. Multicasty i Broadcasty mają identyfikatory od 2000 do 3000. Identyfikatory powyzej 3000 są przypisywane stacjom spoza profilu.


TCP Ports

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako TCP Ports. Zawiera ona informacje o aktywności portów TCP na danej stacji. Dla każdej stacji gromadzone są następujące informacje:

  1. Numer portu TCP (Port number) - numer portu TCP
  2. Liczba ramek odebranych i wytransmitowanych na tym porcie (Total frames) - sumaryczna liczba ramek jakie zostały wysłane lub odebrane na danym porcie TCP stacji.
  3. Ilość danych odebranych i wytransmitowanych na tym porcie (Total data) - sumaryczna liczba bajtów jakie zostały wysłane lub odebrane na danym porcie TCP stacji.
  4. Udział ruchu na porcie w ogólnym ruchu TCP na danej stacji (Share) - procentowy udział ruchu na danym porcie w stosunku do ruchu na wszystkich portach TCP stacji.
  5. Liczba ramek odebranych przez stację na porcie TCP (Received frames) - sumaryczna liczba ramek, które odebrała stacja na danym porcie TCP
  6. Ilość danych odebranych przez stację na porcie TCP (Received data) - sumaryczna liczba bajtów, które odebrała stacja na danym porcie TCP
  7. Liczba ramek nadanych przez stację na porcie TCP (Transmitted frames) - sumaryczna liczba ramek, które wytransmitowała stacja na danym porcie TCP
  8. Ilość danych nadanych przez stację na porcie TCP (Transmitted data) - sumaryczna liczba bajtów, które wytransmitowała stacja na danym porcie TCP


UDP Ports

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako UDP Ports. Zawiera ona informacje o aktywności portów UDP na danej stacji. Dla każdej stacji gromadzone są następujące informacje:

  1. Numer portu UDP (Port number) - numer portu UDP
  2. Liczba ramek odebranych i wytransmitowanych na tym porcie (Total frames) - sumaryczna liczba ramek jakie zostały wysłane lub odebrane na danym porcie UDP stacji.
  3. Ilość danych odebranych i wytransmitowanych na tym porcie (Total data) - sumaryczna liczba bajtów jakie zostały wysłane lub odebrane na danym porcie UDP stacji.
  4. Udział ruchu na porcie w ogólnym ruchu UDP na danej stacji (Share) - procentowy udział ruchu na danym porcie w stosunku do ruchu na wszystkich portach UDP stacji.
  5. Liczba ramek odebranych przez stację na porcie UDP (Received frames) - sumaryczna liczba ramek, które odebrała stacja na danym porcie UDP
  6. Ilość danych odebranych przez stację na porcie UDP (Received data) - sumaryczna liczba bajtów, które odebrała stacja na danym porcie UDP
  7. Liczba ramek nadanych przez stację na porcie UDP (Transmitted frames) - sumaryczna liczba ramek, które wytransmitowała stacja na danym porcie UDP
  8. Ilość danych nadanych przez stację na porcie UDP (Transmitted data) - sumaryczna liczba bajtów, które wytransmitowała stacja na danym porcie UDP


ICMP Received

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako ICMP Received. Zawiera ona informacje o ramkach ICMP wysłanych do danej stacji. Dla każdej stacji gromadzone są następujące informacje:

  1. Adres IP nadawcy ramki (Sender) - adres IP nadawcy ramki ICMP
  2. Typ ramki ICMP (Type)
  3. Kod ICMP (Code)
  4. Liczba ramek od danej stacji o tym typie i kodzie (Received frames)


Adapters info

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako Adapters info. Zawiera ona informacje, pobrane przy pomocy opcji "Refresh statistics" z ANASIL Desktop agenta na temat statusu adapterów sieciowych w danej stacji. Dla każdego adaptera gromadzone są następujące informacje:

  1. Nazwa adaptera sieciowego (Adapter name)
  2. Liczba wytransmitowanych ramek (Frames transmitted)
  3. Liczba odebranych ramek (Frames received)
  4. Liczba ramek wytransmitowanych z błędem (Error frames transmitted)
  5. Liczba ramek odebranych z błędem (Error frames received)
  6. Liczba ramek nieodebranych ze względu na brak buforów (Frames missed)
  7. Liczba ramek odebranych z błędem sumy kontrolnej (CRC errors received)
  8. Liczba ramek odebranych, w których liczba bitów nie była podzielna przez osiem (Alignment errors received)
  9. Liczba ramek przy transmisji których napotkano jedną kolizję (Transmissions with one collision)
  10. Liczba ramek przy transmisji których napotkano więcej niż jedną kolizję (Transmissions with more collisions) -
  11. Liczba ramek wytransmitowanych po uprzednim odrzuceniu (After deferral transmissions)
  12. Liczba ramek odrzuconych ze względu na zbyt dużą liczbę kolizji (Transmissions with max collisions)
  13. Liczba transmisji powodujących błąd overrun (Overrun transmissions)
  14. Liczba transmisji powodujących błąd underrun (Underrun transmissions)
  15. Ile razy adapter sieciowy wykrył odłączenie od sieci (Carrier lost)
  16. Liczba transmisji ze spóźnionymi kolizjami (Late collisions)


Opened ports

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako Opened Ports. Zawiera ona informacje o portach TCP i UDP otwartych na danej stacji. Informacje te zbierane są za pomocą opcji "Get opened ports", która używając do tego ANASIL Desktop Agenta wykonuje zdalnie polecenie netstat. Dla każdego portu gromadzone są następujące informacje:

  1. Protokół (Protocol) - protokół w jakim otwarty jest port (TCP lub UDP)
  2. Lokalny adres IP połączenia (Local address)
  3. Numer lokalnego portu (Local port)
  4. Zdalny adres IP połączenia (Remote address)
  5. Numer zdalnego portu (Remote port)
  6. Status połączenia (Status)


Disk info

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako Disk info. Zawiera ona informacje, pobrane przy pomocy opcji "Refresh statistics" z ANASIL Desktop agenta na temat liczby i stanu dyków twardych w danej stacji. Dla każdego dysku gromadzone są następujące informacje:

  1. Główny katalog dysku (Root)
  2. Nazwa wolumenu (Volume name)
  3. Typ systemu plików (File system)
  4. Numer seryjny dysku (Serial number)
  5. Pojemność dysku (Total space)
  6. Ilość wolnej pamięci na dysku (Free space)
  7. Ilość pamięci dostępnej dla aktualnie zalogowanej osoby (Free to caller)


Applications usage

Dla każdej stacji w drzewie statystyk zdefiniowana jest tablica statystyk oznaczona jako Applications usage. Zawiera ona informacje, pobrane przy pomocy opcji "Get application statistics" z ANASIL Desktop agenta na temat wykorzystania aplikacji na danej stacji. Dla każdej aplikacji gromadzone są następujące informacje:

  1. Nazwa aplikacji (Application)
  2. Pełna ścieżka do głównego modułu aplikacji (Module)
  3. Liczba sekund, przez którą aplikacja była na pierwszym planie (Usage)
  4. Procentowy udział czasu kiedy aplikacja była na pierwszym planie w sumarycznym czasie działania komputera (Percent)


Statystyki protokołów

W głównej gałęzi drzewa statystyk znajduje się tablica statystyk oznaczona jako Protocol counters. Zawiera ona informacje o protokołach (warstwy sieciowej) obecnych w sieci i ich udziale w obciążeniu łącza. Dla każdego protokołu gromadzone są następujące informacje:

  1. Identyfikator protokołu (Protocol ID) - dwu- lub pięciobajtowy (zależnie od typu ramki Ethernet) identyfikator prtokołu.
  2. Liczba danych przetransmitowanych (Data transmitted) - sumaryczna liczba bajtów przesłanych w ramach danego protokołu.
  3. Liczba ramek przetransmitowanych (Frames transmitted) - liczba ramek przesłanych w ramach danego protokołu.
  4. Średni rozmiar ramki (Average frame size) - średni rozmiar ramki (w bajtach) w danym protokole
  5. Udział w wypełnieniu łącza (Utilization share) - udział protokołu w wypełnieniu łącza.

UWAGA: ten sam protokół (np IPX) może wystąpić w tablicy wielokrotnie gdy po sieci poruszają się ramki IPX korzystające z więcej niż jednego typu ramki Ethernet. System tworzy wtedy po jednym elemencie tablicy dla każdego typu ramki.


Statystyki połączeń

W głównej gałęzi drzewa statystyk znajduje się tablica statystyk oznaczona jako Connections. Zawiera ona informacje o połączeniach pomiędzy stacjami w sieci. Dla każdej transmisji pomiędzy dwiema stacjami jest tworzony element w tej tablicy. W każdym elemencie przechowywane są następujące informacje o połączeniu:

  1. Adres MAC stacji źródłowej (Source)
  2. Adres MAC stacji docelowej (Destination)
  3. Liczba danych przesłanych pomiędzy tymi stacjami (Data transmitted)
  4. Liczba ramek przesłanych pomiędzy tymi stacjami (Frames transmitted)
  5. Średni rozmiar ramki w łączności pomiędzy tymi stacjami (Average frame size)
  6. Udział ramek przesłanych pomiędzy stacjami w wypełnieniu łącza (Utilization share)


Statystyki testów point-to-point

W głównej gałęzi drzewa statystyk znajdują się cztery tablice statystyk przechowujące wyniki testów point-to-point dla czterech protokołów. Są one oznaczone jako IPX point-to-point tests, IP (ICMP) point-to-point tests, NetBEUI point-to-point tests oraz Appletalk point-to-point tests. W każdym elemencie wymienionych tablic przechowywane są informacje o wynikach testów jednej stacji. Dla każdej stacji przechowywane są:

  1. Mnemoniczna nazwa testowanej stacji (Station name)
  2. Liczba testowych pakietów wysłanych do stacji (Packets sent)
  3. Liczba testowych pakietów, które powróciły (Packets echoed)
  4. Liczba utraconych testowych pakietów (Packets lost)
  5. Minimalny czas po którym testowy pakiet powrócił (Minimum response time) - wyrażony w milisekundach
  6. Średni czas po którym wracają testowe pakiety (Average response time) - wyrażony w milisekundach
  7. Największy czas po którym testowy pakiet powrócił (Maximum response time) - wyrażony w milisekundach
  8. Opis błędu (Error description) - w testach dla niektórych protokołów pojawia się tu opis błedu powstałego przy wysyłaniu poprzedniej ramki testowej. Wartość tekstowa.


Statystyki pamięci podręcznych

W czasie analiz ruchu w sieci ANASIL buduje sobie pomocnicze tablice, w których zbierane są:

  • Przyporządkowanie adresów sieciowych (MAC) do adresów IP
    Pomocniczy dla TCP/IP protokół ARP (Address resolution protocol) służy do przyporządkowywania adresom IP odpowiednich adresów warstwy liniowej (MAC). ANASIL przechwytuje wszystkie ramki protokołu ARP i na ich podstawie buduje aktualną tablicę tych przyporządkowań. Tablica ta znajduje się w drzewie statystyk w gałęzi Local Network/Protocols/ARP/Global ARP cache. Można ją także zobaczyć wybierając z menu "View" opcję "TCP/IP / ARP cache".
  • Przyporządkowanie adresów sieciowych (MAC) do adresów DDP
    Pomocniczy dla Appletalk DDP protokół AARP (Appletalk Address resolution protocol) służy do przyporządkowywania adresom Appletalk odpowiednich adresów warstwy liniowej (MAC). ANASIL przechwytuje wszystkie ramki protokołu AARP i na ich podstawie buduje aktualną tablicę tych przyporządkowań. Tablica ta znajduje się w drzewie statystyk w gałęzi Local Network/Protocols/AARP/Global AARP cache. Można ją także zobaczyć wybierając z menu "View" opcję "Appletalk / AARP cache".
  • Informacje o dostępności i położeniu usług w sieci IPX
    Protokół SAP (Service Advertising Protocol) z rodziny protokołów IPX służy do rozgłaszania i lokalizacji usług w sieci. ANASIL przechwytuje wszystkie ramki protokołu SAP i na ich podstawie buduje aktualną tablicę dostępnych w sieci usług. Tablica ta znajduje się w drzewie statystyk w gałęzi Local Network/Protocols/IPX/Global SAP cache. Można ją także zobaczyć wybierając z menu "View" opcję "IPX/SPX / SAP lookup".
  • Informacje o dostępności i położeniu usług w sieci Appletalk
    Protokół NBP (Network Binding Protocol) z rodziny protokołów Appletalk służy do rozgłaszania i lokalizacji usług w sieci. ANASIL przechwytuje wszystkie ramki protokołu NBP i na ich podstawie buduje aktualną tablicę dostępnych w sieci usług. Tablica ta znajduje się w drzewie statystyk w gałęzi Local Network/Protocols/Appletalk/Global NBP cache. Można ją także zobaczyć wybierając z menu "View" opcję "Appletalk / NBP lookup".


Statystyki typów ramek

W głównej gałęzi drzewa statystyk znajduje się tablica statystyk oznaczona jako Frame types. Zawiera ona informacje o proporcjach pomiędzy ramkami typu broadcast, multicast i directed. Dla każdego typu przechowywane są następujące informacje:

  1. Nazwa typu (Type name)
  2. Liczba ramek tego typu przetransmitowanych w sieci (Frames)
  3. Ilość danych przetransmitowanych w ramkach tego typu (Data)
  4. Procentowy udział ramek tego typu (Percent)


Statystyki rozmiarów ramek

W głównej gałęzi drzewa statystyk znajduje się tablica statystyk oznaczona jako Frame sizes. Zawiera ona informacje o proporcjach pomiędzy ramkami o różnych rozmiarach. Dla każdego rozmiaru przechowywane są następujące informacje:

  1. Przedział rozmiaru ramki w bajtach (Size)
  2. Liczba ramek o tym rozmiarze przetransmitowanych w sieci (Frames)
  3. Ilość danych przetransmitowanych w ramkach o tym rozmiarze (Data)
  4. Procentowy udział ramek o tym rozmiarze (Share)


Global IP RIP Cache

W gałęzi Protocols/TCP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako Global IP RIP Cache. Zawiera ona informacje rozgłaszane przez routery za pomocą protokołu IP RIP. Przechowywane są w niej następujące informacje:

  1. Adres IP rozgłaszającego routera (Router address)
  2. Rozgłaszany adres IP (Address)
  3. Rozgłaszana maska podsieci (Subnet mask)
  4. Ilość "skoków" do rozgłaszanego adresu (Metric)
  5. Czas ostatniego odświeżenia informacji (Time)


IP Subprotocols

W gałęzi Protocols/TCP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako IP Subprotocols. Zawiera ona informacje o wykorzystaniu sieci przez podprotokoły protokołu IP. Dla każdego podprotokołu przechowywane są następujące informacje:

  1. Identyfikator podprotokołu (Supprotocol Id)
  2. Liczba ramek przetransmitowanych w sieci w ramach tego podprotokołu (Frames)
  3. Ilość danych przetransmitowanych w ramkach tego podprotokołu (Data)
  4. Procentowy udział w/w ramek (Share)


TCP ports

W gałęzi Protocols/TCP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako TCP Ports. Zawiera ona informacje o wykorzystaniu sieci przez ramki nadawane i odbierane w całej sieci na portach protokołu TCP. Dla każdego portu przechowywane są następujące informacje:

  1. Numer portu TCP (Port number) - numer portu TCP
  2. Liczba ramek odebranych i wytransmitowanych na tym porcie (Total frames) - sumaryczna liczba ramek jakie zostały wysłane lub odebrane na danym porcie TCP stacji.
  3. Ilość danych odebranych i wytransmitowanych na tym porcie (Total data) - sumaryczna liczba bajtów jakie zostały wysłane lub odebrane na danym porcie TCP stacji.
  4. Udział ruchu na porcie w ogólnym ruchu TCP na danej stacji (Share) - procentowy udział ruchu na danym porcie w stosunku do ruchu na wszystkich portach TCP stacji.
  5. Liczba ramek odebranych przez stację na porcie TCP (Received frames) - sumaryczna liczba ramek, które odebrała stacja na danym porcie TCP
  6. Ilość danych odebranych przez stację na porcie TCP (Received data) - sumaryczna liczba bajtów, które odebrała stacja na danym porcie TCP
  7. Liczba ramek nadanych przez stację na porcie TCP (Transmitted frames) - sumaryczna liczba ramek, które wytransmitowała stacja na danym porcie TCP
  8. Ilość danych nadanych przez stację na porcie TCP (Transmitted data) - sumaryczna liczba bajtów, które wytransmitowała stacja na danym porcie TCP


UDP Ports

W gałęzi Protocols/UDP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako UDP Ports. Zawiera ona informacje o wykorzystaniu sieci przez ramki nadawane i odbierane w całej sieci na portach protokołu UDP. Dla każdego portu przechowywane są następujące informacje:

  1. Numer portu UDP (Port number) - numer portu UDP
  2. Liczba ramek odebranych i wytransmitowanych na tym porcie (Total frames) - sumaryczna liczba ramek jakie zostały wysłane lub odebrane na danym porcie UDP stacji.
  3. Ilość danych odebranych i wytransmitowanych na tym porcie (Total data) - sumaryczna liczba bajtów jakie zostały wysłane lub odebrane na danym porcie UDP stacji.
  4. Udział ruchu na porcie w ogólnym ruchu UDP na danej stacji (Share) - procentowy udział ruchu na danym porcie w stosunku do ruchu na wszystkich portach UDP stacji.
  5. Liczba ramek odebranych przez stację na porcie UDP (Received frames) - sumaryczna liczba ramek, które odebrała stacja na danym porcie UDP
  6. Ilość danych odebranych przez stację na porcie UDP (Received data) - sumaryczna liczba bajtów, które odebrała stacja na danym porcie UDP
  7. Liczba ramek nadanych przez stację na porcie UDP (Transmitted frames) - sumaryczna liczba ramek, które wytransmitowała stacja na danym porcie UDP
  8. Ilość danych nadanych przez stację na porcie UDP (Transmitted data) - sumaryczna liczba bajtów, które wytransmitowała stacja na danym porcie UDP


Global HTTP traffic

W gałęzi Protocols/UDP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako Global HTTP traffic. Zawiera ona informacje o odwołaniach stacji w sieci do serwerów WWW po protokole HTTP. Dla każdej pary stacja-serwer WWW przechowywane są następujące informacje:

  1. Adres serwera HTTP (Target host)
  2. Adres stacji, która odwołała się do tego serwera (Source host)
  3. Adres proxy, przez który nastąpiło odwołanie (Proxy)
  4. Liczba stron ściągniętych z danego serwera (GET count)
  5. Liczba operacji POST (POST count)
  6. Czas ostatniej transmisji (Last transmission)

Sporządzanie tej statystyki można wyłączyć w oknie opcji programu. W tym samym oknie można również podać na jakim porcie w naszej sieci odbywają się transmisje w protokole HTTP (przy wykorzystaniu serwerów proxy nie musi to być port 80). Jeżeli wpisany numer portu jest równy 0, ANASIL stara się wykryć numer portu samodzielnie.


IP Connections

W gałęzi Protocols/UDP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako IP Connections. Zawiera ona informacje o ilościach ramek i danych przetransmitowanych pomiędzy różnymi adresami IP. Dla każdej pary adresów IP przechowywane są następujące informacje:

  1. Adres IP stacji źródłowej (Source)
  2. Adres IP stacji docelowej (Destination)
  3. Liczba danych przesłanych pomiędzy tymi stacjami (Data transmitted)
  4. Liczba ramek przesłanych pomiędzy tymi stacjami (Frames transmitted)
  5. Średni rozmiar ramki w łączności pomiędzy tymi stacjami (Average frame size)
  6. Udział ramek przesłanych pomiędzy stacjami w wypełnieniu łącza (Utilization share)


Cookies sent

W gałęzi Protocols/UDP IP drzewa statystyk znajduje się tablica statystyk oznaczona jako Cookies sent. Zawiera ona informacje o cookies wysłanych przez stacje w sieci podczas odwołań do serwerów HTTP. Dla każdego cookie przechowywane są następujące informacje:

  1. Adres serwera HTTP (Target host)
  2. Nazwa cookie (Cookie name)
  3. Wysyłana wartość (Cookie value)
  4. Adres IP, z którego wysłano cookie (Source host)


Opis funkcji

W następnych rozdziałach prezentujemy opis wszystkich funkcji programu ANASIL dostępnych z głownego menu programu. Główne menu ANASILa składa się z następujących pod-menu:

  1. Menu "Profiles" - zawierające opcje związane z manipulowaniem profilami sieci oraz globalne opcje programu.
  2. Menu "View" - zawierające opcje związane z widocznością różnych okien programu.
  3. Menu "Constructor" - zawierające opcje służące do konstrukcji viewerów i form.
  4. Menu "Viewers" - zawierające opcje związane z operacjami na viewerach (zamrażanie, odmrażanie, eksport).
  5. Menu "Filtering" - zawierające opcje pozwalające zakładać filtr globalny.
  6. Menu "Capture" - zawierające opcje związane z przechwytywaniem ramek.
  7. Menu "Point-to-point" - zawierające opcje dotyczące testów point-to-point.
  8. Menu "Analyzer" - zawierające globalne opcje analizatora ramek.
  9. Menu "Reports" - zawierające opcje sporządzania raportów.
  10. Menu "Desktop Agent" - zawierające opcje dotyczące ANASIL Desktop Agent.
  11. Menu "Window" - zawierające opcje dotyczące układu okien na ekranie.
  12. Menu "Help" - zawierające opcje dostępu do systemu pomocy.


Menu "Profiles" - opcje związane z profilami sieci

an258.jpg (20560 bytes)

Menu "Profiles" zawiera opcje związane z zarządzaniem profilami sieci oraz globalne opcje programu. Zawiera ono następujące opcje:

  1. Utwórz nowy profil (Create new profile)
  2. Otwórz profil zapisany na dysku (Open profile)
  3. Edytuj aktualny profil (Edit current profile)
  4. Eksportuj aktualny profil (Export profile)
  5. Zamknij (odłącz) aktualny profil (Close profile)
  6. Zmień adapter sieciowy (Change network adapter)
  7. Zmień hasło dostępu do programu (Change/set password)
  8. Opcje programu (Options)
  9. Wyjście z programu (Exit)


Opcja "Create new profile" - Utwórz nowy profil

Opcja "Create new profile" pozwala na utworzenie nowego profilu sieci. Wybranie tej opcji powoduje otwarcie okna edycji profilu z pustym profilem. Wyjście z tego okna przy pomocy przycisku OK spowoduje zachowanie utworzonego profilu pod daną nazwą i uczynienie go profilem aktywnym. Przy następnym starcie systemu profil ten zostanie załadowany automatycznie.


Edycja profilu

Okno edycji profilu pozwala na tworzenie profili oraz na dokonywanie zmian w profilach już istniejących.

an270.jpg (121224 bytes)

W górnej części okna znajdują się globalne parametry profilu:

  • Nazwa profilu (Network name) - mnemoniczna nazwa profilu
  • Identyfikator (Id) - identyfikator profilu (różny od 0). W przyszłości ANASIL zostanie wzbogacony o możliwość analizowania wielu sieci z jednej końcówki. Identyfikatory profili będą wtedy identyfikować również sieci.
  • Komentarz (Comments)
  • Typ sieci (Network type)
  • Adres IP sieci (IP address)
  • Maska podsieci (Subnet mask)
  • Numer sieci IPX (IPX network number)
  • Numery sieci Appletalk (Appletalk number from/to)

Poniżej znajduje się lista stacji należących do profilu (Network stations). Każda pozycja w liście składa się z czterech kolumn: nazwy mnemonicznej stacji (Name), identyfikatora stacji w profilu (Nr), adres MAC (Address) oraz nazwę i wersję systemu operacyjnego (OS).

Poniżej listy stacji znajduje się rząd przycisków dających dostęp do następujących opcji:

  • Automatyczne wykrywanie stacji w sieci i dodawanie ich do profilu (Acquire stations)
  • Odświeżenie adresów IP w profilu (Refresh IP addr)
  • Dodawanie stacji do profilu (Add station)
  • Usuwanie stacji z profilu (Remove station)
  • Edycja parametrów wskazanej stacji (Edit station)

Tworzenie nowego profilu lub uzupełnianie istniejącego

Operację tą najprościej jest przeprowadzić wykorzystując opcję automatycznego wykrywania stacji w sieci (Acquire stations). ANASIL, wykorzystując dostępne protokoły, stara się wtedy wymusić odpowiedź od wszystkich stacji w sieci. Stacje, które się "odezwały" są następnie identyfikowane przy pomocy różnych sieciowych serwisów nazw (DNS, SAP etc.).

Opcję tą można również wykorzystać do uzupełniania istniejącego profilu ponieważ automatyczne wykrywanie stacji w sieci nie usuwa stacji już w profilu istniejących.


Opcja "Acquire stations" - automatyczne zbieranie informacji o stacjach w sieci

Opcja ta uruchamia mechanizm zbierania informacji o stacjach w sieci. Zbieranie informacji przebiega w dwóch fazach: w fazie pierwszej program stara się wymusić od wszystkich stacji w sieci jakąś odpowiedź, używając dostępnych w danej chwili protokołów (patrz Instalacja i konfiguracja). W drugiej fazie, wszystkie stacje, które się "odezwały" są identyfikowane z wykorzystaniem dostępnych sieciowych serwisów nazw. Program korzysta z następujących serwisów:

  • Domain Name Service (DNS) - dla stacji używających protokołu TCP/IP. Wykorzystywany tylko wtedy gdy TCP/IP jest zainstalowany na maszynie na której uruchamiamy ANASILA. Uwaga ta dotyczy wszystkich serwisów nazw.
  • Microsoft Networking Name Service - protokół rozgłaszania nazw stosowany w sieciach firmy Microsoft, a więc w Microsoft Windows for Workgroups, Microsoft Windows 95 i Microsoft Windows NT.
  • Name Binding Protocol (NBP) - dla stacji używających protokołu Appletalk. Część protokołu Appletalk jest zaimplementowana wewnątrz ANASILa, w związku z czym nie trzeba instalować pakietów firm trzecich pozwalających na jego wykorzystanie.
  • Service Advertisment Protocol (SAP) - dla stacji używających protokołu IPX/SPX. Oprócz identyfikacji przez SAP możliwa jest także identyfikacja przez program USERLIST.EXE (NetWare 3.x) lub NLIST.EXE (NetWare 4.x), które tworzą listy użytkowników zalogowanych do konkretnych serwerów NetWare. (patrz Opcje zbierania informacji przez SAP oraz Pliki Inicjalizacyjne).
  • SNMP - stacje lub urządzenia posiadające możliwość posługiwania się protokołem SNMP zostaną zidentyfikowane przy pomocy tego protokołu.
  • ANASIL Desktop Agent - stacje na których zainstalowano ANASIL Desktop Agent zwracają najpełniejszą informację o swojej konfiguracji.

Dostępność wyżej wymienionych serwisów zależy od tego czy odpowiadające im protokoły warstwy transportowej zostały zainstalowane i poprawnie zainicjalizowane.

Wybranie opcji "Acquire stations" powoduje otwarcie okna, w którym użytkownik ma możliwość ustawienia opcji modyfikujących przebieg rozpoznawania stacji. W ten sposób użytkownik może wpływać na sposób doboru nazw. Patrz "Opcje zbierania informacji o sieci".


Opcje zbierania informacji o sieci

Wybranie opcji automatycznego zbierania informacji o stacjach w sieci (Acquire stations) powoduje otwarcie następującego okna:

an271.jpg (53973 bytes)

Po lewej stronie okna znajduje się lista dostępnych serwisów nazw. Serwisy te (a właściwie ich udział w zbieraniu informacji) można wyłączać/włączać przy pomocy flagi znajdującej się po prawej stronie każdego z nich. Kolejność serwisów w oknie decyduje o tym jaka nazwa zostanie wybrana jako nazwa mnemoniczna znalezionych stacji.

Przykład: Stacja używa protokołu TCP/IP oraz serwisu Microsoft Networking. Nazwą stacji w serwisie DNS jest stacja1.bla.com.pl a w Microsoft Networking: Msstacja1. Jeżeli DNS jest na liście przed MS-Net Name Service to stacja w profilu zostanie nazwana stacja1. Jeżeli MS-Net Name Service jest na liście przed DNS to stacja w profilu zostanie nazwana Msstacja1.

Kolejność serwisów w oknie można zmieniać przesuwając je myszką na zasadzie drag & drop.

Kliknięcie na nazwę serwisu może uaktywnić przycisk "Resolver setup". Przycisk ten otwiera okno opcji zbierania informacji dla danego serwisu nazw. Opcje te są dostępne dla serwisu Domain Name Service (TCP/IP) , ANASIL Desktop Agents oraz Service Advertising Protocol (SAP).

Kliknięcie przycisku "Acquire" powoduje uruchomienie procesu zbierania informacji. W czasie zbierania informacji, komunikaty o przebiegu procesu są wyświetlane w oknie komunikatów systemowych.


Opcje zbierania informacji przez DNS

Po wybraniu tej opcji otwiera się następujące okno:

an272.jpg (22396 bytes)

Okno to zawiera dwie flagi:

  1. Czy automatycznie wypełniać pole adresu IP w definicji stacji w profilu (Fill IP address field automatically) - patrz "Profil sieci".
  2. Czy rozwijać nazwę do pełnej nazwy domenowej (Resolve to full domain name) - domyślnie z pełnej nazwy domenowej stacji (np. stacja.domena.com.pl) są usuwane wszystkie składniki poza nazwą stacji (pozostaje tylko stacja). Zaznaczenie tej flagi powoduje, że nazwami mnemonicznymi stacji będą pełne nazwy domenowe.


Opcje zbierania informacji przez SAP

Wybranie tej opcji powoduje otwarcie poniższego okna:

an273.jpg (38604 bytes)

Okno to zawiera opcje dotyczące zbierania informacji przy pomocy serwisu SAP, w sieciach używających protokołów rodziny IPX/SPX. Są to:

  1. Czy rozwijać nazwy serwerów NetWare używając SAP (Resolve server names using SAP) - Zaznaczenie tej flagi powoduje, że system będzie używał protokołu SAP do znajdowania nazw serwerów NetWare na podstawie ich adresu sieciowego.
  2. Czy rozwijać nazwy stacji przy pomocy zewnętrznego programu USERLIST (Resolve workstations using USERLIST) - ANASIL może używać zewnętrznych programów typu command-line do znajdowania nazw stacji na podstawie ich adresów sieciowych. W systemiach Novell NetWare znajdują się odpowiednie programy. Są to USERLIST.EXE w NetWare 3.x oraz NLIST.EXE w systemach NetWare 4.x. Oba te programy potrafią wyprodukować listę aktualnie zalogowanych użytkowników wraz z adresami stacji. Na podstawie tej listy ANASIL moze przypisać adresom nazwy użytkowników.
  3. Wybór zewnętrznego programu (Select used NetWare version) - Okno to pozwala wybrać, który z programów (USERLIST czy NLIST) będziemy używać do rozwijania adresów stacji. Elementy w tym oknie, jak również nazwy i parametry zewnętrznych programów możemy zdefiniować samemu w specjalnym pliku konfiguracyjnym o nazwie USERLIST.INI.
  4. Czy dołączać identyfikator połączenia do nazwy (Append connection id to name) - Ponieważ jeden użytkownik może być zalogowany z więcej niż jednej stacji, może się zdarzyć, że przy rozwijaniu adresów programem USERLIST otrzymamy więcej niż jedną stację o tej samej nazwie. Zaznaczenie tej flagi powoduje, że do każdej znalezionej przez USERLIST nazwy zostanie dodany identyfikator połączenia z serwerem NetWare (zamiast HENIU będzie np. HENIU_21).


Opcje zbierania informacji przez ANASIL Desktop Agent

Wybranie tej opcji powoduje otwarcie poniższego okna:

an274.jpg (41486 bytes)

Okno to zawiera opcje dotyczące zbierania informacji przy pomocy ANASIL Desktop Agent a w szczególności zakresy adresów IP, które należy przepytać w poszukiwaniu stacji z zainstalowanym ANASIL Desktop agentem. Adresy te niekoniecznie muszą się znajdować w podsieci, w której pracuje ANASIL. Większość opcji agenta można wykorzystać również ze zdalnej podsieci.


Opcja "Refresh IP addresses" - odświeżanie adresów IP

Wybranie tej opcji spowoduje odświeżenie informacji o przyporządkowaniu adresów IP stacjom w profilu. Istnieje możliwość automatycznego wywoływania tej opcji przy starcie programu lub otwarciu profilu. Jest to istotne w sieciach używających dynamicznego przypisania adresów IP (np. protokołem DHCP). Opcję taką można ustawić w oknie opcji konfiguracji systemu.


Opcja "Add station" - dodawanie nowych stacji do profilu

Wybranie tej opcji powoduje utworzenie nowej stacji w profilu oraz otwarcie pustego okna edycji właściwości stacji. Zakończenie edycji przyciskiem "OK" powoduje dodanie nowej stacji do edytowanego profilu.


Edycja właściwości stacji

Właściwości stacji w profilu sieci można edytować przy pomocy poniższego okna:

an236.jpg (103854 bytes)

Okno to pozwala wprowadzić lub zmienić parametry stacji przechowywane w profilu sieci. Są to:

  1. Nazwa systemu operacyjnego stacji (Station OS / Version)
  2. Wersja systemu operacyjnego stacji (Station OS / Version)
  3. Adres MAC (Station MAC address)
  4. Czy na stacji zainstalowano ANASIL Desktop Agent (Desktop Agent Installed)
  5. Nazwa mnemoniczna stacji (Station name)
  6. Identyfikator stacji w profilu (Station number) - każda stacja ma swój identyfikator umiejscawiający ją w tablicy statystyk stacji sieciowych. Identyfikator ten powinien być większy od zera i mniejszy od 1000.
  7. Komentarz (Comment)
  8. Adres IP (IP address)
  9. Nazwa stacji w serwisie DNS (DNS name)
  10. Nazwa domeny w serwisie DNS (DNS domain)
  11. Nazwa stacji w serwisie nazw NBP (NBP name)
  12. Typ stacji w serwisie NBP (NBP type)
  13. Nazwa stacji w serwisie nazw Microsoft Networking (MS-Net name)
  14. Domena lub grupa robocza w serwisie nazw Microsoft Networking (MS-Net Domain/Workgroup)

Kliknięcie przycisku "Prev" powoduje zachowanie zmian i przejście do edycji poprzedniej stacji w profilu. Przycisk "Next" powoduje przejście do edycji stacji następnej. Kliknięcie przycisku "OK" powoduje akceptację zmian i wyjście z edycji.

Oprócz opisanej wyżej zakładki, okno to posiada kilka innych zakładek prezentujących informacje zwracane przez ANASIL Desktop Agenta. Są to:

Devices

Zakładka ta prezentuje dla stacji pracujących w systemie Windows 95 i Windows 98 listę urządzeń zainstalowanych w danej stacji włącznie z ich statusem. Pozwala to na zdalne sprawdzenie stanu urządzeń i pomaga w szukaniu przyczyny ewentualnej awarii.

an237.jpg (194374 bytes)

Services

Zakładka ta prezentuje dla stacji pracujących w systemie Windows NT listę serwisów włącznie z ich statusem.

an238.jpg (156095 bytes)

Network Configuration

Zakładka ta prezentuje w formie drzewa konfigurację i powiązania pomiędzy komponentami sieciowymi na danej stacji (adaptery sieciowe, protokoły, usługi)

an239.jpg (117094 bytes)

System info

Zakładka ta prezentuje dodatkowe informacje o systemie takie jak typ procesora czy ilość dostępnej pamięci.

an240.jpg (67445 bytes)

Screen dump

Zakładka ta pozwala na podgląd aktualnego ekranu na stacji z zainstalowanym ANASIL Desktop Agentem.

an241.jpg (164220 bytes)

Ściągnięcie zawartości ekranu następuje po wciśnięciu przycisku "Refresh view". Jeżeli chcemy podglądać ekran w sposób ciągły, można zaznaczyć flagę "Auto-refresh". System będzie wtedy automatycznie odświeżał zawartość ekranu co kilka sekund (domyślnie 5 sekund ale można zmienić tą wartośc wpisując ją w pole "Refr. every"). Jeżeli chcemy mieć podgląd w skali 1:1 (na cały ekran) należy kliknąć flagę "Full screen". Powrót z trybu pełnoekranowego odbywa się przez kliknięcie myszką.

Jeżeli stacja posiada więcej niż jeden monitor, można wybrać podglądany monitor z listy "Select monitor".


Opcja "Remove station" - usuwanie stacji z profilu

Wybranie tej opcji powoduje usunięcie aktualnie zaznaczonych (w oknie edycji profilu) stacji z edytowanego profilu.


Opcja "Edit station" - edycja właściwości stacji

Wybranie tej opcji powoduje przejście do edycji właściwości zaznaczonej stacji w profilu. Zakończenie edycji przyciskiem "OK" powoduje zmianę właściwości edytowanej stacji w profilu.


Opcja "Open profile" - załadowanie istniejącego profilu

Wybranie tej opcji powoduje załadowanie z dysku wybranego profilu i uczynienie go profilem aktywnym.


Opcja "Edit current profile" - edycja aktywnego profilu

Wybranie tej opcji powoduje przejście do edycji aktualnego profilu. Zakończenie edycji przyciskiem "OK" powoduje uaktywnienie dokonanych zmian.


Opcja "Export profile" - wyeksportowanie zawartości profilu do pliku

Opcja ta powoduje wyeksportowanie aktualnego profilu sieci do plików tekstowych (w standardzie czytelnym przez większość aplikacji bazodanowych). Po zapytaniu użytkownika o katalog, do którego należy eksportować, system tworzy w tym katalogu sześć plików zawierających komplet informacji z profilu. Są to:

  • NETWORKS.TXT - plik zawiera informacje o zdefiniowanych sieciach. W obecnej wersji programu jest w nim tylko jedna sieć.
  • STATIONS.TXT - plik zawiera informacje o stacjach w sieci.
  • ADAPTERS.TXT - plik zawiera informacje o adapterach sieciowych zainstalowanych na stacjach.
  • DEVICES.TXT - plik zawiera informacje o statusie urządzeń na stacjach z Windows 95 lub Windows 98
  • SERVICES.TXT - plik zawiera informacje o serwisach na stacjach z Windows NT
  • NETCOMP.TXT - plik zawiera informacje o komponentach sieciowych

Każdy plik jest plikiem tekstowym, w którym każdy rekord zajmuje jedną linię a pola wewnątrz rekordu są rozdzielone znakami tabulacji. W pierwszej linii każdego pliku znajdują się nazwy pól.


Opcja "Close profile" - zamknięcie aktywnego profilu

Opcja ta powoduje zamknięcie (odłączenie) aktywnego profilu sieci.


Opcja "Change adapter" - zmiana adaptera sieciowego

Opcja ta powoduje otwarcie okna z wyliczonymi wszystkimi adapterami sieciowymi, przy pomocy których ANASIL jest w stanie prowadzić analizy:

an275.jpg (37029 bytes)

Żeby zmienić domyślny adapter należy na niego kliknąć i nacisnąć przycisk "Open". Przy następnym starcie systemu ANASIL podłączy się do tego adaptera i za jego pomocą będzie prowadził analizy. Jeżeli chcemy opuścić okno bez zmiany adaptera - naciskamy przycisk "Cancel"


Opcja "Change/set password" - zmiana hasła dostępu do programu

Daną instalację ANASILa można zabezpieczyć hasłem przed niepożądanym użyciem. Od momentu ustawienia hasła system będzie o nie pytał przy wejściu do programu. Wybranie tej opcji powoduje otwarcie takiego okna:

an243.jpg (41375 bytes)

Jeżeli ustawiamy hasło, powinniśmy je wpisać dwa razy w rubryce "New password" i nacisnąć "OK".

Jeżeli chcemy zmienić hasło, powinniśmy stare hasło wpisać w rubryce "Old password" a nowe, dwa razy w rubryce "New password" i nacisnąć "OK".

Jeżeli chcemy skasować hasło, powinniśmy stare hasło wpisać w rubryce "Old password" a rubrykę "New password" zostawić pustą i nacisnąć "OK".


Opcje konfiguracji systemu

Okno poniższe pozwala ustawiać globalne opcje programu ANASIL:

an276.jpg (86372 bytes)

Dzieli się ono na trzy sekcje:

  1. Domyślne typy ramek Ethernet (Default Ethernet frame types) - zawiera ustawienia typów ramek Ethernet używanych w danej sieci przez protokoły IP oraz Appletalk. Zazwyczaj protokół IP używa ramki Ethernet II a protokół Appletalk - ramki Ethernet SNAP.
  2. Opcje (Options)
    1. Wyłączenie detekcji protokołu Appletalk przy starcie systemu (Disable Appletalk detection during startup) - detekcja protokołu Appletalk zabiera przy starcie systemu dosyć dużo czasu. Jeżeli badana sieć nie obsługuje tego protokołu, najlepiej wyłączyć wykrywanie protokołu Appletalk przy pomocy tej opcji.
    2. Duże czcionki w dekoderze protokołów (Big fonts in decoder) - Włączenie tej flagi spowoduje rysowanie zdekodowanych ramek w dekoderze protokołów przy pomocy większych czcionek.
  3. Parametry IP (IP parameters)
    1. Wyłączenie detekcji adresu IP (Override detection) - Jeżeli system błednie wykrywa adres IP stacji na której uruchamiamy ANASILa lub nie wykrywa go wcale, można podać explicite wartości adresu IP danej stacji, maski podsieci IP i domyślnej bramki (odpowiednio w polach IP Address, IP subnet mask oraz Def. gateway).
    2. Automatyczne odświeżanie adresów IP przy otwieraniu profili (Automatically refresh IP addresses opening profile) - W sieciach stosujących dynamiczny przydział adresów IP, włączenie tej opcji spowoduje odświeżenie informacji o adresach IP stacji zawartych w profilu za każdym razem kiedy będziemy ów profil otwierali (oraz przy starcie systemu).
    3. Włączenie zbierania informacji o odwołaniach de serwerów HTTP (Enable HTTP data collecting) - Flaga ta pozwala włączać i wyłączać zbieranie statystyk na temat odwołań do serwerów HTTP. Jeżeli statystyka ta jest niepotrzebna, można ją wyłączyć co da ANASIL'owi więcej czasu na inne analizy.
    4. Numer portu HTTP (HTTP port number) - numer portu używanego w sieci do transmisji protokołem HTTP. Jeżeli pole to ma wartość 0, system stara się wykryć numer tego portu automatycznie.
    5. Najwyższy numer portu TCP i UDP dla jakiego będą zbierane statystyki (Don't collect traffic data...) - Pola te zawierają najwyższy numer portu TCP i UDP dla jakiego będą zbierane statystyki.
    6. Włączenie zbierania informacji na temat transmisji pomiędzy adresami IP (Enable IP traffic matrix data collecting) - Włącza lub wyłącza tworzenie statystyki ruchu pomiędzy adresami IP.

Ustawienia wszystkich opcji są zapisywane w rejestrze systemowym (System Registry). Będą więc obowiązywać dopóki użytkownik ich nie zmieni.


Opcja "Exit" - wyjście z programu

Opcja ta powoduje zamknięcie programu ANASIL.


Menu "View"

an259.jpg (14167 bytes) Menu "View" zawiera opcje włączania lub wyłączania wizualizacji niektórych modułów programu (okien z komunikatami, toolbarów etc.). Znajdują się w nim następujące opcje:

  1. Wizualizacja pamięci podręcznych
    1. TCP/IP / ARP Cache
    2. IPX/SPX / SAP Lookup
    3. Appletalk / AARP Cache
    4. Appletalk / NBP Lookup
  2. Wizualizacja toolbarów
    1. Główny toolbar (Main toolbar)
    2. Toolbar konstruktora viewerów i form (Constructor toolbar)
    3. Toolbar operacji na pamięciach podręcznych (Cache toolbar)
    4. Toolbar operacji związanych z testami Point-to-point (Point-to-point toolbar)
  3. Włączenie/wyłączenie widoczności okna struktury drzewa sieci (Network structure tree)
  4. Włączenie/wyłączenie widoczności okna dziennika wydarzeń (Event log)
  5. Włączenie/wyłączenie widoczności okna komunikatów systemowych (System log)


Opcja "ARP cache" - okno bufora ARP

Wybranie tej opcji powoduje otwarcie okna wizualizującego stan pamięci podręcznej przechowującej przyporządkowanie pomiędzy adresami MAC stacji a ich adresami IP.

wpe4.jpg (15774 bytes)

W lewej kolumnie prezentowane są adresy MAC, w prawej zaś adresy IP. W toolbarze okna znajdują się dwa przyciski pełniące następujące funkcje:

wpe5.jpg (898 bytes) Powoduje opróżnienie pamięci podręcznej.

wpe6.jpg (856 bytes) Powoduje przepytanie całej podsieci i utworzenie nowego, aktualnego przyporządkowania.


Opcja "SAP lookup" - okno bufora protokołu SAP

Wybranie tej opcji powoduje otwarcie okna wizualizującego stan pamięci podręcznej przechowującej spis usług rozgłaszanych protokołem SAP (Service Advertisment Protocol).

wpe1.jpg (28811 bytes)

Okno to zawiera cztery kolumny:

  1. Nazwa usługi (Service name) - nazwa usługi w sieci.
  2. Typ usługi (Service type)
  3. Adres IPX (IPX Address) - adres komputera świadczącego usługę w formacie protokołu IPX (numer sieci : adres stacji : gniazdko)
  4. Liczba "skoków" do usługi (Hops) - liczba routerów jakie musi przejść pakiet żeby dostać się do serwera usługi.

W toolbarze okna znajdują się dwa przyciski pełniące następujące funkcje:

wpe5.jpg (898 bytes) Powoduje opróżnienie pamięci podręcznej.

wpe2.jpg (868 bytes) Powoduje wysłanie globalnego zapytania o usługi protokołem SAP.


Opcja "AARP cache" - okno bufora protokołu AARP

Wybranie tej opcji powoduje otwarcie okna wizualizującego stan pamięci podręcznej przechowującej przyporządkowanie pomiędzy adresami MAC stacji a ich adresami w sieci Appletalk.

wpe1.jpg (9831 bytes)

W lewej kolumnie prezentowane są adresy MAC, w prawej zaś adresy Appletalk. W toolbarze okna znajdują się dwa przyciski pełniące następujące funkcje:

wpe5.jpg (898 bytes) Powoduje opróżnienie pamięci podręcznej.

wpe6.jpg (856 bytes) Powoduje przepytanie całej podsieci i utworzenie nowego, aktualnego przyporządkowania.


Opcja "NBP lookup" - okno bufora protokołu NBP

Wybranie tej opcji powoduje otwarcie okna wizualizującego stan pamięci podręcznej przechowującej informacje o usługach w sieci Appletalk.

wpe2.jpg (9025 bytes)

Okno to zawiera cztery kolumny:

  1. Nazwa usługi (Object name) - nazwa usługi w sieci.
  2. Typ usługi (Object type)
  3. Zona w której znajduje się usługa (Object zone)
  4. Adres komputera świadczącego usługę (Address) - adres komputera świadczącego usługę w formacie protokołu Appletalk

W toolbarze okna znajdują się dwa przyciski pełniące następujące funkcje:

wpe5.jpg (898 bytes) Powoduje opróżnienie pamięci podręcznej.

wpe3.jpg (874 bytes) Powoduje przepytanie całej podsieci i utworzenie nowego, aktualnego przyporządkowania.


Opcja "Network structure tree" - widoczność okna struktury sieci

Opcja ta reguluje widoczność okna wizualizującego drzewo struktury sieci. Domyślnie, okno to jest otwierane po lewej stronie ekranu.


Opcja "Event log" - widoczność okna dziennika wydarzeń

Opcja ta reguluje widoczność okna zawierającego dziennik wydarzeń. Domyślnie okno to jest otwierane u dołu ekranu.


Opcja "System log" - widoczność okna z komunikatami systemowymi

Opcja ta reguluje widoczność okna zawierającego komunikaty systemowe. Domyślnie okno to jest otwierane u dołu ekranu.


Menu "Constructor" - opcje związane z tworzeniem viewerów i form

an260.jpg (24549 bytes) Menu "Constructor" zawiera opcje związane z tworzeniem viewerów i form wizualizujących statystyki zbierane przez program. Składa się ono z następujących opcji:

  1. Wybór viewerów otwieranych automatycznie podczas startu programu (Auto-Open viewers)
  2. Utworzenie nowego viewera (New viewer)
  3. Otwarcie viewera zapisanego na dysku (Open viewer)
  4. Ustawienie nazwy viewera (Set viewer name)
  5. Zachowanie zmian w viewerze pod poprzednią nazwą (Save viewer)
  6. Zachowanie formy jako szablonu (Save form as template)
  7. Zachowanie zmian w viewerze pod nową nazwą (Save viewer as...)
  8. Dodanie nowej formy do wybranego viewera (Add new form)
  9. Ustawienie nazwy formy (Set form name)
  10. Usunięcie aktywnej formy z viewera (Remove current form)
  11. Usunięcie wszystkich form (Remove all forms)


Opcja "Auto-open viewers"

Opcja "Auto-open viewers" służy do określenia, które viewery będą otwierane automatycznie przy starcie systemu. Wybranie tej opcji powoduje otwarcie następującego okna:

an279.jpg (34358 bytes)

Okno to zawiera listę viewerów otwieranych automatycznie (pliki viewerów mają rozszerzenie .anv). Kliknięcie na przycisk "Add" umożliwia dodanie do listy innego viewera. Przyciski "Remove" oraz "Remove all" służą odpowiednio do usuwania z listy zaznaczonego viewera lub wszystkich viewerów. Przycisk "Close" zamyka okno.


Opcja "New viewer" - tworzenie nowego viewera

Wybranie opcji "New viewer" powoduje otwarcie nowego, pustego viewera.

wpe1.jpg (9835 bytes)

Viewer ten posiada domyślnie jedną pustą formę, która z kolei zawiera jeden pusty element. Typ elementu można zmienić klikając na niego prawym klawiszem myszy. Otwiera się wtedy kontekstowe menu elementu, z którego należy wybrać opcję "Change element type".


Opcja "Open viewer" - załadowanie gotowego viewera

Opcja "Open viewer" umożliwia otwarcie viewera zachowanego uprzednio na dysku przy pomocy funkcji "Save viewer" lub "Save viewer as..". Po otwarciu viewera, układ okien jest automatycznie porządkowany przy pomocy funkcji "Layout windows".


Opcja "Set viewer name" - ustawianie nazwy viewera

Opcja "Set viewer name" pozwala ustawić nazwę okna zawierającego aktualnie wybrany viewer. Wybranie tej opcji powoduje otwarcie poniższego okna dialogowego:

an280.jpg (17353 bytes)

W polu edycyjnym należy wpisać nową nazwę viewera. Zmianę potwierdzamy przyciskiem "OK". Przycisk "Cancel" pozwala nam na wycofanie się z tej opcji. Zmiana tytułu okna viewera nastąpi po zamknięciu okna dialogowego.


Opcja "Save viewer" - zachowywanie viewera

Wybranie tej opcji powoduje zachowanie viewera na dysku pod poprzednią nazwą (jeżeli viewer był już na dysku zapisywany). Jeżeli viewer jest zapisywany po raz pierwszy - system zapyta się o nazwę pliku z viewerem.


Opcja "Save viewer as..." - zachowywanie viewera pod daną nazwą

Wybranie tej opcji powoduje zachowanie viewera na dysku pod nową nazwą. Po wybraniu tej opcji system zapyta się o nową nazwę pliku z viewerem.


Opcja "Save form as template" - zachowywanie formy jako szablonu

Opcja pozwala zachować aktywną formę aktywnego viewera w postaci szablonu formy. Opcja ta otwiera pod-menu zawierające następujące opcje:

  1. Station view - zachowuje formę jako szablon wizualizujący pojedynczą stację z tablicy statystyk stacji.
  2. Connection view - zachowuje formę jako szablon wizualizujący połączenie z tablicy statystyk połączeń.
  3. Protocol view - zachowuje formę jako szablon wizualizujący protokół sieciowy z tablicy statystyk protokołów.
  4. IP point-to-point view - zachowuje formę jako szablon wizualizujący pojedynczą testowaną stację z tablicy statystyk testów point-to-point dla protokołu IP.
  5. IPX point-to-point view - zachowuje formę jako szablon wizualizujący pojedynczą testowaną stację z tablicy statystyk testów point-to-point dla protokołu IPX.
  6. NetBEUI point-to-point view - zachowuje formę jako szablon wizualizujący pojedynczą testowaną stację z tablicy statystyk testów point-to-point dla protokołu NetBEUI.
  7. Appletalk point-to-point view - zachowuje formę jako szablon wizualizujący pojedynczą testowaną stację z tablicy statystyk testów point-to-point dla protokołu Appletalk.

UWAGA: Pozycje w tym pod-menu są zazwyczaj nieaktywne. Uaktywniają się tylko gdy aktywna forma zawiera tylko elementy wizualizujące statystyki z jednej tablicy statystyk (np. tylko parametry jednej ze stacji z tablicy statystyk stacji).


Opcja "Add new form" - dodawanie formy do viewera

Wybranie tej opcji powoduje dodanie nowej formy do aktywnego viewera.


Opcja "Set form name" - ustawianie nazwy formy

Opcja "Set form name" pozwala ustawić nazwę aktualnej zakładki (formy) wybranego viewera. Wybranie tej opcji powoduje otwarcie poniższego okna dialogowego:

an281.jpg (16548 bytes)

W polu edycyjnym należy wpisać nową nazwę zakładki (formy). Zmianę potwierdzamy przyciskiem "OK". Przycisk "Cancel" pozwala nam na wycofanie się z tej opcji. Zmiana nastąpi po zamknięciu okna dialogowego.


Opcja "Remove current form" - usuwanie formy

Wybranie tej opcji powoduje usunięcie aktywnej formy z aktywnego viewera. Usunięcie jest nieodwracalne.


Opcja "Remove all forms" - usuwanie wszystkich form

Wybranie tej opcji powoduje usunięcie wszystkich form z aktywnego viewera. Usunięcie jest nieodwracalne.


Kontekstowe menu elementów

wpe1.jpg (5967 bytes) Kliknięcie prawym klawiszem myszy na którykolwiek z elementów formy, powoduje otwarcie kontekstowego menu elementu (patrz po prawej stronie). Menu to zawiera opcje dotyczące konkretnego elementu:

  1. Wizualizacja aktualnego elementu tablicy przy pomocy szablonu (View row with template)
  2. Zmiana typu elementu (Change element type)
  3. Ustawienia elementu (Setup)
  4. Kopiuj zawartość elementu do schowka systemowego (Copy to Clipboard)
  5. Podziel element linią poziomą (Split horizontal)
  6. Podziel element linią pionową (Split vertical)
  7. Usuń element (Delete element)


Opcja "View row with template"

Opcja ta jest aktywna tylko w kontekstowym menu elementu typu tabela. Pozwala ona otworzyć szablon formy zawierający elementy wizualizujące aktualnie wybraną pozycję tabeli. Patrz też opcja "Save form as template".


Opcja "Change element type" - zmiana typu elementu

Opcja ta służy do zmiany typu wybranego elementu. Wybranie tej opcji powoduje otwarcie sub-menu zawierającego wszystkie obsługiwane przez program typy elementów. Są to:

  1. Pusty element (Empty)
  2. Tabela (Table)
  3. Tekst (Text)
  4. Wielokrotny tekst (Multiple Text)
  5. Histogram (Histogram)
  6. Wykres kołowy (Pie chart)
  7. Zagnieżdżona tabela (Sub table)

Zmiana typu elementu powoduje automatyczne otwarcie okna ustawiania opcji nowego elementu.


Opcja "Setup" - ustawianie opcji elementu

Opcja powoduje otwarcie okna ustawiania parametrów wybranego elementu. Zawartość okna jest zależna od typu elementu:

  1. Tabela (Table)
  2. Tekst (Text)
  3. Wielokrotny tekst (Multiple Text)
  4. Histogram (Histogram)
  5. Wykres kołowy (Pie chart)
  6. Zagnieżdżona tabela (Sub table)


Opcja "Copy to clipboard" - kopiowanie zawartości elementu do schowka

Opcja ta kopiuje do schowka systemowego aktualną zawartość elementu. W zależności od typu elementu, do schowka chowane są:

  1. Tabela (Table) - do schowka chowana jest zawartość tabeli w postaci tekstowej. Zawartości kolejnych kolumn tabeli oddzielane są znakami tabulacji. Pozycje tabeli są oddzielone znakami końca wiersza.
  2. Tekst (Text) - do schowka chowany jest tekst wizualizowany w elemencie (w postaci tekstowej).
  3. Wielokrotny tekst (Multiple Text) - do schowka chowane są nazwy statystyk i ich wartości oddzielone znakiem tabulacji (format tekstowy).
  4. Histogram (Histogram) - do schowka chowana jest z jednej strony mapa bitowa histogramu (format graficzny) a z drugiej zestaw wartości obrazowany przez histogram w formacie tekstowym.
  5. Wykres kołowy (Pie chart) - do schowka chowana jest z jednej strony mapa bitowa wykresu (format graficzny) a z drugiej zestaw wartości obrazowany przez wykres w formacie tekstowym.
  6. Zagnieżdżona tabela (Sub table) - do schowka chowana jest zawartość tabeli w postaci tekstowej. Zawartości kolejnych kolumn tabeli oddzielane są znakami tabulacji. Pozycje tabeli są oddzielone znakami końca wiersza.


Opcja "Split horizontal" - podział elementu linią poziomą

Opcja ta powoduje podzielenie elementu na dwa, linią poziomą w następujący sposób:

przed wybraniem opcji:

po wybraniu opcji

  wpe1.jpg (13767 bytes)
  wpe2.jpg (14954 bytes)

Wybranie tej opcji powoduje powstanie nowego, pustego elementu formy.


Opcja "Split vertical" - podział elementu linią pionową

Opcja ta powoduje podzielenie elementu na dwa, linią pionową w następujący sposób:

przed wybraniem opcji:

po wybraniu opcji

  wpe1.jpg (13767 bytes)
  wpe1.jpg (13677 bytes)

Wybranie tej opcji powoduje powstanie nowego, pustego elementu formy.


Opcja "Delete element" - usuwanie elementu

Wybranie tej opcji powoduje usunięcie z formy wybranego elementu.


Menu "Viewers"

an261.jpg (18256 bytes) Menu "Viewers" zawiera opcje związane z aktualnie otwartymi viewerami statystyk. Zawiera ono następujące opcje:

  1. Zamrażanie viewera (Freeze viewer)
  2. Odmrażanie viewera (Unfreeze viewer)
  3. Restart aktualnego viewera (Reset viewer)
  4. Eksport zawartości aktualnej formy do pliku tekstowego (Save form to TEXT file)
  5. Eksport zawartości aktualnej formy do pliku HTML (Save form to HTML file)
  6. Eksport zawartości aktualnego viewera do pliku tekstowego (Save viewer to TEXT file)
  7. Eksport zawartości aktualnego viewera do pliku HTML (Save viewer to HTML file)


Opcja "Freeze viewer" - zamrażanie statystyk

Wybranie tej opcji powoduje zamrożenie aktywnego viewera. Powoduje to zatrzymanie pracy viewera i zachowanie wartości wszystkich statystyk, które viewer wizualizował. Zatrzymany w ten sposób viewer może służyć później np. jako materiał do porównań. Zamrożony viewer można odmrozić opcją "Unfreeze viewer".


Opcja "Unfreeze viewer" - odmrażanie statystyk

Wybranie tej opcji powoduje odmrożenie zamrożonego uprzednio viewera. Patrz opcja: "Freeze viewer".


Opcja "Reset viewer" - restart viewera

Wybranie tej opcji powoduje restart aktywnego viewera. Podczas restartu przeprowadzane są następujące operacje:

  1. Wszystkie wartości średnie, maksymalne i minimalne są ustawiane w stan początkowy.
  2. Kasowana jest cała historia wartości we wszystkich elementach typu histogram.
  3. Zawartość elementów typu tabela jest ładowana na nowo.


Opcja "Save form to TEXT file"

Opcja ta służy do zachowania zawartości wszystkich elementów aktywnej formy w pliku tekstowym. Wybranie tej opcji powoduje otwarcie okna opcji eksportu do pliku tekstowego. Wyjście z tego okna przy pomocy przycisku "Export!" powoduje wykonanie eksportu wszystkich elementów formy.


Opcje eksportu do pliku TEXT

Okno to zawiera opcje eksportu zawartości elementów formy do pliku tekstowego.

an282.jpg (50993 bytes)

Okno to zawiera następujące opcje:

  1. Szablon eksportu (Template) - kliknięcie na przycisk "..." po prawej stronie pola pozwala wybrać jeden z szablonów eksportu.
  2. Nazwa pliku wyjściowego (Output) - kliknięcie na przycisk "..." po prawej stronie pola pozwala wybrać nazwę oraz katalog pliku, do którego wykonywany będzie eksport.

Szablony eksportu pozwalają na podanie do pliku wyjściowego następujących parametrów:

  1. Tytuł eksportu (Title)
  2. Nazwa sieci (Network)
  3. Autor eksportu (Author)
  4. Data i czas początku działania eksportowanej formy/viewera (Started)
  5. Data i czas końca działania eksportowanej formy/viewera (Finished)
  6. Komentarz (Remarks)

Podane w tym oknie wartości parametrów zostaną użyte w pliku wyjściowym po wybraniu przycisku "Export!".


Opcja "Save form to HTML file"

Opcja ta służy do zachowania zawartości wszystkich elementów aktywnej formy w pliku o formacie HTML. Wybranie tej opcji powoduje otwarcie okna opcji eksportu do pliku HTML. Wyjście z tego okna przy pomocy przycisku "Export!" powoduje wykonanie eksportu wszystkich elementów formy.


Opcje eksportu do HTML

Okno to zawiera opcje eksportu zawartości elementów formy do pliku HTML.

an283.jpg (74574 bytes)

Okno to zawiera następujące opcje:

  1. Szablon eksportu (Template) - kliknięcie na przycisk "..." po prawej stronie pola pozwala wybrać jeden z szablonów eksportu.
  2. Nazwa pliku wyjściowego (Output) - kliknięcie na przycisk "..." po prawej stronie pola pozwala wybrać nazwę oraz katalog pliku, do którego wykonywany będzie eksport.
  3. Sposób eksportu plików graficznych (Store pictures in the same directory as output / In other directory) - domyślnie, pliki graficzne (zawierające mapy bitowe histogramów obecnych w formie/viewerze) są eksportowane do tego samego katalogu co plik wyjściowy. Wybranie opcji "In other directory" pozwala wprowadzić nazwę innego katalogu.
  4. Usuwanie plików apic*.jpg przed eksportem (Delete apic*.jpg before export) - pliki graficzne są eksportowane do plików o nazwach apic<numer>.jpg. Zaznaczenie tej flagi powoduje usunięcie wszystkich plików o takich nazwach z katalogu eksportu, przed wykonaniem eksportu.
  5. Jakość grafiki (JPEG quality) - pliki graficzne są zapisywane w formacie JPEG. Kompresja używana w tym formacie powoduje spadek jakości grafiki. Opcja ta pozwala na podanie żądanego współczynnika jakości (1-najgorsza jakość/najlepsza kompresja, 100-najlepsza jakość/najgorsza kompresja).
  6. Czy generować grafikę czarno/białą (Generate grayscale pictures) - zaznaczenie tej flagi spowoduje, że pliki graficzne będą generowane w odcieniach szarości zamiast w kolorze.
  7. Rozmiar generowanych grafik (Form base width/height)

Szablony eksportu pozwalają na podanie do pliku wyjściowego następujących parametrów:

  1. Tytuł eksportu (Title)
  2. Nazwa sieci (Network)
  3. Autor eksportu (Author)
  4. Data i czas początku działania eksportowanej formy/viewera (Started)
  5. Data i czas końca działania eksportowanej formy/viewera (Finished)
  6. Komentarz (Remarks)

Podane w tym oknie wartości parametrów zostaną użyte w pliku wyjściowym po wybraniu przycisku "Export!".


Opcja "Save viewer to TEXT file"

Opcja ta służy do zachowania zawartości wszystkich elementów wszystkich form, aktywnego viewera w pliku tekstowym. Wybranie tej opcji powoduje otwarcie okna opcji eksportu do pliku tekstowego. Wyjście z tego okna przy pomocy przycisku "Export!" powoduje wykonanie eksportu wszystkich elementów viewera.


Opcja "Save viewer to HTML file"

Opcja ta służy do zachowania zawartości wszystkich elementów wszystkich form, aktywnego viewera w pliku HTML. Wybranie tej opcji powoduje otwarcie okna opcji eksportu do pliku HTML. Wyjście z tego okna przy pomocy przycisku "Export!" powoduje wykonanie eksportu wszystkich elementów viewera.


Menu "Filtering" - opcje globalnego filtra

an262.jpg (8785 bytes) Menu "Filtering" zawiera opcje dotyczące tzw. globalnego filtra. Jest to filtr przez który przepuszczane są wszystkie analizowane ramki. Ramki, które spełniły warunek filtra oraz ramki, które go nie spełniły są zliczane i dostępne w bazie statystyk. W menu znajdują się następujące opcje:

  1. Ustawienie globalnego filtra (Set up global filter)
  2. Ustawienie globalnego filtra na filtr pusty (Reset global filter)
  3. Włączenie/wyłączenie filtrowania (Enable global filter)


Opcja "Set up global filter" - ustawienie globalnego filtra

Opcja ta pozwala na ustawienie warunków globalnego filtra. Wybranie tej opcji powoduje otwarcie okna edycji filtra. Wyjście z edycji za pomocą przycisku "OK" powoduje automatyczne włączenie filtrowania.


Edycja filtra

Wejście do edycji filtra powoduje otwarcie się następującego okna:

an284.jpg (43461 bytes)

Okno to umożliwia wybór rodzaju edytowanego filtra:

  1. Filtra prostego (Simple filter)
    Jest to prosty filtr pozwalający nałożyć warunki na adres pochodzenia (Source Address) i przeznaczenia (Destination Address) ramki, rodzaj protokołu/podprotokołu oraz kombinację bajtów w ramce. Kliknięcie na przycisk "Edit" otwiera okno edycji filtra prostego.
  2. Filtra zaawansowanego (Advanced filter)
    Filtr zaawansowany składa się z jednego do trzech filtrów prostych połączonych warunkami logicznymi. Kliknięcie na przycisk "Edit" otwiera okno edycji filtra zaawansowanego.
  3. Filtra zachowanego (Predefined filter)
    Filtr zachowany jest filtrem prostym lub zaawansowanym, który został przez użytkownika zachowany na dysku (bo np. jest często używany). Lista znajdująca się poniżej zawiera spis filtrów zdefiniowanych przez użytkownika. Przycisk "Manage" powoduje przejście do okna Menedżera filtrów zachowanych. Okno to umożliwia tworzenie, edycję oraz kasowanie filtrów zachowanych.

Wciśnięcie przycisku "Reset filter" powoduje skasowanie aktualnie wprowadzonego filtra.


Edycja filtra prostego

Okno poniższe pozwala na edycję prostego filtra:

an285.jpg (88529 bytes)

Zawiera ono następujące opcje:

  1. Przepuść wszystkie ramki (All frames) - włączenie tej flagi powoduje, że filtr będzie przepuszczał wszystkie ramki (wszystkie ramki będą spełniały warunek filtra). Flaga ta ma zastosowanie przy budowaniu filtra zaawansowanego o warunku "przepuść wszystkie ramki z wyjątkiem...".
  2. Adres źródłowy (Source) - pozwala na nałożenie warunku na adres źródłowy ramki. Wybranie stacji np. APC powoduje, że warunek filtra będą spełniać tylko ramki wysyłane przez stację APC.
  3. Adres docelowy (Destination) - pozwala na nałożenie warunku na adres docelowy ramki. Wybranie stacji np. PENTIUM powoduje, że warunek filtra będą spełniać tylko ramki kierowane do stacji PENTIUM.
  4. Przepuść wszystkie ramki pomiędzy tymi stacjami (Between source and destination) - włączenie tej flagi powoduje, że warunek filtra będą spełniać wszystkie ramki przesyłane pomiędzy stacją wymienioną w warunku "Source" a stacją wymienioną w warunku "Destination". W naszym przykładzie będą to ramki wysłane ze stacji APC do stacji PENTIUM oraz ramki wysłane ze stacji PENTIUM do stacji APC.
  5. Filtruj ze względu na protokół sieciowy (Network protocol) - włączenie tej flagi umożliwia nałozenie warunku na protokół sieciowy. Warunek filtra będą spełniać tylko ramki przesyłane w ramach wybranego protokołu.
  6. Filtruj ze względu na pod-protokół sieciowy (Sub-protocol) - włączenie tej flagi umożliwia nałozenie warunku na pod-protokół sieciowy. Warunek filtra będą spełniać tylko ramki przesyłane w ramach wybranego protokołu i pod-protokołu.
  7. Filtruj ze względu na port (Port) - włączenie tej flagi umożliwia nałożenie warunku na port sieciowy (w tych podprotokołach w których występuje takie pojęcie).
  8. Filtruj ze względu na zawartość ramki (Frame contains) - ten zestaw opcji pozwala na nałożenie warunku na zawartość ramki. W polu edycyjnym należy wpisać ciąg bajtów, które ramka powinna zawierać. Ciąg bajtów można podać w następujących formatach:
    1. W formacie heksadecymalnym - ciąg cyfr heksadecymalnych można podać poprzedzając go znakami "0x" (np. 0xA1B2C3 lub 0x12 0x13 0x14)
    2. W formacie dziesiętnym - można podać liczbę z zakresu 0-255
    3. W formacie znakowym - można podać pojedynczy znak pomiędzy znakami apostrofu (np. 'A') lub cały łańcuch pomiędzy znakami cudzysłowu (np. "ALA").
  9. Pozycja w ramce (at offset) - w polu tym podać należy pozycję od której w ramce powinien zaczynać się powyższy ciąg bajtów. Pozycja jest liczona w bajtach od końca nagłówka warstwy liniowej (pierwszy bajt nagłówka protokołu sieciowego ma pozycję (offset) 0). Przy wyborze pozycji można również skorzystać z listy pozycji zawierającej offsety kilku bardziej popularnych pól w nagłówkach różnych protokołów. Lista ta jest zdefiniowana w pliku offsets.ini.
  10. Warunki - do pojedynczego warunku można dodać jeden lub dwa dodatkowe warunki i połączyć je koniunkcją ("AND") lub alternatywą ("OR").

Wybranie przycisku "OK" powoduje zakończenie edycji i zaakceptowanie zmian.


Edycja filtra zaawansowanego

Okno edycji filtra zaawansowanego przedstawia się następująco:

an286.jpg (74839 bytes)

Okno to pozwala zdefiniować do czterech filtrów prostych i połączyć je warunkami logicznymi. Kliknięcie na odpowiedni przycisk "Define" powoduje przejście do edycji jednego z nich. Dostępnymi warunkami logicznymi są:

  • Koniunkcja (AND) - jest spełniona tylko gdy warunki obu filtrów prostych są spełnione
  • Alternatywa (OR) - jest spełniona gdy jeden z warunków filtrów prostych jest spełniony
  • Zanegowana koniunkcja (AND NOT) - jest spełniona gdy warunek filtru pierwszego jest spełniony a warunek filtra drugiego nie jest spełniony. Przy pomocy tego warunku logicznego oraz flagi "All frames" w filtrze prostym można zbudować warunek "wszystkie ramki z wyjątkiem...".

Okno to zawiera również pole, w którym można wprowadzić mnemoniczna Nazwę filtra (Name) oraz flagę (This filter is persistant and will be saved) dzięki której można zachować filtr na dysku do późniejszego użycia.


Menedżer filtrów zachowanych

Filtrami zachowanymi można zarządzać przy pomocy następującego okna:

an287.jpg (35329 bytes)

U góry okna znajduje się lista wszystkich filtrów zachowanych. Kliknięcie na przycisk "New filter" powoduje utworzenie nowego filtra i przejście do jego edycji. Przycisk "Edit filter" powoduje przejście do edycji zaznaczonego w liście filtra. Przycisk "Delete" powoduje skasowanie zaznaczonego filtra.


Opcja "Reset global filter" - zdejmowanie globalnego filtra

Wybranie tej opcji powoduje ustawienie filtra pustego jako aktualnego filtra globalnego.


Opcja "Enable global filtering" - włączanie/wyłączanie globalnego filtra

Opcja ta pozwala na włączanie/wyłączanie globalnego filtrowania ramek. Jest aktywna tylko gdy ustawiono już jakiś filtr przy pomocy opcji "Set up global filter".


Menu "Capture" - opcje przechwytywania i dekodowania ramek

an263.jpg (15258 bytes) Menu "Capture" zawiera opcje dotyczące przechwytywania i dekodowania ramek. W jego skład wchodzą następujące opcje:

  1. Wyczyść bufor dekodowania (Clear capture buffer)
  2. Załaduj bufor dekodowania z pliku (Load capture buffer from file)
  3. Pokaż bufor dekodowania (View capture buffer)
  4. Skompiluj dekoder (Recompile decoder)
  5. Pokaż panel sterowania przechwytywaniem ramek (View capture toolbox)


Opcja "Clear capture buffer" - usunięcie przechwyconych ramek z bufora

Wybranie tej opcji powoduje opróżnienie bufora dekodowania. Wszystkie przechwycone ramki zostaną z niego usunięte.


Opcja "Load capture buffer from file"

ANASIL umożliwia zachowanie przechwyconych ramek w pliku. Opcja "Load capture buffer from file" pozwala załadować przechwycone ramki z dysku (np. do ponownej analizy). Wybranie tej opcji otwiera okno dekodera protokołów i pozwala wybrać plik z zachowanymi ramkami.


Opcja "View capture buffer"

Wybranie tej opcji powoduje otwarcie okna dekodera protokołów. W oknie tym wizualizowana jest aktualna zawartość bufora dekodowania.

an289.jpg (214429 bytes)

Okno to dzieli się na trzy części:

  1. Toolbar
    W toolbarze okna znajduje się pięć przycisków odpowiadających następującym funkcjom:
    1. Załaduj bufor dekodowania z dysku (Loads capture buffer from disk) - opcja ta powoduje wyczyszczenie bufora i załadowanie nowej zawartości z pliku utworzonego uprzednio opcją nr 2.
    2. Zachowaj zawartość bufora dekodowania na dysku (Saves capture buffer to disk) - opcja ta zachowuje zawartość bufora w pliku na dysku.
    3. Zachowaj zawartość bufora dekodowania na dysku w pliku tekstowym (Exports capture buffer to TXT file) - opcja ta zachowuje zawartość bufora w postaci zdekodowanej w pliku tekstowym.
    4. Włącz/wyłącz filtrowanie zawartości bufora dekodowania (Enable/disable capture buffer filter) - zawartość bufora można filtrować przy pomocy mechanizmu filtrów. Przycisk ten powoduje włączenie lub wyłączenie filtrowania zawartości bufora filtrem ustawianym w opcji nr 5. Po prawej stronie toolbara pojawiają się informacje o zastosowanym filtrze oraz o tym ile ramek spełniło warunki filtra.
    5. Tworzenie filtra do filtrowania zawartości bufora dekodowania (Capture buffer filter setup) - opcja ta powoduje przejście do edycji filtra używanego w opcji nr. 4.
    6. Przełącznik wyświetlania w postaci zdekodowanej/binarnej - włączenie tego przycisku powoduje, że ramki będą wyświetlane domyślnie w trybie binarnym.
  2. Okno zawartości bufora dekodowania
    W tej części okna wizualizowana jest zawartość bufora dekodowania. Zawartość jest przedstawiana w postaci tabeli z ośmioma kolumnami. Ikona po lewej stronie każdej pozycji tabeli identyfikuje, czy dana ramka została wysłana w trybie rozgłaszania (broadcast) - pełne niebieskie kółko, w trybie ograniczonego rozgłaszania (multicast) -niepełne niebieskie kółko, czy w trybie skierowanym (directed) - kółko ze strzałką w środku.
    1. Numer ramki w buforze (No.)
    2. Adres pochodzenia ramki (Source address) - jeżeli stacja, która wysłała ramkę jest zdefiniowana w aktywnym profilu sieci, zamiast adresu MAC wyprowadzana jest jej nazwa mnemoniczna. Adres MAC oraz komentarz (zdefiniowany w profilu) można zobaczyć jeżeli przez chwilę zatrzyma się kursor nad nazwą stacji.
    3. Adres przeznaczenia ramki (Destination address) - jeżeli stacja, do której adresowana jest ramka jest zdefiniowana w aktywnym profilu sieci, zamiast adresu MAC wyprowadzana jest jej nazwa mnemoniczna. Adres MAC oraz komentarz (zdefiniowany w profilu) można zobaczyć jeżeli przez chwilę zatrzyma się kursor nad nazwą stacji.
    4. Czas przechwycenia ramki (Time) - czas (w sekundach) jaki upłynął od chwili rozpoczęcia przechwytywania do momentu złapania ramki.
    5. Odstęp od poprzedniej ramki (Delta) - różnica pomiędzy czasem przechwycenia danej ramki a czasem przechwycenia ramki poprzedniej.
    6. Wielkość ramki w bajtach (Size)
    7. Protokół (Protocol) - nazwa protokołu sieciowego w ramach którego wysłano ramkę.
    8. Ścieżka dekodowania (Decode info) - informacja o stosie protokołów zawartym wewnątrz ramki.
  3. Okno zdekodowanej ramki
    W tej części okna wizualizowana jest ramka, wybrana w oknie bufora dekodowania. W ramce wyodrębnione są poszczególne warstwy, odpowiadające nagłówkom poszczególnych protokołów. Kliknięcie na warstwę powoduje przełączenie jej wizualizacji z trybu dekodowania w tryb binarny. W trybie binarnym warstwa ramki jest wizualizowana jako ciąg liczb heksadecymalnych.


Opcja "Recompile decoder"

Dekoder protokołów w ANASILu jest programowalny. Został napisany w specjalnym języku opisu protokołów a jego kody źródłowe znajdują się w podkatalogu DECODER. Żeby przyspieszyć ładowanie się programu oraz wykonywanie procesu dekodowania, program dekodowania przed użyciem jest kompilowany do postaci binarnej. Plikiem wynikowym tego procesu, używanym przez ANASILa do dekodowania ramek jest plik DECODER\decoder.bin.

Jeżeli użytkownik zmodyfikuje program dekodowania (np. dodając do niego własne protokoły), musi wywołać opcję "Recompile decoder", aby wymusić przekompilowanie go i utworzenie nowej kopii pliku DECODER\decoder.bin. Przebieg kompilacji i ewentualne komunikaty o błędach wyświetlane są w oknie komunikatów systemowych.


Opcja "View capture toolbox"

Wybranie opcji "View capture toolbox" powoduje otwarcie okna, za pomocą którego można kontrolować przebieg przechwytywania ramek do bufora dekodowania oraz ustawiać parametry tego procesu.

an288.jpg (54218 bytes)

W górnej części okna wizualizowane jest aktualne wypełnienie bufora dekodowania. Oprócz tego znajdują się tam cztery przyciski sterujące procesem dekodowania:

  1. Start (Start) - włącza przechwytywanie ramek
  2. Stop (Stop) - wyłącza przechwytywanie ramek
  3. Pokaż bufor dekodowania (View buffer) - otwiera okno dekodera protokołów wizualizujące przechwycone ramki.
  4. Wyczyść bufor dekodowania (Clear buffer) - wymazuje zawartość bufora dekodowania.

Podczas łapania ramek, ANASIL może je filtrować i zapisywać w buforze tylko te, które spełniają warunek filtra. Ponadto możliwe jest automatyczne uruchomienie lub zakończenie procesu przechwytywania po odebraniu pierwszej ramki spełniającej dany warunek (Start trigger/Stop trigger). Informacje o aktualnie ustawionych filtrach (Filter/Start trigger/Stop trigger) oraz o statusie przechwytywania ramek (Status) są wyświetlane w dolnej części okna. Oprócz tego znajduje się tam przycisk "Options, filters & triggers", którego naciśnięcie powoduje otwarcie okna opcji przechwytywania ramek.

W nagłówku okna wyświetlana jest liczba ramek, które zostały poddane filtrowaniu i liczba ramek, które spełniły warunek filtra.


Opcje łapania ramek

Okno poniższe pozwala ustawić opcje dotyczące procesu przechwytywania ramek do bufora dekodowania:

wpe1.jpg (21011 bytes)

Okno to pozwala ustawić następujące parametry:

  1. Rozmiar bufora (Buffer size) - rozmiar bufora podajemy w ramkach.
  2. Czy bufor ma być cykliczny (Wrap buffer on overflow) - jeżeli ta flaga jest włączona, bufor po przepełnieniu będzie wypełniany od początku.
  3. Czy włączyć filtrowanie ramek podczas przechwytywania (Enable filtering) - jeżeli nałożymy filtr, do bufora będą zapisywane tylko ramki spełniające warunki filtra. Warunki filtra można ustawić klikając na przycisk "Select filter".
  4. Czy automatycznie rozpoczynać przechwytywanie ramek po napotkaniu pierwszej ramki spełniającej warunki filtra (Enable triggering/Start on) - warunki filtra można ustawić klikając na przycisk "Select filter".
  5. Czy automatycznie kończyć przechwytywanie ramek po napotkaniu pierwszej ramki spełniającej warunki filtra (Enable triggering/Stop on) - warunki filtra można ustawić klikając na przycisk "Select filter".


Menu "Point-to-point"

an264.jpg (16276 bytes) Menu "Point-to-point" zawiera opcje dotyczące testów "Point-to-point". Zawiera ono następujące opcje:

  1. Wybór stacji testowanych protokołem IP (ICMP) (IP (ICMP) Setup)
  2. Wybór stacji testowanych protokołem IPX (IPX Setup)
  3. Wybór stacji testowanych protokołem NetBEUI (NetBEUI Setup)
  4. Wybór stacji testowanych protokołem Appletalk (AEP) (Appletalk (AEP) Setup)
  5. Start/Stop testów protokołem IP (Run IP tests)
  6. Start/Stop testów protokołem IPX (Run IPX tests)
  7. Start/Stop testów protokołem NetBEUI (Run NetBEUI tests)
  8. Start/Stop testów protokołem Appletalk (Run Appletalk tests)


Opcja "IP Setup"

Okno poniższe służy do wyboru stacji badanych w testach point-to-point oraz do ustawiania parametrów tych testów.

wpe1.jpg (24143 bytes)

W górnej części okna znajdują się opcje regulujące prędkość testowania:

  1. Maksymalna prędkość (Full speed test) - włączenie tej flagi powoduje, że program wysyła ramki do testowanych stacji z maksymalną prędkością (wysyłanych jest tyle ramek ile się da).
  2. Wysyłaj jedną ramkę na N milisekund (Send only one frame per...) - włączenie tej flagi powoduje, że program będzie wysyłał najwyżej jedną ramkę na podaną liczbę milisekund. Zmniejsza to wpływ testowania na ogólną wydajność całej podsieci (obciążenie wnoszone przez testowanie jest rozkładane w czasie).

W dolnej części okna znajduje się lista testowanych stacji oraz następujące opcje:

  1. Nazwa mnemoniczna testowanej stacji (Station name) - w polu tym można wpisać nazwę mnemoniczną stacji, która będzie identyfikowała ją w testach point-to-point. Dołączona do pola lista zawiera stacje zdefiniowane w profilu. W momencie wyboru stacji z listy, w polu adresu IP pojawia się adres przypisany wybranej stacji w profilu.
  2. Adres IP lub nazwa DNS (Enter IP address or DNS name) - w polu tym wpisujemy adres IP lub nazwę w serwisie DNS stacji przeznaczonej do testowania. Jeżeli wpiszemy nazwę DNS, możemy użyć przycisku "Resolve" do jej zamiany na adres IP.
  3. Zamień nazwę DNS na adres IP (Resolve) - naciśnięcie tego przycisku powoduje odwołanie się programu do serwisu DNS i zamianę nazwy DNS wpisanej w polu "Adres IP lub nazwa DNS" na adres IP.
  4. Timeout (Timeout value) - w polu tym należy wpisać liczbę milisekund, jaką program będzie czekał na odpowiedź od danej stacji. Po przekroczeniu tego czasu, wysłana ramka zostanie uznana za straconą (stacja nie odpowiedziała).
  5. Dodaj stację do listy (Add station) - naciśnięcie tego przycisku powoduje dodanie stacji opisanej w powyższych polach do listy stacji.
  6. Zmień parametry zaznaczonej stacji (Change) - naciśnięcie tego przycisku powoduje zmianę parametrów stacji zaznaczonej w liście na opisane w powyższych polach.
  7. Załaduj listę stacji z dysku (Load) - przycisk ten umożliwia załadowanie listy stacji z dysku
  8. Schowaj listę stacji na dysk (Save) - przycisk ten umożliwia zachowanie aktualnej listy stacji na dysku do poźniejszego wykorzystania.
  9. Usuń zaznaczoną stację z listy (Remove) - naciśnięcie tego przycisku usuwa z listy aktualnie zaznaczoną stację.
  10. Usuń wszystkie stacje z listy (Remove all) - naciśnięcie tego przycisku usuwa wszystkie stacje z listy.

Wciśnięcie przycisku "OK" powoduje zaakceptowanie zmian i zamknięcie okna.


Opcja "IPX Setup"

Okno poniższe służy do wyboru stacji badanych w testach point-to-point oraz do ustawiania parametrów tych testów.

wpe1.jpg (24922 bytes)

W górnej części okna znajdują się opcje regulujące prędkość testowania:

  1. Maksymalna prędkość (Full speed test) - włączenie tej flagi powoduje, że program wysyła ramki do testowanych stacji z maksymalną prędkością (wysyłanych jest tyle ramek ile się da).
  2. Wysyłaj jedną ramkę na N milisekund (Send only one frame per...) - włączenie tej flagi powoduje, że program będzie wysyłał najwyżej jedną ramkę na podaną liczbę milisekund. Zmniejsza to wpływ testowania na ogólną wydajność całej podsieci (obciążenie wnoszone przez testowanie jest rozkładane w czasie).

W dolnej części okna znajduje się lista testowanych stacji oraz następujące opcje:

  1. Nazwa mnemoniczna testowanej stacji (Station name) - w polu tym można wpisać nazwę mnemoniczną stacji, która będzie identyfikowała ją w testach point-to-point. Dołączona do pola lista zawiera stacje zdefiniowane w profilu. W momencie wyboru stacji z listy, w polu adresu IPX pojawia się adres przypisany wybranej stacji.
  2. Adres IPX (Enter IPX address) - w polu tym wpisujemy adres IPX (w formacie nr_sieci.nr_stacji).
  3. Timeout (Timeout value) - w polu tym należy wpisać liczbę milisekund, jaką program będzie czekał na odpowiedź od danej stacji. Po przekroczeniu tego czasu, wysłana ramka zostanie uznana za straconą (stacja nie odpowiedziała).
  4. Dodaj stację do listy (Add station) - naciśnięcie tego przycisku powoduje dodanie stacji opisanej w powyższych polach do listy stacji.
  5. Zmień parametry zaznaczonej stacji (Change) - naciśnięcie tego przycisku powoduje zmianę parametrów stacji zaznaczonej w liście na opisane w powyższych polach.
  6. Załaduj listę stacji z dysku (Load) - przycisk ten umożliwia załadowanie listy stacji z dysku
  7. Schowaj listę stacji na dysk (Save) - przycisk ten umożliwia zachowanie aktualnej listy stacji na dysku do poźniejszego wykorzystania.
  8. Usuń zaznaczoną stację z listy (Remove) - naciśnięcie tego przycisku usuwa z listy aktualnie zaznaczoną stację.
  9. Usuń wszystkie stacje z listy (Remove all) - naciśnięcie tego przycisku usuwa wszystkie stacje z listy.

Wciśnięcie przycisku "OK" powoduje zaakceptowanie zmian i zamknięcie okna.


Opcja "NetBEUI Setup"

Okno poniższe służy do wyboru stacji badanych w testach point-to-point oraz do ustawiania parametrów tych testów.

wpe1.jpg (24397 bytes)

W górnej części okna znajdują się opcje regulujące prędkość testowania:

  1. Maksymalna prędkość (Full speed test) - włączenie tej flagi powoduje, że program wysyła ramki do testowanych stacji z maksymalną prędkością (wysyłanych jest tyle ramek ile się da).
  2. Wysyłaj jedną ramkę na N milisekund (Send only one frame per...) - włączenie tej flagi powoduje, że program będzie wysyłał najwyżej jedną ramkę na podaną liczbę milisekund. Zmniejsza to wpływ testowania na ogólną wydajność całej podsieci (obciążenie wnoszone przez testowanie jest rozkładane w czasie).

W dolnej części okna znajduje się lista testowanych stacji oraz następujące opcje:

  1. Nazwa mnemoniczna testowanej stacji (Station name) - w polu tym można wpisać nazwę mnemoniczną stacji, która będzie identyfikowała ją w testach point-to-point. Dołączona do pola lista zawiera stacje zdefiniowane w profilu. W momencie wyboru stacji z listy, w polu adresu pojawia się adres przypisany wybranej stacji w profilu.
  2. Adres MAC lub nazwa NetBEUI (Enter NetBEUI name) - w polu tym wpisujemy adres MAC lub nazwę NetBEUI (NetBIOS) stacji przeznaczonej do testowania.
  3. Timeout (Timeout value) - w polu tym należy wpisać liczbę milisekund, jaką program będzie czekał na odpowiedź od danej stacji. Po przekroczeniu tego czasu, wysłana ramka zostanie uznana za straconą (stacja nie odpowiedziała).
  4. Dodaj stację do listy (Add station) - naciśnięcie tego przycisku powoduje dodanie stacji opisanej w powyższych polach do listy stacji.
  5. Zmień parametry zaznaczonej stacji (Change) - naciśnięcie tego przycisku powoduje zmianę parametrów stacji zaznaczonej w liście na opisane w powyższych polach.
  6. Załaduj listę stacji z dysku (Load) - przycisk ten umożliwia załadowanie listy stacji z dysku
  7. Schowaj listę stacji na dysk (Save) - przycisk ten umożliwia zachowanie aktualnej listy stacji na dysku do poźniejszego wykorzystania.
  8. Usuń zaznaczoną stację z listy (Remove) - naciśnięcie tego przycisku usuwa z listy aktualnie zaznaczoną stację.
  9. Usuń wszystkie stacje z listy (Remove all) - naciśnięcie tego przycisku usuwa wszystkie stacje z listy.

Wciśnięcie przycisku "OK" powoduje zaakceptowanie zmian i zamknięcie okna.


Opcja "Appletalk Setup"

Okno poniższe służy do wyboru stacji badanych w testach point-to-point oraz do ustawiania parametrów tych testów.

wpe1.jpg (24044 bytes)

W górnej części okna znajdują się opcje regulujące prędkość testowania:

  1. Maksymalna prędkość (Full speed test) - włączenie tej flagi powoduje, że program wysyła ramki do testowanych stacji z maksymalną prędkością (wysyłanych jest tyle ramek ile się da).
  2. Wysyłaj jedną ramkę na N milisekund (Send only one frame per...) - włączenie tej flagi powoduje, że program będzie wysyłał najwyżej jedną ramkę na podaną liczbę milisekund. Zmniejsza to wpływ testowania na ogólną wydajność całej podsieci (obciążenie wnoszone przez testowanie jest rozkładane w czasie).

W dolnej części okna znajduje się lista testowanych stacji oraz następujące opcje:

  1. Nazwa mnemoniczna testowanej stacji (Station name) - w polu tym można wpisać nazwę mnemoniczną stacji, która będzie identyfikowała ją w testach point-to-point. Dołączona do pola lista zawiera stacje zdefiniowane w profilu. W momencie wyboru stacji z listy, w polu adresu Appletalk pojawia się adres przypisany wybranej stacji.
  2. Adres Appletalk lub nazwa NBP (Enter Appletalk address or NBP name) - w polu tym wpisujemy adres Appletalk (w formacie nr_sieci.nr_stacji) lub nazwę w serwisie NBP stacji przeznaczonej do testowania. Jeżeli wpiszemy nazwę NBP, możemy użyć przycisku "Resolve" do jej zamiany na adres Appletalk.
  3. Zamień nazwę NBP na adres Appletalk (Resolve) - naciśnięcie tego przycisku powoduje odwołanie się programu do serwisu NBP i zamianę nazwy NBP wpisanej w polu "Adres Appletalk lub nazwa NBP" na adres Appletalk.
  4. Timeout (Timeout value) - w polu tym należy wpisać liczbę milisekund, jaką program będzie czekał na odpowiedź od danej stacji. Po przekroczeniu tego czasu, wysłana ramka zostanie uznana za straconą (stacja nie odpowiedziała).
  5. Dodaj stację do listy (Add station) - naciśnięcie tego przycisku powoduje dodanie stacji opisanej w powyższych polach do listy stacji.
  6. Zmień parametry zaznaczonej stacji (Change) - naciśnięcie tego przycisku powoduje zmianę parametrów stacji zaznaczonej w liście na opisane w powyższych polach.
  7. Załaduj listę stacji z dysku (Load) - przycisk ten umożliwia załadowanie listy stacji z dysku
  8. Schowaj listę stacji na dysk (Save) - przycisk ten umożliwia zachowanie aktualnej listy stacji na dysku do poźniejszego wykorzystania.
  9. Usuń zaznaczoną stację z listy (Remove) - naciśnięcie tego przycisku usuwa z listy aktualnie zaznaczoną stację.
  10. Usuń wszystkie stacje z listy (Remove all) - naciśnięcie tego przycisku usuwa wszystkie stacje z listy.

Wciśnięcie przycisku "OK" powoduje zaakceptowanie zmian i zamknięcie okna.


Opcja "Run IP (ICMP) tests"

Opcja ta powoduje włączenie/wyłączenie testowania wybranych (przy pomocy opcji "IP Setup") stacji przy pomocy protokołu IP.


Opcja "Run IPX tests"

Opcja ta powoduje włączenie/wyłączenie testowania wybranych (przy pomocy opcji "IPX Setup") stacji przy pomocy protokołu IPX.


Opcja "Run NetBEUI tests"

Opcja ta powoduje włączenie/wyłączenie testowania wybranych (przy pomocy opcji "NetBEUI Setup") stacji przy pomocy protokołu NetBEUI.


Opcja "Run Appletalk tests"

Opcja ta powoduje włączenie/wyłączenie testowania wybranych (przy pomocy opcji "Appletalk Setup") stacji przy pomocy protokołu Appletalk.


Menu "Analyzer"

an265.jpg (21014 bytes) Menu "Analyzer" zawiera opcje związane z przebiegającą na bieżąco analizą wszystkich ramek w sieci. Są to opcje:

  1. Wstrzymaj analizy (Suspend analysis)
  2. Podejmij analizy na nowo (Resume analysis)
  3. Przepytanie całej podsieci protokołem ARP (ARP subnet query)
  4. Przepytanie całej podsieci protokołem AARP (AARP subnet query)
  5. Wysłanie globalnego zapytania protokołem SAP (SAP query)
  6. Wysłanie zapytania do aktualnej zony protokołem NBP (NBP zone query)
  7. Opróżnienie pamięci podręcznej protokołu ARP (Flush ARP cache)
  8. Opróżnienie pamięci podręcznej protokołu AARP (Flush AARP cache)
  9. Opróżnienie pamięci podręcznej protokołu SAP (Flush SAP cache)
  10. Opróżnienie pamięci podręcznej protokołu NBP (Flush NBP cache)


Opcja "Suspend analysis"

Wybranie tej opcji powoduje odcięcie programu od sieci a tym samym wstrzymanie analiz. Opcja ta jest przydatna przy intensywnym ruchu w sieci, kiedy program dużo czasu poświęca na analizowanie ramek i przez to zwiększa się jego czas reakcji na polecenia użytkownika.


Opcja "Resume analysis"

Opcja ta ponownie podłącza program do sieci i wznawia analizy wyłączone opcją "Suspend analysis".


Opcja "ARP subnet query"

Wybranie tej opcji powoduje przepytanie całej podsieci protokołem ARP i utworzenie nowego, aktualnego przyporządkowania adresów IP adresom MAC. Patrz: "Opcja 'ARP cache'".


Opcja "AARP subnet query"

Wybranie tej opcji powoduje przepytanie całej podsieci protokołem AARP i utworzenie nowego, aktualnego przyporządkowania adresów Appletalk adresom MAC. Patrz: "Opcja 'AARP cache'".


Opcja "SAP query"

Wybranie tej opcji powoduje wysłanie globalnego zapytania o usługi protokołem SAP. Patrz: "Opcja 'SAP lookup'".


Opcja "NBP zone query"

Wybranie tej opcji powoduje wysłanie globalnego zapytania o usługi protokołem NBP. Patrz: "Opcja NBP lookup".


Opcja "Flush ARP cache"

Wybranie tej opcji powoduje opróżnienie pamięci podręcznej protokołu ARP.


Opcja "Flush AARP cache"

Wybranie tej opcji powoduje opróżnienie pamięci podręcznej protokołu AARP.


Opcja "Flush SAP cache"

Wybranie tej opcji powoduje opróżnienie pamięci podręcznej protokołu SAP.


Opcja "Flush NBP cache"

Wybranie tej opcji powoduje opróżnienie pamięci podręcznej protokołu NBP.


Menu "Reports"

an266.jpg (12074 bytes) W menu "Reports" znajdują się opcje dotyczące tworzenia raportów z eksportowanych danych.

  1. Utwórz raport z wyeksportowanych statystyk (Create report from exported stats.)
  2. Utwórz nową definicję raportu (New report definition)
  3. Edytuj istniejącą definicję raportu (Edit report definition)


Opcja "Create report from exported stats"

Z plików binarnych utworzonych w czasie eksportu statystyk możemy sporządzać różnorakie raporty. Opcja "Create report from exported stats" służy właśnie do tego celu. Po wybraniu tej opcji system pyta się o nazwę:

  1. Definicji według, której należy sporządzić raport - definicję tę można utworzyć przy pomocy opcji "New report definition"
  2. Binarnego pliku eksportowego, który będziemy analizować - plik ten jest tworzony w procesie eksportu.
  3. Nazwę pliku wyjściowego - raport jest tworzony do pliku TXT lub HTML

Po wykonaniu raportu system pyta się czy pokazać wykonany raport.


Opcja "New report definition"

Wybranie tej opcji powoduje utworzenie nowej definicji raportu. Jej wybranie powoduje otwarcie okna edycji raportu. Po zakończeniu edycji raportu i wciśnięciu przycisku "OK", system pyta się o nazwę pliku pod którą nowo utworzona definicja ma być zachowana.


Okno edycji definicji raportu

Z plików binarnych utworzonych w czasie eksportu statystyk możemy sporządzać różnorakie raporty. W definicji raportu możemy wybrać z pliku eksportowego tylko niektóre dane, dokonywać uśrednień wartości, liczyć maksima i minima. Jeden plik eksportowy może służyć jako źródło danych do wielu raportów. Raporty mogą być generowane w formacie tekstowym (TAB delimited) lub w formacie HTML.

Definicja raportu jest opisem pól występujących w raporcie wraz ze sposobem ich wyświetlania. Definicję raportu tworzy się w poniższym oknie. Okno to składa się z trzech części - części definiującej pola skalarne (Fields) występujące w raporcie, części definiującej tabele (Tables) występujące w raporcie oraz z definicji samego raportu (Report)

an22.jpg (122422 bytes)

Definicja pól skalarnych

W części opisującej pola skalarne użytkownik wybiera z bazy statystyk elementy, które będą występowały w tworzonym raporcie. Za pomocą klawisza "Add" dodajemy nowe pola do raportu (otwiera się wtedy okno wyboru statystyk). Przyciski "Remove" i "Remove all" powodują usunięcie aktualnie zaznaczonego elementu lub wszystkich elementów.

Po zaznaczeniu pola, w liście "Format" można wybrać format prezentacji danego pola. Zaznaczenie flagi "Per sample" powoduje wyprowadzanie dla tego pola różnicy pomiędzy stanem obecnym a stanem poprzednim. Zaznaczenie flagi "Average" powoduje wyprowadzanie wartości średniej.

Definicja tabel

W części opisującej tabele, użytkownik wybiera z bazy statystyk tabele, które będą występowały w raporcie. Za pomocą klawisza "Add" dodajemy nowe tabele do raportu (otwiera się wtedy okno wyboru statystyk). Przyciski "Remove" i "Remove all" powodują usunięcie aktualnie zaznaczonego elementu lub wszystkich elementów.

Po zaznaczeniu tabeli, z listy "Name col." możemy wybrać element tabeli, który będzie pełnił rolę legendy a z listy "N. format" format wyporwadzania tego pola.

Poniżej, możemy wybrać z listy te kolumny tabeli, które chcemy wyprowadzać wraz z formatem i atrybutami ich wyprowadzania.

Definicja raportu

Definicja raportu składa się z następujących elementów:

  • Add time as first column - zaznaczenie tej flagi powoduje dodanie czasu jako pierwszej kolumny raportu
  • Output as text/html - określa format pliku w którym tworzony będzie raport.
  • Sample length - długość przedziału uśredniania. Statystyki są zbierane z czasem uśredniania równym 1 sekundzie. W polu tym można określić większy czas uśredniania (np. minutę). W czasie eksportu odpowiednie wartości zostaną uśrednione z nowym czasem.
  • Output to file - domyślna nazwa pliku i katalog eksportu
  • Using template - template raportu.


Opcja "Edit report definition"

Wybranie tej opcji powoduje przejście do edycji istniejącej definicji raportu. Po jej wybraniu system pyta się o nazwę pliku z definicją raportu, po czym otwiera okno edycji raportu. Po zakończeniu edycji raportu i wciśnięciu przycisku "OK", system zachowuje zmienioną definicję.


Menu "Desktop Agent"

an267.jpg (26807 bytes) W menu "Desktop Agent" znajdują się opcje służace do wykonywania operacji na wszystkich stacjach, które mają zainstalowane oprogramowanie ANASIL Desktop Agent.

  1. Opcja zdalnego włączenia wszystkich stacji obsługujących WakeUp On LAN (Wake up all stations)
  2. Zdalne wyłączenie wszystkich stacji z ANASIL Desktop agentem bez ostrzeżenia (Shutdown all stations (no warning))
  3. Zdalne wyłączenie wszystkich stacji z ANASIL Desktop agentem z ostrzeżeniem (Shutdown all stations (warning))
  4. Zdalne zrestartowanie wszystkich stacji z ANASIL Desktop agentem bez ostrzeżenia (Restart all stations (no warning))
  5. Zdalne zrestartowanie wszystkich stacji z ANASIL Desktop agentem z ostrzeżeniem (Restart all stations (warning))
  6. Odświeżenie informacji w profilu dla wszystkich stacji z ANASIL Desktop agentem (Refresh station information (all))
  7. Odświeżenie statystyk dla wszystkich stacji z ANASIL Desktop agentem (Refresh station statistics (all))


Menu "Window"

an268.jpg (12940 bytes) W menu "Window" znajdują się opcje operujące na układzie okien programu. Większość z nich wykonuje standardowe operacje na oknach (Cascade, Tile, etc.). Wyjątkiem jest opcja "Layout windows", której wybranie powoduje uporządkowanie ułożenia okien w zależności od ich zawartości.


Opcja "Layout windows"

Wybranie tej opcji powoduje uporządkowanie okien systemu w następujący sposób, tak aby wszystkie okna były w całości widoczne:

layout.gif (56560 bytes)


Menu "Help"

an269.jpg (8676 bytes) Menu "Help" zawiera trzy opcje:

  1. Otwarcie dokumentacji programu (Contents)
  2. Otwarcie okna z informacjami na temat wersji ANASILa (About ANASIL)
  3. Otwarcie strony głównej firmy LF Networks w domyślnym browserze internetowym (LF Networks Web Site)


Opcja "Contents" - otwarcie pomocy

Wybranie tej opcji powoduje otwarcie dokumentacji w przeglądarce HTMLHelp (jeżeli masz zainstalowany Microsoft Internet Explorer) lub w domyślnej przeglądarce internetowej. UWAGA: przeglądarka ta musi obsługiwać język JAVA oraz ramki (frames).


Opcja "About ANASIL"

Wybranie tej opcji powoduje otwarcie okna informującego o aktualnie używanej wersji programu ANASIL.


Opcja "LF Networks Web site"

Wybranie tej opcji powoduje otwarcie głównej strony firmy LF Networks w domyślnej przeglądarce internetowej. Na stronie tej można znaleźć informacje na temat produktów firmy, przeczytać informacje techniczne, ściągnąć dema nowych produktów lub uzupełnienia/poprawki produktów starszych.

ZAPRASZAMY na http://www.lfnetworks.com lub na http://www.lfnetworks.com.pl


Język opisu protokołów

Dokumentacja języka opisu protokołów jest dostępna on-line w sieci Internet pod adresem: http://www.lfnetworks.com/anasil/doc/index.htm

Z tego adresu można również ściągnąć całą dokumentację tego języka w postaci pliku HTMLHelp.


Lista tablic dekodera protokołów

W programie dekodera protokołów można tworzyć tablice zawierające przypisania pomiędzy identyfikatorami a nazwami mnemonicznymi. Tablice te są używane wewnętrznie w czasie dekodowania ramek. Mogą być również użyte przez użytkownika w czasie wizualizacji statystyk numerycznych (zamiast numerycznego identyfikatora można wyprowadzić nazwę zrozumiałą dla użytkownika). Kilkoma bardziej użytecznymi tablicami w dekoderze są:

EII_TYPE

Tablica ta zawiera przypisania pomiędzy identyfikatorem protokołu w ramce Ethernet II a nazwą protokołu.

IPX_TYPE

W tablicy tej znajdują się identyfikatory podprotokołów protokołu IPX.

SAP_SERVER

W tablicy tej znajdują się identyfikatory usług w protokole SAP.

IPX_PORT

W tablicy tej znajdują się numery portów IPX.

IP_PROT_TYPE

W tablicy tej znajdują się identyfikatory podprotokołów protokołu IP.

UDP_PORT_TABLE

W tablicy tej znajdują się numery portów protokołu UDP.

TCP_PORT_TABLE

W tablicy tej znajdują się numery portów protokołu TCP.


Pliki inicjalizacyjne

ANASIL przy starcie ładuje szereg tekstowych plików inicjalizacyjnych. Pliki te mogą być modyfikowane przez użytkownika np. w celu dopasowania programu do konkretnego środowiska (chociaż zazwyczaj nie będzie takiej potrzeby). Nowe, poszerzone wersje tych plików będą również dostępne do ściągnięcia z Internetu ( http://www.lfnetworks.com ) w ramach aktualizacji oprogramowania:

attypes.ini

W pliku attypes.ini przechowywane są nazwy typów obiektów serwisu nazw NBP (Appletalk), które będą interpretowane jako nazwy stacji podczas automatycznego zbierania informacji o sieci. Format pliku jest bardzo prosty - kolejne nazwy są umieszczane w osobnych liniach:

Power Macintosh
Macintosh IIci
Macintosh PowerBook
AFPServer
NetWare AppleTalk Stack
Workstation
LaserJet 4V
LaserJet 5
LaserWriter

mcasts.ini

W pliku mcasts.ini przechowywane są definicje adresów broadcast'ów i multicast'ów. Plik ten pełni dla tych adresów podobną rolę jak profil sieci dla adresów stacji - służy do zamiany binarnych adresów na postać zrozumiałą dla człowieka. Format pliku jest następujący:

Każdy broadcast/multicast jest opisywany w osobnej linii. Każda linia składa się z następujących elementów oddzielonych przecinkami:

  • Identyfikator broadcastu/multicastu w bazie statystyk (liczba od 2000-2999) (patrz Statystyki stacji sieciowych)
  • Adres MAC początkowy. Czasami broadcast/multicast rezerwuje sobie pewien zakres adresów MAC.
  • Adres MAC końcowy.
  • Nazwa mnemoniczna

Na przykład:

2000, FF-FF-FF-FF-FF-FF, FF-FF-FF-FF-FF-FF, Ethernet Broadcast
2001, 09-00-07-FF-FF-FF, 09-00-07-FF-FF-FF, Appletalk Broadcast
2002, 09-00-07-00-00-00, 09-00-07-00-00-FC, Appletalk Zone Multicast
2003, 03-00-00-00-00-01, 03-00-00-00-00-01, Netbios Broadcast
2004, 01-00-5E-00-00-00, 01-00-5E-7F-FF-FF, Internet Multicast

offsets.ini

Plik offsets.ini przechowuje informacje o położeniu niektórych elementów nagłówków protokołów w ramce. Jego zawartość jest wykorzystywana przy tworzeniu filtra prostego. Format tego pliku jest również bardzo prosty: każda linia definiuje położenie jednego elementu nagłówka i składa się z:

  • Liczbowej wartości tego przesunięcia względem początku ramki protokołu sieciowego (zaraz za ramką MAC)
  • Komentarza oddzielonego od przesunięcia znakiem średnika

Na przykład:

28 ;IPX source socket
16 ;IPX dest. socket
20 ;UDP/TCP source port
22 ;UDP/TCP dest. port

proto.ini

W pliku proto.ini zdefiniowane są identyfikatory protokołów sieciowych oraz ich nazwy zrozumiałe dla człowieka. Każda linia opisuje jeden identyfikator protokołu i ma następujący format:

  • Identyfikator protokołu w bazie statystyk (liczba od 1 do 64000)
  • Identyfikator protokołu w sieci. Identyfikatory protokołów (nawet tego samego protokołu np.IPX) różnią się w zależności od typu ramki Ethernet i w związku z tym ANASIL używa dwóch formatów tych identyfikatorów: formatu dwubajtowego (dla ramek Ethernet II i Ethernet 802.2) oraz pięciobajtowego (dla Ethernet SNAP)
  • Nazwa mnemoniczna protokołu
1,  08-00, TCP/IP
2,  08-06, ARP
3,  81-37, IPX (Eth II)
4,  81-38, IPX (Eth II')
5,  00-E0, IPX (Eth 802.2)
6,  00-00, IPX (Eth 802.3)
7,  00-F0, NetBEUI
8,  80-F3, Appletalk ARP
9,  08-00-07-80-9B, Appletalk

userlist.ini

Plik ten definiuje programy zewnętrzne które mogą być uruchamiane w celu zdobycia informacji o przyporządkowaniu adresów MAC nazwom użytkowników serwera NetWare. (patrz Opcje zbierania informacji przez SAP). Plik ten składa się z szeregu sekcji rozpoczynających się nazwą sekcji (np: [Netware 3.X]). W każdej sekcji zdefiniowane są następujące parametry:

  • Command - zawiera linię poleceń używanych do uruchomienia zewnętrznego programu. Powinien być to program nie wymagający żadnej ingerencji ze strony użytkownika i przekazujący na standardowe wyjście dane, których choćby część jest regularną listą zawierającą nazwę użytkownika i adres MAC.
  • Pattern - zawiera wyrażenie regularne używane do wyodrębnienia ze strumienia nazwy użytkownika, adresu MAC, identyfikatora połączenia oraz numeru sieci IPX. W wyrażeniu tym powinny występować cztery sekcje ograniczone nawiasami klamrowymi {}. Każda z tych sekcji określa położenie jednego z szukanych elementów. Sekcje te są numerowane od lewej do prawej począwszy od 1.
  • ConnId - numer sekcji zawierającej identyfikator połączenia z NetWare
  • Name - numer sekcji zawierającej nazwę użytkownika
  • Network - numer sekcji zawierającej hexadecymalny numer sieci IPX
  • Node - numer sekcji zawierającej hexadecymalny adres stacji (MAC)

Analizowane są tylko te linie strumienia wyjściowego, które pasują do wyrażenia regularnego. Pozostałe linie są odrzucane. Przykładowy plik wygląda następująco:

;
;  INI for userlist command on different NetWare versions
;

[Netware 3.X]
Command="USERLIST /A /C"
Pattern=":b{:z}:b(/* )#{*}:b/[{*}/]:b/[{*}/]*$"
ConnId=1
Name=2
Network=3
Node=4

[Netware 4.X]
Command="NLIST User /A /B /C"
Pattern=":b{:z}:b(/*)#{*}:b/[{*}/]:b/[{*}/]*$"
ConnId=1
Name=2
Network=3
Node=4

vendors.ini

W pliku vendors.ini przechowywane są przypisania pomiędzy identyfikatorami producentów kart sieciowych a nazwami producentów. Każdy producent kart sieciowych Ethernet dostaje od IEEE swój trzybajtowy identyfikator, który stanowi starszą część adresu MAC. ANASIL wyświetlając adres MAC może go wyświetlać jako nazwę producenta karty sieciowej (patrz Typy wartości skalarnych). W pliku vendors.ini każda linia opisuje przyporządkowanie identyfikatora (zapisanego jako adres MAC z trzema pozostałymi bajtami wyzerowanymi) i nazwy producenta. Oba te elementy rozdzielone są znakiem przecinka. Przykładowo:

00-00-00-00-00-00, OS/9 Network
00-00-02-00-00-00, BBN
00-00-0C-00-00-00, Cisco
00-00-0E-00-00-00, Fujitsu Limited
00-00-0F-00-00-00, NeXT
00-00-10-00-00-00, Hughes LAN Systems
00-00-11-00-00-00, Tektronix
00-00-15-00-00-00, Datapoint Corporation
00-00-18-00-00-00, Webster Computer Corporation
00-00-1A-00-00-00, AMD
00-00-1B-00-00-00, Novell Inc.
00-00-1D-00-00-00, Cabletron
00-00-20-00-00-00, DIAB (Data Intdustrier AB)
00-00-21-00-00-00, SC&C
00-00-22-00-00-00, Visual Technology
.
.
.

snmptyp.ini

W pliku snmptyp.ini przechowywane są reguły przekształcania nazw systemów operacyjnych zwracanych przez agenta SNMP na postać wpisywaną do profilu sieci. Każda linia tego pliku składa się z trzech elementów:

  1. Wyrażenie regularne stanowiące wzorzec
  2. Nazwa systemu operacyjnego wpisywana do profilu gdy nazwa zwrócona przez agenta SNMP pasuje do wzorca
  3. Wersja systemu operacyjnego


Wyrażenia regularne

Wyrażenie regularne stanowi wzorzec, do którego możemy dopasowywać teksty. Za jego pomocą można również z regularnego tekstu wyodrębniać pewne jego fragmenty. Elementami wzorca mogą być zwyczajne teksty oraz znaki specjalne, których zestaw i znaczenie prezentujemy w poniższej tabelce:

Znak specjalny | Jego znaczenie
/ | Znak ten powoduje zignorowanie następnego znaku (następny znak nie jest interpretowany jako znak specjalny)
? | Znak ten zastępuje dowolny inny znak (np: zarówno 'but' jak 'bot' pasują do wzorca 'b?t')
* | Znak ten zastępuje dowolny ciąg znaków
^ | Znak ten odpowiada początkowi linii
$ | Znak ten odpowiada końcowi linii
[...] | Specyfikuje zestaw znaków (np. [a-zA-Z] specyfikuje małą lub dużą literę alfabetu
[~...] | Specyfikuje zanegowany zestaw znaków (wszystkie znaki z wyjątkiem...)
X1|X2|..|Xn | Alternatywa wzorców.
X1&X2..&Xn | Koniunkcja wzorców
# |
{..} | Wynznacza sekcję wzorca

Oprócz tego, dostępne są pewne predefiniowane wzorce:

Wzorzec | Znaczenie
:a | Specyfikuje znak alfanumeryczny (literę lub cyfrę)
:b | Specyfikuje tzw. "biały" znak (spacja lub tabulacja)
:c | Specyfikuje literę (dużą lub mała)
:d | Specyfikuje cyfrę
:h | Liczba heksadecymalna
:n | Liczba
:w | Słowo złożone z samych liter
:z | Liczba


Szblony eksportów

W czasie eksportu zawartości viewera lub formy do pliku HTML lub do pliku tekstowego, ANASIL używa tzw. szablonów eksportu. Szablonem eksportu jest plik w formacie HTML lub plik tekstowy (ASCII), w którym wyróżniono miejsce do wstawienia właściwych danych eksportowanych. Jest to swego rodzaju rama, w której użytkownik może zdefiniować swój nagłówek (np z logo firmy) i stopkę. Oprócz miejsca do wstawienia eksportu, szablon może mieć zaznaczone również miejsca, w które ANASIL automatycznie wstawi inne parametry eksportu.

Do zaznaczania miejsc w pliku szablonu eksportu użytkownik używa makr:

  • $BODY$ - w miejsce tego makra ANASIL wstawi zawartość eksportu
  • $AUTHOR$ - w miejsce tego makra ANASIL wstawi nazwisko autora raportu (ustawiane w odp. polu okna opcji eksportu)
  • $NETWORK$ - w miejsce tego makra ANASIL wstawi nazwę sieci dla której jest tworzony raport (ustawianą w odp. polu okna opcji eksportu)
  • $START$ - w miejsce tego makra ANASIL wstawi czas rozpoczęcia pomiarów
  • $STOP$ - w miejsce tego makra ANASIL wstawi czas zakończenia pomiarów
  • $TITLE$ - w miejsce tego makra ANASIL wstawi tytuł raportu
  • $REMARKS$ - w miejsce tego makra ANASIL wstawi komentarz podany przez użytkownika

Przykładowe szablony default.htm oraz default.txt znajdują się w podkatalogu WORKS.


Umowa licencyjna

Uwaga: należy dokładnie zapoznać się z treścią niniejszej Umowy Licencyjnej, zwanej dalej Licencją, która stanowi prawnie wiążącą umowę zawartą pomiędzy osobą fizyczną lub prawną, zwaną dalej Użytkownikiem i firmą „LF Networks” Sp. z o.o., zwaną dalej LF Networks. Licencja określa zasady użytkowania oprogramowania, wiążące LF Networks i Użytkownika. Zainstalowanie oprogramowania na komputerze oznacza akceptację wszystkich postanowień niniejszej Licencji.

Oprogramowanie chronione jest polskim i międzynarodowym prawem autorskim i o ochronie praw własności intelektualnej.

1. Przedmiotem niniejszej Licencji jest użytkowanie oprogramowania ANASIL wraz z jego elementami składowymi w postaci oprogramowania Anasil Desktop Agent i Dokumentacji, zwanych dalej Programem.

2. LF Networks jest wyłącznym właścicielem Programu, w tym praw autorskich do Programu.

3. LF Networks przekazuje kopię Programu Użytkownikowi do jego wyłącznego użytku. Użytkownik ma prawo do korzystania z Programu zgodnie z jego przeznaczeniem na sprzęcie komputerowym, którego typ i konfiguracja są określone w dokumentacji.

4. Program może być używany na jednym komputerze, za wyjątkiem jego części składowej w postaci oprogramowania Anasil Desktop Agent, które może być używany na większej liczbie stanowisk komputerowych, co wynika z rodzaju zakupionej wersji.

5. Użytkownikowi nie wolno wynajmować, wydzierżawiać ani wypożyczać Programu, dokumentacji lub ich kopii osobom trzecim.

6. Przekazywanie praw użytkowania Programu jest dopuszczalne tylko przy jednoczesnym przekazaniu niniejszej Licencji i jej akceptacji przez nowego Użytkownika, przekazaniu oryginalnej wersji Programu i powiadomieniu o tym fakcie LF Networks.

7. Zabroniona jest dekompilacja, deasemblacja oraz jakakolwiek inna modyfikacja Programu, a także wykorzystanie Programu lub jego części w innym oprogramowaniu. Niedozwolone jest również wykorzystanie Programu do tworzenia publikacji i opracowań bez odrębnej zgody LF Networks.

8. Zarejestrowanemu Użytkownikowi przysługuje ograniczona gwarancja na Program w okresie 90 dni od daty zakupu oraz prawo do bezpłatnej pomocy i informacji technicznej. Ograniczona gwarancja dotyczy nieobecności nieautoryzowanych kodów oraz funkcjonalnej zgodności Programu z dokumentacją. Ograniczona Gwarancja nie dotyczy całkowitej bezbłędności Programu.

9. LF Networks nie ponosi żadnej odpowiedzialności za powstałe szkody, które mogłyby nastąpić na skutek stosowania Programu, w tym również utratę informacji i straty pieniężne wynikłe z użytkowania lub niemożności użytkowania Programu.

10. W przypadku naruszenia postanowień Licencji, LF Networks ma prawo rozwiązać niniejszą umowę oraz dochodzić swoich roszczeń z tytułu tego naruszenia.


Typy ramek Ethernet

W ramkach protokołu liniowego Ethernet wyróżnić można część nagłówkową oraz część zawierającą przesyłane dane. W sieciach lokalnych spotyka się cztery rodzaje ramek Ethernet, różniących się między sobą zawartością i długością nagłówka:

  • Ethernet 802.3 - podstawową ramkę w sieciach NetWare do wersji 3.11 (rys.1),
  • Ethernet 802.2 - podstawową dla NetWare w wersji 4.0 (rys.2),
  • Ethernet II - używaną zazwyczaj w charakterze warstwy liniowej protokołów rodziny TCP/IP (rys.3),
  • Ethernet SNAP - wykorzystywaną głównie przez protokoły Appletalk (rys.4).

Rys.1 Ramka Ethernet 802.3

Rys.2 Ramka Ethernet 802.2

Rys.3 Ramka Ethernet II

Rys.4 Ramka Ethernet SNAP


Opcja "Main toolbar"

Opcja ta reguluje widoczność toolbaru zawierającego globalne opcje programu:

an254.jpg (28202 bytes)

W toolbarze tym, od lewej znajdują się przyciski odpowiadające następującym opcjom:

  1. Profiles/Create new profile
  2. Profiles/Open profile
  3. Profiles/Close profile
  4. Profiles/Edit current profile
  5. Viewers/Freeze viewer
  6. Viewers/Unfreeze viewer
  7. Viewers/Reset viewer
  8. Viewers/Save form to HTML file
  9. Viewers/Save form to TEXT file
  10. Viewers/Save viewer to HTML file
  11. Viewers/Save viewer to TEXT file
  12. Capture/View capture buffer
  13. Network structure tree
  14. Event log
  15. System log
  16. Window/Layout windows
  17. Filtering/Enable global filtering
  18. Filtering/Set-up global filter
  19. Refresh station information (All)
  20. Refresh station statistics (All)


Opcja "Constructor toolbar"

Opcja ta reguluje widoczność toolbaru zawierającego opcje dotyczące budowania viewerów i form.

an255.jpg (8850 bytes)

W toolbarze tym, od lewej znajdują się przyciski odpowiadające następującym opcjom:

  1. Constructor/New viewer
  2. Constructor/Open viewer
  3. Constructor/Save viewer
  4. Constructor/Add new form
  5. Constructor/Remove current form
  6. Constructor/Set viewer name
  7. Constructor/Set form name
  8. Constructor/Auto-open viewers


Opcja "Cache toolbar"

Opcja ta reguluje widoczność toolbaru zawierającego opcje dotyczące pamięci podręcznych programu:

wpe1.jpg (3170 bytes)

W toolbarze tym, od lewej znajdują się przyciski odpowiadające następującym opcjom:

  1. Analyzer/ARP subnet query
  2. Analyzer/AARP subnet query
  3. Analyzer/SAP query
  4. Analyzer/NBP zone query
  5. Analyzer/Flush ARP cache
  6. Analyzer/Flush AARP cache
  7. Analyzer/Flush SAP cache
  8. Analyzer/Flush NBP cache


Opcja "Point-to-point toolbar"

Opcja ta reguluje widoczność toolbaru zawierającego opcje dotyczące testów point-to-point:

wpe1.jpg (3688 bytes)

W toolbarze tym, od lewej znajdują się przyciski odpowiadające następującym opcjom:

  1. Point-to-point / IP (ICMP) Setup
  2. Point-to-point / Run IP tests
  3. Point-to-point / IPX Setup
  4. Point-to-point / Run IPX tests
  5. Point-to-point / NetBEUI Setup
  6. Point-to-point / Run NetBEUI tests
  7. Point-to-point / Appletalk (AEP) Setup
  8. Point-to-point / Run Appletalk tests