Nápověda k programu GraphDrawer

Konstanty a proměnné

Program SCalculator má v sobě při distribuci obsažen základní seznam konstant. Tento seznam můžete vyvolat kliknutím na tlačítko "const".

V zobrazeném okně můžete rychle vyhledávat konstanty zapsáním části názvu hledané konstanty

Pomocí tlačítek

můžete konstanty libovolně přidávat a mazat.

Konstanta se do výrazu vloží jako číslo.

Konstanty jsou uloženy na pevném disku a jsou při dalším spuštění počítače znovu načteny.

Proměnné

Operace s proměnnými jsou obdobné jako operace s konstantami. Okno proměnných lze vyvolat kliknutím na tlačítko "mem" (viz výše). Proměnná se do příkladu vkládá jako její název.

Chcete-li přičíst aktuální hodnotu výsledku do určité proměnné, klikněte na tlačítko "mem+" (viz výše) a do následovně zobrazeného okna zadejte název proměnné, ke které chcete výsledek přičíst.

Proměnné jsou uloženy pouze v rámci dané instance programu. S ukončením programu zanikají.


Nastavení kalkulačky

K nastavení SCalculatoru slouží část kalkulačky pod editačním políčkem. (nastavení lze také provést přes menu nebo klávesové zkratky, které jsou v menu uvedeny)

Nastavení úhlové jednotky

nastavení určuje, jak se bude prezentovat hodnota vyjadřující úhel

DEG = stupně - F2

RAD = radiány - F3

GRD = grady - F4

Nastavení bitového rozměru

nastavení určuje ,v kolika bitech se budou provádět logické operace

BYTE = 8 bitů - F5

WORD = 16 bitů - F6

DWORD = 32 bitů - F7

Nastavení číselné soustavy

nastavení určuje, v jaké soustavě se budou zadávat čísla a zobrazovat výsledky

BIN = binárně (0-1) - F8

OCT = oktálově (0-7) - F9

DEC = decimálně (0-9) - F10

HEX = hexadecimálně (0-F) - F11


Přehled funkcí a operátorů
- | odčítání (menšenec-menšitel) 2-3=-1
! | faktorial (číslo!) 3!=6
% | procenta (číslo%) 2%=0,02
()[]{} | závorky ({[(výraz)]}) {2*[3*(4+5)]}=54
* | násobení (činitel*činitel) 2*3=6
/ | dělení (dělenec/dělitel) 5/2=2,5
^ | mocnina (základ^exponent) 2^3=8
+ | sčítaní (sčítanec+sčítanec) 2+3=5
abs | absolutní hodnota (abs číslo) abs -5 = 5
and | bitový součin (číslo and číslo) 010110 and 100101 = 000100
arccos | inverzní cosinus (arccos číslo)*2
arccosh | inverzní hyperbolický cosinus (arccosh číslo)*2
arccot | inverzní cotangens (arccot číslo)*2
arccoth | inverzní hyperbolický cotangens (arccoth číslo)*2
arccsc | inverzní cosecant (arccsc číslo)*2
arccsch | inverzní hyperbolický cosecant (arccsch číslo)*2
arcsec | inverzní secant (arcsec číslo)*2
arcsech | inverzní hyperbolický secant (arcsech číslo)*2
arcsin | inverzní sinus (arcsin číslo)*2
arcsinh | inverzní hyperbolický sinus (arcsinh číslo)*2
arctan / arctg | inverzní tangens (arctan číslo)*2
arctanh / arctgh | inverzní hyperbolický tangens (arctanh číslo)*2
bin | prezentuje obsah závorky jako binární příklad (oct číslo)
ceil | zaokrouhlení nahoru (ceil číslo) ceil 3,2 = 4
cos | cosinus (cos úhel)*1
cosh | hyperbolický cosinus (cosh úhel)*1
cot / cotg | cotangens (cot úhel)*1
coth / cotgh | hyperbolický cotangens (coth úhel)*1
csc | cosecant (csc úhel)*1
csch | hyperbolický cosecant (csch úhel)*1
dec | prezentuje obsah závorky jako decimální příklad (dec číslo)
deg | prezentuje úhel ve stupních (deg úhel)*2
degtograd | převede stupně na grady (degtograd úhel) degtograd 10 = 11,1111111111111
degtorad | převede stupně na radiány (degtorad úhel) degtorad 180 = 3,14159265358979
div | celočíselné dělení (dělenec div dělitel) 5 div 2 = 2
dms | převod ze stupňů na stupně, minuty a vteřiny (dms číslo) dms 1,75 = 1,45
exp | exponenciála (exp exponent) exp 0 = 1
floor | zaokrouhlení dolu (floor číslo) floor 3,8 = 3
frac | desetinná část (frac číslo) frac 2,5 = 0,5
grad | prezentuje úhel v grady (deg úhel)*2
gradtodeg | převede grady na stupně (gradtodeg úhel) gradtodeg 1 = 0,9
gradtorad | převede grady na radiány (gradtorad úhel) gradtorad 1 = 0,015707963267949
hex | prezentuje obsah závorky jako hexadecimální příklad (hex číslo)
int | celočíselná část (int číslo) int 2,5 = 2
invdms | prevod ze stupnu, minut a vterin na stupne (invdms číslo) invdms 1,45 = 1,75
ln | přirozený logaritmus (ln číslo) ln 1 = 0
log | dekadický logaritmus (log číslo) log 10 = 1
logn | logaritmus o definovaném základu (základ logn číslo) 2 logn 8 = 3
lshift | bitový posun vlevo (číslo lshift) 010110 lshift 1 = 101100
mod | zbytek po celočíselném dělení (dělenec mod dělitel) 5 mod 2 = 1
not | bitová negace (not číslo) not 010110 = 101001
oct | prezentuje obsah závorky jako oktální příklad (oct číslo)
or | bitový rozdíl (číslo or číslo) 010110 or 100101 = 110111
rad | prezentuje úhel v radiánech (deg úhel)*2
radix | n-tá odmocnina (n radix číslo) 3 radix 27 = 3
radtodeg | převede grady na stupně (radtodeg úhel) radtodeg 3,14159265358979 = 180
radtograd | převede radiány na grady (radtograd úhel) radtograd 1 = 63,6619772367581
round | zaokrouhlení (round číslo) round 2,5 = 3
rshift | bitový posun vpravo (číslo rshift) 010110 rshift 1 = 1011
sec | secant (sec úhel)*1
sech | hyperbolický secant (sech úhel)*1
sign | signifikace kladu / záporu (sign číslo) sign -5,5 = -1
sin | sinus (sin úhel)*1
sinh | hyperbolický sinus (sinh úhel)*1
sqr | druhá mocnina (sqr základ) sqr 3 = 9
sqrt | druhá odmocnina (sqrt číslo) sqrt 9 = 3
tan / tg | tangens (tan úhel)*1
tanh / tgh | hyperbolický tangens (tanh úhel)*1
trunc | odseknutí desetinné části (trunc číslo) trunc 2,5 = 2
xor | exkluzivní bitový rozdíl (číslo xor číslo) 010110 xor 100101 =110011

*1 - úhel je prezentován v aktuální úhlové jednotce
*2 - výsledný úhel je prezentován v aktuální úhlové jednotce

Příbuzná témata:

Zadávání číselných hodnot


Speciální funkce a tlačítka

Historie

tyto tlačítka slouží k procházení historie zadaných výrazů v rámci dané instance programu (nahoru = zpět; dolů = dopředu)

Konverzí funkce

tyto tlačítka reprezentují konverzní funkce, které umožňují prezentovat svůj parametr v číselné soustavě určené názvem této funkce

(binárně, oktálově, decimálně, hexadecimálně)

Vypočítej

kliknutím na toto tlačítko dojde k vypočítaní aktuálně zadaného výrazu

Rychlá nápověda

Velice užitečnou nápovědou k funkcím jednotlivých tlačítek Vám mohou být nápovědné texty. Stačí najet na určité tlačítko SCalculátoru myší a nad ním okamžik setrvat.

Horní řádek nápovědného textu (hintu) určuje syntaxi dané funkce v editačním políčku příkladu. Spodní řádek stručně funkci popisuje.

"Magnetismus oken"

Všechna okna v programu jsou "magnetická", čímž umožňují jejich snadné uspořádání na obrazovce.


Zadávání matematických příkladů

Do editačního políčka SCalculatoru můžete zapisovat příklady přímo přes klávesnici pomocí definovaných operátorů a funkcí. (viz Přehled operátorů a funkcí)

Všechny parametry a výsledky funkcí, které mají co do činění s úhly (funkce goniometrické, cyklometrické...), se prezentují v aktuálně nastavené úhlové jednotce.

Další možností pro zadávání matematických příkladů je používání zkratkových tlačítek kalkulačky, které usnadňují sestavení výrazu.

Kliknete-li na tlačítko určité funkce a je-li v editačním poli označena část výrazu, uzavře se tato část výrazu do závorky a přidá se jako parametr vybrané funkce. V opačném případě se daná funkce připíše do příkladu na pozici kurzoru.


Nápověda k programu SCalculator

Nápovědu vytvořil: Ivo Skalický

(c) 2002 - 2003 ITProCZ


Zadávání funkcí

Funkce můžete v programu zadávat podobně jako v programovacích jazycích založených na Object Pascalu. Podrobný přehled všech použitelných funkcí naleznete v Přehledu funkcí a operátorů.

V případě funkcí se následující hodnota po názvu funkce považuje za její parametr. Není tedy potřebné psát závorku k funkci, která má jako parametr například pouze x.

Zápis

je tedy ekvivalentní se zápisem

Mezera se považuje za tzv. "whitechar" (znak, který nemá žádný význam a používá se pouze pro zpřehlednění zápisu). Chceme-li tedy zadat funkci y= sin x + cos x - 1, můžeme zápis provést takto y=sinx+cosx-1

Správnost námi zadané funkce nám indikuje kontrolní políčko, kde [image] znamená, že funkce byla zadána správně, zatímco [image] značí, že funkce je zadána špatně a nelze ji vyhodnotit.

Příbuzná témata:

Zadávání číselných hodnot

Přehled funkcí a operátorů


Zadávání číselných hodnot

Program GraphDrawer umožňuje zadávání číselných hodnot ve formátu, jaký pro vás nepohodlnější.

Příklady:

hodnotu můžete zadat jako:

reálné číslo

zlomek

matematický příklad

V tomto způsobu zadávání můžete použít jakékoli funkce a operátory, které program podporuje. Viz Přehled funkcí a operátorů

Zadávat číselné hodnoty tímto způsobem můžete do každého editačního políčka v programu, kde je očekávána číselná hodnota. Například: nastavení rozsahu grafu, určení šířky čáry, nastavení rozsahu integrálu...

Příbuzná témata:

Zadávání funkcí

Přehled funkcí a operátorů