Subtitle Processor - Documentation

Subtitle Processor 6 - Documentáció

Ez a dokumentáció a SP 6.0 verzióhoz készült

A Subtitle Processor egy eszköz a feliratfájlok szerkesztéséhez. Lehet vele létezõ feliratokat szerkeszteni, vagy újakat létrehozni vázlatból. Beépített DirectShow technológiát használó filmlejátszója van. Minden olyan filmet le tud játszani, amit Windows Media Player-rel is . Támogatja a feliratstílusokat (a stílusokat is alkalmazó formátumoknál). Idõ-alapú és képkocka(frame)-alapú feliratok egyaránt szerkeszthetõk.

Jogi közlemény: Ez a program Freeware. Bármilyen kereskedelmi, vagy nem kereskedelmi célra felhasználható, amely az országban legális. Az eredeti csomagban szabadon terjeszthetõ, amennyiben az ingyenes. (ha egy megazin CD-mellékletén akarod terjeszteni, akkor lépj kapcsolatba a szerzõvel). A programot a saját felelõsségedre használhatod, garancia nélkül. Ha véletlenül kárt okoz a gépedben, vagy az adataidba, az a te problémád.

Rendszerkövetelmények:

  • 32 bit Windows. Fejlesztve Windows XP-n
  • DirectShow és dekóderszûrõk a filmekhez. (DirectShow 9)
  • Processzor, amellyel lejátszhatók a filmek. PIV2.66-on tesztelve, de bármilyen használható, amely le tudja játszani a SubtitleProcesszorban megnyitott filmeket. H a lejátszót nem használod, gyengébb teljesítményû rendszer is megfelel.
  • Videokártya: Bármilyen grafikus kártya megfelel, amelyik mûködik Windows alatt, és DirectX kompatibilis, a minimális felbontása 800x600. Overlay mód erõsen ajánlott.

Támogatott formátumok: lásd ezt az oldalt , ahol megtalálod a támogatott felirat, filmleíró és multimédia fájlformátumokat.

DirectShow dekóder: Szükség van a megfelelõ audio és video dekóderekre pl. a DivX csomagra. A legjobb eredmény az FFDSHOW (http://sourceforge.net/projects/ffdshow) csomag használatával érhetõ el, amely képes lejátszani a DIVX, MPEG4 és XVID összes verzióját, nyílt forráskódú és ingyenes. A pozicionálás prezíz és azonnali. A DivX 5.02, verziójával nem tudtam pozícionálni a filmben.A pozícionálás után a kép nem frissült. Ha ilyet tapasztalsz, akkor próbáld ki, hogy mûködik-e a Windows Media Player-ben (6.4 javasolt).

Windows 9X: A gazdag kezelõfelület miatt a SubtitleProcessor sok rendszererõforrást igényel. Próbálj ne túl sok programot futtatni egyszerre. Ez az erõforráskorlát nincsen NT alatt (WinNT, Win2000, WinXP). Bár a SubtitleProcessor használható Win9X alatt is, tesztelve már nem lesz a továbbiakban.

Megjegyzés:

A program elsõ futásakor (SubtitleProcessor.ini még nem létezik), vagy az INI fájlban kiválasztott fájl hiányzása esetén az alapértelmezett nyelv az angol. Átkapcsolhatsz más létezõ nyelvre a Beállítások ablakban.

Tartalom:

  • Támogatott formátumok
  • Fõ ablak
  • Feliratszerkesztõ
    • Stílus szerkesztõ
    • Névjegy szerkesztõ
    • Szerkesztõ funkciók
  • Lejátszó
  • Feliratfordító
  • Beállítások és nyelvkiválasztás
  • Egyéb párbeszédablakok
  • Verzió elõzmények

WWW

http://catsoft.no-ip.com, http://catsoft.wz.cz/sp - New versions

casoft@seznam.cz - Kérlek jelezd az esetleges hibákat& javaslatokat


Style Editor

Névjegy szerkesztõ

Ebben az ablakban lehet szerkeszteni a SubStation Alpha által használt szerzõi információkat..

Ebben az ablakban van egy pár csoport szerkesztõ vezérlõelem.:

  • Névjegy - eredeti: Az eredeti szerzõ ill. csoport névjegye
  • Névjegy - javította: A javítást végzõ szerzõ ill. csoport névjegye
  • Képfelbontás: Információ az eredeti szerzõ által használt képfelbontásról
  • Ütközések: Kettõ vagy több felirat ütközésének megoldása (SSA) - az SP nem használja
  • Idõzítõ: Lejátszás sebessége (SSA) és eltolás - az SP nem használja

[Vissza a szerkesztõhöz]


Dialogs

Egyéb párbeszédablakok

1. Formátum kiválasztás

Ez a párbeszédablak akkor jelenik meg, amikor a SubtitleProcessor nem tudja automatikusan meghatározni a feliratfájl formátumát. Az esetek 99.9% -ban a fájlt nem lehet megnyitni.

E párbeszédablak vezérlõelemei:

  • Szöveg elõnézete - a megnyitandó fájl elsõ néhány sora
  • Válassz formátumot - válaszd ki az egyik támogatott formátumot
  • Ok - a fájl megnyitása a kiválasztott formátumban
  • Mégsem - nem nyitja meg a fájlt

2. Drag & Drop

Azon fájlok felsorolása, amelyeket az Intézõbõl, vagy más programból húztál be, vagy megadtál a parancssorban. A vezérlõk:

  • Fájlok - a behúzott fájlok listája
  • 1.felirat - A kiválasztott fájl megnyitása elsõ feliratként
  • 2.felirat - A kiválasztott fájl megnyitása elsõ feliratként (fordító)
  • A/V - A kiválasztott fájl megnyitása multimédia fájlként
  • MVD - A kiválasztott fájl megnyitása filmleíró fájlként (a film és a fõ feliratfájl lesz betöltve)
  • WSP - A kiválasztott fájl megnyitása munkaterületként
  • OK - Az ablak bezárása fájlmegnyitás nélkül

3. Film & felirat információ

A filminformációk kiírása. A filmcím szerkeszthetõ. Ez a filmcím lesz betöltve és elmentve a filmleíróban (MVD) és ezt jeleníti majd meg néhány. lejátszóprogram. Ez nem változik, ha csak egyszerû AVI van betöltve.

4. Felirat felosztása

Kettéosztja a kijelölt feliratot. Írd be a szöveget, majd vidd a megfelelõ helyre az elválasztót (Használd a PgUp/PgDn billentyûket), hogy megadd, melyik szövegrész melyik feliratba kerüljön. A feliratsor ketté lesz választva a Felosztás idõpontjában.

5. Névjegy

Információk megjelenítése a SubtitleProcessorról. Az OK gombbal lehet bezárni. A 3rd party components gomb a felhasznált külsõ szoftverkomponensek listáját mutatja meg.

Mozgasd a kurzort a kép különbözõ részeire és kattints, ha átvált!


Functions

Szerkesztõ funkciók

Ez a szekció többféleszerkesztési funkciótmutat be. Több oldal tartalmaz speciális beviteli mezõt:

Ennek a beviteli mezõnek négy fõ része van:

  • Címke - a szerkesztett érték neve
  • Szövegdoboz - itt lehet szerkeszteni az értéket, amely a megadott egység szerint van értelmezve. Az érvénytelen bevitel automatikusan kijavítódik. .
  • Egység doboz - az érték kiválasztott mértékegységét jeleníti meg. A dobozon való kattintással az egység néhol (ahol lehetséges) átváltható.
  • Gomb - valamilyen mûveletet végez az értékkel - pl. ugrás a megadott pozícióba
  • Legördülõ lista - megnyit egy legördülõ listát elõre definiált értékekkel

Mindegyik doboz mûvelete visszavonható - visszatérhetsz a régi értékhez 'Esc' billentyûvel. A visszavonás átmeneti tárolója kiürül, amikor az 'Enter' billentyût megnyomod az érték megerõsítésére.

A legtöbb esetben háromféle értéket lehet szerkeszteni:

  • Kép. - Képkockák / Egész számok. Az egész számok a lejátszott képkockák sorszámát jelentik (kiegészítve ezzel a kifejezéssel: "-?\d*").
  • ÓPM - Idõ. Idõ ebben a formátumban: Óra:Perc:Másodperc,Tizedmásodperc. Az érték max. 2 kettõspontot(:) és egy tizedesjelet (a karakter függ a Windows beállításától). Bármelyik rész több számjegybõl állhat. Az eredmény kiszámítása: Ó*3600 + P*60 + M + T/(10^tizedesjegyek száma). ha csak egy db. kettõspont van, akkor az érték Perc:Másodperc, kettõspont nélkül Másodpercként lesz kezelve. A tizedesrész bármeggyi számjegybõl állhat. A megfelelõ kifejezés:"(-?\d*:?\d*:?\d*)([,\.]\d*)?".
  • Valós számok. Elõfordulhat, hogy a mezõbe valós számot (tizedesjellel) kell beírni. Ez egy számérték lehet egy db. tizedesjellel elválasztva, esetleg egy negatív elõjellel kiegészítve. A megfelelõ kifejezés"-?\d+([,\.]\d*)?"

Ha nincs egység feltüntetve, akkor tõled függ, milyen értéket írsz be az adott mezõbe. A rendszer nem enged érvénytelen értéket beírni.

Néhány mezõnek van maximális és minimális értéke, ha ezeknél nagyobb, vagy kisebb értéket írsz be, az automatikusan ki lesz javítva, hogy a határok közé essen.

Tizedesjel: Használhatsz "." (pontot) vagy "," (vesszõt) egyaránt, a szerkesztõmezõk mindkettõt elfogadják a Windows helyi beállításaitól függetlenül

Megjegyzés: Néhány beviteli mezõ nem támogatja az egység átváltását, néhánynak pedig más egysége van (például %).

1. Haladó feliratszerkesztõ

Ezen a fülön további feliratparamétereket lehet megváltoztatni:

  • Típus - Felirat típusa (SSA fájlokban)
    • Párbeszéd - a felirat normál felirat
    • Megjegyzés - U.a. mint a párbeszéd, de nem jelenik meg.
    • Kép - Szöveg helyett kép jelenik meg. A feliratszöveg képfájlra mutat
    • Hang, AVI - hang, vagy film lejátszása. Az elérési utat a feliratszöveg tartalmazza
    • Parancs - külsõ program meghívása

    Ezeket a típusokat a SubStation Alpha használja, az SP jelen pillanatban nem jeleníti meg õket.

  • Tulajdonságok - Az SSA által használt további felirattulajdonságok
    • Bal, jobb és függõleges margók - szabad hely a képernyõn, amelyet nem foglal el a feliratszöveg.
    • Megjelölt felirat - "Megjelölt" felirat az SSA. A megjelölt feliratok vastagon jelennek meg a Szerkesztõben, de jelenleg a jelölést az SP nem használja.
    • Effekt - Az SSA-ban használt hatások (gördítés, karaoke stb.). Jelenleg az SP nem kezeli.
  • Sortulajdonságok - A sorok stílusának felülírása az MDVD és SRT formátumokban
    • X és Y koordináták - a kiválasztott sor pozíciója a képernyõn (a képfelbontástól függ) (csak MDVD).
    • Kij. sor stílusa - a kijelölt sor stílusa (a kurzor alatti sor).

2. Sorok újraformázása

Sorok újraformázása - a túl hosszú sorok felosztása, ill. a túl rövid sorok egyesítése. Az üres sorok is eltávolíthatók. A lehetséges beállítások:

  • A képszélességnél hosszabb sorok tördelése - felosztja a túl hosszú sorokat
  • Üres feliratok törlése - a szöveget nem tartalmazó sorok eltávolítása
  • Screen width [pixels] - select desired screen width
  • Rövid sorok egyesítése
    • Soha - Soha nem egyesíti a rövid sorokat
    • Csak a pár hosszú sor meg lett törve - Csak akkor egyesíti a rövid sorokat, ha ugyanabban a feliratban pár hosszú sor meg lett törve.
    • Mindig - Mindig egyesíti a rövid sorokat
    • Kivéve az így kezdõdõ sorok: - A megadott karakterrel kezdõdõ sorokat nem egyesíti
  • Szabad sorok elvetése(x,y<>0) - A nem alapértelmezett X,Y koordinátájú sorok elvetése.

A mûvelet az Újraformázás gombra kattintva kezdõdik.

2. Összefûzés / Tördelés

Két feliratfájl összefûzése (két film összefûzésekor) vagy egy fájl tördelése 2 fájlba (pl. ha egy film kettéválasztása 2 CD-re). Az összefûzés beállításai:

  • Elsõ felirat hossza - A második felirat eltolása ezzel az értékkel (az elsõ filmrész hossza)
  • Második felirat eltolása - A második felirat pozíciójának beállítása

A tördelés beállításai:

  • Töréspont - A töréspontnál nagyobb kezdõ idõpontú sorok átkerülnek a második feliratfájlba

A mûveletek végrehajtásához a megfelelõ gombokra kell kattintani.

3. Eltolás / Nyújtás

3.1 Feliratok beállítása

Beállítható a feliratok megjelenítési ideje és sebessége. A beállítások:

  • Feliratok eltolása - A feliratok eltolása ezzel az értékkel (a sebesség változtatása elõtt)
  • Sebesség vált. - A feliratok megjelenítési sebességének változtatása (szorzás ezzel az értékkel)
  • Csak a kijelöltek - Csak a listában kijelölt feliratok módosítása

Két gomb található a panelon:

  • Eltolás - Csak eltolás (sebesség nem változik)
  • Nyújtás - Eltolás és sebességváltoztatás

3.2 Hossz változtatása

A sebesség megváltoztatása egy Régi és egy Új hosszértékkel. A lehetõségek:

  • Új hossz - A film új hossza
  • Régi hossz - A film régi hossza (a film megnyitásakor automatikusan beíródik)

A Csere gombra kattintva az új sebességérték ki lesz számítva, és beíródik a Sebesség vált. mezõbe. Az Eltolás mezõ tartalma törlõdik, és a nyújtás végrahajtódik.

3.3 FPS újraszámolása

A sebesség megváltoztatása egy Régi és egy Új FPS értékkel (így lehet hozzáigazítani a feliratot egy más képkockasebességû filmhez). Csak képkocka-alapú feliratok esetében használható. A lehetõségek:

  • Új FPS - Új képkockasebesség
  • Régi FPS - Régi képkockasebesség

A Csere gombra kattintva az új sebességérték ki lesz számítva, és beíródik a Sebesség vált. mezõbe. Az Eltolás mezõ tartalma törlõdik, és a nyújtás végrahajtódik.

4. Áttûnések

Áttûnési effektus létrehozása. 2 fõ áttûnési típus van:

  • Stílus áttûnés - Az áttûnés során megváltozik a felirat stílusa. Növekvõ betûméret vagy változó betûszín létrehozása. Csak a betûméret és szín lesz számításba véve.
  • Gördülõ szöveg - A szöveg fokozatos megjelenése vagy eltûnése.

Az áttûnések a megadott lépésszámra lesznek kiszámítva. Több lépés esetén simább áttûnést kapunk de nagyobb lesz a feliratfájl is (csökkentheti a lejátszó teljesítményét). A megadott felirat lesz az áttûnés kiindulópontja

A lehetõségek:

  • Kezdés - Az áttûnés kezdete, az érték automatikusan beíródik megadott sorból.
  • End - Vége
  • Lépésidõ - Egy áttûnési lépés ideje. Használj megfelelõen nagy számot, mivel a a felirat sem jelenik meg gyorsabban, mint a film képkockasebessége.
  • Lépésszám - Az áttûnés lépéseinek száma
  • Gördülõ szöveg - Választható a megjelenés (Be) ill. eltûnés (Ki) (csak a megadott sorra)
    • Be - A szöveg elõtûnik nullától a teljes hozzáig
    • Ki - A szöveg eltûnik a teljes hossztól nulláig
  • Stílus - Stílusváltás az áttûnés során
    • Teljes felirat - A teljes feliratfájl stílusváltása
    • Kijelölt sorok - Csak a megadott sor stílusváltása
    • Célstílus - A kívánt stílus az áttûnés után (az utolsó áttûnõ sor stílusa)

A Kijelölt sor mezõben olvasható a megadott sor szövege (csak tájékoztatásul). A Létrehoz gombra kattintva létrejön az áttûnés

5. OCR javítás

OCR (Optikai karakterfelismerés) hibák javítása. Ilyen hibák elõfordulhatnak ha a felirat DVD-rõl lett rippelve (pl. SubRippel), mivel a DVD-n a feliratok képként vannak eltárolva. A lehetõségek:

  • A szóközök törlése a számokból - eltávolítja a számjegyek közti szóközöket, például: 1 234 5 -> 12345
  • Többszörös szóköz törlése - Eltávolítja többszörös szóközöket , és csak egy szóközt hagy (pl.: 3 szóköz helyett 1), kitörli a bevezetõ és lezáró szóközöket.
  • OCR hibák javítása listából - A táblázatban meghatározott OCR hibák javítása
  • Mindig rákérdez - Minden talált hibánál rákérdez a javításra (a hibadefiníciókat lehet így felülbírálni)

A baloldali táblázat tartalmazza a hibadefiníciókat. It has 4 columns:

  • Keresés - Keresendõ érvénytelen karakterek/szöveg (nem lehet üres)
  • Csere - Cserélendõ karakterek/szöveg
  • Csere valahol - Az érvénytelen karakterláncok keresési helye:
    • Sehol - Nem keresi az érvénytelen karakterláncot (nem kérdez rá). Csak a 'Hol kérdez rá' esetben használd, vagy a hibák letiltására
    • Szó elején - Az érvénytelen karakterlánc egy szó eleén kell (feliratsor elején, vagy szóköz után)
    • Bárhol - Az érvénytelen karakterlánc bárhol lehet a sorban
    • Kivéve szó elején - Ellentétes a 'Szó elején' leírásával
    • Nagybetûk között - de legalább nagybetû az egyik oldalon és egy nem betû karakter a másikon
    • Nagybetûk kivételével - Ellentétes a 'Nagybetûk között' leírásával
  • Hol kérdez rá - Hol kérdezze meg a felhasználót. Ugyanazok az értékei mint a 'Csere valahol'-nak. Amikor talál egy hibát, de ez az érték megtiltja a rákérdezést, akkor a hiba automatikusan ki lesz javítva. Olyan hibáknál célszerû használni, amelyeket nem lehet automatikusan kijavítani (Pl.:I and l).

A táblázat mellett egy 5 gombot tartalmazó eszköztár van:

  • Hiba hozzáadása - Új sort ad a táblázathoz
  • Hiba eltávolítása - A kijelölt sor törlése a táblázatból
  • Alapértelmezés - Eltávolít minden tételt, és betölti az alapértelmezettet
  • Hibalista megnyitása - Hibalista betöltés lemezrõl (INI formátomban)
  • Hibalista mentése - Hibalista mentése lemezre

Az 'OCR-hibák javítása' gomb megnyomásával kezdõdik a javítás. A gomb feletti folyamatjelzõ mutatja a mûvelet helyzetét.

A javítás során megjelenhet egy megerõsítést kérõ panel (attól függ, hogy mi az értéke a 'Hol kérdez rá' és a 'Mindig rákérdez' beállításoknak.):

A panelon látható néhány fontos tétel:

  • Az aktuális hiba 'Keresendõ' --> 'Csere' formában
  • Sorsám és a feliratok száma
  • A felirat szövege, amelyben a keresendõ kifejezés ki van emelve
  • Három gomb:
    • Igen - A javítás megerõsítése (Y billentyû)
    • Nem - A javítás elutasítása (N billentyû)
    • Mégsem - Az egész mûvelet elvetése (C billentyû)

A mûvelet befejezése után egy információs ablak jelenik meg:

Az ablak 3 oszlopot tartalmaz:

  • Hiba - Az aktuális hiba 'Keresendõ' --> 'Csere' formában
  • Javított - Hányszor lett a hiba javítva (automatikusan, vagy a felhasználó által jóváhagyva)
  • Kihagyott - Hányszor lett a hiba javítása elutasítva

Az OCR hibajavítási eljárás nem tartalmaz semmilyen helyesírás-ellenõrzést.

[Vissza a szerkesztõhöz]


Supported formats

Támogatott formátumok

Feliratformátumok

Formátum | Betölt | Ment | Típus | Stílusok
MicroDVD | Igen | Igen | Képkocka | Igen
SubRip | Igen | Igen | Idõ | Igen
Egyszerû idõ | Igen | Igen | Idõ | Nem
SubStation Alpha v4 | Igen | Igen | Idõ | Igen

Filmleíró formátumok

Formátum | Betölt | Ment
MicroDVD - MVD | Igen | Igen

Az MVD támogatás korlátozott. Az SP csak a film címét és a fájlt, illetve egy feliratot és nyelvjelzõt tud beolvasni. Ha más egyéb szakaszok is vannak az MVD-ben, akkor azokat nem veszi figyelembe. Ha egnél több felirat van megadva, akkor is csak az egyiket tölti be éss a nyelvjelzõ hibás lehet.

Multimédia formátumok

Elméletileg minden DirectShow-t szûrõvel rendelkezõ formátum. (amelyek telepítve vannak). Betölthetsz AVI, OGG, MPEG, ASF vagy más formátumokat, de csak a képkocka alpú AVI van teljesen tesztelve. A többi formátum kísérleti, ezt vedd figyelembe. Továbbá betölthetsz csak hangfájlokat (pl. mp3) és feliratokat is (idõalapút, mivel a hangfájlok csak idõalapúak lehetnek) a dalszöveg megjelenítésére a lejátszás során. A csak hangfájlok támogatása is kísérleti.


Version history

6.0

  • Fixed
    • Incorrect resizing of the subtitle preview box & zoom bar in Editor
    • S and L style tags are shown in the subtitle grid immediately
    • Removed invalid error message in Move subtitles
  • New features
    • Highlight oversize subtitles in all editors and grids
    • Zoom in player (mouse wheel)
    • (Auto)Save subtitles together with WSP or MVD
    • Redesigned Drag&Drop dialog, now supports WSP files
    • Switch audio streams in multi-language movies
    • Import SRT format tags as line styles
    • Ask to save subtitles if they are changed and SP is about to load new ones
    • Fast save of files (without dialog) when clicking on save button and a file type is already displayed in the button(1.sub/2.sub/mvd/wsp0
    • Changing style in style combobox changes style in all selected subs
    • New buttons for inserting subtitle before and ater the selected
    • Translation engine gives error message with error position if the lng file is invalid
  • Changes
    • Saved files now added to MRU lists
    • Save subtitles dialogs now show in titles whether the subs are first or second
    • After deleting subs the sub directly after the removed is selected
    • Move & Scale has now 2 separate boxes for Move and Change speed
    • When switching time/frame in subtitle start/end boxes there is a configurable option to use old timestamp value and not convert the displayed one
    • Time->Frame conversion now rounds down start frame and up for end frame
    • Some other tiny changes
    • MVD loade loads subtitle language tag
    • When overwriting MVD a warning is given that MVD support is limited

5.9.9.b2

  • Fixed
    • Places bar not showing on first opening the WSP load dialog
    • Open button not opening the WSP dialog when WSP selected
    • WSP MRU showing Open dialog instead of instantly opening the file
    • Incorrect resizing of the grids in Translator

5.9.9.b1

  • New features
    • SSA Loader - full support of all SSA v4 features in the editor. Nothing is lost when a SSA file is opened and then resaved. In the player however not all the SSA features are rendered. Also contains the 3to4 (UU) encoding / decoding to extract and embed pictures to subtitle files. The only unsupported feature of SSA is embedding the fonts (need to explore the relevant part of Windows API).
    • Enriched Style structure and style dialog to hold new SSA properties
    • Enriched Subtitle structure to hold new SSA parameters
    • New Advanced subtitle editor tab in Editor - contains advanced subtitle properties (SSA)
    • New Credits & properties dialog & button in editor - edit advanced information about the subtitles
    • New tab in Settings with SSA options
    • Save / Load workspace - Save or load the workspace (opened files & selected subtitle index)
    • New option in Settings for auto-saving the workspace
    • Menu structure for saving same as for loading

5.5.1

  • Fixed bugs:
    • width of group boxes in the settings screen (format options)
    • linked English language was 5.4.9.b1 - something was left in Czech (because SP is originally written in Czech)

5.5.0

  • Fixed bugs:
    • SRT loader was buggy and unstable. Now can load even a corrupted SRT file
  • Changes:
    • Subtitle numbers in grids are 1-based (were zero-based)
    • Reworked the configuration dialog - selection of save format

5.4.9.b2

  • Fixed bugs:
    • Insert position to subtitle end
    • Drag&drop form not translated when SP was started with command line parameters
    • Unable to select multiple subtitles in editor
  • New features:
    • Jump buttons in Editor in the start and end timestamp editboxes
    • Split subtitle button in Player
    • Seeking buttons in Editor
    • Seeking toolbar & position indicators in Translator
    • Buttons to jump to start/end timestamp of the selected subtitle in Translator
  • Changes:
    • Edits in player are disabled when there is no subtitle displayed
    • Increased step in gamma control in Player (from 10 to 20)

5.4.9.b1

  • New features:
    • Display both first and second subtitles in Player (configurable, only first subtitles can be edited)
    • Switch position of first and second subtitles in Translator (configurable)
    • Brightness / Contrast / Gamma controls in Player (Alt/Ctrl/Shift + mouse wheel)
    • Better looking subtitle grids
  • Fixed bugs
    • Charset in subtitle grids and all other controls (was EAST_EUROPE, now is SYSTEM_DEFAULT)
    • Memory violation when closing SP if movie is playing (solved by automatic pause before exit)
    • Confusing terminology in help messages (hopefully now Main subtitles = First subtitles in all messages)
    • "Insert current subtitle end position" in player now disabled when there is no subtitle displayed
    • Saving in incorrect format (the selected format in the Save dialog was not taken into account. Also fixed the auto-adding of extensions)
    • Saving newly created subtitles (they hadn't a format specified, MDVD is used now as default)
    • Saving didn't sometimes work completely (incorrect path generation - resulted in invalid path and thus no file could be saved)

5.0.2

  • Fixed
    • Negative numbers in input boxes now correct
    • Loading MDVD subtitles with styles (incorrect recognition of styles due to charset)
    • Extension checking when saving (didn't work if there were dots in the path)
    • MRU code (bug in setting the items count)
    • Translation code (support captions with more lines - e.g. in the settings screen)
  • Added
    • MRU size option in the Settings screen

5.0.1

  • New Split subtitle function
  • Refined some icons
  • New menu system with MRU files
  • New buttons to seek to previous/next subtitles in the player (normal and full screen mode)
  • New Merge subtitles function to merge 2 and more selected subtitles
  • Fixed a potential hidden bug in the timeline engine

4.99b6

  • fixed bug concerning the places bar in dialogs
  • Windows XP styles! Initial support of Windows XP styles, slightly redesigned the interface
  • Added charset support to style editor - styles are used only for rendering subtitles
  • Changes in language files to reflect these new items in the style editor
  • New version of DSPack -now uses DirectShow 9
  • New version of Jedi VCL
  • Fixed invalid floating point operation in the player

4.99b5

  • fixed bug in the UNDO function in editboxes (buffer was not initialized properly)

4.99b4

  • Thanks to Michal Moučka for detailed bug report
  • fixed bug when exiting on read-only filesystem (can't exit due to INI save error)
  • fixed bug when loading from read-only filesystem (not loading subtitles and movies)
  • fixed language files (typos, and invalid XML chars), updated language files to match the changes in the GUI, language files are now in \lang subdirectory and also any file can be selected
  • fixed the options in Load and Save dialogs
  • fixed the Select format dialog (was resizable)
  • fixed bug in Save movie description when saving to different drive
  • fixed a major bug in mode switching (frames <-> time)
  • adjusted the width of the "subtitle text" column in the subtitle editor. It should now fit correctly
  • subtitles are now instantly updated if the editboxes lose focus
  • Undo (ESC key) and Confirm (Enter key) supported in most editboxes in the main windows
  • Completely new editboxes (not using the Pie-Tools package) - now properly validating using Regular Expressions. Units can be switched by clicking on the unit box
  • Changed the behavior when clicking the seek bars - can be selected in Settings screen
  • added Version information in the executable file
  • slightly changed About box
  • updated the documentation and cleared some ambiguities
  • maybe some more changes that I don't remember right now

4.99b3

  • Minor update in the documentation concerning language selection
  • Fixed bug in the style editor (incorrect style loading)

4.99b2

  • Available in English and Czech languages
  • Contains documentation in English
  • Fixed many small bugs

4.99b

  • Contains support for full localization, only czech language available right now.

4.95

  • Completely rewritten the subtitle engine and data structures. Major changes in the code structure
  • New version of DSPack, JVCL and JCL used
  • Ported to Delphi 7
  • Major changes in the user interface
  • Timestamp Matcher changed into Translator
  • New style editing concept introduced
  • Major changes in the editor to accommodate the new style concept
  • New option to change main mode - Frame and Time
  • New function: OCR Corrections
  • Substantial changes in other functions
  • Completely new internationalization engine and new language format
  • New fullscreen mode
  • New code for rendering subtitles
  • New structure of the loading engine prepared for other subtitle formats in the future
  • Reverted back to standard common Open/Save dialogs and removed the APR Dialogs library (fas not free with source code and was not available for Delphi 7)
  • New library for editboxes - PieTools - used
  • New documentation, in English language since this version
  • Lots and lots of small bugs fixed

4.0

  • Added the option to select output formats. New open and save dialogs.
  • Added 2 formats for save: SubRip and SimpleTime
  • New function: Merge / Split
  • New function: Recalculate FPS
  • Corrected bug in the Move function
  • New internationalization support
  • New fullscreen player mode
  • Changes in user interface
  • Lots of small bugs fixed
3.0
  • Added Timestamp Matcher
  • Changes in other windows to accommodate the timestamp matcher
  • Lot of small bugs fixed

2.0

  • Added Movie player
  • Changes in other windows to accommodate the player
  • Lot of small bugs fixed
0.99
  • First version of Subtitle Processor
SubtitleMover
  • Very first version. It was capable of loading and saving MicroDVD format subtitles. Main function was moving the subtitles in time.


Subtitle Editor

Feliratszerkesztõ

Ebben az ablakban lehet szerkeszteni a feliratot. Csak az elsõ feliratfájlt engedi itt szerkeszteni (lásd a fõ ablakbanaz elsõ és a második felirat leírását)

1. Feliratlista

A betöltött felirat listáját tartalmazza (Elsõ felirat). A különbözõ színkódok a következõket jelentik:

  • Fekete szöveg: normál felirat
  • Fekete félkövér szöveg: megjelölt (SSA) felirat
  • Vörös szöveg: túlméretes felirat (szélesebb, mint a r eferenciaképernyõszélesség - lásd szerkesztõ funkciók)
  • Kék téglalap - kijelölt feirat(ok)

A feliratparaméterek:

  • Ssz. - a felirat sorszáma
  • Kezdete - képkocka / idõ - a felirat megjelenése
  • Vége - képkocka / idõ - a felirat eltûnése. Ha nincs megadva, akkor a felirat látható marad a következõ felirat megjelenéséig.
  • Sorok - hány sorból áll az adott felirat
  • Stílus - A stílusparaméterek értéke- SLP:
    • S - a teljes felirat az alapértelmezettõl eltérõ stílusú
    • L - némelyik sor az alapértelmezettõl eltérõ stílusú
    • P - némelyik sor az alapértelmezettõl eltérõ helyzetû
  • Feliratszöveg - az összes feliratsor '|' karakterrel elválasztva

A feliratok száma, a kijelöltek és módosítottak száma a feliratlista alján olvasható. A jobb alsó részen 6 gomb található:

  • Új sor beszúrása a kijelölt elé
  • Új sor beszúrása a kijelölt után
  • Az összes kijelölt sor eltávolítása
  • Felirat felosztása - megnyitja a Felirat felosztása ablakot.
  • Felirat egyesítése - egyesíti a kijelölt feliratokat (az összes szöveg, ill. a legelsõ kezdõpont és legutolsó végpont felhasználásával).
  • Mind - A teljes felirat kijelölése

Filmlejátszás közben az éppen megjelenített felirat ki van jelölve a listában.

2 Feliratszerkesztõ

Itt lehet a kijelölt feliratot szerkeszteni. A szerkesztõmezõk mûveletei visszavonhatók ('Esc' billentyûvel). A szöveg, ill. egyéb értékek megerõsítést nyernek, amikor az adott mezõ elveszíti a fókuszt (pl. egy másik elemre kattintáskor) Lásd a szerkesztõ funkcióknál a további adatokat a szerkesztõmezõkrõl.

A baloldalon van egy pár beviteli mezõ:

  • Felirat kezdete - Megjeleníti a felirat kezdõpontját. A fõ módtól függõen lehet képkocka vagy idõ. A mezõ melletti gomb felirata jeleníti meg az egységet (KÉP - képkocka, ÓPM - Óra:Perc:Másodperc,Tizedmásodperc). A gombra kattintva át lehet váltani az egységet. Az egység átváltásakor vagy a szerkesztõmezõbõl számított, vagy a feliratban tárolt érték jelenik meg. Ez beállítható. (Az idõ->képkocka->idõ konvertálás esetén elveszhet a pontosság. Ezért beállítható, hogy át akarod-e számolni az értéket (és veszíteni a pontosságból), vagy a feliratban tárolt másik értéket használod. Így nem vesztesz a pontosságból, de a mezõbe bevitt érték elvész. (A pontosságveszteség csak idõalapú feliratoknál fordul elõ, a képkocka-alapú feliratoknál az idõ a képkockákból lesz kiszámolva.)
  • Felirat vége - Megjeleníti a felirat végpontját
  • Feliratszöveg - Megjeleníti a felirat szövegét. A sorok száma nincs korlátozva.
  • Felirat stílus - A tljes feliratsor stílusának változtatása

A jobboldalon van az elõnézeti terület. Megjeleníti a kijelölt feliratot a megadott stílusban. A nagyítás mértéke a jobboldali függõleges csúszkával állítható be. A lehetséges értékek: 1:1-tõl (tényleges méret, a csúszka teljesen fent) 1:5.5 (5.5 -ször kisebb, a csúszka teljesen lent van).

Alul van egy pár gomb:

  • Névjegy és tulajdonságok - megjeleníti a Névjegyszerkesztõ ablakot
  • Stílusszerksztõ- megjeleníti a Stílusszerksztõ ablakot
  • Lejátszó - megjeleníti a feliratot a lejátszóban, a kezdõpontjához ugrik, majd megállítja a filmet
  • Fordító - megjeleníti a feliratot a fordítóban
  • Szünet - megállítja a filmet
  • Lejátszás - elindítja a filmet
  • Keresõgombok - ugrik X képkockát (képkocka-alapú módban) vagy másodpercet (idú-alapú módban).Lásd a Lejátszó ablakban.

A film aktuális pozíciója a jobb alsó sarokban jelenik meg.

3 Funkciók

Itt lehet választani néhány szerkesztõ funkció közül. Az egyik panel egy haladó feliratszerkesztõ is, amelyen meg lehet változtatni a a megadott felirat néhány haladó paraméterét.


Main

Fõ képernyõ

A SubtitleProcessor fõ ablaka egy eszköztárat, és 4 lapot tartalmaz: a Feliratszerkesztõt, a Lejátszót, a Fordítót, és a Beállításokat.

Az eszköztár a következõ elemeket tartalmazza (balról jobbra):

  • Névjegy gomb - megjeleníti a Névjegy panelt
  • Megnyitás gomb - megjeleníti a betöltõ menüt, amelynek elemei:
    • Elsõ felirat - Az elsõ felirat megnyitása. Ez a fõ felirat, és a Feliratszerkesztõben és a Lejátszó ablakban is szerkeszthetõ. Megjelenik a Fordító ablakban is.
    • Második felirat - A második felirat megnyitása. Fõleg a fordítóban használatos, illetve néhány szerkesztõ funkcióban
    • Film - Egy DirectShow médiafájl megnyitása.
    • MicroDVD leírás - Egy filmleíró fájl megnyitása- amely film és feliratok elérési útjait tartalmazza
    • Munkaterület - Egy munkaterület megnyitása - ez egy fájl, amely a film és az elsõ és második felirat elérési útjait . A kijelölt feliratsor sorszámát is tartalmazza.

Mindegyik menüelemnek van listája legutóbbi fájlokról. Amikor kiválasztasz egy menüelemet, akkor a fõ gomb felirata megváltozik, ezzel jelezvén, hogy mit fog megnyitni, ha csak egyet kattintasz rajta. A menüt úgy tudod megnyitni, hogy a gomb melletti nyílra kattintasz.

  • Mentés gomb

    Ez a gomb megjeleníti a mentés menüt, amelynek ugyanolyan elemei vannak, mint a Megnyitás menü fõ elemei, csak itt nincsenek almenük. A mentés gomb ikonja szintén megváltozik ezzel jelezvén, hogy mit fog menteni. Ilyenkor a fájl a párbeszédablak megjelenítése nélkül lesz mentve. (ugyanazon a ). A nyílra kattintva megjelenik a mentés menü, melynek elemei megjelenítik a Mentés párbeszédablakot, így a fájl neve megváltoztatható.

  • Fájlinformáció gomb - megjeleníti az informácikat a betöltött fájlokról
  • A Film & feliratinformáció - megjeleníti a Film & feliratinformációs panelt
  • Módváltó gombok:
    • Képkocka mód - A szerkesztõmezõk és a program átváltása képkocka-alapú módra
    • Idõ mód - A szerkesztõmezõk és a program átváltása idõ-alapú módra
  • Kilépés gomb - Az alkalmazás bezárása

Az eszköztár alatti fülekre kattintva lehet kiválasztani a kívánt ablakot.


Movie Player

Lejátszó

Ebben az ablakban lehet lejátszani a filmet, illetve feliratokat készíteni a film megtekintése során. Az ablak tartalmaz néhány pozícióvezérlõt a könnyebb feliratkészítés érdekében.

A képen a film nem látható, mert a képernyõmentés során a film nem menthetõ, de természetesen a használat során normálisan látszik. A feliratok megjelenítése függ a hardvertõl, illetve az Átfedés-keverõtõl (Overlay Mixer) is.

A lejátszó képes megjeleníteni az elsõ és a második feliratot is, a képernyõ alján és tetején egyaránt. Ez beállítható.

1. Pozícióvezérlés

A képkocka- illetve idõalapú módban használható pozícióvezérlõk:

Az eszköztás gombjai:

  • Lejátszás
  • Szünet
  • N-számú képkocka (vagy N másodperc) ugrás elõre/hátra

Az eszöztár alatt található folyamatjelzõ mutatja a film aktuális pozícióját. Kattintással a pozíció változtatható. Az ugrógombokon való kattintás után a film a kívánt pozícióba ugrik, majd ott megáll. A folyamatjelzõn való kattintás után a film vagy megáll, vagy megy tovább (A Beállítások ablakban megadottak szerint)

Van egy 'Ugrás a pozícióba' nevû mezõ is. Ezzel pontosan a kívánt pozícióba lehet ugrani. Az ugrás a mezõ melletti jobboldali gomb megnyomásával hajtódik végre (-->|). A bevitelimezõbe ugyanolyan értékeket lehet beírni, mint a Szerkesztõ funkciók esetében

2. Könyvjelzõk

A bal alsó sarokban találhatõ 2 db könyvjelzõ mezõ:

Ezek a mezõk tárolják a filmpozíciókat, így lejátszható a film újra a tárolt pozíciótól. A beviteli mezõk csak olvashatóak, az eszközár gombjai balról jobbra:
  • Értékadás - Az aktuális filmpozíció megadása könyvjelzõnek
  • Érték törlése - A könyvjelzõ törlése
  • _Ugrás a könyvjelzõhöz - A tárolt pozícióhoz ugrik majd megállítja a lejátszást
  • Lejátszás a könyvjelzõtõl - Elindítja a lejátszást a tárolt pozíciótól

3. Feliratszerkesztõ

A jobb alsó sarok egy egyszerûsített feliratszerkesztõt tartalmaz. A szöveg, a kezdõpont és a végpont értékeit lehet itt szerkeszteni. Ez a szerkesztõ össze van kapcsolva a fõ feliratszerkesztõvel a Feliratszerkesztõ ablakban. A Felirat kezdete, ill. vége mezõk ugrógombjaira kattintva a film a megadott pozícióba ugrik, majd megáll.

Van egy eszköztár a feliratszerkesztõ baloldalán a következõ gombokkal:

  • Ugrás az elõzõ feliratra
  • Ugrás a következõ feliratra
  • Felirat hozzáadása - Felirat hozzáadása az aktuális pozícióban
  • Felirat felosztása - Felosztja a feliratot az aktuális idõpontban.
  • Kezdõpont - Az aktuális pozíciót beírja a Felirat kezdete mezõbe
  • Végpont - Az aktuális pozíciót beírja a Felirat vége mezõbe
  • Felirat törlése - A megjelenített felirat törlése

4. Egyéb vezérlõk

A Lejátszó ablak további vezérlõi:

  • Teljes képrenyõ - Átvált teljes képernyõ módba. Kilépés a teljes képernyõs módból az ESC billentyûvel, vagy a Teljes képernyõ vége gombbal.
  • Hangsáv válaszása - Ez a gomb egy hangszóró ikonnal jelzi az aktuális hangsávot. A gomb melletti nyíl megjelenít egy menüt a választható hangsávokkal (többnyelvû filmeknél), melyek egyike kiválasztható. Az alapértelmezett hangsáv, amely a film megnyitásakor betöltõdik beállítható a Beállítások ablakban.
  • Pozíció panel - jelzi az aktuális filmpozíciót

Teljes képernyõs módban a következõ vezérlõk használhatók:

  • Lejátszás
  • Szünet
  • Ugrás az elõzõ feliratra
  • Ugrás a következõ feliratra
  • Teljes képernyõ vége
  • Állíthatõ pozíciójelzõ
  • Pozíció idõ / képkocka

A teljes képernyõbõl ki lehet lépni:

  • Az ESC billentyûvel
  • Teljes képernyõ vége gombbal

A teljes képernyõs OSD (Képernyõkijelzõ), illetve a feliratok megjelenítése csak akkor használható, ha a videokártya támogatja az átfedés rákeverést (Overlay Mixer).

3. Képvezérlõk

Ezek a csúszkák vezérlik a film Fényerõ / Kontraszt / Gamma / Nagyítás beállításait. Az értékek változtathatók az Alt, Ctrl és/vagy a Shift lenyomásával és az egérgörgõ forgatásával. A vezérlõ másfél másodperc után eltûnik. Ha az egérgörgõ nem mûködik, kattints a filmen és próbáld újra. Néha a folyamatjelzõ nem mutatja, de az F/K/G/N változik - ez akkor történik, ha gond van az Overlay mixerrel.


Settings

Beállítások

Ebben az ablakban lehet a beállításokat megváltoztatni.

Megjegyzés: Ha a kezelõfelület számodra ismeretlen nyelvû, akkor a következõket kell tenned (lásd a képen):

  • Válaszd ki a Beállítások ablakot (Más nyelveken természetesen nem ez a neve, de mindig a negyedik panel)
  • Kattints a földgömb gombon és válassz a rendelkezésre álló nyelvek közül (egyforma minden nyelven)

1. Képkocka sebesség (FPS)

A képkocka sebesség nagyon fontos. Az idõ, illetve képkocka értékek átváltására szolgál. A másodpercenként megjelenített képkockák számát jelenti. Ez határozza meg a feliratok megjelenítéséért felelõs idõzítõ mintavételi rátáját.

A képkockasebességet a film határozza meg. Ha nincs film betöltve, akkor az alapértelmezett 25.0 FPS lesz kiválasztva. A felhasználó szabadon kiválaszthatja a megfelelõ rátát. Ha a film betöltõdött, a képkockasebességet a film határozza meg, és a felhasználó nem tudja megváltoztatni. Ha film nem támogatja a képkocka-alapú módot (ASF vagy OGG például), akkor 25.0 lesz kiválasztva a feliratok megjelenítésére (a másodpercenkénti 25 elég, és normális számokat eredményez idõ-alapú módban), és a programot nem lehet képkocka-alapú módba átkapcsolni.

Minden feliratnak két idõzítése van, az egyik képkockákban, a másik másodpercben megadva. Az egyik a másikból lesz számítva, a felirat fajtájától függõen (képkocka vagy idõ alapú). A képkockasebesség értékét használja program a konvertálásra. Ha az eredeti formátumban lesz a feliratfájl elmentve, akkor az idõzítés nem lesz hibás akkor sem, ha rossz képkockasebesség lett kiválasztva.

Megjegyzés: Ha ebben a mezõben választasz másik FPS-t, azzal nem tudod megváltoztatni a felirat megjelenítési sebességét. Például, ha egy 25,000 fps-û feliratot akarsz korrekten lejátszani egy 23,976 fps-û filmmel, akkor lásd a Szerkesztõ funkcióknál az Eltolás / Nyújtás szekciót.

2. Nyelv

Ha a fölgömböt ábrázoló gombra kattintasz, választhatsz a rendelkezésre álló nyelvi fájlok közül. Ez a lista a program indításakor generálódik. A nyelvi fájlok kiterjesztése *.lng, és a SubtitleProcessor.exe-vel megegyezõ mappában kell lenniük.

A nyelvi fájlok XML formátumúak. Bármely XML-szerkesztõben, vagy egy egyszerû szövegszerkesztõben szerkeszthetõek.

A jövõben további nyelvi fájlok is várhatóak.

Az elsõ futtatáskor az alapértelmezett nyelv az angol. Ha az INI fájlban megadott nyelvi fájl nem létezik, vagy hibás, akkor az angolt tölti be.

3. Beállítások

A beállítások több csoportra oszthatók:

  • Beállítások - különféle SP beállítások:
    • Stílusok mentése - a stíluslista automatikusan mentõdik a fõ program INI fájljába
    • OCR hibalista mentése - az OCR hibalista automatikusan mentõdik a fõ program INI fájljába
    • Helyek megjelenítése a Megnyitás / Mentés ablakban - ha be van jelölve, akkor az újfajta párbeszédablak jeleink meg, ha az operációs rendszer támogatja.
    • Munkaterület mentése - elmenti a megnyitott fájlok elérési útját, és a program indításakor újra megnyitja azokat.
    • Felirat mentése WSP vagy MVD formátum mentésekor is - elmenti a feliratot, amikor elmenti az MVD vagy WSP fájlt.
      • Automatikus mentés (nem jeleníti meg a párbeszédablakot) - a feliratokat automatikusan elmenti az utolsó néven, amikor elmenti az MVD vagy WSP fájlt és nem jeleníti meg a Mentés párbeszédablakot.
    • LMF határ - A legutóbb megnyitott fájlokat tartalmazó lista elemeniek száma.
  • Lejátszó:
    • Keresõsávon kattintáskor - az bekövetkezõ esemény beállítása, miután a felhasználó a keresõsávra kattintott.
      • Mindig lejátsza a filmet - A keresõsávon való kattintás után elindul a lejátszás, akár ment a film, akár nem.
      • Mindig megállítja a filmet - A keresõsávon való kattintás után megállítja a lejátszást, akár ment a film, akár nem,
      • Folytatja a lejátszást, ha ment a film; megáll az új helyen, ha állt a film - A kattintás elõtti lejátszási állapot megõrzése.
    • Megjeleníti az 1. és a 2. feliratot is - mindkét feliratot megjeleníti a lejátszóban. A stílus által meghatározott pozíciót figyelmen kívül hagyja.
    • Az 1. felirat pozíciója - meghatározza az 1. felirat pozícióját (alul vagy felül). A 2. felirat az ellentétes oldalon lesz.
    • Automatikus váltás erre a hangsávra - többnyelvû film betöltéseko automatikusan a megadott hangsávra kapcsol (ha nincs engedélyezve, akkor lejátsza egyszerre az összeset).
  • Fordító:
    • Az 1. felirat pozíciója - az 1. felirat a felsõ vagy az alsó táblázatban jelenjen-e meg.
  • Szerkesztõ
    • Túlméretes feliratok kiemelése - a referencia képernyõnél szélesebb feliratokat pirossal jeleníti meg (minden táblázatban és szerkesztõben).
    • A felirat kezdete|vége egység átkapcsolásnál használja a felirat régi értékeitWhen - lásd a Szerkesztõt.

4. Feliratformátum

Ebben a csoportba a menteni kívánt feliratformátumot lehet kiválasztani. Ha az 'Eredeti' van kijelölve, akor a a feliratok az eredeti formátumukban kerülnek mentésre (ajánlott). Többféle formátumfüggõ lehetõséget lehet kiválasztani. A mentési formátumot a kiválasztott fül határozza meg.


Translator

Fordító

Ebben az ablakban lehet lefordítani a feliratokat más nyelvre. Két rácsot tartalmaz, egyet az eredetinek, egyet a fordítás alatt álló feliratnak, így a felhasználó egydejûleg láthatja mindkettõt.

1. Feliratrácsok

A Fordító két rácsot tartalmaz a feliratok részére. Ezek megjeleníthetik az 1. és a 2. feliratot is, ez a Beállításoktól függ. A rácsok négy oszlopból állnak:

  • Ssz.. - A felirat sorszáma
  • Kezdete - A felirat kezdõ idõpontja. Az idõpont képkockákban és ÓPM idõfomátumban is kiírva. Szerkesztõmódba lépve, az érték megváltozik képkockákra vagy ÓPM-re és a felhasználó átírhatja az idõpontot. A szerkesztõ mód beállítható a szerkesztõ eszköztáron. Az értékek megadására ugyanazoka a szabályok vonatkoznak mint a szerkesztõ funkcióknál leírtak.
  • Vége - A felirat vége. Szabályok, mint a kezdeténél
  • Feliratszöveg - A feliratok szövege. A sorok a | (vonás) karakterrel vannak elválasztva.

Mindkét rácsban lehet szerkeszteni. Amikor egy cellára katintasz, a megfelelõ cella a másik rácsban, illetve a fõ feliratszerkestõben is ki lesz jelölve. A felhasználó pontosan meg tudja határozni, hogy a két rács melyik sorai tartozzanak össze. Ez nagyon hasznos a feliratok rossz idõzítésének olyan korrekciójára, amit nem lehet automatikusan elvégezni.

2. Az eszköztárak

2.1 Rácseszköztárak

Mindkét rácshoz tartozik ilyen eszköztár, melyek a következõ feliratmanipuláló gombokat tartalmazzák:

  • Felirat hozzáadása - új sor beillesztése a kijelölt sor elé a fordításba.
  • Felirat eltávolítása - a kijelölt sor eltávolítása a fordításból
  • Feliratok egyesítése - a kijelölt felirat egyesítése a következõvel (hozzáfûzi a szövegsorokat, és az elsõ felirat kezdõ-, illetve a következõ végpontját használja)
  • Felirat felosztása - Kettéosztja a kijelölt feliratot. Ha rákérdezési mód aktív, akkor a Felirat felosztása párbeszédablak jelenik meg. Egyébként a felosztandó feliratnak legalább két sorból kell állnia, az elsõ feliratban lesz(nek) az elsõ sor(ok), a másodikban a többi. Az elsõ felirat vége és a második kezdete az eredeti felirat kezdõ- és végpontjának átlaga lesz./font>
  • Keresés - Szöveg keresése. Megjeleníti a Windows közös keresõablakát.
  • Ugrás a kezdõ/befejezõ idõpontra - A kijelölt sor kezdõ/végpontjához ugrik a filmben. Hasznos lehet a hang ellenõrzésénél.
2.2 Szerkesztõ eszközök

Ezzel az eszköztárral opciókat lehet beállítani és idõzítéseket módosítani. A gombok:

  • Rákérdez - Ha be van nyomva, akkor az eszköztár minden mûveletének végrehajtása elõtt megkérdezi a felhasználót. Ha nincs benyomva, akkor csak akkor kérdez rá, amikor a 'Minden felirat' opció van kiválasztva.
  • Szerkesztõ mód gombok:
    • Idõ-alapú mód - A rácsokban az idõzítés formátuma Óra:Perc:Másodperc.Tizedmásodperc
    • Képkocka-alapú mód - az idõzítés képkockákban van
  • Idõ/szöveg másolása:
    • Idõzítés másolása az eredetibõl a fordítandóba
    • Idõzítés másolása a fordítandóból az eredetibe
    • Szöveg másolása az eredetibõl a fordítandóba
    • Szöveg másolása a fordítandóból az eredetibe
  • Az Idõ/szöveg másolásának tárgya:
    • Kijelölt sor - csak a kijelölt sorban levõ értékek lesznek átmásolva
    • Minden felirat - minden érték átmásolódik

2.3 Lejátszó eszköztár

Ez az eszköztár képes vezérelni a filmlejátszót ugyanúgy, mint a Lejátszó ablakban.


Style Editor

Stílusszerkesztõ

Ebben az ablakban a stílusokat lehet beállítani.

A stílusok alapelve ugyanaz, mint a szövegszerkesztõkben, vagy egyéb feliratozó programokban (pl. SSA). A különbözõ stílusoknak van egy központi listája, és a stílusok vannak hozzárendelve a feliratokhoz ahelyett, hogy a feliratok betûtulajdonságait kellene állítgatni. Ha stílus változik, akkor minden felirat, amelyik azt használja, a megváltozott stílusban lesz megjelenítve, a felhasználónak nem kell a felriatok paramétereit külön-külön beállítani.

A stílusszerkesztõ négy fõ részre tagolódik:

  • Stíluslista - Megjeleníti a felhasználható stílusokat. Az adott sorra kattintva a sor kiválasztódik, és a beviteli mezõkben megjelennek az aktuális értékei. Három oszlopa van:
    • Ssz.. - a stílus sorszáma
    • Forrás - Helyi vagy Felirat - A helyi azt jelenti, hogy a stílus a SubtitleProcessor.INI fájlból, vagy stílusfájlból származik. A felirat azt jelenti, hogy a stílus a betöltött feliratfájlból származik. A program újraindítása után minden stílus helyi lesz, mivel el lesznek mentve az INI fájlba (ez beállítható).
    • Név - A stílus neve

    A listában felsorolt stílusok a saját beállításuknak megfelelõ betûformátumban jelennek meg.

  • Elõnézeti mezõ - Egy mintaszöveggel mutatja be a stílust
  • Gombok - a stílusok manipulálására:
    • Új - Új stílus létrehozása (alapértelmezett értékekkel- melyeket a *Default - alapértelmezett - stílus tartalmaz)
    • Törlés - A kijelölt stílus törlése, és az arra vonatkozó összes hivatkozás eltávolítása a feliratból. A *Default - alapértelmezett - stílus nem törölhetõ
    • Töröl mind - A *Default - alapértelmezett - stílus kivételével az összes stílus törlése
    • Nem használt törlése - Átvizsgálja a feliratot, és eltávolítja a nem használt stílusokat
    • Stílus betöltése - Stíluslista betöltése lemezrõl. Vigyázat: Az összes meglevõ stílus és hivatkozásaik a feliratban törlõdnek!
    • Stílus mentése - Stíluslista mentése lemezre.
    • Bezár - A stílusszerkesztõ bezárása
  • Stílusszerkesztõ mezõk - a stílus szerkesztésére használhatók

A stílusszerkesztõ mezõk hét csoportot alkotnak :

  • Stílus neve - Stílusnév (ez jelenik meg a stílusválasztó legördülõ listában). Az alapértelmezett stílus nevét nem lehet átírni (mindig *Default lesz, és ez az elsõ a listában)
  • Betûtípus beállítása- A stílus fontparaméterei:
    • Betûtípus - a használt font neve. Üres sor esetén az alapértelmezett lesz használva
    • Méret - betûméret. Nulla esetén az alapértelmezett lesz használva
    • Színek - Betûszínek. Üres esetén az alapértelmezett lesz használva
    • Font opciók:
      • F - Félkövér
      • D - Dõlt
      • A - Aláhúzott
      • Á - Áthúzott
      • E - Alapértelmezett - A stílus- és az alapértelmezett paraméterek egyidejû használata.
    • Karakterkészlet - a font karakterkészletének kiválasztása (minden lehetséges karakterkészlet megjelenik; csak azt válaszd, amit a font is támogat.)
    • Választ... - a rendszer betûtípus párbeszédablak megnyitása.
  • Színek - A stílushoz tartozó színek:
    • Elsõ - a feliratszöveg fõ színe
    • Második, Harmadik - Az SSA használja, amikor kettõ vagy több feliratot jelenít meg egyidejûleg. A SP nem enged több feliratot megjeleníteni, így ezeket nem használja.
    • Árnyék - a körvonal színe, árnyék, vagy tömör doboz a felirat alatt - az SSA használja
  • Függõleges pozíció - meghatározza, hogy a felirat a képernyõ alján, tetején, vagy közepén jelenjen-e meg.
  • Igazítás - meghatározza a feliratsor vízszintes helyzetét
  • Szegélystílus - meghatározza a feliratszegély stílusát:
    • Körvonal + árnyék - minden karakternek van körvonala és vetett árnyéka
    • Tömör doboz - egy tömör doboz van a szöveg alatt
  • Margók
    • Bal / jobb - a szöveg és a képernyõ bal / jobb széle közötti távolság
    • Függõleges - a szöveg és a képernyõ alsó / felsõ széle közötti távolság (a Függõleges pozíciótól függõen)

Megjegyzés: A haladó stílusbeállításokat az SSA használja. A SP megengedi a szerkesztésüket, de a feliratmegjelenítõ egyelõre nem képes használni ezeket. now.

[Vissza a szerkesztõhöz]